NetControls Reference

Softgroup .Net Control Suite contains more than thirty fast, lightweight and easy to use .NET WinForm controls that can enhance your application interface.

Remarks

To add a Softgroup .Net MDIBar to your form simply add the control to the Toolbox window of Microsoft Visual Studio and drag it to the form.

To enter your licenses informations you must set LicenseName, LicenseUser and LicenseKey properties as VB.NET code sample below:

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Softgroup.NetControls.License.LicenseName= "YourCompanyName"

Softgroup.NetControls.License.LicenseUser = "YourUserNameOrMail"

Softgroup.NetControls.License.LicenseKey = "YourSerialNumber"

End Sub

Generated by Softgroup


Softgroup.NetControls Namespace

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Classes
Name | Description
Public class | AdvancedSplitter | Softgroup .Net Advanced Splitter is an advanced enhanced splitter control with automatic collapse/expand of child controls.
Public class | ColorTableBlack | ColorTableBlack define a black color table for Outlook Bar control
Public class | ColorTableBlue | ColorTableBlack define a blue color table for Outlook Bar control
Public class | ColorTableSilver | ColorTableBlack define a silver color table for Outlook Bar control
Public class | ColorTableSystem | ColorTableBlack define a system color table for Outlook Bar control
Public class | ComboColors | Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.
Public class | ComboDrives | Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.
Public class | ComboFonts | Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.
Public class | ComboImages | Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)
Public class | ComboList | Softgroup .Net ComboList is a resizable ComboBox control that has same behaviors of a standard ComboBox with a DropDownList style and many others features.
Public class | ComboPrinters | Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).
Public class | ExplorerBar | Softgroup .Net Explorer Bar Control is a fast, small, lightweight and enhanced implementation of a Windows Explorer Bar control. The Explorer Bar can display intrinsic items or any other control divided into groups that can be expanded and collapsed to allow the user to customise which information is shown.
Public class | ExplorerBarClickBaseEventArgs | Base class for Explorer Bar Click events.
Public class | ExplorerBarGroup | The Group within the Explorer Bar control.
Public class | ExplorerBarGroupClickEventArgs | Event arguments for a click on a group within the Explorer Bar control.
Public class | ExplorerBarGroups | The collection of Groups associated with an ExplorerBar control.
Public class | ExplorerBarItem | An item within the Explorer Bar Group.
Public class | ExplorerBarItemClickEventArgs | Event arguments for a click on an Item within the Explorer Bar control.
Public class | ExplorerBarItems | Contains the collection of items associated with a group in the Explorer Bar control.
Public class | ItemImage | Softgroup.Image is a class that contain a single Image object of a ComboImages item
Public class | ItemImages | Softgroup.Images is a collection class to manage Images of a ComboImages control
Public class | License | License class holds licenses informations data.
Public class | ListBar | Softgorup .Net ListBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook traditional Navigation Bar user interface
Public class | ListBarBeforeGroupChangedEventArgs | Provides event arguments for the BeforeSelectedGroupChanged event raised by the control. This object contains the group that would be selected and provides the opportunity to cancel the group selection.
Public class | ListBarBeforeItemClickEventArgs | Provides event arguments for the BeforeItemClick event and provides the item which is about to be clicked and the option to prevent the item being clicked by setting the Cancel property.
Public class | ListBarClickedEventArgs | ObjectClickedEventArgs class is used as the bases for the ItemClick and GroupClick events of the control.
Public class | ListBarGroup | A ListBarGroup is a bar within a ListBar control. A bar can either contain items or it can contain a control.
Public class | ListBarGroupClickedEventArgs | Provides details of which item has been clicked and the mouse details of the click when the GroupClicked event is raised from a control.
Public class | ListBarGroups | The collection class of ListBarGroup objects in the ListBar control.
Public class | ListBarItem | A class containing the information describing an Item in the ListBar control.
Public class | ListBarItemClickEventArgs | Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar
Public class | ListBarItemDoubleClickEventArgs | Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar
Public class | ListBarItems | The collection class of Items within a ListBarGroup of ListBar control.
Public class | ListBoxImageItem | This class rappresent as item od ListBoxImage
Public class | ListBoxImages | Softgroup .Net LisBox Images is an advanced ListBox that display images with text.
Public class | NetAnimation | Softgroup NetAnimation Control is a fast, small, lightweight and easy to use .NET control that can play an Audio-Video Interleaved (AVI) file or any OS system animation.
Public class NetButton Softgroup .Net Button is an enhanced .NET button control that gives your applications a nice gradient and/or light effects.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.
Public class | NetCalculator | Softgroup .Net Calculator control provides easy to use full customizable calculator control for Windows Forms.
Public class | NetExtraLine | Softgroup .Net Extra Line is a fast, small, lightweight and easy to use advanced Line control with gradient effects.
Public class | NetGIFAnimate | Softgroup NetGIFAnimate control provide functionalities to play animated Graphic Interchange Format images
Public class | NetLineSeparator | Softgroup .Net Line Separator is a fast, small, lightweight and easy to use threed Separator control.
Public class | NetLinkButton | Softgroup .Net LinkButton is a button control designed to mimic the look of command link control found in Windows Vista.'''
Public class | NetMDIBar | Softgroup .Net MDI Bar is a fast, small and lightweight .NET bar control for automatic tracking of MDI children in an MDI parent form.
Public class | NetMDIButton | NetMDIButton is a special ToolStripButton that handles MDIChild forms activity'''
Public class | NetMDIButtonClickEventArgs | Class NetMDIButtonClickEventArgs provide parameters events for NetMDIBar control.
Public class | NetMDIManager | Softgroup .net NetMDIManager is an advanced component that provides new features for .Net MDI applications and eliminates flicker generated during showing or switching of maximized Mdi child forms.
Public class NetNotify Softgroup .Net Notify Message is a fast, small, lightweight and enhanced implementation of .Net MSN Messenger-like notification window.

To add a Softgroup .NetNotify to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.
Public class | NetPanel | Softgroup .Net Advanced Panel control is an extended Panel control that implements unsupported behaviours and features of standard control.
Public class | NetPictureScroll
Public class | NetShellPreview | NetShellPreview is a preview control that can be used to display a system preview like Explorer where available for file extension type.
Public class NetSplitButton Softgroup .Net SplitButton is an enhanced .NET button control that gives your applications a nice button with a split area that can display on user click an associated ContextMenuStrip.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.
Public class | NetSplitButtonAppearance | Button with split part that can show ContextMenuStrip.
Public class | NetTabControl | Softgroup .Net Tab Control is a fast, small, lightweight and enhanced version of standard .Net TabControl that implements unsupported behaviors and features of standard control.
Public class | NetTabPage | Represents a single tab page in a NetTabControl
Public class | NetThumbImage | ThumImage object rappresent a single image displayed in the Thumbnail control
Public class | NetThumbnail | Softgroup .Net Thumbnail is a fast, small, lightweight and easy to use .NET control that gives your applications enhanced and high quality thumbnail images browser.
Public class | NetThumbnailEventArgs | Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.
Public class | NetThumbnailKeyEventArgs | Class NetThumbnailKeyEventArgs provide parameters events for Thumbnail control.
Public class | NetThumbnailMouseEventArgs | Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.
Public class | NetTrackBar | Softgroup NetTrackBar control is a fast, small, lightweight and enhanced version of standard .Net TrackBar that implements unsupported behaviors and features of standard control.
Public class | NetWizard | Softgroup .Net Wizard Control is a fast, small, lightweight and easy to use .NET control to simplify many of the tasks, known as Wizard, that are associated with building a series of forms to collect user input.
Public class | NetWizardNextButtonClickedEventArgs | Class NetWizardNextButtonEventArgs provide parameters events for NextButtonClicked event of NetWizard control.
Public class | NetWizardPage | NetWizardPage class represents a single page in a docked into a Wizard control.
Public class | OutlookBar | Softgorup .Net OutlookBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook Navigation Bar (2003 versione and above) user interface
Public class | OutlookBarCollectionBase | Base collection class for the OutlookBar control
Public class | OutlookBarCollectionEventArgs | This class holds information for OutlookBarCollection events
Public class | OutlookBarControl | Represents base control class used internally by OutlookBar controls
Public class | OutlookBarGroup | This class represents a group which is a part of the OutlookBar control
Public class | OutlookBarGroups | This class represents a collection of OutlookBar groups
Public class | OutlookBarRenderer | This class contains drawing functionality and color table for the OutlookBar control
Public class PrintPreview Softgroup .Net Print Preview is a fast, small and lightweight .Net control that provide nice and accurate print and preview for CheckedListBox, DataGrid, DataGridView, Forms, ListBox, ListView, TreeView, RichTextBox .Net WinForm controls and System.Drawing.Image objects, not provided directly from .Net Framework.

Supported .Net controls:

• CheckedListBox

• DataGrid

• DataGridView

• Forms

• Images

• ListBox

• ListView

• TreeView

• RichTextBox
Public class | ProgressBar | Softgroup .Net ProgressBar control is an advanced progress bar controls with orientation and gradients effects.
Public class | ProgressBlock | Softgroup .Net ProgressBlock control is an highly customizable block progress bar control with orientation and gradient/glass effects.
Public class | ProgressLed | Softgroup ProgressLed is a graphic control that mimics a Led numeric display
Public class | ProgressLedEventArgs | Class ProgressLedEventArgs provide parameters events for ProgressLed control.
Public class | ProgressLoop | Softgroup .Net ProgressLoop control is an advanced loading loop control that can emulate IE, FireFox and MacOSX progress style.
Public class | ProgressSlider | Softgroup ProgressSlider is a enhanced trackbar control that display a progress slider with orientation and thumb button with various styles and effects
Public class | ProgressSliderEventArgs | Class NetThumbnailMouseEventArgs provide parameters events for NetThumbnail control.
Public class | ResultClickEventArgs | ResultClickEventArgs class defines event parameters for ResultClicke event of NetCalculator
Public class | ToolStripColorPicker | Softgroup .Net ToolStripColorPicker control is a ToolStripSplitButton that allows selecting a color from a color picker.
Public class ToolStripCustomize Softgroup .Net ToolStrip Customize component is an easy to use .Net component that provide runtime user customization dialog of any ToolStrip control.

To add a Softgroup .Net Toolstrip Customize component to your form simply add the component to the Toolbox window of Microsoft Visual Studio, drag it to the Form and sets ToolStip property control of component.

To display cutomization dialog at runtime call ShowDialog methods through code or double click on clean area of ToolStrip control.

You can also customize any text displayed by cutomization dialog using Localize method.

To enter your licenses informations you must set LicenseName, LicenseUser and LicenseKey properties of License object as VB.NET code sample below:

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Copy
    Softgroup.NetToolStripCustomize.License.LicenseName= "YourCompanyName"
    Softgroup.NetToolStripCustomize.License.LicenseUser = "YourUserNameOrMail"
    Softgroup.NetToolStripCustomize.License.LicenseKey = "YourSerialNumber"

End Sub
Public class | ToolStripCustomizeShowDialogAfterEventArgs | Class ToolStripCustomizeShowDialogAfterEventArgs provide parameter events for ShowDialogAfter event of ToolStripCustomize control.
Public class | Win8ProgressMarquee | Softgroup Win8ProgressMarquee is a control that mimic Windows 8 progress marquee indicator
Public class | Win8ProgressRing | Softgroup Win8ProgressRing is a control that mimic Windows 8 progress ring indicator
Top
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x


AdvancedSplitter Class

Members

Softgroup .Net Advanced Splitter is an advanced enhanced splitter control with automatic collapse/expand of child controls.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Softgroup.NetControls.AdvancedSplitter), "AdvancedSplitter")> _
<DefaultProperty("Control")> _
<DefaultEvent("CollapsedExpanded")> _
Public Class AdvancedSplitter
    Inherits Splitter
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Softgroup.NetControls.AdvancedSplitter), "AdvancedSplitter")]
[DefaultProperty("Control")]
[DefaultEvent("CollapsedExpanded")]
public class AdvancedSplitter : Splitter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.Splitter
Softgroup.NetControls.AdvancedSplitter
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Members


AdvancedSplitter Members

AdvancedSplitter Class Constructors Events Methods Properties See Also

Softgroup .Net Advanced Splitter is an advanced enhanced splitter control with automatic collapse/expand of child controls.

The following tables list the members exposed by the AdvancedSplitter type.

Constructors
 | Name | Description
Public constructor | AdvancedSplitter Constructor | Initializes a new instance of the AdvancedSplitter class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Splitter).
Public property | Anchor | (inherited from Splitter).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundGradient | Gets/Sets whether the renderer draw background using gradient effects of not
Public property | BackgroundImage | (inherited from Splitter).
Public property | BackgroundImageLayout | (inherited from Splitter).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets or sets .
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | Collapsed | Gets if splitter is currently collapsed.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Control | Gets/Sets the hosted control by splitter. This controll will be automatically collapse or expand by splitter. Splitter must be docked at any size to this control.
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Splitter).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Splitter).
Public property | ForeColor | (inherited from Splitter).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Splitter).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinExtra | (inherited from Splitter).
Public property | MinSize | (inherited from Splitter).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | Gets or sets .
Public property | SplitPosition | (inherited from Splitter).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Splitter).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Splitter).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BringToFront | (inherited from Control).
Public method | CollapseExpand | Collaspe splitter if currently expanded otherwise expand splitter if currently collapsed
Public method | Contains | (inherited from Control).
Public method | CreateControl | (inherited from Control).
Public method | CreateGraphics | (inherited from Control).
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | DoDragDrop | (inherited from Control).
Public method | DrawToBitmap | (inherited from Control).
Public method | EndInvoke | (inherited from Control).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | FindForm | (inherited from Control).
Public method | Focus | (inherited from Control).
 | FromChildHandle | (inherited from Control).
 | FromHandle | (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) (inherited from Control).
Public method | GetContainerControl | (inherited from Control).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetNextControl | (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | Hide | (inherited from Control).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) (inherited from Control).
Public method | Invoke | (Overloaded) (inherited from Control).
 | IsKeyLocked | (inherited from Control).
 | IsMnemonic | (inherited from Control).
Public method | PerformLayout | (Overloaded) (inherited from Control).
Public method | PointToClient | (inherited from Control).
Public method | PointToScreen | (inherited from Control).
Public method | PreProcessControlMessage | (inherited from Control).
Public method | PreProcessMessage | (inherited from Control).
Public method | RectangleToClient | (inherited from Control).
Public method | RectangleToScreen | (inherited from Control).
 | ReferenceEquals | Determina se le istanze di Object specificate rappresentano la stessa istanza. (inherited from Object).
Public method | Refresh | (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | (inherited from Control).
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (inherited from Control).
Public method | SelectNextControl | (inherited from Control).
Public method | SendToBack | (inherited from Control).
Public method | SetBounds | (Overloaded) (inherited from Control).
Public method | Show | (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Public method | ToString | (inherited from Splitter).
Public method | Update | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Splitter).
Public event | BackgroundImageLayoutChanged | (inherited from Splitter).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | CollapsedExpanded | Occurs after the slipper was collapsed or expanded
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Splitter).
Public event | FontChanged | (inherited from Splitter).
Public event | ForeColorChanged | (inherited from Splitter).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Splitter).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Splitter).
Public event | KeyPress | (inherited from Splitter).
Public event | KeyUp | (inherited from Splitter).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Splitter).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | SplitterMoved | (inherited from Splitter).
Public event | SplitterMoving | (inherited from Splitter).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Splitter).
Public event | TextChanged | (inherited from Splitter).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

AdvancedSplitter Class


AdvancedSplitter Constructor

See Also

Initializes a new instance of the AdvancedSplitter class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public AdvancedSplitter()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter Properties

AdvancedSplitter Class See Also

The following tables list the members exposed by the AdvancedSplitter type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Splitter).
Public property | Anchor | (inherited from Splitter).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundGradient | Gets/Sets whether the renderer draw background using gradient effects of not
Public property | BackgroundImage | (inherited from Splitter).
Public property | BackgroundImageLayout | (inherited from Splitter).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets or sets .
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | Collapsed | Gets if splitter is currently collapsed.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Control | Gets/Sets the hosted control by splitter. This controll will be automatically collapse or expand by splitter. Splitter must be docked at any size to this control.
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Splitter).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Splitter).
Public property | ForeColor | (inherited from Splitter).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Splitter).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinExtra | (inherited from Splitter).
Public property | MinSize | (inherited from Splitter).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | Gets or sets .
Public property | SplitPosition | (inherited from Splitter).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Splitter).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Splitter).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

AdvancedSplitter Class


AdvancedSplitter.BackgroundGradient Property

Gets/Sets whether the renderer draw background using gradient effects of not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("AdvancedSplitter")> _
<Description("Gets/Sets whether the renderer draw background using gradient effects of not")> _
<DefaultValue(True)> _
Public Property BackgroundGradient() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("AdvancedSplitter")]
[Description("Gets/Sets whether the renderer draw background using gradient effects of not")]
[DefaultValue(True)]
public bool BackgroundGradient {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter.BorderStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BorderStyle() As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public BorderStyle BorderStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter.Collapsed Property

Gets if splitter is currently collapsed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<Category("AdvancedSplitter")> _
<DefaultValue(False)> _
<Description("Gets if splitter i currently collapsed.")> _
Public ReadOnly Property Collapsed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[Category("AdvancedSplitter")]
[DefaultValue(False)]
[Description("Gets if splitter i currently collapsed.")]
public bool Collapsed {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter.Control Property

Gets/Sets the hosted control by splitter. This controll will be automatically collapse or expand by splitter. Splitter must be docked at any size to this control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("AdvancedSplitter")> _
<DefaultValue(CStr(Nothing))> _
<Description("Gets/Sets the control the splitter must automatically collapse or expand")> _
<RefreshProperties(RefreshProperties.All)> _
Public Property Control() As Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("AdvancedSplitter")]
[DefaultValue(CStr(Nothing))]
[Description("Gets/Sets the control the splitter must automatically collapse or expand")]
[RefreshProperties(RefreshProperties.All)]
public Control Control {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter.Size Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Size() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Size Size {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter Methods

AdvancedSplitter Class See Also

The following tables list the members exposed by the AdvancedSplitter type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BringToFront | (inherited from Control).
Public method | CollapseExpand | Collaspe splitter if currently expanded otherwise expand splitter if currently collapsed
Public method | Contains | (inherited from Control).
Public method | CreateControl | (inherited from Control).
Public method | CreateGraphics | (inherited from Control).
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | DoDragDrop | (inherited from Control).
Public method | DrawToBitmap | (inherited from Control).
Public method | EndInvoke | (inherited from Control).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | FindForm | (inherited from Control).
Public method | Focus | (inherited from Control).
 | FromChildHandle | (inherited from Control).
 | FromHandle | (inherited from Control).
Public method | GetChildAtPoint | (Overloaded) (inherited from Control).
Public method | GetContainerControl | (inherited from Control).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetNextControl | (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | Hide | (inherited from Control).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) (inherited from Control).
Public method | Invoke | (Overloaded) (inherited from Control).
 | IsKeyLocked | (inherited from Control).
 | IsMnemonic | (inherited from Control).
Public method | PerformLayout | (Overloaded) (inherited from Control).
Public method | PointToClient | (inherited from Control).
Public method | PointToScreen | (inherited from Control).
Public method | PreProcessControlMessage | (inherited from Control).
Public method | PreProcessMessage | (inherited from Control).
Public method | RectangleToClient | (inherited from Control).
Public method | RectangleToScreen | (inherited from Control).
 | ReferenceEquals | Determina se le istanze di Object specificate rappresentano la stessa istanza. (inherited from Object).
Public method | Refresh | (inherited from Control).
Public method | ResetBackColor | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetCursor | (inherited from Control).
Public method | ResetFont | (inherited from Control).
Public method | ResetForeColor | (inherited from Control).
Public method | ResetImeMode | (inherited from Control).
Public method | ResetRightToLeft | (inherited from Control).
Public method | ResetText | (inherited from Control).
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Scale | (Overloaded) (inherited from Control).
Public method | Select | (inherited from Control).
Public method | SelectNextControl | (inherited from Control).
Public method | SendToBack | (inherited from Control).
Public method | SetBounds | (Overloaded) (inherited from Control).
Public method | Show | (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Public method | ToString | (inherited from Splitter).
Public method | Update | (inherited from Control).
Top
See Also

Reference

AdvancedSplitter Class


AdvancedSplitter.CollapseExpand Method

Collaspe splitter if currently expanded otherwise expand splitter if currently collapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub CollapseExpand()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void CollapseExpand()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


AdvancedSplitter Events

AdvancedSplitter Class See Also

The following tables list the members exposed by the AdvancedSplitter type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Splitter).
Public event | BackgroundImageLayoutChanged | (inherited from Splitter).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | CollapsedExpanded | Occurs after the slipper was collapsed or expanded
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Splitter).
Public event | FontChanged | (inherited from Splitter).
Public event | ForeColorChanged | (inherited from Splitter).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Splitter).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Splitter).
Public event | KeyPress | (inherited from Splitter).
Public event | KeyUp | (inherited from Splitter).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Splitter).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | SplitterMoved | (inherited from Splitter).
Public event | SplitterMoving | (inherited from Splitter).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Splitter).
Public event | TextChanged | (inherited from Splitter).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

AdvancedSplitter Class


CollapsedExpanded Event

Occurs after the slipper was collapsed or expanded

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event CollapsedExpanded( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event CollapsedExpandedEventHandler CollapsedExpanded
delegate void CollapsedExpandedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

AdvancedSplitter Class
AdvancedSplitter Members


ColorTableBlack Class

Members

ColorTableBlack define a black color table for Outlook Bar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ColorTableBlack
    Inherits ProfessionalColorTable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ColorTableBlack : ProfessionalColorTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Windows.Forms.ProfessionalColorTable
Softgroup.NetControls.ColorTableBlack
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Members


ColorTableBlack Members

ColorTableBlack Class Constructors Methods Properties See Also

ColorTableBlack define a black color table for Outlook Bar control

The following tables list the members exposed by the ColorTableBlack type.

Constructors
 | Name | Description
Public constructor | ColorTableBlack Constructor | Initializes a new instance of the ColorTableBlack class.
Top
Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableBlack Class


ColorTableBlack Constructor

Initializes a new instance of the ColorTableBlack class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ColorTableBlack()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack Properties

ColorTableBlack Class See Also

The following tables list the members exposed by the ColorTableBlack type.

Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
See Also

Reference

ColorTableBlack Class


ColorTableBlack.ButtonCheckedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonCheckedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonCheckedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonCheckedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonCheckedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonPressedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ButtonSelectedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.CheckBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.CheckPressedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckPressedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckPressedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.CheckSelectedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckSelectedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckSelectedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.GripDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.GripLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginRevealedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginRevealedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ImageMarginRevealedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemSelected Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelected() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelected {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuItemSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.MenuStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.OverflowButtonGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.OverflowButtonGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.OverflowButtonGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.RaftingContainerGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.RaftingContainerGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.SeparatorDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.SeparatorLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.StatusStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.StatusStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripContentPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripContentPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripDropDownBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripDropDownBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripDropDownBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack.ToolStripPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlack Class
ColorTableBlack Members


ColorTableBlack Methods

ColorTableBlack Class See Also

The following tables list the members exposed by the ColorTableBlack type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableBlack Class


ColorTableBlue Class

Members

ColorTableBlack define a blue color table for Outlook Bar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ColorTableBlue
    Inherits ProfessionalColorTable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ColorTableBlue : ProfessionalColorTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Windows.Forms.ProfessionalColorTable
Softgroup.NetControls.ColorTableBlue
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Members


ColorTableBlue Members

ColorTableBlue Class Constructors Methods Properties See Also

ColorTableBlack define a blue color table for Outlook Bar control

The following tables list the members exposed by the ColorTableBlue type.

Constructors
 | Name | Description
Public constructor | ColorTableBlue Constructor | Initializes a new instance of the ColorTableBlue class.
Top
Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableBlue Class


ColorTableBlue Constructor

Initializes a new instance of the ColorTableBlue class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ColorTableBlue()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue Properties

ColorTableBlue Class See Also

The following tables list the members exposed by the ColorTableBlue type.

Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
See Also

Reference

ColorTableBlue Class


ColorTableBlue.ButtonCheckedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonCheckedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonCheckedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonCheckedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonCheckedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonPressedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ButtonSelectedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.CheckBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.CheckPressedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckPressedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckPressedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.CheckSelectedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckSelectedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckSelectedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.GripDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.GripLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginRevealedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginRevealedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ImageMarginRevealedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemSelected Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelected() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelected {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuItemSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.MenuStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.OverflowButtonGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.OverflowButtonGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.OverflowButtonGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.RaftingContainerGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.RaftingContainerGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.SeparatorDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.SeparatorLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.StatusStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.StatusStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripContentPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripContentPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripDropDownBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripDropDownBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripDropDownBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue.ToolStripPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableBlue Class
ColorTableBlue Members


ColorTableBlue Methods

ColorTableBlue Class See Also

The following tables list the members exposed by the ColorTableBlue type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableBlue Class


ColorTableSilver Class

Members

ColorTableBlack define a silver color table for Outlook Bar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ColorTableSilver
    Inherits ProfessionalColorTable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ColorTableSilver : ProfessionalColorTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Windows.Forms.ProfessionalColorTable
Softgroup.NetControls.ColorTableSilver
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Members


ColorTableSilver Members

ColorTableSilver Class Constructors Methods Properties See Also

ColorTableBlack define a silver color table for Outlook Bar control

The following tables list the members exposed by the ColorTableSilver type.

Constructors
 | Name | Description
Public constructor | ColorTableSilver Constructor | Initializes a new instance of the ColorTableSilver class.
Top
Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableSilver Class


ColorTableSilver Constructor

Initializes a new instance of the ColorTableSilver class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ColorTableSilver()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver Properties

ColorTableSilver Class See Also

The following tables list the members exposed by the ColorTableSilver type.

Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
See Also

Reference

ColorTableSilver Class


ColorTableSilver.ButtonCheckedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonCheckedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonCheckedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonCheckedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonCheckedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonPressedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ButtonSelectedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.CheckBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.CheckPressedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckPressedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckPressedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.CheckSelectedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckSelectedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckSelectedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.GripDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.GripLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginRevealedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginRevealedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ImageMarginRevealedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemSelected Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelected() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelected {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuItemSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.MenuStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.OverflowButtonGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.OverflowButtonGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.OverflowButtonGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.RaftingContainerGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.RaftingContainerGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.SeparatorDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.SeparatorLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.StatusStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.StatusStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripContentPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripContentPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripDropDownBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripDropDownBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripDropDownBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver.ToolStripPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSilver Class
ColorTableSilver Members


ColorTableSilver Methods

ColorTableSilver Class See Also

The following tables list the members exposed by the ColorTableSilver type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableSilver Class


ColorTableSystem Class

Members

ColorTableBlack define a system color table for Outlook Bar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ColorTableSystem
    Inherits ProfessionalColorTable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ColorTableSystem : ProfessionalColorTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Windows.Forms.ProfessionalColorTable
Softgroup.NetControls.ColorTableSystem
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Members


ColorTableSystem Members

ColorTableSystem Class Constructors Methods Properties See Also

ColorTableBlack define a system color table for Outlook Bar control

The following tables list the members exposed by the ColorTableSystem type.

Constructors
 | Name | Description
Public constructor | ColorTableSystem Constructor | Initializes a new instance of the ColorTableSystem class.
Top
Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableSystem Class


ColorTableSystem Constructor

Initializes a new instance of the ColorTableSystem class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ColorTableSystem()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem Properties

ColorTableSystem Class See Also

The following tables list the members exposed by the ColorTableSystem type.

Properties
 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets .
Public property | ButtonCheckedGradientEnd | Gets .
Public property | ButtonCheckedGradientMiddle | Gets .
Public property | ButtonCheckedHighlight | Gets .
Public property | ButtonCheckedHighlightBorder | Gets .
Public property | ButtonPressedBorder | Gets .
Public property | ButtonPressedGradientBegin | Gets .
Public property | ButtonPressedGradientEnd | Gets .
Public property | ButtonPressedGradientMiddle | Gets .
Public property | ButtonPressedHighlight | Gets .
Public property | ButtonPressedHighlightBorder | Gets .
Public property | ButtonSelectedBorder | Gets .
Public property | ButtonSelectedGradientBegin | Gets .
Public property | ButtonSelectedGradientEnd | Gets .
Public property | ButtonSelectedGradientMiddle | Gets .
Public property | ButtonSelectedHighlight | Gets .
Public property | ButtonSelectedHighlightBorder | Gets .
Public property | CheckBackground | Gets .
Public property | CheckPressedBackground | Gets .
Public property | CheckSelectedBackground | Gets .
Public property | GripDark | Gets .
Public property | GripLight | Gets .
Public property | ImageMarginGradientBegin | Gets .
Public property | ImageMarginGradientEnd | Gets .
Public property | ImageMarginGradientMiddle | Gets .
Public property | ImageMarginRevealedGradientBegin | Gets .
Public property | ImageMarginRevealedGradientEnd | Gets .
Public property | ImageMarginRevealedGradientMiddle | Gets .
Public property | MenuBorder | Gets .
Public property | MenuItemBorder | Gets .
Public property | MenuItemPressedGradientBegin | Gets .
Public property | MenuItemPressedGradientEnd | Gets .
Public property | MenuItemPressedGradientMiddle | Gets .
Public property | MenuItemSelected | Gets .
Public property | MenuItemSelectedGradientBegin | Gets .
Public property | MenuItemSelectedGradientEnd | Gets .
Public property | MenuStripGradientBegin | Gets .
Public property | MenuStripGradientEnd | Gets .
Public property | OverflowButtonGradientBegin | Gets .
Public property | OverflowButtonGradientEnd | Gets .
Public property | OverflowButtonGradientMiddle | Gets .
Public property | RaftingContainerGradientBegin | Gets .
Public property | RaftingContainerGradientEnd | Gets .
Public property | SeparatorDark | Gets .
Public property | SeparatorLight | Gets .
Public property | StatusStripGradientBegin | Gets .
Public property | StatusStripGradientEnd | Gets .
Public property | ToolStripBorder | Gets .
Public property | ToolStripContentPanelGradientBegin | Gets .
Public property | ToolStripContentPanelGradientEnd | Gets .
Public property | ToolStripDropDownBackground | Gets .
Public property | ToolStripGradientBegin | Gets .
Public property | ToolStripGradientEnd | Gets .
Public property | ToolStripGradientMiddle | Gets .
Public property | ToolStripPanelGradientBegin | Gets .
Public property | ToolStripPanelGradientEnd | Gets .
Public property | UseSystemColors | (inherited from ProfessionalColorTable).
Top
See Also

Reference

ColorTableSystem Class


ColorTableSystem.ButtonCheckedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonCheckedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonCheckedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonCheckedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonCheckedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonCheckedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonCheckedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonPressedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonPressedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonPressedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedHighlight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ButtonSelectedHighlightBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ButtonSelectedHighlightBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ButtonSelectedHighlightBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.CheckBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.CheckPressedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckPressedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckPressedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.CheckSelectedBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property CheckSelectedBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color CheckSelectedBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.GripDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.GripLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property GripLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color GripLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginRevealedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginRevealedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ImageMarginRevealedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ImageMarginRevealedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ImageMarginRevealedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemPressedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemPressedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemPressedGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemPressedGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemPressedGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemSelected Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelected() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelected {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemSelectedGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuItemSelectedGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuItemSelectedGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuItemSelectedGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.MenuStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property MenuStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color MenuStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.OverflowButtonGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.OverflowButtonGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.OverflowButtonGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property OverflowButtonGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color OverflowButtonGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.RaftingContainerGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.RaftingContainerGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property RaftingContainerGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color RaftingContainerGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.SeparatorDark Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorDark() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorDark {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.SeparatorLight Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property SeparatorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color SeparatorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.StatusStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.StatusStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property StatusStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color StatusStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripBorder Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripBorder() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripBorder {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripContentPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripContentPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripContentPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripContentPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripDropDownBackground Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripDropDownBackground() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripDropDownBackground {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripGradientMiddle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripGradientMiddle() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripGradientMiddle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripPanelGradientBegin Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientBegin() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientBegin {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem.ToolStripPanelGradientEnd Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overrides Property ToolStripPanelGradientEnd() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Color ToolStripPanelGradientEnd {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ColorTableSystem Class
ColorTableSystem Members


ColorTableSystem Methods

ColorTableSystem Class See Also

The following tables list the members exposed by the ColorTableSystem type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ColorTableSystem Class


ComboColors Class

Members

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.ComboColors), "ComboColors.bmp")> _
<System.ComponentModel.DefaultEvent("SelectedIndexChanged")> _
<System.ComponentModel.DefaultProperty("Items")> _
Public Class ComboColors
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.ComboColors), "ComboColors.bmp")]
[System.ComponentModel.DefaultEvent("SelectedIndexChanged")]
[System.ComponentModel.DefaultProperty("Items")]
public class ComboColors : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboColors
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Members


ComboColors Members

ComboColors Class Constructors Events Methods Properties See Also

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.

The following tables list the members exposed by the ComboColors type.

Constructors
 | Name | Description
Public constructor | ComboColors Constructor | (Overloaded) Initializes a new instance of the ComboColors class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorType | Gets/Sets the type of color shown in list.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets and sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedColor | Gets currently selected color.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboColors Class


ComboColors Constructor

ComboColors Class See Also

Initializes a new instance of the ComboColors class.

Overload List
Name | Description
ComboColors() | Initializes a new instance of the ComboColors class.
ComboColors(IContainer) | Initializes a new instance of the ComboColors class.
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors Properties

ComboColors Class See Also

The following tables list the members exposed by the ComboColors type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorType | Gets/Sets the type of color shown in list.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets and sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedColor | Gets currently selected color.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboColors Class


ComboColors.AutoCompleteCustomSource Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteCustomSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.AutoCompleteMode Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.AutoCompleteSource Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.ColorType Property

Gets/Sets the type of color shown in list.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Description("Gets/Sets the type of color shown in list.")> _
<System.ComponentModel.DefaultValue(GetType(ColorEnum), "KnownColor")> _
Public Property ColorType( _
   ByRef "Gets/Sets the type of color shown in list." As Object _
) As ColorEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Description("Gets/Sets the type of color shown in list.")]
[System.ComponentModel.DefaultValue(GetType(ColorEnum), "KnownColor")]
[System.Runtime.CompilerServices.IndexerName("ColorType")]
public ColorEnum this[
   ref object "Gets/Sets the type of color shown in list."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the type of color shown in list."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DataBindings Property

ComboColors Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DataSource Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DefaultBackColor Property

ComboColors Class See Also

Gets default background color for control.

Overload List
Name | Description
this[ref object] | Gets default background color for control.
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DefaultForeColor Property

ComboColors Class See Also

Gets default foreground color for control.

Overload List
Name | Description
this[ref object] | Gets default foreground color for control.
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DisplayMember Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DisplayMember | (System.Windows.Forms.ListControl).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DrawMode Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DropDownStyle Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DropDownStyle | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FocusStyle Property

Gets and sets the focus style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Description("Gets and sets the focus style.")> _
<System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")> _
Public Property FocusStyle( _
   ByRef "Gets and sets the focus style." As Object _
) As FocusStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Description("Gets and sets the focus style.")]
[System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")]
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets and sets the focus style."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets and sets the focus style."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormatInfo Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormatString Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormattingEnabled Property

ComboColors Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Items Property

ComboColors Class See Also

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Overload List
Name | Description
this[ref object] | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Items | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Margin Property

ComboColors Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.SelectedColor Property

Gets currently selected color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected color.")> _
Public ReadOnly Property SelectedColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently selected color.")]
[System.Runtime.CompilerServices.IndexerName("SelectedColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Text Property

ComboColors Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors Methods

ComboColors Class See Also

The following tables list the members exposed by the ComboColors type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboColors Class


ComboColors Events

ComboColors Class See Also

The following tables list the members exposed by the ComboColors type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboColors Class


MarginChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event MarginChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event MarginChangedEventHandler MarginChanged
delegate void MarginChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboDrives Class

Members

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ComboDrives
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ComboDrives : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboDrives
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Members


ComboDrives Members

ComboDrives Class Constructors Events Methods Properties See Also

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.

The following tables list the members exposed by the ComboDrives type.

Constructors
 | Name | Description
Public constructor | ComboDrives Constructor | (Overloaded) Initializes a new instance of the ComboDrives class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoRefresh | Gets/Sets if list of drives will be automatically updated
Public property | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedDrive | Gets currently selected Drive name.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | RefreshDrives | Force a refresh of drives list in combo
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboDrives Class


ComboDrives Constructor

ComboDrives Class See Also

Initializes a new instance of the ComboDrives class.

Overload List
Name | Description
ComboDrives() | Initializes a new instance of the ComboDrives class.
ComboDrives(IContainer) | Initializes a new instance of the ComboDrives class.
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives Properties

ComboDrives Class See Also

The following tables list the members exposed by the ComboDrives type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoRefresh | Gets/Sets if list of drives will be automatically updated
Public property | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedDrive | Gets currently selected Drive name.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboDrives Class


ComboDrives.AutoCompleteCustomSource Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteCustomSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoCompleteMode Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoCompleteSource Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoRefresh Property

Gets/Sets if list of drives will be automatically updated

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboDrives")> _
<System.ComponentModel.Description("Gets/Sets if list of drives will be automatically updated.")> _
<System.ComponentModel.DefaultValue(False)> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)> _
Public Property AutoRefresh( _
   ByRef "Gets/Sets if list of drives will be automatically updated." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboDrives")]
[System.ComponentModel.Description("Gets/Sets if list of drives will be automatically updated.")]
[System.ComponentModel.DefaultValue(False)]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)]
[System.Runtime.CompilerServices.IndexerName("AutoRefresh")]
public bool this[
   ref object "Gets/Sets if list of drives will be automatically updated."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if list of drives will be automatically updated."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoRefreshTimeout Property

Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboDrives")> _
<System.ComponentModel.Description("Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of drives.")> _
<System.ComponentModel.DefaultValue(1000)> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)> _
Public Property AutoRefreshTimeout( _
   ByRef "Gets/Sets the timeout  As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboDrives")]
[System.ComponentModel.Description("Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of drives.")]
[System.ComponentModel.DefaultValue(1000)]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)]
[System.Runtime.CompilerServices.IndexerName("AutoRefreshTimeout")]
public int this[
   ref object "Gets/Sets the timeout
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the timeout

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DataBindings Property

ComboDrives Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DataSource Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DefaultBackColor Property

ComboDrives Class See Also

Gets default background color for control.

Overload List
Name | Description
this[ref object] | Gets default background color for control.
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DefaultForeColor Property

ComboDrives Class See Also

Gets default foreground color for control.

Overload List
Name | Description
this[ref object] | Gets default foreground color for control.
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DisplayMember Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DisplayMember | (System.Windows.Forms.ListControl).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DrawMode Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DropDownStyle Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DropDownStyle | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FocusStyle Property

Gets/Sets the focus style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboDrives")> _
<System.ComponentModel.Description("Gets/Sets the focus style.")> _
<System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")> _
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboDrives")]
[System.ComponentModel.Description("Gets/Sets the focus style.")]
[System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")]
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the focus style."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FormatInfo Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FormatString Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FormattingEnabled Property

ComboDrives Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Items Property

ComboDrives Class See Also

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Overload List
Name | Description
this[ref object] | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Items | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Margin Property

ComboDrives Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.SelectedDrive Property

Gets currently selected Drive name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected Drive name.")> _
<System.ComponentModel.Category("ComboDrives")> _
Public ReadOnly Property SelectedDrive( _
   ByRef "Gets currently selected Drive name." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently selected Drive name.")]
[System.ComponentModel.Category("ComboDrives")]
[System.Runtime.CompilerServices.IndexerName("SelectedDrive")]
public string this[
   ref object "Gets currently selected Drive name."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets currently selected Drive name."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Text Property

ComboDrives Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives Methods

ComboDrives Class See Also

The following tables list the members exposed by the ComboDrives type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | RefreshDrives | Force a refresh of drives list in combo
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboDrives Class


ComboDrives.RefreshDrives Method

Force a refresh of drives list in combo

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Force a refresh of drives list in combo")> _
Public Sub RefreshDrives()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Force a refresh of drives list in combo")]
public System.Void RefreshDrives()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives Events

ComboDrives Class See Also

The following tables list the members exposed by the ComboDrives type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboDrives Class


MarginChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event MarginChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event MarginChangedEventHandler MarginChanged
delegate void MarginChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboFonts Class

Members

Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class ComboFonts
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class ComboFonts : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboFonts
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Members


ComboFonts Members

ComboFonts Class Constructors Events Methods Properties See Also

Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.

The following tables list the members exposed by the ComboFonts type.

Constructors
 | Name | Description
Public constructor | ComboFonts Constructor | (Overloaded) Initializes a new instance of the ComboFonts class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedFont | Gets currently selected font name.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | ShowIcon | Gets/Sets an icon font is displayed with font name.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | Gets or sets a value indicating whether .
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseFonts | Gets/Sets if item font must be used to draw font name (otherwise control font will be used).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | RefreshFonts | Refresh content of combo fonts
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboFonts Class


ComboFonts Constructor

ComboFonts Class See Also

Initializes a new instance of the ComboFonts class.

Overload List
Name | Description
ComboFonts() | Initializes a new instance of the ComboFonts class.
ComboFonts(IContainer) | Initializes a new instance of the ComboFonts class.
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts Properties

ComboFonts Class See Also

The following tables list the members exposed by the ComboFonts type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedFont | Gets currently selected font name.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | ShowIcon | Gets/Sets an icon font is displayed with font name.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | Gets or sets a value indicating whether .
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseFonts | Gets/Sets if item font must be used to draw font name (otherwise control font will be used).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboFonts Class


ComboFonts.AutoCompleteCustomSource Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteCustomSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.AutoCompleteMode Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.AutoCompleteSource Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DataBindings Property

ComboFonts Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DataSource Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DefaultBackColor Property

ComboFonts Class See Also

Gets default background color for control.

Overload List
Name | Description
this[ref object] | Gets default background color for control.
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DefaultForeColor Property

ComboFonts Class See Also

Gets default foreground color for control.

Overload List
Name | Description
this[ref object] | Gets default foreground color for control.
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DisplayMember Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DisplayMember | (System.Windows.Forms.ListControl).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DrawMode Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DropDownStyle Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DropDownStyle | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FocusStyle Property

Gets/Sets the focus style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboFonts")> _
<System.ComponentModel.Description("Gets/Sets the focus style.")> _
<System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")> _
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboFonts")]
[System.ComponentModel.Description("Gets/Sets the focus style.")]
[System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")]
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the focus style."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormatInfo Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormatString Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormattingEnabled Property

ComboFonts Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Items Property

ComboFonts Class See Also

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Overload List
Name | Description
this[ref object] | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Items | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Margin Property

ComboFonts Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.SelectedFont Property

Gets currently selected font name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected font name.")> _
<System.ComponentModel.Category("ComboFonts")> _
Public ReadOnly Property SelectedFont( _
   ByRef "Gets currently selected font name." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently selected font name.")]
[System.ComponentModel.Category("ComboFonts")]
[System.Runtime.CompilerServices.IndexerName("SelectedFont")]
public string this[
   ref object "Gets currently selected font name."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets currently selected font name."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.ShowIcon Property

Gets/Sets an icon font is displayed with font name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets an icon font is displayed with font name.")> _
<System.ComponentModel.DefaultValue(True)> _
<System.ComponentModel.Category("ComboFonts")> _
Public Property ShowIcon( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets an icon font is displayed with font name.")]
[System.ComponentModel.DefaultValue(True)]
[System.ComponentModel.Category("ComboFonts")]
[System.Runtime.CompilerServices.IndexerName("ShowIcon")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Sorted Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Property Sorted() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Sorted {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Text Property

ComboFonts Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.UseFonts Property

Gets/Sets if item font must be used to draw font name (otherwise control font will be used).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets if item font must be used to draw font name (otherwise control font will be used).")> _
<System.ComponentModel.DefaultValue(False)> _
<System.ComponentModel.Category("ComboFonts")> _
Public Property UseFonts( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets if item font must be used to draw font name (otherwise control font will be used).")]
[System.ComponentModel.DefaultValue(False)]
[System.ComponentModel.Category("ComboFonts")]
[System.Runtime.CompilerServices.IndexerName("UseFonts")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts Methods

ComboFonts Class See Also

The following tables list the members exposed by the ComboFonts type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | RefreshFonts | Refresh content of combo fonts
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboFonts Class


ComboFonts.RefreshFonts Method

Refresh content of combo fonts

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Refresh content of combo fonts")> _
Public Sub RefreshFonts()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Refresh content of combo fonts")]
public System.Void RefreshFonts()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts Events

ComboFonts Class See Also

The following tables list the members exposed by the ComboFonts type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboFonts Class


MarginChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event MarginChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event MarginChangedEventHandler MarginChanged
delegate void MarginChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboImages Class

Members

Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.ComboPrinters), "ComboImages.bmp")> _
<System.ComponentModel.DefaultEvent("SelectedIndexChanged")> _
<System.ComponentModel.DefaultProperty("Items")> _
Public Class ComboImages
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.ComboPrinters), "ComboImages.bmp")]
[System.ComponentModel.DefaultEvent("SelectedIndexChanged")]
[System.ComponentModel.DefaultProperty("Items")]
public class ComboImages : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboImages
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Members


ComboImages Members

ComboImages Class Events Methods Properties See Also

Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)

The following tables list the members exposed by the ComboImages type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Images | Collection of images associated into combo
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedImage | Gets currently selected image.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboImages Class


ComboImages Properties

ComboImages Class See Also

The following tables list the members exposed by the ComboImages type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Images | Collection of images associated into combo
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedImage | Gets currently selected image.
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboImages Class


ComboImages.AutoCompleteCustomSource Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteCustomSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.AutoCompleteMode Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.AutoCompleteSource Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DataBindings Property

ComboImages Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DataSource Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DefaultBackColor Property

ComboImages Class See Also

Gets default background color for control.

Overload List
Name | Description
this[ref object] | Gets default background color for control.
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DefaultForeColor Property

ComboImages Class See Also

Gets default foreground color for control.

Overload List
Name | Description
this[ref object] | Gets default foreground color for control.
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DisplayMember Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DisplayMember | (System.Windows.Forms.ListControl).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DrawMode Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DropDownStyle Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DropDownStyle | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FocusStyle Property

Gets/Sets the focus style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Description("Gets/Sets the focus style.")> _
<System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")> _
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Description("Gets/Sets the focus style.")]
[System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")]
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the focus style."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormatInfo Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormatString Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormattingEnabled Property

ComboImages Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Images Property

Collection of images associated into combo

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Collection of images associated into combo")> _
Public ReadOnly Property Images( _
   ByRef False As Object _
) As ItemImages
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Collection of images associated into combo")]
[System.Runtime.CompilerServices.IndexerName("Images")]
public ItemImages this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Items Property

ComboImages Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
Items | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Margin Property

ComboImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.SelectedImage Property

Gets currently selected image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected image.")> _
Public ReadOnly Property SelectedImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently selected image.")]
[System.Runtime.CompilerServices.IndexerName("SelectedImage")]
public Image this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Text Property

ComboImages Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages Methods

ComboImages Class See Also

The following tables list the members exposed by the ComboImages type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboImages Class


ComboImages Events

ComboImages Class See Also

The following tables list the members exposed by the ComboImages type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboImages Class


MarginChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event MarginChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event MarginChangedEventHandler MarginChanged
delegate void MarginChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboList Class

Members

Softgroup .Net ComboList is a resizable ComboBox control that has same behaviors of a standard ComboBox with a DropDownList style and many others features.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.ComboColors), "ComboList.bmp")> _
<System.ComponentModel.DefaultEvent("SelectedIndexChanged")> _
<System.ComponentModel.DefaultProperty("Items")> _
<Designer(GetType(ComboListDesigner))> _
Public Class ComboList
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.ComboColors), "ComboList.bmp")]
[System.ComponentModel.DefaultEvent("SelectedIndexChanged")]
[System.ComponentModel.DefaultProperty("Items")]
[Designer(GetType(ComboListDesigner))]
public class ComboList : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboList
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Members


ComboList Members

ComboList Class Events Methods Properties See Also

Softgroup .Net ComboList is a resizable ComboBox control that has same behaviors of a standard ComboBox with a DropDownList style and many others features.

The following tables list the members exposed by the ComboList type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (inherited from ComboBox).
Public property | AutoCompleteMode | (inherited from ComboBox).
Public property | AutoCompleteSource | (inherited from ComboBox).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CueBannerText | Gets/Sets Text displayed when control has no selection.
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
Public property | DataSource | (inherited from ComboBox).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayMember | (inherited from ListControl).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (inherited from ComboBox).
Public property | DropDownAutoSize | Gets or sets if DropDownWidth and DropDownHeight must be sets automatically adjusted before dropdown part become visible
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (inherited from ComboBox).
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusRectangle | Gets or sets if focus rectangle must be drawn when control is focued
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (inherited from ListControl).
Public property | FormatString | (inherited from ListControl).
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Highlight | Gets or sets background color used to drawn standard ComboList when selected or focused
Public property | HighlightText | Gets or sets text color used to drawn standard ComboList when selected or focused
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemAutoHeight | Gets or sets if item height is automatically calculated
Public property | ItemFont | Gets or sets the font used to draw items text in the combo box
Public property | ItemHeight | (Overloaded) Gets or sets the height items in the combo box
Public property | Items | (inherited from ComboBox).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | Gets or sets .
Public property | MinimumSize | Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | VisualStyles | Gets or sets if ComboList must be drawn as standard ComboBox or emulating visual styles if enabled
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | AdjustDropDownSize | Adjust the dropdown size (DropDownWidth and DropDownHeight properties).
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | ClearItems | Clear all items of ComboBox
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemMinimumHeight | Gets the minimum height for the ComboList control
Public method | GetItemText | (Overloaded) Gets the text of specified item Index
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboList Class


ComboList Properties

ComboList Class See Also

The following tables list the members exposed by the ComboList type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (inherited from ComboBox).
Public property | AutoCompleteMode | (inherited from ComboBox).
Public property | AutoCompleteSource | (inherited from ComboBox).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CueBannerText | Gets/Sets Text displayed when control has no selection.
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
Public property | DataSource | (inherited from ComboBox).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayMember | (inherited from ListControl).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (inherited from ComboBox).
Public property | DropDownAutoSize | Gets or sets if DropDownWidth and DropDownHeight must be sets automatically adjusted before dropdown part become visible
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (inherited from ComboBox).
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusRectangle | Gets or sets if focus rectangle must be drawn when control is focued
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (inherited from ListControl).
Public property | FormatString | (inherited from ListControl).
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Highlight | Gets or sets background color used to drawn standard ComboList when selected or focused
Public property | HighlightText | Gets or sets text color used to drawn standard ComboList when selected or focused
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemAutoHeight | Gets or sets if item height is automatically calculated
Public property | ItemFont | Gets or sets the font used to draw items text in the combo box
Public property | ItemHeight | (Overloaded) Gets or sets the height items in the combo box
Public property | Items | (inherited from ComboBox).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | Gets or sets .
Public property | MinimumSize | Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | VisualStyles | Gets or sets if ComboList must be drawn as standard ComboBox or emulating visual styles if enabled
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboList Class


ComboList.CueBannerText Property

Gets/Sets Text displayed when control has no selection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.Description("Gets/Sets Text displayed when control has no selection.")> _
<System.ComponentModel.DefaultValue("")> _
Public Property CueBannerText( _
   ByRef "Gets/Sets Text displayed when control has no selection." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.Description("Gets/Sets Text displayed when control has no selection.")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("CueBannerText")]
public string this[
   ref object "Gets/Sets Text displayed when control has no selection."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets Text displayed when control has no selection."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.DropDownAutoSize Property

Gets or sets if DropDownWidth and DropDownHeight must be sets automatically adjusted before dropdown part become visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets if DropDownWidth and DropDownHeight must be sets automatically adjusted before dropdown part become visible")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property DropDownAutoSize( _
   ByRef "ComboList" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets if DropDownWidth and DropDownHeight must be sets automatically adjusted before dropdown part become visible")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("DropDownAutoSize")]
public bool this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.FocusRectangle Property

Gets or sets if focus rectangle must be drawn when control is focued

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets if focus rectangle must be drawn when control is focued")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property FocusRectangle( _
   ByRef "ComboList" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets if focus rectangle must be drawn when control is focued")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("FocusRectangle")]
public bool this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.FormattingEnabled Property

ComboList Class See Also

Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboList Class
ComboList Members


ComboList.Highlight Property

Gets or sets background color used to drawn standard ComboList when selected or focused

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets background color used to drawn standard ComboList when selected or focused")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Highlight")> _
Public Property Highlight( _
   ByRef "ComboList" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets background color used to drawn standard ComboList when selected or focused")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Highlight")]
[System.Runtime.CompilerServices.IndexerName("Highlight")]
public Color this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.HighlightText Property

Gets or sets text color used to drawn standard ComboList when selected or focused

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets text color used to drawn standard ComboList when selected or focused")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HighlightText")> _
Public Property HighlightText( _
   ByRef "ComboList" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets text color used to drawn standard ComboList when selected or focused")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HighlightText")]
[System.Runtime.CompilerServices.IndexerName("HighlightText")]
public Color this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.ItemAutoHeight Property

Gets or sets if item height is automatically calculated

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets if item height is automatically calculated")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(True)> _
<System.ComponentModel.RefreshProperties(RefreshProperties.All)> _
Public Property ItemAutoHeight( _
   ByRef "ComboList" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets if item height is automatically calculated")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(True)]
[System.ComponentModel.RefreshProperties(RefreshProperties.All)]
[System.Runtime.CompilerServices.IndexerName("ItemAutoHeight")]
public bool this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.ItemFont Property

Gets or sets the font used to draw items text in the combo box

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets the font used to draw items text in the combo box")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
<System.ComponentModel.RefreshProperties(RefreshProperties.All)> _
Public Property ItemFont( _
   ByRef "ComboList" As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets the font used to draw items text in the combo box")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.ComponentModel.RefreshProperties(RefreshProperties.All)]
[System.Runtime.CompilerServices.IndexerName("ItemFont")]
public Font this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.ItemHeight Property

ComboList Class See Also

Gets or sets the height items in the combo box

Overload List
Name | Description
this[ref object] | Gets or sets the height items in the combo box
ItemHeight | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboList Class
ComboList Members


ComboList.MaximumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Property MaximumSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Size MaximumSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.MinimumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Property MinimumSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Size MinimumSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.Text Property

ComboList Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboList Class
ComboList Members


ComboList.VisualStyles Property

Gets or sets if ComboList must be drawn as standard ComboBox or emulating visual styles if enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets if ComboList must be drawn as standard ComboBox or emulating visual styles")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property VisualStyles( _
   ByRef "ComboList" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets if ComboList must be drawn as standard ComboBox or emulating visual styles")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("VisualStyles")]
public bool this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList Methods

ComboList Class See Also

The following tables list the members exposed by the ComboList type.

Methods
 | Name | Description
Public method | AdjustDropDownSize | Adjust the dropdown size (DropDownWidth and DropDownHeight properties).
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | ClearItems | Clear all items of ComboBox
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemMinimumHeight | Gets the minimum height for the ComboList control
Public method | GetItemText | (Overloaded) Gets the text of specified item Index
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboList Class


ComboList.AdjustDropDownSize Method

Adjust the dropdown size (DropDownWidth and DropDownHeight properties).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AdjustDropDownSize()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AdjustDropDownSize()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.ClearItems Method

Clear all items of ComboBox

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ClearItems()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ClearItems()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.GetItemMinimumHeight Method

Gets the minimum height for the ComboList control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetItemMinimumHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int GetItemMinimumHeight()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.GetItemText Method

ComboList Class See Also

Gets the text of specified item Index

Overload List
Name | Description
GetItemText(Object) | (System.Windows.Forms.ListControl).
GetItemText(int) | Gets the text of specified item Index
See Also

Reference

ComboList Class
ComboList Members


ComboList Events

ComboList Class See Also

The following tables list the members exposed by the ComboList type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboList Class


ComboPrinters Class

Members

Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.ComboPrinters), "ComboPrinters.bmp")> _
<System.ComponentModel.DefaultEvent("SelectedIndexChanged")> _
<System.ComponentModel.DefaultProperty("Items")> _
Public Class ComboPrinters
    Inherits ComboBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.ComboPrinters), "ComboPrinters.bmp")]
[System.ComponentModel.DefaultEvent("SelectedIndexChanged")]
[System.ComponentModel.DefaultProperty("Items")]
public class ComboPrinters : ComboBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetControls.ComboPrinters
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Members


ComboPrinters Members

ComboPrinters Class Events Methods Properties See Also

Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).

The following tables list the members exposed by the ComboPrinters type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoRefresh | Gets/Sets if list of printers will be automatically updated
Public property | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedPrinter | Gets currently selected printer name.
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | IsPrinterValid | Check if specified printer is a valid printer
Public method | RefreshPrinters | Force a refresh of printers list in combo
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboPrinters Class


ComboPrinters Properties

ComboPrinters Class See Also

The following tables list the members exposed by the ComboPrinters type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoCompleteCustomSource | (Overloaded) Gets or sets .
Public property | AutoCompleteMode | (Overloaded) Gets or sets .
Public property | AutoCompleteSource | (Overloaded) Gets or sets .
Public property | AutoRefresh | Gets/Sets if list of printers will be automatically updated
Public property | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ComboBox).
Public property | BackgroundImage | (inherited from ComboBox).
Public property | BackgroundImageLayout | (inherited from ComboBox).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets .
Public property | DataSource | (Overloaded) Gets or sets .
Public property | DefaultBackColor | (Overloaded) Gets default background color for control.
 | DefaultFont | (inherited from Control).
Public property | DefaultForeColor | (Overloaded) Gets default foreground color for control.
Public property | DisplayMember | (Overloaded) Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | DropDownHeight | (inherited from ComboBox).
Public property | DropDownStyle | (Overloaded) Gets or sets .
Public property | DropDownWidth | (inherited from ComboBox).
Public property | DroppedDown | (inherited from ComboBox).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | (inherited from ComboBox).
Public property | FocusStyle | Gets/Sets the focus style.
Public property | Focused | (inherited from ComboBox).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from ComboBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (inherited from ComboBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemHeight | (inherited from ComboBox).
Public property | Items | (Overloaded) A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaxDropDownItems | (inherited from ComboBox).
Public property | MaxLength | (inherited from ComboBox).
Public property | MaximumSize | (inherited from ComboBox).
Public property | MinimumSize | (inherited from ComboBox).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ComboBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ComboBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | (inherited from ComboBox).
Public property | SelectedItem | (inherited from ComboBox).
Public property | SelectedPrinter | Gets currently selected printer name.
Public property | SelectedText | (inherited from ComboBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionLength | (inherited from ComboBox).
Public property | SelectionStart | (inherited from ComboBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ComboBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets currently Text of combo.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ComboPrinters Class


ComboPrinters.AutoCompleteCustomSource Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteCustomSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoCompleteMode Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoCompleteSource Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoCompleteSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoRefresh Property

Gets/Sets if list of printers will be automatically updated

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Description("Gets/Sets if list of printers will be automatically updated.")> _
<System.ComponentModel.DefaultValue(False)> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)> _
Public Property AutoRefresh( _
   ByRef "Gets/Sets if list of printers will be automatically updated." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Description("Gets/Sets if list of printers will be automatically updated.")]
[System.ComponentModel.DefaultValue(False)]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)]
[System.Runtime.CompilerServices.IndexerName("AutoRefresh")]
public bool this[
   ref object "Gets/Sets if list of printers will be automatically updated."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if list of printers will be automatically updated."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoRefreshTimeout Property

Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Description("Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers.")> _
<System.ComponentModel.DefaultValue(5000)> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)> _
Public Property AutoRefreshTimeout( _
   ByRef "Gets/Sets the timeout  As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Description("Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers.")]
[System.ComponentModel.DefaultValue(5000)]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Visible)]
[System.Runtime.CompilerServices.IndexerName("AutoRefreshTimeout")]
public int this[
   ref object "Gets/Sets the timeout
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the timeout

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DataBindings Property

ComboPrinters Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DataSource Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataSource | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DefaultBackColor Property

ComboPrinters Class See Also

Gets default background color for control.

Overload List
Name | Description
this[ref object] | Gets default background color for control.
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DefaultForeColor Property

ComboPrinters Class See Also

Gets default foreground color for control.

Overload List
Name | Description
this[ref object] | Gets default foreground color for control.
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DisplayMember Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DisplayMember | (System.Windows.Forms.ListControl).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DrawMode Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DropDownStyle Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DropDownStyle | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FocusStyle Property

Gets/Sets the focus style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Description("Gets/Sets the focus style.")> _
<System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")> _
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Description("Gets/Sets the focus style.")]
[System.ComponentModel.DefaultValue(GetType(FocusStyleEnum), "Blend")]
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the focus style."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormatInfo Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormatString Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormattingEnabled Property

ComboPrinters Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Items Property

ComboPrinters Class See Also

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Overload List
Name | Description
this[ref object] | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Items | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Margin Property

ComboPrinters Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.SelectedPrinter Property

Gets currently selected printer name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected printer name.")> _
Public ReadOnly Property SelectedPrinter( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently selected printer name.")]
[System.Runtime.CompilerServices.IndexerName("SelectedPrinter")]
public string this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Text Property

ComboPrinters Class See Also

Gets currently Text of combo.

Overload List
Name | Description
this[ref object] | Gets currently Text of combo.
Text | (System.Windows.Forms.ComboBox).
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters Methods

ComboPrinters Class See Also

The following tables list the members exposed by the ComboPrinters type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ComboBox).
Public method | EndUpdate | (inherited from ComboBox).
Public method | FindString | (Overloaded) (inherited from ComboBox).
Public method | FindStringExact | (Overloaded) (inherited from ComboBox).
Public method | GetItemHeight | (inherited from ComboBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | IsPrinterValid | Check if specified printer is a valid printer
Public method | RefreshPrinters | Force a refresh of printers list in combo
Public method | ResetBindings | (inherited from Control).
Public method | ResetText | (inherited from ComboBox).
Public method | Select | (inherited from ComboBox).
Public method | SelectAll | (inherited from ComboBox).
Public method | ToString | (inherited from ComboBox).
Top
See Also

Reference

ComboPrinters Class


ComboPrinters.IsPrinterValid Method

Check if specified printer is a valid printer

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IsPrinterValid( _
   ByVal sPrinter As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool IsPrinterValid(
   string sPrinter
)
This language is not supported or no code example is available.

Parameters

sPrinter

Type: string

Name of printer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.RefreshPrinters Method

Force a refresh of printers list in combo

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Force a refresh of printers list in combo")> _
Public Sub RefreshPrinters()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Force a refresh of printers list in combo")]
public System.Void RefreshPrinters()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters Events

ComboPrinters Class See Also

The following tables list the members exposed by the ComboPrinters type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ComboBox).
Public event | BackgroundImageLayoutChanged | (inherited from ComboBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from ComboBox).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from ComboBox).
Public event | DropDown | (inherited from ComboBox).
Public event | DropDownClosed | (inherited from ComboBox).
Public event | DropDownStyleChanged | (inherited from ComboBox).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | (inherited from ListControl).
Public event | FormatStringChanged | (inherited from ListControl).
Public event | FormattingEnabledChanged | (inherited from ListControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | Occurs when .
Public event | MeasureItem | (inherited from ComboBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ComboBox).
Public event | Paint | (inherited from ComboBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ComboBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SelectionChangeCommitted | (inherited from ComboBox).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | TextUpdate | (inherited from ComboBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ComboPrinters Class


MarginChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event MarginChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event MarginChangedEventHandler MarginChanged
delegate void MarginChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ExplorerBar Class

Members

Softgroup .Net Explorer Bar Control is a fast, small, lightweight and enhanced implementation of a Windows Explorer Bar control. The Explorer Bar can display intrinsic items or any other control divided into groups that can be expanded and collapsed to allow the user to customise which information is shown.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Softgroup.NetControls.ExplorerBar), "ExplorerBar")> _
<DefaultEvent("Click")> _
<DefaultProperty("Groups")> _
Public Class ExplorerBar
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Softgroup.NetControls.ExplorerBar), "ExplorerBar")]
[DefaultEvent("Click")]
[DefaultProperty("Groups")]
public class ExplorerBar : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ExplorerBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Members


ExplorerBar Members

ExplorerBar Class Events Methods Properties See Also

Softgroup .Net Explorer Bar Control is a fast, small, lightweight and enhanced implementation of a Windows Explorer Bar control. The Explorer Bar can display intrinsic items or any other control divided into groups that can be expanded and collapsed to allow the user to customise which information is shown.

The following tables list the members exposed by the ExplorerBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AnimateGroups | Gets/sets whether groups state changes are animated or not.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets color used to paint the background of control.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorSchema | Gets/Sets predefinied color schema
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | Gets default background color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawGroupsBackground | Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | GradientColor | Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True.'''
Public property | GradientEnabled | Enable/Disable use of background gradient colours.
Public property | GradientMode | Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True.
Public property | Groups | Gets the collection of groups associated with this control.
Public property | GroupsHorizontalMargin | Gets/Seta the margin between control border and groups.
Public property | GroupsVerticalMargin | Gets/Seta the vertical margin between control border and groups.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemsHorizontalMargin | Gets/Sets the internal margin from border of group where item will start to draw.
Public property | ItemsVerticalMargin | Gets/Sets the vertical spacing between each item of groups.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Multiline | Enable/Disable text multiline drawing of items on groups.
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ScrollBarVisible | Return True if vertical scrollbar is visible.
Public property | ScrollBarWidth | Gets or sets the width of vertical scrollbar.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | ToolTipText | Gets/Sets the text of tooltip associate with the control.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResetBindings |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetTitleGroupsHeight | Gets/Sets the groups title height.
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupClick | This event will be raised when a group's title is clicked.
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemClick | This event will be raised when an item is clicked.
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ExplorerBar Class


ExplorerBar Properties

ExplorerBar Class See Also

The following tables list the members exposed by the ExplorerBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AnimateGroups | Gets/sets whether groups state changes are animated or not.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets color used to paint the background of control.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorSchema | Gets/Sets predefinied color schema
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | Gets default background color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawGroupsBackground | Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | GradientColor | Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True.'''
Public property | GradientEnabled | Enable/Disable use of background gradient colours.
Public property | GradientMode | Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True.
Public property | Groups | Gets the collection of groups associated with this control.
Public property | GroupsHorizontalMargin | Gets/Seta the margin between control border and groups.
Public property | GroupsVerticalMargin | Gets/Seta the vertical margin between control border and groups.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemsHorizontalMargin | Gets/Sets the internal margin from border of group where item will start to draw.
Public property | ItemsVerticalMargin | Gets/Sets the vertical spacing between each item of groups.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Multiline | Enable/Disable text multiline drawing of items on groups.
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ScrollBarVisible | Return True if vertical scrollbar is visible.
Public property | ScrollBarWidth | Gets or sets the width of vertical scrollbar.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | ToolTipText | Gets/Sets the text of tooltip associate with the control.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ExplorerBar Class


ExplorerBar.AnimateGroups Property

Gets/sets whether groups state changes are animated or not.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/sets whether groups state changes are animated or not.")> _
<DefaultValue(True)> _
Public Property AnimateGroups( _
   ByRef "Gets/sets whether groups state changes are animated or not." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/sets whether groups state changes are animated or not.")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AnimateGroups")]
public bool this[
   ref object "Gets/sets whether groups state changes are animated or not."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether groups state changes are animated or not."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.BackColor Property

ExplorerBar Class See Also

Gets/Sets color used to paint the background of control.

Overload List
Name | Description
this[ref object] | Gets/Sets color used to paint the background of control.
BackColor | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.BackgroundImageTransparent Property

Gets/sets if image background will be paint transparent.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(False)> _
<Description("Gets/sets if image background will be paint transparent.")> _
Public Property BackgroundImageTransparent( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(False)]
[Description("Gets/sets if image background will be paint transparent.")]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageTransparent")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.BindingContext Property

ExplorerBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BindingContext | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.BorderStyle Property

Gets/sets the border style for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.BorderStyle), "Fixed3D")> _
<Description("Gets/sets the border style for control.")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "Fixed3D" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.BorderStyle), "Fixed3D")]
[Description("Gets/sets the border style for control.")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "Fixed3D"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Fixed3D"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ColorSchema Property

Gets/Sets predefinied color schema

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets color schema combination")> _
<System.ComponentModel.DefaultValue(GetType(ColorSchemaEnum), "Default")> _
Public Property ColorSchema( _
   ByRef "Gets/Sets color schema combination" As Object _
) As ColorSchemaEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets color schema combination")]
[System.ComponentModel.DefaultValue(GetType(ColorSchemaEnum), "Default")]
[System.Runtime.CompilerServices.IndexerName("ColorSchema")]
public ColorSchemaEnum this[
   ref object "Gets/Sets color schema combination"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets color schema combination"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.DataBindings Property

ExplorerBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.DefaultBackColor Property

Gets default background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default background color.")> _
Public ReadOnly Overloads Shared Property DefaultBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default background color.")]
public static Color DefaultBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.DefaultGradientColor Property

Gets the default gradient color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default gradient color.")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default gradient color.")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.DrawGroupsBackground Property

Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed.")> _
<DefaultValue(True)> _
Public Property DrawGroupsBackground( _
   ByRef "Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed.")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("DrawGroupsBackground")]
public bool this[
   ref object "Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if background title's group must be drawn. If False only Text and Button of groups will be displayed."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ForeColor Property

ExplorerBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.GradientColor Property

Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True.'''

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True.")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")> _
Public Property GradientColor( _
   ByRef "Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True.")]
[DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the gradient background colour. Used only if GradientEnabled property is sets to True."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.GradientEnabled Property

Enable/Disable use of background gradient colours.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Enable/Disable use of background gradient colours.")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "Enable/Disable use of background gradient colours." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Enable/Disable use of background gradient colours.")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Enable/Disable use of background gradient colours."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Enable/Disable use of background gradient colours."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.GradientMode Property

Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True.")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")> _
Public Property GradientMode( _
   ByRef "Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True." As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True.")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")]
[System.Runtime.CompilerServices.IndexerName("GradientMode")]
public LinearGradientMode this[
   ref object "Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the gradient mode used to draw control background. Used only if GradientEnabled property is sets to True."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.Groups Property

Gets the collection of groups associated with this control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets the collection of groups associated with this control.")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Groups( _
   ByRef "Gets the collection of groups associated with this control." As Object _
) As ExplorerBarGroups
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets the collection of groups associated with this control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
[System.Runtime.CompilerServices.IndexerName("Groups")]
public ExplorerBarGroups this[
   ref object "Gets the collection of groups associated with this control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the collection of groups associated with this control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.GroupsHorizontalMargin Property

Gets/Seta the margin between control border and groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Seta the margin between control border and groups.")> _
<DefaultValue(0)> _
Public Property GroupsHorizontalMargin( _
   ByRef "Gets/Seta the margin between control border and groups." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Seta the margin between control border and groups.")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("GroupsHorizontalMargin")]
public int this[
   ref object "Gets/Seta the margin between control border and groups."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Seta the margin between control border and groups."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.GroupsVerticalMargin Property

Gets/Seta the vertical margin between control border and groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Seta the vertical margin between control border and groups.")> _
<DefaultValue(4)> _
Public Property GroupsVerticalMargin( _
   ByRef "Gets/Seta the vertical margin between control border and groups." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Seta the vertical margin between control border and groups.")]
[DefaultValue(4)]
[System.Runtime.CompilerServices.IndexerName("GroupsVerticalMargin")]
public int this[
   ref object "Gets/Seta the vertical margin between control border and groups."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Seta the vertical margin between control border and groups."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ItemsHorizontalMargin Property

Gets/Sets the internal margin from border of group where item will start to draw.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets the internal margin from border of group where item will start to draw.")> _
<DefaultValue(4)> _
Public Property ItemsHorizontalMargin( _
   ByRef "Gets/Sets the internal margin from border of group where item will start to draw." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets the internal margin from border of group where item will start to draw.")]
[DefaultValue(4)]
[System.Runtime.CompilerServices.IndexerName("ItemsHorizontalMargin")]
public int this[
   ref object "Gets/Sets the internal margin from border of group where item will start to draw."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the internal margin from border of group where item will start to draw."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ItemsVerticalMargin Property

Gets/Sets the vertical spacing between each item of groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets the vertical spacing between each item of groups")> _
<DefaultValue(2)> _
Public Property ItemsVerticalMargin( _
   ByRef "Gets/Sets the vertical spacing between each item of groups" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets the vertical spacing between each item of groups")]
[DefaultValue(2)]
[System.Runtime.CompilerServices.IndexerName("ItemsVerticalMargin")]
public int this[
   ref object "Gets/Sets the vertical spacing between each item of groups"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the vertical spacing between each item of groups"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.Margin Property

ExplorerBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.Multiline Property

Enable/Disable text multiline drawing of items on groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Enable/Disable text multiline drawing of items on groups.")> _
<DefaultValue(True)> _
Public Property Multiline( _
   ByRef "Enable/Disable text multiline drawing of items on groups." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Enable/Disable text multiline drawing of items on groups.")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("Multiline")]
public bool this[
   ref object "Enable/Disable text multiline drawing of items on groups."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Enable/Disable text multiline drawing of items on groups."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.Padding Property

ExplorerBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ScrollBarVisible Property

Return True if vertical scrollbar is visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetExplorerBar")> _
<Description("Return True if vertical scrollbar is visible.")> _
<DefaultValue(19)> _
<Browsable(False)> _
Public ReadOnly Property ScrollBarVisible( _
   ByRef "Return True if vertical scrollbar is visible." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetExplorerBar")]
[Description("Return True if vertical scrollbar is visible.")]
[DefaultValue(19)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ScrollBarVisible")]
public bool this[
   ref object "Return True if vertical scrollbar is visible."
] {get;}
This language is not supported or no code example is available.

Parameters

"Return True if vertical scrollbar is visible."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ScrollBarWidth Property

Gets or sets the width of vertical scrollbar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetExplorerBar")> _
<Description("Gets or sets the width of vertical scrollbar.")> _
<DefaultValue(19)> _
Public Property ScrollBarWidth( _
   ByRef "Gets or sets the width of vertical scrollbar." As Object _
) As Short
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetExplorerBar")]
[Description("Gets or sets the width of vertical scrollbar.")]
[DefaultValue(19)]
[System.Runtime.CompilerServices.IndexerName("ScrollBarWidth")]
public short this[
   ref object "Gets or sets the width of vertical scrollbar."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets or sets the width of vertical scrollbar."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ToolTipText Property

Gets/Sets the text of tooltip associate with the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets the text of tooltip associate with the control.")> _
<DefaultValue("")> _
Public Property ToolTipText( _
   ByRef "Gets/Sets the text of tooltip associate with the control." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets the text of tooltip associate with the control.")]
[DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object "Gets/Sets the text of tooltip associate with the control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the text of tooltip associate with the control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar Methods

ExplorerBar Class See Also

The following tables list the members exposed by the ExplorerBar type.

Methods
 | Name | Description
Public method | ResetBindings |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetTitleGroupsHeight | Gets/Sets the groups title height.
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ExplorerBar Class


ExplorerBar.ResetBindings Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub ResetBindings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void ResetBindings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.SetTitleGroupsHeight Method

Gets/Sets the groups title height.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/Sets the groups title height.")> _
Public Sub SetTitleGroupsHeight( _
   ByVal iHeight As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/Sets the groups title height.")]
public System.Void SetTitleGroupsHeight(
   int iHeight
)
This language is not supported or no code example is available.

Parameters

iHeight

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar Events

ExplorerBar Class See Also

The following tables list the members exposed by the ExplorerBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupClick | This event will be raised when a group's title is clicked.
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemClick | This event will be raised when an item is clicked.
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ExplorerBar Class


BindingContextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BindingContextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BindingContextChangedEventHandler BindingContextChanged
delegate void BindingContextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ForeColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event ForeColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event ForeColorChangedEventHandler ForeColorChanged
delegate void ForeColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


GroupClick Event

This event will be raised when a group's title is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event GroupClick( _
   ByVal sender As Object, _
   ByVal e As ExplorerBarGroupClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event GroupClickEventHandler GroupClick
delegate void GroupClickEventHandler(
   object sender,
   ExplorerBarGroupClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ExplorerBarGroupClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ItemClick Event

This event will be raised when an item is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ItemClick( _
   ByVal sender As Object, _
   ByVal e As ExplorerBarItemClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ItemClickEventHandler ItemClick
delegate void ItemClickEventHandler(
   object sender,
   ExplorerBarItemClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ExplorerBarItemClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBarClickBaseEventArgs Class

Members

Base class for Explorer Bar Click events.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ExplorerBarClickBaseEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ExplorerBarClickBaseEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ExplorerBarClickBaseEventArgs
Softgroup.NetControls.ExplorerBarGroupClickEventArgs
Softgroup.NetControls.ExplorerBarItemClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarClickBaseEventArgs Members


ExplorerBarClickBaseEventArgs Members

ExplorerBarClickBaseEventArgs Class Methods Properties See Also

Base class for Explorer Bar Click events.

The following tables list the members exposed by the ExplorerBarClickBaseEventArgs type.

Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked
Public property | Location | Gets the mouse location at which the click occurred.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarClickBaseEventArgs Class


ExplorerBarClickBaseEventArgs Properties

ExplorerBarClickBaseEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarClickBaseEventArgs type.

Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked
Public property | Location | Gets the mouse location at which the click occurred.
Top
See Also

Reference

ExplorerBarClickBaseEventArgs Class


ExplorerBarClickBaseEventArgs.Buttons Property

Gets the Button that was clicked

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Buttons() As MouseButtons
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public MouseButtons Buttons {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarClickBaseEventArgs Class
ExplorerBarClickBaseEventArgs Members


ExplorerBarClickBaseEventArgs.Location Property

Gets the mouse location at which the click occurred.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Location() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Point Location {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarClickBaseEventArgs Class
ExplorerBarClickBaseEventArgs Members


ExplorerBarClickBaseEventArgs Methods

ExplorerBarClickBaseEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarClickBaseEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarClickBaseEventArgs Class


ExplorerBarGroup Class

Members

The Group within the Explorer Bar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
<DesignTimeVisible(False)> _
<ToolboxItem(False)> _
Public Class ExplorerBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
[DesignTimeVisible(False)]
[ToolboxItem(False)]
public class ExplorerBarGroup
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.ExplorerBarGroup
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Members


ExplorerBarGroup Members

ExplorerBarGroup Class Constructors Events Methods Properties See Also

The Group within the Explorer Bar control.

The following tables list the members exposed by the ExplorerBarGroup type.

Constructors
 | Name | Description
Public constructor | ExplorerBarGroup Constructor | (Overloaded) Constructs a new, instance of this class.
Top
Properties
 | Name | Description
Public property | AnimateGroup | Gets/sets whether bar state changes should be animated for this group. If the group contains items which hold controls then the value will always be False regardless of the setting.
Public property | BackColor | Gets/sets the background colour of this bar.
Public property | BackgroundImage | Gets/sets the image displayed in to the background of group.
Public property | BackgroundImageLayout | Gets/sets if image background will be paint tiled.
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BorderColor | Gets/sets the color used to draw group border.
 | DefaultBackColor | Gets the default group background color.
 | DefaultBorderColor | Gets the default group border color.
 | DefaultGradientColor | Gets the default gradient color.
 | DefaultTitleBackColor | Gets the default title background color.
 | DefaultTitleForeColor | Gets the default title foreground color.
 | DefaultTitleForeColorLight | Gets the default title light foreground color.
 | DefaultTitleGradientColor | Gets the default title gradient background color.
Public property | Expanded | Gets/Sets the state of this Group.
Public property | Focused | Gets/Sets whether this bar has the focus in the control
Public property | Font | Gets/Sets the used to draw the title of this Group.
Public property | GradientColor | Gets/sets the colour to use at the begin of the title group.'''
Public property | GradientEnabled | Gets/Sets if gradient effect ot titlebar groudp is enabled.
Public property | GradientMode | Gets/sets the gradient mode used to draw group background.
Public property | Items | Gets the collection of items associated with this group.
Public property | Key | Gets/sets the string key associated with this group.
Public property | Tag | Gets/sets a custom object to be associated with this Group.
Public property | Text | Gets/Sets the text title for this group.
Public property | TitleBackColor | Gets/Sets custom titlebar group background color.
Public property | TitleForeColor | Gets/Sets custom titlebar group foreground color.
Public property | TitleForeColorLight | Gets/Sets custom titlebar group light foreground color (this color will be used when mouse is over the titlebar group).
Public property | TitleGradientColor | Gets/Sets custom titlebar group start backrground gradient color (this color will be used only if TitleGradientEnabled is sets to True).
Public property | TitleGradientEnabled | Enable/Disable custom titlebar group grdient effects.
Public property | TitleGradientMode | Gets/sets the gradient mode used to draw group titlebar background.
Public property | TitleHeight | Gets/Sets the group title height.
Public property | TitleImage | Gets/sets the image displayed in the title for this group.
Public property | ToolTipText | Gets/Sets the tooltip text that should be shown for this group.
Top
Methods
 | Name | Description
Public method | CanAnimateGroup | Gets whether it is possible to animate group state changes or not. Groups which contain items that hold controls cannot be animated.
Public method | Clone | Returns a deep clone of this object
Public method | ContainsMnemonic | Gets if this groups's title contains the specified mnemonic.
Public method | EnsureVisible | Ensures that this group is visible in the control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this group.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | Click | This Event will be generated every time user click on a Group.
Top
See Also

Reference

ExplorerBarGroup Class


ExplorerBarGroup Constructor

ExplorerBarGroup Class See Also

Constructs a new, instance of this class.

Overload List
Name | Description
ExplorerBarGroup() | Constructs a new, instance of this class.
ExplorerBarGroup(string) | Create a new ExplorerBarGroup with specified parameters.
ExplorerBarGroup(string, string) | Create a new ExplorerBarGroup with specified parameters.
ExplorerBarGroup(string, string, Image) | Create a new ExplorerBarGroup with specified parameters.
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup Properties

ExplorerBarGroup Class See Also

The following tables list the members exposed by the ExplorerBarGroup type.

Properties
 | Name | Description
Public property | AnimateGroup | Gets/sets whether bar state changes should be animated for this group. If the group contains items which hold controls then the value will always be False regardless of the setting.
Public property | BackColor | Gets/sets the background colour of this bar.
Public property | BackgroundImage | Gets/sets the image displayed in to the background of group.
Public property | BackgroundImageLayout | Gets/sets if image background will be paint tiled.
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BorderColor | Gets/sets the color used to draw group border.
 | DefaultBackColor | Gets the default group background color.
 | DefaultBorderColor | Gets the default group border color.
 | DefaultGradientColor | Gets the default gradient color.
 | DefaultTitleBackColor | Gets the default title background color.
 | DefaultTitleForeColor | Gets the default title foreground color.
 | DefaultTitleForeColorLight | Gets the default title light foreground color.
 | DefaultTitleGradientColor | Gets the default title gradient background color.
Public property | Expanded | Gets/Sets the state of this Group.
Public property | Focused | Gets/Sets whether this bar has the focus in the control
Public property | Font | Gets/Sets the used to draw the title of this Group.
Public property | GradientColor | Gets/sets the colour to use at the begin of the title group.'''
Public property | GradientEnabled | Gets/Sets if gradient effect ot titlebar groudp is enabled.
Public property | GradientMode | Gets/sets the gradient mode used to draw group background.
Public property | Items | Gets the collection of items associated with this group.
Public property | Key | Gets/sets the string key associated with this group.
Public property | Tag | Gets/sets a custom object to be associated with this Group.
Public property | Text | Gets/Sets the text title for this group.
Public property | TitleBackColor | Gets/Sets custom titlebar group background color.
Public property | TitleForeColor | Gets/Sets custom titlebar group foreground color.
Public property | TitleForeColorLight | Gets/Sets custom titlebar group light foreground color (this color will be used when mouse is over the titlebar group).
Public property | TitleGradientColor | Gets/Sets custom titlebar group start backrground gradient color (this color will be used only if TitleGradientEnabled is sets to True).
Public property | TitleGradientEnabled | Enable/Disable custom titlebar group grdient effects.
Public property | TitleGradientMode | Gets/sets the gradient mode used to draw group titlebar background.
Public property | TitleHeight | Gets/Sets the group title height.
Public property | TitleImage | Gets/sets the image displayed in the title for this group.
Public property | ToolTipText | Gets/Sets the tooltip text that should be shown for this group.
Top
See Also

Reference

ExplorerBarGroup Class


ExplorerBarGroup.AnimateGroup Property

Gets/sets whether bar state changes should be animated for this group. If the group contains items which hold controls then the value will always be False regardless of the setting.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(True)> _
<Description("Gets/sets whether bar state changes should be animated for this group.  If the group contains items which hold controls then the value will always be False regardless of the setting.")> _
Public Property AnimateGroup( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(True)]
[Description("Gets/sets whether bar state changes should be animated for this group.  If the group contains items which hold controls then the value will always be False regardless of the setting.")]
[System.Runtime.CompilerServices.IndexerName("AnimateGroup")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.BackColor Property

Gets/sets the background colour of this bar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "Window")> _
<Description("Gets/sets the background colour of this bar.")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "Window" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "Window")]
[Description("Gets/sets the background colour of this bar.")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "Window"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Window"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.BackgroundImage Property

Gets/sets the image displayed in to the background of group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))> _
<Description("Gets/sets the image displayed in to the background of group.")> _
Public Property BackgroundImage( _
   ByRef GetType As Object, _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))]
[Description("Gets/sets the image displayed in to the background of group.")]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object GetType,
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.BackgroundImageLayout Property

Gets/sets if image background will be paint tiled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Windows.Forms.ImageLayout), "None")> _
<Description("Gets/sets if image background will be paint tiled.")> _
Public Property BackgroundImageLayout( _
   ByRef GetType As Object, _
   ByRef "None" As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Windows.Forms.ImageLayout), "None")]
[Description("Gets/sets if image background will be paint tiled.")]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object GetType,
   ref object "None"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"None"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.BackgroundImageTransparent Property

Gets/sets if image background will be paint transparent.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(False)> _
<Description("Gets/sets if image background will be paint transparent.")> _
Public Property BackgroundImageTransparent( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(False)]
[Description("Gets/sets if image background will be paint transparent.")]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageTransparent")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.BorderColor Property

Gets/sets the color used to draw group border.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "Highlight")> _
<Description("Gets/sets the color used to draw group border.")> _
Public Property BorderColor( _
   ByRef GetType As Object, _
   ByRef "Highlight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "Highlight")]
[Description("Gets/sets the color used to draw group border.")]
[System.Runtime.CompilerServices.IndexerName("BorderColor")]
public Color this[
   ref object GetType,
   ref object "Highlight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Highlight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultBackColor Property

Gets the default group background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default group background color.")> _
Public ReadOnly Shared Property DefaultBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default group background color.")]
public static Color DefaultBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultBorderColor Property

Gets the default group border color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default group border color.")> _
Public ReadOnly Shared Property DefaultBorderColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default group border color.")]
public static Color DefaultBorderColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultGradientColor Property

Gets the default gradient color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default gradient color.")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default gradient color.")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultTitleBackColor Property

Gets the default title background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default title background color.")> _
Public ReadOnly Shared Property DefaultTitleBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default title background color.")]
public static Color DefaultTitleBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultTitleForeColor Property

Gets the default title foreground color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default title foreground color.")> _
Public ReadOnly Shared Property DefaultTitleForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default title foreground color.")]
public static Color DefaultTitleForeColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultTitleForeColorLight Property

Gets the default title light foreground color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default title light foreground color.")> _
Public ReadOnly Shared Property DefaultTitleForeColorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default title light foreground color.")]
public static Color DefaultTitleForeColorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.DefaultTitleGradientColor Property

Gets the default title gradient background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default title gradient background color.")> _
Public ReadOnly Shared Property DefaultTitleGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default title gradient background color.")]
public static Color DefaultTitleGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Expanded Property

Gets/Sets the state of this Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(True)> _
<Description("Gets/Sets the state of this Group.")> _
Public Property Expanded( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(True)]
[Description("Gets/Sets the state of this Group.")]
[System.Runtime.CompilerServices.IndexerName("Expanded")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Focused Property

Gets/Sets whether this bar has the focus in the control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Browsable(False)> _
<Description("Gets/Sets whether this bar has the focus in the control")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<DefaultValue(False)> _
Public Property Focused( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Browsable(False)]
[Description("Gets/Sets whether this bar has the focus in the control")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("Focused")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Font Property

Gets/Sets the used to draw the title of this Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Font), CStr(Nothing))> _
<Description("Gets/Sets the used to draw the title of this Group.")> _
Public Property Font( _
   ByRef GetType As Object, _
   ByRef CStr As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Font), CStr(Nothing))]
[Description("Gets/Sets the used to draw the title of this Group.")]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object GetType,
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.GradientColor Property

Gets/sets the colour to use at the begin of the title group.'''

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "Highlight")> _
<Description("Gets/sets the colour to use at the begin of the title group.'''")> _
Public Property GradientColor( _
   ByRef GetType As Object, _
   ByRef "Highlight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "Highlight")]
[Description("Gets/sets the colour to use at the begin of the title group.'''")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object GetType,
   ref object "Highlight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Highlight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.GradientEnabled Property

Gets/Sets if gradient effect ot titlebar groudp is enabled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(False)> _
<Description("Gets/Sets if gradient effect ot titlebar groudp is enabled.")> _
Public Property GradientEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(False)]
[Description("Gets/Sets if gradient effect ot titlebar groudp is enabled.")]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.GradientMode Property

Gets/sets the gradient mode used to draw group background.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")> _
<Description("Gets/sets the gradient mode used to draw group background.")> _
Public Property GradientMode( _
   ByRef GetType As Object, _
   ByRef "Horizontal" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")]
[Description("Gets/sets the gradient mode used to draw group background.")]
[System.Runtime.CompilerServices.IndexerName("GradientMode")]
public LinearGradientMode this[
   ref object GetType,
   ref object "Horizontal"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Horizontal"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Items Property

Gets the collection of items associated with this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
<Description("Gets the collection of items associated with this group.")> _
Public ReadOnly Property Items( _
   ByRef DesignerSerializationVisibility.Content As Object _
) As ExplorerBarItems
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
[Description("Gets the collection of items associated with this group.")]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ExplorerBarItems this[
   ref object DesignerSerializationVisibility.Content
] {get;}
This language is not supported or no code example is available.

Parameters

DesignerSerializationVisibility.Content

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Key Property

Gets/sets the string key associated with this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/sets the string key associated with this group.")> _
<DefaultValue("")> _
Public Property Key( _
   ByRef "Gets/sets the string key associated with this group." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/sets the string key associated with this group.")]
[DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Key")]
public string this[
   ref object "Gets/sets the string key associated with this group."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the string key associated with this group."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Tag Property

Gets/sets a custom object to be associated with this Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Browsable(False)> _
<Description("Gets/sets a custom object to be associated with this Group.")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<DefaultValue(CStr(Nothing))> _
Public Property Tag( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Browsable(False)]
[Description("Gets/sets a custom object to be associated with this Group.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Tag")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Text Property

Gets/Sets the text title for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue("")> _
<Description("Gets/Sets the text title for this group.")> _
Public Property Text( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue("")]
[Description("Gets/Sets the text title for this group.")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleBackColor Property

Gets/Sets custom titlebar group background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "ActiveCaption")> _
<Description("Gets/Sets custom titlebar group background color.")> _
Public Property TitleBackColor( _
   ByRef GetType As Object, _
   ByRef "ActiveCaption" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "ActiveCaption")]
[Description("Gets/Sets custom titlebar group background color.")]
[System.Runtime.CompilerServices.IndexerName("TitleBackColor")]
public Color this[
   ref object GetType,
   ref object "ActiveCaption"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ActiveCaption"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleForeColor Property

Gets/Sets custom titlebar group foreground color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "ActiveCaptionText")> _
<Description("Gets/Sets custom titlebar group foreground color.")> _
Public Property TitleForeColor( _
   ByRef GetType As Object, _
   ByRef "ActiveCaptionText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "ActiveCaptionText")]
[Description("Gets/Sets custom titlebar group foreground color.")]
[System.Runtime.CompilerServices.IndexerName("TitleForeColor")]
public Color this[
   ref object GetType,
   ref object "ActiveCaptionText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ActiveCaptionText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleForeColorLight Property

Gets/Sets custom titlebar group light foreground color (this color will be used when mouse is over the titlebar group).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlLight")> _
<Description("Gets/Sets custom titlebar group light foreground color (this color will be used when mouse is over the titlebar group).")> _
Public Property TitleForeColorLight( _
   ByRef GetType As Object, _
   ByRef "ControlLight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "ControlLight")]
[Description("Gets/Sets custom titlebar group light foreground color (this color will be used when mouse is over the titlebar group).")]
[System.Runtime.CompilerServices.IndexerName("TitleForeColorLight")]
public Color this[
   ref object GetType,
   ref object "ControlLight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlLight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleGradientColor Property

Gets/Sets custom titlebar group start backrground gradient color (this color will be used only if TitleGradientEnabled is sets to True).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "InactiveCaptionText")> _
<Description("Gets/Sets custom titlebar group start backrground gradient color (this color will be used only if TitleGradientEnabled is sets to True).")> _
Public Property TitleGradientColor( _
   ByRef GetType As Object, _
   ByRef "InactiveCaptionText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "InactiveCaptionText")]
[Description("Gets/Sets custom titlebar group start backrground gradient color (this color will be used only if TitleGradientEnabled is sets to True).")]
[System.Runtime.CompilerServices.IndexerName("TitleGradientColor")]
public Color this[
   ref object GetType,
   ref object "InactiveCaptionText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"InactiveCaptionText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleGradientEnabled Property

Enable/Disable custom titlebar group grdient effects.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(True)> _
<Description("Enable/Disable custom titlebar group grdient effects.")> _
Public Property TitleGradientEnabled( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(True)]
[Description("Enable/Disable custom titlebar group grdient effects.")]
[System.Runtime.CompilerServices.IndexerName("TitleGradientEnabled")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleGradientMode Property

Gets/sets the gradient mode used to draw group titlebar background.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")> _
<Description("Gets/sets the gradient mode used to draw group titlebar background.")> _
Public Property TitleGradientMode( _
   ByRef GetType As Object, _
   ByRef "Horizontal" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")]
[Description("Gets/sets the gradient mode used to draw group titlebar background.")]
[System.Runtime.CompilerServices.IndexerName("TitleGradientMode")]
public LinearGradientMode this[
   ref object GetType,
   ref object "Horizontal"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Horizontal"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleHeight Property

Gets/Sets the group title height.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(DefaultExplorerBarTitleGroupHeight)> _
<Description("Gets/Sets the group title height.")> _
Public Property TitleHeight( _
   ByRef DefaultExplorerBarTitleGroupHeight As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(DefaultExplorerBarTitleGroupHeight)]
[Description("Gets/Sets the group title height.")]
[System.Runtime.CompilerServices.IndexerName("TitleHeight")]
public int this[
   ref object DefaultExplorerBarTitleGroupHeight
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultExplorerBarTitleGroupHeight

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.TitleImage Property

Gets/sets the image displayed in the title for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))> _
<Description("Gets/sets the image displayed in the title for this group.")> _
Public Property TitleImage( _
   ByRef GetType As Object, _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))]
[Description("Gets/sets the image displayed in the title for this group.")]
[System.Runtime.CompilerServices.IndexerName("TitleImage")]
public Image this[
   ref object GetType,
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.ToolTipText Property

Gets/Sets the tooltip text that should be shown for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue("")> _
<Description("Gets/Sets the tooltip text that should be shown for this group.")> _
Public Property ToolTipText( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue("")]
[Description("Gets/Sets the tooltip text that should be shown for this group.")]
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup Methods

ExplorerBarGroup Class See Also

The following tables list the members exposed by the ExplorerBarGroup type.

Methods
 | Name | Description
Public method | CanAnimateGroup | Gets whether it is possible to animate group state changes or not. Groups which contain items that hold controls cannot be animated.
Public method | Clone | Returns a deep clone of this object
Public method | ContainsMnemonic | Gets if this groups's title contains the specified mnemonic.
Public method | EnsureVisible | Ensures that this group is visible in the control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this group.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarGroup Class


ExplorerBarGroup.CanAnimateGroup Method

Gets whether it is possible to animate group state changes or not. Groups which contain items that hold controls cannot be animated.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function CanAnimateGroup() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool CanAnimateGroup()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.Clone Method

Returns a deep clone of this object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
public object Clone()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.ContainsMnemonic Method

Gets if this groups's title contains the specified mnemonic.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ContainsMnemonic( _
   ByVal CharCode As Char _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool ContainsMnemonic(
   char CharCode
)
This language is not supported or no code example is available.

Parameters

CharCode

Type: char

Mnemonic key character code.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.EnsureVisible Method

Ensures that this group is visible in the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub EnsureVisible()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void EnsureVisible()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup.ExplorerBar Method

Gets the control which currently owns this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ExplorerBar() As ExplorerBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBar ExplorerBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup Events

ExplorerBarGroup Class See Also

The following tables list the members exposed by the ExplorerBarGroup type.

Events
 | Name | Description
Public event | Click | This Event will be generated every time user click on a Group.
Top
See Also

Reference

ExplorerBarGroup Class


Click Event

This Event will be generated every time user click on a Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Click( _
   ByVal sender As Object, _
   ByVal e As ExplorerBarGroupClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClickEventHandler Click
delegate void ClickEventHandler(
   object sender,
   ExplorerBarGroupClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ExplorerBarGroupClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroupClickEventArgs Class

Members

Event arguments for a click on a group within the Explorer Bar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ExplorerBarGroupClickEventArgs
    Inherits ExplorerBarClickBaseEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ExplorerBarGroupClickEventArgs : ExplorerBarClickBaseEventArgs
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroupClickEventArgs Members


ExplorerBarGroupClickEventArgs Members

ExplorerBarGroupClickEventArgs Class Constructors Methods Properties See Also

Event arguments for a click on a group within the Explorer Bar control.

The following tables list the members exposed by the ExplorerBarGroupClickEventArgs type.

Constructors
 | Name | Description
Public constructor | ExplorerBarGroupClickEventArgs Constructor | Create a new instance of this class
Top
Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked (inherited from ExplorerBarClickBaseEventArgs).
Public property | Group | Gets the group that was clicked
Public property | Location | Gets the mouse location at which the click occurred. (inherited from ExplorerBarClickBaseEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarGroupClickEventArgs Class


ExplorerBarGroupClickEventArgs Constructor

Create a new instance of this class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oGroup As ExplorerBarGroup, _
   ByVal oButtons As MouseButtons, _
   ByVal location As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroupClickEventArgs(
   ExplorerBarGroup oGroup,
   MouseButtons oButtons,
   Point location
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

Bar which was clicked

oButtons

Type: MouseButtons

Mouse Button used to click the item

location

Type: Point

Location in the control that the click occurred

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroupClickEventArgs Class
ExplorerBarGroupClickEventArgs Members


ExplorerBarGroupClickEventArgs Properties

ExplorerBarGroupClickEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarGroupClickEventArgs type.

Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked (inherited from ExplorerBarClickBaseEventArgs).
Public property | Group | Gets the group that was clicked
Public property | Location | Gets the mouse location at which the click occurred. (inherited from ExplorerBarClickBaseEventArgs).
Top
See Also

Reference

ExplorerBarGroupClickEventArgs Class


ExplorerBarGroupClickEventArgs.Group Property

Gets the group that was clicked

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Group() As ExplorerBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup Group {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroupClickEventArgs Class
ExplorerBarGroupClickEventArgs Members


ExplorerBarGroupClickEventArgs Methods

ExplorerBarGroupClickEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarGroupClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarGroupClickEventArgs Class


ExplorerBarGroups Class

Members

The collection of Groups associated with an ExplorerBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
Public Class ExplorerBarGroups
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
public class ExplorerBarGroups : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.ExplorerBarGroups
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Members


ExplorerBarGroups Members

ExplorerBarGroups Class Constructors Methods Properties See Also

The collection of Groups associated with an ExplorerBar control.

The following tables list the members exposed by the ExplorerBarGroups type.

Constructors
 | Name | Description
Public constructor | ExplorerBarGroups Constructor | Create a new instance of this class. The Groups collection is created automatically by the owning ExplorerBar control.
Top
Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ExplorerBarItem object in the group at the specified index.
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new ExplorerBarGroup.
Public method | AddRange | Adds an array of ExplorerBarGroup.
Public method | Clear | Remove all groups in this collection
Public method | Contains | Returns True if the collection contains the specified Group, or False otherwise.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified ExplorerBarGroup within this collection or -1 if not found.
Public method | InsertAfter | Inserts a new Group after the specified existing bar.
Public method | InsertBefore | Inserts a new Group before the specified existing Group.
Public method | Remove | (Overloaded) Removes object with specified key.
Public method | RemoveAt | Removes the group at the specified zero-based index.
Public method | Sort | Sorts groups in this collection
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarGroups Class


ExplorerBarGroups Constructor

Create a new instance of this class. The Groups collection is created automatically by the owning ExplorerBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oNetExporerBar As ExplorerBar _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroups(
   ExplorerBar oNetExporerBar
)
This language is not supported or no code example is available.

Parameters

oNetExporerBar

Type: ExplorerBar

The ExplorerBar which owns the collection of groups.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups Properties

ExplorerBarGroups Class See Also

The following tables list the members exposed by the ExplorerBarGroups type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ExplorerBarItem object in the group at the specified index.
Top
See Also

Reference

ExplorerBarGroups Class


ExplorerBarGroups.Item Property

ExplorerBarGroups Class See Also

Gets the ExplorerBarItem object in the group at the specified index.

Overload List
Name | Description
this[string] | Gets the ExlorerBarItem object in the group with the specified key.
this[int] | Gets the ExplorerBarItem object in the group at the specified index.
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups Methods

ExplorerBarGroups Class See Also

The following tables list the members exposed by the ExplorerBarGroups type.

Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new ExplorerBarGroup.
Public method | AddRange | Adds an array of ExplorerBarGroup.
Public method | Clear | Remove all groups in this collection
Public method | Contains | Returns True if the collection contains the specified Group, or False otherwise.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified ExplorerBarGroup within this collection or -1 if not found.
Public method | InsertAfter | Inserts a new Group after the specified existing bar.
Public method | InsertBefore | Inserts a new Group before the specified existing Group.
Public method | Remove | (Overloaded) Removes object with specified key.
Public method | RemoveAt | Removes the group at the specified zero-based index.
Public method | Sort | Sorts groups in this collection
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarGroups Class


ExplorerBarGroups.Add Method

ExplorerBarGroups Class See Also

Adds a new ExplorerBarGroup.

Overload List
Name | Description
Add() | Adds a new ExplorerBarGroup.
Add(ExplorerBarGroup) | Adds a new ExplorerBarGroup.
Add(string) | Adds a new ExplorerBarGroup with specified parameters.
Add(string, string) | Adds a new ExplorerBarGroup with specified parameters.
Add(string, string, Image) | Adds a new ExplorerBarGroup with specified parameters.
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.AddRange Method

Adds an array of ExplorerBarGroup.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddRange( _
   ByVal oGroups As ExplorerBarGroup() _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddRange(
   ExplorerBarGroup[] oGroups
)
This language is not supported or no code example is available.

Parameters

oGroups

Type: ExplorerBarGroup[]

A valid array of ExplorerBarGroup objects

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Clear Method

Remove all groups in this collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Contains Method

Returns True if the collection contains the specified Group, or False otherwise.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Contains( _
   ByVal oGroup As ExplorerBarGroup _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Contains(
   ExplorerBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

Group to check if present in the collection.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.ExplorerBar Method

Gets the control which currently owns this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ExplorerBar() As ExplorerBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBar ExplorerBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.IndexOf Method

ExplorerBarGroups Class See Also

Gets the index of the specified ExplorerBarGroup within this collection or -1 if not found.

Overload List
Name | Description
IndexOf(ExplorerBarGroup) | Gets the index of the specified ExplorerBarGroup within this collection or -1 if not found.
IndexOf(string) | Gets the index of the specified ExplorerBarGroup key within this collection or -1 if not found.
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.InsertAfter Method

Inserts a new Group after the specified existing bar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertAfter( _
   ByVal oGroup As ExplorerBarGroup, _
   ByVal oNewGroup As ExplorerBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertAfter(
   ExplorerBarGroup oGroup,
   ExplorerBarGroup oNewGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

Existing Group after which the new bar should be inserted.

oNewGroup

Type: ExplorerBarGroup

New Ggroup to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.InsertBefore Method

Inserts a new Group before the specified existing Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertBefore( _
   ByVal oGroup As ExplorerBarGroup, _
   ByVal oNewGroup As ExplorerBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertBefore(
   ExplorerBarGroup oGroup,
   ExplorerBarGroup oNewGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

Existing Group before which the new Group should be inserted.

oNewGroup

Type: ExplorerBarGroup

New Group to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Remove Method

ExplorerBarGroups Class See Also

Removes object with specified key.

Overload List
Name | Description
Remove(ref ExplorerBarGroup) | Removes the specified Group.
Remove(string) | Removes object with specified key.
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.RemoveAt Method

Removes the group at the specified zero-based index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub RemoveAt( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveAt(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

Zero-based index of Group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Sort Method

Sorts groups in this collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Sort( _
   ByVal comparer As IComparer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Sort(
   IComparer comparer
)
This language is not supported or no code example is available.

Parameters

comparer

Type: IComparer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarItem Class

Members

An item within the Explorer Bar Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
<DesignTimeVisible(False)> _
<ToolboxItem(False)> _
Public Class ExplorerBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
[DesignTimeVisible(False)]
[ToolboxItem(False)]
public class ExplorerBarItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.ExplorerBarItem
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Members


ExplorerBarItem Members

ExplorerBarItem Class Constructors Events Methods Properties See Also

An item within the Explorer Bar Group.

The following tables list the members exposed by the ExplorerBarItem type.

Constructors
 | Name | Description
Public constructor | ExplorerBarItem Constructor | (Overloaded) Create a new instance of this class. Default Item type is LinkLabel.
Top
Properties
 | Name | Description
Public property | Bold | Gets/sets whether the font for this item should be boldened.
Public property | Checked | Gets/sets whether this item is checked.
Public property | Control | Gets/sets the control associated with this item.
 | DefaultForeColor | Gets the default item foreground color.
 | DefaultHighlightColor | Gets the default item highlight color.
Public property | Enabled | Gets/sets whether this item is enabled.
Public property | Focused | Gets/sets whether this item has the focus
Public property | Font | Gets/sets the Font for this item. This can be set to Nothing to use the default font.
Public property | ForeColor | Gets/sets the foreground colour for this item.
Public property | HighlightColor | Gets/sets the hot background colour for this item.
Public property | Image | Gets/sets the image for this item.
Public property | ImageSize | Gets/Seta the size of item image. Image of item will be scaled to this size.
Public property | ItemType | Gets/sets the item type.
Public property | Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Public property | Tag | Gets/sets a custom object to be associated with this Item.
Public property | Text | Gets/sets the text to display for this item, if any.
Public property | ToolTipText | Gets/sets the tooltip text to be shown when the mouse hovers over this item.
Top
Methods
 | Name | Description
Public method | CanFocus | Gets whether the control can get input focus.
Public method | Clone | Creates a clone of this object.
Public method | ContainsMnemonic | Determines whether this object should respond to the specified mnemonic key
Public method | EnsureVisible | Ensures that this item is visible in the control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | Group | Gets the Group which owns this item, if any.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | Click | This Event will be generated every time user click on an Item.
Top
See Also

Reference

ExplorerBarItem Class


ExplorerBarItem Constructor

ExplorerBarItem Class See Also

Create a new instance of this class. Default Item type is LinkLabel.

Overload List
Name | Description
ExplorerBarItem() | Create a new instance of this class. Default Item type is LinkLabel.
ExplorerBarItem(ExplorerBarItemTypeEnum) | Create a new instance of this class with specified parameters.
ExplorerBarItem(ExplorerBarItemTypeEnum, string) | Create a new instance of this class with specified parameters.
ExplorerBarItem(ExplorerBarItemTypeEnum, string, string) | Create a new instance of this class with specified parameters.
ExplorerBarItem(ExplorerBarItemTypeEnum, string, string, Image) | Create a new instance of this class with specified parameters.
ExplorerBarItem(string) | Create a new instance of this class with specified parameters. Default Item type is LinkLabel.
ExplorerBarItem(string, string) | Create a new instance of this class with specified parameters. Default Item type is LinkLabel.
ExplorerBarItem(string, string, Image) | Create a new instance of this class with specified parameters. Default Item type is LinkLabel.
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Properties

ExplorerBarItem Class See Also

The following tables list the members exposed by the ExplorerBarItem type.

Properties
 | Name | Description
Public property | Bold | Gets/sets whether the font for this item should be boldened.
Public property | Checked | Gets/sets whether this item is checked.
Public property | Control | Gets/sets the control associated with this item.
 | DefaultForeColor | Gets the default item foreground color.
 | DefaultHighlightColor | Gets the default item highlight color.
Public property | Enabled | Gets/sets whether this item is enabled.
Public property | Focused | Gets/sets whether this item has the focus
Public property | Font | Gets/sets the Font for this item. This can be set to Nothing to use the default font.
Public property | ForeColor | Gets/sets the foreground colour for this item.
Public property | HighlightColor | Gets/sets the hot background colour for this item.
Public property | Image | Gets/sets the image for this item.
Public property | ImageSize | Gets/Seta the size of item image. Image of item will be scaled to this size.
Public property | ItemType | Gets/sets the item type.
Public property | Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Public property | Tag | Gets/sets a custom object to be associated with this Item.
Public property | Text | Gets/sets the text to display for this item, if any.
Public property | ToolTipText | Gets/sets the tooltip text to be shown when the mouse hovers over this item.
Top
See Also

Reference

ExplorerBarItem Class


ExplorerBarItem.Bold Property

Gets/sets whether the font for this item should be boldened.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(False)> _
<Description("Gets/sets whether the font for this item should be boldened.")> _
Public Property Bold( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(False)]
[Description("Gets/sets whether the font for this item should be boldened.")]
[System.Runtime.CompilerServices.IndexerName("Bold")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Checked Property

Gets/sets whether this item is checked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(False)> _
<Description("Gets/sets whether this item is checked.")> _
Public Property Checked( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(False)]
[Description("Gets/sets whether this item is checked.")]
[System.Runtime.CompilerServices.IndexerName("Checked")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Control Property

Gets/sets the control associated with this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets/sets the control associated with this item.")> _
<Browsable(False)> _
<DefaultValue(GetType(Control), CStr(Nothing))> _
Public Property Control( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets the control associated with this item.")]
[Browsable(False)]
[DefaultValue(GetType(Control), CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Control")]
public Control this[
   ref object DesignerSerializationVisibility.Hidden
] {get; set;}
This language is not supported or no code example is available.

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.DefaultForeColor Property

Gets the default item foreground color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default item foreground color.")> _
Public ReadOnly Shared Property DefaultForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default item foreground color.")]
public static Color DefaultForeColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.DefaultHighlightColor Property

Gets the default item highlight color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default item highlight color.")> _
Public ReadOnly Shared Property DefaultHighlightColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default item highlight color.")]
public static Color DefaultHighlightColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Enabled Property

Gets/sets whether this item is enabled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(True)> _
<Description("Gets/sets whether this item is enabled.")> _
Public Property Enabled( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(True)]
[Description("Gets/sets whether this item is enabled.")]
[System.Runtime.CompilerServices.IndexerName("Enabled")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Focused Property

Gets/sets whether this item has the focus

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Browsable(False)> _
<Description("Gets/sets whether this item has the focus")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<DefaultValue(False)> _
Public Property Focused( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Browsable(False)]
[Description("Gets/sets whether this item has the focus")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("Focused")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Font Property

Gets/sets the Font for this item. This can be set to Nothing to use the default font.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Font), CStr(Nothing))> _
<Description("Gets/sets the Font for this item.  This can be set to Nothing to use the default font.")> _
Public Property Font( _
   ByRef GetType As Object, _
   ByRef CStr As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Font), CStr(Nothing))]
[Description("Gets/sets the Font for this item.  This can be set to Nothing to use the default font.")]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object GetType,
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ForeColor Property

Gets/sets the foreground colour for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlText")> _
<Description("Gets/sets the foreground colour for this item.")> _
Public Property ForeColor( _
   ByRef GetType As Object, _
   ByRef "ControlText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "ControlText")]
[Description("Gets/sets the foreground colour for this item.")]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object GetType,
   ref object "ControlText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.HighlightColor Property

Gets/sets the hot background colour for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Color), "Window")> _
<Description("Gets/sets the hot background colour for this item.")> _
Public Property HighlightColor( _
   ByRef GetType As Object, _
   ByRef "Window" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Color), "Window")]
[Description("Gets/sets the hot background colour for this item.")]
[System.Runtime.CompilerServices.IndexerName("HighlightColor")]
public Color this[
   ref object GetType,
   ref object "Window"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Window"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Image Property

Gets/sets the image for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))> _
<Description("Gets/sets the image for this item.")> _
Public Property Image( _
   ByRef GetType As Object, _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Image), CStr(Nothing))]
[Description("Gets/sets the image for this item.")]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object GetType,
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ImageSize Property

Gets/Seta the size of item image. Image of item will be scaled to this size.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(System.Drawing.Size), "16,16")> _
<Description("Gets/Seta the size of item image. Image of item  will be scaled to this size.")> _
Public Property ImageSize( _
   ByRef GetType As Object, _
   ByRef "16,16" As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(System.Drawing.Size), "16,16")]
[Description("Gets/Seta the size of item image. Image of item  will be scaled to this size.")]
[System.Runtime.CompilerServices.IndexerName("ImageSize")]
public Size this[
   ref object GetType,
   ref object "16,16"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"16,16"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ItemType Property

Gets/sets the item type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue(GetType(ExplorerBarItemTypeEnum), "Label")> _
<Description("Gets/sets the item type.")> _
Public Property ItemType( _
   ByRef GetType As Object, _
   ByRef "Label" As Object _
) As ExplorerBarItemTypeEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue(GetType(ExplorerBarItemTypeEnum), "Label")]
[Description("Gets/sets the item type.")]
[System.Runtime.CompilerServices.IndexerName("ItemType")]
public ExplorerBarItemTypeEnum this[
   ref object GetType,
   ref object "Label"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Label"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Key Property

Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Description("Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.")> _
<DefaultValue("")> _
Public Property Key( _
   ByRef "Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Description("Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.")]
[DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Key")]
public string this[
   ref object "Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Tag Property

Gets/sets a custom object to be associated with this Item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<Browsable(False)> _
<Description("Gets/sets a custom object to be associated with this Item.")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<DefaultValue(CStr(Nothing))> _
Public Property Tag( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[Browsable(False)]
[Description("Gets/sets a custom object to be associated with this Item.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Tag")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Text Property

Gets/sets the text to display for this item, if any.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue("")> _
<Description("Gets/sets the text to display for this item, if any.")> _
Public Property Text( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue("")]
[Description("Gets/sets the text to display for this item, if any.")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ToolTipText Property

Gets/sets the tooltip text to be shown when the mouse hovers over this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ExplorerBar")> _
<DefaultValue("")> _
<Description("Gets/sets the tooltip text to be shown when the mouse hovers over this item.")> _
Public Property ToolTipText( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ExplorerBar")]
[DefaultValue("")]
[Description("Gets/sets the tooltip text to be shown when the mouse hovers over this item.")]
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Methods

ExplorerBarItem Class See Also

The following tables list the members exposed by the ExplorerBarItem type.

Methods
 | Name | Description
Public method | CanFocus | Gets whether the control can get input focus.
Public method | Clone | Creates a clone of this object.
Public method | ContainsMnemonic | Determines whether this object should respond to the specified mnemonic key
Public method | EnsureVisible | Ensures that this item is visible in the control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | Group | Gets the Group which owns this item, if any.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarItem Class


ExplorerBarItem.CanFocus Method

Gets whether the control can get input focus.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function CanFocus() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool CanFocus()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Clone Method

Creates a clone of this object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public object Clone()
This language is not supported or no code example is available.

Return Value

Cloned object

Implements

ICloneable.Clone
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ContainsMnemonic Method

Determines whether this object should respond to the specified mnemonic key

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ContainsMnemonic( _
   ByVal CharCode As Char _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool ContainsMnemonic(
   char CharCode
)
This language is not supported or no code example is available.

Parameters

CharCode

Type: char

Mnemonic key character code

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.EnsureVisible Method

Ensures that this item is visible in the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub EnsureVisible()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void EnsureVisible()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.ExplorerBar Method

Gets the control which currently owns this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ExplorerBar() As ExplorerBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBar ExplorerBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem.Group Method

Gets the Group which owns this item, if any.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Group() As ExplorerBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup Group()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Events

ExplorerBarItem Class See Also

The following tables list the members exposed by the ExplorerBarItem type.

Events
 | Name | Description
Public event | Click | This Event will be generated every time user click on an Item.
Top
See Also

Reference

ExplorerBarItem Class


Click Event

This Event will be generated every time user click on an Item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Click( _
   ByVal sender As Object, _
   ByVal e As ExplorerBarItemClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClickEventHandler Click
delegate void ClickEventHandler(
   object sender,
   ExplorerBarItemClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ExplorerBarItemClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItemClickEventArgs Class

Members

Event arguments for a click on an Item within the Explorer Bar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ExplorerBarItemClickEventArgs
    Inherits ExplorerBarClickBaseEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ExplorerBarItemClickEventArgs : ExplorerBarClickBaseEventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ExplorerBarClickBaseEventArgs
Softgroup.NetControls.ExplorerBarItemClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItemClickEventArgs Members


ExplorerBarItemClickEventArgs Members

ExplorerBarItemClickEventArgs Class Methods Properties See Also

Event arguments for a click on an Item within the Explorer Bar control.

The following tables list the members exposed by the ExplorerBarItemClickEventArgs type.

Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked (inherited from ExplorerBarClickBaseEventArgs).
Public property | Item | Item in the explorer bar which was clicked.
Public property | Location | Gets the mouse location at which the click occurred. (inherited from ExplorerBarClickBaseEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarItemClickEventArgs Class


ExplorerBarItemClickEventArgs Properties

ExplorerBarItemClickEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarItemClickEventArgs type.

Properties
 | Name | Description
Public property | Buttons | Gets the Button that was clicked (inherited from ExplorerBarClickBaseEventArgs).
Public property | Item | Item in the explorer bar which was clicked.
Public property | Location | Gets the mouse location at which the click occurred. (inherited from ExplorerBarClickBaseEventArgs).
Top
See Also

Reference

ExplorerBarItemClickEventArgs Class


ExplorerBarItemClickEventArgs.Item Property

Item in the explorer bar which was clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Item() As ExplorerBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem Item {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItemClickEventArgs Class
ExplorerBarItemClickEventArgs Members


ExplorerBarItemClickEventArgs Methods

ExplorerBarItemClickEventArgs Class See Also

The following tables list the members exposed by the ExplorerBarItemClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarItemClickEventArgs Class


ExplorerBarItems Class

Members

Contains the collection of items associated with a group in the Explorer Bar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
Public Class ExplorerBarItems
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
public class ExplorerBarItems : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.ExplorerBarItems
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Members


ExplorerBarItems Members

ExplorerBarItems Class Methods Properties See Also

Contains the collection of items associated with a group in the Explorer Bar control.

The following tables list the members exposed by the ExplorerBarItems type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ExplorerBarItem with specified key.
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new empty ExplorerBarItem of type LinkLabel.
Public method | AddRange | Adds an array of ExplorerBarItem.
Public method | Clear | Remove all items from control
Public method | Contains | Returns True if the collection contains the specified item, or False otherwise.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified ExplorerBarItem within this collection or -1 if not found.
Public method | InsertAfter | Inserts a new item after the specified existing item.
Public method | InsertBefore | Inserts a new item before the specified existing item.
Public method | Remove | (Overloaded) Removes the specified Item.
Public method | RemoveAt | Removes the item at the specified 0-based index.
Public method | Sort | Sorts the items in the group using the specified comparator.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarItems Class


ExplorerBarItems Properties

ExplorerBarItems Class See Also

The following tables list the members exposed by the ExplorerBarItems type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ExplorerBarItem with specified key.
Top
See Also

Reference

ExplorerBarItems Class


ExplorerBarItems.Item Property

ExplorerBarItems Class See Also

Gets the ExplorerBarItem with specified key.

Overload List
Name | Description
this[int] | Gets the ExplorerBarItem at the specified index.
this[string] | Gets the ExplorerBarItem with specified key.
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems Methods

ExplorerBarItems Class See Also

The following tables list the members exposed by the ExplorerBarItems type.

Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new empty ExplorerBarItem of type LinkLabel.
Public method | AddRange | Adds an array of ExplorerBarItem.
Public method | Clear | Remove all items from control
Public method | Contains | Returns True if the collection contains the specified item, or False otherwise.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ExplorerBar | Gets the control which currently owns this item.
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified ExplorerBarItem within this collection or -1 if not found.
Public method | InsertAfter | Inserts a new item after the specified existing item.
Public method | InsertBefore | Inserts a new item before the specified existing item.
Public method | Remove | (Overloaded) Removes the specified Item.
Public method | RemoveAt | Removes the item at the specified 0-based index.
Public method | Sort | Sorts the items in the group using the specified comparator.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ExplorerBarItems Class


ExplorerBarItems.Add Method

ExplorerBarItems Class See Also

Adds a new empty ExplorerBarItem of type LinkLabel.

Overload List
Name | Description
Add() | Adds a new empty ExplorerBarItem of type LinkLabel.
Add(ExplorerBarItemTypeEnum) | Adds a new ExplorerBarItem object with specified parameters.
Add(ExplorerBarItemTypeEnum, string) | Adds a new ExplorerBarItem object with specified parameters.
Add(ExplorerBarItemTypeEnum, string, string) | Adds a new ExplorerBarItem object with specified parameters.
Add(ExplorerBarItemTypeEnum, string, string, Image) | Adds a new ExplorerBarItem object with specified parameters.
Add(ExplorerBarItem) | Adds a new ExplorerBarItem object.
Add(string) | Adds a new ExplorerBarItem of type LinkLabel with specified parameters.
Add(string, string) | Adds a new ExplorerBarItem of type LinkLabel with specified parameters.
Add(string, string, Image) | Adds a new ExplorerBarItem of type LinkLabel with specified parameters.
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.AddRange Method

Adds an array of ExplorerBarItem.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddRange( _
   ByVal oItems As ExplorerBarItem() _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddRange(
   ExplorerBarItem[] oItems
)
This language is not supported or no code example is available.

Parameters

oItems

Type: ExplorerBarItem[]

A valid array of ExplorerBarItem objects

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Clear Method

Remove all items from control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Contains Method

Returns True if the collection contains the specified item, or False otherwise.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Contains( _
   ByVal oGroupItem As ExplorerBarItem _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Contains(
   ExplorerBarItem oGroupItem
)
This language is not supported or no code example is available.

Parameters

oGroupItem

Type: ExplorerBarItem

Item to check if present in the collection.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.ExplorerBar Method

Gets the control which currently owns this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ExplorerBar() As ExplorerBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBar ExplorerBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.IndexOf Method

ExplorerBarItems Class See Also

Gets the index of the specified ExplorerBarItem within this collection or -1 if not found.

Overload List
Name | Description
IndexOf(ExplorerBarItem) | Gets the index of the specified ExplorerBarItem within this collection or -1 if not found.
IndexOf(string) | Gets the index of the specified ExplorerBarItem key within this collection or -1 if not found.
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.InsertAfter Method

Inserts a new item after the specified existing item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertAfter( _
   ByVal itemAfter As ExplorerBarItem, _
   ByVal itemNew As ExplorerBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertAfter(
   ExplorerBarItem itemAfter,
   ExplorerBarItem itemNew
)
This language is not supported or no code example is available.

Parameters

itemAfter

Type: ExplorerBarItem

Existing item after which the new item should be inserted.

itemNew

Type: ExplorerBarItem

New item to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.InsertBefore Method

Inserts a new item before the specified existing item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertBefore( _
   ByVal itemBefore As ExplorerBarItem, _
   ByVal itemNew As ExplorerBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertBefore(
   ExplorerBarItem itemBefore,
   ExplorerBarItem itemNew
)
This language is not supported or no code example is available.

Parameters

itemBefore

Type: ExplorerBarItem

Existing item before which the new item should be inserted.

itemNew

Type: ExplorerBarItem

New item to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Remove Method

ExplorerBarItems Class See Also

Removes the specified Item.

Overload List
Name | Description
Remove(ref ExplorerBarItem) | Removes the specified Item.
Remove(string) | Removes the specified key from the collection.
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.RemoveAt Method

Removes the item at the specified 0-based index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub RemoveAt( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveAt(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

0-based index of the Item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Sort Method

Sorts the items in the group using the specified comparator.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Sort( _
   ByVal comparer As IComparer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Sort(
   IComparer comparer
)
This language is not supported or no code example is available.

Parameters

comparer

Type: IComparer

Object which can compare two items.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ItemImage Class

Members

Softgroup.Image is a class that contain a single Image object of a ComboImages item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Softgroup.Image is a class that contain a single Image object of a ComboImages item")> _
Public Class ItemImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Softgroup.Image is a class that contain a single Image object of a ComboImages item")]
public class ItemImage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.ItemImage
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Members


ItemImage Members

ItemImage Class Methods Properties See Also

Softgroup.Image is a class that contain a single Image object of a ComboImages item

The following tables list the members exposed by the ItemImage type.

Properties
 | Name | Description
Public property | FileName | Gets the file name associated to the image
Public property | Image | Gets a System.Drawing.Icon from this FileIcon object
Public property | Key | Gets the string key associated to the image
Public property | Text | Gets the text of combo item
Top
Methods
 | Name | Description
Public method | Dispose | Esegue attività definite dall'applicazione, come rilasciare o reimpostare risorse non gestite.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ItemImage Class


ItemImage Properties

ItemImage Class See Also

The following tables list the members exposed by the ItemImage type.

Properties
 | Name | Description
Public property | FileName | Gets the file name associated to the image
Public property | Image | Gets a System.Drawing.Icon from this FileIcon object
Public property | Key | Gets the string key associated to the image
Public property | Text | Gets the text of combo item
Top
See Also

Reference

ItemImage Class


ItemImage.FileName Property

Gets the file name associated to the image

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the file name associated to the image")> _
Public ReadOnly Property FileName() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the file name associated to the image")]
public string FileName {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Image Property

Gets a System.Drawing.Icon from this FileIcon object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets a System.Drawing.Icon from this FileIcon object")> _
Public ReadOnly Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets a System.Drawing.Icon from this FileIcon object")]
public Image Image {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Key Property

Gets the string key associated to the image

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the string key associated to the image")> _
Public ReadOnly Property Key() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the string key associated to the image")]
public string Key {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Text Property

Gets the text of combo item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the text of combo item")> _
Public ReadOnly Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the text of combo item")]
public string Text {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Class
ItemImage Members


ItemImage Methods

ItemImage Class See Also

The following tables list the members exposed by the ItemImage type.

Methods
 | Name | Description
Public method | Dispose | Esegue attività definite dall'applicazione, come rilasciare o reimpostare risorse non gestite.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ItemImage Class


ItemImage.Dispose Method

Esegue attività definite dall'applicazione, come rilasciare o reimpostare risorse non gestite.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Dispose()
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImage Class
ItemImage Members


ItemImages Class

Members

Softgroup.Images is a collection class to manage Images of a ComboImages control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Softgroup.Images is a collection class to manage Images of a ComboImages control")> _
Public Class ItemImages
    Implements IEnumerable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Softgroup.Images is a collection class to manage Images of a ComboImages control")]
public class ItemImages : IEnumerable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.ItemImages
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Members


ItemImages Members

ItemImages Class Methods Properties See Also

Softgroup.Images is a collection class to manage Images of a ComboImages control

The following tables list the members exposed by the ItemImages type.

Properties
 | Name | Description
Public property | Count | Gets the number of elements in the collection. First item start from 1.
Public property | Item | (Overloaded) Gets a specified item collection throw key
Top
Methods
 | Name | Description
Public method | AddFromFileExecutable | Add a new image from icon extracted from specified executable file
Public method | AddFromFileExtension | Add a new image extracted from specified file extension association
Public method | AddFromFileImage | Add a new image from file
Public method | AddImage | (Overloaded) Add a new image
Public method | Clear | Clear the content of the collection
Public method | Dispose | Releases all resources used by the. ItemImages.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | Exist | Check if a specified specified key exists in the collection
Public method | GetEnumerator | Restituisce un enumeratore che scorre un insieme.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | IndexOf | Gets index of specified key otherwise return -1 if key does not exists
Public method | Remove | (Overloaded) Remove the specified Item key from the collection
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ItemImages Class


ItemImages Properties

ItemImages Class See Also

The following tables list the members exposed by the ItemImages type.

Properties
 | Name | Description
Public property | Count | Gets the number of elements in the collection. First item start from 1.
Public property | Item | (Overloaded) Gets a specified item collection throw key
Top
See Also

Reference

ItemImages Class


ItemImages.Count Property

Gets the number of elements in the collection. First item start from 1.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the number of elements in the collection. First item start from 1.")> _
Public ReadOnly Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the number of elements in the collection. First item start from 1.")]
public int Count {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Item Property

ItemImages Class See Also

Gets a specified item collection throw key

Overload List
Name | Description
this[int] | Gets a specified item collection throw Index
this[string] | Gets a specified item collection throw key
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages Methods

ItemImages Class See Also

The following tables list the members exposed by the ItemImages type.

Methods
 | Name | Description
Public method | AddFromFileExecutable | Add a new image from icon extracted from specified executable file
Public method | AddFromFileExtension | Add a new image extracted from specified file extension association
Public method | AddFromFileImage | Add a new image from file
Public method | AddImage | (Overloaded) Add a new image
Public method | Clear | Clear the content of the collection
Public method | Dispose | Releases all resources used by the. ItemImages.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | Exist | Check if a specified specified key exists in the collection
Public method | GetEnumerator | Restituisce un enumeratore che scorre un insieme.
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | IndexOf | Gets index of specified key otherwise return -1 if key does not exists
Public method | Remove | (Overloaded) Remove the specified Item key from the collection
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ItemImages Class


ItemImages.AddFromFileExecutable Method

Add a new image from icon extracted from specified executable file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Add a new image from icon extracted from specified executable file")> _
Public Sub AddFromFileExecutable( _
   ByVal Text As String, _
   ByVal FileName As String, _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Add a new image from icon extracted from specified executable file")]
public System.Void AddFromFileExecutable(
   string Text,
   string FileName,
   string Key
)
This language is not supported or no code example is available.

Parameters

Text

Type: string

Combo Item Text

FileName

Type: string

Name of executable file name.

Key

Type: string

The key associated to the image in the collection

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddFromFileExtension Method

Add a new image extracted from specified file extension association

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Add a new image extracted from specified file extension association")> _
Public Sub AddFromFileExtension( _
   ByVal Text As String, _
   ByVal FileExtension As String, _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Add a new image extracted from specified file extension association")]
public System.Void AddFromFileExtension(
   string Text,
   string FileExtension,
   string Key
)
This language is not supported or no code example is available.

Parameters

Text

Type: string

Combo Item Text

FileExtension

Type: string

File extension (for example doc or .doc).

Key

Type: string

The key associated to the image in the collection

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddFromFileImage Method

Add a new image from file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Add a new image from file")> _
Public Sub AddFromFileImage( _
   ByVal Text As String, _
   ByVal FileName As String, _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Add a new image from file")]
public System.Void AddFromFileImage(
   string Text,
   string FileName,
   string Key
)
This language is not supported or no code example is available.

Parameters

Text

Type: string

Combo Item Text

FileName

Type: string

Name of file.

Key

Type: string

The key associated to the image in the collection

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddImage Method

ItemImages Class See Also

Add a new image

Overload List
Name | Description
AddImage(string, Icon, string) | Add a new icon
AddImage(string, Image, string) | Add a new image
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Clear Method

Clear the content of the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Clear the content of the collection")> _
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Clear the content of the collection")]
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Dispose Method

Releases all resources used by the. ItemImages.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
public System.Void Dispose()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Exist Method

Check if a specified specified key exists in the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Check if a specified specified key exists in the collection")> _
Public Function Exist( _
   ByVal Key As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Check if a specified specified key exists in the collection")]
public bool Exist(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key to check

Return Value

True is Key exists otherwise False
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.GetEnumerator Method

Restituisce un enumeratore che scorre un insieme.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetEnumerator() As IEnumerator Implements  _
   IEnumerable.GetEnumerator
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public IEnumerator GetEnumerator()
This language is not supported or no code example is available.

Return Value

Oggetto IEnumerator che può essere utilizzato per scorrere l'insieme.

Implements

IEnumerable.GetEnumerator
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.IndexOf Method

Gets index of specified key otherwise return -1 if key does not exists

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets index of specified key otherwise return -1 if key does not exists")> _
Public Function IndexOf( _
   ByVal Key As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets index of specified key otherwise return -1 if key does not exists")]
public int IndexOf(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key for wich find index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove Method

ItemImages Class See Also

Remove the specified Item key from the collection

Overload List
Name | Description
Remove(int) | Remove the specified Item Index from the collection
Remove(string) | Remove the specified Item key from the collection
See Also

Reference

ItemImages Class
ItemImages Members


License Class

Members

License class holds licenses informations data.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public NotInheritable Class License
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public sealed class License
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.License
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

License Members


License Members

License Class Methods Properties See Also

License class holds licenses informations data.

The following tables list the members exposed by the License type.

Properties
Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

License Class


License Properties

License Class See Also

The following tables list the members exposed by the License type.

Properties
Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top
See Also

Reference

License Class


License.LicenseKey Property

Gets/Sets the license key for the product

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets the license key for the product")> _
Public Shared Property LicenseKey() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets the license key for the product")]
public static string LicenseKey {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

License Class
License Members


License.LicenseName Property

Gets/Sets the license company name for the product

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets the license company name for the product")> _
Public Shared Property LicenseName() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets the license company name for the product")]
public static string LicenseName {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

License Class
License Members


License.LicenseUser Property

Gets/Sets the license user name (usually and email address) for the product

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets the license user name (usually and email address) for the product")> _
Public Shared Property LicenseUser() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets the license user name (usually and email address) for the product")]
public static string LicenseUser {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

License Class
License Members


License Methods

License Class See Also

The following tables list the members exposed by the License type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

License Class


ListBar Class

Members

Softgorup .Net ListBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook traditional Navigation Bar user interface

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Softgroup.NetControls.ListBar), "ListBar")> _
<System.ComponentModel.DefaultEvent("ItemClick")> _
<System.ComponentModel.DefaultProperty("Groups")> _
Public Class ListBar
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Softgroup.NetControls.ListBar), "ListBar")]
[System.ComponentModel.DefaultEvent("ItemClick")]
[System.ComponentModel.DefaultProperty("Groups")]
public class ListBar : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ListBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Members


ListBar Members

ListBar Class Constructors Events Methods Properties See Also

Softgorup .Net ListBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook traditional Navigation Bar user interface

The following tables list the members exposed by the ListBar type.

Constructors
 | Name | Description
Public constructor | ListBar Constructor | (Overloaded) Initializes a new instance of the ListBar class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AnimateGroups | Gets/sets whether groups state changes are animated or not.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets color used to paint the background of control.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorSchema | Gets/Sets predefinied color schema
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | Gets default background color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | Gets default foreground color.
 | DefaultGradientColor | Gets default gradient color
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawFrame | Gets/sets if a single line frame must be drawn around control.
Public property | DrawStyle | Gets/Sets draw style for ListBar control items.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets gradient color mixed with BackColor to create gradient effect
Public property | GradientEnabled | Gets/Sets if gradient background effect is enabled
Public property | GradientStyle | Gets/Sets style for drawing gradient effects
Public property | Groups | Gets the collection of groups in the ListBar.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ScrollButtonSize | Gets/sets groups scroll button size.
Public property | SelectedGroup | Gets/Sets the currently selected group in the ListBar control, if any.
Public property | SelectedGroupIndex | Gets/sets currently selected group index.
Public property | SelectedGroupKey | Gets/sets currently selected group key.
Public property | SelectedItem | Gets/Sets selected Item in the selected Group and makes it visible.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
Public method | ChangeColors | Apply specified colors to all groups and items
Public method | ChangeHeight | Sets specified height for all groups in control.
Public method | ChangeOffset | Sets specified offset for all groups in control.
Public method | EndUpdate | Resumes drawing of the control after drawing was suspended by the BeginUpdate method.
Public method | EnsureItemVisible | Brings the specified ListBarItem into view if it is not already visible. The ListBarItem must be in the selected group.
Public method | HasContextMenuOpened | Return True if a Context Menu of any Item in any Group is currently opened.
Public method | ResetBindings |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetTitleGroupsHeight | Sets specified height for all groups.
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BeforeGroupChange | Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.
Public event | BeforeItemClick | Raised before an oItem in a ListBar control is clicked. Allows the oItem selection to be cancelled.
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupChanged | Raised when the selected group in a ListBar control has been changed.
Public event | GroupClick | Raised when a group has been clicked in the ListBar control.
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemClick | Raised when an oItem has been clicked in the ListBar control.
Public event | ItemDoubleClick | Raised when an oItem has been double clicked in the ListBar control.
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ListBar Class


ListBar Constructor

ListBar Class See Also

Initializes a new instance of the ListBar class.

Overload List
Name | Description
ListBar() | Initializes a new instance of the ListBar class.
ListBar(IContainer) | Initializes a new instance of the ListBar class.
See Also

Reference

ListBar Class
ListBar Members


ListBar Properties

ListBar Class See Also

The following tables list the members exposed by the ListBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AnimateGroups | Gets/sets whether groups state changes are animated or not.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets color used to paint the background of control.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BackgroundImageTransparent | Gets/sets if image background will be paint transparent.
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorSchema | Gets/Sets predefinied color schema
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | Gets default background color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | Gets default foreground color.
 | DefaultGradientColor | Gets default gradient color
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawFrame | Gets/sets if a single line frame must be drawn around control.
Public property | DrawStyle | Gets/Sets draw style for ListBar control items.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets gradient color mixed with BackColor to create gradient effect
Public property | GradientEnabled | Gets/Sets if gradient background effect is enabled
Public property | GradientStyle | Gets/Sets style for drawing gradient effects
Public property | Groups | Gets the collection of groups in the ListBar.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ScrollButtonSize | Gets/sets groups scroll button size.
Public property | SelectedGroup | Gets/Sets the currently selected group in the ListBar control, if any.
Public property | SelectedGroupIndex | Gets/sets currently selected group index.
Public property | SelectedGroupKey | Gets/sets currently selected group key.
Public property | SelectedItem | Gets/Sets selected Item in the selected Group and makes it visible.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ListBar Class


ListBar.AnimateGroups Property

Gets/sets whether groups state changes are animated or not.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<Description("Gets/sets whether groups state changes are animated or not.")> _
<DefaultValue(True)> _
Public Property AnimateGroups( _
   ByRef "Gets/sets whether groups state changes are animated or not." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[Description("Gets/sets whether groups state changes are animated or not.")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AnimateGroups")]
public bool this[
   ref object "Gets/sets whether groups state changes are animated or not."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether groups state changes are animated or not."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.BackColor Property

ListBar Class See Also

Gets/Sets color used to paint the background of control.

Overload List
Name | Description
this[ref object] | Gets/Sets color used to paint the background of control.
BackColor | (System.Windows.Forms.Control).
See Also

Reference

ListBar Class
ListBar Members


ListBar.BackgroundImageTransparent Property

Gets/sets if image background will be paint transparent.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<DefaultValue(False)> _
<Description("Gets/sets if image background will be paint transparent.")> _
Public Property BackgroundImageTransparent( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[DefaultValue(False)]
[Description("Gets/sets if image background will be paint transparent.")]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageTransparent")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.BindingContext Property

ListBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BindingContext | (System.Windows.Forms.Control).
See Also

Reference

ListBar Class
ListBar Members


ListBar.BorderStyle Property

Gets/sets the border style for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.BorderStyle), "Fixed3D")> _
<Description("Gets/sets the border style for control.")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "Fixed3D" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.BorderStyle), "Fixed3D")]
[Description("Gets/sets the border style for control.")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "Fixed3D"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Fixed3D"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.ColorSchema Property

Gets/Sets predefinied color schema

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets/Sets color schema combination")> _
<System.ComponentModel.DefaultValue(GetType(ColorSchemaEnum), "Default")> _
Public Property ColorSchema( _
   ByRef "Gets/Sets color schema combination" As Object _
) As ColorSchemaEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets/Sets color schema combination")]
[System.ComponentModel.DefaultValue(GetType(ColorSchemaEnum), "Default")]
[System.Runtime.CompilerServices.IndexerName("ColorSchema")]
public ColorSchemaEnum this[
   ref object "Gets/Sets color schema combination"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets color schema combination"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DataBindings Property

ListBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

ListBar Class
ListBar Members


ListBar.DefaultBackColor Property

Gets default background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default background color.")> _
Public ReadOnly Overloads Shared Property DefaultBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default background color.")]
public static Color DefaultBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DefaultForeColor Property

Gets default foreground color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default foreground color.")> _
Public ReadOnly Overloads Shared Property DefaultForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default foreground color.")]
public static Color DefaultForeColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DefaultGradientColor Property

Gets default gradient color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default gradient color")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default gradient color")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DrawFrame Property

Gets/sets if a single line frame must be drawn around control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<System.ComponentModel.DefaultValue(False)> _
<Description("Gets/sets if a single line frame must be drawn around control.")> _
Public Property DrawFrame( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[System.ComponentModel.DefaultValue(False)]
[Description("Gets/sets if a single line frame must be drawn around control.")]
[System.Runtime.CompilerServices.IndexerName("DrawFrame")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DrawStyle Property

Gets/Sets draw style for ListBar control items.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets/Sets draw style for ListBar control items.")> _
<System.ComponentModel.DefaultValue(GetType(DrawStyleEnum), "Enhanced")> _
Public Property DrawStyle( _
   ByRef "Gets/Sets draw style for ListBar control items." As Object _
) As DrawStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets/Sets draw style for ListBar control items.")]
[System.ComponentModel.DefaultValue(GetType(DrawStyleEnum), "Enhanced")]
[System.Runtime.CompilerServices.IndexerName("DrawStyle")]
public DrawStyleEnum this[
   ref object "Gets/Sets draw style for ListBar control items."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets draw style for ListBar control items."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.GradientColor Property

Gets/Sets gradient color mixed with BackColor to create gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets/Sets gradient background color of control")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")> _
Public Property GradientColor( _
   ByRef "Gets/Sets gradient background color of control" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets/Sets gradient background color of control")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "Gets/Sets gradient background color of control"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets gradient background color of control"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.GradientEnabled Property

Gets/Sets if gradient background effect is enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets/Sets if gradient background effect is enabled")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "Gets/Sets if gradient background effect is enabled" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets/Sets if gradient background effect is enabled")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Gets/Sets if gradient background effect is enabled"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if gradient background effect is enabled"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.GradientStyle Property

Gets/Sets style for drawing gradient effects

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets/Sets style for drawing gradient effects")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")> _
Public Property GradientStyle( _
   ByRef "Gets/Sets style for drawing gradient effects" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets/Sets style for drawing gradient effects")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")]
[System.Runtime.CompilerServices.IndexerName("GradientStyle")]
public LinearGradientMode this[
   ref object "Gets/Sets style for drawing gradient effects"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets style for drawing gradient effects"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.Groups Property

Gets the collection of groups in the ListBar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets the collection of groups in the ListBar.")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Groups( _
   ByRef "Gets the collection of groups in the ListBar." As Object _
) As ListBarGroups
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets the collection of groups in the ListBar.")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Content)]
[System.Runtime.CompilerServices.IndexerName("Groups")]
public ListBarGroups this[
   ref object "Gets the collection of groups in the ListBar."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the collection of groups in the ListBar."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.Margin Property

ListBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ListBar Class
ListBar Members


ListBar.Padding Property

ListBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

ListBar Class
ListBar Members


ListBar.ScrollButtonSize Property

Gets/sets groups scroll button size.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<System.ComponentModel.DefaultValue(DefaultListabarScrollButtonsSize)> _
<Description("Gets/sets groups scroll button size.")> _
Public Property ScrollButtonSize( _
   ByRef DefaultListabarScrollButtonsSize As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[System.ComponentModel.DefaultValue(DefaultListabarScrollButtonsSize)]
[Description("Gets/sets groups scroll button size.")]
[System.Runtime.CompilerServices.IndexerName("ScrollButtonSize")]
public int this[
   ref object DefaultListabarScrollButtonsSize
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultListabarScrollButtonsSize

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.SelectedGroup Property

Gets/Sets the currently selected group in the ListBar control, if any.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
Public Property SelectedGroup( _
   ByRef False As Object _
) As ListBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("SelectedGroup")]
public ListBarGroup this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.SelectedGroupIndex Property

Gets/sets currently selected group index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<Description("Gets/sets currently selected group index.")> _
<System.ComponentModel.DefaultValue(-1)> _
Public Property SelectedGroupIndex( _
   ByRef System.ComponentModel.DesignerSerializationVisibility.Hidden As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets currently selected group index.")]
[System.ComponentModel.DefaultValue(-1)]
[System.Runtime.CompilerServices.IndexerName("SelectedGroupIndex")]
public int this[
   ref object System.ComponentModel.DesignerSerializationVisibility.Hidden
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.SelectedGroupKey Property

Gets/sets currently selected group key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<Description("Gets/sets currently selected group key.")> _
<System.ComponentModel.DefaultValue("")> _
Public Property SelectedGroupKey( _
   ByRef System.ComponentModel.DesignerSerializationVisibility.Hidden As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets currently selected group key.")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("SelectedGroupKey")]
public string this[
   ref object System.ComponentModel.DesignerSerializationVisibility.Hidden
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.SelectedItem Property

Gets/Sets selected Item in the selected Group and makes it visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
Public Property SelectedItem( _
   ByRef False As Object _
) As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("SelectedItem")]
public ListBarItem this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar Methods

ListBar Class See Also

The following tables list the members exposed by the ListBar type.

Methods
 | Name | Description
Public method | BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
Public method | ChangeColors | Apply specified colors to all groups and items
Public method | ChangeHeight | Sets specified height for all groups in control.
Public method | ChangeOffset | Sets specified offset for all groups in control.
Public method | EndUpdate | Resumes drawing of the control after drawing was suspended by the BeginUpdate method.
Public method | EnsureItemVisible | Brings the specified ListBarItem into view if it is not already visible. The ListBarItem must be in the selected group.
Public method | HasContextMenuOpened | Return True if a Context Menu of any Item in any Group is currently opened.
Public method | ResetBindings |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetTitleGroupsHeight | Sets specified height for all groups.
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ListBar Class


ListBar.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub BeginUpdate()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void BeginUpdate()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.ChangeColors Method

Apply specified colors to all groups and items

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Apply specified colors to all groups and items")> _
Public Sub ChangeColors( _
   ByVal GroupBackColor As Color, _
   ByVal GroupForeColor As Color, _
   ByVal ItemForeColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Apply specified colors to all groups and items")]
public System.Void ChangeColors(
   Color GroupBackColor,
   Color GroupForeColor,
   Color ItemForeColor
)
This language is not supported or no code example is available.

Parameters

GroupBackColor

Type: Color

Group background colour

GroupForeColor

Type: Color

Group foreground colour

ItemForeColor

Type: Color

Item foreground colour

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.ChangeHeight Method

Sets specified height for all groups in control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ChangeHeight( _
   ByVal iHeight As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ChangeHeight(
   int iHeight
)
This language is not supported or no code example is available.

Parameters

iHeight

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.ChangeOffset Method

Sets specified offset for all groups in control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ChangeOffset( _
   ByVal iOffset As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ChangeOffset(
   int iOffset
)
This language is not supported or no code example is available.

Parameters

iOffset

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.EndUpdate Method

Resumes drawing of the control after drawing was suspended by the BeginUpdate method.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub EndUpdate()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void EndUpdate()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.EnsureItemVisible Method

Brings the specified ListBarItem into view if it is not already visible. The ListBarItem must be in the selected group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub EnsureItemVisible( _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void EnsureItemVisible(
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ListBarItem

oItem to bring into view.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members
ListBar.SelectedGroup
ListBarItem


ListBar.HasContextMenuOpened Method

Return True if a Context Menu of any Item in any Group is currently opened.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function HasContextMenuOpened() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool HasContextMenuOpened()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.ResetBindings Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetBindings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetBindings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.SetTitleGroupsHeight Method

Sets specified height for all groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetListBar")> _
<System.ComponentModel.DefaultValue(DefaultListabarTitleGroupHeight)> _
<Description("Sets specified height for all groups.")> _
Public Sub SetTitleGroupsHeight( _
   ByVal iHeight As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetListBar")]
[System.ComponentModel.DefaultValue(DefaultListabarTitleGroupHeight)]
[Description("Sets specified height for all groups.")]
public System.Void SetTitleGroupsHeight(
   int iHeight
)
This language is not supported or no code example is available.

Parameters

iHeight

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar Events

ListBar Class See Also

The following tables list the members exposed by the ListBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BeforeGroupChange | Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.
Public event | BeforeItemClick | Raised before an oItem in a ListBar control is clicked. Allows the oItem selection to be cancelled.
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupChanged | Raised when the selected group in a ListBar control has been changed.
Public event | GroupClick | Raised when a group has been clicked in the ListBar control.
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemClick | Raised when an oItem has been clicked in the ListBar control.
Public event | ItemDoubleClick | Raised when an oItem has been double clicked in the ListBar control.
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ListBar Class


BeforeGroupChange Event

Raised before the selected group in the ListBar control is changed. Allows the group selection to be cancelled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event BeforeGroupChange( _
   ByVal sender As Object, _
   ByVal e As ListBarBeforeGroupChangedEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event BeforeGroupChangeEventHandler BeforeGroupChange
delegate void BeforeGroupChangeEventHandler(
   object sender,
   ListBarBeforeGroupChangedEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarBeforeGroupChangedEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


BeforeItemClick Event

Raised before an oItem in a ListBar control is clicked. Allows the oItem selection to be cancelled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event BeforeItemClick( _
   ByVal sender As Object, _
   ByVal e As ListBarBeforeItemClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event BeforeItemClickEventHandler BeforeItemClick
delegate void BeforeItemClickEventHandler(
   object sender,
   ListBarBeforeItemClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarBeforeItemClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


BindingContextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BindingContextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BindingContextChangedEventHandler BindingContextChanged
delegate void BindingContextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


GroupChanged Event

Raised when the selected group in a ListBar control has been changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event GroupChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event GroupChangedEventHandler GroupChanged
delegate void GroupChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


GroupClick Event

Raised when a group has been clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event GroupClick( _
   ByVal sender As Object, _
   ByVal e As ListBarGroupClickedEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event GroupClickEventHandler GroupClick
delegate void GroupClickEventHandler(
   object sender,
   ListBarGroupClickedEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarGroupClickedEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ItemClick Event

Raised when an oItem has been clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ItemClick( _
   ByVal sender As Object, _
   ByVal e As ListBarItemClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ItemClickEventHandler ItemClick
delegate void ItemClickEventHandler(
   object sender,
   ListBarItemClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarItemClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ItemDoubleClick Event

Raised when an oItem has been double clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ItemDoubleClick( _
   ByVal sender As Object, _
   ByVal e As ListBarItemDoubleClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ItemDoubleClickEventHandler ItemDoubleClick
delegate void ItemDoubleClickEventHandler(
   object sender,
   ListBarItemDoubleClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarItemDoubleClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBarBeforeGroupChangedEventArgs Class

Members

Provides event arguments for the BeforeSelectedGroupChanged event raised by the control. This object contains the group that would be selected and provides the opportunity to cancel the group selection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBarBeforeGroupChangedEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBarBeforeGroupChangedEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ListBarBeforeGroupChangedEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeGroupChangedEventArgs Members


ListBarBeforeGroupChangedEventArgs Members

ListBarBeforeGroupChangedEventArgs Class Methods Properties See Also

Provides event arguments for the BeforeSelectedGroupChanged event raised by the control. This object contains the group that would be selected and provides the opportunity to cancel the group selection.

The following tables list the members exposed by the ListBarBeforeGroupChangedEventArgs type.

Properties
 | Name | Description
Public property | Cancel | Gets/Sets whether the group selection should be cancelled or not.
Public property | Group | Gets the group that will be selected.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarBeforeGroupChangedEventArgs Class


ListBarBeforeGroupChangedEventArgs Properties

ListBarBeforeGroupChangedEventArgs Class See Also

The following tables list the members exposed by the ListBarBeforeGroupChangedEventArgs type.

Properties
 | Name | Description
Public property | Cancel | Gets/Sets whether the group selection should be cancelled or not.
Public property | Group | Gets the group that will be selected.
Top
See Also

Reference

ListBarBeforeGroupChangedEventArgs Class


ListBarBeforeGroupChangedEventArgs.Cancel Property

Gets/Sets whether the group selection should be cancelled or not.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets whether the group selection should be cancelled or not.")> _
Public Property Cancel() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets whether the group selection should be cancelled or not.")]
public bool Cancel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeGroupChangedEventArgs Class
ListBarBeforeGroupChangedEventArgs Members


ListBarBeforeGroupChangedEventArgs.Group Property

Gets the group that will be selected.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the group that will be selected.")> _
Public ReadOnly Property Group() As ListBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the group that will be selected.")]
public ListBarGroup Group {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeGroupChangedEventArgs Class
ListBarBeforeGroupChangedEventArgs Members


ListBarBeforeGroupChangedEventArgs Methods

ListBarBeforeGroupChangedEventArgs Class See Also

The following tables list the members exposed by the ListBarBeforeGroupChangedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarBeforeGroupChangedEventArgs Class


ListBarBeforeItemClickEventArgs Class

Members

Provides event arguments for the BeforeItemClick event and provides the item which is about to be clicked and the option to prevent the item being clicked by setting the Cancel property.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBarBeforeItemClickEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBarBeforeItemClickEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ListBarBeforeItemClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeItemClickEventArgs Members


ListBarBeforeItemClickEventArgs Members

ListBarBeforeItemClickEventArgs Class Methods Properties See Also

Provides event arguments for the BeforeItemClick event and provides the item which is about to be clicked and the option to prevent the item being clicked by setting the Cancel property.

The following tables list the members exposed by the ListBarBeforeItemClickEventArgs type.

Properties
 | Name | Description
Public property | Cancel | Gets/sets whether the click should be cancelled or not.
Public property | Item | Gets the ListBarItem object that is about to be clicked.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarBeforeItemClickEventArgs Class


ListBarBeforeItemClickEventArgs Properties

ListBarBeforeItemClickEventArgs Class See Also

The following tables list the members exposed by the ListBarBeforeItemClickEventArgs type.

Properties
 | Name | Description
Public property | Cancel | Gets/sets whether the click should be cancelled or not.
Public property | Item | Gets the ListBarItem object that is about to be clicked.
Top
See Also

Reference

ListBarBeforeItemClickEventArgs Class


ListBarBeforeItemClickEventArgs.Cancel Property

Gets/sets whether the click should be cancelled or not.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property Cancel() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Cancel {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeItemClickEventArgs Class
ListBarBeforeItemClickEventArgs Members


ListBarBeforeItemClickEventArgs.Item Property

Gets the ListBarItem object that is about to be clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Item() As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ListBarItem Item {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarBeforeItemClickEventArgs Class
ListBarBeforeItemClickEventArgs Members


ListBarBeforeItemClickEventArgs Methods

ListBarBeforeItemClickEventArgs Class See Also

The following tables list the members exposed by the ListBarBeforeItemClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarBeforeItemClickEventArgs Class


ListBarClickedEventArgs Class

Members

ObjectClickedEventArgs class is used as the bases for the ItemClick and GroupClick events of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public MustInherit Class ListBarClickedEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public abstract class ListBarClickedEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ListBarClickedEventArgs
Softgroup.NetControls.ListBarGroupClickedEventArgs
Softgroup.NetControls.ListBarItemClickEventArgs
Softgroup.NetControls.ListBarItemDoubleClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarClickedEventArgs Members


ListBarClickedEventArgs Members

ListBarClickedEventArgs Class Methods Properties See Also

ObjectClickedEventArgs class is used as the bases for the ItemClick and GroupClick events of the control.

The following tables list the members exposed by the ListBarClickedEventArgs type.

Properties
 | Name | Description
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked.
Public property | MouseButton | The MouseButton used to click the item.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarClickedEventArgs Class


ListBarClickedEventArgs Properties

ListBarClickedEventArgs Class See Also

The following tables list the members exposed by the ListBarClickedEventArgs type.

Properties
 | Name | Description
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked.
Public property | MouseButton | The MouseButton used to click the item.
Top
See Also

Reference

ListBarClickedEventArgs Class


ListBarClickedEventArgs.Location Property

The Location of the mouse, relative to the control, when the item was clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("The Location of the mouse, relative to the control, when the item was clicked.")> _
Public ReadOnly Property Location() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("The Location of the mouse, relative to the control, when the item was clicked.")]
public Point Location {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarClickedEventArgs Class
ListBarClickedEventArgs Members


ListBarClickedEventArgs.MouseButton Property

The MouseButton used to click the item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("The MouseButton used to click the item.")> _
Public ReadOnly Property MouseButton() As MouseButtons
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("The MouseButton used to click the item.")]
public MouseButtons MouseButton {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarClickedEventArgs Class
ListBarClickedEventArgs Members


ListBarClickedEventArgs Methods

ListBarClickedEventArgs Class See Also

The following tables list the members exposed by the ListBarClickedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarClickedEventArgs Class


ListBarGroup Class

Members

A ListBarGroup is a bar within a ListBar control. A bar can either contain items or it can contain a control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
<DesignTimeVisible(False)> _
<ToolboxItem(False)> _
Public Class ListBarGroup
    Inherits Component
    Implements IListBarMouseObject
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
[DesignTimeVisible(False)]
[ToolboxItem(False)]
public class ListBarGroup : Component,
   IListBarMouseObject
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Softgroup.NetControls.ListBarGroup
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Members


ListBarGroup Members

ListBarGroup Class Constructors Events Methods Properties See Also

A ListBarGroup is a bar within a ListBar control. A bar can either contain items or it can contain a control.

The following tables list the members exposed by the ListBarGroup type.

Constructors
 | Name | Description
Public constructor | ListBarGroup Constructor | (Overloaded) Create a new ListBarGroup object.
Top
Properties
 | Name | Description
Public property | BackColor | Gets/Sets the background colour to use when drawing the button for this group.
Public property | Container | (inherited from Component).
Public property | Control | Gets/sets a System.Windows.Forms.Control object displayed within this group client area. This property can only be gets/sets at runtime.
 | DefaultBackColor | Gets default background colour to use when drawing the button for this group.
 | DefaultForeColor | Gets default foreground colour to use when drawing the group button.
 | DefaultGradientColor | Gets default gradient color mixed with BackColor to create group button gradient effect
Public property | Font | Gets/Sets the font used to draw the caption of this group.
Public property | ForeColor | Gets/sets the foreground colour to use when drawing the group button.
Public property | GradientColor | Gets/Sets gradient color mixed with BackColor to create group button gradient effect
Public property | GradientEnabled | Gets/Sets if gradient background effect is enabled on group button
Public property | GradientStyle | Gets/Sets style for drawing group button gradient effects
Public property | Image | Gets/Sets the image displayed at left or right of text group.
Public property | ImageAlign | Gets/Sets image alignment with the group Text.
Public property | Items | Gets the collection of items contained into this group.
Public property | Key | Gets/sets the string key associated with this group.
Public property | ListBar | Gets a reference to ListBar control
Public property | MouseOver | Gets/sets whether the mouse is over the group button.
Public property | Offset | Gets/Sets horizonal margins and spacing for text and image.
Public property | Selected | Gets/Sets whether this group is selected or not.
Public property | SelectedItem | Gets the selected ListBarItam in this Group, if any, otherwise null.
Public property | Site | (inherited from Component).
Public property | Tag | Gets/sets a user-defined object associated with this group.
Public property | Text | Gets/Sets the text caption displayed for this group.
Public property | TitleHeight | Gets the height in pixels of the group button title (minimum is 24 pixels).
Public property | ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this group's button.
Public property | ViewStyle | Gets/Sets the which view to show the items within this bar.
Public property | Visible | Gets/sets whether this group is visible.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of this object
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
Events
 | Name | Description
Public event | Click | Raised when a group has been clicked in the ListBar control.
Public event | Disposed | (inherited from Component).
Top
See Also

Reference

ListBarGroup Class


ListBarGroup Constructor

ListBarGroup Class See Also

Create a new ListBarGroup object.

Overload List
Name | Description
ListBarGroup() | Create a new ListBarGroup object.
ListBarGroup(string) | Create a new ListBarGroup object.
ListBarGroup(string, Image) | Create a new ListBarGroup object.
ListBarGroup(string, string) | Create a new ListBarGroup object.
ListBarGroup(string, string, Image) | Create a new ListBarGroup object.
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Properties

ListBarGroup Class See Also

The following tables list the members exposed by the ListBarGroup type.

Properties
 | Name | Description
Public property | BackColor | Gets/Sets the background colour to use when drawing the button for this group.
Public property | Container | (inherited from Component).
Public property | Control | Gets/sets a System.Windows.Forms.Control object displayed within this group client area. This property can only be gets/sets at runtime.
 | DefaultBackColor | Gets default background colour to use when drawing the button for this group.
 | DefaultForeColor | Gets default foreground colour to use when drawing the group button.
 | DefaultGradientColor | Gets default gradient color mixed with BackColor to create group button gradient effect
Public property | Font | Gets/Sets the font used to draw the caption of this group.
Public property | ForeColor | Gets/sets the foreground colour to use when drawing the group button.
Public property | GradientColor | Gets/Sets gradient color mixed with BackColor to create group button gradient effect
Public property | GradientEnabled | Gets/Sets if gradient background effect is enabled on group button
Public property | GradientStyle | Gets/Sets style for drawing group button gradient effects
Public property | Image | Gets/Sets the image displayed at left or right of text group.
Public property | ImageAlign | Gets/Sets image alignment with the group Text.
Public property | Items | Gets the collection of items contained into this group.
Public property | Key | Gets/sets the string key associated with this group.
Public property | ListBar | Gets a reference to ListBar control
Public property | MouseOver | Gets/sets whether the mouse is over the group button.
Public property | Offset | Gets/Sets horizonal margins and spacing for text and image.
Public property | Selected | Gets/Sets whether this group is selected or not.
Public property | SelectedItem | Gets the selected ListBarItam in this Group, if any, otherwise null.
Public property | Site | (inherited from Component).
Public property | Tag | Gets/sets a user-defined object associated with this group.
Public property | Text | Gets/Sets the text caption displayed for this group.
Public property | TitleHeight | Gets the height in pixels of the group button title (minimum is 24 pixels).
Public property | ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this group's button.
Public property | ViewStyle | Gets/Sets the which view to show the items within this bar.
Public property | Visible | Gets/sets whether this group is visible.
Top
See Also

Reference

ListBarGroup Class


ListBarGroup.BackColor Property

Gets/Sets the background colour to use when drawing the button for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the background colour to use when drawing the button for this group.")> _
<DefaultValue(GetType(System.Drawing.Color), "Control")> _
<Category("NetListBar")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "Control" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the background colour to use when drawing the button for this group.")]
[DefaultValue(GetType(System.Drawing.Color), "Control")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "Control"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Control"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Control Property

Gets/sets a System.Windows.Forms.Control object displayed within this group client area.

This property can only be gets/sets at runtime.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public Property Control( _
   ByRef False As Object _
) As Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Control")]
public Control this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.DefaultBackColor Property

Gets default background colour to use when drawing the button for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default background colour to use when drawing the button for this group.")> _
Public ReadOnly Shared Property DefaultBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default background colour to use when drawing the button for this group.")]
public static Color DefaultBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.DefaultForeColor Property

Gets default foreground colour to use when drawing the group button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default foreground colour to use when drawing the group button.")> _
Public ReadOnly Shared Property DefaultForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default foreground colour to use when drawing the group button.")]
public static Color DefaultForeColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.DefaultGradientColor Property

Gets default gradient color mixed with BackColor to create group button gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default gradient color mixed with BackColor to create group button gradient effect")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default gradient color mixed with BackColor to create group button gradient effect")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Font Property

Gets/Sets the font used to draw the caption of this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(CStr(Nothing))> _
<Description("Gets/Sets the font used to draw the caption of this group.")> _
<Category("NetListBar")> _
Public Property Font( _
   ByRef "NetListBar" As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(CStr(Nothing))]
[Description("Gets/Sets the font used to draw the caption of this group.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.ForeColor Property

Gets/sets the foreground colour to use when drawing the group button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "ControlText")> _
<Description("Gets/sets the foreground colour to use when drawing the group button.")> _
<Category("NetListBar")> _
Public Property ForeColor( _
   ByRef "NetListBar" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "ControlText")]
[Description("Gets/sets the foreground colour to use when drawing the group button.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.GradientColor Property

Gets/Sets gradient color mixed with BackColor to create group button gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets gradient color mixed with BackColor to create group button gradient effect")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")> _
<Category("NetListBar")> _
Public Property GradientColor( _
   ByRef GetType As Object, _
   ByRef "ControlLightLight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets gradient color mixed with BackColor to create group button gradient effect")]
[DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object GetType,
   ref object "ControlLightLight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlLightLight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.GradientEnabled Property

Gets/Sets if gradient background effect is enabled on group button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets if gradient background effect is enabled on group button")> _
<DefaultValue(False)> _
<Category("NetListBar")> _
Public Property GradientEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets if gradient background effect is enabled on group button")]
[DefaultValue(False)]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.GradientStyle Property

Gets/Sets style for drawing group button gradient effects

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets style for drawing group button gradient effects")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Vertical")> _
<Category("NetListBar")> _
Public Property GradientStyle( _
   ByRef GetType As Object, _
   ByRef "Vertical" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets style for drawing group button gradient effects")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Vertical")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("GradientStyle")]
public LinearGradientMode this[
   ref object GetType,
   ref object "Vertical"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Vertical"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Image Property

Gets/Sets the image displayed at left or right of text group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the image displayed at left or right of text group.")> _
<Category("NetListBar")> _
<DefaultValue(CStr(Nothing))> _
Public Property Image( _
   ByRef "NetListBar" As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the image displayed at left or right of text group.")]
[Category("NetListBar")]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Remarks

The image must be 16x16 size.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.ImageAlign Property

Gets/Sets image alignment with the group Text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets image alignment with the group Text.")> _
<Category("NetListBar")> _
<DefaultValue(GetType(System.Windows.Forms.LeftRightAlignment), "Left")> _
Public Property ImageAlign( _
   ByRef "NetListBar" As Object _
) As LeftRightAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets image alignment with the group Text.")]
[Category("NetListBar")]
[DefaultValue(GetType(System.Windows.Forms.LeftRightAlignment), "Left")]
[System.Runtime.CompilerServices.IndexerName("ImageAlign")]
public LeftRightAlignment this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Items Property

Gets the collection of items contained into this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the collection of items contained into this group.")> _
<Category("NetListBar")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Items( _
   ByRef "NetListBar" As Object _
) As ListBarItems
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the collection of items contained into this group.")]
[Category("NetListBar")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ListBarItems this[
   ref object "NetListBar"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Key Property

Gets/sets the string key associated with this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/sets the string key associated with this group.")> _
<DefaultValue("")> _
<Category("NetListBar")> _
Public Property Key( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets the string key associated with this group.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Key")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.ListBar Property

Gets a reference to ListBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public Property ListBar( _
   ByRef False As Object _
) As ListBar
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ListBar")]
public ListBar this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.MouseOver Property

Gets/sets whether the mouse is over the group button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets whether the mouse is over the group button.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("MouseOver")]
public bool this[
   ref object "Gets/sets whether the mouse is over the group button."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether the mouse is over the group button."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Offset Property

Gets/Sets horizonal margins and spacing for text and image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets horizonal margins and spacing for text and image.")> _
<Category("NetListBar")> _
<DefaultValue(3)> _
Public Property Offset( _
   ByRef "NetListBar" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets horizonal margins and spacing for text and image.")]
[Category("NetListBar")]
[DefaultValue(3)]
[System.Runtime.CompilerServices.IndexerName("Offset")]
public int this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Selected Property

Gets/Sets whether this group is selected or not.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets/Sets whether this group is selected or not.")> _
<Browsable(False)> _
Public Property Selected( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/Sets whether this group is selected or not.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Selected")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.SelectedItem Property

Gets the selected ListBarItam in this Group, if any, otherwise null.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets the selected ListBarItam in this Group, if any, otherwise null.")> _
<Browsable(False)> _
Public ReadOnly Property SelectedItem( _
   ByRef "Gets the selected ListBarItam in this Group, if any, otherwise null." As Object _
) As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets the selected ListBarItam in this Group, if any, otherwise null.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("SelectedItem")]
public ListBarItem this[
   ref object "Gets the selected ListBarItam in this Group, if any, otherwise null."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the selected ListBarItam in this Group, if any, otherwise null."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Tag Property

Gets/sets a user-defined object associated with this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<DefaultValue(CStr(Nothing))> _
<Description("Gets/sets a user-defined object associated with this group.")> _
<Category("NetListBar")> _
<Browsable(False)> _
Public Property Tag( _
   ByRef CStr As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue(CStr(Nothing))]
[Description("Gets/sets a user-defined object associated with this group.")]
[Category("NetListBar")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Tag")]
public object this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Text Property

Gets/Sets the text caption displayed for this group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the text caption displayed for this group.")> _
<DefaultValue("")> _
<Category("NetListBar")> _
Public Property Text( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the text caption displayed for this group.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.TitleHeight Property

Gets the height in pixels of the group button title (minimum is 24 pixels).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetListBar")> _
<Description("Gets the height in pixels of the group button title (minimum is 24 pixels).")> _
<System.ComponentModel.DefaultValue(DefaultListabarTitleGroupHeight)> _
Public Property TitleHeight( _
   ByRef "Gets the height in pixels of the group button title  As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetListBar")]
[Description("Gets the height in pixels of the group button title (minimum is 24 pixels).")]
[System.ComponentModel.DefaultValue(DefaultListabarTitleGroupHeight)]
[System.Runtime.CompilerServices.IndexerName("TitleHeight")]
public int this[
   ref object "Gets the height in pixels of the group button title
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets the height in pixels of the group button title

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.ToolTipText Property

Gets/sets the tooltip text that will be displayed when the user hovers over this group's button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets the tooltip text that will be displayed when the user hovers over this group's button.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.ViewStyle Property

Gets/Sets the which view to show the items within this bar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(ListBar.GroupViewEnum), "Large")> _
<Description("Gets/Sets the which view to show the items within this bar.")> _
<Category("NetListBar")> _
Public Property ViewStyle( _
   ByRef "Gets/Sets the which view to show the items within this bar." As Object _
) As GroupViewEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(ListBar.GroupViewEnum), "Large")]
[Description("Gets/Sets the which view to show the items within this bar.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("ViewStyle")]
public GroupViewEnum this[
   ref object "Gets/Sets the which view to show the items within this bar."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the which view to show the items within this bar."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup.Visible Property

Gets/sets whether this group is visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(True)> _
<Description("Gets/sets whether this group is visible.")> _
<Category("NetListBar")> _
Public Property Visible( _
   ByRef "Gets/sets whether this group is visible." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(True)]
[Description("Gets/sets whether this group is visible.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Visible")]
public bool this[
   ref object "Gets/sets whether this group is visible."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether this group is visible."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Methods

ListBarGroup Class See Also

The following tables list the members exposed by the ListBarGroup type.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of this object
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
See Also

Reference

ListBarGroup Class


ListBarGroup.Clone Method

Returns a deep clone of this object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Returns a deep clone of this object")> _
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Returns a deep clone of this object")]
public object Clone()
This language is not supported or no code example is available.

Implements

ICloneable.Clone
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Events

ListBarGroup Class See Also

The following tables list the members exposed by the ListBarGroup type.

Events
 | Name | Description
Public event | Click | Raised when a group has been clicked in the ListBar control.
Public event | Disposed | (inherited from Component).
Top
See Also

Reference

ListBarGroup Class


Click Event

Raised when a group has been clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Click( _
   ByVal sender As Object, _
   ByVal e As ListBarGroupClickedEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClickEventHandler Click
delegate void ClickEventHandler(
   object sender,
   ListBarGroupClickedEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarGroupClickedEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroupClickedEventArgs Class

Members

Provides details of which item has been clicked and the mouse details of the click when the GroupClicked event is raised from a control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBarGroupClickedEventArgs
    Inherits ListBarClickedEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBarGroupClickedEventArgs : ListBarClickedEventArgs
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroupClickedEventArgs Members


ListBarGroupClickedEventArgs Members

ListBarGroupClickedEventArgs Class Methods Properties See Also

Provides details of which item has been clicked and the mouse details of the click when the GroupClicked event is raised from a control.

The following tables list the members exposed by the ListBarGroupClickedEventArgs type.

Properties
 | Name | Description
Public property | Group | Gets the that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarGroupClickedEventArgs Class


ListBarGroupClickedEventArgs Properties

ListBarGroupClickedEventArgs Class See Also

The following tables list the members exposed by the ListBarGroupClickedEventArgs type.

Properties
 | Name | Description
Public property | Group | Gets the that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
See Also

Reference

ListBarGroupClickedEventArgs Class


ListBarGroupClickedEventArgs.Group Property

Gets the that has been clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Group() As ListBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ListBarGroup Group {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroupClickedEventArgs Class
ListBarGroupClickedEventArgs Members


ListBarGroupClickedEventArgs Methods

ListBarGroupClickedEventArgs Class See Also

The following tables list the members exposed by the ListBarGroupClickedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarGroupClickedEventArgs Class


ListBarGroups Class

Members

The collection class of ListBarGroup objects in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
Public Class ListBarGroups
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
public class ListBarGroups : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.ListBarGroups
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Members


ListBarGroups Members

ListBarGroups Class Methods Properties See Also

The collection class of ListBarGroup objects in the ListBar control.

The following tables list the members exposed by the ListBarGroups type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ListBarItem object in the group with the specified key.
Public property | ListBar | Gets a reference to ListBar control
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new Group in the collection.
Public method | AddRange | Adds a list of ListBarGroup to the control.
Public method | Clear | Remove all groups from control
Public method | Contains | Determines whether a element is contained within the control's collection of groups.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified Group within this collection.
Public method | Insert | Inserts a Group at the specified index in the collection of groups.
Public method | InsertAfter | Inserts a Group immediately after the specified ListBarGroup.
Public method | InsertBefore | Inserts a Group immediately before the specified Group.
Public method | Remove | (Overloaded) Removes the specified Group .
Public method | RemoveAt | Consente di rimuovere la voce in corrispondenza dell'indice specificato dell'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarGroups Class


ListBarGroups Properties

ListBarGroups Class See Also

The following tables list the members exposed by the ListBarGroups type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ListBarItem object in the group with the specified key.
Public property | ListBar | Gets a reference to ListBar control
Top
See Also

Reference

ListBarGroups Class


ListBarGroups.Item Property

ListBarGroups Class See Also

Gets the ListBarItem object in the group with the specified key.

Overload List
Name | Description
this[int] | Gets the ListBarItem object in the group at the specified index.
this[string] | Gets the ListBarItem object in the group with the specified key.
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.ListBar Property

Gets a reference to ListBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
Public Property ListBar( _
   ByRef False As Object _
) As ListBar
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ListBar")]
public ListBar this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups Methods

ListBarGroups Class See Also

The following tables list the members exposed by the ListBarGroups type.

Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new Group in the collection.
Public method | AddRange | Adds a list of ListBarGroup to the control.
Public method | Clear | Remove all groups from control
Public method | Contains | Determines whether a element is contained within the control's collection of groups.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Gets the index of the specified Group within this collection.
Public method | Insert | Inserts a Group at the specified index in the collection of groups.
Public method | InsertAfter | Inserts a Group immediately after the specified ListBarGroup.
Public method | InsertBefore | Inserts a Group immediately before the specified Group.
Public method | Remove | (Overloaded) Removes the specified Group .
Public method | RemoveAt | Consente di rimuovere la voce in corrispondenza dell'indice specificato dell'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarGroups Class


ListBarGroups.Add Method

ListBarGroups Class See Also

Adds a new Group in the collection.

Overload List
Name | Description
Add() | Adds a new Group in the collection.
Add(ListBarGroup) | Adds specified Group in the collection.
Add(string) | Adds a new Group in the collection with spcified Text.
Add(string, string) | Adds a new Group in the collection with specified Text and Key.
Add(string, string, Image) | Adds a new Group in the collection with spcified Text, Key and Image.
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.AddRange Method

Adds a list of ListBarGroup to the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddRange( _
   ByVal oGroups As ListBarGroup() _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddRange(
   ListBarGroup[] oGroups
)
This language is not supported or no code example is available.

Parameters

oGroups

Type: ListBarGroup[]

A valid array of ListBarGroup objects

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Clear Method

Remove all groups from control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Contains Method

Determines whether a element is contained within the control's collection of groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Contains( _
   ByVal oGroup As ListBarGroup _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Contains(
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ListBarGroup

The ListBarGroup to check if present.

Return Value

True if the ListBarGroup is contained within the control's collection, False otherwise.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.IndexOf Method

ListBarGroups Class See Also

Gets the index of the specified Group within this collection.

Overload List
Name | Description
IndexOf(ListBarGroup) | Gets the index of the specified Group within this collection.
IndexOf(string) | Gets the index of the specified Group key within this collection.
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Insert Method

Inserts a Group at the specified index in the collection of groups.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Insert( _
   ByVal Index As Integer, _
   ByVal oGroup As ListBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Insert(
   int Index,
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

The 0-based index to insert the group at.

oGroup

Type: ListBarGroup

The ListBarGroup to add.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.InsertAfter Method

Inserts a Group immediately after the specified ListBarGroup.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertAfter( _
   ByVal oGroupAfter As ListBarGroup, _
   ByVal oGroup As ListBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertAfter(
   ListBarGroup oGroupAfter,
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroupAfter

Type: ListBarGroup

ListBarGroup to insert after.

oGroup

Type: ListBarGroup

Group to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.InsertBefore Method

Inserts a Group immediately before the specified Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertBefore( _
   ByVal oGroupBefore As ListBarGroup, _
   ByVal oGroup As ListBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertBefore(
   ListBarGroup oGroupBefore,
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroupBefore

Type: ListBarGroup

ListBarGroup to insert before.

oGroup

Type: ListBarGroup

Group to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Remove Method

ListBarGroups Class See Also

Removes the specified Group .

Overload List
Name | Description
Remove(int) | Removes the specified Index.
Remove(string) | Removes group with specified key.
Remove(ListBarGroup) | Removes the specified Group .
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarItem Class

Members

A class containing the information describing an Item in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
<DesignTimeVisible(False)> _
<ToolboxItem(False)> _
Public Class ListBarItem
    Inherits Component
    Implements IComparable, _
               IListBarMouseObject
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
[DesignTimeVisible(False)]
[ToolboxItem(False)]
public class ListBarItem : Component,
   IComparable,
   IListBarMouseObject
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Softgroup.NetControls.ListBarItem
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Members


ListBarItem Members

ListBarItem Class Constructors Events Methods Properties See Also

A class containing the information describing an Item in the ListBar control.

The following tables list the members exposed by the ListBarItem type.

Constructors
 | Name | Description
Public constructor | ListBarItem Constructor | (Overloaded) Create a new ListBarItem object.
Top
Properties
 | Name | Description
Public property | Container | (inherited from Component).
Public property | ContextMenuStrip | Gets/Sets ContextMenuStrip associated to this item.
 | DefaultForeColor | Gets default foreground colour for this item.
Public property | Enabled | Gets/sets whether this item is enabled.
Public property | Font | Gets/sets the font used for this object. The default font is null which means the item renders using the font of the parent control.
Public property | ForeColor | Gets/sets the foreground colour for this item.
Public property | GetItemRectangle | Gets Item Recangle bounds.
Public property | Height | Gets the height of this item.
Public property | Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Public property | LargeImage | Gets/Sets the large image displayed with this item.
Public property | ListBar | Gets a referenct to ListBar control
Public property | Location | Gets the location for this item in the control.
Public property | MouseOver | Gets whether the mouse is over this item.
Public property | Selected | Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.
Public property | Site | (inherited from Component).
Public property | SmallImage | Gets/Sets the small image displayed with this item.
Public property | Tag | Gets/sets an object which can be used to associate user-defined data with this item.
Public property | Text | Gets/sets the caption displayed for this item.
Public property | ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this item.
Public property | Width | Gets the width of this item.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of this object
Public method | CompareTo | Compares this object with another object of the same type.
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | EnsureVisible | Ensures that this item can be seen in the owner control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLargeImage | Get actual image used to drawn item with large image state.
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetSmallImage | Get actual image used to drawn item with small image state.
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
Events
 | Name | Description
Public event | Click | Raised when an oItem has been clicked in the ListBar control.
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | Raised when an oItem has been double clicked in the ListBar control.
Top
See Also

Reference

ListBarItem Class


ListBarItem Constructor

ListBarItem Class See Also

Create a new ListBarItem object.

Overload List
Name | Description
ListBarItem() | Create a new ListBarItem object.
ListBarItem(string) | Create a new ListBarItem object.
ListBarItem(string, Image, Image) | Create a new ListBarItem object.
ListBarItem(string, string, Image, Image) | Create a new ListBarItem object.
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Properties

ListBarItem Class See Also

The following tables list the members exposed by the ListBarItem type.

Properties
 | Name | Description
Public property | Container | (inherited from Component).
Public property | ContextMenuStrip | Gets/Sets ContextMenuStrip associated to this item.
 | DefaultForeColor | Gets default foreground colour for this item.
Public property | Enabled | Gets/sets whether this item is enabled.
Public property | Font | Gets/sets the font used for this object. The default font is null which means the item renders using the font of the parent control.
Public property | ForeColor | Gets/sets the foreground colour for this item.
Public property | GetItemRectangle | Gets Item Recangle bounds.
Public property | Height | Gets the height of this item.
Public property | Key | Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.
Public property | LargeImage | Gets/Sets the large image displayed with this item.
Public property | ListBar | Gets a referenct to ListBar control
Public property | Location | Gets the location for this item in the control.
Public property | MouseOver | Gets whether the mouse is over this item.
Public property | Selected | Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.
Public property | Site | (inherited from Component).
Public property | SmallImage | Gets/Sets the small image displayed with this item.
Public property | Tag | Gets/sets an object which can be used to associate user-defined data with this item.
Public property | Text | Gets/sets the caption displayed for this item.
Public property | ToolTipText | Gets/sets the tooltip text that will be displayed when the user hovers over this item.
Public property | Width | Gets the width of this item.
Top
See Also

Reference

ListBarItem Class


ListBarItem.ContextMenuStrip Property

Gets/Sets ContextMenuStrip associated to this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets ContextMenuStrip associated to this item.")> _
<DefaultValue(CStr(Nothing))> _
<Browsable(False)> _
Public Property ContextMenuStrip( _
   ByRef CStr As Object _
) As ContextMenuStrip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets ContextMenuStrip associated to this item.")]
[DefaultValue(CStr(Nothing))]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ContextMenuStrip")]
public ContextMenuStrip this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.DefaultForeColor Property

Gets default foreground colour for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default foreground colour for this item.")> _
Public ReadOnly Shared Property DefaultForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default foreground colour for this item.")]
public static Color DefaultForeColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Enabled Property

Gets/sets whether this item is enabled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(True)> _
<Description("Gets/sets whether this item is enabled.")> _
<Category("NetListBar")> _
Public Property Enabled( _
   ByRef "Gets/sets whether this item is enabled." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(True)]
[Description("Gets/sets whether this item is enabled.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Enabled")]
public bool this[
   ref object "Gets/sets whether this item is enabled."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether this item is enabled."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Font Property

Gets/sets the font used for this object. The default font is null which means the item renders using the font of the parent control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/sets the font used for this object.  The default font is null which means the item renders using the font of the parent control.")> _
<DefaultValue(CStr(Nothing))> _
<Category("NetListBar")> _
Public Property Font( _
   ByRef CStr As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets the font used for this object.  The default font is null which means the item renders using the font of the parent control.")]
[DefaultValue(CStr(Nothing))]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.ForeColor Property

Gets/sets the foreground colour for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "ControlText")> _
<Description("Gets/sets the foreground colour for this item.")> _
<Category("NetListBar")> _
Public Property ForeColor( _
   ByRef "Gets/sets the foreground colour for this item." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "ControlText")]
[Description("Gets/sets the foreground colour for this item.")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object "Gets/sets the foreground colour for this item."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the foreground colour for this item."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.GetItemRectangle Property

Gets Item Recangle bounds.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property GetItemRectangle() As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
public Rectangle GetItemRectangle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Height Property

Gets the height of this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets the height of this item.")> _
<Browsable(False)> _
Public ReadOnly Property Height( _
   ByRef False As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets the height of this item.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Height")]
public int this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Key Property

Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.")> _
<DefaultValue("")> _
<Category("NetListBar")> _
Public Property Key( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets a user-defined string value which can be used to look up the item in the collection which owns it.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Key")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.LargeImage Property

Gets/Sets the large image displayed with this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the large image displayed with this item.")> _
<Category("NetListBar")> _
<DefaultValue(CStr(Nothing))> _
Public Property LargeImage( _
   ByRef "NetListBar" As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the large image displayed with this item.")]
[Category("NetListBar")]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("LargeImage")]
public Image this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.ListBar Property

Gets a referenct to ListBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Description("Gets a referenct to ListBar control")> _
<Browsable(False)> _
Public Property ListBar( _
   ByRef "Gets a referenct to ListBar control" As Object _
) As ListBar
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Description("Gets a referenct to ListBar control")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ListBar")]
public ListBar this[
   ref object "Gets a referenct to ListBar control"
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets a referenct to ListBar control"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Location Property

Gets the location for this item in the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets the location for this item in the control.")> _
<Browsable(False)> _
Public Property Location( _
   ByRef "Gets the location for this item in the control." As Object _
) As Point
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets the location for this item in the control.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Location")]
public Point this[
   ref object "Gets the location for this item in the control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the location for this item in the control."

Type: object

Remarks

The location is relative to the group the item belongs to. Therefore to find the position relative to the control you need to add the bottom position of the button rectangle for the group and the scroll offset of the item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.MouseOver Property

Gets whether the mouse is over this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets whether the mouse is over this item.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("MouseOver")]
public bool this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Selected Property

Gets/sets whether this item is "selected" or not. Only one item in the ListBar control can be selected at a time.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets/sets whether this item is ""selected"" or not. Only one item in the ListBar control can be selected at a time.")> _
<Browsable(False)> _
Public Property Selected( _
   ByRef "Gets/sets whether this item is ""selected"" or not. Only one item in the ListBar control can be selected at a time." As Object _
) As Boolean
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets whether this item is ""selected"" or not. Only one item in the ListBar control can be selected at a time.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Selected")]
public bool this[
   ref object "Gets/sets whether this item is ""selected"" or not. Only one item in the ListBar control can be selected at a time."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether this item is ""selected"" or not. Only one item in the ListBar control can be selected at a time."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.SmallImage Property

Gets/Sets the small image displayed with this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the small image displayed with this item.")> _
<Category("NetListBar")> _
<DefaultValue(CStr(Nothing))> _
Public Property SmallImage( _
   ByRef "NetListBar" As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the small image displayed with this item.")]
[Category("NetListBar")]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("SmallImage")]
public Image this[
   ref object "NetListBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetListBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Tag Property

Gets/sets an object which can be used to associate user-defined data with this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets/sets an object which can be used to associate user-defined data with this item.")> _
<Category("NetListBar")> _
<DefaultValue(CStr(Nothing))> _
<Browsable(False)> _
Public Property Tag( _
   ByRef "Gets/sets an object which can be used to associate user-defined data with this item." As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/sets an object which can be used to associate user-defined data with this item.")]
[Category("NetListBar")]
[DefaultValue(CStr(Nothing))]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Tag")]
public object this[
   ref object "Gets/sets an object which can be used to associate user-defined data with this item."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets an object which can be used to associate user-defined data with this item."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Text Property

Gets/sets the caption displayed for this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/sets the caption displayed for this item.")> _
<DefaultValue("")> _
<Category("NetListBar")> _
Public Property Text( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets the caption displayed for this item.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.ToolTipText Property

Gets/sets the tooltip text that will be displayed when the user hovers over this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[Description("Gets/sets the tooltip text that will be displayed when the user hovers over this item.")]
[DefaultValue("")]
[Category("NetListBar")]
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.Width Property

Gets the width of this item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets the width of this item.")> _
<Browsable(False)> _
Public Property Width( _
   ByRef "Gets the width of this item." As Object _
) As Integer
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets the width of this item.")]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Width")]
public int this[
   ref object "Gets the width of this item."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the width of this item."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Methods

ListBarItem Class See Also

The following tables list the members exposed by the ListBarItem type.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of this object
Public method | CompareTo | Compares this object with another object of the same type.
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | EnsureVisible | Ensures that this item can be seen in the owner control.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLargeImage | Get actual image used to drawn item with large image state.
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetSmallImage | Get actual image used to drawn item with small image state.
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
See Also

Reference

ListBarItem Class


ListBarItem.Clone Method

Returns a deep clone of this object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Returns a deep clone of this object")> _
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Returns a deep clone of this object")]
public object Clone()
This language is not supported or no code example is available.

Implements

ICloneable.Clone
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.CompareTo Method

Compares this object with another object of the same type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Compares this object with another object of the same type.")> _
Public Function CompareTo( _
   ByVal oItem As Object _
) As Integer Implements  _
   IComparable.CompareTo
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Compares this object with another object of the same type.")]
public int CompareTo(
   object oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: object

Another ListBarItem object

Implements

IComparable.CompareTo
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.EnsureVisible Method

Ensures that this item can be seen in the owner control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Ensures that this item can be seen in the owner control.")> _
Public Sub EnsureVisible()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Ensures that this item can be seen in the owner control.")]
public System.Void EnsureVisible()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.GetLargeImage Method

Get actual image used to drawn item with large image state.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetLargeImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Image GetLargeImage()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem.GetSmallImage Method

Get actual image used to drawn item with small image state.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetSmallImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Image GetSmallImage()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Events

ListBarItem Class See Also

The following tables list the members exposed by the ListBarItem type.

Events
 | Name | Description
Public event | Click | Raised when an oItem has been clicked in the ListBar control.
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | Raised when an oItem has been double clicked in the ListBar control.
Top
See Also

Reference

ListBarItem Class


Click Event

Raised when an oItem has been clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Click( _
   ByVal sender As Object, _
   ByVal e As ListBarItemClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClickEventHandler Click
delegate void ClickEventHandler(
   object sender,
   ListBarItemClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarItemClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


DoubleClick Event

Raised when an oItem has been double clicked in the ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event DoubleClick( _
   ByVal sender As Object, _
   ByVal e As ListBarItemDoubleClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event DoubleClickEventHandler DoubleClick
delegate void DoubleClickEventHandler(
   object sender,
   ListBarItemDoubleClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: ListBarItemDoubleClickEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItemClickEventArgs Class

Members

Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBarItemClickEventArgs
    Inherits ListBarClickedEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBarItemClickEventArgs : ListBarClickedEventArgs
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItemClickEventArgs Members


ListBarItemClickEventArgs Members

ListBarItemClickEventArgs Class Methods Properties See Also

Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar

The following tables list the members exposed by the ListBarItemClickEventArgs type.

Properties
 | Name | Description
Public property | ContextMenuStrip | Gets/Sets a ContextMenuStrip to display at current mouse position.
Public property | Item | Gets the ListBarItem that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItemClickEventArgs Class


ListBarItemClickEventArgs Properties

ListBarItemClickEventArgs Class See Also

The following tables list the members exposed by the ListBarItemClickEventArgs type.

Properties
 | Name | Description
Public property | ContextMenuStrip | Gets/Sets a ContextMenuStrip to display at current mouse position.
Public property | Item | Gets the ListBarItem that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
See Also

Reference

ListBarItemClickEventArgs Class


ListBarItemClickEventArgs.ContextMenuStrip Property

Gets/Sets a ContextMenuStrip to display at current mouse position.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets a ContextMenuStrip to display at current mouse position.")> _
Public Property ContextMenuStrip() As ContextMenuStrip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets a ContextMenuStrip to display at current mouse position.")]
public ContextMenuStrip ContextMenuStrip {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItemClickEventArgs Class
ListBarItemClickEventArgs Members


ListBarItemClickEventArgs.Item Property

Gets the ListBarItem that has been clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ListBarItem that has been clicked.")> _
Public ReadOnly Property Item() As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ListBarItem that has been clicked.")]
public ListBarItem Item {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItemClickEventArgs Class
ListBarItemClickEventArgs Members


ListBarItemClickEventArgs Methods

ListBarItemClickEventArgs Class See Also

The following tables list the members exposed by the ListBarItemClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItemClickEventArgs Class


ListBarItemDoubleClickEventArgs Class

Members

Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBarItemDoubleClickEventArgs
    Inherits ListBarClickedEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBarItemDoubleClickEventArgs : ListBarClickedEventArgs
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItemDoubleClickEventArgs Members


ListBarItemDoubleClickEventArgs Members

ListBarItemDoubleClickEventArgs Class Methods Properties See Also

Provides details of which item has been clicked and the mouse details of the click when the ItemClick event is raised from a ListBar

The following tables list the members exposed by the ListBarItemDoubleClickEventArgs type.

Properties
 | Name | Description
Public property | Item | Gets the ListBarItem that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItemDoubleClickEventArgs Class


ListBarItemDoubleClickEventArgs Properties

ListBarItemDoubleClickEventArgs Class See Also

The following tables list the members exposed by the ListBarItemDoubleClickEventArgs type.

Properties
 | Name | Description
Public property | Item | Gets the ListBarItem that has been clicked.
Public property | Location | The Location of the mouse, relative to the control, when the item was clicked. (inherited from ListBarClickedEventArgs).
Public property | MouseButton | The MouseButton used to click the item. (inherited from ListBarClickedEventArgs).
Top
See Also

Reference

ListBarItemDoubleClickEventArgs Class


ListBarItemDoubleClickEventArgs.Item Property

Gets the ListBarItem that has been clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ListBarItem that has been clicked.")> _
Public ReadOnly Property Item() As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ListBarItem that has been clicked.")]
public ListBarItem Item {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItemDoubleClickEventArgs Class
ListBarItemDoubleClickEventArgs Members


ListBarItemDoubleClickEventArgs Methods

ListBarItemDoubleClickEventArgs Class See Also

The following tables list the members exposed by the ListBarItemDoubleClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItemDoubleClickEventArgs Class


ListBarItems Class

Members

The collection class of Items within a ListBarGroup of ListBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Serializable()> _
Public Class ListBarItems
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Serializable()]
public class ListBarItems : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.ListBarItems
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Members


ListBarItems Members

ListBarItems Class Methods Properties See Also

The collection class of Items within a ListBarGroup of ListBar control.

The following tables list the members exposed by the ListBarItems type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ListBarItem at the specified index.
Public property | ListBar | Gets a referenct to ListBar control
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new empty Item object into the Group.
Public method | AddRange | Adds a list of ListBarItem into the Group.
Public method | Clear | Remove all groups from control
Public method | Contains | Returns true if the specified is contained within this collection, otherwise false.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Returns the index of the specified item in the collection if present, -1 otherwise.
Public method | Insert | Inserts an item at the specified index in the bar.
Public method | InsertAfter | Inserts an item immediately after the specified ListBarItem.
Public method | InsertBefore | Inserts an item immediately before the specified ListBarItem.
Public method | Remove | (Overloaded) Removes the specified item from the collection.
Public method | RemoveAt | Removes the specified index from the collection.
Public method | Sort | (Overloaded) Sorts the items in this collection using the specified comparer.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItems Class


ListBarItems Properties

ListBarItems Class See Also

The following tables list the members exposed by the ListBarItems type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | (Overloaded) Gets the ListBarItem at the specified index.
Public property | ListBar | Gets a referenct to ListBar control
Top
See Also

Reference

ListBarItems Class


ListBarItems.Item Property

ListBarItems Class See Also

Gets the ListBarItem at the specified index.

Overload List
Name | Description
this[int] | Gets the ListBarItem at the specified index.
this[string] | Gets the ListBarItem with specified key.
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.ListBar Property

Gets a referenct to ListBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public Property ListBar( _
   ByRef False As Object _
) As ListBar
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ListBar")]
public ListBar this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems Methods

ListBarItems Class See Also

The following tables list the members exposed by the ListBarItems type.

Methods
 | Name | Description
Public method | Add | (Overloaded) Adds a new empty Item object into the Group.
Public method | AddRange | Adds a list of ListBarItem into the Group.
Public method | Clear | Remove all groups from control
Public method | Contains | Returns true if the specified is contained within this collection, otherwise false.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | (Overloaded) Returns the index of the specified item in the collection if present, -1 otherwise.
Public method | Insert | Inserts an item at the specified index in the bar.
Public method | InsertAfter | Inserts an item immediately after the specified ListBarItem.
Public method | InsertBefore | Inserts an item immediately before the specified ListBarItem.
Public method | Remove | (Overloaded) Removes the specified item from the collection.
Public method | RemoveAt | Removes the specified index from the collection.
Public method | Sort | (Overloaded) Sorts the items in this collection using the specified comparer.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ListBarItems Class


ListBarItems.Add Method

ListBarItems Class See Also

Adds a new empty Item object into the Group.

Overload List
Name | Description
Add() | Adds a new empty Item object into the Group.
Add(ListBarItem) | Adds specified ListBarItem object in the group.
Add(string) | Adds a new ListBarItem object in the group with specified Text.
Add(string, string) | Adds a new ListBarItem object in the group with specified Text and Key.
Add(string, string, Image, Image) | Adds a new ListBarItem object in the group with specified Text, Key, Small and Large image.
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.AddRange Method

Adds a list of ListBarItem into the Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddRange( _
   ByVal oItems As ListBarItem() _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddRange(
   ListBarItem[] oItems
)
This language is not supported or no code example is available.

Parameters

oItems

Type: ListBarItem[]

A valid array of ListBarItem objects

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Clear Method

Remove all groups from control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Contains Method

Returns true if the specified is contained within this collection, otherwise false.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Contains( _
   ByVal oItem As ListBarItem _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Contains(
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ListBarItem

The ListBarItem to check.

Return Value

True if the specified ListBarItem is contained within this collection, False otherwise.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.IndexOf Method

ListBarItems Class See Also

Returns the index of the specified item in the collection if present, -1 otherwise.

Overload List
Name | Description
IndexOf(ListBarItem) | Returns the index of the specified item in the collection if present, -1 otherwise.
IndexOf(string) | Gets the index of the specified Item key within this collection.
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Insert Method

Inserts an item at the specified index in the bar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Insert( _
   ByVal Index As Integer, _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Insert(
   int Index,
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

The index to insert at.

oItem

Type: ListBarItem

The ListBarItem to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.InsertAfter Method

Inserts an item immediately after the specified ListBarItem.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertAfter( _
   ByVal oItemAfter As ListBarItem, _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertAfter(
   ListBarItem oItemAfter,
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItemAfter

Type: ListBarItem

ListBarItem to insert after.

oItem

Type: ListBarItem

Item to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.InsertBefore Method

Inserts an item immediately before the specified ListBarItem.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub InsertBefore( _
   ByVal oItemBefore As ListBarItem, _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void InsertBefore(
   ListBarItem oItemBefore,
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItemBefore

Type: ListBarItem

ListBarItem to insert before.

oItem

Type: ListBarItem

Item to insert.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Remove Method

ListBarItems Class See Also

Removes the specified item from the collection.

Overload List
Name | Description
Remove(string) | Removes the specified key from the collection.
Remove(ListBarItem) | Removes the specified item from the collection.
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.RemoveAt Method

Removes the specified index from the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub RemoveAt( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveAt(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Sort Method

ListBarItems Class See Also

Sorts the items in this collection using the specified comparer.

Overload List
Name | Description
Sort() | Sorts the items in this collection using the default comparison operation (alphabetic).
Sort(IComparer) | Sorts the items in this collection using the specified comparer.
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBoxImageItem Class

Members

This class rappresent as item od ListBoxImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ListBoxImageItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ListBoxImageItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.ListBoxImageItem
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Members


ListBoxImageItem Members

ListBoxImageItem Class Constructors Methods Properties See Also

This class rappresent as item od ListBoxImage

The following tables list the members exposed by the ListBoxImageItem type.

Constructors
 | Name | Description
Public constructor | ListBoxImageItem Constructor | (Overloaded) Create new instance of the class
Top
Properties
 | Name | Description
Public property | ImageIndex | Gets/Sets image index of item
Public property | ImageKey | Gets/Sets Image of item
Public property | Text | Gets/Text image key of item
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Converts a ListBoxImage object to a string
Top
See Also

Reference

ListBoxImageItem Class


ListBoxImageItem Constructor

ListBoxImageItem Class See Also

Create new instance of the class

Overload List
Name | Description
ListBoxImageItem(string) | Create new instance of the class
ListBoxImageItem(string, int) | Create new instance of the class
ListBoxImageItem(string, string) | Create new instance of the class
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImageItem Properties

ListBoxImageItem Class See Also

The following tables list the members exposed by the ListBoxImageItem type.

Properties
 | Name | Description
Public property | ImageIndex | Gets/Sets image index of item
Public property | ImageKey | Gets/Sets Image of item
Public property | Text | Gets/Text image key of item
Top
See Also

Reference

ListBoxImageItem Class


ListBoxImageItem.ImageIndex Property

Gets/Sets image index of item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property ImageIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int ImageIndex {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImageItem.ImageKey Property

Gets/Sets Image of item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property ImageKey() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string ImageKey {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImageItem.Text Property

Gets/Text image key of item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string Text {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImageItem Methods

ListBoxImageItem Class See Also

The following tables list the members exposed by the ListBoxImageItem type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetHashCode | Funge da funzione hash per un determinato tipo. (inherited from Object).
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Converts a ListBoxImage object to a string
Top
See Also

Reference

ListBoxImageItem Class


ListBoxImageItem.ToString Method

Converts a ListBoxImage object to a string

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Function ToString() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override string ToString()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImages Class

Members

Softgroup .Net LisBox Images is an advanced ListBox that display images with text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.ListBoxImages), "ListBoxIMages.bmp")> _
<System.ComponentModel.DefaultEvent("SelectedIndexChanged")> _
<System.ComponentModel.DefaultProperty("Item")> _
Public Class ListBoxImages
    Inherits ListBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.ListBoxImages), "ListBoxIMages.bmp")]
[System.ComponentModel.DefaultEvent("SelectedIndexChanged")]
[System.ComponentModel.DefaultProperty("Item")]
public class ListBoxImages : ListBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
Softgroup.NetControls.ListBoxImages
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Members


ListBoxImages Members

ListBoxImages Class Events Methods Properties See Also

Softgroup .Net LisBox Images is an advanced ListBox that display images with text.

The following tables list the members exposed by the ListBoxImages type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ListBox).
Public property | BackgroundImage | (inherited from ListBox).
Public property | BackgroundImageLayout | (inherited from ListBox).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from ListBox).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColumnWidth | (inherited from ListBox).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | CustomTabOffsets | (inherited from ListBox).
Public property | DataBindings | (inherited from Control).
Public property | DataSource | (inherited from ListControl).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayMember | (inherited from ListControl).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from ListBox).
Public property | ForeColor | (inherited from ListBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalExtent | (inherited from ListBox).
Public property | HorizontalScrollbar | (inherited from ListBox).
Public property | ImageList | Gets/Sets ImageList control used to store listbox items images
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | Item | Gets the ListBoxImageItem at the specified index
Public property | ItemHeight | (inherited from ListBox).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | MultiColumn | (inherited from ListBox).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ListBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ListBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from ListBox).
Public property | ScrollAlwaysVisible | (inherited from ListBox).
Public property | SelectedIndex | (inherited from ListBox).
Public property | SelectedIndices | (inherited from ListBox).
Public property | SelectedItem | (inherited from ListBox).
Public property | SelectedItems | (inherited from ListBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionMode | (inherited from ListBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ListBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from ListBox).
Public property | Top | (inherited from Control).
Public property | TopIndex | (inherited from ListBox).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCustomTabOffsets | (inherited from ListBox).
Public property | UseTabStops | (inherited from ListBox).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | AddItem | (Overloaded) Add a new item to listbox with specified text
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ListBox).
Public method | ClearSelected | (inherited from ListBox).
Public method | EndUpdate | (inherited from ListBox).
Public method | FindString | (Overloaded)
Public method | FindStringExact | (Overloaded)
Public method | GetItemHeight | (inherited from ListBox).
Public method | GetItemRectangle | (inherited from ListBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetSelected | (inherited from ListBox).
Public method | IndexFromPoint | (Overloaded) (inherited from ListBox).
Public method | Refresh | (inherited from ListBox).
Public method | RemoveItem | (Overloaded) Remove from listbox specified item
Public method | ResetBackColor | (inherited from ListBox).
Public method | ResetBindings | (inherited from Control).
Public method | ResetForeColor | (inherited from ListBox).
Public method | SetImage | (Overloaded) Change image index of specified item
Public method | SetSelected | (inherited from ListBox).
Public method | SetText | Change text of specified item
Public method | SetTextImage | (Overloaded) Change text and image index of specified item
Public method | ToString | (inherited from ListBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ListBox).
Public event | BackgroundImageLayoutChanged | (inherited from ListBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from ListBox).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | Occurs when .
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | Occurs when .
Public event | FormatStringChanged | Occurs when .
Public event | FormattingEnabledChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MeasureItem | (inherited from ListBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from ListBox).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ListBox).
Public event | Paint | (inherited from ListBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ListBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from ListBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ListBoxImages Class


ListBoxImages Properties

ListBoxImages Class See Also

The following tables list the members exposed by the ListBoxImages type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from ListBox).
Public property | BackgroundImage | (inherited from ListBox).
Public property | BackgroundImageLayout | (inherited from ListBox).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from ListBox).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColumnWidth | (inherited from ListBox).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | CustomTabOffsets | (inherited from ListBox).
Public property | DataBindings | (inherited from Control).
Public property | DataSource | (inherited from ListControl).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayMember | (inherited from ListControl).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from ListBox).
Public property | ForeColor | (inherited from ListBox).
Public property | FormatInfo | (Overloaded) Gets or sets .
Public property | FormatString | (Overloaded) Gets or sets .
Public property | FormattingEnabled | (Overloaded) Gets or sets a value indicating whether .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalExtent | (inherited from ListBox).
Public property | HorizontalScrollbar | (inherited from ListBox).
Public property | ImageList | Gets/Sets ImageList control used to store listbox items images
Public property | ImeMode | (inherited from Control).
Public property | IntegralHeight | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | Item | Gets the ListBoxImageItem at the specified index
Public property | ItemHeight | (inherited from ListBox).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | MultiColumn | (inherited from ListBox).
Public property | Name | (inherited from Control).
Public property | Padding | (inherited from ListBox).
Public property | Parent | (inherited from Control).
Public property | PreferredHeight | (inherited from ListBox).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from ListBox).
Public property | ScrollAlwaysVisible | (inherited from ListBox).
Public property | SelectedIndex | (inherited from ListBox).
Public property | SelectedIndices | (inherited from ListBox).
Public property | SelectedItem | (inherited from ListBox).
Public property | SelectedItems | (inherited from ListBox).
Public property | SelectedValue | (inherited from ListControl).
Public property | SelectionMode | (inherited from ListBox).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Sorted | (inherited from ListBox).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from ListBox).
Public property | Top | (inherited from Control).
Public property | TopIndex | (inherited from ListBox).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCustomTabOffsets | (inherited from ListBox).
Public property | UseTabStops | (inherited from ListBox).
Public property | UseWaitCursor | (inherited from Control).
Public property | ValueMember | (inherited from ListControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ListBoxImages Class


ListBoxImages.DrawMode Property

ListBoxImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.ListBox).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormatInfo Property

ListBoxImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatInfo | (System.Windows.Forms.ListControl).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormatString Property

ListBoxImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
FormatString | (System.Windows.Forms.ListControl).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormattingEnabled Property

ListBoxImages Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
FormattingEnabled | (System.Windows.Forms.ListControl).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.ImageList Property

Gets/Sets ImageList control used to store listbox items images

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property ImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ImageList ImageList {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.IntegralHeight Property

ListBoxImages Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
IntegralHeight | (System.Windows.Forms.ListBox).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.Item Property

Gets the ListBoxImageItem at the specified index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ListBoxImageItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public ListBoxImageItem this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.Items Property

ListBoxImages Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
Items | (System.Windows.Forms.ListBox).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages Methods

ListBoxImages Class See Also

The following tables list the members exposed by the ListBoxImages type.

Methods
 | Name | Description
Public method | AddItem | (Overloaded) Add a new item to listbox with specified text
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | BeginUpdate | (inherited from ListBox).
Public method | ClearSelected | (inherited from ListBox).
Public method | EndUpdate | (inherited from ListBox).
Public method | FindString | (Overloaded)
Public method | FindStringExact | (Overloaded)
Public method | GetItemHeight | (inherited from ListBox).
Public method | GetItemRectangle | (inherited from ListBox).
Public method | GetItemText | (inherited from ListControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetSelected | (inherited from ListBox).
Public method | IndexFromPoint | (Overloaded) (inherited from ListBox).
Public method | Refresh | (inherited from ListBox).
Public method | RemoveItem | (Overloaded) Remove from listbox specified item
Public method | ResetBackColor | (inherited from ListBox).
Public method | ResetBindings | (inherited from Control).
Public method | ResetForeColor | (inherited from ListBox).
Public method | SetImage | (Overloaded) Change image index of specified item
Public method | SetSelected | (inherited from ListBox).
Public method | SetText | Change text of specified item
Public method | SetTextImage | (Overloaded) Change text and image index of specified item
Public method | ToString | (inherited from ListBox).
Top
See Also

Reference

ListBoxImages Class


ListBoxImages.AddItem Method

ListBoxImages Class See Also

Add a new item to listbox with specified text

Overload List
Name | Description
AddItem(string) | Add a new item to listbox with specified text
AddItem(string, int) | Add a new item to listbox with specified text and image index
AddItem(string, string) | Add a new item to listbox with specified text and image key
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindString Method

ListBoxImages Class See Also

Overload List
Name | Description
FindString(string) |
FindString(string, int) |
FindString(String,Int32) | (System.Windows.Forms.ListBox).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindStringExact Method

ListBoxImages Class See Also

Overload List
Name | Description
FindStringExact(string) |
FindStringExact(string, int) |
FindStringExact(String,Int32) | (System.Windows.Forms.ListBox).
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.RemoveItem Method

ListBoxImages Class See Also

Remove from listbox specified item

Overload List
Name | Description
RemoveItem(int) | Remove from listbox specified item index
RemoveItem(ListBoxImageItem) | Remove from listbox specified item
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetImage Method

ListBoxImages Class See Also

Change image index of specified item

Overload List
Name | Description
SetImage(int, int) | Change image index of specified item
SetImage(int, string) | Change image index of specified item
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetText Method

Change text of specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetText( _
   ByVal Index As Integer, _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetText(
   int Index,
   string sText
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

sText

Type: string

Item text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetTextImage Method

ListBoxImages Class See Also

Change text and image index of specified item

Overload List
Name | Description
SetTextImage(int, string, int) | Change text and image index of specified item
SetTextImage(int, string, string) | Change text and image key of specified item
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages Events

ListBoxImages Class See Also

The following tables list the members exposed by the ListBoxImages type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from ListBox).
Public event | BackgroundImageLayoutChanged | (inherited from ListBox).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from ListBox).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | DataSourceChanged | (inherited from ListControl).
Public event | DisplayMemberChanged | (inherited from ListControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | Occurs when .
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | Format | (inherited from ListControl).
Public event | FormatInfoChanged | Occurs when .
Public event | FormatStringChanged | Occurs when .
Public event | FormattingEnabledChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MeasureItem | (inherited from ListBox).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from ListBox).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from ListBox).
Public event | Paint | (inherited from ListBox).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SelectedIndexChanged | (inherited from ListBox).
Public event | SelectedValueChanged | (inherited from ListControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from ListBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueMemberChanged | (inherited from ListControl).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ListBoxImages Class


DrawItem Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event DrawItem( _
   ByVal sender As Object, _
   ByVal e As DrawItemEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event DrawItemEventHandler DrawItem
delegate void DrawItemEventHandler(
   object sender,
   DrawItemEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: DrawItemEventArgs

An DrawItemEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


FormatInfoChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event FormatInfoChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event FormatInfoChangedEventHandler FormatInfoChanged
delegate void FormatInfoChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


FormatStringChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event FormatStringChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event FormatStringChangedEventHandler FormatStringChanged
delegate void FormatStringChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


FormattingEnabledChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event FormattingEnabledChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event FormattingEnabledChangedEventHandler FormattingEnabledChanged
delegate void FormattingEnabledChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


NetAnimation Class

Members

Softgroup NetAnimation Control is a fast, small, lightweight and easy to use .NET control that can play an Audio-Video Interleaved (AVI) file or any OS system animation.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetAnimation), "NetAnimation.bmp")> _
<DefaultProperty("FileName")> _
<DefaultEvent("StateChanged")> _
Public Class NetAnimation
    Inherits CommonControlBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetAnimation), "NetAnimation.bmp")]
[DefaultProperty("FileName")]
[DefaultEvent("StateChanged")]
public class NetAnimation : CommonControlBase
This language is not supported or no code example is available.
Remarks

To add a Softgroup NetAnimation Control to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Members


NetAnimation Members

NetAnimation Class Events Methods Properties See Also

Softgroup NetAnimation Control is a fast, small, lightweight and easy to use .NET control that can play an Audio-Video Interleaved (AVI) file or any OS system animation.

The following tables list the members exposed by the NetAnimation type.

Properties
 | Name | Description
Public property | AnimationMode | Gets/sets the source of the animation
Public property | AutoCenter | Gets/sets whether the animation is centered in the control
Public property | AutoPlay | Gets/sets whether the animation should automatically play
Public property | BorderStyle | Border style rendered around the control.
Public property | FileName | Gets/sets the filename of the animation to play
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | ImeMode | Gets or sets .
Public property | IsOpen | Indicates if an animation is currently opened
Public property | Playing | Indicates if the animation is currently playing
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Text | Gets or sets .
Public property | Transparent | Gets/sets whether the animation is displayed transparently
Public property | UseTimer | Gets/sets whether the animation is played using a timer instead of a separate thread.
Top
Methods
 | Name | Description
Public method | Close | Closes the currently opened animation file
Public method | Open | (Overloaded) Opens the specified avi animation file
Public method | Play | (Overloaded) Plays the specified file
Public method | Seek | Positions the animation at the specified frame
Public method | Stop | Stops playing the current animation
Top
Events
 | Name | Description
Public event | StateChanged | Invoked when the animation starts and ends playing.
Top
See Also

Reference

NetAnimation Class


NetAnimation Properties

NetAnimation Class See Also

The following tables list the members exposed by the NetAnimation type.

Properties
 | Name | Description
Public property | AnimationMode | Gets/sets the source of the animation
Public property | AutoCenter | Gets/sets whether the animation is centered in the control
Public property | AutoPlay | Gets/sets whether the animation should automatically play
Public property | BorderStyle | Border style rendered around the control.
Public property | FileName | Gets/sets the filename of the animation to play
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | ImeMode | Gets or sets .
Public property | IsOpen | Indicates if an animation is currently opened
Public property | Playing | Indicates if the animation is currently playing
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Text | Gets or sets .
Public property | Transparent | Gets/sets whether the animation is displayed transparently
Public property | UseTimer | Gets/sets whether the animation is played using a timer instead of a separate thread.
Top
See Also

Reference

NetAnimation Class


NetAnimation.AnimationMode Property

Gets/sets the source of the animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(AnimationModeDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets the source of the animation")> _
Public Property AnimationMode( _
   ByRef "NetAnimation" As Object _
) As AnimationType
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(AnimationModeDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets the source of the animation")]
[System.Runtime.CompilerServices.IndexerName("AnimationMode")]
public AnimationType this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Remarks

<p class="body">The AnimationSource determines which animation will be displayed. When set to AviFile, the animation is obtained from the file specified for the FileName property. Other settings are common operating system animations.</p>

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.AutoCenter Property

Gets/sets whether the animation is centered in the control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(AutoCenterDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets whether the animation is centered in the control")> _
Public Property AutoCenter( _
   ByRef "NetAnimation" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(AutoCenterDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets whether the animation is centered in the control")]
[System.Runtime.CompilerServices.IndexerName("AutoCenter")]
public bool this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Remarks

<p class="body">When set to true, the animation will be centered within the control bounds as the control is resized. When set to false, the animation is sited in the upper left corner of the client area of the control.</p>

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.AutoPlay Property

Gets/sets whether the animation should automatically play

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(AutoPlayDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets whether the animation should automatically play")> _
Public Property AutoPlay( _
   ByRef "NetAnimation" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(AutoPlayDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets whether the animation should automatically play")]
[System.Runtime.CompilerServices.IndexerName("AutoPlay")]
public bool this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Remarks

<p class="body">When set to true, the animation will automatically begin when the handle for the control is created.</p>

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.BorderStyle Property

Border style rendered around the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(BorderStyleDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Border style rendered around the control.")> _
Public Property BorderStyle( _
   ByRef "NetAnimation" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(BorderStyleDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Border style rendered around the control.")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.FileName Property

Gets/sets the filename of the animation to play

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue("")> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets the filename of the animation to play")> _
Public Property FileName( _
   ByRef "NetAnimation" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue("")]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets the filename of the animation to play")]
[System.Runtime.CompilerServices.IndexerName("FileName")]
public string this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Remarks

<p class="body">The FileName property indicates the name of the avi file that should be played when the Play method is invoked. The AnimationSource property should be set to AviFile to use this property.</p>

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Font( _
   ByRef EditorBrowsableState.Never As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef EditorBrowsableState.Never As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.ImeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
<Browsable(False)> _
Public Property ImeMode( _
   ByRef False As Object _
) As ImeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ImeMode")]
public ImeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.IsOpen Property

Indicates if an animation is currently opened

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<System.ComponentModel.Description("Indicates if an animation is currently opened")> _
Public ReadOnly Property IsOpen() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[System.ComponentModel.Description("Indicates if an animation is currently opened")]
public bool IsOpen {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Playing Property

Indicates if the animation is currently playing

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<System.ComponentModel.Description("Indicates if the animation is currently playing")> _
Public ReadOnly Property Playing() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[System.ComponentModel.Description("Indicates if the animation is currently playing")]
public bool Playing {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DefaultValue(False)> _
Public Property TabStop( _
   ByRef EditorBrowsableState.Never As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("TabStop")]
public bool this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Text( _
   ByRef EditorBrowsableState.Never As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Transparent Property

Gets/sets whether the animation is displayed transparently

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(TransparentDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets whether the animation is displayed transparently")> _
Public Property Transparent( _
   ByRef "NetAnimation" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(TransparentDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets whether the animation is displayed transparently")]
[System.Runtime.CompilerServices.IndexerName("Transparent")]
public bool this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.UseTimer Property

Gets/sets whether the animation is played using a timer instead of a separate thread.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(UseTimerDefault)> _
<System.ComponentModel.Category("NetAnimation")> _
<System.ComponentModel.Description("Gets/sets whether the animation is played using a timer instead of a separate thread.")> _
Public Property UseTimer( _
   ByRef "NetAnimation" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(UseTimerDefault)]
[System.ComponentModel.Category("NetAnimation")]
[System.ComponentModel.Description("Gets/sets whether the animation is played using a timer instead of a separate thread.")]
[System.Runtime.CompilerServices.IndexerName("UseTimer")]
public bool this[
   ref object "NetAnimation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetAnimation"

Type: object

Remarks

<p class="body">When set to true, the animation control will use a timer instead of a separate thread to handle changing the frames of the animation.</p>

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation Methods

NetAnimation Class See Also

The following tables list the members exposed by the NetAnimation type.

Methods
 | Name | Description
Public method | Close | Closes the currently opened animation file
Public method | Open | (Overloaded) Opens the specified avi animation file
Public method | Play | (Overloaded) Plays the specified file
Public method | Seek | Positions the animation at the specified frame
Public method | Stop | Stops playing the current animation
Top
See Also

Reference

NetAnimation Class


NetAnimation.Close Method

Closes the currently opened animation file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Closes the currently opened animation file")> _
Public Sub Close()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Closes the currently opened animation file")]
public System.Void Close()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Open Method

NetAnimation Class See Also

Opens the specified avi animation file

Overload List
Name | Description
Open() | Opens the avi animation source specified by the AnimationSource property
Open(string) | Opens the specified avi animation file
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Play Method

NetAnimation Class See Also

Plays the specified file

Overload List
Name | Description
Play(int, int, int) | Plays the AnimationSource a specified number of times starting with a particular frame and ending with a particular frame.
Play(int) | Plays the AnimationSource a specified number of times
Play() | Plays the animation specified by the AnimationSource property
Play(string) | Plays the specified file
Play(string, int) | Plays the specified file
Play(string, int, int, int) | Plays the specified file
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Seek Method

Positions the animation at the specified frame

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Positions the animation at the specified frame")> _
Public Sub Seek( _
   ByVal Frame As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Positions the animation at the specified frame")]
public System.Void Seek(
   int Frame
)
This language is not supported or no code example is available.

Parameters

Frame

Type: int

Frame number

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Stop Method

Stops playing the current animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Stops playing the current animation")> _
Public Sub Stop()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Stops playing the current animation")]
public System.Void Stop()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation Events

NetAnimation Class See Also

The following tables list the members exposed by the NetAnimation type.

Events
 | Name | Description
Public event | StateChanged | Invoked when the animation starts and ends playing.
Top
See Also

Reference

NetAnimation Class


StateChanged Event

Invoked when the animation starts and ends playing.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Invoked when the animation starts and ends playing.")> _
Public Event StateChanged( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Invoked when the animation starts and ends playing.")]
public event StateChangedEventHandler StateChanged
delegate void StateChangedEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetButton Class

Members

Softgroup .Net Button is an enhanced .NET button control that gives your applications a nice gradient and/or light effects.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetButton), "NetButton.bmp")> _
<System.ComponentModel.DefaultProperty("TextButton")> _
<System.ComponentModel.DefaultEvent("Click")> _
Public Class NetButton
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetButton), "NetButton.bmp")]
[System.ComponentModel.DefaultProperty("TextButton")]
[System.ComponentModel.DefaultEvent("Click")]
public class NetButton : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetButton
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Members


NetButton Members

NetButton Class Events Methods Properties See Also

Softgroup .Net Button is an enhanced .NET button control that gives your applications a nice gradient and/or light effects.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

The following tables list the members exposed by the NetButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets or sets .
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorBottom | Gets/Sets the bottom color of the button.
Public property | ColorDisabled | Gets/Sets the disabled color of text button.
Public property | ColorLight | Gets/Sets the light effect colour used when the mouse is inside the button.
Public property | ColorText | Gets/Sets the color of button text.
Public property | ColorTop | Gets/Sets the top colour of the button.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | CornerRadius | Gets/Sets rhe radius for the button corners.
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultColorBottom | Gets the default bottom color.
 | DefaultColorDisabled | Gets the default disabled color.
 | DefaultColorLight | Gets the default light color.
 | DefaultColorText | Gets the default text color.
 | DefaultColorTop | Gets the default top color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | Gets/Sets the dialog-box result produced in a modal form by clicking the button.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets the image displayed on the button.
Public property | ImageAlign | Gets/Sets the alignment of the image displayed in the button.
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | LightEffect | Gets/Sets if light effect is enabled.
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | State | Gets the current state of button.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextButton | Gets/Sets the text that is displayed on the button.
Public property | TextButtonAlign | Gets/Sets the alignment of the text that is displayed on the button.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseMnemonic | Gets/Sets a value indicating whether the control interprets an ampersand character (&) in the control's TextButton property to be an access key prefix character.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | NotifyDefault |
Public method | PerformClick |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextButtonChanged | This event will be raised every time text of button changed
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetButton Class


NetButton Properties

NetButton Class See Also

The following tables list the members exposed by the NetButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets or sets .
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorBottom | Gets/Sets the bottom color of the button.
Public property | ColorDisabled | Gets/Sets the disabled color of text button.
Public property | ColorLight | Gets/Sets the light effect colour used when the mouse is inside the button.
Public property | ColorText | Gets/Sets the color of button text.
Public property | ColorTop | Gets/Sets the top colour of the button.
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | CornerRadius | Gets/Sets rhe radius for the button corners.
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultColorBottom | Gets the default bottom color.
 | DefaultColorDisabled | Gets the default disabled color.
 | DefaultColorLight | Gets the default light color.
 | DefaultColorText | Gets the default text color.
 | DefaultColorTop | Gets the default top color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | Gets/Sets the dialog-box result produced in a modal form by clicking the button.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets the image displayed on the button.
Public property | ImageAlign | Gets/Sets the alignment of the image displayed in the button.
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | LightEffect | Gets/Sets if light effect is enabled.
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | State | Gets the current state of button.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextButton | Gets/Sets the text that is displayed on the button.
Public property | TextButtonAlign | Gets/Sets the alignment of the text that is displayed on the button.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseMnemonic | Gets/Sets a value indicating whether the control interprets an ampersand character (&) in the control's TextButton property to be an access key prefix character.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetButton Class


NetButton.BackColor Property

NetButton Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackColor | (System.Windows.Forms.Control).
See Also

Reference

NetButton Class
NetButton Members


NetButton.BackgroundImage Property

NetButton Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetButton Class
NetButton Members


NetButton.BackgroundImageLayout Property

NetButton Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetButton Class
NetButton Members


NetButton.ColorBottom Property

Gets/Sets the bottom color of the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlDark")> _
<System.ComponentModel.Description("Gets/Sets the bottom color of the button.")> _
Public Property ColorBottom( _
   ByRef GetType As Object, _
   ByRef "ControlDark" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlDark")]
[System.ComponentModel.Description("Gets/Sets the bottom color of the button.")]
[System.Runtime.CompilerServices.IndexerName("ColorBottom")]
public Color this[
   ref object GetType,
   ref object "ControlDark"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlDark"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ColorDisabled Property

Gets/Sets the disabled color of text button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "DimGray")> _
<System.ComponentModel.Description("Gets/Sets the disabled color of text button.")> _
Public Property ColorDisabled( _
   ByRef GetType As Object, _
   ByRef "DimGray" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "DimGray")]
[System.ComponentModel.Description("Gets/Sets the disabled color of text button.")]
[System.Runtime.CompilerServices.IndexerName("ColorDisabled")]
public Color this[
   ref object GetType,
   ref object "DimGray"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"DimGray"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ColorLight Property

Gets/Sets the light effect colour used when the mouse is inside the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Appearance")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HighlightText")> _
<System.ComponentModel.Description("Gets/Sets the light effect colour used when the mouse is inside the button.")> _
Public Property ColorLight( _
   ByRef GetType As Object, _
   ByRef "HighlightText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Appearance")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HighlightText")]
[System.ComponentModel.Description("Gets/Sets the light effect colour used when the mouse is inside the button.")]
[System.Runtime.CompilerServices.IndexerName("ColorLight")]
public Color this[
   ref object GetType,
   ref object "HighlightText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"HighlightText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ColorText Property

Gets/Sets the color of button text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlText")> _
<System.ComponentModel.Description("Gets/Sets the color of button text.")> _
Public Property ColorText( _
   ByRef GetType As Object, _
   ByRef "ControlText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlText")]
[System.ComponentModel.Description("Gets/Sets the color of button text.")]
[System.Runtime.CompilerServices.IndexerName("ColorText")]
public Color this[
   ref object GetType,
   ref object "ControlText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ColorTop Property

Gets/Sets the top colour of the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.Description("Gets/Sets the top colour of the button.")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")> _
Public Property ColorTop( _
   ByRef "Gets/Sets the top colour of the button." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.Description("Gets/Sets the top colour of the button.")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")]
[System.Runtime.CompilerServices.IndexerName("ColorTop")]
public Color this[
   ref object "Gets/Sets the top colour of the button."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the top colour of the button."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.CornerRadius Property

Gets/Sets rhe radius for the button corners.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(8)> _
<System.ComponentModel.Description("Gets/Sets rhe radius for the button corners.")> _
Public Property CornerRadius( _
   ByRef 8 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(8)]
[System.ComponentModel.Description("Gets/Sets rhe radius for the button corners.")]
[System.Runtime.CompilerServices.IndexerName("CornerRadius")]
public int this[
   ref object 8
] {get; set;}
This language is not supported or no code example is available.

Parameters

8

Type: object

Remarks

A greater value make more smooth corners effect. Avoid to use a value greater than the half of the controls height. Set this property to a value of 0 (zero) for no rectangle shape effect. Default value is 8.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DefaultColorBottom Property

Gets the default bottom color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the default bottom color.")> _
Public ReadOnly Shared Property DefaultColorBottom() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the default bottom color.")]
public static Color DefaultColorBottom {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DefaultColorDisabled Property

Gets the default disabled color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the default disabled color.")> _
Public ReadOnly Shared Property DefaultColorDisabled() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the default disabled color.")]
public static Color DefaultColorDisabled {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DefaultColorLight Property

Gets the default light color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the default light color.")> _
Public ReadOnly Shared Property DefaultColorLight() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the default light color.")]
public static Color DefaultColorLight {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DefaultColorText Property

Gets the default text color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the default text color.")> _
Public ReadOnly Shared Property DefaultColorText() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the default text color.")]
public static Color DefaultColorText {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DefaultColorTop Property

Gets the default top color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the default top color.")> _
Public ReadOnly Shared Property DefaultColorTop() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the default top color.")]
public static Color DefaultColorTop {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.DialogResult Property

Gets/Sets the dialog-box result produced in a modal form by clicking the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<DefaultValue(GetType(DialogResult), "None")> _
<System.ComponentModel.Description("Gets/Sets the dialog-box result produced in a modal form by clicking the button.")> _
Public Property DialogResult( _
   ByRef GetType As Object, _
   ByRef "None" As Object _
) As DialogResult Implements  _
   IButtonControl.DialogResult
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[DefaultValue(GetType(DialogResult), "None")]
[System.ComponentModel.Description("Gets/Sets the dialog-box result produced in a modal form by clicking the button.")]
[System.Runtime.CompilerServices.IndexerName("DialogResult")]
public DialogResult this[
   ref object GetType,
   ref object "None"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"None"

Type: object

Implements

IButtonControl.DialogResult
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ForeColor Property

NetButton Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetButton Class
NetButton Members


NetButton.Image Property

Gets/Sets the image displayed on the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
<System.ComponentModel.Description("Gets/Sets the image displayed on the button.")> _
Public Property Image( _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.ComponentModel.Description("Gets/Sets the image displayed on the button.")]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.ImageAlign Property

Gets/Sets the alignment of the image displayed in the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(GetType(ContentAlignment), "MiddleLeft")> _
<System.ComponentModel.Description("Gets/Sets the alignment of the image displayed in the button.")> _
Public Property ImageAlign( _
   ByRef GetType As Object, _
   ByRef "MiddleLeft" As Object _
) As ContentAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(GetType(ContentAlignment), "MiddleLeft")]
[System.ComponentModel.Description("Gets/Sets the alignment of the image displayed in the button.")]
[System.Runtime.CompilerServices.IndexerName("ImageAlign")]
public ContentAlignment this[
   ref object GetType,
   ref object "MiddleLeft"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"MiddleLeft"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.LightEffect Property

Gets/Sets if light effect is enabled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.DefaultValue(True)> _
<System.ComponentModel.Description("Gets/Sets if light effect is enabled.")> _
Public Property LightEffect( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.DefaultValue(True)]
[System.ComponentModel.Description("Gets/Sets if light effect is enabled.")]
[System.Runtime.CompilerServices.IndexerName("LightEffect")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.State Property

Gets the current state of button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets the current state of button.")> _
Public ReadOnly Property State( _
   ByRef False As Object _
) As ButtonState
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets the current state of button.")]
[System.Runtime.CompilerServices.IndexerName("State")]
public ButtonState this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.TextButton Property

Gets/Sets the text that is displayed on the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.Description("Gets/Sets the text that is displayed on the button.")> _
<System.ComponentModel.DefaultValue("NetButton")> _
Public Property TextButton( _
   ByRef "Gets/Sets the text that is displayed on the button." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.Description("Gets/Sets the text that is displayed on the button.")]
[System.ComponentModel.DefaultValue("NetButton")]
[System.Runtime.CompilerServices.IndexerName("TextButton")]
public string this[
   ref object "Gets/Sets the text that is displayed on the button."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the text that is displayed on the button."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.TextButtonAlign Property

Gets/Sets the alignment of the text that is displayed on the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.Description("Gets/Sets the alignment of the text that is displayed on the button.")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.ContentAlignment), "MiddleCenter")> _
Public Property TextButtonAlign( _
   ByRef "Gets/Sets the alignment of the text that is displayed on the button." As Object _
) As ContentAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.Description("Gets/Sets the alignment of the text that is displayed on the button.")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.ContentAlignment), "MiddleCenter")]
[System.Runtime.CompilerServices.IndexerName("TextButtonAlign")]
public ContentAlignment this[
   ref object "Gets/Sets the alignment of the text that is displayed on the button."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the alignment of the text that is displayed on the button."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.UseMnemonic Property

Gets/Sets a value indicating whether the control interprets an ampersand character (&) in the control's TextButton property to be an access key prefix character.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetButton")> _
<System.ComponentModel.Description("Gets/Sets a value indicating whether the control interprets an ampersand character (&) in the control's TextButton property to be an access key prefix character.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property UseMnemonic( _
   ByRef "Gets/Sets a value indicating whether the control interprets an ampersand character  As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetButton")]
[System.ComponentModel.Description("Gets/Sets a value indicating whether the control interprets an ampersand character (&) in the control's TextButton property to be an access key prefix character.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("UseMnemonic")]
public bool this[
   ref object "Gets/Sets a value indicating whether the control interprets an ampersand character
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets a value indicating whether the control interprets an ampersand character

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton Methods

NetButton Class See Also

The following tables list the members exposed by the NetButton type.

Methods
 | Name | Description
Public method | NotifyDefault |
Public method | PerformClick |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetButton Class


NetButton.NotifyDefault Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub NotifyDefault( _
   ByVal value As Boolean _
) Implements  _
   IButtonControl.NotifyDefault
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void NotifyDefault(
   bool value
)
This language is not supported or no code example is available.

Parameters

value

Type: bool

If set to true, then ; otherwise, .

Implements

IButtonControl.NotifyDefault
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.PerformClick Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub PerformClick() Implements  _
   IButtonControl.PerformClick
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void PerformClick()
This language is not supported or no code example is available.

Implements

IButtonControl.PerformClick
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton Events

NetButton Class See Also

The following tables list the members exposed by the NetButton type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextButtonChanged | This event will be raised every time text of button changed
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetButton Class


TextButtonChanged Event

This event will be raised every time text of button changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event TextButtonChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event TextButtonChangedEventHandler TextButtonChanged
delegate void TextButtonChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetCalculator Class

Members

Softgroup .Net Calculator control provides easy to use full customizable calculator control for Windows Forms.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetCalculator), "NetCalculator.bmp")> _
<System.ComponentModel.DefaultEvent("ResultClick")> _
<System.ComponentModel.DefaultProperty("Value")> _
Public Class NetCalculator
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetCalculator), "NetCalculator.bmp")]
[System.ComponentModel.DefaultEvent("ResultClick")]
[System.ComponentModel.DefaultProperty("Value")]
public class NetCalculator : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetControls.NetCalculator
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Members


NetCalculator Members

NetCalculator Class Constructors Events Methods Properties See Also

Softgroup .Net Calculator control provides easy to use full customizable calculator control for Windows Forms.

The following tables list the members exposed by the NetCalculator type.

Constructors
 | Name | Description
Public constructor | NetCalculator Constructor | Initializes a new instance of the NetCalculator class.
Top
Properties
 | Name | Description
Public property | AcceptReturn | Gets/Sets if Return key will be handled like result command
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (Overloaded) Gets or sets a value indicating whether .
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | Gets/Sets FlatStyle for controls
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LastCommand | Gets a string that rappresent last command requested by the user.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OperatorsForeColor | Gets/Sets operators buttons foreground color
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | ResultBackColor | Gets/Sets result box background color
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ShowCloseButton | Gets/Sets if Close button is visible
Public property | ShowResultButton | Gets/Sets if Result button is visible
Public property | ShowTips | Gets/Sets if Tooltips for controls are enabled
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DoDragDrop |
Public method | DoResult | Send a Result (=) command to the calculator
Public method | GetPreferredSize | (inherited from Control).
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | ToDecimal | Gets/Sets current value result of calculation as decimal
Public method | ToDouble | Gets/Sets current value result of calculation as double
Public method | ToSingle | Gets/Sets current value result of calculation as single
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Public method | Value | Gets/Sets current value result of calculation
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | CloseClick | This event will be fired when Close button was click
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | Occurs when .
Public event | DragEnter | Occurs when .
Public event | DragLeave | Occurs when .
Public event | DragOver | Occurs when .
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | ResultClick | This event will be fired when Result button was click othersize if False
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetCalculator Class


NetCalculator Constructor

Initializes a new instance of the NetCalculator class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetCalculator()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator Properties

NetCalculator Class See Also

The following tables list the members exposed by the NetCalculator type.

Properties
 | Name | Description
Public property | AcceptReturn | Gets/Sets if Return key will be handled like result command
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (Overloaded) Gets or sets a value indicating whether .
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FlatStyle | Gets/Sets FlatStyle for controls
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LastCommand | Gets a string that rappresent last command requested by the user.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OperatorsForeColor | Gets/Sets operators buttons foreground color
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | ResultBackColor | Gets/Sets result box background color
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | ShowCloseButton | Gets/Sets if Close button is visible
Public property | ShowResultButton | Gets/Sets if Result button is visible
Public property | ShowTips | Gets/Sets if Tooltips for controls are enabled
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetCalculator Class


NetCalculator.AcceptReturn Property

Gets/Sets if Return key will be handled like result command

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets if Return key will be handled like result command")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AcceptReturn( _
   ByRef "Gets/Sets if Return key will be handled like result command" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets if Return key will be handled like result command")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AcceptReturn")]
public bool this[
   ref object "Gets/Sets if Return key will be handled like result command"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if Return key will be handled like result command"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AllowDrop Property

NetCalculator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AllowDrop | (System.Windows.Forms.Control).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScroll Property

NetCalculator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollMargin Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMargin | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollMinSize Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMinSize | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollOffset Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollOffset | (System.Windows.Forms.Control).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollPosition Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollPosition | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoSize Property

NetCalculator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.UserControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoSizeMode Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoSizeMode | (System.Windows.Forms.UserControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoValidate Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoValidate | (System.Windows.Forms.UserControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.BindingContext Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BindingContext | (System.Windows.Forms.ContainerControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.CausesValidation Property

NetCalculator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.DataBindings Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.FlatStyle Property

Gets/Sets FlatStyle for controls

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets FlatStyle for buttons")> _
<System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.FlatStyle), "Standard")> _
Public Property FlatStyle( _
   ByRef "Gets/Sets FlatStyle for buttons" As Object _
) As FlatStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets FlatStyle for buttons")]
[System.ComponentModel.DefaultValue(GetType(System.Windows.Forms.FlatStyle), "Standard")]
[System.Runtime.CompilerServices.IndexerName("FlatStyle")]
public FlatStyle this[
   ref object "Gets/Sets FlatStyle for buttons"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets FlatStyle for buttons"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.HorizontalScroll Property

NetCalculator Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
HorizontalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.LastCommand Property

Gets a string that rappresent last command requested by the user.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets a string that rappresent last command requested by the user.")> _
Public ReadOnly Property LastCommand( _
   ByRef "Gets a string that rappresent last command requested by the user." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets a string that rappresent last command requested by the user.")]
[System.Runtime.CompilerServices.IndexerName("LastCommand")]
public string this[
   ref object "Gets a string that rappresent last command requested by the user."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets a string that rappresent last command requested by the user."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.OperatorsForeColor Property

Gets/Sets operators buttons foreground color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets operators buttons foreground color")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HotTack")> _
Public Property OperatorsForeColor( _
   ByRef "Gets/Sets operators buttons foreground color" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets operators buttons foreground color")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "HotTack")]
[System.Runtime.CompilerServices.IndexerName("OperatorsForeColor")]
public Color this[
   ref object "Gets/Sets operators buttons foreground color"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets operators buttons foreground color"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Padding Property

NetCalculator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ResultBackColor Property

Gets/Sets result box background color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets result box background color")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")> _
Public Property ResultBackColor( _
   ByRef "Gets/Sets result box background color" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets result box background color")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")]
[System.Runtime.CompilerServices.IndexerName("ResultBackColor")]
public Color this[
   ref object "Gets/Sets result box background color"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets result box background color"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ShowCloseButton Property

Gets/Sets if Close button is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets if Close button is visible")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property ShowCloseButton( _
   ByRef "Gets/Sets if Close button is visible" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets if Close button is visible")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("ShowCloseButton")]
public bool this[
   ref object "Gets/Sets if Close button is visible"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if Close button is visible"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ShowResultButton Property

Gets/Sets if Result button is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets if Result button is visible")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property ShowResultButton( _
   ByRef "Gets/Sets if Result button is visible" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets if Result button is visible")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("ShowResultButton")]
public bool this[
   ref object "Gets/Sets if Result button is visible"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if Result button is visible"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ShowTips Property

Gets/Sets if Tooltips for controls are enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Gets/Sets if Tooltips for controls are enabled")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property ShowTips( _
   ByRef "Gets/Sets if Tooltips for controls are enabled" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Gets/Sets if Tooltips for controls are enabled")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("ShowTips")]
public bool this[
   ref object "Gets/Sets if Tooltips for controls are enabled"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if Tooltips for controls are enabled"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.VerticalScroll Property

NetCalculator Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
VerticalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator Methods

NetCalculator Class See Also

The following tables list the members exposed by the NetCalculator type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DoDragDrop |
Public method | DoResult | Send a Result (=) command to the calculator
Public method | GetPreferredSize | (inherited from Control).
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | ToDecimal | Gets/Sets current value result of calculation as decimal
Public method | ToDouble | Gets/Sets current value result of calculation as double
Public method | ToSingle | Gets/Sets current value result of calculation as single
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Public method | Value | Gets/Sets current value result of calculation
Top
See Also

Reference

NetCalculator Class


NetCalculator.DoDragDrop Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)
This language is not supported or no code example is available.

Parameters

data

Type: object

allowedEffects

Type: DragDropEffects

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.DoResult Method

Send a Result (=) command to the calculator

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("Calculator")> _
<System.ComponentModel.Description("Send a Result (=) command to the calculator")> _
Public Sub DoResult()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("Calculator")]
[System.ComponentModel.Description("Send a Result (=) command to the calculator")]
public System.Void DoResult()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ResetBindings Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetBindings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetBindings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ScrollControlIntoView Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ScrollControlIntoView(
   Control activeControl
)
This language is not supported or no code example is available.

Parameters

activeControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.SetAutoScrollMargin Method

NetCalculator Class See Also

Overload List
Name | Description
SetAutoScrollMargin(int, int) |
SetAutoScrollMargin(Int32,Int32) | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ToDecimal Method

Gets/Sets current value result of calculation as decimal

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets current value result of calculation as decimal")> _
Public Function ToDecimal() As Decimal
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets current value result of calculation as decimal")]
public decimal ToDecimal()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ToDouble Method

Gets/Sets current value result of calculation as double

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets current value result of calculation as double")> _
Public Function ToDouble() As Double
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets current value result of calculation as double")]
public double ToDouble()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ToSingle Method

Gets/Sets current value result of calculation as single

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets current value result of calculation as single")> _
Public Function ToSingle() As Single
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets current value result of calculation as single")]
public float ToSingle()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Validate Method

NetCalculator Class See Also

Overload List
Name | Description
Validate() |
Validate(bool) |
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ValidateChildren Method

NetCalculator Class See Also

Overload List
Name | Description
ValidateChildren() |
ValidateChildren(ValidationConstraints) |
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Value Method

Gets/Sets current value result of calculation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets current value result of calculation")> _
Public Function Value() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets current value result of calculation")]
public string Value()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator Events

NetCalculator Class See Also

The following tables list the members exposed by the NetCalculator type.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | CloseClick | This event will be fired when Close button was click
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | Occurs when .
Public event | DragEnter | Occurs when .
Public event | DragLeave | Occurs when .
Public event | DragOver | Occurs when .
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | ResultClick | This event will be fired when Result button was click othersize if False
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetCalculator Class


AutoSizeChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoSizeChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoSizeChangedEventHandler AutoSizeChanged
delegate void AutoSizeChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


AutoValidateChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoValidateChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoValidateChangedEventHandler AutoValidateChanged
delegate void AutoValidateChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


BindingContextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BindingContextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BindingContextChangedEventHandler BindingContextChanged
delegate void BindingContextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


CausesValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event CausesValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event CausesValidationChangedEventHandler CausesValidationChanged
delegate void CausesValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


CloseClick Event

This event will be fired when Close button was click

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event CloseClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event CloseClickEventHandler CloseClick
delegate void CloseClickEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


DragDrop Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event DragDrop( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event DragDropEventHandler DragDrop
delegate void DragDropEventHandler(
   object sender,
   DragEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: DragEventArgs

An DragEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


DragEnter Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event DragEnter( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event DragEnterEventHandler DragEnter
delegate void DragEnterEventHandler(
   object sender,
   DragEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: DragEventArgs

An DragEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


DragLeave Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event DragLeave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event DragLeaveEventHandler DragLeave
delegate void DragLeaveEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


DragOver Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event DragOver( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event DragOverEventHandler DragOver
delegate void DragOverEventHandler(
   object sender,
   DragEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: DragEventArgs

An DragEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


ResultClick Event

This event will be fired when Result button was click othersize if False

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ResultClick( _
   ByVal sender As Object, _
   ByVal e As ResultClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ResultClickEventHandler ResultClick
delegate void ResultClickEventHandler(
   object sender,
   ResultClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender

e

Type: ResultClickEventArgs

A ResultClickEventArgs event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


Scroll Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Scroll( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ScrollEventHandler Scroll
delegate void ScrollEventHandler(
   object sender,
   ScrollEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: ScrollEventArgs

An ScrollEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


Validated Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatedEventHandler Validated
delegate void ValidatedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


Validating Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validating( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatingEventHandler Validating
delegate void ValidatingEventHandler(
   object sender,
   CancelEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: CancelEventArgs

An CancelEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetExtraLine Class

Members

Softgroup .Net Extra Line is a fast, small, lightweight and easy to use advanced Line control with gradient effects.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetExtraLine), "NetExtraLine.bmp")> _
<DefaultProperty("ForeColor")> _
<DefaultEvent("Click")> _
Public Class NetExtraLine
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetExtraLine), "NetExtraLine.bmp")]
[DefaultProperty("ForeColor")]
[DefaultEvent("Click")]
public class NetExtraLine : Control
This language is not supported or no code example is available.
Remarks

To add a Softgroup .Net Extra Line Control to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetExtraLine
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Members


NetExtraLine Members

NetExtraLine Class Constructors Events Methods Properties See Also

Softgroup .Net Extra Line is a fast, small, lightweight and easy to use advanced Line control with gradient effects.

The following tables list the members exposed by the NetExtraLine type.

Constructors
 | Name | Description
Public constructor | NetExtraLine Constructor | Create new instance of the class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Border | Gets/Sets if control has a border
Public property | BorderColor | Gets/Sets border color
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | GradientEnabled | Gets/Sets if gradient effect is enabled
Public property | GradientEndColor | Gets/Sets ending color of gradient effect
Public property | GradientMiddleColor | Gets/Sets middle color of gradient effect
Public property | GradientMode | Gets/Sets ending color of gradient effect
Public property | GradientOffset | Gets/Sets offset for gradient effect
Public property | GradientSize | Gets/Sets size of gradient effect
Public property | GradientStartColor | Gets/Sets starting color of gradient effect
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (Overloaded) Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetExtraLine Class


NetExtraLine Constructor

Create new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetExtraLine()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine Properties

NetExtraLine Class See Also

The following tables list the members exposed by the NetExtraLine type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Border | Gets/Sets if control has a border
Public property | BorderColor | Gets/Sets border color
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | GradientEnabled | Gets/Sets if gradient effect is enabled
Public property | GradientEndColor | Gets/Sets ending color of gradient effect
Public property | GradientMiddleColor | Gets/Sets middle color of gradient effect
Public property | GradientMode | Gets/Sets ending color of gradient effect
Public property | GradientOffset | Gets/Sets offset for gradient effect
Public property | GradientSize | Gets/Sets size of gradient effect
Public property | GradientStartColor | Gets/Sets starting color of gradient effect
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (Overloaded) Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetExtraLine Class


NetExtraLine.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoSize Property

NetExtraLine Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.BackgroundImage Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.BackgroundImageLayout Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Border Property

Gets/Sets if control has a border

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetExtraLine")> _
<System.ComponentModel.Description("Gets/Sets if control has a border")> _
<DefaultValue(True)> _
Public Property Border( _
   ByRef "Gets/Sets if control has a border" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetExtraLine")]
[System.ComponentModel.Description("Gets/Sets if control has a border")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("Border")]
public bool this[
   ref object "Gets/Sets if control has a border"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if control has a border"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.BorderColor Property

Gets/Sets border color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "DarkGray")> _
<System.ComponentModel.Description("Gets/Sets border color")> _
<Category("NetExtraLine")> _
Public Property BorderColor( _
   ByRef "Gets/Sets border color" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "DarkGray")]
[System.ComponentModel.Description("Gets/Sets border color")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("BorderColor")]
public Color this[
   ref object "Gets/Sets border color"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets border color"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.CausesValidation Property

NetExtraLine Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.DataBindings Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Font Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientEnabled Property

Gets/Sets if gradient effect is enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(False)> _
<System.ComponentModel.Description("Gets/Sets if gradient effect is enabled")> _
<Category("NetExtraLine")> _
Public Property GradientEnabled( _
   ByRef "Gets/Sets if gradient effect is enabled" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(False)]
[System.ComponentModel.Description("Gets/Sets if gradient effect is enabled")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Gets/Sets if gradient effect is enabled"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if gradient effect is enabled"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientEndColor Property

Gets/Sets ending color of gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "MediumBlue")> _
<System.ComponentModel.Description("Gets/Sets ending color of gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientEndColor( _
   ByRef "Gets/Sets ending color of gradient effect" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "MediumBlue")]
[System.ComponentModel.Description("Gets/Sets ending color of gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientEndColor")]
public Color this[
   ref object "Gets/Sets ending color of gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets ending color of gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientMiddleColor Property

Gets/Sets middle color of gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "Gold")> _
<System.ComponentModel.Description("Gets/Sets middle color of gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientMiddleColor( _
   ByRef "Gets/Sets middle color of gradient effect" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "Gold")]
[System.ComponentModel.Description("Gets/Sets middle color of gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientMiddleColor")]
public Color this[
   ref object "Gets/Sets middle color of gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets middle color of gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientMode Property

Gets/Sets ending color of gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(LinearGradientMode), "Horizontal")> _
<System.ComponentModel.Description("Gets/Sets ending color of gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientMode( _
   ByRef "Gets/Sets ending color of gradient effect" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(LinearGradientMode), "Horizontal")]
[System.ComponentModel.Description("Gets/Sets ending color of gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientMode")]
public LinearGradientMode this[
   ref object "Gets/Sets ending color of gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets ending color of gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientOffset Property

Gets/Sets offset for gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(1.0!)> _
<System.ComponentModel.Description("Gets/Sets offset for gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientOffset( _
   ByRef "Gets/Sets offset for gradient effect" As Object _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(1.0!)]
[System.ComponentModel.Description("Gets/Sets offset for gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientOffset")]
public float this[
   ref object "Gets/Sets offset for gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets offset for gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientSize Property

Gets/Sets size of gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Size), "0,0")> _
<System.ComponentModel.Description("Gets/Sets size of gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientSize( _
   ByRef "Gets/Sets size of gradient effect" As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Size), "0,0")]
[System.ComponentModel.Description("Gets/Sets size of gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientSize")]
public Size this[
   ref object "Gets/Sets size of gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets size of gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.GradientStartColor Property

Gets/Sets starting color of gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(System.Drawing.Color), "MediumBlue")> _
<System.ComponentModel.Description("Gets/Sets starting color of gradient effect")> _
<Category("NetExtraLine")> _
Public Property GradientStartColor( _
   ByRef "Gets/Sets starting color of gradient effect" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(System.Drawing.Color), "MediumBlue")]
[System.ComponentModel.Description("Gets/Sets starting color of gradient effect")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("GradientStartColor")]
public Color this[
   ref object "Gets/Sets starting color of gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets starting color of gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.ImeMode Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ImeMode | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Margin Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Orientation Property

Gets/Sets control orientation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Orientation), "Horizontal")> _
<System.ComponentModel.Description("Gets/Sets control orientation")> _
<Category("NetExtraLine")> _
Public Property Orientation( _
   ByRef "Gets/Sets control orientation" As Object _
) As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Orientation), "Horizontal")]
[System.ComponentModel.Description("Gets/Sets control orientation")]
[Category("NetExtraLine")]
[System.Runtime.CompilerServices.IndexerName("Orientation")]
public Orientation this[
   ref object "Gets/Sets control orientation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets control orientation"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.RightToLeft Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
RightToLeft | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.TabStop Property

NetExtraLine Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
TabStop | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Text Property

NetExtraLine Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Text | (System.Windows.Forms.Control).
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine Methods

NetExtraLine Class See Also

The following tables list the members exposed by the NetExtraLine type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetExtraLine Class


NetExtraLine Events

NetExtraLine Class See Also

The following tables list the members exposed by the NetExtraLine type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetExtraLine Class


NetGIFAnimate Class

Members

Softgroup NetGIFAnimate control provide functionalities to play animated Graphic Interchange Format images

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.NetGIFAnimate), "NetGIFAnimate.bmp")> _
<System.ComponentModel.DefaultEvent("Click")> _
<System.ComponentModel.DefaultProperty("Image")> _
Public Class NetGIFAnimate
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.NetGIFAnimate), "NetGIFAnimate.bmp")]
[System.ComponentModel.DefaultEvent("Click")]
[System.ComponentModel.DefaultProperty("Image")]
public class NetGIFAnimate : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetControls.NetGIFAnimate
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Members


NetGIFAnimate Members

NetGIFAnimate Class Events Methods Properties See Also

Softgroup NetGIFAnimate control provide functionalities to play animated Graphic Interchange Format images

The following tables list the members exposed by the NetGIFAnimate type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | Animated | Gets/Sets animation Play (True) or Stop (False)
Public property | AutoAnimate | Gets/Sets image file name to animate
Public property | AutoCenter | Gets/Sets whether image frames should be centered on client area control.
Public property | AutoFit | Gets/Sets whether image frames should be painted on entire client area control.
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (Overloaded) Gets .
 | DefaultForeColor | (Overloaded) Gets .
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | Image | Gets/Sets image object to animate (must be GIF format)
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | FramesCount | Gets total number of frames in the anumation file
Public method | GetPreferredSize | (inherited from Control).
Public method | LoadFromFile | Load an image to animate form file name
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings |
Public method | ResetFont |
Public method | ResetForeColor |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | ShowFrame | Diaplay specified frame index
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | OnChange | This event will be fired every time an animation image change
Public event | OnStartAnimate | This event will be fired every time an animation start to play
Public event | OnStopAnimate | This event will be fired every time an animation stop to play
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetGIFAnimate Class


NetGIFAnimate Properties

NetGIFAnimate Class See Also

The following tables list the members exposed by the NetGIFAnimate type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | Animated | Gets/Sets animation Play (True) or Stop (False)
Public property | AutoAnimate | Gets/Sets image file name to animate
Public property | AutoCenter | Gets/Sets whether image frames should be centered on client area control.
Public property | AutoFit | Gets/Sets whether image frames should be painted on entire client area control.
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (Overloaded) Gets .
 | DefaultForeColor | (Overloaded) Gets .
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | Image | Gets/Sets image object to animate (must be GIF format)
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetGIFAnimate Class


NetGIFAnimate.Animated Property

Gets/Sets animation Play (True) or Stop (False)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("GIFAnimate")> _
<System.ComponentModel.Description("Gets/Sets animation Play (True) or Stop (False)")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property Animated( _
   ByRef "Gets/Sets animation Play  As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("GIFAnimate")]
[System.ComponentModel.Description("Gets/Sets animation Play (True) or Stop (False)")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("Animated")]
public bool this[
   ref object "Gets/Sets animation Play
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets animation Play

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoAnimate Property

Gets/Sets image file name to animate

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("GIFAnimate")> _
<System.ComponentModel.Description("Gets/Sets image file name to animate")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoAnimate( _
   ByRef "Gets/Sets image file name to animate" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("GIFAnimate")]
[System.ComponentModel.Description("Gets/Sets image file name to animate")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoAnimate")]
public bool this[
   ref object "Gets/Sets image file name to animate"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets image file name to animate"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoCenter Property

Gets/Sets whether image frames should be centered on client area control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("GIFAnimate")> _
<System.ComponentModel.Description("Gets/Sets whether image frames should be centered on client area control")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoCenter( _
   ByRef "Gets/Sets whether image frames should be centered on client area control" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("GIFAnimate")]
[System.ComponentModel.Description("Gets/Sets whether image frames should be centered on client area control")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoCenter")]
public bool this[
   ref object "Gets/Sets whether image frames should be centered on client area control"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets whether image frames should be centered on client area control"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoFit Property

Gets/Sets whether image frames should be painted on entire client area control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("GIFAnimate")> _
<System.ComponentModel.Description("Gets/Sets whether image frames should be painted on entire client area control.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoFit( _
   ByRef "Gets/Sets whether image frames should be painted on entire client area control." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("GIFAnimate")]
[System.ComponentModel.Description("Gets/Sets whether image frames should be painted on entire client area control.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoFit")]
public bool this[
   ref object "Gets/Sets whether image frames should be painted on entire client area control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets whether image frames should be painted on entire client area control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoScroll Property

NetGIFAnimate Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoScrollMargin Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMargin | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoScrollMinSize Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMinSize | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoScrollOffset Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollOffset | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoScrollPosition Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollPosition | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoSize Property

NetGIFAnimate Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.UserControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoSizeMode Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoSizeMode | (System.Windows.Forms.UserControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoValidate Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoValidate | (System.Windows.Forms.UserControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.BackgroundImage Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.BackgroundImageLayout Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.BindingContext Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BindingContext | (System.Windows.Forms.ContainerControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.CausesValidation Property

NetGIFAnimate Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.DataBindings Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.DefaultFont Property

NetGIFAnimate Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DefaultFont | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.DefaultForeColor Property

NetGIFAnimate Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Font Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ForeColor Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.HorizontalScroll Property

NetGIFAnimate Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
HorizontalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Image Property

Gets/Sets image object to animate (must be GIF format)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("GIFAnimate")> _
<System.ComponentModel.Description("Gets/Sets image object to animate (must be GIF format)")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property Image( _
   ByRef "Gets/Sets image object to animate  As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("GIFAnimate")]
[System.ComponentModel.Description("Gets/Sets image object to animate (must be GIF format)")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object "Gets/Sets image object to animate
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets image object to animate

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Padding Property

NetGIFAnimate Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.VerticalScroll Property

NetGIFAnimate Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
VerticalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate Methods

NetGIFAnimate Class See Also

The following tables list the members exposed by the NetGIFAnimate type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | FramesCount | Gets total number of frames in the anumation file
Public method | GetPreferredSize | (inherited from Control).
Public method | LoadFromFile | Load an image to animate form file name
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings |
Public method | ResetFont |
Public method | ResetForeColor |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | ShowFrame | Diaplay specified frame index
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Top
See Also

Reference

NetGIFAnimate Class


NetGIFAnimate.FramesCount Method

Gets total number of frames in the anumation file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets total number of frames in the anumation file")> _
Public Function FramesCount() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets total number of frames in the anumation file")]
public int FramesCount()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.LoadFromFile Method

Load an image to animate form file name

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Load an image to animate form file name")> _
Public Sub LoadFromFile( _
   ByVal FileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Load an image to animate form file name")]
public System.Void LoadFromFile(
   string FileName
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ResetBindings Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetBindings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetBindings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ResetFont Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetFont()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetFont()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ResetForeColor Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetForeColor()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetForeColor()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ScrollControlIntoView Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ScrollControlIntoView(
   Control activeControl
)
This language is not supported or no code example is available.

Parameters

activeControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.SetAutoScrollMargin Method

NetGIFAnimate Class See Also

Overload List
Name | Description
SetAutoScrollMargin(int, int) |
SetAutoScrollMargin(Int32,Int32) | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ShowFrame Method

Diaplay specified frame index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Diaplay specified frame index")> _
Public Sub ShowFrame( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Diaplay specified frame index")]
public System.Void ShowFrame(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of frmae to display

Remarks

Calling this method during animation it will be stopped

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Validate Method

NetGIFAnimate Class See Also

Overload List
Name | Description
Validate() |
Validate(bool) |
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ValidateChildren Method

NetGIFAnimate Class See Also

Overload List
Name | Description
ValidateChildren() |
ValidateChildren(ValidationConstraints) |
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate Events

NetGIFAnimate Class See Also

The following tables list the members exposed by the NetGIFAnimate type.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | OnChange | This event will be fired every time an animation image change
Public event | OnStartAnimate | This event will be fired every time an animation start to play
Public event | OnStopAnimate | This event will be fired every time an animation stop to play
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetGIFAnimate Class


AutoSizeChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoSizeChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoSizeChangedEventHandler AutoSizeChanged
delegate void AutoSizeChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


AutoValidateChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoValidateChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoValidateChangedEventHandler AutoValidateChanged
delegate void AutoValidateChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


BindingContextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BindingContextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BindingContextChangedEventHandler BindingContextChanged
delegate void BindingContextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


CausesValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event CausesValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event CausesValidationChangedEventHandler CausesValidationChanged
delegate void CausesValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ForeColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event ForeColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ForeColorChangedEventHandler ForeColorChanged
delegate void ForeColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


OnChange Event

This event will be fired every time an animation image change

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event OnChange( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event OnChangeEventHandler OnChange
delegate void OnChangeEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


OnStartAnimate Event

This event will be fired every time an animation start to play

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event OnStartAnimate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event OnStartAnimateEventHandler OnStartAnimate
delegate void OnStartAnimateEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


OnStopAnimate Event

This event will be fired every time an animation stop to play

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event OnStopAnimate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event OnStopAnimateEventHandler OnStopAnimate
delegate void OnStopAnimateEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


Scroll Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Scroll( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ScrollEventHandler Scroll
delegate void ScrollEventHandler(
   object sender,
   ScrollEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: ScrollEventArgs

An ScrollEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


Validated Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatedEventHandler Validated
delegate void ValidatedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


Validating Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validating( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatingEventHandler Validating
delegate void ValidatingEventHandler(
   object sender,
   CancelEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: CancelEventArgs

An CancelEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetLineSeparator Class

Members

Softgroup .Net Line Separator is a fast, small, lightweight and easy to use threed Separator control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetLineSeparator), "NetLineSeparator.bmp")> _
<DefaultProperty("Text")> _
<DefaultEvent("Click")> _
Public Class NetLineSeparator
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetLineSeparator), "NetLineSeparator.bmp")]
[DefaultProperty("Text")]
[DefaultEvent("Click")]
public class NetLineSeparator : Control
This language is not supported or no code example is available.
Remarks

To add a Softgroup .Net Line Separator control to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetLineSeparator
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Members


NetLineSeparator Members

NetLineSeparator Class Constructors Events Methods Properties See Also

Softgroup .Net Line Separator is a fast, small, lightweight and easy to use threed Separator control.

The following tables list the members exposed by the NetLineSeparator type.

Constructors
 | Name | Description
Public constructor | NetLineSeparator Constructor | Create new instance of the class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (Overloaded) Gets or sets .
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextAlignment | Gets/Sets text alignment
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetLineSeparator Class


NetLineSeparator Constructor

Create new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetLineSeparator()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator Properties

NetLineSeparator Class See Also

The following tables list the members exposed by the NetLineSeparator type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (Overloaded) Gets or sets .
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (Overloaded) Gets or sets .
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextAlignment | Gets/Sets text alignment
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetLineSeparator Class


NetLineSeparator.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.AutoSize Property

NetLineSeparator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.CausesValidation Property

NetLineSeparator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.DataBindings Property

NetLineSeparator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.ImeMode Property

NetLineSeparator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ImeMode | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.Margin Property

NetLineSeparator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.Orientation Property

Gets/Sets control orientation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetLineSeparator")> _
<System.ComponentModel.Description("Gets/Sets control orientation")> _
<DefaultValue(GetType(System.Windows.Forms.Orientation), "Horizontal")> _
Public Property Orientation( _
   ByRef "Gets/Sets control orientation" As Object _
) As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetLineSeparator")]
[System.ComponentModel.Description("Gets/Sets control orientation")]
[DefaultValue(GetType(System.Windows.Forms.Orientation), "Horizontal")]
[System.Runtime.CompilerServices.IndexerName("Orientation")]
public Orientation this[
   ref object "Gets/Sets control orientation"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets control orientation"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.TabIndex Property

NetLineSeparator Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
TabIndex | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.TabStop Property

NetLineSeparator Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
TabStop | (System.Windows.Forms.Control).
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.TextAlignment Property

Gets/Sets text alignment

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetLineSeparator")> _
<System.ComponentModel.Description("Gets/Sets text alignment")> _
<DefaultValue(GetType(System.Drawing.StringAlignment), "Near")> _
Public Property TextAlignment( _
   ByRef "Gets/Sets text alignment" As Object _
) As StringAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetLineSeparator")]
[System.ComponentModel.Description("Gets/Sets text alignment")]
[DefaultValue(GetType(System.Drawing.StringAlignment), "Near")]
[System.Runtime.CompilerServices.IndexerName("TextAlignment")]
public StringAlignment this[
   ref object "Gets/Sets text alignment"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets text alignment"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator Methods

NetLineSeparator Class See Also

The following tables list the members exposed by the NetLineSeparator type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetLineSeparator Class


NetLineSeparator Events

NetLineSeparator Class See Also

The following tables list the members exposed by the NetLineSeparator type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetLineSeparator Class


NetLinkButton Class

Members

Softgroup .Net LinkButton is a button control designed to mimic the look of command link control found in Windows Vista.'''

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Drawing.ToolboxBitmap(GetType(NetButton), "NetLinkButton.bmp")> _
<System.ComponentModel.DefaultProperty("Text")> _
<System.ComponentModel.DefaultEvent("Click")> _
Public Class NetLinkButton
    Inherits Button
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Drawing.ToolboxBitmap(GetType(NetButton), "NetLinkButton.bmp")]
[System.ComponentModel.DefaultProperty("Text")]
[System.ComponentModel.DefaultEvent("Click")]
public class NetLinkButton : Button
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ButtonBase
System.Windows.Forms.Button
Softgroup.NetControls.NetLinkButton
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Members


NetLinkButton Members

NetLinkButton Class Events Methods Properties See Also

Softgroup .Net LinkButton is a button control designed to mimic the look of command link control found in Windows Vista.'''

The following tables list the members exposed by the NetLinkButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoEllipsis | (inherited from ButtonBase).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from ButtonBase).
Public property | AutoSizeMode | (inherited from Button).
Public property | BackColor | (inherited from ButtonBase).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | (inherited from Button).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FlatAppearance | (inherited from ButtonBase).
Public property | FlatStyle | (inherited from ButtonBase).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets the left-hand Bitmap object of the control.
Public property | ImageAlign | (inherited from ButtonBase).
Public property | ImageIndex | (inherited from ButtonBase).
Public property | ImageKey | (inherited from ButtonBase).
Public property | ImageList | (inherited from ButtonBase).
Public property | ImageScalingSize | Gets/Sets the target size of the Image object.
Public property | ImageVerticalAlign | Gets/Sets the alignment of the Image object along the vertical axis.
Public property | ImeMode | (inherited from ButtonBase).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from ButtonBase).
Public property | TextAlign | (inherited from ButtonBase).
Public property | TextHeader | Gets/Sets the string associated with the Header text of the control.
Public property | TextImageRelation | (inherited from ButtonBase).
Public property | TextVerticalAlign | Gets/Sets the alignment of the displayed text along the vertical axis.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCompatibleTextRendering | (inherited from ButtonBase).
Public property | UseMnemonic | (inherited from ButtonBase).
Public property | UseVisualStyleBackColor | (inherited from ButtonBase).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from ButtonBase).
Public method | NotifyDefault | (inherited from Button).
Public method | PerformClick |
Public method | ResetBindings | (inherited from Control).
Public method | ToString | (inherited from Button).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from ButtonBase).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Button).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from ButtonBase).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Button).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetLinkButton Class


NetLinkButton Properties

NetLinkButton Class See Also

The following tables list the members exposed by the NetLinkButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoEllipsis | (inherited from ButtonBase).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from ButtonBase).
Public property | AutoSizeMode | (inherited from Button).
Public property | BackColor | (inherited from ButtonBase).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | (inherited from Button).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FlatAppearance | (inherited from ButtonBase).
Public property | FlatStyle | (inherited from ButtonBase).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets the left-hand Bitmap object of the control.
Public property | ImageAlign | (inherited from ButtonBase).
Public property | ImageIndex | (inherited from ButtonBase).
Public property | ImageKey | (inherited from ButtonBase).
Public property | ImageList | (inherited from ButtonBase).
Public property | ImageScalingSize | Gets/Sets the target size of the Image object.
Public property | ImageVerticalAlign | Gets/Sets the alignment of the Image object along the vertical axis.
Public property | ImeMode | (inherited from ButtonBase).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from ButtonBase).
Public property | TextAlign | (inherited from ButtonBase).
Public property | TextHeader | Gets/Sets the string associated with the Header text of the control.
Public property | TextImageRelation | (inherited from ButtonBase).
Public property | TextVerticalAlign | Gets/Sets the alignment of the displayed text along the vertical axis.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCompatibleTextRendering | (inherited from ButtonBase).
Public property | UseMnemonic | (inherited from ButtonBase).
Public property | UseVisualStyleBackColor | (inherited from ButtonBase).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetLinkButton Class


NetLinkButton.Image Property

Gets/Sets the left-hand Bitmap object of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("LinkButton")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
<Description("Gets/Sets the left-hand Bitmap object of the control.")> _
Public Overloads Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("LinkButton")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[Description("Gets/Sets the left-hand Bitmap object of the control.")]
public Image Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton.ImageScalingSize Property

Gets/Sets the target size of the Image object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("LinkButton")> _
<DefaultValue(GetType(Size), "24,24")> _
<Description("Gets/Sets the target size of the Image object.")> _
Public Property ImageScalingSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("LinkButton")]
[DefaultValue(GetType(Size), "24,24")]
[Description("Gets/Sets the target size of the Image object.")]
public Size ImageScalingSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton.ImageVerticalAlign Property

Gets/Sets the alignment of the Image object along the vertical axis.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("LinkButton")> _
<DefaultValue(GetType(VerticalAlign), "Middle")> _
<Description("Gets/Sets the alignment of the Image object along the vertical axis")> _
Public Property ImageVerticalAlign() As VerticalAlign
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("LinkButton")]
[DefaultValue(GetType(VerticalAlign), "Middle")]
[Description("Gets/Sets the alignment of the Image object along the vertical axis")]
public VerticalAlign ImageVerticalAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton.TextHeader Property

Gets/Sets the string associated with the Header text of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("LinkButton")> _
<DefaultValue("")> _
<Description("Gets/Sets the string associated with the Header text of the control.")> _
Public Property TextHeader() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("LinkButton")]
[DefaultValue("")]
[Description("Gets/Sets the string associated with the Header text of the control.")]
public string TextHeader {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton.TextVerticalAlign Property

Gets/Sets the alignment of the displayed text along the vertical axis.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("LinkButton")> _
<DefaultValue(GetType(VerticalAlign), "Middle")> _
<Description("Gets/Sets the alignment of the displayed text along the vertical axis")> _
Public Property TextVerticalAlign() As VerticalAlign
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("LinkButton")]
[DefaultValue(GetType(VerticalAlign), "Middle")]
[Description("Gets/Sets the alignment of the displayed text along the vertical axis")]
public VerticalAlign TextVerticalAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton Methods

NetLinkButton Class See Also

The following tables list the members exposed by the NetLinkButton type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from ButtonBase).
Public method | NotifyDefault | (inherited from Button).
Public method | PerformClick |
Public method | ResetBindings | (inherited from Control).
Public method | ToString | (inherited from Button).
Top
See Also

Reference

NetLinkButton Class


NetLinkButton.PerformClick Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub PerformClick()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void PerformClick()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLinkButton Class
NetLinkButton Members


NetLinkButton Events

NetLinkButton Class See Also

The following tables list the members exposed by the NetLinkButton type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from ButtonBase).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Button).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from ButtonBase).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Button).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetLinkButton Class


NetMDIBar Class

Members

Softgroup .Net MDI Bar is a fast, small and lightweight .NET bar control for automatic tracking of MDI children in an MDI parent form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetMDIBar), "NetMDIBar.bmp")> _
<System.ComponentModel.DefaultProperty("ActiveBold")> _
Public Class NetMDIBar
    Inherits ToolStrip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetMDIBar), "NetMDIBar.bmp")]
[System.ComponentModel.DefaultProperty("ActiveBold")]
public class NetMDIBar : ToolStrip
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ToolStrip
Softgroup.NetControls.NetMDIBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Members


NetMDIBar Members

NetMDIBar Class Events Methods Properties See Also

Softgroup .Net MDI Bar is a fast, small and lightweight .NET bar control for automatic tracking of MDI children in an MDI parent form.

The following tables list the members exposed by the NetMDIBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveBold | Gets/Sets whether bold font text must be used for active button
Public property | AllowDrop | (inherited from ToolStrip).
Public property | AllowItemReorder | (Overloaded) Gets or sets a value indicating whether .
Public property | AllowMerge | (Overloaded) Gets or sets a value indicating whether .
Public property | Anchor | (inherited from ToolStrip).
Public property | AutoHideBar | Gets/Sets if NetMDIBar must be hidden if no mdi child forms is visible
Public property | AutoHideClose | Gets/Sets Close Button must be hidden if a child form is maximized
Public property | AutoScroll | (inherited from ToolStrip).
Public property | AutoScrollMargin | (inherited from ToolStrip).
Public property | AutoScrollMinSize | (inherited from ToolStrip).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ToolStrip).
Public property | AutoSize | (inherited from ToolStrip).
Public property | BackColor | (inherited from ToolStrip).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from ToolStrip).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanOverflow | (Overloaded) Gets or sets a value indicating whether .
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from ToolStrip).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorCloseButton | Gets/Sets colour of text buttons
Public property | ColorTextButton | Gets/Sets colour of text buttons
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from ToolStrip).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from ToolStrip).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
Public property | DefaultDropDownDirection | (inherited from ToolStrip).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ToolStrip).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from ToolStrip).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from ToolStrip).
Public property | ForeColor | (inherited from ToolStrip).
Public property | GripDisplayStyle | (Overloaded) Gets .
Public property | GripMargin | (Overloaded) Gets or sets .
Public property | GripRectangle | (Overloaded) Gets .
Public property | GripStyle | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from ToolStrip).
Public property | Height | (inherited from Control).
Public property | Hidden | Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True.
Public property | HorizontalScroll | (inherited from ToolStrip).
Public property | ImageList | (Overloaded) Gets or sets .
Public property | ImageScalingSize | (inherited from ToolStrip).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsCurrentlyDragging | (inherited from ToolStrip).
Public property | IsDisposed | (inherited from Control).
Public property | IsDropDown | (inherited from ToolStrip).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (Overloaded) Gets .
Public property | LayoutSettings | (Overloaded) Gets or sets .
Public property | LayoutStyle | (Overloaded) Gets or sets .
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | (inherited from ToolStrip).
Public property | OverflowButton | (inherited from ToolStrip).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | PreviewWindow | Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton.
Public property | PreviewWindowBorderColor | Gets/Sets the color used to paint border of MDI Child Preview Window.
Public property | PreviewWindowBorderSize | Gets/Sets the border size of MDI Child Preview Window.
Public property | PreviewWindowColor | Gets/Sets the background color for Preview Window of MDI Child.
Public property | PreviewWindowGradientColor | Gets/Sets the gradient color used to paint Preview Window backgound.
Public property | PreviewWindowGradientEnabled | Gets/Sets if a Preview Window must be paint with a gradient effect.
Public property | PreviewWindowGradientStyle | Gets/Sets the gradient style effect used to paint Preview Window backgound.
Public property | PreviewWindowOpacity | Gets/Sets the opacity of MDI Child Preview Window.
Public property | PreviewWindowPercentScale | Gets/Sets the form percentage scaling factor of MDI Child Preview Window.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | RenderMode | (inherited from ToolStrip).
Public property | Renderer | (inherited from ToolStrip).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedButton | Gets/Sets the currently selected button.
Public property | ShowIcons | Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons
Public property | ShowItemToolTips | (inherited from ToolStrip).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Stretch | (Overloaded) Gets or sets a value indicating whether .
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from ToolStrip).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextDirection | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ToolStrip).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | AddMDIChild | Manually add a new MDI child form to MDIBar buttons.
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | ContainsForm | Gets a value indicating if specified Mdi Child Form is hosted by the control
Public method | FindButton | Finds a NetMdiButton from a Form.
Public method | FindNextButton | Gets next available NetMDIButton starting from specified NetMDIButton
Public method | FindPrevButton | Gets available visible NetMDIButton starting from specified NetMDIButton
Public method | GetChildAtPoint | (Overloaded) (inherited from ToolStrip).
Public method | GetItemAt | (Overloaded) (inherited from ToolStrip).
Public method | GetNextItem | (inherited from ToolStrip).
Public method | GetPreferredSize | (inherited from Control).
Public method | MDIChildActivate | Activate spedificed Form (use this method for mdi child forms)
Public method | RefreshBar | Refresh MDIBar buttons
Public method | ResetBindings | (inherited from Control).
Public method | ResetMinimumSize | (inherited from ToolStrip).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ToolStrip).
Public method | ToString | (inherited from ToolStrip).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from ToolStrip).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BeginDrag | (inherited from ToolStrip).
Public event | BindingContextChanged | (inherited from Control).
Public event | ButtonClick | This event will be generated every type the user click on a NetMDIButton that host a child form
Public event | CausesValidationChanged | (inherited from ToolStrip).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from ToolStrip).
Public event | ControlRemoved | (inherited from ToolStrip).
Public event | CursorChanged | (inherited from ToolStrip).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | EndDrag | (inherited from ToolStrip).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from ToolStrip).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemAdded | (inherited from ToolStrip).
Public event | ItemClicked | (inherited from ToolStrip).
Public event | ItemRemoved | (inherited from ToolStrip).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | LayoutCompleted | (inherited from ToolStrip).
Public event | LayoutStyleChanged | (inherited from ToolStrip).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | PaintGrip | (inherited from ToolStrip).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | RendererChanged | (inherited from ToolStrip).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedButtonChanged | This event will be generated every time current selected button will be changed
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetMDIBar Class


NetMDIBar Properties

NetMDIBar Class See Also

The following tables list the members exposed by the NetMDIBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveBold | Gets/Sets whether bold font text must be used for active button
Public property | AllowDrop | (inherited from ToolStrip).
Public property | AllowItemReorder | (Overloaded) Gets or sets a value indicating whether .
Public property | AllowMerge | (Overloaded) Gets or sets a value indicating whether .
Public property | Anchor | (inherited from ToolStrip).
Public property | AutoHideBar | Gets/Sets if NetMDIBar must be hidden if no mdi child forms is visible
Public property | AutoHideClose | Gets/Sets Close Button must be hidden if a child form is maximized
Public property | AutoScroll | (inherited from ToolStrip).
Public property | AutoScrollMargin | (inherited from ToolStrip).
Public property | AutoScrollMinSize | (inherited from ToolStrip).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ToolStrip).
Public property | AutoSize | (inherited from ToolStrip).
Public property | BackColor | (inherited from ToolStrip).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from ToolStrip).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanOverflow | (Overloaded) Gets or sets a value indicating whether .
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from ToolStrip).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | ColorCloseButton | Gets/Sets colour of text buttons
Public property | ColorTextButton | Gets/Sets colour of text buttons
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from ToolStrip).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from ToolStrip).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
Public property | DefaultDropDownDirection | (inherited from ToolStrip).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ToolStrip).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from ToolStrip).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from ToolStrip).
Public property | ForeColor | (inherited from ToolStrip).
Public property | GripDisplayStyle | (Overloaded) Gets .
Public property | GripMargin | (Overloaded) Gets or sets .
Public property | GripRectangle | (Overloaded) Gets .
Public property | GripStyle | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from ToolStrip).
Public property | Height | (inherited from Control).
Public property | Hidden | Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True.
Public property | HorizontalScroll | (inherited from ToolStrip).
Public property | ImageList | (Overloaded) Gets or sets .
Public property | ImageScalingSize | (inherited from ToolStrip).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsCurrentlyDragging | (inherited from ToolStrip).
Public property | IsDisposed | (inherited from Control).
Public property | IsDropDown | (inherited from ToolStrip).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | Items | (Overloaded) Gets .
Public property | LayoutEngine | (Overloaded) Gets .
Public property | LayoutSettings | (Overloaded) Gets or sets .
Public property | LayoutStyle | (Overloaded) Gets or sets .
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | (inherited from ToolStrip).
Public property | OverflowButton | (inherited from ToolStrip).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | PreviewWindow | Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton.
Public property | PreviewWindowBorderColor | Gets/Sets the color used to paint border of MDI Child Preview Window.
Public property | PreviewWindowBorderSize | Gets/Sets the border size of MDI Child Preview Window.
Public property | PreviewWindowColor | Gets/Sets the background color for Preview Window of MDI Child.
Public property | PreviewWindowGradientColor | Gets/Sets the gradient color used to paint Preview Window backgound.
Public property | PreviewWindowGradientEnabled | Gets/Sets if a Preview Window must be paint with a gradient effect.
Public property | PreviewWindowGradientStyle | Gets/Sets the gradient style effect used to paint Preview Window backgound.
Public property | PreviewWindowOpacity | Gets/Sets the opacity of MDI Child Preview Window.
Public property | PreviewWindowPercentScale | Gets/Sets the form percentage scaling factor of MDI Child Preview Window.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | RenderMode | (inherited from ToolStrip).
Public property | Renderer | (inherited from ToolStrip).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedButton | Gets/Sets the currently selected button.
Public property | ShowIcons | Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons
Public property | ShowItemToolTips | (inherited from ToolStrip).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Stretch | (Overloaded) Gets or sets a value indicating whether .
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from ToolStrip).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | TextDirection | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ToolStrip).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetMDIBar Class


NetMDIBar.ActiveBold Property

Gets/Sets whether bold font text must be used for active button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/sets whether bold font text must be used for active button")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property ActiveBold( _
   ByRef "Gets/sets whether bold font text must be used for active button" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/sets whether bold font text must be used for active button")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("ActiveBold")]
public bool this[
   ref object "Gets/sets whether bold font text must be used for active button"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets whether bold font text must be used for active button"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AllowItemReorder Property

NetMDIBar Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AllowItemReorder | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AllowMerge Property

NetMDIBar Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AllowMerge | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AutoHideBar Property

Gets/Sets if NetMDIBar must be hidden if no mdi child forms is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets if NetMDIBar must be hidden if no mdi child forms are displayed")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoHideBar( _
   ByRef "Gets/Sets if NetMDIBar must be hidden if no mdi child forms are displayed" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets if NetMDIBar must be hidden if no mdi child forms are displayed")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoHideBar")]
public bool this[
   ref object "Gets/Sets if NetMDIBar must be hidden if no mdi child forms are displayed"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if NetMDIBar must be hidden if no mdi child forms are displayed"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AutoHideClose Property

Gets/Sets Close Button must be hidden if a child form is maximized

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets Close Button must be hidden if a child form is maximized")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoHideClose( _
   ByRef "Gets/Sets Close Button must be hidden if a child form is maximized" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets Close Button must be hidden if a child form is maximized")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoHideClose")]
public bool this[
   ref object "Gets/Sets Close Button must be hidden if a child form is maximized"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets Close Button must be hidden if a child form is maximized"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.CanOverflow Property

NetMDIBar Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CanOverflow | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ColorCloseButton Property

Gets/Sets colour of text buttons

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets text colour for close button")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Red")> _
Public Property ColorCloseButton( _
   ByRef "Gets/Sets text colour for close button" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets text colour for close button")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Red")]
[System.Runtime.CompilerServices.IndexerName("ColorCloseButton")]
public Color this[
   ref object "Gets/Sets text colour for close button"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets text colour for close button"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ColorTextButton Property

Gets/Sets colour of text buttons

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets text colour for buttons")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.KnownColor), "ControlText")> _
Public Property ColorTextButton( _
   ByRef "Gets/Sets text colour for buttons" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets text colour for buttons")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.KnownColor), "ControlText")]
[System.Runtime.CompilerServices.IndexerName("ColorTextButton")]
public Color this[
   ref object "Gets/Sets text colour for buttons"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets text colour for buttons"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripDisplayStyle Property

NetMDIBar Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
GripDisplayStyle | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripMargin Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
GripMargin | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripRectangle Property

NetMDIBar Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
GripRectangle | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripStyle Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
GripStyle | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.Hidden Property

Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True.")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property Hidden( _
   ByRef "Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True.")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("Hidden")]
public bool this[
   ref object "Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if NetMDIBar must be hidden also if AutoHideBar is sets to True."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ImageList Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ImageList | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.Items Property

NetMDIBar Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
Items | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutEngine Property

NetMDIBar Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
LayoutEngine | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutSettings Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
LayoutSettings | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutStyle Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
LayoutStyle | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.MaximumSize Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MaximumSize | (System.Windows.Forms.Control).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.MinimumSize Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MinimumSize | (System.Windows.Forms.Control).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindow Property

Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property PreviewWindow( _
   ByRef "Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("PreviewWindow")]
public bool this[
   ref object "Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if a Preview Window of MDI Child will be displayed when mouse is over NetMDIButton."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowBorderColor Property

Gets/Sets the color used to paint border of MDI Child Preview Window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the color used to paint border of MDI Child Preview Window.")> _
<DefaultValue(GetType(Color), "WindowFrame")> _
Public Property PreviewWindowBorderColor( _
   ByRef "Gets/Sets the color used to paint border of MDI Child Preview Window." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the color used to paint border of MDI Child Preview Window.")]
[DefaultValue(GetType(Color), "WindowFrame")]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowBorderColor")]
public Color this[
   ref object "Gets/Sets the color used to paint border of MDI Child Preview Window."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the color used to paint border of MDI Child Preview Window."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowBorderSize Property

Gets/Sets the border size of MDI Child Preview Window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the border size of MDI Child Preview Window.")> _
<DefaultValue(8)> _
Public Property PreviewWindowBorderSize( _
   ByRef "Gets/Sets the border size of MDI Child Preview Window." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the border size of MDI Child Preview Window.")]
[DefaultValue(8)]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowBorderSize")]
public int this[
   ref object "Gets/Sets the border size of MDI Child Preview Window."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the border size of MDI Child Preview Window."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowColor Property

Gets/Sets the background color for Preview Window of MDI Child.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the background color for  Preview Window of MDI Child.")> _
<DefaultValue(GetType(Color), "Desktop")> _
Public Property PreviewWindowColor( _
   ByRef "Gets/Sets the background color for  Preview Window of MDI Child." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the background color for  Preview Window of MDI Child.")]
[DefaultValue(GetType(Color), "Desktop")]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowColor")]
public Color this[
   ref object "Gets/Sets the background color for  Preview Window of MDI Child."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the background color for Preview Window of MDI Child."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowGradientColor Property

Gets/Sets the gradient color used to paint Preview Window backgound.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the gradient color used to paint Preview Window backgound.")> _
<DefaultValue(GetType(Color), "Window")> _
Public Property PreviewWindowGradientColor( _
   ByRef "Gets/Sets the gradient color used to paint Preview Window backgound." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the gradient color used to paint Preview Window backgound.")]
[DefaultValue(GetType(Color), "Window")]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowGradientColor")]
public Color this[
   ref object "Gets/Sets the gradient color used to paint Preview Window backgound."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the gradient color used to paint Preview Window backgound."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowGradientEnabled Property

Gets/Sets if a Preview Window must be paint with a gradient effect.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets if a Preview Window must be paint with a gradient effect.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property PreviewWindowGradientEnabled( _
   ByRef "Gets/Sets if a Preview Window must be paint with a gradient effect." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets if a Preview Window must be paint with a gradient effect.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowGradientEnabled")]
public bool this[
   ref object "Gets/Sets if a Preview Window must be paint with a gradient effect."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if a Preview Window must be paint with a gradient effect."

Type: object

Remarks

Preview Window of Active MDI Child is never displayed.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowGradientStyle Property

Gets/Sets the gradient style effect used to paint Preview Window backgound.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the gradient style effect used to paint Preview Window backgound.")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Vertical")> _
Public Property PreviewWindowGradientStyle( _
   ByRef "Gets/Sets the gradient style effect used to paint Preview Window backgound." As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the gradient style effect used to paint Preview Window backgound.")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Vertical")]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowGradientStyle")]
public LinearGradientMode this[
   ref object "Gets/Sets the gradient style effect used to paint Preview Window backgound."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the gradient style effect used to paint Preview Window backgound."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowOpacity Property

Gets/Sets the opacity of MDI Child Preview Window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the opacity of MDI Child Preview Window.")> _
<DefaultValue(CDbl(1))> _
Public Property PreviewWindowOpacity( _
   ByRef "Gets/Sets the opacity of MDI Child Preview Window." As Object _
) As Double
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the opacity of MDI Child Preview Window.")]
[DefaultValue(CDbl(1))]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowOpacity")]
public double this[
   ref object "Gets/Sets the opacity of MDI Child Preview Window."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the opacity of MDI Child Preview Window."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.PreviewWindowPercentScale Property

Gets/Sets the form percentage scaling factor of MDI Child Preview Window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetMDIBar")> _
<Description("Gets/Sets the form percentage scaling factor of MDI Child Preview Window.")> _
<DefaultValue(60)> _
Public Property PreviewWindowPercentScale( _
   ByRef "Gets/Sets the form percentage scaling factor of MDI Child Preview Window." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetMDIBar")]
[Description("Gets/Sets the form percentage scaling factor of MDI Child Preview Window.")]
[DefaultValue(60)]
[System.Runtime.CompilerServices.IndexerName("PreviewWindowPercentScale")]
public int this[
   ref object "Gets/Sets the form percentage scaling factor of MDI Child Preview Window."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the form percentage scaling factor of MDI Child Preview Window."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.SelectedButton Property

Gets/Sets the currently selected button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property SelectedButton( _
   ByRef False As Object _
) As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("SelectedButton")]
public NetMDIButton this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ShowIcons Property

Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetMDIBar")> _
<System.ComponentModel.Description("Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property ShowIcons( _
   ByRef "Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetMDIBar")]
[System.ComponentModel.Description("Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("ShowIcons")]
public bool this[
   ref object "Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if Icons of mdi child forms must be shown on NetMDIButtons"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.Stretch Property

NetMDIBar Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
Stretch | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.TextDirection Property

NetMDIBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
TextDirection | (System.Windows.Forms.ToolStrip).
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar Methods

NetMDIBar Class See Also

The following tables list the members exposed by the NetMDIBar type.

Methods
 | Name | Description
Public method | AddMDIChild | Manually add a new MDI child form to MDIBar buttons.
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | ContainsForm | Gets a value indicating if specified Mdi Child Form is hosted by the control
Public method | FindButton | Finds a NetMdiButton from a Form.
Public method | FindNextButton | Gets next available NetMDIButton starting from specified NetMDIButton
Public method | FindPrevButton | Gets available visible NetMDIButton starting from specified NetMDIButton
Public method | GetChildAtPoint | (Overloaded) (inherited from ToolStrip).
Public method | GetItemAt | (Overloaded) (inherited from ToolStrip).
Public method | GetNextItem | (inherited from ToolStrip).
Public method | GetPreferredSize | (inherited from Control).
Public method | MDIChildActivate | Activate spedificed Form (use this method for mdi child forms)
Public method | RefreshBar | Refresh MDIBar buttons
Public method | ResetBindings | (inherited from Control).
Public method | ResetMinimumSize | (inherited from ToolStrip).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ToolStrip).
Public method | ToString | (inherited from ToolStrip).
Top
See Also

Reference

NetMDIBar Class


NetMDIBar.AddMDIChild Method

Manually add a new MDI child form to MDIBar buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function AddMDIChild( _
   ByVal oForm As Form _
) As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButton AddMDIChild(
   Form oForm
)
This language is not supported or no code example is available.

Parameters

oForm

Type: Form

A valid Mdi Child Form

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ContainsForm Method

Gets a value indicating if specified Mdi Child Form is hosted by the control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ContainsForm( _
   ByVal oForm As Form _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool ContainsForm(
   Form oForm
)
This language is not supported or no code example is available.

Parameters

oForm

Type: Form

A valid Mdi Child Form

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.FindButton Method

Finds a NetMdiButton from a Form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function FindButton( _
   ByVal oForm As Form _
) As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButton FindButton(
   Form oForm
)
This language is not supported or no code example is available.

Parameters

oForm

Type: Form

A valid Mdi Child Form

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.FindNextButton Method

Gets next available NetMDIButton starting from specified NetMDIButton

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function FindNextButton( _
   ByVal oButton As NetMDIButton _
) As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButton FindNextButton(
   NetMDIButton oButton
)
This language is not supported or no code example is available.

Parameters

oButton

Type: NetMDIButton

A valid NetMDIButton

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.FindPrevButton Method

Gets available visible NetMDIButton starting from specified NetMDIButton

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function FindPrevButton( _
   ByVal oButton As NetMDIButton _
) As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButton FindPrevButton(
   NetMDIButton oButton
)
This language is not supported or no code example is available.

Parameters

oButton

Type: NetMDIButton

A valid NetMDIButton

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.MDIChildActivate Method

Activate spedificed Form (use this method for mdi child forms)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub MDIChildActivate( _
   ByVal oForm As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void MDIChildActivate(
   Form oForm
)
This language is not supported or no code example is available.

Parameters

oForm

Type: Form

A valid Form object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.RefreshBar Method

Refresh MDIBar buttons

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub RefreshBar()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RefreshBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar Events

NetMDIBar Class See Also

The following tables list the members exposed by the NetMDIBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from ToolStrip).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BeginDrag | (inherited from ToolStrip).
Public event | BindingContextChanged | (inherited from Control).
Public event | ButtonClick | This event will be generated every type the user click on a NetMDIButton that host a child form
Public event | CausesValidationChanged | (inherited from ToolStrip).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from ToolStrip).
Public event | ControlRemoved | (inherited from ToolStrip).
Public event | CursorChanged | (inherited from ToolStrip).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | EndDrag | (inherited from ToolStrip).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from ToolStrip).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | ItemAdded | (inherited from ToolStrip).
Public event | ItemClicked | (inherited from ToolStrip).
Public event | ItemRemoved | (inherited from ToolStrip).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | LayoutCompleted | (inherited from ToolStrip).
Public event | LayoutStyleChanged | (inherited from ToolStrip).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | PaintGrip | (inherited from ToolStrip).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | RendererChanged | (inherited from ToolStrip).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedButtonChanged | This event will be generated every time current selected button will be changed
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetMDIBar Class


ButtonClick Event

This event will be generated every type the user click on a NetMDIButton that host a child form

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ButtonClick( _
   ByVal sender As Object, _
   ByVal e As NetMDIButtonClickEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ButtonClickEventHandler ButtonClick
delegate void ButtonClickEventHandler(
   object sender,
   NetMDIButtonClickEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The event sender object

e

Type: NetMDIButtonClickEventArgs

A NetMDIButtonClickEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


SelectedButtonChanged Event

This event will be generated every time current selected button will be changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event SelectedButtonChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event SelectedButtonChangedEventHandler SelectedButtonChanged
delegate void SelectedButtonChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The event sender object

e

Type: EventArgs

A System.EventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIButton Class

Members

NetMDIButton is a special ToolStripButton that handles MDIChild forms activity'''

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(False)> _
<System.Windows.Forms.Design.ToolStripItemDesignerAvailability(System.Windows.Forms.Design.ToolStripItemDesignerAvailability.None)> _
Public Class NetMDIButton
    Inherits ToolStripButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(False)]
[System.Windows.Forms.Design.ToolStripItemDesignerAvailability(System.Windows.Forms.Design.ToolStripItemDesignerAvailability.None)]
public class NetMDIButton : ToolStripButton
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.ToolStripItem
System.Windows.Forms.ToolStripButton
Softgroup.NetControls.NetMDIButton
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButton Members


NetMDIButton Members

NetMDIButton Class Events Methods Properties See Also

NetMDIButton is a special ToolStripButton that handles MDIChild forms activity'''

The following tables list the members exposed by the NetMDIButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from ToolStripItem).
Public property | AccessibleDefaultActionDescription | (inherited from ToolStripItem).
Public property | AccessibleDescription | (inherited from ToolStripItem).
Public property | AccessibleName | (inherited from ToolStripItem).
Public property | AccessibleRole | (inherited from ToolStripItem).
Public property | Alignment | (inherited from ToolStripItem).
Public property | AllowDrop | (inherited from ToolStripItem).
Public property | Anchor | (inherited from ToolStripItem).
Public property | AutoSize | (inherited from ToolStripItem).
Public property | AutoToolTip | (inherited from ToolStripButton).
Public property | Available | (inherited from ToolStripItem).
Public property | BackColor | (inherited from ToolStripItem).
Public property | BackgroundImage | (inherited from ToolStripItem).
Public property | BackgroundImageLayout | (inherited from ToolStripItem).
Public property | Bounds | (inherited from ToolStripItem).
Public property | CanSelect | (inherited from ToolStripButton).
Public property | CheckOnClick | (inherited from ToolStripButton).
Public property | CheckState | (inherited from ToolStripButton).
Public property | Checked | (inherited from ToolStripButton).
Public property | Container | (inherited from Component).
Public property | ContentRectangle | (inherited from ToolStripItem).
Public property | DisplayStyle | (inherited from ToolStripItem).
Public property | Dock | (inherited from ToolStripItem).
Public property | DoubleClickEnabled | (inherited from ToolStripItem).
Public property | Enabled | (inherited from ToolStripItem).
Public property | Font | (inherited from ToolStripItem).
Public property | ForeColor | (inherited from ToolStripItem).
Public property | Height | (inherited from ToolStripItem).
Public property | Hidden | Gets/Sets if Button is Hidden into NetMDIBar control.
Public property | Image | (inherited from ToolStripItem).
Public property | ImageAlign | (inherited from ToolStripItem).
Public property | ImageIndex | (inherited from ToolStripItem).
Public property | ImageKey | (inherited from ToolStripItem).
Public property | ImageScaling | (inherited from ToolStripItem).
Public property | ImageTransparentColor | (inherited from ToolStripItem).
Public property | IsDisposed | (inherited from ToolStripItem).
Public property | IsOnDropDown | (inherited from ToolStripItem).
Public property | IsOnOverflow | (inherited from ToolStripItem).
Public property | MDIChild | Gets the MDIChild Form associated with this NetMDIButton.
Public property | Margin | (inherited from ToolStripItem).
Public property | MergeAction | (inherited from ToolStripItem).
Public property | MergeIndex | (inherited from ToolStripItem).
Public property | Name | (inherited from ToolStripItem).
Public property | Overflow | (inherited from ToolStripItem).
Public property | Owner | (inherited from ToolStripItem).
Public property | OwnerItem | (inherited from ToolStripItem).
Public property | Padding | (inherited from ToolStripItem).
Public property | Placement | (inherited from ToolStripItem).
Public property | Pressed | (inherited from ToolStripItem).
Public property | RightToLeft | (inherited from ToolStripItem).
Public property | RightToLeftAutoMirrorImage | (inherited from ToolStripItem).
Public property | Selected | (inherited from ToolStripItem).
Public property | Site | (inherited from Component).
Public property | Size | (inherited from ToolStripItem).
Public property | Tag | (inherited from ToolStripItem).
Public property | Text | (inherited from ToolStripItem).
Public property | TextAlign | (inherited from ToolStripItem).
Public property | TextDirection | (inherited from ToolStripItem).
Public property | TextImageRelation | (inherited from ToolStripItem).
Public property | ToolTipText | (inherited from ToolStripItem).
Public property | Visible | (inherited from ToolStripItem).
Public property | Width | (inherited from ToolStripItem).
Top
Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | DoDragDrop | (inherited from ToolStripItem).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetCurrentParent | (inherited from ToolStripItem).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetPreferredSize | (inherited from ToolStripButton).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) (inherited from ToolStripItem).
Public method | IsActiveMDIChild | Return True if MDIChild Form associated with this NetMDIButton is the Active MDI Child Window.
Public method | PerformClick | (inherited from ToolStripItem).
Public method | ResetBackColor | (inherited from ToolStripItem).
Public method | ResetDisplayStyle | (inherited from ToolStripItem).
Public method | ResetFont | (inherited from ToolStripItem).
Public method | ResetForeColor | (inherited from ToolStripItem).
Public method | ResetImage | (inherited from ToolStripItem).
Public method | ResetMargin | (inherited from ToolStripItem).
Public method | ResetPadding | (inherited from ToolStripItem).
Public method | ResetRightToLeft | (inherited from ToolStripItem).
Public method | ResetTextDirection | (inherited from ToolStripItem).
Public method | Select | (inherited from ToolStripItem).
Public method | ToString | (inherited from ToolStripItem).
Top
Events
 | Name | Description
Public event | AvailableChanged | (inherited from ToolStripItem).
Public event | BackColorChanged | (inherited from ToolStripItem).
Public event | CheckStateChanged | (inherited from ToolStripButton).
Public event | CheckedChanged | (inherited from ToolStripButton).
Public event | Click | (inherited from ToolStripItem).
Public event | DisplayStyleChanged | (inherited from ToolStripItem).
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | (inherited from ToolStripItem).
Public event | DragDrop | (inherited from ToolStripItem).
Public event | DragEnter | (inherited from ToolStripItem).
Public event | DragLeave | (inherited from ToolStripItem).
Public event | DragOver | (inherited from ToolStripItem).
Public event | EnabledChanged | (inherited from ToolStripItem).
Public event | ForeColorChanged | (inherited from ToolStripItem).
Public event | GiveFeedback | (inherited from ToolStripItem).
Public event | LocationChanged | (inherited from ToolStripItem).
Public event | MouseDown | (inherited from ToolStripItem).
Public event | MouseEnter | (inherited from ToolStripItem).
Public event | MouseHover | (inherited from ToolStripItem).
Public event | MouseLeave | (inherited from ToolStripItem).
Public event | MouseMove | (inherited from ToolStripItem).
Public event | MouseUp | (inherited from ToolStripItem).
Public event | OwnerChanged | (inherited from ToolStripItem).
Public event | Paint | (inherited from ToolStripItem).
Public event | QueryAccessibilityHelp | (inherited from ToolStripItem).
Public event | QueryContinueDrag | (inherited from ToolStripItem).
Public event | RightToLeftChanged | (inherited from ToolStripItem).
Public event | TextChanged | (inherited from ToolStripItem).
Public event | VisibleChanged | (inherited from ToolStripItem).
Top
See Also

Reference

NetMDIButton Class


NetMDIButton Properties

NetMDIButton Class See Also

The following tables list the members exposed by the NetMDIButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from ToolStripItem).
Public property | AccessibleDefaultActionDescription | (inherited from ToolStripItem).
Public property | AccessibleDescription | (inherited from ToolStripItem).
Public property | AccessibleName | (inherited from ToolStripItem).
Public property | AccessibleRole | (inherited from ToolStripItem).
Public property | Alignment | (inherited from ToolStripItem).
Public property | AllowDrop | (inherited from ToolStripItem).
Public property | Anchor | (inherited from ToolStripItem).
Public property | AutoSize | (inherited from ToolStripItem).
Public property | AutoToolTip | (inherited from ToolStripButton).
Public property | Available | (inherited from ToolStripItem).
Public property | BackColor | (inherited from ToolStripItem).
Public property | BackgroundImage | (inherited from ToolStripItem).
Public property | BackgroundImageLayout | (inherited from ToolStripItem).
Public property | Bounds | (inherited from ToolStripItem).
Public property | CanSelect | (inherited from ToolStripButton).
Public property | CheckOnClick | (inherited from ToolStripButton).
Public property | CheckState | (inherited from ToolStripButton).
Public property | Checked | (inherited from ToolStripButton).
Public property | Container | (inherited from Component).
Public property | ContentRectangle | (inherited from ToolStripItem).
Public property | DisplayStyle | (inherited from ToolStripItem).
Public property | Dock | (inherited from ToolStripItem).
Public property | DoubleClickEnabled | (inherited from ToolStripItem).
Public property | Enabled | (inherited from ToolStripItem).
Public property | Font | (inherited from ToolStripItem).
Public property | ForeColor | (inherited from ToolStripItem).
Public property | Height | (inherited from ToolStripItem).
Public property | Hidden | Gets/Sets if Button is Hidden into NetMDIBar control.
Public property | Image | (inherited from ToolStripItem).
Public property | ImageAlign | (inherited from ToolStripItem).
Public property | ImageIndex | (inherited from ToolStripItem).
Public property | ImageKey | (inherited from ToolStripItem).
Public property | ImageScaling | (inherited from ToolStripItem).
Public property | ImageTransparentColor | (inherited from ToolStripItem).
Public property | IsDisposed | (inherited from ToolStripItem).
Public property | IsOnDropDown | (inherited from ToolStripItem).
Public property | IsOnOverflow | (inherited from ToolStripItem).
Public property | MDIChild | Gets the MDIChild Form associated with this NetMDIButton.
Public property | Margin | (inherited from ToolStripItem).
Public property | MergeAction | (inherited from ToolStripItem).
Public property | MergeIndex | (inherited from ToolStripItem).
Public property | Name | (inherited from ToolStripItem).
Public property | Overflow | (inherited from ToolStripItem).
Public property | Owner | (inherited from ToolStripItem).
Public property | OwnerItem | (inherited from ToolStripItem).
Public property | Padding | (inherited from ToolStripItem).
Public property | Placement | (inherited from ToolStripItem).
Public property | Pressed | (inherited from ToolStripItem).
Public property | RightToLeft | (inherited from ToolStripItem).
Public property | RightToLeftAutoMirrorImage | (inherited from ToolStripItem).
Public property | Selected | (inherited from ToolStripItem).
Public property | Site | (inherited from Component).
Public property | Size | (inherited from ToolStripItem).
Public property | Tag | (inherited from ToolStripItem).
Public property | Text | (inherited from ToolStripItem).
Public property | TextAlign | (inherited from ToolStripItem).
Public property | TextDirection | (inherited from ToolStripItem).
Public property | TextImageRelation | (inherited from ToolStripItem).
Public property | ToolTipText | (inherited from ToolStripItem).
Public property | Visible | (inherited from ToolStripItem).
Public property | Width | (inherited from ToolStripItem).
Top
See Also

Reference

NetMDIButton Class


NetMDIButton.Hidden Property

Gets/Sets if Button is Hidden into NetMDIBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property Hidden() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Hidden {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButton Class
NetMDIButton Members


NetMDIButton.MDIChild Property

Gets the MDIChild Form associated with this NetMDIButton.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property MDIChild() As Form
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Form MDIChild {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButton Class
NetMDIButton Members


NetMDIButton Methods

NetMDIButton Class See Also

The following tables list the members exposed by the NetMDIButton type.

Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | DoDragDrop | (inherited from ToolStripItem).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetCurrentParent | (inherited from ToolStripItem).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | GetPreferredSize | (inherited from ToolStripButton).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) (inherited from ToolStripItem).
Public method | IsActiveMDIChild | Return True if MDIChild Form associated with this NetMDIButton is the Active MDI Child Window.
Public method | PerformClick | (inherited from ToolStripItem).
Public method | ResetBackColor | (inherited from ToolStripItem).
Public method | ResetDisplayStyle | (inherited from ToolStripItem).
Public method | ResetFont | (inherited from ToolStripItem).
Public method | ResetForeColor | (inherited from ToolStripItem).
Public method | ResetImage | (inherited from ToolStripItem).
Public method | ResetMargin | (inherited from ToolStripItem).
Public method | ResetPadding | (inherited from ToolStripItem).
Public method | ResetRightToLeft | (inherited from ToolStripItem).
Public method | ResetTextDirection | (inherited from ToolStripItem).
Public method | Select | (inherited from ToolStripItem).
Public method | ToString | (inherited from ToolStripItem).
Top
See Also

Reference

NetMDIButton Class


NetMDIButton.IsActiveMDIChild Method

Return True if MDIChild Form associated with this NetMDIButton is the Active MDI Child Window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IsActiveMDIChild() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool IsActiveMDIChild()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButton Class
NetMDIButton Members


NetMDIButton Events

NetMDIButton Class See Also

The following tables list the members exposed by the NetMDIButton type.

Events
 | Name | Description
Public event | AvailableChanged | (inherited from ToolStripItem).
Public event | BackColorChanged | (inherited from ToolStripItem).
Public event | CheckStateChanged | (inherited from ToolStripButton).
Public event | CheckedChanged | (inherited from ToolStripButton).
Public event | Click | (inherited from ToolStripItem).
Public event | DisplayStyleChanged | (inherited from ToolStripItem).
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | (inherited from ToolStripItem).
Public event | DragDrop | (inherited from ToolStripItem).
Public event | DragEnter | (inherited from ToolStripItem).
Public event | DragLeave | (inherited from ToolStripItem).
Public event | DragOver | (inherited from ToolStripItem).
Public event | EnabledChanged | (inherited from ToolStripItem).
Public event | ForeColorChanged | (inherited from ToolStripItem).
Public event | GiveFeedback | (inherited from ToolStripItem).
Public event | LocationChanged | (inherited from ToolStripItem).
Public event | MouseDown | (inherited from ToolStripItem).
Public event | MouseEnter | (inherited from ToolStripItem).
Public event | MouseHover | (inherited from ToolStripItem).
Public event | MouseLeave | (inherited from ToolStripItem).
Public event | MouseMove | (inherited from ToolStripItem).
Public event | MouseUp | (inherited from ToolStripItem).
Public event | OwnerChanged | (inherited from ToolStripItem).
Public event | Paint | (inherited from ToolStripItem).
Public event | QueryAccessibilityHelp | (inherited from ToolStripItem).
Public event | QueryContinueDrag | (inherited from ToolStripItem).
Public event | RightToLeftChanged | (inherited from ToolStripItem).
Public event | TextChanged | (inherited from ToolStripItem).
Public event | VisibleChanged | (inherited from ToolStripItem).
Top
See Also

Reference

NetMDIButton Class


NetMDIButtonClickEventArgs Class

Members

Class NetMDIButtonClickEventArgs provide parameters events for NetMDIBar control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class NetMDIButtonClickEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class NetMDIButtonClickEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.NetMDIButtonClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButtonClickEventArgs Members


NetMDIButtonClickEventArgs Members

NetMDIButtonClickEventArgs Class Constructors Methods Properties See Also

Class NetMDIButtonClickEventArgs provide parameters events for NetMDIBar control.

The following tables list the members exposed by the NetMDIButtonClickEventArgs type.

Constructors
 | Name | Description
Public constructor | NetMDIButtonClickEventArgs Constructor | Initializes a new instance of the NetMDIButtonClickEventArgs class.
Top
Properties
 | Name | Description
Public property | Button | Return True if displayed page is last.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetMDIButtonClickEventArgs Class


NetMDIButtonClickEventArgs Constructor

Initializes a new instance of the NetMDIButtonClickEventArgs class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oButton As NetMDIButton _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButtonClickEventArgs(
   NetMDIButton oButton
)
This language is not supported or no code example is available.

Parameters

oButton

Type: NetMDIButton

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButtonClickEventArgs Class
NetMDIButtonClickEventArgs Members


NetMDIButtonClickEventArgs Properties

NetMDIButtonClickEventArgs Class See Also

The following tables list the members exposed by the NetMDIButtonClickEventArgs type.

Properties
 | Name | Description
Public property | Button | Return True if displayed page is last.
Top
See Also

Reference

NetMDIButtonClickEventArgs Class


NetMDIButtonClickEventArgs.Button Property

Return True if displayed page is last.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Button() As NetMDIButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIButton Button {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIButtonClickEventArgs Class
NetMDIButtonClickEventArgs Members


NetMDIButtonClickEventArgs Methods

NetMDIButtonClickEventArgs Class See Also

The following tables list the members exposed by the NetMDIButtonClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetMDIButtonClickEventArgs Class


NetMDIManager Class

Members

Softgroup .net NetMDIManager is an advanced component that provides new features for .Net MDI applications and eliminates flicker generated during showing or switching of maximized Mdi child forms.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetMDIManager), "NetMDIManager.bmp")> _
<System.ComponentModel.DefaultProperty("BackColor")> _
<System.ComponentModel.DefaultEvent("Disposed")> _
Public Class NetMDIManager
    Inherits NativeWindow
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetMDIManager), "NetMDIManager.bmp")]
[System.ComponentModel.DefaultProperty("BackColor")]
[System.ComponentModel.DefaultEvent("Disposed")]
public class NetMDIManager : NativeWindow
This language is not supported or no code example is available.
Remarks

Note that all properties provided by this component has effects only at runtime, not in design mode

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.Windows.Forms.NativeWindow
Softgroup.NetControls.NetMDIManager
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Members


NetMDIManager Members

NetMDIManager Class Constructors Events Methods Properties See Also

Softgroup .net NetMDIManager is an advanced component that provides new features for .Net MDI applications and eliminates flicker generated during showing or switching of maximized Mdi child forms.

The following tables list the members exposed by the NetMDIManager type.

Constructors
 | Name | Description
Public constructor | NetMDIManager Constructor | (Overloaded) Initializes a new instance of the class
Top
Properties
 | Name | Description
Public property | BackColor | Gets/Sets the background color for the control. This property will be applied only at runtime (at design time has no effetcs).
Public property | BorderStyle | Gets/Set border style for the control. This property will be applied only at runtime (at design time has no effetcs).
Public property | DoubleBuffer | Gets/Sets if double buffering of MDI Client area must be enabled.
Public property | Handle | Gets .
Public property | Image | Gets/Sets the image displayed into client area. This property will be applied only at runtime (at design time has no effetcs).
Public property | ImageAlign | Gets/Sets the alignment of the background image if any. Not available when RenderMode is set to Standard type.
Public property | ImageStretch | Gets/Sets a value indicating whether image must be stretched to fill the entire client area. Not available when RenderMode is set to Standard type.
Public property | MDIBar | Gets or sets .
Public property | MdiClient | Gets the MdiClient control.
Public property | ParentForm | Gets/Sets the Mdi parent form.
Public property | RenderMode | Gets/Sets type of control rendering.
Public property | ShowScrollbars | Gets/Sets a value indicating whether MDI client scrollbars are visible.
Public property | Site | Gets/Sets the ISite for the Component/>.
Top
Methods
 | Name | Description
Public method | AssignHandle | (inherited from NativeWindow).
Public method | CreateHandle | (inherited from NativeWindow).
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | DefWndProc | (inherited from NativeWindow).
Public method | DestroyHandle | (inherited from NativeWindow).
Public method | Dispose | Releases all resources used by the. NetMDIManager.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
 | FromHandle | (inherited from NativeWindow).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | MDIChildActivate | Activate spedificed Form (use this method to activate mdi child forms)
Public method | MDIChildActive | Gets current active MDI Child Form
Public method | Refresh | Refresh MDI client area
Public method | ReleaseHandle | (inherited from NativeWindow).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the control is disposed.
Top
See Also

Reference

NetMDIManager Class


NetMDIManager Constructor

NetMDIManager Class See Also

Initializes a new instance of the class

Overload List
Name | Description
NetMDIManager() | Initializes a new instance of the class
NetMDIManager(Form) | Initializes a new instance of the class with specified MDI parent form.
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager Properties

NetMDIManager Class See Also

The following tables list the members exposed by the NetMDIManager type.

Properties
 | Name | Description
Public property | BackColor | Gets/Sets the background color for the control. This property will be applied only at runtime (at design time has no effetcs).
Public property | BorderStyle | Gets/Set border style for the control. This property will be applied only at runtime (at design time has no effetcs).
Public property | DoubleBuffer | Gets/Sets if double buffering of MDI Client area must be enabled.
Public property | Handle | Gets .
Public property | Image | Gets/Sets the image displayed into client area. This property will be applied only at runtime (at design time has no effetcs).
Public property | ImageAlign | Gets/Sets the alignment of the background image if any. Not available when RenderMode is set to Standard type.
Public property | ImageStretch | Gets/Sets a value indicating whether image must be stretched to fill the entire client area. Not available when RenderMode is set to Standard type.
Public property | MDIBar | Gets or sets .
Public property | MdiClient | Gets the MdiClient control.
Public property | ParentForm | Gets/Sets the Mdi parent form.
Public property | RenderMode | Gets/Sets type of control rendering.
Public property | ShowScrollbars | Gets/Sets a value indicating whether MDI client scrollbars are visible.
Public property | Site | Gets/Sets the ISite for the Component/>.
Top
See Also

Reference

NetMDIManager Class


NetMDIManager.BackColor Property

Gets/Sets the background color for the control. This property will be applied only at runtime (at design time has no effetcs).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets the background color for the control. This property will be applied only at runtime (at design time has no effetcs).")> _
<DefaultValue(GetType(Color), "AppWorkspace")> _
Public Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets the background color for the control. This property will be applied only at runtime (at design time has no effetcs).")]
[DefaultValue(GetType(Color), "AppWorkspace")]
public Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.BorderStyle Property

Gets/Set border style for the control. This property will be applied only at runtime (at design time has no effetcs).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Set border style for the control. This property will be applied only at runtime (at design time has no effetcs).")> _
<DefaultValue(GetType(BorderStyle), "Fixed3D")> _
Public Property BorderStyle() As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Set border style for the control. This property will be applied only at runtime (at design time has no effetcs).")]
[DefaultValue(GetType(BorderStyle), "Fixed3D")]
public BorderStyle BorderStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.DoubleBuffer Property

Gets/Sets if double buffering of MDI Client area must be enabled.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Layout")> _
<Description("Gets/Sets if double buffering of MDI Client area must be enabled.")> _
<DefaultValue(False)> _
Public Property DoubleBuffer() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Layout")]
[Description("Gets/Sets if double buffering of MDI Client area must be enabled.")]
[DefaultValue(False)]
public bool DoubleBuffer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.Handle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
Public ReadOnly Shadows Property Handle() As IntPtr
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
new public IntPtr Handle {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.Image Property

Gets/Sets the image displayed into client area. This property will be applied only at runtime (at design time has no effetcs).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets the image displayed into client area. This property will be applied only at runtime (at design time has no effetcs).")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets the image displayed into client area. This property will be applied only at runtime (at design time has no effetcs).")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
public Image Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.ImageAlign Property

Gets/Sets the alignment of the background image if any. Not available when RenderMode is set to Standard type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets the alignment of the background image if any. Not available when RenderMode is set to Standard type.")> _
<DefaultValue(GetType(ContentAlignment), "MiddleCenter")> _
Public Property ImageAlign() As ContentAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets the alignment of the background image if any. Not available when RenderMode is set to Standard type.")]
[DefaultValue(GetType(ContentAlignment), "MiddleCenter")]
public ContentAlignment ImageAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.ImageStretch Property

Gets/Sets a value indicating whether image must be stretched to fill the entire client area. Not available when RenderMode is set to Standard type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets a value indicating whether image must be stretched to fill the entire client area. Not available when RenderMode is set to Standard type.")> _
<DefaultValue(False)> _
Public Property ImageStretch() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets a value indicating whether image must be stretched to fill the entire client area. Not available when RenderMode is set to Standard type.")]
[DefaultValue(False)]
public bool ImageStretch {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.MDIBar Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property MDIBar() As NetMDIBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetMDIBar MDIBar {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.MdiClient Property

Gets the MdiClient control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
Public ReadOnly Property MdiClient() As MdiClient
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
public MdiClient MdiClient {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.ParentForm Property

Gets/Sets the Mdi parent form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
Public Property ParentForm() As Form
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
public Form ParentForm {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.RenderMode Property

Gets/Sets type of control rendering.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets type of control rendering.")> _
<DefaultValue(GetType(RenderModeType), "Standard")> _
Public Property RenderMode() As RenderModeType
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets type of control rendering.")]
[DefaultValue(GetType(RenderModeType), "Standard")]
public RenderModeType RenderMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.ShowScrollbars Property

Gets/Sets a value indicating whether MDI client scrollbars are visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Layout")> _
<Description("Gets/Sets a value indicating whether MDI client scrollbars are visible.")> _
<DefaultValue(True)> _
Public Property ShowScrollbars() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Layout")]
[Description("Gets/Sets a value indicating whether MDI client scrollbars are visible.")]
[DefaultValue(True)]
public bool ShowScrollbars {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.Site Property

Gets/Sets the ISite for the Component/>.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public ISite Site {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager Methods

NetMDIManager Class See Also

The following tables list the members exposed by the NetMDIManager type.

Methods
 | Name | Description
Public method | AssignHandle | (inherited from NativeWindow).
Public method | CreateHandle | (inherited from NativeWindow).
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | DefWndProc | (inherited from NativeWindow).
Public method | DestroyHandle | (inherited from NativeWindow).
Public method | Dispose | Releases all resources used by the. NetMDIManager.
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
 | FromHandle | (inherited from NativeWindow).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | MDIChildActivate | Activate spedificed Form (use this method to activate mdi child forms)
Public method | MDIChildActive | Gets current active MDI Child Form
Public method | Refresh | Refresh MDI client area
Public method | ReleaseHandle | (inherited from NativeWindow).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetMDIManager Class


NetMDIManager.Dispose Method

Releases all resources used by the. NetMDIManager.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
public System.Void Dispose()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.MDIChildActivate Method

Activate spedificed Form (use this method to activate mdi child forms)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub MDIChildActivate( _
   ByVal oForm As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void MDIChildActivate(
   Form oForm
)
This language is not supported or no code example is available.

Parameters

oForm

Type: Form

A valid Form object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.MDIChildActive Method

Gets current active MDI Child Form

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function MDIChildActive() As Form
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Form MDIChildActive()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager.Refresh Method

Refresh MDI client area

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Refresh()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Refresh()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager Events

NetMDIManager Class See Also

The following tables list the members exposed by the NetMDIManager type.

Events
 | Name | Description
Public event | Disposed | Occurs when the control is disposed.
Top
See Also

Reference

NetMDIManager Class


Disposed Event

Occurs when the control is disposed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
public event DisposedEventHandler Disposed
delegate void DisposedEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetNotify Class

Members

Softgroup .Net Notify Message is a fast, small, lightweight and enhanced implementation of .Net MSN Messenger-like notification window.

To add a Softgroup .NetNotify to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetNotify), "NetNotify.bmp")> _
<System.ComponentModel.DefaultProperty("Text")> _
<System.ComponentModel.DefaultEvent("Clicked")> _
Public Class NetNotify
    Inherits Component
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetNotify), "NetNotify.bmp")]
[System.ComponentModel.DefaultProperty("Text")]
[System.ComponentModel.DefaultEvent("Clicked")]
public class NetNotify : Component
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Softgroup.NetControls.NetNotify
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Members


NetNotify Members

NetNotify Class Events Methods Properties See Also

Softgroup .Net Notify Message is a fast, small, lightweight and enhanced implementation of .Net MSN Messenger-like notification window.

To add a Softgroup .NetNotify to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

The following tables list the members exposed by the NetNotify type.

Properties
 | Name | Description
Public property | Alignment | Gets/Sets message text alignment for notification window.
Public property | AnimationDelay | Gets/Sets the number of milliseconds after which notification window will be closed automatically.
Public property | AnimationSpeed | Gets/Sets the number of milliseconds used for animaton speed effect of notification window.
Public property | AnimationType | Gets/Sets animation type effect used to display notification window
Public property | AutoHide | Gets/Sets if notification window must be closed after animation delay (AnimationDelay) time will be elapsed
Public property | AutoSizeHeight | Gets/Sets if height of notification window will be calculated automatically.
Public property | AutoSizeWidth | Gets/Sets if width of notification window will be calculated automatically.
Public property | BackColor | Gets/sets the background colour of notification window.
Public property | BorderColor | Gets/sets the border colour of notification window.
Public property | BorderStyle | Gets/sets the border style of notification window.
Public property | CloseButton | Gets/sets if notification window has a close button.
Public property | CloseButtonColor | Gets/sets the close button colour of notification window.
Public property | Container | (inherited from Component).
Public property | Font | Gets/sets the font used to display text message on notification window.
Public property | ForeColor | Gets/sets the text colour used to display message on notification window.
Public property | GradientColor | Gets/sets the gradient colour used in notification window background.
Public property | GradientEnabled | Gets/sets if the notification window has background gradient effect.
Public property | GradientStyle | Gets/sets the notification window gradient style.
Public property | Height | Gets/sets the notification window height.
Public property | Image | Gets/sets the image displaied on notification window.
Public property | ImageSize | Gets/sets the size of image displaied on notification window.
Public property | Padding | Gets/sets margins information used to display text on notification window.
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public property | Site | (inherited from Component).
Public property | Size | Gets or sets the size of notification window.
Public property | Text | Gets/sets the text message displayed on notification window.
Public property | TitleActiveColor | Gets/sets the title active colour used to display text of notification window when active.
Public property | TitleAlignment | Gets/sets the alignment of notification window text title.
Public property | TitleBackColor | Gets/sets the background colour used to display text of notification window.
Public property | TitleFont | Gets/sets the font used to display text of notification window title.
Public property | TitleForeColor | Gets/sets the foreground colour used to display text of notification window.
Public property | TitleGradientColor | Gets/sets the gradient colour used in notification window title background.
Public property | TitleGradientEnabled | Gets/sets if the notification window title has background gradient effect.
Public property | TitleGradientStyle | Gets/sets the notification window title gradient style.
Public property | TitleText | Gets/sets the text of notification window title.
Public property | Visible | Gets if notification window is currently visible.
Public property | Width | Gets/sets the notification window width.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Display | (Overloaded) Display notification window without active activate it
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Hide | Hide notification window.
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
Events
 | Name | Description
Public event | Clicked | This event will be generated because of user has clicked on notification window
Public event | Closed | This event will be generated because of user has clicked close button
Public event | Disposed | (inherited from Component).
Top
See Also

Reference

NetNotify Class


NetNotify Properties

NetNotify Class See Also

The following tables list the members exposed by the NetNotify type.

Properties
 | Name | Description
Public property | Alignment | Gets/Sets message text alignment for notification window.
Public property | AnimationDelay | Gets/Sets the number of milliseconds after which notification window will be closed automatically.
Public property | AnimationSpeed | Gets/Sets the number of milliseconds used for animaton speed effect of notification window.
Public property | AnimationType | Gets/Sets animation type effect used to display notification window
Public property | AutoHide | Gets/Sets if notification window must be closed after animation delay (AnimationDelay) time will be elapsed
Public property | AutoSizeHeight | Gets/Sets if height of notification window will be calculated automatically.
Public property | AutoSizeWidth | Gets/Sets if width of notification window will be calculated automatically.
Public property | BackColor | Gets/sets the background colour of notification window.
Public property | BorderColor | Gets/sets the border colour of notification window.
Public property | BorderStyle | Gets/sets the border style of notification window.
Public property | CloseButton | Gets/sets if notification window has a close button.
Public property | CloseButtonColor | Gets/sets the close button colour of notification window.
Public property | Container | (inherited from Component).
Public property | Font | Gets/sets the font used to display text message on notification window.
Public property | ForeColor | Gets/sets the text colour used to display message on notification window.
Public property | GradientColor | Gets/sets the gradient colour used in notification window background.
Public property | GradientEnabled | Gets/sets if the notification window has background gradient effect.
Public property | GradientStyle | Gets/sets the notification window gradient style.
Public property | Height | Gets/sets the notification window height.
Public property | Image | Gets/sets the image displaied on notification window.
Public property | ImageSize | Gets/sets the size of image displaied on notification window.
Public property | Padding | Gets/sets margins information used to display text on notification window.
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public property | Site | (inherited from Component).
Public property | Size | Gets or sets the size of notification window.
Public property | Text | Gets/sets the text message displayed on notification window.
Public property | TitleActiveColor | Gets/sets the title active colour used to display text of notification window when active.
Public property | TitleAlignment | Gets/sets the alignment of notification window text title.
Public property | TitleBackColor | Gets/sets the background colour used to display text of notification window.
Public property | TitleFont | Gets/sets the font used to display text of notification window title.
Public property | TitleForeColor | Gets/sets the foreground colour used to display text of notification window.
Public property | TitleGradientColor | Gets/sets the gradient colour used in notification window title background.
Public property | TitleGradientEnabled | Gets/sets if the notification window title has background gradient effect.
Public property | TitleGradientStyle | Gets/sets the notification window title gradient style.
Public property | TitleText | Gets/sets the text of notification window title.
Public property | Visible | Gets if notification window is currently visible.
Public property | Width | Gets/sets the notification window width.
Top
See Also

Reference

NetNotify Class


NetNotify.Alignment Property

Gets/Sets message text alignment for notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(HorizontalAlignment), "Left")> _
Public Property Alignment( _
   ByRef GetType As Object, _
   ByRef "Left" As Object _
) As HorizontalAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(HorizontalAlignment), "Left")]
[System.Runtime.CompilerServices.IndexerName("Alignment")]
public HorizontalAlignment this[
   ref object GetType,
   ref object "Left"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Left"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AnimationDelay Property

Gets/Sets the number of milliseconds after which notification window will be closed automatically.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(3000)> _
Public Property AnimationDelay( _
   ByRef 3000 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(3000)]
[System.Runtime.CompilerServices.IndexerName("AnimationDelay")]
public int this[
   ref object 3000
] {get; set;}
This language is not supported or no code example is available.

Parameters

3000

Type: object

Remarks

This property take effect only if AutoHide property is sets to True.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AnimationSpeed Property

Gets/Sets the number of milliseconds used for animaton speed effect of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(1)> _
Public Property AnimationSpeed( _
   ByRef 1 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(1)]
[System.Runtime.CompilerServices.IndexerName("AnimationSpeed")]
public int this[
   ref object 1
] {get; set;}
This language is not supported or no code example is available.

Parameters

1

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AnimationType Property

Gets/Sets animation type effect used to display notification window

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(AnimationTypeEnum), "FadeSlide")> _
Public Property AnimationType( _
   ByRef GetType As Object, _
   ByRef "FadeSlide" As Object _
) As AnimationTypeEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(AnimationTypeEnum), "FadeSlide")]
[System.Runtime.CompilerServices.IndexerName("AnimationType")]
public AnimationTypeEnum this[
   ref object GetType,
   ref object "FadeSlide"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"FadeSlide"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AutoHide Property

Gets/Sets if notification window must be closed after animation delay (AnimationDelay) time will be elapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(True)> _
Public Property AutoHide( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoHide")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AutoSizeHeight Property

Gets/Sets if height of notification window will be calculated automatically.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(True)> _
Public Property AutoSizeHeight( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeHeight")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.AutoSizeWidth Property

Gets/Sets if width of notification window will be calculated automatically.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(False)> _
Public Property AutoSizeWidth( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeWidth")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.BackColor Property

Gets/sets the background colour of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "ActiveCaption")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "ActiveCaption" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "ActiveCaption")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "ActiveCaption"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ActiveCaption"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.BorderColor Property

Gets/sets the border colour of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "WindowFrame")> _
Public Property BorderColor( _
   ByRef GetType As Object, _
   ByRef "WindowFrame" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "WindowFrame")]
[System.Runtime.CompilerServices.IndexerName("BorderColor")]
public Color this[
   ref object GetType,
   ref object "WindowFrame"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"WindowFrame"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.BorderStyle Property

Gets/sets the border style of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(BorderStyleEnum), "FixedSingle")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "FixedSingle" As Object _
) As BorderStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(BorderStyleEnum), "FixedSingle")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyleEnum this[
   ref object GetType,
   ref object "FixedSingle"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"FixedSingle"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.CloseButton Property

Gets/sets if notification window has a close button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(True)> _
Public Property CloseButton( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("CloseButton")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.CloseButtonColor Property

Gets/sets the close button colour of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "Red")> _
Public Property CloseButtonColor( _
   ByRef GetType As Object, _
   ByRef "Red" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "Red")]
[System.Runtime.CompilerServices.IndexerName("CloseButtonColor")]
public Color this[
   ref object GetType,
   ref object "Red"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Red"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Font Property

Gets/sets the font used to display text message on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
Public Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.ForeColor Property

Gets/sets the text colour used to display message on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "ControlLight")> _
Public Property ForeColor( _
   ByRef GetType As Object, _
   ByRef "ControlLight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "ControlLight")]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object GetType,
   ref object "ControlLight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlLight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.GradientColor Property

Gets/sets the gradient colour used in notification window background.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "GradientActiveCaption")> _
Public Property GradientColor( _
   ByRef GetType As Object, _
   ByRef "GradientActiveCaption" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "GradientActiveCaption")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object GetType,
   ref object "GradientActiveCaption"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"GradientActiveCaption"

Type: object

Remarks

This property take effects only if GradientEnabled is sets to True.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.GradientEnabled Property

Gets/sets if the notification window has background gradient effect.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(True)> _
Public Property GradientEnabled( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.GradientStyle Property

Gets/sets the notification window gradient style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(LinearGradientMode), "Vertical")> _
Public Property GradientStyle( _
   ByRef GetType As Object, _
   ByRef "Vertical" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(LinearGradientMode), "Vertical")]
[System.Runtime.CompilerServices.IndexerName("GradientStyle")]
public LinearGradientMode this[
   ref object GetType,
   ref object "Vertical"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Vertical"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Height Property

Gets/sets the notification window height.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(100)> _
Public Property Height( _
   ByRef 100 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(100)]
[System.Runtime.CompilerServices.IndexerName("Height")]
public int this[
   ref object 100
] {get; set;}
This language is not supported or no code example is available.

Parameters

100

Type: object

Remarks

This property take effects only in AutoHeight is sets to False

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Image Property

Gets/sets the image displaied on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(CStr(Nothing))> _
Public Property Image( _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.ImageSize Property

Gets/sets the size of image displaied on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Size), "16,16")> _
Public Property ImageSize( _
   ByRef GetType As Object, _
   ByRef "16,16" As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Size), "16,16")]
[System.Runtime.CompilerServices.IndexerName("ImageSize")]
public Size this[
   ref object GetType,
   ref object "16,16"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"16,16"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Padding Property

Gets/sets margins information used to display text on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Padding), "0,0,0,0")> _
Public Property Padding( _
   ByRef GetType As Object, _
   ByRef "0,0,0,0" As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Padding), "0,0,0,0")]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object GetType,
   ref object "0,0,0,0"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"0,0,0,0"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(False)> _
Public Property RightToLeft( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("RightToLeft")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Size Property

Gets or sets the size of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Size), "250,100")> _
Public Property Size( _
   ByRef GetType As Object, _
   ByRef "250,100" As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Size), "250,100")]
[System.Runtime.CompilerServices.IndexerName("Size")]
public Size this[
   ref object GetType,
   ref object "250,100"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"250,100"

Type: object

Remarks

This property will be used if AutoSizeHeight and/or AutoSizeWidth properties are set to False.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Text Property

Gets/sets the text message displayed on notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue("")> _
Public Property Text( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleActiveColor Property

Gets/sets the title active colour used to display text of notification window when active.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "ActiveCaptionText")> _
Public Property TitleActiveColor( _
   ByRef GetType As Object, _
   ByRef "ActiveCaptionText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "ActiveCaptionText")]
[System.Runtime.CompilerServices.IndexerName("TitleActiveColor")]
public Color this[
   ref object GetType,
   ref object "ActiveCaptionText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ActiveCaptionText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleAlignment Property

Gets/sets the alignment of notification window text title.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(HorizontalAlignment), "Left")> _
Public Property TitleAlignment( _
   ByRef GetType As Object, _
   ByRef "Left" As Object _
) As HorizontalAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(HorizontalAlignment), "Left")]
[System.Runtime.CompilerServices.IndexerName("TitleAlignment")]
public HorizontalAlignment this[
   ref object GetType,
   ref object "Left"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Left"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleBackColor Property

Gets/sets the background colour used to display text of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "Desktop")> _
Public Property TitleBackColor( _
   ByRef GetType As Object, _
   ByRef "Desktop" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "Desktop")]
[System.Runtime.CompilerServices.IndexerName("TitleBackColor")]
public Color this[
   ref object GetType,
   ref object "Desktop"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Desktop"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleFont Property

Gets/sets the font used to display text of notification window title.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
Public Property TitleFont() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
public Font TitleFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleForeColor Property

Gets/sets the foreground colour used to display text of notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "InactiveCaptionText")> _
Public Property TitleForeColor( _
   ByRef GetType As Object, _
   ByRef "InactiveCaptionText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "InactiveCaptionText")]
[System.Runtime.CompilerServices.IndexerName("TitleForeColor")]
public Color this[
   ref object GetType,
   ref object "InactiveCaptionText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"InactiveCaptionText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleGradientColor Property

Gets/sets the gradient colour used in notification window title background.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(Color), "GradientActiveCaption")> _
Public Property TitleGradientColor( _
   ByRef GetType As Object, _
   ByRef "GradientActiveCaption" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(Color), "GradientActiveCaption")]
[System.Runtime.CompilerServices.IndexerName("TitleGradientColor")]
public Color this[
   ref object GetType,
   ref object "GradientActiveCaption"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"GradientActiveCaption"

Type: object

Remarks

This property take effects only if GradientEnabled is sets to True.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleGradientEnabled Property

Gets/sets if the notification window title has background gradient effect.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(True)> _
Public Property TitleGradientEnabled( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("TitleGradientEnabled")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleGradientStyle Property

Gets/sets the notification window title gradient style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(GetType(LinearGradientMode), "Vertical")> _
Public Property TitleGradientStyle( _
   ByRef GetType As Object, _
   ByRef "Vertical" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(GetType(LinearGradientMode), "Vertical")]
[System.Runtime.CompilerServices.IndexerName("TitleGradientStyle")]
public LinearGradientMode this[
   ref object GetType,
   ref object "Vertical"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Vertical"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.TitleText Property

Gets/sets the text of notification window title.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue("")> _
Public Property TitleText( _
   ByRef "" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("TitleText")]
public string this[
   ref object ""
] {get; set;}
This language is not supported or no code example is available.

Parameters

""

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Visible Property

Gets if notification window is currently visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
Public ReadOnly Property Visible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
public bool Visible {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Width Property

Gets/sets the notification window width.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("NetNotify")> _
<DefaultValue(250)> _
Public Property Width( _
   ByRef 250 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("NetNotify")]
[DefaultValue(250)]
[System.Runtime.CompilerServices.IndexerName("Width")]
public int this[
   ref object 250
] {get; set;}
This language is not supported or no code example is available.

Parameters

250

Type: object

Remarks

This property take effects only in AutoWidth is sets to False

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify Methods

NetNotify Class See Also

The following tables list the members exposed by the NetNotify type.

Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Display | (Overloaded) Display notification window without active activate it
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | Hide | Hide notification window.
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | ToString | (inherited from Component).
Top
See Also

Reference

NetNotify Class


NetNotify.Display Method

NetNotify Class See Also

Display notification window without active activate it

Overload List
Name | Description
Display() | Display notification window without active activate it
Display(bool) | Display notification window activated or not activated.
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify.Hide Method

Hide notification window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Hide()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Hide()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetNotify Events

NetNotify Class See Also

The following tables list the members exposed by the NetNotify type.

Events
 | Name | Description
Public event | Clicked | This event will be generated because of user has clicked on notification window
Public event | Closed | This event will be generated because of user has clicked close button
Public event | Disposed | (inherited from Component).
Top
See Also

Reference

NetNotify Class


Clicked Event

This event will be generated because of user has clicked on notification window

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Clicked( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClickedEventHandler Clicked
delegate void ClickedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


Closed Event

This event will be generated because of user has clicked close button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event Closed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ClosedEventHandler Closed
delegate void ClosedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetPanel Class

Members

Softgroup .Net Advanced Panel control is an extended Panel control that implements unsupported behaviours and features of standard control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(Softgroup.NetControls.NetPanel), "NetPanel.bmp")> _
Public Class NetPanel
    Inherits Panel
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(Softgroup.NetControls.NetPanel), "NetPanel.bmp")]
public class NetPanel : Panel
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Softgroup.NetControls.NetPanel
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Members


NetPanel Members

NetPanel Class Events Methods Properties See Also

Softgroup .Net Advanced Panel control is an extended Panel control that implements unsupported behaviours and features of standard control.

The following tables list the members exposed by the NetPanel type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | (inherited from ScrollableControl).
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Panel).
Public property | AutoSizeMode | (inherited from Panel).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | BordersColor | Gets/Sets borders color
Public property | BordersVisible | Gets/Sets if borders will be drawn
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContentPadding | Gets/Sets the space between the element border
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Corners | Gets/Sets which panel corners are visible
Public property | CornersRadius | Gets/Sets radius of panel corners
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (Overloaded) Gets default background colour
 | DefaultBordersColor | Gets default borders color
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColorEnd | Gets the default background gradient end colour
 | DefaultGradientColorStart | Gets the default background gradient start colour
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColorEnd | Gets/Sets the background gradient end colour
Public property | GradientColorStart | Gets/Sets the background gradient start colour
Public property | GradientEnabled | Enable/Disable background gradient effect
Public property | GradientMode | Gets/Sets background gradient effect direction
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Image | Gets/Sets the image for panel
Public property | ImageAlpha | Gets/Sets alpha color (opacity) of image.
Public property | ImagePosition | Gets/Sets the image position inside client area of panel
Public property | ImageSize | Gets/Sets the image size
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | PaddingImageText | Gets/Sets the space between the element border and image
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Panel).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets/Sets the text of panel
Public property | TextPosition | Gets/Sets the text position inside client area of panel
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | ToString | (inherited from Panel).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetPanel Class


NetPanel Properties

NetPanel Class See Also

The following tables list the members exposed by the NetPanel type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | (inherited from ScrollableControl).
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Panel).
Public property | AutoSizeMode | (inherited from Panel).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | BordersColor | Gets/Sets borders color
Public property | BordersVisible | Gets/Sets if borders will be drawn
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContentPadding | Gets/Sets the space between the element border
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Corners | Gets/Sets which panel corners are visible
Public property | CornersRadius | Gets/Sets radius of panel corners
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (Overloaded) Gets default background colour
 | DefaultBordersColor | Gets default borders color
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColorEnd | Gets the default background gradient end colour
 | DefaultGradientColorStart | Gets the default background gradient start colour
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColorEnd | Gets/Sets the background gradient end colour
Public property | GradientColorStart | Gets/Sets the background gradient start colour
Public property | GradientEnabled | Enable/Disable background gradient effect
Public property | GradientMode | Gets/Sets background gradient effect direction
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Image | Gets/Sets the image for panel
Public property | ImageAlpha | Gets/Sets alpha color (opacity) of image.
Public property | ImagePosition | Gets/Sets the image position inside client area of panel
Public property | ImageSize | Gets/Sets the image size
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | PaddingImageText | Gets/Sets the space between the element border and image
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Panel).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets/Sets the text of panel
Public property | TextPosition | Gets/Sets the text position inside client area of panel
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetPanel Class


NetPanel.BordersColor Property

Gets/Sets borders color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Color), "ActiveBorder")> _
<Description("Gets/Sets borders color")> _
<Category("NetPanel")> _
Public Property BordersColor( _
   ByRef "Gets/Sets borders color" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Color), "ActiveBorder")]
[Description("Gets/Sets borders color")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("BordersColor")]
public Color this[
   ref object "Gets/Sets borders color"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets borders color"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.BordersVisible Property

Gets/Sets if borders will be drawn

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(True)> _
<Description("Gets/Sets if borders will be drawn")> _
<Category("NetPanel")> _
Public Property BordersVisible( _
   ByRef "Gets/Sets if borders will be drawn" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(True)]
[Description("Gets/Sets if borders will be drawn")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("BordersVisible")]
public bool this[
   ref object "Gets/Sets if borders will be drawn"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if borders will be drawn"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.ContentPadding Property

Gets/Sets the space between the element border

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Padding), "0,0,0,0")> _
<Description("Gets/Sets the space between the element border")> _
<Category("NetPanel")> _
Public Property ContentPadding( _
   ByRef "Gets/Sets the space between the element border" As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Padding), "0,0,0,0")]
[Description("Gets/Sets the space between the element border")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("ContentPadding")]
public Padding this[
   ref object "Gets/Sets the space between the element border"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the space between the element border"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.Corners Property

Gets/Sets which panel corners are visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(VisibleCornersEnum), "None")> _
<Description("Gets/Sets which panel corners are visible")> _
<Category("NetPanel")> _
Public Property Corners( _
   ByRef "Gets/Sets which panel corners are visible" As Object _
) As VisibleCornersEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(VisibleCornersEnum), "None")]
[Description("Gets/Sets which panel corners are visible")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("Corners")]
public VisibleCornersEnum this[
   ref object "Gets/Sets which panel corners are visible"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets which panel corners are visible"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.CornersRadius Property

Gets/Sets radius of panel corners

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(20)> _
<Description("Gets/Sets radius of panel corners")> _
<Category("NetPanel")> _
Public Property CornersRadius( _
   ByRef "Gets/Sets radius of panel corners" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(20)]
[Description("Gets/Sets radius of panel corners")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("CornersRadius")]
public int this[
   ref object "Gets/Sets radius of panel corners"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets radius of panel corners"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.DefaultBackColor Property

NetPanel Class See Also

Gets default background colour

Overload List
Name | Description
this[ref object] | Gets default background colour
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.DefaultBordersColor Property

Gets default borders color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default borders color")> _
<Category("NetPanel")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public ReadOnly Shared Property DefaultBordersColor( _
   ByRef "NetPanel" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default borders color")]
[Category("NetPanel")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultBordersColor")]
public static Color this[
   ref object "NetPanel"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPanel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.DefaultGradientColorEnd Property

Gets the default background gradient end colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default background gradient end colour")> _
<Category("NetPanel")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public ReadOnly Shared Property DefaultGradientColorEnd( _
   ByRef "NetPanel" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default background gradient end colour")]
[Category("NetPanel")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultGradientColorEnd")]
public static Color this[
   ref object "NetPanel"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPanel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.DefaultGradientColorStart Property

Gets the default background gradient start colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default background gradient start colour")> _
<Category("NetPanel")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public ReadOnly Shared Property DefaultGradientColorStart( _
   ByRef "NetPanel" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default background gradient start colour")]
[Category("NetPanel")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultGradientColorStart")]
public static Color this[
   ref object "NetPanel"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPanel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.GradientColorEnd Property

Gets/Sets the background gradient end colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Color), "Control")> _
<Description("Gets/Sets the background gradient end colour")> _
<Category("NetPanel")> _
Public Property GradientColorEnd( _
   ByRef "Gets/Sets the background gradient end colour" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Color), "Control")]
[Description("Gets/Sets the background gradient end colour")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("GradientColorEnd")]
public Color this[
   ref object "Gets/Sets the background gradient end colour"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the background gradient end colour"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.GradientColorStart Property

Gets/Sets the background gradient start colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Color), "ControlLightLight")> _
<Description("Gets/Sets the background gradient start colour")> _
<Category("NetPanel")> _
Public Property GradientColorStart( _
   ByRef "Gets/Sets the background gradient start colour" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Color), "ControlLightLight")]
[Description("Gets/Sets the background gradient start colour")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("GradientColorStart")]
public Color this[
   ref object "Gets/Sets the background gradient start colour"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the background gradient start colour"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.GradientEnabled Property

Enable/Disable background gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Enable/Disable background gradient effect")> _
<Category("NetPanel")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "NetPanel" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Enable/Disable background gradient effect")]
[Category("NetPanel")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "NetPanel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetPanel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.GradientMode Property

Gets/Sets background gradient effect direction

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(LinearGradientMode), "Vertical")> _
<Description("Gets/Sets background gradient effect direction")> _
<Category("NetPanel")> _
Public Property GradientMode( _
   ByRef "Gets/Sets background gradient effect direction" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(LinearGradientMode), "Vertical")]
[Description("Gets/Sets background gradient effect direction")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("GradientMode")]
public LinearGradientMode this[
   ref object "Gets/Sets background gradient effect direction"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets background gradient effect direction"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.Image Property

Gets/Sets the image for panel

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(CStr(Nothing))> _
<Description("Gets/Sets the image for panel")> _
<Category("NetPanel")> _
Public Property Image( _
   ByRef "Gets/Sets the image for panel" As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(CStr(Nothing))]
[Description("Gets/Sets the image for panel")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object "Gets/Sets the image for panel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the image for panel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.ImageAlpha Property

Gets/Sets alpha color (opacity) of image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(75)> _
<Description("Gets/Sets the apha color (opacity) of image.")> _
<Category("NetPanel")> _
Public Property ImageAlpha( _
   ByRef "Gets/Sets the apha color  As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(75)]
[Description("Gets/Sets the apha color (opacity) of image.")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("ImageAlpha")]
public int this[
   ref object "Gets/Sets the apha color
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the apha color

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.ImagePosition Property

Gets/Sets the image position inside client area of panel

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(ImageTextPositionEnum), "BottomLeft")> _
<Description("Gets/Sets the image position inside client area of panel")> _
<Category("NetPanel")> _
Public Property ImagePosition( _
   ByRef "Gets/Sets the image position inside client area of panel" As Object _
) As ImageTextPositionEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(ImageTextPositionEnum), "BottomLeft")]
[Description("Gets/Sets the image position inside client area of panel")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("ImagePosition")]
public ImageTextPositionEnum this[
   ref object "Gets/Sets the image position inside client area of panel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the image position inside client area of panel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.ImageSize Property

Gets/Sets the image size

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Size), "32,32")> _
<Description("Gets/Sets the image size")> _
<Category("NetPanel")> _
Public Property ImageSize( _
   ByRef "Gets/Sets the image size" As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Size), "32,32")]
[Description("Gets/Sets the image size")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("ImageSize")]
public Size this[
   ref object "Gets/Sets the image size"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the image size"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.PaddingImageText Property

Gets/Sets the space between the element border and image

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Padding), "5,5,5,5")> _
<Description("Gets/Sets the space between the element border and the image")> _
<Category("NetPanel")> _
Public Property PaddingImageText( _
   ByRef "Gets/Sets the space between the element border and the image" As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Padding), "5,5,5,5")]
[Description("Gets/Sets the space between the element border and the image")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("PaddingImageText")]
public Padding this[
   ref object "Gets/Sets the space between the element border and the image"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the space between the element border and the image"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.Text Property

NetPanel Class See Also

Gets/Sets the text of panel

Overload List
Name | Description
this[ref object] | Gets/Sets the text of panel
Text | (System.Windows.Forms.Panel).
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.TextPosition Property

Gets/Sets the text position inside client area of panel

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(ImageTextPositionEnum), "BottomLeft")> _
<Description("Gets/Sets the text position inside client area of panel")> _
<Category("NetPanel")> _
Public Property TextPosition( _
   ByRef "Gets/Sets the text position inside client area of panel" As Object _
) As ImageTextPositionEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(ImageTextPositionEnum), "BottomLeft")]
[Description("Gets/Sets the text position inside client area of panel")]
[Category("NetPanel")]
[System.Runtime.CompilerServices.IndexerName("TextPosition")]
public ImageTextPositionEnum this[
   ref object "Gets/Sets the text position inside client area of panel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the text position inside client area of panel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel Methods

NetPanel Class See Also

The following tables list the members exposed by the NetPanel type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | ToString | (inherited from Panel).
Top
See Also

Reference

NetPanel Class


NetPanel Events

NetPanel Class See Also

The following tables list the members exposed by the NetPanel type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetPanel Class


NetPictureScroll Class

Members

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetTabControl), "NetPictureScroll.bmp")> _
<DefaultEvent("ImageChanged")> _
Public Class NetPictureScroll
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetTabControl), "NetPictureScroll.bmp")]
[DefaultEvent("ImageChanged")]
public class NetPictureScroll : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetPictureScroll
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Members


NetPictureScroll Members

NetPictureScroll Class Events Methods Properties See Also

The following tables list the members exposed by the NetPictureScroll type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets control background color.
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/Sets border style of control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets displayed image.
Public property | ImeMode | (inherited from Control).
Public property | InterpolationMode | Gets/Sets interpolation mode used to display image.
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Stretch | Gets/Sets a value indicating if image must be displayed stretch.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | ZoomFactor | Gets/Sets a value indicating zoom factor (minimum value is 0.001).
Top
Methods
 | Name | Description
Public method | LoadFromFile | Load and image from specified file
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImageChanged | Occurs when image changed.
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StretchChanged | Occurs when Stretch property changed.
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Public event | ZoomFactorChanged | Occurs when ZoomFactor property changed.
Top
See Also

Reference

NetPictureScroll Class


NetPictureScroll Properties

NetPictureScroll Class See Also

The following tables list the members exposed by the NetPictureScroll type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets control background color.
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/Sets border style of control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets/Sets displayed image.
Public property | ImeMode | (inherited from Control).
Public property | InterpolationMode | Gets/Sets interpolation mode used to display image.
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Stretch | Gets/Sets a value indicating if image must be displayed stretch.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | ZoomFactor | Gets/Sets a value indicating zoom factor (minimum value is 0.001).
Top
See Also

Reference

NetPictureScroll Class


NetPictureScroll.BackColor Property

NetPictureScroll Class See Also

Gets/Sets control background color.

Overload List
Name | Description
this[ref object, ref object] | Gets/Sets control background color.
BackColor | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.BackgroundImage Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.BackgroundImageLayout Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.BorderStyle Property

Gets/Sets border style of control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets border style of control")> _
<System.ComponentModel.DefaultValue(GetType(BorderStyle), "FixedSingle")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "FixedSingle" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets border style of control")]
[System.ComponentModel.DefaultValue(GetType(BorderStyle), "FixedSingle")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "FixedSingle"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"FixedSingle"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Font Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.ForeColor Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Image Property

Gets/Sets displayed image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets displayed image")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property Image( _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets displayed image")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("Image")]
public Image this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.InterpolationMode Property

Gets/Sets interpolation mode used to display image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets Interpolation mode used to display image")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Drawing2D.InterpolationMode), "HighQualityBilinear")> _
Public Property InterpolationMode( _
   ByRef GetType As Object, _
   ByRef "HighQualityBilinear" As Object _
) As InterpolationMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets Interpolation mode used to display image")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Drawing2D.InterpolationMode), "HighQualityBilinear")]
[System.Runtime.CompilerServices.IndexerName("InterpolationMode")]
public InterpolationMode this[
   ref object GetType,
   ref object "HighQualityBilinear"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"HighQualityBilinear"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Margin Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Stretch Property

Gets/Sets a value indicating if image must be displayed stretch.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets a value indicating if image must be displayed stretch.")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property Stretch( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets a value indicating if image must be displayed stretch.")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("Stretch")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Text Property

NetPictureScroll Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Text | (System.Windows.Forms.Control).
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.ZoomFactor Property

Gets/Sets a value indicating zoom factor (minimum value is 0.001).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets a value indicating zoom factor (minimum value is 0.001).")> _
<System.ComponentModel.DefaultValue(1.0F)> _
Public Property ZoomFactor( _
   ByRef 1.0F As Object _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets a value indicating zoom factor (minimum value is 0.001).")]
[System.ComponentModel.DefaultValue(1.0F)]
[System.Runtime.CompilerServices.IndexerName("ZoomFactor")]
public float this[
   ref object 1.0F
] {get; set;}
This language is not supported or no code example is available.

Parameters

1.0F

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll Methods

NetPictureScroll Class See Also

The following tables list the members exposed by the NetPictureScroll type.

Methods
 | Name | Description
Public method | LoadFromFile | Load and image from specified file
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetPictureScroll Class


NetPictureScroll.LoadFromFile Method

Load and image from specified file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub LoadFromFile( _
   ByVal sFileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void LoadFromFile(
   string sFileName
)
This language is not supported or no code example is available.

Parameters

sFileName

Type: string

The full path image file name

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll Events

NetPictureScroll Class See Also

The following tables list the members exposed by the NetPictureScroll type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImageChanged | Occurs when image changed.
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StretchChanged | Occurs when Stretch property changed.
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Public event | ZoomFactorChanged | Occurs when ZoomFactor property changed.
Top
See Also

Reference

NetPictureScroll Class


ImageChanged Event

Occurs when image changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Occurs when image changed.")> _
Public Event ImageChanged( _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Occurs when image changed.")]
public event ImageChangedEventHandler ImageChanged
delegate void ImageChangedEventHandler(
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


StretchChanged Event

Occurs when Stretch property changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Occurs when Stretch property changed.")> _
Public Event StretchChanged( _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Occurs when Stretch property changed.")]
public event StretchChangedEventHandler StretchChanged
delegate void StretchChangedEventHandler(
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


ZoomFactorChanged Event

Occurs when ZoomFactor property changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Occurs when ZoomFactor property changed.")> _
Public Event ZoomFactorChanged( _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Occurs when ZoomFactor property changed.")]
public event ZoomFactorChangedEventHandler ZoomFactorChanged
delegate void ZoomFactorChangedEventHandler(
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetShellPreview Class

Members

NetShellPreview is a preview control that can be used to display a system preview like Explorer where available for file extension type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(NetShellPreview), "NetShellPreview.bmp")> _
<DefaultProperty("FileName")> _
<DefaultEvent("PreviewChanged")> _
Public Class NetShellPreview
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(NetShellPreview), "NetShellPreview.bmp")]
[DefaultProperty("FileName")]
[DefaultEvent("PreviewChanged")]
public class NetShellPreview : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetShellPreview
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Members


NetShellPreview Members

NetShellPreview Class Constructors Events Methods Properties See Also

NetShellPreview is a preview control that can be used to display a system preview like Explorer where available for file extension type.

The following tables list the members exposed by the NetShellPreview type.

Constructors
 | Name | Description
Public constructor | NetShellPreview Constructor | Create a new instance of the class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets control background color.
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/Sets border style of control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FileName | Gets current loaded presentation file name.
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | Close | Close the preview
Public method | IsPreviewAvailable | Return True if Preview is available for specified file.
Public method | Open | Load and preview (if available) specified file.
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewChanged | This event will be generated any time a file preview will be changed.
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetShellPreview Class


NetShellPreview Constructor

Create a new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetShellPreview()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview Properties

NetShellPreview Class See Also

The following tables list the members exposed by the NetShellPreview type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets control background color.
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/Sets border style of control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FileName | Gets current loaded presentation file name.
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (Overloaded) Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetShellPreview Class


NetShellPreview.BackColor Property

NetShellPreview Class See Also

Gets/Sets control background color.

Overload List
Name | Description
this[ref object, ref object] | Gets/Sets control background color.
BackColor | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.BackgroundImage Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.BackgroundImageLayout Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.BorderStyle Property

Gets/Sets border style of control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets border style of control")> _
<System.ComponentModel.DefaultValue(GetType(BorderStyle), "FixedSingle")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "FixedSingle" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets border style of control")]
[System.ComponentModel.DefaultValue(GetType(BorderStyle), "FixedSingle")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "FixedSingle"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"FixedSingle"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.FileName Property

Gets current loaded presentation file name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property FileName() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string FileName {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Font Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.ForeColor Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Margin Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Text Property

NetShellPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Text | (System.Windows.Forms.Control).
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview Methods

NetShellPreview Class See Also

The following tables list the members exposed by the NetShellPreview type.

Methods
 | Name | Description
Public method | Close | Close the preview
Public method | IsPreviewAvailable | Return True if Preview is available for specified file.
Public method | Open | Load and preview (if available) specified file.
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetShellPreview Class


NetShellPreview.Close Method

Close the preview

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Close()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Close()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.IsPreviewAvailable Method

Return True if Preview is available for specified file.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IsPreviewAvailable( _
   ByVal sFileName As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool IsPreviewAvailable(
   string sFileName
)
This language is not supported or no code example is available.

Parameters

sFileName

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Open Method

Load and preview (if available) specified file.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Open( _
   ByVal sFilename As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Open(
   string sFilename
)
This language is not supported or no code example is available.

Parameters

sFilename

Type: string

A valid path/file file name

Return Value

Return True for success otherwise return False
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview Events

NetShellPreview Class See Also

The following tables list the members exposed by the NetShellPreview type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewChanged | This event will be generated any time a file preview will be changed.
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetShellPreview Class


PreviewChanged Event

This event will be generated any time a file preview will be changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event PreviewChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event PreviewChangedEventHandler PreviewChanged
delegate void PreviewChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetSplitButton Class

Members

Softgroup .Net SplitButton is an enhanced .NET button control that gives your applications a nice button with a split area that can display on user click an associated ContextMenuStrip.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetSplitButton), "NetSplitButton.bmp")> _
<System.ComponentModel.DefaultProperty("Text")> _
<System.ComponentModel.DefaultEvent("Click")> _
Public Class NetSplitButton
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetSplitButton), "NetSplitButton.bmp")]
[System.ComponentModel.DefaultProperty("Text")]
[System.ComponentModel.DefaultEvent("Click")]
public class NetSplitButton : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.NetSplitButton
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Members


NetSplitButton Members

NetSplitButton Class Constructors Events Methods Properties See Also

Softgroup .Net SplitButton is an enhanced .NET button control that gives your applications a nice button with a split area that can display on user click an associated ContextMenuStrip.

To add a Softgroup .NetButton to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

The following tables list the members exposed by the NetSplitButton type.

Constructors
 | Name | Description
Public constructor | NetSplitButton Constructor | Intialize a new SplitButton instance.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | AlwaysDropDown | Indicates whether the SplitButton always shows the drop-down menu even if the non-split part is clicked.
Public property | Anchor | (inherited from Control).
Public property | AutoEllipsis | This property controls the activation handling of bleedover for the text that extends beyond the width of the button.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | Indicates whether the control is automatically resized to fit its contents.
Public property | AutoSizeMode | Allows the control to optionally shrink when AutoSize is true.
Public property | BackColor | For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | ContextMenuStrip associated with this control.
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | The dialog-box result produced in a modal form by clicking the button.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DoubleClickEnabled | Indicates whether the double click event is raised on the SplitButton.
Public property | Enabled | (inherited from Control).
Public property | FlatAppearance | For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.
Public property | FlatStyle | Gets or sets the visual style of the button.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets or sets the image that is displayed on a button control.
Public property | ImageAlign | The alignment of the image that will be displayed on the control.
Public property | ImageIndex | The index of the image in the ImageList to display on the control.
Public property | ImageKey | Gets or sets the image list index key of the image displayed on the button control.
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control.
Public property | ImeMode | Determine the IME (Input Method Editor) status of the object when selected.
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | PreventEnterSpaceKeys | Indicates whether the button reacts to Enter and Space keys.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SplitGlyphScaling | Split are glyph scaling factor.
Public property | SplitImageList | ImageList for the split button part.
Public property | SplitSize | Split part width in pixels.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets the text caption displayed in the button.
Public property | TextAlign | Gets or sets the alignment of the text on the button control.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCompatibleTextRendering | Specifies whether text rendering shoud be compatible with previous releases of Windows Forms.
Public property | UseMnemonic | Gets or sets a value indicating whether an ampersand (&) included in the text of the control.
Public property | UseVisualStyleBackColor | Determines whether the backgrount is drawn using visual styles, if visual styles are supported.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | NotifyDefault | Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.
Public method | PerformClick | Generates a Click event for the control.
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when AutoSize property has changed.
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MenuShowing | Occurs before the context menu is shown.
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | SplitClick | Occurs when the split part is clicked.
Public event | SplitDoubleClick | Occurs when the split part is double-clicked.
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetSplitButton Class


NetSplitButton Constructor

Intialize a new SplitButton instance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetSplitButton()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton Properties

NetSplitButton Class See Also

The following tables list the members exposed by the NetSplitButton type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | AlwaysDropDown | Indicates whether the SplitButton always shows the drop-down menu even if the non-split part is clicked.
Public property | Anchor | (inherited from Control).
Public property | AutoEllipsis | This property controls the activation handling of bleedover for the text that extends beyond the width of the button.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | Indicates whether the control is automatically resized to fit its contents.
Public property | AutoSizeMode | Allows the control to optionally shrink when AutoSize is true.
Public property | BackColor | For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | ContextMenuStrip associated with this control.
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DialogResult | The dialog-box result produced in a modal form by clicking the button.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DoubleClickEnabled | Indicates whether the double click event is raised on the SplitButton.
Public property | Enabled | (inherited from Control).
Public property | FlatAppearance | For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.
Public property | FlatStyle | Gets or sets the visual style of the button.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | Gets or sets the image that is displayed on a button control.
Public property | ImageAlign | The alignment of the image that will be displayed on the control.
Public property | ImageIndex | The index of the image in the ImageList to display on the control.
Public property | ImageKey | Gets or sets the image list index key of the image displayed on the button control.
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control.
Public property | ImeMode | Determine the IME (Input Method Editor) status of the object when selected.
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | PreventEnterSpaceKeys | Indicates whether the button reacts to Enter and Space keys.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SplitGlyphScaling | Split are glyph scaling factor.
Public property | SplitImageList | ImageList for the split button part.
Public property | SplitSize | Split part width in pixels.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets the text caption displayed in the button.
Public property | TextAlign | Gets or sets the alignment of the text on the button control.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseCompatibleTextRendering | Specifies whether text rendering shoud be compatible with previous releases of Windows Forms.
Public property | UseMnemonic | Gets or sets a value indicating whether an ampersand (&) included in the text of the control.
Public property | UseVisualStyleBackColor | Determines whether the backgrount is drawn using visual styles, if visual styles are supported.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetSplitButton Class


NetSplitButton.AlwaysDropDown Property

Indicates whether the SplitButton always shows the drop-down menu even if the non-split part is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("Indicates whether the SplitButton always shows the drop-down menu even if the non-split part is clicked.")> _
<DefaultValue(DefaultAlwaysDropDown)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property AlwaysDropDown() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("Indicates whether the SplitButton always shows the drop-down menu even if the non-split part is clicked.")]
[DefaultValue(DefaultAlwaysDropDown)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public bool AlwaysDropDown {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.AutoEllipsis Property

This property controls the activation handling of bleedover for the text that extends beyond the width of the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("This property controls the activation handling of bleedover for the text that extends beyond the width of the button.")> _
<DefaultValue(DefaultAutoEllipsis)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public Property AutoEllipsis() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("This property controls the activation handling of bleedover for the text that extends beyond the width of the button.")]
[DefaultValue(DefaultAutoEllipsis)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
public bool AutoEllipsis {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.AutoSize Property

Indicates whether the control is automatically resized to fit its contents.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Layout")> _
<Description("Indicates whether the control is automatically resized to fit its contents.")> _
<DefaultValue(DefaultAutoSize)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Overrides Property AutoSize() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Layout")]
[Description("Indicates whether the control is automatically resized to fit its contents.")]
[DefaultValue(DefaultAutoSize)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public override bool AutoSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.AutoSizeMode Property

Allows the control to optionally shrink when AutoSize is true.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Layout")> _
<Description("Allows the control to optionally shrink when AutoSize is true.")> _
<DefaultValue(GetType(AutoSizeMode), "GrowOnly")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property AutoSizeMode() As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Layout")]
[Description("Allows the control to optionally shrink when AutoSize is true.")]
[DefaultValue(GetType(AutoSizeMode), "GrowOnly")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public AutoSizeMode AutoSizeMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.BackColor Property

For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state")> _
Public Overrides Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state")]
public override Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ContextMenuStrip Property

ContextMenuStrip associated with this control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("ContextMenuStrip associated with this control.")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Overrides Property ContextMenuStrip() As ContextMenuStrip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("ContextMenuStrip associated with this control.")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
public override ContextMenuStrip ContextMenuStrip {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.DialogResult Property

The dialog-box result produced in a modal form by clicking the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("The dialog-box result produced in a modal form by clicking the button.")> _
<DefaultValue(GetType(DialogResult), "None")> _
Public Property DialogResult() As DialogResult Implements  _
   IButtonControl.DialogResult
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("The dialog-box result produced in a modal form by clicking the button.")]
[DefaultValue(GetType(DialogResult), "None")]
public DialogResult DialogResult {get; set;}
This language is not supported or no code example is available.

Implements

IButtonControl.DialogResult
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.DoubleClickEnabled Property

Indicates whether the double click event is raised on the SplitButton.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("Indicates whether the double click event is raised on the SplitButton.")> _
<DefaultValue(DefaultDoubleClickEnabled)> _
Public Property DoubleClickEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("Indicates whether the double click event is raised on the SplitButton.")]
[DefaultValue(DefaultDoubleClickEnabled)]
public bool DoubleClickEnabled {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.FlatAppearance Property

For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FlatAppearance() As NetSplitButtonAppearance
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("For buttons whose FlatStyle is FlatStyle.Flat, determines the appearance of the border and the colors used to indicate its state.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
public NetSplitButtonAppearance FlatAppearance {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.FlatStyle Property

Gets or sets the visual style of the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the visual style of the button.")> _
<DefaultValue(GetType(FlatStyle), "Standard")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property FlatStyle() As FlatStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the visual style of the button.")]
[DefaultValue(GetType(FlatStyle), "Standard")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public FlatStyle FlatStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.Image Property

Gets or sets the image that is displayed on a button control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the image that is displayed on a button control.")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the image that is displayed on a button control.")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Image Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ImageAlign Property

The alignment of the image that will be displayed on the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("The alignment of the image that will be displayed on the control.")> _
<DefaultValue(GetType(ContentAlignment), "MiddleCenter")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property ImageAlign() As ContentAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("The alignment of the image that will be displayed on the control.")]
[DefaultValue(GetType(ContentAlignment), "MiddleCenter")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public ContentAlignment ImageAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ImageIndex Property

The index of the image in the ImageList to display on the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("The index of the image in the ImageList to display on the control.")> _
<DefaultValue(DefaultImageIndex)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property ImageIndex() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("The index of the image in the ImageList to display on the control.")]
[DefaultValue(DefaultImageIndex)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public int ImageIndex {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ImageKey Property

Gets or sets the image list index key of the image displayed on the button control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the image list index key of the image displayed on the button control.")> _
<DefaultValue("")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property ImageKey() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the image list index key of the image displayed on the button control.")]
[DefaultValue("")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public string ImageKey {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ImageList Property

Gets or sets the ImageList that contains the Image displayed on a button control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the ImageList that contains the Image displayed on a button control.")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property ImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the ImageList that contains the Image displayed on a button control.")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public ImageList ImageList {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.ImeMode Property

Determine the IME (Input Method Editor) status of the object when selected.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<Category("Behavior")> _
<Description("Determine the IME (Input Method Editor) status of the object when selected.")> _
<DefaultValue(DefaultImeMode_)> _
Public Shadows Property ImeMode() As ImeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[Category("Behavior")]
[Description("Determine the IME (Input Method Editor) status of the object when selected.")]
[DefaultValue(DefaultImeMode_)]
new public ImeMode ImeMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.PreventEnterSpaceKeys Property

Indicates whether the button reacts to Enter and Space keys.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("Indicates whether the button reacts to Enter and Space keys.")> _
<DefaultValue(DefaultBlockEnterAndSpaceBar)> _
Public Property PreventEnterSpaceKeys() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("Indicates whether the button reacts to Enter and Space keys.")]
[DefaultValue(DefaultBlockEnterAndSpaceBar)]
public bool PreventEnterSpaceKeys {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.SplitGlyphScaling Property

Split are glyph scaling factor.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Split are glyph scaling factor.")> _
<DefaultValue(DefaultSplitGlyphScaling)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property SplitGlyphScaling() As Single
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Split are glyph scaling factor.")]
[DefaultValue(DefaultSplitGlyphScaling)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public float SplitGlyphScaling {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.SplitImageList Property

ImageList for the split button part.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("ImageList for the split button part.")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property SplitImageList() As ImageList
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("ImageList for the split button part.")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
public ImageList SplitImageList {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.SplitSize Property

Split part width in pixels.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Split part width in pixels.")> _
<DefaultValue(DefaultSplitSize)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property SplitSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Split part width in pixels.")]
[DefaultValue(DefaultSplitSize)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public int SplitSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.Text Property

Gets or sets the text caption displayed in the button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the text caption displayed in the button.")> _
<DefaultValue("")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Overrides Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the text caption displayed in the button.")]
[DefaultValue("")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public override string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.TextAlign Property

Gets or sets the alignment of the text on the button control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets the alignment of the text on the button control.")> _
<DefaultValue(GetType(ContentAlignment), "MiddleCenter")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property TextAlign() As ContentAlignment
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets the alignment of the text on the button control.")]
[DefaultValue(GetType(ContentAlignment), "MiddleCenter")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public ContentAlignment TextAlign {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.UseCompatibleTextRendering Property

Specifies whether text rendering shoud be compatible with previous releases of Windows Forms.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<Description("Specifies whether text rendering shoud be compatible with previous releases of Windows Forms.")> _
<DefaultValue(DefaultUseCompatibleTextRendering)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public Property UseCompatibleTextRendering() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[Description("Specifies whether text rendering shoud be compatible with previous releases of Windows Forms.")]
[DefaultValue(DefaultUseCompatibleTextRendering)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
public bool UseCompatibleTextRendering {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.UseMnemonic Property

Gets or sets a value indicating whether an ampersand (&) included in the text of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets or sets a value indicating whether an ampersand (&amp;) included in the text of the control.")> _
<DefaultValue(DefaultUseMnemonic)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property UseMnemonic() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets or sets a value indicating whether an ampersand (&amp;) included in the text of the control.")]
[DefaultValue(DefaultUseMnemonic)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public bool UseMnemonic {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.UseVisualStyleBackColor Property

Determines whether the backgrount is drawn using visual styles, if visual styles are supported.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Determines whether the backgrount is drawn using visual styles, if visual styles are supported.")> _
<DefaultValue(DefaultUseVisualStyleBackColor)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property UseVisualStyleBackColor() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Determines whether the backgrount is drawn using visual styles, if visual styles are supported.")]
[DefaultValue(DefaultUseVisualStyleBackColor)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public bool UseVisualStyleBackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton Methods

NetSplitButton Class See Also

The following tables list the members exposed by the NetSplitButton type.

Methods
 | Name | Description
Public method | NotifyDefault | Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.
Public method | PerformClick | Generates a Click event for the control.
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

NetSplitButton Class


NetSplitButton.NotifyDefault Method

Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
public virtual System.Void NotifyDefault(
   bool value
)
This language is not supported or no code example is available.

Parameters

value

Type: bool

true if the control should behave as a default button; otherwise false.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.PerformClick Method

Generates a Click event for the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
public System.Void PerformClick()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton.Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Sub Refresh()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override System.Void Refresh()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButton Events

NetSplitButton Class See Also

The following tables list the members exposed by the NetSplitButton type.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when AutoSize property has changed.
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MenuShowing | Occurs before the context menu is shown.
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | SplitClick | Occurs when the split part is clicked.
Public event | SplitDoubleClick | Occurs when the split part is double-clicked.
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetSplitButton Class


AutoSizeChanged Event

Occurs when AutoSize property has changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Property Changed")> _
<Description("Occurs when AutoSize property has changed")> _
Public Shadows Event AutoSizeChanged( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Property Changed")]
[Description("Occurs when AutoSize property has changed")]
new public event AutoSizeChangedEventHandler AutoSizeChanged
delegate void AutoSizeChangedEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


MenuShowing Event

Occurs before the context menu is shown.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Action")> _
<Description("Occurs before the context menu is shown")> _
Public Event MenuShowing( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Action")]
[Description("Occurs before the context menu is shown")]
public event MenuShowingEventHandler MenuShowing
delegate void MenuShowingEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


SplitClick Event

Occurs when the split part is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Action")> _
<Description("Occurs when the split part is clicked")> _
Public Event SplitClick( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Action")]
[Description("Occurs when the split part is clicked")]
public event SplitClickEventHandler SplitClick
delegate void SplitClickEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


SplitDoubleClick Event

Occurs when the split part is double-clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Action")> _
<Description("Occurs when the split part is double-clicked")> _
Public Event SplitDoubleClick( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Action")]
[Description("Occurs when the split part is double-clicked")]
public event SplitDoubleClickEventHandler SplitDoubleClick
delegate void SplitDoubleClickEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButton Class
NetSplitButton Members


NetSplitButtonAppearance Class

Members

Button with split part that can show ContextMenuStrip.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<TypeConverter(GetType(NetSplitButtonAppearanceConverter))> _
Public NotInheritable Class NetSplitButtonAppearance
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[TypeConverter(GetType(NetSplitButtonAppearanceConverter))]
public sealed class NetSplitButtonAppearance
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
Softgroup.NetControls.NetSplitButtonAppearance
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Members


NetSplitButtonAppearance Members

NetSplitButtonAppearance Class Methods Properties See Also

Button with split part that can show ContextMenuStrip.

The following tables list the members exposed by the NetSplitButtonAppearance type.

Properties
 | Name | Description
Public property | BorderColor | Specifies the color of border around button.
Public property | BorderSize | Specifies the size of border around button in pixels.
Public property | MouseDownBackColor | Specifies the color of the client area while the button is pressed.
Public property | MouseOverBackColor | Specifies the color of the client area while cursor IS in it.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to this instance.
Public method | GetHashCode | Returns a hash code for this instance.
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetSplitButtonAppearance Class


NetSplitButtonAppearance Properties

NetSplitButtonAppearance Class See Also

The following tables list the members exposed by the NetSplitButtonAppearance type.

Properties
 | Name | Description
Public property | BorderColor | Specifies the color of border around button.
Public property | BorderSize | Specifies the size of border around button in pixels.
Public property | MouseDownBackColor | Specifies the color of the client area while the button is pressed.
Public property | MouseOverBackColor | Specifies the color of the client area while cursor IS in it.
Top
See Also

Reference

NetSplitButtonAppearance Class


NetSplitButtonAppearance.BorderColor Property

Specifies the color of border around button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Specifies the color of border around button")> _
<DefaultValue(GetType(Color), "")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property BorderColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Specifies the color of border around button")]
[DefaultValue(GetType(Color), "")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Color BorderColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetSplitButtonAppearance.BorderSize Property

Specifies the size of border around button in pixels.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Specifies the size of border around button in pixels")> _
<DefaultValue(DefaultBorderSize)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property BorderSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Specifies the size of border around button in pixels")]
[DefaultValue(DefaultBorderSize)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public int BorderSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetSplitButtonAppearance.MouseDownBackColor Property

Specifies the color of the client area while the button is pressed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Specifies the color of the client area while the button is pressed")> _
<DefaultValue(GetType(Color), "")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property MouseDownBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Specifies the color of the client area while the button is pressed")]
[DefaultValue(GetType(Color), "")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Color MouseDownBackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetSplitButtonAppearance.MouseOverBackColor Property

Specifies the color of the client area while cursor IS in it.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Specifies the color of the client area while cursor IS in it")> _
<DefaultValue(GetType(Color), "")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Property MouseOverBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Specifies the color of the client area while cursor IS in it")]
[DefaultValue(GetType(Color), "")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Color MouseOverBackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetSplitButtonAppearance Methods

NetSplitButtonAppearance Class See Also

The following tables list the members exposed by the NetSplitButtonAppearance type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Determines whether the specified Object is equal to this instance.
Public method | GetHashCode | Returns a hash code for this instance.
Public method | GetType | Ottiene l'oggetto Type dell'istanza corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetSplitButtonAppearance Class


NetSplitButtonAppearance.Equals Method

NetSplitButtonAppearance Class See Also

Determines whether the specified Object is equal to this instance.

Overload List
Name | Description
Equals(Object,Object) | Determina se le istanze di Object specificate sono considerate uguali. (inherited from Object).
Equals(object) | Determines whether the specified Object is equal to this instance.
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetSplitButtonAppearance.GetHashCode Method

Returns a hash code for this instance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


NetTabControl Class

Members

Softgroup .Net Tab Control is a fast, small, lightweight and enhanced version of standard .Net TabControl that implements unsupported behaviors and features of standard control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetTabControl), "NetTabControl.bmp")> _
<Designer(GetType(NetTabControlDesigner))> _
<DefaultEvent("SelectedIndexChanging")> _
Public Class NetTabControl
    Inherits TabControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetTabControl), "NetTabControl.bmp")]
[Designer(GetType(NetTabControlDesigner))]
[DefaultEvent("SelectedIndexChanging")]
public class NetTabControl : TabControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TabControl
Softgroup.NetControls.NetTabControl
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Members


NetTabControl Members

NetTabControl Class Constructors Events Methods Properties See Also

Softgroup .Net Tab Control is a fast, small, lightweight and enhanced version of standard .Net TabControl that implements unsupported behaviors and features of standard control.

The following tables list the members exposed by the NetTabControl type.

Constructors
 | Name | Description
Public constructor | NetTabControl Constructor | (Overloaded) Initializes a new instance of the NetTabControl class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | Alignment | (inherited from TabControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | Appearance | (Overloaded) Gets or sets the visual appearance of the control's tabs.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from TabControl).
Public property | BackgroundImage | (inherited from TabControl).
Public property | BackgroundImageLayout | (inherited from TabControl).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultHotColor | Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).
 | DefaultSelectedTabColor | Gets the default color for the color of selected tabs.
 | DefaultTabColor | Gets/Sets the default color of unselected tabs.
Public property | DisplayRectangle | (inherited from TabControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from TabControl).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HotColor | Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).
Public property | HotTrack | (inherited from TabControl).
Public property | HoverTab | Gets the current NetTabPage where mouse is over.
Public property | ImageList | (inherited from TabControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemSize | (inherited from TabControl).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Multiline | (inherited from TabControl).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from TabControl).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | RightToLeftLayout | (inherited from TabControl).
Public property | RowCount | (inherited from TabControl).
Public property | SelectedIndex | (inherited from TabControl).
Public property | SelectedTab | (Overloaded) Gets/Sets the currently selected tab page
Public property | SelectedTabColor | Gets/Sets color of selected tabs.
Public property | SelectedTabFontStyle | The font style used to display text tabs.
Public property | SetFocusOnTabChanged | Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one.
Public property | ShowToolTips | (inherited from TabControl).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SizeMode | (inherited from TabControl).
Public property | TabColor | Gets/Sets the color of unselected tabs.
Public property | TabCount | (inherited from TabControl).
Public property | TabIndex | (inherited from Control).
Public property | TabPages | Gets the collection of pages of NetTabControl.
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from TabControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UpdatingTabPageControl | Gets/Sets control that must receive focus on next TabPage update (this property can be sets only if not UpdatingTabPageIndex is -1).
Public property | UpdatingTabPageIndex | Gets the index of TabPage that is currently updating or -1 if none.
Public property | UseVisualStyles | Enables/Disables Theme Visual Styles (supported when Appearance is sets to Normal).
Public property | UseVisualStylesTabPages | Enables/Disables Theme Visual Styles for all TabPages.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DeselectTab | (Overloaded)
Public method | GetControl | (inherited from TabControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetTabPageIndex | Get index of specified NetTabPage or -1 if not found
Public method | GetTabRect | (inherited from TabControl).
Public method | InsertTabPage | Inserta a new NetTabPage before specified NetTabPage index.
Public method | ResetBindings | (inherited from Control).
Public method | SelectNextTabPage | (Overloaded) Makes the NetTabPage following the specified index the current NetTabPage.
Public method | SelectPrevTabPage | (Overloaded) Makes the NetTabPage preceding with the specified index the current NetTabPage.
Public method | SelectTab | (Overloaded)
Public method | ToString | (inherited from TabControl).
Public method | UpdateTabPageFocus | (Overloaded) Update focus of specified tabepage on first control.
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from TabControl).
Public event | BackgroundImageChanged | (inherited from TabControl).
Public event | BackgroundImageLayoutChanged | (inherited from TabControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Deselected | (inherited from TabControl).
Public event | Deselecting | (inherited from TabControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from TabControl).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from TabControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from TabControl).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | RightToLeftLayoutChanged | (inherited from TabControl).
Public event | Selected | (inherited from TabControl).
Public event | SelectedIndexChanged | (inherited from TabControl).
Public event | SelectedIndexChanging | Occurs when as a tab is being changed.
Public event | Selecting | (inherited from TabControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from TabControl).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetTabControl Class


NetTabControl Constructor

NetTabControl Class See Also

Initializes a new instance of the NetTabControl class.

Overload List
Name | Description
NetTabControl() | Initializes a new instance of the NetTabControl class.
NetTabControl(IContainer) | Initializes a new instance of the NetTabControl class.
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl Properties

NetTabControl Class See Also

The following tables list the members exposed by the NetTabControl type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | Alignment | (inherited from TabControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | Appearance | (Overloaded) Gets or sets the visual appearance of the control's tabs.
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from TabControl).
Public property | BackgroundImage | (inherited from TabControl).
Public property | BackgroundImageLayout | (inherited from TabControl).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultHotColor | Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).
 | DefaultSelectedTabColor | Gets the default color for the color of selected tabs.
 | DefaultTabColor | Gets/Sets the default color of unselected tabs.
Public property | DisplayRectangle | (inherited from TabControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DrawMode | (Overloaded) Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from TabControl).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HotColor | Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).
Public property | HotTrack | (inherited from TabControl).
Public property | HoverTab | Gets the current NetTabPage where mouse is over.
Public property | ImageList | (inherited from TabControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | ItemSize | (inherited from TabControl).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Multiline | (inherited from TabControl).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from TabControl).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | RightToLeftLayout | (inherited from TabControl).
Public property | RowCount | (inherited from TabControl).
Public property | SelectedIndex | (inherited from TabControl).
Public property | SelectedTab | (Overloaded) Gets/Sets the currently selected tab page
Public property | SelectedTabColor | Gets/Sets color of selected tabs.
Public property | SelectedTabFontStyle | The font style used to display text tabs.
Public property | SetFocusOnTabChanged | Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one.
Public property | ShowToolTips | (inherited from TabControl).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SizeMode | (inherited from TabControl).
Public property | TabColor | Gets/Sets the color of unselected tabs.
Public property | TabCount | (inherited from TabControl).
Public property | TabIndex | (inherited from Control).
Public property | TabPages | Gets the collection of pages of NetTabControl.
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from TabControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UpdatingTabPageControl | Gets/Sets control that must receive focus on next TabPage update (this property can be sets only if not UpdatingTabPageIndex is -1).
Public property | UpdatingTabPageIndex | Gets the index of TabPage that is currently updating or -1 if none.
Public property | UseVisualStyles | Enables/Disables Theme Visual Styles (supported when Appearance is sets to Normal).
Public property | UseVisualStylesTabPages | Enables/Disables Theme Visual Styles for all TabPages.
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetTabControl Class


NetTabControl.Appearance Property

NetTabControl Class See Also

Gets or sets the visual appearance of the control's tabs.

Overload List
Name | Description
this[ref object, ref object] | Gets or sets the visual appearance of the control's tabs.
Appearance | (System.Windows.Forms.TabControl).
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DefaultHotColor Property

Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).")> _
Public ReadOnly Shared Property DefaultHotColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).")]
public static Color DefaultHotColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DefaultSelectedTabColor Property

Gets the default color for the color of selected tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default color for the color of selected tabs.")> _
Public ReadOnly Shared Property DefaultSelectedTabColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default color for the color of selected tabs.")]
public static Color DefaultSelectedTabColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DefaultTabColor Property

Gets/Sets the default color of unselected tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the default color of unselected tabs.")> _
Public ReadOnly Shared Property DefaultTabColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the default color of unselected tabs.")]
public static Color DefaultTabColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DrawMode Property

NetTabControl Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DrawMode | (System.Windows.Forms.TabControl).
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.HotColor Property

Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<DefaultValue(GetType(Color), "ControlLightLight")> _
<Description("Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).")> _
<Category("NetTabControl")> _
Public Property HotColor( _
   ByRef GetType As Object, _
   ByRef "ControlLightLight" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[DefaultValue(GetType(Color), "ControlLightLight")]
[Description("Gets/Sets the color of tabs when mouse passes over them (HotTrack must be sets to True).")]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("HotColor")]
public Color this[
   ref object GetType,
   ref object "ControlLightLight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlLightLight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.HoverTab Property

Gets the current NetTabPage where mouse is over.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<System.ComponentModel.Description("Gets the current NetTabPage where mouse is over.")> _
Public ReadOnly Property HoverTab() As NetTabPage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[System.ComponentModel.Description("Gets the current NetTabPage where mouse is over.")]
public NetTabPage HoverTab {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectedTab Property

NetTabControl Class See Also

Gets/Sets the currently selected tab page

Overload List
Name | Description
this[ref object] | Gets/Sets the currently selected tab page
SelectedTab | (System.Windows.Forms.TabControl).
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectedTabColor Property

Gets/Sets color of selected tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Description("Gets/Sets color of selected tabs.")> _
<Category("NetTabControl")> _
<DefaultValue(GetType(Color), "ControlLight")> _
Public Property SelectedTabColor( _
   ByRef "Gets/Sets color of selected tabs." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Description("Gets/Sets color of selected tabs.")]
[Category("NetTabControl")]
[DefaultValue(GetType(Color), "ControlLight")]
[System.Runtime.CompilerServices.IndexerName("SelectedTabColor")]
public Color this[
   ref object "Gets/Sets color of selected tabs."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets color of selected tabs."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectedTabFontStyle Property

The font style used to display text tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<DefaultValue(GetType(FontStyle), "Regular")> _
<Description("The font style used to display text tabs.")> _
<Category("NetTabControl")> _
Public Property SelectedTabFontStyle( _
   ByRef GetType As Object, _
   ByRef "Regular" As Object _
) As FontStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[DefaultValue(GetType(FontStyle), "Regular")]
[Description("The font style used to display text tabs.")]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("SelectedTabFontStyle")]
public FontStyle this[
   ref object GetType,
   ref object "Regular"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Regular"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SetFocusOnTabChanged Property

Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Description("Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one.")> _
<DefaultValue(True)> _
<Category("NetTabControl")> _
Public Property SetFocusOnTabChanged( _
   ByRef "Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Description("Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one.")]
[DefaultValue(True)]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("SetFocusOnTabChanged")]
public bool this[
   ref object "Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Enables/Disables behavior of moving focus into first control of selected NetTabPage when TabControl receive focus and/or user change to a different one."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.TabColor Property

Gets/Sets the color of unselected tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Description("Gets/Sets the color of unselected tabs.")> _
<Category("NetTabControl")> _
<DefaultValue(GetType(Color), "Control")> _
Public Property TabColor( _
   ByRef "Gets/Sets the color of unselected tabs." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Description("Gets/Sets the color of unselected tabs.")]
[Category("NetTabControl")]
[DefaultValue(GetType(Color), "Control")]
[System.Runtime.CompilerServices.IndexerName("TabColor")]
public Color this[
   ref object "Gets/Sets the color of unselected tabs."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the color of unselected tabs."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.TabPages Property

Gets the collection of pages of NetTabControl.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Editor(GetType(NetTabPageCollectionEditor), GetType(UITypeEditor))> _
<System.ComponentModel.Description("Gets the collection of pages of NetTabControl.")> _
Public ReadOnly Overloads Property TabPages() As TabPageCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Editor(GetType(NetTabPageCollectionEditor), GetType(UITypeEditor))]
[System.ComponentModel.Description("Gets the collection of pages of NetTabControl.")]
public TabPageCollection TabPages {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UpdatingTabPageControl Property

Gets/Sets control that must receive focus on next TabPage update (this property can be sets only if not UpdatingTabPageIndex is -1).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<Description("Gets/Sets control that must receive focus on next TabPage update (this property can be sets only if not UpdatingTabPageIndex is -1).")> _
<DefaultValue(CStr(Nothing))> _
<Category("NetTabControl")> _
Public Property UpdatingTabPageControl( _
   ByRef "Gets/Sets control that must receive focus on next TabPage update  As Object _
) As Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[Description("Gets/Sets control that must receive focus on next TabPage update (this property can be sets only if not UpdatingTabPageIndex is -1).")]
[DefaultValue(CStr(Nothing))]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("UpdatingTabPageControl")]
public Control this[
   ref object "Gets/Sets control that must receive focus on next TabPage update
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets control that must receive focus on next TabPage update

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UpdatingTabPageIndex Property

Gets the index of TabPage that is currently updating or -1 if none.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<Description("Gets the index of TabPage that is currently updating or -1 if none.")> _
<DefaultValue(-1)> _
<Category("NetTabControl")> _
Public ReadOnly Property UpdatingTabPageIndex( _
   ByRef "Gets the index of TabPage that is currently updating or -1 if none." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[Description("Gets the index of TabPage that is currently updating or -1 if none.")]
[DefaultValue(-1)]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("UpdatingTabPageIndex")]
public int this[
   ref object "Gets the index of TabPage that is currently updating or -1 if none."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the index of TabPage that is currently updating or -1 if none."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UseVisualStyles Property

Enables/Disables Theme Visual Styles (supported when Appearance is sets to Normal).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.All)> _
<Description("Enables/Disables Theme Visual Styles (Support when Appearance is sets to Normal).")> _
<DefaultValue(True)> _
<Category("NetTabControl")> _
Public Property UseVisualStyles( _
   ByRef "Enables/Disables Theme Visual Styles  As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.All)]
[Description("Enables/Disables Theme Visual Styles (Support when Appearance is sets to Normal).")]
[DefaultValue(True)]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("UseVisualStyles")]
public bool this[
   ref object "Enables/Disables Theme Visual Styles
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Enables/Disables Theme Visual Styles

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UseVisualStylesTabPages Property

Enables/Disables Theme Visual Styles for all TabPages.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.All)> _
<Description("Enables/Disables Theme Visual Styles  for all TabPages.")> _
<DefaultValue(False)> _
<Category("NetTabControl")> _
Public Property UseVisualStylesTabPages( _
   ByRef "Enables/Disables Theme Visual Styles  for all TabPages." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.All)]
[Description("Enables/Disables Theme Visual Styles  for all TabPages.")]
[DefaultValue(False)]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("UseVisualStylesTabPages")]
public bool this[
   ref object "Enables/Disables Theme Visual Styles  for all TabPages."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Enables/Disables Theme Visual Styles for all TabPages."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl Methods

NetTabControl Class See Also

The following tables list the members exposed by the NetTabControl type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DeselectTab | (Overloaded)
Public method | GetControl | (inherited from TabControl).
Public method | GetPreferredSize | (inherited from Control).
Public method | GetTabPageIndex | Get index of specified NetTabPage or -1 if not found
Public method | GetTabRect | (inherited from TabControl).
Public method | InsertTabPage | Inserta a new NetTabPage before specified NetTabPage index.
Public method | ResetBindings | (inherited from Control).
Public method | SelectNextTabPage | (Overloaded) Makes the NetTabPage following the specified index the current NetTabPage.
Public method | SelectPrevTabPage | (Overloaded) Makes the NetTabPage preceding with the specified index the current NetTabPage.
Public method | SelectTab | (Overloaded)
Public method | ToString | (inherited from TabControl).
Public method | UpdateTabPageFocus | (Overloaded) Update focus of specified tabepage on first control.
Top
See Also

Reference

NetTabControl Class


NetTabControl.DeselectTab Method

NetTabControl Class See Also

Overload List
Name | Description
DeselectTab(int) |
DeselectTab(TabPage) |
DeselectTab(string) |
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.GetTabPageIndex Method

Get index of specified NetTabPage or -1 if not found

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetTabPageIndex( _
   ByVal oTabPage As NetTabPage _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int GetTabPageIndex(
   NetTabPage oTabPage
)
This language is not supported or no code example is available.

Parameters

oTabPage

Type: NetTabPage

A valid TabPage index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.InsertTabPage Method

Inserta a new NetTabPage before specified NetTabPage index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Inserta a new NetTabPage before specified NetTabPage index.")> _
Public Sub InsertTabPage( _
   ByVal oTabPage As NetTabPage, _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Inserta a new NetTabPage before specified NetTabPage index.")]
public System.Void InsertTabPage(
   NetTabPage oTabPage,
   int index
)
This language is not supported or no code example is available.

Parameters

oTabPage

Type: NetTabPage

index

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectNextTabPage Method

NetTabControl Class See Also

Makes the NetTabPage following the specified index the current NetTabPage.

Overload List
Name | Description
SelectNextTabPage(int) | Makes the NetTabPage following the specified index the current NetTabPage.
SelectNextTabPage(NetTabPage) | Makes the NetTabPage following the specified key the current NetTabPage.
SelectNextTabPage(string) | Makes the NetTabPage following the specified key the current NetTabPage.
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectPrevTabPage Method

NetTabControl Class See Also

Makes the NetTabPage preceding with the specified index the current NetTabPage.

Overload List
Name | Description
SelectPrevTabPage(int) | Makes the NetTabPage preceding with the specified index the current NetTabPage.
SelectPrevTabPage(NetTabPage) | Makes the NetTabPage preceding with the specified sKey the current NetTabPage.
SelectPrevTabPage(string) | Makes the NetTabPage preceding with the specified sKey the current NetTabPage.
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectTab Method

NetTabControl Class See Also

Overload List
Name | Description
SelectTab(int) |
SelectTab(TabPage) |
SelectTab(string) |
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UpdateTabPageFocus Method

NetTabControl Class See Also

Update focus of specified tabepage on first control.

Overload List
Name | Description
UpdateTabPageFocus(int) | Update focus of specified tabepage on first control.
UpdateTabPageFocus(int, Control) | Sets focus of specified tabepage on specified control.
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl Events

NetTabControl Class See Also

The following tables list the members exposed by the NetTabControl type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from TabControl).
Public event | BackgroundImageChanged | (inherited from TabControl).
Public event | BackgroundImageLayoutChanged | (inherited from TabControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Deselected | (inherited from TabControl).
Public event | Deselecting | (inherited from TabControl).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | DrawItem | (inherited from TabControl).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from TabControl).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from TabControl).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | RightToLeftLayoutChanged | (inherited from TabControl).
Public event | Selected | (inherited from TabControl).
Public event | SelectedIndexChanged | (inherited from TabControl).
Public event | SelectedIndexChanging | Occurs when as a tab is being changed.
Public event | Selecting | (inherited from TabControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from TabControl).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetTabControl Class


SelectedIndexChanging Event

Occurs when as a tab is being changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Occurs when as a tab is being changed.")> _
Public Event SelectedIndexChanging( _
   ByVal sender As Object, _
   ByVal e As TabControlCancelEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Occurs when as a tab is being changed.")]
public event SelectedIndexChangingEventHandler SelectedIndexChanging
delegate void SelectedIndexChangingEventHandler(
   object sender,
   TabControlCancelEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: TabControlCancelEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabPage Class

Members

Represents a single tab page in a NetTabControl

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Designer(GetType(NetTabPageDesigner))> _
Public Class NetTabPage
    Inherits TabPage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Designer(GetType(NetTabPageDesigner))]
public class NetTabPage : TabPage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
System.Windows.Forms.TabPage
Softgroup.NetControls.NetTabPage
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Members


NetTabPage Members

NetTabPage Class Constructors Events Methods Properties See Also

Represents a single tab page in a NetTabControl

The following tables list the members exposed by the NetTabPage type.

Constructors
 | Name | Description
Public constructor | NetTabPage Constructor | (Overloaded) Initializes a new instance of the NetTabPage class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from TabPage).
Public property | AutoScroll | (inherited from ScrollableControl).
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from TabPage).
Public property | AutoSizeMode | (inherited from TabPage).
Public property | BackColor | (inherited from TabPage).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default background gradient colour
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from TabPage).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (Overloaded) Gets/Sets enabled state of NetTabPage
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets the background gradient colour
Public property | GradientEnabled | Enable/Disable background gradient effect
Public property | GradientMode | Gets/Sets background gradient effect direction
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImageIndex | (inherited from TabPage).
Public property | ImageKey | (inherited from TabPage).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from TabPage).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from TabPage).
Public property | MinimumSize | (inherited from TabPage).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from TabPage).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from TabPage).
Public property | TabStop | (inherited from TabPage).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from TabPage).
Public property | ToolTipText | (inherited from TabPage).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseVisualStyleBackColor | (inherited from TabPage).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from TabPage).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
 | GetTabPageOfComponent | (inherited from TabPage).
Public method | Hide | Hide NetTabPage
Public method | NetTabControl | Gets a reference to NetTabControl container
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | Show | (Overloaded) Display NetTabPage
Public method | ToString | (inherited from TabPage).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from TabPage).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from TabPage).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from TabPage).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from TabPage).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from TabPage).
Public event | TabStopChanged | (inherited from TabPage).
Public event | TextChanged | (inherited from TabPage).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from TabPage).
Top
See Also

Reference

NetTabPage Class


NetTabPage Constructor

NetTabPage Class See Also

Initializes a new instance of the NetTabPage class.

Overload List
Name | Description
NetTabPage() | Initializes a new instance of the NetTabPage class.
NetTabPage(IContainer) | Initializes a new instance of the NetTabPage class.
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage Properties

NetTabPage Class See Also

The following tables list the members exposed by the NetTabPage type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from TabPage).
Public property | AutoScroll | (inherited from ScrollableControl).
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from TabPage).
Public property | AutoSizeMode | (inherited from TabPage).
Public property | BackColor | (inherited from TabPage).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default background gradient colour
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from TabPage).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (Overloaded) Gets/Sets enabled state of NetTabPage
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets the background gradient colour
Public property | GradientEnabled | Enable/Disable background gradient effect
Public property | GradientMode | Gets/Sets background gradient effect direction
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImageIndex | (inherited from TabPage).
Public property | ImageKey | (inherited from TabPage).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from TabPage).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from TabPage).
Public property | MinimumSize | (inherited from TabPage).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from TabPage).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from TabPage).
Public property | TabStop | (inherited from TabPage).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from TabPage).
Public property | ToolTipText | (inherited from TabPage).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseVisualStyleBackColor | (inherited from TabPage).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from TabPage).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetTabPage Class


NetTabPage.DefaultGradientColor Property

Gets the default background gradient colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets the default background gradient colour")> _
Public ReadOnly Shared Property DefaultGradientColor( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets the default background gradient colour")]
[System.Runtime.CompilerServices.IndexerName("DefaultGradientColor")]
public static Color this[
   ref object DesignerSerializationVisibility.Hidden
] {get;}
This language is not supported or no code example is available.

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.Enabled Property

NetTabPage Class See Also

Gets/Sets enabled state of NetTabPage

Overload List
Name | Description
this[ref object] | Gets/Sets enabled state of NetTabPage
Enabled | (System.Windows.Forms.TabPage).
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.GradientColor Property

Gets/Sets the background gradient colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(Color), "ControlLightLight")> _
<Description("Gets/Sets the background gradient colour")> _
<Category("Appearance")> _
Public Property GradientColor( _
   ByRef "Gets/Sets the background gradient colour" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(Color), "ControlLightLight")]
[Description("Gets/Sets the background gradient colour")]
[Category("Appearance")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "Gets/Sets the background gradient colour"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the background gradient colour"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.GradientEnabled Property

Enable/Disable background gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Enable/Disable background gradient effect")> _
<Category("Appearance")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "Appearance" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Enable/Disable background gradient effect")]
[Category("Appearance")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Remarks

If UseVisualStyle of NetTabControl and UseVisualStylesBackcolor are enabled: GradientEnabled, GradientMode and GradienColor properties will be ignored

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.GradientMode Property

Gets/Sets background gradient effect direction

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(GetType(LinearGradientMode), "Vertical")> _
<Description("Gets/Sets background gradient effect direction")> _
<Category("Appearance")> _
Public Property GradientMode( _
   ByRef "Gets/Sets background gradient effect direction" As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(GetType(LinearGradientMode), "Vertical")]
[Description("Gets/Sets background gradient effect direction")]
[Category("Appearance")]
[System.Runtime.CompilerServices.IndexerName("GradientMode")]
public LinearGradientMode this[
   ref object "Gets/Sets background gradient effect direction"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets background gradient effect direction"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage Methods

NetTabPage Class See Also

The following tables list the members exposed by the NetTabPage type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
 | GetTabPageOfComponent | (inherited from TabPage).
Public method | Hide | Hide NetTabPage
Public method | NetTabControl | Gets a reference to NetTabControl container
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | Show | (Overloaded) Display NetTabPage
Public method | ToString | (inherited from TabPage).
Top
See Also

Reference

NetTabPage Class


NetTabPage.Hide Method

Hide NetTabPage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Hide NetTabPage")> _
Public Overloads Sub Hide()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Hide NetTabPage")]
public System.Void Hide()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.NetTabControl Method

Gets a reference to NetTabControl container

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function NetTabControl() As NetTabControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetTabControl NetTabControl()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.Show Method

NetTabPage Class See Also

Display NetTabPage

Overload List
Name | Description
Show(bool) | Display NetTabPage and optionally select it
Show() | Display NetTabPage
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage Events

NetTabPage Class See Also

The following tables list the members exposed by the NetTabPage type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from TabPage).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from TabPage).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from TabPage).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from TabPage).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from TabPage).
Public event | TabStopChanged | (inherited from TabPage).
Public event | TextChanged | (inherited from TabPage).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from TabPage).
Top
See Also

Reference

NetTabPage Class


NetThumbImage Class

Members

ThumImage object rappresent a single image displayed in the Thumbnail control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(False)> _
<DesignTimeVisible(False)> _
Public Class NetThumbImage
    Inherits PictureBox
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(False)]
[DesignTimeVisible(False)]
public class NetThumbImage : PictureBox
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.PictureBox
Softgroup.NetControls.NetThumbImage
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbImage Members


NetThumbImage Members

NetThumbImage Class Events Methods Properties See Also

ThumImage object rappresent a single image displayed in the Thumbnail control

The following tables list the members exposed by the NetThumbImage type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from PictureBox).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from PictureBox).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from PictureBox).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | ErrorImage | (inherited from PictureBox).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from PictureBox).
Public property | ForeColor | (inherited from PictureBox).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | (inherited from PictureBox).
Public property | ImageLocation | (inherited from PictureBox).
Public property | ImeMode | (inherited from PictureBox).
Public property | InitialImage | (inherited from PictureBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
Public property | MouseOver | Return True if mouse pointer is currently under this ThumbImage object
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from PictureBox).
Public property | Selected | Return True if this ThumbImage object is currently selected
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SizeMode | (inherited from PictureBox).
Public property | TabIndex | (inherited from PictureBox).
Public property | TabStop | (inherited from PictureBox).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from PictureBox).
Public property | Thumbnail | Gets the NetThumbnail control that currently host this ThumbImage object
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | WaitOnLoad | (inherited from PictureBox).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | CancelAsync | (inherited from PictureBox).
Public method | GetPreferredSize | (inherited from Control).
Public method | Load | (Overloaded) (inherited from PictureBox).
Public method | LoadAsync | (Overloaded) (inherited from PictureBox).
Public method | ResetBindings | (inherited from Control).
Public method | ToString | (inherited from PictureBox).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from PictureBox).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from PictureBox).
Public event | FontChanged | (inherited from PictureBox).
Public event | ForeColorChanged | (inherited from PictureBox).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from PictureBox).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from PictureBox).
Public event | KeyPress | (inherited from PictureBox).
Public event | KeyUp | (inherited from PictureBox).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from PictureBox).
Public event | LoadCompleted | (inherited from PictureBox).
Public event | LoadProgressChanged | (inherited from PictureBox).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from PictureBox).
Public event | SizeChanged | (inherited from Control).
Public event | SizeModeChanged | (inherited from PictureBox).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from PictureBox).
Public event | TabStopChanged | (inherited from PictureBox).
Public event | TextChanged | (inherited from PictureBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetThumbImage Class


NetThumbImage Properties

NetThumbImage Class See Also

The following tables list the members exposed by the NetThumbImage type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from PictureBox).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from PictureBox).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from PictureBox).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | ErrorImage | (inherited from PictureBox).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from PictureBox).
Public property | ForeColor | (inherited from PictureBox).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | Image | (inherited from PictureBox).
Public property | ImageLocation | (inherited from PictureBox).
Public property | ImeMode | (inherited from PictureBox).
Public property | InitialImage | (inherited from PictureBox).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
Public property | MouseOver | Return True if mouse pointer is currently under this ThumbImage object
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from PictureBox).
Public property | Selected | Return True if this ThumbImage object is currently selected
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SizeMode | (inherited from PictureBox).
Public property | TabIndex | (inherited from PictureBox).
Public property | TabStop | (inherited from PictureBox).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from PictureBox).
Public property | Thumbnail | Gets the NetThumbnail control that currently host this ThumbImage object
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | WaitOnLoad | (inherited from PictureBox).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetThumbImage Class


NetThumbImage.MouseOver Property

Return True if mouse pointer is currently under this ThumbImage object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property MouseOver() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool MouseOver {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbImage Class
NetThumbImage Members


NetThumbImage.Selected Property

Return True if this ThumbImage object is currently selected

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property Selected() As Boolean
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Selected {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbImage Class
NetThumbImage Members


NetThumbImage.Thumbnail Property

Gets the NetThumbnail control that currently host this ThumbImage object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Thumbnail() As NetThumbnail
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnail Thumbnail {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbImage Class
NetThumbImage Members


NetThumbImage Methods

NetThumbImage Class See Also

The following tables list the members exposed by the NetThumbImage type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | CancelAsync | (inherited from PictureBox).
Public method | GetPreferredSize | (inherited from Control).
Public method | Load | (Overloaded) (inherited from PictureBox).
Public method | LoadAsync | (Overloaded) (inherited from PictureBox).
Public method | ResetBindings | (inherited from Control).
Public method | ToString | (inherited from PictureBox).
Top
See Also

Reference

NetThumbImage Class


NetThumbImage Events

NetThumbImage Class See Also

The following tables list the members exposed by the NetThumbImage type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from PictureBox).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from PictureBox).
Public event | FontChanged | (inherited from PictureBox).
Public event | ForeColorChanged | (inherited from PictureBox).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from PictureBox).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from PictureBox).
Public event | KeyPress | (inherited from PictureBox).
Public event | KeyUp | (inherited from PictureBox).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from PictureBox).
Public event | LoadCompleted | (inherited from PictureBox).
Public event | LoadProgressChanged | (inherited from PictureBox).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from PictureBox).
Public event | SizeChanged | (inherited from Control).
Public event | SizeModeChanged | (inherited from PictureBox).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from PictureBox).
Public event | TabStopChanged | (inherited from PictureBox).
Public event | TextChanged | (inherited from PictureBox).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetThumbImage Class


NetThumbnail Class

Members

Softgroup .Net Thumbnail is a fast, small, lightweight and easy to use .NET control that gives your applications enhanced and high quality thumbnail images browser.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetThumbnail), "NetThumbnail.bmp")> _
<DefaultProperty("SelectedThumbImage")> _
<DefaultEvent("ImageClick")> _
Public Class NetThumbnail
    Inherits FlowLayoutPanel
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetThumbnail), "NetThumbnail.bmp")]
[DefaultProperty("SelectedThumbImage")]
[DefaultEvent("ImageClick")]
public class NetThumbnail : FlowLayoutPanel
This language is not supported or no code example is available.
Remarks

To add a Softgroup .Net Animation Control to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
System.Windows.Forms.FlowLayoutPanel
Softgroup.NetControls.NetThumbnail
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Members


NetThumbnail Members

NetThumbnail Class Constructors Events Methods Properties See Also

Softgroup .Net Thumbnail is a fast, small, lightweight and easy to use .NET control that gives your applications enhanced and high quality thumbnail images browser.

The following tables list the members exposed by the NetThumbnail type.

Constructors
 | Name | Description
Public constructor | NetThumbnail Constructor | Create a new instance of the class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AsyncMode | Gets/Sets if thumb images must be loaded asynchronously (more fast)
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Panel).
Public property | AutoSizeMode | (inherited from Panel).
Public property | BackColor | (Overloaded) Gets the background color of control
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FlowDirection | (inherited from FlowLayoutPanel).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImagesExtensions | Gets/Sets a string that rappresent estensions file images (separated by a pipe character) that can be displayed into control. The syntax is .ext1|.ext2| ... .extN. For ex.: .bmp|.jpg dispay only bitmap and jpeg images files type.
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from FlowLayoutPanel).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedThumbImage | Gets currently selected ThumbImage object.
Public property | ShowPreview | Gets/Sets if a preview window must be shown when user double click on a thumbnail
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Panel).
Public property | ThumSize | Gets/Sets the thumb image box size (this values can't less than 8)
Public property | ThumbBackColor | Gets/Sets the background colour of thumb images
Public property | ThumbBorderColor | Gets/Sets the color used to draw border of thumb images
Public property | ThumbHighLightMode | Gets/Sets the mode used to highlight currently selected ThumbImage object (see HighliteModeEnum enumeration).
Public property | ThumbHighlightColor | Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it.
Public property | ThumbImages | Gets the collection of current ThumbImage objects loaded
Public property | ThumbMaximum | Gets/Sets the maximum number of thumb images that can be loaded in the control (0 for no limit)
Public property | ThumbSelectedColor | Gets/Sets the colour used to draw border of currently selected ThumbImage object.
Public property | ThumbToolTips | Gets/Sets if tooltip informations must be shown for thumb images
Public property | Tooltip | Gets the tooltip control associated to this NetThumbnail control used to display thumbs images tooltips
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | WrapContents | (inherited from FlowLayoutPanel).
Top
Methods
 | Name | Description
Public method | AddFromFile | Add image into control from specified file name
Public method | AddFromFolder | (Overloaded) Add images into control from specified folder
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | Clear | Clear all images loded into the control
Public method | FindThumbImage | Find if specified file name is currently loaded into control and return its ThumbImage object otherwise return Nothing
Public method | GetExtensions | Gets a string array of file images estensions that can be displayed into control.
Public method | GetFlowBreak | (inherited from FlowLayoutPanel).
Public method | GetPreferredSize | (inherited from Control).
Public method | RemoveThumb | Remove specifided ThumbImage object from control
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | SetFlowBreak | (inherited from FlowLayoutPanel).
Public method | SetToolTip | Sets the tooltip text of specified ThumbImage
Public method | ToString | (inherited from Panel).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImageAdded | This event will be generated every time a new ThumbImage will be added to control
Public event | ImageClick | This event will be generated every time user click on a ThumbImage
Public event | ImageDoubleClick | This event will be generated every time user double click on a ThumbImage
Public event | ImageKeyDown | This event will be generated every time a key was pressed on a ThumbImage
Public event | ImageMouseDown | This event will be generated every time a mouse button was pressed on a ThumbImage
Public event | ImageMouseEnter | This event will be generated every time mouse cursor enter on a ThumbImage
Public event | ImageMouseHover | This event will be generated every time mouse cursor is over a ThumbImage
Public event | ImageMouseLeave | This event will be generated every time mouse cursor leave a ThumbImage
Public event | ImageMouseMove | This event will be generated every time mouse moves over a ThumbImage
Public event | ImageMouseUp | This event will be generated every time a mouse button was released on a ThumbImage
Public event | ImageMouseWheel | This event will be generated every time mouse wheel was moved over a ThumbImage
Public event | ImageRemoved | This event will be generated every time a ThumbImage will be removed form the control
Public event | ImageSelected | This event will be generated every time selected ThumbImage changes
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetThumbnail Class


NetThumbnail Constructor

Create a new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnail()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail Properties

NetThumbnail Class See Also

The following tables list the members exposed by the NetThumbnail type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AsyncMode | Gets/Sets if thumb images must be loaded asynchronously (more fast)
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (inherited from ScrollableControl).
Public property | AutoScrollMinSize | (inherited from ScrollableControl).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (inherited from Panel).
Public property | AutoSizeMode | (inherited from Panel).
Public property | BackColor | (Overloaded) Gets the background color of control
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FlowDirection | (inherited from FlowLayoutPanel).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImagesExtensions | Gets/Sets a string that rappresent estensions file images (separated by a pipe character) that can be displayed into control. The syntax is .ext1|.ext2| ... .extN. For ex.: .bmp|.jpg dispay only bitmap and jpeg images files type.
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from FlowLayoutPanel).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedThumbImage | Gets currently selected ThumbImage object.
Public property | ShowPreview | Gets/Sets if a preview window must be shown when user double click on a thumbnail
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Panel).
Public property | ThumSize | Gets/Sets the thumb image box size (this values can't less than 8)
Public property | ThumbBackColor | Gets/Sets the background colour of thumb images
Public property | ThumbBorderColor | Gets/Sets the color used to draw border of thumb images
Public property | ThumbHighLightMode | Gets/Sets the mode used to highlight currently selected ThumbImage object (see HighliteModeEnum enumeration).
Public property | ThumbHighlightColor | Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it.
Public property | ThumbImages | Gets the collection of current ThumbImage objects loaded
Public property | ThumbMaximum | Gets/Sets the maximum number of thumb images that can be loaded in the control (0 for no limit)
Public property | ThumbSelectedColor | Gets/Sets the colour used to draw border of currently selected ThumbImage object.
Public property | ThumbToolTips | Gets/Sets if tooltip informations must be shown for thumb images
Public property | Tooltip | Gets the tooltip control associated to this NetThumbnail control used to display thumbs images tooltips
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Public property | WrapContents | (inherited from FlowLayoutPanel).
Top
See Also

Reference

NetThumbnail Class


NetThumbnail.AsyncMode Property

Gets/Sets if thumb images must be loaded asynchronously (more fast)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(True)> _
<System.ComponentModel.Description("Gets/Sets if thumb images must be loaded asynchronously (more fast)")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property AsyncMode( _
   ByRef "Gets/Sets if thumb images must be loaded asynchronously  As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(True)]
[System.ComponentModel.Description("Gets/Sets if thumb images must be loaded asynchronously (more fast)")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("AsyncMode")]
public bool this[
   ref object "Gets/Sets if thumb images must be loaded asynchronously
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if thumb images must be loaded asynchronously

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.AutoScroll Property

NetThumbnail Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.BackColor Property

NetThumbnail Class See Also

Gets the background color of control

Overload List
Name | Description
this[ref object, ref object] | Gets the background color of control
BackColor | (System.Windows.Forms.Control).
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.Font Property

NetThumbnail Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ForeColor Property

NetThumbnail Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ImagesExtensions Property

Gets/Sets a string that rappresent estensions file images (separated by a pipe character) that can be displayed into control. The syntax is .ext1|.ext2| ... .extN. For ex.: .bmp|.jpg dispay only bitmap and jpeg images files type.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(".bmp|.gif|.ico|.jpg|.jpeg|.wmf|.png|.tiff|.tif")> _
<System.ComponentModel.Description("Gets/Sets a string that rappresent estensions file images (separated by a pipe character) that can be displayed into control. The syntax is .ext1|.ext2| ... .extN. For ex.: .bmp|.jpg dispay only bitmap and jpeg images files type.")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ImagesExtensions( _
   ByRef "Gets/Sets a string that rappresent estensions file images  As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(".bmp|.gif|.ico|.jpg|.jpeg|.wmf|.png|.tiff|.tif")]
[System.ComponentModel.Description("Gets/Sets a string that rappresent estensions file images (separated by a pipe character) that can be displayed into control. The syntax is .ext1|.ext2| ... .extN. For ex.: .bmp|.jpg dispay only bitmap and jpeg images files type.")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ImagesExtensions")]
public string this[
   ref object "Gets/Sets a string that rappresent estensions file images
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets a string that rappresent estensions file images

Type: object

Remarks

Following image file extensions are supported: .bmp, .gif, .ico, .jpg, .jpeg, .wmf, .png, .tiff or .tif

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.SelectedThumbImage Property

Gets currently selected ThumbImage object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<System.ComponentModel.Description("Gets currently selected ThumbImage object.")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property SelectedThumbImage( _
   ByRef "Gets currently selected ThumbImage object." As Object _
) As NetThumbImage
    Get

This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[System.ComponentModel.Description("Gets currently selected ThumbImage object.")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("SelectedThumbImage")]
public NetThumbImage this[
   ref object "Gets currently selected ThumbImage object."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets currently selected ThumbImage object."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ShowPreview Property

Gets/Sets if a preview window must be shown when user double click on a thumbnail

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets if a preview window must be shown when user double click on a thumbnail")> _
<System.ComponentModel.Category("NetThumbnail")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property ShowPreview( _
   ByRef "NetThumbnail" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets if a preview window must be shown when user double click on a thumbnail")]
[System.ComponentModel.Category("NetThumbnail")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("ShowPreview")]
public bool this[
   ref object "NetThumbnail"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetThumbnail"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue(True)> _
Public Overloads Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue(True)]
public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumSize Property

Gets/Sets the thumb image box size (this values can't less than 8)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets the thumb image box size (this values can't less than 8)")> _
<System.ComponentModel.Category("NetThumbnail")> _
<System.ComponentModel.DefaultValue(100)> _
Public Property ThumSize( _
   ByRef "NetThumbnail" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets the thumb image box size (this values can't less than 8)")]
[System.ComponentModel.Category("NetThumbnail")]
[System.ComponentModel.DefaultValue(100)]
[System.Runtime.CompilerServices.IndexerName("ThumSize")]
public int this[
   ref object "NetThumbnail"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetThumbnail"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbBackColor Property

Gets/Sets the background colour of thumb images

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")> _
<System.ComponentModel.Description("Gets/Sets the background colour of thumb images")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbBackColor( _
   ByRef "Gets/Sets the background colour of thumb images" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")]
[System.ComponentModel.Description("Gets/Sets the background colour of thumb images")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbBackColor")]
public Color this[
   ref object "Gets/Sets the background colour of thumb images"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the background colour of thumb images"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbBorderColor Property

Gets/Sets the color used to draw border of thumb images

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "WindowFrame")> _
<System.ComponentModel.Description("Gets/Sets the color used to draw border of thumb images")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbBorderColor( _
   ByRef "Gets/Sets the color used to draw border of thumb images" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "WindowFrame")]
[System.ComponentModel.Description("Gets/Sets the color used to draw border of thumb images")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbBorderColor")]
public Color this[
   ref object "Gets/Sets the color used to draw border of thumb images"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the color used to draw border of thumb images"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbHighLightMode Property

Gets/Sets the mode used to highlight currently selected ThumbImage object (see HighliteModeEnum enumeration).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(GetType(HighliteModeEnum), "GlassOnly")> _
<System.ComponentModel.Description("Gets/Sets the mode used to highlight currently selected ThumbImage object (see HighliteModeEnum enumeration).")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbHighLightMode( _
   ByRef "Gets/Sets the mode used to highlight currently selected ThumbImage object  As Object _
) As HighliteModeEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(GetType(HighliteModeEnum), "GlassOnly")]
[System.ComponentModel.Description("Gets/Sets the mode used to highlight currently selected ThumbImage object (see HighliteModeEnum enumeration).")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbHighLightMode")]
public HighliteModeEnum this[
   ref object "Gets/Sets the mode used to highlight currently selected ThumbImage object
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the mode used to highlight currently selected ThumbImage object

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbHighlightColor Property

Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Highlight")> _
<System.ComponentModel.Description("Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it.")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbHighlightColor( _
   ByRef "Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Highlight")]
[System.ComponentModel.Description("Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it.")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbHighlightColor")]
public Color this[
   ref object "Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the colour used to highlight a ThumbImage object when mouse is over it."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbImages Property

Gets the collection of current ThumbImage objects loaded

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<System.ComponentModel.Description("Gets the collection of current ThumbImage objects loaded")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public ReadOnly Property ThumbImages( _
   ByRef "Gets the collection of current ThumbImage objects loaded" As Object _
) As ControlCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[System.ComponentModel.Description("Gets the collection of current ThumbImage objects loaded")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbImages")]
public ControlCollection this[
   ref object "Gets the collection of current ThumbImage objects loaded"
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the collection of current ThumbImage objects loaded"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbMaximum Property

Gets/Sets the maximum number of thumb images that can be loaded in the control (0 for no limit)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets the maximum number of thumb images that can be loaded in the control (0 for no limit)")> _
<System.ComponentModel.Category("NetThumbnail")> _
<System.ComponentModel.DefaultValue(500)> _
Public Property ThumbMaximum( _
   ByRef "NetThumbnail" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets the maximum number of thumb images that can be loaded in the control (0 for no limit)")]
[System.ComponentModel.Category("NetThumbnail")]
[System.ComponentModel.DefaultValue(500)]
[System.Runtime.CompilerServices.IndexerName("ThumbMaximum")]
public int this[
   ref object "NetThumbnail"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"NetThumbnail"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbSelectedColor Property

Gets/Sets the colour used to draw border of currently selected ThumbImage object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Red")> _
<System.ComponentModel.Description("Gets/Sets the colour used to draw border of currently selected ThumbImage object.")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbSelectedColor( _
   ByRef "Gets/Sets the colour used to draw border of currently selected ThumbImage object." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Red")]
[System.ComponentModel.Description("Gets/Sets the colour used to draw border of currently selected ThumbImage object.")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbSelectedColor")]
public Color this[
   ref object "Gets/Sets the colour used to draw border of currently selected ThumbImage object."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the colour used to draw border of currently selected ThumbImage object."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ThumbToolTips Property

Gets/Sets if tooltip informations must be shown for thumb images

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DefaultValue(True)> _
<System.ComponentModel.Description("Gets/Sets if tooltip informations must be shown for thumb images")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property ThumbToolTips( _
   ByRef "Gets/Sets if tooltip informations must be shown for thumb images" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DefaultValue(True)]
[System.ComponentModel.Description("Gets/Sets if tooltip informations must be shown for thumb images")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("ThumbToolTips")]
public bool this[
   ref object "Gets/Sets if tooltip informations must be shown for thumb images"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if tooltip informations must be shown for thumb images"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.Tooltip Property

Gets the tooltip control associated to this NetThumbnail control used to display thumbs images tooltips

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the tooltip control associated to this NetThumbnail control used to display thumbs images tooltips")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public ReadOnly Property Tooltip( _
   ByRef "NetThumbnail" As Object _
) As ToolTip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the tooltip control associated to this NetThumbnail control used to display thumbs images tooltips")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("Tooltip")]
public ToolTip this[
   ref object "NetThumbnail"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetThumbnail"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail Methods

NetThumbnail Class See Also

The following tables list the members exposed by the NetThumbnail type.

Methods
 | Name | Description
Public method | AddFromFile | Add image into control from specified file name
Public method | AddFromFolder | (Overloaded) Add images into control from specified folder
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | Clear | Clear all images loded into the control
Public method | FindThumbImage | Find if specified file name is currently loaded into control and return its ThumbImage object otherwise return Nothing
Public method | GetExtensions | Gets a string array of file images estensions that can be displayed into control.
Public method | GetFlowBreak | (inherited from FlowLayoutPanel).
Public method | GetPreferredSize | (inherited from Control).
Public method | RemoveThumb | Remove specifided ThumbImage object from control
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | SetFlowBreak | (inherited from FlowLayoutPanel).
Public method | SetToolTip | Sets the tooltip text of specified ThumbImage
Public method | ToString | (inherited from Panel).
Top
See Also

Reference

NetThumbnail Class


NetThumbnail.AddFromFile Method

Add image into control from specified file name

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddFromFile( _
   ByVal FileUrl As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddFromFile(
   string FileUrl
)
This language is not supported or no code example is available.

Parameters

FileUrl

Type: string

Url or path file name of image to load

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.AddFromFolder Method

NetThumbnail Class See Also

Add images into control from specified folder

Overload List
Name | Description
AddFromFolder(string, bool) | Add images into control from specified folder
AddFromFolder(string) | Add images into control from specified folder
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.Clear Method

Clear all images loded into the control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Clear()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Clear()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.FindThumbImage Method

Find if specified file name is currently loaded into control and return its ThumbImage object otherwise return Nothing

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function FindThumbImage( _
   ByVal FileName As String _
) As NetThumbImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbImage FindThumbImage(
   string FileName
)
This language is not supported or no code example is available.

Parameters

FileName

Type: string

A file name

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.GetExtensions Method

Gets a string array of file images estensions that can be displayed into control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function GetExtensions() As String()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string[] GetExtensions()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.RemoveThumb Method

Remove specifided ThumbImage object from control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub RemoveThumb( _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveThumb(
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

oThumbImage

Type: NetThumbImage

A valid ThumbImage object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.SetToolTip Method

Sets the tooltip text of specified ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetToolTip( _
   ByVal oThumbImage As NetThumbImage, _
   ByVal sTipText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetToolTip(
   NetThumbImage oThumbImage,
   string sTipText
)
This language is not supported or no code example is available.

Parameters

oThumbImage

Type: NetThumbImage

A ThumbImage added

sTipText

Type: string

The Tooltip text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail Events

NetThumbnail Class See Also

The following tables list the members exposed by the NetThumbnail type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImageAdded | This event will be generated every time a new ThumbImage will be added to control
Public event | ImageClick | This event will be generated every time user click on a ThumbImage
Public event | ImageDoubleClick | This event will be generated every time user double click on a ThumbImage
Public event | ImageKeyDown | This event will be generated every time a key was pressed on a ThumbImage
Public event | ImageMouseDown | This event will be generated every time a mouse button was pressed on a ThumbImage
Public event | ImageMouseEnter | This event will be generated every time mouse cursor enter on a ThumbImage
Public event | ImageMouseHover | This event will be generated every time mouse cursor is over a ThumbImage
Public event | ImageMouseLeave | This event will be generated every time mouse cursor leave a ThumbImage
Public event | ImageMouseMove | This event will be generated every time mouse moves over a ThumbImage
Public event | ImageMouseUp | This event will be generated every time a mouse button was released on a ThumbImage
Public event | ImageMouseWheel | This event will be generated every time mouse wheel was moved over a ThumbImage
Public event | ImageRemoved | This event will be generated every time a ThumbImage will be removed form the control
Public event | ImageSelected | This event will be generated every time selected ThumbImage changes
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetThumbnail Class


ImageAdded Event

This event will be generated every time a new ThumbImage will be added to control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageAdded( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageAddedEventHandler ImageAdded
delegate void ImageAddedEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageClick Event

This event will be generated every time user click on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageClick( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageClickEventHandler ImageClick
delegate void ImageClickEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageDoubleClick Event

This event will be generated every time user double click on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageDoubleClick( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageDoubleClickEventHandler ImageDoubleClick
delegate void ImageDoubleClickEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageKeyDown Event

This event will be generated every time a key was pressed on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageKeyDown( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailKeyEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageKeyDownEventHandler ImageKeyDown
delegate void ImageKeyDownEventHandler(
   object sender,
   NetThumbnailKeyEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailKeyEventArgs

A NetThumbnailKeyEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseDown Event

This event will be generated every time a mouse button was pressed on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseDown( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailMouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseDownEventHandler ImageMouseDown
delegate void ImageMouseDownEventHandler(
   object sender,
   NetThumbnailMouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailMouseEventArgs

A NetThumbnailMouseEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseEnter Event

This event will be generated every time mouse cursor enter on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseEnter( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseEnterEventHandler ImageMouseEnter
delegate void ImageMouseEnterEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseHover Event

This event will be generated every time mouse cursor is over a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseHover( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseHoverEventHandler ImageMouseHover
delegate void ImageMouseHoverEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseLeave Event

This event will be generated every time mouse cursor leave a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseLeave( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseLeaveEventHandler ImageMouseLeave
delegate void ImageMouseLeaveEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseMove Event

This event will be generated every time mouse moves over a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseMove( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailMouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseMoveEventHandler ImageMouseMove
delegate void ImageMouseMoveEventHandler(
   object sender,
   NetThumbnailMouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailMouseEventArgs

A NetThumbnailMouseEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseUp Event

This event will be generated every time a mouse button was released on a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseUp( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailMouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseUpEventHandler ImageMouseUp
delegate void ImageMouseUpEventHandler(
   object sender,
   NetThumbnailMouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailMouseEventArgs

A NetThumbnailMouseEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageMouseWheel Event

This event will be generated every time mouse wheel was moved over a ThumbImage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageMouseWheel( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailMouseEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageMouseWheelEventHandler ImageMouseWheel
delegate void ImageMouseWheelEventHandler(
   object sender,
   NetThumbnailMouseEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailMouseEventArgs

A NetThumbnailMouseEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageRemoved Event

This event will be generated every time a ThumbImage will be removed form the control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageRemoved( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageRemovedEventHandler ImageRemoved
delegate void ImageRemovedEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that the take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ImageSelected Event

This event will be generated every time selected ThumbImage changes

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ImageSelected( _
   ByVal sender As Object, _
   ByVal e As NetThumbnailEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ImageSelectedEventHandler ImageSelected
delegate void ImageSelectedEventHandler(
   object sender,
   NetThumbnailEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The control that take action

e

Type: NetThumbnailEventArgs

A NetThumbnailEventArgs object with event parameters

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnailEventArgs Class

Members

Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class NetThumbnailEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class NetThumbnailEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.NetThumbnailEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailEventArgs Members


NetThumbnailEventArgs Members

NetThumbnailEventArgs Class Constructors Methods Properties See Also

Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.

The following tables list the members exposed by the NetThumbnailEventArgs type.

Constructors
 | Name | Description
Public constructor | NetThumbnailEventArgs Constructor | Initializes a new instance of the NetThumbnailEventArgs class.
Top
Properties
 | Name | Description
Public property | ThumbImage | Return True if displayed page is last.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailEventArgs Class


NetThumbnailEventArgs Constructor

Initializes a new instance of the NetThumbnailEventArgs class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnailEventArgs(
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

oThumbImage

Type: NetThumbImage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailEventArgs Class
NetThumbnailEventArgs Members


NetThumbnailEventArgs Properties

NetThumbnailEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailEventArgs type.

Properties
 | Name | Description
Public property | ThumbImage | Return True if displayed page is last.
Top
See Also

Reference

NetThumbnailEventArgs Class


NetThumbnailEventArgs.ThumbImage Property

Return True if displayed page is last.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property ThumbImage() As NetThumbImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbImage ThumbImage {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailEventArgs Class
NetThumbnailEventArgs Members


NetThumbnailEventArgs Methods

NetThumbnailEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailEventArgs Class


NetThumbnailKeyEventArgs Class

Members

Class NetThumbnailKeyEventArgs provide parameters events for Thumbnail control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class NetThumbnailKeyEventArgs
    Inherits KeyEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class NetThumbnailKeyEventArgs : KeyEventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
System.Windows.Forms.KeyEventArgs
Softgroup.NetControls.NetThumbnailKeyEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailKeyEventArgs Members


NetThumbnailKeyEventArgs Members

NetThumbnailKeyEventArgs Class Constructors Methods Properties See Also

Class NetThumbnailKeyEventArgs provide parameters events for Thumbnail control.

The following tables list the members exposed by the NetThumbnailKeyEventArgs type.

Constructors
 | Name | Description
Public constructor | NetThumbnailKeyEventArgs Constructor | (Overloaded) Create a new instance of the class.
Top
Properties
 | Name | Description
Public property | Alt | (inherited from KeyEventArgs).
Public property | Control | (inherited from KeyEventArgs).
Public property | Handled | (inherited from KeyEventArgs).
Public property | KeyCode | (inherited from KeyEventArgs).
Public property | KeyData | (inherited from KeyEventArgs).
Public property | KeyValue | (inherited from KeyEventArgs).
Public property | Modifiers | (inherited from KeyEventArgs).
Public property | Shift | (inherited from KeyEventArgs).
Public property | SuppressKeyPress | (inherited from KeyEventArgs).
Public property | ThumbImage | Return True if displayed page is last.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailKeyEventArgs Class


NetThumbnailKeyEventArgs Constructor

NetThumbnailKeyEventArgs Class See Also

Create a new instance of the class.

Overload List
Name | Description
NetThumbnailKeyEventArgs(ref KeyEventArgs, NetThumbImage) | Create a new instance of the class.
NetThumbnailKeyEventArgs(ref Keys, NetThumbImage) | Create a new instance of the class.
See Also

Reference

NetThumbnailKeyEventArgs Class
NetThumbnailKeyEventArgs Members


NetThumbnailKeyEventArgs Properties

NetThumbnailKeyEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailKeyEventArgs type.

Properties
 | Name | Description
Public property | Alt | (inherited from KeyEventArgs).
Public property | Control | (inherited from KeyEventArgs).
Public property | Handled | (inherited from KeyEventArgs).
Public property | KeyCode | (inherited from KeyEventArgs).
Public property | KeyData | (inherited from KeyEventArgs).
Public property | KeyValue | (inherited from KeyEventArgs).
Public property | Modifiers | (inherited from KeyEventArgs).
Public property | Shift | (inherited from KeyEventArgs).
Public property | SuppressKeyPress | (inherited from KeyEventArgs).
Public property | ThumbImage | Return True if displayed page is last.
Top
See Also

Reference

NetThumbnailKeyEventArgs Class


NetThumbnailKeyEventArgs.ThumbImage Property

Return True if displayed page is last.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property ThumbImage() As NetThumbImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbImage ThumbImage {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailKeyEventArgs Class
NetThumbnailKeyEventArgs Members


NetThumbnailKeyEventArgs Methods

NetThumbnailKeyEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailKeyEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailKeyEventArgs Class


NetThumbnailMouseEventArgs Class

Members

Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class NetThumbnailMouseEventArgs
    Inherits MouseEventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class NetThumbnailMouseEventArgs : MouseEventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
System.Windows.Forms.MouseEventArgs
Softgroup.NetControls.NetThumbnailMouseEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailMouseEventArgs Members


NetThumbnailMouseEventArgs Members

NetThumbnailMouseEventArgs Class Constructors Methods Properties See Also

Class NetThumbnailMouseEventArgs provide parameters events for Thumbnail control.

The following tables list the members exposed by the NetThumbnailMouseEventArgs type.

Constructors
 | Name | Description
Public constructor | NetThumbnailMouseEventArgs Constructor | (Overloaded) Create a new instance of the class.
Top
Properties
 | Name | Description
Public property | Button | (inherited from MouseEventArgs).
Public property | Clicks | (inherited from MouseEventArgs).
Public property | Delta | (inherited from MouseEventArgs).
Public property | Location | (inherited from MouseEventArgs).
Public property | ThumbImage | Return True if displayed page is last.
Public property | X | (inherited from MouseEventArgs).
Public property | Y | (inherited from MouseEventArgs).
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailMouseEventArgs Class


NetThumbnailMouseEventArgs Constructor

NetThumbnailMouseEventArgs Class See Also

Create a new instance of the class.

Overload List
Name | Description
NetThumbnailMouseEventArgs(ref MouseEventArgs, NetThumbImage) | Create a new instance of the class.
NetThumbnailMouseEventArgs(ref MouseButtons, ref int, ref int, ref int, ref int, NetThumbImage) | Create a new instance of the class.
See Also

Reference

NetThumbnailMouseEventArgs Class
NetThumbnailMouseEventArgs Members


NetThumbnailMouseEventArgs Properties

NetThumbnailMouseEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailMouseEventArgs type.

Properties
 | Name | Description
Public property | Button | (inherited from MouseEventArgs).
Public property | Clicks | (inherited from MouseEventArgs).
Public property | Delta | (inherited from MouseEventArgs).
Public property | Location | (inherited from MouseEventArgs).
Public property | ThumbImage | Return True if displayed page is last.
Public property | X | (inherited from MouseEventArgs).
Public property | Y | (inherited from MouseEventArgs).
Top
See Also

Reference

NetThumbnailMouseEventArgs Class


NetThumbnailMouseEventArgs.ThumbImage Property

Return True if displayed page is last.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property ThumbImage() As NetThumbImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbImage ThumbImage {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailMouseEventArgs Class
NetThumbnailMouseEventArgs Members


NetThumbnailMouseEventArgs Methods

NetThumbnailMouseEventArgs Class See Also

The following tables list the members exposed by the NetThumbnailMouseEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetThumbnailMouseEventArgs Class


NetTrackBar Class

Members

Softgroup NetTrackBar control is a fast, small, lightweight and enhanced version of standard .Net TrackBar that implements unsupported behaviors and features of standard control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(NetTrackBar), "NetTrackBar")> _
<DefaultEvent("ValueChanged")> _
<DefaultProperty("Value")> _
Public Class NetTrackBar
    Inherits ScrollableControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(NetTrackBar), "NetTrackBar")]
[DefaultEvent("ValueChanged")]
[DefaultProperty("Value")]
public class NetTrackBar : ScrollableControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
Softgroup.NetControls.NetTrackBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Members


NetTrackBar Members

NetTrackBar Class Events Methods Properties See Also

Softgroup NetTrackBar control is a fast, small, lightweight and enhanced version of standard .Net TrackBar that implements unsupported behaviors and features of standard control.

The following tables list the members exposed by the NetTrackBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | Gets or sets .
Public property | AutoScrollPosition | Gets or sets .
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | Gets the default color used to paint the background of control.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient background color.
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | GradientAngle | Gets/Sets the angle of the gradient.
Public property | GradientColor | Gets/Sets the gradient background color. If BackColor is Transparent the gradient will be ignored.
Public property | GradientEnabled | Enable/Disable Gradient effect.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | Maximum | Gets/Sets the maximum value for the Value property.
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets the minimum value of Value property.
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets if the control is displayed horizontally or vertically.
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SmallChange | Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TickAppearance | Gets/Sets the appearance of the ticks on the control.
Public property | TickFrequency | Gets or sets a value that specifies the delta between ticks drawn on the control.
Public property | TickStyle | Gets/Sets ticks appearance on the TrackBar.
Public property | ToolTipDisplay | Gets/Sets if tooltip must be dispayed on moving mouse thumb.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets current position of the thumb on the slider.
Public property | VerticalScroll | Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be raised every time Value property has changed.
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetTrackBar Class


NetTrackBar Properties

NetTrackBar Class See Also

The following tables list the members exposed by the NetTrackBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | Gets or sets .
Public property | AutoScrollPosition | Gets or sets .
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | Gets the default color used to paint the background of control.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient background color.
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | GradientAngle | Gets/Sets the angle of the gradient.
Public property | GradientColor | Gets/Sets the gradient background color. If BackColor is Transparent the gradient will be ignored.
Public property | GradientEnabled | Enable/Disable Gradient effect.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | Maximum | Gets/Sets the maximum value for the Value property.
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets the minimum value of Value property.
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets if the control is displayed horizontally or vertically.
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SmallChange | Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TickAppearance | Gets/Sets the appearance of the ticks on the control.
Public property | TickFrequency | Gets or sets a value that specifies the delta between ticks drawn on the control.
Public property | TickStyle | Gets/Sets ticks appearance on the TrackBar.
Public property | ToolTipDisplay | Gets/Sets if tooltip must be dispayed on moving mouse thumb.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets current position of the thumb on the slider.
Public property | VerticalScroll | Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetTrackBar Class


NetTrackBar.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScroll() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool AutoScroll {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollMargin() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Size AutoScrollMargin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollMinSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Size AutoScrollMinSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.AutoScrollOffset Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollOffset() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Point AutoScrollOffset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.AutoScrollPosition Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollPosition() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Point AutoScrollPosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.DefaultBackColor Property

Gets the default color used to paint the background of control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default color used to paint the background of control.")> _
Public ReadOnly Overloads Shared Property DefaultBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default color used to paint the background of control.")]
public static Color DefaultBackColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.DefaultGradientColor Property

Gets the default gradient background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default gradient background color.")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default gradient background color.")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property ForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Color ForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.GradientAngle Property

Gets/Sets the angle of the gradient.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<DefaultValue(180.0F)> _
<Description("Gets/Sets the angle of the gradient.")> _
Public Property GradientAngle( _
   ByRef "Appearance" As Object _
) As Single
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[DefaultValue(180.0F)]
[Description("Gets/Sets the angle of the gradient.")]
[System.Runtime.CompilerServices.IndexerName("GradientAngle")]
public float this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.GradientColor Property

Gets/Sets the gradient background color. If BackColor is Transparent the gradient will be ignored.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")> _
<Description("Gets/Sets the gradient background color. If BackColor is Transparent the gradient will be ignored.")> _
Public Property GradientColor( _
   ByRef "Appearance" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[DefaultValue(GetType(System.Drawing.Color), "ControlLightLight")]
[Description("Gets/Sets the gradient background color. If BackColor is Transparent the gradient will be ignored.")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.GradientEnabled Property

Enable/Disable Gradient effect.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Enable/Disable Gradient effect.")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "Appearance" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Enable/Disable Gradient effect.")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.HorizontalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Shadows Property HorizontalScroll() As HScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public HScrollProperties HorizontalScroll {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.LargeChange Property

Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(5)> _
<Description("Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.")> _
Public Property LargeChange( _
   ByRef "Behavior" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(5)]
[Description("Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.")]
[System.Runtime.CompilerServices.IndexerName("LargeChange")]
public int this[
   ref object "Behavior"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Behavior"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Margin() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Margin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Maximum Property

Gets/Sets the maximum value for the Value property.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(10)> _
<Description("Gets/Sets the maximum value for the Value property.")> _
Public Property Maximum( _
   ByRef "Behavior" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(10)]
[Description("Gets/Sets the maximum value for the Value property.")]
[System.Runtime.CompilerServices.IndexerName("Maximum")]
public int this[
   ref object "Behavior"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Behavior"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Minimum Property

Gets/Sets the minimum value of Value property.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(0)> _
<Description("Gets/Sets the minimum value of Value property.")> _
Public Property Minimum( _
   ByRef "Behavior" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(0)]
[Description("Gets/Sets the minimum value of Value property.")]
[System.Runtime.CompilerServices.IndexerName("Minimum")]
public int this[
   ref object "Behavior"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Behavior"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Orientation Property

Gets/Sets if the control is displayed horizontally or vertically.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<Description("Gets/Sets if the control is displayed horizontally or vertically.")> _
Public Property Orientation( _
   ByRef "Appearance" As Object _
) As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[Description("Gets/Sets if the control is displayed horizontally or vertically.")]
[System.Runtime.CompilerServices.IndexerName("Orientation")]
public Orientation this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.SmallChange Property

Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(1)> _
<Description("Gets/sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.")> _
Public Property SmallChange( _
   ByRef "Behavior" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(1)]
[Description("Gets/sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.")]
[System.Runtime.CompilerServices.IndexerName("SmallChange")]
public int this[
   ref object "Behavior"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Behavior"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.TickAppearance Property

Gets/Sets the appearance of the ticks on the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<DefaultValue(GetType(EdgeStyle), "Etched")> _
<Description("Gets/Sets the appearance of the ticks on the control.")> _
Public Property TickAppearance( _
   ByRef "Appearance" As Object _
) As EdgeStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[DefaultValue(GetType(EdgeStyle), "Etched")]
[Description("Gets/Sets the appearance of the ticks on the control.")]
[System.Runtime.CompilerServices.IndexerName("TickAppearance")]
public EdgeStyle this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.TickFrequency Property

Gets or sets a value that specifies the delta between ticks drawn on the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<DefaultValue(1)> _
<Description("Gets or sets a value that specifies the delta between ticks drawn on the control.")> _
Public Property TickFrequency( _
   ByRef "Appearance" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[DefaultValue(1)]
[Description("Gets or sets a value that specifies the delta between ticks drawn on the control.")]
[System.Runtime.CompilerServices.IndexerName("TickFrequency")]
public int this[
   ref object "Appearance"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Appearance"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.TickStyle Property

Gets/Sets ticks appearance on the TrackBar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Appearance")> _
<DefaultValue(GetType(TickStyle), "BottomRight")> _
<Description("Gets/Sets ticks appearance on the TrackBar")> _
Public Property TickStyle( _
   ByRef GetType As Object, _
   ByRef "BottomRight" As Object _
) As TickStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Appearance")]
[DefaultValue(GetType(TickStyle), "BottomRight")]
[Description("Gets/Sets ticks appearance on the TrackBar")]
[System.Runtime.CompilerServices.IndexerName("TickStyle")]
public TickStyle this[
   ref object GetType,
   ref object "BottomRight"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"BottomRight"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.ToolTipDisplay Property

Gets/Sets if tooltip must be dispayed on moving mouse thumb.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(True)> _
<Description("Gets/Sets if tooltip must be dispayed on moving mouse thumb.")> _
Public Property ToolTipDisplay( _
   ByRef "Behavior" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(True)]
[Description("Gets/Sets if tooltip must be dispayed on moving mouse thumb.")]
[System.Runtime.CompilerServices.IndexerName("ToolTipDisplay")]
public bool this[
   ref object "Behavior"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Behavior"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.Value Property

Gets/Sets current position of the thumb on the slider.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Bindable(True)> _
<Browsable(True)> _
<Category("Behavior")> _
<DefaultValue(0)> _
<Description("Gets/Sets current position of the thumb on the slider.")> _
Public Property Value( _
   ByRef True As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Bindable(True)]
[Browsable(True)]
[Category("Behavior")]
[DefaultValue(0)]
[Description("Gets/Sets current position of the thumb on the slider.")]
[System.Runtime.CompilerServices.IndexerName("Value")]
public int this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar.VerticalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Shadows Property VerticalScroll() As VScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public VScrollProperties VerticalScroll {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetTrackBar Methods

NetTrackBar Class See Also

The following tables list the members exposed by the NetTrackBar type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Top
See Also

Reference

NetTrackBar Class


NetTrackBar Events

NetTrackBar Class See Also

The following tables list the members exposed by the NetTrackBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be raised every time Value property has changed.
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetTrackBar Class


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


ForeColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event ForeColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event ForeColorChangedEventHandler ForeColorChanged
delegate void ForeColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


Scroll Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event Scroll( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event ScrollEventHandler Scroll
delegate void ScrollEventHandler(
   object sender,
   ScrollEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: ScrollEventArgs

An ScrollEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


ValueChanged Event

This event will be raised every time Value property has changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangedEventHandler ValueChanged
delegate void ValueChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTrackBar Class
NetTrackBar Members


NetWizard Class

Members

Softgroup .Net Wizard Control is a fast, small, lightweight and easy to use .NET control to simplify many of the tasks, known as Wizard, that are associated with building a series of forms to collect user input.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxBitmap(GetType(NetWizard), "NetWizard.bmp")> _
<DefaultProperty("SelectedPage")> _
<DefaultEvent("SelectedIndexChanged")> _
<Designer(GetType(NetWizardDesigner))> _
Public Class NetWizard
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxBitmap(GetType(NetWizard), "NetWizard.bmp")]
[DefaultProperty("SelectedPage")]
[DefaultEvent("SelectedIndexChanged")]
[Designer(GetType(NetWizardDesigner))]
public class NetWizard : UserControl
This language is not supported or no code example is available.
Remarks

To add a Softgroup .Net Wizard Control to your form simply add the component to the Toolbox window of Microsoft Visual Studio and drag it to the Form.

Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetControls.NetWizard
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Members


NetWizard Members

NetWizard Class Constructors Events Methods Properties See Also

Softgroup .Net Wizard Control is a fast, small, lightweight and easy to use .NET control to simplify many of the tasks, known as Wizard, that are associated with building a series of forms to collect user input.

The following tables list the members exposed by the NetWizard type.

Constructors
 | Name | Description
Public constructor | NetWizard Constructor | Create a new instance of the Wizard class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | ButtonsBackColor | Gets/Sets the background color of wizard buttons.
Public property | ButtonsFlatBorderColor | Gets the appearance of the border and the colors used to indicate check state and mouse state of wizard buttons.
Public property | ButtonsFlatBorderSize | Gets or sets a value that specifies the size, in pixels, of the border around the wizard buttons.
Public property | ButtonsFlatMouseDownBackColor | Gets or sets the color of the client area of the wizard buttons when the mouse is pressed within the bounds of the control.
Public property | ButtonsFlatMouseOverBackColor | Gets or sets the color of the client area of the wizard button when the mouse pointer is within the bounds of the control.
Public property | ButtonsFlatStyle | Gets/Sets the flat style of wizard buttons.
Public property | ButtonsForeColor | Gets/Sets the foreground color of wizard buttons.
Public property | ButtonsVisualStyles | Gets/Sets if the background of wizard buttons must be drawn using visual styles.
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | CancelButtonText | Gets/Sets the Text of the Cancel Button.
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FinishButtonText | Gets/Sets the Text displayed on the Finish Button when IsEndPage of the currently selected WizardPage is True.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HelpButtonText | Gets/Sets the Text of the Help Button.
Public property | HelpButtonVisible | Gets/Sets is Help button must be visible.
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | NextButtonText | Gets/Sets the Text displayed on the Next Button
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Pages | Gets the collection of Wizard pages
Public property | PagesPanel | Gets the Panel control that hosts the Wizard Page.
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | PreviousButtonText | Gets/Sets the Text displayed on the Previous Button.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | Gets or sets the SelectedIndex.
Public property | SelectedPage | Gets/Sets the currently selected WizardPage.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TitleBackColor | Gets/Sets the background color of wizard title.
Public property | TitleForeColor | Gets/Sets the foreground color of wizard title.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | (inherited from UserControl).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CancelButtonClicked | This event will be generated when the Cancel Button is clicked.
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpButtonClicked | This event will be generated when the Help Button is clicked.
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | NextButtonClicked | This event will be generated when the Next Button is clicked.
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | PreviousButtonClicked | This event will be generated when the Back Button is clicked.
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedIndexChanged | This event will be generated when the SelectedIndex property has changed.
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetWizard Class


NetWizard Constructor

Create a new instance of the Wizard class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetWizard()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard Properties

NetWizard Class See Also

The following tables list the members exposed by the NetWizard type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from ContainerControl).
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | ButtonsBackColor | Gets/Sets the background color of wizard buttons.
Public property | ButtonsFlatBorderColor | Gets the appearance of the border and the colors used to indicate check state and mouse state of wizard buttons.
Public property | ButtonsFlatBorderSize | Gets or sets a value that specifies the size, in pixels, of the border around the wizard buttons.
Public property | ButtonsFlatMouseDownBackColor | Gets or sets the color of the client area of the wizard buttons when the mouse is pressed within the bounds of the control.
Public property | ButtonsFlatMouseOverBackColor | Gets or sets the color of the client area of the wizard button when the mouse pointer is within the bounds of the control.
Public property | ButtonsFlatStyle | Gets/Sets the flat style of wizard buttons.
Public property | ButtonsForeColor | Gets/Sets the foreground color of wizard buttons.
Public property | ButtonsVisualStyles | Gets/Sets if the background of wizard buttons must be drawn using visual styles.
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | CancelButtonText | Gets/Sets the Text of the Cancel Button.
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | FinishButtonText | Gets/Sets the Text displayed on the Finish Button when IsEndPage of the currently selected WizardPage is True.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HelpButtonText | Gets/Sets the Text of the Help Button.
Public property | HelpButtonVisible | Gets/Sets is Help button must be visible.
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | NextButtonText | Gets/Sets the Text displayed on the Next Button
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Pages | Gets the collection of Wizard pages
Public property | PagesPanel | Gets the Panel control that hosts the Wizard Page.
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | PreviousButtonText | Gets/Sets the Text displayed on the Previous Button.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedIndex | Gets or sets the SelectedIndex.
Public property | SelectedPage | Gets/Sets the currently selected WizardPage.
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | TitleBackColor | Gets/Sets the background color of wizard title.
Public property | TitleForeColor | Gets/Sets the foreground color of wizard title.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetWizard Class


NetWizard.AutoScroll Property

NetWizard Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoScrollMargin Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMargin | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoScrollMinSize Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMinSize | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoSize Property

NetWizard Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.UserControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoSizeMode Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoSizeMode | (System.Windows.Forms.UserControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoValidate Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoValidate | (System.Windows.Forms.UserControl).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.BackgroundImage Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.BackgroundImageLayout Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsBackColor Property

Gets/Sets the background color of wizard buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Drawing.Color), "Control")> _
<System.ComponentModel.Description("Gets/Sets the background color of wizard buttons.")> _
Public Property ButtonsBackColor( _
   ByRef GetType As Object, _
   ByRef "Control" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Drawing.Color), "Control")]
[System.ComponentModel.Description("Gets/Sets the background color of wizard buttons.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsBackColor")]
public Color this[
   ref object GetType,
   ref object "Control"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Control"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsFlatBorderColor Property

Gets the appearance of the border and the colors used to indicate check state and mouse state of wizard buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Drawing.Color), "Empty")> _
<System.ComponentModel.Description("Gets the appearance of the border and the colors used to indicate check state and mouse state of wizard buttons.")> _
Public Property ButtonsFlatBorderColor( _
   ByRef GetType As Object, _
   ByRef "Empty" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Drawing.Color), "Empty")]
[System.ComponentModel.Description("Gets the appearance of the border and the colors used to indicate check state and mouse state of wizard buttons.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsFlatBorderColor")]
public Color this[
   ref object GetType,
   ref object "Empty"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Empty"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsFlatBorderSize Property

Gets or sets a value that specifies the size, in pixels, of the border around the wizard buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(0)> _
<System.ComponentModel.Description("Gets or sets a value that specifies the size, in pixels, of the border around the wizard buttons.")> _
Public Property ButtonsFlatBorderSize( _
   ByRef 0 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(0)]
[System.ComponentModel.Description("Gets or sets a value that specifies the size, in pixels, of the border around the wizard buttons.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsFlatBorderSize")]
public int this[
   ref object 0
] {get; set;}
This language is not supported or no code example is available.

Parameters

0

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsFlatMouseDownBackColor Property

Gets or sets the color of the client area of the wizard buttons when the mouse is pressed within the bounds of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Drawing.Color), "Empty")> _
<System.ComponentModel.Description("Gets or sets the color of the client area of the wizard buttons when the mouse is pressed within the bounds of the control.")> _
Public Property ButtonsFlatMouseDownBackColor( _
   ByRef GetType As Object, _
   ByRef "Empty" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Drawing.Color), "Empty")]
[System.ComponentModel.Description("Gets or sets the color of the client area of the wizard buttons when the mouse is pressed within the bounds of the control.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsFlatMouseDownBackColor")]
public Color this[
   ref object GetType,
   ref object "Empty"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Empty"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsFlatMouseOverBackColor Property

Gets or sets the color of the client area of the wizard button when the mouse pointer is within the bounds of the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Drawing.Color), "Empty")> _
<System.ComponentModel.Description("Gets or sets the color of the client area of the wizard button when the mouse pointer is within the bounds of the control.")> _
Public Property ButtonsFlatMouseOverBackColor( _
   ByRef GetType As Object, _
   ByRef "Empty" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Drawing.Color), "Empty")]
[System.ComponentModel.Description("Gets or sets the color of the client area of the wizard button when the mouse pointer is within the bounds of the control.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsFlatMouseOverBackColor")]
public Color this[
   ref object GetType,
   ref object "Empty"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Empty"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsFlatStyle Property

Gets/Sets the flat style of wizard buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Windows.Forms.FlatStyle), "Standard")> _
<System.ComponentModel.Description("Gets/Sets the flat style of wizard buttons.")> _
Public Property ButtonsFlatStyle( _
   ByRef GetType As Object, _
   ByRef "Standard" As Object _
) As FlatStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Windows.Forms.FlatStyle), "Standard")]
[System.ComponentModel.Description("Gets/Sets the flat style of wizard buttons.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsFlatStyle")]
public FlatStyle this[
   ref object GetType,
   ref object "Standard"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Standard"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsForeColor Property

Gets/Sets the foreground color of wizard buttons.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlText")> _
<System.ComponentModel.Description("Gets/Sets the foreground color of wizard buttons.")> _
Public Property ButtonsForeColor( _
   ByRef GetType As Object, _
   ByRef "ControlText" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(GetType(System.Drawing.Color), "ControlText")]
[System.ComponentModel.Description("Gets/Sets the foreground color of wizard buttons.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsForeColor")]
public Color this[
   ref object GetType,
   ref object "ControlText"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"ControlText"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ButtonsVisualStyles Property

Gets/Sets if the background of wizard buttons must be drawn using visual styles.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButtons")> _
<DefaultValue(True)> _
<System.ComponentModel.Description("Gets/Sets if the background of wizard buttons must be drawn using visual styles.")> _
Public Property ButtonsVisualStyles( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButtons")]
[DefaultValue(True)]
[System.ComponentModel.Description("Gets/Sets if the background of wizard buttons must be drawn using visual styles.")]
[System.Runtime.CompilerServices.IndexerName("ButtonsVisualStyles")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.CancelButtonText Property

Gets/Sets the Text of the Cancel Button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButton")> _
<DefaultValue("&Cancel")> _
<System.ComponentModel.Description("Gets/Sets the Text of the Cancel Button.")> _
Public Property CancelButtonText( _
   ByRef "&Cancel" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButton")]
[DefaultValue("&Cancel")]
[System.ComponentModel.Description("Gets/Sets the Text of the Cancel Button.")]
[System.Runtime.CompilerServices.IndexerName("CancelButtonText")]
public string this[
   ref object "&Cancel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"&Cancel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.CausesValidation Property

NetWizard Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.DataBindings Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.FinishButtonText Property

Gets/Sets the Text displayed on the Finish Button when IsEndPage of the currently selected WizardPage is True.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButton")> _
<DefaultValue("&Finish")> _
<System.ComponentModel.Description("Gets/Sets the Text displayed on the Finish Button when IsEndPage of the currently selected $LS$$SL$$LE$WizardPage$EL$ is True.")> _
Public Property FinishButtonText( _
   ByRef "&Finish" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButton")]
[DefaultValue("&Finish")]
[System.ComponentModel.Description("Gets/Sets the Text displayed on the Finish Button when IsEndPage of the currently selected $LS$$SL$$LE$WizardPage$EL$ is True.")]
[System.Runtime.CompilerServices.IndexerName("FinishButtonText")]
public string this[
   ref object "&Finish"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"&Finish"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ForeColor Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.HelpButtonText Property

Gets/Sets the Text of the Help Button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButton")> _
<DefaultValue("&Help")> _
<System.ComponentModel.Description("Gets/Sets the Text of the Help Button.")> _
Public Property HelpButtonText( _
   ByRef "&Help" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButton")]
[DefaultValue("&Help")]
[System.ComponentModel.Description("Gets/Sets the Text of the Help Button.")]
[System.Runtime.CompilerServices.IndexerName("HelpButtonText")]
public string this[
   ref object "&Help"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"&Help"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.HelpButtonVisible Property

Gets/Sets is Help button must be visible.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButton")> _
<DefaultValue(False)> _
<System.ComponentModel.Description("Gets/Sets is Help button must be visible.")> _
Public Property HelpButtonVisible( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButton")]
[DefaultValue(False)]
[System.ComponentModel.Description("Gets/Sets is Help button must be visible.")]
[System.Runtime.CompilerServices.IndexerName("HelpButtonVisible")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.MaximumSize Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MaximumSize | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.MinimumSize Property

NetWizard Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MinimumSize | (System.Windows.Forms.Control).
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.NextButtonText Property

Gets/Sets the Text displayed on the Next Button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue("&Next")> _
<System.ComponentModel.Description("Gets/Sets the Text displayed on the Next Button")> _
Public Property NextButtonText( _
   ByRef "&Next" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue("&Next")]
[System.ComponentModel.Description("Gets/Sets the Text displayed on the Next Button")]
[System.Runtime.CompilerServices.IndexerName("NextButtonText")]
public string this[
   ref object "&Next"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"&Next"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.Pages Property

Gets the collection of Wizard pages

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<Editor(GetType(NetWizardPageCollectionEditor), GetType(UITypeEditor))> _
<System.ComponentModel.Description("Gets the collection of Wizard pages")> _
Public ReadOnly Property Pages( _
   ByRef GetType As Object, _
   ByRef GetType As Object _
) As ControlCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[Editor(GetType(NetWizardPageCollectionEditor), GetType(UITypeEditor))]
[System.ComponentModel.Description("Gets the collection of Wizard pages")]
[System.Runtime.CompilerServices.IndexerName("Pages")]
public ControlCollection this[
   ref object GetType,
   ref object GetType
] {get;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

GetType

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.PagesPanel Property

Gets the Panel control that hosts the Wizard Page.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property PagesPanel( _
   ByRef DesignerSerializationVisibility.Content As Object _
) As Panel
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Content)]
[System.Runtime.CompilerServices.IndexerName("PagesPanel")]
public Panel this[
   ref object DesignerSerializationVisibility.Content
] {get;}
This language is not supported or no code example is available.

Parameters

DesignerSerializationVisibility.Content

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.PreviousButtonText Property

Gets/Sets the Text displayed on the Previous Button.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardButton")> _
<DefaultValue("&Previous")> _
<System.ComponentModel.Description("Gets/Sets the Text displayed on the Previous Button.")> _
Public Property PreviousButtonText( _
   ByRef "&Previous" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardButton")]
[DefaultValue("&Previous")]
[System.ComponentModel.Description("Gets/Sets the Text displayed on the Previous Button.")]
[System.Runtime.CompilerServices.IndexerName("PreviousButtonText")]
public string this[
   ref object "&Previous"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"&Previous"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.SelectedIndex Property

Gets or sets the SelectedIndex.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<Browsable(False)> _
<System.ComponentModel.Description("Gets or sets the SelectedIndex.")> _
Public Property SelectedIndex( _
   ByRef False As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[Browsable(False)]
[System.ComponentModel.Description("Gets or sets the SelectedIndex.")]
[System.Runtime.CompilerServices.IndexerName("SelectedIndex")]
public int this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

The index of the currently selected WizardPage.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.SelectedPage Property

Gets/Sets the currently selected WizardPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<TypeConverter(GetType(NetWizardSelectedPageConverter))> _
<System.ComponentModel.Description("Gets the currently selected WizardPage.")> _
Public Property SelectedPage( _
   ByRef GetType As Object _
) As NetWizardPage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[TypeConverter(GetType(NetWizardSelectedPageConverter))]
[System.ComponentModel.Description("Gets the currently selected WizardPage.")]
[System.Runtime.CompilerServices.IndexerName("SelectedPage")]
public NetWizardPage this[
   ref object GetType
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

Property Value

The WizardPage that is currently selected.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.TitleBackColor Property

Gets/Sets the background color of wizard title.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardTitle")> _
<DefaultValue(GetType(System.Drawing.Color), "White")> _
<System.ComponentModel.Description("Gets/Sets the background color of wizard title.")> _
Public Property TitleBackColor( _
   ByRef GetType As Object, _
   ByRef "White" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardTitle")]
[DefaultValue(GetType(System.Drawing.Color), "White")]
[System.ComponentModel.Description("Gets/Sets the background color of wizard title.")]
[System.Runtime.CompilerServices.IndexerName("TitleBackColor")]
public Color this[
   ref object GetType,
   ref object "White"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"White"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.TitleForeColor Property

Gets/Sets the foreground color of wizard title.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("WizardTitle")> _
<DefaultValue(GetType(System.Drawing.Color), "Black")> _
<System.ComponentModel.Description("Gets/Sets the foreground color of wizard title.")> _
Public Property TitleForeColor( _
   ByRef GetType As Object, _
   ByRef "Black" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("WizardTitle")]
[DefaultValue(GetType(System.Drawing.Color), "Black")]
[System.ComponentModel.Description("Gets/Sets the foreground color of wizard title.")]
[System.Runtime.CompilerServices.IndexerName("TitleForeColor")]
public Color this[
   ref object GetType,
   ref object "Black"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Black"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard Methods

NetWizard Class See Also

The following tables list the members exposed by the NetWizard type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from UserControl).
Top
See Also

Reference

NetWizard Class


NetWizard Events

NetWizard Class See Also

The following tables list the members exposed by the NetWizard type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from UserControl).
Public event | AutoValidateChanged | (inherited from UserControl).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CancelButtonClicked | This event will be generated when the Cancel Button is clicked.
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpButtonClicked | This event will be generated when the Help Button is clicked.
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | NextButtonClicked | This event will be generated when the Next Button is clicked.
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | PreviousButtonClicked | This event will be generated when the Back Button is clicked.
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedIndexChanged | This event will be generated when the SelectedIndex property has changed.
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetWizard Class


CancelButtonClicked Event

This event will be generated when the Cancel Button is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be generated when the Cancel Button is clicked.")> _
Public Event CancelButtonClicked( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be generated when the Cancel Button is clicked.")]
public event CancelButtonClickedEventHandler CancelButtonClicked
delegate void CancelButtonClickedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


HelpButtonClicked Event

This event will be generated when the Help Button is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be generated when the Help Button is clicked.")> _
Public Event HelpButtonClicked( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be generated when the Help Button is clicked.")]
public event HelpButtonClickedEventHandler HelpButtonClicked
delegate void HelpButtonClickedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NextButtonClicked Event

This event will be generated when the Next Button is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be generated when the Next Button is clicked.")> _
Public Event NextButtonClicked( _
   ByVal sender As Object, _
   ByVal e As NetWizardNextButtonClickedEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be generated when the Next Button is clicked.")]
public event NextButtonClickedEventHandler NextButtonClicked
delegate void NextButtonClickedEventHandler(
   object sender,
   NetWizardNextButtonClickedEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: NetWizardNextButtonClickedEventArgs

A WizardNextButtonClickedEventArgs object that contains parameter events.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


PreviousButtonClicked Event

This event will be generated when the Back Button is clicked.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be generated when the Back Button is clicked.")> _
Public Event PreviousButtonClicked( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be generated when the Back Button is clicked.")]
public event PreviousButtonClickedEventHandler PreviousButtonClicked
delegate void PreviousButtonClickedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


SelectedIndexChanged Event

This event will be generated when the SelectedIndex property has changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be generated when the SelectedIndex property has changed.")> _
Public Event SelectedIndexChanged( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be generated when the SelectedIndex property has changed.")]
public event SelectedIndexChangedEventHandler SelectedIndexChanged
delegate void SelectedIndexChangedEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizardNextButtonClickedEventArgs Class

Members

Class NetWizardNextButtonEventArgs provide parameters events for NextButtonClicked event of NetWizard control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class NetWizardNextButtonClickedEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class NetWizardNextButtonClickedEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.NetWizardNextButtonClickedEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardNextButtonClickedEventArgs Members


NetWizardNextButtonClickedEventArgs Members

NetWizardNextButtonClickedEventArgs Class Constructors Methods Properties See Also

Class NetWizardNextButtonEventArgs provide parameters events for NextButtonClicked event of NetWizard control.

The following tables list the members exposed by the NetWizardNextButtonClickedEventArgs type.

Constructors
 | Name | Description
Public constructor | NetWizardNextButtonClickedEventArgs Constructor | Create a new instance of the class.
Top
Properties
 | Name | Description
Public property | IsEndPage | Return True if displayed page is last.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetWizardNextButtonClickedEventArgs Class


NetWizardNextButtonClickedEventArgs Constructor

Create a new instance of the class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal bEndPage As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetWizardNextButtonClickedEventArgs(
   bool bEndPage
)
This language is not supported or no code example is available.

Parameters

bEndPage

Type: bool

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardNextButtonClickedEventArgs Class
NetWizardNextButtonClickedEventArgs Members


NetWizardNextButtonClickedEventArgs Properties

NetWizardNextButtonClickedEventArgs Class See Also

The following tables list the members exposed by the NetWizardNextButtonClickedEventArgs type.

Properties
 | Name | Description
Public property | IsEndPage | Return True if displayed page is last.
Top
See Also

Reference

NetWizardNextButtonClickedEventArgs Class


NetWizardNextButtonClickedEventArgs.IsEndPage Property

Return True if displayed page is last.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property IsEndPage() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool IsEndPage {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardNextButtonClickedEventArgs Class
NetWizardNextButtonClickedEventArgs Members


NetWizardNextButtonClickedEventArgs Methods

NetWizardNextButtonClickedEventArgs Class See Also

The following tables list the members exposed by the NetWizardNextButtonClickedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

NetWizardNextButtonClickedEventArgs Class


NetWizardPage Class

Members

NetWizardPage class represents a single page in a docked into a Wizard control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Designer(GetType(NetWizardPageDesigner))> _
<ToolboxItem(False)> _
<Description("NetWizardPage class represents a single page in a docked into a Wizard control.")> _
Public Class NetWizardPage
    Inherits Panel
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Designer(GetType(NetWizardPageDesigner))]
[ToolboxItem(False)]
[Description("NetWizardPage class represents a single page in a docked into a Wizard control.")]
public class NetWizardPage : Panel
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Softgroup.NetControls.NetWizardPage
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Members


NetWizardPage Members

NetWizardPage Class Constructors Events Methods Properties See Also

NetWizardPage class represents a single page in a docked into a Wizard control.

The following tables list the members exposed by the NetWizardPage type.

Constructors
 | Name | Description
Public constructor | NetWizardPage Constructor | Create a new instance of WizardPage class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (Overloaded) Gets or sets .
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BannerBorderStyle | Gets/Sets the border style of banner on the left side of this page wizard.
Public property | BannerImage | Gets/Sets the image to display on the left side of this page wizard.
Public property | BannerWidth | Gets/Sets the with of image to display on the left side of this page wizard.
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (Overloaded) Gets or sets .
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Icon | Gets/Sets the Icon displayed in the banner of this page
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsEndPage | Gest/Sets whether this WizardPage is the last page.
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | IsStartPage | Gest/Sets whether this WizardPage is the first page (usually a welcome page).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (Overloaded) Gets or sets .
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Panel).
Public property | TitleDescription | Gets/Sets the description displayed in the Title of this page.
Public property | TitleText | Gets/Sets the text of displayed in the Title of this page
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | ToString | (inherited from Panel).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetWizardPage Class


NetWizardPage Constructor

Create a new instance of WizardPage class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Create a new instance of WizardPage class.")> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Create a new instance of WizardPage class.")]
public NetWizardPage()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage Properties

NetWizardPage Class See Also

The following tables list the members exposed by the NetWizardPage type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (Overloaded) Gets or sets .
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoScrollPosition | (inherited from ScrollableControl).
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | Gets or sets .
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (inherited from Control).
Public property | BackgroundImageLayout | (inherited from Control).
Public property | BannerBorderStyle | Gets/Sets the border style of banner on the left side of this page wizard.
Public property | BannerImage | Gets/Sets the image to display on the left side of this page wizard.
Public property | BannerWidth | Gets/Sets the with of image to display on the left side of this page wizard.
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | (inherited from Panel).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (Overloaded) Gets or sets .
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Icon | Gets/Sets the Icon displayed in the banner of this page
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsEndPage | Gest/Sets whether this WizardPage is the last page.
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | IsStartPage | Gest/Sets whether this WizardPage is the first page (usually a welcome page).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (Overloaded) Gets or sets .
Public property | MinimumSize | (Overloaded) Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (Overloaded) Gets or sets .
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Panel).
Public property | TitleDescription | Gets/Sets the description displayed in the Title of this page.
Public property | TitleText | Gets/Sets the text of displayed in the Title of this page
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

NetWizardPage Class


NetWizardPage.Anchor Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Anchor | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScroll Property

NetWizardPage Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScrollMargin Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMargin | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScrollMinSize Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMinSize | (System.Windows.Forms.ScrollableControl).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoSize Property

NetWizardPage Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.Panel).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoSizeMode Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoSizeMode | (System.Windows.Forms.Panel).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.BannerBorderStyle Property

Gets/Sets the border style of banner on the left side of this page wizard.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue(GetType(System.Windows.Forms.BorderStyle), "None")> _
<System.ComponentModel.Description("Gets/Sets the border style of banner on the left side of this page wizard.")> _
Public Property BannerBorderStyle( _
   ByRef GetType As Object, _
   ByRef "None" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue(GetType(System.Windows.Forms.BorderStyle), "None")]
[System.ComponentModel.Description("Gets/Sets the border style of banner on the left side of this page wizard.")]
[System.Runtime.CompilerServices.IndexerName("BannerBorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "None"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"None"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.BannerImage Property

Gets/Sets the image to display on the left side of this page wizard.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue(CStr(Nothing))> _
<System.ComponentModel.Description("Gets/Sets the image to display on the left side of this page wizard.")> _
Public Property BannerImage( _
   ByRef CStr As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue(CStr(Nothing))]
[System.ComponentModel.Description("Gets/Sets the image to display on the left side of this page wizard.")]
[System.Runtime.CompilerServices.IndexerName("BannerImage")]
public Image this[
   ref object CStr
] {get; set;}
This language is not supported or no code example is available.

Parameters

CStr

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.BannerWidth Property

Gets/Sets the with of image to display on the left side of this page wizard.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue(160)> _
<System.ComponentModel.Description("Gets/Sets the with of image to display on the left side of this page wizard.")> _
Public Property BannerWidth( _
   ByRef 160 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue(160)]
[System.ComponentModel.Description("Gets/Sets the with of image to display on the left side of this page wizard.")]
[System.Runtime.CompilerServices.IndexerName("BannerWidth")]
public int this[
   ref object 160
] {get; set;}
This language is not supported or no code example is available.

Parameters

160

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.CausesValidation Property

NetWizardPage Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.DataBindings Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.Dock Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Dock | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.ForeColor Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.Icon Property

Gets/Sets the Icon displayed in the banner of this page

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<System.ComponentModel.Description("Gets/Sets the Icon displayed in the banner of this page")> _
Public Property Icon( _
   ByRef "Gets/Sets the Icon displayed in the banner of this page" As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[System.ComponentModel.Description("Gets/Sets the Icon displayed in the banner of this page")]
[System.Runtime.CompilerServices.IndexerName("Icon")]
public Image this[
   ref object "Gets/Sets the Icon displayed in the banner of this page"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the Icon displayed in the banner of this page"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.IsEndPage Property

Gest/Sets whether this WizardPage is the last page.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue(False)> _
<System.ComponentModel.Description("Gest/Sets whether this WizardPage is the last page.")> _
Public Property IsEndPage( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue(False)]
[System.ComponentModel.Description("Gest/Sets whether this WizardPage is the last page.")]
[System.Runtime.CompilerServices.IndexerName("IsEndPage")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Remarks

When True, the Wizard control will display the Finish text on the Next Button.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.IsStartPage Property

Gest/Sets whether this WizardPage is the first page (usually a welcome page).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue(False)> _
<System.ComponentModel.Description("Gest/Sets whether this WizardPage is the first page (usually a welcome page).")> _
Public Property IsStartPage( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue(False)]
[System.ComponentModel.Description("Gest/Sets whether this WizardPage is the first page (usually a welcome page).")]
[System.Runtime.CompilerServices.IndexerName("IsStartPage")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Remarks

When True, the Wizard control will not display the Title/Description header.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.MaximumSize Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MaximumSize | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.MinimumSize Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
MinimumSize | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TabIndex Property

NetWizardPage Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
TabIndex | (System.Windows.Forms.Control).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TabStop Property

NetWizardPage Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
TabStop | (System.Windows.Forms.Panel).
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TitleDescription Property

Gets/Sets the description displayed in the Title of this page.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<DefaultValue("Description")> _
<System.ComponentModel.Description("Gets/Sets the description displayed in the Title of this page.")> _
Public Property TitleDescription( _
   ByRef "Description" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[DefaultValue("Description")]
[System.ComponentModel.Description("Gets/Sets the description displayed in the Title of this page.")]
[System.Runtime.CompilerServices.IndexerName("TitleDescription")]
public string this[
   ref object "Description"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Description"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TitleText Property

Gets/Sets the text of displayed in the Title of this page

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Wizard")> _
<System.ComponentModel.Description("Gets/Sets the text of displayed in the Title of this page")> _
Public Property TitleText( _
   ByRef "Gets/Sets the text of displayed in the Title of this page" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Wizard")]
[System.ComponentModel.Description("Gets/Sets the text of displayed in the Title of this page")]
[System.Runtime.CompilerServices.IndexerName("TitleText")]
public string this[
   ref object "Gets/Sets the text of displayed in the Title of this page"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the text of displayed in the Title of this page"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage Methods

NetWizardPage Class See Also

The following tables list the members exposed by the NetWizardPage type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | GetPreferredSize | (inherited from Control).
Public method | ResetBindings | (inherited from Control).
Public method | ScrollControlIntoView | (inherited from ScrollableControl).
Public method | SetAutoScrollMargin | (Overloaded) (inherited from ScrollableControl).
Public method | ToString | (inherited from Panel).
Top
See Also

Reference

NetWizardPage Class


NetWizardPage Events

NetWizardPage Class See Also

The following tables list the members exposed by the NetWizardPage type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Panel).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | (inherited from Control).
Public event | BackgroundImageLayoutChanged | (inherited from Control).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Panel).
Public event | KeyPress | (inherited from Panel).
Public event | KeyUp | (inherited from Panel).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Panel).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

NetWizardPage Class


OutlookBar Class

Members

Softgorup .Net OutlookBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook Navigation Bar (2003 versione and above) user interface

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class OutlookBar
    Inherits OutlookBarControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class OutlookBar : OutlookBarControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
Softgroup.NetControls.OutlookBarControl
Softgroup.NetControls.OutlookBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Members


OutlookBar Members

OutlookBar Class Constructors Events Methods Properties See Also

Softgorup .Net OutlookBar Control is a small, fast and lightweight component for Microsoft Visual Studio .Net that provide an enhanced Microsoft Outlook Navigation Bar (2003 versione and above) user interface

The following tables list the members exposed by the OutlookBar type.

Constructors
 | Name | Description
Public constructor | OutlookBar Constructor | (Overloaded) Create a new instance of the OutlookBar class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether . (inherited from OutlookBarControl).
Public property | AutoScrollMargin | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollMinSize | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollOffset | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollPosition | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImage | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImageLayout | Gets or sets . (inherited from OutlookBarControl).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CollapseVisible | Gets/Sets if a collapse button must be visible on heeader
Public property | Collapsed | Gets/Sets whether the control is collapled or not
Public property | CollapsedFont | Gets/Sets the font used to drawn control text when collapsed
Public property | CollapsedForeColor | Gets/Sets the foreground color used to drawn control text when collapsed
Public property | CollapsedWidth | Gets/Sets width of OutlookBar when collapsed
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Groups | Gets the collection of groups
Public property | GroupsHeight | Gets/Sets the groups button height
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | HeaderFont | Gets/Sets the font used to drawn header area (selected group) of control
Public property | HeaderHeight | Gets/Sets the height of the header title
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
 | Localize | Gets/Sets the localized text used in Options Dialog of OutlookBar
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets . (inherited from OutlookBarControl).
Public property | MinimumSize | Gets or sets . (inherited from OutlookBarControl).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OptionsHeight | Gets/Sets the height of options bar
Public property | Padding | Gets or sets . (inherited from OutlookBarControl).
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PopupGroupHeight | Gets/Sets if group popup when shown must have same height of control
Public property | PopupGroupResize | Gets/Sets if group popup when shown can be resized by user
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | RenderBackgroundGradient | Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not
Public property | RenderBackgroundGroupsGradient | Gets/Sets whether the renderer draw background of groups buttons using gradient effects of not
Public property | Renderer | Gets/Sets the current OutlookBarRenderer object used for control painting
Public property | RendererMode | Gets/Sets the current predefinied rendering color schema used to draw control
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedGroup | Gets/Sets the current selected group
Public property | ShowHideGroupsMenu | Gets/Sets if Show/Hide Groups menu must be visible on options bar
Public property | ShowLessGroupsMenu | Gets/Sets if Show Less Groups menu must be visible on options bar
Public property | ShowMoreGroupsMenu | Gets/Sets if Show More Groups menu must be visible on options bar
Public property | ShowOptionsMenu | Gets/Sets if menu options button must be visible on options bar
Public property | ShowTooltips | Gets/Sets if tooltips must be shown for groups button
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SplitterHeight | Gets/Sets the splitter height
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | VisibleButtons | Gets/Sets the number of visible group buttons
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInit |
Public method | EndInit |
Public method | MouseInSplitter | Returns True if the given coordinate are inside the bounds of the splitter rectangle
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | PopupGroupClose | Close the popup group
Public method | PopupGroupIsVisible | Gets if popup group is currently visible
Public method | Refresh |
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageLayoutChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupAdded | Occurs after a new group has been added to the collection of groups
Public event | GroupRemoved | Occurs after a group has been removed from the collection of groups
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when . (inherited from OutlookBarControl).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | RendererChanged | Occurs after the renderer object is changed has been changed
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedGroupChanged | Occurs after the active group has been changed
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBar Class


OutlookBar Constructor

OutlookBar Class See Also

Create a new instance of the OutlookBar class

Overload List
Name | Description
OutlookBar() | Create a new instance of the OutlookBar class
OutlookBar(IContainer) | Create a new instance of the OutlookBar class with specified container
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar Properties

OutlookBar Class See Also

The following tables list the members exposed by the OutlookBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether . (inherited from OutlookBarControl).
Public property | AutoScrollMargin | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollMinSize | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollOffset | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollPosition | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImage | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImageLayout | Gets or sets . (inherited from OutlookBarControl).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CollapseVisible | Gets/Sets if a collapse button must be visible on heeader
Public property | Collapsed | Gets/Sets whether the control is collapled or not
Public property | CollapsedFont | Gets/Sets the font used to drawn control text when collapsed
Public property | CollapsedForeColor | Gets/Sets the foreground color used to drawn control text when collapsed
Public property | CollapsedWidth | Gets/Sets width of OutlookBar when collapsed
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Groups | Gets the collection of groups
Public property | GroupsHeight | Gets/Sets the groups button height
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | HeaderFont | Gets/Sets the font used to drawn header area (selected group) of control
Public property | HeaderHeight | Gets/Sets the height of the header title
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
 | Localize | Gets/Sets the localized text used in Options Dialog of OutlookBar
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets . (inherited from OutlookBarControl).
Public property | MinimumSize | Gets or sets . (inherited from OutlookBarControl).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OptionsHeight | Gets/Sets the height of options bar
Public property | Padding | Gets or sets . (inherited from OutlookBarControl).
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PopupGroupHeight | Gets/Sets if group popup when shown must have same height of control
Public property | PopupGroupResize | Gets/Sets if group popup when shown can be resized by user
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | RenderBackgroundGradient | Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not
Public property | RenderBackgroundGroupsGradient | Gets/Sets whether the renderer draw background of groups buttons using gradient effects of not
Public property | Renderer | Gets/Sets the current OutlookBarRenderer object used for control painting
Public property | RendererMode | Gets/Sets the current predefinied rendering color schema used to draw control
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | SelectedGroup | Gets/Sets the current selected group
Public property | ShowHideGroupsMenu | Gets/Sets if Show/Hide Groups menu must be visible on options bar
Public property | ShowLessGroupsMenu | Gets/Sets if Show Less Groups menu must be visible on options bar
Public property | ShowMoreGroupsMenu | Gets/Sets if Show More Groups menu must be visible on options bar
Public property | ShowOptionsMenu | Gets/Sets if menu options button must be visible on options bar
Public property | ShowTooltips | Gets/Sets if tooltips must be shown for groups button
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SplitterHeight | Gets/Sets the splitter height
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | VisibleButtons | Gets/Sets the number of visible group buttons
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

OutlookBar Class


OutlookBarControl.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScroll() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool AutoScroll {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollMargin() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Size AutoScrollMargin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollMinSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Size AutoScrollMinSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.AutoScrollOffset Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollOffset() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Point AutoScrollOffset {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.AutoScrollPosition Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AutoScrollPosition() As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Point AutoScrollPosition {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.BackColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBar.CollapseVisible Property

Gets/Sets if a collapse button must be visible on heeader

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if collapse button must be visible on header")> _
<DefaultValue(True)> _
<NotifyParentProperty(True)> _
Public Property CollapseVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if collapse button must be visible on header")]
[DefaultValue(True)]
[NotifyParentProperty(True)]
public bool CollapseVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Collapsed Property

Gets/Sets whether the control is collapled or not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets whether the control is collapled or not")> _
<DefaultValue(False)> _
<NotifyParentProperty(True)> _
Public Property Collapsed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets whether the control is collapled or not")]
[DefaultValue(False)]
[NotifyParentProperty(True)]
public bool Collapsed {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.CollapsedFont Property

Gets/Sets the font used to drawn control text when collapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the font used to drawn control text when collapsed")> _
Public Property CollapsedFont() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the font used to drawn control text when collapsed")]
public Font CollapsedFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.CollapsedForeColor Property

Gets/Sets the foreground color used to drawn control text when collapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the foregrund color used to drawn control text when collapsed")> _
<DefaultValue(GetType(Color), "ControlText")> _
Public Property CollapsedForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the foregrund color used to drawn control text when collapsed")]
[DefaultValue(GetType(Color), "ControlText")]
public Color CollapsedForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.CollapsedWidth Property

Gets/Sets width of OutlookBar when collapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets width of OutlookBar when collapsed")> _
<DefaultValue(MinCollapsedWitdh)> _
Public Property CollapsedWidth() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets width of OutlookBar when collapsed")]
[DefaultValue(MinCollapsedWitdh)]
public int CollapsedWidth {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Groups Property

Gets the collection of groups

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets the collection of groups")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Groups() As OutlookBarGroups
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets the collection of groups")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public OutlookBarGroups Groups {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.GroupsHeight Property

Gets/Sets the groups button height

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the group buttons height")> _
<DefaultValue(MinButtonsHeight)> _
<NotifyParentProperty(True)> _
Public Property GroupsHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the group buttons height")]
[DefaultValue(MinButtonsHeight)]
[NotifyParentProperty(True)]
public int GroupsHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.HeaderFont Property

Gets/Sets the font used to drawn header area (selected group) of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the font used to drawn header area (selected group) of control")> _
Public Property HeaderFont() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the font used to drawn header area (selected group) of control")]
public Font HeaderFont {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.HeaderHeight Property

Gets/Sets the height of the header title

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the height of the header title")> _
<DefaultValue(MinButtonsHeight)> _
<NotifyParentProperty(True)> _
Public Property HeaderHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the height of the header title")]
[DefaultValue(MinButtonsHeight)]
[NotifyParentProperty(True)]
public int HeaderHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Localize Property

Gets/Sets the localized text used in Options Dialog of OutlookBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the localized text used in Options Dialog of OutlookBar")> _
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shared Property Localize( _
   ByVal eLocalize As LocalizeTextEnum _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the localized text used in Options Dialog of OutlookBar")]
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[System.Runtime.CompilerServices.IndexerName("Localize")]
public static string this[
   LocalizeTextEnum eLocalize
] {get; set;}
This language is not supported or no code example is available.

Parameters

eLocalize

Type: LocalizeTextEnum

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBarControl.MaximumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property MaximumSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public override Size MaximumSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl.MinimumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property MinimumSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Size MinimumSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBar.OptionsHeight Property

Gets/Sets the height of options bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the height of options bar")> _
<DefaultValue(MinButtonsHeight)> _
<NotifyParentProperty(True)> _
Public Property OptionsHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the height of options bar")]
[DefaultValue(MinButtonsHeight)]
[NotifyParentProperty(True)]
public int OptionsHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBarControl.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBar.PopupGroupHeight Property

Gets/Sets if group popup when shown must have same height of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if group popup when shown must have same height of control")> _
<DefaultValue(True)> _
Public Property PopupGroupHeight() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if group popup when shown must have same height of control")]
[DefaultValue(True)]
public bool PopupGroupHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.PopupGroupResize Property

Gets/Sets if group popup when shown can be resized by user

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if group popup when shown can be resized by user")> _
<DefaultValue(True)> _
Public Property PopupGroupResize() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if group popup when shown can be resized by user")]
[DefaultValue(True)]
public bool PopupGroupResize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.RenderBackgroundGradient Property

Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not")> _
<DefaultValue(True)> _
Public Property RenderBackgroundGradient() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not")]
[DefaultValue(True)]
public bool RenderBackgroundGradient {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.RenderBackgroundGroupsGradient Property

Gets/Sets whether the renderer draw background of groups buttons using gradient effects of not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets whether the renderer draw background of groups buttons using gradient effects of not")> _
<DefaultValue(True)> _
Public Property RenderBackgroundGroupsGradient() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets whether the renderer draw background of groups buttons using gradient effects of not")]
[DefaultValue(True)]
public bool RenderBackgroundGroupsGradient {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Renderer Property

Gets/Sets the current OutlookBarRenderer object used for control painting

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the current OutlookBarRenderer object used for control painting")> _
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<RefreshProperties(RefreshProperties.All)> _
Public Property Renderer() As OutlookBarRenderer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the current OutlookBarRenderer object used for control painting")]
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[RefreshProperties(RefreshProperties.All)]
public OutlookBarRenderer Renderer {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.RendererMode Property

Gets/Sets the current predefinied rendering color schema used to draw control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the current predefinied rendering color schema used to draw control")> _
<DefaultValue(GetType(RendererModeEnum), "System")> _
Public Property RendererMode() As RendererModeEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the current predefinied rendering color schema used to draw control")]
[DefaultValue(GetType(RendererModeEnum), "System")]
public RendererModeEnum RendererMode {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.SelectedGroup Property

Gets/Sets the current selected group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the current selected group")> _
<DefaultValue(CStr(Nothing))> _
Public Property SelectedGroup() As OutlookBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the current selected group")]
[DefaultValue(CStr(Nothing))]
public OutlookBarGroup SelectedGroup {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.ShowHideGroupsMenu Property

Gets/Sets if Show/Hide Groups menu must be visible on options bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if Show/Hide Groups menu must be visible on options bar")> _
<DefaultValue(True)> _
Public Property ShowHideGroupsMenu() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if Show/Hide Groups menu must be visible on options bar")]
[DefaultValue(True)]
public bool ShowHideGroupsMenu {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.ShowLessGroupsMenu Property

Gets/Sets if Show Less Groups menu must be visible on options bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if Show Less Groups menu must be visible on options bar")> _
<DefaultValue(True)> _
Public Property ShowLessGroupsMenu() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if Show Less Groups menu must be visible on options bar")]
[DefaultValue(True)]
public bool ShowLessGroupsMenu {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.ShowMoreGroupsMenu Property

Gets/Sets if Show More Groups menu must be visible on options bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if Show More Groups menu must be visible on options bar")> _
<DefaultValue(True)> _
Public Property ShowMoreGroupsMenu() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if Show More Groups menu must be visible on options bar")]
[DefaultValue(True)]
public bool ShowMoreGroupsMenu {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.ShowOptionsMenu Property

Gets/Sets if menu options button must be visible on options bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if menu options button must be visible on options bar")> _
<DefaultValue(True)> _
<NotifyParentProperty(True)> _
Public Property ShowOptionsMenu() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if menu options button must be visible on options bar")]
[DefaultValue(True)]
[NotifyParentProperty(True)]
public bool ShowOptionsMenu {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.ShowTooltips Property

Gets/Sets if tooltips must be shown for groups button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets if tooltips must be shown for groups button")> _
<DefaultValue(True)> _
Public Property ShowTooltips() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets if tooltips must be shown for groups button")]
[DefaultValue(True)]
public bool ShowTooltips {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.SplitterHeight Property

Gets/Sets the splitter height

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the splitter height")> _
<DefaultValue(MinSplitterHeight)> _
<NotifyParentProperty(True)> _
Public Property SplitterHeight() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the splitter height")]
[DefaultValue(MinSplitterHeight)]
[NotifyParentProperty(True)]
public int SplitterHeight {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.VisibleButtons Property

Gets/Sets the number of visible group buttons

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBar")> _
<Description("Gets/Sets the number of visible group buttons")> _
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Property VisibleButtons() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBar")]
[Description("Gets/Sets the number of visible group buttons")]
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public int VisibleButtons {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar Methods

OutlookBar Class See Also

The following tables list the members exposed by the OutlookBar type.

Methods
 | Name | Description
Public method | BeginInit |
Public method | EndInit |
Public method | MouseInSplitter | Returns True if the given coordinate are inside the bounds of the splitter rectangle
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | PopupGroupClose | Close the popup group
Public method | PopupGroupIsVisible | Gets if popup group is currently visible
Public method | Refresh |
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
See Also

Reference

OutlookBar Class


OutlookBar.BeginInit Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
public System.Void BeginInit()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.EndInit Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
public System.Void EndInit()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.MouseInSplitter Method

Returns True if the given coordinate are inside the bounds of the splitter rectangle

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function MouseInSplitter( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool MouseInSplitter(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

The x coordinate

y

Type: int

The y coordinate

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.PopupGroupClose Method

Close the popup group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub PopupGroupClose()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void PopupGroupClose()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.PopupGroupIsVisible Method

Gets if popup group is currently visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function PopupGroupIsVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool PopupGroupIsVisible()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar.Refresh Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Sub Refresh()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override System.Void Refresh()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBar Events

OutlookBar Class See Also

The following tables list the members exposed by the OutlookBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageLayoutChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | GroupAdded | Occurs after a new group has been added to the collection of groups
Public event | GroupRemoved | Occurs after a group has been removed from the collection of groups
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when . (inherited from OutlookBarControl).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | RendererChanged | Occurs after the renderer object is changed has been changed
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SelectedGroupChanged | Occurs after the active group has been changed
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBar Class


BackColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event BackColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event BackColorChangedEventHandler BackColorChanged
delegate void BackColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


GroupAdded Event

Occurs after a new group has been added to the collection of groups

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event GroupAdded( _
   ByVal sender As Object, _
   ByVal e As OutlookBarCollectionEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event GroupAddedEventHandler GroupAdded
delegate void GroupAddedEventHandler(
   object sender,
   OutlookBarCollectionEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: OutlookBarCollectionEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


GroupRemoved Event

Occurs after a group has been removed from the collection of groups

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event GroupRemoved( _
   ByVal sender As Object, _
   ByVal e As OutlookBarCollectionEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event GroupRemovedEventHandler GroupRemoved
delegate void GroupRemovedEventHandler(
   object sender,
   OutlookBarCollectionEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: OutlookBarCollectionEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


RendererChanged Event

Occurs after the renderer object is changed has been changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event RendererChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event RendererChangedEventHandler RendererChanged
delegate void RendererChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


SelectedGroupChanged Event

Occurs after the active group has been changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event SelectedGroupChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event SelectedGroupChangedEventHandler SelectedGroupChanged
delegate void SelectedGroupChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


OutlookBarCollectionBase Class

Members

Base collection class for the OutlookBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public MustInherit Class OutlookBarCollectionBase
    Inherits CollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public abstract class OutlookBarCollectionBase : CollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.OutlookBarCollectionBase
Softgroup.NetControls.OutlookBarGroups
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionBase Members


OutlookBarCollectionBase Members

OutlookBarCollectionBase Class Events Methods Properties See Also

Base collection class for the OutlookBar control

The following tables list the members exposed by the OutlookBarCollectionBase type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Top
Methods
 | Name | Description
Public method | Clear | Consente di rimuovere tutti gli oggetti dall'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | RemoveAt | Consente di rimuovere la voce in corrispondenza dell'indice specificato dell'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Sort | Sorts the elements in the entire collection using the specified comparer.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs when an item has been added to the collection
Public event | ItemRemoved | Occurs when an item has been removed from the collection
Top
See Also

Reference

OutlookBarCollectionBase Class


OutlookBarCollectionBase Properties

OutlookBarCollectionBase Class See Also

The following tables list the members exposed by the OutlookBarCollectionBase type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Top
See Also

Reference

OutlookBarCollectionBase Class


OutlookBarCollectionBase Methods

OutlookBarCollectionBase Class See Also

The following tables list the members exposed by the OutlookBarCollectionBase type.

Methods
 | Name | Description
Public method | Clear | Consente di rimuovere tutti gli oggetti dall'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | RemoveAt | Consente di rimuovere la voce in corrispondenza dell'indice specificato dell'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Sort | Sorts the elements in the entire collection using the specified comparer.
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

OutlookBarCollectionBase Class


OutlookBarCollectionBase.Sort Method

Sorts the elements in the entire collection using the specified comparer.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub Sort( _
   ByVal comparer As IComparer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void Sort(
   IComparer comparer
)
This language is not supported or no code example is available.

Parameters

comparer

Type: IComparer

The IComparer implementation to use when comparing elements.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionBase Class
OutlookBarCollectionBase Members


OutlookBarCollectionBase Events

OutlookBarCollectionBase Class See Also

The following tables list the members exposed by the OutlookBarCollectionBase type.

Events
 | Name | Description
Public event | ItemAdded | Occurs when an item has been added to the collection
Public event | ItemRemoved | Occurs when an item has been removed from the collection
Top
See Also

Reference

OutlookBarCollectionBase Class


ItemAdded Event

Occurs when an item has been added to the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ItemAdded( _
   ByVal sender As Object, _
   ByVal e As OutlookBarCollectionEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ItemAddedEventHandler ItemAdded
delegate void ItemAddedEventHandler(
   object sender,
   OutlookBarCollectionEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: OutlookBarCollectionEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionBase Class
OutlookBarCollectionBase Members


ItemRemoved Event

Occurs when an item has been removed from the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ItemRemoved( _
   ByVal sender As Object, _
   ByVal e As OutlookBarCollectionEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ItemRemovedEventHandler ItemRemoved
delegate void ItemRemovedEventHandler(
   object sender,
   OutlookBarCollectionEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: OutlookBarCollectionEventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionBase Class
OutlookBarCollectionBase Members


OutlookBarCollectionEventArgs Class

Members

This class holds information for OutlookBarCollection events

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class OutlookBarCollectionEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class OutlookBarCollectionEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.OutlookBarCollectionEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionEventArgs Members


OutlookBarCollectionEventArgs Members

OutlookBarCollectionEventArgs Class Methods Properties See Also

This class holds information for OutlookBarCollection events

The following tables list the members exposed by the OutlookBarCollectionEventArgs type.

Properties
 | Name | Description
Public property | Item | Gets the item related collection
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

OutlookBarCollectionEventArgs Class


OutlookBarCollectionEventArgs Properties

OutlookBarCollectionEventArgs Class See Also

The following tables list the members exposed by the OutlookBarCollectionEventArgs type.

Properties
 | Name | Description
Public property | Item | Gets the item related collection
Top
See Also

Reference

OutlookBarCollectionEventArgs Class


OutlookBarCollectionEventArgs.Item Property

Gets the item related collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property Item() As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public object Item {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarCollectionEventArgs Class
OutlookBarCollectionEventArgs Members


OutlookBarCollectionEventArgs Methods

OutlookBarCollectionEventArgs Class See Also

The following tables list the members exposed by the OutlookBarCollectionEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

OutlookBarCollectionEventArgs Class


OutlookBarControl Class

Members

Represents base control class used internally by OutlookBar controls

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(False)> _
Public MustInherit Class OutlookBarControl
    Inherits ContainerControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(False)]
public abstract class OutlookBarControl : ContainerControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
Softgroup.NetControls.OutlookBarControl
Softgroup.NetControls.OutlookBar
Softgroup.NetControls.OutlookBarGroup
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Members


OutlookBarControl Members

OutlookBarControl Class Constructors Events Methods Properties See Also

Represents base control class used internally by OutlookBar controls

The following tables list the members exposed by the OutlookBarControl type.

Constructors
 | Name | Description
Public constructor | OutlookBarControl Constructor | Initializes a new instance of the OutlookBarControl
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | Gets or sets .
Public property | AutoScrollPosition | Gets or sets .
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets .
Public property | MinimumSize | Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBarControl Class


OutlookBarControl Constructor

Initializes a new instance of the OutlookBarControl

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBarControl()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarControl Class
OutlookBarControl Members


OutlookBarControl Properties

OutlookBarControl Class See Also

The following tables list the members exposed by the OutlookBarControl type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether .
Public property | AutoScrollMargin | Gets or sets .
Public property | AutoScrollMinSize | Gets or sets .
Public property | AutoScrollOffset | Gets or sets .
Public property | AutoScrollPosition | Gets or sets .
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets .
Public property | MinimumSize | Gets or sets .
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

OutlookBarControl Class


OutlookBarControl Methods

OutlookBarControl Class See Also

The following tables list the members exposed by the OutlookBarControl type.

Methods
 | Name | Description
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
See Also

Reference

OutlookBarControl Class


OutlookBarControl Events

OutlookBarControl Class See Also

The following tables list the members exposed by the OutlookBarControl type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBarControl Class


OutlookBarGroup Class

Members

This class represents a group which is a part of the OutlookBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(False)> _
Public Class OutlookBarGroup
    Inherits OutlookBarControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(False)]
public class OutlookBarGroup : OutlookBarControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
Softgroup.NetControls.OutlookBarControl
Softgroup.NetControls.OutlookBarGroup
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Members


OutlookBarGroup Members

OutlookBarGroup Class Constructors Events Methods Properties See Also

This class represents a group which is a part of the OutlookBar control

The following tables list the members exposed by the OutlookBarGroup type.

Constructors
 | Name | Description
Public constructor | OutlookBarGroup Constructor | (Overloaded) Initializes a new instance of the OutlookBarGroup
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether . (inherited from OutlookBarControl).
Public property | AutoScrollMargin | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollMinSize | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollOffset | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollPosition | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImage | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImageLayout | Gets or sets . (inherited from OutlookBarControl).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | Collapsed | Return True if control is currently collapsed
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | Gets or sets .
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Image | Gets/Sets the image displayed in the group is minimized
Public property | ImageVisible | Gets/Sets if the header image must be visible
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets . (inherited from OutlookBarControl).
Public property | MinimumSize | Gets or sets . (inherited from OutlookBarControl).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OutlookBar | Gets/Sets the owner OutlookBar control
Public property | Padding | Gets or sets . (inherited from OutlookBarControl).
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ControlAdd | Add specified control to the group
Public method | ControlContains | Return True if specified control is already added to the group
Public method | ControlRemove | Remove specified control from the group
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Refresh | Force a full repaint of group
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageLayoutChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when . (inherited from OutlookBarControl).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBarGroup Class


OutlookBarGroup Constructor

OutlookBarGroup Class See Also

Initializes a new instance of the OutlookBarGroup

Overload List
Name | Description
OutlookBarGroup() | Initializes a new instance of the OutlookBarGroup
OutlookBarGroup(IContainer) | Initializes a new instance of the OutlookBarGroup
OutlookBarGroup(string) | Initializes a new instance of the OutlookBarGroup with specified text
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup Properties

OutlookBarGroup Class See Also

The following tables list the members exposed by the OutlookBarGroup type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | Gets or sets a value indicating whether . (inherited from OutlookBarControl).
Public property | AutoScrollMargin | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollMinSize | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollOffset | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoScrollPosition | Gets or sets . (inherited from OutlookBarControl).
Public property | AutoSize | (inherited from Control).
Public property | AutoValidate | (inherited from ContainerControl).
Public property | BackColor | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImage | Gets or sets . (inherited from OutlookBarControl).
Public property | BackgroundImageLayout | Gets or sets . (inherited from OutlookBarControl).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | Collapsed | Return True if control is currently collapsed
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | Gets or sets .
Public property | DockPadding | (inherited from ScrollableControl).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (inherited from ScrollableControl).
Public property | Image | Gets/Sets the image displayed in the group is minimized
Public property | ImageVisible | Gets/Sets if the header image must be visible
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | Gets or sets . (inherited from OutlookBarControl).
Public property | MinimumSize | Gets or sets . (inherited from OutlookBarControl).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | OutlookBar | Gets/Sets the owner OutlookBar control
Public property | Padding | Gets or sets . (inherited from OutlookBarControl).
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from Control).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (inherited from ScrollableControl).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

OutlookBarGroup Class


OutlookBarGroup.Collapsed Property

Return True if control is currently collapsed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBarGroup")> _
<Description("Return True if control is currently collapsed")> _
<Browsable(False)> _
Public ReadOnly Property Collapsed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBarGroup")]
[Description("Return True if control is currently collapsed")]
[Browsable(False)]
public bool Collapsed {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.Dock Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Dock() As DockStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public DockStyle Dock {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.Image Property

Gets/Sets the image displayed in the group is minimized

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBarGroup")> _
<Description("Gets/Sets the image displayed in the group is minimized")> _
<DefaultValue(CStr(Nothing))> _
Public Property Image() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBarGroup")]
[Description("Gets/Sets the image displayed in the group is minimized")]
[DefaultValue(CStr(Nothing))]
public Image Image {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.ImageVisible Property

Gets/Sets if the header image must be visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBarGroup")> _
<Description("Gets/Sets if the header image must be visible")> _
<DefaultValue(True)> _
Public Property ImageVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBarGroup")]
[Description("Gets/Sets if the header image must be visible")]
[DefaultValue(True)]
public bool ImageVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.OutlookBar Property

Gets/Sets the owner OutlookBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("OutlookBarGroup")> _
<Description("Gets/Sets the owner OutlookBar control")> _
<Browsable(False)> _
Public ReadOnly Property OutlookBar() As OutlookBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("OutlookBarGroup")]
[Description("Gets/Sets the owner OutlookBar control")]
[Browsable(False)]
public OutlookBar OutlookBar {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup Methods

OutlookBarGroup Class See Also

The following tables list the members exposed by the OutlookBarGroup type.

Methods
 | Name | Description
Public method | ControlAdd | Add specified control to the group
Public method | ControlContains | Return True if specified control is already added to the group
Public method | ControlRemove | Remove specified control from the group
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Refresh | Force a full repaint of group
Public method | Validate | (Overloaded) (inherited from ContainerControl).
Top
See Also

Reference

OutlookBarGroup Class


OutlookBarGroup.ControlAdd Method

Add specified control to the group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ControlAdd( _
   ByVal oControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ControlAdd(
   Control oControl
)
This language is not supported or no code example is available.

Parameters

oControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.ControlContains Method

Return True if specified control is already added to the group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function ControlContains( _
   ByVal oControl As Control _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool ControlContains(
   Control oControl
)
This language is not supported or no code example is available.

Parameters

oControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.ControlRemove Method

Remove specified control from the group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ControlRemove( _
   ByVal oControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ControlRemove(
   Control oControl
)
This language is not supported or no code example is available.

Parameters

oControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup.Refresh Method

Force a full repaint of group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Sub Refresh()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override System.Void Refresh()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup Events

OutlookBarGroup Class See Also

The following tables list the members exposed by the OutlookBarGroup type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | AutoValidateChanged | (inherited from ContainerControl).
Public event | BackColorChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BackgroundImageLayoutChanged | Occurs when . (inherited from OutlookBarControl).
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when . (inherited from OutlookBarControl).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | (inherited from ScrollableControl).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

OutlookBarGroup Class


DockChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Shadows Event DockChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
new public event DockChangedEventHandler DockChanged
delegate void DockChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroups Class

Members

This class represents a collection of OutlookBar groups

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class OutlookBarGroups
    Inherits OutlookBarCollectionBase
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class OutlookBarGroups : OutlookBarCollectionBase
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Collections.CollectionBase
Softgroup.NetControls.OutlookBarCollectionBase
Softgroup.NetControls.OutlookBarGroups
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Members


OutlookBarGroups Members

OutlookBarGroups Class Events Methods Properties See Also

This class represents a collection of OutlookBar groups

The following tables list the members exposed by the OutlookBarGroups type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | Gets a group at specified index
Public property | OutloolBar | Gets a reference to OutlookBar owner
Top
Methods
 | Name | Description
Public method | Add | Adds a new group to the collection
Public method | Clear | Consente di rimuovere tutti gli oggetti dall'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains a specific group
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | Gets the collection index position of specified OutlookBarGroup
Public method | Remove | Removes specified group from the collection
Public method | RemoveAt | Removes group at specified position from the collection of groups
Public method | Sort | Sorts the elements in the entire collection using the specified comparer. (inherited from OutlookBarCollectionBase).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs when an item has been added to the collection (inherited from OutlookBarCollectionBase).
Public event | ItemRemoved | Occurs when an item has been removed from the collection (inherited from OutlookBarCollectionBase).
Top
See Also

Reference

OutlookBarGroups Class


OutlookBarGroups Properties

OutlookBarGroups Class See Also

The following tables list the members exposed by the OutlookBarGroups type.

Properties
 | Name | Description
Public property | Capacity | Ottiene o imposta il numero di elementi che CollectionBase può contenere. (inherited from CollectionBase).
Public property | Count | Ottiene il numero di elementi contenuti nell'istanza CollectionBase. Questa proprietà non può essere sottoposta a override. (inherited from CollectionBase).
Public property | Item | Gets a group at specified index
Public property | OutloolBar | Gets a reference to OutlookBar owner
Top
See Also

Reference

OutlookBarGroups Class


OutlookBarGroups.Item Property

Gets a group at specified index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal index As Integer _
) As OutlookBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public OutlookBarGroup this[
   int index
] {get;}
This language is not supported or no code example is available.

Parameters

index

Type: int

Itemindex

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups.OutloolBar Property

Gets a reference to OutlookBar owner

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property OutloolBar() As OutlookBar
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBar OutloolBar {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups Methods

OutlookBarGroups Class See Also

The following tables list the members exposed by the OutlookBarGroups type.

Methods
 | Name | Description
Public method | Add | Adds a new group to the collection
Public method | Clear | Consente di rimuovere tutti gli oggetti dall'istanza CollectionBase. Questo metodo non può essere sottoposto a override. (inherited from CollectionBase).
Public method | Contains | Determines whether the collection contains a specific group
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetEnumerator | Restituisce un enumeratore che scorre l'istanza della classe CollectionBase. (inherited from CollectionBase).
Public method | IndexOf | Gets the collection index position of specified OutlookBarGroup
Public method | Remove | Removes specified group from the collection
Public method | RemoveAt | Removes group at specified position from the collection of groups
Public method | Sort | Sorts the elements in the entire collection using the specified comparer. (inherited from OutlookBarCollectionBase).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

OutlookBarGroups Class


OutlookBarGroups.Add Method

Adds a new group to the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal oGroup As OutlookBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   OutlookBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: OutlookBarGroup

The new group to add

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups.Contains Method

Determines whether the collection contains a specific group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function Contains( _
   ByVal oGroup As OutlookBarGroup _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool Contains(
   OutlookBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: OutlookBarGroup

The group

Return Value

Returns true if the list contains the group otherwise false
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups.IndexOf Method

Gets the collection index position of specified OutlookBarGroup

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal oGroup As OutlookBarGroup _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   OutlookBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: OutlookBarGroup

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups.Remove Method

Removes specified group from the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal oGroup As OutlookBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   OutlookBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: OutlookBarGroup

The group to remove

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups.RemoveAt Method

Removes group at specified position from the collection of groups

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Sub RemoveAt( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveAt(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

Index of group to remove

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroups Class
OutlookBarGroups Members


OutlookBarGroups Events

OutlookBarGroups Class See Also

The following tables list the members exposed by the OutlookBarGroups type.

Events
 | Name | Description
Public event | ItemAdded | Occurs when an item has been added to the collection (inherited from OutlookBarCollectionBase).
Public event | ItemRemoved | Occurs when an item has been removed from the collection (inherited from OutlookBarCollectionBase).
Top
See Also

Reference

OutlookBarGroups Class


OutlookBarRenderer Class

Members

This class contains drawing functionality and color table for the OutlookBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class OutlookBarRenderer
    Inherits ToolStripProfessionalRenderer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class OutlookBarRenderer : ToolStripProfessionalRenderer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Windows.Forms.ToolStripRenderer
System.Windows.Forms.ToolStripProfessionalRenderer
Softgroup.NetControls.OutlookBarRenderer
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Members


OutlookBarRenderer Members

OutlookBarRenderer Class Constructors Events Methods Properties See Also

This class contains drawing functionality and color table for the OutlookBar control

The following tables list the members exposed by the OutlookBarRenderer type.

Constructors
 | Name | Description
Public constructor | OutlookBarRenderer Constructor | Initializes a new instance of the ToolstripRenderer class
Top
Properties
 | Name | Description
Public property | ColorTable | Gets/Sets renderer color table
Public property | RenderBackgroundGradient | Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not
Public property | RenderBackgroundGroupsGradient | Gets/Sets whether the renderer draw background of group buttons using gradient effects of not
Public property | RoundedEdges | (inherited from ToolStripProfessionalRenderer).
Top
Methods
 | Name | Description
 | CreateDisabledImage | (inherited from ToolStripRenderer).
Public method | DrawArrow | (inherited from ToolStripRenderer).
Public method | DrawButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawDropDownButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawGrip | (inherited from ToolStripRenderer).
Public method | DrawImageMargin | (inherited from ToolStripRenderer).
Public method | DrawItemBackground | (inherited from ToolStripRenderer).
Public method | DrawItemCheck | (inherited from ToolStripRenderer).
Public method | DrawItemImage | (inherited from ToolStripRenderer).
Public method | DrawItemText | (inherited from ToolStripRenderer).
Public method | DrawLabelBackground | (inherited from ToolStripRenderer).
Public method | DrawMenuItemBackground | (inherited from ToolStripRenderer).
Public method | DrawOverflowButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawSeparator | (inherited from ToolStripRenderer).
Public method | DrawSplitButton | (inherited from ToolStripRenderer).
Public method | DrawStatusStripSizingGrip | (inherited from ToolStripRenderer).
Public method | DrawToolStripBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripBorder | (inherited from ToolStripRenderer).
Public method | DrawToolStripContentPanelBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripPanelBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripStatusLabelBackground | (inherited from ToolStripRenderer).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | OutlookbarDrawBackground | Draws the background of the OutlookBar control
Public method | OutlookbarDrawButtonBackground | Draws the background gradients of an Button
Public method | OutlookbarDrawButtonCollapse | Draws the surface of the Collapse button
Public method | OutlookbarDrawButtonOptionsTriangle | Draws the surface of the options button
Public method | OutlookbarDrawGroupBackground | Draws the background of the OutbookBarGroup control
Public method | OutlookbarDrawGroupCollapsed | Draws the background of the collapsed group
Public method | OutlookbarDrawHeaderBackground | Draws the header background on top of the OutlookBar
Public method | OutlookbarDrawHeaderForeground | Draws the header background on top of the OutlookBar
Public method | OutlookbarDrawImage | Draws an image on the canvas at a given location
Public method | OutlookbarDrawSmallButtonRegion | Draws the background of the rectangle containing the small buttons on the bottom of the OutlookBar
Public method | OutlookbarDrawSplitter | Draws the background of the gradient splitter class to a graphics surface
Public method | OutlookbarDrawText | Draws text on a graphics canvas
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
Events
 | Name | Description
Public event | RenderArrow | (inherited from ToolStripRenderer).
Public event | RenderButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderDropDownButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderGrip | (inherited from ToolStripRenderer).
Public event | RenderImageMargin | (inherited from ToolStripRenderer).
Public event | RenderItemBackground | (inherited from ToolStripRenderer).
Public event | RenderItemCheck | (inherited from ToolStripRenderer).
Public event | RenderItemImage | (inherited from ToolStripRenderer).
Public event | RenderItemText | (inherited from ToolStripRenderer).
Public event | RenderLabelBackground | (inherited from ToolStripRenderer).
Public event | RenderMenuItemBackground | (inherited from ToolStripRenderer).
Public event | RenderOverflowButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderSeparator | (inherited from ToolStripRenderer).
Public event | RenderSplitButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderStatusStripSizingGrip | (inherited from ToolStripRenderer).
Public event | RenderToolStripBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripBorder | (inherited from ToolStripRenderer).
Public event | RenderToolStripContentPanelBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripPanelBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripStatusLabelBackground | (inherited from ToolStripRenderer).
Top
See Also

Reference

OutlookBarRenderer Class


OutlookBarRenderer Constructor

Initializes a new instance of the ToolstripRenderer class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oColorTable As ProfessionalColorTable _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBarRenderer(
   ProfessionalColorTable oColorTable
)
This language is not supported or no code example is available.

Parameters

oColorTable

Type: ProfessionalColorTable

The colors used to draw the MenuStrip

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer Properties

OutlookBarRenderer Class See Also

The following tables list the members exposed by the OutlookBarRenderer type.

Properties
 | Name | Description
Public property | ColorTable | Gets/Sets renderer color table
Public property | RenderBackgroundGradient | Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not
Public property | RenderBackgroundGroupsGradient | Gets/Sets whether the renderer draw background of group buttons using gradient effects of not
Public property | RoundedEdges | (inherited from ToolStripProfessionalRenderer).
Top
See Also

Reference

OutlookBarRenderer Class


OutlookBarRenderer.ColorTable Property

Gets/Sets renderer color table

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Overloads Property ColorTable() As ProfessionalColorTable
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ProfessionalColorTable ColorTable {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.RenderBackgroundGradient Property

Gets/Sets whether the renderer draw background of OutlookBar, Groups and ToolStrips controls using gradient effects of not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property RenderBackgroundGradient() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool RenderBackgroundGradient {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.RenderBackgroundGroupsGradient Property

Gets/Sets whether the renderer draw background of group buttons using gradient effects of not

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property RenderBackgroundGroupsGradient() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool RenderBackgroundGroupsGradient {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer Methods

OutlookBarRenderer Class See Also

The following tables list the members exposed by the OutlookBarRenderer type.

Methods
 | Name | Description
 | CreateDisabledImage | (inherited from ToolStripRenderer).
Public method | DrawArrow | (inherited from ToolStripRenderer).
Public method | DrawButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawDropDownButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawGrip | (inherited from ToolStripRenderer).
Public method | DrawImageMargin | (inherited from ToolStripRenderer).
Public method | DrawItemBackground | (inherited from ToolStripRenderer).
Public method | DrawItemCheck | (inherited from ToolStripRenderer).
Public method | DrawItemImage | (inherited from ToolStripRenderer).
Public method | DrawItemText | (inherited from ToolStripRenderer).
Public method | DrawLabelBackground | (inherited from ToolStripRenderer).
Public method | DrawMenuItemBackground | (inherited from ToolStripRenderer).
Public method | DrawOverflowButtonBackground | (inherited from ToolStripRenderer).
Public method | DrawSeparator | (inherited from ToolStripRenderer).
Public method | DrawSplitButton | (inherited from ToolStripRenderer).
Public method | DrawStatusStripSizingGrip | (inherited from ToolStripRenderer).
Public method | DrawToolStripBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripBorder | (inherited from ToolStripRenderer).
Public method | DrawToolStripContentPanelBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripPanelBackground | (inherited from ToolStripRenderer).
Public method | DrawToolStripStatusLabelBackground | (inherited from ToolStripRenderer).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | OutlookbarDrawBackground | Draws the background of the OutlookBar control
Public method | OutlookbarDrawButtonBackground | Draws the background gradients of an Button
Public method | OutlookbarDrawButtonCollapse | Draws the surface of the Collapse button
Public method | OutlookbarDrawButtonOptionsTriangle | Draws the surface of the options button
Public method | OutlookbarDrawGroupBackground | Draws the background of the OutbookBarGroup control
Public method | OutlookbarDrawGroupCollapsed | Draws the background of the collapsed group
Public method | OutlookbarDrawHeaderBackground | Draws the header background on top of the OutlookBar
Public method | OutlookbarDrawHeaderForeground | Draws the header background on top of the OutlookBar
Public method | OutlookbarDrawImage | Draws an image on the canvas at a given location
Public method | OutlookbarDrawSmallButtonRegion | Draws the background of the rectangle containing the small buttons on the bottom of the OutlookBar
Public method | OutlookbarDrawSplitter | Draws the background of the gradient splitter class to a graphics surface
Public method | OutlookbarDrawText | Draws text on a graphics canvas
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

OutlookBarRenderer Class


OutlookBarRenderer.OutlookbarDrawBackground Method

Draws the background of the OutlookBar control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawBackground( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawBackground(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the background

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawButtonBackground Method

Draws the background gradients of an Button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawButtonBackground( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle, _
   ByVal bActive As Boolean, _
   ByVal eMouseState As MouseStateEnum _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawButtonBackground(
   Graphics g,
   Rectangle bounds,
   bool bActive,
   MouseStateEnum eMouseState
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds that the drawing should apply to

bActive

Type: bool

True if OutlookBarButton is currently Active

eMouseState

Type: MouseStateEnum

Input State of Button

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawButtonCollapse Method

Draws the surface of the Collapse button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawButtonCollapse( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle, _
   ByVal eMouseState As MouseStateEnum, _
   ByVal bRightToLeft As Boolean, _
   ByVal bCollapsed As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawButtonCollapse(
   Graphics g,
   Rectangle bounds,
   MouseStateEnum eMouseState,
   bool bRightToLeft,
   bool bCollapsed
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds that the drawing should apply to

eMouseState

Type: MouseStateEnum

The input state of the control

bRightToLeft

Type: bool

Right to left or left to right

bCollapsed

Type: bool

The bar is collasped or not

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawButtonOptionsTriangle Method

Draws the surface of the options button

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawButtonOptionsTriangle( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawButtonOptionsTriangle(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics canvas to draw on

bounds

Type: Rectangle

The bounds of the text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawGroupBackground Method

Draws the background of the OutbookBarGroup control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawGroupBackground( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawGroupBackground(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the background

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawGroupCollapsed Method

Draws the background of the collapsed group

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawGroupCollapsed( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle, _
   ByVal sText As String, _
   ByVal oFont As Font, _
   ByVal oForeColor As Color, _
   ByVal bRightToLeft As Boolean, _
   ByVal eMouseState As MouseStateEnum _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawGroupCollapsed(
   Graphics g,
   Rectangle bounds,
   string sText,
   Font oFont,
   Color oForeColor,
   bool bRightToLeft,
   MouseStateEnum eMouseState
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The canvas to draw on

bounds

Type: Rectangle

The bounds of the drawing

sText

Type: string

The text that should appear into the bar

oFont

Type: Font

The font to use when drawing the text

oForeColor

Type: Color

The text foreground color

bRightToLeft

Type: bool

eMouseState

Type: MouseStateEnum

The mouse state of the collapsed group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawHeaderBackground Method

Draws the header background on top of the OutlookBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawHeaderBackground( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawHeaderBackground(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the header

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawHeaderForeground Method

Draws the header background on top of the OutlookBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawHeaderForeground( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle, _
   ByVal oGroupImage As Image, _
   ByVal bImageVisible As Boolean, _
   ByVal sText As String, _
   ByVal oFont As Font, _
   ByVal oForeColor As Color, _
   ByVal bRightToLeft As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawHeaderForeground(
   Graphics g,
   Rectangle bounds,
   Image oGroupImage,
   bool bImageVisible,
   string sText,
   Font oFont,
   Color oForeColor,
   bool bRightToLeft
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the header

oGroupImage

Type: Image

The bounds of the header

bImageVisible

Type: bool

The bounds of the header

sText

Type: string

The Text to draw

oFont

Type: Font

The Text font

oForeColor

Type: Color

The Text foreground color

bRightToLeft

Type: bool

Text must be drawn using Right-To-Left

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawImage Method

Draws an image on the canvas at a given location

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawImage( _
   ByVal g As Graphics, _
   ByVal oImage As Image, _
   ByVal oPoint As Point _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawImage(
   Graphics g,
   Image oImage,
   Point oPoint
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics canvas to draw on

oImage

Type: Image

The image

oPoint

Type: Point

The location of the image

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawSmallButtonRegion Method

Draws the background of the rectangle containing the small buttons on the bottom of the OutlookBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawSmallButtonRegion( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawSmallButtonRegion(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the small rectangle

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawSplitter Method

Draws the background of the gradient splitter class to a graphics surface

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawSplitter( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawSplitter(
   Graphics g,
   Rectangle bounds
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the drawing relative to the graphics surface

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer.OutlookbarDrawText Method

Draws text on a graphics canvas

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overridable Sub OutlookbarDrawText( _
   ByVal g As Graphics, _
   ByVal bounds As Rectangle, _
   ByVal sText As String, _
   ByVal oFont As Font, _
   ByVal oForeColor As Color, _
   ByVal bRightToLeft As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public virtual System.Void OutlookbarDrawText(
   Graphics g,
   Rectangle bounds,
   string sText,
   Font oFont,
   Color oForeColor,
   bool bRightToLeft
)
This language is not supported or no code example is available.

Parameters

g

Type: Graphics

The graphics surface to draw on

bounds

Type: Rectangle

The bounds of the text

sText

Type: string

The text to draw

oFont

Type: Font

The font of the text

oForeColor

Type: Color

The font of the text

bRightToLeft

Type: bool

Rigth to left or left to right layout

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarRenderer Class
OutlookBarRenderer Members


OutlookBarRenderer Events

OutlookBarRenderer Class See Also

The following tables list the members exposed by the OutlookBarRenderer type.

Events
 | Name | Description
Public event | RenderArrow | (inherited from ToolStripRenderer).
Public event | RenderButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderDropDownButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderGrip | (inherited from ToolStripRenderer).
Public event | RenderImageMargin | (inherited from ToolStripRenderer).
Public event | RenderItemBackground | (inherited from ToolStripRenderer).
Public event | RenderItemCheck | (inherited from ToolStripRenderer).
Public event | RenderItemImage | (inherited from ToolStripRenderer).
Public event | RenderItemText | (inherited from ToolStripRenderer).
Public event | RenderLabelBackground | (inherited from ToolStripRenderer).
Public event | RenderMenuItemBackground | (inherited from ToolStripRenderer).
Public event | RenderOverflowButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderSeparator | (inherited from ToolStripRenderer).
Public event | RenderSplitButtonBackground | (inherited from ToolStripRenderer).
Public event | RenderStatusStripSizingGrip | (inherited from ToolStripRenderer).
Public event | RenderToolStripBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripBorder | (inherited from ToolStripRenderer).
Public event | RenderToolStripContentPanelBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripPanelBackground | (inherited from ToolStripRenderer).
Public event | RenderToolStripStatusLabelBackground | (inherited from ToolStripRenderer).
Top
See Also

Reference

OutlookBarRenderer Class


PrintPreview Class

Members

Softgroup .Net Print Preview is a fast, small and lightweight .Net control that provide nice and accurate print and preview for CheckedListBox, DataGrid, DataGridView, Forms, ListBox, ListView, TreeView, RichTextBox .Net WinForm controls and System.Drawing.Image objects, not provided directly from .Net Framework.

Supported .Net controls:

• CheckedListBox

• DataGrid

• DataGridView

• Forms

• Images

• ListBox

• ListView

• TreeView

• RichTextBox

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Drawing.ToolboxBitmap(GetType(PrintPreview), "NetPrint.bmp")> _
<System.ComponentModel.DefaultEvent("BeginPrint")> _
<System.ComponentModel.DefaultProperty("DocumentName")> _
Public Class PrintPreview
    Inherits UserControl
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Drawing.ToolboxBitmap(GetType(PrintPreview), "NetPrint.bmp")]
[System.ComponentModel.DefaultEvent("BeginPrint")]
[System.ComponentModel.DefaultProperty("DocumentName")]
public class PrintPreview : UserControl
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetControls.PrintPreview
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Members


PrintPreview Members

PrintPreview Class Events Methods Properties See Also

Softgroup .Net Print Preview is a fast, small and lightweight .Net control that provide nice and accurate print and preview for CheckedListBox, DataGrid, DataGridView, Forms, ListBox, ListView, TreeView, RichTextBox .Net WinForm controls and System.Drawing.Image objects, not provided directly from .Net Framework.

Supported .Net controls:

• CheckedListBox

• DataGrid

• DataGridView

• Forms

• Images

• ListBox

• ListView

• TreeView

• RichTextBox

The following tables list the members exposed by the PrintPreview type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (Overloaded) Gets or sets .
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Control | Gets the printed control object
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (Overloaded) Gets .
 | DefaultFont | (Overloaded) Gets .
 | DefaultForeColor | (Overloaded) Gets .
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | DocumentName | Gets or sets the print document name.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | PageFooterColor | The color used to print the page footer text
Public property | PageFooterFont | The font used to print page footer text
Public property | PageFooterLocation | The location of the page footer text
Public property | PageFooterText | Text printed at the bottom of each page
Public property | PageHeaderColor | The color used to print the page header
Public property | PageHeaderFont | The font used to print the page header
Public property | PageHeaderLocation | The location of the page header text
Public property | PageHeaderText | Text printed at the top of each page
Public property | PageMargins | Gest/Sets page margins in thousandths of inches.
Public property | PageNumberColor | The color used to print page numbers
Public property | PageNumberFont | The font used to print page numbers
Public property | PageNumberLocation | The location of page numbers
Public property | PageNumberText | Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages.
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | PrintFinished | Return True if print/preview is finished.
Public property | PrintStarted | Return True if print/preview is started
Public property | PrinterSettings | Gets the System.Drawing.Printing.PrinterSettings object associated to the control.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseExDialog | Gets or sets a value indicating whether the dialog should be shown in the Windows XP style for systems running Windows XP Home Edition, Windows XP Professional, Windows Server 2003 or later.
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DocumentPreview | (Overloaded) Print document to preview window.
Public method | DocumentPrint | (Overloaded) Print document to the printer.
Public method | GetPreferredSize | (inherited from Control).
 | Localize | With this method you can localize preview dialog for any language. Because this is a shared method localized strings must be sets before control will be loaded otherwise you must call Refresh method after a call to Localize method for localized strings will take effects
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Refresh | Redraw and refresh control
Public method | ResetBackColor |
Public method | ResetBindings |
Public method | ResetFont |
Public method | ResetForeColor |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | EndPrint | Occurs when the last page of the document has printed. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | PrintPage | Occurs when the output to print for the current page is needed. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

PrintPreview Class


PrintPreview Properties

PrintPreview Class See Also

The following tables list the members exposed by the PrintPreview type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | ActiveControl | (inherited from ContainerControl).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScaleDimensions | (inherited from ContainerControl).
Public property | AutoScaleMode | (inherited from ContainerControl).
Public property | AutoScroll | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoScrollMargin | (Overloaded) Gets or sets .
Public property | AutoScrollMinSize | (Overloaded) Gets or sets .
Public property | AutoScrollOffset | (Overloaded) Gets or sets .
Public property | AutoScrollPosition | (Overloaded) Gets or sets .
Public property | AutoSize | (Overloaded) Gets or sets a value indicating whether .
Public property | AutoSizeMode | (Overloaded) Gets or sets .
Public property | AutoValidate | (Overloaded) Gets or sets .
Public property | BackColor | (Overloaded) Gets or sets .
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (Overloaded) Gets or sets .
Public property | BorderStyle | (inherited from UserControl).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (Overloaded) Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Control | Gets the printed control object
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | CurrentAutoScaleDimensions | (inherited from ContainerControl).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (Overloaded) Gets or sets .
 | DefaultBackColor | (Overloaded) Gets .
 | DefaultFont | (Overloaded) Gets .
 | DefaultForeColor | (Overloaded) Gets .
Public property | DisplayRectangle | (inherited from ScrollableControl).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | DockPadding | (inherited from ScrollableControl).
Public property | DocumentName | Gets or sets the print document name.
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (Overloaded) Gets or sets .
Public property | ForeColor | (Overloaded) Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | HorizontalScroll | (Overloaded) Gets .
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) Gets or sets .
Public property | PageFooterColor | The color used to print the page footer text
Public property | PageFooterFont | The font used to print page footer text
Public property | PageFooterLocation | The location of the page footer text
Public property | PageFooterText | Text printed at the bottom of each page
Public property | PageHeaderColor | The color used to print the page header
Public property | PageHeaderFont | The font used to print the page header
Public property | PageHeaderLocation | The location of the page header text
Public property | PageHeaderText | Text printed at the top of each page
Public property | PageMargins | Gest/Sets page margins in thousandths of inches.
Public property | PageNumberColor | The color used to print page numbers
Public property | PageNumberFont | The font used to print page numbers
Public property | PageNumberLocation | The location of page numbers
Public property | PageNumberText | Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages.
Public property | Parent | (inherited from Control).
Public property | ParentForm | (inherited from ContainerControl).
Public property | PreferredSize | (inherited from Control).
Public property | PrintFinished | Return True if print/preview is finished.
Public property | PrintStarted | Return True if print/preview is started
Public property | PrinterSettings | Gets the System.Drawing.Printing.PrinterSettings object associated to the control.
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | (inherited from UserControl).
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseExDialog | Gets or sets a value indicating whether the dialog should be shown in the Windows XP style for systems running Windows XP Home Edition, Windows XP Professional, Windows Server 2003 or later.
Public property | UseWaitCursor | (inherited from Control).
Public property | VerticalScroll | (Overloaded) Gets .
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

PrintPreview Class


PrintPreview.AutoScroll Property

PrintPreview Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollMargin Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMargin | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollMinSize Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollMinSize | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollOffset Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollOffset | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollPosition Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoScrollPosition | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoSize Property

PrintPreview Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
AutoSize | (System.Windows.Forms.UserControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoSizeMode Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoSizeMode | (System.Windows.Forms.UserControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoValidate Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
AutoValidate | (System.Windows.Forms.UserControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackColor Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackColor | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackgroundImage Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackgroundImageLayout Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BindingContext Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BindingContext | (System.Windows.Forms.ContainerControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.CausesValidation Property

PrintPreview Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
CausesValidation | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Control Property

Gets the printed control object

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Description("Gets the printed control object")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.DefaultValue(CType(Nothing, String))> _
Public ReadOnly Property Control( _
   ByRef "Gets the printed control object" As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Description("Gets the printed control object")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.DefaultValue(CType(Nothing, String))]
[System.Runtime.CompilerServices.IndexerName("Control")]
public object this[
   ref object "Gets the printed control object"
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets the printed control object"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DataBindings Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
DataBindings | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultBackColor Property

PrintPreview Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DefaultBackColor | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultFont Property

PrintPreview Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DefaultFont | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultForeColor Property

PrintPreview Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
DefaultForeColor | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DocumentName Property

Gets or sets the print document name.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("Gets or sets the print document name.")> _
<System.ComponentModel.DefaultValue("document")> _
Public Property DocumentName( _
   ByRef "Gets or sets the print document name." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("Gets or sets the print document name.")]
[System.ComponentModel.DefaultValue("document")]
[System.Runtime.CompilerServices.IndexerName("DocumentName")]
public string this[
   ref object "Gets or sets the print document name."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets or sets the print document name."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Font Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Font | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ForeColor Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.HorizontalScroll Property

PrintPreview Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
HorizontalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Padding Property

PrintPreview Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageFooterColor Property

The color used to print the page footer text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The color used to print the page footer text")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")> _
Public Property PageFooterColor( _
   ByRef "The color used to print the page footer text" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The color used to print the page footer text")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")]
[System.Runtime.CompilerServices.IndexerName("PageFooterColor")]
public Color this[
   ref object "The color used to print the page footer text"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The color used to print the page footer text"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageFooterFont Property

The font used to print page footer text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The font used to print page footer text")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt")> _
Public Property PageFooterFont( _
   ByRef "The font used to print page footer text" As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The font used to print page footer text")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt")]
[System.Runtime.CompilerServices.IndexerName("PageFooterFont")]
public Font this[
   ref object "The font used to print page footer text"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The font used to print page footer text"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageFooterLocation Property

The location of the page footer text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The location of the page footer text")> _
<System.ComponentModel.DefaultValue(GetType(HeaderFooterPositionEnum), "hfpCenter")> _
Public Property PageFooterLocation( _
   ByRef "The location of the page footer text" As Object _
) As HeaderFooterPositionEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The location of the page footer text")]
[System.ComponentModel.DefaultValue(GetType(HeaderFooterPositionEnum), "hfpCenter")]
[System.Runtime.CompilerServices.IndexerName("PageFooterLocation")]
public HeaderFooterPositionEnum this[
   ref object "The location of the page footer text"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The location of the page footer text"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageFooterText Property

Text printed at the bottom of each page

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("Text printed at the bottom of each page")> _
<System.ComponentModel.DefaultValue("Date: %Date% - Time: %Time%")> _
Public Property PageFooterText( _
   ByRef "Text printed at the bottom of each page" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("Text printed at the bottom of each page")]
[System.ComponentModel.DefaultValue("Date: %Date% - Time: %Time%")]
[System.Runtime.CompilerServices.IndexerName("PageFooterText")]
public string this[
   ref object "Text printed at the bottom of each page"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Text printed at the bottom of each page"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageHeaderColor Property

The color used to print the page header

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The color used to print the page header")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")> _
Public Property PageHeaderColor( _
   ByRef "The color used to print the page header" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The color used to print the page header")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")]
[System.Runtime.CompilerServices.IndexerName("PageHeaderColor")]
public Color this[
   ref object "The color used to print the page header"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The color used to print the page header"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageHeaderFont Property

The font used to print the page header

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The font used to print the page header")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt; style=Bold")> _
Public Property PageHeaderFont( _
   ByRef "The font used to print the page header" As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The font used to print the page header")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt; style=Bold")]
[System.Runtime.CompilerServices.IndexerName("PageHeaderFont")]
public Font this[
   ref object "The font used to print the page header"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The font used to print the page header"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageHeaderLocation Property

The location of the page header text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The location of the page header text")> _
<System.ComponentModel.DefaultValue(GetType(HeaderFooterPositionEnum), "hfpCenter")> _
Public Property PageHeaderLocation( _
   ByRef "The location of the page header text" As Object _
) As HeaderFooterPositionEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The location of the page header text")]
[System.ComponentModel.DefaultValue(GetType(HeaderFooterPositionEnum), "hfpCenter")]
[System.Runtime.CompilerServices.IndexerName("PageHeaderLocation")]
public HeaderFooterPositionEnum this[
   ref object "The location of the page header text"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The location of the page header text"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageHeaderText Property

Text printed at the top of each page

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("Text printed at the top of each page")> _
<System.ComponentModel.DefaultValue("")> _
Public Property PageHeaderText( _
   ByRef "Text printed at the top of each page" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("Text printed at the top of each page")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("PageHeaderText")]
public string this[
   ref object "Text printed at the top of each page"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Text printed at the top of each page"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageMargins Property

Gest/Sets page margins in thousandths of inches.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("Gest/Sets Bottom page margin in thousandths of inches.")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Printing.Margins), "45,45,45,45")> _
Public Property PageMargins( _
   ByRef "Gest/Sets Bottom page margin in thousandths of inches." As Object _
) As Margins
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("Gest/Sets Bottom page margin in thousandths of inches.")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Printing.Margins), "45,45,45,45")]
[System.Runtime.CompilerServices.IndexerName("PageMargins")]
public Margins this[
   ref object "Gest/Sets Bottom page margin in thousandths of inches."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gest/Sets Bottom page margin in thousandths of inches."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageNumberColor Property

The color used to print page numbers

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The color used to print page numbers")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")> _
Public Property PageNumberColor( _
   ByRef "The color used to print page numbers" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The color used to print page numbers")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Black")]
[System.Runtime.CompilerServices.IndexerName("PageNumberColor")]
public Color this[
   ref object "The color used to print page numbers"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The color used to print page numbers"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageNumberFont Property

The font used to print page numbers

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The font used to print page numbers")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt")> _
Public Property PageNumberFont( _
   ByRef "The font used to print page numbers" As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The font used to print page numbers")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Font), "Microsoft Sans Serif; 8,25pt")]
[System.Runtime.CompilerServices.IndexerName("PageNumberFont")]
public Font this[
   ref object "The font used to print page numbers"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The font used to print page numbers"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageNumberLocation Property

The location of page numbers

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("The location of page numbers")> _
<System.ComponentModel.DefaultValue(GetType(PageNumberPositionEnum), "pnpBottomRight")> _
Public Property PageNumberLocation( _
   ByRef "The location of page numbers" As Object _
) As PageNumberPositionEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("The location of page numbers")]
[System.ComponentModel.DefaultValue(GetType(PageNumberPositionEnum), "pnpBottomRight")]
[System.Runtime.CompilerServices.IndexerName("PageNumberLocation")]
public PageNumberPositionEnum this[
   ref object "The location of page numbers"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"The location of page numbers"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PageNumberText Property

Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.Description("Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages.")> _
<System.ComponentModel.DefaultValue("Page %Page% of %Pages%")> _
Public Property PageNumberText( _
   ByRef "Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.Description("Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages.")]
[System.ComponentModel.DefaultValue("Page %Page% of %Pages%")]
[System.Runtime.CompilerServices.IndexerName("PageNumberText")]
public string this[
   ref object "Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Formatting string for page numbers. Must include %Page% and/or %Pages% keywords which are placeholders for the page number and the total number of pages."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PrintFinished Property

Return True if print/preview is finished.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Return True if print/preview is finished.")> _
<System.ComponentModel.Category("NetPrint")> _
Public ReadOnly Property PrintFinished( _
   ByRef "NetPrint" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Return True if print/preview is finished.")]
[System.ComponentModel.Category("NetPrint")]
[System.Runtime.CompilerServices.IndexerName("PrintFinished")]
public bool this[
   ref object "NetPrint"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPrint"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PrintStarted Property

Return True if print/preview is started

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Return True if print/preview is started")> _
<System.ComponentModel.Category("NetPrint")> _
Public ReadOnly Property PrintStarted( _
   ByRef "NetPrint" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Return True if print/preview is started")]
[System.ComponentModel.Category("NetPrint")]
[System.Runtime.CompilerServices.IndexerName("PrintStarted")]
public bool this[
   ref object "NetPrint"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPrint"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.PrinterSettings Property

Gets the System.Drawing.Printing.PrinterSettings object associated to the control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Description("Gets the System.Drawing.Printing.PrinterSettings object associated to the control.")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Category("NetPrint")> _
Public ReadOnly Property PrinterSettings( _
   ByRef False As Object _
) As PrinterSettings
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Description("Gets the System.Drawing.Printing.PrinterSettings object associated to the control.")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Category("NetPrint")]
[System.Runtime.CompilerServices.IndexerName("PrinterSettings")]
public PrinterSettings this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.UseExDialog Property

Gets or sets a value indicating whether the dialog should be shown in the Windows XP style for systems running Windows XP Home Edition, Windows XP Professional, Windows Server 2003 or later.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("NetPrint")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property UseExDialog( _
   ByRef True As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("NetPrint")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("UseExDialog")]
public bool this[
   ref object True
] {get; set;}
This language is not supported or no code example is available.

Parameters

True

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.VerticalScroll Property

PrintPreview Class See Also

Gets .

Overload List
Name | Description
this[ref object] | Gets .
VerticalScroll | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview Methods

PrintPreview Class See Also

The following tables list the members exposed by the PrintPreview type.

Methods
 | Name | Description
Public method | BeginInvoke | (Overloaded) (inherited from Control).
Public method | DocumentPreview | (Overloaded) Print document to preview window.
Public method | DocumentPrint | (Overloaded) Print document to the printer.
Public method | GetPreferredSize | (inherited from Control).
 | Localize | With this method you can localize preview dialog for any language. Because this is a shared method localized strings must be sets before control will be loaded otherwise you must call Refresh method after a call to Localize method for localized strings will take effects
Public method | PerformAutoScale | (inherited from ContainerControl).
Public method | Refresh | Redraw and refresh control
Public method | ResetBackColor |
Public method | ResetBindings |
Public method | ResetFont |
Public method | ResetForeColor |
Public method | ScrollControlIntoView |
Public method | SetAutoScrollMargin | (Overloaded)
Public method | Validate | (Overloaded)
Public method | ValidateChildren | (Overloaded)
Top
See Also

Reference

PrintPreview Class


PrintPreview.DocumentPreview Method

PrintPreview Class See Also

Print document to preview window.

Overload List
Name | Description
DocumentPreview(object) | Print document to preview window.
DocumentPreview(object, bool) | Print document to preview window.
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DocumentPrint Method

PrintPreview Class See Also

Print document to the printer.

Overload List
Name | Description
DocumentPrint(object) | Print document to the printer.
DocumentPrint(object, bool) | Print document to the printer.
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Localize Method

With this method you can localize preview dialog for any language. Because this is a shared method localized strings must be sets before control will be loaded otherwise you must call Refresh method after a call to Localize method for localized strings will take effects

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("With this method you can localize preview dialog for any language. Because this is a shared method localized strings must be sets before control will be loaded otherwise you must call Refresh method after a call to Localize method for localized strings will take effects")> _
Public Shared Sub Localize( _
   ByVal iObject As PreviewTextEnum, _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("With this method you can localize preview dialog for any language. Because this is a shared method localized strings must be sets before control will be loaded otherwise you must call Refresh method after a call to Localize method for localized strings will take effects")]
public static System.Void Localize(
   PreviewTextEnum iObject,
   string sText
)
This language is not supported or no code example is available.

Parameters

iObject

Type: PreviewTextEnum

An variable of type Softgroup.PreviewTextEnum that specify the object type to change text

sText

Type: string

Text for required object type

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Refresh Method

Redraw and refresh control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overrides Sub Refresh()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override System.Void Refresh()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ResetBackColor Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetBackColor()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetBackColor()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ResetBindings Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetBindings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetBindings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ResetFont Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetFont()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetFont()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ResetForeColor Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ResetForeColor()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ResetForeColor()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ScrollControlIntoView Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void ScrollControlIntoView(
   Control activeControl
)
This language is not supported or no code example is available.

Parameters

activeControl

Type: Control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.SetAutoScrollMargin Method

PrintPreview Class See Also

Overload List
Name | Description
SetAutoScrollMargin(int, int) |
SetAutoScrollMargin(Int32,Int32) | (System.Windows.Forms.ScrollableControl).
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Validate Method

PrintPreview Class See Also

Overload List
Name | Description
Validate() |
Validate(bool) |
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ValidateChildren Method

PrintPreview Class See Also

Overload List
Name | Description
ValidateChildren() |
ValidateChildren(ValidationConstraints) |
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview Events

PrintPreview Class See Also

The following tables list the members exposed by the PrintPreview type.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when .
Public event | AutoValidateChanged | Occurs when .
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | BindingContextChanged | Occurs when .
Public event | CausesValidationChanged | Occurs when .
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | EndPrint | Occurs when the last page of the document has printed. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | Load | (inherited from UserControl).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | PrintPage | Occurs when the output to print for the current page is needed. This is the same event generated by System.Drawing.Printing.PrintDocument object.
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | Scroll | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from UserControl).
Public event | Validated | Occurs when .
Public event | Validating | Occurs when .
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

PrintPreview Class


AutoSizeChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoSizeChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoSizeChangedEventHandler AutoSizeChanged
delegate void AutoSizeChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


AutoValidateChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event AutoValidateChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event AutoValidateChangedEventHandler AutoValidateChanged
delegate void AutoValidateChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


BackColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BackColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BackColorChangedEventHandler BackColorChanged
delegate void BackColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


BeginPrint Event

Occurs when the Print method is called and before the first page of the document prints. This is the same event generated by System.Drawing.Printing.PrintDocument object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Occurs when the Print method is called and before the first page of the document prints. This is the same event generated by System.Drawing.Printing.PrintDocument object.")> _
Public Event BeginPrint( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Occurs when the Print method is called and before the first page of the document prints. This is the same event generated by System.Drawing.Printing.PrintDocument object.")]
public event BeginPrintEventHandler BeginPrint
delegate void BeginPrintEventHandler(
   object sender,
   PrintEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: PrintEventArgs

Object variable of type System.Drawing.Printing.PrintEventArgs containing data related to this event.

Remarks

See Net Framework 2.x documentation for more details.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


BindingContextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event BindingContextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event BindingContextChangedEventHandler BindingContextChanged
delegate void BindingContextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


CausesValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event CausesValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event CausesValidationChangedEventHandler CausesValidationChanged
delegate void CausesValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


EndPrint Event

Occurs when the last page of the document has printed. This is the same event generated by System.Drawing.Printing.PrintDocument object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Occurs when the last page of the document has printed. This is the same event generated by System.Drawing.Printing.PrintDocument object.")> _
Public Event EndPrint( _
   ByVal sender As Object, _
   ByVal e As PrintEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Occurs when the last page of the document has printed. This is the same event generated by System.Drawing.Printing.PrintDocument object.")]
public event EndPrintEventHandler EndPrint
delegate void EndPrintEventHandler(
   object sender,
   PrintEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: PrintEventArgs

Object variable of type System.Drawing.Printing.PrintEventArgs containing data related to this event.

Remarks

See Net Framework 2.x documentation for more details.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


ForeColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event ForeColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ForeColorChangedEventHandler ForeColorChanged
delegate void ForeColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPage Event

Occurs when the output to print for the current page is needed. This is the same event generated by System.Drawing.Printing.PrintDocument object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Occurs when the output to print for the current page is needed. This is the same event generated by System.Drawing.Printing.PrintDocument object.")> _
Public Event PrintPage( _
   ByVal sender As Object, _
   ByVal e As PrintPageEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Occurs when the output to print for the current page is needed. This is the same event generated by System.Drawing.Printing.PrintDocument object.")]
public event PrintPageEventHandler PrintPage
delegate void PrintPageEventHandler(
   object sender,
   PrintPageEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: PrintPageEventArgs

Object variable of type System.Drawing.Printing.PrintPageEventArgs containing data related to this event.

Remarks

See Net Framework 2.x documentation for more details.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


Scroll Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Scroll( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ScrollEventHandler Scroll
delegate void ScrollEventHandler(
   object sender,
   ScrollEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: ScrollEventArgs

An ScrollEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


Validated Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatedEventHandler Validated
delegate void ValidatedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


Validating Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Event Validating( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public event ValidatingEventHandler Validating
delegate void ValidatingEventHandler(
   object sender,
   CancelEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: CancelEventArgs

An CancelEventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


ProgressBar Class

Members

Softgroup .Net ProgressBar control is an advanced progress bar controls with orientation and gradients effects.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Softgroup.NetControls.ProgressBar), "ProgressBar")> _
<DefaultEvent("ValueChanged")> _
<DefaultProperty("Value")> _
Public Class ProgressBar
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Softgroup.NetControls.ProgressBar), "ProgressBar")]
[DefaultEvent("ValueChanged")]
[DefaultProperty("Value")]
public class ProgressBar : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ProgressBar
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Members


ProgressBar Members

ProgressBar Class Events Methods Properties See Also

Softgroup .Net ProgressBar control is an advanced progress bar controls with orientation and gradients effects.

The following tables list the members exposed by the ProgressBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFillColor | Gets the default fill color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FillColor | Gets/Sets the color you see when there's an absense of value. As the Value nears the Max, you see less of this color.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets the gradient color that is blended with "BackColor" if the "Gradient" property is True.
Public property | GradientDirection | If "GradientBackground" is True, this determines what type of gradient effect will be used.
Public property | GradientEnabled | If True, the value of "GraDientColor" will be blended with "BackColor" in a Gradient effect.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | Maximum | Gets/sets the maximum value of the ProgressBar
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/sets the minimum value of the ProgressBar.
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TextPercent | Gets/Sets if text percentage is visible
Public property | TextVisible | If set to TRUE, the current percentage of the ProgressBar is displayed to the user.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/sets the current value of the ProgressBar
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be raised every time progress value changes
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressBar Class


ProgressBar Properties

ProgressBar Class See Also

The following tables list the members exposed by the ProgressBar type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BorderStyle | Gets/sets the border style for control.
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFillColor | Gets the default fill color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | FillColor | Gets/Sets the color you see when there's an absense of value. As the Value nears the Max, you see less of this color.
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | GradientColor | Gets/Sets the gradient color that is blended with "BackColor" if the "Gradient" property is True.
Public property | GradientDirection | If "GradientBackground" is True, this determines what type of gradient effect will be used.
Public property | GradientEnabled | If True, the value of "GraDientColor" will be blended with "BackColor" in a Gradient effect.
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | Maximum | Gets/sets the maximum value of the ProgressBar
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/sets the minimum value of the ProgressBar.
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TextPercent | Gets/Sets if text percentage is visible
Public property | TextVisible | If set to TRUE, the current percentage of the ProgressBar is displayed to the user.
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/sets the current value of the ProgressBar
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ProgressBar Class


ProgressBar.BackgroundImage Property

ProgressBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.BackgroundImageLayout Property

ProgressBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.BorderStyle Property

Gets/sets the border style for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<DefaultValue(GetType(System.Windows.Forms.BorderStyle), "None")> _
<Description("Gets/sets the border style for control.")> _
Public Property BorderStyle( _
   ByRef GetType As Object, _
   ByRef "None" As Object _
) As BorderStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[DefaultValue(GetType(System.Windows.Forms.BorderStyle), "None")]
[Description("Gets/sets the border style for control.")]
[System.Runtime.CompilerServices.IndexerName("BorderStyle")]
public BorderStyle this[
   ref object GetType,
   ref object "None"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"None"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property CausesValidation() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool CausesValidation {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.DefaultFillColor Property

Gets the default fill color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default fill color.")> _
Public ReadOnly Shared Property DefaultFillColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default fill color.")]
public static Color DefaultFillColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.DefaultGradientColor Property

Gets the default gradient color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default gradient color.")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default gradient color.")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.FillColor Property

Gets/Sets the color you see when there's an absense of value. As the Value nears the Max, you see less of this color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("Gets/Sets the color you see when there's an absense of value.  As the Value nears the Max, you see less of this color.")> _
<DefaultValue(GetType(System.Drawing.Color), "Snow")> _
Public Property FillColor( _
   ByRef "Gets/Sets the color you see when there's an absense of value.  As the Value nears the Max, you see less of this color." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("Gets/Sets the color you see when there's an absense of value.  As the Value nears the Max, you see less of this color.")]
[DefaultValue(GetType(System.Drawing.Color), "Snow")]
[System.Runtime.CompilerServices.IndexerName("FillColor")]
public Color this[
   ref object "Gets/Sets the color you see when there's an absense of value.  As the Value nears the Max, you see less of this color."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the color you see when there's an absense of value. As the Value nears the Max, you see less of this color."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.GradientColor Property

Gets/Sets the gradient color that is blended with "BackColor" if the "Gradient" property is True.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("Gets/Sets the gradient color that is blended with ""BackColor"" if the ""Gradient"" property is True.")> _
<DefaultValue(GetType(System.Drawing.Color), "ControlDark")> _
Public Property GradientColor( _
   ByRef "Gets/Sets the gradient color that is blended with ""BackColor"" if the ""Gradient"" property is True." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("Gets/Sets the gradient color that is blended with ""BackColor"" if the ""Gradient"" property is True.")]
[DefaultValue(GetType(System.Drawing.Color), "ControlDark")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "Gets/Sets the gradient color that is blended with ""BackColor"" if the ""Gradient"" property is True."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the gradient color that is blended with ""BackColor"" if the ""Gradient"" property is True."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.GradientDirection Property

If "GradientBackground" is True, this determines what type of gradient effect will be used.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("If ""GradientBackground"" is True, this determines what type of gradient effect will be used.")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")> _
Public Property GradientDirection( _
   ByRef "If ""GradientBackground"" is True, this determines what type of gradient effect will be used." As Object _
) As LinearGradientMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("If ""GradientBackground"" is True, this determines what type of gradient effect will be used.")]
[DefaultValue(GetType(System.Drawing.Drawing2D.LinearGradientMode), "Horizontal")]
[System.Runtime.CompilerServices.IndexerName("GradientDirection")]
public LinearGradientMode this[
   ref object "If ""GradientBackground"" is True, this determines what type of gradient effect will be used."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"If ""GradientBackground"" is True, this determines what type of gradient effect will be used."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.GradientEnabled Property

If True, the value of "GraDientColor" will be blended with "BackColor" in a Gradient effect.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("If True, the value of ""GraDientColor"" will be blended with ""BackColor"" in a Gradient effect.")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "If True, the value of ""GraDientColor"" will be blended with ""BackColor"" in a Gradient effect." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("If True, the value of ""GraDientColor"" will be blended with ""BackColor"" in a Gradient effect.")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "If True, the value of ""GraDientColor"" will be blended with ""BackColor"" in a Gradient effect."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"If True, the value of ""GraDientColor"" will be blended with ""BackColor"" in a Gradient effect."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Margin Property

ProgressBar Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Maximum Property

Gets/sets the maximum value of the ProgressBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("Gets/sets the maximum value of the ProgressBar")> _
<DefaultValue(100)> _
Public Property Maximum( _
   ByRef "Gets/sets the maximum value of the ProgressBar" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("Gets/sets the maximum value of the ProgressBar")]
[DefaultValue(100)]
[System.Runtime.CompilerServices.IndexerName("Maximum")]
public int this[
   ref object "Gets/sets the maximum value of the ProgressBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the maximum value of the ProgressBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Minimum Property

Gets/sets the minimum value of the ProgressBar.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("Gets/sets the minimum value of the ProgressBar.")> _
<DefaultValue(0)> _
Public Property Minimum( _
   ByRef "Gets/sets the minimum value of the ProgressBar." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("Gets/sets the minimum value of the ProgressBar.")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("Minimum")]
public int this[
   ref object "Gets/sets the minimum value of the ProgressBar."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the minimum value of the ProgressBar."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Orientation Property

Gets/Sets control orientation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Gets/Sets control orientation")> _
<DefaultValue(GetType(Orientation), "Horizontal")> _
Public Property Orientation() As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[RefreshProperties(RefreshProperties.All)]
[Description("Gets/Sets control orientation")]
[DefaultValue(GetType(Orientation), "Horizontal")]
public Orientation Orientation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property RightToLeft() As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public RightToLeft RightToLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.TextPercent Property

Gets/Sets if text percentage is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets if text percentage is visible")> _
<Category("ProgressBar")> _
<DefaultValue(True)> _
Public Property TextPercent( _
   ByRef "ProgressBar" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets if text percentage is visible")]
[Category("ProgressBar")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("TextPercent")]
public bool this[
   ref object "ProgressBar"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBar"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.TextVisible Property

If set to TRUE, the current percentage of the ProgressBar is displayed to the user.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("If set to TRUE, the current percentage of the ProgressBar is displayed to the user.")> _
<DefaultValue(True)> _
Public Property TextVisible( _
   ByRef "If set to TRUE, the current percentage of the ProgressBar is displayed to the user." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("If set to TRUE, the current percentage of the ProgressBar is displayed to the user.")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("TextVisible")]
public bool this[
   ref object "If set to TRUE, the current percentage of the ProgressBar is displayed to the user."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"If set to TRUE, the current percentage of the ProgressBar is displayed to the user."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.Value Property

Gets/sets the current value of the ProgressBar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBar")> _
<Description("Gets/sets the current value of the ProgressBar.")> _
<DefaultValue(0)> _
Public Property Value( _
   ByRef "Gets/sets the current value of the ProgressBar." As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBar")]
[Description("Gets/sets the current value of the ProgressBar.")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("Value")]
public int this[
   ref object "Gets/sets the current value of the ProgressBar."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/sets the current value of the ProgressBar."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar Methods

ProgressBar Class See Also

The following tables list the members exposed by the ProgressBar type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ProgressBar Class


ProgressBar Events

ProgressBar Class See Also

The following tables list the members exposed by the ProgressBar type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be raised every time progress value changes
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressBar Class


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


CauseValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event CauseValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event CauseValidationChangedEventHandler CauseValidationChanged
delegate void CauseValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


RightToLeftChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event RightToLeftChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event RightToLeftChangedEventHandler RightToLeftChanged
delegate void RightToLeftChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ValueChanged Event

This event will be raised every time progress value changes

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangedEventHandler ValueChanged
delegate void ValueChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBlock Class

Members

Softgroup .Net ProgressBlock control is an highly customizable block progress bar control with orientation and gradient/glass effects.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(ProgressBlock), "ProgressBlock")> _
<DefaultEvent("ValueChanged")> _
<DefaultProperty("Value")> _
Public Class ProgressBlock
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(ProgressBlock), "ProgressBlock")]
[DefaultEvent("ValueChanged")]
[DefaultProperty("Value")]
public class ProgressBlock : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ProgressBlock
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Members


ProgressBlock Members

ProgressBlock Class Events Methods Properties See Also

Softgroup .Net ProgressBlock control is an highly customizable block progress bar control with orientation and gradient/glass effects.

The following tables list the members exposed by the ProgressBlock type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets background color of control
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BlockColor | Gets/Sets color used to drawn blocks
Public property | BlockSize | Gets/Sets blocks size in pixels
Public property | BlockSpacing | Gets/Sets spacing in pixels betweeen blocks
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultBlockColor | Gets the default block color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets/Sets foreground text color of control
Public property | GlassEffect | Gets/Sets if glass effect is enabled
Public property | GradientColor | Gets/Sets color for gradient effect
Public property | GradientEnabled | Gets/Sets if gradient mode is enabled
Public property | GradientFocus | Gets/Sets a value from 0 through 100 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).
Public property | GradientWrapMode | Gets/Sets Wrap mode for gradient effect
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | Maximum | Gets/Sets the maximim value for progress
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets the minimum value for progress
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TextPercent | Gets/Sets if text percentage is visible
Public property | TextVisible | Gets/Sets is progress value text is visible
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets current Value of the Progress Bar
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be generated every time progress Value changed.
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressBlock Class


ProgressBlock Properties

ProgressBlock Class See Also

The following tables list the members exposed by the ProgressBlock type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (Overloaded) Gets/Sets background color of control
Public property | BackgroundImage | (Overloaded) Gets or sets .
Public property | BackgroundImageLayout | (Overloaded) Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | BlockColor | Gets/Sets color used to drawn blocks
Public property | BlockSize | Gets/Sets blocks size in pixels
Public property | BlockSpacing | Gets/Sets spacing in pixels betweeen blocks
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultBlockColor | Gets the default block color.
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
 | DefaultGradientColor | Gets the default gradient color.
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (Overloaded) Gets/Sets foreground text color of control
Public property | GlassEffect | Gets/Sets if glass effect is enabled
Public property | GradientColor | Gets/Sets color for gradient effect
Public property | GradientEnabled | Gets/Sets if gradient mode is enabled
Public property | GradientFocus | Gets/Sets a value from 0 through 100 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).
Public property | GradientWrapMode | Gets/Sets Wrap mode for gradient effect
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (Overloaded) Gets or sets .
Public property | Maximum | Gets/Sets the maximim value for progress
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets the minimum value for progress
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | (Overloaded) Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | TextPercent | Gets/Sets if text percentage is visible
Public property | TextVisible | Gets/Sets is progress value text is visible
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets current Value of the Progress Bar
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ProgressBlock Class


ProgressBlock.BackColor Property

ProgressBlock Class See Also

Gets/Sets background color of control

Overload List
Name | Description
this[ref object] | Gets/Sets background color of control
BackColor | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BackgroundImage Property

ProgressBlock Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImage | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BackgroundImageLayout Property

ProgressBlock Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
BackgroundImageLayout | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BlockColor Property

Gets/Sets color used to drawn blocks

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets color used to drawn blocks")> _
<Category("ProgressBlock")> _
<DefaultValue(GetType(System.Drawing.Color), "Lime")> _
Public Property BlockColor( _
   ByRef "ProgressBlock" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets color used to drawn blocks")]
[Category("ProgressBlock")]
[DefaultValue(GetType(System.Drawing.Color), "Lime")]
[System.Runtime.CompilerServices.IndexerName("BlockColor")]
public Color this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BlockSize Property

Gets/Sets blocks size in pixels

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets blocks size in pixels")> _
<Category("ProgressBlock")> _
<DefaultValue(CByte(6))> _
Public Property BlockSize( _
   ByRef "ProgressBlock" As Object _
) As Byte
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets blocks size in pixels")]
[Category("ProgressBlock")]
[DefaultValue(CByte(6))]
[System.Runtime.CompilerServices.IndexerName("BlockSize")]
public byte this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BlockSpacing Property

Gets/Sets spacing in pixels betweeen blocks

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets spacing in pixels betweeen blocks")> _
<Category("ProgressBlock")> _
<DefaultValue(CByte(2))> _
Public Property BlockSpacing( _
   ByRef "ProgressBlock" As Object _
) As Byte
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets spacing in pixels betweeen blocks")]
[Category("ProgressBlock")]
[DefaultValue(CByte(2))]
[System.Runtime.CompilerServices.IndexerName("BlockSpacing")]
public byte this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property CausesValidation() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool CausesValidation {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.DefaultBlockColor Property

Gets the default block color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default block color.")> _
Public ReadOnly Shared Property DefaultBlockColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default block color.")]
public static Color DefaultBlockColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.DefaultGradientColor Property

Gets the default gradient color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the default gradient color.")> _
Public ReadOnly Shared Property DefaultGradientColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the default gradient color.")]
public static Color DefaultGradientColor {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.ForeColor Property

ProgressBlock Class See Also

Gets/Sets foreground text color of control

Overload List
Name | Description
this[ref object] | Gets/Sets foreground text color of control
ForeColor | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.GlassEffect Property

Gets/Sets if glass effect is enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets if glass effect is enabled")> _
<Category("ProgressBlock")> _
<DefaultValue(False)> _
Public Property GlassEffect( _
   ByRef "ProgressBlock" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets if glass effect is enabled")]
[Category("ProgressBlock")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GlassEffect")]
public bool this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.GradientColor Property

Gets/Sets color for gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets color for gradient effect")> _
<Category("ProgressBlock")> _
<DefaultValue(GetType(System.Drawing.Color), "Silver")> _
Public Property GradientColor( _
   ByRef "ProgressBlock" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets color for gradient effect")]
[Category("ProgressBlock")]
[DefaultValue(GetType(System.Drawing.Color), "Silver")]
[System.Runtime.CompilerServices.IndexerName("GradientColor")]
public Color this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.GradientEnabled Property

Gets/Sets if gradient mode is enabled

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBlock")> _
<Description("Gets/Sets if gradient mode is enabled")> _
<DefaultValue(False)> _
Public Property GradientEnabled( _
   ByRef "Gets/Sets if gradient mode is enabled" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBlock")]
[Description("Gets/Sets if gradient mode is enabled")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("GradientEnabled")]
public bool this[
   ref object "Gets/Sets if gradient mode is enabled"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if gradient mode is enabled"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.GradientFocus Property

Gets/Sets a value from 0 through 100 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets a value from 0 through 100 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).")> _
<Category("ProgressBlock")> _
<DefaultValue(100)> _
Public Property GradientFocus( _
   ByRef "ProgressBlock" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets a value from 0 through 100 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).")]
[Category("ProgressBlock")]
[DefaultValue(100)]
[System.Runtime.CompilerServices.IndexerName("GradientFocus")]
public int this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.GradientWrapMode Property

Gets/Sets Wrap mode for gradient effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBlock")> _
<Description("Gets/Sets Wrap mode for gradient effect")> _
<DefaultValue(GetType(System.Drawing.Drawing2D.WrapMode), "Tile")> _
Public Property GradientWrapMode( _
   ByRef "Gets/Sets Wrap mode for gradient effect" As Object _
) As WrapMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBlock")]
[Description("Gets/Sets Wrap mode for gradient effect")]
[DefaultValue(GetType(System.Drawing.Drawing2D.WrapMode), "Tile")]
[System.Runtime.CompilerServices.IndexerName("GradientWrapMode")]
public WrapMode this[
   ref object "Gets/Sets Wrap mode for gradient effect"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets Wrap mode for gradient effect"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Margin Property

ProgressBlock Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Margin | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Maximum Property

Gets/Sets the maximim value for progress

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.Repaint)> _
<Category("ProgressBlock")> _
<Description("Gets/Sets the maximum value for progress")> _
<DefaultValue(100)> _
Public Property Maximum( _
   ByRef "ProgressBlock" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.Repaint)]
[Category("ProgressBlock")]
[Description("Gets/Sets the maximum value for progress")]
[DefaultValue(100)]
[System.Runtime.CompilerServices.IndexerName("Maximum")]
public int this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Minimum Property

Gets/Sets the minimum value for progress

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.Repaint)> _
<Category("ProgressBlock")> _
<Description("Gets/Sets the minimum value for progress")> _
<DefaultValue(0)> _
Public Property Minimum( _
   ByRef "ProgressBlock" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.Repaint)]
[Category("ProgressBlock")]
[Description("Gets/Sets the minimum value for progress")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("Minimum")]
public int this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Orientation Property

Gets/Sets control orientation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressBlock")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Gets/Sets control orientation")> _
<DefaultValue(GetType(Orientation), "Horizontal")> _
Public Property Orientation() As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressBlock")]
[RefreshProperties(RefreshProperties.All)]
[Description("Gets/Sets control orientation")]
[DefaultValue(GetType(Orientation), "Horizontal")]
public Orientation Orientation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Padding Property

ProgressBlock Class See Also

Gets or sets .

Overload List
Name | Description
this[ref object] | Gets or sets .
Padding | (System.Windows.Forms.Control).
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property RightToLeft() As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public RightToLeft RightToLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.TextPercent Property

Gets/Sets if text percentage is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets if text percentage is visible")> _
<Category("ProgressBlock")> _
<DefaultValue(True)> _
Public Property TextPercent( _
   ByRef "ProgressBlock" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets if text percentage is visible")]
[Category("ProgressBlock")]
[DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("TextPercent")]
public bool this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.TextVisible Property

Gets/Sets is progress value text is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets is progress value text is visible")> _
<Category("ProgressBlock")> _
<DefaultValue(False)> _
Public Property TextVisible( _
   ByRef "ProgressBlock" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets is progress value text is visible")]
[Category("ProgressBlock")]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("TextVisible")]
public bool this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Value Property

Gets/Sets current Value of the Progress Bar

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.Repaint)> _
<Category("ProgressBlock")> _
<Description("Gets/Sets current Value of the Progress Bar")> _
<DefaultValue(0)> _
Public Property Value( _
   ByRef "ProgressBlock" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.Repaint)]
[Category("ProgressBlock")]
[Description("Gets/Sets current Value of the Progress Bar")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("Value")]
public int this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock Methods

ProgressBlock Class See Also

The following tables list the members exposed by the ProgressBlock type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ProgressBlock Class


ProgressBlock Events

ProgressBlock Class See Also

The following tables list the members exposed by the ProgressBlock type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | This event will be generated every time progress Value changed.
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressBlock Class


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


CauseValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event CauseValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event CauseValidationChangedEventHandler CauseValidationChanged
delegate void CauseValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


RightToLeftChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event RightToLeftChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event RightToLeftChangedEventHandler RightToLeftChanged
delegate void RightToLeftChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ValueChanged Event

This event will be generated every time progress Value changed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("This event will be generated every time progress Value changed.")> _
Public Event ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("This event will be generated every time progress Value changed.")]
public event ValueChangedEventHandler ValueChanged
delegate void ValueChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressLed Class

Members

Softgroup ProgressLed is a graphic control that mimics a Led numeric display

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(ProgressLed), "ProgressLed")> _
<DefaultEvent("ValueChanged")> _
<DefaultProperty("Text")> _
Public Class ProgressLed
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(ProgressLed), "ProgressLed")]
[DefaultEvent("ValueChanged")]
[DefaultProperty("Text")]
public class ProgressLed : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ProgressLed
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Members


ProgressLed Members

ProgressLed Class Events Methods Properties See Also

Softgroup ProgressLed is a graphic control that mimics a Led numeric display

The following tables list the members exposed by the ProgressLed type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets/Sets background color of control
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisabledColor | Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets/Sets foreground color of control
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets/Sets the value for all leds as text (text can contains a number from 0 o 9 or (-) minus character or a dot (.)
Public property | ToolTipBackColor | Gets/Sets the background color of tooltip
Public property | ToolTipDisplay | Gets/Sets tooltip display mode
Public property | ToolTipForeColor | Gets/Sets the foreground color of tooltip
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets single value for specified led position
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetValue | Sets single value to display for specified led position and optionally display a point
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | ToolTipShowing | ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | ValueChanged event will be generated when control Value was changed
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressLed Class


ProgressLed Properties

ProgressLed Class See Also

The following tables list the members exposed by the ProgressLed type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets/Sets background color of control
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisabledColor | Gets or sets .
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets/Sets foreground color of control
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets/Sets the value for all leds as text (text can contains a number from 0 o 9 or (-) minus character or a dot (.)
Public property | ToolTipBackColor | Gets/Sets the background color of tooltip
Public property | ToolTipDisplay | Gets/Sets tooltip display mode
Public property | ToolTipForeColor | Gets/Sets the foreground color of tooltip
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets single value for specified led position
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ProgressLed Class


ProgressLed.BackColor Property

Gets/Sets background color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets background color of control")> _
<DefaultValue(GetType(Color), "Black")> _
Public Overrides Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets background color of control")]
[DefaultValue(GetType(Color), "Black")]
public override Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property CausesValidation() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool CausesValidation {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.DisabledColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Led")> _
<Description("Gets/Sets the disabled color")> _
<DefaultValue(GetType(Color), "Gray")> _
Public Property DisabledColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Led")]
[Description("Gets/Sets the disabled color")]
[DefaultValue(GetType(Color), "Gray")]
public Color DisabledColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.ForeColor Property

Gets/Sets foreground color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets foreground color of control")> _
<DefaultValue(GetType(Color), "Red")> _
Public Overrides Property ForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets foreground color of control")]
[DefaultValue(GetType(Color), "Red")]
public override Color ForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Margin() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Margin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property RightToLeft() As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public RightToLeft RightToLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.Text Property

Gets/Sets the value for all leds as text (text can contains a number from 0 o 9 or (-) minus character or a dot (.)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets the value for all leds as text (text can contains a number from 0 o 9 or (-) minus character or a dot (.)")> _
<DefaultValue("    ")> _
Public Overrides Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets the value for all leds as text (text can contains a number from 0 o 9 or (-) minus character or a dot (.)")]
[DefaultValue("    ")]
public override string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.ToolTipBackColor Property

Gets/Sets the background color of tooltip

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets the background color of tooltip")> _
<DefaultValue(GetType(Color), "Info")> _
Public Property ToolTipBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets the background color of tooltip")]
[DefaultValue(GetType(Color), "Info")]
public Color ToolTipBackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.ToolTipDisplay Property

Gets/Sets tooltip display mode

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets tooltip display mode")> _
<DefaultValue(False)> _
Public Property ToolTipDisplay() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets tooltip display mode")]
[DefaultValue(False)]
public bool ToolTipDisplay {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.ToolTipForeColor Property

Gets/Sets the foreground color of tooltip

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressLed")> _
<Description("Gets/Sets the foreground color of tooltip")> _
<DefaultValue(GetType(Color), "InfoText")> _
Public Property ToolTipForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressLed")]
[Description("Gets/Sets the foreground color of tooltip")]
[DefaultValue(GetType(Color), "InfoText")]
public Color ToolTipForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed.Value Property

Gets/Sets single value for specified led position

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<Category("ProgressLed")> _
<Description("Gets/Sets single value for specified led position")> _
<DefaultValue(0)> _
Public Property Value( _
   ByVal iPosition As Integer _
) As Char
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[Category("ProgressLed")]
[Description("Gets/Sets single value for specified led position")]
[DefaultValue(0)]
[System.Runtime.CompilerServices.IndexerName("Value")]
public char this[
   int iPosition
] {get; set;}
This language is not supported or no code example is available.

Parameters

iPosition

Type: int

Led Index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed Methods

ProgressLed Class See Also

The following tables list the members exposed by the ProgressLed type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SetValue | Sets single value to display for specified led position and optionally display a point
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ProgressLed Class


ProgressLed.SetValue Method

Sets single value to display for specified led position and optionally display a point

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetValue( _
   ByVal iPosition As Integer, _
   ByVal sChar As Char, _
   ByVal bDisplayDot As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetValue(
   int iPosition,
   char sChar,
   bool bDisplayDot
)
This language is not supported or no code example is available.

Parameters

iPosition

Type: int

Led Index

sChar

Type: char

A char value

bDisplayDot

Type: bool

If True a point will be displayed otherwise False.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLed Events

ProgressLed Class See Also

The following tables list the members exposed by the ProgressLed type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | (inherited from Control).
Public event | ToolTipShowing | ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChanged | ValueChanged event will be generated when control Value was changed
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressLed Class


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


CauseValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event CauseValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event CauseValidationChangedEventHandler CauseValidationChanged
delegate void CauseValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


RightToLeftChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event RightToLeftChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event RightToLeftChangedEventHandler RightToLeftChanged
delegate void RightToLeftChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ToolTipShowing Event

ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ToolTipShowing( _
   ByVal sender As Object, _
   ByVal e As ProgressLedEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ToolTipShowingEventHandler ToolTipShowing
delegate void ToolTipShowingEventHandler(
   object sender,
   ProgressLedEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: ProgressLedEventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ValueChanged Event

ValueChanged event will be generated when control Value was changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangedEventHandler ValueChanged
delegate void ValueChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLed Class
ProgressLed Members


ProgressLedEventArgs Class

Members

Class ProgressLedEventArgs provide parameters events for ProgressLed control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ProgressLedEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ProgressLedEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ProgressLedEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLedEventArgs Members


ProgressLedEventArgs Members

ProgressLedEventArgs Class Constructors Methods Properties See Also

Class ProgressLedEventArgs provide parameters events for ProgressLed control.

The following tables list the members exposed by the ProgressLedEventArgs type.

Constructors
 | Name | Description
Public constructor | ProgressLedEventArgs Constructor | Initializes a new instance of the ProgressLedEventArgs class.
Top
Properties
 | Name | Description
Public property | Text | Return the text.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ProgressLedEventArgs Class


ProgressLedEventArgs Constructor

Initializes a new instance of the ProgressLedEventArgs class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ProgressLedEventArgs(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLedEventArgs Class
ProgressLedEventArgs Members


ProgressLedEventArgs Properties

ProgressLedEventArgs Class See Also

The following tables list the members exposed by the ProgressLedEventArgs type.

Properties
 | Name | Description
Public property | Text | Return the text.
Top
See Also

Reference

ProgressLedEventArgs Class


ProgressLedEventArgs.Text Property

Return the text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLedEventArgs Class
ProgressLedEventArgs Members


ProgressLedEventArgs Methods

ProgressLedEventArgs Class See Also

The following tables list the members exposed by the ProgressLedEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ProgressLedEventArgs Class


ProgressLoop Class

Members

Softgroup .Net ProgressLoop control is an advanced loading loop control that can emulate IE, FireFox and MacOSX progress style.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultEvent("LoopProgress")> _
<DefaultProperty("Started")> _
<System.Drawing.ToolboxBitmap(GetType(ProgressLoop), "ProgressLoop.bmp")> _
Public Class ProgressLoop
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultEvent("LoopProgress")]
[DefaultProperty("Started")]
[System.Drawing.ToolboxBitmap(GetType(ProgressLoop), "ProgressLoop.bmp")]
public class ProgressLoop : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ProgressLoop
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Members


ProgressLoop Members

ProgressLoop Class Events Methods Properties See Also

Softgroup .Net ProgressLoop control is an advanced loading loop control that can emulate IE, FireFox and MacOSX progress style.

The following tables list the members exposed by the ProgressLoop type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | LoopDensity | Gets or sets the number of progress loop lines.
Public property | LoopInnerRadius | Gets or sets the radius of progress loop inner circle.
Public property | LoopOuterRadius | Gets or sets the radius of progress loop outer circle.
Public property | LoopSpeed | Gets or sets the rotation progress loop speed.
Public property | LoopStyle | Gets/Sets the predefinied style of progress loop.
Public property | LoopThickness | Gets or sets the thickness of a loopline.
Public property | Margin | Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Started | Gets or sets if control animation is started (in progress).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | GetPreferredSize |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation progress.
Public method | Stop | Stop control animation progress.
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LoopProgress | This event will be generated every time loop speed time was reached and control need to be painted.
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressLoop Class


ProgressLoop Properties

ProgressLoop Class See Also

The following tables list the members exposed by the ProgressLoop type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | (inherited from Control).
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | (inherited from Control).
Public property | ForeColor | (inherited from Control).
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | LoopDensity | Gets or sets the number of progress loop lines.
Public property | LoopInnerRadius | Gets or sets the radius of progress loop inner circle.
Public property | LoopOuterRadius | Gets or sets the radius of progress loop outer circle.
Public property | LoopSpeed | Gets or sets the rotation progress loop speed.
Public property | LoopStyle | Gets/Sets the predefinied style of progress loop.
Public property | LoopThickness | Gets or sets the thickness of a loopline.
Public property | Margin | Gets or sets .
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | Started | Gets or sets if control animation is started (in progress).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (Overloaded) Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ProgressLoop Class


ProgressLoop.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property CausesValidation() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool CausesValidation {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopDensity Property

Gets or sets the number of progress loop lines.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets the number of progress loop lines.")> _
<DefaultValue(DefaultLoopDensity)> _
<Category("ProgressLoop")> _
Public Property LoopDensity( _
   ByRef DefaultLoopDensity As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets the number of progress loop lines.")]
[DefaultValue(DefaultLoopDensity)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopDensity")]
public int this[
   ref object DefaultLoopDensity
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultLoopDensity

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopInnerRadius Property

Gets or sets the radius of progress loop inner circle.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets the radius of progress loop inner circle.")> _
<DefaultValue(DefaultInnerCircleRadius)> _
<Category("ProgressLoop")> _
Public Property LoopInnerRadius( _
   ByRef DefaultInnerCircleRadius As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets the radius of progress loop inner circle.")]
[DefaultValue(DefaultInnerCircleRadius)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopInnerRadius")]
public int this[
   ref object DefaultInnerCircleRadius
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultInnerCircleRadius

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopOuterRadius Property

Gets or sets the radius of progress loop outer circle.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets the radius of progress loop outer circle.")> _
<DefaultValue(DefaultOuterCircleRadius)> _
<Category("ProgressLoop")> _
Public Property LoopOuterRadius( _
   ByRef DefaultOuterCircleRadius As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets the radius of progress loop outer circle.")]
[DefaultValue(DefaultOuterCircleRadius)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopOuterRadius")]
public int this[
   ref object DefaultOuterCircleRadius
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultOuterCircleRadius

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopSpeed Property

Gets or sets the rotation progress loop speed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets the rotation progress loop speed.")> _
<DefaultValue(100)> _
<Category("ProgressLoop")> _
Public Property LoopSpeed( _
   ByRef 100 As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets the rotation progress loop speed.")]
[DefaultValue(100)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopSpeed")]
public int this[
   ref object 100
] {get; set;}
This language is not supported or no code example is available.

Parameters

100

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopStyle Property

Gets/Sets the predefinied style of progress loop.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets the predefinied style of progress loop.")> _
<DefaultValue(GetType(LoopStyleEnum), "Default")> _
<Category("ProgressLoop")> _
Public Property LoopStyle( _
   ByRef GetType As Object, _
   ByRef "Default" As Object _
) As LoopStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets the predefinied style of progress loop.")]
[DefaultValue(GetType(LoopStyleEnum), "Default")]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopStyle")]
public LoopStyleEnum this[
   ref object GetType,
   ref object "Default"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Default"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.LoopThickness Property

Gets or sets the thickness of a loopline.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets the thickness of a loopline.")> _
<DefaultValue(DefaultLoopLineThickness)> _
<Category("ProgressLoop")> _
Public Property LoopThickness( _
   ByRef DefaultLoopLineThickness As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets the thickness of a loopline.")]
[DefaultValue(DefaultLoopLineThickness)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("LoopThickness")]
public int this[
   ref object DefaultLoopLineThickness
] {get; set;}
This language is not supported or no code example is available.

Parameters

DefaultLoopLineThickness

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Margin() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Margin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property RightToLeft() As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public RightToLeft RightToLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Started Property

Gets or sets if control animation is started (in progress).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets or sets if control animation is started (in progress).")> _
<DefaultValue(False)> _
<Category("ProgressLoop")> _
Public Property Started( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets or sets if control animation is started (in progress).")]
[DefaultValue(False)]
[Category("ProgressLoop")]
[System.Runtime.CompilerServices.IndexerName("Started")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.TabStop Property

ProgressLoop Class See Also

Gets or sets a value indicating whether .

Overload List
Name | Description
this[ref object] | Gets or sets a value indicating whether .
TabStop | (System.Windows.Forms.Control).
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop Methods

ProgressLoop Class See Also

The following tables list the members exposed by the ProgressLoop type.

Methods
 | Name | Description
Public method | GetPreferredSize |
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation progress.
Public method | Stop | Stop control animation progress.
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ProgressLoop Class


ProgressLoop.GetPreferredSize Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Overrides Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override Size GetPreferredSize(
   Size proposedSize
)
This language is not supported or no code example is available.

Parameters

proposedSize

Type: Size

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Start Method

Start control animation progress.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Start control animation progress.")> _
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Start control animation progress.")]
public System.Void Start()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop.Stop Method

Stop control animation progress.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Stop control animation progress.")> _
Public Sub Stop()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Stop control animation progress.")]
public System.Void Stop()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressLoop Events

ProgressLoop Class See Also

The following tables list the members exposed by the ProgressLoop type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | (inherited from Control).
Public event | ForeColorChanged | (inherited from Control).
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LoopProgress | This event will be generated every time loop speed time was reached and control need to be painted.
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressLoop Class


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


CauseValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event CauseValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event CauseValidationChangedEventHandler CauseValidationChanged
delegate void CauseValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


LoopProgress Event

This event will be generated every time loop speed time was reached and control need to be painted.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("This event will be generated every time loop speed time was reached and control need to be painted.")> _
Public Event LoopProgress( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("This event will be generated every time loop speed time was reached and control need to be painted.")]
public event LoopProgressEventHandler LoopProgress
delegate void LoopProgressEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


RightToLeftChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event RightToLeftChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event RightToLeftChangedEventHandler RightToLeftChanged
delegate void RightToLeftChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressSlider Class

Members

Softgroup ProgressSlider is a enhanced trackbar control that display a progress slider with orientation and thumb button with various styles and effects

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(ProgressLed), "ProgressSlider")> _
<DefaultEvent("ValueChanged")> _
<DefaultProperty("Value")> _
Public Class ProgressSlider
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(ProgressLed), "ProgressSlider")]
[DefaultEvent("ValueChanged")]
[DefaultProperty("Value")]
public class ProgressSlider : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.ProgressSlider
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Members


ProgressSlider Members

ProgressSlider Class Events Methods Properties See Also

Softgroup ProgressSlider is a enhanced trackbar control that display a progress slider with orientation and thumb button with various styles and effects

The following tables list the members exposed by the ProgressSlider type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether .
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets/Sets background color of control
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LargeChange | Gets/Sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | Maximum | Gets/Sets maximum value for the position of the slider
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets minimum value for the value position
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SmallChange | Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | ThumbBorderColor | Gets/Sets thumb border color
Public property | ThumbColor1 | Gets/Sets first thumb color (background)
Public property | ThumbColor2 | Gets/Sets second thumb color (gradient/focus)
Public property | ThumbCornerRadius | Gets/Set thumb corner radius
Public property | ThumbSize | Gets/Sets thumb size
Public property | ThumbStyle | Gets/Sets thumb button style
Public property | ThumbVisible | Gets/Sets if thumb is visible
Public property | TickColor | Gets/Sets slider tick color
Public property | TickStyle | Gets/Sets the tick drawing style
Public property | TickType | Gets/Sets the tick drawing type
Public property | ToolTipBackColor | Gets/Sets the background color of tooltip
Public property | ToolTipDisplay | Gets/Sets tooltip display mode
Public property | ToolTipForeColor | Gets/Sets the foreground color of tooltip
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | TrackColor | Gets/Sets track color
Public property | TrackFillColor | Set the track portion fill color
Public property | TrackProgress | Gets/Sets if track portion must be drawn with progress value
Public property | TrackProgressColor | Gets/Sets track portion progress color
Public property | TrackShadow | Gets/Sets if track portion must be drawn with shadow effect
Public property | TrackSize | Adjust the slider track size
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets position value of the slider
Public property | ValueChanging | Return True if value is currently changing
Public property | Visible | (inherited from Control).
Public property | WheelScrollTicks | Gets/Sets number of positions the slider moves in response to mouse wheel
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | ToolTipShowing | ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChangeEnd | ValueChangeEnd event will be generated every time Value property changed
Public event | ValueChangeStart | ValueChangeStart event will be generated every time Value property will change
Public event | ValueChanged | ValueChanged event will be generated every time Value property change
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressSlider Class


ProgressSlider Properties

ProgressSlider Class See Also

The following tables list the members exposed by the ProgressSlider type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | Gets or sets a value indicating whether .
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets/Sets background color of control
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | Gets or sets a value indicating whether .
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | Gets or sets .
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LargeChange | Gets/Sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | Gets or sets .
Public property | Maximum | Gets/Sets maximum value for the position of the slider
Public property | MaximumSize | (inherited from Control).
Public property | Minimum | Gets/Sets minimum value for the value position
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Orientation | Gets/Sets control orientation
Public property | Padding | Gets or sets .
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | Gets or sets .
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | SmallChange | Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public property | TabIndex | (inherited from Control).
Public property | TabStop | (inherited from Control).
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | ThumbBorderColor | Gets/Sets thumb border color
Public property | ThumbColor1 | Gets/Sets first thumb color (background)
Public property | ThumbColor2 | Gets/Sets second thumb color (gradient/focus)
Public property | ThumbCornerRadius | Gets/Set thumb corner radius
Public property | ThumbSize | Gets/Sets thumb size
Public property | ThumbStyle | Gets/Sets thumb button style
Public property | ThumbVisible | Gets/Sets if thumb is visible
Public property | TickColor | Gets/Sets slider tick color
Public property | TickStyle | Gets/Sets the tick drawing style
Public property | TickType | Gets/Sets the tick drawing type
Public property | ToolTipBackColor | Gets/Sets the background color of tooltip
Public property | ToolTipDisplay | Gets/Sets tooltip display mode
Public property | ToolTipForeColor | Gets/Sets the foreground color of tooltip
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | TrackColor | Gets/Sets track color
Public property | TrackFillColor | Set the track portion fill color
Public property | TrackProgress | Gets/Sets if track portion must be drawn with progress value
Public property | TrackProgressColor | Gets/Sets track portion progress color
Public property | TrackShadow | Gets/Sets if track portion must be drawn with shadow effect
Public property | TrackSize | Adjust the slider track size
Public property | UseWaitCursor | (inherited from Control).
Public property | Value | Gets/Sets position value of the slider
Public property | ValueChanging | Return True if value is currently changing
Public property | Visible | (inherited from Control).
Public property | WheelScrollTicks | Gets/Sets number of positions the slider moves in response to mouse wheel
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

ProgressSlider Class


ProgressSlider.AllowDrop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property AllowDrop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool AllowDrop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.BackColor Property

Gets/Sets background color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets background color of control")> _
<DefaultValue(GetType(Color), "Control")> _
Public Overrides Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets background color of control")]
[DefaultValue(GetType(Color), "Control")]
public override Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property CausesValidation() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public bool CausesValidation {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property ForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Color ForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.LargeChange Property

Gets/Sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Gets/Sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.")> _
<DefaultValue(2)> _
Public Property LargeChange() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Gets/Sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.")]
[DefaultValue(2)]
public int LargeChange {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Margin() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Margin {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Maximum Property

Gets/Sets maximum value for the position of the slider

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Gets/Sets maximum value for the position of the slider")> _
<DefaultValue(100)> _
Public Property Maximum() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Gets/Sets maximum value for the position of the slider")]
[DefaultValue(100)]
public int Maximum {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Minimum Property

Gets/Sets minimum value for the value position

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Gets/Sets minimum value for the value position")> _
<DefaultValue(0)> _
Public Property Minimum() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Gets/Sets minimum value for the value position")]
[DefaultValue(0)]
public int Minimum {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Orientation Property

Gets/Sets control orientation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Gets/Sets control orientation")> _
<DefaultValue(GetType(Orientation), "Horizontal")> _
Public Property Orientation() As Orientation
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[RefreshProperties(RefreshProperties.All)]
[Description("Gets/Sets control orientation")]
[DefaultValue(GetType(Orientation), "Horizontal")]
public Orientation Orientation {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Padding() As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public Padding Padding {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property RightToLeft() As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public RightToLeft RightToLeft {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.SmallChange Property

Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.")> _
<DefaultValue(1)> _
Public Property SmallChange() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Gets/Sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.")]
[DefaultValue(1)]
public int SmallChange {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbBorderColor Property

Gets/Sets thumb border color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets thumb border color")> _
<DefaultValue(GetType(Color), "Gray")> _
Public Property ThumbBorderColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets thumb border color")]
[DefaultValue(GetType(Color), "Gray")]
public Color ThumbBorderColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbColor1 Property

Gets/Sets first thumb color (background)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets first thumb color (background)")> _
<DefaultValue(GetType(Color), "DimGray")> _
Public Property ThumbColor1() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets first thumb color (background)")]
[DefaultValue(GetType(Color), "DimGray")]
public Color ThumbColor1 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbColor2 Property

Gets/Sets second thumb color (gradient/focus)

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets second thumb color (gradient/focus)")> _
<DefaultValue(GetType(Color), "Black")> _
Public Property ThumbColor2() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets second thumb color (gradient/focus)")]
[DefaultValue(GetType(Color), "Black")]
public Color ThumbColor2 {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbCornerRadius Property

Gets/Set thumb corner radius

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<Description("Gets/Set thumb corner radius")> _
<DefaultValue(4)> _
Public Property ThumbCornerRadius() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[Description("Gets/Set thumb corner radius")]
[DefaultValue(4)]
public int ThumbCornerRadius {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbSize Property

Gets/Sets thumb size

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Gets/Sets thumb size")> _
<DefaultValue(GetType(Size), "14, 14")> _
Public Property ThumbSize() As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[RefreshProperties(RefreshProperties.All)]
[Description("Gets/Sets thumb size")]
[DefaultValue(GetType(Size), "14, 14")]
public Size ThumbSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbStyle Property

Gets/Sets thumb button style

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Gets/Sets thumb button style")> _
<DefaultValue(GetType(ThumbStyleEnum), "Circle1")> _
Public Property ThumbStyle() As ThumbStyleEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[RefreshProperties(RefreshProperties.All)]
[Description("Gets/Sets thumb button style")]
[DefaultValue(GetType(ThumbStyleEnum), "Circle1")]
public ThumbStyleEnum ThumbStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ThumbVisible Property

Gets/Sets if thumb is visible

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets if thumb is visible")> _
<DefaultValue(True)> _
Public Property ThumbVisible() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets if thumb is visible")]
[DefaultValue(True)]
public bool ThumbVisible {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TickColor Property

Gets/Sets slider tick color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets slider tick color")> _
<DefaultValue(GetType(Color), "DarkGray")> _
Public Property TickColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets slider tick color")]
[DefaultValue(GetType(Color), "DarkGray")]
public Color TickColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TickStyle Property

Gets/Sets the tick drawing style

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets the tick drawing style")> _
<DefaultValue(GetType(TickStyle), "None")> _
Public Property TickStyle() As TickStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets the tick drawing style")]
[DefaultValue(GetType(TickStyle), "None")]
public TickStyle TickStyle {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TickType Property

Gets/Sets the tick drawing type

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets the tick drawing type")> _
<DefaultValue(GetType(TickTypeEnum), "Standard")> _
Public Property TickType() As TickTypeEnum
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets the tick drawing type")]
[DefaultValue(GetType(TickTypeEnum), "Standard")]
public TickTypeEnum TickType {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ToolTipBackColor Property

Gets/Sets the background color of tooltip

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets the background color of tooltip")> _
<DefaultValue(GetType(Color), "Info")> _
Public Property ToolTipBackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets the background color of tooltip")]
[DefaultValue(GetType(Color), "Info")]
public Color ToolTipBackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ToolTipDisplay Property

Gets/Sets tooltip display mode

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets tooltip display mode")> _
<DefaultValue(True)> _
Public Property ToolTipDisplay() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets tooltip display mode")]
[DefaultValue(True)]
public bool ToolTipDisplay {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ToolTipForeColor Property

Gets/Sets the foreground color of tooltip

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets the foreground color of tooltip")> _
<DefaultValue(GetType(Color), "InfoText")> _
Public Property ToolTipForeColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets the foreground color of tooltip")]
[DefaultValue(GetType(Color), "InfoText")]
public Color ToolTipForeColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackColor Property

Gets/Sets track color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets track color")> _
<DefaultValue(GetType(Color), "Gainsboro")> _
Public Property TrackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets track color")]
[DefaultValue(GetType(Color), "Gainsboro")]
public Color TrackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackFillColor Property

Set the track portion fill color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Set the track fill color")> _
<DefaultValue(GetType(Color), "Transparent")> _
Public Property TrackFillColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Set the track fill color")]
[DefaultValue(GetType(Color), "Transparent")]
public Color TrackFillColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackProgress Property

Gets/Sets if track portion must be drawn with progress value

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets if track must be drawn with progress value")> _
<DefaultValue(False)> _
Public Property TrackProgress() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets if track must be drawn with progress value")]
[DefaultValue(False)]
public bool TrackProgress {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackProgressColor Property

Gets/Sets track portion progress color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets track progress color")> _
<DefaultValue(GetType(Color), "Highlight")> _
Public Property TrackProgressColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets track progress color")]
[DefaultValue(GetType(Color), "Highlight")]
public Color TrackProgressColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackShadow Property

Gets/Sets if track portion must be drawn with shadow effect

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets if track must be drawn with shadow effect")> _
<DefaultValue(False)> _
Public Property TrackShadow() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets if track must be drawn with shadow effect")]
[DefaultValue(False)]
public bool TrackShadow {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.TrackSize Property

Adjust the slider track size

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<RefreshProperties(RefreshProperties.All)> _
<Description("Adjust the slider track depth")> _
<DefaultValue(6)> _
Public Property TrackSize() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[RefreshProperties(RefreshProperties.All)]
[Description("Adjust the slider track depth")]
[DefaultValue(6)]
public int TrackSize {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.Value Property

Gets/Sets position value of the slider

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Gets/Sets value position of the slider")> _
<DefaultValue(0)> _
Public Property Value() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Gets/Sets value position of the slider")]
[DefaultValue(0)]
public int Value {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.ValueChanging Property

Return True if value is currently changing

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Return True if value is currently changing")> _
<Browsable(False)> _
Public ReadOnly Property ValueChanging() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Return True if value is currently changing")]
[Browsable(False)]
public bool ValueChanging {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider.WheelScrollTicks Property

Gets/Sets number of positions the slider moves in response to mouse wheel

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ProgressSlider")> _
<Description("Gets/Sets number of positions the slider moves in response to mouse wheel")> _
<DefaultValue(3)> _
Public Property WheelScrollTicks() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ProgressSlider")]
[Description("Gets/Sets number of positions the slider moves in response to mouse wheel")]
[DefaultValue(3)]
public int WheelScrollTicks {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSlider Methods

ProgressSlider Class See Also

The following tables list the members exposed by the ProgressSlider type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

ProgressSlider Class


ProgressSlider Events

ProgressSlider Class See Also

The following tables list the members exposed by the ProgressSlider type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | (inherited from Control).
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CauseValidationChanged | Occurs when .
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | (inherited from Control).
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | Occurs when .
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | Occurs when .
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | Occurs when .
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | ToolTipShowing | ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | ValueChangeEnd | ValueChangeEnd event will be generated every time Value property changed
Public event | ValueChangeStart | ValueChangeStart event will be generated every time Value property will change
Public event | ValueChanged | ValueChanged event will be generated every time Value property change
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

ProgressSlider Class


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


CauseValidationChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event CauseValidationChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event CauseValidationChangedEventHandler CauseValidationChanged
delegate void CauseValidationChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ForeColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event ForeColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event ForeColorChangedEventHandler ForeColorChanged
delegate void ForeColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


PaddingChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event PaddingChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event PaddingChangedEventHandler PaddingChanged
delegate void PaddingChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


RightToLeftChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event RightToLeftChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event RightToLeftChangedEventHandler RightToLeftChanged
delegate void RightToLeftChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ToolTipShowing Event

ToolTipShowing event will be generated immediatly before ToolTip text will be dispalyed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ToolTipShowing( _
   ByVal sender As Object, _
   ByVal e As ProgressSliderEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ToolTipShowingEventHandler ToolTipShowing
delegate void ToolTipShowingEventHandler(
   object sender,
   ProgressSliderEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: ProgressSliderEventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ValueChangeEnd Event

ValueChangeEnd event will be generated every time Value property changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChangeEnd( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangeEndEventHandler ValueChangeEnd
delegate void ValueChangeEndEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ValueChangeStart Event

ValueChangeStart event will be generated every time Value property will change

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChangeStart( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangeStartEventHandler ValueChangeStart
delegate void ValueChangeStartEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ValueChanged Event

ValueChanged event will be generated every time Value property change

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event ValueChangedEventHandler ValueChanged
delegate void ValueChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSlider Class
ProgressSlider Members


ProgressSliderEventArgs Class

Members

Class NetThumbnailMouseEventArgs provide parameters events for NetThumbnail control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ProgressSliderEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ProgressSliderEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ProgressSliderEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSliderEventArgs Members


ProgressSliderEventArgs Members

ProgressSliderEventArgs Class Constructors Methods Properties See Also

Class NetThumbnailMouseEventArgs provide parameters events for NetThumbnail control.

The following tables list the members exposed by the ProgressSliderEventArgs type.

Constructors
 | Name | Description
Public constructor | ProgressSliderEventArgs Constructor | Initializes a new instance of the ProgressSliderEventArgs class.
Top
Properties
 | Name | Description
Public property | Text | Return the text.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ProgressSliderEventArgs Class


ProgressSliderEventArgs Constructor

Initializes a new instance of the ProgressSliderEventArgs class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ProgressSliderEventArgs(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSliderEventArgs Class
ProgressSliderEventArgs Members


ProgressSliderEventArgs Properties

ProgressSliderEventArgs Class See Also

The following tables list the members exposed by the ProgressSliderEventArgs type.

Properties
 | Name | Description
Public property | Text | Return the text.
Top
See Also

Reference

ProgressSliderEventArgs Class


ProgressSliderEventArgs.Text Property

Return the text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressSliderEventArgs Class
ProgressSliderEventArgs Members


ProgressSliderEventArgs Methods

ProgressSliderEventArgs Class See Also

The following tables list the members exposed by the ProgressSliderEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ProgressSliderEventArgs Class


ResultClickEventArgs Class

Members

ResultClickEventArgs class defines event parameters for ResultClicke event of NetCalculator

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ResultClickEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ResultClickEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ResultClickEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ResultClickEventArgs Members


ResultClickEventArgs Members

ResultClickEventArgs Class Methods Properties See Also

ResultClickEventArgs class defines event parameters for ResultClicke event of NetCalculator

The following tables list the members exposed by the ResultClickEventArgs type.

Properties
 | Name | Description
Public property | EnterPressed | Gets a value indicating whether .
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ResultClickEventArgs Class


ResultClickEventArgs Properties

ResultClickEventArgs Class See Also

The following tables list the members exposed by the ResultClickEventArgs type.

Properties
 | Name | Description
Public property | EnterPressed | Gets a value indicating whether .
Top
See Also

Reference

ResultClickEventArgs Class


ResultClickEventArgs.EnterPressed Property

Gets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property EnterPressed() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public bool EnterPressed {get;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ResultClickEventArgs Class
ResultClickEventArgs Members


ResultClickEventArgs Methods

ResultClickEventArgs Class See Also

The following tables list the members exposed by the ResultClickEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ResultClickEventArgs Class


ToolStripColorPicker Class

Members

Softgroup .Net ToolStripColorPicker control is a ToolStripSplitButton that allows selecting a color from a color picker.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultEvent("SelectedColorChanged")> _
<DefaultProperty("Color")> _
<Description("Softgroup .Net ToolStripColorPicker control is a ToolStripSplitButton that allows selecting a color from a color picker.")> _
<ToolboxItem(False)> _
<ToolboxBitmap(GetType(ToolStripColorPicker), "ToolStripColorPicker")> _
<System.Windows.Forms.Design.ToolStripItemDesignerAvailability(System.Windows.Forms.Design.ToolStripItemDesignerAvailability.ToolStrip Or System.Windows.Forms.Design.ToolStripItemDesignerAvailability.StatusStrip)> _
Public Class ToolStripColorPicker
    Inherits ToolStripSplitButton
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultEvent("SelectedColorChanged")]
[DefaultProperty("Color")]
[Description("Softgroup .Net ToolStripColorPicker control is a ToolStripSplitButton that allows selecting a color from a color picker.")]
[ToolboxItem(False)]
[ToolboxBitmap(GetType(ToolStripColorPicker), "ToolStripColorPicker")]
[System.Windows.Forms.Design.ToolStripItemDesignerAvailability(System.Windows.Forms.Design.ToolStripItemDesignerAvailability.ToolStrip Or System.Windows.Forms.Design.ToolStripItemDesignerAvailability.StatusStrip)]
public class ToolStripColorPicker : ToolStripSplitButton
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.ToolStripItem
System.Windows.Forms.ToolStripDropDownItem
System.Windows.Forms.ToolStripSplitButton
Softgroup.NetControls.ToolStripColorPicker
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Members


ToolStripColorPicker Members

ToolStripColorPicker Class Constructors Events Methods Properties See Also

Softgroup .Net ToolStripColorPicker control is a ToolStripSplitButton that allows selecting a color from a color picker.

The following tables list the members exposed by the ToolStripColorPicker type.

Constructors
 | Name | Description
Public constructor | ToolStripColorPicker Constructor | (Overloaded) Initializes a new instance of the class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from ToolStripItem).
Public property | AccessibleDefaultActionDescription | (inherited from ToolStripItem).
Public property | AccessibleDescription | (inherited from ToolStripItem).
Public property | AccessibleName | (inherited from ToolStripItem).
Public property | AccessibleRole | (inherited from ToolStripItem).
Public property | Alignment | (inherited from ToolStripItem).
Public property | AllowDrop | (inherited from ToolStripItem).
Public property | Anchor | (inherited from ToolStripItem).
Public property | AutoSize | Gets or sets a value indicating whether .
Public property | AutoToolTip | (inherited from ToolStripSplitButton).
Public property | Available | (inherited from ToolStripItem).
Public property | BackColor | (inherited from ToolStripItem).
Public property | BackgroundImage | (inherited from ToolStripItem).
Public property | BackgroundImageLayout | (inherited from ToolStripItem).
Public property | Bounds | (inherited from ToolStripItem).
Public property | ButtonBounds | (inherited from ToolStripSplitButton).
Public property | ButtonPressed | (inherited from ToolStripSplitButton).
Public property | ButtonSelected | (inherited from ToolStripSplitButton).
Public property | CanSelect | (inherited from ToolStripItem).
Public property | Color | Gets or sets the color assign to the color picker control.
Public property | Container | (inherited from Component).
Public property | ContentRectangle | (inherited from ToolStripItem).
Public property | DefaultItem | (inherited from ToolStripSplitButton).
Public property | DisplayStyle | (inherited from ToolStripItem).
Public property | Dock | (inherited from ToolStripItem).
Public property | DoubleClickEnabled | (inherited from ToolStripItem).
Public property | DropDown | Gets or sets .
Public property | DropDownButtonBounds | (inherited from ToolStripSplitButton).
Public property | DropDownButtonPressed | (inherited from ToolStripSplitButton).
Public property | DropDownButtonSelected | (inherited from ToolStripSplitButton).
Public property | DropDownButtonWidth | (inherited from ToolStripSplitButton).
Public property | DropDownDirection | (inherited from ToolStripDropDownItem).
Public property | DropDownItems | Gets .
Public property | Enabled | (inherited from ToolStripItem).
Public property | Font | (inherited from ToolStripItem).
Public property | ForeColor | (inherited from ToolStripItem).
Public property | HasDropDownItems | (inherited from ToolStripDropDownItem).
Public property | Height | (inherited from ToolStripItem).
Public property | Image | (inherited from ToolStripItem).
Public property | ImageAlign | (inherited from ToolStripItem).
Public property | ImageIndex | (inherited from ToolStripItem).
Public property | ImageKey | (inherited from ToolStripItem).
Public property | ImageScaling | (inherited from ToolStripItem).
Public property | ImageTransparentColor | (inherited from ToolStripItem).
Public property | IsDisposed | (inherited from ToolStripItem).
Public property | IsOnDropDown | (inherited from ToolStripItem).
Public property | IsOnOverflow | (inherited from ToolStripItem).
Public property | Margin | (inherited from ToolStripItem).
Public property | MergeAction | (inherited from ToolStripItem).
Public property | MergeIndex | (inherited from ToolStripItem).
Public property | Name | (inherited from ToolStripItem).
Public property | Overflow | (inherited from ToolStripItem).
Public property | Owner | (inherited from ToolStripItem).
Public property | OwnerItem | (inherited from ToolStripItem).
Public property | Padding | (inherited from ToolStripItem).
Public property | Placement | (inherited from ToolStripItem).
Public property | Pressed | (inherited from ToolStripDropDownItem).
Public property | RightToLeft | (inherited from ToolStripItem).
Public property | RightToLeftAutoMirrorImage | (inherited from ToolStripItem).
Public property | Selected | (inherited from ToolStripItem).
Public property | Site | (inherited from Component).
Public property | Size | (inherited from ToolStripItem).
Public property | SplitterBounds | (inherited from ToolStripSplitButton).
Public property | Tag | (inherited from ToolStripItem).
Public property | Text | (inherited from ToolStripItem).
Public property | TextAlign | (inherited from ToolStripItem).
Public property | TextDirection | (inherited from ToolStripItem).
Public property | TextImageRelation | (inherited from ToolStripItem).
Public property | ToolTipText | (inherited from ToolStripItem).
Public property | Visible | (inherited from ToolStripItem).
Public property | Width | (inherited from ToolStripItem).
Top
Methods
 | Name | Description
Public method | DoDragDrop | (inherited from ToolStripItem).
Public method | GetCurrentParent | (inherited from ToolStripItem).
Public method | GetPreferredSize | (inherited from ToolStripSplitButton).
Public method | HideDropDown | (inherited from ToolStripDropDownItem).
Public method | Invalidate | (Overloaded) (inherited from ToolStripItem).
Public method | OnButtonDoubleClick | (inherited from ToolStripSplitButton).
Public method | OnSelectedColorChanged | Generate the SelectedColorChanged event.
Public method | PerformButtonClick | (inherited from ToolStripSplitButton).
Public method | ResetDropDownButtonWidth | (inherited from ToolStripSplitButton).
Public method | ShowDialog | Display picker inside a dialog
Public method | ShowDropDown | (inherited from ToolStripDropDownItem).
Top
Events
 | Name | Description
Public event | AvailableChanged | (inherited from ToolStripItem).
Public event | BackColorChanged | (inherited from ToolStripItem).
Public event | ButtonClick | (inherited from ToolStripSplitButton).
Public event | ButtonDoubleClick | (inherited from ToolStripSplitButton).
Public event | Click | (inherited from ToolStripItem).
Public event | DefaultItemChanged | (inherited from ToolStripSplitButton).
Public event | DisplayStyleChanged | (inherited from ToolStripItem).
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | (inherited from ToolStripItem).
Public event | DragDrop | (inherited from ToolStripItem).
Public event | DragEnter | (inherited from ToolStripItem).
Public event | DragLeave | (inherited from ToolStripItem).
Public event | DragOver | (inherited from ToolStripItem).
Public event | DropDownClosed | (inherited from ToolStripDropDownItem).
Public event | DropDownItemClicked | (inherited from ToolStripDropDownItem).
Public event | DropDownOpened | (inherited from ToolStripDropDownItem).
Public event | DropDownOpening | (inherited from ToolStripDropDownItem).
Public event | EnabledChanged | (inherited from ToolStripItem).
Public event | ForeColorChanged | (inherited from ToolStripItem).
Public event | GiveFeedback | (inherited from ToolStripItem).
Public event | LocationChanged | (inherited from ToolStripItem).
Public event | MouseDown | (inherited from ToolStripItem).
Public event | MouseEnter | (inherited from ToolStripItem).
Public event | MouseHover | (inherited from ToolStripItem).
Public event | MouseLeave | (inherited from ToolStripItem).
Public event | MouseMove | (inherited from ToolStripItem).
Public event | MouseUp | (inherited from ToolStripItem).
Public event | OwnerChanged | (inherited from ToolStripItem).
Public event | Paint | (inherited from ToolStripItem).
Public event | QueryAccessibilityHelp | (inherited from ToolStripItem).
Public event | QueryContinueDrag | (inherited from ToolStripItem).
Public event | RightToLeftChanged | (inherited from ToolStripItem).
Public event | SelectedColorChanged | This event will be raised when the value of the Color property changes.
Public event | TextChanged | (inherited from ToolStripItem).
Public event | VisibleChanged | (inherited from ToolStripItem).
Top
See Also

Reference

ToolStripColorPicker Class


ToolStripColorPicker Constructor

ToolStripColorPicker Class See Also

Initializes a new instance of the class

Overload List
Name | Description
ToolStripColorPicker() | Initializes a new instance of the class
ToolStripColorPicker(Color) | Initiala new instance of the class with specified color
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker Properties

ToolStripColorPicker Class See Also

The following tables list the members exposed by the ToolStripColorPicker type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from ToolStripItem).
Public property | AccessibleDefaultActionDescription | (inherited from ToolStripItem).
Public property | AccessibleDescription | (inherited from ToolStripItem).
Public property | AccessibleName | (inherited from ToolStripItem).
Public property | AccessibleRole | (inherited from ToolStripItem).
Public property | Alignment | (inherited from ToolStripItem).
Public property | AllowDrop | (inherited from ToolStripItem).
Public property | Anchor | (inherited from ToolStripItem).
Public property | AutoSize | Gets or sets a value indicating whether .
Public property | AutoToolTip | (inherited from ToolStripSplitButton).
Public property | Available | (inherited from ToolStripItem).
Public property | BackColor | (inherited from ToolStripItem).
Public property | BackgroundImage | (inherited from ToolStripItem).
Public property | BackgroundImageLayout | (inherited from ToolStripItem).
Public property | Bounds | (inherited from ToolStripItem).
Public property | ButtonBounds | (inherited from ToolStripSplitButton).
Public property | ButtonPressed | (inherited from ToolStripSplitButton).
Public property | ButtonSelected | (inherited from ToolStripSplitButton).
Public property | CanSelect | (inherited from ToolStripItem).
Public property | Color | Gets or sets the color assign to the color picker control.
Public property | Container | (inherited from Component).
Public property | ContentRectangle | (inherited from ToolStripItem).
Public property | DefaultItem | (inherited from ToolStripSplitButton).
Public property | DisplayStyle | (inherited from ToolStripItem).
Public property | Dock | (inherited from ToolStripItem).
Public property | DoubleClickEnabled | (inherited from ToolStripItem).
Public property | DropDown | Gets or sets .
Public property | DropDownButtonBounds | (inherited from ToolStripSplitButton).
Public property | DropDownButtonPressed | (inherited from ToolStripSplitButton).
Public property | DropDownButtonSelected | (inherited from ToolStripSplitButton).
Public property | DropDownButtonWidth | (inherited from ToolStripSplitButton).
Public property | DropDownDirection | (inherited from ToolStripDropDownItem).
Public property | DropDownItems | Gets .
Public property | Enabled | (inherited from ToolStripItem).
Public property | Font | (inherited from ToolStripItem).
Public property | ForeColor | (inherited from ToolStripItem).
Public property | HasDropDownItems | (inherited from ToolStripDropDownItem).
Public property | Height | (inherited from ToolStripItem).
Public property | Image | (inherited from ToolStripItem).
Public property | ImageAlign | (inherited from ToolStripItem).
Public property | ImageIndex | (inherited from ToolStripItem).
Public property | ImageKey | (inherited from ToolStripItem).
Public property | ImageScaling | (inherited from ToolStripItem).
Public property | ImageTransparentColor | (inherited from ToolStripItem).
Public property | IsDisposed | (inherited from ToolStripItem).
Public property | IsOnDropDown | (inherited from ToolStripItem).
Public property | IsOnOverflow | (inherited from ToolStripItem).
Public property | Margin | (inherited from ToolStripItem).
Public property | MergeAction | (inherited from ToolStripItem).
Public property | MergeIndex | (inherited from ToolStripItem).
Public property | Name | (inherited from ToolStripItem).
Public property | Overflow | (inherited from ToolStripItem).
Public property | Owner | (inherited from ToolStripItem).
Public property | OwnerItem | (inherited from ToolStripItem).
Public property | Padding | (inherited from ToolStripItem).
Public property | Placement | (inherited from ToolStripItem).
Public property | Pressed | (inherited from ToolStripDropDownItem).
Public property | RightToLeft | (inherited from ToolStripItem).
Public property | RightToLeftAutoMirrorImage | (inherited from ToolStripItem).
Public property | Selected | (inherited from ToolStripItem).
Public property | Site | (inherited from Component).
Public property | Size | (inherited from ToolStripItem).
Public property | SplitterBounds | (inherited from ToolStripSplitButton).
Public property | Tag | (inherited from ToolStripItem).
Public property | Text | (inherited from ToolStripItem).
Public property | TextAlign | (inherited from ToolStripItem).
Public property | TextDirection | (inherited from ToolStripItem).
Public property | TextImageRelation | (inherited from ToolStripItem).
Public property | ToolTipText | (inherited from ToolStripItem).
Public property | Visible | (inherited from ToolStripItem).
Public property | Width | (inherited from ToolStripItem).
Top
See Also

Reference

ToolStripColorPicker Class


ToolStripColorPicker.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DefaultValue(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
Public Shadows Property AutoSize() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DefaultValue(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
new public bool AutoSize {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker.Color Property

Gets or sets the color assign to the color picker control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("ToolStripColoPicker")> _
<Description("Gets or sets the color assign to the color picker control.")> _
<DefaultValue(GetType(Color), "White")> _
Public Property Color() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("ToolStripColoPicker")]
[Description("Gets or sets the color assign to the color picker control.")]
[DefaultValue(GetType(Color), "White")]
public Color Color {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker.DropDown Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public Shadows Property DropDown() As ToolStripDropDown
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ToolStripDropDown DropDown {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker.DropDownItems Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Shadows Property DropDownItems() As ToolStripItemCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
new public ToolStripItemCollection DropDownItems {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker Methods

ToolStripColorPicker Class See Also

The following tables list the members exposed by the ToolStripColorPicker type.

Methods
 | Name | Description
Public method | DoDragDrop | (inherited from ToolStripItem).
Public method | GetCurrentParent | (inherited from ToolStripItem).
Public method | GetPreferredSize | (inherited from ToolStripSplitButton).
Public method | HideDropDown | (inherited from ToolStripDropDownItem).
Public method | Invalidate | (Overloaded) (inherited from ToolStripItem).
Public method | OnButtonDoubleClick | (inherited from ToolStripSplitButton).
Public method | OnSelectedColorChanged | Generate the SelectedColorChanged event.
Public method | PerformButtonClick | (inherited from ToolStripSplitButton).
Public method | ResetDropDownButtonWidth | (inherited from ToolStripSplitButton).
Public method | ShowDialog | Display picker inside a dialog
Public method | ShowDropDown | (inherited from ToolStripDropDownItem).
Top
See Also

Reference

ToolStripColorPicker Class


ToolStripColorPicker.OnSelectedColorChanged Method

Generate the SelectedColorChanged event.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub OnSelectedColorChanged( _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void OnSelectedColorChanged(
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

e

Type: EventArgs

Event arguments

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker.ShowDialog Method

Display picker inside a dialog

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub ShowDialog( _
   ByVal owner As IWin32Window, _
   ByVal sTitle As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void ShowDialog(
   IWin32Window owner,
   string sTitle
)
This language is not supported or no code example is available.

Parameters

owner

Type: IWin32Window

Dialog Owner Form

sTitle

Type: string

Dialog Title

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker Events

ToolStripColorPicker Class See Also

The following tables list the members exposed by the ToolStripColorPicker type.

Events
 | Name | Description
Public event | AvailableChanged | (inherited from ToolStripItem).
Public event | BackColorChanged | (inherited from ToolStripItem).
Public event | ButtonClick | (inherited from ToolStripSplitButton).
Public event | ButtonDoubleClick | (inherited from ToolStripSplitButton).
Public event | Click | (inherited from ToolStripItem).
Public event | DefaultItemChanged | (inherited from ToolStripSplitButton).
Public event | DisplayStyleChanged | (inherited from ToolStripItem).
Public event | Disposed | (inherited from Component).
Public event | DoubleClick | (inherited from ToolStripItem).
Public event | DragDrop | (inherited from ToolStripItem).
Public event | DragEnter | (inherited from ToolStripItem).
Public event | DragLeave | (inherited from ToolStripItem).
Public event | DragOver | (inherited from ToolStripItem).
Public event | DropDownClosed | (inherited from ToolStripDropDownItem).
Public event | DropDownItemClicked | (inherited from ToolStripDropDownItem).
Public event | DropDownOpened | (inherited from ToolStripDropDownItem).
Public event | DropDownOpening | (inherited from ToolStripDropDownItem).
Public event | EnabledChanged | (inherited from ToolStripItem).
Public event | ForeColorChanged | (inherited from ToolStripItem).
Public event | GiveFeedback | (inherited from ToolStripItem).
Public event | LocationChanged | (inherited from ToolStripItem).
Public event | MouseDown | (inherited from ToolStripItem).
Public event | MouseEnter | (inherited from ToolStripItem).
Public event | MouseHover | (inherited from ToolStripItem).
Public event | MouseLeave | (inherited from ToolStripItem).
Public event | MouseMove | (inherited from ToolStripItem).
Public event | MouseUp | (inherited from ToolStripItem).
Public event | OwnerChanged | (inherited from ToolStripItem).
Public event | Paint | (inherited from ToolStripItem).
Public event | QueryAccessibilityHelp | (inherited from ToolStripItem).
Public event | QueryContinueDrag | (inherited from ToolStripItem).
Public event | RightToLeftChanged | (inherited from ToolStripItem).
Public event | SelectedColorChanged | This event will be raised when the value of the Color property changes.
Public event | TextChanged | (inherited from ToolStripItem).
Public event | VisibleChanged | (inherited from ToolStripItem).
Top
See Also

Reference

ToolStripColorPicker Class


SelectedColorChanged Event

This event will be raised when the value of the Color property changes.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Behavior")> _
<Description("Occurs when the value of the Color property changes.")> _
Public Event SelectedColorChanged( _
   ByRef sender As Object, _
   ByRef e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Behavior")]
[Description("Occurs when the value of the Color property changes.")]
public event SelectedColorChangedEventHandler SelectedColorChanged
delegate void SelectedColorChangedEventHandler(
   ref object sender,
   ref EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripCustomize Class

Members

Softgroup .Net ToolStrip Customize component is an easy to use .Net component that provide runtime user customization dialog of any ToolStrip control.

To add a Softgroup .Net Toolstrip Customize component to your form simply add the component to the Toolbox window of Microsoft Visual Studio, drag it to the Form and sets ToolStip property control of component.

To display cutomization dialog at runtime call ShowDialog methods through code or double click on clean area of ToolStrip control.

You can also customize any text displayed by cutomization dialog using Localize method.

To enter your licenses informations you must set LicenseName, LicenseUser and LicenseKey properties of License object as VB.NET code sample below:

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Copy
    Softgroup.NetToolStripCustomize.License.LicenseName= "YourCompanyName"
    Softgroup.NetToolStripCustomize.License.LicenseUser = "YourUserNameOrMail"
    Softgroup.NetToolStripCustomize.License.LicenseKey = "YourSerialNumber"

End Sub

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Drawing.ToolboxBitmap(GetType(ToolStripCustomize), "ToolStripCustomize.bmp")> _
<System.ComponentModel.DefaultEvent("ShowDialogAfter")> _
<System.ComponentModel.DefaultProperty("ToolStrip")> _
Public Class ToolStripCustomize
    Inherits Component
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Drawing.ToolboxBitmap(GetType(ToolStripCustomize), "ToolStripCustomize.bmp")]
[System.ComponentModel.DefaultEvent("ShowDialogAfter")]
[System.ComponentModel.DefaultProperty("ToolStrip")]
public class ToolStripCustomize : Component
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Softgroup.NetControls.ToolStripCustomize
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Members


ToolStripCustomize Members

ToolStripCustomize Class Events Methods Properties See Also

Softgroup .Net ToolStrip Customize component is an easy to use .Net component that provide runtime user customization dialog of any ToolStrip control.

To add a Softgroup .Net Toolstrip Customize component to your form simply add the component to the Toolbox window of Microsoft Visual Studio, drag it to the Form and sets ToolStip property control of component.

To display cutomization dialog at runtime call ShowDialog methods through code or double click on clean area of ToolStrip control.

You can also customize any text displayed by cutomization dialog using Localize method.

To enter your licenses informations you must set LicenseName, LicenseUser and LicenseKey properties of License object as VB.NET code sample below:

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Copy
    Softgroup.NetToolStripCustomize.License.LicenseName= "YourCompanyName"
    Softgroup.NetToolStripCustomize.License.LicenseUser = "YourUserNameOrMail"
    Softgroup.NetToolStripCustomize.License.LicenseKey = "YourSerialNumber"

End Sub

The following tables list the members exposed by the ToolStripCustomize type.

Properties
 | Name | Description
Public property | AutoSaveRestore | Gets/Sets if component must automatically Save and Restore ToolStrip user settings.
Public property | Container | (inherited from Component).
Public property | CurrentSettings | Gets current user settings string for custom saving or restoring of ToolStrip layout.
Public property | DefaultItems | Gets/Sets the list of ToolStripItem items used as default items (see remarks) when user click Reset button on customization dialog.
Public property | Site | (inherited from Component).
Public property | ToolStrip | Gets/Sets the ToolStrip control for which customization must be done.
Public property | UseToolStripItemsAsDefault | Gets/Sets if current ToolStrip control items must be used as default items (see remarks) when user click Reset button on Customization Dialog.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
 | Localize | Localize any text displayed by the ToolStrip customization dialog.
 | LocalizeReset | Reset all current localization strings to default language (english).
Public method | RestoreSettings | (Overloaded) Restore previous saved user settings of ToolStrip layout.
Public method | SaveSettings | Save current user settings of ToolStrip layout.
Public method | ShowDialog | Display ToolStrip customization dialog.
Public method | ToString | (inherited from Component).
Top
Events
 | Name | Description
Public event | Disposed | (inherited from Component).
Public event | ShowDialogAfter | This event will be raised after ToolStrip customization dialog was be displayed
Public event | ShowDialogBefore | This event will be raised before ToolStrip customization dialog will be displayed.
Top
See Also

Reference

ToolStripCustomize Class


ToolStripCustomize Properties

ToolStripCustomize Class See Also

The following tables list the members exposed by the ToolStripCustomize type.

Properties
 | Name | Description
Public property | AutoSaveRestore | Gets/Sets if component must automatically Save and Restore ToolStrip user settings.
Public property | Container | (inherited from Component).
Public property | CurrentSettings | Gets current user settings string for custom saving or restoring of ToolStrip layout.
Public property | DefaultItems | Gets/Sets the list of ToolStripItem items used as default items (see remarks) when user click Reset button on customization dialog.
Public property | Site | (inherited from Component).
Public property | ToolStrip | Gets/Sets the ToolStrip control for which customization must be done.
Public property | UseToolStripItemsAsDefault | Gets/Sets if current ToolStrip control items must be used as default items (see remarks) when user click Reset button on Customization Dialog.
Top
See Also

Reference

ToolStripCustomize Class


ToolStripCustomize.AutoSaveRestore Property

Gets/Sets if component must automatically Save and Restore ToolStrip user settings.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ToolStripCustomize")> _
<System.ComponentModel.Description("Gets/Sets if component must automatically Save and Restore ToolStrip user settings.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property AutoSaveRestore( _
   ByRef "Gets/Sets if component must automatically Save and Restore ToolStrip user settings." As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ToolStripCustomize")]
[System.ComponentModel.Description("Gets/Sets if component must automatically Save and Restore ToolStrip user settings.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("AutoSaveRestore")]
public bool this[
   ref object "Gets/Sets if component must automatically Save and Restore ToolStrip user settings."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if component must automatically Save and Restore ToolStrip user settings."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.CurrentSettings Property

Gets current user settings string for custom saving or restoring of ToolStrip layout.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ToolStripCustomize")> _
<System.ComponentModel.Description("Gets current user settings string for custom saving or restoring of ToolStrip layout.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property CurrentSettings( _
   ByRef "Gets current user settings string for custom saving or restoring of ToolStrip layout." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ToolStripCustomize")]
[System.ComponentModel.Description("Gets current user settings string for custom saving or restoring of ToolStrip layout.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("CurrentSettings")]
public string this[
   ref object "Gets current user settings string for custom saving or restoring of ToolStrip layout."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets current user settings string for custom saving or restoring of ToolStrip layout."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.DefaultItems Property

Gets/Sets the list of ToolStripItem items used as default items (see remarks) when user click Reset button on customization dialog.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ToolStripCustomize")> _
<System.ComponentModel.Description("Gets/Sets the list of ToolStrip items used as default items (see remarks) when user click Reset button on customization dialog.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property DefaultItems( _
   ByRef "Gets/Sets the list of ToolStrip items used as default items  As Object _
) As List(Of ToolStripItem)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ToolStripCustomize")]
[System.ComponentModel.Description("Gets/Sets the list of ToolStrip items used as default items (see remarks) when user click Reset button on customization dialog.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultItems")]
public List<ToolStripItem> this[
   ref object "Gets/Sets the list of ToolStrip items used as default items
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the list of ToolStrip items used as default items

Type: object

Remarks

You can define default custom ToolStripItem list (initial list of ToolStipItem that must have ToolStrip control when user click on Reset button on customization dialog).

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.ToolStrip Property

Gets/Sets the ToolStrip control for which customization must be done.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ToolStripCustomize")> _
<System.ComponentModel.Description("Gets/Sets the ToolStrip control for which customization must be done.")> _
<System.ComponentModel.DefaultValue(CStr(Nothing))> _
Public Property ToolStrip( _
   ByRef "Gets/Sets the ToolStrip control for which customization must be done." As Object _
) As ToolStrip
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ToolStripCustomize")]
[System.ComponentModel.Description("Gets/Sets the ToolStrip control for which customization must be done.")]
[System.ComponentModel.DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("ToolStrip")]
public ToolStrip this[
   ref object "Gets/Sets the ToolStrip control for which customization must be done."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the ToolStrip control for which customization must be done."

Type: object

Remarks

ToolStrip control must have a unique and valid property Name otherwise component can't save and restore ToolStrip customizations made by the user. When you sets this property DefaultToolStripItems collection will be cleared and filled with current items in the ToolStrip control if UseToolStripItemsAsDefault is sets to True.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.UseToolStripItemsAsDefault Property

Gets/Sets if current ToolStrip control items must be used as default items (see remarks) when user click Reset button on Customization Dialog.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ToolStripCustomize")> _
<System.ComponentModel.Description("Gets/Sets if current ToolStrip control items must be used as default items (see remarks) when user click Reset button on Customization Dialog.")> _
<System.ComponentModel.DefaultValue(True)> _
Public Property UseToolStripItemsAsDefault( _
   ByRef "Gets/Sets if current ToolStrip control items must be used as default items  As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ToolStripCustomize")]
[System.ComponentModel.Description("Gets/Sets if current ToolStrip control items must be used as default items (see remarks) when user click Reset button on Customization Dialog.")]
[System.ComponentModel.DefaultValue(True)]
[System.Runtime.CompilerServices.IndexerName("UseToolStripItemsAsDefault")]
public bool this[
   ref object "Gets/Sets if current ToolStrip control items must be used as default items
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets if current ToolStrip control items must be used as default items

Type: object

Remarks

You can define default custom ToolStripItem list (initial list of ToolStipItem that must have ToolStrip control when user click on Reset button on Customization Dialog).

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize Methods

ToolStripCustomize Class See Also

The following tables list the members exposed by the ToolStripCustomize type.

Methods
 | Name | Description
Public method | CreateObjRef | Consente di creare un oggetto che contiene tutte le informazioni rilevanti necessarie per la generazione del proxy utilizzato per effettuare la comunicazione con un oggetto remoto. (inherited from MarshalByRefObject).
Public method | Dispose | (inherited from Component).
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | GetLifetimeService | Consente di recuperare l'oggetto servizio di durata corrente per controllare i criteri di durata per l'istanza. (inherited from MarshalByRefObject).
Public method | InitializeLifetimeService | Consente di ottenere un oggetto servizio di durata per il controllo dei criteri di durata per l'istanza. (inherited from MarshalByRefObject).
 | Localize | Localize any text displayed by the ToolStrip customization dialog.
 | LocalizeReset | Reset all current localization strings to default language (english).
Public method | RestoreSettings | (Overloaded) Restore previous saved user settings of ToolStrip layout.
Public method | SaveSettings | Save current user settings of ToolStrip layout.
Public method | ShowDialog | Display ToolStrip customization dialog.
Public method | ToString | (inherited from Component).
Top
See Also

Reference

ToolStripCustomize Class


ToolStripCustomize.Localize Method

Localize any text displayed by the ToolStrip customization dialog.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Localize any text displayed by the ToolStrip customization dialog.")> _
Public Shared Sub Localize( _
   ByVal iString As ToolStripCustomizeStrings, _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Localize any text displayed by the ToolStrip customization dialog.")]
public static System.Void Localize(
   ToolStripCustomizeStrings iString,
   string sText
)
This language is not supported or no code example is available.

Parameters

iString

Type: ToolStripCustomizeStrings

A valid NetToolStripCustomizeStrings enumeration value

sText

Type: string

The text to be displayed for specified NetToolStripCustomizeStrings enumeration value

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.LocalizeReset Method

Reset all current localization strings to default language (english).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Reset all current localization strings to default language (english).")> _
Public Shared Sub LocalizeReset()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Reset all current localization strings to default language (english).")]
public static System.Void LocalizeReset()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.RestoreSettings Method

ToolStripCustomize Class See Also

Restore previous saved user settings of ToolStrip layout.

Overload List
Name | Description
RestoreSettings(string) | Restore custom previous saved user settings of ToolStrip layout.
RestoreSettings() | Restore previous saved user settings of ToolStrip layout.
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.SaveSettings Method

Save current user settings of ToolStrip layout.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Save current user settings of ToolStrip layout.")> _
Public Sub SaveSettings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Save current user settings of ToolStrip layout.")]
public System.Void SaveSettings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.ShowDialog Method

Display ToolStrip customization dialog.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Display ToolStrip Customization dialog.")> _
Public Function ShowDialog() As DialogResult
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Display ToolStrip Customization dialog.")]
public DialogResult ShowDialog()
This language is not supported or no code example is available.
Remarks

The result of this function will be OK if user apply custom changed, Ignore if the user decide to Reset ToolStrip or Cancel in all other cases.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize Events

ToolStripCustomize Class See Also

The following tables list the members exposed by the ToolStripCustomize type.

Events
 | Name | Description
Public event | Disposed | (inherited from Component).
Public event | ShowDialogAfter | This event will be raised after ToolStrip customization dialog was be displayed
Public event | ShowDialogBefore | This event will be raised before ToolStrip customization dialog will be displayed.
Top
See Also

Reference

ToolStripCustomize Class


ShowDialogAfter Event

This event will be raised after ToolStrip customization dialog was be displayed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be raised after ToolStrip customization dialog was be displayed")> _
Public Event ShowDialogAfter( _
   ByVal sender As Object, _
   ByVal e As ToolStripCustomizeShowDialogAfterEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be raised after ToolStrip customization dialog was be displayed")]
public event ShowDialogAfterEventHandler ShowDialogAfter
delegate void ShowDialogAfterEventHandler(
   object sender,
   ToolStripCustomizeShowDialogAfterEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The sender of event.

e

Type: ToolStripCustomizeShowDialogAfterEventArgs

A ToolStripCustomizeShowDialogAfterEventArgs object with parameters events.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ShowDialogBefore Event

This event will be raised before ToolStrip customization dialog will be displayed.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("This event will be raised before ToolStrip customization dialog will be displayed.")> _
Public Event ShowDialogBefore( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("This event will be raised before ToolStrip customization dialog will be displayed.")]
public event ShowDialogBeforeEventHandler ShowDialogBefore
delegate void ShowDialogBeforeEventHandler(
   object sender,
   CancelEventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The sender of event.

e

Type: CancelEventArgs

A System.ComponentModel.CancelEventArg object with parameters events.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomizeShowDialogAfterEventArgs Class

Members

Class ToolStripCustomizeShowDialogAfterEventArgs provide parameter events for ShowDialogAfter event of ToolStripCustomize control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Class ToolStripCustomizeShowDialogAfterEventArgs
    Inherits EventArgs
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public class ToolStripCustomizeShowDialogAfterEventArgs : EventArgs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.EventArgs
Softgroup.NetControls.ToolStripCustomizeShowDialogAfterEventArgs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Members


ToolStripCustomizeShowDialogAfterEventArgs Members

ToolStripCustomizeShowDialogAfterEventArgs Class Constructors Methods Properties See Also

Class ToolStripCustomizeShowDialogAfterEventArgs provide parameter events for ShowDialogAfter event of ToolStripCustomize control.

The following tables list the members exposed by the ToolStripCustomizeShowDialogAfterEventArgs type.

Constructors
 | Name | Description
Public constructor | ToolStripCustomizeShowDialogAfterEventArgs Constructor | Initializes a new instance of the ToolStripCustomizeShowDialogAfterEventArgs class.
Top
Properties
 | Name | Description
Public property | DialogResult | Return a System.Windows.Forms.DialogResult value.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Class


ToolStripCustomizeShowDialogAfterEventArgs Constructor

Initializes a new instance of the ToolStripCustomizeShowDialogAfterEventArgs class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal eDialogResult As DialogResult _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ToolStripCustomizeShowDialogAfterEventArgs(
   DialogResult eDialogResult
)
This language is not supported or no code example is available.

Parameters

eDialogResult

Type: DialogResult

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Class
ToolStripCustomizeShowDialogAfterEventArgs Members


ToolStripCustomizeShowDialogAfterEventArgs Properties

ToolStripCustomizeShowDialogAfterEventArgs Class See Also

The following tables list the members exposed by the ToolStripCustomizeShowDialogAfterEventArgs type.

Properties
 | Name | Description
Public property | DialogResult | Return a System.Windows.Forms.DialogResult value.
Top
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Class


ToolStripCustomizeShowDialogAfterEventArgs.DialogResult Property

Return a System.Windows.Forms.DialogResult value.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public ReadOnly Property DialogResult() As DialogResult
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public DialogResult DialogResult {get;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Class
ToolStripCustomizeShowDialogAfterEventArgs Members


ToolStripCustomizeShowDialogAfterEventArgs Methods

ToolStripCustomizeShowDialogAfterEventArgs Class See Also

The following tables list the members exposed by the ToolStripCustomizeShowDialogAfterEventArgs type.

Methods
 | Name | Description
Public method | Equals | (Overloaded) Consente di determinare se l'oggetto Object specificato è uguale all'oggetto Object corrente. (inherited from Object).
Public method | ToString | Restituisce un oggetto String che rappresenta l'oggetto Object corrente. (inherited from Object).
Top
See Also

Reference

ToolStripCustomizeShowDialogAfterEventArgs Class


Win8ProgressMarquee Class

Members

Softgroup Win8ProgressMarquee is a control that mimic Windows 8 progress marquee indicator

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Win8ProgressMarquee), "Win8ProgressMarquee")> _
<DefaultEvent("FrequencyChanged")> _
<DefaultProperty("Frequency")> _
Public Class Win8ProgressMarquee
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Win8ProgressMarquee), "Win8ProgressMarquee")]
[DefaultEvent("FrequencyChanged")]
[DefaultProperty("Frequency")]
public class Win8ProgressMarquee : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.Win8ProgressMarquee
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Members


Win8ProgressMarquee Members

Win8ProgressMarquee Class Constructors Events Methods Properties See Also

Softgroup Win8ProgressMarquee is a control that mimic Windows 8 progress marquee indicator

The following tables list the members exposed by the Win8ProgressMarquee type.

Constructors
 | Name | Description
Public constructor | Win8ProgressMarquee Constructor | Initializes a new instance of the Win8ProgressMarquee class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | Frequency | Gets/Sets progress repaint frequency
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation
Public method | Stop | Stop control animation
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | (inherited from Control).
Public event | FrequencyChanged | This event will be raised every time Frequency property value changed
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

Win8ProgressMarquee Class


Win8ProgressMarquee Constructor

Initializes a new instance of the Win8ProgressMarquee class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Win8ProgressMarquee()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee Properties

Win8ProgressMarquee Class See Also

The following tables list the members exposed by the Win8ProgressMarquee type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | (inherited from Control).
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | Frequency | Gets/Sets progress repaint frequency
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

Win8ProgressMarquee Class


Win8ProgressMarquee.BackColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.Frequency Property

Gets/Sets progress repaint frequency

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets progress repaint frequency")> _
<DefaultValue(100)> _
Public Property Frequency() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets progress repaint frequency")]
[DefaultValue(100)]
public int Frequency {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee Methods

Win8ProgressMarquee Class See Also

The following tables list the members exposed by the Win8ProgressMarquee type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation
Public method | Stop | Stop control animation
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

Win8ProgressMarquee Class


Win8ProgressMarquee.Start Method

Start control animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Start()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee.Stop Method

Stop control animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Stop()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Stop()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressMarquee Events

Win8ProgressMarquee Class See Also

The following tables list the members exposed by the Win8ProgressMarquee type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | (inherited from Control).
Public event | FrequencyChanged | This event will be raised every time Frequency property value changed
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

Win8ProgressMarquee Class


BackColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackColorChangedEventHandler BackColorChanged
delegate void BackColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


DockChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event DockChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event DockChangedEventHandler DockChanged
delegate void DockChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


FrequencyChanged Event

This event will be raised every time Frequency property value changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event FrequencyChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event FrequencyChangedEventHandler FrequencyChanged
delegate void FrequencyChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressMarquee Class
Win8ProgressMarquee Members


Win8ProgressRing Class

Members

Softgroup Win8ProgressRing is a control that mimic Windows 8 progress ring indicator

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<ToolboxItem(True)> _
<ToolboxBitmap(GetType(Win8ProgressRing), "Win8ProgressRing")> _
<DefaultEvent("FrequencyChanged")> _
<DefaultProperty("Frequency")> _
Public Class Win8ProgressRing
    Inherits Control
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[ToolboxItem(True)]
[ToolboxBitmap(GetType(Win8ProgressRing), "Win8ProgressRing")]
[DefaultEvent("FrequencyChanged")]
[DefaultProperty("Frequency")]
public class Win8ProgressRing : Control
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Softgroup.NetControls.Win8ProgressRing
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Members


Win8ProgressRing Members

Win8ProgressRing Class Constructors Events Methods Properties See Also

Softgroup Win8ProgressRing is a control that mimic Windows 8 progress ring indicator

The following tables list the members exposed by the Win8ProgressRing type.

Constructors
 | Name | Description
Public constructor | Win8ProgressRing Constructor | Initializes a new instance of the Win8ProgressRing class.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | Frequency | Gets/Sets progress repaint frequency
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation
Public method | Stop | Stop control animation
Public method | SuspendLayout | (inherited from Control).
Top
Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | (inherited from Control).
Public event | FrequencyChanged | This event will be raised every time Frequency property value changed
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

Win8ProgressRing Class


Win8ProgressRing Constructor

Initializes a new instance of the Win8ProgressRing class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public Win8ProgressRing()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing Properties

Win8ProgressRing Class See Also

The following tables list the members exposed by the Win8ProgressRing type.

Properties
 | Name | Description
Public property | AccessibilityObject | (inherited from Control).
Public property | AccessibleDefaultActionDescription | (inherited from Control).
Public property | AccessibleDescription | (inherited from Control).
Public property | AccessibleName | (inherited from Control).
Public property | AccessibleRole | (inherited from Control).
Public property | AllowDrop | (inherited from Control).
Public property | Anchor | (inherited from Control).
Public property | AutoScrollOffset | (inherited from Control).
Public property | AutoSize | (inherited from Control).
Public property | BackColor | Gets or sets .
Public property | BackgroundImage | Gets or sets .
Public property | BackgroundImageLayout | Gets or sets .
Public property | BindingContext | (inherited from Control).
Public property | Bottom | (inherited from Control).
Public property | Bounds | (inherited from Control).
Public property | CanFocus | (inherited from Control).
Public property | CanSelect | (inherited from Control).
Public property | Capture | (inherited from Control).
Public property | CausesValidation | (inherited from Control).
 | CheckForIllegalCrossThreadCalls | (inherited from Control).
Public property | ClientRectangle | (inherited from Control).
Public property | ClientSize | (inherited from Control).
Public property | CompanyName | (inherited from Control).
Public property | Container | (inherited from Component).
Public property | ContainsFocus | (inherited from Control).
Public property | ContextMenu | (inherited from Control).
Public property | ContextMenuStrip | (inherited from Control).
Public property | Controls | (inherited from Control).
Public property | Created | (inherited from Control).
Public property | Cursor | (inherited from Control).
Public property | DataBindings | (inherited from Control).
 | DefaultBackColor | (inherited from Control).
 | DefaultFont | (inherited from Control).
 | DefaultForeColor | (inherited from Control).
Public property | DisplayRectangle | (inherited from Control).
Public property | Disposing | (inherited from Control).
Public property | Dock | Gets or sets .
Public property | Enabled | (inherited from Control).
Public property | Focused | (inherited from Control).
Public property | Font | Gets or sets .
Public property | ForeColor | (inherited from Control).
Public property | Frequency | Gets/Sets progress repaint frequency
Public property | Handle | (inherited from Control).
Public property | HasChildren | (inherited from Control).
Public property | Height | (inherited from Control).
Public property | ImeMode | (inherited from Control).
Public property | InvokeRequired | (inherited from Control).
Public property | IsAccessible | (inherited from Control).
Public property | IsDisposed | (inherited from Control).
Public property | IsHandleCreated | (inherited from Control).
Public property | IsMirrored | (inherited from Control).
Public property | LayoutEngine | (inherited from Control).
Public property | Left | (inherited from Control).
Public property | Location | (inherited from Control).
Public property | Margin | (inherited from Control).
Public property | MaximumSize | (inherited from Control).
Public property | MinimumSize | (inherited from Control).
 | ModifierKeys | (inherited from Control).
 | MouseButtons | (inherited from Control).
 | MousePosition | (inherited from Control).
Public property | Name | (inherited from Control).
Public property | Padding | (Overloaded) (inherited from Control).
Public property | Parent | (inherited from Control).
Public property | PreferredSize | (inherited from Control).
Public property | ProductName | (inherited from Control).
Public property | ProductVersion | (inherited from Control).
Public property | RecreatingHandle | (inherited from Control).
Public property | Region | (inherited from Control).
Public property | Right | (inherited from Control).
Public property | RightToLeft | (inherited from Control).
Public property | Site | (inherited from Control).
Public property | Size | (inherited from Control).
Public property | TabIndex | (inherited from Control).
Public property | TabStop | Gets or sets a value indicating whether .
Public property | Tag | (inherited from Control).
Public property | Text | Gets or sets .
Public property | Top | (inherited from Control).
Public property | TopLevelControl | (inherited from Control).
Public property | UseWaitCursor | (inherited from Control).
Public property | Visible | (inherited from Control).
Public property | Width | (inherited from Control).
Public property | WindowTarget | (inherited from Control).
Top
See Also

Reference

Win8ProgressRing Class


Win8ProgressRing.BackColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackColor() As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Color BackColor {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackgroundImage() As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Image BackgroundImage {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property BackgroundImageLayout() As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public ImageLayout BackgroundImageLayout {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.Dock Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Dock() As DockStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public DockStyle Dock {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Font() As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public Font Font {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.Frequency Property

Gets/Sets progress repaint frequency

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Category("Appearance")> _
<Description("Gets/Sets progress repaint frequency")> _
<DefaultValue(100)> _
Public Property Frequency() As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Category("Appearance")]
[Description("Gets/Sets progress repaint frequency")]
[DefaultValue(100)]
public int Frequency {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property TabStop() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public bool TabStop {get; set;}
This language is not supported or no code example is available.

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Property Text() As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public string Text {get; set;}
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing Methods

Win8ProgressRing Class See Also

The following tables list the members exposed by the Win8ProgressRing type.

Methods
 | Name | Description
Public method | ResumeLayout | (Overloaded) (inherited from Control).
Public method | Start | Start control animation
Public method | Stop | Stop control animation
Public method | SuspendLayout | (inherited from Control).
Top
See Also

Reference

Win8ProgressRing Class


Win8ProgressRing.Start Method

Start control animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Start()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing.Stop Method

Stop control animation

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Stop()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Stop()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


Win8ProgressRing Events

Win8ProgressRing Class See Also

The following tables list the members exposed by the Win8ProgressRing type.

Events
 | Name | Description
Public event | AutoSizeChanged | (inherited from Control).
Public event | BackColorChanged | Occurs when .
Public event | BackgroundImageChanged | Occurs when .
Public event | BackgroundImageLayoutChanged | Occurs when .
Public event | BindingContextChanged | (inherited from Control).
Public event | CausesValidationChanged | (inherited from Control).
Public event | ChangeUICues | (inherited from Control).
Public event | Click | (inherited from Control).
Public event | ClientSizeChanged | (inherited from Control).
Public event | ContextMenuChanged | (inherited from Control).
Public event | ContextMenuStripChanged | (inherited from Control).
Public event | ControlAdded | (inherited from Control).
Public event | ControlRemoved | (inherited from Control).
Public event | CursorChanged | (inherited from Control).
Public event | Disposed | (inherited from Component).
Public event | DockChanged | Occurs when .
Public event | DoubleClick | (inherited from Control).
Public event | DragDrop | (inherited from Control).
Public event | DragEnter | (inherited from Control).
Public event | DragLeave | (inherited from Control).
Public event | DragOver | (inherited from Control).
Public event | EnabledChanged | (inherited from Control).
Public event | Enter | (inherited from Control).
Public event | FontChanged | Occurs when .
Public event | ForeColorChanged | (inherited from Control).
Public event | FrequencyChanged | This event will be raised every time Frequency property value changed
Public event | GiveFeedback | (inherited from Control).
Public event | GotFocus | (inherited from Control).
Public event | HandleCreated | (inherited from Control).
Public event | HandleDestroyed | (inherited from Control).
Public event | HelpRequested | (inherited from Control).
Public event | ImeModeChanged | (inherited from Control).
Public event | Invalidated | (inherited from Control).
Public event | KeyDown | (inherited from Control).
Public event | KeyPress | (inherited from Control).
Public event | KeyUp | (inherited from Control).
Public event | Layout | (inherited from Control).
Public event | Leave | (inherited from Control).
Public event | LocationChanged | (inherited from Control).
Public event | LostFocus | (inherited from Control).
Public event | MarginChanged | (inherited from Control).
Public event | MouseCaptureChanged | (inherited from Control).
Public event | MouseClick | (inherited from Control).
Public event | MouseDoubleClick | (inherited from Control).
Public event | MouseDown | (inherited from Control).
Public event | MouseEnter | (inherited from Control).
Public event | MouseHover | (inherited from Control).
Public event | MouseLeave | (inherited from Control).
Public event | MouseMove | (inherited from Control).
Public event | MouseUp | (inherited from Control).
Public event | MouseWheel | (inherited from Control).
Public event | Move | (inherited from Control).
Public event | PaddingChanged | (inherited from Control).
Public event | Paint | (inherited from Control).
Public event | ParentChanged | (inherited from Control).
Public event | PreviewKeyDown | (inherited from Control).
Public event | QueryAccessibilityHelp | (inherited from Control).
Public event | QueryContinueDrag | (inherited from Control).
Public event | RegionChanged | (inherited from Control).
Public event | Resize | (inherited from Control).
Public event | RightToLeftChanged | (inherited from Control).
Public event | SizeChanged | (inherited from Control).
Public event | StyleChanged | (inherited from Control).
Public event | SystemColorsChanged | (inherited from Control).
Public event | TabIndexChanged | (inherited from Control).
Public event | TabStopChanged | (inherited from Control).
Public event | TextChanged | Occurs when .
Public event | Validated | (inherited from Control).
Public event | Validating | (inherited from Control).
Public event | VisibleChanged | (inherited from Control).
Top
See Also

Reference

Win8ProgressRing Class


BackColorChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackColorChangedEventHandler BackColorChanged
delegate void BackColorChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


BackgroundImageChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageChangedEventHandler BackgroundImageChanged
delegate void BackgroundImageChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


BackgroundImageLayoutChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event BackgroundImageLayoutChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event BackgroundImageLayoutChangedEventHandler BackgroundImageLayoutChanged
delegate void BackgroundImageLayoutChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


DockChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event DockChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event DockChangedEventHandler DockChanged
delegate void DockChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


FontChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event FontChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event FontChangedEventHandler FontChanged
delegate void FontChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


FrequencyChanged Event

This event will be raised every time Frequency property value changed

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Event FrequencyChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public event FrequencyChangedEventHandler FrequencyChanged
delegate void FrequencyChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

e

Type: EventArgs

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


TextChanged Event

Occurs when .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Event TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public event TextChangedEventHandler TextChanged
delegate void TextChangedEventHandler(
   object sender,
   EventArgs e
)
This language is not supported or no code example is available.

Parameters

sender

Type: object

The source of the event.

e

Type: EventArgs

An EventArgs that contains the event data.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

Win8ProgressRing Class
Win8ProgressRing Members


ListBoxImages.AddItem (System.String) Method

Add a new item to listbox with specified text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddItem( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddItem(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.AddItem (System.String, System.Int32) Method

Add a new item to listbox with specified text and image index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddItem( _
   ByVal sText As String, _
   ByVal iImageIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddItem(
   string sText,
   int iImageIndex
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

iImageIndex

Type: int

Item image index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.AddItem (System.String, System.String) Method

Add a new item to listbox with specified text and image key

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddItem( _
   ByVal sText As String, _
   ByVal sImageKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddItem(
   string sText,
   string sImageKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

sImageKey

Type: string

Item image key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.RemoveItem (Softgroup.NetControls.ListBoxImageItem) Method

Remove from listbox specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub RemoveItem( _
   ByVal Item As ListBoxImageItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveItem(
   ListBoxImageItem Item
)
This language is not supported or no code example is available.

Parameters

Item

Type: ListBoxImageItem

Item to remove

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.RemoveItem (System.Int32) Method

Remove from listbox specified item index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub RemoveItem( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void RemoveItem(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

Item index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetImage (System.Int32, System.Int32) Method

Change image index of specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetImage( _
   ByVal Index As Integer, _
   ByVal iImageIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetImage(
   int Index,
   int iImageIndex
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

iImageIndex

Type: int

Image index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetImage (System.Int32, System.String) Method

Change image index of specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetImage( _
   ByVal Index As Integer, _
   ByVal sImageKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetImage(
   int Index,
   string sImageKey
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

sImageKey

Type: string

Imahe key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetTextImage (System.Int32, System.String, System.Int32) Method

Change text and image index of specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetTextImage( _
   ByVal Index As Integer, _
   ByVal sText As String, _
   ByVal iImageIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetTextImage(
   int Index,
   string sText,
   int iImageIndex
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

sText

Type: string

Item text

iImageIndex

Type: int

Image index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.SetTextImage (System.Int32, System.String, System.String) Method

Change text and image key of specified item

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SetTextImage( _
   ByVal Index As Integer, _
   ByVal sText As String, _
   ByVal sImageKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SetTextImage(
   int Index,
   string sText,
   string sImageKey
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

sText

Type: string

Item text

sImageKey

Type: string

Image Key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindString (System.String) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Function FindString( _
   ByVal s As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
public int FindString(
   string s
)
This language is not supported or no code example is available.

Parameters

s

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindString (System.String, System.Int32) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Function FindString( _
   ByVal s As String, _
   ByVal startIndex As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
public int FindString(
   string s,
   int startIndex
)
This language is not supported or no code example is available.

Parameters

s

Type: string

startIndex

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindStringExact (System.String) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Function FindStringExact( _
   ByVal s As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
public int FindStringExact(
   string s
)
This language is not supported or no code example is available.

Parameters

s

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FindStringExact (System.String, System.Int32) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Function FindStringExact( _
   ByVal s As String, _
   ByVal startIndex As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
public int FindStringExact(
   string s,
   int startIndex
)
This language is not supported or no code example is available.

Parameters

s

Type: string

startIndex

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.IntegralHeight Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property IntegralHeight( _
   ByRef False As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("IntegralHeight")]
public int this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.Items Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBoxImages.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImages Class
ListBoxImages Members


ListBar.BackColor Property

Gets/Sets color used to paint the background of control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(True)> _
<Description("Gets/Sets color used to paint the background of control.")> _
<System.ComponentModel.Category("NetListBar")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Control")> _
Public Property BackColor( _
   ByRef "Gets/Sets color used to paint the background of control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(True)]
[Description("Gets/Sets color used to paint the background of control.")]
[System.ComponentModel.Category("NetListBar")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Control")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object "Gets/Sets color used to paint the background of control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets color used to paint the background of control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.BindingContext Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BindingContext( _
   ByRef False As Object _
) As BindingContext
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BindingContext")]
public BindingContext this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


NetTabPage.Show Method

Display NetTabPage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Display NetTabPage")> _
Public Overloads Sub Show()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Display NetTabPage")]
public System.Void Show()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.Show (System.Boolean) Method

Display NetTabPage and optionally select it

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Display NetTabPage and optionally select it")> _
Public Overloads Sub Show( _
   ByVal bSelect As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Display NetTabPage and optionally select it")]
public System.Void Show(
   bool bSelect
)
This language is not supported or no code example is available.

Parameters

bSelect

Type: bool

Make NetTabPage selected

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage.Enabled Property

Gets/Sets enabled state of NetTabPage

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(True)> _
<System.ComponentModel.Description("Gets/Sets enabled state of NetTabPage")> _
<EditorBrowsable(EditorBrowsableState.Always)> _
Public Property Enabled( _
   ByRef EditorBrowsableState.Always As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(True)]
[System.ComponentModel.Description("Gets/Sets enabled state of NetTabPage")]
[EditorBrowsable(EditorBrowsableState.Always)]
[System.Runtime.CompilerServices.IndexerName("Enabled")]
public bool this[
   ref object EditorBrowsableState.Always
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Always

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetButton.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetGIFAnimate.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetShellPreview.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Text( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property ForeColor( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Font( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property BackgroundImageLayout( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetGIFAnimate.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetShellPreview.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property BackgroundImage( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Margin( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


NetShellPreview.BackColor Property

Gets/Sets control background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets control background color")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "Window" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets control background color")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "Window"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Window"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetShellPreview Class
NetShellPreview Members


ProgressBlock.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


NetGIFAnimate.AutoScrollOffset Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollOffset( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollOffset")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ProgressBlock.BackColor Property

Gets/Sets background color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets background color of control")> _
<Category("ProgressBlock")> _
<DefaultValue(GetType(System.Drawing.Color), "White")> _
Public Property BackColor( _
   ByRef "ProgressBlock" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets background color of control")]
[Category("ProgressBlock")]
[DefaultValue(GetType(System.Drawing.Color), "White")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


NetGIFAnimate.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ProgressBlock.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


ProgressBlock.ForeColor Property

Gets/Sets foreground text color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets/Sets foreground text color of control")> _
<Category("ProgressBlock")> _
<DefaultValue(GetType(System.Drawing.Color), "Black")> _
Public Property ForeColor( _
   ByRef "ProgressBlock" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets/Sets foreground text color of control")]
[Category("ProgressBlock")]
[DefaultValue(GetType(System.Drawing.Color), "Black")]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object "ProgressBlock"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ProgressBlock"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBlock Class
ProgressBlock Members


OutlookBar Constructor

Create a new instance of the OutlookBar class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


NetGIFAnimate.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


OutlookBarGroup Constructor

Initializes a new instance of the OutlookBarGroup

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBarGroup()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


NetGIFAnimate.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


OutlookBarGroup Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the OutlookBarGroup

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBarGroup(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


OutlookBarGroup Constructor (System.String)

Initializes a new instance of the OutlookBarGroup with specified text

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBarGroup(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

The text of group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBarGroup Class
OutlookBarGroup Members


PrintPreview.DocumentPreview (System.Object) Method

Print document to preview window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Print document to preview window.")> _
Public Function DocumentPreview( _
   ByVal oControl As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Print document to preview window.")]
public bool DocumentPreview(
   object oControl
)
This language is not supported or no code example is available.

Parameters

oControl

Type: object

The control to print or preview (must me one of supported controls)

Return Value

True for success or False in case of user cancel printer/page dialog or if an error occurs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


NetGIFAnimate.AutoScrollPosition Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollPosition( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollPosition")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


PrintPreview.DocumentPreview (System.Object, System.Boolean) Method

Print document to preview window.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Print document to preview window.")> _
Public Function DocumentPreview( _
   ByVal oControl As Object, _
   ByVal DisplayDialog As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Print document to preview window.")]
public bool DocumentPreview(
   object oControl,
   bool DisplayDialog
)
This language is not supported or no code example is available.

Parameters

oControl

Type: object

The control to print or preview (must me one of supported controls)

DisplayDialog

Type: bool

True to display printer dialog otherwise False.

Return Value

True for success or False in case of user cancel printer/page dialog or if an error occurs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DocumentPrint (System.Object) Method

Print document to the printer.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Print document to the printer.")> _
Public Function DocumentPrint( _
   ByVal oControl As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Print document to the printer.")]
public bool DocumentPrint(
   object oControl
)
This language is not supported or no code example is available.

Parameters

oControl

Type: object

The control to print or preview (must me one of supported controls)

Return Value

True for success or False in case of user cancel printer/page dialog or if an error occurs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DocumentPrint (System.Object, System.Boolean) Method

Print document to the printer.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Print document to the printer.")> _
Public Function DocumentPrint( _
   ByVal oControl As Object, _
   ByVal DisplayDialog As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Print document to the printer.")]
public bool DocumentPrint(
   object oControl,
   bool DisplayDialog
)
This language is not supported or no code example is available.

Parameters

oControl

Type: object

The control to print or preview (must me one of supported controls)

DisplayDialog

Type: bool

True to display printer dialog otherwise False.

Return Value

True for success or False in case of user cancel printer/page dialog or if an error occurs
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


NetGIFAnimate.DefaultForeColor Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Shared Property DefaultForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public static Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


PrintPreview.SetAutoScrollMargin Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void SetAutoScrollMargin(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

y

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Validate Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Validate (System.Boolean) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate(
   bool checkAutoValidate
)
This language is not supported or no code example is available.

Parameters

checkAutoValidate

Type: bool

If set to true, then ; otherwise, .

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ValidateChildren Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ValidateChildren (System.Windows.Forms.ValidationConstraints) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren(
   ValidationConstraints validationConstraints
)
This language is not supported or no code example is available.

Parameters

validationConstraints

Type: ValidationConstraints

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultFont Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Shared Property DefaultFont( _
   ByRef False As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DefaultFont")]
public static Font this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


NetGIFAnimate.VerticalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property VerticalScroll( _
   ByRef False As Object _
) As VScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("VerticalScroll")]
public VScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


PrintPreview.HorizontalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property HorizontalScroll( _
   ByRef False As Object _
) As HScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("HorizontalScroll")]
public HScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultBackColor Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Shared Property DefaultBackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public static Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollOffset Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollOffset( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollOffset")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


NetGIFAnimate.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


PrintPreview.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Font( _
   ByRef False As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.AutoScrollPosition Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollPosition( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollPosition")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.BindingContext Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BindingContext( _
   ByRef False As Object _
) As BindingContext
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BindingContext")]
public BindingContext this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.DefaultForeColor Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Shared Property DefaultForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public static Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


NetThumbnailMouseEventArgs Constructor (System.Windows.Forms.MouseEventArgs, Softgroup.NetControls.NetThumbImage)

Create a new instance of the class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByRef e As MouseEventArgs, _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnailMouseEventArgs(
   ref MouseEventArgs e,
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

e

Type: MouseEventArgs

oThumbImage

Type: NetThumbImage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailMouseEventArgs Class
NetThumbnailMouseEventArgs Members


NetAnimation.Play (System.String) Method

Plays the specified file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the specified file")> _
Public Sub Play( _
   ByVal sFileName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the specified file")]
public System.Void Play(
   string sFileName
)
This language is not supported or no code example is available.

Parameters

sFileName

Type: string

File name of the avi animation to play. The FileName property is updated with this value

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetExtraLine.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.RightToLeft Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DefaultValue(False)> _
Public Property RightToLeft( _
   ByRef EditorBrowsableState.Never As Object _
) As RightToLeft
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("RightToLeft")]
public RightToLeft this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DefaultValue(False)> _
Public Property TabStop( _
   ByRef EditorBrowsableState.Never As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("TabStop")]
public bool this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetTabPage Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the NetTabPage class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public NetTabPage(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


NetTabPage Constructor

Initializes a new instance of the NetTabPage class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public NetTabPage()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabPage Class
NetTabPage Members


ListBoxImageItem Constructor (System.String)

Create new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ListBoxImageItem(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


NetAnimation.Play (System.Int32, System.Int32, System.Int32) Method

Plays the AnimationSource a specified number of times starting with a particular frame and ending with a particular frame.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the AnimationSource a specified number of times starting with a particular frame and ending with a particular frame.")> _
Public Sub Play( _
   ByVal Repetitions As Integer, _
   ByVal StartFrame As Integer, _
   ByVal EndFrame As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the AnimationSource a specified number of times starting with a particular frame and ending with a particular frame.")]
public System.Void Play(
   int Repetitions,
   int StartFrame,
   int EndFrame
)
This language is not supported or no code example is available.

Parameters

Repetitions

Type: int

Number of times to play the animation. -1 indicates unlimited cycles

StartFrame

Type: int

Starting frame number. 0 is the first frame

EndFrame

Type: int

Ending frame number. -1 indicates the last frame

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


ListBoxImageItem Constructor (System.String, System.Int32)

Create new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal iImageIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ListBoxImageItem(
   string sText,
   int iImageIndex
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

iImageIndex

Type: int

Item image index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ListBoxImageItem Constructor (System.String, System.String)

Create new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal sImageKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ListBoxImageItem(
   string sText,
   string sImageKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text

sImageKey

Type: string

Item image key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBoxImageItem Class
ListBoxImageItem Members


ComboImages.DisplayMember Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DisplayMember( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DisplayMember")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.AutoCompleteMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteMode( _
   ByRef False As Object _
) As AutoCompleteMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteMode")]
public AutoCompleteMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DefaultBackColor Property

Gets default background color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets default background color for control.")> _
Public ReadOnly Property DefaultBackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets default background color for control.")]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


NetAnimation.Play (System.Int32) Method

Plays the AnimationSource a specified number of times

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the AnimationSource a specified number of times")> _
Public Sub Play( _
   ByVal Repetitions As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the AnimationSource a specified number of times")]
public System.Void Play(
   int Repetitions
)
This language is not supported or no code example is available.

Parameters

Repetitions

Type: int

Number of times to play the animation. -1 indicates unlimited cycles

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


ComboImages.DefaultForeColor Property

Gets default foreground color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Description("Gets default foreground color for control.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property DefaultForeColor( _
   ByRef "Gets default foreground color for control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Description("Gets default foreground color for control.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public Color this[
   ref object "Gets default foreground color for control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets default foreground color for control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DataSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataSource( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataSource")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.AutoCompleteSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteSource( _
   ByRef False As Object _
) As AutoCompleteSource
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteSource")]
public AutoCompleteSource this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.AutoCompleteCustomSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteCustomSource( _
   ByRef False As Object _
) As AutoCompleteStringCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteCustomSource")]
public AutoCompleteStringCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboImages")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DefaultValue("")> _
Public Property Text( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboImages")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DropDownStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DropDownStyle( _
   ByRef False As Object _
) As ComboBoxStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DropDownStyle")]
public ComboBoxStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Items Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.DataBindings Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboImages Class
ComboImages Members


ComboPrinters.DisplayMember Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DisplayMember( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DisplayMember")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


NetAnimation.Play Method

Plays the animation specified by the AnimationSource property

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the animation specified by the AnimationSource property")> _
Public Sub Play()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the animation specified by the AnimationSource property")]
public System.Void Play()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


ComboPrinters.AutoCompleteMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteMode( _
   ByRef False As Object _
) As AutoCompleteMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteMode")]
public AutoCompleteMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DataSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataSource( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataSource")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property Items( _
   ByRef System.ComponentModel.DesignerSerializationVisibility.Hidden As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object System.ComponentModel.DesignerSerializationVisibility.Hidden
] {get;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoCompleteCustomSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteCustomSource( _
   ByRef False As Object _
) As AutoCompleteStringCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteCustomSource")]
public AutoCompleteStringCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DefaultBackColor Property

Gets default background color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets default background color for control.")> _
Public ReadOnly Property DefaultBackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets default background color for control.")]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DropDownStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DropDownStyle( _
   ByRef False As Object _
) As ComboBoxStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DropDownStyle")]
public ComboBoxStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoCompleteSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteSource( _
   ByRef False As Object _
) As AutoCompleteSource
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteSource")]
public AutoCompleteSource this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DefaultForeColor Property

Gets default foreground color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Description("Gets default foreground color for control.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property DefaultForeColor( _
   ByRef "Gets default foreground color for control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Description("Gets default foreground color for control.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public Color this[
   ref object "Gets default foreground color for control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets default foreground color for control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboPrinters")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DefaultValue("")> _
Public Property Text( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboPrinters")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.DataBindings Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboPrinters Class
ComboPrinters Members


ExplorerBar.BackColor Property

Gets/Sets color used to paint the background of control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(True)> _
<Description("Gets/Sets color used to paint the background of control.")> _
<System.ComponentModel.Category("NetListBar")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Control")> _
Public Property BackColor( _
   ByRef "Gets/Sets color used to paint the background of control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(True)]
[Description("Gets/Sets color used to paint the background of control.")]
[System.ComponentModel.Category("NetListBar")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Control")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object "Gets/Sets color used to paint the background of control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets color used to paint the background of control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ExplorerBar.BindingContext Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property BindingContext( _
   ByRef False As Object _
) As BindingContext
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BindingContext")]
public BindingContext this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


NetThumbnailMouseEventArgs Constructor (System.Windows.Forms.MouseButtons, System.Int32, System.Int32, System.Int32, System.Int32, Softgroup.NetControls.NetThumbImage)

Create a new instance of the class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByRef eButton As MouseButtons, _
   ByRef iClicks As Integer, _
   ByRef xPos As Integer, _
   ByRef yPos As Integer, _
   ByRef iDelta As Integer, _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnailMouseEventArgs(
   ref MouseButtons eButton,
   ref int iClicks,
   ref int xPos,
   ref int yPos,
   ref int iDelta,
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

eButton

Type: MouseButtons

iClicks

Type: int

xPos

Type: int

yPos

Type: int

iDelta

Type: int

oThumbImage

Type: NetThumbImage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailMouseEventArgs Class
NetThumbnailMouseEventArgs Members


ComboFonts.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DefaultValue("")> _
<System.ComponentModel.Category("ComboFonts")> _
Public Property Text( _
   ByRef "Gets currently text of control." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DefaultValue("")]
[System.ComponentModel.Category("ComboFonts")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object "Gets currently text of control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets currently text of control."

Type: object

Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.AutoCompleteSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteSource( _
   ByRef False As Object _
) As AutoCompleteSource
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteSource")]
public AutoCompleteSource this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DefaultBackColor Property

Gets default background color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboFonts")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets default background color for control.")> _
Public ReadOnly Property DefaultBackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboFonts")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets default background color for control.")]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.AutoCompleteMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteMode( _
   ByRef False As Object _
) As AutoCompleteMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteMode")]
public AutoCompleteMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ListBarGroups.IndexOf (Softgroup.NetControls.ListBarGroup) Method

Gets the index of the specified Group within this collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal oGroup As ListBarGroup _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ListBarGroup

The group to find the index for.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.IndexOf (System.String) Method

Gets the index of the specified Group key within this collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal sKey As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

Key of group.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Add Method

Adds a new Group in the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Add (System.String) Method

Adds a new Group in the collection with spcified Text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Add (System.String, System.String) Method

Adds a new Group in the collection with specified Text and Key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

sKey

Type: string

A string key associated with this group.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Add (System.String, System.String, System.Drawing.Image) Method

Adds a new Group in the collection with spcified Text, Key and Image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

sKey

Type: string

A string key associated with this group.

oImage

Type: Image

The image displayed with group.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Add (Softgroup.NetControls.ListBarGroup) Method

Adds specified Group in the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal oGroup As ListBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ListBarGroup

A valid Group object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Remove (Softgroup.NetControls.ListBarGroup) Method

Removes the specified Group .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal oGroup As ListBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   ListBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ListBarGroup

The group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Remove (System.Int32) Method

Removes the specified Index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

The index of group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Remove (System.String) Method

Removes group with specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

The key of group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Item (System.String) Property

Gets the ListBarItem object in the group with the specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal Key As String _
) As ListBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public ListBarGroup this[
   string Key
] {get;}
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key of Item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


ListBarGroups.Item (System.Int32) Property

Gets the ListBarItem object in the group at the specified index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ListBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public ListBarGroup this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of Item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroups Class
ListBarGroups Members


NetPanel.DefaultBackColor Property

Gets default background colour

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets default background colour")> _
<Category("NetPanel")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
Public ReadOnly Shared Property DefaultBackColor( _
   ByRef "NetPanel" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets default background colour")]
[Category("NetPanel")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public static Color this[
   ref object "NetPanel"
] {get;}
This language is not supported or no code example is available.

Parameters

"NetPanel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


NetPanel.Text Property

Gets/Sets the text of panel

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DefaultValue("")> _
<Description("Gets/Sets the text of panel")> _
<Category("NetPanel")> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)> _
<Browsable(True)> _
Public Property Text( _
   ByRef "Gets/Sets the text of panel" As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DefaultValue("")]
[Description("Gets/Sets the text of panel")]
[Category("NetPanel")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(True)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object "Gets/Sets the text of panel"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets/Sets the text of panel"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPanel Class
NetPanel Members


ListBar Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the ListBar class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ListBar(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


ListBar Constructor

Initializes a new instance of the ListBar class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ListBar()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBar Class
ListBar Members


NetMDIBar.GripMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property GripMargin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("GripMargin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.ImageList Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ImageList( _
   ByRef False As Object _
) As ImageList
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ImageList")]
public ImageList this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.CanOverflow Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CanOverflow( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CanOverflow")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.Items Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ToolStripItemCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ToolStripItemCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.TextDirection Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property TextDirection( _
   ByRef False As Object _
) As ToolStripTextDirection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("TextDirection")]
public ToolStripTextDirection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutEngine Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property LayoutEngine( _
   ByRef False As Object _
) As LayoutEngine
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("LayoutEngine")]
public LayoutEngine this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.MinimumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MinimumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MinimumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property LayoutStyle( _
   ByRef False As Object _
) As ToolStripLayoutStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("LayoutStyle")]
public ToolStripLayoutStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.LayoutSettings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property LayoutSettings( _
   ByRef False As Object _
) As LayoutSettings
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("LayoutSettings")]
public LayoutSettings this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripDisplayStyle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property GripDisplayStyle( _
   ByRef False As Object _
) As ToolStripGripDisplayStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("GripDisplayStyle")]
public ToolStripGripDisplayStyle this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripRectangle Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property GripRectangle( _
   ByRef False As Object _
) As Rectangle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("GripRectangle")]
public Rectangle this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.GripStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property GripStyle( _
   ByRef False As Object _
) As ToolStripGripStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("GripStyle")]
public ToolStripGripStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AllowMerge Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AllowMerge( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AllowMerge")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.MaximumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MaximumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MaximumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.AllowItemReorder Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AllowItemReorder( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AllowItemReorder")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetMDIBar.Stretch Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Stretch( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Stretch")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIBar Class
NetMDIBar Members


NetThumbnail.AddFromFolder (System.String, System.Boolean) Method

Add images into control from specified folder

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddFromFolder( _
   ByVal FolderName As String, _
   ByVal IncludeSubFolders As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddFromFolder(
   string FolderName,
   bool IncludeSubFolders
)
This language is not supported or no code example is available.

Parameters

FolderName

Type: string

Folder name

IncludeSubFolders

Type: bool

True to include subfolders otherwise False

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.BackColor Property

Gets the background color of control

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets the background color for control")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")> _
<System.ComponentModel.Category("NetThumbnail")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "Window" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets the background color for control")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")]
[System.ComponentModel.Category("NetThumbnail")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "Window"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Window"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Font( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


ComboList.GetItemText Method

Gets the text of specified item Index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Function GetItemText( _
   ByVal Index As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public string GetItemText(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

A valid item index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Text( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ExplorerBarGroups.Add (System.String, System.String, System.Drawing.Image) Method

Adds a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oTitleImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey,
   Image oTitleImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

sKey

Type: string

Group key

oTitleImage

Type: Image

Image for group title

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Add (Softgroup.NetControls.ExplorerBarGroup) Method

Adds a new ExplorerBarGroup.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal oGroup As ExplorerBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

Group to add.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


NetWizardPage.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetLineSeparator.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
<DefaultValue(False)> _
Public Property TabStop( _
   ByRef EditorBrowsableState.Never As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("TabStop")]
public bool this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


ExplorerBarItem Constructor

Create a new instance of this class. Default Item type is LinkLabel.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (System.String)

Create a new instance of this class with specified parameters. Default Item type is LinkLabel.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (System.String, System.String)

Create a new instance of this class with specified parameters. Default Item type is LinkLabel.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (System.String, System.String, System.Drawing.Image)

Create a new instance of this class with specified parameters. Default Item type is LinkLabel.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

oImage

Type: Image

A valid Image object for item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum)

Create a new instance of this class with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal eItemType As ExplorerBarItemTypeEnum _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   ExplorerBarItemTypeEnum eItemType
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String)

Create a new instance of this class with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   ExplorerBarItemTypeEnum eItemType,
   string sText
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarGroup Constructor

Constructs a new, instance of this class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup Constructor (System.String)

Create a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


NetGIFAnimate.SetAutoScrollMargin Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void SetAutoScrollMargin(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

y

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ProgressBar.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


NetGIFAnimate.Validate Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetNotify.Display (System.Boolean) Method

Display notification window activated or not activated.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Display( _
   ByVal Activate As Boolean _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Display(
   bool Activate
)
This language is not supported or no code example is available.

Parameters

Activate

Type: bool

True to display and activate notification window otherwise False

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


NetGIFAnimate.Validate (System.Boolean) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate(
   bool checkAutoValidate
)
This language is not supported or no code example is available.

Parameters

checkAutoValidate

Type: bool

If set to true, then ; otherwise, .

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ValidateChildren Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.ValidateChildren (System.Windows.Forms.ValidationConstraints) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren(
   ValidationConstraints validationConstraints
)
This language is not supported or no code example is available.

Parameters

validationConstraints

Type: ValidationConstraints

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.BindingContext Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BindingContext( _
   ByRef False As Object _
) As BindingContext
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BindingContext")]
public BindingContext this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.DefaultFont Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Shared Property DefaultFont( _
   ByRef False As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DefaultFont")]
public static Font this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Font( _
   ByRef False As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetCalculator.ValidateChildren Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.ValidateChildren (System.Windows.Forms.ValidationConstraints) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool ValidateChildren(
   ValidationConstraints validationConstraints
)
This language is not supported or no code example is available.

Parameters

validationConstraints

Type: ValidationConstraints

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AllowDrop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AllowDrop( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AllowDrop")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetGIFAnimate.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetGIFAnimate.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ComboDrives.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DisplayMember Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DisplayMember( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DisplayMember")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoCompleteMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteMode( _
   ByRef False As Object _
) As AutoCompleteMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteMode")]
public AutoCompleteMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DefaultForeColor Property

Gets default foreground color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets default foreground color for control.")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Category("ComboDrives")> _
Public ReadOnly Property DefaultForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets default foreground color for control.")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Category("ComboDrives")]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoCompleteCustomSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteCustomSource( _
   ByRef False As Object _
) As AutoCompleteStringCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteCustomSource")]
public AutoCompleteStringCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


NetGIFAnimate.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


ComboDrives.DataBindings Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboFonts Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the ComboFonts class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboFonts(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts Constructor

Initializes a new instance of the ComboFonts class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboFonts()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


NetGIFAnimate.HorizontalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property HorizontalScroll( _
   ByRef False As Object _
) As HScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("HorizontalScroll")]
public HScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetGIFAnimate Class
NetGIFAnimate Members


NetAnimation.Open (System.String) Method

Opens the specified avi animation file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Opens the specified avi animation file")> _
Public Sub Open( _
   ByVal filename As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Opens the specified avi animation file")]
public System.Void Open(
   string filename
)
This language is not supported or no code example is available.

Parameters

filename

Type: string

Filename of the animation to open. The FileName property is updated with this value

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetAnimation.Open Method

Opens the avi animation source specified by the AnimationSource property

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Opens the avi animation source specified by the AnimationSource property")> _
Public Sub Open()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Opens the avi animation source specified by the AnimationSource property")]
public System.Void Open()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


ListBarItems.Add Method

Adds a new empty Item object into the Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Add (System.String) Method

Adds a new ListBarItem object in the group with specified Text.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Add (System.String, System.String) Method

Adds a new ListBarItem object in the group with specified Text and Key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

sKey

Type: string

a user-defined string value which can be used to look up the item in the collection which owns it

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Add (System.String, System.String, System.Drawing.Image, System.Drawing.Image) Method

Adds a new ListBarItem object in the group with specified Text, Key, Small and Large image.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oSmallImage As Image, _
   ByVal oLargeImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey,
   Image oSmallImage,
   Image oLargeImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

sKey

Type: string

A user-defined string value which can be used to look up the item in the collection which owns it

oSmallImage

Type: Image

A valid image displayed with this item.

oLargeImage

Type: Image

A valid image displayed with this item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Add (Softgroup.NetControls.ListBarItem) Method

Adds specified ListBarItem object in the group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ListBarItem

The new Item to add.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


NetAnimation.Play (System.String, System.Int32, System.Int32, System.Int32) Method

Plays the specified file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the specified file")> _
Public Sub Play( _
   ByVal sFileName As String, _
   ByVal Repetitions As Integer, _
   ByVal StartFrame As Integer, _
   ByVal EndFrame As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the specified file")]
public System.Void Play(
   string sFileName,
   int Repetitions,
   int StartFrame,
   int EndFrame
)
This language is not supported or no code example is available.

Parameters

sFileName

Type: string

File name of the avi animation to play. The FileName property is updated with this value

Repetitions

Type: int

Number of times to play the animation. -1 indicates unlimited cycles

StartFrame

Type: int

Starting frame number. 0 is the first frame

EndFrame

Type: int

Ending frame number. -1 indicates the last frame

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


ListBarItems.Remove (System.String) Method

Removes the specified key from the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key of item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Sort (System.Collections.IComparer) Method

Sorts the items in this collection using the specified comparer.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Sort( _
   ByVal comparer As IComparer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Sort(
   IComparer comparer
)
This language is not supported or no code example is available.

Parameters

comparer

Type: IComparer

IComparer implementation specifying how to sort the objects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Sort Method

Sorts the items in this collection using the default comparison operation (alphabetic).

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Sort()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Sort()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Item (System.Int32) Property

Gets the ListBarItem at the specified index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public ListBarItem this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Item (System.String) Property

Gets the ListBarItem with specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Default Public ReadOnly Property Item( _
   ByVal key As String _
) As ListBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Runtime.CompilerServices.IndexerName("Item")]
public ListBarItem this[
   string key
] {get;}
This language is not supported or no code example is available.

Parameters

key

Type: string

Key of item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


NetAnimation.Play (System.String, System.Int32) Method

Plays the specified file

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Plays the specified file")> _
Public Sub Play( _
   ByVal sFileName As String, _
   ByVal Repetitions As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Plays the specified file")]
public System.Void Play(
   string sFileName,
   int Repetitions
)
This language is not supported or no code example is available.

Parameters

sFileName

Type: string

File name of the avi animation to play. The FileName property is updated with this value

Repetitions

Type: int

Number of times to play the animation. -1 indicates unlimited cycles

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetAnimation Class
NetAnimation Members


NetExtraLine.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Font( _
   ByRef EditorBrowsableState.Never As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetThumbnailKeyEventArgs Constructor (System.Windows.Forms.KeyEventArgs, Softgroup.NetControls.NetThumbImage)

Create a new instance of the class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByRef e As KeyEventArgs, _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnailKeyEventArgs(
   ref KeyEventArgs e,
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

e

Type: KeyEventArgs

oThumbImage

Type: NetThumbImage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailKeyEventArgs Class
NetThumbnailKeyEventArgs Members


NetThumbnailKeyEventArgs Constructor (System.Windows.Forms.Keys, Softgroup.NetControls.NetThumbImage)

Create a new instance of the class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByRef okeyData As Keys, _
   ByVal oThumbImage As NetThumbImage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public NetThumbnailKeyEventArgs(
   ref Keys okeyData,
   NetThumbImage oThumbImage
)
This language is not supported or no code example is available.

Parameters

okeyData

Type: Keys

oThumbImage

Type: NetThumbImage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnailKeyEventArgs Class
NetThumbnailKeyEventArgs Members


ComboColors.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DefaultValue("")> _
Public Property Text( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DefaultValue("")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.AutoCompleteCustomSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteCustomSource( _
   ByRef False As Object _
) As AutoCompleteStringCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteCustomSource")]
public AutoCompleteStringCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DataBindings Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.AutoCompleteSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteSource( _
   ByRef False As Object _
) As AutoCompleteSource
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteSource")]
public AutoCompleteSource this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DefaultForeColor Property

Gets default foreground color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Description("Gets default foreground color for control.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property DefaultForeColor( _
   ByRef "Gets default foreground color for control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Description("Gets default foreground color for control.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public Color this[
   ref object "Gets default foreground color for control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets default foreground color for control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


NetTabControl.DeselectTab (System.Int32) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub DeselectTab( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void DeselectTab(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DeselectTab (System.String) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub DeselectTab( _
   ByVal tabPageName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void DeselectTab(
   string tabPageName
)
This language is not supported or no code example is available.

Parameters

tabPageName

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DeselectTab (System.Windows.Forms.TabPage) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub DeselectTab( _
   ByVal tabPage As TabPage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void DeselectTab(
   TabPage tabPage
)
This language is not supported or no code example is available.

Parameters

tabPage

Type: TabPage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UpdateTabPageFocus (System.Int32, System.Windows.Forms.Control) Method

Sets focus of specified tabepage on specified control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub UpdateTabPageFocus( _
   ByVal iTabPageIndex As Integer, _
   ByVal oControl As Control _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void UpdateTabPageFocus(
   int iTabPageIndex,
   Control oControl
)
This language is not supported or no code example is available.

Parameters

iTabPageIndex

Type: int

TabPage index to update focus

oControl

Type: Control

Control that must receive focus

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


ComboColors Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the ComboColors class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboColors(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors Constructor

Initializes a new instance of the ComboColors class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboColors()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


NetWizard.MinimumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MinimumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MinimumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScroll( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoScrollMinSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMinSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMinSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetTabControl Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the NetTabControl class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public NetTabControl(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl Constructor

Initializes a new instance of the NetTabControl class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public NetTabControl()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


ExplorerBarItems.Add (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String, System.String) Method

Adds a new ExplorerBarItem object with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarItemTypeEnum eItemType,
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String, System.String, System.Drawing.Image) Method

Adds a new ExplorerBarItem object with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarItemTypeEnum eItemType,
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

oImage

Type: Image

A valid Image object for item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (Softgroup.NetControls.ExplorerBarItem) Method

Adds a new ExplorerBarItem object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal oItem As ExplorerBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ExplorerBarItem

Item to add.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ComboFonts.DropDownStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DropDownStyle( _
   ByRef False As Object _
) As ComboBoxStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DropDownStyle")]
public ComboBoxStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.AutoCompleteCustomSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteCustomSource( _
   ByRef False As Object _
) As AutoCompleteStringCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteCustomSource")]
public AutoCompleteStringCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DataBindings Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Category("ComboFonts")> _
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Category("ComboFonts")]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DataSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataSource( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataSource")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.DefaultForeColor Property

Gets default foreground color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboFonts")> _
<System.ComponentModel.Description("Gets default foreground color for control.")> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property DefaultForeColor( _
   ByRef "Gets default foreground color for control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboFonts")]
[System.ComponentModel.Description("Gets default foreground color for control.")]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DefaultForeColor")]
public Color this[
   ref object "Gets default foreground color for control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets default foreground color for control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


NetSplitButtonAppearance.Equals Method

Determines whether the specified Object is equal to this instance.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.

Parameters

obj

Type: object

The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception type | Condition
NullReferenceException | The obj parameter is null.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetSplitButtonAppearance Class
NetSplitButtonAppearance Members


ListBarGroup Constructor

Create a new ListBarGroup object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new instance of the class.")> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new instance of the class.")]
public ListBarGroup()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Constructor (System.String)

Create a new ListBarGroup object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new instance of the class.")> _
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new instance of the class.")]
public ListBarGroup(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


NetPictureScroll.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property ForeColor( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetThumbnail.AddFromFolder (System.String) Method

Add images into control from specified folder

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub AddFromFolder( _
   ByVal FolderPath As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void AddFromFolder(
   string FolderPath
)
This language is not supported or no code example is available.

Parameters

FolderPath

Type: string

Folder name

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property ForeColor( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetThumbnail.AutoScroll Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property AutoScroll( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("AutoScroll")]
public bool this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetThumbnail Class
NetThumbnail Members


NetButton.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


NetButton.BackColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetButton Class
NetButton Members


ComboList.FormattingEnabled Property

Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(False)> _
Public Property FormattingEnabled( _
   ByRef "ComboList" As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets a value indicating whether type conversion and formatting is applied to the control property data.")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(False)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ComboList.ItemHeight Property

Gets or sets the height items in the combo box

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets or sets the height items in the combo box")> _
<System.ComponentModel.Category("ComboList")> _
<System.ComponentModel.DefaultValue(13)> _
Public Property ItemHeight( _
   ByRef "ComboList" As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets or sets the height items in the combo box")]
[System.ComponentModel.Category("ComboList")]
[System.ComponentModel.DefaultValue(13)]
[System.Runtime.CompilerServices.IndexerName("ItemHeight")]
public int this[
   ref object "ComboList"
] {get; set;}
This language is not supported or no code example is available.

Parameters

"ComboList"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboList Class
ComboList Members


ExplorerBarGroups.IndexOf (Softgroup.NetControls.ExplorerBarGroup) Method

Gets the index of the specified ExplorerBarGroup within this collection or -1 if not found.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal oGroup As ExplorerBarGroup _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   ExplorerBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

The ExplorerBarGroup to find the index for.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.IndexOf (System.String) Method

Gets the index of the specified ExplorerBarGroup key within this collection or -1 if not found.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal sKey As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

Key of ExplorerBarGroup to find the index for.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Add Method

Adds a new ExplorerBarGroup.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Add (System.String) Method

Adds a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Add (System.String, System.String) Method

Adds a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

sKey

Type: string

Group key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Remove (System.String) Method

Removes object with specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

The key of group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Remove (Softgroup.NetControls.ExplorerBarGroup) Method

Removes the specified Group.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByRef oGroup As ExplorerBarGroup _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   ref ExplorerBarGroup oGroup
)
This language is not supported or no code example is available.

Parameters

oGroup

Type: ExplorerBarGroup

The Group to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Item (System.Int32) Property

Gets the ExplorerBarItem object in the group at the specified index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ExplorerBarItem object in the group at the specified index.")> _
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ExplorerBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ExplorerBarItem object in the group at the specified index.")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ExplorerBarGroup this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of Item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


ExplorerBarGroups.Item (System.String) Property

Gets the ExlorerBarItem object in the group with the specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ExlorerBarItem object in the group with the specified key.")> _
Default Public ReadOnly Property Item( _
   ByVal Key As String _
) As ExplorerBarGroup
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ExlorerBarItem object in the group with the specified key.")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ExplorerBarGroup this[
   string Key
] {get;}
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key of Item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroups Class
ExplorerBarGroups Members


NetWizardPage.MaximumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MaximumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MaximumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.Anchor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<DefaultValue(GetType(AnchorStyles), "None")> _
Public Property Anchor( _
   ByRef False As Object _
) As AnchorStyles
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[DefaultValue(GetType(AnchorStyles), "None")]
[System.Runtime.CompilerServices.IndexerName("Anchor")]
public AnchorStyles this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.MinimumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MinimumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MinimumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.Dock Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<DefaultValue(GetType(DockStyle), "Fill")> _
Public Property Dock( _
   ByRef False As Object _
) As DockStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[DefaultValue(GetType(DockStyle), "Fill")]
[System.Runtime.CompilerServices.IndexerName("Dock")]
public DockStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TabIndex Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property TabIndex( _
   ByRef False As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("TabIndex")]
public int this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property TabStop( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("TabStop")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetWizardPage.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizardPage Class
NetWizardPage Members


NetLineSeparator.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.ImeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
<Browsable(False)> _
Public Property ImeMode( _
   ByRef False As Object _
) As ImeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ImeMode")]
public ImeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


NetLineSeparator.TabIndex Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property TabIndex( _
   ByRef False As Object _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("TabIndex")]
public int this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetLineSeparator Class
NetLineSeparator Members


ComboDrives Constructor (System.ComponentModel.IContainer)

Initializes a new instance of the ComboDrives class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboDrives(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives Constructor

Initializes a new instance of the ComboDrives class.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.Diagnostics.DebuggerNonUserCode()> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.Diagnostics.DebuggerNonUserCode()]
public ComboDrives()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ExplorerBarItem Constructor (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String, System.String)

Create a new instance of this class with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   ExplorerBarItemTypeEnum eItemType,
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarItem Constructor (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String, System.String, System.Drawing.Image)

Create a new instance of this class with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarItem(
   ExplorerBarItemTypeEnum eItemType,
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

oImage

Type: Image

A valid Image object for item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItem Class
ExplorerBarItem Members


ExplorerBarGroup Constructor (System.String, System.String)

Create a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

sKey

Type: string

Group key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ExplorerBarGroup Constructor (System.String, System.String, System.Drawing.Image)

Create a new ExplorerBarGroup with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oTitleImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ExplorerBarGroup(
   string sText,
   string sKey,
   Image oTitleImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Group text

sKey

Type: string

Group key

oTitleImage

Type: Image

Image for group title

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarGroup Class
ExplorerBarGroup Members


ToolStripColorPicker Constructor

Initializes a new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ToolStripColorPicker()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ToolStripColorPicker Constructor (System.Drawing.Color)

Initiala new instance of the class with specified color

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal oColor As Color _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public ToolStripColorPicker(
   Color oColor
)
This language is not supported or no code example is available.

Parameters

oColor

Type: Color

The color to assign to the color picker control

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripColorPicker Class
ToolStripColorPicker Members


ProgressLoop.TabStop Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property TabStop( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("TabStop")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressLoop Class
ProgressLoop Members


ProgressBar.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ProgressBar Class
ProgressBar Members


NetMDIManager Constructor

Initializes a new instance of the class

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<CodeAnalysis.SuppressMessage("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[CodeAnalysis.SuppressMessage("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")]
public NetMDIManager()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetMDIManager Constructor (System.Windows.Forms.Form)

Initializes a new instance of the class with specified MDI parent form.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<CodeAnalysis.SuppressMessage("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")> _
Public Sub New( _
   ByVal oParentForm As Form _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[CodeAnalysis.SuppressMessage("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")]
public NetMDIManager(
   Form oParentForm
)
This language is not supported or no code example is available.

Parameters

oParentForm

Type: Form

A valid MDI parent form.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetMDIManager Class
NetMDIManager Members


NetNotify.Display Method

Display notification window without active activate it

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Display()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Display()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetNotify Class
NetNotify Members


OutlookBar Constructor (System.ComponentModel.IContainer)

Create a new instance of the OutlookBar class with specified container

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub New( _
   ByVal container As IContainer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public OutlookBar(
   IContainer container
)
This language is not supported or no code example is available.

Parameters

container

Type: IContainer

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

OutlookBar Class
OutlookBar Members


ListBarItem Constructor

Create a new ListBarItem object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new ListBarItem object.")> _
Public Sub New()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new ListBarItem object.")]
public ListBarItem()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Constructor (System.String)

Create a new ListBarItem object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new ListBarItem object.")> _
Public Sub New( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new ListBarItem object.")]
public ListBarItem(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Constructor (System.String, System.Drawing.Image, System.Drawing.Image)

Create a new ListBarItem object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new ListBarItem object.")> _
Public Sub New( _
   ByVal sText As String, _
   ByVal oSmallImage As Image, _
   ByVal oLargeImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new ListBarItem object.")]
public ListBarItem(
   string sText,
   Image oSmallImage,
   Image oLargeImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

oSmallImage

Type: Image

A valid image displayed with this item.

oLargeImage

Type: Image

A valid image displayed with this item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


ListBarItem Constructor (System.String, System.String, System.Drawing.Image, System.Drawing.Image)

Create a new ListBarItem object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new ListBarItem object.")> _
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oSmallImage As Image, _
   ByVal oLargeImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new ListBarItem object.")]
public ListBarItem(
   string sText,
   string sKey,
   Image oSmallImage,
   Image oLargeImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this item

sKey

Type: string

a user-defined string value which can be used to look up the item in the collection which owns it

oSmallImage

Type: Image

A valid small image displayed with this item.

oLargeImage

Type: Image

A valid large image displayed with this item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItem Class
ListBarItem Members


NetCalculator.SetAutoScrollMargin Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public System.Void SetAutoScrollMargin(
   int x,
   int y
)
This language is not supported or no code example is available.

Parameters

x

Type: int

y

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Validate Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate() As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Validate (System.Boolean) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Shadows Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
new public bool Validate(
   bool checkAutoValidate
)
This language is not supported or no code example is available.

Parameters

checkAutoValidate

Type: bool

If set to true, then ; otherwise, .

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.VerticalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property VerticalScroll( _
   ByRef False As Object _
) As VScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("VerticalScroll")]
public VScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.BindingContext Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BindingContext( _
   ByRef False As Object _
) As BindingContext
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BindingContext")]
public BindingContext this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.Padding Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Padding( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Padding")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollPosition Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollPosition( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollPosition")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.HorizontalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property HorizontalScroll( _
   ByRef False As Object _
) As HScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("HorizontalScroll")]
public HScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.AutoScrollOffset Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollOffset( _
   ByRef False As Object _
) As Point
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollOffset")]
public Point this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


NetCalculator.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetCalculator Class
NetCalculator Members


PrintPreview.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


PrintPreview.VerticalScroll Property

Gets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public ReadOnly Property VerticalScroll( _
   ByRef False As Object _
) As VScrollProperties
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("VerticalScroll")]
public VScrollProperties this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

PrintPreview Class
PrintPreview Members


ComboDrives.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Category("ComboDrives")> _
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Category("ComboDrives")]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DataSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataSource( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataSource")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoCompleteSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteSource( _
   ByRef False As Object _
) As AutoCompleteSource
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteSource")]
public AutoCompleteSource this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Text Property

Gets currently Text of combo.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets currently text of control.")> _
<System.ComponentModel.DefaultValue("")> _
<System.ComponentModel.Category("ComboDrives")> _
Public Property Text( _
   ByRef "Gets currently text of control." As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets currently text of control.")]
[System.ComponentModel.DefaultValue("")]
[System.ComponentModel.Category("ComboDrives")]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object "Gets currently text of control."
] {get; set;}
This language is not supported or no code example is available.

Parameters

"Gets currently text of control."

Type: object

Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DefaultBackColor Property

Gets default background color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets default background color for control.")> _
<System.ComponentModel.Category("ComboDrives")> _
Public ReadOnly Property DefaultBackColor( _
   ByRef "Gets default background color for control." As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets default background color for control.")]
[System.ComponentModel.Category("ComboDrives")]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public Color this[
   ref object "Gets default background color for control."
] {get;}
This language is not supported or no code example is available.

Parameters

"Gets default background color for control."

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.DropDownStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DropDownStyle( _
   ByRef False As Object _
) As ComboBoxStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DropDownStyle")]
public ComboBoxStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboDrives Class
ComboDrives Members


ItemImages.AddImage (System.String, System.Drawing.Image, System.String) Method

Add a new image

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Add a new image")> _
Public Sub AddImage( _
   ByVal Text As String, _
   ByVal NewImage As Image, _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Add a new image")]
public System.Void AddImage(
   string Text,
   Image NewImage,
   string Key
)
This language is not supported or no code example is available.

Parameters

Text

Type: string

Combo Item Text

NewImage

Type: Image

A valid Image object.

Key

Type: string

The key associated to the image in the collection

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddImage (System.String, System.Drawing.Icon, System.String) Method

Add a new icon

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Add a new icon")> _
Public Sub AddImage( _
   ByVal Text As String, _
   ByVal NewIcon As Icon, _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Add a new icon")]
public System.Void AddImage(
   string Text,
   Icon NewIcon,
   string Key
)
This language is not supported or no code example is available.

Parameters

Text

Type: string

Combo Item Text

NewIcon

Type: Icon

A valid Icon object.

Key

Type: string

The key associated to the image in the collection

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove (System.String) Method

Remove the specified Item key from the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Remove the specified Item key from the collection")> _
Public Sub Remove( _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Remove the specified Item key from the collection")]
public System.Void Remove(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

An existing Key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove (System.Int32) Method

Remove the specified Item Index from the collection

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Remove the specified Item Index from the collection")> _
Public Sub Remove( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Remove the specified Item Index from the collection")]
public System.Void Remove(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

An existing Index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Item (System.String) Property

Gets a specified item collection throw key

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets a specified item collection throw key")> _
Default Public ReadOnly Property Item( _
   ByVal Key As String _
) As ItemImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets a specified item collection throw key")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ItemImage this[
   string Key
] {get;}
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key of item to retrieve

Property Value

A Softgroup.Image object
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Item (System.Int32) Property

Gets a specified item collection throw Index

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets a specified item collection throw Index")> _
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ItemImage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets a specified item collection throw Index")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ItemImage this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of item to retrieve

Property Value

A Softgroup.Image object
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ItemImages Class
ItemImages Members


ListBarItems.IndexOf (Softgroup.NetControls.ListBarItem) Method

Returns the index of the specified item in the collection if present, -1 otherwise.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal oItem As ListBarItem _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ListBarItem

The ListBarItem to check.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.IndexOf (System.String) Method

Gets the index of the specified Item key within this collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal sKey As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

Key of item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


ListBarItems.Remove (Softgroup.NetControls.ListBarItem) Method

Removes the specified item from the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal oItem As ListBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   ListBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ListBarItem

Item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarItems Class
ListBarItems Members


NetExtraLine.DataBindings Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataBindings( _
   ByRef False As Object _
) As ControlBindingsCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataBindings")]
public ControlBindingsCollection this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Text( _
   ByRef EditorBrowsableState.Never As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


NetExtraLine.ImeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
<Browsable(False)> _
Public Property ImeMode( _
   ByRef False As Object _
) As ImeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("ImeMode")]
public ImeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetExtraLine Class
NetExtraLine Members


ExplorerBar.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBar Class
ExplorerBar Members


ComboColors.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DrawMode( _
   ByRef False As Object _
) As DrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public DrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DataSource Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DataSource( _
   ByRef False As Object _
) As Object
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DataSource")]
public object this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DefaultBackColor Property

Gets default background color for control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.Description("Gets default background color for control.")> _
Public ReadOnly Property DefaultBackColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.Description("Gets default background color for control.")]
[System.Runtime.CompilerServices.IndexerName("DefaultBackColor")]
public Color this[
   ref object False
] {get;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property Margin( _
   ByRef False As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DropDownStyle Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DropDownStyle( _
   ByRef False As Object _
) As ComboBoxStyle
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DropDownStyle")]
public ComboBoxStyle this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormattingEnabled Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormattingEnabled( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormattingEnabled")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.AutoCompleteMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoCompleteMode( _
   ByRef False As Object _
) As AutoCompleteMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoCompleteMode")]
public AutoCompleteMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Category("ComboColors")> _
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
Public ReadOnly Property Items( _
   ByRef System.ComponentModel.DesignerSerializationVisibility.Hidden As Object _
) As ObjectCollection
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Category("ComboColors")]
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object System.ComponentModel.DesignerSerializationVisibility.Hidden
] {get;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.DisplayMember Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DisplayMember( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DisplayMember")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormatInfo Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatInfo( _
   ByRef False As Object _
) As IFormatProvider
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatInfo")]
public IFormatProvider this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FormatString Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property FormatString( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("FormatString")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboColors Class
ComboColors Members


NetTabControl.SelectNextTabPage (System.Int32) Method

Makes the NetTabPage following the specified index the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectNextTabPage( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectNextTabPage(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

A valid Tabpages index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectNextTabPage (System.String) Method

Makes the NetTabPage following the specified key the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectNextTabPage( _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectNextTabPage(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

A valid TabPages key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectNextTabPage (Softgroup.NetControls.NetTabPage) Method

Makes the NetTabPage following the specified key the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectNextTabPage( _
   ByVal oTabPage As NetTabPage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectNextTabPage(
   NetTabPage oTabPage
)
This language is not supported or no code example is available.

Parameters

oTabPage

Type: NetTabPage

A valid TabPages object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectPrevTabPage (System.Int32) Method

Makes the NetTabPage preceding with the specified index the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectPrevTabPage( _
   ByVal Index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectPrevTabPage(
   int Index
)
This language is not supported or no code example is available.

Parameters

Index

Type: int

A valid TabPages index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectPrevTabPage (System.String) Method

Makes the NetTabPage preceding with the specified sKey the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectPrevTabPage( _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectPrevTabPage(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

A valid TabPages index

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectPrevTabPage (Softgroup.NetControls.NetTabPage) Method

Makes the NetTabPage preceding with the specified sKey the current NetTabPage.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub SelectPrevTabPage( _
   ByVal oTabPage As NetTabPage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void SelectPrevTabPage(
   NetTabPage oTabPage
)
This language is not supported or no code example is available.

Parameters

oTabPage

Type: NetTabPage

A valid TabPages object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectTab (System.Int32) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub SelectTab( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void SelectTab(
   int index
)
This language is not supported or no code example is available.

Parameters

index

Type: int

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectTab (System.Windows.Forms.TabPage) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub SelectTab( _
   ByVal tabPage As TabPage _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void SelectTab(
   TabPage tabPage
)
This language is not supported or no code example is available.

Parameters

tabPage

Type: TabPage

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectTab (System.String) Method

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)

Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<EditorBrowsable(EditorBrowsableState.Never)> _
Public Shadows Sub SelectTab( _
   ByVal tabPageName As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[EditorBrowsable(EditorBrowsableState.Never)]
new public System.Void SelectTab(
   string tabPageName
)
This language is not supported or no code example is available.

Parameters

tabPageName

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.UpdateTabPageFocus (System.Int32) Method

Update focus of specified tabepage on first control.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub UpdateTabPageFocus( _
   ByVal iTabPageIndex As Integer _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void UpdateTabPageFocus(
   int iTabPageIndex
)
This language is not supported or no code example is available.

Parameters

iTabPageIndex

Type: int

TabPage index to update focus

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.Appearance Property

Gets or sets the visual appearance of the control's tabs.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<RefreshProperties(RefreshProperties.All)> _
<DefaultValue(GetType(TabAppearance), "Normal")> _
<Description("Gets or sets the visual appearance of the control's tabs.")> _
<Category("NetTabControl")> _
Public Property Appearance( _
   ByRef GetType As Object, _
   ByRef "Normal" As Object _
) As TabAppearance
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[RefreshProperties(RefreshProperties.All)]
[DefaultValue(GetType(TabAppearance), "Normal")]
[Description("Gets or sets the visual appearance of the control's tabs.")]
[Category("NetTabControl")]
[System.Runtime.CompilerServices.IndexerName("Appearance")]
public TabAppearance this[
   ref object GetType,
   ref object "Normal"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Normal"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.DrawMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<EditorBrowsable(EditorBrowsableState.Never)> _
<Browsable(False)> _
Public Property DrawMode( _
   ByRef False As Object _
) As TabDrawMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[EditorBrowsable(EditorBrowsableState.Never)]
[Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("DrawMode")]
public TabDrawMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetTabControl.SelectedTab Property

Gets/Sets the currently selected tab page

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Browsable(False)> _
<DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)> _
<Description("Gets/Sets the currently selected tab page.")> _
<Category("NetTabControl")> _
<DefaultValue(CStr(Nothing))> _
Public Property SelectedTab( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As NetTabPage
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Browsable(False)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("Gets/Sets the currently selected tab page.")]
[Category("NetTabControl")]
[DefaultValue(CStr(Nothing))]
[System.Runtime.CompilerServices.IndexerName("SelectedTab")]
public NetTabPage this[
   ref object DesignerSerializationVisibility.Hidden
] {get; set;}
This language is not supported or no code example is available.

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetTabControl Class
NetTabControl Members


NetWizard.AutoSize Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSize( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSize")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImage( _
   ByRef False As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.CausesValidation Property

Gets or sets a value indicating whether .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property CausesValidation( _
   ByRef False As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("CausesValidation")]
public bool this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Property Value

true if ; otherwise, false.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoSizeMode Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoSizeMode( _
   ByRef False As Object _
) As AutoSizeMode
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoSizeMode")]
public AutoSizeMode this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.MaximumSize Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property MaximumSize( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("MaximumSize")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoValidate Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoValidate( _
   ByRef False As Object _
) As AutoValidate
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoValidate")]
public AutoValidate this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.ForeColor Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property ForeColor( _
   ByRef False As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("ForeColor")]
public Color this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property BackgroundImageLayout( _
   ByRef False As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


NetWizard.AutoScrollMargin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property AutoScrollMargin( _
   ByRef False As Object _
) As Size
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("AutoScrollMargin")]
public Size this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetWizard Class
NetWizard Members


ExplorerBarItems.IndexOf (Softgroup.NetControls.ExplorerBarItem) Method

Gets the index of the specified ExplorerBarItem within this collection or -1 if not found.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal oItem As ExplorerBarItem _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   ExplorerBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ExplorerBarItem

The ExplorerBarItem to find the index for.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.IndexOf (System.String) Method

Gets the index of the specified ExplorerBarItem key within this collection or -1 if not found.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Function IndexOf( _
   ByVal sKey As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public int IndexOf(
   string sKey
)
This language is not supported or no code example is available.

Parameters

sKey

Type: string

Key of ExplorerBarItem to find the index for.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add Method

Adds a new empty ExplorerBarItem of type LinkLabel.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (System.String) Method

Adds a new ExplorerBarItem of type LinkLabel with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (System.String, System.String) Method

Adds a new ExplorerBarItem of type LinkLabel with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (System.String, System.String, System.Drawing.Image) Method

Adds a new ExplorerBarItem of type LinkLabel with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

sKey

Type: string

The Item key

oImage

Type: Image

A valid Image object for item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum) Method

Adds a new ExplorerBarItem object with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal eItemType As ExplorerBarItemTypeEnum _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarItemTypeEnum eItemType
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Add (Softgroup.NetControls.ExplorerBar.ExplorerBarItemTypeEnum, System.String) Method

Adds a new ExplorerBarItem object with specified parameters.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Add( _
   ByVal eItemType As ExplorerBarItemTypeEnum, _
   ByVal sText As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Add(
   ExplorerBarItemTypeEnum eItemType,
   string sText
)
This language is not supported or no code example is available.

Parameters

eItemType

Type: ExplorerBarItemTypeEnum

A value of type ExplorerBarItemTypeEnum that define the type item of item.

sText

Type: string

Item text (If a minus character will passed as text an item separator will be created)

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Remove (Softgroup.NetControls.ExplorerBarItem) Method

Removes the specified Item.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByRef oItem As ExplorerBarItem _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   ref ExplorerBarItem oItem
)
This language is not supported or no code example is available.

Parameters

oItem

Type: ExplorerBarItem

The Item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Remove (System.String) Method

Removes the specified key from the collection.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
Public Sub Remove( _
   ByVal Key As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
public System.Void Remove(
   string Key
)
This language is not supported or no code example is available.

Parameters

Key

Type: string

Key of item to remove.

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Item (System.String) Property

Gets the ExplorerBarItem with specified key.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ExplorerBarItem with specified key.")> _
Default Public ReadOnly Property Item( _
   ByVal key As String _
) As ExplorerBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ExplorerBarItem with specified key.")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ExplorerBarItem this[
   string key
] {get;}
This language is not supported or no code example is available.

Parameters

key

Type: string

Key of item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ExplorerBarItems.Item (System.Int32) Property

Gets the ExplorerBarItem at the specified index.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Gets the ExplorerBarItem at the specified index.")> _
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ExplorerBarItem
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Gets the ExplorerBarItem at the specified index.")]
[System.Runtime.CompilerServices.IndexerName("Item")]
public ExplorerBarItem this[
   int Index
] {get;}
This language is not supported or no code example is available.

Parameters

Index

Type: int

Index of item

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ExplorerBarItems Class
ExplorerBarItems Members


ComboFonts.DisplayMember Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.Browsable(False)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
Public Property DisplayMember( _
   ByRef False As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.Browsable(False)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.Runtime.CompilerServices.IndexerName("DisplayMember")]
public string this[
   ref object False
] {get; set;}
This language is not supported or no code example is available.

Parameters

False

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ComboFonts Class
ComboFonts Members


ToolStripCustomize.RestoreSettings Method

Restore previous saved user settings of ToolStrip layout.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Restore previous saved user settings of ToolStrip layout.")> _
Public Sub RestoreSettings()
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Restore previous saved user settings of ToolStrip layout.")]
public System.Void RestoreSettings()
This language is not supported or no code example is available.
Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ToolStripCustomize.RestoreSettings (System.String) Method

Restore custom previous saved user settings of ToolStrip layout.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Restore custom previous saved user settings of ToolStrip layout.")> _
Public Sub RestoreSettings( _
   ByVal sUserSettings As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Restore custom previous saved user settings of ToolStrip layout.")]
public System.Void RestoreSettings(
   string sUserSettings
)
This language is not supported or no code example is available.

Parameters

sUserSettings

Type: string

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ToolStripCustomize Class
ToolStripCustomize Members


ListBarGroup Constructor (System.String, System.String)

Create a new ListBarGroup object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new instance of the class.")> _
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new instance of the class.")]
public ListBarGroup(
   string sText,
   string sKey
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

sKey

Type: string

a user-defined string value which can be used to look up the item in the collection which owns it

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Constructor (System.String, System.Drawing.Image)

Create a new ListBarGroup object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new instance of the class.")> _
Public Sub New( _
   ByVal sText As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new instance of the class.")]
public ListBarGroup(
   string sText,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

oImage

Type: Image

The image displayed for this Group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


ListBarGroup Constructor (System.String, System.String, System.Drawing.Image)

Create a new ListBarGroup object.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<Description("Create a new instance of the class.")> _
Public Sub New( _
   ByVal sText As String, _
   ByVal sKey As String, _
   ByVal oImage As Image _
)
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[Description("Create a new instance of the class.")]
public ListBarGroup(
   string sText,
   string sKey,
   Image oImage
)
This language is not supported or no code example is available.

Parameters

sText

Type: string

Text caption displayed for this group

sKey

Type: string

a user-defined string value which can be used to look up the item in the collection which owns it

oImage

Type: Image

The image displayed for this Group

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

ListBarGroup Class
ListBarGroup Members


NetPictureScroll.BackColor Property

Gets/Sets control background color.

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.Description("Gets/Sets control background color")> _
<System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")> _
Public Property BackColor( _
   ByRef GetType As Object, _
   ByRef "Window" As Object _
) As Color
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.Description("Gets/Sets control background color")]
[System.ComponentModel.DefaultValue(GetType(System.Drawing.Color), "Window")]
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object GetType,
   ref object "Window"
] {get; set;}
This language is not supported or no code example is available.

Parameters

GetType

Type: object

"Window"

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Font Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Font( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Font
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Font")]
public Font this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.BackgroundImage Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property BackgroundImage( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Image
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImage")]
public Image this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Margin Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Margin( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As Padding
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Margin")]
public Padding this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.Text Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property Text( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As String
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("Text")]
public string this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members


NetPictureScroll.BackgroundImageLayout Property

Gets or sets .

Assembly: Softgroup.NetControls (in Softgroup.NetControls.dll)
Syntax
VB
C#
C++
F#
JScript
Copy
<System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
<System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)> _
<System.ComponentModel.Browsable(False)> _
Public Property BackgroundImageLayout( _
   ByRef System.ComponentModel.EditorBrowsableState.Never As Object _
) As ImageLayout
This language is not supported or no code example is available.
VB
C#
C++
F#
JScript
Copy
[System.ComponentModel.DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsable(System.ComponentModel.EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(False)]
[System.Runtime.CompilerServices.IndexerName("BackgroundImageLayout")]
public ImageLayout this[
   ref object System.ComponentModel.EditorBrowsableState.Never
] {get; set;}
This language is not supported or no code example is available.

Parameters

System.ComponentModel.EditorBrowsableState.Never

Type: object

Platforms

Windows XP SP3, Windows Vista, Windows 7, Windows 8.x, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x
See Also

Reference

NetPictureScroll Class
NetPictureScroll Members