VBFormResize

VBFormResize Overview

Softgroup VB Form Resize ActiveX 7

Objects
Resize

Constants
FontResizeModeEnum


FontResizeModeEnum enumeration

Members

Constant | Value
frmMedium | 0
frmMinimum | 1
frmMaximum | 2


Resize

Resize object


ResizeControl event

This event will be generated every time a control will be resized

Syntax

Sub object_ResizeControl(oCtrl As Object, bControlResize As Boolean, bFontResize As Boolean)

The ResizeControl event syntax has these named arguments:

Part | Description
oCtrl | Object
bControlResize | Boolean
bFontResize | Boolean


LayoutRestore method

Restore previous saved layout of form.

Return Type

A Boolean value.

Syntax

object.LayoutRestore(LayoutName As String)

The LayoutRestore method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
LayoutName | String


LayoutSave method

Save current layout of form.

Return Type

A Boolean value.

Syntax

object.LayoutSave(LayoutName As String)

The LayoutSave method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
LayoutName | String


FontResize property (Resize)

Gets/Sets if automatic resize of fonts is enabled

Property type

A Boolean value.

Syntax

object.FontResize [= value]

The FontResize property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
value | A Boolean value.


FontResizeMode property (Resize)

Gets/Sets fonts resize mode.

Property type

A FontResizeModeEnum value.

Syntax

object.FontResizeMode [= value]

The FontResizeMode property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
value | A FontResizeModeEnum value.


Resize property (Resize)

Enable/Disalbe Resize of controls on form

Property type

A Boolean value.

Syntax

object.Resize [= value]

The Resize property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
value | A Boolean value.


ResizeMin property (Resize)

Enable (True) or Disable (False) resize the form to a minimum size other than designe time size.

Property type

A Boolean value.

Syntax

object.ResizeMin [= value]

The ResizeMin property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
value | A Boolean value.


SN property (Resize)

Gets/Sets serial number for product

Property type

A String value.

Syntax

object.SN [= value]

The SN property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Resize.
value | A String value.