BarBorder class

Provides access to the BarBorder object.

For a list of all members of this type, see BarBorder Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.BarBorder

Remarks

The BarBorder object is the border object for a ScaleBar. A ScaleBar is the strip associated with a selected scale in a gauge. The supported members of the BarBorder object allow you to customize the display of the border for a ScaleBar.

The Bar property is used to obtain access to a ScaleBar object, and the Border property is used to obtain the BarBorder for a ScaleBar.

@2005 Software FX, Inc. All Rights Reserved. Chart FX is a registered trademark of Software FX, Inc
All other names are trademarks or registered trademarks of their respective owners.


BarBorder Class Members

Chart FX Gauges

BarBorder Members

BarBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Thickness | Gets or sets the width for the Bar Border object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Color Property of BaseColorable class

BaseColorable.Color Property

Gets or sets the color for a gauge element.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • For more information regarding the Color type, please refer to the .NET Framework documentation.

Example

To set the border Color for a Radial Gauge:

[C#]
 radialGauge1.Border.Color = Color.Red;

[Visual Basic]
 radialGauge1.Border.Color = Color.Red

Applies to

BaseColorable

See Also

BaseColorable Class | BaseColorable Members


Thickness Property of BarBorder class

BarBorder.Thickness Property

Gets or sets the width for the Bar Border object.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

  • The Border property of the ScaleBar class is used to access the BarBorder object for a scale.

Example

To set the width for a scale bar's border:

[C#]
 radialGauge1.MainScale.Bar.Border.Thickness = (float) 0.003;

[Visual Basic]
 radialGauge1.MainScale.Bar.Border.Thickness = 0.003

get-gauge -MainScale_Bar_Border_Thickness 003

Applies to

BarBorder

See Also

BarBorder Class | BarBorder Members | Border Property | ScaleBar Class


Visible Property of BaseViewable class

BaseViewable.Visible Property

Gets or sets a value indicating whether an object is visible or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • When set the false, the object is not visible.

Example

To hide a gauge:

[C#]
 radialGauge1.Visible = false;

[Visual Basic]
 radialGauge1.Visible = False

get-gauge -Visible false

Applies to

BaseViewable

See Also

BaseViewable Class | BaseViewable Members | Gauge Class


BaseGauge class

Provides access to the BaseGauge object.

For a list of all members of this type, see BaseGauge Members

ChartFX.WinForms.Gauge.BaseGauge

Remarks

The BaseGauge class supports the common members for all types of gauge objects. Both the Gauge and DigitalPanel object derive from this class.

All other gauge types are derived from the Gauge or DigitalPanel objects.


BaseGauge Class Members

BaseGauge Members

BaseGauge Overview

Public Properties

public property Antialiasing | Gets or sets the smooth visual effect for a gauge.
public property Culture | Allows you to localize gauges for a specific language and region.
public property Font | Gets or sets the font type which will be used by default in the gauge.
public property Images | Allows you to accesss the images for a gauge.
public property InnerGauges | The collection of InnerGauges currently associated with the gauge.
public property Palette | Allows you to set a Chart FX pre-defined palette.
public property Titles | Returns the collection of titles defined in the gauge.
public property ToolTip | Gets or sets the tool tip text.
public property ToolTipEnabled | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone | Creates a new object that is a copy of the current instance.
public method Export | Allows you to export the gauge to a data file or stream.
public method HitTest | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import | Allows you to import the gauge from a data file or stream.

Public Event

public event GetTip | The source of the event.
public event PostPaint | The source of the event.
public event PrePaint | The source of the event.


Antialiasing Property of BaseGauge class

BaseGauge.Antialiasing Property

Gets or sets the smooth visual effect for a gauge.

[Visual Basic]
Public Property Antialiasing As AntialiasingModes[C#]
public AntialiasingModes Antialiasing {get;set;}

Property Value

The default is All.

Value | Meaning
None | No smoothing applied.
Text | Smoothing applied to text objects only.
Graphic | Smoothing applied to graphic objects only.
All | Smoothing applied to all gauge elements.

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Example

To set the Antialiasing property for a gauge to None:

[C#]
 radialGauge1.Antialiasing = AntialiasingTypes.None;

[Visual Basic]
 radialGauge1.Antialiasing = AntialiasingTypes.None

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members


Culture Property of BaseGauge class

BaseGauge.Culture Property

Allows you to localize gauges for a specific language and region.

[Visual Basic]
Public Property Culture As CultureInfo[C#]
public CultureInfo Culture {get;set;}

Remarks

  • Culture attributes set with this property will effect the entire gauge, if no attributes are set using this property then Chart FX inherits the current Thread culture. For more information regarding the CultureInfo type and the Thread class, please refer to the .NET Framework Documentation.

  • The ValueFormat class supports a Culture property that allows you to set the culture for values, not the entire gauge.

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture. These values are documented in the .NET Framework Documentation.

  • An application that is ready for localization is separated into two conceptual blocks, a block that contains all user interface elements and a block that contains executable code. The user interface block contains only localizable user-interface elements such as strings, error messages, dialog boxes, menus, embedded object resources, and so on for the neutral culture. The code block contains only the application code to be used by all supported cultures. The common language runtime supports a satellite assembly resource model that separates an application's executable code from its resources. For more information about implementing this model, see .NET Framework Documentation.

    For each localized version of your application that you want to create, add a new satellite assembly that contains the localized user interface block translated into the appropriate language for the target culture. The code block for all cultures should remain the same. The combination of a localized version of the user interface block with the code block produces a localized version of your application.

Example

To set the Gauge culture to use "Spanish - Spain" as the Language-Country/Region:

[C#]
 radialGauge1.Culture = new System.Globalization.CultureInfo("es-ES");

[Visual Basic]
 radialGauge1.Culture = New System.Globalization.CultureInfo("es-ES")

get-gauge -Culture "es-ES"

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | Culture (ValueFormat) Property | ValueFormat Class


Font Property of BaseGauge class

BaseGauge.Font Property

Gets or sets the font type which will be used by default in the gauge.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • This Font property is used to configure the GaugeFont object for a gauge. Please see the GaugeF ont class for supported font members.

Example

To configure the font for a gauge:

[C#]
 GaugeFont myGaugeFont = new GaugeFont(FontFamily.GenericSerif, FontSize.Medium, FontStyle.Regular);
radialGauge1.Font = myGaugeFont;

[Visual Basic]
 Dim myGaugeFont As New GaugeFont(FontFamily.GenericSerif, FontSize.Medium, FontStyle.Regular)radialGauge1.Font = myGaugeFont

get-gauge -Font "Arial, 12"

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | GaugeFont Class


Images Property of BaseGauge class

BaseGauge.Images Property

Allows you to accesss the images for a gauge.

[Visual Basic]
Public ReadOnly Property Images As ImageCollection[C#]
public ImageCollection Images {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • This property returns an ImageCollection object. You may also specifying an index value to access a specific BaseImage item in the ImageCollection. Please see the ImageCollection object for additional information.

Example

To access the First ImageCollection object for a radial gauge:

[C#]
 ImageCollection myImg = radialGauge1.Images[0];

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | BaseImage Class


InnerGauges Property of BaseGauge class

BaseGauge.InnerGauges Property

The collection of InnerGauges currently associated with the gauge.

[Visual Basic]
Public ReadOnly Property InnerGauges As InnerGaugeCollection[C#]
public InnerGaugeCollection InnerGauges {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members


Palette Property of BaseGauge class

BaseGauge.Palette Property

Allows you to set a Chart FX pre-defined palette.

[Visual Basic]
Public Property Palette As Palette[C#]
public Palette Palette {get;set;}

Value | Meaning
Default | Set the palette to Default.
Alternate | Set the palette to Alternate.
Autumn | Set the palette to an Autumn scheme.
BrownSugar | Set the palette to a BrownSugar scheme.
ChartFX6 | Set the palette to the ChartFX 6 scheme.
Classic | Set the palette to Classic.
Colorful | Set the palette to a Colorful scheme.
DarkPastels | Set the palette to a DarkPastels scheme.
Earthtones | Set the palette to an Earthtones scheme.
HighContrast | Set the palette to a HighContrast scheme.
LilacsInMist | Set the palette to LilacsInMist scheme.
Mesa | Set the palette to Mesa scheme.
ModernBusiness | Set the palette to a ModernBusiness scheme.
NatureAdventure | Set the palette to a NatureAdventure scheme.
NatureSky | Set the palette to a NatureSky scheme.
Oceanica | Set the palette to Oceanica scheme.
Professional | Set the palette to a Professional scheme.
RainyDay | Set the palette to a RainyDay scheme.
SandAndSky | Set the palette to a SandAndSky scheme.
Simple | Set the palette to a Simple scheme.
Slate | Set the palette to Slate scheme.
SnowyPine | Set the palette to SnowyPine.
Vivid | Set the palette to a Vivid scheme.
Windows | Set the palette to a Windows scheme.

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as Chart FX Gauges for .NET will change the windows palette for the chart window. So if you previously set a color using any of the Chart FX Gauges for .NET supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Example

To configure the Default palette for a gauge:

[C#]
 radialGauge1.Palette = PaletteType.Default;

[Visual Basic]
 radialGauge1.Palette = PaletteType.Default

get-gauge -Palette Default

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | DigitalPanel Class | VerticalGauge Class | HorizontalGauge Class | RadialGauge Class


Titles Property of BaseGauge class

BaseGauge.Titles Property

Returns the collection of titles defined in the gauge.

[Visual Basic]
Public ReadOnly Property Titles As TitleCollection[C#]
public TitleCollection Titles {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

  • The Color property may be used to get or set the color of the title text; the Font Property can be used to configure a new font object for the title.

Example

To configure a title for a gauge:

[C#]
 Title newTitle = new Title();
newTitle.Text = "Pressure";
radialGauge1.Titles.Add(newTitle);

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | Font Property | Color Property


ToolTip Property of BaseGauge class

BaseGauge.ToolTip Property

Gets or sets the tool tip text.

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

  • The ToolTipEnabled property may be used to control whether or not a tool tip will be diplayed for a gauge.

Example

To set the tooltip for a gauge to read "Pressure Gauge":

[C#]
 myGauge.ToolTip = "Pressure Gauge";

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | ToolTipEnabled Property


ToolTipEnabled Property of BaseGauge class

BaseGauge.ToolTipEnabled Property

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

[Visual Basic]
Public Property ToolTipEnabled As Boolean[C#]
public Boolean ToolTipEnabled {get;set;}

Remarks

  • Tooltips allow the user to easily recognize the appropriate Chart FX Gauges for .NET element.

  • This property must be set to True for the GetTip event to be raised.

Example

To disable tooltips for a gauge:

[C#]
 radialGauge1.ToolTip = false;

[Visual Basic]
 radialGauge1.ToolTip = False

get-gauge -ToolTip false

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | DigitalPanel Class | LinearGauge Class | RadialGauge Class


Clone Method of BaseGauge class

BaseGauge.Clone Method

Creates a new object that is a copy of the current instance.

[Visual Basic]
Public Function Clone AS Object[C#]
public Object Clone();

Remarks

  • Clone can be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references. The resulting clone must be of the same type as or a compatible type to the original instance.

See Also

BaseGauge Class | BaseGauge Members


Export Method of BaseGauge class

BaseGauge.Export Method

Allows you to export the gauge to a data file or stream.

[Visual Basic]
Public Sub Export( _
   ByVal format As FileFormat, _
   ByVal fileName As String _
)[C#]
public Void Export(
   FileFormat format,
   String fileName
);

Parameters

Parameter | Type | Meaning
format | FileFormat | The Chart FX format to export.
fileName | String | The location of the file to export the chart.

Parameter | Type | Meaning
format | ImageFormat | The image format to export.
stream | Stream | A stream where to store the exported gauge.

Parameter | Type | Meaning
format | FileFormat | The Chart FX format to export.
stream | Stream | A stream where to store the exported gauge.

Remarks

  • The Binary format will export the gauge which includes data values. The BinaryTemplate and XML formats include visual attributes only (no data).

  • The Import method is used to introduce a previously saved gauge file or template.

Example

To export a gauge in binary format to a MemorySteam object:

[C#]
 MemoryStream myGaugeStream = new MemoryStream();
radialGauge1.Export(FileFormat.Binary, myGaugeStream);

See Also

BaseGauge Class | BaseGauge Members | Import Method


HitTest Method of BaseGauge class

BaseGauge.HitTest Method

Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).

[Visual Basic]
Public Function HitTest( _
   ByVal pt As Point _
) AS HitTestTargetStack[C#]
public HitTestTargetStack HitTest(
   Point pt
);

Parameters

Parameter | Type | Meaning
pt | Point | Point location to use when preforming the HitZone action.

Remarks

  • Use this method to obtain access to a gauge element at a selected coordinate (point).

Example

To obtain the HitTestTargetStack for a Gauge at point 50,50:

[C#]
 HitTestTargetStack myHit = digitalPanel1.HitTest(new Point(50,50));

See Also

BaseGauge Class | BaseGauge Members


Import Method of BaseGauge class

BaseGauge.Import Method

Allows you to import the gauge from a data file or stream.

[Visual Basic]
Public Sub Import( _
   ByVal format As FileFormat, _
   ByVal stream As Stream _
)[C#]
public Void Import(
   FileFormat format,
   Stream stream
);

Parameters

Parameter | Type | Meaning
format | FileFormat | The Chart FX format to import.
stream | Stream | A stream where to import a saved gauge.

Parameter | Type | Meaning
format | FileFormat | The Chart FX format to import.
fileName | String | The location of the file to import the chart.

Remarks

  • The Binary format will export the gauge which includes data values. The BinaryTemplate and XML formats include visual attributes only (no data).

  • The Export method is used to save gauge file or template.

Example

To Import a gauge binary file:

[C#]
 radialGauge.Import(FileFormat.Binary, "C:\\Data\\gauge.bin");

[Visual Basic]
 radialGauge.Import(FileFormat.Binary, "C:\Data\gauge.bin")

See Also

BaseGauge Class | BaseGauge Members | Export Method


GetTip Event of BaseGauge class

BaseGauge.GetTip Event

Occurs before a tooltop is displayed in the gauge area.

[Visual Basic]
Public Event GetTip As GetTipEventHandler[C#]
public event GetTipEventHandler GetTip

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | GetTipEventArgs | A GetTipEventArgs object that contains the event data.

Event Data

The event handler receives an argument of type GetTipEventArgs containing data related to this event. The following GetTipEventArgs property provides information specific to this event.

Property | Description
FoundTargets | A stacked object that contains all the items currently under the mouse with the backmost object on the bottom of the stack.
SelectedTarget | The topmost gauge object that will display a Tooltip.

Remarks

  • This event will be triggered only when the ToolTipEnabled property is set to True.

See Also

BaseGauge Class | BaseGauge Members


PostPaint Event of BaseGauge class

BaseGauge.PostPaint Event

Occurs right after the gauge control is redrawn.

[Visual Basic]
Public Event PostPaint As CustomPaintEventHandler[C#]
public event CustomPaintEventHandler PostPaint

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | PaintEventArgs | A PaintEventArgs that contains the event data.

Event Data

The event handler receives an argument of type CustomPaintEventArgs containing data related to this event. The following CustomPaintEventArgs property provides information specific to this event.

Property | Description
Graphics | Gets the Graphics object used to custom paint the chart.
Height | Gets the height of the area to be painted (in pixels).
Width | Gets the width of the area to be painted (in pixels).

Remarks

  • Raised by the gauge just after it has been painted to the device context.

See Also

BaseGauge Class | BaseGauge Members | PrePaint Property


PrePaint Event of BaseGauge class

BaseGauge.PrePaint Event

Occurs right before the chart control is redrawn.

[Visual Basic]
Public Event PrePaint As CustomPaintEventHandler[C#]
public event CustomPaintEventHandler PrePaint

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | PaintEventArgs | A PaintEventArgs that contains the event data.

Event Data

The event handler receives an argument of type CustomPaintEventArgs containing data related to this event. The following CustomPaintEventArgs property provides information specific to this event.

Property | Description
Graphics | Gets the Graphics object used to custom paint the chart.
Height | Gets the height of the area to be painted (in pixels).
Width | Gets the width of the area to be painted (in pixels).

Remarks

  • Raised by the gauge just before being painted to the device context.

See Also

BaseGauge Class | BaseGauge Members | PostPaint Property


BitmapImage class

Represents a Bitmap Image attached to the gauge.

For a list of all members of this type, see BitmapImage Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.Primitives.BaseImage
ChartFX.WinForms.Gauge.BitmapImage

Remarks

This class can handle images of the following formats: .gif, .jpg, .bmp, .wmf, .png


BitmapImage Class Members

BitmapImage Members

BitmapImage Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Image | Represents the actual Image object in the gauge.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property PhysicalHeight (inherited from BaseImage) | Retrieve the height (in pixels) of the image file.
public property PhysicalSize | Returns the Size object representing the orginal image file.
public property PhysicalWidth (inherited from BaseImage) | Retrieve the width (in pixels) of the image file.
public property Size (inherited from BaseImage) | A numeric size modifier applied in conjunction with a Custom SizeMode setting.
public property SizeMode (inherited from BaseImage) | Defines the display size options for the background image.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Angle Property of Annotation class

Annotation.Angle Property

Gets or sets the rotation angle in degrees for an annotation.

[Visual Basic]
Public Property Angle As Single[C#]
public Single Angle {get;set;}

Example

To set the angle for a title to 45 degrees:

[C#]
 radialGauge1.Titles[0].Angle = 45;

get-gauge -Titles_0_Angle 45

Applies to

Annotation

See Also

Annotation Class | Annotation Members


Image Property of BitmapImage class

BitmapImage.Image Property

Represents the actual Image object in the gauge.

[Visual Basic]
Public Property Image As Image[C#]
public Image Image {get;set;}

Remarks

  • Images that are larger than the gauge are not automatically scaled.

Example

Add a Bitmap Image from a file.

[C#]
 radialGauge1.Images.Add(new BitmapImage(Image.FromFile("c:\\myImage.jpg")));

[Visual Basic]
 Dim newImage As ChartFX.WinForms.Gauge.BitmapImage
newImage = New BitmapImage(Image.FromFile("c:\\myImage.jpg"))
RadialGauge1.Images.Add(newImage)

Applies to

BitmapImage

See Also

BitmapImage Class | BitmapImage Members


Layout Property of Annotation class

Annotation.Layout Property

Allows you to access the layout object for an Annotation.

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

Applies to

Annotation

See Also

Annotation Class | Annotation Members | LayoutAttributes Class


PhysicalHeight Property of BaseImage class

BaseImage.PhysicalHeight Property

Retrieve the height (in pixels) of the image file.

[Visual Basic]
Public ReadOnly Property PhysicalHeight As Int32[C#]
public Int32 PhysicalHeight {get;}

Remarks

  • This is a Get-only property.

Applies to

BaseImage

See Also

BaseImage Class | BaseImage Members


PhysicalSize Property of BitmapImage class

BitmapImage.PhysicalSize Property

Returns the Size object representing the orginal image file.

[Visual Basic]
Public ReadOnly Property PhysicalSize As Size[C#]
public Size PhysicalSize {get;}

Applies to

BitmapImage

See Also

BitmapImage Class | BitmapImage Members


PhysicalWidth Property of BaseImage class

BaseImage.PhysicalWidth Property

Retrieve the width (in pixels) of the image file.

[Visual Basic]
Public ReadOnly Property PhysicalWidth As Int32[C#]
public Int32 PhysicalWidth {get;}

Remarks

  • This is a Get-only property.

Applies to

BaseImage

See Also

BaseImage Class | BaseImage Members


Size Property of BaseImage class

BaseImage.Size Property

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Example

Set a Size value.

[C#]
 verticalGauge1.Images[0].Size = 0.5f;

[Visual Basic]
 VerticalGauge1.Images(0).Size = 0.5

get-gauge -Images_0_Size 5f

Applies to

BaseImage

See Also

BaseImage Class | BaseImage Members


SizeMode Property of BaseImage class

BaseImage.SizeMode Property

Defines the display size options for the background image.

[Visual Basic]
Public Property SizeMode As ImageSizeMode[C#]
public ImageSizeMode SizeMode {get;set;}

Property Value

The default is Normal.

Value | Meaning
Normal | The image is placed in the center of the container, in its original size. The image is clipped if it is larger than the container.
Stretch | The image is stretched or shrunk to fit the size of the container.
Custom | The image size will be custom set by the Size property.

Remarks

  • When using the Custom value a size can be specified using the Size property.

Example

Set the SizeMode to Custom and specify a Size modifier value.

[C#]
 radialGauge1.Images[0].SizeMode = ImageSizeMode.Custom;
radialGauge1.Images[0].Size = 1.0f;

[Visual Basic]
 RadialGauge1.Images(0).SizeMode = ImageSizeMode.Custom RadialGauge1.Images(0).Size = 1

get-gauge -Images_0_SizeMode Custom -Images_0_Size 0f

Applies to

BaseImage

See Also

BaseImage Class | BaseImage Members


Border class

Provides access to the Border object.

For a list of all members of this type, see Border Members

ChartFX.WinForms.Gauge.Border

Remarks

A border is the outer frame of a gauge object. This class is a base class for other border class of specific gauge types. For example, the border of a RadialGauge is the outer ring encasing the gauge object. The DigitalPanel, VerticalGauge and HorizontalGauge objects also supports an outer border.


Border Class Members

Border Members

Border Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor | Gets or sets the inside color for a gauge border.
public property InsideEffects | Enables or disables border shadow and gradient.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Glare Property of Border class

Border.Glare Property

Gets or sets a value indicating whether to use a lighting effect for a border.

[Visual Basic]
Public Property Glare As Boolean[C#]
public Boolean Glare {get;set;}

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

  • The Border property of a linear or radial gauge is used to obtain the border object.

Example

To turn on the glare effect for a gauge:

[C#]
 radialGauge1.Border.Glare = true;

[Visual Basic]
 radialGauge1.Border.Glare = true

Applies to

Border

See Also

Border Class | Border Members | InsideColor Property | RadialGauge Class | LinearGauge Class | RadialBorder Class | LinearBorder Class


InsideColor Property of Border class

Border.InsideColor Property

Gets or sets the inside color for a gauge border.

[Visual Basic]
Public Property InsideColor As Color[C#]
public Color InsideColor {get;set;}

Remarks

  • This property is used to configure the inner color value for a Border object.

  • For more information regarding the Color type, please refer to the .NET Framework documentation.

Example

To set the inside color for a RadialGauge object:

[C#]
 radialGauge1.Border.InsideColor = Color.White;

[Visual Basic]
 radialGauge1.Border.InsideColor = Color.White

get-gauge -Border_InsideColor White

Applies to

Border

See Also

Border Class | Border Members | Glare Property | LinearGauge Class | LinearBorder Class | RadialGauge Class | RadialBorder Class


InsideEffects Property of Border class

Border.InsideEffects Property

Enables or disables border shadow and gradient.

[Visual Basic]
Public Property InsideEffects As Boolean[C#]
public Boolean InsideEffects {get;set;}

Remarks

  • A natural gradient is applied when there is no specific background image.

Example

To Disable the InsideEffects:

[C#]
 radialGauge1.Border.InsideEffects = false;

[Visual Basic]
 RadialGauge1.Border.InsideEffects = False

get-gauge -Border_InsideEffects false

Applies to

Border

See Also

Border Class | Border Members


CustomLabelHash class

Applies custom defined labels for values on the Gauge's scale.

For a list of all members of this type, see CustomLabelHash Members

ChartFX.WinForms.Gauge.CustomLabelHash

Remarks

Due to the nature of the Smart Labeling feature, if a gauge is too small, then all labels will not necessarily be displayed. This is a built-in mechanism to ensure all labels are legible.


CustomLabelHash Class Members

CustomLabelHash Members

CustomLabelHash Overview

Public Properties

public property Count | The number of custom labels currently created.
public property Item | Provides direct access to the values in the Hash table.

Public Methods

public method Clear | Clears all custom labels and restores the Gauge's scale to default settings.
public method GetEnumerator | Returns an enumerator that can iterate through the collection.


Count Property of CustomLabelHash class

CustomLabelHash.Count Property

The number of custom labels currently created.

[Visual Basic]
Public ReadOnly Property Count As Int32[C#]
public Int32 Count {get;}

Remarks

  • For more information on Hash structures refer to .NET Framework documentation.

Example

Retrieve the number of custom labels in the gauge.

[C#]
 int val = radialGauge1.MainScale.CustomLabels.Count;

[Visual Basic]
 Dim val = RadialGauge1.MainScale.CustomLabels.Count

Applies to

CustomLabelHash

See Also

CustomLabelHash Class | CustomLabelHash Members


Item Property of CustomLabelHash class

CustomLabelHash.Item Property

Provides direct access to the values in the Hash table.

[Visual Basic]
Public Property Item As String[C#]
public String Item {get;set;}

Remarks

  • In VB.Net this property is exposed, but in C# the items of the CustomLabelHash are accessed via the array instance of the object.

Example

Set a label for marker position '0'.

[C#]
 verticalGauge1.MainScale.CustomLabels[0] = "Label at 0";

[Visual Basic]
 VerticalGauge1.MainScale.CustomLabels.Item(0) = "Label at 0"

get-gauge -MainScale_CustomLabels_0_ "Label at 0"

Applies to

CustomLabelHash

See Also

CustomLabelHash Class | CustomLabelHash Members


Clear Method of CustomLabelHash class

CustomLabelHash.Clear Method

Clears all custom labels and restores the Gauge's scale to default settings.

[Visual Basic]
Public Sub Clear[C#]
public Void Clear();

Remarks

  • Once labels are cleared they are not retrievable.

Example

Clear all labels.

[C#]
 radialGauge1.MainScale.CustomLabels.Clear();

[Visual Basic]
 RadialGauge1.MainScale.CustomLabels.Clear()

See Also

CustomLabelHash Class | CustomLabelHash Members


GetEnumerator Method of CustomLabelHash class

CustomLabelHash.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator AS IEnumerator[C#]
public IEnumerator GetEnumerator();

Remarks

  • For more information on Hash structures refer to .NET Framework documentation.

See Also

CustomLabelHash Class | CustomLabelHash Members


DigitalPanel class

Provides access to the DigitalPanel object.

For a list of all members of this type, see DigitalPanel Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.DigitalPanel

Remarks

The DigitalPanel gauge is a digital representation of values using 7 Segments, 14Segments or LEDs.

7 Segments can represent only numeric values, while 14 Segments and LEDs can represent numbers, tesxt and dates.

Here is an example of a 7 segment DigitalPanel:

Here is an example of a 14 segment DigitalPanel:

Here is an example of an LED DigitalPanel:


DigitalPanel Class Members

DigitalPanel Members

DigitalPanel Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Appearance | Returns the DigitalAppearance for a Digital Panel.
public property Border | Gets the Border object for a Digital Panel.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property DigitalMapping | Get the current digital mapping type.
public property DigitalMappingDefinitionLength | Get the length of the digital mapping array.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property SupportedCharacterSet | Returns the CharacterSet object used in a Digital Panel.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.
public property Value | Gets or sets the value for a Digital Panel.
public property ValueFormat | Gets or sets the numeric format string for a Digital Panel.
public property ValuePadding | Gets or Sets the number of digit placeholders in the panel.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method FormatValue | Used to format a value based on the configured ValueFormat string.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.
public method SupportCharacter | Used to determine if a selected character is supported for the Digital Panel object.

Public Event

public event GetTip (inherited from BaseGauge) | The source of the event.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event ValueChanged | The source of the event.


Appearance Property of DigitalPanel class

DigitalPanel.Appearance Property

Returns the DigitalAppearance for a Digital Panel.

[Visual Basic]
Public ReadOnly Property Appearance As DigitalAppearance[C#]
public DigitalAppearance Appearance {get;}

Remarks

  • This property is used to obtain access to the DigitalAppearance for a Digital Panel. This object is the section of a digital panel that contains the segment or LEDs characters. The supported members of the DigitalAppearance may be used to customize the display of digits in the Digital Panel.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | DigitalAppearance Class


Border Property of DigitalPanel class

DigitalPanel.Border Property

Gets the Border object for a Digital Panel.

[Visual Basic]
Public ReadOnly Property Border As LinearBorder[C#]
public LinearBorder Border {get;}

Remarks

  • The Border is the outer object encasing a Digital Panel. There are a myriad of different frame designs and styles that may be used to customize the display of Digital Panels.

  • This property returns a LinearBorder object. For additional information regarding supported members, please see the LinearBorder class.

Example

To obtain the LinearBorder object for a Digital Panel:

[C#]
 LinearBorder myBorder = digitalPanel1.Border;

[Visual Basic]
 Dim myBorder As New LinearBorder()
myBorder = digitalPanel1.Border

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | LinearBorder Class


DigitalMapping Property of DigitalPanel class

DigitalPanel.DigitalMapping Property

Get the current digital mapping type.

[Visual Basic]
Public ReadOnly Property DigitalMapping As DigitalMappingType[C#]
public DigitalMappingType DigitalMapping {get;}

Value | Meaning
SevenSegments | Digits made from seven segements.
FourteenSegments | Digits made from fourteen segements.
Led | Digits made from Led's; 7 rows -- 5 columns

Remarks

  • (3) digital mapping types are available: FourteenSegment, SevenSegment, and LedSegments.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members


DigitalMappingDefinitionLength Property of DigitalPanel class

DigitalPanel.DigitalMappingDefinitionLength Property

Get the length of the digital mapping array.

[Visual Basic]
Public ReadOnly Property DigitalMappingDefinitionLength As Int32[C#]
public Int32 DigitalMappingDefinitionLength {get;}

Remarks

  • Depending on the DigitalMappingType this property will return either 14, 7, or 35.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members


SupportedCharacterSet Property of DigitalPanel class

DigitalPanel.SupportedCharacterSet Property

Returns the CharacterSet object used in a Digital Panel.

[Visual Basic]
Public ReadOnly Property SupportedCharacterSet As CharacterSets[C#]
public CharacterSets SupportedCharacterSet {get;}

Value | Meaning
None | No character set support.
DigitCharacter | Digit character set support.
NonDigitLowerCaseCharacter | Lower case letter support.
NonDigitUpperCaseCharacter | Upper case letter support.
All | All variations of character sets supported.

Remarks

  • The SupportCharacter method may be used to determine if a selected character is supported for a Digital Panel.

  • The Value property to control the value for a Digital Panel. The default value is 100.

  • The ValueFormat property may be used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

Example

To obtain the supported CharacterSet object:

[C#]
 CharacterSet myChartSet = myDigitalPanel.SupportedCharacterSet;

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | Value Property | ValueFormat Property | SupportCharacter Method | DigitalAppearance Class


Value Property of DigitalPanel class

DigitalPanel.Value Property

Gets or sets the value for a Digital Panel.

[Visual Basic]
Public Property Value As Object[C#]
public Object Value {get;set;}

Remarks

  • This property is used to control the value for a Digital Panel. The default value is 100.

  • The Appearance property is used to return the DigitalAppearance for a Digital Panel. The DigitalAppearance is used to customize the display of segents or LEDs.

  • The ValueFormat property may be used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

Example

To set the value for a digital panel:

[C#]
 myDigitalPanel.Value = 95;

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | Appearance Property | ValueFormat Property | DigitalAppearance Class


ValueFormat Property of DigitalPanel class

DigitalPanel.ValueFormat Property

Gets or sets the numeric format string for a Digital Panel.

[Visual Basic]
Public Property ValueFormat As String[C#]
public String ValueFormat {get;set;}

Remarks

  • This property is used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

  • The Value property to control the value for a Digital Panel. The default value is 100.

  • The Appearance property is used to return the DigitalAppearance for a Digital Panel. The DigitalAppearance is used to customize the display of segents or LEDs.

Example

To configure the ValueFormat property:

[C#]
 myDigitalPanel.ValueFormat = "###.00";

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | Value Property | Appearance Property | DigitalAppearance Class


ValuePadding Property of DigitalPanel class

DigitalPanel.ValuePadding Property

Gets or Sets the number of digit placeholders in the panel.

[Visual Basic]
Public Property ValuePadding As Int32[C#]
public Int32 ValuePadding {get;set;}

Remarks

  • If no padding value is specified, then the gauge will format the display based on the current value.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members


FormatValue Method of DigitalPanel class

DigitalPanel.FormatValue Method

Used to format a value based on the configured ValueFormat string.

[Visual Basic]
Public Function FormatValue( _
   ByVal value As Object _
) AS String[C#]
public String FormatValue(
   Object value
);

Parameters

Parameter | Type | Meaning
value | Object | The value to format.

Remarks

  • This method returns a formatted string. Users may configure set a value to be formatted as a parameter. The returned string is formatted using the ValueFormat string.

  • The SupportCharacter method may be used to determine if a selected character is supported for a Digital Panel.

Example

To obtain a formated string based on the configured ValueFormat:

[C#]
 string myValue = FormatValue(35.53);

See Also

DigitalPanel Class | DigitalPanel Members | ValueFormat Property | SupportCharacter Method


SupportCharacter Method of DigitalPanel class

DigitalPanel.SupportCharacter Method

Used to determine if a selected character is supported for the Digital Panel object.

[Visual Basic]
Public Function SupportCharacter( _
   ByVal c As Char _
) AS Boolean[C#]
public Boolean SupportCharacter(
   Char c
);

Parameters

Parameter | Type | Meaning
c | Char | A character to evaluate.

Remarks

  • This method returns a boolean value specifying whether a selectd character is supported in a Digital Panel.

  • The SupportedCharacterSet returns the CharacterSet object used in a Digital Panel.

  • The FormatValue method is used to convert a value into a formatted string. This method uses the configured ValueFormat to generate the formatted string.

Example

To determine if a character is supported:

[C#]
 bool isSupported = myDigitalPanel.SupportCharacter( myChar );

See Also

DigitalPanel Class | DigitalPanel Members | SupportedCharacterSet Property | FormatValue Method


ValueChanged Event of DigitalPanel class

DigitalPanel.ValueChanged Event

Occurs after the value of the panel has changed.

[Visual Basic]
Public Event ValueChanged As EventHandler[C#]
public event EventHandler ValueChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | A standard EventArgs object.

Event Data

EventArgs

Remarks

  • Do not attempt to modify the value from within this event handler as it will cause the gauge application to enter an infinite loop.

See Also

DigitalPanel Class | DigitalPanel Members


DigitalAppearance class

Provides access to the DigitalAppearance object.

For a list of all members of this type, see DigitalAppearance Members

ChartFX.WinForms.Gauge.DigitalAppearance

Remarks

The DigitalAppearance object is used to customize the display for a DigitalPanel. Supported members provide access to members controlling the Layout, Size, Styles, etc.


DigitalAppearance Class Members

DigitalAppearance Members

DigitalAppearance Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Layout | Allows you to configure the layout for a DigitContainer.
public property OffDigitTransparency | Gets or sets the transparency for segments and LEDs not used to create a digit's current value.
public property Size | Gets or sets the size of Digits in a Digital Container.
public property Style | Gets or sets the Style for the characters displyed in a DigitalPanel.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Layout Property of DigitalAppearance class

DigitalAppearance.Layout Property

Allows you to configure the layout for a DigitContainer.

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of Digits inside the DigitalPanel.

Example

To align the Digits to the Top-Left of the DigitalPanel:

[C#]
 digitalPanel1.Digits.Layout.Target = LayoutTargetType.Border;
digitalPanel1.Digits.Layout.Alignment = System.Drawing.ContentAlignment.TopLeft;

get-gauge -1_Digits_Layout_Target Border -1_Digits_Layout_Alignment TopLeft

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | LayoutAttributes Class


OffDigitTransparency Property of DigitalAppearance class

DigitalAppearance.OffDigitTransparency Property

Gets or sets the transparency for segments and LEDs not used to create a digit's current value.

[Visual Basic]
Public Property OffDigitTransparency As Byte[C#]
public Byte OffDigitTransparency {get;set;}

Remarks

  • This property controls the transparency of LEDs and Segments which are not used to display digit values.
    For example, when displaying a value of one in a seven-segment style digit, only the two right vertical segements are used to diplay the value. The others will utilize the OffDigitTransparency setting.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Example

To configure the OffDigitTransparency to 25:

[C#]
 myDigitalContainer.OffDigitTransparency = 25;

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Style Property | Layout Property | DigitalPanel Class


Size Property of DigitalAppearance class

DigitalAppearance.Size Property

Gets or sets the size of Digits in a Digital Container.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This property is used to control the size of segment or LED digits displayed in a Digital Container.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The OffDigitTransparency property controls the transparency of LEDs and Segments which are not used to display digit values.

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Example

To set the size of digits in a Digital Container to 0.7:

[C#]
 myDigitalContainer.Size = 0.7;

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Style Property | OffDigitTransparency Property | Style Property | DigitalPanel Class


Style Property of DigitalAppearance class

DigitalAppearance.Style Property

Gets or sets the Style for the characters displyed in a DigitalPanel.

[Visual Basic]
Public Property Style As DigitalCharacterStyle[C#]
public DigitalCharacterStyle Style {get;set;}

Value | Meaning
SevenSegments01 | Seven segment style 01.
SevenSegments02 | Seven segment style 02.
SevenSegments03 | Seven segment style 03.
SevenSegments04 | Seven segment style 04.
SevenSegments05 | Seven segment style 05.
SevenSegments06 | Seven segment style 06.
SevenSegments07 | Seven segment style 07.
FourteenSegments01 | Fourteen segment style 01.
FourteenSegments02 | Fourteen segment style 02.
FourteenSegments03 | Fourteen segment style 03.
FourteenSegments04 | Fourteen segment style 04.
FourteenSegments05 | Fourteen segment style 05.
FourteenSegments06 | Fourteen segment style 06.
FourteenSegments07 | Fourteen segment style 07.
FourteenSegments08 | Fourteen segment style 08.
Led01 | LED style 01.
Led02 | LED style 02.
Led03 | LED style 03.
Led04 | LED style 04.
Led05 | LED style 05.
Led06 | LED style 06.
Led07 | LED style 07.
Led08 | LED style 08.

Remarks

  • Thsi property is used to select which type of charartere is going to be displayes on the DigitalPanel: 7-Segment, 14-Segment or LED.

  • The 7-segment styles provide display sets of the ten numerals, plus the following symbods: . , - , : and '.

  • The 14-segment styles provids a display set of 44 commonly used characters, including the ten numerals, the uppercase alphabet and other symbols.

  • The LED styles provide the same alphanumeric character set as a 14-Segment display plus lower case alphabet.

  • All 3 types include diferent variations and formats: italic, rounded, square, etc.

Example

To configure the style the DigitalPanel to LED:

[C#]
 digitalPanel1.Appearance.Style = DigitalCharacterStyle.Led01;

[Visual Basic]
 digitalPanel1.Digits.Style = DigitalCharacterStyle.Led01

get-gauge -Type Digital -Appearance_Style Led01

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Size Property


Filler class

Provides access to the Filler object.

For a list of all members of this type, see Filler Members

ChartFX.WinForms.Gauge.Indicator
ChartFX.WinForms.Gauge.Filler

Remarks

A Filler indicator type that is supported for a LinearGauge; derived from the Indicator class. The Filler object is the bar marker that has a beggining and ending value. The supported members of this class allow customization of this Indicator type.

The following is a sample of a Filler in a HorizontalGauge:

Chart FX Gauges for .NET Gauges provides several Filler Styles, in diferent shapes and forms, the following is a example of a HorizontaGauge with a repeat filler:


Filler Class Members

Filler Members

Filler Overview

Public Properties

public property AnimationSpan (inherited from Indicator) | Gets or Sets the time span value between each movement of an indicator.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Draggable (inherited from Indicator) | Gets or sets a value indicating whether the indicator is movable via user interface.
public property DraggableCursor (inherited from Indicator) | Gets or Sets the mouse cursor displayed when dragging an indicator.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Origin | Gets or sets the starting value of a filler indicator type.
public property OriginCustom | Gets or sets the custom origin for a filler indicator.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a filler indicator.
public property ToolTip (inherited from Indicator) | Gets or sets the tool tip text for an Indicator.
public property UseFillerAsBar | Gets or sets a value indicating to use the Filler as the background in a linear gauge.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property ValueDisplayed (inherited from Indicator) | Returns the Value pointed to by the Indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method HoveringRange (inherited from Indicator) Returns the range object currently under the Indicator, if it exists.

Public Event

public event ValueChanged (inherited from Indicator) Fires after the indicator value changes.


AnimationSpan Property of Indicator class

Indicator.AnimationSpan Property

Gets or Sets the time span value between each movement of an indicator.

[Visual Basic]
Public Property AnimationSpan As TimeSpan[C#]
public TimeSpan AnimationSpan {get;set;}

Remarks

  • A value of 1 will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

Example

To enable Animation on a main indicator of a Radial Gauge:

[C#]
 radialGauge1.MainIndicator.AnimationSpan = new TimeSpan(1000);

get-gauge -MainIndicator_AnimationSpan new TimeSpan(1000

Applies to

Indicator

See Also

Indicator Class | Indicator Members


Draggable Property of Indicator class

Indicator.Draggable Property

Gets or sets a value indicating whether the indicator is movable via user interface.

[Visual Basic]
Public Property Draggable As Boolean[C#]
public Boolean Draggable {get;set;}

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To configure an indicator as draggable for users:

[C#]
 radialGauge1.Scales[0].Indicators[0].Draggable = true;

[Visual Basic]
 radialGauge1.Scales(0).Indicators(0).Draggable = True

get-gauge -Scales_0_Indicators_0_Draggable true

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Value Property | LinearScale Class | RadialScale Class


DraggableCursor Property of Indicator class

Indicator.DraggableCursor Property

Gets or Sets the mouse cursor displayed when dragging an indicator.

[Visual Basic]
Public Property DraggableCursor As Cursor[C#]
public Cursor DraggableCursor {get;set;}

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

Set the DraggableCursor to the Windows PanWest cursor.

[C#]
 radialGauge1.MainIndicator.DraggableCursor = Cursors.PanWest;

[Visual Basic]
 RadialGauge1.MainIndicator.DraggableCursor = Cursors.PanWest

get-gauge -MainIndicator_DraggableCursor PanWest

Applies to

Indicator

See Also

Indicator Class | Indicator Members


Format Property of Indicator class

Indicator.Format Property

Returns the ValueFormat object for a selected indicator.

[Visual Basic]
Public ReadOnly Property Format As ValueFormat[C#]
public ValueFormat Format {get;}

Remarks

  • This property returns a ValueFormat object. Please see the ValueFormat class for additional information regarding supported members.

  • The Value property may be used to configure a value for selected indicator.

Example

To obtain the ValueFormat object for an indicator:

[C#]
 ValueFormat myFormat = radialGauge1.MainScale.Indicators[0].Format;

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Value Property | ValueFormat Class | LinearScale Class | RadialScale Class


Origin Property of Filler class

Filler.Origin Property

Gets or sets the starting value of a filler indicator type.

[Visual Basic]
Public Property Origin As FillerOrigin[C#]
public FillerOrigin Origin {get;set;}

Property Value

The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • The Style property may be used to configure the style for a filler object.

Example

To configure the Origin to be the ending value:

[C#]
 myFiller.Origin = FillerOriginType.OrginAtEndValue;

Applies to

Filler

See Also

Filler Class | Filler Members | OriginCustom Property | Style Property | Indicator Class | Marker Class


OriginCustom Property of Filler class

Filler.OriginCustom Property

Gets or sets the custom origin for a filler indicator.

[Visual Basic]
Public Property OriginCustom As Double[C#]
public Double OriginCustom {get;set;}

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

Example

To set the OriginCustom to 15:

[C#]
 Filler myFiller = new Filler();
myFiller.Origin = FillerOriginType.OriginCustom;
myFiller.OriginCustom = 15;

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Style Property | Indicator Class | Marker Class


Snap Property of Indicator class

Indicator.Snap Property

Gets or set the Snapping for an indicator.

[Visual Basic]
Public Property Snap As Double[C#]
public Double Snap {get;set;}

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Indicator to Snap to Scale:

[C#]
 radialGauge1.MainScale.Indicators[0].Snap = 5;

get-gauge -MainScale_Indicators_0_Snap 5

Applies to

Indicator

See Also

Indicator Class | Indicator Members


Style Property of Filler class

Filler.Style Property

Gets or sets the style for a filler indicator.

[Visual Basic]
Public Property Style As FillerStyle[C#]
public FillerStyle Style {get;set;}

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To configure the filler style to 'Filler2':

[C#]
 myFiller.Style = FillerStyle.Filler2;

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Indicator Class | Marker Class


ToolTip Property of Indicator class

Indicator.ToolTip Property

Gets or sets the tool tip text for an Indicator.

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Filler Class | Needle Class | Marker Class


UseFillerAsBar Property of Filler class

Filler.UseFillerAsBar Property

Gets or sets a value indicating to use the Filler as the background in a linear gauge.

[Visual Basic]
Public Property UseFillerAsBar As Boolean[C#]
public Boolean UseFillerAsBar {get;set;}

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • The Style property may be used to configure the style for a filler object.

Example

To specify that the filler will be used as the background:

[C#]
 Filler myFiller = new Filler();
myFiller.UseFillerAsBar = true;

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Style Property | Marker Class | Indicator Class


UseRangeColor Property of Indicator class

Indicator.UseRangeColor Property

Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.

[Visual Basic]
Public Property UseRangeColor As RangeType[C#]
public RangeType UseRangeColor {get;set;}

Property Value

The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Value Property | Section Class | Strip Class


Value Property of Indicator class

Indicator.Value Property

Gets or sets the value for an indicator.

[Visual Basic]
Public Property Value As Object[C#]
public Object Value {get;set;}

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

  • When using VB.NET in Visual Studio 2003 an explicit declaration of a NumericalValue type is necessary to assign a Value to the gauge. See sample below.

Example

Set the Value in VS2005.

[C#]
 horizontalGauge1.MainIndicator.Value = 25;

[Visual Basic]
 HorizontalGauge1.MainIndicator.Value = 25

get-gauge -MainIndicator_Value 25

Set the Value in VS2003.

[C#]
 horizontalGauge1.MainIndicator.Value = 25;

[Visual Basic]
 HorizontalGauge1.MainIndicator.Value = New NumericalValue(25)

get-gauge -MainIndicator_Value 25

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Draggable Property | Format Property


ValueDisplayed Property of Indicator class

Indicator.ValueDisplayed Property

Returns the Value pointed to by the Indicator.

[Visual Basic]
Public ReadOnly Property ValueDisplayed As Double[C#]
public Double ValueDisplayed {get;}

Remarks

  • The ValueDisplayed may differ from the Value if, for example, the Snap property is set to 2, then a Value of 51 would display as 52.

Applies to

Indicator

See Also

Indicator Class | Indicator Members


VerticalPosition Property of Indicator class

Indicator.VerticalPosition Property

Gets or Sets the positioning of the Indicator to behind or above the tick marks.

[Visual Basic]
Public Property VerticalPosition As IndicatorVerticalPosition[C#]
public IndicatorVerticalPosition VerticalPosition {get;set;}

Property Value

The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

  • This is merely an aesthetic feature, but will change the order of the HitTestTargetStack.

Example

Set the Indicator position to behind the tick marks.

[C#]
 radialGauge1.MainIndicator.VerticalPosition = IndicatorVerticalPosition.BehindTickmarks;

[Visual Basic]
 RadialGauge1.MainIndicator.VerticalPosition = IndicatorVerticalPosition.BehindTickmarks

get-gauge -MainIndicator_VerticalPosition BehindTickmarks

Applies to

Indicator

See Also

Indicator Class | Indicator Members


HoveringRange Method of Indicator class

Indicator.HoveringRange Method

Returns the range object currently under the Indicator, if it exists.

[Visual Basic]
Public Function HoveringRange( _
   ByVal rangeType As RangeType _
) AS IRange[C#]
public IRange HoveringRange(
   RangeType rangeType
);

Parameters

Parameter | Type | Meaning
rangeType | RangeType | The type of Range to check for.

Remarks

  • A null reference is returned if no Sections or Stripes are found.

Example

Check if the Indicator is Hovering over a Section of the gauge scale.

[C#]
 ChartFX.WinForms.Gauge.Section myS = (Section) radialGauge1.MainIndicator.HoveringRange(RangeType.None);

[Visual Basic]
 Dim myS As ChartFX.WinForms.Gauge.Section
myS = RadialGauge1.MainIndicator.HoveringRange(RangeType.Section)

See Also

Indicator Class | Indicator Members


ValueChanged Event of Indicator class

Indicator.ValueChanged Event

Fires after the indicator value changes.

[Visual Basic]
Public Event ValueChanged As EventHandler[C#]
public event EventHandler ValueChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

See Also

Indicator Class | Indicator Members


Gauge class

Provides access to the Gauge object.

For a list of all members of this type, see Gauge Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.Gauge

Remarks

The HorizontalGauge, VerticalGauge and RadialGauge objects derive from the Gauge class. The Gauge class is not designed to be used directly. All the supported members of the Gauge object are also supported by the HorizontalGauge, VerticalGauge and RadialGauge objects.

By default, a gauge contains one scale (called the main scale of the gauge). This main scale contains one indicator (called the main indicator of the gauge). The gauge provides handy shortcuts to access the main indicator (MainIndicator), the value of the main indicator (MainValue), as well as a strongly typed main scale (a radial scale for the RadialGauge: MainScale, and a linear scale for the LinearGauge: MainScale).


Gauge Class Members

Gauge Members

Gauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.
public property MainValue | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Shadow | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.

Public Event

public event DraggingStarted | The source of the event.
public event DraggingStopped | The source of the event.
public event GetTip (inherited from BaseGauge) | The source of the event.
public event MainValueChanged | Fires after the MainValue has changed.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event RangeEntered | The source of the event.
public event RangeLeft | The source of the event.
public event ValueChanged | The source of the event.


MainIndicator Property of Gauge class

Gauge.MainIndicator Property

Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.

[Visual Basic]
Public Property MainIndicator As Indicator[C#]
public Indicator MainIndicator {get;set;}

Remarks

  • A gauge may have many indicators, however only one MainIndicator.

  • The MainValue property is used to obtain the value of the MainIndicator.

  • Cast the return value of the MainIndicator to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.

Example

The following code accesses the main indicator of a radial gauge, casts it as a Needle, and changes the style:

[C#]
 Needle mainNeedle = (Needle) radialGauge1.MainIndicator;
mainNeedle.Style = NeedleStyle.Needle01;

[Visual Basic]
 Dim mainNeedle As Needle
mainNeedle= CType(Needle, radialGauge1.MainIndicator)
mainNeedle.Style = NeedleStyle.Needle01

Applies to

Gauge

See Also

Gauge Class | Gauge Members | MainValue Property | MainScale Property | RadialGauge Class | HorizontalGauge Class | VerticalGauge Class | Needle Class | Marker Class | Filler Class


MainValue Property of Gauge class

Gauge.MainValue Property

Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.

[Visual Basic]
Public Property MainValue As Object[C#]
public Object MainValue {get;set;}

Remarks

  • A gauge may display several values, for example a radial gauge may have multiple indicator needles. This property is used to configure the value displayed as the main value of a gauge object.

  • The MainIndicator method is used to obtain access to the main indicator.

  • When using VB.NET in Visual Studio 2003 an explicit declaration of a NumericalValue type is necessary to assign a MainValue to the gauge. See sample below.

Example

To set the MainValue for a radial gauge in VS2005:

[C#]
 radialGauge1.MainValue = 98.7;

[Visual Basic]
 RadialGauge1.MainValue = 98.7

get-gauge -MainValue 7

To set the MainValue for a radial gauge in VS2003:

[C#]
 radialGauge1.MainValue = 98.7;

[Visual Basic]
 RadialGauge1.MainValue = New NumericalValue(98.7)

get-gauge -MainValue 7

Applies to

Gauge

See Also

Gauge Class | Gauge Members | MainIndicator Property | RadialGauge Class | HorizontalGauge Class | VerticalGauge Class


Shadow Property of Gauge class

Gauge.Shadow Property

Gets or sets a value indicating to whether to display a shadow in a gauge.

[Visual Basic]
Public Property Shadow As ShadowEffect[C#]
public ShadowEffect Shadow {get;set;}

Property Value

The default is None.

Value | Meaning
None | No shadow effect.
Plain | A plain shadow effect.
Realistic | A realistic shadow effect.

Example

To configure a shadow for a radial gauge:

[C#]
 radialGauge1.Shadow = true;

get-gauge -Shadow true

Applies to

Gauge

See Also

Gauge Class | Gauge Members


DraggingStarted Event of Gauge class

Gauge.DraggingStarted Event

Occurs before a cursor drag occurs in a gauge.

[Visual Basic]
Public Event DraggingStarted As IndicatorEventHandler[C#]
public event IndicatorEventHandler DraggingStarted

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | IndicatorEventArgs | A DragIndicatorEventArgs that contains the event data.

Event Data

The event handler receives an argument of type IndicatorEventArgs containing data related to this event. The following IndicatorEventArgs property provides information specific to this event.

Property | Description
Indicator | A reference to the gauge's indicator.

Remarks

  • Use the DraggingStarted event to know when a cursor drag stars in a Gauge.

See Also

Gauge Class | Gauge Members


DraggingStopped Event of Gauge class

Gauge.DraggingStopped Event

Occurs after a cursor drag occurs in a gauge.

[Visual Basic]
Public Event DraggingStopped As IndicatorEventHandler[C#]
public event IndicatorEventHandler DraggingStopped

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | IndicatorEventArgs | A DragIndicatorEventArgs that contains the event data.

Event Data

The event handler receives an argument of type IndicatorEventArgs containing data related to this event. The following IndicatorEventArgs property provides information specific to this event.

Property | Description
Indicator | A reference to the gauge's indicator.

Remarks

  • Use the DraggingStopped event to know when a cursor drag stops in a Gauge.

See Also

Gauge Class | Gauge Members


MainValueChanged Event of Gauge class

Gauge.MainValueChanged Event

Fires after the MainValue has changed.

[Visual Basic]
Public Event MainValueChanged As EventHandler[C#]
public event EventHandler MainValueChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

Remarks

  • This event could be used for error checking of values.

See Also

Gauge Class | Gauge Members


RangeEntered Event of Gauge class

Gauge.RangeEntered Event

Occurs when an indicator enters a Section of the gauge scale.

[Visual Basic]
Public Event RangeEntered As RangeEventHandler[C#]
public event RangeEventHandler RangeEntered

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | RangeEventArgs | A RangeEventArgs objects that contains event data.

Event Data

The event handler receives an argument of type RangeEventArgs containing data related to this event. The following RangeEventArgs property provides information specific to this event.

Property | Description
Indicator | A reference to the gauge's indicator.
Range | A reference to the Range object that was 'Entered' or 'Left'.

Remarks

  • This event fires if the Indicator is physically dragged by the user or programmatically moved into a Section.

See Also

Gauge Class | Gauge Members


RangeLeft Event of Gauge class

Gauge.RangeLeft Event

Occurs when an indicator leaves a section of the gauge scale.

[Visual Basic]
Public Event RangeLeft As RangeEventHandler[C#]
public event RangeEventHandler RangeLeft

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | RangeEventArgs | A RangeEventArgs object that contains the event data.

Event Data

The event handler receives an argument of type RangeEventArgs containing data related to this event. The following RangeEventArgs property provides information specific to this event.

Property | Description
Indicator | A reference to the gauge's indicator.
Range | A reference to the Range object that was 'Entered' or 'Left'.

Remarks

  • This event fires if the Indicator is physically dragged by the user or programmatically moved out of a Section.

See Also

Gauge Class | Gauge Members


ValueChanged Event of Gauge class

Gauge.ValueChanged Event

Occurs after the value for a gauge is modified.

[Visual Basic]
Public Event ValueChanged As IndicatorEventHandler[C#]
public event IndicatorEventHandler ValueChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | A EventArgs that contains the event data.

Event Data

The event handler receives an argument of type IndicatorEventArgs containing data related to this event. The following IndicatorEventArgs property provides information specific to this event.

Property | Description
Indicator | A reference to the gauge's indicator.

Remarks

  • This event is raised after the indicator value for a gauge object is modified.

Example

To handle the ValueChanged event:

[C#]
 radialGauge1.ValueChanged += new System.EventHandler(radialGauge1_ValueChanged);

private void radialGauge1_ValueChanged(object sender, System.EventArgs e)
{
MessageBox.Show( "ValueChanged fired");
}

get-gauge -ValueChanged_+ EventHandler(radialGauge1_ValueChanged

See Also

Gauge Class | Gauge Members | DigitalPanel Class | LinearGauge Class | RadialGauge Class


GaugeFont class

Provides access to the GaugeFont object.

For a list of all members of this type, see GaugeFont Members

ChartFX.WinForms.Gauge.GaugeFont

Remarks

The GaugeFont object defines a particular format for text, including font face, size, and style attributes for text in a gauge.


GaugeFont Class Members

GaugeFont Members

GaugeFont Overview

Public Properties

public property Bold | Gets a value that indicates whether a GaugeFont object is bold.
public property FontFamily | Gets the FontFamily object associated with the GaugeFont object.
public property Italic | Gets a value that indicates whether a GaugeFont object is italic
public property Name | Gets the face name of a GaugeFont object.
public property Size | Gets the FontSize of a GaugeFont object.
public property Strikeout | Gets value that indicates whether the font is strikethrough.
public property Style | Gets style information for this Font object.
public property Underline | Gets a value that indicates whether the GaugeFont is underlined.

Public Methods

public method Clone | Creates an exact copy of this GaugeFont object.
public method Dispose | Releases all resources used by a GaugeFont object.


Bold Property of GaugeFont class

GaugeFont.Bold Property

Gets a value that indicates whether a GaugeFont object is bold.

[Visual Basic]
Public ReadOnly Property Bold As Boolean[C#]
public Boolean Bold {get;}

Remarks

  • This property returns true if this GaugeFont object is bold; otherwise, false.

Example

To determine if a font is bold:

[C#]
 bool isBold = myGaugeFont.Bold;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | GaugeFont Class


FontFamily Property of GaugeFont class

GaugeFont.FontFamily Property

Gets the FontFamily object associated with the GaugeFont object.

[Visual Basic]
Public ReadOnly Property FontFamily As FontFamily[C#]
public FontFamily FontFamily {get;}

Remarks

  • A FontFamily object represents a group of fonts that have a similar font face, but may have different sizes and styles. For example, Arial, Times New Roman, and Verdana.

Example

Get the FontFamily for a GaugeFont object:

[C#]
 FontFamily myFontFamily = myGaugeFont.FontFamily;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Style Property | Size Property


Italic Property of GaugeFont class

GaugeFont.Italic Property

Gets a value that indicates whether a GaugeFont object is italic

[Visual Basic]
Public ReadOnly Property Italic As Boolean[C#]
public Boolean Italic {get;}

Remarks

  • This property returns true if a GaugeFont object is italic; otherwise, false.

Example

To determine if a GaugeFont object is Italic;

[C#]
 bool isItalic = myGaugeFont.Italic;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Bold Property | Name Property | Size Property | Strikeout Property | Underline Property | GaugeFont Class


Name Property of GaugeFont class

GaugeFont.Name Property

Gets the face name of a GaugeFont object.

[Visual Basic]
Public ReadOnly Property Name As String[C#]
public String Name {get;}

Remarks

  • This property returns a string representation of the face name for a GaugeFont object.

Example

To obtain the string face name for a GaugeFont object:

[C#]
 string myFontName = myGaugeFont.Name;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Style Property | GaugeFont Class


Size Property of GaugeFont class

GaugeFont.Size Property

Gets the FontSize of a GaugeFont object.

[Visual Basic]
Public ReadOnly Property Size As GaugeFontSize[C#]
public GaugeFontSize Size {get;}

Value | Meaning
Smallest | Smallest font size.
Smaller | Smaller font size.
Medium | Medium font size.
Larger | Large font size.
Largest | Largest font size.

Remarks

  • This property returns the FontSize for a GaugeFont.

Example

To determine the FontSize for a GaugeFont object:

[C#]
 FontSize myFontSize = myGaugeFont.Size;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Style Property | GaugeFont Class


Strikeout Property of GaugeFont class

GaugeFont.Strikeout Property

Gets value that indicates whether the font is strikethrough.

[Visual Basic]
Public ReadOnly Property Strikeout As Boolean[C#]
public Boolean Strikeout {get;}

Remarks

  • This property returns true if the font is struck through; otherwise, false. The default value is false.

Example

To determine whether a GaugeFont is struck:

[C#]
 bool isStruck = myGaugeFont.Strikeout;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Bold Property | Italic Property | Size Property | Underline Property | GaugeFont Class


Style Property of GaugeFont class

GaugeFont.Style Property

Gets style information for this Font object.

[Visual Basic]
Public ReadOnly Property Style As FontStyle[C#]
public FontStyle Style {get;}

Remarks

  • A FontStyle enumeration that contains style information for this Font object.

Example

To obtain the FontStyle for a gauge font:

[C#]
 FontStyle myFontStyle = myGaugeFont.Style;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Name Property


Underline Property of GaugeFont class

GaugeFont.Underline Property

Gets a value that indicates whether the GaugeFont is underlined.

[Visual Basic]
Public ReadOnly Property Underline As Boolean[C#]
public Boolean Underline {get;}

Remarks

  • This property returns true if the font is underlined; otherwise, false. The default value is false.

Example

To determine whether a GaugeFont is underlined:

[C#]
 bool isUnderlined = myGaugeFont.Underline;

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Italic Property | Strikeout Property | GaugeFont Class


Clone Method of GaugeFont class

GaugeFont.Clone Method

Creates an exact copy of this GaugeFont object.

[Visual Basic]
Public Function Clone AS Object[C#]
public Object Clone();

Remarks

  • The GaugeFont object this method creates, cast as an object.

Example

To create a copy of myFont:

[C#]
 GaugeFont cloneFont = (GaugeFont)myFont.Clone();

See Also

GaugeFont Class | GaugeFont Members | GaugeFont Class


Dispose Method of GaugeFont class

GaugeFont.Dispose Method

Releases all resources used by a GaugeFont object.

[Visual Basic]
Public Sub Dispose[C#]
public Void Dispose();

Remarks

  • Calling Dispose allows the resources used by a GaugeFont object to be reallocated for other purposes.

Example

To release all the resources used by a GaugeFont object:

[C#]
 myGaugeFont.Dispose();

See Also

GaugeFont Class | GaugeFont Members | GaugeFont Class


HorizontalGauge class

Provides access to the HorizontalGauge object.

For a list of all members of this type, see HorizontalGauge Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.Gauge
ChartFX.WinForms.Gauge.LinearGauge
ChartFX.WinForms.Gauge.HorizontalGauge

Remarks

A HorizontalGauge includes scales that are configured in a horizontal position. Supported members of the HorizontalGauge class allow developers to configure a border, colors, sections, flip the gradient color scheme, access to the scale and indicator objects, etc.

Below is an example of a HorizontalGauge:


HorizontalGauge Class Members

HorizontalGauge Members

HorizontalGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border (inherited from LinearGauge) | Returns the LinearBorder object for a linear gauge.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.
public property MainScale (inherited from LinearGauge) | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales (inherited from LinearGauge) | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.

Public Event

public event DraggingStarted (inherited from Gauge) | The source of the event.
public event DraggingStopped (inherited from Gauge) | The source of the event.
public event GetTip (inherited from BaseGauge) | The source of the event.
public event MainValueChanged (inherited from Gauge) | Fires after the MainValue has changed.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event RangeEntered (inherited from Gauge) | The source of the event.
public event RangeLeft (inherited from Gauge) | The source of the event.
public event ValueChanged (inherited from Gauge) | The source of the event.


Border Property of LinearGauge class

LinearGauge.Border Property

Returns the LinearBorder object for a linear gauge.

[Visual Basic]
Public ReadOnly Property Border As LinearBorder[C#]
public LinearBorder Border {get;}

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. The Style property may be used to configure any of the supported LinearBorderStyle enumeration types.

  • This property returns a LinearBorder object. For additional information regarding supported members, please see the LinearBorder class.

Example

To access the LinearBorder object for a linear gauge and change the style:

[C#]
 LinearBorder myBorder = linearGauge1.Border;
myBorder.Style = LinearBorderStyle.LinearBorder01;

[Visual Basic]
 Dim myBorder As LinearBorder = linearGauge1.Border
myBorder.Style = LinearBorderStyle.LinearBorder01

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | Style Property | LinearBorder Class | HorizontalGauge Class | VerticalGauge Class


MainScale Property of LinearGauge class

LinearGauge.MainScale Property

Returns the main scale of a linear gauge.

[Visual Basic]
Public ReadOnly Property MainScale As LinearScale[C#]
public LinearScale MainScale {get;}

Remarks

  • A scale for a linear gauge is the range of values which a gauge can indicate a value. The indicator marks a value in a given scale.

  • The Scales property may be used to obtain the LinearScaleCollection for a linear gauge. The MainScale property is used to return the main scale object in the collection. By default, the main scale is the first scale of the collection.

Example

To obtain the main LinearScale for a linear gauge:

[C#]
 LinearScale myLinScale = (LinearScale) linearGauge1.MainScale;

[Visual Basic]
 Dim myLinScale As LinearScale
myLinScale = CType(LinearScale, linearGauge1.MainScale)

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | Scales Property | MainScale Property | LinearScale Class | HorizontalGauge Class | VerticalGauge Class


Scales Property of LinearGauge class

LinearGauge.Scales Property

Returns the LinearScaleCollection for a linear gauge.

[Visual Basic]
Public ReadOnly Property Scales As LinearScaleCollection[C#]
public LinearScaleCollection Scales {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The LinearScale object is used to control attributes for a linear gauge scale.

  • The MainScale property is used to obtain the main scale for a selected LinearGauge.

Example

To access the 1st scale object of a linear gauge:

[C#]
 LinearScale myScale = (LinearScale) linearGauge1.Scales[0];

[Visual Basic]
 Dim myScale As LinearScale
myScale = CType(LinearScale, linearGauge1.Scales(0))

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | MainScale Property | LinearScale Class | HorizontalGauge Class | VerticalGauge Class


Indicator class

Provides access to the Indicator object.

For a list of all members of this type, see Indicator Members

ChartFX.WinForms.Gauge.Indicator

Remarks

Indicators mark values in a guage. They are suppored for gauge types that include scales (HorizontalGauge, VerticalGauge and RadialGauge). The LinearScale and RadialScale classes support indicator objects. Fillers, Markers and Needles are all supported indicator objects.


Indicator Class Members

Indicator Members

Indicator Overview

Public Properties

public property AnimationSpan | Gets or Sets the time span value between each movement of an indicator.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Draggable | Gets or sets a value indicating whether the indicator is movable via user interface.
public property DraggableCursor | Gets or Sets the mouse cursor displayed when dragging an indicator.
public property Format | Returns the ValueFormat object for a selected indicator.
public property Snap | Gets or set the Snapping for an indicator.
public property ToolTip | Gets or sets the tool tip text for an Indicator.
public property UseRangeColor | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value | Gets or sets the value for an indicator.
public property ValueDisplayed | Returns the Value pointed to by the Indicator.
public property VerticalPosition | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method HoveringRange Returns the range object currently under the Indicator, if it exists.

Public Event

public event ValueChanged Fires after the indicator value changes.


InnerBaseGauge class

Provides access to the InnerBaseGauge object.

For a list of all members of this type, see InnerBaseGauge Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge

Remarks

Implements basic funtionality for Inner Gauges.


InnerBaseGauge Class Members

InnerBaseGauge Members

InnerBaseGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed Source of the event.


LinkToMainValue Property of InnerBaseGauge class

InnerBaseGauge.LinkToMainValue Property

Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

[Visual Basic]
Public Property LinkToMainValue As Boolean[C#]
public Boolean LinkToMainValue {get;set;}

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent radial gauge:

[C#]
 radialGauge1.InnerGauges[0].LinkToMainValue= true;

[Visual Basic]
 radialGauge1.InnerGauges(0).LinkToMainValue= True

get-gauge -InnerGauges_0_LinkToMainValue true

Applies to

InnerBaseGauge

See Also

InnerBaseGauge Class | InnerBaseGauge Members | Dispose Method | InnerBaseGauge Class


Dispose Method of InnerBaseGauge class

InnerBaseGauge.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose[C#]
public Void Dispose();

Remarks

  • Use this method to close or release unmanaged resources such as files, streams, and handles held by an instance of the class that implements this interface. This method is, by convention, used for all tasks associated with freeing resources held by an object, or preparing an object for reuse.

  • Please see your Development Environment documentation for additional information regarding Dispose.

Example

To call Dispose for an inner gauge:

[C#]
 radialGauge1.InnerGauges[0].Dispose();

[Visual Basic]
 radialGauge1.InnerGauges(0).Dispose()

See Also

InnerBaseGauge Class | InnerBaseGauge Members


Disposed Event of InnerBaseGauge class

InnerBaseGauge.Disposed Event

Occurs after an InnerBaseGauge is disposed.

[Visual Basic]
Public Event Disposed As EventHandler[C#]
public event EventHandler Disposed

Parameters

Parameter | Type | Meaning
sender | Object | Source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

Remarks

  • For more information on object Garbage Collection refer to .NET Framework documentation.

See Also

InnerBaseGauge Class | InnerBaseGauge Members


InnerBaseLinearGauge class

Provides access to the InnerBaseLinearGauge object.

For a list of all members of this type, see InnerBaseLinearGauge Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge
ChartFX.WinForms.Gauge.InnerBaseLinearGauge

Remarks

Derived from the InnerBaseGauge class, the InnerBaseLinearGauge is the base class for the InnerVerticalGauge and InnerHorizontalGauge object.

Using the InnerLinearGauge class, developers may embed a LinearGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerBaseLinearGauge Class Members

InnerBaseLinearGauge Members

InnerBaseLinearGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose (inherited from InnerBaseGauge) Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed (inherited from InnerBaseGauge) Source of the event.


Size Property of InnerBaseLinearGauge class

InnerBaseLinearGauge.Size Property

Gets or sets the size for a inner linear gauge.

[Visual Basic]
Public Property Size As SizeF[C#]
public SizeF Size {get;set;}

Remarks

  • This property accepts a SizeF object. This object accepts both Height and Width attributes.

  • Setting the size to (1,1) should indicate that the inner linear gauge is at the maximum size.

Example

To set the size for a inner linear gauge:

[C#]
 InnerLinearGauge myInnerLinearGauge = (InnerLinearGauge) radialGauge1.InnerGauges[0];
myInnerLinearGauge.Size = new SizeF(.3, .5);

Applies to

InnerBaseLinearGauge

See Also

InnerBaseLinearGauge Class | InnerBaseLinearGauge Members | LinearGauge Class


InnerDigitalPanel class

Provides access to the InnerDigitalPanel object.

For a list of all members of this type, see InnerDigitalPanel Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge
ChartFX.WinForms.Gauge.InnerBaseLinearGauge
ChartFX.WinForms.Gauge.InnerDigitalPanel

Remarks

Using the InnerDigitalPanel class, developers may embed a DigitalPanel inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerDigitalPanel Class Members

InnerDigitalPanel Members

InnerDigitalPanel Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property DigitalPanel | Returns the DigitalPanel object for an inner digital meter.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose (inherited from InnerBaseGauge) Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed (inherited from InnerBaseGauge) Source of the event.


DigitalPanel Property of InnerDigitalPanel class

InnerDigitalPanel.DigitalPanel Property

Returns the DigitalPanel object for an inner digital meter.

[Visual Basic]
Public ReadOnly Property DigitalPanel As DigitalPanel[C#]
public DigitalPanel DigitalPanel {get;}

Remarks

  • This property is used to return the DigitalPanel object for an inner digital Panel. For additional information regarding supported members, please see the DigitalPanel class.

Example

To access the DigitalPanel object for an inner digital Panel:

[C#]
 DigitalPanel myDigpanel = (DigitalPanel) myInnerDigPanel.DigitalPanel;

Applies to

InnerDigitalPanel

See Also

InnerDigitalPanel Class | InnerDigitalPanel Members | DigitalPanel Class


InnerHorizontalGauge class

Provides access to the InnerHorizontalGauge object.

For a list of all members of this type, see InnerHorizontalGauge Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge
ChartFX.WinForms.Gauge.InnerBaseLinearGauge
ChartFX.WinForms.Gauge.InnerHorizontalGauge

Remarks

Using the InnerHorizontalGauge class, developers may embed a HorizontalGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerHorizontalGauge Class Members

InnerHorizontalGauge Members

InnerHorizontalGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property HorizontalGauge | Exposes the HorizontalGauge properties of the InnerGauge.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose (inherited from InnerBaseGauge) Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed (inherited from InnerBaseGauge) Source of the event.


HorizontalGauge Property of InnerHorizontalGauge class

InnerHorizontalGauge.HorizontalGauge Property

Exposes the HorizontalGauge properties of the InnerGauge.

[Visual Basic]
Public ReadOnly Property HorizontalGauge As HorizontalGauge[C#]
public HorizontalGauge HorizontalGauge {get;}

Remarks

  • This property is used to return the HorizontalGauge object for an inner horizontal gauge. For additional information regarding supported members, please see the LinearGauge class.

Applies to

InnerHorizontalGauge

See Also

InnerHorizontalGauge Class | InnerHorizontalGauge Members


InnerRadialGauge class

Provides access to the InnerRadialGauge object.

For a list of all members of this type, see InnerRadialGauge Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge
ChartFX.WinForms.Gauge.InnerRadialGauge

Remarks

Using the InnerRadialGauge class, developers may embed a RadialGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerRadialGauge Class Members

InnerRadialGauge Members

InnerRadialGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property RadialGauge | Returns the RadialGauge object for an inner radial gauge.
public property Size | Gets or sets the InnerGauge size
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose (inherited from InnerBaseGauge) Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed (inherited from InnerBaseGauge) Source of the event.


RadialGauge Property of InnerRadialGauge class

InnerRadialGauge.RadialGauge Property

Returns the RadialGauge object for an inner radial gauge.

[Visual Basic]
Public ReadOnly Property RadialGauge As RadialGauge[C#]
public RadialGauge RadialGauge {get;}

Remarks

  • This property is used to return the RadialGauge object for an inner radial gauge. For additional information regarding supported members, please see the RadialGauge class.

Applies to

InnerRadialGauge

See Also

InnerRadialGauge Class | InnerRadialGauge Members | RadialGauge Class


Size Property of InnerRadialGauge class

InnerRadialGauge.Size Property

Gets or sets the InnerGauge size

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • The InnerGauge is scaled based on the value provided in this property. A value of 2.0 or greater will scale the InnerGauge larger than the Main Gauge.

Applies to

InnerRadialGauge

See Also

InnerRadialGauge Class | InnerRadialGauge Members


InnerVerticalGauge class

Provides access to the InnerVerticalGauge object.

For a list of all members of this type, see InnerVerticalGauge Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.InnerBaseGauge
ChartFX.WinForms.Gauge.InnerBaseLinearGauge
ChartFX.WinForms.Gauge.InnerVerticalGauge

Remarks

Using the InnerVerticalGauge class, developers may embed a VerticalGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerVerticalGauge Class Members

InnerVerticalGauge Members

InnerVerticalGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property VerticalGauge | Returns the LinearGauge object for an inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method Dispose (inherited from InnerBaseGauge) Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Public Event

public event Disposed (inherited from InnerBaseGauge) Source of the event.


VerticalGauge Property of InnerVerticalGauge class

InnerVerticalGauge.VerticalGauge Property

Returns the LinearGauge object for an inner linear gauge.

[Visual Basic]
Public ReadOnly Property VerticalGauge As VerticalGauge[C#]
public VerticalGauge VerticalGauge {get;}

Remarks

  • This property is used to return the LinearGauge object for an inner linear gauge. For additional information regarding supported members, please see the LinearGauge class.

Applies to

InnerVerticalGauge

See Also

InnerVerticalGauge Class | InnerVerticalGauge Members | LinearGauge Class | HorizontalGauge Class | VerticalGauge Class


LabelAttributes class

Provides access to the LabelAttributes object.

For a list of all members of this type, see LabelAttributes Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.LabelAttributes

Remarks

The LabelAttributes object is used to customize the display of labels in gauge objects. Supported members allow Font, Format, Orientation and Position configuration for labels in gauges.


LabelAttributes Class Members

LabelAttributes Members

LabelAttributes Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Font | Gets or sets the font for a label.
public property Orientation | Gets or sets the orientation for labels of scale tick marks.
public property Position | Gets or sets the location of labels for a selected scale.
public property PositionCustom | Gets or sets a custom position for a LabelAttributes object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Font Property of LabelAttributes class

LabelAttributes.Font Property

Gets or sets the font for a label.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • The GaugeFont object is used to configure font attributes for labels in a gauge. Please see the GaugeFont class for supported members.

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To obtain the GaugeFont object for a radial gauge's Major tickmarks:

[C#]
 GaugeFont myFont = (GaugeFont) radialGauge1.Scales[0].MajorTickmark.Label.Font;

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Orientation Property | Position Property | PositionCustom Property | GaugeFont Class | ValueFormat Class


Orientation Property of LabelAttributes class

LabelAttributes.Orientation Property

Gets or sets the orientation for labels of scale tick marks.

[Visual Basic]
Public Property Orientation As LabelOrientation[C#]
public LabelOrientation Orientation {get;set;}

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To configure the orientation for radial scale labels to Tangent:

[C#]
 radialGauge1.Scales[0].MajorTickmark.Label.Orientation = LabelOrientation.Tangent;

get-gauge -Scales_0_MajorTickmark_Label_Orientation Tangent

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Position Property | PositionCustom Property | ValueFormat Class


Position Property of LabelAttributes class

LabelAttributes.Position Property

Gets or sets the location of labels for a selected scale.

[Visual Basic]
Public Property Position As Position[C#]
public Position Position {get;set;}

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To configure the Position of major tickmark labels to be below the scale:

[C#]
 radialGauge1.Scales[0].MajorTickmark.Label.Position = Position.Bottom;

get-gauge -Scales_0_MajorTickmark_Label_Position Bottom

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | PositionCustom Property | Orientation Property | ValueFormat Class


PositionCustom Property of LabelAttributes class

LabelAttributes.PositionCustom Property

Gets or sets a custom position for a LabelAttributes object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To configure a PositionCustom for a LabelAttributes object:

[C#]
 radialGauge1.Scales[0].MajorTickmark.Label.Position = Position.Custom;
radialGauge1.Scales[0].MajorTickmark.Label.PositionCustom = (float) -5;

get-gauge -Scales_0_MajorTickmark_Label_Position Custom -Scales_0_MajorTickmark_Label_PositionCustom 5

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Position Property | Orientation Property


LayoutAttributes class

Provides access to the Layoutobject.

For a list of all members of this type, see LayoutAttributes Members

ChartFX.WinForms.Gauge.LayoutAttributes

Remarks

The LayoutAttributes object allows you to manipulate the Aligment and Anchoring position of objects inside the Gauge, i.e. Digits, Images, Titles, InnerGauges, etc.


LayoutAttributes Class Members

LayoutAttributes Members

LayoutAttributes Overview

Public Properties

public property Alignment | Gets or sets the alignment for a layout object.
public property AnchorPoint | Gets or sets the location for a Layout object.
public property Target | Gets or set the Target of a Layout object.


Alignment Property of LayoutAttributes class

LayoutAttributes.Alignment Property

Gets or sets the alignment for a layout object.

[Visual Basic]
Public Property Alignment As ContentAlignment[C#]
public ContentAlignment Alignment {get;set;}

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to Border, the object will be "docked" in the selected fixed position. The following is an example of a DigitalPanel with the Digits aligned to TOP-LEF:

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To align the Digits to the Top-Left of the DigitalPanel:

[C#]
 digitalPanel1.Appearance.LayoutAttributes.Target = LayoutTargetType.Border;
digitalPanel1.Appearance.LayoutAttributes.Alignment = System.Drawing.ContentAlignment.TopLeft;

To anchor the the Digits to a specific position:

[C#]
 digitalPanel1.Appearance.LayoutAttributes.AnchorPoint = new Point(0.7,0.8);
digitalPanel1.Appearance.LayoutAttributes.Alignment = System.Drawing.ContentAlignment.BottomCenter;

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Target Property | AnchorPoint Property | DigitalAppearance Class | Annotation Class


AnchorPoint Property of LayoutAttributes class

LayoutAttributes.AnchorPoint Property

Gets or sets the location for a Layout object.

[Visual Basic]
Public Property AnchorPoint As PointF[C#]
public PointF AnchorPoint {get;set;}

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to Border.

Example

To anchor the Digits to a specific position:

[C#]
 digitalPanel1.Appearance.LayoutAttributes.AnchorPoint = new Point(0.7,0.8);
digitalPanel1.Appearance.LayoutAttributes.Alignment = System.Drawing.ContentAlignment.BottomCenter;

get-gauge -1_Appearance_LayoutAttributes_AnchorPoint 8 -1_Appearance_LayoutAttributes_Alignment BottomCenter

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Alignment Property | Target Property


Target Property of LayoutAttributes class

LayoutAttributes.Target Property

Gets or set the Target of a Layout object.

[Visual Basic]
Public Property Target As LayoutTarget[C#]
public LayoutTarget Target {get;set;}

Property Value

The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to Border, the AnchorPoint should be used to position the layout object.

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Alignment Property | AnchorPoint Property


LinearBorder class

Provides access to the LinearBorder object.

For a list of all members of this type, see LinearBorder Members

ChartFX.WinForms.Gauge.Border
ChartFX.WinForms.Gauge.LinearBorder

Remarks

The LinearBorder class is used to customize the outer frame for a DigitalPanel, VerticalGauge and HorizontalGauge.


LinearBorder Class Members

LinearBorder Members

LinearBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare (inherited from Border) | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor (inherited from Border) | Gets or sets the inside color for a gauge border.
public property InsideEffects (inherited from Border) | Enables or disables border shadow and gradient.
public property Inverted | Gets or set a property to invert the Border of a Linear Gauge
public property Style | Gets or sets the style for a LinearBorder object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Inverted Property of LinearBorder class

LinearBorder.Inverted Property

Gets or set a property to invert the Border of a Linear Gauge

[Visual Basic]
Public Property Inverted As Boolean[C#]
public Boolean Inverted {get;set;}

Remarks

  • The following is a HorizontalGauge with Inverted = false:

  • The following is the same HorizontalGauge with Inverted = true:

Example

To set border to be Inverted:

[C#]
 Gauge1.Border.Inverted = true;

Applies to

LinearBorder

See Also

LinearBorder Class | LinearBorder Members | HorizontalGauge Class | VerticalGauge Class


Style Property of LinearBorder class

LinearBorder.Style Property

Gets or sets the style for a LinearBorder object.

[Visual Basic]
Public Property Style As LinearBorderStyle[C#]
public LinearBorderStyle Style {get;set;}

Value | Meaning
LinearBorder01 | Set the border style to LinearBorder01.
LinearBorder02 | Set the border style to LinearBorder02.
LinearBorder03 | Set the border style to LinearBorder03.
LinearBorder04 | Set the border style to LinearBorder04.
LinearBorder05 | Set the border style to LinearBorder05.
LinearBorder06 | Set the border style to LinearBorder06.
LinearBorder07 | Set the border style to LinearBorder07.
LinearBorder08 | Set the border style to LinearBorder08.
LinearBorder09 | Set the border style to LinearBorder09.
LinearBorder10 | Set the border style to LinearBorder10.
LinearBorder11 | Set the border style to LinearBorder11.
LinearBorder12 | Set the border style to LinearBorder12.
LinearBorder13 | Set the border style to LinearBorder13.
LinearBorder14 | Set the border style to LinearBorder14.
LinearBorder15 | Set the border style to LinearBorder15.
LinearBorder16 | Set the border style to LinearBorder16.
LinearBorder17 | Set the border style to LinearBorder17.
Thermometer01 | Set the border style to Thermometer01.
Thermometer02 | Set the border style to Thermometer02.
Thermometer03 | Set the border style to Thermometer03.

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. This property may be used to configure any of the supported LinearBorderStyle enumeration types.

  • The Border property of the LinearGauge object is used to access the LinearBorder object.

Example

To configure the linear gauge as thermometer:

[C#]
 linearGauge1.Border.Style = LinearBorderStyle.Thermometer;

[Visual Basic]
 linearGauge1.Border.Style = LinearBorderStyle.Thermometer

get-gauge -Border_Style Thermometer

Applies to

LinearBorder

See Also

LinearBorder Class | LinearBorder Members | Border (LinearGauge) Property | Border (RadialGauge) Property | LinearGauge Class


LinearGauge class

Provides access to the LinearGauge object.

For a list of all members of this type, see LinearGauge Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.Gauge
ChartFX.WinForms.Gauge.LinearGauge

Remarks

The HorizontalGauge and VerticalGauge objects derive from the LinearGauge class. The LinearGauge class is not designed to be used directly. All the supported members of thhis class are also supported by the HorizontalGauge and VerticalGauge classes.


LinearGauge Class Members

LinearGauge Members

LinearGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border | Returns the LinearBorder object for a linear gauge.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.
public property MainScale | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.

Public Event

public event DraggingStarted (inherited from Gauge) | The source of the event.
public event DraggingStopped (inherited from Gauge) | The source of the event.
public event GetTip (inherited from BaseGauge) | The source of the event.
public event MainValueChanged (inherited from Gauge) | Fires after the MainValue has changed.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event RangeEntered (inherited from Gauge) | The source of the event.
public event RangeLeft (inherited from Gauge) | The source of the event.
public event ValueChanged (inherited from Gauge) | The source of the event.


LinearScale class

Provides access to the LinearScale object.

For a list of all members of this type, see LinearScale Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseSection
ChartFX.WinForms.Gauge.Scale
ChartFX.WinForms.Gauge.LinearScale

Remarks

A Scale for a LinearGauge is the range of values which a gauge can indicate a value. An indicator (Marker of Filler) marks a value in a given scale. The Scale for a LinearGauge is displayed in a vertical or horizontal position.


LinearScale Class Members

LinearScale Members

LinearScale Overview

Public Properties

public property Bar (inherited from Scale) | Returns the ScaleBar object for a section.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property CustomLabels (inherited from Scale) | The collection of Custom Labels currently associated with the scale.
public property FillerVolume | Gets or Sets the Filler size within a Linear Gauge
public property Indicators (inherited from Scale) | The collection of Indicators currently associated with the scale.
public property Inverted | Gets amd set a boolean flag to invert the scale
public property Layout | Gets the layout object for a LinearScale
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Sections (inherited from Scale) | Returns the SectionCollection for a scale object.
public property Size | Gets or sets the size for a Linear Scale.
public property Stripes | The collection of Stripes currently associated with the scale.
public property Thickness (inherited from Scale) | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Allows you to access the Tickmark properties for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


Bar Property of Scale class

Scale.Bar Property

Returns the ScaleBar object for a section.

[Visual Basic]
Public ReadOnly Property Bar As ScaleBar[C#]
public ScaleBar Bar {get;}

Remarks

  • The ScaleBar object is the colored band for a section object. The supported members of the SectionBar class are used to customize this object.

  • The Border property of the ScaleBar class is used to obtain the border object for a ScaleBar.

Example

To access the ScaleBar object for a Scale:

[C#]
 ScaleBar myScaleBar = (ScaleBar) radialGauge1.MainScale.Bar;

Applies to

Scale

See Also

Scale Class | Scale Members | Border Property | ScaleBar Class


CustomLabels Property of Scale class

Scale.CustomLabels Property

The collection of Custom Labels currently associated with the scale.

[Visual Basic]
Public ReadOnly Property CustomLabels As CustomLabelHash[C#]
public CustomLabelHash CustomLabels {get;}

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

Set a CustomLabel for scale value '50'.

[C#]
 radialGauge1.MainScale.CustomLabels[50] = "Hello, Label";

[Visual Basic]
 RadialGauge1.MainScale.CustomLabels.Item(50) = "Label at 50"

get-gauge -MainScale_CustomLabels_50_ "Hello, Label"

Applies to

Scale

See Also

Scale Class | Scale Members


FillerVolume Property of LinearScale class

LinearScale.FillerVolume Property

Gets or Sets the Filler size within a Linear Gauge

[Visual Basic]
Public Property FillerVolume As Single[C#]
public Single FillerVolume {get;set;}

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Example

Set the FillerVolume to 0.25

[C#]
 horizontalGauge1.MainScale.FillerVolume = 0.25f;

[Visual Basic]
 HorizontalGauge1.MainScale.FillerVolume = 0.25

get-gauge -MainScale_FillerVolume 25f

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members


Indicators Property of Scale class

Scale.Indicators Property

The collection of Indicators currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Indicators As IndicatorCollection[C#]
public IndicatorCollection Indicators {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

Change the color of the 1st Indicator of the MainScale.

[C#]
 radialGauge1.MainScale.Indicators[0].Color = Color.AliceBlue;

[Visual Basic]
 RadialGauge1.MainScale.Indicators.Item(0).Color = Color.AliceBlue

get-gauge -MainScale_Indicators_0_Color AliceBlue

Applies to

Scale

See Also

Scale Class | Scale Members


Inverted Property of LinearScale class

LinearScale.Inverted Property

Gets amd set a boolean flag to invert the scale

[Visual Basic]
Public Property Inverted As Boolean[C#]
public Boolean Inverted {get;set;}

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Example

To invert the scale of the main scale in a Horizontal Gauge:

[C#]
 horizontalGauge1.MainScale.Inverted = true;

get-gauge -MainScale_Inverted true

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | HorizontalGauge Class | VerticalGauge Class


Layout Property of LinearScale class

LinearScale.Layout Property

Gets the layout object for a LinearScale

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Example

To dock the main scale in the Bottom and Center in a Horizontal Gauge:

[C#]
 horizontalGauge1.MainScale.Layout.Alignment = System.Drawing.ContentAlignment.BottomCenter;

get-gauge -MainScale_Layout_Alignment BottomCenter

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | LayoutAttributes Class


Max Property of Range class

Range.Max Property

Get or set the Maximum value of the gauge scale.

[Visual Basic]
Public Property Max As Double[C#]
public Double Max {get;set;}

Example

Set the MainScale Max.

[C#]
 RadialGauge gauge1 = new RadialGauge();
gauge1.MainScale.Max = 50;

[Visual Basic]
 Dim gauge1 As RadialGauge = New RadialGauge()
gauge1.MainScale.Max = 50

Applies to

Range

See Also

Range Class | Range Members


MaxAlwaysDisplayed Property of BaseSection class

BaseSection.MaxAlwaysDisplayed Property

Gets or sets a value indicating whether to display the ending value of a section.

[Visual Basic]
Public Property MaxAlwaysDisplayed As Boolean[C#]
public Boolean MaxAlwaysDisplayed {get;set;}

Remarks

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the hide ending values in a section

[C#]
 mySection.MaxValueAlwaysDisplayed = false;

[Visual Basic]
 mySection.MaxValueAlwaysDisplayed = False

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Max Property | Min Property | Section Class


Min Property of Range class

Range.Min Property

Get or set the Minimum value for the gauge scale.

[Visual Basic]
Public Property Min As Double[C#]
public Double Min {get;set;}

Example

Set Min of a Section.

[C#]
 RadialGauge gauge1 = new RadialGauge();
gauge1.MainScale.Sections.Add(new Section());
gauge1.MainScale.Sections[0].Min = 10;

[Visual Basic]
 Dim gauge1 As RadialGauge = New RadialGauge() gauge1.MainScale.Sections.Add(New Section()) gauge1.MainScale.Sections(0).Min = 10

Applies to

Range

See Also

Range Class | Range Members


MinAlwaysDisplayed Property of BaseSection class

BaseSection.MinAlwaysDisplayed Property

Gets or sets a value indicating whether to display the starting value of a section.

[Visual Basic]
Public Property MinAlwaysDisplayed As Boolean[C#]
public Boolean MinAlwaysDisplayed {get;set;}

Remarks

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the hide ending values in a section

[C#]
 mySection.MinValueAlwaysDisplayed = false;

[Visual Basic]
 mySection.MinValueAlwaysDisplayed = False

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Max Property | Min Property | Section Class


Sections Property of Scale class

Scale.Sections Property

Returns the SectionCollection for a scale object.

[Visual Basic]
Public ReadOnly Property Sections As SectionCollection[C#]
public SectionCollection Sections {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

  • Please see the Section class for additional information regarding supported members.

Example

To access the SectionCollection for a Scale object:

[C#]
 SectionCollection mySections = radialGauge1.MainScale.Sections;

Applies to

Scale

See Also

Scale Class | Scale Members | Section Class


Size Property of LinearScale class

LinearScale.Size Property

Gets or sets the size for a Linear Scale.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This property is used to control the size of the scale in a Linear Gauge.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

  • You can not set this property to 0; Gauges have a minimun size to display at least the first and las value in the scale. If you want to hide the scale, set the Visible property to false.

Example

To set the size of the scale to be 75% of the lenght of a Horizontal Gauge:

[C#]
 horizontalGauge1.MainScale.Size = 0.75;

get-gauge -MainScale_Size 75

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | HorizontalGauge Class | VerticalGauge Class


Stripes Property of LinearScale class

LinearScale.Stripes Property

The collection of Stripes currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Stripes As LinearStripCollection[C#]
public LinearStripCollection Stripes {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

Retrieve the 2nd Stripe in the gauge's collection and set Max to 40.

[C#]
 ChartFX.WinForms.Gauge.Strip myStrip = horizontalGauge1.MainScale.Stripes[1];
myStrip.Max = 40;

[Visual Basic]
 Dim myStrip As Strip
myStrip = HorizontalGauge1.MainScale.Stripes(1)
myStrip.Max = 40

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members


Thickness Property of Scale class

Scale.Thickness Property

Gets or sets the width for a scale.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Example

To set the width for the main scale of a radial gauge:

[C#]
 radialGauge1.MainScale.Thickness = (float) 0.05;

get-gauge -MainScale_Thickness 05

Applies to

Scale

See Also

Scale Class | Scale Members | Bar Property | ScaleBar Class


Tickmarks Property of BaseSection class

BaseSection.Tickmarks Property

Allows you to access the Tickmark properties for a section.

[Visual Basic]
Public ReadOnly Property Tickmarks As TickmarkSet[C#]
public TickmarkSet Tickmarks {get;}

Remarks

  • This property returns a TickmarkSet object. For more information regarding the supported members, please see the TickmarkSet class.

  • Using the TickmarkSet, you can access the attributes for the Major, Medium and Minor tickmarks.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Tickmark Class


MaxChanged Event of Range class

Range.MaxChanged Event

Event triggered when the associated Max value is changed.

[Visual Basic]
Public Event MaxChanged As EventHandler[C#]
public event EventHandler MaxChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

Remarks

  • Various gauge parts contain Range properties, for example, Scales, Sections, and Stripes.

See Also

Range Class | Range Members


MinChanged Event of Range class

Range.MinChanged Event

Event triggered when the associated Max value is changed.

[Visual Basic]
Public Event MinChanged As EventHandler[C#]
public event EventHandler MinChanged

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

Remarks

  • Various gauge parts contain Range properties, for example, Scales, Sections, and Stripes.

See Also

Range Class | Range Members


LinearStrip class

Provides access to the LinearStrip object.

For a list of all members of this type, see LinearStrip Members

ChartFX.WinForms.Gauge.Strip
ChartFX.WinForms.Gauge.LinearStrip

Remarks

A LinearStrip object is displayed next to a LinearScale. A Min and Max value may be configured to emphasize a range of values. Developers may include multiple LinearStrip objects in a linear gauge. The following image depicts two LinearStrip items (Red and Yellow) on a Horizontal Gauge.


LinearStrip Class Members

LinearStrip Members

LinearStrip Overview

Public Properties

public property AlternateColor (inherited from Strip) | Gets or sets the second color used in strip gradients or patterns.
public property Border (inherited from Strip) | Allows you to access the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType (inherited from Strip) | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property Offset | Gets or set the offset of a Strip respect ot the Scale.
public property Pattern (inherited from Strip) | Get or Set the Windows-Style pattern applied to the Strip
public property Thickness (inherited from Strip) | Gets or sets the width for a strip object.
public property UseFullRangeForGradient (inherited from Strip) | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


AlternateColor Property of Strip class

Strip.AlternateColor Property

Gets or sets the second color used in strip gradients or patterns.

[Visual Basic]
Public Property AlternateColor As Color[C#]
public Color AlternateColor {get;set;}

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

  • The Min and Max is used to configure the range for a Stripe object.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

Example

To set the AlternateColor for a radial strip:

[C#]
 RadialStrip myStrip = radialGauge1.MainScale.Stripes[0];
myStrip.AlternateColor = Color.Red;

Applies to

Strip

See Also

Strip Class | Strip Members | FillType Property | Min Property | Max Property | RadialScale Class | LinearScale Class


Border Property of Strip class

Strip.Border Property

Allows you to access the BarBorder object for a Strip object.

[Visual Basic]
Public ReadOnly Property Border As BarBorder[C#]
public BarBorder Border {get;}

Remarks

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

  • The Min and Max is used to configure the range for a Stripe object.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

Example

To access the BarBorder for a radial strip:

[C#]
 RadialStrip myStrip = radialGauge1.MainScale.Stripes[0];
BarBorder myBorder = myStrip.Border;

Applies to

Strip

See Also

Strip Class | Strip Members | Thickness Property | Min Property | Max Property | BarBorder Class | RadialScale Class | LinearScale Class


FillType Property of Strip class

Strip.FillType Property

Gets or sets the fill style for a strip solid, gradient or pattern.

[Visual Basic]
Public Property FillType As StripFillType[C#]
public StripFillType FillType {get;set;}

Property Value

The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

  • The Thickness property is used to configure the width for a strip.

  • The Min and Max is used to configure the range for a Stripe object.

Example

To configure the FillType for a strip as gradient:

[C#]
 RadialStrip myStrip = radialGauge1.MainScale.Stripes[0];
myStrip.FillType = FillType.Gradient;

Applies to

Strip

See Also

Strip Class | Strip Members | AlternateColor Property | Thickness Property | Min Property | Max Property | RadialScale Class | LinearScale Class


Offset Property of LinearStrip class

LinearStrip.Offset Property

Gets or set the offset of a Strip respect ot the Scale.

[Visual Basic]
Public Property Offset As Single[C#]
public Single Offset {get;set;}

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Example

To display a strip on the center of the main Sclale:

Applies to

LinearStrip

See Also

LinearStrip Class | LinearStrip Members | HorizontalGauge Class | VerticalGauge Class | LinearScale Class


Pattern Property of Strip class

Strip.Pattern Property

Get or Set the Windows-Style pattern applied to the Strip

[Visual Basic]
Public Property Pattern As HatchStyle[C#]
public HatchStyle Pattern {get;set;}

Remarks

  • For more information on Windows Patterns refer to .NET Framework documentation.

  • The HatchStyle enumeration is part of the System.Drawing.Drawing2D namespace.

  • The Strip.FillType property must be set to Pattern in order to see pattern effects.

  • An AlternateColor may also be specified for use with Patterns.

Example

Set a Strip Pattern.

[C#]
 horizontalGauge1.MainScale.Stripes[0].Pattern = System.Drawing.Drawing2D.HatchStyle.BackwardDiagonal;

[Visual Basic]
 HorizontalGauge1.MainScale.Stripes[0].Pattern = System.Drawing.Drawing2D.HatchStyle.BackwardDiagonal

get-gauge -MainScale_Stripes_0_Pattern BackwardDiagonal

Applies to

Strip

See Also

Strip Class | Strip Members


Thickness Property of Strip class

Strip.Thickness Property

Gets or sets the width for a strip object.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Remarks

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

  • The Border property is used to access the BarBorder object for a strip.

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

Example

To set the thickness for a strip:

[C#]
 RadialStrip myStrip = radialGauge1.MainScale.Stripes[0];
myStrip.Thickness = (float) 0.25;

Applies to

Strip

See Also

Strip Class | Strip Members | Border Property | Thickness Property | RadialScale Class | LinearScale Class | BarBorder Class


UseFullRangeForGradient Property of Strip class

Strip.UseFullRangeForGradient Property

Apply the gradient effect over the range of the scale.

[Visual Basic]
Public Property UseFullRangeForGradient As Boolean[C#]
public Boolean UseFullRangeForGradient {get;set;}

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

  • The FillType property must be set to Gradient for this property to have an effect.

Applies to

Strip

See Also

Strip Class | Strip Members


Marker class

Provides access to the Marker object.

For a list of all members of this type, see Marker Members

ChartFX.WinForms.Gauge.Indicator
ChartFX.WinForms.Gauge.Marker

Remarks

The Marker object is derived from the Indicator class. Markers are types of indicators that may be used in both a LinearGauge and RadialGauge.

The supported members of the Marker class may be used to configure Labels, Text, Size, Position and Style.


Marker Class Members

Marker Members

Marker Overview

Public Properties

public property AnimationSpan (inherited from Indicator) | Gets or Sets the time span value between each movement of an indicator.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property DisplayedText | Returns the current text displayed for a marker.
public property Draggable (inherited from Indicator) | Gets or sets a value indicating whether the indicator is movable via user interface.
public property DraggableCursor (inherited from Indicator) | Gets or Sets the mouse cursor displayed when dragging an indicator.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Label | Gets the LabelAttributes object for a Marker.
public property Position | Gets or sets the position for a marker.
public property PositionCustom | Gets or sets a custom position for a Marker object.
public property Size | Gets or sets a value to control the size of a marker.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a indicator marker.
public property Text | Gets or sets text for a marker.
public property ToolTip (inherited from Indicator) | Gets or sets the tool tip text for an Indicator.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property ValueDisplayed (inherited from Indicator) | Returns the Value pointed to by the Indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method HoveringRange (inherited from Indicator) Returns the range object currently under the Indicator, if it exists.

Public Event

public event ValueChanged (inherited from Indicator) Fires after the indicator value changes.


DisplayedText Property of Marker class

Marker.DisplayedText Property

Returns the current text displayed for a marker.

[Visual Basic]
Public ReadOnly Property DisplayedText As String[C#]
public String DisplayedText {get;}

Remarks

  • The DisplayedText represents a formated marker Text.

Example

To access the DisplayText for a marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
string myText = myMarker.DisplayedText;

Applies to

Marker

See Also

Marker Class | Marker Members | Style Property | Text Property | Label Property | LabelAttributes Class


Label Property of Marker class

Marker.Label Property

Gets the LabelAttributes object for a Marker.

[Visual Basic]
Public ReadOnly Property Label As LabelAttributes[C#]
public LabelAttributes Label {get;}

Remarks

  • This property provides access to the LabelAttributes object for a Marker. Please see the LabelAttributes class for additional information regarding supported members.

  • This parameter provides access to the Label object for a Marker.

Example

To access the LabelAttributes object for a Marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
LabelAttributes myLabels = myMarker.Label;

Applies to

Marker

See Also

Marker Class | Marker Members | Style Property | Size Property | LabelAttributes Class


Position Property of Marker class

Marker.Position Property

Gets or sets the position for a marker.

[Visual Basic]
Public Property Position As Position[C#]
public Position Position {get;set;}

Property Value

The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

  • The Label property is used to access the LabelAttributes object for a Marker.

Example

To set the position of a marker to Bottom:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
myMarker.Position = Position.Bottom;

Applies to

Marker

See Also

Marker Class | Marker Members | PositionCustom Property | Style Property | Label Property | LabelAttributes Class


PositionCustom Property of Marker class

Marker.PositionCustom Property

Gets or sets a custom position for a Marker object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the PositionCustom for a marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
myMarker.PositionCustom = (float) 0.8;

Applies to

Marker

See Also

Marker Class | Marker Members | Position Property | Style Property | Label Property


Size Property of Marker class

Marker.Size Property

Gets or sets a value to control the size of a marker.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the size for a marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
myMarker.Size = 5;

Applies to

Marker

See Also

Marker Class | Marker Members | Style Property


Style Property of Marker class

Marker.Style Property

Gets or sets the style for a indicator marker.

[Visual Basic]
Public Property Style As MarkerStyle[C#]
public MarkerStyle Style {get;set;}

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

  • The Value property may be used to configure a value for selected marker.

  • The Draggable property is used to configure whether an indicator needle value may be modified via user interaction (change value).

Example

To configure the style for a marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.Scales[0].Indicators[0];
myMarker.Style = NeedleStyle.Marker2;

Applies to

Marker

See Also

Marker Class | Marker Members | Value Property | Draggable Property | Indicator Class


Text Property of Marker class

Marker.Text Property

Gets or sets text for a marker.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set text for a marker:

[C#]
 Marker myMarker = (Marker) radialGauge1.MainScale.Indicators[0];
myMarker.CustomText = "Pressure Value";

Applies to

Marker

See Also

Marker Class | Marker Members | Label Property | DisplayedText Property | Value Property | Style Property | LabelAttributes Class


Needle class

Provides access to the Needle object.

For a list of all members of this type, see Needle Members

ChartFX.WinForms.Gauge.Indicator
ChartFX.WinForms.Gauge.Needle

Remarks

The Needle object is derived from the Indicator class. Needles are types of indicators that may be used for only a RadialGauge.

The supported members of the Needle class may be used to configure the Size and Style for needles.


Needle Class Members

Needle Members

Needle Overview

Public Properties

public property AnimationSpan (inherited from Indicator) | Gets or Sets the time span value between each movement of an indicator.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Draggable (inherited from Indicator) | Gets or sets a value indicating whether the indicator is movable via user interface.
public property DraggableCursor (inherited from Indicator) | Gets or Sets the mouse cursor displayed when dragging an indicator.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Size | Gets or sets a value to control the size of a needle.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a radial indicator needle.
public property ToolTip (inherited from Indicator) | Gets or sets the tool tip text for an Indicator.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property ValueDisplayed (inherited from Indicator) | Returns the Value pointed to by the Indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Methods

public method HoveringRange (inherited from Indicator) Returns the range object currently under the Indicator, if it exists.

Public Event

public event ValueChanged (inherited from Indicator) Fires after the indicator value changes.


Size Property of Needle class

Needle.Size Property

Gets or sets a value to control the size of a needle.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • When set to zero, the needle is not visible in a radial gauge. This is a ratio property, therefore the overall size of a radial gauge is also a factor when rendering the needle.

Example

To configure the SizeRatio for a needle:

[C#]
 Needle myNeedle = (Needle) radialGauge1.Scales[0].Indicators[0];
myNeedle.Size = 1.0;

Applies to

Needle

See Also

Needle Class | Needle Members


Style Property of Needle class

Needle.Style Property

Gets or sets the style for a radial indicator needle.

[Visual Basic]
Public Property Style As NeedleStyle[C#]
public NeedleStyle Style {get;set;}

Value | Meaning
Needle01 | Set the needle style to Needle01.
Needle02 | Set the needle style to Needle02.
Needle03 | Set the needle style to Needle03.
Needle04 | Set the needle style to Needle04.
Needle05 | Set the needle style to Needle05.
Needle06 | Set the needle style to Needle06.
Needle07 | Set the needle style to Needle07.
Needle08 | Set the needle style to Needle08.
Needle09 | Set the needle style to Needle09.
Needle10 | Set the needle style to Needle10.
Needle11 | Set the needle style to Needle11.
Needle12 | Set the needle style to Needle12.
Needle13 | Set the needle style to Needle13.
Needle14 | Set the needle style to Needle14.
Needle15 | Set the needle style to Needle15.
Needle16 | Set the needle style to Needle16.
Needle17 | Set the needle style to Needle17.
Needle18 | Set the needle style to Needle18.
Needle19 | Set the needle style to Needle19.
Needle20 | Set the needle style to Needle20.

Remarks

  • A needle is an indicator in a radial gauge which marks a value. There are several different needle designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported NeedleStyle enumeration types.

Example

To configure the Style for a needle:

[C#]
 Needle myNeedle = (Needle) radialGauge1.Scales[0].Indicators[0];
myNeedle.Style = NeedleStyle.Needle5;

Applies to

Needle

See Also

Needle Class | Needle Members | Size Property


RadialBorder class

Provides access to the RadialBorder object.

For a list of all members of this type, see RadialBorder Members

ChartFX.WinForms.Gauge.Border
ChartFX.WinForms.Gauge.RadialBorder

Remarks

The RadialBorder class is used to customize the outer frame for a RadialGauge. The Border property of the RadialGauge object returns the RadialBorder object.


RadialBorder Class Members

RadialBorder Members

RadialBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare (inherited from Border) | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor (inherited from Border) | Gets or sets the inside color for a gauge border.
public property InsideEffects (inherited from Border) | Enables or disables border shadow and gradient.
public property Style | Gets or sets the style for a RadialBorder object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Style Property of RadialBorder class

RadialBorder.Style Property

Gets or sets the style for a RadialBorder object.

[Visual Basic]
Public Property Style As RadialBorderStyle[C#]
public RadialBorderStyle Style {get;set;}

Value | Meaning
CircularBorder01 | Set the border style to CircularBorder01.
CircularBorder02 | Set the border style to CircularBorder02.
CircularBorder03 | Set the border style to CircularBorder03.
CircularBorder04 | Set the border style to CircularBorder04.
CircularBorder05 | Set the border style to CircularBorder05.
CircularBorder06 | Set the border style to CircularBorder06.
CircularBorder07 | Set the border style to CircularBorder07.
CircularBorder08 | Set the border style to CircularBorder08.
CircularBorder09 | Set the border style to CircularBorder09.
CircularBorder10 | Set the border style to CircularBorder10.
CircularBorder11 | Set the border style to CircularBorder11.
CircularBorder12 | Set the border style to CircularBorder12.
CircularBorder13 | Set the border style to CircularBorder13.
CircularBorder14 | Set the border style to CircularBorder14.
CircularBorder15 | Set the border style to CircularBorder15.
CircularBorder16 | Set the border style to CircularBorder16.
CircularBorder17 | Set the border style to CircularBorder17.
CircularBorder18 | Set the border style to CircularBorder18.
CircularBorder19 | Set the border style to CircularBorder19.
SemiCircularBorder01 | Set the border style to SemiCircularBorder01.
SemiCircularBorder02 | Set the border style to SemiCircularBorder02.
SemiCircularBorder03 | Set the border style to SemiCircularBorder03.
SemiCircularBorder04 | Set the border style to SemiCircularBorder04.
SemiCircularBorder05 | Set the border style to SemiCircularBorder05.
SemiCircularBorder06 | Set the border style to SemiCircularBorder06.
SemiCircularBorder07 | Set the border style to SemiCircularBorder07.
RectangularBorder01 | Set the border style to RectangularBorder01.
RectangularBorder02 | Set the border style to RectangularBorder02.
RectangularBorder03 | Set the border style to RectangularBorder03.
RectangularBorder04 | Set the border style to RectangularBorder04.

Remarks

  • The RadialBorder is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported RadialBorderStyle types.

  • The Border property of the RadialGauge object is used to access the RadialBorder object.

Example

To configure the style for a RadialBorder:

[C#]
 radialGauge1.Border.Style = RadialBorderStyle.SemiCircularBorder01;

[Visual Basic]
 radialGauge1.Border.Style = RadialBorderStyle.SemiCircularBorder01

get-gauge -Border_Style SemiCircularBorder01

Applies to

RadialBorder

See Also

RadialBorder Class | RadialBorder Members | Border Property | RadialGauge Class


RadialCap class

Provides access to the RadialCap object.

For a list of all members of this type, see RadialCap Members

ChartFX.WinForms.Gauge.RadialCap

Remarks

The RadialCap is the object that connects an indictor Needle to a RadialScale object. The RadialCap is located at the center of a RadialScale. If a Marker indicator is used, the RadialCap will still be visible in the gauge. Supported members of this object allow control over size, style and needle position.


RadialCap Class Members

RadialCap Members

RadialCap Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Size | Gets or sets a value to control the size of a RadialCap.
public property Style | Gets or sets the styles for a RadialCap.
public property VerticalPosition | Gets or Sets the positioning of the Radial Cap to behind or above the Indicator(s).
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Size Property of RadialCap class

RadialCap.Size Property

Gets or sets a value to control the size of a RadialCap.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Example

To increase the size of the MainScale RadialCap for a RadialGauge:

[C#]
 radialGauge1.MainScale.Cap.Size = (float) .4;

get-gauge -MainScale_Cap_Size 4

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members | Cap Property | Style Property | RadialScale Class | RadialGauge Class


Style Property of RadialCap class

RadialCap.Style Property

Gets or sets the styles for a RadialCap.

[Visual Basic]
Public Property Style As RadialCapStyle[C#]
public RadialCapStyle Style {get;set;}

Value | Meaning
Cap01 | Set the cap style to Cap01.
Cap02 | Set the cap style to Cap02.
Cap03 | Set the cap style to Cap03.
Cap04 | Set the cap style to Cap04.
Cap05 | Set the cap style to Cap05.
Cap06 | Set the cap style to Cap06.
Cap07 | Set the cap style to Cap07.
Cap08 | Set the cap style to Cap08.
Cap09 | Set the cap style to Cap09.
Cap10 | Set the cap style to Cap10.
Cap11 | Set the cap style to Cap11.
Cap12 | Set the cap style to Cap12.
Cap13 | Set the cap style to Cap13.
Cap14 | Set the cap style to Cap14.
Cap15 | Set the cap style to Cap15.
Cap16 | Set the cap style to Cap16.
Cap17 | Set the cap style to Cap17.
Cap18 | Set the cap style to Cap18.
RotatingCap01 | Set the cap style to RotatingCap01.
RotatingCap02 | Set the cap style to RotatingCap02.
RotatingCap03 | Set the cap style to RotatingCap03.

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

  • The Cap property is used to obtain the RadialCap object of a RadialScale.

  • The Size property is used to control the size of a RadialCap.

Example

To configure a style for the MainScale RadialCap object:

[C#]
 radialGauge1.MainScale.Cap.Style = RadialCapStyle.Cap02;

get-gauge -MainScale_Cap_Style Cap02

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members | Cap Property | Size Property | RadialScale Class


VerticalPosition Property of RadialCap class

RadialCap.VerticalPosition Property

Gets or Sets the positioning of the Radial Cap to behind or above the Indicator(s).

[Visual Basic]
Public Property VerticalPosition As RadialCapVerticalPosition[C#]
public RadialCapVerticalPosition VerticalPosition {get;set;}

Property Value

The default is AboveNeedles.

Value | Meaning
AboveNeedles | Positions the Cap on top of the Needle.
BehindNeedles | Positions the Cap inder the Needle.

Remarks

  • This is merely an aesthetic feature, but will change the order of the HitTestTargetStack.

Example

Set the Radial Cap position to behind the Indicator needle.

[C#]
 radialGauge1.MainScale.Cap.VerticalPosition = RadialCapVerticalPosition.BehindNeedles;

[Visual Basic]
 RadialGauge1.MainScale.Cap.VerticalPosition = RadialCapVerticalPosition.BehindNeedles

get-gauge -MainScale_Cap_VerticalPosition BehindNeedles

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members


RadialGauge class

Provides access to the RadialGauge object.

For a list of all members of this type, see RadialGauge Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.Gauge
ChartFX.WinForms.Gauge.RadialGauge

Remarks

A RadialGauge is a circular gauge that includes a circular scale. Needle or Marker indicators are used to display values for a RadialGauge scale. RadialScales may include multiple scales and multiple indicators per scale object. Below is an example of a RadialGauge:


RadialGauge Class Members

RadialGauge Members

RadialGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border | Allows you to determine the border settings for a radial gauge.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.
public property MainScale | Returns the main scale of a radial gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales | Returns the RadialScaleCollection for the RadialGauge object.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.

Public Event

public event DraggingStarted (inherited from Gauge) | The source of the event.
public event DraggingStopped (inherited from Gauge) | The source of the event.
public event GetTip (inherited from BaseGauge) | The source of the event.
public event MainValueChanged (inherited from Gauge) | Fires after the MainValue has changed.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event RangeEntered (inherited from Gauge) | The source of the event.
public event RangeLeft (inherited from Gauge) | The source of the event.
public event ValueChanged (inherited from Gauge) | The source of the event.


Border Property of RadialGauge class

RadialGauge.Border Property

Allows you to determine the border settings for a radial gauge.

[Visual Basic]
Public ReadOnly Property Border As RadialBorder[C#]
public RadialBorder Border {get;}

Remarks

  • The RadialBorder is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges.

  • This property returns a RadialBorder object. For additional information regarding supported members, please see the RadialBorder class.

Example

To set the Radial Border a Rectangular border:

[C#]
 radialGauge1.Border.Style = RadialBorderStyle.RectangularBorder04;

[Visual Basic]
 radialGauge1.Border.Style = RadialBorderStyle.RectangularBorder04

get-gauge -Border_Style RectangularBorder04

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | RadialBorder Class


MainScale Property of RadialGauge class

RadialGauge.MainScale Property

Returns the main scale of a radial gauge.

[Visual Basic]
Public ReadOnly Property MainScale As RadialScale[C#]
public RadialScale MainScale {get;}

Remarks

  • A scale for a radial gauge is the range of values which a gauge can indicate a value. Indicators mark values in a given scale.

  • By default, the RadialCap of the main scale is visible. If a scale is not the main scale, its cap will not be visible by default.

  • The Scales property may be used to obtain the RadialScaleCollection for a radial gauge. The MainScale property is used to return the main scale object. By default, the main scale is the first scale of the collection.

Example

To obtain the main scale object for a radial gauge:

[C#]
 RadialScale myMainScale = radialGauge1.MainScale;

[Visual Basic]
 Dim myMainScale As RadialScale
myMainScale = radialGauge1.MainScale

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | Scales Property | MainIndicator Property | MainValue Property | RadialScale Class


Scales Property of RadialGauge class

RadialGauge.Scales Property

Returns the RadialScaleCollection for the RadialGauge object.

[Visual Basic]
Public ReadOnly Property Scales As RadialScaleCollection[C#]
public RadialScaleCollection Scales {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The RadialScale object is used to control attributes for a selected scale.

  • The MainScale property is used to obtain the main scale for a selected RadialGauge.

Example

To access the 1st scale object of a radial gauge:

[C#]
 RadialScale myScale = (RadialScale) radialGauge1.Scales[0];

[Visual Basic]
 Dim myScale As RadialScale
RadialScale = radialGauge1.Scales(0)

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | MainScale Property | RadialScale Class


RadialScale class

Provides access to the RadialScale object.

For a list of all members of this type, see RadialScale Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseSection
ChartFX.WinForms.Gauge.Scale
ChartFX.WinForms.Gauge.RadialScale

Remarks

The RadialScale object is the circular scale of values displayed inside a RadialGauge. RadialGauge objects may support multiple radial scales. A Needle or Marker indicator type by be used to depict a value for a RadialScale.


RadialScale Class Members

RadialScale Members

RadialScale Overview

Public Properties

public property Bar (inherited from Scale) | Returns the ScaleBar object for a section.
public property Cap | Returns the RadialCap object for a selected RadialScale.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property CustomLabels (inherited from Scale) | The collection of Custom Labels currently associated with the scale.
public property Indicators (inherited from Scale) | The collection of Indicators currently associated with the scale.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Pivot | Gets or Sets the position of the scale within the gauge.
public property Radius | Gets or sets the radius for a RadialScale object.
public property Sections (inherited from Scale) | Returns the SectionCollection for a scale object.
public property StartAngle | Gets or sets the starting angle in degrees for a RadialScale.
public property Stripes | The collection of Stripes currently associated with the scale.
public property SweepAngle | Gets or sets the starting angle in degrees for a RadialScale.
public property Thickness (inherited from Scale) | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Allows you to access the Tickmark properties for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Cap Property of RadialScale class

RadialScale.Cap Property

Returns the RadialCap object for a selected RadialScale.

[Visual Basic]
Public ReadOnly Property Cap As RadialCap[C#]
public RadialCap Cap {get;}

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

  • The Cap property is used to access the RadialCap object of a RadialScale object. The supported members of the RadialCap class may be used to customize the display of a cap.

Example

To configure the RadialCap style for the MainScale of a RadialGauge:

[C#]
 radialGauge1.MainScale.Cap.Style = RadialCapStyle.RadialCap2;

get-gauge -MainScale_Cap_Style RadialCap2

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | Size Property | Style Property | RadialCap Class | RadialScale Class


Pivot Property of RadialScale class

RadialScale.Pivot Property

Gets or Sets the position of the scale within the gauge.

[Visual Basic]
Public Property Pivot As PointF[C#]
public PointF Pivot {get;set;}

Remarks

  • RadialScale movement centers around the Cap.

  • The coordinate system for positioning the scale mirrors a Unit Circle. The center point is (0,0). The top-center point is (0,1) and the bottom-center point is (0,-1). The left-center point is (-1,0) and the right-center point is (1,0).

  • This property accepts a PointF object that defines the coordinates.

Example

Set the Pivot using a PointF object.

[C#]
 radialGauge1.MainScale.Pivot = new PointF(-0.75f, 0.5f);

[Visual Basic]
 RadialGauge1.MainScale.Pivot = New PointF(-0.75, 0.5)

get-gauge -MainScale_Pivot 5f

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members


Radius Property of RadialScale class

RadialScale.Radius Property

Gets or sets the radius for a RadialScale object.

[Visual Basic]
Public Property Radius As Single[C#]
public Single Radius {get;set;}

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for RadialScales, multiple RadialScale objects may be displayed in a single RadialGauge object.

  • This property is used to control the size of a RadialScale object.

Example

To configure the Radius of the MainScale of a RadialGauge to 0.5:

[C#]
 radialGauge1.MainScale.Radius = (float) 0.5;

get-gauge -MainScale_Radius 5

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | RadialGauge Class


StartAngle Property of RadialScale class

RadialScale.StartAngle Property

Gets or sets the starting angle in degrees for a RadialScale.

[Visual Basic]
Public Property StartAngle As Single[C#]
public Single StartAngle {get;set;}

Remarks

  • This property supports a configuration value between 0 and 360.

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The SweepAngle property is used to get or set the angle at the ending value for a scale.

Example

To configure the starting angle for a scale to 275 degrees:

[C#]
 radialGauge1.Scales[0].StartAngle = 275;

get-gauge -Scales_0_StartAngle 275

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | Radius Property | SweepAngle Property | RadialGauge Class


Stripes Property of RadialScale class

RadialScale.Stripes Property

The collection of Stripes currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Stripes As RadialStripCollection[C#]
public RadialStripCollection Stripes {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

Retrieve the 2nd Stripe in the gauge's collection and set Max to 40.

[C#]
 ChartFX.WinForms.Gauge.Strip myStrip = horizontalGauge1.MainScale.Stripes[1];
myStrip.Max = 40;

[Visual Basic]
 Dim myStrip As Strip
myStrip = HorizontalGauge1.MainScale.Stripes(1)
myStrip.Max = 40

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members


SweepAngle Property of RadialScale class

RadialScale.SweepAngle Property

Gets or sets the starting angle in degrees for a RadialScale.

[Visual Basic]
Public Property SweepAngle As Single[C#]
public Single SweepAngle {get;set;}

Remarks

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The StartAngle property is used to get or set the ending angle in degrees for a RadialScale.

Example

To configure the SweepAngle for a RadialScale to -225:

[C#]
 radialGauge1.Scales[0].SweepAngle = -225;

get-gauge -Scales_0_SweepAngle -225

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | StartAngle Property | Radius Property


RadialStrip class

Provides access to the RadialStrip object.

For a list of all members of this type, see RadialStrip Members

ChartFX.WinForms.Gauge.Strip
ChartFX.WinForms.Gauge.RadialStrip

Remarks

A RadialStrip is an object used that may be used to emphasize a range of values for a RadialGauge. Multiple RadialStrips may be configured for a selected RadialScale. RadialGauges also support Section objects; these are very similar however are painted over RadialScale tickmarks and include labels.


RadialStrip Class Members

RadialStrip Members

RadialStrip Overview

Public Properties

public property AlternateColor (inherited from Strip) | Gets or sets the second color used in strip gradients or patterns.
public property Border (inherited from Strip) | Allows you to access the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType (inherited from Strip) | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property Pattern (inherited from Strip) | Get or Set the Windows-Style pattern applied to the Strip
public property Radius | Gets or sets the radius for a RadialStrip object.
public property Thickness (inherited from Strip) | Gets or sets the width for a strip object.
public property UseFullRangeForGradient (inherited from Strip) | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


Radius Property of RadialStrip class

RadialStrip.Radius Property

Gets or sets the radius for a RadialStrip object.

[Visual Basic]
Public Property Radius As Single[C#]
public Single Radius {get;set;}

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for RadialStripe objects, multiple RadialStrips may be displayed over the same range of a RadialScale object.

  • This property is used to control the size of a RadialStrip object.

  • The Stripes property is used to access the RadialStrip object of a RadialScale.

Example

To configure the Radius of a strip to 1:

[C#]
 radialGauge1.MainScale.Stripes[0].Radius = 1;

get-gauge -MainScale_Stripes_0_Radius 1

Applies to

RadialStrip

See Also

RadialStrip Class | RadialStrip Members | Stripes Property | RadialScale Class


Scale class

Provides access to the Scale object.

For a list of all members of this type, see Scale Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseSection
ChartFX.WinForms.Gauge.Scale

Remarks

The Scale class is a base class for the RadialScale and LinearScale objects. A scale is a range of values which the configured gauge value is displayed. The Scale object was not designed for direct use by developers.


Scale Class Members

Scale Members

Scale Overview

Public Properties

public property Bar | Returns the ScaleBar object for a section.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property CustomLabels | The collection of Custom Labels currently associated with the scale.
public property Indicators | The collection of Indicators currently associated with the scale.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Sections | Returns the SectionCollection for a scale object.
public property Thickness | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Allows you to access the Tickmark properties for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


ScaleBar class

Provides access to the ScaleBar object.

For a list of all members of this type, see ScaleBar Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.Primitives.BaseSectionBar
ChartFX.WinForms.Gauge.ScaleBar

Remarks

A ScaleBar is the strip associated with a selected scale in a gauge. The supported members of this class allow users to configure a Border for selected ScaleBar object.


ScaleBar Class Members

ScaleBar Members

ScaleBar Overview

Public Properties

public property Border | Allows you to access the Bar Border object for a gauge bar object.
public property Color (inherited from BaseSectionBar) | Get or set the color of the section bar.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Border Property of ScaleBar class

ScaleBar.Border Property

Allows you to access the Bar Border object for a gauge bar object.

[Visual Basic]
Public ReadOnly Property Border As BarBorder[C#]
public BarBorder Border {get;}

Remarks

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

  • The Bar property of the Scale class is used to gain access to the ScaleBar object.

Example

To access the BarBorder object for a ScaleBar:

[C#]
 BarBorder myBorder = radialGauge1.MainScale.Bar.Border;

Applies to

ScaleBar

See Also

ScaleBar Class | ScaleBar Members | Thickness Property | Bar Property | BarBorder Class | Scale Class


Color Property of BaseSectionBar class

BaseSectionBar.Color Property

Get or set the color of the section bar.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Applies to

BaseSectionBar

See Also

BaseSectionBar Class | BaseSectionBar Members


Section class

Provides access to the Section object.

For a list of all members of this type, see Section Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseSection
ChartFX.WinForms.Gauge.Section

Remarks

A Section object is a range of values for a selected RadialScale or LinearScale objects. Sections also support SectionBar which is the strip associated with a section. The SectionBar object may be used to configure a border for a section.


Section Class Members

Section Members

Section Overview

Public Properties

public property Bar | Returns the SectionBar object for a section.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Tickmarks (inherited from BaseSection) | Allows you to access the Tickmark properties for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Bar Property of Section class

Section.Bar Property

Returns the SectionBar object for a section.

[Visual Basic]
Public ReadOnly Property Bar As SectionBar[C#]
public SectionBar Bar {get;}

Remarks

  • The SectionBar object is the colored band for a section object. The supported members of the SectionBar class are used to customize this object.

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

  • The MinAlwaysDisplayed property is a boolean used to specify whether or not a Section will display the starting value at all times.

Example

To obtain the SectionBar object for a Section of a radial gauge:

[C#]
 SectionBar mySectBar = radialGauge1.Scales[0].Sections[0].Bar;

Applies to

Section

See Also

Section Class | Section Members | MinAlwaysDisplayed Property | Max Property | Min Property | SectionBar Class


SectionBar class

Provides access to the SectionBar object

For a list of all members of this type, see SectionBar Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.Primitives.BaseSectionBar
ChartFX.WinForms.Gauge.SectionBar

Remarks

A SectionBar is the strip associated with a selected scale in a gauge. The supported members of this class allow users to configure a Color for selected SectionBar object.


SectionBar Class Members

SectionBar Members

SectionBar Overview

Public Properties

public property Color (inherited from BaseSectionBar) | Get or set the color of the section bar.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Strip class

Provides access to the Strip object.

For a list of all members of this type, see Strip Members

ChartFX.WinForms.Gauge.Strip

Remarks

The LinearStrip and RadialStrip objects are derived from the Strip class. The Strip class was not designed for direct use by developers.


Strip Class Members

Strip Members

Strip Overview

Public Properties

public property AlternateColor | Gets or sets the second color used in strip gradients or patterns.
public property Border | Allows you to access the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property Pattern | Get or Set the Windows-Style pattern applied to the Strip
public property Thickness | Gets or sets the width for a strip object.
public property UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


Tickmark class

Provides access to the Tickmark object.

For a list of all members of this type, see Tickmark Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.Tickmark

Remarks

Tickmarks are displayed in a RadialGauge and LinearGauge scale objects. The members of this object are used to customize the display for tickmarks in gauges.


Tickmark Class Members

Tickmark Members

Tickmark Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Label | Returns the LabelAttributes object for a tickmark.
public property Position | Gets or sets the position for tickmarks in a scale.
public property PositionCustom | Gets or sets a custom position for a Tickmark object.
public property Size | Gets or sets a value to control the size of tickmarks.
public property Step | Gets or sets a value indicating the interval for tickmark display.
public property Style | Gets or sets the tickmark style.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Label Property of Tickmark class

Tickmark.Label Property

Returns the LabelAttributes object for a tickmark.

[Visual Basic]
Public ReadOnly Property Label As LabelAttributes[C#]
public LabelAttributes Label {get;}

Remarks

  • This property provides access to the LabelAttributes object for a tickmark. Please see the LabelAttributes class for additional information regarding supported members.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To access the LabelAttributes object for a tickmark:

[C#]
 LabelAttributes myLabelAttributes = radialGauge1.MainScale.MajorTickmark.Label;

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Step Property | ValueFormat Class


Position Property of Tickmark class

Tickmark.Position Property

Gets or sets the position for tickmarks in a scale.

[Visual Basic]
Public Property Position As Position[C#]
public Position Position {get;set;}

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To configure the tickmark position to Bottom:

[C#]
 radialGauge1.MainScale.MajorTickmark.Position = Position.Bottom;

get-gauge -MainScale_MajorTickmark_Position Bottom

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | PositionCustom Property | Step Property | Style Property | ValueFormat Class


PositionCustom Property of Tickmark class

Tickmark.PositionCustom Property

Gets or sets a custom position for a Tickmark object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To configure the custom position for the major tickmarks in a radial scale:

[C#]
 radialGauge1.MainScale.MajorTickmark.PositionCustom = (float) 0.2;

get-gauge -MainScale_MajorTickmark_PositionCustom 2

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Step Property | Style Property | ValueFormat Class


Size Property of Tickmark class

Tickmark.Size Property

Gets or sets a value to control the size of tickmarks.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To configure the size for a tickmark:

[C#]
 radialGauge1.MainScale.MajorTickmark.Size = (float) 0.5;

get-gauge -MainScale_MajorTickmark_Size 5

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Step Property | Style Property | ValueFormat Class


Step Property of Tickmark class

Tickmark.Step Property

Gets or sets a value indicating the interval for tickmark display.

[Visual Basic]
Public Property Step As Double[C#]
public Double Step {get;set;}

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the TickMark step to 5:

[C#]
 radialGauge1.MainScale.MajorTickmark.Step = 5;

get-gauge -MainScale_MajorTickmark_Step 5

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Style Property | ValueFormat Class


Style Property of Tickmark class

Tickmark.Style Property

Gets or sets the tickmark style.

[Visual Basic]
Public Property Style As TickmarkStyle[C#]
public TickmarkStyle Style {get;set;}

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To configure the style for major tickmarks in a radial gauge:

[C#]
 radialGauge1.MainScale.MajorTickmark.Style = TickmarkStyle.Tickmark10_3;

get-gauge -MainScale_MajorTickmark_Style Tickmark10_3

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | PositionCustom Property | ValueFormat Class


TickmarkSet class

Provides access to the TickmarkSet object.

For a list of all members of this type, see TickmarkSet Members

ChartFX.WinForms.Gauge.TickmarkSet

Remarks

The TickmackSet object provides access to the Major, Medium and Minor tickmarks objects.

Tickmarks are displayed in a RadialGauge, VerticalGauge and HorizontalGauge scale objects.


TickmarkSet Class Members

TickmarkSet Members

TickmarkSet Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Format | Gets or sets the ValueFormat object for selected tickmark object.
public property Major | Allows for configuration of the Major tick marks.
public property Medium | Allows for configuration of the Medium tick marks.
public property Minor | Allows for configuration of the Minor tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Format Property of TickmarkSet class

TickmarkSet.Format Property

Gets or sets the ValueFormat object for selected tickmark object.

[Visual Basic]
Public ReadOnly Property Format As ValueFormat[C#]
public ValueFormat Format {get;}

Remarks

  • The ValueFormat object supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels. Please see the ValueFormat class for more information.

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To access the ValueFormat object for major tick marks:

[C#]
 ValueFormat tickFormat = radialGauge1.MainScale.MajorTickmark.Format;

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members | Position Property | PositionCustom Property | ValueFormat Class


Major Property of TickmarkSet class

TickmarkSet.Major Property

Allows for configuration of the Major tick marks.

[Visual Basic]
Public ReadOnly Property Major As Tickmark[C#]
public Tickmark Major {get;}

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

Change the size of the Major tick marks.

[C#]
 radialGauge1.MainScale.Tickmarks.Major.Size = 5.0f;

[Visual Basic]
 RadialGauge1.MainScale.Tickmarks.Major.Size = 5

get-gauge -MainScale_Tickmarks_Major_Size 0f

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Medium Property of TickmarkSet class

TickmarkSet.Medium Property

Allows for configuration of the Medium tick marks.

[Visual Basic]
Public ReadOnly Property Medium As Tickmark[C#]
public Tickmark Medium {get;}

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

Change the color of the Medium tick marks.

[C#]
 radialGauge1.MainScale.Tickmarks.Medium.Color = Color.Azure;

[Visual Basic]
 RadialGauge1.MainScale.Tickmarks.Medium.Color = Color.Azure

get-gauge -MainScale_Tickmarks_Medium_Color Azure

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Minor Property of TickmarkSet class

TickmarkSet.Minor Property

Allows for configuration of the Minor tick marks.

[Visual Basic]
Public ReadOnly Property Minor As Tickmark[C#]
public Tickmark Minor {get;}

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

Change the Minor tick mark style.

[C#]
 radialGauge1.MainScale.Tickmarks.Minor.Style = TickmarkStyle.Tickmark05_1;

[Visual Basic]
 RadialGauge1.MainScale.Tickmarks.Minor.Style = TickmarkStyle.Tickmark05_1

get-gauge -MainScale_Tickmarks_Minor_Style Tickmark05_1

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Title class

Provides access to the Title object.

For a list of all members of this type, see Title Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.Title

Remarks

The Title object derives from the Annotation class. Titles are supported for all gauge types. The supported members of this object allow you to configure text for gauge titles.


Title Class Members

Title Members

Title Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Color | Sets the color of text for the specified title.
public property DisplayedText | Returns the displayed title text as a string.
public property Font | Gets or sets the Gauge Font object for a gauge title.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property Text | Gets or sets the text for the selected title.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Color Property of Title class

Title.Color Property

Sets the color of text for the specified title.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • The Text propety is used to set the caption for a title.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Example

To configure text color to red:

[C#]
 radialGauge1.Titles[0].Color = Color.Red;

[Visual Basic]
 radialGauge1.Titles(0).Color = Color.Red

get-gauge -Titles_0_Color Red

Applies to

Title

See Also

Title Class | Title Members | Text Property


DisplayedText Property of Title class

Title.DisplayedText Property

Returns the displayed title text as a string.

[Visual Basic]
Public ReadOnly Property DisplayedText As String[C#]
public String DisplayedText {get;}

Remarks

  • The Text propety is used to set the caption for a title.

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To return the DisplayedText for a title:

[C#]
 string myTitleString = radialGauge1.Titles[0].DisplayedText;

Applies to

Title

See Also

Title Class | Title Members | Text Property | Color Property | Font Property


Font Property of Title class

Title.Font Property

Gets or sets the Gauge Font object for a gauge title.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • This property is used to access the ScalableFont object for a gauge title. Gauges also support a Font property for the entire gauge object.

  • This Font property is used to configure the ScalableFont object for a gauge. Please see the GaugeFont class for supported font members.

Example

To configure the font for a radial gauge:

[C#]
 ScalableFont myScalableFont = new ScalableFont(FontFamily.GenericSerif, FontSize.Medium, FontStyle.Regular);
radialGauge1.Titles[0].Font = myScalableFont;

get-gauge -Titles_0_Font myScalableFont

Applies to

Title

See Also

Title Class | Title Members | Font Property | GaugeFont Class


Text Property of Title class

Title.Text Property

Gets or sets the text for the selected title.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To set title text for a gauge:

[C#]
 radialGauge1.Titles[0].Text = "Pressure";

[Visual Basic]
 radialGauge1.Titles(0).Text = "Pressure"

get-gauge -Titles_0_Text "Pressure"

Applies to

Title

See Also

Title Class | Title Members | Color Property | Font Property


Value class

Provides access to the gauge Value object.

For a list of all members of this type, see Value Members

ChartFX.WinForms.Gauge.Value

Remarks

This property implicity casts double to Value and Value to double.


Value Class Members

Value Members

Value Overview

Public Properties

public property CurrentValue Get the value of the gauge.

Public Methods

public method Dispose Performs tasks associated with freeing, releasing, or resetting unmanaged resources.


CurrentValue Property of Value class

Value.CurrentValue Property

Get the value of the gauge.

[Visual Basic]
Public ReadOnly Property CurrentValue As Double[C#]
public Double CurrentValue {get;}

Remarks

  • This is a read-only property.

Applies to

Value

See Also

Value Class | Value Members


Dispose Method of Value class

Value.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose[C#]
public Void Dispose();

Remarks

  • Use this method to close or release unmanaged resources such as files, streams, and handles held by an instance of the class that implements this interface. This method is, by convention, used for all tasks associated with freeing resources held by an object, or preparing an object for reuse.

  • Please see your .NET Framework documentation for additional information regarding Dispose.

See Also

Value Class | Value Members


ValueFormat class

Provides access to the ValueFormat object.

For a list of all members of this type, see ValueFormat Members

ChartFX.WinForms.Gauge.ValueFormat

Remarks

The ValueFormat class members allow you to format labels as Currency, Numeric, Percentage, Scientific or Custom.


ValueFormat Class Members

ValueFormat Members

ValueFormat Overview

Public Properties

public property Culture | Allows you to localize labels and data for a specific language and region.
public property Decimals | Gets or sets the number of decimals for a label.
public property FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
public property FormatType | Gets or sets the value Type for which to get a formatting object.

Public Methods

public method FormatValue Format a value to a string.


Culture Property of ValueFormat class

ValueFormat.Culture Property

Allows you to localize labels and data for a specific language and region.

[Visual Basic]
Public Property Culture As CultureInfo[C#]
public CultureInfo Culture {get;set;}

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture. These values are documented in the .NET Framework Documentation.

  • An application that is ready for localization is separated into two conceptual blocks, a block that contains all user interface elements and a block that contains executable code. The user interface block contains only localizable user-interface elements such as strings, error messages, dialog boxes, menus, embedded object resources, and so on for the neutral culture. The code block contains only the application code to be used by all supported cultures. The common language runtime supports a satellite assembly resource model that separates an application's executable code from its resources. For more information about implementing this model, see 'Resources in Applications' in the .NET Framework Documentation.

    For each localized version of your application that you want to create, add a new satellite assembly that contains the localized user interface block translated into the appropriate language for the target culture. The code block for all cultures should remain the same. The combination of a localized version of the user interface block with the code block produces a localized version of your application.

  • For more information regarding the CultureInfo type, please refer to the .NET Framework .

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

[C#]
 radialGauge1.MainScale.Indicators[0].Format.Culture = System.Globalization.CultureInfo("es-ES");

get-gauge -MainScale_Indicators_0_Format_Culture "es-ES"

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members


Decimals Property of ValueFormat class

ValueFormat.Decimals Property

Gets or sets the number of decimals for a label.

[Visual Basic]
Public Property Decimals As Int32[C#]
public Int32 Decimals {get;set;}

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

  • The FormatValue method is used to format any double using the configured format of the ValueFormat object.

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

Example

To set the decimals to 3 for a gauges labels:

[C#]
 radialGauge1.MainScale.Indicators[0].Format.Decimals = 3;

get-gauge -MainScale_Indicators_0_Format_Decimals 3

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members | FormatCustom Property | FormatType Property | FormatValue Method | ValueFormat Class


FormatCustom Property of ValueFormat class

ValueFormat.FormatCustom Property

Allows you to set a custom format to the selected label, mouseover tip or value.

[Visual Basic]
Public Property FormatCustom As String[C#]
public String FormatCustom {get;set;}

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check .NET Framework documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members


FormatType Property of ValueFormat class

ValueFormat.FormatType Property

Gets or sets the value Type for which to get a formatting object.

[Visual Basic]
Public Property FormatType As ValueFormatType[C#]
public ValueFormatType FormatType {get;set;}

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To configure the Percentage format for the Main Indicator:

[C#]
 radialGauge1.MainIndicator.Format.FormatType = ValueFormatType.Percentage;

get-gauge -MainIndicator_Format_FormatType Percentage

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members | Decimals Property | Culture Property | FormatCustom Property


FormatValue Method of ValueFormat class

ValueFormat.FormatValue Method

Format a value to a string.

[Visual Basic]
Public Function FormatValue( _
   ByVal value As Double _
) AS String[C#]
public String FormatValue(
   Double value
);

Parameters

Parameter | Type | Meaning
value | Double | The value to format.

Remarks

  • The value will format based on the selected FormatType.

Example

Format a value.

[C#]
 string newValue = radialGauge1.MainIndicator.Format.FormatValue(20);

[Visual Basic]
 Dim newValue As String
newValue = RadialGauge1.MainIndicator.Format.FormatValue(20)

See Also

ValueFormat Class | ValueFormat Members


VectorImage class

Represents a Vector Image attached to a gauge.

For a list of all members of this type, see VectorImage Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.Primitives.BaseImage
ChartFX.WinForms.Gauge.VectorImage

Remarks

This class only accepts .SVG files.


VectorImage Class Members

VectorImage Members

VectorImage Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Content | Get or set the data content of the vector image.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property PhysicalHeight (inherited from BaseImage) | Retrieve the height (in pixels) of the image file.
public property PhysicalSize | Returns the Size object representing the orginal image file.
public property PhysicalWidth (inherited from BaseImage) | Retrieve the width (in pixels) of the image file.
public property Size (inherited from BaseImage) | A numeric size modifier applied in conjunction with a Custom SizeMode setting.
public property SizeMode (inherited from BaseImage) | Defines the display size options for the background image.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Content Property of VectorImage class

VectorImage.Content Property

Get or set the data content of the vector image.

[Visual Basic]
Public Property Content As Byte[][C#]
public Byte[] Content {get;set;}

Remarks

  • Data is represented as a byte array.

Applies to

VectorImage

See Also

VectorImage Class | VectorImage Members


PhysicalSize Property of VectorImage class

VectorImage.PhysicalSize Property

Returns the Size object representing the orginal image file.

[Visual Basic]
Public ReadOnly Property PhysicalSize As Size[C#]
public Size PhysicalSize {get;}

Applies to

VectorImage

See Also

VectorImage Class | VectorImage Members


VerticalGauge class

Provides access to the VerticalGauge object.

For a list of all members of this type, see VerticalGauge Members

ChartFX.WinForms.Gauge.BaseGauge
ChartFX.WinForms.Gauge.Gauge
ChartFX.WinForms.Gauge.LinearGauge
ChartFX.WinForms.Gauge.VerticalGauge

Remarks

A LinearGauge includes scales that may be configured in a vertical or horizontal position. Supported members of the LinearGauge class allow developers to configure a border, scale orientation, flip the gradient color scheme and access to the scale and indicator objects. Below is an example of a LinearGauge.


VerticalGauge Class Members

VerticalGauge Members

VerticalGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border (inherited from LinearGauge) | Returns the LinearBorder object for a linear gauge.
public property Culture (inherited from BaseGauge) | Allows you to localize gauges for a specific language and region.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Allows you to accesss the images for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.
public property MainScale (inherited from LinearGauge) | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales (inherited from LinearGauge) | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property ToolTip (inherited from BaseGauge) | Gets or sets the tool tip text.
public property ToolTipEnabled (inherited from BaseGauge) | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Public Methods

public method Clone (inherited from BaseGauge) | Creates a new object that is a copy of the current instance.
public method Export (inherited from BaseGauge) | Allows you to export the gauge to a data file or stream.
public method HitTest (inherited from BaseGauge) | Returns a HitZoneTargetStack indicating the gauge element located at a specific point (coordinate).
public method Import (inherited from BaseGauge) | Allows you to import the gauge from a data file or stream.

Public Event

public event DraggingStarted (inherited from Gauge) | The source of the event.
public event DraggingStopped (inherited from Gauge) | The source of the event.
public event GetTip (inherited from BaseGauge) | The source of the event.
public event MainValueChanged (inherited from Gauge) | Fires after the MainValue has changed.
public event PostPaint (inherited from BaseGauge) | The source of the event.
public event PrePaint (inherited from BaseGauge) | The source of the event.
public event RangeEntered (inherited from Gauge) | The source of the event.
public event RangeLeft (inherited from Gauge) | The source of the event.
public event ValueChanged (inherited from Gauge) | The source of the event.


CalculatedInitialValue class

Provides access to the CalculatedInitialValue object.

For a list of all members of this type, see CalculatedInitialValue Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedInitialValue

Remarks

A CalculatedInitialValue is used in the constructor of a CalculatedValueAverage object.


CalculatedInitialValue Class Members

CalculatedInitialValue Members

CalculatedInitialValue Overview

Public Properties

public property CurrentValue (inherited from CalculatedValue) | Get the current calculated value
public property InitialValue | Get the initial value of the sample.
public property SourceValue (inherited from CalculatedValue) | Gets the value from which the Calculated Value was found.


CurrentValue Property of CalculatedValue class

CalculatedValue.CurrentValue Property

Get the current calculated value

[Visual Basic]
Public ReadOnly Property CurrentValue As Double[C#]
public Double CurrentValue {get;}

Remarks

  • Depending on the type of CalculatedValue used, the CurrentValue can reflect a source Indicator's average, min, max, or actual value.

Applies to

CalculatedValue

See Also

CalculatedValue Class | CalculatedValue Members


InitialValue Property of CalculatedInitialValue class

CalculatedInitialValue.InitialValue Property

Get the initial value of the sample.

[Visual Basic]
Public ReadOnly Property InitialValue As Double[C#]
public Double InitialValue {get;}

Remarks

  • This value is set once in the object constructor and is then read-only.

Applies to

CalculatedInitialValue

See Also

CalculatedInitialValue Class | CalculatedInitialValue Members


SourceValue Property of CalculatedValue class

CalculatedValue.SourceValue Property

Gets the value from which the Calculated Value was found.

[Visual Basic]
Public ReadOnly Property SourceValue As IIndicator[C#]
public IIndicator SourceValue {get;}

Remarks

  • This value represents the original, unmodified value.

Applies to

CalculatedValue

See Also

CalculatedValue Class | CalculatedValue Members


CalculatedValue class

A calculated indicator value.

For a list of all members of this type, see CalculatedValue Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue

Remarks

Calculated values can be used to display the calculated average of another indicator's values.


CalculatedValue Class Members

CalculatedValue Members

CalculatedValue Overview

Public Properties

public property CurrentValue | Get the current calculated value
public property SourceValue | Gets the value from which the Calculated Value was found.


CalculatedValueAverage class

Provides access to the CalculatedValueAverage object.

For a list of all members of this type, see CalculatedValueAverage Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedInitialValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValueAverage

Remarks

Every time the source indicator value is changed the new value is added to the sample and a new average is calculated.


CalculatedValueAverage Class Members

CalculatedValueAverage Members

CalculatedValueAverage Overview

Public Properties

public property CurrentSampleSize | Get the current number of values in the sample.
public property CurrentValue (inherited from CalculatedValue) | Get the current calculated value
public property InitialSampleSize | Get the size of the initial sample.
public property InitialValue (inherited from CalculatedInitialValue) | Get the initial value of the sample.
public property SourceValue (inherited from CalculatedValue) | Gets the value from which the Calculated Value was found.


CurrentSampleSize Property of CalculatedValueAverage class

CalculatedValueAverage.CurrentSampleSize Property

Get the current number of values in the sample.

[Visual Basic]
Public ReadOnly Property CurrentSampleSize As Int32[C#]
public Int32 CurrentSampleSize {get;}

Remarks

  • Every time the souce Indicator value changes the new value is added to the sample.

Applies to

CalculatedValueAverage

See Also

CalculatedValueAverage Class | CalculatedValueAverage Members | Indicator Class


InitialSampleSize Property of CalculatedValueAverage class

CalculatedValueAverage.InitialSampleSize Property

Get the size of the initial sample.

[Visual Basic]
Public ReadOnly Property InitialSampleSize As Int32[C#]
public Int32 InitialSampleSize {get;}

Remarks

  • This value is set once in the object constructor and is then read-only.

Applies to

CalculatedValueAverage

See Also

CalculatedValueAverage Class | CalculatedValueAverage Members


CalculatedValueLink class

Provides access to the CalculatedValueLink object.

For a list of all members of this type, see CalculatedValueLink Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValueLink

Remarks

A CalculatedValueLink, when assigned a source indicator, will return the value of the source indicator.


CalculatedValueLink Class Members

CalculatedValueLink Members

CalculatedValueLink Overview

Public Properties

public property CurrentValue (inherited from CalculatedValue) | Get the current calculated value
public property SourceValue (inherited from CalculatedValue) | Gets the value from which the Calculated Value was found.


CalculatedValueMax class

Provides access to the CalculatedValueMax object.

For a list of all members of this type, see CalculatedValueMax Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedInitialValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValueMax

Remarks

This object will only report the Max value of the source indicator as the source indicator changes.


CalculatedValueMax Class Members

CalculatedValueMax Members

CalculatedValueMax Overview

Public Properties

public property CurrentValue (inherited from CalculatedValue) | Get the current calculated value
public property InitialValue (inherited from CalculatedInitialValue) | Get the initial value of the sample.
public property SourceValue (inherited from CalculatedValue) | Gets the value from which the Calculated Value was found.


CalculatedValueMin class

Provides access to the CalculatedValueMin object.

For a list of all members of this type, see CalculatedValueMin Members

ChartFX.WinForms.Gauge.Value
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedInitialValue
ChartFX.WinForms.Gauge.CalculatedValues.CalculatedValueMin

Remarks

This object will only report the Min value of the source indicator as the source indicator changes.


CalculatedValueMin Class Members

CalculatedValueMin Members

CalculatedValueMin Overview

Public Properties

public property CurrentValue (inherited from CalculatedValue) | Get the current calculated value
public property InitialValue (inherited from CalculatedInitialValue) | Get the initial value of the sample.
public property SourceValue (inherited from CalculatedValue) | Gets the value from which the Calculated Value was found.


CenteredMetaDataNonComposite class

Exposes meta data of centered non composite image.

For a list of all members of this type, see CenteredMetaDataNonComposite Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.CenteredMetaDataNonComposite

Remarks

Description goes here


CenteredMetaDataNonComposite Class Members

CenteredMetaDataNonComposite Members

CenteredMetaDataNonComposite Overview

Public Properties

public property Center | Get or set the center point.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter | Get or set the Y-value of the center.


Center Property of CenteredMetaDataNonComposite class

CenteredMetaDataNonComposite.Center Property

Get or set the center point.

[Visual Basic]
Public Property Center As PointF[C#]
public PointF Center {get;set;}

Applies to

CenteredMetaDataNonComposite

See Also

CenteredMetaDataNonComposite Class | CenteredMetaDataNonComposite Members


Target Property of MetaData class

MetaData.Target Property

Get or set the style target of the metadata.

[Visual Basic]
Public Property Target As MetaDataTarget[C#]
public MetaDataTarget Target {get;set;}

Value | Meaning
VerticalGauge | Indicates a VerticalGauge can use the metadata.
HorizontalGauge | Indicates a HorizontalGauge can use the metadata.
DigitalPanel | Indicates a DigitalPanel can use the metadata.
RadialGauge | Indicates a RadialGauge can use the metadata.
All | Indicates all gauges can use the metadata.

Applies to

MetaData

See Also

MetaData Class | MetaData Members


YCenter Property of CenteredMetaDataNonComposite class

CenteredMetaDataNonComposite.YCenter Property

Get or set the Y-value of the center.

[Visual Basic]
Public Property YCenter As Single[C#]
public Single YCenter {get;set;}

Applies to

CenteredMetaDataNonComposite

See Also

CenteredMetaDataNonComposite Class | CenteredMetaDataNonComposite Members


DigitalMapping class

Provides customization options for the digit style of the DigitalPanel

For a list of all members of this type, see DigitalMapping Members

ChartFX.WebForms.Gauge.Customization.DigitalMapping

Remarks

This class is used in conjunction with the ResourceLibrary event, DigitalMappingResolve, to handle customization of the DigtalPanel digits.


DigitalMapping Class Members

DigitalMapping Members

DigitalMapping Overview

Public Properties

public property Count | Gets the number of elements actually contained in the collection.
public property DefinitionLength | Gets the length of the DigitalMappingType.
public property Item | Gets or sets the element at the specified index.

Public Methods

public method Clear | Clear the DigitalMapping collection.
public method Clone | Creates a new object that is a copy of the current instance.


Count Property of DigitalMapping class

DigitalMapping.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
Public ReadOnly Property Count As Int32[C#]
public Int32 Count {get;}

Applies to

DigitalMapping

See Also

DigitalMapping Class | DigitalMapping Members


DefinitionLength Property of DigitalMapping class

DigitalMapping.DefinitionLength Property

Gets the length of the DigitalMappingType.

[Visual Basic]
Public ReadOnly Property DefinitionLength As Int32[C#]
public Int32 DefinitionLength {get;}

Remarks

  • The SevenSegment DigitalMappingType would return a value of (7) for the DefinitionLength.

Applies to

DigitalMapping

See Also

DigitalMapping Class | DigitalMapping Members


Item Property of DigitalMapping class

DigitalMapping.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Property Item As Boolean[][C#]
public Boolean[] Item {get;set;}

Parameters

Parameter | Type | Meaning
c | Char | The character for which DigitalMapping information is retrieved or set.

Remarks

  • This property gets or set a boolean array indicating the on/off status of the DigitMappingType pieces representing the specified character.

  • DigitalMapping allows the developer to create digit mapping for characters not included in the default set of mapped characters or modify existing members.

Applies to

DigitalMapping

See Also

DigitalMapping Class | DigitalMapping Members


Clear Method of DigitalMapping class

DigitalMapping.Clear Method

Clear the DigitalMapping collection.

[Visual Basic]
Public Sub Clear[C#]
public Void Clear();

Remarks

  • Count is set to 0, and references to other objects from elements of the collection are also released.

See Also

DigitalMapping Class | DigitalMapping Members


Clone Method of DigitalMapping class

DigitalMapping.Clone Method

Creates a new object that is a copy of the current instance.

[Visual Basic]
Public Function Clone AS Object[C#]
public Object Clone();

Remarks

  • Clone can be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references. The resulting clone must be of the same type as or a compatible type to the original instance.

See Also

DigitalMapping Class | DigitalMapping Members


MetaData class

A basic metadata object used to hold target information.

For a list of all members of this type, see MetaData Members

ChartFX.WebForms.Gauge.Customization.MetaData

Remarks

This class is not directly instantiated. Other MetaData classes use this class to represent target.


MetaData Class Members

MetaData Members

MetaData Overview

Public Properties

public property Target Get or set the style target of the metadata.


MetaDataComposite class

Represents metadata of composite objects.

For a list of all members of this type, see MetaDataComposite Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataComposite

Remarks

A gauge filler is an example of a composite-style image, also the linear border.


MetaDataComposite Class Members

MetaDataComposite Members

MetaDataComposite Overview

Public Properties

public property Left | Gets the metadata for the left image.
public property Right | Gets the metadata for the right image.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.


Left Property of MetaDataComposite class

MetaDataComposite.Left Property

Gets the metadata for the left image.

[Visual Basic]
Public ReadOnly Property Left As MetaDataCompositeExtremity[C#]
public MetaDataCompositeExtremity Left {get;}

Remarks

  • Composite images are composed of (3) parts: left, center, and right.

Applies to

MetaDataComposite

See Also

MetaDataComposite Class | MetaDataComposite Members


Right Property of MetaDataComposite class

MetaDataComposite.Right Property

Gets the metadata for the right image.

[Visual Basic]
Public ReadOnly Property Right As MetaDataCompositeExtremity[C#]
public MetaDataCompositeExtremity Right {get;}

Remarks

  • Composite images are composed of (3) parts: left, center, and right.

Applies to

MetaDataComposite

See Also

MetaDataComposite Class | MetaDataComposite Members


MetaDataCompositeExtremity class

Represents the left or right piece of a composite.

For a list of all members of this type, see MetaDataCompositeExtremity Members

ChartFX.WebForms.Gauge.Customization.MetaDataCompositeExtremity

Remarks

A linear border and a gauge filler are examples of composites.


MetaDataCompositeExtremity Class Members

MetaDataCompositeExtremity Members

MetaDataCompositeExtremity Overview

Public Properties

public property IsEmpty | Indicates whether the object contains an image.
public property Ratio | Get or set the size scale of the image.

Public Methods

public method Dispose Flags a resource for garbage collection.


IsEmpty Property of MetaDataCompositeExtremity class

MetaDataCompositeExtremity.IsEmpty Property

Indicates whether the object contains an image.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean[C#]
public Boolean IsEmpty {get;}

Applies to

MetaDataCompositeExtremity

See Also

MetaDataCompositeExtremity Class | MetaDataCompositeExtremity Members


Ratio Property of MetaDataCompositeExtremity class

MetaDataCompositeExtremity.Ratio Property

Get or set the size scale of the image.

[Visual Basic]
Public Property Ratio As Single[C#]
public Single Ratio {get;set;}

Remarks

  • Values greater than 1 will increase your image display size.

Applies to

MetaDataCompositeExtremity

See Also

MetaDataCompositeExtremity Class | MetaDataCompositeExtremity Members


Dispose Method of MetaDataCompositeExtremity class

MetaDataCompositeExtremity.Dispose Method

Flags a resource for garbage collection.

[Visual Basic]
Public Sub Dispose[C#]
public Void Dispose();

See Also

MetaDataCompositeExtremity Class | MetaDataCompositeExtremity Members


MetaDataDecimalDot class

Exposes decimal dot meta data.

For a list of all members of this type, see MetaDataDecimalDot Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataDecimalDot

Remarks

A developer can customize the appear of the decimal dot used in a digital panel.


MetaDataDecimalDot Class Members

MetaDataDecimalDot Members

MetaDataDecimalDot Overview

Public Properties

public property Target (inherited from MetaData) Get or set the style target of the metadata.


MetaDataDigitalCharacter class

Exposes digital character metadata.

For a list of all members of this type, see MetaDataDigitalCharacter Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataDigitalCharacter

Remarks

A developer can customize the mapping of digital characters.

More specifically a developer can specify which segements of the digital character type to represent their character.


MetaDataDigitalCharacter Class Members

MetaDataDigitalCharacter Members

MetaDataDigitalCharacter Overview

Public Properties

public property Mapping | Gets the mapping type represented by the metadata.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.


Mapping Property of MetaDataDigitalCharacter class

MetaDataDigitalCharacter.Mapping Property

Gets the mapping type represented by the metadata.

[Visual Basic]
Public ReadOnly Property Mapping As DigitalMappingType[C#]
public DigitalMappingType Mapping {get;}

Value | Meaning
SevenSegments | Digits made from seven segements.
FourteenSegments | Digits made from fourteen segements.
Led | Digits made from Led's; 7 rows -- 5 columns

Remarks

  • Each mapping type stores mapping information in a different size array.

Applies to

MetaDataDigitalCharacter

See Also

MetaDataDigitalCharacter Class | MetaDataDigitalCharacter Members


MetaDataFiller class

Exposes metadata for the Filler object.

For a list of all members of this type, see MetaDataFiller Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataComposite
ChartFX.WebForms.Gauge.Customization.MetaDataFiller

Remarks

Horizontal and Vertical gauges contain Filler objects.


MetaDataFiller Class Members

MetaDataFiller Members

MetaDataFiller Overview

Public Properties

public property Coverage | Get or set the coverage of Filler composite image extremities.
public property Left (inherited from MetaDataComposite) | Gets the metadata for the left image.
public property Repeater | Gets the value indicating whether the style is a repeater.
public property Right (inherited from MetaDataComposite) | Gets the metadata for the right image.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.


Coverage Property of MetaDataFiller class

MetaDataFiller.Coverage Property

Get or set the coverage of Filler composite image extremities.

[Visual Basic]
Public Property Coverage As CompositeImageExtemityCoverage[C#]
public CompositeImageExtemityCoverage Coverage {get;set;}

Remarks

  • If you set this property to IncludeNone, then the left and right extremes of the filler will go beyond the scale bar.

Example

Set the coverage to only include the left.

[C#]
 if ((e.Style is ChartFX.WinForms.Gauge.FillerStyle))
{
MetaDataFiller myF = (MetaDataFiller)e.MetaData;
myF.Coverage = CompositeImageExtemityCoverage.IncludeLeft;
}

[Visual Basic]
 If TypeOf (e.Style Is ChartFX.WinForms.Gauge.FillerStyle) Then
Dim myF As MetaDataFiller = CType(e.MetaData, MetaDataFiller)
myF.Coverage = CompositeImageExtemityCoverage.IncludeLeft
End If

Applies to

MetaDataFiller

See Also

MetaDataFiller Class | MetaDataFiller Members


Repeater Property of MetaDataFiller class

MetaDataFiller.Repeater Property

Gets the value indicating whether the style is a repeater.

[Visual Basic]
Public ReadOnly Property Repeater As Boolean[C#]
public Boolean Repeater {get;}

Remarks

  • A Filler style can be composed of (3) images or (1) image repeated.

Applies to

MetaDataFiller

See Also

MetaDataFiller Class | MetaDataFiller Members


MetaDataLedCharacter class

Exposes the metadata of the Led characters for DigitalPanel.

For a list of all members of this type, see MetaDataLedCharacter Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataDigitalCharacter
ChartFX.WebForms.Gauge.Customization.MetaDataLedCharacter

Remarks

Configuring this metadata object can customize the appearance of Led character.


MetaDataLedCharacter Class Members

MetaDataLedCharacter Members

MetaDataLedCharacter Overview

Public Properties

public property Mapping (inherited from MetaDataDigitalCharacter) | Gets the mapping type represented by the metadata.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property Volume | Get or set the fill volume of the Led character


Volume Property of MetaDataLedCharacter class

MetaDataLedCharacter.Volume Property

Get or set the fill volume of the Led character

[Visual Basic]
Public Property Volume As Single[C#]
public Single Volume {get;set;}

Applies to

MetaDataLedCharacter

See Also

MetaDataLedCharacter Class | MetaDataLedCharacter Members


MetaDataLinearBorder class

Exposes metadata of the linear border style.

For a list of all members of this type, see MetaDataLinearBorder Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataComposite
ChartFX.WebForms.Gauge.Customization.MetaDataLinearBorder

Remarks

Only the Horizontal, Vertical, and DigitalPanel gauges use linear borders.


MetaDataLinearBorder Class Members

MetaDataLinearBorder Members

MetaDataLinearBorder Overview

Public Properties

public property Left (inherited from MetaDataComposite) | Gets the metadata for the left image.
public property MaxRatioBetweenThicknessAndLength | Get or set the ratio between thickness and length.
public property Right (inherited from MetaDataComposite) | Gets the metadata for the right image.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property UserClippingEdge | Get or set the clipping edge of linear border.


MaxRatioBetweenThicknessAndLength Property of MetaDataLinearBorder class

MetaDataLinearBorder.MaxRatioBetweenThicknessAndLength Property

Get or set the ratio between thickness and length.

[Visual Basic]
Public Property MaxRatioBetweenThicknessAndLength As Single[C#]
public Single MaxRatioBetweenThicknessAndLength {get;set;}

Remarks

  • Some ratios because thickness and length can cause graphic distortions; images should be tested before deployment.

Applies to

MetaDataLinearBorder

See Also

MetaDataLinearBorder Class | MetaDataLinearBorder Members


UserClippingEdge Property of MetaDataLinearBorder class

MetaDataLinearBorder.UserClippingEdge Property

Get or set the clipping edge of linear border.

[Visual Basic]
Public Property UserClippingEdge As SizeF[C#]
public SizeF UserClippingEdge {get;set;}

Remarks

  • This property directly affects the Scale display. The values should be kept below 1.0f in most cases.

Applies to

MetaDataLinearBorder

See Also

MetaDataLinearBorder Class | MetaDataLinearBorder Members


MetaDataMarker class

Exposes metadata of a marker object.

For a list of all members of this type, see MetaDataMarker Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataMarker

Remarks

This object most often represents tickmarks.


MetaDataMarker Class Members

MetaDataMarker Members

MetaDataMarker Overview

Public Properties

public property Center (inherited from CenteredMetaDataNonComposite) | Get or set the center point.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter (inherited from CenteredMetaDataNonComposite) | Get or set the Y-value of the center.


MetaDataNeedle class

Exposes metadata of a needle.

For a list of all members of this type, see MetaDataNeedle Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataNeedle

Remarks

Configuring this metadata allows a developer to customize built-in needles or create their own.


MetaDataNeedle Class Members

MetaDataNeedle Members

MetaDataNeedle Overview

Public Properties

public property Center (inherited from CenteredMetaDataNonComposite) | Get or set the center point.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter (inherited from CenteredMetaDataNonComposite) | Get or set the Y-value of the center.

Public Methods

public method AddDefaultHitZones | Adds the default hit zones to a needle.
public method AddHitZone | Add a custom hit zone to a needle.


AddDefaultHitZones Method of MetaDataNeedle class

MetaDataNeedle.AddDefaultHitZones Method

Adds the default hit zones to a needle.

[Visual Basic]
Public Sub AddDefaultHitZones( _
    _
)[C#]
public Void AddDefaultHitZones(

);

Parameters

Parameter Type Meaning

Remarks

  • Hit Zones affect how a gauge is moved during a dragging operation. A developer may configure a drag-left operation to move the needle to the right.

See Also

MetaDataNeedle Class | MetaDataNeedle Members


AddHitZone Method of MetaDataNeedle class

MetaDataNeedle.AddHitZone Method

Add a custom hit zone to a needle.

[Visual Basic]
Public Sub AddHitZone( _
   ByVal type As IndicatorSubHitTests, _
   ByVal path As GraphicsPath _
)[C#]
public Void AddHitZone(
   IndicatorSubHitTests type,
   GraphicsPath path
);

Parameters

Parameter | Type | Meaning
type | IndicatorSubHitTests | The type of hit test to add.
path | GraphicsPath | The graphics path used.

See Also

MetaDataNeedle Class | MetaDataNeedle Members


MetaDataNonComposite class

Exposes the metadata of a non-composite image.

For a list of all members of this type, see MetaDataNonComposite Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite

Remarks

A non-composite image refers to an image made from (1) part, not multiple parts.


MetaDataNonComposite Class Members

MetaDataNonComposite Members

MetaDataNonComposite Overview

Public Properties

public property Target (inherited from MetaData) Get or set the style target of the metadata.


MetaDataRadialBorder class

Exposes the metadata of a radial border.

For a list of all members of this type, see MetaDataRadialBorder Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.CenteredMetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataRadialBorder

Remarks

Only a radial gauge will expose this metadata.


MetaDataRadialBorder Class Members

MetaDataRadialBorder Members

MetaDataRadialBorder Overview

Public Properties

public property AllowableStartAngle | Get or set the radial scale start angle.
public property AllowableSweepAngle | Get or set the radial scale sweep angle.
public property Center (inherited from CenteredMetaDataNonComposite) | Get or set the center point.
public property IgnoreAllowableStartAndSweepAngle | Get or set the value indicating whether the "Allowable" properties are used.
public property MaxScaleRadius | Get or set the radius from radial cap to scale.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter (inherited from CenteredMetaDataNonComposite) | Get or set the Y-value of the center.

Public Methods

public method AdjustSymetricalAllowableAngles Adjusts both sweep and start angles for symmetry.


AllowableStartAngle Property of MetaDataRadialBorder class

MetaDataRadialBorder.AllowableStartAngle Property

Get or set the radial scale start angle.

[Visual Basic]
Public Property AllowableStartAngle As Single[C#]
public Single AllowableStartAngle {get;set;}

Applies to

MetaDataRadialBorder

See Also

MetaDataRadialBorder Class | MetaDataRadialBorder Members


AllowableSweepAngle Property of MetaDataRadialBorder class

MetaDataRadialBorder.AllowableSweepAngle Property

Get or set the radial scale sweep angle.

[Visual Basic]
Public Property AllowableSweepAngle As Single[C#]
public Single AllowableSweepAngle {get;set;}

Applies to

MetaDataRadialBorder

See Also

MetaDataRadialBorder Class | MetaDataRadialBorder Members


IgnoreAllowableStartAndSweepAngle Property of MetaDataRadialBorder class

MetaDataRadialBorder.IgnoreAllowableStartAndSweepAngle Property

Get or set the value indicating whether the "Allowable" properties are used.

[Visual Basic]
Public Property IgnoreAllowableStartAndSweepAngle As Boolean[C#]
public Boolean IgnoreAllowableStartAndSweepAngle {get;set;}

Remarks

  • As soon as the developer set a value for AllowableStartAngle or AllowableSweepAngle this variable is automatically set to false.

Applies to

MetaDataRadialBorder

See Also

MetaDataRadialBorder Class | MetaDataRadialBorder Members


MaxScaleRadius Property of MetaDataRadialBorder class

MetaDataRadialBorder.MaxScaleRadius Property

Get or set the radius from radial cap to scale.

[Visual Basic]
Public Property MaxScaleRadius As Single[C#]
public Single MaxScaleRadius {get;set;}

Remarks

  • Values less than 1 will shrink the scale. Most cases will not increase the scale past 1.0

Applies to

MetaDataRadialBorder

See Also

MetaDataRadialBorder Class | MetaDataRadialBorder Members


AdjustSymetricalAllowableAngles Method of MetaDataRadialBorder class

MetaDataRadialBorder.AdjustSymetricalAllowableAngles Method

Adjusts both sweep and start angles for symmetry.

[Visual Basic]
Public Sub AdjustSymetricalAllowableAngles( _
   ByVal allowableStartAngle As Single _
)[C#]
public Void AdjustSymetricalAllowableAngles(
   Single allowableStartAngle
);

Parameters

Parameter | Type | Meaning
allowableStartAngle | Single | The desired start angle.

Remarks

  • The method will automatically calculate and set a Sweep angle value that creates symmetry with the indicated start angle.

  • This method also sets IgnoreAllowableStartAndSweepAngle to false.

See Also

MetaDataRadialBorder Class | MetaDataRadialBorder Members


MetaDataRadialCap class

Exposes the metadata for a radial cap.

For a list of all members of this type, see MetaDataRadialCap Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataRadialCap

Remarks

Only a radial gauge will expose this metadata.


MetaDataRadialCap Class Members

MetaDataRadialCap Members

MetaDataRadialCap Overview

Public Properties

public property Center (inherited from CenteredMetaDataNonComposite) | Get or set the center point.
public property RotateWithNeedle | Get or set the value indicating whether the cap will rotate with the needle.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter (inherited from CenteredMetaDataNonComposite) | Get or set the Y-value of the center.


RotateWithNeedle Property of MetaDataRadialCap class

MetaDataRadialCap.RotateWithNeedle Property

Get or set the value indicating whether the cap will rotate with the needle.

[Visual Basic]
Public Property RotateWithNeedle As Boolean[C#]
public Boolean RotateWithNeedle {get;set;}

Applies to

MetaDataRadialCap

See Also

MetaDataRadialCap Class | MetaDataRadialCap Members


MetaDataRepeater class

Exposes the metadata of a repeater-style filler.

For a list of all members of this type, see MetaDataRepeater Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataRepeater

Remarks

Use this class as opposed to MetaDataFiller if you've selected a Repeater filler style.


MetaDataRepeater Class Members

MetaDataRepeater Members

MetaDataRepeater Overview

Public Properties

public property GapInPercentOfWidth | Get or set the gap between filler repeats.
public property Repeater | Get the value indicating whether filler is a repeater.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.


GapInPercentOfWidth Property of MetaDataRepeater class

MetaDataRepeater.GapInPercentOfWidth Property

Get or set the gap between filler repeats.

[Visual Basic]
Public Property GapInPercentOfWidth As Single[C#]
public Single GapInPercentOfWidth {get;set;}

Remarks

  • A value of 0 will eliminate space between repeats. As values increase so does the gap.

Applies to

MetaDataRepeater

See Also

MetaDataRepeater Class | MetaDataRepeater Members


Repeater Property of MetaDataRepeater class

MetaDataRepeater.Repeater Property

Get the value indicating whether filler is a repeater.

[Visual Basic]
Public ReadOnly Property Repeater As Boolean[C#]
public Boolean Repeater {get;}

Applies to

MetaDataRepeater

See Also

MetaDataRepeater Class | MetaDataRepeater Members


MetaDataSegmentCharacter class

Allows for configuration of the DigitalCharacterStyle.

For a list of all members of this type, see MetaDataSegmentCharacter Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataDigitalCharacter
ChartFX.WebForms.Gauge.Customization.MetaDataSegmentCharacter

Remarks

This metadata controls the decimal dot and thousand marker properties for Digital Panels.


MetaDataSegmentCharacter Class Members

MetaDataSegmentCharacter Members

MetaDataSegmentCharacter Overview

Public Properties

public property ColonDotVerticalOffset | Get or set the vertical offset (positioning) of the colon.
public property ColonDotVerticalSpace | Get or set the space between dots in a colon character.
public property DecimalDot | Get or set the decimal dot style.
public property DotSize | Get or set the digital panel's decimal dot size.
public property Mapping (inherited from MetaDataDigitalCharacter) | Gets the mapping type represented by the metadata.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property ThousandMarker | Get or set the style used for the thousand marker.


ColonDotVerticalOffset Property of MetaDataSegmentCharacter class

MetaDataSegmentCharacter.ColonDotVerticalOffset Property

Get or set the vertical offset (positioning) of the colon.

[Visual Basic]
Public Property ColonDotVerticalOffset As Single[C#]
public Single ColonDotVerticalOffset {get;set;}

Remarks

  • Negative values will lower the dots. Most cases would not go above or below 1.0 and -1.0

Applies to

MetaDataSegmentCharacter

See Also

MetaDataSegmentCharacter Class | MetaDataSegmentCharacter Members


ColonDotVerticalSpace Property of MetaDataSegmentCharacter class

MetaDataSegmentCharacter.ColonDotVerticalSpace Property

Get or set the space between dots in a colon character.

[Visual Basic]
Public Property ColonDotVerticalSpace As Single[C#]
public Single ColonDotVerticalSpace {get;set;}

Applies to

MetaDataSegmentCharacter

See Also

MetaDataSegmentCharacter Class | MetaDataSegmentCharacter Members


DecimalDot Property of MetaDataSegmentCharacter class

MetaDataSegmentCharacter.DecimalDot Property

Get or set the decimal dot style.

[Visual Basic]
Public Property DecimalDot As DecimalDotStyle[C#]
public DecimalDotStyle DecimalDot {get;set;}

Remarks

  • The DecimalDotStyle enumeration is used to set this property.

Example

Set DecimalDot.

[C#]
 void Current_BuiltInMetaDataResolve(object sender, BuiltInMetaDataResolveEventArgs e) {
if ((e.Style is DigitalCharacterStyle) && ((DigitalCharacterStyle)e.Style) == DigitalCharacterStyle.FourteenSegments01) {
MetaDataSegmentCharacter metaData = (MetaDataSegmentCharacter)e.MetaData;
metaData.DecimalDot = DecimalDotStyle.CircleItalic;
}
}

[Visual Basic]
 Private Sub Current_BuiltInMetaDataResolve(ByVal sender As Object, ByVal e As BuiltInMetaDataResolveEventArgs)
If TypeOf (e.Style Is DigitalCharacterStyle) &&((DigitalCharacterStyle)e.Style) = DigitalCharacterStyle.FourteenSegments01 Then
Dim metaData As MetaDataSegmentCharacter = CType(e.MetaData, MetaDataSegmentCharacter)
metaData.DecimalDot = DecimalDotStyle.CircleItalic
End If
End Sub

Applies to

MetaDataSegmentCharacter

See Also

MetaDataSegmentCharacter Class | MetaDataSegmentCharacter Members


DotSize Property of MetaDataSegmentCharacter class

MetaDataSegmentCharacter.DotSize Property

Get or set the digital panel's decimal dot size.

[Visual Basic]
Public Property DotSize As Single[C#]
public Single DotSize {get;set;}

Remarks

  • In most cases a size of 0.1 is the standard decimal point size. A value greater than 0.2 would be too big for most cases.

Applies to

MetaDataSegmentCharacter

See Also

MetaDataSegmentCharacter Class | MetaDataSegmentCharacter Members


ThousandMarker Property of MetaDataSegmentCharacter class

MetaDataSegmentCharacter.ThousandMarker Property

Get or set the style used for the thousand marker.

[Visual Basic]
Public Property ThousandMarker As ThousandMarkerStyle[C#]
public ThousandMarkerStyle ThousandMarker {get;set;}

Remarks

  • The ThousandMarkerStyle enumeration is used to set this property.

Example

Set the ThousandMarker.

[C#]
 void Current_BuiltInMetaDataResolve(object sender, BuiltInMetaDataResolveEventArgs e) {
if ((e.Style is DigitalCharacterStyle) && ((DigitalCharacterStyle)e.Style) == DigitalCharacterStyle.FourteenSegments01) {
MetaDataSegmentCharacter metaData = (MetaDataSegmentCharacter)e.MetaData;
metaData.ThousandMarker = ThousandMarkerStyle.Italic;
}
}

[Visual Basic]
 Private Sub Current_BuiltInMetaDataResolve(ByVal sender As Object, ByVal e As BuiltInMetaDataResolveEventArgs)
If TypeOf (e.Style Is DigitalCharacterStyle) &&((DigitalCharacterStyle)e.Style) = DigitalCharacterStyle.FourteenSegments01 Then
Dim metaData As MetaDataSegmentCharacter = CType(e.MetaData, MetaDataSegmentCharacter)
metaData.ThousandMarker = ThousandMarkerStyle.Italic
End If
End Sub

Applies to

MetaDataSegmentCharacter

See Also

MetaDataSegmentCharacter Class | MetaDataSegmentCharacter Members


MetaDataThousandMarker class

Represents the metadata of the thousand's marker.

For a list of all members of this type, see MetaDataThousandMarker Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataThousandMarker

Remarks

Allows a developer to customize the thousand's marker.


MetaDataThousandMarker Class Members

MetaDataThousandMarker Members

MetaDataThousandMarker Overview

Public Properties

public property Target (inherited from MetaData) Get or set the style target of the metadata.


MetaDataTickmark class

Represents the metadata of a tickmark.

For a list of all members of this type, see MetaDataTickmark Members

ChartFX.WebForms.Gauge.Customization.MetaData
ChartFX.WebForms.Gauge.Customization.MetaDataNonComposite
ChartFX.WebForms.Gauge.Customization.MetaDataTickmark

Remarks

Allows the developer to create custom tickmarks.


MetaDataTickmark Class Members

MetaDataTickmark Members

MetaDataTickmark Overview

Public Properties

public property Center (inherited from CenteredMetaDataNonComposite) | Get or set the center point.
public property Target (inherited from MetaData) | Get or set the style target of the metadata.
public property YCenter (inherited from CenteredMetaDataNonComposite) | Get or set the Y-value of the center.


ResourceLibrary class

A static class with a single instance in the AppDomain for all gauges on a form.

For a list of all members of this type, see ResourceLibrary Members

ChartFX.WebForms.Gauge.Customization.ResourceLibrary

Remarks

In an ASP.NET application a ResourceLibrary instance exists for each page containing a gauge.

The ResourceLibrary Resolve events are called once during intial gauge painting and again if a property change should trigger the event.


ResourceLibrary Class Members

ResourceLibrary Members

ResourceLibrary Overview

Public Properties

public property Current | Returns the current instance of the ResourceLibrary.
public property SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

Public Methods

public method Clear | Clears the entire Resource Library.
public method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting resources.

Public Event

public event BuiltInMetaDataResolve | Called for all gauges in an application to process BuiltIn styles.
public event ClearComplete | Fired when the Clear operation completes.
public event CustomMetaDataResolve | Called any time a Gauge style name is not built-in.
public event DigitalMappingLoad | Fires when a Digital Mapping is loaded.
public event DigitalMappingResolve | Called to process the DigitalPanel's character mapping.
public event MetaDataLoad | Fires when Meta Data is loaded.
public event PaletteLoad | Fires when a palette is loaded.
public event PaletteResolve | Called when the specified palette is not built-in.
public event VectorialImageLoad | Fires when a vector image is loaded.
public event VectorialImageResolve | Called in conjunction with CustomMetaDataResolve to load custom vector images.


Current Property of ResourceLibrary class

ResourceLibrary.Current Property

Returns the current instance of the ResourceLibrary.

[Visual Basic]
Public ReadOnly Property Current As ResourceLibrary[C#]
public ResourceLibrary Current {get;}

Applies to

ResourceLibrary

See Also

ResourceLibrary Class | ResourceLibrary Members


SyncRoot Property of ResourceLibrary class

ResourceLibrary.SyncRoot Property

Gets an object that can be used to synchronize access to the ICollection.

[Visual Basic]
Public ReadOnly Property SyncRoot As Object[C#]
public Object SyncRoot {get;}

Remarks

  • For more information regarding this property refer to the .NET Framework API regarding ICollection.Syncroot

Applies to

ResourceLibrary

See Also

ResourceLibrary Class | ResourceLibrary Members


Clear Method of ResourceLibrary class

ResourceLibrary.Clear Method

Clears the entire Resource Library.

[Visual Basic]
Public Sub Clear[C#]
public Void Clear();

Remarks

  • This method is mostly used during the debugging stage and has no real use during production. There is significant system resource use when the ResourceLibrary is resolved after a Clear.

Example

Clear the current ResourceLibrary instance.

[C#]
 ResourceLibrary.Current.Clear();

[Visual Basic]
 ResourceLibrary.Current.Clear()

See Also

ResourceLibrary Class | ResourceLibrary Members


Dispose Method of ResourceLibrary class

ResourceLibrary.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting resources.

[Visual Basic]
Public Sub Dispose[C#]
public Void Dispose();

Remarks

  • Use this method to close or release unmanaged resources such as files, streams, and handles held by an instance of the class that implements the IDisposable interface. This method is, by convention, used for all tasks associated with freeing resources held by an object, or preparing an object for reuse.

See Also

ResourceLibrary Class | ResourceLibrary Members


BuiltInMetaDataResolve Event of ResourceLibrary class

ResourceLibrary.BuiltInMetaDataResolve Event

Called for all gauges in an application to process BuiltIn styles.

[Visual Basic]
Public Event BuiltInMetaDataResolve As BuiltInMetaDataResolveHandler[C#]
public event BuiltInMetaDataResolveHandler BuiltInMetaDataResolve

Parameters

Parameter | Type | Meaning
sender | Object | The Source of the event.
e | BuiltInMetaDataResolveEventArgs | Contains event data.

Event Data

The event handler receives an argument of type BuiltInMetaDataResolveEventArgs containing data related to this event. The following BuiltInMetaDataResolveEventArgs property provides information specific to this event.

Property | Description
MetaData | Represents MetaDate for the currently processing style.
CallingTarget | Indicates the gauge(s) for which this resource is loaded.
Style | The style using this resource.

Remarks

  • Each Style property of a Gauge is processed by this event.

  • The ResourceLibrary ensures that a particular style-resource is only loaded once. For example, if Major Tickmark and Medium Tickmark use the same Tickmark.Style, the resource is only loaded once, but applied to both properties.

Example

Add BuiltInMetaDataResolve event handler.

[C#]
 ResourceLibrary.Current.BuiltInMetaDataResolve += new BuiltInMetaDataResolveHandler(Current_BuiltInMetaDataResolve);

[Visual Basic]
 ResourceLibrary.Current.BuiltInMetaDataResolve += New BuiltInMetaDataResolveHandler(Current_BuiltInMetaDataResolve)

See Also

ResourceLibrary Class | ResourceLibrary Members


ClearComplete Event of ResourceLibrary class

ResourceLibrary.ClearComplete Event

Fired when the Clear operation completes.

[Visual Basic]
Public Event ClearComplete As EventHandler[C#]
public event EventHandler ClearComplete

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

See Also

ResourceLibrary Class | ResourceLibrary Members


CustomMetaDataResolve Event of ResourceLibrary class

ResourceLibrary.CustomMetaDataResolve Event

Called any time a Gauge style name is not built-in.

[Visual Basic]
Public Event CustomMetaDataResolve As CustomInMetaDataResolveHandler[C#]
public event CustomInMetaDataResolveHandler CustomMetaDataResolve

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | CustomMetaDataResolveEventArgs | Contains event data.

Event Data

The event handler receives an argument of type CustomMetaDataResolveEventArgs containing data related to this event. The following CustomMetaDataResolveEventArgs property provides information specific to this event.

Property | Description
CallingTarget | Indicates the gauge(s) for which this resource is loaded.
MetaData | Represents MetaDate for the currently processing style.
MetaDataType | The Type of MetaData to create.
Style | The style affected by this MetaData.

Remarks

  • This events allows for total customization of the gauge styles. When you assign a custom name to a style the ResourceLibrary calls this event because it does style name is not built-in.

  • You use the MetaDataType EventArgs property to determine which gauge item is currently being customized. Then you specify your new MetaData item's name and subsequently the VectorialImageResolve event is called to load a Vector image.

Example

Process CustomMetaData using the MetaDataType variable.

[C#]
 void Current_CustomMetaDataResolve(object sender, CustomMetaDataResolveEventArgs e)
{
if (e.MetaDataType == typeof(MetaDataMarker)) {
MetaDataMarker marker = new MetaDataMarker("Tickmark01-1");// use resolved image
e.MetaData = marker;
} else if (e.MetaDataType == typeof(MetaDataNeedle)) {
MetaDataNeedle needle = new MetaDataNeedle("Marker06"); // use resolved image
needle.Image.YCenter = 50;
e.MetaData = needle;
} else if (e.MetaDataType == typeof(MetaDataRadialCap)) {
MetaDataRadialCap cap = new MetaDataRadialCap("MyCustomRadialCapImageName");//use custom image
e.MetaData = cap;
}
}

[Visual Basic]
 void Current_CustomMetaDataResolve(Object sender, CustomMetaDataResolveEventArgs e) {
If e.MetaDataType = Type.GetType(MetaDataMarker) Then
Dim marker As MetaDataMarker = New MetaDataMarker("Tickmark01-1") ' use resolved image
e.MetaData = marker
Else If e.MetaDataType = Type.GetType(MetaDataNeedle) Then
Dim needle As MetaDataNeedle = New MetaDataNeedle("Marker06") ' use resolved image
needle.Image.YCenter = 50
e.MetaData = needle
Else If e.MetaDataType = Type.GetType(MetaDataRadialCap) Then
Dim cap As MetaDataRadialCap = New MetaDataRadialCap("MyCustomRadialCapImageName") 'use custom image
e.MetaData = cap
End If
}

See Also

ResourceLibrary Class | ResourceLibrary Members


DigitalMappingLoad Event of ResourceLibrary class

ResourceLibrary.DigitalMappingLoad Event

Fires when a Digital Mapping is loaded.

[Visual Basic]
Public Event DigitalMappingLoad As EventHandler[C#]
public event EventHandler DigitalMappingLoad

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | EventArgs | Contains event data.

Event Data

EventArgs

See Also

ResourceLibrary Class | ResourceLibrary Members


DigitalMappingResolve Event of ResourceLibrary class

ResourceLibrary.DigitalMappingResolve Event

Called to process the DigitalPanel's character mapping.

[Visual Basic]
Public Event DigitalMappingResolve As DigitalMappingResolveHandler[C#]
public event DigitalMappingResolveHandler DigitalMappingResolve

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | DigitalMappingResolveEventArgs | Contains event data.

Event Data

The event handler receives an argument of type DigitalMappingResolveEventArgs containing data related to this event. The following DigitalMappingResolveEventArgs property provides information specific to this event.

Property | Description
DigitalMapping | Represents the digital mapping array of all digits of the current DigitalMappingType.
Type | The type based on the DigitalCharacterStyle.
LoadDigitalMappingFromDefault LoadDigitalMappingFromStream

Remarks

  • The DigitalPanel allows for (3) DigitalMappingTypes: FourteenSegments, SevenSegments, and Led. These mapping types are composed of segements totaling 14, 7, and 35 respectively.

  • Mappings are formed from Boolean arrays with size of 14, 7, and 35. Segments are turned on or off using True or False values.

  • Common characters are already mapped for the MappingTypes. A developer may modify the existing mappings or create new character mappings.

Example

Create a custom mapping and add it to the DigitalMapping array.

[C#]
 void Current_DigitalMappingResolve(object sender, DigitalMappingResolveEventArgs e) {
bool[] mapping = new bool[e.DigitalMapping.DefinitionLength];
for (int i = 1; i <= e.DigitalMapping.DefinitionLength; ++i) {
for (int j = 1; j <= e.DigitalMapping.DefinitionLength; ++j) {
mapping[j - 1] = true;//(i == j);
}
e.DigitalMapping[(char)i] = mapping;
}
}

[Visual Basic]
 Private Sub Current_DigitalMappingResolve(ByVal sender As Object, ByVal e As DigitalMappingResolveEventArgs)
Dim mapping() As Boolean = New Boolean(e.DigitalMapping.DefinitionLength) {}
Dim i As Integer
For i = 1 To e.DigitalMapping.DefinitionLength Step + 1
Dim j As Integer
For j = 1 To e.DigitalMapping.DefinitionLength Step + 1
mapping(j - 1) = True'(i == j);
Next
e.DigitalMapping(CType(i) = mapping, Char)
Next
End Sub

See Also

ResourceLibrary Class | ResourceLibrary Members


MetaDataLoad Event of ResourceLibrary class

ResourceLibrary.MetaDataLoad Event

Fires when Meta Data is loaded.

[Visual Basic]
Public Event MetaDataLoad As MetaDataLoadHandler[C#]
public event MetaDataLoadHandler MetaDataLoad

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | MetaDataLoadEventArgs | Contains event data.

Event Data

The event handler receives an argument of type MetaDataLoadEventArgs containing data related to this event. The following MetaDataLoadEventArgs property provides information specific to this event.

Property | Description
ClonedMetaData | Represents MetaDate for the currently processing style.
Style | The style affected by this MetaData.

Remarks

  • The eventargs indicates which meta data was loaded.

See Also

ResourceLibrary Class | ResourceLibrary Members


PaletteLoad Event of ResourceLibrary class

ResourceLibrary.PaletteLoad Event

Fires when a palette is loaded.

[Visual Basic]
Public Event PaletteLoad As PaletteLoadHandler[C#]
public event PaletteLoadHandler PaletteLoad

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | PaletteLoadEventArgs | Contains event data.

Event Data

The event handler receives an argument of type PaletteLoadEventArgs containing data related to this event. The following PaletteLoadEventArgs property provides information specific to this event.

Property | Description
Palette | The palette to be loaded.

Remarks

  • The eventargs indicates which palette was loaded.

See Also

ResourceLibrary Class | ResourceLibrary Members


PaletteResolve Event of ResourceLibrary class

ResourceLibrary.PaletteResolve Event

Called when the specified palette is not built-in.

[Visual Basic]
Public Event PaletteResolve As PaletteResolveHandler[C#]
public event PaletteResolveHandler PaletteResolve

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | PaletteResolveEventArgs | Contains event data.

Event Data

The event handler receives an argument of type PaletteResolveEventArgs containing data related to this event. The following PaletteResolveEventArgs property provides information specific to this event.

Property | Description
Palette | The currently resolving palette.
LoadPaletteFromDefault LoadPaletteFromStream

Remarks

  • This event allows you to begin processing your custom palette.

  • The PaletteLoad event is called after this event.

Example

Load a custom palette.

[C#]
 void Current_PaletteResolve(object sender, PaletteResolveEventArgs e) {
if (e.Palette.Name == "MyCustomPalette") {
using (MemoryStream colorStream = new MemoryStream(PaletteCustomization.Properties.Resources.Custom)) {
using (MemoryStream mappingStream = new MemoryStream(PaletteCustomization.Properties.Resources.Custom_Mapping)) {
e.LoadPaletteFromStream(colorStream, mappingStream);
}
}
}
}

[Visual Basic]
 Private Sub Current_PaletteResolve(ByVal sender As Object, ByVal e As PaletteResolveEventArgs)
If e.Palette.Name = "MyCustomPalette" Then
Imports (MemoryStream colorStream = New MemoryStream(PaletteCustomization.Properties.Resources.Custom)) {
Imports (MemoryStream mappingStream = New MemoryStream(PaletteCustomization.Properties.Resources.Custom_Mapping)) {
e.LoadPaletteFromStream(colorStream, mappingStream)
}
}
End If
End Sub

See Also

ResourceLibrary Class | ResourceLibrary Members


VectorialImageLoad Event of ResourceLibrary class

ResourceLibrary.VectorialImageLoad Event

Fires when a vector image is loaded.

[Visual Basic]
Public Event VectorialImageLoad As VectorialImageLoadHandler[C#]
public event VectorialImageLoadHandler VectorialImageLoad

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | VectorialImageLoadEventArgs | Contains event data.

Event Data

The event handler receives an argument of type VectorialImageLoadEventArgs containing data related to this event. The following VectorialImageLoadEventArgs property provides information specific to this event.

Property | Description
Name | The given name of the image to be loaded.

Remarks

  • The eventargs indicates which meta data was loaded.

See Also

ResourceLibrary Class | ResourceLibrary Members


VectorialImageResolve Event of ResourceLibrary class

ResourceLibrary.VectorialImageResolve Event

Called in conjunction with CustomMetaDataResolve to load custom vector images.

[Visual Basic]
Public Event VectorialImageResolve As VectorialImageResolveHandler[C#]
public event VectorialImageResolveHandler VectorialImageResolve

Parameters

Parameter | Type | Meaning
sender | Object | The source of the event.
e | VectorialImageResolveEventArgs | Contains event data.

Event Data

The event handler receives an argument of type VectorialImageResolveEventArgs containing data related to this event. The following VectorialImageResolveEventArgs property provides information specific to this event.

Property | Description
Name | The custom name to reference the vector image.

Remarks

  • You must load your image into a stream variable, then use the VectorialImageResolveEventArgs method LoadImageFromStream.

Example

Load a custom image from stream.

[C#]
 void Current_VectorialImageResolve(object sender, VectorialImageResolveEventArgs e) {
if (e.Name == "MyCustomRadialCapImageName") {
using (MemoryStream s = new MemoryStream(BuiltInStyles.Properties.Resources.Cap06)) {
e.LoadImageFromStream(s);
}
}
}

[Visual Basic]
 Private Sub Current_VectorialImageResolve(ByVal sender As Object, ByVal e As VectorialImageResolveEventArgs)
If e.Name = "MyCustomRadialCapImageName" Then
Imports (MemoryStream s = New MemoryStream(BuiltInStyles.Properties.Resources.Cap06)) {
e.LoadImageFromStream(s)
End If
}
End Sub

See Also

ResourceLibrary Class | ResourceLibrary Members


BaseHitTestTarget class

Provides access to the HitTestTarget object.

For a list of all members of this type, see BaseHitTestTarget Members

Remarks

This class is not directly instantiated by developers. Instead use one of the derived classes.


BaseHitTestTarget Class Members

BaseHitTestTarget Members

BaseHitTestTarget Overview

Public Properties

public property ToolTip Gets or sets the tool tip displayed by the target.


ToolTip Property of BaseHitTestTarget class

BaseHitTestTarget.ToolTip Property

Gets or sets the tool tip displayed by the target.

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

Applies to

BaseHitTestTarget

See Also

BaseHitTestTarget Class | BaseHitTestTarget Members


BaseValueHitZoneTarget class

Provides access to the BaseValueHitZoneTarget object.

For a list of all members of this type, see BaseValueHitZoneTarget Members

ChartFX.WinForms.Gauge.HitDetection.BaseValueHitZoneTarget

Remarks

This class provides a generic HitZoneTarget type for use when analyzing the results of a HitTestTargetStack.


BaseValueHitZoneTarget Class Members

BaseValueHitZoneTarget Members

BaseValueHitZoneTarget Overview

Public Properties

public property ToolTip (inherited from BaseHitTestTarget) | Gets or sets the tool tip displayed by the target.
public property Value | Gets the value of the HitZoneTarget.


Value Property of BaseValueHitZoneTarget class

BaseValueHitZoneTarget.Value Property

Gets the value of the HitZoneTarget.

[Visual Basic]
Public ReadOnly Property Value As Double[C#]
public Double Value {get;}

Remarks

  • This is a read-only property.

Applies to

BaseValueHitZoneTarget

See Also

BaseValueHitZoneTarget Class | BaseValueHitZoneTarget Members


BorderHitTestTarget class

Provides access to the BorderHitTestTarget object.

For a list of all members of this type, see BorderHitTestTarget Members

ChartFX.WinForms.Gauge.HitDetection.BorderHitTestTarget

Remarks

This class allows the developer to configure a ToolTip for a border object.


BorderHitTestTarget Class Members

BorderHitTestTarget Members

BorderHitTestTarget Overview

Public Properties

public property ToolTip (inherited from BaseHitTestTarget) | Gets or sets the tool tip displayed by the target.
public property Zone | Gets the target's BorderZone type.


Zone Property of BorderHitTestTarget class

BorderHitTestTarget.Zone Property

Gets the target's BorderZone type.

[Visual Basic]
Public ReadOnly Property Zone As BorderZone[C#]
public BorderZone Zone {get;}

Value | Meaning
InsideBorder | The Inside Border of a gauge.
OutsideBorder | The Outside Border of a gauge.
Glare | The Glare of a gauge.

Remarks

  • A zone can be either InsideBorder, OutsideBorder, or Glare.

Applies to

BorderHitTestTarget

See Also

BorderHitTestTarget Class | BorderHitTestTarget Members


HitTestTargetStack class

The Gauge objects currently under the mouse at the time of the HitTest.

For a list of all members of this type, see HitTestTargetStack Members

ChartFX.WinForms.Gauge.HitDetection.HitTestTargetStack

Remarks

Objects are loaded onto the stack based on their Z-coordinate drawing position. Backmost items are on the bottom of the stack, frontmost items are on the top of the stack.


HitTestTargetStack Class Members

HitTestTargetStack Members

HitTestTargetStack Overview

Public Properties

public property TopMostNoneEmptyTarget Returns a reference to the TopMost object under the mouse.

Public Methods

public method Clone | Creates a shallow copy of the Stack.
public method Contains | Determines whether an element is in the Stack.
public method Peek | Returns the object at the top of the Stack without removing it.
public method Pop | Removes and returns the object at the top of the Stack.
public method Push | Inserts an object at the top of the Stack.


TopMostNoneEmptyTarget Property of HitTestTargetStack class

HitTestTargetStack.TopMostNoneEmptyTarget Property

Returns a reference to the TopMost object under the mouse.

[Visual Basic]
Public ReadOnly Property TopMostNoneEmptyTarget As IHitTestTarget[C#]
public IHitTestTarget TopMostNoneEmptyTarget {get;}

Remarks

  • 'NoneEmptyTarget' means that, for example, a gauge with 3 indicators all at different values will all be on the stack, but only the indicator(s) (and other gauge objects) directly under the mouse will be returned.

Applies to

HitTestTargetStack

See Also

HitTestTargetStack Class | HitTestTargetStack Members


Clone Method of HitTestTargetStack class

HitTestTargetStack.Clone Method

Creates a shallow copy of the Stack.

[Visual Basic]
Public Function Clone AS Object[C#]
public Object Clone();

Remarks

  • For more information regarding stacks refer to .NET Framework documentation.

See Also

HitTestTargetStack Class | HitTestTargetStack Members


Contains Method of HitTestTargetStack class

HitTestTargetStack.Contains Method

Determines whether an element is in the Stack.

[Visual Basic]
Public Function Contains( _
   ByVal target As IHitTestTarget _
) AS Boolean[C#]
public Boolean Contains(
   IHitTestTarget target
);

Parameters

Parameter | Type | Meaning
target | IHitTestTarget | The object to locate on the stack.

Remarks

  • For more information regarding stacks refer to .NET Framework documentation.

See Also

HitTestTargetStack Class | HitTestTargetStack Members


Peek Method of HitTestTargetStack class

HitTestTargetStack.Peek Method

Returns the object at the top of the Stack without removing it.

[Visual Basic]
Public Function Peek AS IHitTestTarget[C#]
public IHitTestTarget Peek();

Remarks

  • For more information regarding stacks refer to .NET Framework documentation.

See Also

HitTestTargetStack Class | HitTestTargetStack Members


Pop Method of HitTestTargetStack class

HitTestTargetStack.Pop Method

Removes and returns the object at the top of the Stack.

[Visual Basic]
Public Function Pop AS IHitTestTarget[C#]
public IHitTestTarget Pop();

Remarks

  • For more information regarding stacks refer to .NET Framework documentation.

See Also

HitTestTargetStack Class | HitTestTargetStack Members


Push Method of HitTestTargetStack class

HitTestTargetStack.Push Method

Inserts an object at the top of the Stack.

[Visual Basic]
Public Sub Push( _
   ByVal target As IHitTestTarget _
)[C#]
public Void Push(
   IHitTestTarget target
);

Parameters

Parameter | Type | Meaning
target | IHitTestTarget | The object to insert at the top of the Stack.

See Also

HitTestTargetStack Class | HitTestTargetStack Members


LabelHitZoneTarget class

Provides access to the LabelHitZoneTarget object.

For a list of all members of this type, see LabelHitZoneTarget Members

ChartFX.WinForms.Gauge.HitDetection.BaseValueHitZoneTarget
ChartFX.WinForms.Gauge.HitDetection.LabelHitZoneTarget

Remarks

This class can modify the Label properties for the target LabeledObject.


LabelHitZoneTarget Class Members

LabelHitZoneTarget Members

LabelHitZoneTarget Overview

Public Properties

public property DisplayedText | Gets the text displayed by the target label.
public property Label | Gets the LabelAttributes object for the gauge.
public property LabeledObject | Gets the targeted LabelZone object type.
public property ToolTip (inherited from BaseHitTestTarget) | Gets or sets the tool tip displayed by the target.
public property Value (inherited from BaseValueHitZoneTarget) | Gets the value of the HitZoneTarget.


DisplayedText Property of LabelHitZoneTarget class

LabelHitZoneTarget.DisplayedText Property

Gets the text displayed by the target label.

[Visual Basic]
Public ReadOnly Property DisplayedText As String[C#]
public String DisplayedText {get;}

Remarks

  • This is a read-only property.

Applies to

LabelHitZoneTarget

See Also

LabelHitZoneTarget Class | LabelHitZoneTarget Members


Label Property of LabelHitZoneTarget class

LabelHitZoneTarget.Label Property

Gets the LabelAttributes object for the gauge.

[Visual Basic]
Public ReadOnly Property Label As LabelAttributes[C#]
public LabelAttributes Label {get;}

Remarks

  • The LabelAttributes will modify all labels of the particular group (i.e. Major tickmark labels, Minor tickmark label, etc.).

Applies to

LabelHitZoneTarget

See Also

LabelHitZoneTarget Class | LabelHitZoneTarget Members


LabeledObject Property of LabelHitZoneTarget class

LabelHitZoneTarget.LabeledObject Property

Gets the targeted LabelZone object type.

[Visual Basic]
Public ReadOnly Property LabeledObject As IHasLabel[C#]
public IHasLabel LabeledObject {get;}

Remarks

  • This property will indicate what object group contains the label (i.e. MajorTickmark, MinorTickmark, etc.).

Applies to

LabelHitZoneTarget

See Also

LabelHitZoneTarget Class | LabelHitZoneTarget Members


TickmarkHitZoneTarget class

Provides access to the TickmarkHitZoneTarget object.

For a list of all members of this type, see TickmarkHitZoneTarget Members

ChartFX.WinForms.Gauge.HitDetection.BaseValueHitZoneTarget
ChartFX.WinForms.Gauge.HitDetection.TickmarkHitZoneTarget

Remarks

Access to this object allows the developer to configure Tickmark settings.


TickmarkHitZoneTarget Class Members

TickmarkHitZoneTarget Members

TickmarkHitZoneTarget Overview

Public Properties

public property Range | Gets the associated gauge Section.
public property Tickmark | Gets the targeted tickmark group.
public property ToolTip (inherited from BaseHitTestTarget) | Gets or sets the tool tip displayed by the target.
public property Value (inherited from BaseValueHitZoneTarget) | Gets the value of the HitZoneTarget.


Range Property of TickmarkHitZoneTarget class

TickmarkHitZoneTarget.Range Property

Gets the associated gauge Section.

[Visual Basic]
Public ReadOnly Property Range As BaseSection[C#]
public BaseSection Range {get;}

Remarks

  • If no Sections are created, then this property returns a reference to the MainScale.

Applies to

TickmarkHitZoneTarget

See Also

TickmarkHitZoneTarget Class | TickmarkHitZoneTarget Members


Tickmark Property of TickmarkHitZoneTarget class

TickmarkHitZoneTarget.Tickmark Property

Gets the targeted tickmark group.

[Visual Basic]
Public ReadOnly Property Tickmark As Tickmark[C#]
public Tickmark Tickmark {get;}

Remarks

  • This property may be used to modify the attributes of the tickmark group.

Example

Change the tickmark color to blue.

[C#]
 TickmarkHitZoneTarget ttz = (TickmarkHitZoneTarget)e.SelectedTarget;
ttz.Tickmark.Color = Color.Blue;

[Visual Basic]
 Dim ttz As TickmarkHitZoneTarget = CType(e.SelectedTarget, TickmarkHitZoneTarget) ttz.Tickmark.Color = Color.Blue

Applies to

TickmarkHitZoneTarget

See Also

TickmarkHitZoneTarget Class | TickmarkHitZoneTarget Members


Annotation class

Provides access to the Annotation object.

For a list of all members of this type, see Annotation Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation

Remarks

The Annotation class is a base class which BaseImage, InnerBaseGauge, and Title are derived.

The Annotation object support members are used to position and align annotations inside the gauges.


Annotation Class Members

Annotation Members

Annotation Overview

Public Properties

public property Angle | Gets or sets the rotation angle in degrees for an annotation.
public property Layout | Allows you to access the layout object for an Annotation.
public property VerticalPosition | Gets or sets the vertical position for an annotation object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


VerticalPosition Property of Annotation class

Annotation.VerticalPosition Property

Gets or sets the vertical position for an annotation object.

[Visual Basic]
Public Property VerticalPosition As AnnotationVerticalPosition[C#]
public AnnotationVerticalPosition VerticalPosition {get;set;}

Property Value

The default is BehindIndicators.

Value | Meaning
BehindIndicators | Description goes here
AboveIndicators | Description goes here
OutsideBorder | Description goes here

Remarks

  • Use the VerticalPosition property to determine the vertical postion of an Annotation object in relation with the Indicators and the border.

  • You can set this property to a BitmapImage, VectorImage or a Title.

Example

To set the VerticalPosition property to AboveIndicators for an image:

[C#]
 BitmapImage image = new BitmapImage("MyImage.png");
image.VerticalPosition = AnnotationVerticalPosition.AboveIndicators;
radialGauge1.Images.Add(image);

Applies to

Annotation

See Also

Annotation Class | Annotation Members


BaseColorable class

Provides access to the BaseColorable object.

For a list of all members of this type, see BaseColorable Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable

Remarks

The BaseColorable class is derived from the BaseViewable class. These objects are not designed to be used directly, however do provide other objects support for setting Color attributes for selected gauge objects.

Please see the Color class in your development environment documentation for more information regarding functionality for supported members.


BaseColorable Class Members

BaseColorable Members

BaseColorable Overview

Public Properties

public property Color | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseElement class

Provides access to the BaseElement object.

For a list of all members of this type, see BaseElement Members

Remarks

This is an internal object, it should not be accessed directly.


BaseElement Class Members

BaseElement Members

BaseElement Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseElementItem class

Provides access to the BaseElementItem object.

For a list of all members of this type, see BaseElementItem Members

Remarks

This is an internal object, it should not be accessed directly.


BaseElementItem Class Members

BaseElementItem Members

BaseElementItem Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseImage class

A primitivate image class to be inherited.

For a list of all members of this type, see BaseImage Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.Annotation
ChartFX.WinForms.Gauge.Primitives.BaseImage

Remarks

This class is inherited by BitmapImage and VectorImage classes and should not be directly instantiated.


BaseImage Class Members

BaseImage Members

BaseImage Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Allows you to access the layout object for an Annotation.
public property PhysicalHeight | Retrieve the height (in pixels) of the image file.
public property PhysicalSize | Retrieve the Size object describing the image file.
public property PhysicalWidth | Retrieve the width (in pixels) of the image file.
public property Size | A numeric size modifier applied in conjunction with a Custom SizeMode setting.
public property SizeMode | Defines the display size options for the background image.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


PhysicalSize Property of BaseImage class

BaseImage.PhysicalSize Property

Retrieve the Size object describing the image file.

[Visual Basic]
Public ReadOnly Property PhysicalSize As Size[C#]
public Size PhysicalSize {get;}

Remarks

  • This is a Get-only property.

Applies to

BaseImage

See Also

BaseImage Class | BaseImage Members


BaseSection class

Provides access to the BaseSection object.

For a list of all members of this type, see BaseSection Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseSection

Remarks

Both the Scale and Section objects are derived from the BaseSection class. A Scale object is used for gauge types which support a scale, for example a RadialGauge. A Section object is a portion of a selected scale.

The BaseSection object was not designed for direct use.


BaseSection Class Members

BaseSection Members

BaseSection Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Max (inherited from Range) | Get or set the Maximum value of the gauge scale.
public property MaxAlwaysDisplayed | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from Range) | Get or set the Minimum value for the gauge scale.
public property MinAlwaysDisplayed | Gets or sets a value indicating whether to display the starting value of a section.
public property Tickmarks | Allows you to access the Tickmark properties for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged (inherited from Range) | Event triggered when the associated Max value is changed.
public event MinChanged (inherited from Range) | Event triggered when the associated Max value is changed.


BaseSectionBar class

A base class used to inherit common bar properties.

For a list of all members of this type, see BaseSectionBar Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable
ChartFX.WinForms.Gauge.Primitives.BaseColorable
ChartFX.WinForms.Gauge.Primitives.BaseSectionBar

Remarks

Both the ScaleBar and SectionBar objects are derived from the BaseSectionbar class.

The BaseSection object was not designed for direct use.


BaseSectionBar Class Members

BaseSectionBar Members

BaseSectionBar Overview

Public Properties

public property Color | Get or set the color of the section bar.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseViewable class

Provides access to the BaseViewable object.

For a list of all members of this type, see BaseViewable Members

ChartFX.WinForms.Gauge.Primitives.BaseViewable

Remarks

The BaseViewable class was not designed for direct use, however may other gauge objects derive and utilize the supported member (Visible) to show or hide selected gauge elements.


BaseViewable Class Members

BaseViewable Members

BaseViewable Overview

Public Properties

public property Visible Gets or sets a value indicating whether an object is visible or not.


Range class

Represents the range settings for various gauge elements.

For a list of all members of this type, see Range Members

ChartFX.WinForms.Gauge.Primitives.Range

Remarks

This class is used by the gauges, scales, sections, and any object that configures a Min/Max.


Range Class Members

Range Members

Range Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Max | Get or set the Maximum value of the gauge scale.
public property Min | Get or set the Minimum value for the gauge scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.

Public Event

public event MaxChanged | Event triggered when the associated Max value is changed.
public event MinChanged | Event triggered when the associated Max value is changed.