Chart class

Provides access to the Chart object. This is the main class of the ChartFX library.

For a list of all members of this type, see Chart Members

ChartFX.ReportingServices.Chart

Remarks

General chart properties are provided to set general attributes in the chart. For example, you may use properties to show or hide tools in the chart window or to apply a specific line style to all lines in a line chart.

The data is passed to the chart using the Data property. Alternativelly, data binding is also available through the DataSource and DataSourceSettings properties.

There may be a case in which a general property is also found in a specific object. For example, you may use a general property called Gallery property to change the chart type displayed (for all series in the chart), but if you use the Gallery property supported by the Series object you will change the chart type for a particular series (thus creating a MultiType chart) instead of all series in the chart. You may even go a step further by assigning properties directly to specific points rather than series using the Point object.

Some properties of the Chart object act as a mechanism for assigning attributes directly to other objects that exist in the chart. Some of these properties include LegendBox, ToolBar, MenuBar, and DataGrid. If you want to assign individual properties to elements in the chart, you may refer to the different objects available.

The chart can be rendered in 3D. View3D property provides access the 3D customization of the chart.

@2005 Software FX, Inc. All Rights Reserved. Chart FX is a registered trademark of Software FX, Inc
All other names are trademarks or registered trademarks of their respective owners.


Chart Class Members

Chart FX for Reporting Services

Chart Members

Chart Overview

Public Properties

public property AllSeries | Gets the global attributes which are shared across the series of the chart.
public property AxesStyle | Used to change the style of the axes.
public property AxisX | Assigns properties specifically to the primary X axis.
public property AxisY | Assigns properties specifically to the primary Y axis of the chart.
public property AxisY2 | Assigns properties specifically to the secondary Y axis of the chart.
public property Background | Allows you to assign a gradient to the background of a chart. FillMode needs to be set to Gradient.
public property Border | Gets or Sets a default or image border to the chart.
public property ConditionalAttributes | Returns the collection of ConditionalAttributes objects.
public property ContextMenus | Allows you to enable or disable context sensitive menus when the user right clicks a particular Chart FX element.
public property Data | Allows you to set the y values. Altarnativelly, the y-values can be access through the Y property of the DataValues.
public property DataGrid | Gets the Data Grid of the chart. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the chart and the grid at the same time.
public property Font | Gets or Sets the font type which will be used by default in the chart.
public property ForeColor | Gets or Sets the default font color of the chart.
public property Gallery | Sets the gallery type of the chart. The gallery type can also be accessed through the AllSeries property.
public property Height | Specifies the suggested height of the chart when generating images. This property allows you to configure the height of the image using units other than pixels.
public property LegendBox | Allows you to acces the legend box of the chart.
public property PageColor | Allows you to specify a form background color needed to fill areas around image border shadowing.
public property Palette | Allows you to set a Chart FX pre-defined palette.
public property Panes | Returns the collection of the defined panes of the chart.
public property Personalize | Allows you to set the preferences for saving and loading personalized charts.
public property PlotAreaColor | Gets and Sets the color of the PlotAreaBackground. Alternatively, the color can be access using the Color property of the PlotAreaBackground object.
public property PlotAreaMargin | Gets and Sets the top, bottom, left and right gaps of the chart.
public property Series | Assigns properties directly to the selected series in the chart.
public property View3D | Allows you to enable or disable 3D view of the chart. Also permits to customize the 3D view.
public property Visible | Gets or sets a value specifying to show or hide the chart.
public property Width | Specifies the suggested width of the chart when generating images. This property allows you to configure the width of the image using units other than pixels.


AllSeries property of Chart class

Chart.AllSeries Property

Gets the global attributes which are shared across the series of the chart.

[Visual Basic]
Public ReadOnly Property AllSeries As GlobalAttributes[C#]
public GlobalAttributes AllSeries {get;}

Remarks

  • For performance reason, the series and the points related to the series share the same visual attributes. Those visual attributes are stored in the GlobalAttributes class. Therefore, to set a attribute common to all the points of the chart, AllSeries should be used. If the user wants to change a visual attribute for a particular series, Series should be used. Similarly, if the user wants to change a visual attribute for a particular point, Points should be used.

  • Below, the galleries of all the series have been changed to Pies:

Applies to

Chart

See Also

Chart Class | Chart Members | Series (Chart) Property | Point (Chart) Property | SeriesAttributes Class | PointAttributes Class


AxesStyle property of Chart class

Chart.AxesStyle Property

Used to change the style of the axes.

[Visual Basic]
Public Property AxesStyle As AxesStyle[C#]
public AxesStyle AxesStyle {get;set;}

Remarks

  • Toggling the chart from 2D and 3D modes will produce different effects.

  • Below, the style of the Axis is set to math:

Applies to

Chart

See Also

Chart Class | Chart Members | AxesX Property | AxesY Property | View3D Property | Step (Axis) Property | MinorStep (Axis) Property | Enabled (Attributes3D) Property | Attributes3D Class


AxisX property of Chart class

Chart.AxisX Property

Assigns properties specifically to the primary X axis.

[Visual Basic]
Public ReadOnly Property AxisX As AxisX[C#]
public AxisX AxisX {get;}

Remarks

  • Below, the primary X axis of the chart is hidden.

Applies to

Chart

See Also

Chart Class | Chart Members | AxesY Property | AxisY Property | AxisY2 Property


AxisY property of Chart class

Chart.AxisY Property

Assigns properties specifically to the primary Y axis of the chart.

[Visual Basic]
Public ReadOnly Property AxisY As AxisY[C#]
public AxisY AxisY {get;}

Remarks

  • Below, the labels of the primary Y axis are set to blue and are formatted to use 4 decimals.

Applies to

Chart

See Also

Chart Class | Chart Members | AxisY2 Property | AxesY Property


AxisY2 property of Chart class

Chart.AxisY2 Property

Assigns properties specifically to the secondary Y axis of the chart.

[Visual Basic]
Public ReadOnly Property AxisY2 As AxisY[C#]
public AxisY AxisY2 {get;}

Remarks

  • By default, the secondary Y axis is not visible. This axis needs to be associated to a series in order to be rendered by the chart.

  • Below, the second series of the chart is associated to the secondary Y axis.

Applies to

Chart

See Also

Chart Class | Chart Members | AxesY Property | AxisY Property


Background property of Chart class

Chart.Background Property

Allows you to assign a gradient to the background of a chart. FillMode needs to be set to Gradient.

[Visual Basic]
Public Property Background As IBackgroundAdornment[C#]
public IBackgroundAdornment Background {get;set;}

Remarks

  • Each chart has only one background. Gradients may be applied to the background of both 2D and 3D charts.

  • Below, the background of the chart is set to be a gradient.

Applies to

Chart

See Also

Chart Class | Chart Members | FillMode (GlobalAttributes) Property | PlotAreaBackground Property | PlotAreaColor Property | GradientBackground Class | ImageBackground Class | SolidBackground Class


Border property of Chart class

Chart.Border Property

Gets or Sets a default or image border to the chart.

[Visual Basic]
Public Property Border As IBorderAdornment[C#]
public IBorderAdornment Border {get;set;}

Remarks

  • The Border property is used when setting default and image borders to the chart. In order to assign a standard or image border, you must create a new SimpleBorder or ImageBorder object. To use ImageBorder in your chart, the proper assembly must be added as a reference in the project.

  • The ImageBorder class uses shading to give a multidimensional effect. The PageColor property can be used to modify the background color of the shaded area around the border.

  • Below, the chart has an image border with the Embed style:

  • Below, the chart has a basic border with the Raised style:

Applies to

Chart

See Also

Chart Class | Chart Members | PageColor Property | SimpleBorder Class | ImageBorder Class


ConditionalAttributes property of Chart class

Chart.ConditionalAttributes Property

Returns the collection of ConditionalAttributes objects.

[Visual Basic]
Public ReadOnly Property ConditionalAttributes As ConditionalAttributesCollection[C#]
public ConditionalAttributesCollection ConditionalAttributes {get;}

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the ConditionalAttributes item.

Remarks

  • This property exposes the members of the Condition and ConditionalAttributes classes. Please see the Condition and ConditionalAttributes classes for additional information regarding those supported members.

Applies to

Chart

See Also

Chart Class | Chart Members | Condition Class | ConditionalAttributes Class


ContextMenus property of Chart class

Chart.ContextMenus Property

Allows you to enable or disable context sensitive menus when the user right clicks a particular Chart FX element.

[Visual Basic]
Public Property ContextMenus As Boolean[C#]
public Boolean ContextMenus {get;set;}

Remarks

  • This property allows the end user to easily alter various chart elements rather than finding the appropriate dialog in the chart tabbed dialog. Therefore, we strongly recommend the use of this setting.

  • This is the context menu activated when right-clicking on a point marker while the ContextMenus property is set to True:

Applies to

Chart

See Also

Chart Class | Chart Members


Data property of Chart class

Chart.Data Property

Allows you to set the y values. Altarnativelly, the y-values can be access through the Y property of the DataValues class.

[Visual Basic]
Public ReadOnly Property Data As DataValues[C#]
public DataValues Data {get;}

Parameters

Parameter | Type | Meaning
series | Int32 | An integer specifying the series you want to set the y-value.
point | Int32 | An integer specifying the point you want to set the y value.

Remarks

  • Once the chart has been populated using Value property, the DataGrid object allows users to view point values at runtime.

  • Please note that instead of the y value associated with the point, you can assign a hidden constant will cause the point to be hidden in the chart. Although a hidden point is physically in the data array, when you use this constant the marker will not appear in the chart, and if you have charts like a line or area chart, the line will break at that particular point.

Applies to

Chart

See Also

Chart Class | Chart Members | X (DataValues) Property | Y (DataValues) Property | YFrom (DataValues) Property | Data (Chart) Property | RecalculateScale Method | DataValues Class


DataGrid property of Chart class

Chart.DataGrid Property

Gets the Data Grid of the chart. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the chart and the grid at the same time.

[Visual Basic]
Public ReadOnly Property DataGrid As DataGrid[C#]
public DataGrid DataGrid {get;}

Remarks

  • Below, the DataGrid is visible:

Applies to

Chart

See Also

Chart Class | Chart Members | Visible (DataGrid) Property


Font property of Chart class

Chart.Font Property

Gets or Sets the font type which will be used by default in the chart.

[Visual Basic]
Public Property Font As Font[C#]
public Font Font {get;set;}

Remarks

  • See the Font class in .NET Framework .

  • Below, the default font of the chart is italic and has a font size of 12:

Applies to

Chart

See Also

Chart Class | Chart Members | Font (PointLabelAttributes) Property


ForeColor property of Chart class

Chart.ForeColor Property

Gets or Sets the default font color of the chart.

[Visual Basic]
Public Property ForeColor As Color[C#]
public Color ForeColor {get;set;}

Remarks

  • See the Color class in .NET Framework .

  • Below, the defaut font color is set to green:

Applies to

Chart

See Also

Chart Class | Chart Members | Font Property | BackColor Property


Gallery property of Chart class

Chart.Gallery Property

Sets the gallery type of the chart. The gallery type can also be accessed through the AllSeries property.

[Visual Basic]
Public Property Gallery As Gallery[C#]
public Gallery Gallery {get;set;}

Remarks

  • When you set the gallery with this property, it applies to all the series in the chart. If you want to create a Multitype (or combination chart) please refer to the Gallery properties of the SeriesAttributes class.

  • When selecting a Gallery for charts, keep in mind the number of data series which will be included in the chart. Pie, Pyramid and Doughnut chart types can only display one series per chart. If you have multiple data series, you may want to select a Gallery type that supports one that one series.

  • GalleryAttributes allows you to assign additional attributes to selected gallery types.

Applies to

Chart

See Also

Chart Class | Chart Members | Gallery (GlobalAttributes) Property | GalleryAttributes Property | AllSeries Property | GlobalAttributes Class | SeriesAttributes Class


Height property of Chart class

Chart.Height Property

Specifies the suggested height of the chart when generating images. This property allows you to configure the height of the image using units other than pixels.

[Visual Basic]
Public Property Height As Unit[C#]
public Unit Height {get;set;}

Remarks

  • You may also set the dimensions for the image generated using the Height and Width properties of ImageSettings.

  • For more information regarding the dimension classes, please refer to the documentation in the .NET Framework .

  • This method overrides the default implementation of WebControl. Please refer to the documentation of WebControl in the .NET Framework .

Applies to

Chart

See Also

Chart Class | Chart Members | Height (ImageSettings) Property | Width (ImageSettings) Property


LegendBox property of Chart class

Chart.LegendBox Property

Allows you to acces the legend box of the chart.

[Visual Basic]
Public ReadOnly Property LegendBox As LegendBox[C#]
public LegendBox LegendBox {get;}

Remarks

  • The values legend box is used to display legends associated with data points and is used to improve the chart's readability in charts like Pie, Doughnut and Pyramid where there's no axis, but point labels are still necessary in the chart.

  • Below, the legend box is render at the bottom of the chart:

Applies to

Chart

See Also

Chart Class | Chart Members | Visible (LegendBox) Property


PageColor property of Chart class

Chart.PageColor Property

Allows you to specify a form background color needed to fill areas around image border shadowing.

[Visual Basic]
Public Property PageColor As Color[C#]
public Color PageColor {get;set;}

Remarks

  • This is automatically done in Chart FX when creating desktop applications. This property is useful when using image borders with the Internet Edition.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • The ImageBorder class uses shading to give a multidimensional effect. The PageColor property can be used to modify the background color of the shaded area around the border. Below, the page color of the chart has been set to purple:

Applies to

Chart

See Also

Chart Class | Chart Members | Border Property


Palette property of Chart class

Chart.Palette Property

Allows you to set a Chart FX pre-defined palette.

[Visual Basic]
Public Property Palette As String[C#]
public String Palette {get;set;}

Remarks

  • When changing the palette, all the properties related to changing colors in the chart will also be affected as Chart FX will change the windows palette for the chart window. So if you previously set a color using any of the Chart FX supported properties (ForeColor, BackColor, etc) this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • New palettes may be created and integrated into ChartFX. For more information regarding palette creation, please contact SoftwareFX support.

  • Below is a list of Chart FX palettes:

    Natural.Sky

    ChartFX6.EarthTones

    ChartFX6.ModernBusiness

    DarkPastels.Pastels

    Mesa.Mesa

    Natural.Adventure

    HighContrast.HighContrast

    Vivid

    ChartFX6.Alternate

    ChartFX6.Windows

    ChartFX6.ChartFX6

    We have also created a set of palettes matching the colors in the Visual Studio Auto Format option, provided by several native Visual Studio components, such as the GridView (Web Forms).

    The Visual Studio schemes supported by Chart FX are:

    Schemes.Colorful

    Schemes.Classic

    Schemes.Simple

    Schemes.Professional

    Schemes2.Autumn

    Schemes2.Oceanica

    Schemes2.Brown Sugar

    Schemes2.Slate

    Schemes3.Sand & Sky

    Schemes3.Rainy Day

    Schemes3.Snowy Pine

    Schemes3.Lilacs in Mist

    Schemes4.Mocha

    Schemes4.Black&Blue1

    Note: To properly load these palettes, you will simply use their string names (i.e. “DarkPastels.Pastels").

    For the most updated list of supported palettes, check the Palette property in the design time Property dialog. For the Internet Control, check the internet designer for the latest supported Internet palettes.

  • Below, the palette of the chart is set to EarthTones, sucessively:

Applies to

Chart

See Also

Chart Class | Chart Members | Color (PointAttributes) Property | AlternateColor (PointAttributes) Property | ForeColor Property | BackColor Property | PointAttributes Class | SeriesAttributes Class


Panes property of Chart class

Chart.Panes Property

Returns the collection of the defined panes of the chart.

[Visual Basic]
Public ReadOnly Property Panes As PaneCollection[C#]
public PaneCollection Panes {get;}

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the Panes item.

Remarks

  • The main pane of the chart is the first indexed pane of the collection.

  • Below, the first series of the chart is associated to the main pane. However, the second and third series are associated to a second pane:

Applies to

Chart

See Also

Chart Class | Chart Members | MainPane Property | Pane Class


Personalize property of Chart class

Chart.Personalize Property

Allows you to set the preferences for saving and loading personalized charts.

[Visual Basic]
Public ReadOnly Property Personalize As PersonalizeAttributes[C#]
public PersonalizeAttributes Personalize {get;}

Remarks

  • Many users require and demand information on an individual basis. Using personalized charts allows users to change visual attributes and have those settings saved locally. When the user accesses the chart in the future, the saved settings can be automatically loaded so the user can view a chart configured to their personal preference.

Applies to

Chart

See Also

Chart Class | Chart Members | Export Method | Import Method


PlotAreaColor property of Chart class

Chart.PlotAreaColor Property

Gets and Sets the color of the PlotAreaBackground. Alternatively, the color can be access using the Color property of the PlotAreaBackground object.

[Visual Basic]
Public Property PlotAreaColor As Color[C#]
public Color PlotAreaColor {get;set;}

Remarks

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • When the chart renders several panes, setting the color of the plot area is equivalent to setting the BackColor of the panes individually.

    Below, the color of the plot area is set to purple:

  • PlotAreaColor supports transparency. When the PlotArea is transparent, the background of the PlotArea is rendered by the Background and BackColor properties. In this screenshot, the PlotAreaColor is set to transparent and the BackColor is set to blue:

Applies to

Chart

See Also

Chart Class | Chart Members | BackColor (Pane) Property | BackColor Property | PlotAreaBackground Property | ImageBackground Class | SolidBackground Class | ImageBackground Class


PlotAreaMargin property of Chart class

Chart.PlotAreaMargin Property

Gets and Sets the top, bottom, left and right gaps of the chart.

[Visual Basic]
Public ReadOnly Property PlotAreaMargin As Margins[C#]
public Margins PlotAreaMargin {get;}

Remarks

  • A gap is defined as the margin between the chart and the bounding rectangle in pixels. Each chart has a top, bottom, left and right gaps.

  • Below, the bottom gap of the chart is set to 100 pixels. The other gaps are set to 0:

Applies to

Chart

See Also

Chart Class | Chart Members


Series property of Chart class

Chart.Series Property

Assigns properties directly to the selected series in the chart.

[Visual Basic]
Public ReadOnly Property Series As SeriesAttributesCollection[C#]
public SeriesAttributesCollection Series {get;}

Parameters

Parameter | Type | Meaning
n | Int32 | A zero based index indicating the data series in the chart.

Remarks

  • Allows you to assign supported properties directly to the specified data series. For supported properties, please see the SeriesAttributes class.

  • AllSeries allows to set properties common to all the Series or/and Points of the chart.

  • The Series property allows you to create charts with mixed Gallery types and assign specific colors to each series.

  • Below is an example of a multi-gallery chart:

Applies to

Chart

See Also

Chart Class | Chart Members | Gallery Property | Gallery (GlobalAttributes) Property | Gallery (SeriesAttributes) Property | AllSeries Property | Points Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


View3D property of Chart class

Chart.View3D Property

Allows you to enable or disable 3D view of the chart. Also permits to customize the 3D view.

[Visual Basic]
Public ReadOnly Property View3D As Attributes3D[C#]
public Attributes3D View3D {get;}

Remarks

  • When this property is set to True, you can apply a rotation angle or perspective with the AngleX, AngleY and Perspective properties of the Attributes3D class.

  • Below is a chart where the 3D view is enabled:

Applies to

Chart

See Also

Chart Class | Chart Members


Visible property of Chart class

Chart.Visible Property

Gets or sets a value specifying to show or hide the chart.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • By defualt the chart is visible.

Applies to

Chart

See Also

Chart Class | Chart Members


Width property of Chart class

Chart.Width Property

Specifies the suggested width of the chart when generating images. This property allows you to configure the width of the image using units other than pixels.

[Visual Basic]
Public Property Width As Unit[C#]
public Unit Width {get;set;}

Remarks

  • You may also set the dimensions for the image generated using the Height and Width properties of ImageSettings.

  • For more information regarding the dimension classes, please refer to the .NET Framework documentation.

  • This method overrides the default implementation of WebControl. Please refer to the documentation of WebControl in the .NET Framework .

Applies to

Chart

See Also

Chart Class | Chart Members | Height (ImageSettings) Property | Width (ImageSettings) Property


Attributes3D class

Provides access to the Attributes3D object.

For a list of all members of this type, see Attributes3D Members

ChartFX.ReportingServices.Attributes3D

Remarks

The Attributes3D object supported members allow developers to add 3D views and perspective to charts. By enabling 3D in charts, developers may further customize the display my manipulating X and Y angles, depth, perspective, rotation and shadowing. Additionally, members like Cluster allow you to add a Z dimension to charts.


Attributes3D Class Members

Attributes3D Members

Attributes3D Overview

Public Properties

public property AngleX | Gets or Sets the 3D rotation angle around the X-axis.
public property AngleY | Gets or Sets a 3D rotation angle around the Y-axis.
public property BoxThickness | Gets or Sets the thickness for the box surrounding the chart.
public property Cluster | Displays a z-clustered 3D chart.
public property Depth | Gets or Sets the thickness along the Z-axis for the series.
public property Enabled | Gets or Sets a value indicating whether 3D effects should be applied.
public property Rotated | Gets or Sets a value indicating the chart is Rotated.
public property Shadow | Gets or Sets a value indicating the type of shading to display when rotating the chart.


AngleX property of Attributes3D class

Attributes3D.AngleX Property

Gets or Sets the 3D rotation angle around the X-axis.

[Visual Basic]
Public Property AngleX As Int32[C#]
public Int32 AngleX {get;set;}

Remarks

  • The value can be set to an integer between [0-90] or [270-360] indicating the degree of rotation around the X-axis.

  • Negative values or values greater than 360 are automatically reduced to a value in the range of 0 to 359.

  • This property can only be used when the chart is in 3D view. So, be sure the View3D properties is set to Visible.

  • To avoid jagged lines we recommend you use prominent angles (for example: 0,30,45,60,90, etc).

  • To set a Y-axis rotation angle, please refer to the AngleY property.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | AngleY Property | View3D Property | Chart Class


AngleY property of Attributes3D class

Attributes3D.AngleY Property

Gets or Sets a 3D rotation angle around the Y-axis.

[Visual Basic]
Public Property AngleY As Int32[C#]
public Int32 AngleY {get;set;}

Remarks

  • The value can be set to an integer between [0-90] or [270-360] indicating the degree of rotation around the Y-axis.

  • Negative values or values greater than 360 are automatically reduced to a value in the range of 0 to 359.

  • This property can only be used when the chart is in 3D view. So, be sure the Enabled property is set to True.

  • To avoid jagged lines we recommend you use prominent angles (for example: 0,30,45,60,90, etc).

  • To set a X-axis rotation angle, please refer to the AngleX property.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | AngleX Property | View3D (Chart) Property


BoxThickness property of Attributes3D class

Attributes3D.BoxThickness Property

Gets or Sets the thickness for the box surrounding the chart.

[Visual Basic]
Public Property BoxThickness As Int32[C#]
public Int32 BoxThickness {get;set;}

Remarks

  • Here is a chart with BoxThickness of 10.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | AngleX Property | AngleY Property | Depth Property | Perspective Property | View3D Property | Chart Class


Cluster property of Attributes3D class

Attributes3D.Cluster Property

Displays a z-clustered 3D chart.

When set to True the chart will show as clustered, when set to False the chart displays the series side-by-side.

[Visual Basic]
Public Property Cluster As Boolean[C#]
public Boolean Cluster {get;set;}

Remarks

  • When setting this property you must make sure the chart is displayed in 3D mode (by setting the Enabled property to true) and that the chart is cluster capable (BAR, LINES or GANTT chart).

  • When displaying a clustered chart, each series will have its own position in the Z axis. This means, if this property is set to true each data series will occupy one row of data along the Z-axis

  • AREA charts are always clustered as there is no way to paint different series side by side. On the other hand, if you have a BAR chart, it is possible to paint bars side-by-side and not clustered in the z-axis.

  • Below is an example of a non-clustered bar chart vs. a clustered bar chart.

    Non-Clustered:

    Clustered:

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | View3D (Chart) Property | Chart Class


Depth property of Attributes3D class

Attributes3D.Depth Property

Gets or Sets the thickness along the Z-axis for the series.

[Visual Basic]
Public Property Depth As Int32[C#]
public Int32 Depth {get;set;}

Remarks

  • Here are two examples demonstrating the differences when using Depth of 0 and Depth of 150.

    Depth value of 0:

    Depth value of 150:

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | BoxThickness Property | View3D Property | Chart Class


Enabled property of Attributes3D class

Attributes3D.Enabled Property

Gets or Sets a value indicating whether 3D effects should be applied.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • Toggles the chart between 2D and 3D modes.

    When set to True the chart is displayed in 3D.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | View3D Property | Chart Class


Rotated property of Attributes3D class

Attributes3D.Rotated Property

Gets or Sets a value indicating the chart is Rotated.

[Visual Basic]
Public Property Rotated As Boolean[C#]
public Boolean Rotated {get;set;}

Remarks

  • Allows you to enable or disable a Rotated view in a 3D chart.

  • When a chart is Rotated, angles and perspective attribute are also applied.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | AngleX Property | AngleY Property | Perspective Property | View3D Property | Chart Class


Shadow property of Attributes3D class

Attributes3D.Shadow Property

Gets or Sets a value indicating the type of shading to display when rotating the chart.

[Visual Basic]
Public Property Shadow As Shadow[C#]
public Shadow Shadow {get;set;}

Remarks

  • There are 3 options for this property.

    Fixed (default):

    Sets standard shading for crevasses exposed in 3D charts such as the boxes surrounding the.

    None:

    Removes all shading features. Note, this may reduce the 3D effect of the chart.

    Realistic:

    Chart FX adjusts the shading depending on the angle and rotation settings.

Applies to

Attributes3D

See Also

Attributes3D Class | Attributes3D Members | View3D Property | Chart Class


Axis class

This is the base for the Axis classes.

For a list of all members of this type, see Axis Members

ChartFX.ReportingServices.AxisSectionBase
ChartFX.ReportingServices.Axis

Remarks

Axes are one of the most important aspects in a chart since they provide users with a visual means to read and analyze data. Therefore, a charting tool must provide mechanisms to manipulate axis settings programmatically.

Chart FX automatically configures axes accommodating the data that was used to populate the chart. This behavior will minimize the initial programming effort of customizing the chart's axes. However, in some cases programmers will face complex needs like special labeling, scrolling, formatting and scaling that must be addressed via code. To achieve this, Chart FX provides a powerful object-oriented API, so programmers can customize virtually any axis setting.

It's important to be aware that Chart FX supports many different axes: The main Y Axis, the Secondary Y axis and the X-Axis are illustrated in the following figure:

Normally, the X-axis is a categorical axis (although it can also be a numerical axis in XY Plots) and the Y axes are numerical axis that you can independently control through different properties available in the axis object.


Axis Class Members

Axis Members

Axis Overview

Public Properties

public property CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
public property FirstLabel | Gets or sets a value used to customize the first label displayed on a selected axis.
public property Font | Allows you to change the label Font attributes of the selected axis.
public property ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
public property Grids (inherited from AxisSectionBase) | Allows customization of grid lines by providing access to the supported members of the Grids class.
public property Inverted | Sets a selected numerical axis max value lesser than the min value.
public property LabelAngle | Sets the text rotation for the labels in the selected axis.
public property LabelsFormat | Used to format the labels displayed on the selected axis.
public property LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
public property Line | Allows you to apply supported Line class members to a selected axis line.
public property LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
public property Max | Defines the maximum value of a specific axis.
public property MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
public property Notify | Used to enable or disable the GetAxisLabel event so you can customize labels on the specified axis.
public property Position | Specifies the placement of the axis labels and tick marks relative to the chart.
public property ScaleUnit | Returns or sets the scale unit of a selected axis.
public property Sections | Returns a selected AxisSection object.
public property Staggered | Alternates the level of the axis labels for the selected axis labels.
public property Step | Specifies the interval of major tick marks and gridlines on the selected axis.
public property Style | Allows you to add additional styles to the selected axis.
public property TextColor (inherited from AxisSectionBase) | Gets or Sets the color for text of a selected BaseAxisSection object.
public property Title | Gets or sets the title for a specific axis.
public property Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


CustomGridLines property of Axis class

Axis.CustomGridLines Property

Gets the collection of CustomGridLines that belong to the Chart.

[Visual Basic]
Public ReadOnly Property CustomGridLines As CustomGridLineCollection[C#]
public CustomGridLineCollection CustomGridLines {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

Applies to

Axis

See Also

Axis Class | Axis Members


FirstLabel property of Axis class

Axis.FirstLabel Property

Gets or sets a value used to customize the first label displayed on a selected axis.

[Visual Basic]
Public Property FirstLabel As Int32[C#]
public Int32 FirstLabel {get;set;}

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

  • Below, the first label in the X-Axis is set to 3:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Labels Property | KeyLabels Property | Step Property | MinorStep Property | Chart Class


Font property of Axis class

Axis.Font Property

Allows you to change the label Font attributes of the selected axis.

[Visual Basic]
Public Property Font As Font[C#]
public Font Font {get;set;}

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Font Property of the Title object.

  • When setting a font in Chart FX, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the .NET Framework Documentation.

  • Below, the Y axis labels font is set to "Arial" 14:

Applies to

Axis

See Also

Axis Class | Axis Members


ForceZero property of Axis class

Axis.ForceZero Property

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

[Visual Basic]
Public Property ForceZero As Boolean[C#]
public Boolean ForceZero {get;set;}

Remarks

  • By default, Chart FX will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want Chart FX to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Applies to

Axis

See Also

Axis Class | Axis Members


Grids property of AxisSectionBase class

AxisSectionBase.Grids Property

Allows customization of grid lines by providing access to the supported members of the Grids class.

[Visual Basic]
Public ReadOnly Property Grids As Grids[C#]
public Grids Grids {get;}

Remarks

  • This property provides customization of the chart Plot Area, but using the Interlaced and InterlacedColor properties of the Grids class.

  • Lines across the Axes can be added at the major and minor steps by setting Major and Minor Gridlines.

  • Lines across the Axes can be added at specific points by adding a CustomGridLine.

  • Below, the Minor gridline of the Axis Y is set to visible:

Applies to

AxisSectionBase

See Also

AxisSectionBase Class | AxisSectionBase Members | Major Property | Minor Property | Interlaced (Grids) Property | InterlacedColor (Grids) Property | Grids Class | GridLine Class | CustomGridLine Class


Inverted property of Axis class

Axis.Inverted Property

Sets a selected numerical axis max value lesser than the min value.

[Visual Basic]
Public Property Inverted As Boolean[C#]
public Boolean Inverted {get;set;}

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the X Axis in an XY plot chart. In an XY plot, the X Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

  • Below, the Y Axis is set to be inverted:

Applies to

Axis

See Also

Axis Class | Axis Members | Max Property | Min Property | AxisY (Chart) Property | AxisX (Chart) Property | RecalculateScale (Chart) Method | Chart Class


LabelAngle property of Axis class

Axis.LabelAngle Property

Sets the text rotation for the labels in the selected axis.

[Visual Basic]
Public Property LabelAngle As Int16[C#]
public Int16 LabelAngle {get;set;}

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the Angle property of the PointLabelAttributes class.

  • Below, the X axis label angle is set to 90:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | Labels Property | Angle (PointLabelAttributes) Property | Chart Class


LabelsFormat property of Axis class

Axis.LabelsFormat Property

Used to format the labels displayed on the selected axis.

[Visual Basic]
Public ReadOnly Property LabelsFormat As ValueFormat[C#]
public ValueFormat LabelsFormat {get;}

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | DataFormat Property | Chart Class | ValueFormat Class


LabelValue property of Axis class

Axis.LabelValue Property

Allows you to set associate text labels to major tick marks in a numerical axis.

This property can get or set the LabelValue assigned to any of the axes.

[Visual Basic]
Public Property LabelValue As Double[C#]
public Double LabelValue {get;set;}

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the Y axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default Chart FX will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the Y axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 Chart FX will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, TextColor, and Font properties, respectively.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Step Property | Labels Property | LabelAngle Property | TextColor Property | Font Property | Chart Class


Line property of Axis class

Axis.Line Property

Allows you to apply supported Line class members to a selected axis line.

[Visual Basic]
Public ReadOnly Property Line As Line[C#]
public Line Line {get;}

Remarks

  • You may control the Color, Width and Style of the selected line using the supported members of the Line class.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Below, the Y axis line color is set to red:

Applies to

Axis

See Also

Axis Class | Axis Members | Color Property | Width Property | Style Property | EndCap Property | StartCap Property | AxisX Property | AxisY Property | Line Class | Axis Class


LogBase property of Axis class

Axis.LogBase Property

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

[Visual Basic]
Public Property LogBase As Double[C#]
public Double LogBase {get;set;}

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

  • The LogBase has been set to 10 in the following bar chart:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Min Property | Max Property | Step Property | MinorStep Property | RecalculateScale (Chart) Method | Chart Class


Max property of Axis class

Axis.Max Property

Defines the maximum value of a specific axis.

Gets or sets the Max value assigned to the specified axis.

[Visual Basic]
Public Property Max As Double[C#]
public Double Max {get;set;}

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, Chart FX will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Applies to

Axis

See Also

Axis Class | Axis Members | AutoScale Property | AxisX Property | AxisY Property | Min Property | RecalculateScale (Chart) Method | Chart Class


MinorStep property of Axis class

Axis.MinorStep Property

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

[Visual Basic]
Public Property MinorStep As Double[C#]
public Double MinorStep {get;set;}

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

  • Below, the Y axis minorstep is set to 2:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Grids (AxisSectionBase) Property | AutoScale Property | Step Property | FirstLabel Property | RecalculateScale (Chart) Method | Chart Class


Notify property of Axis class

Axis.Notify Property

Used to enable or disable the GetAxisLabel event so you can customize labels on the specified axis.

[Visual Basic]
Public Property Notify As Boolean[C#]
public Boolean Notify {get;set;}

Remarks

  • This property also applies to the GetPointLabel event. The GetPointLabel event is raised when point labels are painted for a data series, AND the series is associated to a Y axis which Notify is set to True.

  • If this property is set to False, the GetAxisLabel or GetPointLabel events will not be raised. When set to True, it is possible for the developer to handle these events.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | GetAxisLabel (Chart event) Method | GetPointLabel (Chart event) Method | Chart Class


Position property of Axis class

Axis.Position Property

Specifies the placement of the axis labels and tick marks relative to the chart.

[Visual Basic]
Public Property Position As AxisPosition[C#]
public AxisPosition Position {get;set;}

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Both X and Y axes have been set to the Axis Position to Far position to switch their default locations:

  • Multiple axes may be created using the AxesX and the AxesY properties of the Chart class.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Labels Property | Chart Class


ScaleUnit property of Axis class

Axis.ScaleUnit Property

Returns or sets the scale unit of a selected axis.

[Visual Basic]
Public Property ScaleUnit As Double[C#]
public Double ScaleUnit {get;set;}

Remarks

  • This constant is very useful when the values used on the Y axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the Y axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Max Property | Min Property | RecalculateScale (Chart) Method | Chart Class


Sections property of Axis class

Axis.Sections Property

Returns a selected AxisSection object.

[Visual Basic]
Public ReadOnly Property Sections As AxisSectionCollection[C#]
public AxisSectionCollection Sections {get;}

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection and AxisSectionBase classes. Please see the AxisSection and AxisSectionBase classes for additional information regarding those supported members.

  • Below, the axis have a section from 20 to 60:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisSection Class | AxisSectionBase Class


Staggered property of Axis class

Axis.Staggered Property

Alternates the level of the axis labels for the selected axis labels.

[Visual Basic]
Public Property Staggered As Boolean[C#]
public Boolean Staggered {get;set;}

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

  • Below, the X axis staggered property is set to true:

Applies to

Axis

See Also

Axis Class | Axis Members


Step property of Axis class

Axis.Step Property

Specifies the interval of major tick marks and gridlines on the selected axis.

It also controls the gap or interval between labels in the selected axis.

[Visual Basic]
Public Property Step As Double[C#]
public Double Step {get;set;}

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your X axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, Chart FX will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • In the example below, the Step for the Y axis has been set to 50. Notice the tick marks on the Y axis increase by 50:

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX (Chart) Property | AxisY (Chart) Property | Grids (AxisSectionBase) Property | AutoScale Property | MinorStep Property | FirstLabel Property | RecalculateScale Method | Chart Class


Style property of Axis class

Axis.Style Property

Allows you to add additional styles to the selected axis.

[Visual Basic]
Public Property Style As AxisStyle[C#]
public AxisStyle Style {get;set;}

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use the bitwise operators (And, Or, Not, Xor) provided by your development tool.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | Axis Property | Max Property | Min Property | Labels Property | RecalculateScale Method | Chart Class


TextColor property of AxisSectionBase class

AxisSectionBase.TextColor Property

Gets or Sets the color for text of a selected BaseAxisSection object.

[Visual Basic]
Public Property TextColor As Color[C#]
public Color TextColor {get;set;}

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • For more information regarding the Color type, please refer to the .NET Framework .

  • Below, the Y axis section textcolor is set to red:

Applies to

AxisSectionBase

See Also

AxisSectionBase Class | AxisSectionBase Members | TextColor Property | Sections Property | Axis Class | AxisY Class | AxisX Class | AxisSection Class


Title property of Axis class

Axis.Title Property

Gets or sets the title for a specific axis.

[Visual Basic]
Public Property Title As Title[C#]
public Title Title {get;set;}

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Title class. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's Titles property.

  • You can create a MultiLine title by including the chr(10) character.

  • You can create a MultiLine title by including the VbCrLf character.

  • Below is a chart with both X and Y Axis titles:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | Text Property | Chart Class | Title Class


Visible property of Axis class

Axis.Visible Property

Shows or hides the lines, labels, tick marks and grids for the selected axis.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the Grids and tick marks are also hidden.

  • The X axis has been hidden in the chart below:

Applies to

Axis

See Also

Axis Class | Axis Members | AxisX Property | AxisY Property | Chart Class


AxisSection class

Provides access to the AxisSection object.

For a list of all members of this type, see AxisSection Members

ChartFX.ReportingServices.AxisSectionBase
ChartFX.ReportingServices.AxisSection

Remarks

This Class is used to customize the axis sections of a chart. By creating axis sections, the supported Class members allow the developer to assign visual attributes to the newly created axis sections. By allowing this customization, developers can focus end user's attention on particular values in the chart or display additional detail.

The Axis Section implementation is another analytical feature embedded into Chart FX. Utilizing this object in your charting applications allows end users to quickly identify focus areas of a chart and determine whether values fall into this range. This analytic enhancement makes data driven charts more pleasing to the eye and easily deciphered by users.

The Sections property returns the AxisSection object which may be configured using the AxisSection and AxisSectionBase class members.

The From property is used to specify the beginning value of the section range for a selected AxisSection object. The To property is used to specify the ending value of the section range for a selected AxisSection object.

The FontStyle property is used to configure additional font attributes for the selected axis section.


AxisSection Class Members

AxisSection Members

AxisSection Overview

Public Properties

public property BackColor | Gets or Sets the AxisSection background color.
public property FontStyle | Gets or Sets additional font attributes to the axis section.
public property From | Gets or sets a value indicating the beginning value of the range for a selected AxisSection object.
public property Grids (inherited from AxisSectionBase) | Allows customization of grid lines by providing access to the supported members of the Grids class.
public property Text | Gets or Sets the text string for a selected BaseAxisSection object.
public property TextColor (inherited from AxisSectionBase) | Gets or Sets the color for text of a selected BaseAxisSection object.
public property To | Gets or Sets a value indicating the ending value of the range the axis section.
public property Visible | Shows or hides the selected axis section.


BackColor property of AxisSection class

AxisSection.BackColor Property

Gets or Sets the AxisSection background color.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the Y axis section backcolor is set to Red:

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members | Sections Property | From Property | To Property | Axis Class | AxisSection Class


FontStyle property of AxisSection class

AxisSection.FontStyle Property

Gets or Sets additional font attributes to the axis section.

[Visual Basic]
Public Property FontStyle As FontStyle[C#]
public FontStyle FontStyle {get;set;}

Remarks

  • For more information regarding the FontStyle type, please refer to the .NET Framework Documentation.

  • Below, the Y axis section fontstyle is set to underline:

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members | Sections (Axis) Property | Axis Class


From property of AxisSection class

AxisSection.From Property

Gets or sets a value indicating the beginning value of the range for a selected AxisSection object.

[Visual Basic]
Public Property From As Double[C#]
public Double From {get;set;}

Remarks

  • The To property is used to specify the ending value of the section range for a selected AxisSection object.

  • The AxisSectionBase class members are used to customize the mayor gridlines, minor gridlines, textColor and Link for a AxisSection object.

  • The FontStyle property is used to configure additional font attributes for the selected axis section.

  • The Sections property returns the AxisSection object which may be configured using the AxisSection and AxisSectionBase class members.

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members | To Property | Class


Text property of AxisSection class

AxisSection.Text Property

Gets or Sets the text string for a selected BaseAxisSection object.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members


To property of AxisSection class

AxisSection.To Property

Gets or Sets a value indicating the ending value of the range the axis section.

[Visual Basic]
Public Property To As Double[C#]
public Double To {get;set;}

Remarks

  • The From property is used to specify the beginning value of the section range for a selected AxisSection object.

  • The AxisSectionBase class members are used to customize the mayor gridlines, minor gridlines, textColor and Link for a AxisSection object.

  • The FontStyle property is used to configure additional font attributes for the selected axis section.

  • The Sections property returns the AxisSection object which may be configured using the AxisSection and AxisSectionBase class members.

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members | From Property | AxisSectionBase Class


Visible property of AxisSection class

AxisSection.Visible Property

Shows or hides the selected axis section.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Applies to

AxisSection

See Also

AxisSection Class | AxisSection Members


AxisSectionBase class

Provides access to the AxisSectionBase, which is the root class for both the Axis and AxisSection classes.

For a list of all members of this type, see AxisSectionBase Members

ChartFX.ReportingServices.AxisSectionBase

Remarks

This Base class is not intended to be used directly by the programmer, however, derived classes can be used for axis customization. For example, the Axis class is derived from the AxisSectionBase and its members accessible through the use of the AxisX and AxisY properties. Furthermore, AxisSectionBase is the based class which AxisSection derive from.

The members of AxisSectionBase class are used to customize the gridlines, text color, and URL of the related Axis and AxisSection.


AxisSectionBase Class Members

AxisSectionBase Members

AxisSectionBase Overview

Public Properties

public property Grids | Allows customization of grid lines by providing access to the supported members of the Grids class.
public property TextColor | Gets or Sets the color for text of a selected BaseAxisSection object.


AxisX class

This class provides a shortcut to the Chart's main Axis X object.

For a list of all members of this type, see AxisX Members

ChartFX.ReportingServices.AxisSectionBase
ChartFX.ReportingServices.Axis
ChartFX.ReportingServices.AxisX

Remarks

This class provides a shortcut to the Chart's main Axis X object.


AxisX Class Members

AxisX Members

AxisX Overview

Public Properties

public property CustomGridLines (inherited from Axis) | Gets the collection of CustomGridLines that belong to the Chart.
public property FirstLabel (inherited from Axis) | Gets or sets a value used to customize the first label displayed on a selected axis.
public property Font (inherited from Axis) | Allows you to change the label Font attributes of the selected axis.
public property ForceZero (inherited from Axis) | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
public property Grids (inherited from AxisSectionBase) | Allows customization of grid lines by providing access to the supported members of the Grids class.
public property Inverted (inherited from Axis) | Sets a selected numerical axis max value lesser than the min value.
public property LabelAngle (inherited from Axis) | Sets the text rotation for the labels in the selected axis.
public property LabelsFormat (inherited from Axis) | Used to format the labels displayed on the selected axis.
public property LabelValue (inherited from Axis) | Allows you to set associate text labels to major tick marks in a numerical axis.
public property Line (inherited from Axis) | Allows you to apply supported Line class members to a selected axis line.
public property LogBase (inherited from Axis) | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
public property Max (inherited from Axis) | Defines the maximum value of a specific axis.
public property MinorStep (inherited from Axis) | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
public property Notify (inherited from Axis) | Used to enable or disable the GetAxisLabel event so you can customize labels on the specified axis.
public property Position (inherited from Axis) | Specifies the placement of the axis labels and tick marks relative to the chart.
public property ScaleUnit (inherited from Axis) | Returns or sets the scale unit of a selected axis.
public property Sections (inherited from Axis) | Returns a selected AxisSection object.
public property Staggered (inherited from Axis) | Alternates the level of the axis labels for the selected axis labels.
public property Step (inherited from Axis) | Specifies the interval of major tick marks and gridlines on the selected axis.
public property Style (inherited from Axis) | Allows you to add additional styles to the selected axis.
public property TextColor (inherited from AxisSectionBase) | Gets or Sets the color for text of a selected BaseAxisSection object.
public property Title (inherited from Axis) | Gets or sets the title for a specific axis.
public property Visible (inherited from Axis) | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AxisY class

This class provides a shortcut to the Chart's main Axis Y object.

For a list of all members of this type, see AxisY Members

ChartFX.ReportingServices.AxisSectionBase
ChartFX.ReportingServices.Axis
ChartFX.ReportingServices.AxisY

Remarks

This class provides a shortcut to the Chart's main Axis Y object.


AxisY Class Members

AxisY Members

AxisY Overview

Public Properties

public property CustomGridLines (inherited from Axis) | Gets the collection of CustomGridLines that belong to the Chart.
public property FirstLabel (inherited from Axis) | Gets or sets a value used to customize the first label displayed on a selected axis.
public property Font (inherited from Axis) | Allows you to change the label Font attributes of the selected axis.
public property ForceZero (inherited from Axis) | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
public property Grids (inherited from AxisSectionBase) | Allows customization of grid lines by providing access to the supported members of the Grids class.
public property Inverted (inherited from Axis) | Sets a selected numerical axis max value lesser than the min value.
public property LabelAngle (inherited from Axis) | Sets the text rotation for the labels in the selected axis.
public property LabelsFormat (inherited from Axis) | Used to format the labels displayed on the selected axis.
public property LabelValue (inherited from Axis) | Allows you to set associate text labels to major tick marks in a numerical axis.
public property Line (inherited from Axis) | Allows you to apply supported Line class members to a selected axis line.
public property LogBase (inherited from Axis) | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
public property Max (inherited from Axis) | Defines the maximum value of a specific axis.
public property MinorStep (inherited from Axis) | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
public property Notify (inherited from Axis) | Used to enable or disable the GetAxisLabel event so you can customize labels on the specified axis.
public property Position (inherited from Axis) | Specifies the placement of the axis labels and tick marks relative to the chart.
public property ScaleUnit (inherited from Axis) | Returns or sets the scale unit of a selected axis.
public property Sections (inherited from Axis) | Returns a selected AxisSection object.
public property Staggered (inherited from Axis) | Alternates the level of the axis labels for the selected axis labels.
public property Step (inherited from Axis) | Specifies the interval of major tick marks and gridlines on the selected axis.
public property Style (inherited from Axis) | Allows you to add additional styles to the selected axis.
public property TextColor (inherited from AxisSectionBase) | Gets or Sets the color for text of a selected BaseAxisSection object.
public property Title (inherited from Axis) | Gets or sets the title for a specific axis.
public property Visible (inherited from Axis) | Shows or hides the lines, labels, tick marks and grids for the selected axis.


BorderAttributes class

Provides access to the BorderAttributes object.

For a list of all members of this type, see BorderAttributes Members

ChartFX.ReportingServices.BorderAttributes

Remarks

The members of the BorderAttributes class allow customization of the border for Points and Series.

Color, Effect, Style, Width, etc., are some of the configurable attributes for Borders.

The border is the line around the point marker. The following example shows a chart with the Series borders set to a width of 3 and Red color:

The folowing image shows the same settings applied to a Area chart:


BorderAttributes Class Members

BorderAttributes Members

BorderAttributes Overview

Public Properties

public property Color | Gets or Sets the color of the border of a point marker.
public property Effect | Gets or Sets a BorderEffect for point marker border.
public property Style | Gets or Sets a DashStyle for the point marker border
public property Visible | Gets or Sets a value making the border visible or not.
public property Width | Gets or Sets a value setting the width in pixels.


Color property of BorderAttributes class

BorderAttributes.Color Property

Gets or Sets the color of the border of a point marker.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

BorderAttributes

See Also

BorderAttributes Class | BorderAttributes Members | Style Property | Effect Property | Width Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Effect property of BorderAttributes class

BorderAttributes.Effect Property

Gets or Sets a BorderEffect for point marker border.

[Visual Basic]
Public Property Effect As BorderEffect[C#]
public BorderEffect Effect {get;set;}

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • The following image shows the BorderEffect.Shadow applied to a chart:

Applies to

BorderAttributes

See Also

BorderAttributes Class | BorderAttributes Members | Style Property | Color Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Style property of BorderAttributes class

BorderAttributes.Style Property

Gets or Sets a DashStyle for the point marker border

[Visual Basic]
Public Property Style As DashStyle[C#]
public DashStyle Style {get;set;}

Remarks

  • For more information, see the DashStyle documentation in the .NET Framework .

Applies to

BorderAttributes

See Also

BorderAttributes Class | BorderAttributes Members | Effect Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Visible property of BorderAttributes class

BorderAttributes.Visible Property

Gets or Sets a value making the border visible or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Point markers Borders are Visible by default.

Applies to

BorderAttributes

See Also

BorderAttributes Class | BorderAttributes Members | Color Property | Effect Property | Style Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Width property of BorderAttributes class

BorderAttributes.Width Property

Gets or Sets a value setting the width in pixels.

[Visual Basic]
Public Property Width As Int16[C#]
public Int16 Width {get;set;}

Remarks

  • This property allows you to configure the width of point markers border.

Applies to

BorderAttributes

See Also

BorderAttributes Class | BorderAttributes Members | Color Property | Style Property | Effect Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Condition class

Provides access to the Condition object.

For a list of all members of this type, see Condition Members

ChartFX.ReportingServices.Condition

Remarks

The supported members of the Condition class allow you to customize the conditions for a ConditionalAttributes. This includes the range for a data value to meet the requirements for the ConditionalAttribute, if the ConditionalAttribute will be active, etc.


Condition Class Members

Condition Members

Condition Overview

Public Properties

public property Active | Gets or Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.
public property DataElement | Gets or sets the data value that the specified ConditionalAttribute will evaluate.
public property From | Gets or Sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object.
public property FromOpen | Gets or Sets a value indicating whether or not to include the configured From value in the range.
public property Inverse | Gets or Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.
public property To | Gets or Sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object.
public property ToOpen | Gets or Sets a value indicating whether or not to include the configured To value in the range.


Active property of Condition class

Condition.Active Property

Gets or Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.

[Visual Basic]
Public Property Active As Boolean[C#]
public Boolean Active {get;set;}

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

Applies to

Condition

See Also

Condition Class | Condition Members | From Property | FromOpen Property | To Property | ToOpen Property | Inverse Property | DataElement Property | Evaluate Method | ConditionalAttributes Class


DataElement property of Condition class

Condition.DataElement Property

Gets or sets the data value that the specified ConditionalAttribute will evaluate.

[Visual Basic]
Public Property DataElement As DataElement[C#]
public DataElement DataElement {get;set;}

Remarks

  • By default, the YValue for the chart is evaluated for a condition. You can use this property to select to evaluate the IniValue or XValue for each point contained in the chart.

  • Use the Active property to specify if a selected ConditionalAttributes object may be applied to a chart.

  • The To property is used to specify the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property indicates whether or not to include the configured To value in the range.

  • The From property is used to specify the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property indicates whether or not to include the configured From value in the range.

  • Use the Inverse property to reverse the configured To and From attributes and create the opposite condition configured.

Applies to

Condition

See Also

Condition Class | Condition Members | Active Property | From Property | FromOpen Property | To Property | ToOpen Property | Inverse Property | Evaluate Method | ConditionalAttributes Class


From property of Condition class

Condition.From Property

Gets or Sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object.

[Visual Basic]
Public Property From As Double[C#]
public Double From {get;set;}

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Applies to

Condition

See Also

Condition Class | Condition Members | FromOpen Property | To Property | ToOpen Property | Inverse Property | DataElement Property | Evaluate Method | ConditionalAttributes Class


FromOpen property of Condition class

Condition.FromOpen Property

Gets or Sets a value indicating whether or not to include the configured From value in the range.

[Visual Basic]
Public Property FromOpen As Boolean[C#]
public Boolean FromOpen {get;set;}

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Applies to

Condition

See Also

Condition Class | Condition Members | From Property | To Property | ToOpen Property | DataElement Property | Inverse Property | Evaluate Method | ConditionalAttributes Class


Inverse property of Condition class

Condition.Inverse Property

Gets or Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

[Visual Basic]
Public Property Inverse As Boolean[C#]
public Boolean Inverse {get;set;}

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Applies to

Condition

See Also

Condition Class | Condition Members | Active Property | DataElement Property | To Property | ToOpen Property | From Property | FromOpen Property | Evaluate Method | ConditionalAttributes Class


To property of Condition class

Condition.To Property

Gets or Sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object.

[Visual Basic]
Public Property To As Double[C#]
public Double To {get;set;}

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Applies to

Condition

See Also

Condition Class | Condition Members | From Property | FromOpen Property | ToOpen Property | Inverse Property | DataElement Property | Evaluate Method | ConditionalAttributes Class


ToOpen property of Condition class

Condition.ToOpen Property

Gets or Sets a value indicating whether or not to include the configured To value in the range.

[Visual Basic]
Public Property ToOpen As Boolean[C#]
public Boolean ToOpen {get;set;}

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Evaluate method returns a boolean indicating whether or not the configured condition is met for a specified value.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Applies to

Condition

See Also

Condition Class | Condition Members | From Property | FromOpen Property | To Property | Inverse Property | DataElement Property | Evaluate Method | ConditionalAttributes Class


ConditionalAttributes class

The members of the ConditionalAttributes class allow developers to control when special attributes should be applied to the chart and what chart elements will be taken into consideration when they are applied.

For a list of all members of this type, see ConditionalAttributes Members

ChartFX.ReportingServices.PointAttributes
ChartFX.ReportingServices.ConditionalAttributes

Remarks

The members of the ConditionalAttributes class allow developers to control when special attributes should be applied to the chart and what chart elements will be taken into consideration when they are applied.

Once the class has been configured with the desired attributes, the object may be assigned to a chart's point, based on the configured conditions. The value of each point in the chart is evaluated based on the conditions of each ConditionalAttributes item. Points that meet the conditions of a particular conditional attribute item will be retain the settings of that item. For more information regarding the configuration of the conditions, please see the Condition class.

The conditional attributes must be defined before the Chart is populated.


ConditionalAttributes Class Members

ConditionalAttributes Members

ConditionalAttributes Overview

Public Properties

public property AlternateColor (inherited from PointAttributes) | Gets or Sets the alternate color for a selected item when using gradient FillMode.
public property BarShape (inherited from PointAttributes) | Gets or Sets the Shape for the Bars.
public property Border (inherited from PointAttributes) | Provides access to the border attributes object.
public property Color (inherited from PointAttributes) | Allows you to set a color for the selected item.
public property Condition | Returns a Condition object for the specified ConditionalAttributes object.
public property FillMode (inherited from PointAttributes) | Gets or Sets a value indicating how Chart FX should fill the area representing the point.
public property Line (inherited from PointAttributes) | Gets the LineAttributes object for the particular point.
public property MarkerShape (inherited from PointAttributes) | Gets or Sets the the type used to paint markers for the selected item.
public property MarkerSize (inherited from PointAttributes) | Gets or Sets a value controlling the size of the markers for the selected item.
public property Pattern (inherited from PointAttributes) | Gets or Sets a value specifying the pattern for the selected item.
public property PointLabels (inherited from PointAttributes) | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
public property Series | Gets or Sets a value indicating which series index the ConditionalAttribute will be applied.
public property Text (inherited from PointAttributes) | Gets or Sets a value for labeling the point or series attribute.
public property Volume (inherited from PointAttributes) | Gets or Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


AlternateColor property of PointAttributes class

PointAttributes.AlternateColor Property

Gets or Sets the alternate color for a selected item when using gradient FillMode.

[Visual Basic]
Public Property AlternateColor As Color[C#]
public Color AlternateColor {get;set;}

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

    chart1.FillMode= FillMode.Gradient;

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the second series color is a gradient using two different colors:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | Color Property | Palette (Chart) Property | FillMode Property | SeriesAttributes Class | GlobalAttributes Class


BarShape property of PointAttributes class

PointAttributes.BarShape Property

Gets or Sets the Shape for the Bars.

[Visual Basic]
Public Property BarShape As BarShape[C#]
public BarShape BarShape {get;set;}

Remarks

  • This property applies when chart.Gallery is set to Bar.

  • Below, the second series barshape is set to cone:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members


Border property of PointAttributes class

PointAttributes.Border Property

Provides access to the border attributes object.

[Visual Basic]
Public ReadOnly Property Border As BorderAttributes[C#]
public BorderAttributes Border {get;}

Remarks

  • The members of the BorderAttributes class allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

  • The following code, which set the Border color for all series to red,

    chart1.AllSeries.Border.Color = Color.Red;

    will produce the following chart:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | Line Property | Series Class | PointAttributes Class


Color property of PointAttributes class

PointAttributes.Color Property

Allows you to set a color for the selected item.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • If no colors are specified, the default color is automatically selected by Chart FX when you create the chart, and chosen according to the current palette and its position in the series array.

  • For more information regarding the Color type, please refer to your .NET Framework documentation.

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | AlternateColor Property | Color (Border) Property | Palette (Chart) Property | SeriesAttributes Class


Condition property of ConditionalAttributes class

ConditionalAttributes.Condition Property

Returns a Condition object for the specified ConditionalAttributes object.

[Visual Basic]
Public ReadOnly Property Condition As Condition[C#]
public Condition Condition {get;}

Remarks

  • You may use this object to manipulate the conditions in which the ConditionalAttribute applies.

Applies to

ConditionalAttributes

See Also

ConditionalAttributes Class | ConditionalAttributes Members | Condition Class


FillMode property of PointAttributes class

PointAttributes.FillMode Property

Gets or Sets a value indicating how Chart FX should fill the area representing the point.

[Visual Basic]
Public Property FillMode As FillMode[C#]
public FillMode FillMode {get;set;}

Remarks

  • The default value is FillMode.Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • The Chart FX patternbar uses colored patterns that are suitable for the screen but when they are printed, they are defined as 8x8 pixels and therefore they will not be visible when printing with high resolution printer (i.e. 600 dpi). The ForceColors property in the printer object uses hatched patterns to print the charts.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

  • Below, the second series fillmode is set to pattern:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | Pattern Property | Color Property | AlternateColor Property | Chart Class | SeriesAttributes Class | GlobalAttributes Class


Line property of PointAttributes class

PointAttributes.Line Property

Gets the LineAttributes object for the particular point.

[Visual Basic]
Public ReadOnly Property Line As LineAttributes[C#]
public LineAttributes Line {get;}

Remarks

  • The LineAttributes members allows customization of the lines at the GlobalAttributes, SeriesAttributes and PointAttributes level.

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

  • Below, the second series line width is set to 4:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | LineAttributes Class | GlobalAttributes Class | SeriesAttributes Class


MarkerShape property of PointAttributes class

PointAttributes.MarkerShape Property

Gets or Sets the the type used to paint markers for the selected item.

[Visual Basic]
Public Property MarkerShape As MarkerShape[C#]
public MarkerShape MarkerShape {get;set;}

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

  • Below, the second series marker shape is set to triangle:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | MarkerSize Property | Gallery (Chart) Property | Picture Property | Chart Class | SeriesAttributes Class


MarkerSize property of PointAttributes class

PointAttributes.MarkerSize Property

Gets or Sets a value controlling the size of the markers for the selected item.

[Visual Basic]
Public Property MarkerSize As Int16[C#]
public Int16 MarkerSize {get;set;}

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

  • Below, the second series marker size is set to 4:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | MarkerShape Property | Picture Property | Chart Class | Series Class


Pattern property of PointAttributes class

PointAttributes.Pattern Property

Gets or Sets a value specifying the pattern for the selected item.

[Visual Basic]
Public Property Pattern As HatchStyle[C#]
public HatchStyle Pattern {get;set;}

Remarks

  • To use this property, you must make sure the chart FillMode is set to either B&W or colored patterns.

  • If the chart's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • Below, the second series pattern is set to cross:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | FillMode Property | Color Property | AlternateColor Property | Series Class | Chart Class


PointLabels property of PointAttributes class

PointAttributes.PointLabels Property

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

[Visual Basic]
Public ReadOnly Property PointLabels As PointLabelAttributes[C#]
public PointLabelAttributes PointLabels {get;}

Remarks

  • The PointAttributes members allows customization of the Point labels at the GlobalAttributes, SeriesAttributes and PointAttributes level.

  • Below, the second series point labels is set to visible:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | PointLabelAttributes Class


Series property of ConditionalAttributes class

ConditionalAttributes.Series Property

Gets or Sets a value indicating which series index the ConditionalAttribute will be applied.

[Visual Basic]
Public Property Series As Int32[C#]
public Int32 Series {get;set;}

Remarks

  • By default, ConditionalAttributes are applied to all series in the chart. To reset a ConditionalAttribute to be applied to all series, set the Series property to -1.

  • The Condition property is used to obtain the Condition object for a selected ConditionalAttribute. Using this object you may configure the conditions for the ConditionalAttributes object.

Applies to

ConditionalAttributes

See Also

ConditionalAttributes Class | ConditionalAttributes Members | Condition Property | Condition Class


Text property of PointAttributes class

PointAttributes.Text Property

Gets or Sets a value for labeling the point or series attribute.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

  • For SeriesAttibutes and ConditionalAttributes, Text will be used to asign a string for the Legend.

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | ToolTips Property | PointLabels Property | Legend Property | SeriesAttributes Class | ConditionalAttributes Class


Volume property of PointAttributes class

PointAttributes.Volume Property

Gets or Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

[Visual Basic]
Public Property Volume As Int16[C#]
public Int16 Volume {get;set;}

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

  • If you want to control the Volume property for all the series in the chart (i.e. apply the same volume setting to all of them) you can use the chart class AllSeries property.

  • Below, the first point Volume is set to 100 and the second point Volume is set to 40:

Applies to

PointAttributes

See Also

PointAttributes Class | PointAttributes Members | Gallery(Chart) Property | Gallery(Series) Property | Chart Class | Series Class


DataGrid class

Provides access to the DataGrid object, that is a component which displays the data in a tabular format.

For a list of all members of this type, see DataGrid Members

ChartFX.ReportingServices.DockableBar
ChartFX.ReportingServices.DataGrid

Remarks

Chart FX provides a spreadsheet called DataGrid, that allows users to see the data contained in the chart in tabular format.

The DataGrid can be controled separately from the Chart, allowing docking styles and independent Visual Attributes.


DataGrid Class Members

DataGrid Members

DataGrid Overview

Public Properties

public property BackColor (inherited from DockableBar) | Gets or Sets a value for the background color of a dockable bar.
public property BackColorData | Sets the background color of the cells on the data grid.
public property BackColorDataAlternate | Assigns the alternate color for displaying the DataGrid rows or columns.
public property BackColorHeader | Sets the background color of the header for the Data Editor.
public property Border (inherited from DockableBar) | Allows the developer to specify the border style.
public property ContentLayout | Allows you to align the data editor in the bottom of the chart area.
public property Dock (inherited from DockableBar) | Sets the position of the data grid.
public property HorizontalGridColor | Allows you to set the Horizontal color for the gridlines displayed in the data grid.
public property Interlaced | Alternates the background color of on the data grid to improve readability.
public property ReadOnly | Permits values to be changed through the data grid.
public property ShowHeader | Gets or Sets a value indicating the header of the columns should be visible or not.
public property ShowHiddenSeries | Gets or Sets a value indicating hidden series should be visible in data editor.
public property ShowMarkers | Gets or Sets a value indicating if serie markers should be visible in the serie headers.
public property TextColorData | Sets the text color of the cells on the data grid.
public property TextColorDataAlternate | Sets the alternate text color for text in the data grid cells.
public property TextColorHeader | Gets or Sets the text color of the headers on the data editor.
public property VerticalGridColor | Allows you to select the Vertical line color for the gridline displayed at the data editor box.
public property Visible (inherited from DockableBar) | Gets or Sets a value indicating the Dockablebar object should be shown or not.


BackColor property of DockableBar class

DockableBar.BackColor Property

Gets or Sets a value for the background color of a dockable bar.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

DockableBar

See Also

DockableBar Class | DockableBar Members | Border Property | Width Property | Height Property | Dock Property


BackColorData property of DataGrid class

DataGrid.BackColorData Property

Sets the background color of the cells on the data grid.

[Visual Basic]
Public Property BackColorData As Color[C#]
public Color BackColorData {get;set;}

Remarks

  • You need to have the data grid visible in order to see the changes made with BackColorData property. Use Visible property to enable the data grid.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the data grid backcolordata is set to MintCream:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColorDataAlternate Property | BackColor (DockableBar) Property | BackColorHeader Property | TextColorData Property | TextColorHeader Property | Interlaced Property


BackColorDataAlternate property of DataGrid class

DataGrid.BackColorDataAlternate Property

Assigns the alternate color for displaying the DataGrid rows or columns.

[Visual Basic]
Public Property BackColorDataAlternate As Color[C#]
public Color BackColorDataAlternate {get;set;}

Remarks

  • When viewing and interpreting DataGrids with muliple points or series, sometimes it is difficult to distinguish one row from another or one column from the other. With this prorperty you can specify the alternating color for the DataGrid.

  • You should specify the direction of the alternating colors by using the Interlaced property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColorHeader Property | BackColor (DockableBar) Property | BackColorData Property | Axis Class


BackColorHeader property of DataGrid class

DataGrid.BackColorHeader Property

Sets the background color of the header for the Data Editor.

[Visual Basic]
Public Property BackColorHeader As Color[C#]
public Color BackColorHeader {get;set;}

Remarks

  • You need to have the data editor visible in order to see the changes made with BackColorHeader property. Use Visible property to enable the dataGrid.

  • You can set the dataGird background and data editor cells background with BackColor and BackColorData property, respectively.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the data grid backcolorheader is set to DarkGreen:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColor (DockableBar) Property | BackColorData Property | TextColorData Property | TextColorHeader Property | Chart Class | LegendBox Class


Border property of DockableBar class

DockableBar.Border Property

Allows the developer to specify the border style.

[Visual Basic]
Public Property Border As Border[C#]
public Border Border {get;set;}

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Applies to

DockableBar

See Also

DockableBar Class | DockableBar Members | Border (Chart) Property | Dock Property


ContentLayout property of DataGrid class

DataGrid.ContentLayout Property

Allows you to align the data editor in the bottom of the chart area.

[Visual Basic]
Public Property ContentLayout As ContentLayout[C#]
public ContentLayout ContentLayout {get;set;}

Remarks

  • The Visible property needs to be true to see the effects of this property.

  • Note, when the DataGrid is docked on the left or right:

    Near = Top

    Far = Bottom

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | Height Property | Visible Property | Width Property | Dock Property | DockableBar Class


Dock property of DockableBar class

DockableBar.Dock Property

Sets the position of the data grid.

[Visual Basic]
Public Property Dock As DockArea[C#]
public DockArea Dock {get;set;}

Remarks

  • All tools in Chart FX are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, Chart FX will calculate the appropriate width and height.

Applies to

DockableBar

See Also

DockableBar Class | DockableBar Members | AutoSize Property | Width Property | Height Property


HorizontalGridColor property of DataGrid class

DataGrid.HorizontalGridColor Property

Allows you to set the Horizontal color for the gridlines displayed in the data grid.

[Visual Basic]
Public Property HorizontalGridColor As Color[C#]
public Color HorizontalGridColor {get;set;}

Remarks

  • The data grid must be Visible in order to see the these changes.

  • You can set the Vertical line color of the data grid gridline with VerticalGridColor property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the data grid horizontal and vertical grid color is set to Black:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | VerticalGridColor Property | BackColor Property | BackColorHeader Property | TextColorData Property | TextColorHeader Property | Visible Property


Interlaced property of DataGrid class

DataGrid.Interlaced Property

Alternates the background color of on the data grid to improve readability.

[Visual Basic]
Public Property Interlaced As Interlaced[C#]
public Interlaced Interlaced {get;set;}

Remarks

  • If you want to alternate the color for every series, then use Interlaced.Horizontal. For alternating the color of the points, use Interlaced.Vertical.

    With only a few series and points it is easier to read without Interlaced.

  • Use the BackColorData and BackColorDataAlternate properties to set the colors for the Interlaced property.

  • Below, the data grid interlaced property is set to Interlaced.Horizontal:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColorData Property | BackColorDataAlternate Property


ReadOnly property of DataGrid class

DataGrid.ReadOnly Property

Permits values to be changed through the data grid.

[Visual Basic]
Public Property ReadOnly As Boolean[C#]
public Boolean ReadOnly {get;set;}

Remarks

  • To change a value, simply double click the cell you wish to change.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | AllowChanges (Chart) Property | DataChangedByUser (Chart) Property


ShowHeader property of DataGrid class

DataGrid.ShowHeader Property

Gets or Sets a value indicating the header of the columns should be visible or not.

[Visual Basic]
Public Property ShowHeader As Boolean[C#]
public Boolean ShowHeader {get;set;}

Remarks

  • The ShowMarkers property shows or hides the series indicator displayed on the side of the dataGirid.

  • You may modify the color of the header using the BackColorHeader property.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColorHeader Property | ShowMarkers Property


ShowHiddenSeries property of DataGrid class

DataGrid.ShowHiddenSeries Property

Gets or Sets a value indicating hidden series should be visible in data editor.

[Visual Basic]
Public Property ShowHiddenSeries As Boolean[C#]
public Boolean ShowHiddenSeries {get;set;}

Remarks

  • A series can be marked hidden by setting the Visible property of the SeriesAttributes class, however you may want to still show this series in the data grid using this property.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | Visible Property | DataGrid (Chart) Property


ShowMarkers property of DataGrid class

DataGrid.ShowMarkers Property

Gets or Sets a value indicating if serie markers should be visible in the serie headers.

[Visual Basic]
Public Property ShowMarkers As Boolean[C#]
public Boolean ShowMarkers {get;set;}

Remarks

  • When the marker is hidden, only text is shown to label the series.

  • The ShowHeader property may be used to show or hide the dataGrid header.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | ShowHeader Property


TextColorData property of DataGrid class

DataGrid.TextColorData Property

Sets the text color of the cells on the data grid.

[Visual Basic]
Public Property TextColorData As Color[C#]
public Color TextColorData {get;set;}

Remarks

  • This property does not change the color of the header text, you can set the header text color of the dataGrid with TextColorHeader property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColorData Property | BackColorDataAlternate Property | BackColorHeader Property | CellAttributes Class


TextColorDataAlternate property of DataGrid class

DataGrid.TextColorDataAlternate Property

Sets the alternate text color for text in the data grid cells.

[Visual Basic]
Public Property TextColorDataAlternate As Color[C#]
public Color TextColorDataAlternate {get;set;}

Remarks

  • This property is useful when the Interlaced property is used.

  • The initial color of the text in the dataGrid cells can be set using the TextColorData property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | TextColorData Property | BackColorDataAlternate Property


TextColorHeader property of DataGrid class

DataGrid.TextColorHeader Property

Gets or Sets the text color of the headers on the data editor.

[Visual Basic]
Public Property TextColorHeader As Color[C#]
public Color TextColorHeader {get;set;}

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use Visible property to enable the data editor.

  • You can set the other cells text color of the dataGird with TextColorData property.

  • You can change the color of a specific cell by using BackColor property

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the data grid header text color is set to White:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | BackColor Property | BackColorHeader Property | TextColorData Property | Chart Class | CellAttributes Class


VerticalGridColor property of DataGrid class

DataGrid.VerticalGridColor Property

Allows you to select the Vertical line color for the gridline displayed at the data editor box.

[Visual Basic]
Public Property VerticalGridColor As Color[C#]
public Color VerticalGridColor {get;set;}

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use Visible property to enable the data editor.

  • You can set the Horizontal line color of the data grid gridline with HorizontalGridColor property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the data grid horizontal and vertical grid color is set to Black:

Applies to

DataGrid

See Also

DataGrid Class | DataGrid Members | HorizontalGridColor Property | BackColor Property | BackColorHeader Property | TextColorData Property | TextColorHeader Property | Visible Property


Visible property of DockableBar class

DockableBar.Visible Property

Gets or Sets a value indicating the Dockablebar object should be shown or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Applies to

DockableBar

See Also

DockableBar Class | DockableBar Members | DataGrid (Chart) Property | ToolBar (Chart) Property | MenuBar (Chart) Property | LegendBox (Chart) Property | Chart Class


DataValues class

Provides access to the DataValues object which is the key component to pass data to the chart.

For a list of all members of this type, see DataValues Members

ChartFX.ReportingServices.DataValues

Remarks

You can also assign x-values to create an XY Plot using the X property.

You can set initial values using the YFrom property. Used in conjunction with the Y property, you can create a 'floating bars' effect for bar charts.

Many times charts contain a large amount of data whereby visualizing such data via a chart has little or no value. For example, you may have the number of sales per day for all 365 days of the year however seeing a trend from month to month is very difficult due to the busy and excess information in the chart. Instead you can use ChartFX Data Compacting feature to provide meaningful summarized data. For convenience, ChartFX provides predefined formulas for popular compacting schemes such as First, Last, Min, Max, and Average.

Please note that instead of the value associated with the point, you can assign a hidden constant which will cause the point to be hidden in the chart. Although a hidden point is physically in the data array, when you use this constant the marker will not appear in the chart, and if you have charts like a line or area chart, the line will break at that particular point.


DataValues Class Members

DataValues Members

DataValues Overview

Public Properties

public property CompactedBy | Gets or sets a value indicating the interval of units to compress data.
public property Points | Gets or Sets a value indicating the number of series allocated for the chart.
public property Series | Gets or Sets a value indicating the number of series allocated for the chart.


CompactedBy property of DataValues class

DataValues.CompactedBy Property

Gets or sets a value indicating the interval of units to compress data.

[Visual Basic]
Public Property CompactedBy As Double[C#]
public Double CompactedBy {get;set;}

Remarks

  • This property is used to configure the units for compression in the X Axis. If the XAxis has been passed DateTime XValues and has been formated for Date, the units represented by the CompactBy property would be Days. For example a value of 30 would be interperted into 1 Month. If you do not have configured XValues in the chart, then the unit base is 1 (categorical axis).

  • The UndoCompact method is used to decompress compacted data and show all values.

  • The Data property is used to access the DataValues object for a chart.

Applies to

DataValues

See Also

DataValues Class | DataValues Members | Compacted Property | Data Property | Compact Method | Chart Class


Points property of DataValues class

DataValues.Points Property

Gets or Sets a value indicating the number of series allocated for the chart.

[Visual Basic]
Public Property Points As Int32[C#]
public Int32 Points {get;set;}

Remarks

  • The Points and Series properties are usually set a design-time using the property dialog box for the Chart object. The only time these properties should be included in code is when you wish to read the number of series or points in a chart.

  • This property is normally used to get the number of data points per series available in the chart for administration purposes. For example, if you want to change the values of each data point in a series, you will need the number of available points per series to complete the For loop.

  • Below, the chart has 2 series and 5 points per series:

Applies to

DataValues

See Also

DataValues Class | DataValues Members | Series Property


Series property of DataValues class

DataValues.Series Property

Gets or Sets a value indicating the number of series allocated for the chart.

[Visual Basic]
Public Property Series As Int32[C#]
public Int32 Series {get;set;}

Remarks

  • The Points and Series properties are usually set a design-time using the property dialog box for the Chart object. The only time these properties should be included in code is when you wish to read the number of series or points in a chart.

  • This property is normally used to get the number of series available on the chart for administration purposes. For example, if you want to set a different color for each data series using the Color property, you will need the number of available data series to complete the For loop.

  • Below, the chart has five series and two points per series:

Applies to

DataValues

See Also

DataValues Class | DataValues Members | Points Property


DockableBar class

Provides access to the DockableBar object, which is the parent class of objects such as the LegendBox, the ToolBar, and the DataGrid.

For a list of all members of this type, see DockableBar Members

ChartFX.ReportingServices.DockableBar

Remarks

The background color may be modified using the BackColor property.

Using the Dock property, you can dock the bar in different areas of the chart.

You must make the bar visible in order to see any of the visual attributes configured using the properties of the class.

The border of the bar can the set by using a pre-defined object such as SimpleBorder, or ImageBorder using the property Border.

The following properties of the Chart return objects inheriting from DockableBar: LegendBox, ToolBar, MenuBar, and DataGrid.

Dragging the legend box (end user) is not supported but may be positioned in the chart area using the Dock property. Functionality has been added to the legends to enhance the appearance in a docked position (left, right, top or bottom). For example, you can include borders around a legend or leave them in the default compacted view. By modifying visual attributes, the legend box appears to be floating but it is attach to a logical position that will change as the chart size changes.


DockableBar Class Members

DockableBar Members

DockableBar Overview

Public Properties

public property BackColor | Gets or Sets a value for the background color of a dockable bar.
public property Border | Allows the developer to specify the border style.
public property Dock | Sets the position of the data grid.
public property Visible | Gets or Sets a value indicating the Dockablebar object should be shown or not.


GlobalAttributes class

Provides access to the GlobalAttributes object.

For a list of all members of this type, see GlobalAttributes Members

ChartFX.ReportingServices.PointAttributes
ChartFX.ReportingServices.SeriesAttributes
ChartFX.ReportingServices.GlobalAttributes

Remarks

The GobalAttributes class alows customization of visual attibutes that apply to all the Series and Points in a Chart.

Using the GobalAttributes members, you can set Gallery type, Colors, Markes shapes, Borders, etc.

GlobalAttibuttes are accesed through the AllSeries property of the Chart class.


GlobalAttributes Class Members

GlobalAttributes Members

GlobalAttributes Overview

Public Properties

public property BarShape (inherited from PointAttributes) | Gets or Sets the Shape for the Bars.
public property Border (inherited from PointAttributes) | Provides access to the border attributes object.
public property FillMode (inherited from PointAttributes) | Gets or Sets a value indicating how Chart FX should fill the area representing the point.
public property Gallery | Gets and sets the chart type for all Series.
public property Line (inherited from PointAttributes) | Gets the LineAttributes object for the particular point.
public property MarkerShape (inherited from PointAttributes) | Gets or Sets the the type used to paint markers for the selected item.
public property MarkerSize (inherited from PointAttributes) | Gets or Sets a value controlling the size of the markers for the selected item.
public property MarkerStep (inherited from SeriesAttributes) | Controls how frequently point markers are shown in the selected series.
public property MultipleColors | Gets and sets the Multiple colors to allow for independently colored data points.
public property PointLabels (inherited from PointAttributes) | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
public property Stacked | Gets or sets the Stacked style in the chart.
public property Volume (inherited from PointAttributes) | Gets or Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


Gallery property of GlobalAttributes class

GlobalAttributes.Gallery Property

Gets and sets the chart type for all Series.

[Visual Basic]
Public Property Gallery As Gallery[C#]
public Gallery Gallery {get;set;}

Remarks

  • When you set the gallery with this property it applies to all the series in the chart. If you want to create a Multitype (or combination chart) please refer to the Series object Gallery property.

  • When selecting a Gallery for charts, keep in mind the number of data series which will be included in the chart. Pie, Pyramid and Doughnut chart types can only display one series per chart. If you have multiple data series, you may want to select a Gallery type that supports one that one series.

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Applies to

GlobalAttributes

See Also

GlobalAttributes Class | GlobalAttributes Members | Gallery (Series) Property | GalleryAttributes Property | AllSeries Property | Series Class | Pie Class | Radar Class | Bubble Class | Surface Class | Curve Class


MarkerStep property of SeriesAttributes class

SeriesAttributes.MarkerStep Property

Controls how frequently point markers are shown in the selected series.

[Visual Basic]
Public Property MarkerStep As Int16[C#]
public Int16 MarkerStep {get;set;}

Remarks

  • This property is very useful when the chart contains a large number of points and the point markers disturb the chart's readability. For example, if you are showing 100 points in a line chart, the physical separation (pixels) of them is very small and probably the point markers will make the chart unreadable to the end user. In this case, you can set this property to force Chart FX to show point markers every 20 points.

  • Point markers will not be shown in 3D line charts.

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | MarkerFont Property | Chart Class


MultipleColors property of GlobalAttributes class

GlobalAttributes.MultipleColors Property

Gets and sets the Multiple colors to allow for independently colored data points.

[Visual Basic]
Public Property MultipleColors As Boolean[C#]
public Boolean MultipleColors {get;set;}

Remarks

  • When set to True all data points on a series will have a unique color. When set to False all the data points in the series will assume the same color.

  • When MultipleColors is set to True and the LegendBox has been set to Visible, the Legend will show the Axis X Labels.

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

  • You can assign specific colors to specific points by utilizing the Color property of the PointAttributes class.

Applies to

GlobalAttributes

See Also

GlobalAttributes Class | GlobalAttributes Members | Color Property | LegendBox (Chart) Property | AllSeries (Chart) Property | Chart Class | PointAttributes Class


Stacked property of GlobalAttributes class

GlobalAttributes.Stacked Property

Gets or sets the Stacked style in the chart.

[Visual Basic]
Public Property Stacked As Stacked[C#]
public Stacked Stacked {get;set;}

Remarks

  • This property applies to BAR or AREA charts only.

  • This property applies the stacked style to all series in the chart. Chart FX also support multistacked charts where you can stack series by pairs. For more information, please refer to the Stacked property in the series object.

  • Below is a chart using the Stacked100 enumeration to stack the chart:

Applies to

GlobalAttributes

See Also

GlobalAttributes Class | GlobalAttributes Members | Stacked Property | AllSeries Property | Series Class | Chart Class


GridLine class

Provides access to the GridLine object.

For a list of all members of this type, see GridLine Members

ChartFX.ReportingServices.Line
ChartFX.ReportingServices.GridLine

Remarks

GridLines are used to place lines across the Axes, at the major and minor intervals.

Mayor GridLines will show the lines at the step. Minor Gridlines will show line at the MinorStep.


GridLine Class Members

GridLine Members

GridLine Overview

Public Properties

public property Color (inherited from Line) | Sets or Gets the line color for a selected line.
public property EndCap (inherited from Line) | Gets or Sets a marker shape at the ending of a selected line.
public property StartCap (inherited from Line) | Gets or Sets a marker shape at the beginning of a selected line.
public property Style (inherited from Line) | Gets or Sets the line style for a selected line.
public property TickMark | Gets or sets the style for the tick marks of an GridLine object.
public property Visible | Gets or sets a value indicating whether the grid line for the selected Gridline will be visible.
public property Width (inherited from Line) | Gets or Sets the line width for a selected line.


Color property of Line class

Line.Color Property

Sets or Gets the line color for a selected line.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line class.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the X axis line color is set to red:

Applies to

Line

See Also

Line Class | Line Members | EndCap Property | StartCap Property | Style Property | Width Property | AxisY Property | AxisX Property | Chart Class | Axis Class | GridLine Class


EndCap property of Line class

Line.EndCap Property

Gets or Sets a marker shape at the ending of a selected line.

[Visual Basic]
Public Property EndCap As LineCap[C#]
public LineCap EndCap {get;set;}

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line class.

  • Below, the X axis line endcap is set to RoundAnchor:

Applies to

Line

See Also

Line Class | Line Members | StartCap Property | Color Property | Style Property | Width Property | AxisX Property | AxisY Property | Chart Class | Axis Class | GridLine Class


StartCap property of Line class

Line.StartCap Property

Gets or Sets a marker shape at the beginning of a selected line.

[Visual Basic]
Public Property StartCap As LineCap[C#]
public LineCap StartCap {get;set;}

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line class.

  • Below, the X axis line startcap is set to RoundAnchor:

Applies to

Line

See Also

Line Class | Line Members | EndCap Property | Color Property | Style Property | Width Property | AxisX Property | AxisY Property | Chart Class | Axis Class | GridLine Class


Style property of Line class

Line.Style Property

Gets or Sets the line style for a selected line.

[Visual Basic]
Public Property Style As DashStyle[C#]
public DashStyle Style {get;set;}

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line class.

  • The image below depicts a 'Dot' Line style assigned to the Y axis:

  • For more information regarding the Drawing type, please refer to the .NET Framework Documentation.

Applies to

Line

See Also

Line Class | Line Members | EndCap Property | StartCap Property | Color Property | Width Property | AxisY Property | AxisX Property | Chart Class | Axis Class | GridLine Class


TickMark property of GridLine class

GridLine.TickMark Property

Gets or sets the style for the tick marks of an GridLine object.

[Visual Basic]
Public Property TickMark As TickMark[C#]
public TickMark TickMark {get;set;}

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the Grids property.

  • The major unit is controlled by the Step property, the minor unit is controled by the MinorStep property.

Applies to

GridLine

See Also

GridLine Class | GridLine Members | Grids (AxisSectionBase) Property | Step (Axis) Property | MinorStep (Axis) Property | Axis Class | AxisSection Class | Grids Class


Visible property of GridLine class

GridLine.Visible Property

Gets or sets a value indicating whether the grid line for the selected Gridline will be visible.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Applies to

GridLine

See Also

GridLine Class | GridLine Members | Grids (AxisSectionBase) Property | Major (Grid) Property | Minor (Grids) Property | Axis Class | AxisSection Class | Grids Class


Width property of Line class

Line.Width Property

Gets or Sets the line width for a selected line.

[Visual Basic]
Public Property Width As Int32[C#]
public Int32 Width {get;set;}

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line class.

  • Below, the X axis line width is set to 3:

Applies to

Line

See Also

Line Class | Line Members | EndCap Property | StartCap Property | Style Property | Color Property | AxisY Property | AxisX Property | Chart Class | Axis Class | GridLine Class


Grids class

Provides acces to the Grids object.

For a list of all members of this type, see Grids Members

ChartFX.ReportingServices.Grids

Remarks

Provides access to the Grids class members.

The Grids class allows customization of the chart Plot Area, setting colors and alternate colors, mayor and minor gridlines, tickmarcks, custom gridlines, etc.


Grids Class Members

Grids Members

Grids Overview

Public Properties

public property Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
public property InterlacedColor | Gets or sets the AlternateColor for a selected Grids object.
public property Major | Provides access to the GridLine class to customize the Mayor Grid.
public property Minor | Provides access to the GridLine class to customize the Minor Grid.


Interlaced property of Grids class

Grids.Interlaced Property

Creates a grid of alternating colors for a selected axis to improve chart readability.

[Visual Basic]
Public Property Interlaced As Boolean[C#]
public Boolean Interlaced {get;set;}

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • Use the InterlacedColor andthe chart's PlotAreaColor properties to set the Interlaced colors.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

  • Here is an Interlaced grid on the Y axis:

Applies to

Grids

See Also

Grids Class | Grids Members | AxisX Property | AxisY Property | Grids Property | Interlaced (DataGrid) Property | PlotAreaColor Property | Chart Class | DataGrid Class


InterlacedColor property of Grids class

Grids.InterlacedColor Property

Gets or sets the AlternateColor for a selected Grids object.

[Visual Basic]
Public Property InterlacedColor As Color[C#]
public Color InterlacedColor {get;set;}

Remarks

  • The AlternateColor is used when the selected axis is configured as Interlaced. The other color is defined by the configured PlotAreaColor.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Here is an example of an Interlaced Y axis with Inteterleaced color and Plotaread Color:

Applies to

Grids

See Also

Grids Class | Grids Members | Interlaced Property | AxisX Class | AxisY Class


Major property of Grids class

Grids.Major Property

Provides access to the GridLine class to customize the Mayor Grid.

[Visual Basic]
Public ReadOnly Property Major As GridLine[C#]
public GridLine Major {get;}

Remarks

  • The Major interval is controlled by the Axis Step Property.

  • Major Gridlines are Visible by default.

  • Please see the GridLine class for the supported members exposed by this property.

Applies to

Grids

See Also

Grids Class | Grids Members | Minor Property | Step (Axis) Property | Axis Class | Gridline Class


Minor property of Grids class

Grids.Minor Property

Provides access to the GridLine class to customize the Minor Grid.

[Visual Basic]
Public ReadOnly Property Minor As GridLine[C#]
public GridLine Minor {get;}

Remarks

  • The minor interval is controlled by the MinorStep Property, which must be set in order to use the Minor Grid.

  • Please see the GridLine class for the supported members exposed by this property.

  • Below is a sample showing a the Minor Grid (LightBlue) when the MinorStep was set to 1.5:

Applies to

Grids

See Also

Grids Class | Grids Members | Major Property | MinorStep (Axis) Property | Axis Class | GridLine Class


LegendBox class

Provides access to the customization of the legend box of the chart.

For a list of all members of this type, see LegendBox Members

ChartFX.ReportingServices.DockableBar
ChartFX.ReportingServices.LegendBox

Remarks

A legend box is a tool within a chart that contains relevant information to explain what is being depicted in a chart.

The LegendBox can show legends from Series, KeyLabels, Conditional Attributes, Custom Gridlines, etc.

You must make the legend box visible in order to see any of the visual attributes configured using the properties of the class.

The legend box inherites from DockableBar. Therefore, some visual properties of the legend box can be accessed using the properties implemented by DockableBar.


LegendBox Class Members

LegendBox Members

LegendBox Overview

Public Properties

public property BackColor (inherited from DockableBar) | Gets or Sets a value for the background color of a dockable bar.
public property Border (inherited from DockableBar) | Allows the developer to specify the border style.
public property ContentLayout | Allows you to align the content for the legend box.
public property Dock (inherited from DockableBar) | Sets the position of the data grid.
public property PlotAreaOnly | Allows the legend box margins to go outside of the chart's drawing area.
public property TextColor | Gets or Sets the color used for the text in the legend box.
public property Titles | Returns or sets a title object for the legend box.
public property Visible (inherited from DockableBar) | Gets or Sets a value indicating the Dockablebar object should be shown or not.


ContentLayout property of LegendBox class

LegendBox.ContentLayout Property

Allows you to align the content for the legend box.

[Visual Basic]
Public Property ContentLayout As ContentLayout[C#]
public ContentLayout ContentLayout {get;set;}

Remarks

  • When the Leyend box is doked at the lefy or right of the Chart, Near means Top, and Far means Bottom.

  • The following images shows a Legend Box aligned Near:

Applies to

LegendBox

See Also

LegendBox Class | LegendBox Members | AutoSize Property | Dock Property


PlotAreaOnly property of LegendBox class

LegendBox.PlotAreaOnly Property

Allows the legend box margins to go outside of the chart's drawing area.

[Visual Basic]
Public Property PlotAreaOnly As Boolean[C#]
public Boolean PlotAreaOnly {get;set;}

Remarks

  • If there is enough space and the legend is centered (default), there will be no noticeable difference when this property is configured. The difference is visible when there are many legend values, the drawing area is too small, the opposite gaps (e.g. top and bottom) are different or the legend is not centered.

  • By default the legends are drawn inside the chart drawing area, for example when the legend box is at the right, the first legend will be at the top of the chart area, it will not use the margin on top. If you set PlotAreaOnly to false, the margins will also be available for the legend.

Applies to

LegendBox

See Also

LegendBox Class | LegendBox Members | ContentLayout Property


TextColor property of LegendBox class

LegendBox.TextColor Property

Gets or Sets the color used for the text in the legend box.

[Visual Basic]
Public Property TextColor As Color[C#]
public Color TextColor {get;set;}

Remarks

  • Before you can see the text color assignments, the selected legend box must be visible.

  • You can assign the text for the values legend box using the Labels or Text properties.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

LegendBox

See Also

LegendBox Class | LegendBox Members | Labels (Axis) Property | Axis Class | Chart Class | Title Class


Titles property of LegendBox class

LegendBox.Titles Property

Returns or sets a title object for the legend box.

[Visual Basic]
Public ReadOnly Property Titles As TitleCollection[C#]
public TitleCollection Titles {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index for the selected legend box.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

  • The TextColor property may be used to get or set the color of the title text; the Font Property can be used to configure a new font object for the title.

Applies to

LegendBox

See Also

LegendBox Class | LegendBox Members | TextColor (Title) Property | Font (Title) Property | Axis Class | TitleDockable Class


Line class

Provides access to the Line object.

For a list of all members of this type, see Line Members

ChartFX.ReportingServices.Line

Remarks

Using these properties you can set the color, width and style of many line objects including Axis, GridLine and CustomGridLine.

Members also allow for shapes to be applied to all the supported line objects. This allows for interesting design ideas such as an Axis representing a thermometer.


Line Class Members

Line Members

Line Overview

Public Properties

public property Color | Sets or Gets the line color for a selected line.
public property EndCap | Gets or Sets a marker shape at the ending of a selected line.
public property StartCap | Gets or Sets a marker shape at the beginning of a selected line.
public property Style | Gets or Sets the line style for a selected line.
public property Width | Gets or Sets the line width for a selected line.


Pane class

Provides access to the Pane object.

For a list of all members of this type, see Pane Members

ChartFX.ReportingServices.Pane

Remarks

The Panes feature of Chart FX allows the developer to display multiple panes of data in a single chart window. This data analysis feature allows developers to separate or combine several series allowing for improved analysis experience. This could be used for many applications, the most obvious being to improve readability by simplifing the display of a chart.

In the chart above, three series are each assigned to in individual pane. As you can see, each pane as several attributes unique per pane instance, such as the InsideBackObject, InsideColor, Proportion, Separation and Title. Also observe how each of the panes has an independent axis.

The first indexed pane of the collection is referred to the main pane of the chart. It can be accessed by the MainPane property of the Chart class.


Pane Class Members

Pane Members

Pane Overview

Public Properties

public property AxisY | Provides access to the members of the main Y Axis for the selected Pane.
public property BackColor | Gets or sets the inside color for the selected pane.
public property Proportion | Gets or sets a value indicating the proportional size of the selected pane.
public property Separation | Gets or sets a value indicating the space in between panes.
public property Title | Gets the Title object for a selected chart pane.
public property Visible | Gets or Sets a value indicating the Pane object should be shown or not.


AxisY property of Pane class

Pane.AxisY Property

Provides access to the members of the main Y Axis for the selected Pane.

[Visual Basic]
Public ReadOnly Property AxisY As AxisY[C#]
public AxisY AxisY {get;}

Remarks

  • This property is a shortcut to the Pane's main AxisY.

  • To access any other Pane's Y axes, i.e. Secondary Y axis, you the Axes property.

  • When using Panes, the AxisY for the first Pane can be also accessed directly from the Chart object:

    chart1.Pane[0].AxisY.Title = "Chart Title";

    is equivalent to

    chart1.AxisY.Title = "Chart Title";

  • Below, the second pane Y axis title is set to "Y Axis (Second Pane)":

Applies to

Pane

See Also

Pane Class | Pane Members | Axes Property | AxisY Class


BackColor property of Pane class

Pane.BackColor Property

Gets or sets the inside color for the selected pane.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • For more information regarding the Color type, please refer to your .NET Framework documentation.

  • For gradient background, see the Background.

  • Below, the second pane back color is set to dark blue:

Applies to

Pane

See Also

Pane Class | Pane Members | Background Property | Chart Class | AxisY Class


Proportion property of Pane class

Pane.Proportion Property

Gets or sets a value indicating the proportional size of the selected pane.

[Visual Basic]
Public Property Proportion As Double[C#]
public Double Proportion {get;set;}

Remarks

  • This property accepts an integer that specifies the "proportional" size of a selected pane. For Example, If you set this property to the value of 2 for a selected pane, that pane's height would be twice the size of any default pane's size. The default pane size will depend on the number of panes visible in the chart as well as the dimensions of the chart object itself.

  • Below, the second pane proportion is set to 3:

Applies to

Pane

See Also

Pane Class | Pane Members | Background Property | BackColor Property | Separation Property | Title Property | Chart Class | AxisY Class


Separation property of Pane class

Pane.Separation Property

Gets or sets a value indicating the space in between panes.

[Visual Basic]
Public Property Separation As Int32[C#]
public Int32 Separation {get;set;}

Remarks

  • This property is useful when multiple panes are configured and you need to create space for readability.

  • Below, the second pane separation is set to 60:

Applies to

Pane

See Also

Pane Class | Pane Members | Chart Class | AxisY Class


Title property of Pane class

Pane.Title Property

Gets the Title object for a selected chart pane.

[Visual Basic]
Public Property Title As Title[C#]
public Title Title {get;set;}

Remarks

  • This property returns a Title object. Accessing the title class members you will be able to control attributes such as: Alignment, Color, Font,Text, etc.

  • Each pane may only have one title.

  • Below, the second pane title is set to "Second Pane":

Applies to

Pane

See Also

Pane Class | Pane Members | Separation Property | Title Class | TitleDockable Class | Chart Class | AxisY Class


Visible property of Pane class

Pane.Visible Property

Gets or Sets a value indicating the Pane object should be shown or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Hiding a Pane object will hide all the series associated to that pane, not only from the chart area but also from the Legend and the DataGrid. The hidden series objects will remain accessible but invisible.

  • Hiding a Pane object does not destroy or lose previous settings assigned by other properties.

Applies to

Pane

See Also

Pane Class | Pane Members


PersonalizeAttributes class

Provides access to the PersonalizeAttributes object, which allows to access the personalization features of ChartFX.

For a list of all members of this type, see PersonalizeAttributes Members

ChartFX.ReportingServices.PersonalizeAttributes

Remarks

Many users require and demand information on an individual basis. Using personalized charts allows users to change visual attributes and have those settings saved locally. When the user accesses the chart in the future, the saved settings can be automatically loaded so the users can view a chart configured to their personal preferences.

When using the personalized features for Chart FX, the users attribute changes must be saved locally on their computer. The Name property allows you to create unique or uniform names for your charts so the personalized settings can be loaded or saved.


PersonalizeAttributes Class Members

PersonalizeAttributes Members

PersonalizeAttributes Overview

Public Properties

public property AutoLoad | Allow you to enable or disable the automatic loading of the chart personalization. When AutoLoad is set to True, the personalized features are automatically loaded when the chart is created.
public property AutoSave | Gets or Sets a value indicating to enable or disable the automatic saving of the chart attributes. When AutoSave is set to True, the personalized features are automatically saved when the chart is destroyed.
public property Enabled | Allow you to enable the Personalize Attributes.
public property EnableRestore | Allow you to enable the restoration of the chart. When the user makes the first visual change to the chart through the UI, the original chart is saved in memory if EnableRestore is set to True.
public property Name | Allows you to set the personalization name of the chart.


AutoLoad property of PersonalizeAttributes class

PersonalizeAttributes.AutoLoad Property

Allow you to enable or disable the automatic loading of the chart personalization. When AutoLoad is set to True, the personalized features are automatically loaded when the chart is created.

[Visual Basic]
Public Property AutoLoad As Boolean[C#]
public Boolean AutoLoad {get;set;}

Remarks

  • When AutoLoad is set to True, Chart FX will look for a saved transformation file in the user's local Isolated Storage before the chart is rendered. If found, the settings will be applied to the chart. This functions as if the user selected the "Load My Chart" option in the Personalization toolbar options. By default this option is disabled.

  • The AutoSave property gets or sets a value indicating to enable or disable the automatic saving of the chart attributes. When AutoSave is set to True, the personalized features are automatically saved when the chart is destroyed.

  • The EnableRestore property allows you to enable restoration of the chart. When the user makes the first visual change to the chart through the UI, the original chart is saved in memory if EnableRestore is set to True.

  • The CanRestore property returns True if the original chart can be restored. By default, returns False but it will return True as soon as the end-user modifies any attribute of the chart or a saved chart is loaded.

  • The Personalize property returns the PersonalizeAttributes object of a chart.

Applies to

PersonalizeAttributes

See Also

PersonalizeAttributes Class | PersonalizeAttributes Members | AutoSave Property | EnableRestore Property | CanRestore Property | Personalize Property | Load Method | Chart Class


AutoSave property of PersonalizeAttributes class

PersonalizeAttributes.AutoSave Property

Gets or Sets a value indicating to enable or disable the automatic saving of the chart attributes. When AutoSave is set to True, the personalized features are automatically saved when the chart is destroyed.

[Visual Basic]
Public Property AutoSave As Boolean[C#]
public Boolean AutoSave {get;set;}

Remarks

  • Any transformations made to the chart will be automatically saved to the Isolated Storage when the chart is destroyed (the browser is refreshed or closed, or another page is invoked). By default this option is disabled.

  • The AutoLoad property gets or sets a value indicating to enable or disable the automatic loading of the chart personalization. When AutoLoad is set to True, the personalized features are automatically loaded when the chart is created.

  • The EnableRestore property allows you to enable restoration of the chart. When the user makes the first visual change to the chart through the UI, the original chart is saved in memory if EnableRestore is set to True.

  • The CanRestore property returns True if the original chart can be restored. By default, returns False but it will return True as soon as the end-user modifies any attribute of the chart or a saved chart is loaded.

  • The Personalize property returns the PersonalizeAttributes object of a chart.

Applies to

PersonalizeAttributes

See Also

PersonalizeAttributes Class | PersonalizeAttributes Members | AutoLoad Property | EnableRestore Property | CanRestore Property | Personalize Property | Save Method | Chart Class


Enabled property of PersonalizeAttributes class

PersonalizeAttributes.Enabled Property

Allow you to enable the Personalize Attributes.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • The AutoLoad property gets or sets a value indicating to enable or disable the automatic loading of the chart personalization. When AutoLoad is set to True, the personalized features are automatically loaded when the chart is created.

  • The AutoSave property gets or sets a value indicating to enable or disable the automatic saving of the chart attributes. When AutoSave is set to True, the personalized features are automatically saved when the chart is destroyed.

  • The CanRestore property returns True if the original chart can be restored. By default, returns False but it will return True as soon as the end-user modifies any attribute of the chart or a saved chart is loaded.

  • The EnableRestore property allows you to enable restoration of the chart. When the user makes the first visual change to the chart through the UI, the original chart is saved in memory if EnableRestore is set to True.

  • The Personalize property returns the PersonalizeAttributes object of a chart.

Applies to

PersonalizeAttributes

See Also

PersonalizeAttributes Class | PersonalizeAttributes Members


EnableRestore property of PersonalizeAttributes class

PersonalizeAttributes.EnableRestore Property

Allow you to enable the restoration of the chart. When the user makes the first visual change to the chart through the UI, the original chart is saved in memory if EnableRestore is set to True.

[Visual Basic]
Public Property EnableRestore As Boolean[C#]
public Boolean EnableRestore {get;set;}

Remarks

  • The CanRestore property returns True if the original chart can be restored. By default, returns False but it will return True as soon as the end-user modifies any attribute of the chart or a saved chart is loaded.

  • The RestoreDefault property clears all the transformations made by the end-user and resets the chart to the default personalization settings.

  • The Personalize property returns the PersonalizeAttributes object of a chart, which the CanRestore member is available.

Applies to

PersonalizeAttributes

See Also

PersonalizeAttributes Class | PersonalizeAttributes Members | CanRestore Property | Personalize Property | RestoreDefault Method | Chart Class


Name property of PersonalizeAttributes class

PersonalizeAttributes.Name Property

Allows you to set the personalization name of the chart.

[Visual Basic]
Public Property Name As String[C#]
public String Name {get;set;}

Remarks

  • When using the personalized features for Chart FX, the users attribute changes must be saved locally on their computer. The Name property allows you to create unique or uniform names for your charts so the personalized settings can be loaded or saved.

Applies to

PersonalizeAttributes

See Also

PersonalizeAttributes Class | PersonalizeAttributes Members | Load Method | Save Method


PointAttributes class

Provides access to the PointAttributes object.

For a list of all members of this type, see PointAttributes Members

ChartFX.ReportingServices.PointAttributes

Remarks

The goal of any chart is to provide a clear visual representation of data that can be easily read and interpreted by the user. To this end, ChartFX enables you to set PointLabels to clearly mark and identify the values on the chart. This is particularly useful when there are many data points and many series, which could appear busy and difficult to decipher.

Chart FX offer enhanced functionality and versatility. You are able to control the size, color, font etc. of every individual point label in your chart. This is extremely useful for highlighting critical points of data in a chart.


PointAttributes Class Members

PointAttributes Members

PointAttributes Overview

Public Properties

public property AlternateColor | Gets or Sets the alternate color for a selected item when using gradient FillMode.
public property BarShape | Gets or Sets the Shape for the Bars.
public property Border | Provides access to the border attributes object.
public property Color | Allows you to set a color for the selected item.
public property FillMode | Gets or Sets a value indicating how Chart FX should fill the area representing the point.
public property Line | Gets the LineAttributes object for the particular point.
public property MarkerShape | Gets or Sets the the type used to paint markers for the selected item.
public property MarkerSize | Gets or Sets a value controlling the size of the markers for the selected item.
public property Pattern | Gets or Sets a value specifying the pattern for the selected item.
public property PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
public property Text | Gets or Sets a value for labeling the point or series attribute.
public property Volume | Gets or Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


PointLabelAttributes class

Provides access to the PointAttributes object, which allows you to configure how the labelling is rendered by ChartFX.

For a list of all members of this type, see PointLabelAttributes Members

ChartFX.ReportingServices.PointLabelAttributes

Remarks

Unless defined otherwise, all the point labels of the chart share the same settings. Those global settings are available through the PointLabels property of the GlobalAttributes. The GlobalAttributes class is accessible through the AllSeries property of the chart.


PointLabelAttributes Class Members

PointLabelAttributes Members

PointLabelAttributes Overview

Public Properties

public property Alignment | Gets or Sets the vertical alignment for the point label.
public property Angle | Gets or Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
public property BackColor | Gets or Sets the backgrond color of the point label.
public property BorderColor | Gets or Sets the border color of the point label.
public property BorderWidth | Gets or Sets a value indicating the width of the border surrounding the point label.
public property Font | Gets or Sets a Font object to use as rendering font for the point label.
public property LineAlignment | Gets or Sets the horizontal alignment for the point label.
public property TextColor | Gets or Sets a value for the point label color.
public property Visible | Gets or Sets a value indicating if point label should be displayed or not.


Alignment property of PointLabelAttributes class

PointLabelAttributes.Alignment Property

Gets or Sets the vertical alignment for the point label.

[Visual Basic]
Public Property Alignment As StringAlignment[C#]
public StringAlignment Alignment {get;set;}

Remarks

  • For more information on StringAlignment see the .NET Framework documentation.

  • Bellow, the aligment of the point labels is set to near:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Angle Property | Font Property | Format Property | Offset Property | LineAlignment Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Angle property of PointLabelAttributes class

PointLabelAttributes.Angle Property

Gets or Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

[Visual Basic]
Public Property Angle As Int16[C#]
public Int16 Angle {get;set;}

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • When generating charts using .NET Compact Framework, the angles "0" and "90" are the only supported configurations.

  • In order to set this property, the font type associated with the axis needs to be a True Type Font.

  • This property is also available in the SeriesAttributes or PointAttributes objects. Therefore, a label angle can be set to a specific series or point instead of all series in the chart.

  • To use this property, you must make sure the PointLabels are visible.

  • Bellow, the angle of the point labels is set to 45:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Font Property | Alignment Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


BackColor property of PointLabelAttributes class

PointLabelAttributes.BackColor Property

Gets or Sets the backgrond color of the point label.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • The PointLabels property of the PointAttributes class returns a PointLabelsAttributes object.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • For more information regarding the Color type, please refer to your .NET Framework documentation.

  • Bellow, the Back color of the point labels is set to red:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | BorderColor Property | BorderWidth Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


BorderColor property of PointLabelAttributes class

PointLabelAttributes.BorderColor Property

Gets or Sets the border color of the point label.

[Visual Basic]
Public Property BorderColor As Color[C#]
public Color BorderColor {get;set;}

Remarks

  • The PointLabels property of the PointAttributes class returns a PointLabelsAttributes object.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • For more information regarding the Color type, please refer to your .NET Framework documentation.

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | BackColor Property | BorderWidth Property | Alignment Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


BorderWidth property of PointLabelAttributes class

PointLabelAttributes.BorderWidth Property

Gets or Sets a value indicating the width of the border surrounding the point label.

[Visual Basic]
Public Property BorderWidth As Int16[C#]
public Int16 BorderWidth {get;set;}

Remarks

  • The PointLabels property of the PointAttributes class returns a PointLabelsAttributes object.

  • The BorderColor property gets or sets the border color of the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | BorderColor Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


Font property of PointLabelAttributes class

PointLabelAttributes.Font Property

Gets or Sets a Font object to use as rendering font for the point label.

[Visual Basic]
Public Property Font As Font[C#]
public Font Font {get;set;}

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired chart element every time.

  • See the Font class in .NET Framework

  • Bellow, the font of the point labels is set to Arial 12:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Chart.Font Property | Format Property | SeriesAttributes Class | PointAttributes Class | GlobalAttributes Class


LineAlignment property of PointLabelAttributes class

PointLabelAttributes.LineAlignment Property

Gets or Sets the horizontal alignment for the point label.

[Visual Basic]
Public Property LineAlignment As StringAlignment[C#]
public StringAlignment LineAlignment {get;set;}

Remarks

  • For more information on StringAlignment see the .NET Framework documentation.

  • Bellow, the line alignment of the point labels is set to far:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Angle Property | Font Property | Format Property | Offset Property | Alignment Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


TextColor property of PointLabelAttributes class

PointLabelAttributes.TextColor Property

Gets or Sets a value for the point label color.

[Visual Basic]
Public Property TextColor As Color[C#]
public Color TextColor {get;set;}

Remarks

  • It is recommended to use a light color when the inside color of the chart is dark (and, vice versa).

  • See Color class in .NET Framework

  • Bellow, the text color of the point labels is set to red:

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Font Property | BackColor Property | BorderColor Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


Visible property of PointLabelAttributes class

PointLabelAttributes.Visible Property

Gets or Sets a value indicating if point label should be displayed or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • The PointLabels property of the PointAttributes class returns a PointLabelsAttributes object.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

Applies to

PointLabelAttributes

See Also

PointLabelAttributes Class | PointLabelAttributes Members | Angle Property | Alignment Property | PointAttributes Class | SeriesAttributes Class | GlobalAttributes Class


SeriesAttributes class

Provides access to the SeriesAttributes object.

For a list of all members of this type, see SeriesAttributes Members

ChartFX.ReportingServices.PointAttributes
ChartFX.ReportingServices.SeriesAttributes

Remarks

The chart series are represented by groups of data points. For example if you want to plot yearly sales for two different products. Product A and Product B are called the series of the chart. For example, if you create a bar chart, two groups of bars will appear, a group of bars will represent each product and each bar will represent actual sales for a particular month, as depicted in the following figure:

The series object allows you to set everything related to the series of the chart, including data, legends and visual attributes like colors, chart types and border styles among others.

What's important about the series object is that you can use properties available in this object to set specific settings to individual series in the chart without affecting the other ones. For example, if you want to create a combination (multitype) chart, where Product A is plotted as line with data labels and Product B is displayed as bars with no borders, you can access each series properties using the series object and obtain the following chart:


SeriesAttributes Class Members

SeriesAttributes Members

SeriesAttributes Overview

Public Properties

public property AlternateColor (inherited from PointAttributes) | Gets or Sets the alternate color for a selected item when using gradient FillMode.
public property AxisY | Gets or Sets a value indicating the AxisY the series is connected to.
public property BarShape (inherited from PointAttributes) | Gets or Sets the Shape for the Bars.
public property Border (inherited from PointAttributes) | Provides access to the border attributes object.
public property Color | Gets or Sets a Color for the selected series.
public property FillMode (inherited from PointAttributes) | Gets or Sets a value indicating how Chart FX should fill the area representing the point.
public property Gallery | Gets or Sets a gallery type for a particular series. All chart types are available in both 2D and 3D modes.
public property Line (inherited from PointAttributes) | Gets the LineAttributes object for the particular point.
public property MarkerShape (inherited from PointAttributes) | Gets or Sets the the type used to paint markers for the selected item.
public property MarkerSize (inherited from PointAttributes) | Gets or Sets a value controlling the size of the markers for the selected item.
public property MarkerStep | Controls how frequently point markers are shown in the selected series.
public property Pane | Gets or Sets the Pane which the series belongs to.
public property Pattern (inherited from PointAttributes) | Gets or Sets a value specifying the pattern for the selected item.
public property PointLabels (inherited from PointAttributes) | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
public property Stacked | Gets or Sets a value allowing you to stack the selected series with the previous series to achieve multi-stacked charts.
public property Text (inherited from PointAttributes) | Gets or Sets a value for labeling the point or series attribute.
public property Visible | Gets or Sets a value allowing you to show or hide the series.
public property Volume (inherited from PointAttributes) | Gets or Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


AxisY property of SeriesAttributes class

SeriesAttributes.AxisY Property

Gets or Sets a value indicating the AxisY the series is connected to.

[Visual Basic]
Public Property AxisY As AxisY[C#]
public AxisY AxisY {get;set;}

Remarks

  • The AxesY property is used to access the AxisYCollection for a chart. The AxisY property is used to assign a data series to one of the existing AxisY items in the AxisYCollection.

  • The AxisX property gets or sets a value indicating the AxisX the series is connected to.

  • Here is an example of a chart with a secondary Y Axis. Each series is connected to a different YAxis:

    Also notice interesting options such as axis TextColor to help axis affiliation.

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | AxisX Property | AxesY Property | TextColor (AxisSectionBase) Property | Axis Class | AxisX Class | Chart Class


Color property of SeriesAttributes class

SeriesAttributes.Color Property

Gets or Sets a Color for the selected series.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • If no colors are specified, The default color is automatically selected by Chart FX when you create the chart, and chosen according to the current palette and its position in the series array.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | BackColor Property | Palette Property | Chart Class


Gallery property of SeriesAttributes class

SeriesAttributes.Gallery Property

Gets or Sets a gallery type for a particular series. All chart types are available in both 2D and 3D modes.

[Visual Basic]
Public Property Gallery As Gallery[C#]
public Gallery Gallery {get;set;}

Remarks

  • Applying this property to a specific series will create a MultiType chart, where different Chart Types can be combined in the same chart.

    You must be careful of the chart types you select to combine as not all of them will produce desirable results. For example, combining a chart that does not have numerical axis (e.g. Pie Chart) with a chart that has a numerical axis (e.g. Line Chart) will produce a chart that can't be read by the end user.

    A rule of thumb is that you can combine axis charts with similar types and non-axis charts with similar types, as follows:

    Axis Charts:

    Lines, Bar, Curve, Scatter, Area, Step, HiLowClose, Cube, Bubble, CandleStick, CurveArea, OpenHiLowClose, Pareto.

    Non-axis charts:

    Pie, Radar, DoughNut, Pyramid

    Note: Gantt, Surface and Contour can't be combined with other chart types

  • Another important issue to keep in mind when creating MultiType charts is the number of series each chart type requires to properly plot the data. For example, an Open-Hi-Lo-Close chart requires 4 consecutive series to properly plot the data, so if you want to combine this chart type with a line chart, the series containing the data for the line chart must be either the first or the last series in the data set.

  • Pocket Chart FX for .NET Compact Framework supports a subset of the gallery types supported by the full version of Chart FX.

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | Gallery Property | Chart Class | Bubble Class | Curve Class | Pie Class | Radar Class | Surface Class


Pane property of SeriesAttributes class

SeriesAttributes.Pane Property

Gets or Sets the Pane which the series belongs to.

[Visual Basic]
Public Property Pane As Pane[C#]
public Pane Pane {get;set;}

Remarks

  • Once a series is assigned to a pane, this pane will be visible.

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | Pane Class


Stacked property of SeriesAttributes class

SeriesAttributes.Stacked Property

Gets or Sets a value allowing you to stack the selected series with the previous series to achieve multi-stacked charts.

[Visual Basic]
Public Property Stacked As Boolean[C#]
public Boolean Stacked {get;set;}

Remarks

  • Stacked options apply only to Bar and Area charts. So before applying this property, you must make sure the previous series and the selected series are of the same type (Bar or Area).

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | Stacked Property | Chart Class


Visible property of SeriesAttributes class

SeriesAttributes.Visible Property

Gets or Sets a value allowing you to show or hide the series.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Hiding an Series will:

    - not recalculate any of the scale values for the axis.

    - not remove the data associated with it.

    - hide the legend associated with it from the Series Legend.

    - hide all the data points in the DataGrid

  • You can also display hidden series in the DataEditor using the ShowHiddenSeries of the DataGrid class

Applies to

SeriesAttributes

See Also

SeriesAttributes Class | SeriesAttributes Members | RecalculateScale (Chart) Method | PointAttributes Class


Title class

Provides access to the Title object, and allows the customization of the axis titles as well as the titles of the chart.

For a list of all members of this type, see Title Members

ChartFX.ReportingServices.Title

Remarks

A title is a string that can be assigned to any portion outside the main chart area. Chart FX supports the creation of many titles through the Titles property in the Chart class.

Titles are also avaliable for Axis.

Titles can be positioned, aligned and formated according to the different properties supported by this class and the TitleDockable class.

Titles can be assigned via the Chart FX designer properties list or you can create and control them programmatically.


Title Class Members

Title Members

Title Overview

Public Properties

public property Alignment | Allows you to set the alignment of the specified title.
public property BackColor | Gets or sets the color background of the specified title.
public property Font | Assigns a font to the specified title.
public property Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
public property LineAlignment | Gets or sets the vertical alignment for the lines of the chart title.
public property Link | Gets the Link object for a selected title item.
public property RichText | Sets or Get the RichText property for the selected Title.
public property Separation | Specify the space in pixels above and below the selected title text when read from right to left.
public property Text | Gets or sets the text for the selected title.
public property TextColor | Sets the color of text for the specified title.


Alignment property of Title class

Title.Alignment Property

Allows you to set the alignment of the specified title.

[Visual Basic]
Public Property Alignment As StringAlignment[C#]
public StringAlignment Alignment {get;set;}

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right. For information regarding the StringAlignment type refer to .NET Framework .

  • The Alignment property may also be used for Axis Title by utilizing the Axis class.

  • The LineAlignment property can be used to position the top title vertically in the title area.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Applies to

Title

See Also

Title Class | Title Members | LineAlignment (TitleDockable) Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class | TitleDockable Class


BackColor property of Title class

Title.BackColor Property

Gets or sets the color background of the specified title.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • See .NET Framework documentation for information regarding the Color type.

  • Below, the background title of the chart is set to yellow:

Applies to

Title

See Also

Title Class | Title Members | TextColor Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class


Font property of Title class

Title.Font Property

Assigns a font to the specified title.

[Visual Basic]
Public Property Font As Font[C#]
public Font Font {get;set;}

Remarks

  • You can set the font for the entire chart using the Chart object Font property.

  • When setting a font in Chart FX, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the .NET Framework Documentation.

  • Below, the title of the chart is rendered using an Arial font of size 12:

Applies to

Title

See Also

Title Class | Title Members | Text Property | Font (Chart) Property | Title (Axis) Property | Titles (Chart) Property | Chart Class | Axis Class


Indentation property of Title class

Title.Indentation Property

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

[Visual Basic]
Public Property Indentation As Int32[C#]
public Int32 Indentation {get;set;}

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Applies to

Title

See Also

Title Class | Title Members | PlotAreaMargin (Chart) Property | Separation Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class | Margings Class


LineAlignment property of Title class

Title.LineAlignment Property

Gets or sets the vertical alignment for the lines of the chart title.

[Visual Basic]
Public Property LineAlignment As StringAlignment[C#]
public StringAlignment LineAlignment {get;set;}

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

  • The Alignment property allows you set the title left, center or right justified in the chart.

Applies to

Title

See Also

Title Class | Title Members | Alignment Property | Titles (Chart) Property | Axis Class | Chart Class


Link property of Title class

Title.Link Property

Gets the Link object for a selected title item.

[Visual Basic]
Public ReadOnly Property Link As Link[C#]
public Link Link {get;}

Remarks

  • Developers may obtain the Link object for a title item using this property. Using the supported Link class members, developers may configure a Url and Target for the object.

Applies to

Title

See Also

Title Class | Title Members | Url Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class


RichText property of Title class

Title.RichText Property

Sets or Get the RichText property for the selected Title.

[Visual Basic]
Public Property RichText As Boolean[C#]
public Boolean RichText {get;set;}

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

  • Below, the chart uses a title with the word "Sales" bold and underlined:

Applies to

Title

See Also

Title Class | Title Members | Text Property | Font Property | TextColor Property | Title (Axis) Property | Titles (Chart) Property | Chart Class | Axis Class


Separation property of Title class

Title.Separation Property

Specify the space in pixels above and below the selected title text when read from right to left.

[Visual Basic]
Public Property Separation As Int32[C#]
public Int32 Separation {get;set;}

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Applies to

Title

See Also

Title Class | Title Members | Indentation Property | Text Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class


Text property of Title class

Title.Text Property

Gets or sets the text for the selected title.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Applies to

Title

See Also

Title Class | Title Members | TextColor Property | BackColor Property | Title (Axis) Property | Titles (Chart) Property | RichText Property | Chart Class | Axis Class


TextColor property of Title class

Title.TextColor Property

Sets the color of text for the specified title.

[Visual Basic]
Public Property TextColor As Color[C#]
public Color TextColor {get;set;}

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Below, the title of the chart is set to red:

Applies to

Title

See Also

Title Class | Title Members | Text Property | BackColor Property | Title (Axis) Property | Titles (Chart) Property | Axis Class | Chart Class


ValueFormat class

Provides access to the ValueFormat object.

For a list of all members of this type, see ValueFormat Members

ChartFX.ReportingServices.ValueFormat

Remarks

The ValueFormat members allow you to format values as numbers, dates, currency, scientific and time. These properties may be applied to axis labels (using the LabelsFormat property of the Axis class), and point labels (using the DataFormat of the Axis class).


ValueFormat Class Members

ValueFormat Members

ValueFormat Overview

Public Properties

public property CustomFormat | Gets or sets a custom format to the selected label, mouseover tip or value.
public property Decimals | Gets or sets the number of decimals for the selected label, mouseover tip or value.
public property Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


CustomFormat property of ValueFormat class

ValueFormat.CustomFormat Property

Gets or sets a custom format to the selected label, mouseover tip or value.

[Visual Basic]
Public Property CustomFormat As String[C#]
public String CustomFormat {get;set;}

Remarks

  • This property must be invoked before data has been bound or passed to the chart using the DataSource or Data properties of the Chart respectivelly.

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check .NET Framework documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Below, the labels of the X axis display the name of the month as well as the year:

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members | DataFormat (Axis) Property | LabelsFormat (Axis) Property | Decimals Property | Culture Property | Axis Class | Chart Class


Decimals property of ValueFormat class

ValueFormat.Decimals Property

Gets or sets the number of decimals for the selected label, mouseover tip or value.

[Visual Basic]
Public Property Decimals As Int32[C#]
public Int32 Decimals {get;set;}

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • Below, the labels of the chart are rendered with only one decimal:

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members | DataFormat (Axis) Property | LabelsFormat (Axis) Property | CustomFormat Property | Culture Property | Axis Class


Format property of ValueFormat class

ValueFormat.Format Property

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

[Visual Basic]
Public Property Format As AxisFormat[C#]
public AxisFormat Format {get;set;}

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Applies to

ValueFormat

See Also

ValueFormat Class | ValueFormat Members | DataFormat (Axis) Property | LabelsFormat (Axis) Property | Culture Property | Axis Class


SimpleBorder class

Provides access to the SimpleBorder object.

For a list of all members of this type, see SimpleBorder Members

ChartFX.ReportingServices.Adornments.SimpleBorder

Remarks

Use the SimpleBorder's properties to configure the Border of the Chart, as well as the Border of the DockableBars such as the DataGrid, the LegendBox, or the ToolBar.

The following image shows a red SimpleBorder with a "Bump" effect around the chart. The DataGrid's border is blue with a "Sunken" effect and the LegendBox is white with an "Embed" effect.

Please see the Type property for a complete list of the supported SimpleBorder types.

Important Note : To set the basic border of a chart in your applications, you must reference the Adormments assembly in your project.

If your looking for the graphical image borders, please refer to the ImageBorder class.


SimpleBorder Class Members

SimpleBorder Members

SimpleBorder Overview

Public Properties

public property Color | Sets the color of the border.
public property InternalOpposite | Sets the internal tool borders opposite of the configured default border when present.
public property Type | Gets or sets the type of the Simple border object.


Color property of SimpleBorder class

SimpleBorder.Color Property

Sets the color of the border.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • Not all SimpleBorders have a outlining border to use this property. If there is not a border, the color assignment will have no effect.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Here is an example of the "Raised" SimpleBorder with the border color turned to red:

Applies to

SimpleBorder

See Also

SimpleBorder Class | SimpleBorder Members | Border (Chart) Property | Border (DockableBar) Property | Type Property | Draw Method | Chart Class | DockableBar Class


InternalOpposite property of SimpleBorder class

SimpleBorder.InternalOpposite Property

Sets the internal tool borders opposite of the configured default border when present.

[Visual Basic]
Public Property InternalOpposite As Boolean[C#]
public Boolean InternalOpposite {get;set;}

Remarks

  • If a chart is using an internal border for a DockableBar object and the basic border is set to raised, setting this property to True will cause the internal border to be sunken.

  • Below, InternalOpposite is set to true when the MenuBar and the Chart share the same border:

    Similarly, InternalOpposite is set to false in the following screenshot:

Applies to

SimpleBorder

See Also

SimpleBorder Class | SimpleBorder Members | Border (Chart) Property | Border (DockableBar) Property | DockableBar Class | Chart Class


Type property of SimpleBorder class

SimpleBorder.Type Property

Gets or sets the type of the Simple border object.

[Visual Basic]
Public Property Type As BasicBorderType[C#]
public BasicBorderType Type {get;set;}

Remarks

  • Once you create the default border object, you may assign attributes to the object with the supported SimpleBorder properties.

Applies to

SimpleBorder

See Also

SimpleBorder Class | SimpleBorder Members | Color Property | InternalOpposite Property | Border (Chart) Property | Border (DockableBar) Property | Chart Class | DockableBar Class


GradientBackground class

Provides access to the GradientBackground object.

For a list of all members of this type, see GradientBackground Members

ChartFX.ReportingServices.Adornments.GradientBackground

Remarks

As opposed to marker gradients, background gradients are used for cosmetic purposes only. In other words, background gradients are only used to enhance the chart's visual appearance and have no direct relation to the data contained in the chart. When applied to the chart background, gradients can help you achieve a superior visual effect for your desktop and web applications.

In Chart FX, background gradients can be applied to two rectangular areas in the chart area: The chart's inside background (i.e., PlotAreaBackground) and the main background (i.e., Background). Chart FX allows horizontal, vertical, diagonal and radial gradients when applying gradient fills to either of these areas of the chart.

To set the gradient colors, you can use the Color, ColorFrom and ColorTo properties. When creating two color gradients, you can control the gradient brush using the Factor and Position properties. The Position property allows you to specify where each color will start and stop in a multicolor gradient background.

Creating the GradientBackground Object

In order to add a gradient background to your chart, you will need to create an instance of the GradientBackground object. Once an object has been created, you may assign the desired attributes to create the gradient. Below is a small example of creating the GradientBackground object and attribute assignment:

GradientBackground myGradient = new GradientBackground(GradientType.BACKWARD_DIAGONAL);
myGradient.setColor(0, java.awt.Color.red);
myGradient.setColor(1, java.awt.Color.blue);
myGradient.setPosition(0, 0);
myGradient.setPosition(1, 1);
chart1.setBackground(myGradient);

Important Note : To set the gradient background of a chart in your applications, you must reference the Adormments assembly in your project.


GradientBackground Class Members

GradientBackground Members

GradientBackground Overview

Public Properties

public property Angle | Sets the gradient angle when using the 'Angled' gradient background.
public property ColorFrom | Gets or sets the beginning color of a gradient.
public property ColorTo | Ending color of a gradient.
public property EffectArea | Gets or sets a value indicating the percentage of chart area affected by a GradientBackground.
public property Type | Sets the style of the gradient for a selected gradient background.


Angle property of GradientBackground class

GradientBackground.Angle Property

Sets the gradient angle when using the 'Angled' gradient background.

[Visual Basic]
Public Property Angle As Single[C#]
public Single Angle {get;set;}

Remarks

  • The Angle property supports values ranging from 0 to 360 degrees.

  • You must select the 'Angled' type gradient when creating the GradientBackground object in order for this property to take effect.

  • The first chart gradient has been set to 45 degrees:

    The second has been set to 120 degrees:

Applies to

GradientBackground

See Also

GradientBackground Class | GradientBackground Members | Color Property | Factor Property | Position Property | Background (Chart) Property | PlotAreaBackground (Chart) Property | Type Property | Chart Class


ColorFrom property of GradientBackground class

GradientBackground.ColorFrom Property

Gets or sets the beginning color of a gradient.

[Visual Basic]
Public Property ColorFrom As Color[C#]
public Color ColorFrom {get;set;}

Remarks

  • This property sets the beginning color of a gradient. You can also set the beginning color of the gradient by utilizing the Color property using index zero.

Applies to

GradientBackground

See Also

GradientBackground Class | GradientBackground Members | Color Property | ColorTo Property | Background (Chart) Property | PlotAreaBackground (Chart) Property | Chart Class


ColorTo property of GradientBackground class

GradientBackground.ColorTo Property

Ending color of a gradient.

[Visual Basic]
Public Property ColorTo As Color[C#]
public Color ColorTo {get;set;}

Remarks

  • This property sets the ending color of a gradient. You can also set the ending color of the gradient by setting the last index of the Color collection.

Applies to

GradientBackground

See Also

GradientBackground Class | GradientBackground Members | Color Property | ColorFrom Property | Background (Chart) Property | PlotAreaBackground (Chart) Property | Chart Class


EffectArea property of GradientBackground class

GradientBackground.EffectArea Property

Gets or sets a value indicating the percentage of chart area affected by a GradientBackground.

[Visual Basic]
Public Property EffectArea As Int32[C#]
public Int32 EffectArea {get;set;}

Remarks

  • This property may be configured to a value between 0 and 100. The default value is 20, indicating that 20 percent of the chart is affected by a gradient background.

  • Specifying 100 indicates the entire chart background should be configured with a GradientBackground.

Applies to

GradientBackground

See Also

GradientBackground Class | GradientBackground Members | Angle Property | Color Property | ColorFrom Property | ColorTo Property | Factor Property | Position Property | Type Property | Draw Method


Type property of GradientBackground class

GradientBackground.Type Property

Sets the style of the gradient for a selected gradient background.

[Visual Basic]
Public Property Type As GradientType[C#]
public GradientType Type {get;set;}

Remarks

  • When using the 'Angled' gradient enumeration, you can set the desired angle for the gradient using the Angle property.

  • Below is a gradient of type "BackwardDiagonal":

    Alternatively, this is a gradient of type "Radial":

    Finally, this is a gradient of type "Vertical":

Applies to

GradientBackground

See Also

GradientBackground Class | GradientBackground Members | Angle Property | Color Property | Background (Chart) Property | PlotAreaBackground (Chart) Property | Chart Class


ImageBackground class

Provides access to the ImageBackground object.

For a list of all members of this type, see ImageBackground Members

ChartFX.ReportingServices.Adornments.ImageBackground

Remarks

The ImageBackground class is used to set an image for the background of a chart. Developers may render an image either in the Background or in the PlotAreaBackground of the Chart.

In order to add a image background to your chart, you will need to create an instance of the ImageBackground class. Once an object has been created, you may assign the desired attributes to configure the image. such as Mode and BackColor. Below is a small example of creating the ImageBackground object:

ImageBackground ib = new ImageBackground();
ib.BackColor = Color.Red;
ib.Mode = ImageMode.Center;
ib.Image = System.Drawing.Image.FromFile(@"C:\Image.bmp");
Chart1.Background = ib;

Below is a chart where two images have been configured for the Background and the PlotAreaBackground:

Important Note : To set the image background of a chart in your applications, you must reference the Adormments assembly in your project.


ImageBackground Class Members

ImageBackground Members

ImageBackground Overview

Public Properties

public property BackColor | Gets or sets the background color when an ImageBackground object uses a picture with transparency.
public property Image | Gets or sets a image for the ImageBackground object.
public property Mode | Gets or sets the rendering style for the image used as the ImageBackground.


BackColor property of ImageBackground class

ImageBackground.BackColor Property

Gets or sets the background color when an ImageBackground object uses a picture with transparency.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Alternativelly, you can use the PlotAreaColor and BackColor properties of the Chart.

  • Below, the BackColor is set to Yellow:

Applies to

ImageBackground

See Also

ImageBackground Class | ImageBackground Members | Image Property | PlotAreaColor (Chart) Property | BackColor (Chart) Property | Mode Property | Chart Class


Image property of ImageBackground class

ImageBackground.Image Property

Gets or sets a image for the ImageBackground object.

[Visual Basic]
Public Property Image As Image[C#]
public Image Image {get;set;}

Remarks

  • To make the background image viewable, you may wish to configure the PlotAreaColor of the Chart to be transparent.

  • You may need to adjust the TextColor and Font within the Chart when using this property to make the chart readable.

  • For more information regarding the Image type, please refer to the .NET Framework Documentation.

  • An image has been set as the Background for the chart below:

Applies to

ImageBackground

See Also

ImageBackground Class | ImageBackground Members | PlotAreaColor (Chart) Property | TextColor (Axis) Property | Font (Chart) Property | Background (Chart) Property | PlotAreaBackground (Chart) Property | GradientBackground Class


Mode property of ImageBackground class

ImageBackground.Mode Property

Gets or sets the rendering style for the image used as the ImageBackground.

[Visual Basic]
Public Property Mode As ImageMode[C#]
public ImageMode Mode {get;set;}

Remarks

  • This property is used to set the style for the picture configured with the Image property.

  • Below is an ImageBackground with the "Watermark" mode and BackColor set to MediumAquamarine:

    Alternatively, this is an ImageBackground with the "Tile" mode:

    Finally, this is an ImageBackground with the "Center" mode and BackColor set to MediumAquamarine:

Applies to

ImageBackground

See Also

ImageBackground Class | ImageBackground Members | Image Property | BackColor Property


ImageBorder class

Provides access to the ImageBorder object.

For a list of all members of this type, see ImageBorder Members

ChartFX.ReportingServices.Adornments.ImageBorder

Remarks

When thinking about of all the features built into Chart FX geared to enhance the chart's presentation layer, none stand out more than Image Borders.

Image Borders add the graphic pizzazz required in today's desktop and internet application.

Use the ImageBorder's properties to configure the Border of the Chart, as well as the Border of the DockableBars such as the DataGrid, the LegendBox, or the ToolBar.

Important Note : To set the image border of a chart in your applications, you must reference the Adormments assembly in your project.

Please see the Type property for a complete list of the supported ImageBorder enumerations.

If your looking for the standard border designs, please refer to the BasicBorder class.


ImageBorder Class Members

ImageBorder Members

ImageBorder Overview

Public Properties

public property Color | Gets or sets the color of the border.
public property Type | Gets or sets the type for the image border.


Color property of ImageBorder class

ImageBorder.Color Property

Gets or sets the color of the border.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • Not all ImageBorders have a outlining border to use this property. If the border does not include a border, the setting will have no effect.

  • The Chart FX ImageBorders use shading to give a multidimensional effect. The PageColor property can be used to modify the background color of the shaded area around ImageBorders.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

  • Here is an example of the 'Colonial' ImageBorder with the border color turned to red:

Applies to

ImageBorder

See Also

ImageBorder Class | ImageBorder Members | Border (Chart) Property | Border (DockableBar) Property | Type Property | PageColor (Chart) Property | Chart Class | DockableBar Class


Type property of ImageBorder class

ImageBorder.Type Property

Gets or sets the type for the image border.

[Visual Basic]
Public Property Type As ImageBorderType[C#]
public ImageBorderType Type {get;set;}

Remarks

  • Once you create the image border object, you may assign attributes to the object with the supported ImageBorder properties.

Applies to

ImageBorder

See Also

ImageBorder Class | ImageBorder Members | Border (Chart) Property | Border (DockableBar) Property | Color Property | Chart Class | DockableBar Class | SimpleBorder Class


SolidBackground class

Provides access to the SolidBackground object.

For a list of all members of this type, see SolidBackground Members

ChartFX.ReportingServices.Adornments.SolidBackground

Remarks

The SolidBackground object allows to change the color to the chart backgrounds.

The Color can be changed for either the Chart's background area, or the Chart's plot area, by using the BackColor and PlotAreaColor properties.

The following image shows an Azure BackColor:

Important Note : To set the solid background of a chart in your applications, you must reference the Adormments assembly in your project.


SolidBackground Class Members

SolidBackground Members

SolidBackground Overview

Public Properties

public property Color Gets or sets the color of the background.


Color property of SolidBackground class

SolidBackground.Color Property

Gets or sets the color of the background.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • This property is used to set the color of the solid background in a chart. The Chart Background is the area behind the ploting area, and is set to Yellow in the sample:

  • It can also be used to set the color of the ploting area (i.e., PlotAreaBackground):

  • The Chart's BackColor and PlotAreaColor are shorcuts to this property, the following code:

    SolidBackground s = new SolidBackground();
    s.Color = Color.Azure;
    chart1.Background = s;
    would produce the same result as:

    chart1.BackColor = Color.Azure;

Applies to

SolidBackground

See Also

SolidBackground Class | SolidBackground Members | BackColor Property | PlotAreaColor Property | Draw Method | Chart Class


BarBorder class

Provides access to the BarBorder object.

For a list of all members of this type, see BarBorder Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.BarBorder

Remarks

The BarBorder object is the border object for a ScaleBar. A ScaleBar is the strip associated with a selected scale in a gauge. The supported members of the BarBorder object allow you to customize the display of the border for a ScaleBar.

The Bar property is used to obtain access to a ScaleBar object, and the Border property is used to obtain the BarBorder for a ScaleBar.


BarBorder Class Members

BarBorder Members

BarBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Thickness | Gets or sets the width for the BarBorder object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Color property of BaseColorable class

BaseColorable.Color Property

Gets or sets the color for a gauge element.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • For more information regarding the Color type, please refer to the .NET Framework documentation.

Applies to

BaseColorable

See Also

BaseColorable Class | BaseColorable Members


Thickness property of BarBorder class

BarBorder.Thickness Property

Gets or sets the width for the BarBorder object.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Remarks

  • The BarBorder is the outline around a ScaleBar. This property is used to configure the width of the bar's border.

  • The Border property of the ScaleBar class is used to access the BarBorder object for a scale.

Applies to

BarBorder

See Also

BarBorder Class | BarBorder Members | Border Property | ScaleBar Class


Visible property of BaseViewable class

BaseViewable.Visible Property

Gets or sets a value indicating whether an object is visible or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • When set the false, the object is not visible.

Applies to

BaseViewable

See Also

BaseViewable Class | BaseViewable Members | Gauge Class


BaseGauge class

Provides access to the BaseGauge object.

For a list of all members of this type, see BaseGauge Members

ChartFX.ReportingServices.Gauge.BaseGauge

Remarks

The BaseGauge class supports the common members for all types of gauge objects. Both the Gauge and DigitalPanel object derive from this class.

All other gauge types are derived from the Gauge or DigitalPanel objects.


BaseGauge Class Members

BaseGauge Members

BaseGauge Overview

Public Properties

public property Antialiasing | Gets or sets the smooth visual effect for a gauge.
public property Font | Gets or sets the font type which will be used by default in the gauge.
public property Images | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges | The collection of InnerGauges currently associated with the gauge.
public property Palette | Allows you to set a Chart FX pre-defined palette.
public property Titles | Returns the collection of titles defined in the gauge.


Antialiasing property of BaseGauge class

BaseGauge.Antialiasing Property

Gets or sets the smooth visual effect for a gauge.

[Visual Basic]
Public Property Antialiasing As AntialiasingModes[C#]
public AntialiasingModes Antialiasing {get;set;}

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members


Font property of BaseGauge class

BaseGauge.Font Property

Gets or sets the font type which will be used by default in the gauge.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • This Font property is used to configure the GaugeFont object for a gauge. Please see the GaugeF ont class for supported font members.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | GaugeFont Class


Images property of BaseGauge class

BaseGauge.Images Property

Returns the ImageAnnotationCollection for a gauge.

[Visual Basic]
Public ReadOnly Property Images As GaugeImageCollection[C#]
public GaugeImageCollection Images {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • This property returns an ImageAnnotationCollection object. You may also specifying an index value to access a specific ImageAnnotation item in the ImageAnnotationCollection. Please see the ImageAnnotation object for additional information.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | ImageAnnotation Class


InnerGauges property of BaseGauge class

BaseGauge.InnerGauges Property

The collection of InnerGauges currently associated with the gauge.

[Visual Basic]
Public ReadOnly Property InnerGauges As InnerGaugeCollection[C#]
public InnerGaugeCollection InnerGauges {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members


Palette property of BaseGauge class

BaseGauge.Palette Property

Allows you to set a Chart FX pre-defined palette.

[Visual Basic]
Public Property Palette As Palette[C#]
public Palette Palette {get;set;}

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as Chart FX will change the windows palette for the chart window. So if you previously set a color using any of the Chart FX supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | DigitalPanel Class | VerticalGauge Class | HorizontalGauge Class | RadialGauge Class


Titles property of BaseGauge class

BaseGauge.Titles Property

Returns the collection of titles defined in the gauge.

[Visual Basic]
Public ReadOnly Property Titles As TitleCollection[C#]
public TitleCollection Titles {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

  • The TextColor property may be used to get or set the color of the title text; the Font Property can be used to configure a new font object for the title.

Applies to

BaseGauge

See Also

BaseGauge Class | BaseGauge Members | Font Property | TextColor Property


Border class

Provides access to the Border object.

For a list of all members of this type, see Border Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Border

Remarks

A border is the outer frame of a gauge object. This class is a base class for other border class of specific gauge types. For example, the border of a RadialGauge is the outer ring encasing the gauge object. The DigitalPanel, VerticalGauge and HorizontalGauge objects also supports an outer border.


Border Class Members

Border Members

Border Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor | Gets or sets the inside color for a gauge border.
public property InsideEffects | Enables or disables border shadow and gradient.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Glare property of Border class

Border.Glare Property

Gets or sets a value indicating whether to use a lighting effect for a border.

[Visual Basic]
Public Property Glare As Boolean[C#]
public Boolean Glare {get;set;}

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

  • The Border property of a linear or radial gauge is used to obtain the border object.

Applies to

Border

See Also

Border Class | Border Members | InsideColor Property | Thickness Property | RadialGauge Class | LinearGauge Class | RadialBorder Class | LinearBorder Class


InsideColor property of Border class

Border.InsideColor Property

Gets or sets the inside color for a gauge border.

[Visual Basic]
Public Property InsideColor As Color[C#]
public Color InsideColor {get;set;}

Remarks

  • This property is used to configure the inner color value for a Border object.

  • For more information regarding the Color type, please refer to the .NET Framework documentation.

Applies to

Border

See Also

Border Class | Border Members | Glare Property | Thickness Property | LinearGauge Class | LinearBorder Class | RadialGauge Class | RadialBorder Class


InsideEffects property of Border class

Border.InsideEffects Property

Enables or disables border shadow and gradient.

[Visual Basic]
Public Property InsideEffects As Boolean[C#]
public Boolean InsideEffects {get;set;}

Remarks

  • A natural gradient is applied when there is no specific background image.

Applies to

Border

See Also

Border Class | Border Members


DigitalPanel class

Provides access to the DigitalPanel object.

For a list of all members of this type, see DigitalPanel Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.DigitalPanel

Remarks

The DigitalPanel gauge is a digital representation of values using 7 Segments, 14Segments or LEDs.

7 Segments can represent only numeric values, while 14 Segments and LEDs can represent numbers, tesxt and dates.

Here is an example of a 7 segment DigitalPanel:

Here is an example of a 14 segment DigitalPanel:

Here is an example of an LED DigitalPanel:


DigitalPanel Class Members

DigitalPanel Members

DigitalPanel Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Appearance | Returns the DigitsContainer for a Digital Panel.
public property Border | Gets the Border object for a Digital Panel.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.
public property Value | Gets or sets the value for a Digital Panel.
public property ValueFormat | Gets or sets the numeric format string for a Digital Panel.
public property ValuePadding | Gets or Sets the number of digit placeholders in the panel.


Appearance property of DigitalPanel class

DigitalPanel.Appearance Property

Returns the DigitsContainer for a Digital Panel.

[Visual Basic]
Public ReadOnly Property Appearance As DigitalAppearance[C#]
public DigitalAppearance Appearance {get;}

Remarks

  • This property is used to obtain access to the DigitsContainer for a Digital Panel. This object is the section of a digital panel that contains the segment or LEDs characters. The supported members of the DigitsContainer may be used to customize the display of digits in the Digital Panel.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | DigitalAppearance Class


Border property of DigitalPanel class

DigitalPanel.Border Property

Gets the Border object for a Digital Panel.

[Visual Basic]
Public ReadOnly Property Border As LinearBorder[C#]
public LinearBorder Border {get;}

Remarks

  • The Border is the outer object encasing a Digital Panel. There are a myriad of different frame designs and styles that may be used to customize the display of Digital Panels.

  • This property returns a LinearBorder object. For additional information regarding supported members, please see the LinearBorder class.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | LinearBorder Class


Value property of DigitalPanel class

DigitalPanel.Value Property

Gets or sets the value for a Digital Panel.

[Visual Basic]
Public Property Value As Object[C#]
public Object Value {get;set;}

Remarks

  • This property is used to control the value for a Digital Panel. The default value is 100.

  • The Digits property is used to return the DigitsContainer for a Digital Panel. The DigitsContainer is used to customize the display of segents or LEDs.

  • The ValueFormat property may be used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | Digits Property | ValueFormat Property | DigitsContainer Class


ValueFormat property of DigitalPanel class

DigitalPanel.ValueFormat Property

Gets or sets the numeric format string for a Digital Panel.

[Visual Basic]
Public Property ValueFormat As String[C#]
public String ValueFormat {get;set;}

Remarks

  • This property is used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

  • The Value property to control the value for a Digital Panel. The default value is 100.

  • The Digits property is used to return the DigitsContainer for a Digital Panel. The DigitsContainer is used to customize the display of segents or LEDs.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members | Value Property | Digits Property | DigitsContainer Class


ValuePadding property of DigitalPanel class

DigitalPanel.ValuePadding Property

Gets or Sets the number of digit placeholders in the panel.

[Visual Basic]
Public Property ValuePadding As Int32[C#]
public Int32 ValuePadding {get;set;}

Remarks

  • If no padding value is specified, then the gauge will format the display based on the current value.

Applies to

DigitalPanel

See Also

DigitalPanel Class | DigitalPanel Members


DigitalAppearance class

Provides access to the DigitalAppearance object.

For a list of all members of this type, see DigitalAppearance Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.DigitalAppearance

Remarks

The DigitalAppearance object is used to customize the display for a DigitalPanel. Supported members provide access to members controlling the Layout, Size, Styles, etc.


DigitalAppearance Class Members

DigitalAppearance Members

DigitalAppearance Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Layout | Gets the layout object for a DigitContainer.
public property OffDigitTransparency | Gets or sets the transparency for segments and LEDs not used to create a digit's current value.
public property Size | Gets or sets the size of Digits in a Digital Container.
public property Style | Gets or sets the Style for the caracters displyed in a DigitalPanel.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Layout property of DigitalAppearance class

DigitalAppearance.Layout Property

Gets the layout object for a DigitContainer.

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of Digits inside the DigitalPanel.

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Layout Class


OffDigitTransparency property of DigitalAppearance class

DigitalAppearance.OffDigitTransparency Property

Gets or sets the transparency for segments and LEDs not used to create a digit's current value.

[Visual Basic]
Public Property OffDigitTransparency As Byte[C#]
public Byte OffDigitTransparency {get;set;}

Remarks

  • This property controls the transparency of LEDs and Segments which are not used to display digit values.
    For example, when displaying a value of one in a seven-segment style digit, only the two right vertical segements are used to diplay the value. The others will utilize the OffDigitTransparency setting.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Style Property | Layout Property | DigitalPanel Class


Size property of DigitalAppearance class

DigitalAppearance.Size Property

Gets or sets the size of Digits in a Digital Container.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This property is used to control the size of segment or LED digits displayed in a Digital Container.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The OffDigitTransparency property controls the transparency of LEDs and Segments which are not used to display digit values.

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Style Property | OffDigitTransparency Property | Style Property | DigitalPanel Class


Style property of DigitalAppearance class

DigitalAppearance.Style Property

Gets or sets the Style for the caracters displyed in a DigitalPanel.

[Visual Basic]
Public Property Style As DigitalCharacterStyle[C#]
public DigitalCharacterStyle Style {get;set;}

Remarks

  • Thsi property is used to select which type of charartere is going to be displayes on the DigitalPanel: 7-Segment, 14-Segment or LED.

  • The 7-segment styles provide display sets of the ten numerals, plus the following symbods: . , - , : and '.

  • The 14-segment styles provids a display set of 44 commonly used characters, including the ten numerals, the uppercase alphabet and other symbols.

  • The LED styles provide the same alphanumeric character set as a 14-Segment display plus lower case alphabet.

  • All 3 types include diferent variations and formats: italic, rounded, square, etc.

Applies to

DigitalAppearance

See Also

DigitalAppearance Class | DigitalAppearance Members | Size Property


Filler class

Provides access to the Filler object.

For a list of all members of this type, see Filler Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Indicator
ChartFX.ReportingServices.Gauge.Filler

Remarks

A Filler indicator type that is supported for a LinearGauge; derived from the Indicator class. The Filler object is the bar marker that has a beggining and ending value. The supported members of this class allow customization of this Indicator type.

The following is a sample of a Filler in a HorizontalGauge:

Chart FX Gauges for .NET provides several Filler Styles, in diferent shapes and forms, the following is a example of a HorizontaGauge with a repeat filler:


Filler Class Members

Filler Members

Filler Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Origin | Gets or sets the starting value of a filler indicator type.
public property OriginCustom | Gets or sets the custom origin for a filler indicator.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a filler indicator.
public property UseFillerAsBar | Gets or sets a value indicating to use the Filler as the background in a linear gauge.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Format property of Indicator class

Indicator.Format Property

Returns the ValueFormat object for a selected indicator.

[Visual Basic]
Public ReadOnly Property Format As ValueFormat[C#]
public ValueFormat Format {get;}

Remarks

  • This property returns a ValueFormat object. Please see the ValueFormat class for additional information regarding supported members.

  • The Value property may be used to configure a value for selected indicator.

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Value Property | ValueFormat Class | LinearScale Class | RadialScale Class


Origin property of Filler class

Filler.Origin Property

Gets or sets the starting value of a filler indicator type.

[Visual Basic]
Public Property Origin As FillerOrigin[C#]
public FillerOrigin Origin {get;set;}

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The CustomOrigin property is used to configure a custom starting value when the Origin property is configured to FillerOriginType.CustomOrigin.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • The Style property may be used to configure the style for a filler object.

Applies to

Filler

See Also

Filler Class | Filler Members | CustomOrigin Property | Style Property | Indicator Class | Marker Class


OriginCustom property of Filler class

Filler.OriginCustom Property

Gets or sets the custom origin for a filler indicator.

[Visual Basic]
Public Property OriginCustom As Double[C#]
public Double OriginCustom {get;set;}

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Style Property | Indicator Class | Marker Class


Snap property of Indicator class

Indicator.Snap Property

Gets or set the Snapping for an indicator.

[Visual Basic]
Public Property Snap As Double[C#]
public Double Snap {get;set;}

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Applies to

Indicator

See Also

Indicator Class | Indicator Members


Style property of Filler class

Filler.Style Property

Gets or sets the style for a filler indicator.

[Visual Basic]
Public Property Style As FillerStyle[C#]
public FillerStyle Style {get;set;}

Remarks

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Indicator Class | Marker Class


UseFillerAsBar property of Filler class

Filler.UseFillerAsBar Property

Gets or sets a value indicating to use the Filler as the background in a linear gauge.

[Visual Basic]
Public Property UseFillerAsBar As Boolean[C#]
public Boolean UseFillerAsBar {get;set;}

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • Filler indiators are only supported for a LinearGauge. LinearGauges also support the Marker indicator type.

  • The Style property may be used to configure the style for a filler object.

Applies to

Filler

See Also

Filler Class | Filler Members | Origin Property | Style Property | Marker Class | Indicator Class


UseRangeColor property of Indicator class

Indicator.UseRangeColor Property

Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.

[Visual Basic]
Public Property UseRangeColor As RangeType[C#]
public RangeType UseRangeColor {get;set;}

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Value Property | Section Class | Strip Class


Value property of Indicator class

Indicator.Value Property

Gets or sets the value for an indicator.

[Visual Basic]
Public Property Value As Value[C#]
public Value Value {get;set;}

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

  • When using VB.NET in Visual Studio 2003 an explicit declaration of a NumericalValue type is necessary to assign a Value to the gauge. See sample below.

Applies to

Indicator

See Also

Indicator Class | Indicator Members | Draggable Property | Format Property | DisplayedValue Property


VerticalPosition property of Indicator class

Indicator.VerticalPosition Property

Gets or Sets the positioning of the Indicator to behind or above the tick marks.

[Visual Basic]
Public Property VerticalPosition As IndicatorVerticalPosition[C#]
public IndicatorVerticalPosition VerticalPosition {get;set;}

Remarks

  • This is merely an aesthetic feature, but will change the order of the HitTestTargetStack.

Applies to

Indicator

See Also

Indicator Class | Indicator Members


Gauge class

Provides access to the Gauge object.

For a list of all members of this type, see Gauge Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.Gauge

Remarks

The HorizontalGauge, VerticalGauge and RadialGauge objects derive from the Gauge class. The Gauge class is not designed to be used directly. All the supported members of the Gauge object are also supported by the HorizontalGauge, VerticalGauge and RadialGauge objects.

By default, a gauge contains one scale (called the main scale of the gauge). This main scale contains one indicator (called the main indicator of the gauge). The gauge provides handy shortcuts to access the main indicator (MainIndicator), the value of the main indicator (MainValue), as well as a strongly typed main scale (a radial scale for the RadialGauge: MainScale, and a linear scale for the LinearGauge: MainScale).


Gauge Class Members

Gauge Members

Gauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators. Cast the return value to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.
public property MainValue | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Shadow | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.


MainIndicator property of Gauge class

Gauge.MainIndicator Property

[Visual Basic]
Public Property MainIndicator As Indicator[C#]
public Indicator MainIndicator {get;set;}

Remarks

  • A gauge may have many indicators, however only one MainIndicator.

  • The MainValue property is used to obtain the value of the MainIndicator.

Applies to

Gauge

See Also

Gauge Class | Gauge Members | MainValue Property | MainScale Property | RadialGauge Class | HorizontalGauge Class | VerticalGauge Class | Needle Class | Marker Class | Filler Class


MainValue property of Gauge class

Gauge.MainValue Property

Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.

[Visual Basic]
Public Property MainValue As Value[C#]
public Value MainValue {get;set;}

Remarks

  • A gauge may display several values, for example a radial gauge may have multiple indicator needles. This property is used to configure the value displayed as the main value of a gauge object.

  • The MainIndicator method is used to obtain access to the main indicator.

  • When using VB.NET in Visual Studio 2003 an explicit declaration of a NumericalValue type is necessary to assign a MainValue to the gauge. See sample below.

Applies to

Gauge

See Also

Gauge Class | Gauge Members | MainIndicator Property | MainScale Property | RadialGauge Class | HorizontalGauge Class | VerticalGauge Class


Shadow property of Gauge class

Gauge.Shadow Property

Gets or sets a value indicating to whether to display a shadow in a gauge.

[Visual Basic]
Public Property Shadow As ShadowEffect[C#]
public ShadowEffect Shadow {get;set;}

Remarks

  • The ShadowEffect property may be used to obtain a ShadowEffect object for a gauge. Using the supported members of the ShadowEffect class, developers can manipulate the display of a gauge shadow.

Applies to

Gauge

See Also

Gauge Class | Gauge Members | ShadowEffect Class


GaugeFont class

Provides access to the GaugeFont object.

For a list of all members of this type, see GaugeFont Members

ChartFX.ReportingServices.Gauge.GaugeFont

Remarks

The GaugeFont object defines a particular format for text, including font face, size, and style attributes for text in a gauge.


GaugeFont Class Members

GaugeFont Members

GaugeFont Overview

Public Properties

public property Bold | Gets a value that indicates whether a GaugeFont object is bold.
public property FontFamily | Gets the FontFamily object associated with the GaugeFont object.
public property Italic | Gets a value that indicates whether a GaugeFont object is italic
public property Name | Gets the face name of a GaugeFont object.
public property Size | Gets the FontSize of a GaugeFont object.
public property Strikeout | Gets value that indicates whether the font is strikethrough.
public property Style | Gets style information for this Font object.
public property Underline | Gets a value that indicates whether the GaugeFont is underlined.


Bold property of GaugeFont class

GaugeFont.Bold Property

Gets a value that indicates whether a GaugeFont object is bold.

[Visual Basic]
Public ReadOnly Property Bold As Boolean[C#]
public Boolean Bold {get;}

Remarks

  • This property returns true if this GaugeFont object is bold; otherwise, false.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | GaugeFont Class


FontFamily property of GaugeFont class

GaugeFont.FontFamily Property

Gets the FontFamily object associated with the GaugeFont object.

[Visual Basic]
Public ReadOnly Property FontFamily As FontFamily[C#]
public FontFamily FontFamily {get;}

Remarks

  • A FontFamily object represents a group of fonts that have a similar font face, but may have different sizes and styles. For example, Arial, Times New Roman, and Verdana.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Style Property | Size Property


Italic property of GaugeFont class

GaugeFont.Italic Property

Gets a value that indicates whether a GaugeFont object is italic

[Visual Basic]
Public ReadOnly Property Italic As Boolean[C#]
public Boolean Italic {get;}

Remarks

  • This property returns true if a GaugeFont object is italic; otherwise, false.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Bold Property | Name Property | Size Property | Strikeout Property | Underline Property | GaugeFont Class


Name property of GaugeFont class

GaugeFont.Name Property

Gets the face name of a GaugeFont object.

[Visual Basic]
Public ReadOnly Property Name As String[C#]
public String Name {get;}

Remarks

  • This property returns a string representation of the face name for a GaugeFont object.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Style Property | GaugeFont Class


Size property of GaugeFont class

GaugeFont.Size Property

Gets the FontSize of a GaugeFont object.

[Visual Basic]
Public ReadOnly Property Size As GaugeFontSize[C#]
public GaugeFontSize Size {get;}

Remarks

  • This property returns the FontSize for a GaugeFont.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Style Property | GaugeFont Class


Strikeout property of GaugeFont class

GaugeFont.Strikeout Property

Gets value that indicates whether the font is strikethrough.

[Visual Basic]
Public ReadOnly Property Strikeout As Boolean[C#]
public Boolean Strikeout {get;}

Remarks

  • This property returns true if the font is struck through; otherwise, false. The default value is false.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Bold Property | Italic Property | Size Property | Underline Property | GaugeFont Class


Style property of GaugeFont class

GaugeFont.Style Property

Gets style information for this Font object.

[Visual Basic]
Public ReadOnly Property Style As FontStyle[C#]
public FontStyle Style {get;}

Remarks

  • A FontStyle enumeration that contains style information for this Font object.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | FontFamily Property | Name Property


Underline property of GaugeFont class

GaugeFont.Underline Property

Gets a value that indicates whether the GaugeFont is underlined.

[Visual Basic]
Public ReadOnly Property Underline As Boolean[C#]
public Boolean Underline {get;}

Remarks

  • This property returns true if the font is underlined; otherwise, false. The default value is false.

Applies to

GaugeFont

See Also

GaugeFont Class | GaugeFont Members | Italic Property | Strikeout Property | GaugeFont Class


GaugeImage class

An image displayed in the background of the Gauge.

For a list of all members of this type, see GaugeImage Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.GaugeImage

Remarks

GaugeImages are added to the Images collection object of the Gauge. By default, the most recently added image in the collection is displayed on the Gauge.

The Visible property of the GaugeImage can be used to determine which image is currently shown in the background.


GaugeImage Class Members

GaugeImage Members

GaugeImage Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Image | Represents the actual System.Drawing.Image file.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property Size | A numeric size modifier applied in conjunction with a Custom SizeMode setting.
public property SizeMode | Defines the display size options for the background image.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Angle property of Annotation class

Annotation.Angle Property

Gets or sets the rotation angle in degrees for an annotation.

[Visual Basic]
Public Property Angle As Single[C#]
public Single Angle {get;set;}

Applies to

Annotation

See Also

Annotation Class | Annotation Members | Property | Title Class


Image property of GaugeImage class

GaugeImage.Image Property

Represents the actual System.Drawing.Image file.

[Visual Basic]
Public Property Image As Image[C#]
public Image Image {get;set;}

Remarks

  • Images that are larger than the gauge are not automatically scaled.

Applies to

GaugeImage

See Also

GaugeImage Class | GaugeImage Members


Layout property of Annotation class

Annotation.Layout Property

Gets the layout object for an Annotation.

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

Applies to

Annotation

See Also

Annotation Class | Annotation Members | LayoutAttributes Class


Size property of GaugeImage class

GaugeImage.Size Property

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Applies to

GaugeImage

See Also

GaugeImage Class | GaugeImage Members


SizeMode property of GaugeImage class

GaugeImage.SizeMode Property

Defines the display size options for the background image.

[Visual Basic]
Public Property SizeMode As ImageSizeMode[C#]
public ImageSizeMode SizeMode {get;set;}

Remarks

  • When using the Custom value a size can be specified using the GaugeImage.Size property.

Applies to

GaugeImage

See Also

GaugeImage Class | GaugeImage Members


HorizontalGauge class

Provides access to the HorizontalGauge object

For a list of all members of this type, see HorizontalGauge Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.Gauge
ChartFX.ReportingServices.Gauge.LinearGauge
ChartFX.ReportingServices.Gauge.HorizontalGauge

Remarks

A HorizontalGauge includes scales that are configured in a horizontal position. Supported members of the HorizontalGauge class allow developers to configure a border, colors, sections, flip the gradient color scheme, access to the scale and indicator objects, etc.

Below is an example of a HorizontalGauge:


HorizontalGauge Class Members

HorizontalGauge Members

HorizontalGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border (inherited from LinearGauge) | Returns the LinearBorder object for a linear gauge.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators. Cast the return value to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.
public property MainScale (inherited from LinearGauge) | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales (inherited from LinearGauge) | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.


Border property of LinearGauge class

LinearGauge.Border Property

Returns the LinearBorder object for a linear gauge.

[Visual Basic]
Public ReadOnly Property Border As LinearBorder[C#]
public LinearBorder Border {get;}

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. The Style property may be used to configure any of the supported LinearBorderStyle enumeration types.

  • This property returns a LinearBorder object. For additional information regarding supported members, please see the LinearBorder class.

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | Style Property | LinearBorder Class | HorizontalGauge Class | VerticalGauge Class


MainScale property of LinearGauge class

LinearGauge.MainScale Property

Returns the main scale of a linear gauge.

[Visual Basic]
Public ReadOnly Property MainScale As LinearScale[C#]
public LinearScale MainScale {get;}

Remarks

  • A scale for a linear gauge is the range of values which a gauge can indicate a value. The indicator marks a value in a given scale.

  • The Scales property may be used to obtain the LinearScaleCollection for a linear gauge. The MainScale property is used to return the main scale object in the collection. By default, the main scale is the first scale of the collection.

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | Scales Property | MainValue Property | MainScale Property | LinearScale Class | HorizontalGauge Class | VerticalGauge Class


Scales property of LinearGauge class

LinearGauge.Scales Property

Returns the LinearScaleCollection for a linear gauge.

[Visual Basic]
Public ReadOnly Property Scales As LinearScaleCollection[C#]
public LinearScaleCollection Scales {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The LinearScale object is used to control attributes for a linear gauge scale.

  • The MainScale property is used to obtain the main scale for a selected LinearGauge.

Applies to

LinearGauge

See Also

LinearGauge Class | LinearGauge Members | MainScale Property | LinearScale Class | HorizontalGauge Class | VerticalGauges Class


Indicator class

Provides access to the Indicator object.

For a list of all members of this type, see Indicator Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Indicator

Remarks

Indicators mark values in a guage. They are suppored for gauge types that include scales (HorizontalGauge, VerticalGauge and RadialGauge). The LinearScale and RadialScale classes support indicator objects. Fillers, Markers and Needles are all supported indicator objects.


Indicator Class Members

Indicator Members

Indicator Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Format | Returns the ValueFormat object for a selected indicator.
public property Snap | Gets or set the Snapping for an indicator.
public property UseRangeColor | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value | Gets or sets the value for an indicator.
public property VerticalPosition | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


InnerBaseGauge class

Provides access to the InnerBaseGauge object.

For a list of all members of this type, see InnerBaseGauge Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge

Remarks

Implements basic funtionality for Inner Gauges.


InnerBaseGauge Class Members

InnerBaseGauge Members

InnerBaseGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


LinkToMainValue property of InnerBaseGauge class

InnerBaseGauge.LinkToMainValue Property

Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

[Visual Basic]
Public Property LinkToMainValue As Boolean[C#]
public Boolean LinkToMainValue {get;set;}

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Applies to

InnerBaseGauge

See Also

InnerBaseGauge Class | InnerBaseGauge Members | Dispose Method | InnerGauge Class


InnerBaseLinearGauge class

Provides access to the InnerBaseLinearGauge object.

For a list of all members of this type, see InnerBaseLinearGauge Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge
ChartFX.ReportingServices.Gauge.InnerBaseLinearGauge

Remarks

Derived from the InnerBaseGauge class, the InnerBaseLinearGauge is the base class for the InnerLinearGauge object.

Using the InnerLinearGauge class, developers may embed a LinearGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerBaseLinearGauge Class Members

InnerBaseLinearGauge Members

InnerBaseLinearGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Size property of InnerBaseLinearGauge class

InnerBaseLinearGauge.Size Property

Gets or sets the size for a inner linear gauge.

[Visual Basic]
Public Property Size As SizeF[C#]
public SizeF Size {get;set;}

Remarks

  • This property accepts a SizeF object. This object accepts both Height and Width attributes.

  • Setting the size to (1,1) should indicate that the inner linear gauge is at the maximum size.

Applies to

InnerBaseLinearGauge

See Also

InnerBaseLinearGauge Class | InnerBaseLinearGauge Members | LinearGauge Class


InnerDigitalPanel class

Provides access to the InnerDigitalMeter object.

For a list of all members of this type, see InnerDigitalPanel Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge
ChartFX.ReportingServices.Gauge.InnerBaseLinearGauge
ChartFX.ReportingServices.Gauge.InnerDigitalPanel

Remarks

Using the InnerDigitalPanel class, developers may embed a DigitalPanel inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerDigitalPanel Class Members

InnerDigitalPanel Members

InnerDigitalPanel Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


InnerHorizontalGauge class

Provides access to the InnerLinearGauge object.

For a list of all members of this type, see InnerHorizontalGauge Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge
ChartFX.ReportingServices.Gauge.InnerBaseLinearGauge
ChartFX.ReportingServices.Gauge.InnerHorizontalGauge

Remarks

Using the InnerHorizontalGauge class, developers may embed a HorizontalGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerHorizontalGauge Class Members

InnerHorizontalGauge Members

InnerHorizontalGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


InnerRadialGauge class

Provides access to the InnerRadialGauge object.

For a list of all members of this type, see InnerRadialGauge Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge
ChartFX.ReportingServices.Gauge.InnerRadialGauge

Remarks

Using the InnerRadialGauge class, developers may embed a RadialGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerRadialGauge Class Members

InnerRadialGauge Members

InnerRadialGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


InnerVerticalGauge class

Provides access to the InnerVerticalGauge object.

For a list of all members of this type, see InnerVerticalGauge Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.InnerBaseGauge
ChartFX.ReportingServices.Gauge.InnerBaseLinearGauge
ChartFX.ReportingServices.Gauge.InnerVerticalGauge

Remarks

Using the InnerVerticalGauge class, developers may embed a VerticalGauge inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.


InnerVerticalGauge Class Members

InnerVerticalGauge Members

InnerVerticalGauge Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property LinkToMainValue (inherited from InnerBaseGauge) | Gets or sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
public property Size (inherited from InnerBaseLinearGauge) | Gets or sets the size for a inner linear gauge.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


LabelAttributes class

Provides access to the LabelAttributes object.

For a list of all members of this type, see LabelAttributes Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.LabelAttributes

Remarks

The LabelAttributes object is used to customize the display of labels in gauge objects. Supported members allow Font, Format, Orientation and Position configuration for labels in gauges.


LabelAttributes Class Members

LabelAttributes Members

LabelAttributes Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Font | Gets or sets the GaugeFont for a label.
public property Orientation | Gets or sets the orientation for labels of scale tick marks.
public property Position | Gets or sets the location of labels for a selected scale.
public property PositionCustom | Gets or sets a custom position for a LabelAttributes object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Font property of LabelAttributes class

LabelAttributes.Font Property

Gets or sets the GaugeFont for a label.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • The GaugeFont object is used to configure font attributes for labels in a gauge. Please see the GaugeFont class for supported members.

  • The Format property is used obtain the ValueFormat object for gauge labels. Please see the ValueFormat class for information regarding supported members.

  • The Orientation, Position and CustomPosition property are used to configure the location of labels for a selected scale.

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Orientation Property | Position Property | CustomPosition Property | Format Property | GaugeFont Class | ValueFormat Class


Orientation property of LabelAttributes class

LabelAttributes.Orientation Property

Gets or sets the orientation for labels of scale tick marks.

[Visual Basic]
Public Property Orientation As LabelOrientation[C#]
public LabelOrientation Orientation {get;set;}

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The CustomPosition property is used to configure the location of labels when the Postion property is configured to Custom.

  • The Format property is used obtain the ValueFormat object for gauge labels. Please see the ValueFormat class for information regarding supported members.

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Position Property | CustomPosition Property | Format Property | ValueFormat Class


Position property of LabelAttributes class

LabelAttributes.Position Property

Gets or sets the location of labels for a selected scale.

[Visual Basic]
Public Property Position As Position[C#]
public Position Position {get;set;}

Remarks

  • When this property is configured to Custom, the CustomPosition property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | CustomPosition Property | Orientation Property | Format Property | ValueFormat Class


PositionCustom property of LabelAttributes class

LabelAttributes.PositionCustom Property

Gets or sets a custom position for a LabelAttributes object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Applies to

LabelAttributes

See Also

LabelAttributes Class | LabelAttributes Members | Position Property | Orientation Property


LayoutAttributes class

Provides access to the Layoutobject.

For a list of all members of this type, see LayoutAttributes Members

ChartFX.ReportingServices.Gauge.LayoutAttributes

Remarks

The LayoutAttributes object allows you to manipulate the Aligment and Anchoring position of objects inside the Gauge, i.e. Digits, Images, Titles, InnerGauges, etc.


LayoutAttributes Class Members

LayoutAttributes Members

LayoutAttributes Overview

Public Properties

public property Alignment | Gets or sets the alignment for a layout object.
public property AnchorPoint | Gets or sets the location for a Layout object.
public property Target | Gets or set the Target of a Layout object.


Alignment property of LayoutAttributes class

LayoutAttributes.Alignment Property

Gets or sets the alignment for a layout object.

[Visual Basic]
Public Property Alignment As ContentAlignment[C#]
public ContentAlignment Alignment {get;set;}

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to Border, the object will be "docked" in the selected fixed position. The following is an example of a DigitalPanel with the Digits aligned to TOP-LEF:

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Target Property | AnchorPoint Property | DigitsContainer Class | Annotation Class


AnchorPoint property of LayoutAttributes class

LayoutAttributes.AnchorPoint Property

Gets or sets the location for a Layout object.

[Visual Basic]
Public Property AnchorPoint As PointF[C#]
public PointF AnchorPoint {get;set;}

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to LayoutTargetType.Border.

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Alignment Property | Target Property


Target property of LayoutAttributes class

LayoutAttributes.Target Property

Gets or set the Target of a Layout object.

[Visual Basic]
Public Property Target As LayoutTarget[C#]
public LayoutTarget Target {get;set;}

Remarks

  • The Target wil determine the behaviour of the Aligment.

  • When the target is set to LayoutTargetType.Border, the AnchorPoint should be used to position the layout object.

Applies to

LayoutAttributes

See Also

LayoutAttributes Class | LayoutAttributes Members | Aligment Property | AnchorPoint Property


LinearBorder class

Provides access to the LinearBorder object.

For a list of all members of this type, see LinearBorder Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Border
ChartFX.ReportingServices.Gauge.LinearBorder

Remarks

The LinearBorder class is used to customize the outer frame for a DigitalPanel, VerticalGauge and HorizontalGauge.


LinearBorder Class Members

LinearBorder Members

LinearBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare (inherited from Border) | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor (inherited from Border) | Gets or sets the inside color for a gauge border.
public property InsideEffects (inherited from Border) | Enables or disables border shadow and gradient.
public property Inverted | Gets or set a property to invert the Border of a Linear Gauge
public property Style | Gets or sets the style for a LinearBorder object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Inverted property of LinearBorder class

LinearBorder.Inverted Property

Gets or set a property to invert the Border of a Linear Gauge

[Visual Basic]
Public Property Inverted As Boolean[C#]
public Boolean Inverted {get;set;}

Remarks

  • The folowing is a HorizontalGauge with Invertes = false:

  • The folowing is the same HorizontalGauge with Invertes = true:

Applies to

LinearBorder

See Also

LinearBorder Class | LinearBorder Members | HorizontalGauge Class | VerticalGauge Class


Style property of LinearBorder class

LinearBorder.Style Property

Gets or sets the style for a LinearBorder object.

[Visual Basic]
Public Property Style As LinearBorderStyle[C#]
public LinearBorderStyle Style {get;set;}

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. This property may be used to configure any of the supported LinearBorderStyle enumeration types.

  • The Border property of the LinearGauge object is used to access the LinearBorder object.

Applies to

LinearBorder

See Also

LinearBorder Class | LinearBorder Members | Border (LinearGauge) Property | Border (RadialGauge) Property | LinearGauge Class


LinearGauge class

Provides access to the LinearGauge object.

For a list of all members of this type, see LinearGauge Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.Gauge
ChartFX.ReportingServices.Gauge.LinearGauge

Remarks

The HorizontalGauge and VerticalGauge objects derive from the LinearGauge class. The LinearGauge class is not designed to be used directly. All the supported members of thhis class are also supported by the HorizontalGauge and VerticalGauge classes.


LinearGauge Class Members

LinearGauge Members

LinearGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border | Returns the LinearBorder object for a linear gauge.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators. Cast the return value to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.
public property MainScale | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.


LinearScale class

Provides access to the LinearScale object.

For a list of all members of this type, see LinearScale Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseSection
ChartFX.ReportingServices.Gauge.Scale
ChartFX.ReportingServices.Gauge.LinearScale

Remarks

A Scale for a LinearGauge is the range of values which a gauge can indicate a value. An indicator (Marker of Filler) marks a value in a given scale. The Scale for a LinearGauge is displayed in a vertical or horizontal position.


LinearScale Class Members

LinearScale Members

LinearScale Overview

Public Properties

public property Bar (inherited from Scale) | Returns the ScaleBar object for a section.
public property CustomLabels (inherited from Scale) | The collection of Custom Labels currently associated with the scale.
public property FillerVolume | Gets or Sets the Filler size within a Linear Gauge
public property Indicators | Get the Collection of Indicators for a Selected LinearScale.
public property Inverted | Gets amd set a boolean flag to invert the scale
public property Layout | Gets the layout object for a LinearScale
public property Max (inherited from BaseSection) | Gets or sets the ending value for a gauge section.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from BaseSection) | Gets or sets the starting value for a gauge section.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Sections (inherited from Scale) | Returns the SectionCollection for a scale object.
public property Size | Gets or sets the size for a Linear Scale.
public property Stripes | The collection of Stripes currently associated with the scale.
public property Thickness (inherited from Scale) | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Returns the TickmarkSet object for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Bar property of Scale class

Scale.Bar Property

Returns the ScaleBar object for a section.

[Visual Basic]
Public ReadOnly Property Bar As ScaleBar[C#]
public ScaleBar Bar {get;}

Remarks

  • The ScaleBar object is the colored band for a section object. The supported members of the SectionBar class are used to customize this object.

  • The Border property of the ScaleBar class is used to obtain the border object for a ScaleBar.

Applies to

Scale

See Also

Scale Class | Scale Members | Border Property | ScaleBar Class


CustomLabels property of Scale class

Scale.CustomLabels Property

The collection of Custom Labels currently associated with the scale.

[Visual Basic]
Public ReadOnly Property CustomLabels As CustomLabelHash[C#]
public CustomLabelHash CustomLabels {get;}

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Applies to

Scale

See Also

Scale Class | Scale Members


FillerVolume property of LinearScale class

LinearScale.FillerVolume Property

Gets or Sets the Filler size within a Linear Gauge

[Visual Basic]
Public Property FillerVolume As Single[C#]
public Single FillerVolume {get;set;}

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members


Indicators property of LinearScale class

LinearScale.Indicators Property

Get the Collection of Indicators for a Selected LinearScale.

[Visual Basic]
Public ReadOnly Property Indicators As IndicatorCollection[C#]
public IndicatorCollection Indicators {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying a Indicator in the inner gauge in the IndicatorCollection.

Remarks

  • Indicators are used to mark values in a guage.

  • They are suppored for gauge types that include scales: HorizontalGauge, VerticalGauge and RadialGauge.

  • Fillers, Markers and Needles are all supported indicator objects.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | HorizontalGauge Class | VerticalGauge Class | RadialGauge Class | Indicator Class | Filler Class | Marker Class | Needle Class


Inverted property of LinearScale class

LinearScale.Inverted Property

Gets amd set a boolean flag to invert the scale

[Visual Basic]
Public Property Inverted As Boolean[C#]
public Boolean Inverted {get;set;}

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | HorizontalGauge Class | VerticalGauge Class


Layout property of LinearScale class

LinearScale.Layout Property

Gets the layout object for a LinearScale

[Visual Basic]
Public ReadOnly Property Layout As LayoutAttributes[C#]
public LayoutAttributes Layout {get;}

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | LayoutAttributes Class


Max property of BaseSection class

BaseSection.Max Property

Gets or sets the ending value for a gauge section.

[Visual Basic]
Public Property Max As Double[C#]
public Double Max {get;set;}

Remarks

  • This property is used to configure the ending value for a section. A section has both a starting and ending value. The Min property is used to configure the starting section value.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Min Property | MaxAlwaysDisplayed Property | Section Class


MaxAlwaysDisplayed property of BaseSection class

BaseSection.MaxAlwaysDisplayed Property

Gets or sets a value indicating whether to display the ending value of a section.

[Visual Basic]
Public Property MaxAlwaysDisplayed As Boolean[C#]
public Boolean MaxAlwaysDisplayed {get;set;}

Remarks

  • The Max property may be used to configure the ending range value for a section object.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Max Property | Min Property | Section Class


Min property of BaseSection class

BaseSection.Min Property

Gets or sets the starting value for a gauge section.

[Visual Basic]
Public Property Min As Double[C#]
public Double Min {get;set;}

Remarks

  • This property is used to configure the starting value for a section. A section has both a starting and ending value. The Max property is used to configure the ending section value.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Max Property | MinAlwaysDisplayed Property | Section Class


MinAlwaysDisplayed property of BaseSection class

BaseSection.MinAlwaysDisplayed Property

Gets or sets a value indicating whether to display the starting value of a section.

[Visual Basic]
Public Property MinAlwaysDisplayed As Boolean[C#]
public Boolean MinAlwaysDisplayed {get;set;}

Remarks

  • The Min property may be used to configure the ending range value for a section object.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Max Property | Min Property | Section Class


Sections property of Scale class

Scale.Sections Property

Returns the SectionCollection for a scale object.

[Visual Basic]
Public ReadOnly Property Sections As SectionCollection[C#]
public SectionCollection Sections {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

  • Please see the Section class for additional information regarding supported members.

Applies to

Scale

See Also

Scale Class | Scale Members | Property | Section Class


Size property of LinearScale class

LinearScale.Size Property

Gets or sets the size for a Linear Scale.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • This property is used to control the size of the scale in a LinearGaugeDigital.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

  • You can not set this property to 0; Gauges have a minimun size to display at least the first and las value in the scale. If you want to hide the scale, set the Visible property to false.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members | HorizontalGauge Class | VerticalGauge Class


Stripes property of LinearScale class

LinearScale.Stripes Property

The collection of Stripes currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Stripes As LinearStripCollection[C#]
public LinearStripCollection Stripes {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Applies to

LinearScale

See Also

LinearScale Class | LinearScale Members


Thickness property of Scale class

Scale.Thickness Property

Gets or sets the width for a scale.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Applies to

Scale

See Also

Scale Class | Scale Members | Bar Property | ScaleBar Class


Tickmarks property of BaseSection class

BaseSection.Tickmarks Property

Returns the TickmarkSet object for a section.

[Visual Basic]
Public ReadOnly Property Tickmarks As TickmarkSet[C#]
public TickmarkSet Tickmarks {get;}

Remarks

  • This property returns a TickmarkSet object. For more information regarding the supported members, please see the TickmarkSet class.

  • Using the TickmarkSet, you can access the attributes for the Mayor, Medium and Minor tickmarks.

Applies to

BaseSection

See Also

BaseSection Class | BaseSection Members | Tickmark Class


LinearStrip class

Provides access to the LinearStrip object.

For a list of all members of this type, see LinearStrip Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Strip
ChartFX.ReportingServices.Gauge.LinearStrip

Remarks

A LinearStrip object is displayed next to a LinearScale. A Min and Max value may be configured to emphasize a range of values. Developers may include multiple LinearStrip objects in a linear gauge. The following image depicts two LinearStrip items (Red and Yellow) on a Horizontal Gauge.


LinearStrip Class Members

LinearStrip Members

LinearStrip Overview

Public Properties

public property AlternateColor (inherited from Strip) | Gets or sets the second color used in strip gradients or patterns.
public property Border (inherited from Strip) | Gets the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType (inherited from Strip) | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max (inherited from Strip) | Gets or sets the ending value for a strip object.
public property Min (inherited from Strip) | Gets or sets the starting value for a strip object.
public property Offset | Gets or set the offset of a Strip respect ot the Scale.
public property Pattern (inherited from Strip) | Get or Set the Windows-Style pattern applied to the Strip
public property Thickness (inherited from Strip) | Gets or sets the width for a strip object.
public property UseFullRangeForGradient (inherited from Strip) | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


AlternateColor property of Strip class

Strip.AlternateColor Property

Gets or sets the second color used in strip gradients or patterns.

[Visual Basic]
Public Property AlternateColor As Color[C#]
public Color AlternateColor {get;set;}

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

  • The StartValue and EndValue is used to configure the range for a Stripe object.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

Applies to

Strip

See Also

Strip Class | Strip Members | FillType Property | StartValue Property | EndValue Property | RadialScale Class | LinearScale Class


Border property of Strip class

Strip.Border Property

Gets the BarBorder object for a Strip object.

[Visual Basic]
Public ReadOnly Property Border As BarBorder[C#]
public BarBorder Border {get;}

Remarks

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

  • The StartValue and EndValue is used to configure the range for a Stripe object.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

Applies to

Strip

See Also

Strip Class | Strip Members | Thickness Property | StartValue Property | EndValue Property | BarBorder Class | RadialScale Class | LinearScale Class


FillType property of Strip class

Strip.FillType Property

Gets or sets the fill style for a strip solid, gradient or pattern.

[Visual Basic]
Public Property FillType As StripFillType[C#]
public StripFillType FillType {get;set;}

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

  • The Thickness property is used to configure the width for a strip.

  • The StartValue and EndValue is used to configure the range for a Stripe object.

Applies to

Strip

See Also

Strip Class | Strip Members | AlternateColor Property | Thickness Property | StartValue Property | EndValue Property | RadialScale Class | LinearScale Class


Max property of Strip class

Strip.Max Property

Gets or sets the ending value for a strip object.

[Visual Basic]
Public Property Max As Double[C#]
public Double Max {get;set;}

Remarks

  • The Max and Min are used to configure the range for a Strip object.

Applies to

Strip

See Also

Strip Class | Strip Members | Min Property


Min property of Strip class

Strip.Min Property

Gets or sets the starting value for a strip object.

[Visual Basic]
Public Property Min As Double[C#]
public Double Min {get;set;}

Remarks

  • The Min and Max are used to configure the range for a Strip object.

Applies to

Strip

See Also

Strip Class | Strip Members | Max Property


Offset property of LinearStrip class

LinearStrip.Offset Property

Gets or set the offset of a Strip respect ot the Scale.

[Visual Basic]
Public Property Offset As Single[C#]
public Single Offset {get;set;}

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Applies to

LinearStrip

See Also

LinearStrip Class | LinearStrip Members | HorizontalGauge Class | VerticalGauge Class | LinearScale Class


Pattern property of Strip class

Strip.Pattern Property

Get or Set the Windows-Style pattern applied to the Strip

[Visual Basic]
Public Property Pattern As HatchStyle[C#]
public HatchStyle Pattern {get;set;}

Remarks

  • For more information on Windows Patterns refer to .NET Framework documentation.

  • The HatchStyle enumeration is part of the System.Drawing.Drawing2D namespace.

  • The Strip.FillType property must be set to Pattern in order to see pattern effects.

  • An AlternateColor may also be specified for use with Patterns.

Applies to

Strip

See Also

Strip Class | Strip Members


Thickness property of Strip class

Strip.Thickness Property

Gets or sets the width for a strip object.

[Visual Basic]
Public Property Thickness As Single[C#]
public Single Thickness {get;set;}

Remarks

  • The Stripes property of the RadialScale and LinearScale is used to access the strip items in each repective scale object.

  • The Border property is used to access the BarBorder object for a strip.

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

Applies to

Strip

See Also

Strip Class | Strip Members | Border Property | Thickness Property | RadialScale Class | LinearScale Class | BarBorder Class


UseFullRangeForGradient property of Strip class

Strip.UseFullRangeForGradient Property

Apply the gradient effect over the range of the scale.

[Visual Basic]
Public Property UseFullRangeForGradient As Boolean[C#]
public Boolean UseFullRangeForGradient {get;set;}

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

  • The Strip.FillType property must be set to Gradient for this property to have an effect.

Applies to

Strip

See Also

Strip Class | Strip Members


Marker class

Provides access to the Marker object.

For a list of all members of this type, see Marker Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Indicator
ChartFX.ReportingServices.Gauge.Marker

Remarks

The Marker object is derived from the Indicator class. Markers are types of indicators that may be used in both a LinearGauge and RadialGauge.

The supported members of the Marker class may be used to configure Labels, Text, Size, Position and Style.


Marker Class Members

Marker Members

Marker Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property DisplayedText | Returns the current text displayed for a marker.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Label | Gets the LabelAttributes object for a Marker.
public property Position | Gets or sets the position for a marker.
public property PositionCustom | Gets or sets a custom position for a Marker object.
public property Size | Gets or sets a value to control the size of a marker.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a indicator marker.
public property Text | Gets or sets text for a marker.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


DisplayedText property of Marker class

Marker.DisplayedText Property

Returns the current text displayed for a marker.

[Visual Basic]
Public ReadOnly Property DisplayedText As String[C#]
public String DisplayedText {get;}

Remarks

  • The DisplayedText represents a formated marker Text.

Applies to

Marker

See Also

Marker Class | Marker Members | Style Property | Text Property | Label Property | Format Property | LabelAttributes Class


Label property of Marker class

Marker.Label Property

Gets the LabelAttributes object for a Marker.

[Visual Basic]
Public ReadOnly Property Label As LabelAttributes[C#]
public LabelAttributes Label {get;}

Remarks

  • This property provides access to the LabelAttributes object for a Marker. Please see the LabelAttributes class for additional information regarding supported members.

Applies to

Marker

See Also

Marker Class | Marker Members | Value Property | Style Property | Size Property | LabelAttributes Class


Position property of Marker class

Marker.Position Property

Gets or sets the position for a marker.

[Visual Basic]
Public Property Position As Position[C#]
public Position Position {get;set;}

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

  • The Label property is used to access the LabelAttributes object for a Marker.

Applies to

Marker

See Also

Marker Class | Marker Members | PositionCustom Property | Style Property | Label Property | LabelAttributes Class


PositionCustom property of Marker class

Marker.PositionCustom Property

Gets or sets a custom position for a Marker object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Applies to

Marker

See Also

Marker Class | Marker Members | Position Property | Style Property | Label Property


Size property of Marker class

Marker.Size Property

Gets or sets a value to control the size of a marker.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Applies to

Marker

See Also

Marker Class | Marker Members | Style Property


Style property of Marker class

Marker.Style Property

Gets or sets the style for a indicator marker.

[Visual Basic]
Public Property Style As MarkerStyle[C#]
public MarkerStyle Style {get;set;}

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

  • The Value property may be used to configure a value for selected marker.

  • The Draggable property is used to configure whether an indicator needle value may be modified via user interaction (change value).

Applies to

Marker

See Also

Marker Class | Marker Members | Value Property | Draggable Property | Indicator Class


Text property of Marker class

Marker.Text Property

Gets or sets text for a marker.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Applies to

Marker

See Also

Marker Class | Marker Members | Label Property | DisplayedText Property | Value Property | Style Property | Format Property | LabelAttributes Class


Needle class

Provides access to the Needle object.

For a list of all members of this type, see Needle Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Indicator
ChartFX.ReportingServices.Gauge.Needle

Remarks

The Needle object is derived from the Indicator class. Needles are types of indicators that may be used for only a RadialGauge.

The supported members of the Needle class may be used to configure the Size and Style for needles.


Needle Class Members

Needle Members

Needle Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Format (inherited from Indicator) | Returns the ValueFormat object for a selected indicator.
public property Size | Gets or sets a value to control the size of a needle.
public property Snap (inherited from Indicator) | Gets or set the Snapping for an indicator.
public property Style | Gets or sets the style for a radial indicator needle.
public property UseRangeColor (inherited from Indicator) | Gets or sets a value specifying wether to set an indicator to the same color as a section or stripe.
public property Value (inherited from Indicator) | Gets or sets the value for an indicator.
public property VerticalPosition (inherited from Indicator) | Gets or Sets the positioning of the Indicator to behind or above the tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Size property of Needle class

Needle.Size Property

Gets or sets a value to control the size of a needle.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • When set to zero, the needle is not visible in a radial gauge. This is a ratio property, therefore the overall size of a radial gauge is also a factor when rendering the needle.

Applies to

Needle

See Also

Needle Class | Needle Members


Style property of Needle class

Needle.Style Property

Gets or sets the style for a radial indicator needle.

[Visual Basic]
Public Property Style As NeedleStyle[C#]
public NeedleStyle Style {get;set;}

Remarks

  • A needle is an indicator in a radial gauge which marks a value. There are several different needle designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported NeedleStyle enumeration types.

Applies to

Needle

See Also

Needle Class | Needle Members | Size Property


RadialBorder class

Provides access to the RadialBorder object.

For a list of all members of this type, see RadialBorder Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Border
ChartFX.ReportingServices.Gauge.RadialBorder

Remarks

The RadialBorder class is used to customize the outer frame for a RadialGauge. The Border property of the RadialGauge object returns the RadialBorder object.


RadialBorder Class Members

RadialBorder Members

RadialBorder Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Glare (inherited from Border) | Gets or sets a value indicating whether to use a lighting effect for a border.
public property InsideColor (inherited from Border) | Gets or sets the inside color for a gauge border.
public property InsideEffects (inherited from Border) | Enables or disables border shadow and gradient.
public property Style | Gets or sets the style for a RadialBorder object.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Style property of RadialBorder class

RadialBorder.Style Property

Gets or sets the style for a RadialBorder object.

[Visual Basic]
Public Property Style As RadialBorderStyle[C#]
public RadialBorderStyle Style {get;set;}

Remarks

  • The RadialBorer is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported RadialBorderStyle enumeration types.

  • The Border property of the RadialGauge object is used to access the RadialBorder object.

Applies to

RadialBorder

See Also

RadialBorder Class | RadialBorder Members | Border Property | RadialGauge Class


RadialCap class

Provides access to the RadialCap object.

For a list of all members of this type, see RadialCap Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.RadialCap

Remarks

The RadialCap is the object that connects an indictor Needle to a RadialScale object. The RadialCap is located at the center of a RadialScale. If a Marker indicator is used, the RadialCap will still be visible in the gauge. Supported members of this object allow control over size, style and needle position.


RadialCap Class Members

RadialCap Members

RadialCap Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Size | Gets or sets a value to control the size of a RadialCap.
public property Style | Gets or sets the styles for a RadialCap.
public property VerticalPosition | Gets or Sets the positioning of the Radial Cap to behind or above the Indicator(s).
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Size property of RadialCap class

RadialCap.Size Property

Gets or sets a value to control the size of a RadialCap.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members | Cap Property | Style Property | RadialScale Class | RadialGauge Class


Style property of RadialCap class

RadialCap.Style Property

Gets or sets the styles for a RadialCap.

[Visual Basic]
Public Property Style As RadialCapStyle[C#]
public RadialCapStyle Style {get;set;}

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

  • The Cap property is used to obtain the RadialCap object of a RadialScale.

  • The BehindNeedles property is used to toggle the display of RadialCap objects in-front or behind the indicator needles.

  • The SizeRatio property is used to control the size of a RadialCap.

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members | Cap Property | BehindNeedles Property | SizeRatio Property | RadialScale Class


VerticalPosition property of RadialCap class

RadialCap.VerticalPosition Property

Gets or Sets the positioning of the Radial Cap to behind or above the Indicator(s).

[Visual Basic]
Public Property VerticalPosition As RadialCapVerticalPosition[C#]
public RadialCapVerticalPosition VerticalPosition {get;set;}

Remarks

  • This is merely an aesthetic feature, but will change the order of the HitTestTargetStack.

Applies to

RadialCap

See Also

RadialCap Class | RadialCap Members


RadialGauge class

Provides access to the RadialGauge object.

For a list of all members of this type, see RadialGauge Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.Gauge
ChartFX.ReportingServices.Gauge.RadialGauge

Remarks

A RadialGauge is a circular gauge that includes a circular scale. Needle or Marker indicators are used to display values for a RadialGauge scale. RadialScales may include multiple scales and multiple indicators per scale object. Below is an example of a RadialGauge:


RadialGauge Class Members

RadialGauge Members

RadialGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border | Returns the RadialBorder object for a radial gauge.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators. Cast the return value to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.
public property MainScale | Returns the main scale of a radial gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales | Returns the RadialScaleCollection for the RadialGauge object.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.


Border property of RadialGauge class

RadialGauge.Border Property

Returns the RadialBorder object for a radial gauge.

[Visual Basic]
Public ReadOnly Property Border As RadialBorder[C#]
public RadialBorder Border {get;}

Remarks

  • The RadialBorder is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges.

  • This property returns a RadialBorder object. For additional information regarding supported members, please see the RadialBorder class.

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | RadialBorder Class


MainScale property of RadialGauge class

RadialGauge.MainScale Property

Returns the main scale of a radial gauge.

[Visual Basic]
Public ReadOnly Property MainScale As RadialScale[C#]
public RadialScale MainScale {get;}

Remarks

  • A scale for a radial gauge is the range of values which a gauge can indicate a value. Indicators mark values in a given scale.

  • By default, the RadialCap of the main scale is visible. If a scale is not the main scale, its cap will not be visible by default.

  • The Scales property may be used to obtain the RadialScaleCollection for a radial gauge. The MainScale property is used to return the main scale object. By default, the main scale is the first scale of the collection.

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | Scales Property | MainIndicator Property | MainValue Property | RadialScale Class


Scales property of RadialGauge class

RadialGauge.Scales Property

Returns the RadialScaleCollection for the RadialGauge object.

[Visual Basic]
Public ReadOnly Property Scales As RadialScaleCollection[C#]
public RadialScaleCollection Scales {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The RadialScale object is used to control attributes for a selected scale.

  • The MainScale property is used to obtain the main scale for a selected RadialGauge.

Applies to

RadialGauge

See Also

RadialGauge Class | RadialGauge Members | MainScale Property | RadialScale Class


RadialScale class

Provides access to the RadialScale object.

For a list of all members of this type, see RadialScale Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseSection
ChartFX.ReportingServices.Gauge.Scale
ChartFX.ReportingServices.Gauge.RadialScale

Remarks

The RadialScale object is the circular scale of values displayed inside a RadialGauge. RadialGauge objects may support multiple radial scales. A Needle or Marker indicator type by be used to depict a value for a RadialScale.


RadialScale Class Members

RadialScale Members

RadialScale Overview

Public Properties

public property Bar (inherited from Scale) | Returns the ScaleBar object for a section.
public property Cap | Returns the RadialCap object for a selected RadialScale.
public property CustomLabels (inherited from Scale) | The collection of Custom Labels currently associated with the scale.
public property Indicators | Returns the RadialIndicator collection for a selected RadialScale object.
public property Max (inherited from BaseSection) | Gets or sets the ending value for a gauge section.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from BaseSection) | Gets or sets the starting value for a gauge section.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Pivot | Gets or Sets the position of the scale within the gauge.
public property Radius | Gets or sets the radius for a RadialScale object.
public property Sections (inherited from Scale) | Returns the SectionCollection for a scale object.
public property StartAngle | Gets or sets the starting angle in degrees for a RadialScale.
public property Stripes | The collection of Stripes currently associated with the scale.
public property SweepAngle | Gets or sets the starting angle in degrees for a RadialScale.
public property Thickness (inherited from Scale) | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Returns the TickmarkSet object for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Cap property of RadialScale class

RadialScale.Cap Property

Returns the RadialCap object for a selected RadialScale.

[Visual Basic]
Public ReadOnly Property Cap As RadialCap[C#]
public RadialCap Cap {get;}

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

  • The Cap property is used to access the RadialCap object of a RadialScale object. The supported members of the RadialCap class may be used to customize the display of a cap.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | BehindNeedles Property | SizeRatio Property | Style Property | RadialCap Class | RadialScale Class


Indicators property of RadialScale class

RadialScale.Indicators Property

Returns the RadialIndicator collection for a selected RadialScale object.

[Visual Basic]
Public ReadOnly Property Indicators As IndicatorCollection[C#]
public IndicatorCollection Indicators {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying a RadialIndicator item.

Remarks

  • By specifying an index, developers may obtain a particular Indicator object for a RadialScale.

  • RadialScales support both Marker and Needle indicators. For additional information regarding members, please see the respective Marker, Needle and Indicator classes.

  • The Value property is used to configure the value for an indicator object.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | Value Property | Marker Class | Needle Class | Indicator Class


Pivot property of RadialScale class

RadialScale.Pivot Property

Gets or Sets the position of the scale within the gauge.

[Visual Basic]
Public Property Pivot As PointF[C#]
public PointF Pivot {get;set;}

Remarks

  • RadialScale movement centers around the Cap.

  • The coordinate system for positioning the scale mirrors a Unit Circle. The center point is (0,0). The top-center point is (0,1) and the bottom-center point is (0,-1). The left-center point is (-1,0) and the right-center point is (1,0).

  • This property accepts a PointF object that defines the coordinates.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members


Radius property of RadialScale class

RadialScale.Radius Property

Gets or sets the radius for a RadialScale object.

[Visual Basic]
Public Property Radius As Single[C#]
public Single Radius {get;set;}

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for RadialScales, multiple RadialScale objects may be displayed in a single RadialGauge object.

  • This property is used to control the size of a RadialScale object.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | RadialGauge Class


StartAngle property of RadialScale class

RadialScale.StartAngle Property

Gets or sets the starting angle in degrees for a RadialScale.

[Visual Basic]
Public Property StartAngle As Single[C#]
public Single StartAngle {get;set;}

Remarks

  • This property supports a configuration value between 0 and 360.

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The SweepAngle property is used to get or set the angle at the ending value for a scale.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | Radius Property | SweepAngle Property | RadialGauge Class


Stripes property of RadialScale class

RadialScale.Stripes Property

The collection of Stripes currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Stripes As RadialStripCollection[C#]
public RadialStripCollection Stripes {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members


SweepAngle property of RadialScale class

RadialScale.SweepAngle Property

Gets or sets the starting angle in degrees for a RadialScale.

[Visual Basic]
Public Property SweepAngle As Single[C#]
public Single SweepAngle {get;set;}

Remarks

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The StartAngle property is used to get or set the ending angle in degrees for a RadialScale.

Applies to

RadialScale

See Also

RadialScale Class | RadialScale Members | StartAngle Property | Radius Property


RadialStrip class

Provides access to the RadialStrip object.

For a list of all members of this type, see RadialStrip Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Strip
ChartFX.ReportingServices.Gauge.RadialStrip

Remarks

A RadialStrip is an object used that may be used to emphasize a range of values for a RadialGauge. Multiple RadialStrips may be configured for a selected RadialScale. RadialGauges also support Section objects; these are very similar however are painted over RadialScale tickmarks and include labels.


RadialStrip Class Members

RadialStrip Members

RadialStrip Overview

Public Properties

public property AlternateColor (inherited from Strip) | Gets or sets the second color used in strip gradients or patterns.
public property Border (inherited from Strip) | Gets the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType (inherited from Strip) | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max (inherited from Strip) | Gets or sets the ending value for a strip object.
public property Min (inherited from Strip) | Gets or sets the starting value for a strip object.
public property Pattern (inherited from Strip) | Get or Set the Windows-Style pattern applied to the Strip
public property Radius | Gets or sets the radius for a RadialStrip object.
public property Thickness (inherited from Strip) | Gets or sets the width for a strip object.
public property UseFullRangeForGradient (inherited from Strip) | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Radius property of RadialStrip class

RadialStrip.Radius Property

Gets or sets the radius for a RadialStrip object.

[Visual Basic]
Public Property Radius As Single[C#]
public Single Radius {get;set;}

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for RadialStripe objects, multiple RadialStrips may be displayed over the same range of a RadialScale object.

  • This property is used to control the size of a RadialStrip object.

  • The Stripes property is used to access the RadialStripCollection object of a RadialScale.

Applies to

RadialStrip

See Also

RadialStrip Class | RadialStrip Members | Stripes Property | RadialScale Class | RadialStripCollection Class


Scale class

Provides access to the Scale object.

For a list of all members of this type, see Scale Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseSection
ChartFX.ReportingServices.Gauge.Scale

Remarks

The Scale class is a base class for the RadialScale and LinearScale objects. A scale is a range of values which the configured gauge value is displayed. The Scale object was not designed for direct use by developers.


Scale Class Members

Scale Members

Scale Overview

Public Properties

public property Bar | Returns the ScaleBar object for a section.
public property CustomLabels | The collection of Custom Labels currently associated with the scale.
public property Indicators | The collection of Indicators currently associated with the scale.
public property Max (inherited from BaseSection) | Gets or sets the ending value for a gauge section.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from BaseSection) | Gets or sets the starting value for a gauge section.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Sections | Returns the SectionCollection for a scale object.
public property Thickness | Gets or sets the width for a scale.
public property Tickmarks (inherited from BaseSection) | Returns the TickmarkSet object for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Indicators property of Scale class

Scale.Indicators Property

The collection of Indicators currently associated with the scale.

[Visual Basic]
Public ReadOnly Property Indicators As IndicatorCollection[C#]
public IndicatorCollection Indicators {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Applies to

Scale

See Also

Scale Class | Scale Members


ScaleBar class

Provides access to the ScaleBar object.

For a list of all members of this type, see ScaleBar Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseSectionBar
ChartFX.ReportingServices.Gauge.ScaleBar

Remarks

A ScaleBar is the strip associated with a selected scale in a gauge. The supported members of this class allow users to configure a Border for selected ScaleBar object.


ScaleBar Class Members

ScaleBar Members

ScaleBar Overview

Public Properties

public property Border | Gets the BarBorder object for a ScaleBar object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Border property of ScaleBar class

ScaleBar.Border Property

Gets the BarBorder object for a ScaleBar object.

[Visual Basic]
Public ReadOnly Property Border As BarBorder[C#]
public BarBorder Border {get;}

Remarks

  • The Thickness property of the BarBorder class is used to control the width of a ScaleBar border.

  • The Bar property of the Scale class is used to gain access to the ScaleBar object.

Applies to

ScaleBar

See Also

ScaleBar Class | ScaleBar Members | Thickness Property | Bar Property | BarBorder Class | Scale Class


Section class

Provides access to the Section object.

For a list of all members of this type, see Section Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseSection
ChartFX.ReportingServices.Gauge.Section

Remarks

A Section object is a range of values for a selected RadialScale or LinearScale objects. Sections also support SectionBar which is the strip associated with a section. The SectionBar object may be used to configure a border for a section.


Section Class Members

Section Members

Section Overview

Public Properties

public property Bar | Returns the SectionBar object for a section.
public property Max (inherited from BaseSection) | Gets or sets the ending value for a gauge section.
public property MaxAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the ending value of a section.
public property Min (inherited from BaseSection) | Gets or sets the starting value for a gauge section.
public property MinAlwaysDisplayed (inherited from BaseSection) | Gets or sets a value indicating whether to display the starting value of a section.
public property Tickmarks (inherited from BaseSection) | Returns the TickmarkSet object for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Bar property of Section class

Section.Bar Property

Returns the SectionBar object for a section.

[Visual Basic]
Public ReadOnly Property Bar As SectionBar[C#]
public SectionBar Bar {get;}

Remarks

  • The SectionBar object is the colored band for a section object. The supported members of the SectionBar class are used to customize this object.

  • The EndValue property may be used to configure the ending range value for a section object. The StartValue property is used to configure the starting range value.

  • The StartValueAlwaysDisplayed property is a boolean used to specify whether or not a Section will display the starting value at all times.

Applies to

Section

See Also

Section Class | Section Members | StartValueAlwaysDisplayed Property | EndValue Property | StartValue Property | SectionBar Class


SectionBar class

Provides access to the SectionBar object

For a list of all members of this type, see SectionBar Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseSectionBar
ChartFX.ReportingServices.Gauge.SectionBar

Remarks

A SectionBar is the strip associated with a selected scale in a gauge. The supported members of this class allow users to configure a Color for selected SectionBar object.


SectionBar Class Members

SectionBar Members

SectionBar Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Strip class

Provides access to the Strip object.

For a list of all members of this type, see Strip Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem
ChartFX.ReportingServices.Gauge.Strip

Remarks

The LinearStrip and RadialStrip objects are derived from the Strip class. The Strip class was not designed for direct use by developers.


Strip Class Members

Strip Members

Strip Overview

Public Properties

public property AlternateColor | Gets or sets the second color used in strip gradients or patterns.
public property Border | Gets the BarBorder object for a Strip object.
public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property FillType | Gets or sets the fill style for a strip solid, gradient or pattern.
public property Max | Gets or sets the ending value for a strip object.
public property Min | Gets or sets the starting value for a strip object.
public property Pattern | Get or Set the Windows-Style pattern applied to the Strip
public property Thickness | Gets or sets the width for a strip object.
public property UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Tickmark class

Provides access to the Tickmark object.

For a list of all members of this type, see Tickmark Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Tickmark

Remarks

Tickmarks are displayed in a RadialGauge and LinearGauge scale objects. The members of this object are used to customize the display for tickmarks in gauges.


Tickmark Class Members

Tickmark Members

Tickmark Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Label | Returns the LabelAttributes object for a tickmark.
public property PositionCustom | Gets or sets a custom position for a Tickmark object.
public property Size | Gets or sets a value to control the size of tickmarks.
public property Step | Gets or sets a value indicating the interval for tickmark display.
public property Style | Gets or sets the tickmark style.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Label property of Tickmark class

Tickmark.Label Property

Returns the LabelAttributes object for a tickmark.

[Visual Basic]
Public ReadOnly Property Label As LabelAttributes[C#]
public LabelAttributes Label {get;}

Remarks

  • This property provides access to the LabelAttributes object for a tickmark. Please see the LabelAttributes class for additional information regarding supported members.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Format property is used to obtain the ValueFormat object for a selected Tickmarks. Please see the ValueFormat object for supported members.

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | CustomLabels Property | Position Property | Step Property | Format Property | ValueFormat Class


PositionCustom property of Tickmark class

Tickmark.PositionCustom Property

Gets or sets a custom position for a Tickmark object.

[Visual Basic]
Public Property PositionCustom As Single[C#]
public Single PositionCustom {get;set;}

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Format property is used to obtain the ValueFormat object for a selected Tickmarks. Please see the ValueFormat object for supported members.

  • The Style property is used to configure style for a selected tickmark object.

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Step Property | Format Property | Style Property | ValueFormat Class


Size property of Tickmark class

Tickmark.Size Property

Gets or sets a value to control the size of tickmarks.

[Visual Basic]
Public Property Size As Single[C#]
public Single Size {get;set;}

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Format property is used to obtain the ValueFormat object for a selected Tickmarks. Please see the ValueFormat object for supported members.

  • The Style property is used to configure style for a selected tickmark object.

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Position Property | Step Property | Format Property | Style Property | ValueFormat Class


Step property of Tickmark class

Tickmark.Step Property

Gets or sets a value indicating the interval for tickmark display.

[Visual Basic]
Public Property Step As Double[C#]
public Double Step {get;set;}

Remarks

  • Using the CustomLabels property, developers may configure a custom step as well as configure string labels for tickmark labels.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Format property is used to obtain the ValueFormat object for a selected Tickmarks. Please see the ValueFormat object for supported members.

  • The Style property is used to configure style for a selected tickmark object.

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | CustomLabels Property | Position Property | Format Property | Style Property | ValueFormat Class


Style property of Tickmark class

Tickmark.Style Property

Gets or sets the tickmark style.

[Visual Basic]
Public Property Style As TickmarkStyle[C#]
public TickmarkStyle Style {get;set;}

Remarks

  • The Format property is used to obtain the ValueFormat object for a selected Tickmarks. Please see the ValueFormat object for supported members.

  • The Position and CustomPosition property are used to control the location tickmark display.

Applies to

Tickmark

See Also

Tickmark Class | Tickmark Members | Format Property | Position Property | CustomPosition Property | ValueFormat Class


TickmarkSet class

Provides access to the TickmarkSet object.

For a list of all members of this type, see TickmarkSet Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.TickmarkSet

Remarks

The TickmackSet object provides access to the Major, Medium and Minor tickmarks objects.

Tickmarks are displayed in a RadialGauge, VerticalGauge and HorizontalGauge scale objects.


TickmarkSet Class Members

TickmarkSet Members

TickmarkSet Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Format | Gets or sets the ValueFormat object for selected tickmark object.
public property Major | Allows for configuration of the Major tick marks.
public property Medium | Allows for configuration of the Medium tick marks.
public property Minor | Allows for configuration of the Minor tick marks.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Format property of TickmarkSet class

TickmarkSet.Format Property

Gets or sets the ValueFormat object for selected tickmark object.

[Visual Basic]
Public ReadOnly Property Format As ValueFormat[C#]
public ValueFormat Format {get;}

Remarks

  • The ValueFormat object supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels. Please see the ValueFormat class for more information.

  • The Position and CustomPosition property are used to control the location tickmark display.

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members | Position Property | CustomPosition Property | ValueFormat Class


Major property of TickmarkSet class

TickmarkSet.Major Property

Allows for configuration of the Major tick marks.

[Visual Basic]
Public ReadOnly Property Major As Tickmark[C#]
public Tickmark Major {get;}

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Medium property of TickmarkSet class

TickmarkSet.Medium Property

Allows for configuration of the Medium tick marks.

[Visual Basic]
Public ReadOnly Property Medium As Tickmark[C#]
public Tickmark Medium {get;}

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Minor property of TickmarkSet class

TickmarkSet.Minor Property

Allows for configuration of the Minor tick marks.

[Visual Basic]
Public ReadOnly Property Minor As Tickmark[C#]
public Tickmark Minor {get;}

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Applies to

TickmarkSet

See Also

TickmarkSet Class | TickmarkSet Members


Title2 class

Title class

Provides access to the Title object.

For a list of all members of this type, see Title Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation
ChartFX.ReportingServices.Gauge.Title2

Remarks

The Title object derives from the Annotation class. Titles are supported for all gauge types. The supported members of this object allow you to configure text for gauge titles.


Title2 Class Members

Title2 Members

Title2 Overview

Public Properties

public property Angle (inherited from Annotation) | Gets or sets the rotation angle in degrees for an annotation.
public property Color | Sets the color of text for the specified title.
public property DisplayedText | Returns the displayed title text as a string.
public property Font | Gets or sets the ScalableFont object for a gauge title.
public property Layout (inherited from Annotation) | Gets the layout object for an Annotation.
public property Text | Gets or sets the text for the selected title.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


Color property of Title class

Title.Color Property

Sets the color of text for the specified title.

[Visual Basic]
Public Property Color As Color[C#]
public Color Color {get;set;}

Remarks

  • The Text propety is used to set the caption for a title.

  • For more information regarding the Color type, please refer to the .NET Framework Documentation.

Applies to

Title2

See Also

Title Class | Title Members | Text Property


DisplayedText property of Title class

Title.DisplayedText Property

Returns the displayed title text as a string.

[Visual Basic]
Public ReadOnly Property DisplayedText As String[C#]
public String DisplayedText {get;}

Remarks

  • The Text propety is used to set the caption for a title.

  • The TextColor property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Applies to

Title2

See Also

Title Class | Title Members | Text Property | TextColor Property | Font Property


Font property of Title class

Title.Font Property

Gets or sets the ScalableFont object for a gauge title.

[Visual Basic]
Public Property Font As GaugeFont[C#]
public GaugeFont Font {get;set;}

Remarks

  • This property is used to access the ScalableFont object for a gauge title. Gauges also support a Font property for the entire gauge object.

  • This Font property is used to configure the ScalableFont object for a gauge. Please see the ScalableFont class for supported font members.

Applies to

Title2

See Also

Title Class | Title Members | Font Property | ScalableFont Class


Text property of Title class

Title.Text Property

Gets or sets the text for the selected title.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Applies to

Title2

See Also

Title Class | Title Members | TextColor Property | Font Property


ValueFormat2 class

ValueFormat class

Provides access to the ValueFormat object.

For a list of all members of this type, see ValueFormat Members

ChartFX.ReportingServices.Gauge.ValueFormat2

Remarks

The ValueFormat class members allow you to format labels as Currency, Numeric, Percentage, Scientific or Custom.


ValueFormat2 Class Members

ValueFormat2 Members

ValueFormat2 Overview

Public Properties

public property Culture | Allows you to localize labels and data for a specific language and region.
public property Decimals | Gets or sets the number of decimals for a label.
public property FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.


Culture property of ValueFormat class

ValueFormat.Culture Property

Allows you to localize labels and data for a specific language and region.

[Visual Basic]
Public Property Culture As CultureInfo[C#]
public CultureInfo Culture {get;set;}

Remarks

  • If no attributes are set using this property or the Chart class Culture property, then Chart FX inherits the current Thread culture. For more information please see the Thread class in the .NET Framework Documentation.

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture. These values are documented in the .NET Framework Documentation.

  • An application that is ready for localization is separated into two conceptual blocks, a block that contains all user interface elements and a block that contains executable code. The user interface block contains only localizable user-interface elements such as strings, error messages, dialog boxes, menus, embedded object resources, and so on for the neutral culture. The code block contains only the application code to be used by all supported cultures. The common language runtime supports a satellite assembly resource model that separates an application's executable code from its resources. For more information about implementing this model, see 'Resources in Applications' in the .NET Framework Documentation.

    For each localized version of your application that you want to create, add a new satellite assembly that contains the localized user interface block translated into the appropriate language for the target culture. The code block for all cultures should remain the same. The combination of a localized version of the user interface block with the code block produces a localized version of your application.

  • For more information regarding the CultureInfo type, please refer to the .NET Framework .

Applies to

ValueFormat2

See Also

ValueFormat Class | ValueFormat Members | Property | Method | Class


Decimals property of ValueFormat class

ValueFormat.Decimals Property

Gets or sets the number of decimals for a label.

[Visual Basic]
Public Property Decimals As Int32[C#]
public Int32 Decimals {get;set;}

Remarks

  • When a CustomFormat is applied, formatting assigned using the Decimals property will be ignored.

  • The Format method is used to format any double using the configured format of the ValueFormat object.

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

Applies to

ValueFormat2

See Also

ValueFormat Class | ValueFormat Members | CustomFormat Property | FormatType Property | Format Method | ValueFormat Class


FormatCustom property of ValueFormat class

ValueFormat.FormatCustom Property

Allows you to set a custom format to the selected label, mouseover tip or value.

[Visual Basic]
Public Property FormatCustom As String[C#]
public String FormatCustom {get;set;}

Remarks

  • This property must be invoked before data has been bound or passed to the chart.

  • This property may be used in conjunction with the DataFormat and LabelsFormat properties.

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

Applies to

ValueFormat2

See Also

ValueFormat Class | ValueFormat Members


VerticalGauge class

Description goes here

For a list of all members of this type, see VerticalGauge Members

ChartFX.ReportingServices.Gauge.BaseGauge
ChartFX.ReportingServices.Gauge.Gauge
ChartFX.ReportingServices.Gauge.LinearGauge
ChartFX.ReportingServices.Gauge.VerticalGauge

Remarks

A LinearGauge includes scales that may be configured in a vertical or horizontal position. Supported members of the LinearGauge class allow developers to configure a border, scale orientation, flip the gradient color scheme and access to the scale and indicator objects. Below is an example of a LinearGauge.


VerticalGauge Class Members

VerticalGauge Members

VerticalGauge Overview

Public Properties

public property Antialiasing (inherited from BaseGauge) | Gets or sets the smooth visual effect for a gauge.
public property Border (inherited from LinearGauge) | Returns the LinearBorder object for a linear gauge.
public property Font (inherited from BaseGauge) | Gets or sets the font type which will be used by default in the gauge.
public property Images (inherited from BaseGauge) | Returns the ImageAnnotationCollection for a gauge.
public property InnerGauges (inherited from BaseGauge) | The collection of InnerGauges currently associated with the gauge.
public property MainIndicator (inherited from Gauge) | Gets or sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators. Cast the return value to either a Needle, a Marker, or a Filler in order to set the style or other specific properties.
public property MainScale (inherited from LinearGauge) | Returns the main scale of a linear gauge.
public property MainValue (inherited from Gauge) | Gets or sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.
public property Palette (inherited from BaseGauge) | Allows you to set a Chart FX pre-defined palette.
public property Scales (inherited from LinearGauge) | Returns the LinearScaleCollection for a linear gauge.
public property Shadow (inherited from Gauge) | Gets or sets a value indicating to whether to display a shadow in a gauge.
public property Titles (inherited from BaseGauge) | Returns the collection of titles defined in the gauge.


Annotation class

Provides access to the Annotation object.

For a list of all members of this type, see Annotation Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.Annotation

Remarks

The Annotation class is a base class which GaugeImage, InnerBaseGauge, and Title are derived.

The Annotation object support members are used to position and align annotations inside the gauges.


Annotation Class Members

Annotation Members

Annotation Overview

Public Properties

public property Angle | Gets or sets the rotation angle in degrees for an annotation.
public property Layout | Gets the layout object for an Annotation.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseColorable class

Provides access to the BaseColorable object.

For a list of all members of this type, see BaseColorable Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable

Remarks

The BaseColorable class is derived from the BaseViewable class. These objects are not designed to be used directly, however do provide other objects support for setting Color attributes for selected gauge objects.

Please see the Color class in your development environment documentation for more information regarding functionality for supported members.


BaseColorable Class Members

BaseColorable Members

BaseColorable Overview

Public Properties

public property Color | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseElement class

Provides access to the BaseElement object.

For a list of all members of this type, see BaseElement Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement

Remarks

This is an internal object, it should not be accessed directly.


BaseElement Class Members

BaseElement Members

BaseElement Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseElementItem class

Provides access to the BaseElementItem object.

For a list of all members of this type, see BaseElementItem Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseElement
ChartFX.ReportingServices.Gauge.Primitives.BaseElementItem

Remarks

This is an internal object, it should not be accessed directly.


BaseElementItem Class Members

BaseElementItem Members

BaseElementItem Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseSection class

Provides access to the BaseSection object.

For a list of all members of this type, see BaseSection Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseSection

Remarks

Both the Scale and Section objects are derived from the BaseSection class. A Scale object is used for gauge types which support a scale, for example a RadialGauge. A Section object is a portion of a selected scale.

The BaseSection object was not designed for direct use.


BaseSection Class Members

BaseSection Members

BaseSection Overview

Public Properties

public property Max | Gets or sets the ending value for a gauge section.
public property MaxAlwaysDisplayed | Gets or sets a value indicating whether to display the ending value of a section.
public property Min | Gets or sets the starting value for a gauge section.
public property MinAlwaysDisplayed | Gets or sets a value indicating whether to display the starting value of a section.
public property Tickmarks | Returns the TickmarkSet object for a section.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseSectionBar class

Description goes here

For a list of all members of this type, see BaseSectionBar Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable
ChartFX.ReportingServices.Gauge.Primitives.BaseColorable
ChartFX.ReportingServices.Gauge.Primitives.BaseSectionBar

Remarks

Both the ScaleBar and SectionBar objects are derived from the BaseSectionbar class.

The BaseSection object was not designed for direct use.


BaseSectionBar Class Members

BaseSectionBar Members

BaseSectionBar Overview

Public Properties

public property Color (inherited from BaseColorable) | Gets or sets the color for a gauge element.
public property Visible (inherited from BaseViewable) | Gets or sets a value indicating whether an object is visible or not.


BaseViewable class

Provides access to the BaseViewable object.

For a list of all members of this type, see BaseViewable Members

ChartFX.ReportingServices.Gauge.Primitives.BaseViewable

Remarks

The BaseViewable class was not designed for direct use, however may other gauge objects derive and utilize the supported member (Visible) to show or hide selected gauge elements.


BaseViewable Class Members

BaseViewable Members

BaseViewable Overview

Public Properties

public property Visible Gets or sets a value indicating whether an object is visible or not.