ArtisticPanel class

Provides access to the ArtisticPanel Class

For a list of all members of this type, see ArtisticPanel Members

GridFX.WebForms.ArtisticPanel

Remarks

Used to define different styles of border settings for a Panel

@2007 Software FX, Inc. All Rights Reserved. Grid FX and Chart FX are registered trademarks of Software FX, Inc.
All other names are trademarks or registered trademarks of their respective owners.


ArtisticPanel Class Members

Grid FX

ArtisticPanel Members

ArtisticPanel Overview

Public Properties

public property Border Gets access to the GridBorderSettings class that allows to set the border properties of the ArtisticPanel


Border property of class

ArtisticPanel.Border Property

Gets access to the GridBorderSettings class that allows to set the border properties of the ArtisticPanel

[Visual Basic]
Public ReadOnly Property Border As GridBorderSettings[C#]
public GridBorderSettings Border {get;}

Remarks

  • This is basically a Panel with fancy borders and mostly set at design-time.

Applies to

ArtisticPanel

See Also

ArtisticPanel Class | ArtisticPanel Members


BaseImageFormat class

Provides properties to format Image objects

For a list of all members of this type, see BaseImageFormat Members

GridFX.WebForms.BaseImageFormat

Remarks

The BaseImageFormat Class allows a user to format an ImageField. These settings can be the height and width of the image, as well as stretching the image or using its size ratio.


BaseImageFormat Class Members

BaseImageFormat Members

BaseImageFormat Overview

Public Properties

public property Height | Gets and sets the height of the image.
public property StretchImages | Determines if the image will be stretched or will retain its original size.
public property UseSizeRatio | Locks the size ratio of the image.
public property Width | Gets or sets the width of the image.


Height property of class

BaseImageFormat.Height Property

Gets and sets the height of the image.

[Visual Basic]
Public Property Height As Int32[C#]
public Int32 Height {get;set;}

Example

To set the height of the image:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image_url1"];
imageField.Format.UseThumbnail = false;
BaseImageFormat baseImageFormat = imageField.Format.FullImage;
baseImageFormat.Height = 80;

Applies to

BaseImageFormat

See Also

BaseImageFormat Class | BaseImageFormat Members


StretchImages property of class

BaseImageFormat.StretchImages Property

Determines if the image will be stretched or will retain its original size.

[Visual Basic]
Public Property StretchImages As Boolean[C#]
public Boolean StretchImages {get;set;}

Example

To enable this property:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image_url1"];
imageField.Format.UseThumbnail = false;
BaseImageFormat baseImageFormat = imageField.Format.FullImage;
baseImageFormat.StretchImages = true;

[Visual Basic]
 Dim imageField As New ImageField
imageField = CType(Grid1.Fields("Url"), GridFX.WebForms.ImageField)
imageField.Format.UseThumbnail = False
Dim baseImageFormat As BaseImageFormat
baseImageFormat = imageField.Format.FullImage
baseImageFormat.StretchImages = True

Applies to

BaseImageFormat

See Also

BaseImageFormat Class | BaseImageFormat Members


UseSizeRatio property of class

BaseImageFormat.UseSizeRatio Property

Locks the size ratio of the image.

[Visual Basic]
Public Property UseSizeRatio As Boolean[C#]
public Boolean UseSizeRatio {get;set;}

Remarks

  • If there is a change in the height or in the width values when this property is enabled, the image will be resized according to the value entered, but maintaining its original size ratio.

  • In order to allow full control over the height and width of the image, this property needs to be set to false.

Example

To set the UseSizeRatio to false:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image_url1"];
imageField.Format.UseThumbnail = false;
BaseImageFormat baseImageFormat = imageField.Format.FullImage;
baseImageFormat.UseSizeRatio = false;

[Visual Basic]
 Dim imageField As New ImageField
imageField = CType(Grid1.Fields("Url"), GridFX.WebForms.ImageField)
imageField.Format.UseThumbnail = False
Dim baseImageFormat As BaseImageFormat
baseImageFormat = imageField.Format.FullImage
baseImageFormat.UseSizeRatio = False

Applies to

BaseImageFormat

See Also

BaseImageFormat Class | BaseImageFormat Members


Width property of class

BaseImageFormat.Width Property

Gets or sets the width of the image.

[Visual Basic]
Public Property Width As Int32[C#]
public Int32 Width {get;set;}

Example

To set the width of the image to 80px:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image_url1"];
imageField.Format.UseThumbnail = false;
BaseImageFormat baseImageFormat = imageField.Format.FullImage;
baseImageFormat.Width= 80;

[Visual Basic]
 Dim imageField As New ImageField
imageField = CType(Grid1.Fields("Url"), GridFX.WebForms.ImageField
imageField.Format.UseThumbnail = False
Dim baseImageFormat As BaseImageFormat
baseImageFormat = imageField.Format.FullImage
baseImageFormat.Width = 80

Applies to

BaseImageFormat

See Also

BaseImageFormat Class | BaseImageFormat Members


BooleanField class

A field that handles boolean data

For a list of all members of this type, see BooleanField Members

GridFX.WebForms.DataField
GridFX.WebForms.BooleanField

Remarks

It allows access to the BooleanField class. Most properties are inherited from the GridField Class.


BooleanField Class Members

BooleanField Members

BooleanField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Gets a BooleanFormatter object that specifies formatting settings for the Boolean Field.
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property Input | Gets or sets the input settings for the BooleanField
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Culture property of class

DataField.Culture Property

Allows the user localize a DataField for a specific language and region.

[Visual Basic]
Public Property Culture As CultureInfo[C#]
public CultureInfo Culture {get;set;}

Remarks

  • Culture attributes set with this Property will apply to the entire DataField.

  • If the Culture Property is not set, then the DataField inherits the current thread culture used by the Grid. For more information regarding the CultureInfo type and the Thread Class, please refer to the .NET Framework Documentation.

  • When setting this Property, you may need the Culture Name or Culture Identifier constants for the desired Culture. These values are documented in the .NET Framework Documentation.

Example

Set the DataField Culture to use "Spanish - Spain" as the Language-Country/Region:

[C#]
 Grid1.Fields[1].Culture = new System.Globalization.CultureInfo("es-ES");

Applies to

DataField

See Also

DataField Class | DataField Members


DataPath property of class

DataField.DataPath Property

Gets or sets the mapping string that points to the data field within a data item

[Visual Basic]
Public Property DataPath As String[C#]
public String DataPath {get;set;}

Remarks

  • When this property is set, this field will be bound to data. The data may come from a field that is already displayed on the Grid.

  • If the DataPath Property is not set, then no data will be shown for this DataField.

Example

Bind the Field's DataPath to another Field that already contains data:

[C#]
 Grid1.Fields[1].DataPath = "Age";

Applies to

DataField

See Also

DataField Class | DataField Members


Filtering property of class

DataField.Filtering Property

Gets filtering settings for a DataField.

[Visual Basic]
Public ReadOnly Property Filtering As FieldFilteringSettings[C#]
public FieldFilteringSettings Filtering {get;}

Remarks

  • The filtering options used by this property are part of the FieldFilteringSettings class. Please refer to this class for more details

Example

Enable Filtering for a DataField:

[C#]
 Grid1.Fields[1].Filtering.Enabled = true;

Applies to

DataField

See Also

DataField Class | DataField Members | FieldFilteringSettings Class


Format property of class

BooleanField.Format Property

Gets a BooleanFormatter object that specifies formatting settings for the Boolean Field.

[Visual Basic]
Public ReadOnly Property Format As BooleanFormatter[C#]
public BooleanFormatter Format {get;}

Remarks

  • This property allows the developer to specify the way the field displays boolean data.

  • Besides the Default "Yes or No" setting, it is also possible to change the text used or even change the Display format to a Checkbox or a pre-defined image.

    [C#]
     BooleanField myField = (BooleanField)grid1.Fields[1];
    myField.Format.Display = BooleanDisplayType.ImageSet;
    myField.Format.ImageSet = BooleanFieldFormatImageSet.CheckOrXWithBorder;

Example

To set the boolean fiedl to display a preexisting image:

[C#]
 BooleanField myField = (BooleanField)grid1.Fields[1];
myField.Format.Display = BooleanDisplayType.ImageSet;
myField.Format.ImageSet = BooleanFieldFormatImageSet.CheckOrXWithBorder;

Applies to

BooleanField

See Also

BooleanField Class | BooleanField Members | BooleanFormatter Class


Grouping property of class

DataField.Grouping Property

Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.

[Visual Basic]
Public ReadOnly Property Grouping As FieldGroupingSettings[C#]
public FieldGroupingSettings Grouping {get;}

Remarks

  • The filtering options used by this property are part of the FieldGroupingSettings class. Please refer to this class for more details.

Example

Enable Grouping for a GridField and set the Interval by which it will be grouped:

[C#]
 FixedNumberInterval fixedNumInterval = new FixedNumberInterval();
fixedNumInterval.HideData = true;
fixedNumInterval.IncludeFieldTitleInTitle = true;
fixedNumInterval.NullTitle = "Title is not set";
fixedNumInterval.Start = 20;
FieldGroupingSettings fieldGroup = Grid1.Fields[1].Grouping;
fieldGroup.Enabled = true;

Applies to

DataField

See Also

DataField Class | DataField Members | FieldGroupingSettings Class


Input property of class

BooleanField.Input Property

Gets or sets the input settings for the BooleanField

[Visual Basic]
Public ReadOnly Property Input As BooleanFieldInputSettings[C#]
public BooleanFieldInputSettings Input {get;}

Remarks

  • This property allows you to define if and how Null values will be alowed in the grid field.

Example

To always allow NullValues in the selected BooelanField:

[C#]
 BooleanField myField = (BooleanField)grid1.Fields[1];
myField.Input.NullOption = BooleanFieldNullInputOption.Always;

Applies to

BooleanField

See Also

BooleanField Class | BooleanField Members | Class


IsKey property of class

DataField.IsKey Property

Gets or sets whether the DataField is a Data Key.

[Visual Basic]
Public Property IsKey As Boolean[C#]
public Boolean IsKey {get;set;}

Remarks

  • When the textIsKey property for a DataField is set, this field will be read-only. This property can help the user prevent editing on a field that is bound to a Primary Key field in the Database.

  • Keys can be also sent to DataSource Controls to help in the execution of commands.

  • By default, this property is set to false.

Example

Set a DataField to be a DataKey:

[C#]
 Grid1.Fields[1].IsKey = true;

Applies to

DataField

See Also

DataField Class | DataField Members


ReadOnly property of class

DataField.ReadOnly Property

Gets or sets whether a DataField is editable or not.

[Visual Basic]
Public Property ReadOnly As Boolean[C#]
public Boolean ReadOnly {get;set;}

Remarks

  • The ReadOnly Property can work in conjunction with the IsKey Property. If the IsKey Property is set, and the DataField represents such Key Value, then the field is ReadOnly by default.

Example

Set a GridField to be ReadOnly:

[C#]
 Grid1.Fields[1].ReadOnly = true;

Applies to

DataField

See Also

DataField Class | DataField Members


Sorting property of class

DataField.Sorting Property

Provides access to the FieldSortingSettings object that allows configuring sorting options for the field

[Visual Basic]
Public ReadOnly Property Sorting As FieldSortingSettings[C#]
public FieldSortingSettings Sorting {get;}

Remarks

  • In order for any of the sorting settings to have an effect, the Sorting.Enabled Property for the Field must be set to True.

Example

Sort a DataField in Ascending order:

[C#]
 Grid1.Fields[1].Sorting.Enabled = true;
Grid1.Fields[1].Sorting.Direction = SortDirection.Ascending;

Applies to

DataField

See Also

DataField Class | DataField Members | FieldSortingSettings Class


Title property of class

DataField.Title Property

Gets or sets the title for a DataField

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Example

Set the Title for a DataField:

[C#]
 Grid1.Fields[1].Title = "Hourly Rate";

Applies to

DataField

See Also

DataField Class | DataField Members


UniqueID property of class

DataField.UniqueID Property

Gets or sets a Unique Identifier for a DataField

[Visual Basic]
Public Property UniqueID As String[C#]
public String UniqueID {get;set;}

Remarks

  • The UniqueID is used to identify the field in various places. This is required to avoid runtime errors.

  • If the name is never set, it will default to the DataPath value.

Example

Set the UniqueID for a DataField:

[C#]
 Grid1.Fields[1].UniqueID = "Salary";

Applies to

DataField

See Also

DataField Class | DataField Members


Visible property of class

DataField.Visible Property

Gets or sets whether the DataField will be visible or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • If the Visible Property is set to False, any layout columns, cells, or FieldValues that are assigned to such DataField will have their visibility turned off as well.

Example

Hide a DataField:

[C#]
 Grid1.Fields[1].Visible = false;

Applies to

DataField

See Also

DataField Class | DataField Members | Property


BooleanFormatter class

Provides properties to format boolean objects

For a list of all members of this type, see BooleanFormatter Members

GridFX.WebForms.FieldValueFormatter
GridFX.WebForms.BooleanFormatter

Remarks

Permits the use of a number of output formatting options like displaying the boolean data as images or text.


BooleanFormatter Class Members

BooleanFormatter Members

BooleanFormatter Overview

Public Properties

public property Custom | Allows access to the BooleanFormatterCustomSettings object.
public property Display | Gets or sets the display type of boolean data to be shown.
public property ImageSet | Gets or sets the display type to be shown as an image.
public property TextSet | Gets or sets the display type to be shown as text.
public property TreatNullAsFalse | Display all the null values as false.


Custom property of class

BooleanFormatter.Custom Property

Allows access to the BooleanFormatterCustomSettings object.

[Visual Basic]
Public ReadOnly Property Custom As BooleanFormatterCustomOutputSettings[C#]
public BooleanFormatterCustomOutputSettings Custom {get;}

Remarks

  • This property allows further customization to the way the boolean data will be displayed. This customization includes setting an user text or an user image(assigned through an Url) to the True, Null and False values.

  • In order to use this property, the Display property must be set to Custom.

Example

To display a custom text when the boolean data is true:

[C#]
 BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
booleanField.Format.Display = BooleanDisplayType.Custom;
booleanField.Format.Custom.TrueText = "this is true";

              [Visual Basic]
Dim booleanField As New BooleanField
        booleanField = CType(Grid1.Fields("UniqueID"), GridFX.WebForms.BooleanField)
booleanField.Format.Display = BooleanDisplayType.Custom
booleanField.Format.Custom.TrueText = "this is true"

Applies to

BooleanFormatter

See Also

BooleanFormatter Class | BooleanFormatter Members | BooleanFormatterCustomOutputSettings Class


Display property of class

BooleanFormatter.Display Property

Gets or sets the display type of boolean data to be shown.

[Visual Basic]
Public Property Display As BooleanDisplayType[C#]
public BooleanDisplayType Display {get;set;}

Property Value

The default is TextSet.

Value | Meaning
TextSet | Displays boolean data as text.
ImageSet | Displays boolean data as images.
CheckBox | Displays boolean data as checkboxes.
Custom | Displays boolean data according to custom settings.

Remarks

  • The Display property determines how the Boolean data will be shown to the user.

  • The data can be displayed as an image set, a text set, a check box or a custom format.

Example

To set the output to an image set:

[C#]
 BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
booleanField.Format.Display = BooleanDisplayType.ImageSet;

              [Visual Basic]
Dim booleanfield As New BooleanField
        booleanfield = CType(Grid1.Fields("UniqueID"), GridFX.WebForms.BooleanField)
booleanfield.Format.Display = BooleanDisplayType.ImageSet

Applies to

BooleanFormatter

See Also

BooleanFormatter Class | BooleanFormatter Members


ImageSet property of class

BooleanFormatter.ImageSet Property

Gets or sets the display type to be shown as an image.

[Visual Basic]
Public Property ImageSet As BooleanFieldFormatImageSet[C#]
public BooleanFieldFormatImageSet ImageSet {get;set;}

Property Value

The default is CheckOrX.

Value | Meaning
CheckOrX | Displays a Check for true values or a X for false values.
CheckOrXRounded | Displays a Check or a X with rounded edges.
PlusOrMinus | Displays a Plus for true values or a Minus for false values.
CheckOrXWithBorder | Displays a Check inside a green circle or a X inside a red square.
LED | Displays a lit LED for true values or a turned off for false values.
ThumbsUpOrDown | Displays thumbs up for true values or thumbs down for false values.
ThumbsUpOrDownWithCuff | Displays thumbs up for true values or thumbs down for false values. The hands will displayed will have cuffs.
ArrowUpOrDown | Displays an arrow pointing up for true values or an arrow pointing down for false values.

Remarks

  • The ImageSet property gives numerous options to display the boolean data when the Display property is set to ImageSet.

Example

To set the ImageSet to display the Boolean data as LED’s:

[C#]
 BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
booleanField.Format.Display = BooleanDisplayType.ImageSet;
booleanField.Format.ImageSet = BooleanFieldFormatImageSet.LED;

              [Visual Basic]
Dim booleanfield As New BooleanField
        booleanfield = CType(Grid1.Fields("UniqueID"), GridFX.WebForms.BooleanField)
booleanfield.Format.Display = BooleanDisplayType.ImageSet
booleanfield.Format.ImageSet = BooleanFieldFormatImageSet.LED

Applies to

BooleanFormatter

See Also

BooleanFormatter Class | BooleanFormatter Members


TextSet property of class

BooleanFormatter.TextSet Property

Gets or sets the display type to be shown as text.

[Visual Basic]
Public Property TextSet As BooleanFieldFormatTextSet[C#]
public BooleanFieldFormatTextSet TextSet {get;set;}

Property Value

The default is YesOrNo.

Value | Meaning
TrueOrFalse | Displays "True" for true values or "False" for false values.
YesOrNo | Displays "Yes" for true values or "No" for false values.
TOrF | Displays "T" for true values or "F" for false values.
YOrN | Displays "Y" for true values or "N" for false values.

Remarks

  • The TextSet property gives numerous options to display the boolean data when the Display property is set to TextSet.

Example

To set the TextSet to display the Boolean data as True or False:

[C#]
 BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
booleanField.Format.Display = BooleanDisplayType.TextSet;
booleanField.Format.TextSet = BooleanFieldFormatTextSet.TrueOrFalse;

[Visual Basic]
 Dim booleanfield As New BooleanField
booleanfield = CType(Grid1.Fields("UniqueID"), GridFX.WebForms.BooleanField)
booleanfield.Format.Display = BooleanDisplayType.TextSet
booleanfield.Format.TextSet = BooleanFieldFormatTextSet.TrueOrFalse

Applies to

BooleanFormatter

See Also

BooleanFormatter Class | BooleanFormatter Members


TreatNullAsFalse property of class

BooleanFormatter.TreatNullAsFalse Property

Display all the null values as false.

[Visual Basic]
Public Property TreatNullAsFalse As Boolean[C#]
public Boolean TreatNullAsFalse {get;set;}

Remarks

  • Enabling the TreatNullAsFalse is useful when the user does not desire empty spaces in the grid when a boolean value is null.

Example

To enable this property:

[C#]
 BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
booleanField.Format.TreatNullAsFalse = true;

[Visual Basic]
 BooleanField booleanField = (BooleanField)Grid1.Fields["Boolean"];
booleanField.Format.Display = BooleanDisplayType.Custom;
booleanField.Format.TreatNullAsFalse = true;

Applies to

BooleanFormatter

See Also

BooleanFormatter Class | BooleanFormatter Members


BooleanFormatterCustomOutputSettings class

Formats the custom boolean output

For a list of all members of this type, see BooleanFormatterCustomOutputSettings Members

GridFX.WebForms.BooleanFormatterCustomOutputSettings

Remarks

This objects allows formatting of the boolean field when the Display type is set to Custom


BooleanFormatterCustomOutputSettings Class Members

BooleanFormatterCustomOutputSettings Members

BooleanFormatterCustomOutputSettings Overview

Public Properties

public property FalseImageUrl | Gets or sets the image Url for the False boolean value.
public property FalseText | Gets or sets the text for the false boolean values.
public property NullImageUrl | Gets or sets the image Url for the null boolean value.
public property NullText | Gets or sets the text for the null boolean values.
public property TrueImageUrl | Gets or sets the image Url for the True boolean value.
public property TrueText | Gets or sets the text for the true boolean values.


FalseImageUrl property of class

BooleanFormatterCustomOutputSettings.FalseImageUrl Property

Gets or sets the image Url for the False boolean value.

[Visual Basic]
Public Property FalseImageUrl As String[C#]
public String FalseImageUrl {get;set;}

Example

To set the image Url:

BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"]; BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;bfcos.FalseImageUrl = "http://image.jpg";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


FalseText property of class

BooleanFormatterCustomOutputSettings.FalseText Property

Gets or sets the text for the false boolean values.

[Visual Basic]
Public Property FalseText As String[C#]
public String FalseText {get;set;}

Example

To set the false text:

BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;
bfcos.FalseText = "new false text";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


NullImageUrl property of class

BooleanFormatterCustomOutputSettings.NullImageUrl Property

Gets or sets the image Url for the null boolean value.

[Visual Basic]
Public Property NullImageUrl As String[C#]
public String NullImageUrl {get;set;}

Example

To set the image Url:

        BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
        BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;
bfcos.NullImageUrl = "http://image.jpg";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


NullText property of class

BooleanFormatterCustomOutputSettings.NullText Property

Gets or sets the text for the null boolean values.

[Visual Basic]
Public Property NullText As String[C#]
public String NullText {get;set;}

Example

To set the null text:

BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;
bfcos.NullText = "new null text";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


TrueImageUrl property of class

BooleanFormatterCustomOutputSettings.TrueImageUrl Property

Gets or sets the image Url for the True boolean value.

[Visual Basic]
Public Property TrueImageUrl As String[C#]
public String TrueImageUrl {get;set;}

Example

To set the image Url:

              [C#]
BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
        BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;
bfcos.TrueImageUrl = "http://image.jpg";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


TrueText property of class

BooleanFormatterCustomOutputSettings.TrueText Property

Gets or sets the text for the true boolean values.

[Visual Basic]
Public Property TrueText As String[C#]
public String TrueText {get;set;}

Example

To set the true text:

        BooleanField booleanField = (BooleanField)Grid1.Fields["UniqueID"];
        BooleanFormatterCustomOutputSettings bfcos = booleanField.Format.Custom;
bfcos.TrueText = "new true text";

Applies to

BooleanFormatterCustomOutputSettings

See Also

BooleanFormatterCustomOutputSettings Class | BooleanFormatterCustomOutputSettings Members


BooleanValueCondition class

Allows access to the BooleanValueCondition object.

For a list of all members of this type, see BooleanValueCondition Members

GridFX.WebForms.FieldValueCondition
GridFX.WebForms.BooleanValueCondition

Remarks

This class provides comparison options to filter the records by their boolean values.


BooleanValueCondition Class Members

BooleanValueCondition Members

BooleanValueCondition Overview

Public Properties

public property Comparison | Gets or sets the type of comparison that will be used to filter the records by their boolean values.
public property Field (inherited from FieldValueCondition) | Gets or sets the field to which the condition will apply


Comparison property of class

BooleanValueCondition.Comparison Property

Gets or sets the type of comparison that will be used to filter the records by their boolean values.

[Visual Basic]
Public Property Comparison As BooleanValueComparison[C#]
public BooleanValueComparison Comparison {get;set;}

Property Value

The default is IsTrue.

Value | Meaning
True | Represents a True Value
False | Represents a False Value
Null | Represents an undefined Value
TrueOrFalse | Represents either a True or False Value.

Remarks

  • In order for any filtering to work, the field must be established.

  • By default, this property is set to true.

Example

To select all records which boolean value is true:

[C#]
 BooleanValueCondition bvc = new BooleanValueCondition();
bvc.Comparison = BooleanValueComparison.True;
bvc.Field = Grid1.Fields["Check"];
Grid1.Filtering.Conditions.Add(bvc);

Applies to

BooleanValueCondition

See Also

BooleanValueCondition Class | BooleanValueCondition Members


Field property of class

FieldValueCondition.Field Property

Gets or sets the field to which the condition will apply

[Visual Basic]
Public Property Field As DataField[C#]
public DataField Field {get;set;}

Remarks

  • This is an abstract base class that defines only the GridField affected by the condition. For each different Field Type, a specific ValueCondition class is available.

Example

To apply a condition to a Numeric Field in the grid

[C#]
 NumericValueCondition myCondition = new NumericValueCondition();
myCondition.Field = grid1.Fields[3];
myCondition.Comparison = NumberComparison.GreaterThan;
myCondition.Value = 10;

Applies to

FieldValueCondition

See Also

FieldValueCondition Class | FieldValueCondition Members


ButtonPager class

Provides access to the ButtonPager object.

For a list of all members of this type, see ButtonPager Members

GridFX.WebForms.GridPagerSettings
GridFX.WebForms.ButtonPager

Remarks

This class provides manipulation of the pager settings.


ButtonPager Class Members

ButtonPager Members

ButtonPager Overview

Public Properties

public property EnableLooping | Gets or sets whether the pager will loop back to the first page after reaching the last page when the forward button is pressed.
public property Style (inherited from GridPagerSettings) | Gets the style settings of the pager.
public property Visibility (inherited from GridPagerSettings) | Gets or sets the conditions that will make the pager visible or not.


EnableLooping property of class

ButtonPager.EnableLooping Property

Gets or sets whether the pager will loop back to the first page after reaching the last page when the forward button is pressed.

[Visual Basic]
Public Property EnableLooping As Boolean[C#]
public Boolean EnableLooping {get;set;}

Remarks

  • By default, the pager stops going forward once it gets to the last page.

Example

To enable looping for the TopPager:

[C#]
 ((GridFX.WebForms.ButtonPager)Grid1.Paging.TopPager).EnableLooping = true;

[Visual Basic]
 CType(Grid1.Paging.TopPager,GridFX.WebForms.ButtonPager).EnableLooping = true

Applies to

ButtonPager

See Also

ButtonPager Class | ButtonPager Members


Style property of class

GridPagerSettings.Style Property

Gets the style settings of the pager.

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Example

To bold the pager text:

[C#]
 Grid1.Paging.TopPager.Style.Bold = true;

[Visual Basic]
 Grid1.Paging.TopPager.Style.Bold = true

Applies to

GridPagerSettings

See Also

GridPagerSettings Class | GridPagerSettings Members


Visibility property of class

GridPagerSettings.Visibility Property

Gets or sets the conditions that will make the pager visible or not.

[Visual Basic]
Public Property Visibility As PagerVisibility[C#]
public PagerVisibility Visibility {get;set;}

Value | Meaning
VisibleIfMultiplePages | Description goes here
AlwaysVisible | Description goes here
NeverVisible | Description goes here

Example

To make the TopPager always visible:

[C#]
 Grid1.Paging.TopPager.Visibility = GridFX.WebForms.PagerVisibility.AlwaysVisible;

[Visual Basic]
 Grid1.Paging.TopPager.Visibility = GridFX.WebForms.PagerVisibility.AlwaysVisible

Applies to

GridPagerSettings

See Also

GridPagerSettings Class | GridPagerSettings Members


CellStyle class

Style settings for a table cell.

For a list of all members of this type, see CellStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.CellStyle

Remarks

CellStyle is used to access the settings of different grid's elements, such as columns, header, row header, etc.

Typically you may not assign a CellStyle object directly. Rather, you must access the members of the class. For example, if you want to set the backcolor of the column header to red, you will use the following code:

StringGrid1.ColumnHeader.Style.BackColor = Color.Red;


CellStyle Class Members

CellStyle Members

CellStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property HorizontalAlign | Gets or sets the horizontal alignment used by a CellStyle
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Overflow | Gets or sets whether the cell text will be clipped or not.
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property VerticalAlign | Gets or sets the vertical alignment used by a CellStyle
public property Wrap | Gets or sets whether the text contents of the cell will be wrapped or not.


BackColor property of class

StyleSettings.BackColor Property

Gets or sets the background color of a SingleCellColumn in the Grid

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Example

To set the backcolor of the grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.BackColor = Color.LightGreen;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.BackColor = System.Drawing.Color.LightGreen

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


Bold property of class

StyleSettings.Bold Property

Gets or sets the Bold property which displays the text of a SingleCellColumn in bold

[Visual Basic]
Public Property Bold As Boolean[C#]
public Boolean Bold {get;set;}

Example

To enable the bold property of data in the grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.Bold = true;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Bold = true

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


CssClass property of class

StyleSettings.CssClass Property

Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid

[Visual Basic]
Public Property CssClass As String[C#]
public String CssClass {get;set;}

Remarks

  • The defined StyleSheet must be referenced in the aspx before setting this property to the CssClass.

Example

To set the CssClass of text in the Grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.CssClass = "cssClass";

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.CssClass = "cssClass"

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


FontFamily property of class

StyleSettings.FontFamily Property

Gets or sets the text Font of a SingleCellColumn in the Grid

[Visual Basic]
Public Property FontFamily As String[C#]
public String FontFamily {get;set;}

Example

To set the font property of data in the grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.FontFamily = "Courier New";

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.FontFamily = "Courier New"

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


FontSize property of class

StyleSettings.FontSize Property

Gets or sets the font size of text in a SingleCellColumn in the Grid

[Visual Basic]
Public Property FontSize As FontUnit[C#]
public FontUnit FontSize {get;set;}

Example

To set the font size of text in the grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.FontSize = 10;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.FontSize = 10

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


ForeColor property of class

StyleSettings.ForeColor Property

Gets or sets the text color of a SingleCellColumn in the Grid

[Visual Basic]
Public Property ForeColor As Color[C#]
public Color ForeColor {get;set;}

Example

To set the text color of the grid column:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.ForeColor = Color.DarkOrchid;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.ForeColor = System.Drawing.Color.DarkOrchid

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


HorizontalAlign property of class

CellStyle.HorizontalAlign Property

Gets or sets the horizontal alignment used by a CellStyle

[Visual Basic]
Public Property HorizontalAlign As HorizontalAlign[C#]
public HorizontalAlign HorizontalAlign {get;set;}

Remarks

  • By default, the CellStyle is taken from the current Motif. Setting a different HorizontalAlign will override it.

  • Setting its value to HorizontalAlign.NotSet will revert to the style specified by the Grid and/or the Motif.

  • Refer to the .NET Framework documentation of System.Web.UI.WebControls.HorizontalAlign for further details.

Example

To set the horizontal alignment of the first column's items to justify:

[C#]
 SingleCellColumn singleCellColumn = (SingleCellColumn) Grid1.Columns[0];
singleCellColumn.Style.Items.HorizontalAlign = HorizontalAlign.Justify;

[Visual Basic]
 Dim singleCellColumn As GridFX.WebForms.SingleCellColumn
singleCellColumn = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
singleCellColumn.Style.Items.HorizontalAlign = System.Web.UI.WebControls.HorizontalAlign.Justify

Applies to

CellStyle

See Also

CellStyle Class | CellStyle Members | VerticalAlign Property | Motif Property


Italic property of class

StyleSettings.Italic Property

Gets or sets the Italic property which displays the text of a SingleCellColumn in italic

[Visual Basic]
Public Property Italic As Boolean[C#]
public Boolean Italic {get;set;}

Example

To set the text style in italic:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.Italic = true;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Italic = true

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


Overflow property of class

CellStyle.Overflow Property

Gets or sets whether the cell text will be clipped or not.

[Visual Basic]
Public Property Overflow As OverflowBehavior[C#]
public OverflowBehavior Overflow {get;set;}

Value | Meaning
Wrap | Description goes here
Ellipsis | Description goes here
Clip | Description goes here
Visible | Description goes here

Remarks

  • Overflow can be set to Clip or Ellipsis. Setting the property to Clip will clip the text if the cell contents is too long. Setting the property to Ellipsis will add (...) to the end of the text.

    The CellStyle.Wrap property should be set to false when using Overflow property.

Example

To set the Overflow property to Clip:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.Wrap = false;
sc.Style.Overflow = OverflowBehavior.Clip;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Wrap = false
sc.Style.Overflow = GridFX.WebForms.OverflowBehavior.Clip

Applies to

CellStyle

See Also

CellStyle Class | CellStyle Members


Underline property of class

StyleSettings.Underline Property

Gets or sets the Underline property of text of a SingleCellColumn in the Grid

[Visual Basic]
Public Property Underline As Boolean[C#]
public Boolean Underline {get;set;}

Example

To set the underline property of text to true:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.Underline = true;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Underline = true

Applies to

StyleSettings

See Also

StyleSettings Class | StyleSettings Members


VerticalAlign property of class

CellStyle.VerticalAlign Property

Gets or sets the vertical alignment used by a CellStyle

[Visual Basic]
Public Property VerticalAlign As VerticalAlign[C#]
public VerticalAlign VerticalAlign {get;set;}

Remarks

  • By default, the CellStyle is taken from the current Motif. Setting a different HorizontalAlign will override it.

  • Setting its value to VerticalAlign.NotSet will revert to the style specified by the Grid and/or the Motif.

  • Refer to the .NET Framework documentation of System.Web.UI.WebControls.VerticalAlign for further details.

Example

To set the vertical alignment of the first column's items to top:

[C#]
 SingleCellColumn singleCellColumn = (SingleCellColumn) Grid1.Columns[0];
singleCellColumn.Style.Items.VerticalAlign = VerticalAlign.Top;

[Visual Basic]
 Dim singleCellColumn As GridFX.WebForms.SingleCellColumn
singleCellColumn = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
singleCellColumn.Style.Items.VerticalAlign = System.Web.UI.WebControls.VerticalAlign.Top

Applies to

CellStyle

See Also

CellStyle Class | CellStyle Members | HorizontalAlign Property | Motif Property


Wrap property of class

CellStyle.Wrap Property

Gets or sets whether the text contents of the cell will be wrapped or not.

[Visual Basic]
Public Property Wrap As Boolean[C#]
public Boolean Wrap {get;set;}

Remarks

  • Use the Width property if needed to see the effect of the Wrap property. Set the Width property of the cell to a value such that the text contents won't fit in the grid cell.

    By setting the property to false, the cell contents will not be wrapped to the next line.

Example

To set the Wrap property to true:

[C#]
 SingleCellColumn sc = (SingleCellColumn)Grid1.Columns[0];
sc.Style.Wrap = true;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Wrap = true

Applies to

CellStyle

See Also

CellStyle Class | CellStyle Members


ChartField class

A field that binds to a collection and displays it using a Chart.

For a list of all members of this type, see ChartField Members

GridFX.WebForms.DataField
GridFX.WebForms.ChartField

Remarks

Used to set properties of the Charts associated with the ChartField in the Grid


ChartField Class Members

ChartField Members

ChartField Overview

Public Properties

public property Chart | Gets access to the Chart class that allows to set properties of the Chart associated with the ChartField
public property CollapsedMode | Gets or sets the way the chart will be displayed
public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property DataSourceID | Gets or sets the DataSource of the ChartField
public property DataSourceMember | Gets or sets the DataSourceMember of the ChartField
public property ExpandedSize | Gets or sets the size of the expanded chart
public property ExpandEvent | Gets or sets the event that will trigger the expansion
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property ThumbnailSize | Gets or sets the size of the chart as a thumbnail
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Chart property of class

ChartField.Chart Property

Gets access to the Chart class that allows to set properties of the Chart associated with the ChartField

[Visual Basic]
Public ReadOnly Property Chart As Chart[C#]
public Chart Chart {get;}

Remarks

  • The Chart property allows access to all the attributes and properties of the chart.

Example

To hide the charts' legend box:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
chartField.Chart.LegendBox.Visible = false;

[Visual Basic]
 Dim chartField As New ChartField
chartField = CType(Grid1.Fields("Chart"), GridFX.WebForms.ChartField)
chartField.Chart.LegendBox.Visible = False

Applies to

ChartField

See Also

ChartField Class | ChartField Members


CollapsedMode property of class

ChartField.CollapsedMode Property

Gets or sets the way the chart will be displayed

[Visual Basic]
Public Property CollapsedMode As CollapsedMode[C#]
public CollapsedMode CollapsedMode {get;set;}

Property Value

The default is Sparkline.

Value | Meaning
Thumbnail | Displays the chart as a thumbnail
Icon | Displays the chart as an Icon
Full | Displays the chart at its full size
Sparkline | Displays the chart as a sparkline

Remarks

  • The CollapsedMode property allows to change the way the charts will be displayed in the ChartField.

  • The charts can be shown as an icon, a thumbnail or as a full sized chart.

Example

Set the CollapsedMode to thumbnail

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
chartField.CollapsedMode = CollapsedMode.Thumbnail;

[Visual Basic]
 Dim chartField As New ChartField
chartField = CType(Grid1.Fields("Chart"), GridFX.WebForms.ChartField)
chartField.CollapsedMode = CollapsedMode.Thumbnail

Applies to

ChartField

See Also

ChartField Class | ChartField Members


DataSourceID property of class

ChartField.DataSourceID Property

Gets or sets the DataSource of the ChartField

[Visual Basic]
Public Property DataSourceID As String[C#]
public String DataSourceID {get;set;}

Example

To set the DataSource for the ChartField:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
chartField.DataSourceID = "AccessDataSource2";

Applies to

ChartField

See Also

ChartField Class | ChartField Members


DataSourceMember property of class

ChartField.DataSourceMember Property

Gets or sets the DataSourceMember of the ChartField

[Visual Basic]
Public Property DataSourceMember As String[C#]
public String DataSourceMember {get;set;}

Remarks

  • When getting data from more than one database, this property defines the ID of the selected database.

Example

To set the DataSourceMember of the Chart:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
chartField.DataSourceMember = "DBTable1";

Applies to

ChartField

See Also

ChartField Class | ChartField Members


ExpandedSize property of class

ChartField.ExpandedSize Property

Gets or sets the size of the expanded chart

[Visual Basic]
Public Property ExpandedSize As Size[C#]
public Size ExpandedSize {get;set;}

Remarks

  • The ExpandedSize property establishes the width and height of the chart when it is expanded.

Example

To set the expanded size of a chart field:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
System.Drawing.Size expandedSize = new System.Drawing.Size(300,300);
chartField.ExpandedSize = expandedSize;

[Visual Basic]
 Dim chartField As New ChartField
chartField = CType(Grid1.Fields("Chart"), GridFX.WebForms.ChartField)
Dim expandedSize As New System.Drawing.Size(300, 300)
chartField.ExpandedSize = expandedSize

Applies to

ChartField

See Also

ChartField Class | ChartField Members


ExpandEvent property of class

ChartField.ExpandEvent Property

Gets or sets the event that will trigger the expansion

[Visual Basic]
Public Property ExpandEvent As PopupExpandEvent[C#]
public PopupExpandEvent ExpandEvent {get;set;}

Property Value

The default is Click.

Value | Meaning
Never | To disable the ExpandEvent.
Click | To expand by clicking.
Hover | To expand by hovering.
ClickOrHover | To expand either by clicking or hovering.

Remarks

  • By default this property is set to Click.

Example

To set a chart to expand either by clicking or hovering on it:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
chartField.CollapsedMode = CollapsedMode.Sparkline;
chartField.ExpandEvent = ThumbnailExpandEvent.ClickOrHover;

[Visual Basic]
 Dim chartField As New ChartField
chartField = CType(Grid1.Fields("Chart"), GridFX.WebForms.ChartField)
chartField.ExpandEvent = ThumbnailExpandEvent.ClickOrHover

Applies to

ChartField

See Also

ChartField Class | ChartField Members


ThumbnailSize property of class

ChartField.ThumbnailSize Property

Gets or sets the size of the chart as a thumbnail

[Visual Basic]
Public Property ThumbnailSize As Size[C#]
public Size ThumbnailSize {get;set;}

Remarks

  • The ThumbnailSize property establishes the width and height of the chart when the CollapsedMode is set to Thumbnail.

Example

To set the size of the thumbnail:

[C#]
 ChartField chartField = (ChartField)Grid1.Fields["Chart"];
System.Drawing.Size thumbnailSize = new System.Drawing.Size(50, 50);
chartField.ThumbnailSize = thumbnailSize;

[Visual Basic]
 Dim chartField As New ChartField
chartField = CType(Grid1.Fields("Chart"), GridFX.WebForms.ChartField)
Dim thumbnailSize As New System.Drawing.Size(50, 50)
chartField.ThumbnailSize = thumbnailSize

Applies to

ChartField

See Also

ChartField Class | ChartField Members


ColumnAreasStyle class

A style that has style properties for an column as well as specific styles for the column header and items.

For a list of all members of this type, see ColumnAreasStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.CellStyle
GridFX.WebForms.ColumnAreasStyle

Remarks

Any property(ies) set at the root level will cascade down to the Header and Item styles, unless of course they have the same property(ies) set.


ColumnAreasStyle Class Members

ColumnAreasStyle Members

ColumnAreasStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property Header | Gets access to the CellStyle class which allows to set the style attributes of cells in the column header
public property HorizontalAlign (inherited from CellStyle) | Gets or sets the horizontal alignment used by a CellStyle
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Items | Gets access to the CellStyle class which allows to set the style attributes of cells in the grid items
public property Overflow (inherited from CellStyle) | Gets or sets whether the cell text will be clipped or not.
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property VerticalAlign (inherited from CellStyle) | Gets or sets the vertical alignment used by a CellStyle
public property Wrap (inherited from CellStyle) | Gets or sets whether the text contents of the cell will be wrapped or not.


Header property of class

ColumnAreasStyle.Header Property

Gets access to the CellStyle class which allows to set the style attributes of cells in the column header

[Visual Basic]
Public ReadOnly Property Header As CellStyle[C#]
public CellStyle Header {get;}

Example

To set the background color of the column header:

[C#]
 SingleCellColumn singleCellColumn = (SingleCellColumn)Grid1.Columns[0];
singleCellColumn.Style.Header.BackColor = Color.LightGreen;

[Visual Basic]
 Dim singleCellColumn As GridFX.WebForms.SingleCellColumn
singleCellColumn = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
singleCellColumn.Style.Header.BackColor = System.Drawing.Color.LightGreen

Applies to

ColumnAreasStyle

See Also

ColumnAreasStyle Class | ColumnAreasStyle Members | CellStyle Class Class


Items property of class

ColumnAreasStyle.Items Property

Gets access to the CellStyle class which allows to set the style attributes of cells in the grid items

[Visual Basic]
Public ReadOnly Property Items As CellStyle[C#]
public CellStyle Items {get;}

Example

To set the text color of the grid items in a column:

[C#]
 SingleCellColumn singleCellColumn = (SingleCellColumn)Grid1.Columns[0];
singleCellColumn.Style.Items.ForeColor = Color.DarkOrange;

[Visual Basic]
 Dim singleCellColumn As GridFX.WebForms.SingleCellColumn
singleCellColumn = CType(Grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
singleCellColumn.Style.Items.ForeColor = System.Drawing.Color.DarkOrange

Applies to

ColumnAreasStyle

See Also

ColumnAreasStyle Class | ColumnAreasStyle Members | CellStyle Class Class


ColumnCell class

A cell that is contained within a MultiCellColumn.

For a list of all members of this type, see ColumnCell Members

GridFX.WebForms.LayoutCell
GridFX.WebForms.ColumnCell

Remarks

Provides functionality to set the style and title for the grid cell which enhances the appearance of the grid.


ColumnCell Class Members

ColumnCell Members

ColumnCell Overview

Public Properties

public property ColumnSpan (inherited from LayoutCell) | Gets or sets the number of columns that a grid field cell will span.
public property RowSpan (inherited from LayoutCell) | Gets or sets the number of rows a grid field cell will span.
public property Style | Gets a reference to the CellStyle and StyleSettings class that allows you to set the style attributes of the ColumnCell.
public property Title | Gets or sets the title text for the grid cell.
public property Visible (inherited from LayoutCell) | Gets or sets the visible property which allows the cell to be displayed or hidden.


ColumnSpan property of class

LayoutCell.ColumnSpan Property

Gets or sets the number of columns that a grid field cell will span.

[Visual Basic]
Public Property ColumnSpan As Int32[C#]
public Int32 ColumnSpan {get;set;}

Remarks

  • There should be atleast one field column after the column for which the column span property is being set.

    [C#]
     GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
    grid1.Columns.Add(mc);
    GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
    cell.ColumnSpan = 2;
    mc.Cells.Add(cell);
    GridFX.WebForms.FieldCell cell1 = new FieldCell();
    cell1.Field = grid1.Fields["Discontinued"];
    mc.Cells.Add(cell1);

Example

To set the columnspan to 2:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.ColumnSpan = 2;
mc.Cells.Add(cell);
GridFX.WebForms.FieldCell cell1 = new FieldCell();
cell1.Field = grid1.Fields["Discontinued"];
mc.Cells.Add(cell1);

Applies to

LayoutCell

See Also

LayoutCell Class | LayoutCell Members


RowSpan property of class

LayoutCell.RowSpan Property

Gets or sets the number of rows a grid field cell will span.

[Visual Basic]
Public Property RowSpan As Int32[C#]
public Int32 RowSpan {get;set;}

Remarks

  • Setting the rowspan of a cell to 2 yields a grid similar to this one:

    [C#]
     GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
    grid1.Columns.Add(mc);
    GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
    cell.RowSpan = 2;
    mc.Cells.Add(cell);
    GridFX.WebForms.FieldCell cell1 = new FieldCell();
    cell1.Field = grid1.Fields["Discontinued"];
    mc.Cells.Add(cell1);

Example

To set the rowspan to 2:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.RowSpan = 2;
mc.Cells.Add(cell);
GridFX.WebForms.FieldCell cell1 = new FieldCell();
cell1.Field = grid1.Fields["Discontinued"];
mc.Cells.Add(cell1);

Applies to

LayoutCell

See Also

LayoutCell Class | LayoutCell Members


Style property of class

ColumnCell.Style Property

Gets a reference to the CellStyle and StyleSettings class that allows you to set the style attributes of the ColumnCell.

[Visual Basic]
Public ReadOnly Property Style As ColumnAreasStyle[C#]
public ColumnAreasStyle Style {get;}

Remarks

  • The Style values will cascade down to the header, footer and items of the column.

    [C#]
     MultiCellColumn mc = (MultiCellColumn)grid1.Columns[2];
    ColumnCell cc = mc.Cells[0];
    cc.Style.Italic = true;

Example

To set the style of the column to "Italic":

[C#]
 MultiCellColumn mc = (MultiCellColumn) grid1.Columns[2];
ColumnCell cc = mc.Cells[0];
cc.Style.Italic = true;

[Visual Basic]
 Dim mc As GridFX.WebForms.MultiCellColumn
mc = CType(grid1.Columns(2),GridFX.WebForms.MultiCellColumn)
Dim cc As GridFX.WebForms.ColumnCell
cc = mc.Cells(0)
cc.Style.Italic = true

Applies to

ColumnCell

See Also

ColumnCell Class | ColumnCell Members | CellStyle Class Class | StyleSettings Class Class | ColumnAreasStyle Class Class


Title property of class

ColumnCell.Title Property

Gets or sets the title text for the grid cell.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Example

To set the cell title to 'My title':

[C#]
 MultiCellColumn mc = (MultiCellColumn) grid1.Columns[2];
ColumnCell cc = mc.Cells[0];
cc.Title = "My Title";

[Visual Basic]
 Dim mc As GridFX.WebForms.MultiCellColumn
mc = CType(grid1.Columns(2),GridFX.WebForms.MultiCellColumn)
Dim cc As GridFX.WebForms.ColumnCell
cc = mc.Cells(0)
cc.Title = "My Title"

Applies to

ColumnCell

See Also

ColumnCell Class | ColumnCell Members


Visible property of class

LayoutCell.Visible Property

Gets or sets the visible property which allows the cell to be displayed or hidden.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • Setting this property to false will hide the MultiCellColumn that contains the cell.

  • When setting this property to false, the RowSpan and ColumnSpan settings for this cell will be ignored.

Example

To hide the grid field:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.Visible = false;
mc.Cells.Add(cell);

Applies to

LayoutCell

See Also

LayoutCell Class | LayoutCell Members


ColumnsExtremitySettings class

Settings for the grid's column header.

For a list of all members of this type, see ColumnsExtremitySettings Members

GridFX.WebForms.ColumnsExtremitySettings

Remarks

Used to set the properties of the Grid's column header bar.


ColumnsExtremitySettings Class Members

ColumnsExtremitySettings Members

ColumnsExtremitySettings Overview

Public Properties

public property Style | Gets access to the CellStyle class which allows to set the style attributes of the Grid's header bar
public property Visible | Gets or sets whether the Grid's header bar will be displayed or hidden


Style property of class

ColumnsExtremitySettings.Style Property

Gets access to the CellStyle class which allows to set the style attributes of the Grid's header bar

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Remarks

  • This property exposes the members of the CellStyle class. Please see the CellStyle class for additional information regarding those supported members.

Example

To set the style of the text contents of the grid's header bar:

[C#]
 Grid1.Header.Style.ForeColor = Color.DodgerBlue;
Grid1.Header.Style.HorizontalAlign = HorizontalAlign.Center;

Applies to

ColumnsExtremitySettings

See Also

ColumnsExtremitySettings Class | ColumnsExtremitySettings Members | CellStyle Class Class


Visible property of class

ColumnsExtremitySettings.Visible Property

Gets or sets whether the Grid's header bar will be displayed or hidden

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Example

To hide the grid's header bar:

[C#]
 Grid1.Header.Visible = false;

Applies to

ColumnsExtremitySettings

See Also

ColumnsExtremitySettings Class | ColumnsExtremitySettings Members


DataField class

Provides access to the GridField Class and to the layer between Grid Elements and actual Data Values with options for formatting, input, grouping, etc.

For a list of all members of this type, see DataField Members

GridFX.WebForms.DataField

Remarks

When using a GridField Object, you can retrieve values from the underlying DataSource, Format Values for displaying on the Grid, as well as providing Controls for modifying values within Grid Items.


DataField Class Members

DataField Members

DataField Overview

Public Properties

public property Culture | Allows the user localize a DataField for a specific language and region.
public property DataPath | Gets or sets the mapping string that points to the data field within a data item
public property Filtering | Gets filtering settings for a DataField.
public property Grouping | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property IsKey | Gets or sets whether the DataField is a Data Key.
public property ReadOnly | Gets or sets whether a DataField is editable or not.
public property Sorting | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title | Gets or sets the title for a DataField
public property UniqueID | Gets or sets a Unique Identifier for a DataField
public property Visible | Gets or sets whether the DataField will be visible or not.


DateTimeField class

A field that handles DateTime values.

For a list of all members of this type, see DateTimeField Members

GridFX.WebForms.DataField
GridFX.WebForms.DateTimeField

Remarks

It allows access to the DateTimeField class. Most properties are inherited from the GridField Class.


DateTimeField Class Members

DateTimeField Members

DateTimeField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Gets a DateTimeFormatter object that specifies formatting settings for the DateTime Field
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property Input | Gets the input settings object for the DateTimeField
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Format property of class

DateTimeField.Format Property

Gets a DateTimeFormatter object that specifies formatting settings for the DateTime Field

[Visual Basic]
Public ReadOnly Property Format As DateTimeFormatter[C#]
public DateTimeFormatter Format {get;}

Remarks

  • This property allows the developer to specify the way the field displays boolean data.

  • Besides the default text display, it is also possible to set the date to display using a DigitalPanel instead.

  • Use this property to specify the formatting of the date values (long and short dates, custom formatting, etc.)

Example

To set the DateField to display using DigitalPanels:

[C#]
 DateTimeField myDateField = (DateTimeField)grid1.Fields[1];
myDateField.Format.Display = DateTimeDisplayType.DigitalPanel;

Applies to

DateTimeField

See Also

DateTimeField Class | DateTimeField Members | DateTimeFormatter Class


Input property of class

DateTimeField.Input Property

Gets the input settings object for the DateTimeField

[Visual Basic]
Public ReadOnly Property Input As DateTimeFieldInputSettings[C#]
public DateTimeFieldInputSettings Input {get;}

Remarks

  • This property allows you to define if a specific DateTimeField in the Grid is required.

Example

To set a specific DateTimeField to be always required:

[C#]
 DateTimeField myDateField = (DateTimeField)grid1.Fields[1];
myDateField.Input.Required = DateTimeFieldRequiredInput.Always;

Applies to

DateTimeField

See Also

DateTimeField Class | DateTimeField Members


DateTimeFormatter class

Formats DateField objects.

For a list of all members of this type, see DateTimeFormatter Members

GridFX.WebForms.FieldValueFormatter
GridFX.WebForms.DateTimeFormatter

Remarks

Permits the use of a number of output formatting options; like for instance, displaying dates as text or as a digital panel.


DateTimeFormatter Class Members

DateTimeFormatter Members

DateTimeFormatter Overview

Public Properties

public property CustomFormat | Gets or sets a custom date value format.
public property DigitalPanel | Allows access to all the attributes and properties of the digital panels.
public property Display | Gets and sets how the dates will be shown.
public property NullText | Gets or sets the text to shown when a date is null.
public property TreatMinAsNull | Allows the user to treat the minimum value for a DateTimeField as if it was a Null value
public property ValueFormat | Gets and sets pre-defined DateTime formats.


CustomFormat property of class

DateTimeFormatter.CustomFormat Property

Gets or sets a custom date value format.

[Visual Basic]
Public Property CustomFormat As String[C#]
public String CustomFormat {get;set;}

Remarks

  • In order to use this property, the ValueFormat property must be set to Custom.

Example

To define a custom date value format:

[C#]
 DateTimeField dateTimeField = (DateTimeField)Grid1.Fields["Date"];
dateTimeField.Format.ValueFormat = DateTimeValueFormat.Custom;
dateTimeField.Format.CustomFormat = "mm/dd/yy";

[Visual Basic]
 Dim dateTimeField As New DateTimeField
dateTimeField = CType(Grid1.Fields("Date"), GridFX.WebForms.DateTimeField)
dateTimeField.Format.ValueFormat = DateTimeValueFormat.Custom
dateTimeField.Format.CustomFormat = "mm/dd/yy"

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members


DigitalPanel property of class

DateTimeFormatter.DigitalPanel Property

Allows access to all the attributes and properties of the digital panels.

[Visual Basic]
Public ReadOnly Property DigitalPanel As DigitalPanel[C#]
public DigitalPanel DigitalPanel {get;}

Remarks

  • This property is used when the DateTimeFormatter Display property is set to DigitalPanel in order to have access to all the attributes and properties of the digital panels.

Example

To set the back color of the digital panel:

[C#]
 DateTimeField dateTimeField = (DateTimeField)Grid1.Fields["Date"];
dateTimeField.Format.DigitalPanel.BackColor = System.Drawing.Color.Aqua;

              [Visual Basic]
Dim dateTimeField As New DateTimeField
        dateTimeField = CType(Grid1.Fields("Date"), GridFX.WebForms.DateTimeField)
dateTimeField.Format.DigitalPanel.BackColor = Drawing.Color.Aqua

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members


Display property of class

DateTimeFormatter.Display Property

Gets and sets how the dates will be shown.

[Visual Basic]
Public Property Display As DateTimeDisplayType[C#]
public DateTimeDisplayType Display {get;set;}

Property Value

The default is Text.

Value | Meaning
Text | Displays the dates as text.
DigitalPanel | Displays the dates as a digital panel.

Remarks

  • The Display property allows the date to be shown as text or as a digital panel.

  • By default this property is set to show the dates as text.

Example

To display dates as a digital panel:

[C#]
 DateTimeField dateTimeField = (DateTimeField)Grid1.Fields["Date"];
dateTimeField.Format.Display = DateTimeDisplayType.DigitalPanel;

[Visual Basic]
 Dim dateTimeField As New DateTimeFielddateTimeField = CType(Grid1.Fields("Date"), GridFX.WebForms.DateTimeField)dateTimeField.Format.Display = DateTimeDisplayType.DigitalPanel

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members


NullText property of class

DateTimeFormatter.NullText Property

Gets or sets the text to shown when a date is null.

[Visual Basic]
Public Property NullText As String[C#]
public String NullText {get;set;}

Example

To set the null text:

[C#]
 DateTimeField dateTimeField = (DateTimeField)Grid1.Fields["Date"];
dateTimeField.Format.NullText = "The date is null";

[Visual Basic]
 Dim dateTimeField As New DateTimeField
dateTimeField = CType(Grid1.Fields("Date"), GridFX.WebForms.DateTimeField)
dateTimeField.Format.NullText = "The date is null"

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members


TreatMinAsNull property of class

DateTimeFormatter.TreatMinAsNull Property

Allows the user to treat the minimum value for a DateTimeField as if it was a Null value

[Visual Basic]
Public Property TreatMinAsNull As Boolean[C#]
public Boolean TreatMinAsNull {get;set;}

Example

To treat the minimum value of a specific field as a Null value:

[C#]
 DateTimeField myDateField = (DateTimeField)grid1.Fields[0];
myDateField.Format.TreatMinAsNull = true;

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members


ValueFormat property of class

DateTimeFormatter.ValueFormat Property

Gets and sets pre-defined DateTime formats.

[Visual Basic]
Public Property ValueFormat As DateTimeValueFormat[C#]
public DateTimeValueFormat ValueFormat {get;set;}

Property Value

The default is ShortDate.

Value | Meaning
NotSet | Uses the default format.
ShortDate | Displays two digits for the month, two for the day and four for the year.
ShortTime | Displays two digits for the hour, two for the minutes and AM or PM.
LongDate | Displays the day of the week and month as text, two digits for the day of the month and four digits for the year.
LongTime | Description goes here
ShortDateTime | Description goes here
LongDateTime | Description goes here
MonthDay | Description goes here
YearMonth | Description goes here
Custom | Description goes here

Remarks

  • This property provides a number of date formatting options, which avoids having to enter the actual pattern.

  • In addition this property also has the option to enter a custom format.

  • The settings established with this property will affect the date format whether the dates are displayed as text or as a digital panel.

Example

To set the ValueFormat to ShortDateTime:

[C#]
 DateTimeField dateTimeField = (DateTimeField)Grid1.Fields["Date"];
dateTimeField.Format.ValueFormat = DateTimeValueFormat.ShortDateTime;

[Visual Basic]
 Dim dateTimeField As New DateTimeField
dateTimeField = CType(Grid1.Fields("Date"), GridFX.WebForms.DateTimeField)
dateTimeField.Format.ValueFormat = DateTimeValueFormat.ShortDateTime

Applies to

DateTimeFormatter

See Also

DateTimeFormatter Class | DateTimeFormatter Members | CustomFormat Property


DateTimeIncrementInterval class

Provides access to the DateTimeIncrementInterval object.

For a list of all members of this type, see DateTimeIncrementInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval

Remarks

This class allows control over the Date Intervals and Ranges.


DateTimeIncrementInterval Class Members

DateTimeIncrementInterval Members

DateTimeIncrementInterval Overview

Public Properties

public property DateTimeFormatInTitle | Gets or sets how the dates will be shown in the groups title.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length | Gets or sets the length of the Interval.
public property NullTitle | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles | Allows the utilization of relative titles.
public property Start | Gets or sets the start for the group.
public property StartSource | Gets or sets how the groups will start.
public property Title | Gets or sets the groups' title.


DateTimeFormatInTitle property of class

DateTimeIncrementInterval.DateTimeFormatInTitle Property

Gets or sets how the dates will be shown in the groups title.

[Visual Basic]
Public Property DateTimeFormatInTitle As String[C#]
public String DateTimeFormatInTitle {get;set;}

Remarks

  • In order to format the title this property uses the Standard DateTime Format Strings.

  • For example, a "d" would format the title as a short date pattern, a "D" as a long date pattern, a ''t' as a short time pattern and so on.

Example

To set the date format of the title to display as a short date pattern:

[C#]
 WeekInterval wi = new WeekInterval();
wi.DateTimeFormatInTitle = "d";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.DateTimeFormatInTitle = "d"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members


HideData property of class

GroupInterval.HideData Property

Allows to hide the field name of the records.

[Visual Basic]
Public Property HideData As Boolean[C#]
public Boolean HideData {get;set;}

Remarks

  • By default, the records inside of the groups will display the data that is being used to place them in the groups. This property allows to hide that data.

Example

To hide the data from the records under the groups:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.HideData = true;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.HideData = true
Grid1.Grouping.RootLevel.Interval = fni

Applies to

GroupInterval

See Also

GroupInterval Class | GroupInterval Members


Length property of class

DateTimeIncrementInterval.Length Property

Gets or sets the length of the Interval.

[Visual Basic]
Public Property Length As Int32[C#]
public Int32 Length {get;set;}

Remarks

  • This property sets the length of dates the Interval will encompass.

  • For instance, if the interval is set to weeks and the length of that interval is set to 2, then each group will contain data for two weeks.

Example

To set a two week interval:

[C#]
 WeekInterval wi = new WeekInterval();
wi.Length = 2;
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.Length = 2
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members


NullTitle property of class

DateTimeIncrementInterval.NullTitle Property

Gets or sets the title displayed when the date field of a record is null.

[Visual Basic]
Public Property NullTitle As String[C#]
public String NullTitle {get;set;}

Example

To set the title to be displayed for null dates:

[C#]
 WeekInterval wi = new WeekInterval();
wi.NullTitle = "Number of null dates:({ItemCount})";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.NullTitle = "Number of null dates:({ItemCount})"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members


RelativeTitles property of class

DateTimeIncrementInterval.RelativeTitles Property

Allows the utilization of relative titles.

[Visual Basic]
Public ReadOnly Property RelativeTitles As DateTimeRelativeTitles[C#]
public DateTimeRelativeTitles RelativeTitles {get;}

Remarks

  • This property is useful when a non-fixed title for the groups is desired. In other words, the titles can be customized to show a different information as the groups move away from the reference date.

Example

To edit a relative title:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.MoreThanOneIncrementBeforeNow = "Weeks Before the Specifed Date";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.MoreThanOneIncrementBeforeNow = "Weeks Before the Specifed Date"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members | Property | DateTimeRelativeTitles Class


Start property of class

DateTimeIncrementInterval.Start Property

Gets or sets the start for the group.

[Visual Basic]
Public Property Start As Int32[C#]
public Int32 Start {get;set;}

Remarks

  • By default, the start of the group is the date of the first record. This property is useful when a specific start of a group is desired regardless of the date of the first record.

  • For example, if the customer wants to organize the data in groups of 10 years starting on the fifth year of each decade, he or she would select a year interval with a length of 10 and a start of 5. In this case, groups would go from 1975 to 1984, then from 1985 to 1994 and so on.

  • In order to use this property the StartSource must be set to StartProperty.

Example

To set this property:

[C#]
 YearInterval yi = new YearInterval();
yi.Length = 10;
yi.Start = 5;
Grid1.Grouping.RootLevel.Interval = yi;

[Visual Basic]
 Dim yi As GridFX.WebForms.YearInterval
yi = New GridFX.WebForms.YearInterval
yi.Length = 10
yi.Start = 5
Grid1.Grouping.RootLevel.Interval = yi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members | Length Property | StartSource Property


StartSource property of class

DateTimeIncrementInterval.StartSource Property

Gets or sets how the groups will start.

[Visual Basic]
Public Property StartSource As GroupIntervalOffset[C#]
public GroupIntervalOffset StartSource {get;set;}

Value | Meaning
OffsetProperty | Description goes here
FirstDataValue | Description goes here
StartProperty | Description goes here

Remarks

  • By default this property is set to FirstDataValue.

  • If a specific group start is desired, then this property must be set to StartProperty.

Example

To enable this property:

[C#]
 YearInterval yi = new YearInterval();
yi.StartSource = GroupIntervalStart.StartProperty;
Grid1.Grouping.RootLevel.Interval = yi;

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members | Start Property


Title property of class

DateTimeIncrementInterval.Title Property

Gets or sets the groups' title.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

  • This property allows customization of the group title. For instance, it lets add words before and after the dates or rearrange the order of the items in the title altogether.

Example

To customize the group title:

[C#]
 WeekInterval wi = new WeekInterval();
wi.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeIncrementInterval

See Also

DateTimeIncrementInterval Class | DateTimeIncrementInterval Members | DateTimeFormatInTitle Property


DateTimeRange class

Allows access to the DateTimeRange object.

For a list of all members of this type, see DateTimeRange Members

GridFX.WebForms.DateTimeRange

Remarks

@2007 Software FX, Inc. All Rights Reserved. Grid FX and Chart FX are registered trademarks of Software FX, Inc.
All other names are trademarks or registered trademarks of their respective owners.


DateTimeRange Class Members

DateTimeRange Members

DateTimeRange Overview

Public Properties

public property DistanceFromReference | Gets or sets the range's interval and its distance from the reference date.
public property SubIncrement | Gets or sets the way the range's main interval (established in the DistanceFromReference property) will be broken down.


DistanceFromReference property of class

DateTimeRange.DistanceFromReference Property

Gets or sets the range's interval and its distance from the reference date.

[Visual Basic]
Public Property DistanceFromReference As DateTimeIncrementInterval[C#]
public DateTimeIncrementInterval DistanceFromReference {get;set;}

Remarks

  • The range's distance from the reference date is established by the range's length.

Example

To set the interval for the DistanceFromReference property of the range:

[C#]
 DateTimeRange range0 = new DateTimeRange();
range0.DistanceFromReference = new WeekInterval();

[Visual Basic]
 Dim range0 As GridFX.WebForms.DateTimeRange
range0 = New GridFX.WebForms.DateTimeRange
range0.DistanceFromReference = New GridFX.WebForms.WeekInterval

Applies to

DateTimeRange

See Also

DateTimeRange Class | DateTimeRange Members | SubIncrement Property


SubIncrement property of class

DateTimeRange.SubIncrement Property

Gets or sets the way the range's main interval (established in the DistanceFromReference property) will be broken down.

[Visual Basic]
Public Property SubIncrement As DateTimeIncrementInterval[C#]
public DateTimeIncrementInterval SubIncrement {get;set;}

Example

To break down a range's week interval into days:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
dtri.UseRelativeTitles = true;
DayInterval di = new DayInterval();
DateTimeRange range0 = new DateTimeRange();
range0.DistanceFromReference = new WeekInterval();
range0.SubIncrement = new DayInterval();
range0.SubIncrement = di;
dtri.RangesBeforeReferenceDate.Add(range0);
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
dtri.UseRelativeTitles = true
Dim di As GridFX.WebForms.DayInterval
di = New GridFX.WebForms.DayInterval
Dim range0 As GridFX.WebForms.DateTimeRange
range0 = New GridFX.WebForms.DateTimeRange
range0.DistanceFromReference = New GridFX.WebForms.WeekInterval
range0.SubIncrement = New GridFX.WebForms.DayInterval
range0.SubIncrement = di
dtri.RangesBeforeReferenceDate.Add(range0)
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DateTimeRange

See Also

DateTimeRange Class | DateTimeRange Members | DistanceFromReference Property


DateTimeRangeInterval class

Provides access to the DateTimeRangeInterval object.

For a list of all members of this type, see DateTimeRangeInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeRangeInterval

Remarks

This class allows a variable customization of the grouping by dates.

The customization is done by adding ranges to establish how the dates should be grouped before and after a specified reference date.


DateTimeRangeInterval Class Members

DateTimeRangeInterval Members

DateTimeRangeInterval Overview

Public Properties

public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property RangesAfterReferenceDate | Gets the ranges to be used after the reference date.
public property RangesBeforeReferenceDate | Gets the ranges to be used before the reference date.
public property ReferenceDate | Gets or sets the date used as a reference by the DateTimeRangeInterval.
public property UseRelativeTitles | Enables or disables the use of relative titles.


RangesAfterReferenceDate property of class

DateTimeRangeInterval.RangesAfterReferenceDate Property

Gets the ranges to be used after the reference date.

[Visual Basic]
Public ReadOnly Property RangesAfterReferenceDate As DateTimeRangeCollection[C#]
public DateTimeRangeCollection RangesAfterReferenceDate {get;}

Remarks

  • This property allows to set and add ranges to the DateTimeRangeInterval; each range specifying a grouping behavior.

  • The grouping established with this property will affect all records with dates later than the reference date.

Example

To set and add a range:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
DateTimeRange range0 = new DateTimeRange();
range0.DistanceFromReference = new WeekInterval();
range0.SubIncrement = new DayInterval();
dtri.RangesAfterReferenceDate.Add(range0);
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
Dim range0 As GridFX.WebForms.DateTimeRange
range0 = New GridFX.WebForms.DateTimeRange
range0.DistanceFromReference = New GridFX.WebForms.WeekInterval
range0.SubIncrement = New GridFX.WebForms.DayInterval
dtri.RangesAfterReferenceDate.Add(range0)
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DateTimeRangeInterval

See Also

DateTimeRangeInterval Class | DateTimeRangeInterval Members | ReferenceDate Property | DateTimeRange Class


RangesBeforeReferenceDate property of class

DateTimeRangeInterval.RangesBeforeReferenceDate Property

Gets the ranges to be used before the reference date.

[Visual Basic]
Public ReadOnly Property RangesBeforeReferenceDate As DateTimeRangeCollection[C#]
public DateTimeRangeCollection RangesBeforeReferenceDate {get;}

Remarks

  • This property allows to set and add ranges to the DateTimeRangeInterval, each range specifying a grouping behavior.

  • The grouping established with this property will affect all records with dates earlier than the reference date.

Example

To set and add a range:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
DateTimeRange range0 = new DateTimeRange();
range0.DistanceFromReference = new WeekInterval();
range0.SubIncrement = new DayInterval();
dtri.RangesBeforeReferenceDate.Add(range0);
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
Dim range0 As GridFX.WebForms.DateTimeRange
range0 = New GridFX.WebForms.DateTimeRange
range0.DistanceFromReference = New GridFX.WebForms.WeekInterval
range0.SubIncrement = New GridFX.WebForms.DayInterval
dtri.RangesBeforeReferenceDate.Add(range0)
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DateTimeRangeInterval

See Also

DateTimeRangeInterval Class | DateTimeRangeInterval Members | ReferenceDate Property | DateTimeRange Class


ReferenceDate property of class

DateTimeRangeInterval.ReferenceDate Property

Gets or sets the date used as a reference by the DateTimeRangeInterval.

[Visual Basic]
Public Property ReferenceDate As DateTime[C#]
public DateTime ReferenceDate {get;set;}

Remarks

  • This property establishes a reference point that is used to set the grouping behavior.

  • By default, this property will take the value of the current date.

Example

To set the reference date:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
System.DateTime dt = new DateTime(2001, 03, 09);
dtri.ReferenceDate = dt;
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
Dim dt As Date
dt = New Date(2001, 3, 9)
dtri.ReferenceDate = dt
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DateTimeRangeInterval

See Also

DateTimeRangeInterval Class | DateTimeRangeInterval Members | RangesBeforeReferenceDate Property | RangesAfterReferenceDate Property


UseRelativeTitles property of class

DateTimeRangeInterval.UseRelativeTitles Property

Enables or disables the use of relative titles.

[Visual Basic]
Public Property UseRelativeTitles As Boolean[C#]
public Boolean UseRelativeTitles {get;set;}

Example

To enable the relative titles:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
dtri.UseRelativeTitles = true;
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
dtri.UseRelativeTitles = true
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DateTimeRangeInterval

See Also

DateTimeRangeInterval Class | DateTimeRangeInterval Members | Property | DateTimeRelativeTitles Class


DateTimeRelativeTitles class

Provides access to the DateTimeRelativeTitles object.

For a list of all members of this type, see DateTimeRelativeTitles Members

GridFX.WebForms.DateTimeRelativeTitles

Remarks

When using date-based grouping, use this class to customize group titles so that they display more meaningful infromation.

For example, instead of showing a date range (e.g. Sunday, July 01, 2007 - Saturday, July 07, 2007) the title will show the group's distance from a reference date (e.g. This Week, Last Week, 1 Week Ago, etc).


DateTimeRelativeTitles Class Members

DateTimeRelativeTitles Members

DateTimeRelativeTitles Overview

Public Properties

public property MoreThanOneIncrementAfter | Gets or sets the relative title of the two or more increments after the reference date's interval increment when the reference date is different than the default date.
public property MoreThanOneIncrementAfterNow | Gets or sets the relative title of two or more increments after the reference date's interval increment when the reference date is the default date (date currently in progress).
public property MoreThanOneIncrementBefore | Gets or sets the relative title of two or more increments prior to the reference date's interval increment when the reference date is different than the default date.
public property MoreThanOneIncrementBeforeNow | Gets or sets the relative title of two or more increments prior to the reference date's interval increment when the reference date is the default date (date currently in progress).
public property OneIncrementAfter | Gets or sets the relative title of the one increment after the reference date's interval increment when the reference date is different than the default date.
public property OneIncrementAfterNow | Gets or sets the relative title of the one increment after the reference date's interval increment when the reference date is the default date (date currently in progress).
public property OneIncrementBefore | Gets or sets the relative title of the one increment prior to the reference date's interval increment when the reference date is different than the default date.
public property OneIncrementBeforeNow | Gets or sets the relative title of the one increment prior to the reference date's interval increment when the reference date is the default date (date currently in progress).
public property ReferenceDate | Gets or sets the date used as a reference by the DateTimeRelativeTitles class.
public property SameIncrement | Gets or sets the relative title of the reference date's interval increment when the reference date is different than the default date.
public property SameIncrementNow | Gets or sets the relative title of the reference date's interval increment when the reference date is the default date (date currently in progress).
public property UseRelativeTitles | Enables or disables the use of relative titles.


MoreThanOneIncrementAfter property of class

DateTimeRelativeTitles.MoreThanOneIncrementAfter Property

Gets or sets the relative title of the two or more increments after the reference date's interval increment when the reference date is different than the default date.

[Visual Basic]
Public Property MoreThanOneIncrementAfter As String[C#]
public String MoreThanOneIncrementAfter {get;set;}

Remarks

  • The increment number will be included at the begining of this title.

Example

To set the title for two or more increments after the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
wi.RelativeTitles.MoreThanOneIncrementAfter = "Weeks From The Reference Date";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
Dim dt As Date
dt = New Date(2007, 7, 9)
wi.RelativeTitles.ReferenceDate = dt
wi.RelativeTitles.MoreThanOneIncrementAfter = "Weeks From The Reference Date"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


MoreThanOneIncrementAfterNow property of class

DateTimeRelativeTitles.MoreThanOneIncrementAfterNow Property

Gets or sets the relative title of two or more increments after the reference date's interval increment when the reference date is the default date (date currently in progress).

[Visual Basic]
Public Property MoreThanOneIncrementAfterNow As String[C#]
public String MoreThanOneIncrementAfterNow {get;set;}

Remarks

  • The increment number will be included at the begining of this title.

Example

To set the title for two or more increments after the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.MoreThanOneIncrementAfterNow = "Weeks From Today";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.MoreThanOneIncrementAfterNow = "Weeks From Today"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members | Class


MoreThanOneIncrementBefore property of class

DateTimeRelativeTitles.MoreThanOneIncrementBefore Property

Gets or sets the relative title of two or more increments prior to the reference date's interval increment when the reference date is different than the default date.

[Visual Basic]
Public Property MoreThanOneIncrementBefore As String[C#]
public String MoreThanOneIncrementBefore {get;set;}

Remarks

  • The increment number will be included at the begining of this title.

Example

To set the title for two or more increments prior to the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
wi.RelativeTitles.MoreThanOneIncrementBefore = "Weeks Before The Reference Date";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
Dim dt As Date
dt = New Date(2007, 7, 9)
wi.RelativeTitles.ReferenceDate = dt
wi.RelativeTitles.MoreThanOneIncrementBefore = "Weeks Before The Reference Date"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members | Property


MoreThanOneIncrementBeforeNow property of class

DateTimeRelativeTitles.MoreThanOneIncrementBeforeNow Property

Gets or sets the relative title of two or more increments prior to the reference date's interval increment when the reference date is the default date (date currently in progress).

[Visual Basic]
Public Property MoreThanOneIncrementBeforeNow As String[C#]
public String MoreThanOneIncrementBeforeNow {get;set;}

Remarks

  • The increment number will be included at the begining of this title.

Example

To set the title for two or more increments prior to the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.MoreThanOneIncrementBeforeNow = "Weeks Ago";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.MoreThanOneIncrementBeforeNow = "Weeks Ago"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


OneIncrementAfter property of class

DateTimeRelativeTitles.OneIncrementAfter Property

Gets or sets the relative title of the one increment after the reference date's interval increment when the reference date is different than the default date.

[Visual Basic]
Public Property OneIncrementAfter As String[C#]
public String OneIncrementAfter {get;set;}

Example

To set the title for the increment after the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
wi.RelativeTitles.OneIncrementAfter = "Next Week";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
Dim dt As Date
dt = New Date(2007, 7, 9)
wi.RelativeTitles.ReferenceDate = dt
wi.RelativeTitles.OneIncrementAfter = "Next Week"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


OneIncrementAfterNow property of class

DateTimeRelativeTitles.OneIncrementAfterNow Property

Gets or sets the relative title of the one increment after the reference date's interval increment when the reference date is the default date (date currently in progress).

[Visual Basic]
Public Property OneIncrementAfterNow As String[C#]
public String OneIncrementAfterNow {get;set;}

Example

To set the title for the increment after the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.OneIncrementAfterNow = "Next Week";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.OneIncrementAfterNow = "Next Week"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


OneIncrementBefore property of class

DateTimeRelativeTitles.OneIncrementBefore Property

Gets or sets the relative title of the one increment prior to the reference date's interval increment when the reference date is different than the default date.

[Visual Basic]
Public Property OneIncrementBefore As String[C#]
public String OneIncrementBefore {get;set;}

Example

To set the title for the increment prior to the reference date's interval increment:

WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
wi.RelativeTitles.OneIncrementBefore = "Last Week";
Grid1.Grouping.RootLevel.Interval = wi;

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


OneIncrementBeforeNow property of class

DateTimeRelativeTitles.OneIncrementBeforeNow Property

Gets or sets the relative title of the one increment prior to the reference date's interval increment when the reference date is the default date (date currently in progress).

[Visual Basic]
Public Property OneIncrementBeforeNow As String[C#]
public String OneIncrementBeforeNow {get;set;}

Example

To set the title for the increment prior to the reference date's interval increment:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.OneIncrementBeforeNow = "Last Week";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.OneIncrementBeforeNow = "Last Week"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


ReferenceDate property of class

DateTimeRelativeTitles.ReferenceDate Property

Gets or sets the date used as a reference by the DateTimeRelativeTitles class.

[Visual Basic]
Public Property ReferenceDate As DateTime[C#]
public DateTime ReferenceDate {get;set;}

Remarks

  • By default, the reference date is the day currently in progress (Today).

Example

To specify a reference date:

[Visual Basic]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
Grid1.Grouping.RootLevel.Interval = wi;

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


SameIncrement property of class

DateTimeRelativeTitles.SameIncrement Property

Gets or sets the relative title of the reference date's interval increment when the reference date is different than the default date.

[Visual Basic]
Public Property SameIncrement As String[C#]
public String SameIncrement {get;set;}

Example

To set the relative title of increment of the reference date:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
System.DateTime dt = new DateTime(2007, 07, 09);
wi.RelativeTitles.ReferenceDate = dt;
wi.RelativeTitles.SameIncrement = "Current Week";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
Dim dt As Date
dt = New Date(2007, 7, 9)
wi.RelativeTitles.ReferenceDate = dt
wi.RelativeTitles.SameIncrement = "Current Week"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


SameIncrementNow property of class

DateTimeRelativeTitles.SameIncrementNow Property

Gets or sets the relative title of the reference date's interval increment when the reference date is the default date (date currently in progress).

[Visual Basic]
Public Property SameIncrementNow As String[C#]
public String SameIncrementNow {get;set;}

Example

To set the relative title of increment of the reference date:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
wi.RelativeTitles.SameIncrementNow = "Current Week";
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
wi.RelativeTitles.SameIncrementNow = "Current Week"
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


UseRelativeTitles property of class

DateTimeRelativeTitles.UseRelativeTitles Property

Enables or disables the use of relative titles.

[Visual Basic]
Public Property UseRelativeTitles As Boolean[C#]
public Boolean UseRelativeTitles {get;set;}

Remarks

  • By default, this property is set to false.

Example

To use relative titles:

[C#]
 WeekInterval wi = new WeekInterval();
wi.RelativeTitles.UseRelativeTitles = true;
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.RelativeTitles.UseRelativeTitles = true
Grid1.Grouping.RootLevel.Interval = wi

Applies to

DateTimeRelativeTitles

See Also

DateTimeRelativeTitles Class | DateTimeRelativeTitles Members


DateTimeValueCondition class

Allows access to the DateTimeValueCondition object.

For a list of all members of this type, see DateTimeValueCondition Members

GridFX.WebForms.FieldValueCondition
GridFX.WebForms.DateTimeValueCondition

Remarks

This class provides a number of comparison options to filter the records by their dates. The filtering takes place by comparing the dates of the records against a reference value.


DateTimeValueCondition Class Members

DateTimeValueCondition Members

DateTimeValueCondition Overview

Public Properties

public property Comparison | Gets or sets the type of comparison that will be used to filter the records by dates.
public property Field (inherited from FieldValueCondition) | Gets or sets the field to which the condition will apply
public property Value | Gets or sets the value used to perform the comparison.


Comparison property of class

DateTimeValueCondition.Comparison Property

Gets or sets the type of comparison that will be used to filter the records by dates.

[Visual Basic]
Public Property Comparison As DateTimeComparison[C#]
public DateTimeComparison Comparison {get;set;}

Property Value

The default is Equal.

Value | Meaning
Equal | Description goes here
NotEqual | Description goes here
GreaterThan | Description goes here
GreaterThanEqual | Description goes here
LessThan | Description goes here
LessThanEqual | Description goes here
IsNull | Description goes here
IsNotNull | Description goes here
Within1Minute | Description goes here
Within5Minutes | Description goes here
Within10Minutes | Description goes here
Within15Minutes | Description goes here
Within30Minutes | Description goes here
Within1Hour | Description goes here
Within12Hours | Description goes here
SameDay | Description goes here
SameDayAndDayBefore | Description goes here
SameWeek | Description goes here
SameMonth | Description goes here
SameQuarter | Description goes here
SameYear | Description goes here

Remarks

  • In order for any filtering to work, the field must be established.

Example

To select all dates that are less than or equal to the Value:

[C#]
 DateTimeValueCondition dtvc = new DateTimeValueCondition();
dtvc.Comparison = DateTimeComparison.LessThanEqual;
dtvc.Field = Grid1.Fields["DateCreated"];
System.DateTime dt = new DateTime(2007, 06, 19);
dtvc.Value = dt;
Grid1.Filtering.Conditions.Add(dtvc);

Applies to

DateTimeValueCondition

See Also

DateTimeValueCondition Class | DateTimeValueCondition Members | Value Property


Value property of class

DateTimeValueCondition.Value Property

Gets or sets the value used to perform the comparison.

[Visual Basic]
Public Property Value As DateTime[C#]
public DateTime Value {get;set;}

Example

To set the reference value:

[C#]
 DateTimeValueCondition dtvc = new DateTimeValueCondition();
dtvc.Comparison = DateTimeComparison.LessThanEqual;
dtvc.Field = Grid1.Fields["DateCreated"];
System.DateTime dt = new DateTime(2007, 06, 19);
dtvc.Value = dt;
Grid1.Filtering.Conditions.Add(dtvc);

Applies to

DateTimeValueCondition

See Also

DateTimeValueCondition Class | DateTimeValueCondition Members | Comparison Property


DayInterval class

Provides access to the DayInterval object.

For a list of all members of this type, see DayInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.DayInterval

Remarks

This class is used to group records by days.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


DayInterval Class Members

DayInterval Members

DayInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property FirstDayOfWeek | Gets or sets the day to be used as the first day of the week when grouping.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Start (inherited from DateTimeIncrementInterval) | Gets or sets the start for the group.
public property StartSource (inherited from DateTimeIncrementInterval) | Gets or sets how the groups will start.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.
public property UseDayNamesWithinOneWeekOfReferenceDate | Gets or sets the use of day names within a week of the reference date.


FirstDayOfWeek property of class

DayInterval.FirstDayOfWeek Property

Gets or sets the day to be used as the first day of the week when grouping.

[Visual Basic]
Public Property FirstDayOfWeek As DayOfWeek[C#]
public DayOfWeek FirstDayOfWeek {get;set;}

Remarks

  • When grouping the records by week, this setting lets the grid know the Day to be used as the first day of the week. This, if you set the first day to Monday, the records will go from Monday to Sunday for each interval.

  • By default, the first day of the week is Sunday.

Example

To set the first day of the week to Monday :

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
DayInterval di = new DayInterval();
di.FirstDayOfWeek = DayOfWeek.Monday;
DateTimeRange();
range0.DistanceFromReference = new WeekInterval();
range0.SubIncrement = di;
dtri.RangesBeforeReferenceDate.Add(range0);
Grid1.Grouping.RootLevel.Interval = dtri;

Applies to

DayInterval

See Also

DayInterval Class | DayInterval Members


UseDayNamesWithinOneWeekOfReferenceDate property of class

DayInterval.UseDayNamesWithinOneWeekOfReferenceDate Property

Gets or sets the use of day names within a week of the reference date.

[Visual Basic]
Public Property UseDayNamesWithinOneWeekOfReferenceDate As Boolean[C#]
public Boolean UseDayNamesWithinOneWeekOfReferenceDate {get;set;}

Remarks

  • This property changes the title of DayInterval groups from the dates to the names of the days, only within a week from the reference day. If the reference date is the day currently in progress then it will display "Today" instead of the date and "Yesterday" instead of the previous date. For the rest of the dates that are within that week, it will display the actual day name (Monday, Tuesday, etc).

  • In order to use this property, UseRelativeTitles must be set to true. Also, the Interval must be set to DateTimeRangeInterval.

  • It is important to keep in mind that this property is meant to be used inside of a DayInterval SubIncrement of a DateTimeRangeInterval Range.

Example

To use names of the days only within a week from the reference day:

[C#]
 DateTimeRangeInterval dtri = new DateTimeRangeInterval();
dtri.UseRelativeTitles = true;
DayInterval di = new DayInterval();
di.UseDayNamesWithinOneWeekOfReferenceDate = true;
DateTimeRange range0 = new DateTimeRange();
range0.DistanceFromReference = new WeekInterval();
range0.SubIncrement = di;
dtri.RangesBeforeReferenceDate.Add(range0);
Grid1.Grouping.RootLevel.Interval = dtri;

[Visual Basic]
 Dim dtri As GridFX.WebForms.DateTimeRangeInterval
dtri = New GridFX.WebForms.DateTimeRangeInterval
dtri.UseRelativeTitles = true
Dim di As GridFX.WebForms.DayInterval
di = New GridFX.WebForms.DayInterval
di.UseDayNamesWithinOneWeekOfReferenceDate = true
Dim range0 As GridFX.WebForms.DateTimeRange
range0 = New GridFX.WebForms.DateTimeRange
range0.DistanceFromReference = New GridFX.WebForms.WeekInterval
range0.SubIncrement = di
dtri.RangesBeforeReferenceDate.Add(range0)
Grid1.Grouping.RootLevel.Interval = dtri

Applies to

DayInterval

See Also

DayInterval Class | DayInterval Members | UseRelativeTitles Property | ReferenceDate Property


DecadeInterval class

Provides access to the DecadeInterval object.

For a list of all members of this type, see DecadeInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.DecadeInterval

Remarks

This class is used to group records by decades.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


DecadeInterval Class Members

DecadeInterval Members

DecadeInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Start (inherited from DateTimeIncrementInterval) | Gets or sets the start for the group.
public property StartSource (inherited from DateTimeIncrementInterval) | Gets or sets how the groups will start.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.


DistinctValuesInterval class

Provides access to the DistinctValuesInterval object.

For a list of all members of this type, see DistinctValuesInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DistinctValuesInterval

Remarks

This class is used to group records that have the exact same value.


DistinctValuesInterval Class Members

DistinctValuesInterval Members

DistinctValuesInterval Overview

Public Properties

public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property IncludeFieldTitleInTitle | Gets or sets the field name in the group title.
public property IncludeItemCountInTitle | Gets or sets the item count in the group title.
public property Title | Gets or sets the groups' title.


IncludeFieldTitleInTitle property of class

DistinctValuesInterval.IncludeFieldTitleInTitle Property

Gets or sets the field name in the group title.

[Visual Basic]
Public Property IncludeFieldTitleInTitle As Boolean[C#]
public Boolean IncludeFieldTitleInTitle {get;set;}

Remarks

  • By default, this property is set to true.

Example

To show the field name in the group title:

[C#]
 DistinctValuesInterval dvi = new DistinctValuesInterval();
dvi.IncludeFieldTitleInTitle = true;
Grid1.Grouping.RootLevel.Interval = dvi;

[Visual Basic]
 Dim dvi As GridFX.WebForms.DistinctValuesInterval
dvi = New GridFX.WebForms.DistinctValuesInterval
dvi.IncludeFieldTitleInTitle = true
Grid1.Grouping.RootLevel.Interval = dvi

Applies to

DistinctValuesInterval

See Also

DistinctValuesInterval Class | DistinctValuesInterval Members


IncludeItemCountInTitle property of class

DistinctValuesInterval.IncludeItemCountInTitle Property

Gets or sets the item count in the group title.

[Visual Basic]
Public Property IncludeItemCountInTitle As Boolean[C#]
public Boolean IncludeItemCountInTitle {get;set;}

Remarks

  • By default, this property is set to true.

  • The item count is the number of records that fall under a group. This property offers the option to display or not display the item count in the group title.

Example

To display the item count in the group title:

[C#]
 DistinctValuesInterval dvi = new DistinctValuesInterval();
dvi.IncludeItemCountInTitle = true;
Grid1.Grouping.RootLevel.Interval = dvi;

[Visual Basic]
 Dim dvi As GridFX.WebForms.DistinctValuesInterval
dvi = New GridFX.WebForms.DistinctValuesInterval
dvi.IncludeItemCountInTitle = true
Grid1.Grouping.RootLevel.Interval = dvi

Applies to

DistinctValuesInterval

See Also

DistinctValuesInterval Class | DistinctValuesInterval Members


Title property of class

DistinctValuesInterval.Title Property

Gets or sets the groups' title.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

  • This property allows customization of the group title. For instance, it lets add words before and after the dates or rearrange the order of the items in the title altogether.

Example

To set the title:

[C#]
 DistinctValuesInterval dvi = new DistinctValuesInterval();
dvi.Title = "Quantity: {Value}";
Grid1.Grouping.RootLevel.Interval = dvi;

[Visual Basic]
 Dim dvi As GridFX.WebForms.DistinctValuesInterval
dvi = New GridFX.WebForms.DistinctValuesInterval
dvi.Title = "Quantity: {Value}"
Grid1.Grouping.RootLevel.Interval = dvi

Applies to

DistinctValuesInterval

See Also

DistinctValuesInterval Class | DistinctValuesInterval Members


EmptyCell class

Provides access to the EmptyCell which is used for layout purposes.

For a list of all members of this type, see EmptyCell Members

GridFX.WebForms.LayoutCell
GridFX.WebForms.ColumnCell
GridFX.WebForms.EmptyCell

Remarks

An EmptyCell is empty and is used for layout and appearance purposes.


EmptyCell Class Members

EmptyCell Members

EmptyCell Overview

Public Properties

public property ColumnSpan | Gets or sets the number of columns the cell will span
public property RowSpan | Gets or sets the number of rows the empty cell will span.
public property Style (inherited from ColumnCell) | Gets a reference to the CellStyle and StyleSettings class that allows you to set the style attributes of the ColumnCell.
public property Title (inherited from ColumnCell) | Gets or sets the title text for the grid cell.
public property Visible (inherited from LayoutCell) | Gets or sets the visible property which allows the cell to be displayed or hidden.


ColumnSpan property of class

EmptyCell.ColumnSpan Property

Gets or sets the number of columns the cell will span

[Visual Basic]
Public Property ColumnSpan As Int32[C#]
public Int32 ColumnSpan {get;set;}

Remarks

  • The columnspan property cannot be set to a value other than 1.

    [C#]
     GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
    grid1.Columns.Add(mc);
    GridFX.WebForms.EmptyCell ec = new EmptyCell();
    ec.ColumnSpan = 1;
    mc.Cells.Add(ec);
    GridFX.WebForms.FieldCell fcell = new FieldCell();
    fcell.Field = grid1.Fields["DateField"];
    mc.Cells.Add(fcell);

    The empty cell is basically used for appearance and layout purposes. To differentiate that the empty cell is actually being created, create and add a second cell, say FieldCell or TemplateCell and you would notice gaps between cells in the last column of grid as shown below:

Example

To set the columnspan to 1:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.EmptyCell ec = new EmptyCell();
ec.ColumnSpan = 1;
mc.Cells.Add(ec);
GridFX.WebForms.FieldCell fcell = new FieldCell();
fcell.Field = grid1.Fields["DateField"];
mc.Cells.Add(fcell);

Applies to

EmptyCell

See Also

EmptyCell Class | EmptyCell Members


RowSpan property of class

EmptyCell.RowSpan Property

Gets or sets the number of rows the empty cell will span.

[Visual Basic]
Public Property RowSpan As Int32[C#]
public Int32 RowSpan {get;set;}

Remarks

  • The rowspan property cannot be set to a value other than 1.

Example

To set the rowspan to 1:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.EmptyCell ec = new EmptyCell();
ec.RowSpan = 1;
mc.Cells.Add(ec);
GridFX.WebForms.FieldCell fcell = new FieldCell();
fcell.Field = grid1.Fields["DateField"];
mc.Cells.Add(fcell);

Applies to

EmptyCell

See Also

EmptyCell Class | EmptyCell Members


ExpandableSideBar class

Provides access to the Expandable SideBar object

For a list of all members of this type, see ExpandableSideBar Members

GridFX.WebForms.SideBar
GridFX.WebForms.ExpandableSideBar

Remarks

By enabling the Sidebar on the Grid control, you can easily add controls like charts, gauges or standard web controls to your grid to enhance its functionality

The Expandable Sidebar Inherited from the SideBar class and has the feature to display the sidebar as expanded or not.

The advantage of the Expandable Sidebar is that it gives the user the option to expand and collapse the sidebar at runtime.


ExpandableSideBar Class Members

ExpandableSideBar Members

ExpandableSideBar Overview

Public Properties

public property Expandable | Gets or sets whether the contents of the sidebar can be expanded or not.
public property Expanded | Gets or sets whether the Sidebar will be expanded to show its contents.
public property FlowsOverToolbarAndPager (inherited from SideBar) | Sets or Gets whether the Sidebar will cover the whole grid length or if it is limited to show between the toolbar and the pager.
public property Separator (inherited from SideBar) | Gets or sets the attributes of the element that separates the sidebar from the grid.
public property ShowTitleStrip | Gets or sets whether the title of the sidebar is to be displayed or hidden.
public property Side (inherited from SideBar) | Gets or sets the position of the sidebar to the Bottom, Left, Right or Top of the grid.
public property Style (inherited from SideBar) | Gets or sets the style attributes of the sidebar contents.
public property Title | Gets or sets the title of the sidebar.
public property TitleStyle | Provides access to the style attributes for the sidebar title.
public property Visible (inherited from SideBar) | Gets or sets the visible property which allows the sidebar to be displayed or hidden.

Public Methods

public method FindControl (inherited from SideBar) Used to find a control in the sidebar and edit the properties of the control.


Expandable property of class

ExpandableSideBar.Expandable Property

Gets or sets whether the contents of the sidebar can be expanded or not.

[Visual Basic]
Public Property Expandable As Boolean[C#]
public Boolean Expandable {get;set;}

Remarks

  • By default, when a sidebar is added to the grid, it is made visible. By setting the Expandable property to false, there is no option to collapse the contents of the sidebar as shown below:

                  [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Expandable = false;
grid1.SideBars.Add(sidebar);

Example

To disable the expandable property for the sidebar:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Expandable = false;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Expandable = false
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

ExpandableSideBar

See Also

ExpandableSideBar Class | ExpandableSideBar Members


Expanded property of class

ExpandableSideBar.Expanded Property

Gets or sets whether the Sidebar will be expanded to show its contents.

[Visual Basic]
Public Property Expanded As Boolean[C#]
public Boolean Expanded {get;set;}

Remarks

  • By default, the contents of the sidebar are made visible. By setting the expanded property to false, the sidebar contents are hidden:

                  [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Expanded = false;
grid1.SideBars.Add(sidebar);

Example

To collapse the SideBar:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Expanded = false;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Expanded = false
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

ExpandableSideBar

See Also

ExpandableSideBar Class | ExpandableSideBar Members


FlowsOverToolbarAndPager property of class

SideBar.FlowsOverToolbarAndPager Property

Sets or Gets whether the Sidebar will cover the whole grid length or if it is limited to show between the toolbar and the pager.

[Visual Basic]
Public Property FlowsOverToolbarAndPager As Boolean[C#]
public Boolean FlowsOverToolbarAndPager {get;set;}

Remarks

  • By setting the property to true, the sidebar will span the toolbar and pager areas as shown below:

                  [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.FlowsOverToolbarAndPager = true;
grid1.SideBars.Add(sidebar);

Example

To set the Sidebar to use the whole grid area vertically:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.FlowsOverToolbarAndPager = true;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.FlowsOverToolbarAndPager = true
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBar

See Also

SideBar Class | SideBar Members


Separator property of class

SideBar.Separator Property

Gets or sets the attributes of the element that separates the sidebar from the grid.

[Visual Basic]
Public Property Separator As SideBarSeparator[C#]
public SideBarSeparator Separator {get;set;}

Example

To set the color for the separator:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Separator.BackColor = System.Drawing.Color.BlueViolet;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Separator.BackColor = System.Drawing.Color.BlueViolet
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBar

See Also

SideBar Class | SideBar Members | SideBarSeparator Class Class


ShowTitleStrip property of class

ExpandableSideBar.ShowTitleStrip Property

Gets or sets whether the title of the sidebar is to be displayed or hidden.

[Visual Basic]
Public Property ShowTitleStrip As Boolean[C#]
public Boolean ShowTitleStrip {get;set;}

Example

To hide the title of the sidebar:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.ShowTitleStrip = false;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.ShowTitleStrip = false
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

ExpandableSideBar

See Also

ExpandableSideBar Class | ExpandableSideBar Members | Title Property


Side property of class

SideBar.Side Property

Gets or sets the position of the sidebar to the Bottom, Left, Right or Top of the grid.

[Visual Basic]
Public Property Side As SideBarSide[C#]
public SideBarSide Side {get;set;}

Value | Meaning
Left | Description goes here
Top | Description goes here
Right | Description goes here
Bottom | Description goes here

Remarks

  • When docking the Sidebar to left or right, you can use the FlowsOverToolBarAndPager property to extend the Sidebar vertically to use the whole grid length.

Example

To set the position of sidebar to the bottom of the grid:

[C++]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Side = SideBarSide.Bottom;
grid1.SideBars.Add(sidebar);

Applies to

SideBar

See Also

SideBar Class | SideBar Members | FlowsOverToolBarAndPager Property | SideBarSide Class Class


Style property of class

SideBar.Style Property

Gets or sets the style attributes of the sidebar contents.

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Example

To set the text style to italic:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Style.Italic = true;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Style.Italic = true
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBar

See Also

SideBar Class | SideBar Members | CellStyle class Class


Title property of class

ExpandableSideBar.Title Property

Gets or sets the title of the sidebar.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Example

To set the sidebar title:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Title = "Properties SideBar";
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Title = "Properties SideBar"
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

ExpandableSideBar

See Also

ExpandableSideBar Class | ExpandableSideBar Members


TitleStyle property of class

ExpandableSideBar.TitleStyle Property

[Visual Basic]
Public ReadOnly Property TitleStyle As CellStyle[C#]
public CellStyle TitleStyle {get;}

Example

To set the color for the sidebar title:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.TitleStyle.ForeColor = System.Drawing.Color.DarkBlue;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.TitleStyle.ForeColor = System.Drawing.Color.DarkBlue
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

ExpandableSideBar

See Also

ExpandableSideBar Class | ExpandableSideBar Members | CellStyle Class Class


Visible property of class

SideBar.Visible Property

Gets or sets the visible property which allows the sidebar to be displayed or hidden.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • After the Sidebar is Hidden, it is not possible for the user to show the sidebar again at run-time. If you need the user to expand and collapse the Sidebar, use ExpandableSideBar instead.

Example

To hide the sidebar:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Visible = false;
grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Visible = false
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBar

See Also

SideBar Class | SideBar Members | ExpandableSideBar Class


ExpansionButtonSettings class

Description goes here

For a list of all members of this type, see ExpansionButtonSettings Members

GridFX.WebForms.ExpansionButtonSettings

Remarks

Description goes here


ExpansionButtonSettings Class Members

ExpansionButtonSettings Members

ExpansionButtonSettings Overview

Public Properties

public property CollapseImageUrl | Gets or sets the URL to display an image for collapsable nodes.
public property CollapseText | Gets or sets the text for collapsable nodes.
public property CollapseToolTip | Gets or sets the ToolTip for collapsable nodes.
public property ExpandImageUrl | Gets or sets the URL to display an image for expandable nodes.
public property ExpandText | Gets or sets the text to be placed on the expansion button
public property ExpandToolTip | Gets or sets the ToolTip for expandable nodes.


CollapseImageUrl property of class

ExpansionButtonSettings.CollapseImageUrl Property

Gets or sets the URL to display an image for collapsable nodes.

[Visual Basic]
Public Property CollapseImageUrl As String[C#]
public String CollapseImageUrl {get;set;}

Remarks

  • The URL to a custom image to display for collapsable nodes. The default is an empty string (""), which displays the default minus sign (-) image.

  • Use the ExpandImageUrl property to to display an image for expandable nodes.

Example

To configure the Image URL when the expansion button is collapsed:

[C#]
 grid1.Grouping.ExpansionButton.CollapseImageUrl = "MyImageURL";

[Visual Basic]
 grid1.Grouping.ExpansionButton.CollapseImageUrl = "MyImageURL"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


CollapseText property of class

ExpansionButtonSettings.CollapseText Property

Gets or sets the text for collapsable nodes.

[Visual Basic]
Public Property CollapseText As String[C#]
public String CollapseText {get;set;}

Remarks

  • Use the CollapseText propert to display the text for collapsable nodes.

Example

To configure the text for the expanded button when it's collapsed:

[C#]
 grid1.Grouping.ExpansionButton.CollapseText = "MyText";

[Visual Basic]
 grid1.Grouping.ExpansionButton.CollapseText = "MyText"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


CollapseToolTip property of class

ExpansionButtonSettings.CollapseToolTip Property

Gets or sets the ToolTip for collapsable nodes.

[Visual Basic]
Public Property CollapseToolTip As String[C#]
public String CollapseToolTip {get;set;}

Remarks

  • Use the CollapseToolTip property to configure the ToolTip for nodes in collapsable mode.

Example

To configure the ToolTip for the expansion button:

[C#]
 grid1.Grouping.ExpansionButton.CollapseToolTip = "MyToolTip";

[Visual Basic]
 grid1.Grouping.ExpansionButton.CollapseToolTip = "MyToolTip"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


ExpandImageUrl property of class

ExpansionButtonSettings.ExpandImageUrl Property

Gets or sets the URL to display an image for expandable nodes.

[Visual Basic]
Public Property ExpandImageUrl As String[C#]
public String ExpandImageUrl {get;set;}

Remarks

  • The URL to a custom image to display for expandable nodes. The default is an empty string (""), which displays the default plus sign (+) image.

  • Use the CollapseImageUrl property to to display an image for collapsable nodes.

Example

To configure the Image URL when the expansion button is expanded:

[C#]
 grid1.Grouping.ExpansionButton.ExpandImageUrl = "MyImageURL";

[Visual Basic]
 grid1.Grouping.ExpansionButton.ExpandImageUrl = "MyImageURL"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


ExpandText property of class

ExpansionButtonSettings.ExpandText Property

Gets or sets the text to be placed on the expansion button

[Visual Basic]
Public Property ExpandText As String[C#]
public String ExpandText {get;set;}

Remarks

  • Use the ExpandText property to display the text for expandable nodes.

  • If no image is being used, this defines the text put in the push button that is used.

  • Use the CollapseText propert to display the text for collapsable nodes.

Example

To configure the text for the expanded button when it's expanded:

[C#]
 grid1.Grouping.ExpansionButton.ExpandText = "MyText";

[Visual Basic]
 grid1.Grouping.ExpansionButton.ExpandText = "MyText"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


ExpandToolTip property of class

ExpansionButtonSettings.ExpandToolTip Property

Gets or sets the ToolTip for expandable nodes.

[Visual Basic]
Public Property ExpandToolTip As String[C#]
public String ExpandToolTip {get;set;}

Remarks

  • Use the ExpandToolTip property to configure the ToolTip for nodes in expandable mode.

  • Use the CollapseToolTip property to configure the ToolTip for nodes in collapsable mode.

Example

To configure the ToolTip for the expansion button:

[C#]
 grid1.Grouping.ExpansionButton.CollapseToolTip = "MyToolTip";

[Visual Basic]
 grid1.Grouping.ExpansionButton.CollapseToolTip = "MyToolTip"

Applies to

ExpansionButtonSettings

See Also

ExpansionButtonSettings Class | ExpansionButtonSettings Members


FieldCell class

Provides access to the FieldCell object.

For a list of all members of this type, see FieldCell Members

GridFX.WebForms.LayoutCell
GridFX.WebForms.ColumnCell
GridFX.WebForms.FieldCell

Remarks

This class has a reference to the GridField Class and is also used to set attributes for the field cell contents.


FieldCell Class Members

FieldCell Members

FieldCell Overview

Public Properties

public property ColumnSpan (inherited from LayoutCell) | Gets or sets the number of columns that a grid field cell will span.
public property ContentType | Gets or sets the content type which allows the cell contents to be displayed in a certain format based on the property set.
public property Field | Allows you to access the field properties in a Grid column.
public property HyperLink | Allows you to access a webpage by clicking on a cell in the grid field column.
public property RowSpan (inherited from LayoutCell) | Gets or sets the number of rows a grid field cell will span.
public property Style (inherited from ColumnCell) | Gets a reference to the CellStyle and StyleSettings class that allows you to set the style attributes of the ColumnCell.
public property Title (inherited from ColumnCell) | Gets or sets the title text for the grid cell.
public property ToolTip | Gets or sets the tooltip for the contents of cells in the grid field column.
public property Visible (inherited from LayoutCell) | Gets or sets the visible property which allows the cell to be displayed or hidden.


ContentType property of class

FieldCell.ContentType Property

Gets or sets the content type which allows the cell contents to be displayed in a certain format based on the property set.

[Visual Basic]
Public Property ContentType As FieldControlContentType[C#]
public FieldControlContentType ContentType {get;set;}

Property Value

The default is Auto.

Value | Meaning
Auto | Description goes here
Label | Description goes here
CardTitle | Description goes here
CardImage | Description goes here

Remarks

  • ContentType can be set to one of the 4 possible options: Auto, CardImage, CardTitle, Label. The following image shows a cell with the ContentType set to Label:

                  [C#]
GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
    grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.ContentType = FieldControlContentType.Label;
mc.Cells.Add(cell);

  • By setting this to something besides Auto, you are forcing the output to be a certain way. This lets you force the output to always show a field name.

Example

To set the FieldCell Content Type to Label:

              [C#]
GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
cell.ContentType = FieldControlContentType.Label;
mc.Cells.Add(cell);

Applies to

FieldCell

See Also

FieldCell Class | FieldCell Members | Class


Field property of class

FieldCell.Field Property

Allows you to access the field properties in a Grid column.

[Visual Basic]
Public Property Field As DataField[C#]
public DataField Field {get;set;}

Remarks

  • The Field property encapsulates the GridField properties to customize the field in a Grid Column.

Example

To set the Field visible property for the first column to false:

[C#]
 grid1.Fields[0].Visible = false;

To set the Field title:

              [C#]
GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
    grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
cell.Field.Title = "Cell Title";
mc.Cells.Add(cell);

Applies to

FieldCell

See Also

FieldCell Class | FieldCell Members | GridField Class Class


HyperLink property of class

FieldCell.HyperLink Property

Allows you to access a webpage by clicking on a cell in the grid field column.

[Visual Basic]
Public ReadOnly Property HyperLink As FieldControlHyperLink[C#]
public FieldControlHyperLink HyperLink {get;}

Remarks

  • By setting the HyperLink property for a cell, the cell contents will be displayed as a link and clicking on the link will open the webpage pointed to in the HyperLink.Url:

                  [C#]
GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
    grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.HyperLink.Url = "http://www.softwarefx.com";
cell.HyperLink.Target = "_target";
mc.Cells.Add(cell);

Example

To set a Hyperlink for a field cell:

              [C#]
GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
cell.HyperLink.Url = "http://www.softwarefx.com";
    cell.HyperLink.Target = "_target";
mc.Cells.Add(cell);

Applies to

FieldCell

See Also

FieldCell Class | FieldCell Members | FieldControlHyperLink Class Class


ToolTip property of class

FieldCell.ToolTip Property

Gets or sets the tooltip for the contents of cells in the grid field column.

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Example

To set the tooltip for the contents in the grid field to 'DateField':

[C#]
 GridFX.WebForms.MultiCellColumn mc = new GridFX.WebForms.MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
cell.ToolTip = "DateField";
mc.Cells.Add(cell);

Applies to

FieldCell

See Also

FieldCell Class | FieldCell Members


FieldColumn class

Layout column that is made strictly to display a single GridField.

For a list of all members of this type, see FieldColumn Members

GridFX.WebForms.GridColumn
GridFX.WebForms.SingleCellColumn
GridFX.WebForms.FieldColumn

Remarks

This column automatically creates a FieldHeaderCell for the header and FieldValueCells for each LayoutBlock.


FieldColumn Class Members

FieldColumn Members

FieldColumn Overview

Public Properties

public property Field | Gets a reference to the GridField object that defines the behaviour of the column.
public property HyperLink | Description goes here
public property Style (inherited from SingleCellColumn) | Gets access to the ColumnAreasStyle class which allows to set the style attributes of the SingleCellColumn.
public property Title (inherited from SingleCellColumn) | Gets or sets the title or header text of the SingleCellColumn.
public property ToolTip | Description goes here
public property Visible | Gets or sets a value indicating whether the FieldColumn is rendered.
public property Width (inherited from GridColumn) | Gets or sets a value determining the column width in pixels.


Field property of class

FieldColumn.Field Property

Gets a reference to the GridField object that defines the behaviour of the column.

[Visual Basic]
Public Property Field As DataField[C#]
public DataField Field {get;set;}

Remarks

  • When the GridField is set, this column will be hidden when the Field's Visible property is set to false or the Field is grouped and columns are hidden when grouped.

  • If the Visible property is false, this column will be hidden in the output.

  • Additionally, if the Field is removed from the Grid at some point, this column will also be removed.

Applies to

FieldColumn

See Also

FieldColumn Class | FieldColumn Members | Visible Property | GridField Class


HyperLink property of class

FieldColumn.HyperLink Property

Description goes here

[Visual Basic]
Public ReadOnly Property HyperLink As FieldControlHyperLink[C#]
public FieldControlHyperLink HyperLink {get;}

Applies to

FieldColumn

See Also

FieldColumn Class | FieldColumn Members


Style property of class

SingleCellColumn.Style Property

Gets access to the ColumnAreasStyle class which allows to set the style attributes of the SingleCellColumn.

[Visual Basic]
Public ReadOnly Property Style As ColumnAreasStyle[C#]
public ColumnAreasStyle Style {get;}

Remarks

  • SingleCellColumn can be defined to be any column in the Grid that is not defined as a MultiCellColumn.

Example

To display the SingleCellColumn contents in Bold and set the ForeColor property of the column:

[C#]
 GridFX.WebForms.SingleCellColumn sc = (SingleCellColumn)grid1.Columns[0];
sc.Style.Bold = true;
sc.Style.ForeColor = Color.Purple;

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(grid1.Columns(0),GridFX.WebForms.SingleCellColumn)
sc.Style.Bold = true
sc.Style.ForeColor = System.Drawing.Color.Purple

Applies to

SingleCellColumn

See Also

SingleCellColumn Class | SingleCellColumn Members | ColumnAreasStyle Class Class


Title property of class

SingleCellColumn.Title Property

Gets or sets the title or header text of the SingleCellColumn.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Example

To set the title of the SingleCellColumn:

[C#]
 GridFX.WebForms.SingleCellColumn sc = (SingleCellColumn)grid1.Columns[1];
sc.Title = "SingleCellColumn";

[Visual Basic]
 Dim sc As GridFX.WebForms.SingleCellColumn
sc = CType(grid1.Columns(1),GridFX.WebForms.SingleCellColumn)
sc.Title = "SingleCellColumn"

Applies to

SingleCellColumn

See Also

SingleCellColumn Class | SingleCellColumn Members


ToolTip property of class

FieldColumn.ToolTip Property

Description goes here

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Applies to

FieldColumn

See Also

FieldColumn Class | FieldColumn Members


Visible property of class

FieldColumn.Visible Property

Gets or sets a value indicating whether the FieldColumn is rendered.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Example

To hide the first collumn:

[C#]
 FieldColumn fc = (FieldColumn) Grid1.Columns[0];
fc.Visible = false;

[Visual Basic]
 Dim fc As GridFX.WebForms.FieldColumn
fc = CType(Grid1.Columns(0),GridFX.WebForms.FieldColumn)
fc.Visible = false

Applies to

FieldColumn

See Also

FieldColumn Class | FieldColumn Members


Width property of class

GridColumn.Width Property

Gets or sets a value determining the column width in pixels.

[Visual Basic]
Public Property Width As Unit[C#]
public Unit Width {get;set;}

Remarks

  • Only applies to grids set to Columnar Layout.

Example

To set the width of the first column to 200 pixels.

[C#]
 Grid1.Columns[1].Width = 200;

[Visual Basic]
 Grid1.Columns(1).Width = 200

Applies to

GridColumn

See Also

GridColumn Class | GridColumn Members


FieldContainer class

Provides access to the FieldContainer class

For a list of all members of this type, see FieldContainer Members

GridFX.WebForms.FieldContainer

Remarks

This property provides acces to a control that is tied to a DataField and is contained within a template in the grid.


FieldContainer Class Members

FieldContainer Members

FieldContainer Overview

Public Properties

public property ContentType | Description goes here
public property Field | Description goes here
public property HyperLink | Description goes here
public property ID | Description goes here
public property NamingContainer | Description goes here
public property Text | Description goes here
public property ToolTip | Description goes here
public property Visible | Description goes here


ContentType property of class

FieldContainer.ContentType Property

Description goes here

[Visual Basic]
Public Property ContentType As FieldControlContentType[C#]
public FieldControlContentType ContentType {get;set;}

Property Value

The default is Auto.

Value | Meaning
Auto | Description goes here
Label | Description goes here
CardTitle | Description goes here
CardImage | Description goes here

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


Field property of class

FieldContainer.Field Property

Description goes here

[Visual Basic]
Public Property Field As DataField[C#]
public DataField Field {get;set;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


HyperLink property of class

FieldContainer.HyperLink Property

Description goes here

[Visual Basic]
Public ReadOnly Property HyperLink As FieldControlHyperLink[C#]
public FieldControlHyperLink HyperLink {get;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


ID property of class

FieldContainer.ID Property

Description goes here

[Visual Basic]
Public Property ID As String[C#]
public String ID {get;set;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


NamingContainer property of class

FieldContainer.NamingContainer Property

Description goes here

[Visual Basic]
Public ReadOnly Property NamingContainer As Control[C#]
public Control NamingContainer {get;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


Text property of class

FieldContainer.Text Property

Description goes here

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


ToolTip property of class

FieldContainer.ToolTip Property

Description goes here

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


Visible property of class

FieldContainer.Visible Property

Description goes here

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Applies to

FieldContainer

See Also

FieldContainer Class | FieldContainer Members


FieldFilteringSettings class

Provides access to the FieldFilteringSettings Class and to the filtering options of a GridField.

For a list of all members of this type, see FieldFilteringSettings Members

GridFX.WebForms.FieldFilteringSettings

Remarks

Allows for customization of filtering options of a given GridField through the FieldFilteringSettings Class


FieldFilteringSettings Class Members

FieldFilteringSettings Members

FieldFilteringSettings Overview

Public Properties

public property Enabled Gets or sets a Boolean value that specifies wheter or not filtering can be done on the field.


Enabled property of class

FieldFilteringSettings.Enabled Property

Gets or sets a Boolean value that specifies wheter or not filtering can be done on the field.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • Use the Enabled property to allow filtering be enabled or disabled at run time.

  • If this is false and an attempt to add the field as a FilterField is made, an exception will be thrown.

Example

To disable the filtering feature in the first field of the grid:

[C#]
 grid1.Fields[0].Filtering.Enabled = false;

Applies to

FieldFilteringSettings

See Also

FieldFilteringSettings Class | FieldFilteringSettings Members


FieldGroupingSettings class

Provides access to the FieldGroupingSettings Class.

For a list of all members of this type, see FieldGroupingSettings Members

GridFX.WebForms.FieldGroupingSettings

Remarks

The FieldGroupingSettings Class allows the user to group the data that belongs to a particular GridField.


FieldGroupingSettings Class Members

FieldGroupingSettings Members

FieldGroupingSettings Overview

Public Properties

public property Enabled | Determines whether grouping is enabled for this field.
public property FooterTemplate | Allows the user to define the content within the footer of the groups for a GridField.
public property HeaderTemplate | Allows the user to define the content within the header of the groups for a GridField.
public property Interval | Allows the user to set a default Interval value that is used when a GridField is grouped.


Enabled property of class

FieldGroupingSettings.Enabled Property

Determines whether grouping is enabled for this field.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • Use the Enabled property to specify a boolean value indicating whether or not grouping is enabled for the field. If false, it cannot be grouped.

Example

To disable the grouping feature for the first field in the grid:

[C#]
 Grid1.Fields[0].Grouping.Enabled = false;

Applies to

FieldGroupingSettings

See Also

FieldGroupingSettings Class | FieldGroupingSettings Members


FooterTemplate property of class

FieldGroupingSettings.FooterTemplate Property

Allows the user to define the content within the footer of the groups for a GridField.

[Visual Basic]
Public Property FooterTemplate As ITemplate[C#]
public ITemplate FooterTemplate {get;set;}

Remarks

  • If this Template is not defined, the footer row will not be shown.

  • To add a FooterTemplate to the FieldGroupingSettings, you must access the Edit Templates feature from the Design-Time Template Editor within the Smart Tag Wizard.

Applies to

FieldGroupingSettings

See Also

FieldGroupingSettings Class | FieldGroupingSettings Members


HeaderTemplate property of class

FieldGroupingSettings.HeaderTemplate Property

Allows the user to define the content within the header of the groups for a GridField.

[Visual Basic]
Public Property HeaderTemplate As ITemplate[C#]
public ITemplate HeaderTemplate {get;set;}

Remarks

  • If this Template is not defined, a Group Title will be provided automatically.

  • To add a HeaderTemplate to the FieldGroupingSettings, you must access the Edit Templates feature from the Design-Time Template Editor within the Smart Tag Wizard.

Applies to

FieldGroupingSettings

See Also

FieldGroupingSettings Class | FieldGroupingSettings Members


Interval property of class

FieldGroupingSettings.Interval Property

Allows the user to set a default Interval value that is used when a GridField is grouped.

[Visual Basic]
Public Property Interval As GroupInterval[C#]
public GroupInterval Interval {get;set;}

Remarks

  • The Interval Property for a grouped field is type independent. It will take on the Interval Type of the value being looked up.

  • If the grouped field is a NumberField, for example, then the Interval Type can take on the FixedNumber, NumberRanges, or DistinctValues intervals available for such field.

  • The Start Property defines the value of the interval by which the field will be grouped.

Example

Set the Interval by which this field will be grouped:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Temperature";
FieldGroupingSettings fieldGroup = numField.Grouping;
fieldGroup.Enabled = true;
FixedNumberInterval fixedNumInterval = new FixedNumberInterval();
fixedNumInterval.HideData = true;
fixedNumInterval.IncludeFieldTitleInTitle = true;
fixedNumInterval.NullTitle = "Title is not set";
fixedNumInterval.Start = 20;
fieldGroup.Interval = fixedNumInterval;

Applies to

FieldGroupingSettings

See Also

FieldGroupingSettings Class | FieldGroupingSettings Members | GroupInterval Class


FieldSortingSettings class

Provides access to the FieldSortingSettings Class and to the various sort options applied to a specific field.

For a list of all members of this type, see FieldSortingSettings Members

GridFX.WebForms.FieldSortingSettings

Remarks

Description goes here


FieldSortingSettings Class Members

FieldSortingSettings Members

FieldSortingSettings Overview

Public Properties

public property Direction | The sort direction when this field is first sorted.
public property Enabled | Permits or prevents the user from sorting the field in the UI.


Direction property of class

FieldSortingSettings.Direction Property

The sort direction when this field is first sorted.

[Visual Basic]
Public Property Direction As SortDirection[C#]
public SortDirection Direction {get;set;}

Remarks

  • Use the Direction propery to indicate the direccion of the sorting. The default value is ascending.

  • Use the Sorting Fields property to add the fields that will be sorted.

  • The data will be sorted by the first column in the sorting Fields collection, then subsequent columns will been sorted in their respective order of appearance.

Example

To sort the third column of the grid in a descending way:

[C#]
 grid1.Fields[2].Sorting.Direction = SortDirection.Descending;

// This line is used to add the field into the sorting Fields collection:
grid1.Sorting.SortedFields.Add(grid1.Fields[2]);

Applies to

FieldSortingSettings

See Also

FieldSortingSettings Class | FieldSortingSettings Members | Fields Property


Enabled property of class

FieldSortingSettings.Enabled Property

Permits or prevents the user from sorting the field in the UI.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • This does NOT prevent the field from being sorted in design time or through code behind.

Example

To prevents the user from sorting the field at Run Time:

[C#]
 grid1.Fields[2].Sorting.Enabled = false;

Applies to

FieldSortingSettings

See Also

FieldSortingSettings Class | FieldSortingSettings Members


FiscalQuarterInterval class

Provides access to the FiscalQuarterInterval object.

For a list of all members of this type, see FiscalQuarterInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.FiscalQuarterInterval

Remarks

This class is used to group records by fiscal quarters.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


FiscalQuarterInterval Class Members

FiscalQuarterInterval Members

FiscalQuarterInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property FiscalYearStart | Gets or sets the start of the fiscal year.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.


FiscalYearStart property of class

FiscalQuarterInterval.FiscalYearStart Property

Gets or sets the start of the fiscal year.

[Visual Basic]
Public Property FiscalYearStart As FiscalYearStart[C#]
public FiscalYearStart FiscalYearStart {get;set;}

Property Value

The default is January.

Value | Meaning
January | Description goes here
Febuary | Description goes here
March | Description goes here
April | Description goes here
May | Description goes here
June | Description goes here
July | Description goes here
August | Description goes here
September | Description goes here
October | Description goes here
November | Description goes here
December | Description goes here

Remarks

  • Since the fiscal year start may vary from business to business, this property provides the option to select any month as the fiscal year start.

Example

To set the start of the fiscal year to April:

[C#]
 FiscalQuarterInterval fqi = new FiscalQuarterInterval();
fqi.FiscalYearStart = FiscalYearStart.April;
Grid1.Grouping.RootLevel.Interval = fqi;

[Visual Basic]
 Dim fqi As GridFX.WebForms.FiscalQuarterInterval
fqi = New GridFX.WebForms.FiscalQuarterInterval
fqi.FiscalYearStart = GridFX.WebForms.FiscalYearStart.April
Grid1.Grouping.RootLevel.Interval = fqi

Applies to

FiscalQuarterInterval

See Also

FiscalQuarterInterval Class | FiscalQuarterInterval Members


FiscalYearInterval class

Provides access to the FiscalYearInterval object.

For a list of all members of this type, see FiscalYearInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.FiscalYearInterval

Remarks

This class is used to group records by fiscal years.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


FiscalYearInterval Class Members

FiscalYearInterval Members

FiscalYearInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property FiscalYearStart | Gets or sets the start of the fiscal year.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.


FiscalYearStart property of class

FiscalYearInterval.FiscalYearStart Property

Gets or sets the start of the fiscal year.

[Visual Basic]
Public Property FiscalYearStart As FiscalYearStart[C#]
public FiscalYearStart FiscalYearStart {get;set;}

Property Value

The default is January.

Value | Meaning
January | Description goes here
Febuary | Description goes here
March | Description goes here
April | Description goes here
May | Description goes here
June | Description goes here
July | Description goes here
August | Description goes here
September | Description goes here
October | Description goes here
November | Description goes here
December | Description goes here

Remarks

  • Since the fiscal year start may vary from business to business, this property provides the option to select any month as the fiscal year start.

Example

To set the start of the fiscal year to April:

              [C#]
FiscalYearInterval fyi = new FiscalYearInterval();
        fyi.FiscalYearStart = FiscalYearStart.April;
        Grid1.Grouping.RootLevel.Interval = fyi;

[Visual Basic]
 Dim fyi As GridFX.WebForms.FiscalYearInterval
fyi = New GridFX.WebForms.FiscalYearInterval
fyi.FiscalYearStart = GridFX.WebForms.FiscalYearStart.April
Grid1.Grouping.RootLevel.Interval = fyi

Applies to

FiscalYearInterval

See Also

FiscalYearInterval Class | FiscalYearInterval Members


FixedNumberInterval class

Provides access to the FixedNumberInterval object.

For a list of all members of this type, see FixedNumberInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.FixedNumberInterval

Remarks

This class is to be used whenever a fixed range grouping is desired.


FixedNumberInterval Class Members

FixedNumberInterval Members

FixedNumberInterval Overview

Public Properties

public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property IncludeFieldTitleInTitle | Gets or sets whether the field name will be shown in the group title.
public property IncludeItemCountInTitle | Gets or sets the item count in the group title.
public property Length | Gets or sets the range length of the group interval.
public property NullTitle | Gets or sets the title of the null values group.
public property NullTreatment | Gets or sets how null values will be treated.
public property Start | Gets or sets the start for the group.
public property StartSource | Gets or sets how the groups will start.
public property Title | Gets or sets the groups' title.


IncludeFieldTitleInTitle property of class

FixedNumberInterval.IncludeFieldTitleInTitle Property

Gets or sets whether the field name will be shown in the group title.

[Visual Basic]
Public Property IncludeFieldTitleInTitle As Boolean[C#]
public Boolean IncludeFieldTitleInTitle {get;set;}

Remarks

  • By default, this property is set to true and therefore the field name will be part of the title of the group.

Example

To prevent the field name from showing in the group title:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.IncludeFieldTitleInTitle = false;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.IncludeFieldTitleInTitle = false
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members


IncludeItemCountInTitle property of class

FixedNumberInterval.IncludeItemCountInTitle Property

Gets or sets the item count in the group title.

[Visual Basic]
Public Property IncludeItemCountInTitle As Boolean[C#]
public Boolean IncludeItemCountInTitle {get;set;}

Remarks

  • The item count is the number of records that fall under a group. This property offers the option to display or not display the item count in the group title. By default this property is set to True.

Example

To prevent the item count from displaying in the group title:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.IncludeItemCountInTitle = false;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.IncludeItemCountInTitle = false
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members | Property


Length property of class

FixedNumberInterval.Length Property

Gets or sets the range length of the group interval.

[Visual Basic]
Public Property Length As Number[C#]
public Number Length {get;set;}

Example

To set the length of an interval:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.Length = 500;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.Length = 500
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members


NullTitle property of class

FixedNumberInterval.NullTitle Property

Gets or sets the title of the null values group.

[Visual Basic]
Public Property NullTitle As String[C#]
public String NullTitle {get;set;}

Remarks

  • This property is used when the NullTreatment is set to CreateNullGroup.

Example

To set a title to the null group:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.NullTreatment = NumberIncrementNullTreatment.CreateNullGroup;
fni.NullTitle = "No Data Specified";
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.NullTreatment = GridFX.WebForms.NumberIncrementNullTreatment.CreateNullGroup
fni.NullTitle = "No Data Specified"
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members | NullTreatment Property


NullTreatment property of class

FixedNumberInterval.NullTreatment Property

Gets or sets how null values will be treated.

[Visual Basic]
Public Property NullTreatment As NumberIncrementNullTreatment[C#]
public NumberIncrementNullTreatment NullTreatment {get;set;}

Property Value

The default is CreateNullGroup.

Value | Meaning
CreateNullGroup | Description goes here
TreatAsZero | Description goes here

Remarks

  • By default, if a null value is found, a group for null values will be created. In order to customize the title of this group, the NullTitle property should be used.

  • The other option this property offers, is to treat null values as zero.

Example

To set the null treatment :

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.NullTreatment = NumberIncrementNullTreatment.TreatAsZero;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.NullTreatment = GridFX.WebForms.NumberIncrementNullTreatment.TreatAsZero
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members | NullTitle Property


Start property of class

FixedNumberInterval.Start Property

Gets or sets the start for the group.

[Visual Basic]
Public Property Start As Number[C#]
public Number Start {get;set;}

Remarks

  • By default, the start of the group is the date of the first record. This property is useful when a specific start of a group is desired regardless of the date of the first record.

  • In order to use this property the StartSource property must be set to StartProperty.

Example

To set the start for the groups:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.StartSource = FixedIntervalStart.StartProperty;
fni.Start = 0;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.StartSource = GridFX.WebForms.FixedIntervalStart.StartProperty
fni.Start = 0
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members | StartSource Property


StartSource property of class

FixedNumberInterval.StartSource Property

Gets or sets how the groups will start.

[Visual Basic]
Public Property StartSource As FixedIntervalStart[C#]
public FixedIntervalStart StartSource {get;set;}

Property Value

The default is StartProperty.

Value | Meaning
StartProperty | Description goes here
FirstDataValue | Description goes here

Remarks

  • By default this property is set to FirstDataValue.

  • If a specific group start is desired, then this property must be set to StartProperty.

  • The other option offered by this property, is to organize the groups starting from the first data value.

Example

To set this property:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.StartSource = FixedIntervalStart.FirstDataValue;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.StartSource = GridFX.WebForms.FixedIntervalStart.FirstDataValue
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members | Start Property


Title property of class

FixedNumberInterval.Title Property

Gets or sets the groups' title.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

  • This property allows customization of the group title. For instance, it lets the developer add words before and after the dates or rearrange the order of the items in the title altogether.

Example

To set the title:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})";
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})"
Grid1.Grouping.RootLevel.Interval = fni

Applies to

FixedNumberInterval

See Also

FixedNumberInterval Class | FixedNumberInterval Members


FloatingBarSettings class

Description goes here

For a list of all members of this type, see FloatingBarSettings Members

GridFX.WebForms.FloatingBarSettings

Remarks

Description goes here


FloatingBarSettings Class Members

FloatingBarSettings Members

FloatingBarSettings Overview

Public Properties

public property Enabled Description goes here


Enabled property of class

FloatingBarSettings.Enabled Property

Description goes here

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Applies to

FloatingBarSettings

See Also

FloatingBarSettings Class | FloatingBarSettings Members


FullSizeImageFormat class

Provides access to the FieldInputSettings Class.

For a list of all members of this type, see FullSizeImageFormat Members

GridFX.WebForms.BaseImageFormat
GridFX.WebForms.FullSizeImageFormat

Remarks

These are settings for images displayed within an ImageField. These settings can stretch an image, set its height and width, and use its size ratio.


FullSizeImageFormat Class Members

FullSizeImageFormat Members

FullSizeImageFormat Overview

Public Properties

public property Height (inherited from BaseImageFormat) | Gets and sets the height of the image.
public property StretchImages (inherited from BaseImageFormat) | Determines if the image will be stretched or will retain its original size.
public property UseSizeRatio (inherited from BaseImageFormat) | Locks the size ratio of the image.
public property Width (inherited from BaseImageFormat) | Gets or sets the width of the image.


Grid class

Provides access to the Grid object. This is the main class of the GridFX library.

For a list of all members of this type, see Grid Members

GridFX.WebForms.Grid

Remarks

General grid properties are provided to set general attributes in the grid. You may use properties to not only configure visual properties like colors and borders but also to configure the Data source and the behavior of the grid at runtime. For example, it is possible to configure individual chart items as well as to define paging and sorting options for the end user.

While access is given to most of the Grid objects, due to the complexity resulting from the vast amount of features included in the component, many features like layouts and grouping are better configured at design time through the Wizards and the property grid.


Grid Class Members

Grid Members

Grid Overview

Public Properties

public property ApplicationSettings | Provides access to special configuration settings for the Grid component
public property Border | Gets access to the GridBorderSettings class that allows to set the properties of the grid border
public property CellSpacing | Gets or sets the amount of space between the grid cells.
public property Columns | Gets the collection of columns that belong to the Grid.
public property Commands | Provides access to all available Grid commands.
public property Culture | Gets and sets the localized culture settings used by the grid.
public property DataFields | Gets the collection of fields in the grid
public property DataMember | Description goes here
public property DataParameterField | Gets or sets the DataField associated with the Grid's DataParameterField.
public property DataParameterValue | Gets the PrimaryKey's value returned for a data source control's ControlParameter when a child control is selecting its data.
public property DataParameterValues | Gets the GridField's value specified in the indexer returned for a data source control's ControlParameter when a child control is selecting its data.
public property DataSource | Gets or sets the object from which the data-bound control retrieves its list of data items.
public property DataSourceID | Gets or sets the ID of the control from which the data-bound control retrieves its list of data items.
public property Editing | Gets the Editing settings applied to the Grid.
public property EnableViewState | Gets or sets the EnableViewState indicating whether the object persists its view state
public property Filtering | Gets the Filtering settings applied to the Grid. The settings include enabling/disabling and the conditions.
public property FloatingBar | Allow to access the floating bar of the grid which provides a way to manipulate visual settings of the grid's columns at runtime.
public property Grouping | Gets the grouping settings applied to the grid.
public property Groups | Gets the settings of a particular group.
public property Highlighting | Gets the Highlighting settings applied to the Grid.
public property ItemDetails | Allows to configure the behavior of the grid item.
public property Items | Returns the collection of items in the grid control.
public property ItemStyles | Allows to configure the style attributes of the Grid items
public property Layout | Gets access to the grid layout which can be set to columnar, card or form
public property Motif | Gets or sets the Motif that defines the style of the grid elements.
public property Page | Description goes here
public property Paging | Gets the Settings for paging in the grid.
public property Palette | Gets or sets a palette that determines the colors that are applied to the grid elements.
public property SelectedItems | Gets the selected item object at runtime.
public property Selection | Gets the objects that are selected by the user.
public property SideBars | Gets access to the SideBar class which allows to set properties of the grid sidebar.
public property Sorting | Allows you to access the settings for sorting in the grid.
public property TitleBar | Gets access to the TitleBar class which allows to set the properties of the grid's titlebar.
public property ToolBar | Gets access to the GridToolbarSettings class that allows to set the properties of the grid's toolbar.

Public Methods

public method CopyAllItemValuesToString | Allows to copy all data items in the grid cells into a string object
public method CopyFieldValuesToString | Allows to copy all data items of a particular Grid DataField into a string object
public method CopyItemValuesToString | Allows to copy data from a particular Grid Item into a string object
public method CopySelectedItemValuesToString | Allows to copy data from a selected GridItem into a string object
public method DataBind | Used to bind data to the Grid
public method DeleteItem | Deletes the specific item in the grid control.
public method Update | Updates all the items that are in edit mode.


ApplicationSettings property of class

Grid.ApplicationSettings Property

Provides access to special configuration settings for the Grid component

[Visual Basic]
Public ReadOnly Property ApplicationSettings As GridConfigurationSection[C#]
public GridConfigurationSection ApplicationSettings {get;}

Remarks

  • Use this property to configure the disk location for temporary files.

  • Also, it is possible to choose the desired FileHandler between the PSS service or the basic temporary files approach.

Example

To set Grid to generate temporary files instead of using the PSS service:

[C#]
 grid1.ApplicationSettings.FileHandler = OutputFileHandler.TemporaryFiles;
grid1.ApplicationSettings.TemporaryFilesPhysicalPath = "C:\\TEMP";

Applies to

Grid

See Also

Grid Class | Grid Members | Property


Border property of class

Grid.Border Property

Gets access to the GridBorderSettings class that allows to set the properties of the grid border

[Visual Basic]
Public ReadOnly Property Border As GridBorderSettings[C#]
public GridBorderSettings Border {get;}

Remarks

  • Use the Border property to specify the settings for the border of the grid.

Example

To set the border color of the grid to red:

[C#]
 grid1.Border.Color = Color.Red;

[Visual Basic]
 grid1.Border.Color = System.Drawing.Color.Red

Applies to

Grid

See Also

Grid Class | Grid Members | GridBorderSettings Class Class


CellSpacing property of class

Grid.CellSpacing Property

Gets or sets the amount of space between the grid cells.

[Visual Basic]
Public Property CellSpacing As Int32[C#]
public Int32 CellSpacing {get;set;}

Remarks

  • Use the CellSpacing property to control the spacing between adjacent cells in a Grid. This spacing is applied both vertically and horizontally.

  • Use the CellPadding property to control the spacing between the contents of a cell and the cell's border. The padding amount specified is added to all four sides of a cell.

Example

To set the CellSpacing property to 2:

[C#]
 grid1.CellSpacing = 2;

[Visual Basic]
 grid1.CellSpacing = 2

Applies to

Grid

See Also

Grid Class | Grid Members


Columns property of class

Grid.Columns Property

Gets the collection of columns that belong to the Grid.

[Visual Basic]
Public ReadOnly Property Columns As GridColumnCollection[C#]
public GridColumnCollection Columns {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The index to start at.

Remarks

  • Use this property to programmatically control the collection of columns in the Grid control.

  • This property exposes the members of the Column class. Please see the GridColumn class for additional information regarding those supported members.

Example

To set the Visible property for the first grid column:

[C#]
 grid1.Columns[0].Visible = false;

[Visual Basic]
 grid1.Columns(0).Visible = false

Applies to

Grid

See Also

Grid Class | Grid Members | GridColumn Class Class


Commands property of class

Grid.Commands Property

Provides access to all available Grid commands.

[Visual Basic]
Public ReadOnly Property Commands As GridCommands[C#]
public GridCommands Commands {get;}

Remarks

  • Use the Commands property to configure the UI commands in the grid.

  • Use the ScriptFunction property to change the Script executed when use the grid command.

  • Use the UseCallBacks property to allow calls to server events from client code without causing the page to post back and refresh.

Example

To clear the group levels at run time using a button:

[C#]
 Button1.OnClientClick = Grid1.Commands.ClearAllGroupLevels.GetExecuteScript();

Applies to

Grid

See Also

Grid Class | Grid Members | Grid.UseCallBacks Property | Class


Culture property of class

Grid.Culture Property

Gets and sets the localized culture settings used by the grid.

[Visual Basic]
Public Property Culture As CultureInfo[C#]
public CultureInfo Culture {get;set;}

Remarks

  • By default, the Grid control automatically uses the culture setting extracted from the user's browser. This property allows the developer to force the Culture to one specific setting.

Example

To change the grid's culture to spanish:

[C#]
 Grid1.Culture = new System.Globalization.CultureInfo("es-ES");

[Visual Basic]
 Grid1.Culture = New System.Globalization.CultureInfo("es-ES")

Applies to

Grid

See Also

Grid Class | Grid Members | GridField.Culture Property


DataFields property of class

Grid.DataFields Property

Gets the collection of fields in the grid

[Visual Basic]
Public ReadOnly Property DataFields As DataFieldCollection[C#]
public DataFieldCollection DataFields {get;}

Parameters

Parameter | Type | Meaning
id | String | The Id property of the data source control

Parameter | Type | Meaning
index | Int32 | The index to start a

Remarks

  • Use the textDataFields property to configure individual fields in the grid.

  • This property exposes the members of the GridField class. Please see the DataField class for additional information regarding those supported members.

Applies to

Grid

See Also

Grid Class | Grid Members | Property | DataField Class


DataMember property of class

Grid.DataMember Property

Description goes here

[Visual Basic]
Public Property DataMember As String[C#]
public String DataMember {get;set;}

Applies to

Grid

See Also

Grid Class | Grid Members


DataParameterField property of class

Grid.DataParameterField Property

Gets or sets the DataField associated with the Grid's DataParameterField.

[Visual Basic]
Public Property DataParameterField As DataField[C#]
public DataField DataParameterField {get;set;}

Remarks

  • This property is usefull when trying to associate a Child Grid to your Grid.

Applies to

Grid

See Also

Grid Class | Grid Members


DataParameterValue property of class

Grid.DataParameterValue Property

Gets the PrimaryKey's value returned for a data source control's ControlParameter when a child control is selecting its data.

[Visual Basic]
Public ReadOnly Property DataParameterValue As Object[C#]
public Object DataParameterValue {get;}

Applies to

Grid

See Also

Grid Class | Grid Members


DataParameterValues property of class

Grid.DataParameterValues Property

Gets the GridField's value specified in the indexer returned for a data source control's ControlParameter when a child control is selecting its data.

[Visual Basic]
Public ReadOnly Property DataParameterValues As GridItemDataSet[C#]
public GridItemDataSet DataParameterValues {get;}

Parameters

Parameter | Type | Meaning
fieldID | String | Name of the field.

Parameter | Type | Meaning
key | GridField | Field.

Applies to

Grid

See Also

Grid Class | Grid Members


DataSource property of class

Grid.DataSource Property

Gets or sets the object from which the data-bound control retrieves its list of data items.

[Visual Basic]
Public Property DataSource As Object[C#]
public Object DataSource {get;set;}

Remarks

  • Use the DataSource property to specify data source that provides data for populating the Grid.

  • Use the DataSourceID property to set or access the ID property of the data source control that the Grid control should use to retrieve its data source.

Example

To set populate the data source of the grid with a DataSet: TODO: steve give info on using a custom data source, since it requires more than just setting the property

[C#]
 grid1.DataSource = myDataSet;

[Visual Basic]
 grid1.DataSource = myDataSet

Applies to

Grid

See Also

Grid Class | Grid Members | DataSourceID Property


DataSourceID property of class

Grid.DataSourceID Property

Gets or sets the ID of the control from which the data-bound control retrieves its list of data items.

[Visual Basic]
Public Property DataSourceID As String[C#]
public String DataSourceID {get;set;}

Remarks

  • Use the DataSourceID property to set or access the ID property of the data source control that the Grid control should use to retrieve its data source.

  • Use the DataSource property to specify data source that provides data for populating the Grid.

Example

To configure the DataSourceID property for the Grid:

[C#]
 grid1.DataSourceID = "Table1";

[Visual Basic]
 grid1.DataSourceID = "Table1"

Applies to

Grid

See Also

Grid Class | Grid Members | DataSource Property


Editing property of class

Grid.Editing Property

Gets the Editing settings applied to the Grid.

[Visual Basic]
Public ReadOnly Property Editing As GridEditingSettings[C#]
public GridEditingSettings Editing {get;}

Remarks

  • When the Enabled property of Editing is set to true, the user may edit an Item from the Grid at run time. This property is set to false by default.

  • There are two Editing modes. They can be chosen by changing the enum property UIType. The default is InPlace.

Example

Allows for editing of an Item in run time.

[C#]
 Grid1.Editing.Enabled = true;

Switch to ModalForm Editing.

[C#]
 Grid1.Editing.UIType = EditingUI.ModalForm;

Applies to

Grid

See Also

Grid Class | Grid Members | GridUpdatingSettings Class


EnableViewState property of class

Grid.EnableViewState Property

Gets or sets the EnableViewState indicating whether the object persists its view state

[Visual Basic]
Public Property EnableViewState As Boolean[C#]
public Boolean EnableViewState {get;set;}

Example

To enable the ViewState:

[C#]
 Grid1.EnableViewState = true;

[Visual Basic]
 Grid1.EnableViewState = true

Applies to

Grid

See Also

Grid Class | Grid Members


Filtering property of class

Grid.Filtering Property

Gets the Filtering settings applied to the Grid. The settings include enabling/disabling and the conditions.

[Visual Basic]
Public ReadOnly Property Filtering As GridFilteringSettings[C#]
public GridFilteringSettings Filtering {get;}

Remarks

  • Disabling Filtering can be achieved by changing the bool Enabled. The default conditions is true.

Example

Disabling Filtering.

[C#]
 Grid1.Filtering.Enabled = false;

[Visual Basic]
 Grid1.Filtering.Enabled = false

Applies to

Grid

See Also

Grid Class | Grid Members | GridFilteringSettings Class


FloatingBar property of class

Grid.FloatingBar Property

Allow to access the floating bar of the grid which provides a way to manipulate visual settings of the grid's columns at runtime.

[Visual Basic]
Public ReadOnly Property FloatingBar As FloatingBarSettings[C#]
public FloatingBarSettings FloatingBar {get;}

Remarks

  • The floating bar provides a simple and intuitive interface to configure many column layout properties like text alignment, font styles, data ordering etc.

  • By default, the floating bar is enabled.

Example

To disable the floating bar:

[C#]
 Grid1.FloatingBar.Enabled = false;

[Visual Basic]
 Grid1.FloatingBar.Enabled = false

Applies to

Grid

See Also

Grid Class | Grid Members


Grouping property of class

Grid.Grouping Property

Gets the grouping settings applied to the grid.

[Visual Basic]
Public ReadOnly Property Grouping As GridGroupingSettings[C#]
public GridGroupingSettings Grouping {get;}

Remarks

  • The Grouping property represents all the grouping settings applied to the grid.

  • When the grouping Enabled property is set to false none grouping settings will be applied to the grid.

  • This property exposes the members of the GridGroupingSettings class. Please see the GridGroupingSettings class for additional information regarding those supported members.

Example

To set the grouping DefaultExpansion for the grid to Collapsed:

[C#]
 //create a new GridField
GridField RootLevelField = (GridField)grid1.Fields["CategoryName"];

//Grouping functionality is enabled
grid1.Grouping.Enabled = true;

//CategoryName field is set as the first nesting level
grid1.Grouping.RootLevel.Field = RootLevelField;
grid1.Grouping.RootLevel.Expanded = true;

Applies to

Grid

See Also

Grid Class | Grid Members | Enabled Property | GridGroupingSettings Class


Groups property of class

Grid.Groups Property

Gets the settings of a particular group.

[Visual Basic]
Public ReadOnly Property Groups As ReadOnlyCollection`1[C#]
public ReadOnlyCollection`1 Groups {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Group index

Remarks

  • In order for changes to take effect, the code to modify the group should be written inside the textDataBound event. This is because the groups need to be defined before any changes take place.

  • This property only gets the settings of the RootLevel groups.

Example

To expand the records of the first group:

[C#]
 Grid1.Groups[0].Expanded =true;

[Visual Basic]
 Grid1.Groups(0).Expanded = true

Applies to

Grid

See Also

Grid Class | Grid Members | GridGroupingSettings.RootLevel Property


Highlighting property of class

Grid.Highlighting Property

Gets the Highlighting settings applied to the Grid.

[Visual Basic]
Public ReadOnly Property Highlighting As GridHighlightingSettings[C#]
public GridHighlightingSettings Highlighting {get;}

Remarks

  • Setting the Enabled property of Highlighting to false will disable the highlighting of Items and column as the mouse hover over them. This property is set to true by default.

  • Different styles can be selected by setting the Style property.

Example

Disable highlighting.

[C#]
 Grid1.Highlighting.Enabled = false;

[Visual Basic]
 Grid1.Highlighting.Enabled = false

Applies to

Grid

See Also

Grid Class | Grid Members | GridHighlightingSettings Class


ItemDetails property of class

Grid.ItemDetails Property

Allows to configure the behavior of the grid item.

[Visual Basic]
Public ReadOnly Property ItemDetails As ItemDetailsSettings[C#]
public ItemDetailsSettings ItemDetails {get;}

Remarks

  • This property is useful to configure expansion settings for the grid item. It is possible to define whether the item will be expanded or not and to configure the expansion itself as well as the visual properties of the expansion button.

  • To modify visual styling of the Grid items, please refer to the ItemStyles property.

    • Visual Studio .NET

Example

To set the expanded property of the details cell:

[C#]
 Grid1.ItemDetails.Expanded = true;

[Visual Basic]
 Grid1.ItemDetails.Expanded = true

Applies to

Grid

See Also

Grid Class | Grid Members | Class


Items property of class

Grid.Items Property

Returns the collection of items in the grid control.

[Visual Basic]
Public ReadOnly Property Items As ObservableList`1[C#]
public ObservableList`1 Items {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The index to start at

Remarks

  • Use the Items property to configure the items in the grid control.

  • This property exposes the members of the BodyCellContainer class. Please see the BodyCellContainer class for additional information regarding those supported members.

Example

TODO: we will likely prevent users from adding grid items to the grid when it is data bound. To add a new Item to the grid:

[C#]
 // Add the field to the grid
TextField nameField = new TextField("Name");
grid1.Fields.Add(nameField);

// Add the items - note that FieldValues can be set at any time,
// not just before or after the item is added
GridItem newItem = new GridItem();
newItem.FieldValues[nameField] = "Joe";
grid1.Items.Add(newItem);

Applies to

Grid

See Also

Grid Class | Grid Members | BodyCellContainer Class


ItemStyles property of class

Grid.ItemStyles Property

Allows to configure the style attributes of the Grid items

[Visual Basic]
Public ReadOnly Property ItemStyles As GridItemStyleSettings[C#]
public GridItemStyleSettings ItemStyles {get;}

Remarks

  • This property can be used to modify the visual attributes of the grid items such as font styles, color and palettes.

  • To modify expansion behavior of the Grid items, please refer to the ItemDetails property.

Example

To set the background color of the grid items:

[C#]
 Grid1.ItemStyles.MainStyle.BackColor = Color.Orchid;

[Visual Basic]
 Grid1.ItemStyles.MainStyle.BackColor = System.Drawing.Color.Orchid

Applies to

Grid

See Also

Grid Class | Grid Members | ItemDetails Property | Class


Layout property of class

Grid.Layout Property

Gets access to the grid layout which can be set to columnar, card or form

[Visual Basic]
Public ReadOnly Property Layout As GridLayoutSettings[C#]
public GridLayoutSettings Layout {get;}

Example

To set the grid layout to card type:

[C#]
 Grid1.Layout.Type = GridLayoutType.Cards;

[Visual Basic]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Cards

Applies to

Grid

See Also

Grid Class | Grid Members | GridLayoutSettings Class Class


Motif property of class

Grid.Motif Property

Gets or sets the Motif that defines the style of the grid elements.

[Visual Basic]
Public Property Motif As GridMotif[C#]
public GridMotif Motif {get;set;}

Value | Meaning
Business | Description goes here
Default | Description goes here
Butterfly | Description goes here
iGrid | Description goes here
Impact | Description goes here
Lilliput | Description goes here
Outlook | Description goes here
Professional | Description goes here
Simple | Description goes here
Spreadsheet | Description goes here

Example

To set the grid motif:

[C#]
 Grid1.Motif = GridMotif.OutlookWeb;

[Visual Basic]
 Grid1.Motif = GridFX.WebForms.GridMotif.OutlookWeb

Applies to

Grid

See Also

Grid Class | Grid Members


Page property of class

Grid.Page Property

Description goes here

[Visual Basic]
Public Property Page As Page[C#]
public Page Page {get;set;}

Applies to

Grid

See Also

Grid Class | Grid Members


Paging property of class

Grid.Paging Property

Gets the Settings for paging in the grid.

[Visual Basic]
Public ReadOnly Property Paging As GridPagingSettings[C#]
public GridPagingSettings Paging {get;}

Remarks

  • The Paging property allows you to customize the paging settings for the grid.

  • This property exposes the members of the GridPagingSettings class. Please see the GridPagingSettings class for additional information regarding those supported members.

Example

To set the PageSize property to 10:

[C#]
 grid1.Paging.PageSize = 10;

[Visual Basic]
 grid1.Paging.PageSize = 10

Applies to

Grid

See Also

Grid Class | Grid Members | GridPagingSettings Class


Palette property of class

Grid.Palette Property

Gets or sets a palette that determines the colors that are applied to the grid elements.

[Visual Basic]
Public Property Palette As GridPalette[C#]
public GridPalette Palette {get;set;}

Value | Meaning
Default | Description goes here
SilverSky | Description goes here
DeepBlue | Description goes here
Grayscale | Description goes here
Windows | Description goes here
LilacsInMist | Description goes here
SnowyPine | Description goes here
HighContrast | Description goes here
Adventure | Description goes here
Mesa | Description goes here
Pastels | Description goes here
Sky | Description goes here
AltPastels | Description goes here
ModernBusiness | Description goes here
RainyDay | Description goes here
SandAndSky | Description goes here
Slate | Description goes here
BrownSugar | Description goes here
Oceanica | Description goes here
Autumn | Description goes here
Simple | Description goes here
Classic | Description goes here
Colorful | Description goes here
ChartFX6 | Description goes here
Alternate | Description goes here
Earthtones | Description goes here
Mocha | Description goes here
Professional | Description goes here
BlackAndBlue | Description goes here

Remarks

  • Use the Palette property to determines the colors that are applied to grid elements.

  • When changing the palette, all the properties related to changing colors in the grid will also be affected. So if you previously set a color using any of the Grid FX supported properties (ForeColor, BackColor, etc) this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

Example

To set the palette property of the grid:

[C#]
 grid1.Palette = GridPalette.Adventure;

[Visual Basic]
 grid1.Palette = GridFX.WebForms.GridPalette.Adventure

Applies to

Grid

See Also

Grid Class | Grid Members


SelectedItems property of class

Grid.SelectedItems Property

Gets the selected item object at runtime.

[Visual Basic]
Public ReadOnly Property SelectedItems As SelectedGridItemCollection[C#]
public SelectedGridItemCollection SelectedItems {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Index of the selected item

Example

To get decimal data from the selected record:

[C#]
 double selectedAmount = Convert.ToDouble( Grid1.SelectedItems[0].DataValues["Amount"]);

[Visual Basic]
 Dim selectedAmount As Double
selectedAmount = System.Convert.ToDouble(Grid1.SelectedItems(0).DataValues("Amount"))

Applies to

Grid

See Also

Grid Class | Grid Members


Selection property of class

Grid.Selection Property

Gets the objects that are selected by the user.

[Visual Basic]
Public ReadOnly Property Selection As GridSelectionSettings[C#]
public GridSelectionSettings Selection {get;}

Remarks

  • Use the Selection property to configure the objects selected by the user.

  • This property returns a GridSelectionSettings object. Refer to that object in order to configure the grid selection settings.

Example

To underline the selected item:

[C#]
 Grid1.Selection.Style.Underline = true;

[Visual Basic]
 Grid1.Selection.Style.Underline = true

Applies to

Grid

See Also

Grid Class | Grid Members | GridSelectionSettings Class


SideBars property of class

Grid.SideBars Property

Gets access to the SideBar class which allows to set properties of the grid sidebar.

[Visual Basic]
Public ReadOnly Property SideBars As SideBarCollection[C#]
public SideBarCollection SideBars {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Remarks

  • Please refer to the SideBar class for more information on the properties of the sidebar.

Example

To create a sidebar and add it to the grid:

[C#]
 GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Visible = true;
Grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Visible = true
Grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

Grid

See Also

Grid Class | Grid Members | SideBarCollection Class Class


Sorting property of class

Grid.Sorting Property

Allows you to access the settings for sorting in the grid.

[Visual Basic]
Public ReadOnly Property Sorting As GridSortingSettings[C#]
public GridSortingSettings Sorting {get;}

Remarks

  • Use the Sorting property to configure the sort settings for the grid.

  • This property exposes the members of the GridSortingSettings class. Please see the GridSortingSettings class for additional information regarding those supported members.

Example

To sort the grid based in the fifth field:

[C#]
 grid1.Sorting.SortedFields.Add(grid1.Fields[4]);

Applies to

Grid

See Also

Grid Class | Grid Members | GridSortingSettings Class


TitleBar property of class

Grid.TitleBar Property

Gets access to the TitleBar class which allows to set the properties of the grid's titlebar.

[Visual Basic]
Public ReadOnly Property TitleBar As GridTitleBarSettings[C#]
public GridTitleBarSettings TitleBar {get;}

Remarks

  • Used to set a title for the grid and different settings like image background, image icon.

    Please refer to the TitleBar classes which are used to set different properties of the grid's titlebar: GridTitleBarSettings, GridTitleBarImageSettings, TitleBarStyle

Example

To set a title for the grid:

[C#]
 Grid1.TitleBar.Visible = true;
Grid1.TitleBar.Title = "Grid Title";

[Visual Basic]
 Grid1.TitleBar.Visible = true
Grid1.TitleBar.Title = "Grid Title"

Applies to

Grid

See Also

Grid Class | Grid Members | GridTitleBarSettings Class Class


ToolBar property of class

Grid.ToolBar Property

Gets access to the GridToolbarSettings class that allows to set the properties of the grid's toolbar.

[Visual Basic]
Public ReadOnly Property ToolBar As GridToolbarSettings[C#]
public GridToolbarSettings ToolBar {get;}

Remarks

  • Refer to the GridToolbarSettings class for additional information on the grid's toolbar.

Example

To display the toolbar:

[C#]
 Grid1.ToolBar.Visible = true;

[Visual Basic]
 Grid1.ToolBar.Visible = true

Applies to

Grid

See Also

Grid Class | Grid Members | GridToolbarSettings Class Class


CopyAllItemValuesToString method of Grid class

Grid.CopyAllItemValuesToString Method

Allows to copy all data items in the grid cells into a string object

[Visual Basic]
Public Function CopyAllItemValuesToString( _
   ByVal field As GridField _
) AS String[C#]
public String CopyAllItemValuesToString(
   GridField field
);

Parameters

Parameter | Type | Meaning
field | GridField | Description goes here

Remarks

  • Used to copy all the grid items in the currently active page.

Example

To copy all the grid items:

[C#]
 string value;
value = Grid1.CopyAllItemValuesToString();

See Also

Grid Class | Grid Members


CopyFieldValuesToString method of Grid class

Grid.CopyFieldValuesToString Method

Allows to copy all data items of a particular Grid DataField into a string object

[Visual Basic]
Public Function CopyFieldValuesToString( _
   ByVal field As DataField _
) AS String[C#]
public String CopyFieldValuesToString(
   DataField field
);

Parameters

Parameter | Type | Meaning
field | DataField | DataField that needs to be copied

Remarks

  • Used to copy items of a DataField in the currently active page.

Example

To copy data items of a grid field:

[C#]
 string value;
value = Grid1.CopyFieldValuesToString(Grid1.DataFields[0]);

See Also

Grid Class | Grid Members


CopyItemValuesToString method of Grid class

Grid.CopyItemValuesToString Method

Allows to copy data from a particular Grid Item into a string object

[Visual Basic]
Public Function CopyItemValuesToString( _
   ByVal item As GridItem _
) AS String[C#]
public String CopyItemValuesToString(
   GridItem item
);

Parameters

Parameter | Type | Meaning
item | GridItem | GridItem that needs to be copied

Remarks

  • A GridItem is basically a row in the grid. For instance: Grid1.Items[2] represents data in the third row in the grid. This method copies all fields of a particular grid item.

Example

To copy data in the first row in grid:

[C#]
 string value;
value = Grid1.CopyItemValuesToString(Grid1.Items[0]);

See Also

Grid Class | Grid Members


CopySelectedItemValuesToString method of Grid class

Grid.CopySelectedItemValuesToString Method

Allows to copy data from a selected GridItem into a string object

[Visual Basic]
Public Function CopySelectedItemValuesToString AS String3[C#]
public String3 CopySelectedItemValuesToString();

Remarks

  • Select a particular row (GridItem) in the grid and this method will copy data from the selected grid item into a string.

Example

To copy data from a selected GridItem:

[C#]
 string value;
value = Grid1.CopySelectedItemValuesToString();

See Also

Grid Class | Grid Members


DataBind method of Grid class

Grid.DataBind Method

Used to bind data to the Grid

[Visual Basic]
Public Sub DataBind[C#]
public Void DataBind();

Example

To bind data to the grid:

[C#]
 Grid1.DataBind();

[Visual Basic]
 Grid1.DataBind

See Also

Grid Class | Grid Members


DeleteItem method of Grid class

Grid.DeleteItem Method

Deletes the specific item in the grid control.

[Visual Basic]
Public Sub DeleteItem( _
   ByVal item As GridItem _
)[C#]
public Void DeleteItem(
   GridItem item
);

Parameters

Parameter | Type | Meaning
item | GridItem | The grid item to delete.

Remarks

  • Use the DeleteItem method to programmatically delete the specific item in the grid.

  • You cannot delete a GridItem when the Grid's ReadOnly property is true.

Example

TODO: Ask how to do the sample

[C#]
 grid1.DeleteItem((GridItem) grid1.Items[0]);

[Visual Basic]
 grid1.DeleteItem(grid1.Items(0))

See Also

Grid Class | Grid Members | ReadOnly Property


Update method of Grid class

Grid.Update Method

Updates all the items that are in edit mode.

[Visual Basic]
Public Sub Update[C#]
public Void Update();

Remarks

  • Used to commit all changes to the Grid.

Example

To update items in the grid:

[C#]
 Grid1.Update();

[Visual Basic]
 Grid1.Update

See Also

Grid Class | Grid Members


GridColumn class

Provides access to the GridColumn object.

For a list of all members of this type, see GridColumn Members

GridFX.WebForms.GridColumn

Remarks

This object can be used to set the width and whether or not a column is visible. Only applies to grids set to Columnar Layout.


GridColumn Class Members

GridColumn Members

GridColumn Overview

Public Properties

public property Visible | Gets or sets a boolean determining whether the column is visible or not.
public property Width | Gets or sets a value determining the column width in pixels.


Visible property of class

GridColumn.Visible Property

Gets or sets a boolean determining whether the column is visible or not.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • The default value for every column is true.

  • Only applies to grids set to Columnar Layout.

Example

To hide the second column of a grid set to columnar.

[C#]
 Grid1.Columns[1].Visible = false;

[Visual Basic]
 Grid1.Columns(1).Visible = false

Applies to

GridColumn

See Also

GridColumn Class | GridColumn Members


GridDescendant class

Description goes here

For a list of all members of this type, see GridDescendant Members

GridFX.WebForms.GridDescendant

Remarks

Description goes here


GridDescendant Class Members

GridDescendant Members

GridDescendant Overview

Public Properties

public property NamingContainer Description goes here


NamingContainer property of class

GridDescendant.NamingContainer Property

Description goes here

[Visual Basic]
Public ReadOnly Property NamingContainer As Control[C#]
public Control NamingContainer {get;}

Applies to

GridDescendant

See Also

GridDescendant Class | GridDescendant Members


GridEditingSettings class

Provides access to the GridEditingSettings Object

For a list of all members of this type, see GridEditingSettings Members

GridFX.WebForms.GridEditingSettings

Remarks

The members of the GridEditingSettings class allow developers to control how users edit data contained in the grid. Users can delete, insert or update data in an edit bar or in place.


GridEditingSettings Class Members

GridEditingSettings Members

GridEditingSettings Overview

Public Properties

public property Deleting | Gets the deleting Settings applied to the Grid.
public property Inserting | Gets the Inserting settings applied to the Grid.
public property Updating | Gets the updating settings applied to the Grid.
public property ValidationGroup | Gets or sets the string corresponding to the ValidationGroup the grid is associated with.


Deleting property of class

GridEditingSettings.Deleting Property

Gets the deleting Settings applied to the Grid.

[Visual Basic]
Public ReadOnly Property Deleting As GridDeletingSettings[C#]
public GridDeletingSettings Deleting {get;}

Remarks

  • When the Enabled property of Deleting is set to true, the user will be able to delete an Item from the Grid.

  • This property is set to false by default.

Example

To allow users to delete an Item from the Grid at run time:

[C#]
 Grid1.Editing.Deleting.Enabled = false;

[Visual Basic]
 Grid1.Editing.Deleting.Enabled = false

Applies to

GridEditingSettings

See Also

GridEditingSettings Class | GridEditingSettings Members | GridDeletingSettings Class


Inserting property of class

GridEditingSettings.Inserting Property

Gets the Inserting settings applied to the Grid.

[Visual Basic]
Public ReadOnly Property Inserting As GridInsertingSettings[C#]
public GridInsertingSettings Inserting {get;}

Remarks

  • Setting the Enabled property of Inserting to true will enable the insertion of items to the grid at runtime.

  • This property is set to false by default.

Example

To enable inserting:

[C#]
 Grid1.Editing.Inserting.Enabled = true;

[Visual Basic]
 Grid1.Editing.Inserting.Enabled = true

Applies to

GridEditingSettings

See Also

GridEditingSettings Class | GridEditingSettings Members | GridInsertingSettings Class


Updating property of class

GridEditingSettings.Updating Property

Gets the updating settings applied to the Grid.

[Visual Basic]
Public ReadOnly Property Updating As GridUpdatingSettings[C#]
public GridUpdatingSettings Updating {get;}

Remarks

  • This property lets you specify whether the user will be allowed to modify the data of existing items.

Example

To enable updating:

[C#]
 Grid1.Editing.Updating.Enabled = true;

[Visual Basic]
 Grid1.Editing.Updating.Enabled = true

Applies to

GridEditingSettings

See Also

GridEditingSettings Class | GridEditingSettings Members | GridUpdatingSettings Class


ValidationGroup property of class

GridEditingSettings.ValidationGroup Property

Gets or sets the string corresponding to the ValidationGroup the grid is associated with.

[Visual Basic]
Public Property ValidationGroup As String[C#]
public String ValidationGroup {get;set;}

Remarks

  • This property defines ValidationGroup for all validators in the Grid. This can be used by buttons that validate the Grid and/or other controls.

Example

To set the validation group:

[C#]
 Grid1.Editing.ValidationGroup = "ValidationSettings";

[Visual Basic]
 Grid1.Editing.ValidationGroup = "ValidationSettings"

Applies to

GridEditingSettings

See Also

GridEditingSettings Class | GridEditingSettings Members


GridFilteringSettings class

Provides access to the GridFilteringSettings object.

For a list of all members of this type, see GridFilteringSettings Members

GridFX.WebForms.GridFilteringSettings

Remarks

Used to enable or disable filtering as well as access its conditions.


GridFilteringSettings Class Members

GridFilteringSettings Members

GridFilteringSettings Overview

Public Properties

public property Conditions | Gets the filtering conditions.
public property Enabled | Gets or sets a boolean value indicating whether filtering is enabled or disabled.


Conditions property of class

GridFilteringSettings.Conditions Property

Gets the filtering conditions.

[Visual Basic]
Public ReadOnly Property Conditions As FieldValueConditionCollection[C#]
public FieldValueConditionCollection Conditions {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | An integer specifying the index of the condition you want to access.

Remarks

  • The conditions index obey the order they were added to this collection.

Example

Add a condition to the collection. This would be a Greater Then condition that would display only items that has the second field with values greater then 3.

[C#]
 NumericValueCondition myCondition = new NumericValueCondition();
myCondition.Comparison = NumberComparison.GreaterThan;
myCondition.Value = 3;
myCondition.Field = Grid1.Fields[1];
Grid1.Filtering.Conditions.Add(myCondition);

Applies to

GridFilteringSettings

See Also

GridFilteringSettings Class | GridFilteringSettings Members


Enabled property of class

GridFilteringSettings.Enabled Property

Gets or sets a boolean value indicating whether filtering is enabled or disabled.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • The default value is true.

Example

To disable filtering.

[C#]
 Grid1.Filtering.Enabled = false;

[Visual Basic]
 Grid1.Filtering.Enabled = false

Applies to

GridFilteringSettings

See Also

GridFilteringSettings Class | GridFilteringSettings Members


GridGroupingSettings class

Provides access to the GridGroupingSettings object

For a list of all members of this type, see GridGroupingSettings Members

GridFX.WebForms.GridGroupingSettings

Remarks

Grouping is one of the greatest features in GridFX allowing to gather together a collection of similar data. Data is grouped in different levels of hierarchy and can be shown expanded or collapsed. The appearance of grouped data can be customized by setting different properties.


GridGroupingSettings Class Members

GridGroupingSettings Members

GridGroupingSettings Overview

Public Properties

public property Enabled | Gets or sets the grouping of the records.
public property ExpansionButton | Gets or sets the settings for the button that expands and collapses the groups.
public property HideGroupedColumns | Gets or sets whether the field used for the grouping will be displayed or not.
public property Indentation | Gets or sets how items within each group should be indented.
public property RootLevel | Gets or sets the settings of the first grouping level.
public property Style | Gets or sets all the style settings for the grouping.
public property UIBehavior | Gets or sets the behavior of the grouping at runtime.


Enabled property of class

GridGroupingSettings.Enabled Property

Gets or sets the grouping of the records.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Example

To enable grouping of the records:

[C#]
 Grid1.Grouping.Enabled = true;

[Visual Basic]
 Grid1.Grouping.Enabled = true

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members


ExpansionButton property of class

GridGroupingSettings.ExpansionButton Property

Gets or sets the settings for the button that expands and collapses the groups.

[Visual Basic]
Public ReadOnly Property ExpansionButton As ExpansionButtonSettings[C#]
public ExpansionButtonSettings ExpansionButton {get;}

Example

To set the text inside the expansion button:

[C#]
 Grid1.Grouping.ExpansionButton.ExpandText = "To Expand";

[Visual Basic]
 Grid1.Grouping.ExpansionButton.ExpandText = "To Expand"

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members


HideGroupedColumns property of class

GridGroupingSettings.HideGroupedColumns Property

Gets or sets whether the field used for the grouping will be displayed or not.

[Visual Basic]
Public Property HideGroupedColumns As GroupedColumnHiding[C#]
public GroupedColumnHiding HideGroupedColumns {get;set;}

Property Value

The default is Automatic.

Value | Meaning
Automatic | Description goes here
Always | Description goes here
Never | Description goes here

Example

To hide the field used for grouping:

[C#]
 Grid1.Grouping.HideGroupedColumns = GroupedColumnHiding.Always;

[Visual Basic]
 Grid1.Grouping.HideGroupedColumns = GridFX.WebForms.GroupedColumnHiding.Always

In the following grid, the field used to group the records (Amount) has been hiden:

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members


Indentation property of class

GridGroupingSettings.Indentation Property

Gets or sets how items within each group should be indented.

[Visual Basic]
Public Property Indentation As GroupedItemsIndentation[C#]
public GroupedItemsIndentation Indentation {get;set;}

Property Value

The default is AlwaysIndent.

Value | Meaning
AlwaysIndent | Description goes here
IndentAfterFirstLevel | Description goes here
NeverIndent | Description goes here

Example

To disable group indentation:

[C#]
 Grid1.Grouping.Indentation = GroupedItemsIndentation.NeverIndent;

[Visual Basic]
 Grid1.Grouping.Indentation = GridFX.WebForms.GroupedItemsIndentation.NeverIndent

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members


RootLevel property of class

GridGroupingSettings.RootLevel Property

Gets or sets the settings of the first grouping level.

[Visual Basic]
Public ReadOnly Property RootLevel As GroupLevel[C#]
public GroupLevel RootLevel {get;}

Remarks

  • The root level must have a field set in order to be used.

Example

To set the field to the root level:

[C#]
 Grid1.Grouping.RootLevel.Field = Grid1.Fields["Amount"];

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members | GroupLevel Property


Style property of class

GridGroupingSettings.Style Property

Gets or sets all the style settings for the grouping.

[Visual Basic]
Public ReadOnly Property Style As GridGroupingStyles[C#]
public GridGroupingStyles Style {get;}

Example

To change the back color of the groups header:

[C#]
 Grid1.Grouping.RootLevel.Style.Header.BackColor = System.Drawing.Color.Azure;

[Visual Basic]
 Grid1.Grouping.RootLevel.Style.Header.BackColor = System.Drawing.Color.Azure

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members


UIBehavior property of class

GridGroupingSettings.UIBehavior Property

Gets or sets the behavior of the grouping at runtime.

[Visual Basic]
Public Property UIBehavior As GroupingUIBehavior[C#]
public GroupingUIBehavior UIBehavior {get;set;}

Value | Meaning
SingleLevel | Description goes here
MultiLevel | Description goes here
Disabled | Description goes here

Remarks

  • If the GroupingUIBehavior is set to single level, anytime a field is selected to be grouped at runtime, the grid will reset any previous grouping and will create this new grouping.

  • If the GroupingIUBehavior is set to multi level, anytime a field is selected to be grouped it will become a ChildLevel group, unless there is no previous grouping in which case the new group will become the RootLevel group. Any other groups created after that will become ChildLevel groups.

Example

To enable multi level grouping at runtime:

[C#]
 Grid1.Grouping.UIBehavior = GroupingUIBehavior.MultiLevel;

[Visual Basic]
 Grid1.Grouping.UIBehavior = GridFX.WebForms.GroupingUIBehavior.MultiLevel

Applies to

GridGroupingSettings

See Also

GridGroupingSettings Class | GridGroupingSettings Members | GroupLevel.ChildLevel Property


GridGroupingStyles class

Allows access to the GridGroupingStyles object.

For a list of all members of this type, see GridGroupingStyles Members

GridFX.WebForms.GridGroupingStyles

Remarks

This class allows to set style options when the grouping is enabled.


GridGroupingStyles Class Members

GridGroupingStyles Members

GridGroupingStyles Overview

Public Properties

public property ColumnHeaderIndent | Gets or set the style for the spacer cell inserted in the grid's column header to align for the indentation cell in each group.
public property Levels | Gets the style options for all the grouping levels (root and child levels).


ColumnHeaderIndent property of class

GridGroupingStyles.ColumnHeaderIndent Property

Gets or set the style for the spacer cell inserted in the grid's column header to align for the indentation cell in each group.

[Visual Basic]
Public ReadOnly Property ColumnHeaderIndent As CellStyle[C#]
public CellStyle ColumnHeaderIndent {get;}

Example

To change the back color of the grid's header indentation:

[C#]
 Grid1.Grouping.Style.ColumnHeaderIndent.BackColor = System.Drawing.Color.Beige;

[Visual Basic]
 Grid1.Grouping.Style.ColumnHeaderIndent.BackColor = System.Drawing.Color.Beige

Applies to

GridGroupingStyles

See Also

GridGroupingStyles Class | GridGroupingStyles Members


Levels property of class

GridGroupingStyles.Levels Property

Gets the style options for all the grouping levels (root and child levels).

[Visual Basic]
Public ReadOnly Property Levels As GroupLevelStyle[C#]
public GroupLevelStyle Levels {get;}

Remarks

  • The style options set with this property will remain even if the grouping is changed at runtime.

Example

To change the header back color for all levels:

[C#]
 Grid1.Grouping.Style.Levels.Header.BackColor = System.Drawing.Color.Aqua;

[Visual Basic]
 Grid1.Grouping.Style.Levels.Header.BackColor = System.Drawing.Color.Aqua

Applies to

GridGroupingStyles

See Also

GridGroupingStyles Class | GridGroupingStyles Members


GridItem class

Provides access to the GridItem Class

For a list of all members of this type, see GridItem Members

GridFX.WebForms.GridChild
GridFX.WebForms.OutputCellContainer
GridFX.WebForms.GridItem

Remarks

A GridItem represents a Row within the Grid. A DataItem is the most common GridItem, and they can take on different views while changing the layout, the content, and even the data of the item. A GridItem is handled in the DataBound Event.


GridItem Class Members

GridItem Members

GridItem Overview

Public Properties

public property CardCell | Description goes here
public property Cells (inherited from OutputCellContainer) | Gets or sets the list of output cells to be added to the OutputCellContainer.
public property DataItem | Description goes here
public property DataItemIndex | Returns the index of a GridItem within a DataSource.
public property DataValues | Returns the collection of DataValues for a particular GridItem.
public property DetailsCell | Description goes here
public property DisplayIndex | Returns the index of a GridItem within a page on the Grid.
public property Editing | Allows the user to edit a GridItem within the Grid.
public property Expanded | Allows the user to expand the view of the grouped GridItems in the collection.
public property Group | Returns the GridItemGroup where this GridItem is contained.
public property GroupIndex | Returns the index of a grouped GridItem.
public property Selected | Allows the user to select a GridItem from the Grid.
public property Style | Allows the user to set the Style for an specific GridItem.

Public Methods

public method FindControlInTemplate Description goes here


CardCell property of class

GridItem.CardCell Property

Description goes here

[Visual Basic]
Public ReadOnly Property CardCell As OutputCell[C#]
public OutputCell CardCell {get;}

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Cells property of class

OutputCellContainer.Cells Property

Gets or sets the list of output cells to be added to the OutputCellContainer.

[Visual Basic]
Public ReadOnly Property Cells As IList`1[C#]
public IList`1 Cells {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Example

To add an OutputCell to the OutputCellContainer:

              [C#]
GridFX.WebForms.OutputCell outcell;
GridFX.WebForms.OutputCellContainer outcellcont;
grid1.DataBound += new EventHandler(grid1_DataBound);

void grid1_DataBound(object sender, EventArgs e)
{
outcell = (OutputCell)grid1.Items[1].Cells[2];
        outcell.Style.Bold = true;
outcellcont = (OutputCellContainer)grid1.Controls[0];
outcellcont.DataBinding += new EventHandler(outcellcont_DataBinding);
}

void outcellcont_DataBinding(object sender, EventArgs e)
{
outcellcont.Cells.Add(outcell);
}

Applies to

OutputCellContainer

See Also

OutputCellContainer Class | OutputCellContainer Members


DataItem property of class

GridItem.DataItem Property

Description goes here

[Visual Basic]
Public Property DataItem As Object[C#]
public Object DataItem {get;set;}

Applies to

GridItem

See Also

GridItem Class | GridItem Members


DataItemIndex property of class

GridItem.DataItemIndex Property

Returns the index of a GridItem within a DataSource.

[Visual Basic]
Public Property DataItemIndex As Int32[C#]
public Int32 DataItemIndex {get;set;}

Remarks

  • The DataItemIndex Property returns the index of a GridItem within a collection of items that are already bound to the Grid.

Example

Get the DataItemIndex of the first GridItem:

[C#]
 int itemIndex;
itemIndex = Grid1.Items[0].DataItemIndex;

[Visual Basic]
 Dim itemIndex As Integer
itemIndex = Grid1.Items(0).DataItemIndex

Applies to

GridItem

See Also

GridItem Class | GridItem Members


DataValues property of class

GridItem.DataValues Property

Returns the collection of DataValues for a particular GridItem.

[Visual Basic]
Public ReadOnly Property DataValues As GridItemDataSet[C#]
public GridItemDataSet DataValues {get;}

Parameters

Parameter | Type | Meaning
fieldID | String | Description goes here

Parameter | Type | Meaning
key | GridField | Description goes here

Remarks

  • The DataValues Property allows the user to access the data values for a GridItem within the Grid.

Example

Return how many DataValues a GridItem has:

[C#]
 int dataValues;
dataValues = Grid1.Items[0].DataValues.Count;

[Visual Basic]
 Dim dataValues As Integer
dataValues = Grid1.Items(0).DataValues.Count

Applies to

GridItem

See Also

GridItem Class | GridItem Members


DetailsCell property of class

GridItem.DetailsCell Property

Description goes here

[Visual Basic]
Public ReadOnly Property DetailsCell As OutputCell[C#]
public OutputCell DetailsCell {get;}

Applies to

GridItem

See Also

GridItem Class | GridItem Members


DisplayIndex property of class

GridItem.DisplayIndex Property

Returns the index of a GridItem within a page on the Grid.

[Visual Basic]
Public Property DisplayIndex As Int32[C#]
public Int32 DisplayIndex {get;set;}

Remarks

  • The DisplayIndex Property returns the index of a GridItem that is bound to a page within the Grid.

Example

Get the DisplayIndex of a GridItem:

[C#]
 int displayIndex;
displayIndex = Grid1.Items[0].DisplayIndex;

[Visual Basic]
 Dim displayIndex As Integer
displayIndex = Grid1.Items(0).DisplayIndex

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Editing property of class

GridItem.Editing Property

Allows the user to edit a GridItem within the Grid.

[Visual Basic]
Public Property Editing As Boolean[C#]
public Boolean Editing {get;set;}

Example

Allow editing for a GridItem:

[C#]
 GridItem item = Grid1.Items[0];
item.Editing = true;

[Visual Basic]
 Dim item As GridFX.WebForms.GridItem
item = Grid1.Items(0)
item.Editing = true

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Expanded property of class

GridItem.Expanded Property

Allows the user to expand the view of the grouped GridItems in the collection.

[Visual Basic]
Public Property Expanded As Boolean[C#]
public Boolean Expanded {get;set;}

Remarks

  • The Expanded Property allows the user to expand a grouped GridItem:

Example

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Group property of class

GridItem.Group Property

Returns the GridItemGroup where this GridItem is contained.

[Visual Basic]
Public Property Group As GridItemGroup[C#]
public GridItemGroup Group {get;set;}

Remarks

  • The Group Property is read-only.

  • Grouping GridItems is very useful, particularly when you want to display the data grouped by a specific Category, for example:

Applies to

GridItem

See Also

GridItem Class | GridItem Members


GroupIndex property of class

GridItem.GroupIndex Property

Returns the index of a grouped GridItem.

[Visual Basic]
Public Property GroupIndex As Int32[C#]
public Int32 GroupIndex {get;set;}

Remarks

  • The GroupIndex Property is read-only.

Example

Get the GroupIndex for a GridItem:

[C#]
 int groupIndex;
groupIndex = Grid1.Items[0].GroupIndex;

[Visual Basic]
 Dim groupIndex As Integer
groupIndex = Grid1.Items(0).GroupIndex

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Selected property of class

GridItem.Selected Property

Allows the user to select a GridItem from the Grid.

[Visual Basic]
Public Property Selected As Boolean[C#]
public Boolean Selected {get;set;}

Example

Select a GridItem:

[C#]
 GridItem item = Grid1.Items[1];
item.Selected = true;

[Visual Basic]
 Dim item As GridFX.WebForms.GridItem
item = Grid1.Items(1)
item.Selected = true

Applies to

GridItem

See Also

GridItem Class | GridItem Members


Style property of class

GridItem.Style Property

Allows the user to set the Style for an specific GridItem.

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Remarks

  • The Style Property allows the user to change the BackColor, FontFamily, FontSize, etc. of a GridItem.

Example

Set the BackColor for a GridItem:

[C#]
 GridItem item = Grid1.Items[1];
item.Style.BackColor = Color.OrangeRed;

[Visual Basic]
 Dim item As GridFX.WebForms.GridItem
item = Grid1.Items(1)
item.Style.BackColor = System.Drawing.Color.OrangeRed

Applies to

GridItem

See Also

GridItem Class | GridItem Members


FindControlInTemplate method of GridItem class

GridItem.FindControlInTemplate Method

Description goes here

[Visual Basic]
Public Function FindControlInTemplate( _
   ByVal id As String _
) AS Control[C#]
public Control FindControlInTemplate(
   String id
);

Parameters

Parameter | Type | Meaning
id | String | Description goes here

See Also

GridItem Class | GridItem Members


GridItemGroup class

Provides access to the GridItemGroup Class

For a list of all members of this type, see GridItemGroup Members

GridFX.WebForms.GridChild
GridFX.WebForms.OutputCellContainer
GridFX.WebForms.GridItemGroup

Remarks

The GridItemGroup represents a Collection of GridItem objects or sub groups in the Grid. A GridItemGroup is handled in the DataBound Event.


GridItemGroup Class Members

GridItemGroup Members

GridItemGroup Overview

Public Properties

public property Cells (inherited from OutputCellContainer) | Gets or sets the list of output cells to be added to the OutputCellContainer.
public property ChildGroups | Gets the ChildGroup collection that belongs to a GridItemGroup.
public property Expanded | Gets or sets a value indicating if the group's contents are expanded.
public property GroupIndex | Gets a value indicating the index of a GridItemGroup.
public property IsLeafGroup | Gets a value indicating if this group represents a tree, thus containing other child groups directly.
public property Items | Gets a value indicating the amount of items contained with a GridItemGroup.
public property Level | Gets the GroupLevel that created a GridItemGroup.
public property ParentGroup | Gets the ParentGroup collection that belongs to a GridItemGroup.
public property Title | Gets the title for a GridItemGroup, which is the header of such group.


ChildGroups property of class

GridItemGroup.ChildGroups Property

Gets the ChildGroup collection that belongs to a GridItemGroup.

[Visual Basic]
Public ReadOnly Property ChildGroups As ReadOnlyCollection`1[C#]
public ReadOnlyCollection`1 ChildGroups {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Remarks

  • If the GridItemGroup contains ChildGroups, then you can access such groups by calling the corresponding index.

Example

Expand a ChildGroup of a GridItemGroup:

[C#]
 GridItemGroup itemGroup = Grid1.Groups[0];
itemGroup.ChildGroups[0].Expanded = true;

[Visual Basic]
 Dim itemGroup As GridFX.WebForms.GridItemGroup
itemGroup = Grid1.Groups(0)
itemGroup.ChildGroups(0).Expanded = true

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


Expanded property of class

GridItemGroup.Expanded Property

Gets or sets a value indicating if the group's contents are expanded.

[Visual Basic]
Public Property Expanded As Boolean[C#]
public Boolean Expanded {get;set;}

Example

Expand a GridItemGroup:

[C#]
 GridItemGroup itemGroup = Grid1.Groups[0];
itemGroup.Expanded = true;

[Visual Basic]
 Dim itemGroup As GridFX.WebForms.GridItemGroup
itemGroup = Grid1.Groups(0)
itemGroup.Expanded = true

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


GroupIndex property of class

GridItemGroup.GroupIndex Property

Gets a value indicating the index of a GridItemGroup.

[Visual Basic]
Public Property GroupIndex As Int32[C#]
public Int32 GroupIndex {get;set;}

Remarks

  • The GroupIndex property is read-only.

  • If the group has a parent group, then the GroupIndex property returns the index of such child group.

Example

Get the index of a GridItemGroup:

[C#]
 int index = Grid1.Groups[0].GroupIndex;

[Visual Basic]
 Dim index As Integer
index = Grid1.Groups(0).GroupIndex

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


IsLeafGroup property of class

GridItemGroup.IsLeafGroup Property

Gets a value indicating if this group represents a tree, thus containing other child groups directly.

[Visual Basic]
Public Property IsLeafGroup As Boolean[C#]
public Boolean IsLeafGroup {get;set;}

Remarks

  • The IsLeafGroup property is read-only.

Example

Determine if the GridItemGroup contains other groups:

[C#]
 bool isLeaf = Grid1.Groups[0].IsLeafGroup;

[Visual Basic]
 Dim isLeaf As Boolean
isLeaf = Grid1.Groups(0).IsLeafGroup

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


Items property of class

GridItemGroup.Items Property

Gets a value indicating the amount of items contained with a GridItemGroup.

[Visual Basic]
Public Property Items As IList`1[C#]
public IList`1 Items {get;set;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Remarks

  • The Items property is read-only.

  • If a GridItemGroup has child groups, then the Items property returns a combined list of all the items contained in those child groups.

Example

Get the amount of items in a GridItemGroup:

[C#]
 int itemCount = Grid1.Groups[0].Items.Count;

[Visual Basic]
 Dim itemCount As Integer
itemCount = Grid1.Groups(0).Items.Count

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


Level property of class

GridItemGroup.Level Property

Gets the GroupLevel that created a GridItemGroup.

[Visual Basic]
Public Property Level As GroupLevel[C#]
public GroupLevel Level {get;set;}

Remarks

  • The Level property contains information that belongs to a parent or child group thus allowing changes for the GroupLevel of a GridItemGroup.

Example

Changing the BackColor for all ChildGroups within the same GroupLevel:

[C#]
 GridItemGroup itemGroup = Grid1.Groups[0];
itemGroup.ChildGroups[0].Level.Style.BackColor = System.Drawing.Color.LightGray;

[Visual Basic]
 Dim itemGroup As GridFX.WebForms.GridItemGroup
itemGroup = Grid1.Groups(0)
itemGroup.ChildGroups(0).Level.Style.BackColor = System.Drawing.Color.LightGray

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


ParentGroup property of class

GridItemGroup.ParentGroup Property

Gets the ParentGroup collection that belongs to a GridItemGroup.

[Visual Basic]
Public Property ParentGroup As GridItemGroup[C#]
public GridItemGroup ParentGroup {get;set;}

Remarks

  • Expanding the ParentGroup:

Example

Expand the ParentGroup of a GridItemGroup:

[C#]
 GridItemGroup itemGroup = Grid1.Groups[0];
itemGroup.Expanded = true;

[Visual Basic]
 Dim itemGroup As GridFX.WebForms.GridItemGroup
itemGroup = Grid1.Groups(0)
itemGroup.Expanded = true

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


Title property of class

GridItemGroup.Title Property

Gets the title for a GridItemGroup, which is the header of such group.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Example

Get the title for a GridItemGroup:

[C#]
 string title = Grid1.Groups[0].Title;

[Visual Basic]
 Dim title As String
title = Grid1.Groups(0).Title

Applies to

GridItemGroup

See Also

GridItemGroup Class | GridItemGroup Members


GridItemModificationState class

Provides access to the GridItemModificationState Class.

For a list of all members of this type, see GridItemModificationState Members

GridFX.WebForms.GridItemModificationState

Remarks

The GridItemModificationState Class exposes the modification parameters of a grid item during the update process.

This class can only be accessed through the ItemDataValues property of the GridItemModifyEventArgs object returned by the ItemUpdating Event


GridItemModificationState Class Members

GridItemModificationState Members

GridItemModificationState Overview

Public Properties

public property Item | Gets the GridItem being modified.
public property Keys | Gets the Keys for the GridItem.
public property NewValues | Gets the new values for the GridItem being modified.
public property OldValues | Gets a System.Collections.Specialized.OrderedDictionary object for the GridItem being modified containing the old values


Item property of class

GridItemModificationState.Item Property

Gets the GridItem being modified.

[Visual Basic]
Public ReadOnly Property Item As GridItem[C#]
public GridItem Item {get;}

Remarks

  • The Items property is read-only.

  • This property can be accessed through the ItemDataValues property of the GridItemModifyEventArgs object returned by the ItemUpdating Event.

Example

To obtain the GridItem object being modified.

[C#]
 GridItem gridItemMod = e.ItemDataValues.Item;

Applies to

GridItemModificationState

See Also

GridItemModificationState Class | GridItemModificationState Members | GridItemModifyEventArgs Class


Keys property of class

GridItemModificationState.Keys Property

Gets the Keys for the GridItem.

[Visual Basic]
Public ReadOnly Property Keys As OrderedDictionary[C#]
public OrderedDictionary Keys {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | The index fo the key in the collection

Parameter | Type | Meaning
key | Object | Name of the Key object

Remarks

  • The Items property is read-only.

    Can only be accessed within the ItemUpdating event.

Example

Gets the OrderedDictionary containing the key for the GridItem being updated.

OrderedDictionary keys = e.ItemDataValues.Keys;

Applies to

GridItemModificationState

See Also

GridItemModificationState Class | GridItemModificationState Members


NewValues property of class

GridItemModificationState.NewValues Property

Gets the new values for the GridItem being modified.

[Visual Basic]
Public ReadOnly Property NewValues As OrderedDictionary[C#]
public OrderedDictionary NewValues {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Gets the index of the new values for the GridItem being modified.

Parameter | Type | Meaning
key | Object | Gets the key of the new values for the GridItem being modified.

Remarks

  • The Items property is read-only.

    Can only be accessed within the ItemUpdating event.

Example

Gets a System.Collections.Specialized.OrderedDictionary object for the GridItem being modified containing the new values.

System.Collections.Specialized.OrderedDictionary newVal = e.ItemDataValues.NewValues;

Applies to

GridItemModificationState

See Also

GridItemModificationState Class | GridItemModificationState Members


OldValues property of class

GridItemModificationState.OldValues Property

Gets a System.Collections.Specialized.OrderedDictionary object for the GridItem being modified containing the old values

[Visual Basic]
Public ReadOnly Property OldValues As OrderedDictionary[C#]
public OrderedDictionary OldValues {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Gets the index of the old values for the GridItem being modified.

Parameter | Type | Meaning
key | Object | Gets the key of the old values for the GridItem being modified.

Remarks

  • The Items property is read-only.

    Can only be accessed within the ItemUpdating event.

Example

To Get a System.Collections.Specialized.OrderedDictionary object for the GridItem being modified containing the old values:

System.Collections.Specialized.OrderedDictionary oldVal = e.ItemDataValues.OldValues;

Applies to

GridItemModificationState

See Also

GridItemModificationState Class | GridItemModificationState Members


GridItemStyle class

Provides access to the GridItemStyle Class

For a list of all members of this type, see GridItemStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.CellStyle
GridFX.WebForms.GridItemStyle

Remarks

The GridItemStyle Class allows to configure effects and enhance visual appearances of GridItem objects.


GridItemStyle Class Members

GridItemStyle Members

GridItemStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property HorizontalAlign (inherited from CellStyle) | Gets or sets the horizontal alignment used by a CellStyle
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Overflow (inherited from CellStyle) | Gets or sets whether the cell text will be clipped or not.
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property VerticalAlign (inherited from CellStyle) | Gets or sets the vertical alignment used by a CellStyle
public property Wrap (inherited from CellStyle) | Gets or sets whether the text contents of the cell will be wrapped or not.


GridLayoutSettings class

Provides access to the GridLayoutSettings class.

For a list of all members of this type, see GridLayoutSettings Members

GridFX.WebForms.GridLayoutSettings

Remarks

This class provides properties to configure the layout of the grid. The GridLayoutSettings class lets you choose between a card-based, columnar or form grid.

Once the layout is chosen, it is also possible to adjust the settings of the selected layout.


GridLayoutSettings Class Members

GridLayoutSettings Members

GridLayoutSettings Overview

Public Properties

public property Cards | Provides access to the configuration of the grid's layout when set to cards.
public property Columnar | Provides access to the configuration of the grid's layout when set to columnar.
public property Form | Provides access to the configuration of the grid's layout when set to Form.
public property Type | Gets or sets the Layout type for the grid


Cards property of class

GridLayoutSettings.Cards Property

Provides access to the configuration of the grid's layout when set to cards.

[Visual Basic]
Public ReadOnly Property Cards As CardLayoutSettings[C#]
public CardLayoutSettings Cards {get;}

Remarks

  • This property allows the developer to configure the different visual properties of the card-based layout of the grid.

Example

To change style settings for the card's data contents:

[C#]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Cards;
Grid1.Layout.Cards.DataStyle.Bold = true ;

[Visual Basic]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Cards
Grid1.Layout.Cards.DataStyle.Bold = true

Applies to

GridLayoutSettings

See Also

GridLayoutSettings Class | GridLayoutSettings Members


Columnar property of class

GridLayoutSettings.Columnar Property

Provides access to the configuration of the grid's layout when set to columnar.

[Visual Basic]
Public ReadOnly Property Columnar As ColumnarLayoutSettings[C#]
public ColumnarLayoutSettings Columnar {get;}

Remarks

  • This property allows the developer to configure the different visual properties of the column-based layout of the grid.

Example

To set the Grids columns to maintain a fixed width:

[C#]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form;
Grid1.Layout.Columnar.FixColumnWidths = true;

[Visual Basic]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form
Grid1.Layout.Columnar.FixColumnWidths = true

Applies to

GridLayoutSettings

See Also

GridLayoutSettings Class | GridLayoutSettings Members | Property


Form property of class

GridLayoutSettings.Form Property

Provides access to the configuration of the grid's layout when set to Form.

[Visual Basic]
Public ReadOnly Property Form As FormLayoutSettings[C#]
public FormLayoutSettings Form {get;}

Remarks

  • This property allows the developer to configure the different visual properties of the Form - based layout of the grid.

  • Use this property to define a template, change borders, headings and label styles, etc.

Example

To set the border color for the form layout:

[C#]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form;
Grid1.Layout.Form.Border.Color = System.Drawing.Color.Black;

[Visual Basic]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form
Grid1.Layout.Form.Border.Color = System.Drawing.Color.Black

Applies to

GridLayoutSettings

See Also

GridLayoutSettings Class | GridLayoutSettings Members


Type property of class

GridLayoutSettings.Type Property

Gets or sets the Layout type for the grid

[Visual Basic]
Public Property Type As GridLayoutType[C#]
public GridLayoutType Type {get;set;}

Property Value

The default is Columnar.

Value | Meaning
Columnar | Description goes here
Card | Description goes here

Example

To set the grid's layout to form:

[C#]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form;

[Visual Basic]
 Grid1.Layout.Type = GridFX.WebForms.GridLayoutType.Form

Applies to

GridLayoutSettings

See Also

GridLayoutSettings Class | GridLayoutSettings Members


GridPagerSettings class

Provides access to the GridPagerSettings object.

For a list of all members of this type, see GridPagerSettings Members

GridFX.WebForms.GridPagerSettings

Remarks

This class provides manipulation of the pager settings.


GridPagerSettings Class Members

GridPagerSettings Members

GridPagerSettings Overview

Public Properties

public property Style | Gets the style settings of the pager.
public property Visibility | Gets or sets the conditions that will make the pager visible or not.


GridPagingSettings class

Provides access to the GridPagingSettings object.

For a list of all members of this type, see GridPagingSettings Members

GridFX.WebForms.GridPagingSettings

Remarks

This class provides the settings to configure and manipulate the Grid's paging.


GridPagingSettings Class Members

GridPagingSettings Members

GridPagingSettings Overview

Public Properties

public property BottomPager | Gets or sets the settings for the bottom pager.
public property CurrentPageSize | Gets the number of records displayed in the current page.
public property DataItemCount | Gets or sets the total number of items in the entire data source.
public property Enabled | Gets or sets whether data paging is turned on or off.
public property FirstItemIndex | Gets or sets the index of the first item in the current page.
public property PageCount | Gets the number of pages available in the grid.
public property PageIndex | Gets or sets the index of the current page.
public property PageSize | Gets or sets the maximun number of items per page.
public property TopPager | Gets or sets the settings for the top pager.


BottomPager property of class

GridPagingSettings.BottomPager Property

Gets or sets the settings for the bottom pager.

[Visual Basic]
Public Property BottomPager As GridPagerSettings[C#]
public GridPagerSettings BottomPager {get;set;}

Remarks

  • By default, the bottom pager is not visible.

Example

To make the bottom pager visible only if the number of records exceeds the PageSize:

[C#]
 Grid1.Paging.BottomPager.Visibility = GridFX.WebForms.PagerVisibility.VisibleIfMultiplePages;

[Visual Basic]
 Grid1.Paging.BottomPager.Visibility = GridFX.WebForms.PagerVisibility.VisibleIfMultiplePages

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


CurrentPageSize property of class

GridPagingSettings.CurrentPageSize Property

Gets the number of records displayed in the current page.

[Visual Basic]
Public ReadOnly Property CurrentPageSize As Int32[C#]
public Int32 CurrentPageSize {get;}

Example

To get thetext CurrentPageSize:

[C#]
 int pageSize = Grid1.Paging.CurrentPageSize;

[Visual Basic]
 Dim pageSize As Integer
pageSize = Grid1.Paging.CurrentPageSize

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


DataItemCount property of class

GridPagingSettings.DataItemCount Property

Gets or sets the total number of items in the entire data source.

[Visual Basic]
Public Property DataItemCount As Int32[C#]
public Int32 DataItemCount {get;set;}

Remarks

  • Tipically, this property is set by the grid duting data binding.

Example

To get the item count of all the records in the data source:

[C#]
 int itemCount = Grid1.Paging.DataItemCount;

[Visual Basic]
 Dim itemCount As Integer
itemCount = Grid1.Paging.DataItemCount

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


Enabled property of class

GridPagingSettings.Enabled Property

Gets or sets whether data paging is turned on or off.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • Whe this property is set to false, the grid will treat the entire data source as a single page.

Example

To enable data paging:

[C#]
 Grid1.Paging.Enabled = true;

[Visual Basic]
 Grid1.Paging.Enabled = true

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


FirstItemIndex property of class

GridPagingSettings.FirstItemIndex Property

Gets or sets the index of the first item in the current page.

[Visual Basic]
Public Property FirstItemIndex As Int32[C#]
public Int32 FirstItemIndex {get;set;}

Example

To get the first item of the current page:

[C#]
 int index = Grid1.Paging.FirstItemIndex;

[Visual Basic]
 Dim index As Integer
index = Grid1.Paging.FirstItemIndex

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


PageCount property of class

GridPagingSettings.PageCount Property

Gets the number of pages available in the grid.

[Visual Basic]
Public ReadOnly Property PageCount As Int32[C#]
public Int32 PageCount {get;}

Example

To get the number of available pages:

[C#]
 int pageCount = Grid1.Paging.PageCount;

[Visual Basic]
 Dim pageCount As Integer
pageCount = Grid1.Paging.PageCount

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


PageIndex property of class

GridPagingSettings.PageIndex Property

Gets or sets the index of the current page.

[Visual Basic]
Public Property PageIndex As Int32[C#]
public Int32 PageIndex {get;set;}

Example

To get the index of the current page:

[C#]
 int pageIndex = Grid1.Paging.PageIndex;

[Visual Basic]
 Dim pageIndex As Integer
pageIndex = Grid1.Paging.PageIndex

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


PageSize property of class

GridPagingSettings.PageSize Property

Gets or sets the maximun number of items per page.

[Visual Basic]
Public Property PageSize As Int32[C#]
public Int32 PageSize {get;set;}

Example

To sets the page size:

[C#]
 Grid1.Paging.PageSize = 20;

[Visual Basic]
 Grid1.Paging.PageSize = 20

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


TopPager property of class

GridPagingSettings.TopPager Property

Gets or sets the settings for the top pager.

[Visual Basic]
Public Property TopPager As GridPagerSettings[C#]
public GridPagerSettings TopPager {get;set;}

Remarks

  • By default, the TopPager will be visible only if the number of records exceeds the PageSize.

Example

To make the textTopPager always visible:

[C#]
 Grid1.Paging.TopPager.Visibility = GridFX.WebForms.PagerVisibility.AlwaysVisible;

[Visual Basic]
 Grid1.Paging.TopPager.Visibility = GridFX.WebForms.PagerVisibility.AlwaysVisible

Applies to

GridPagingSettings

See Also

GridPagingSettings Class | GridPagingSettings Members


GridSortingSettings class

Provides access to the GridSortingSettings object.

For a list of all members of this type, see GridSortingSettings Members

GridFX.WebForms.GridSortingSettings

Remarks

This class provides the settings to configure and manipulate the Grid's sorting.


GridSortingSettings Class Members

GridSortingSettings Members

GridSortingSettings Overview

Public Properties

public property Enabled | Gets or sets a bool determining if sorting is allowed during run time.
public property SortedFields | Allows you to set settings of a sorted field.
public property UIBehavior | Used to change the sorting user interface behavior.


Enabled property of class

GridSortingSettings.Enabled Property

Gets or sets a bool determining if sorting is allowed during run time.

[Visual Basic]
Public Property Enabled As Boolean[C#]
public Boolean Enabled {get;set;}

Remarks

  • The default value is true.

Example

Disabling the sorting capability of a Grid during run time.

[C#]
 Grid1.Sorting.Enabled = false;

[Visual Basic]
 Grid1.Sorting.Enabled = false

Applies to

GridSortingSettings

See Also

GridSortingSettings Class | GridSortingSettings Members


SortedFields property of class

GridSortingSettings.SortedFields Property

Allows you to set settings of a sorted field.

[Visual Basic]
Public Property SortedFields As FieldReferenceCollection[C#]
public FieldReferenceCollection SortedFields {get;set;}

Parameters

Parameter | Type | Meaning
index | Int32 | An integer specifying the sorted field you want to set the settings to.

Example

To change the title of the first field you are sorting by.

[C#]
 Grid1.Sorting.SortedFields[0].Title = "Sorted by: " + Grid1.Sorting.SortedFields[0].Title;

[Visual Basic]
 Grid1.Sorting.SortedFields(0).Title = ("Sorted by: " + Grid1.Sorting.SortedFields(0).Title)

Applies to

GridSortingSettings

See Also

GridSortingSettings Class | GridSortingSettings Members


UIBehavior property of class

GridSortingSettings.UIBehavior Property

Used to change the sorting user interface behavior.

[Visual Basic]
Public Property UIBehavior As SortingUIBehavior[C#]
public SortingUIBehavior UIBehavior {get;set;}

Value | Meaning
SingleField | Description goes here
MultipleFields | Description goes here
Disabled | Description goes here

Remarks

  • There are three different behaviors: SingleFields, MultipleFields and Disabled.

  • The default value is SingleFields.

Example

To allow multiple fields sorting.

[C#]
 Grid1.Sorting.UIBehavior = SortingUIBehavior.MultipleFields;

[Visual Basic]
 Grid1.Sorting.UIBehavior = GridFX.WebForms.SortingUIBehavior.MultipleFields

Applies to

GridSortingSettings

See Also

GridSortingSettings Class | GridSortingSettings Members


GridTitleBarImageSettings class

Provides access to the image icon of the Grid's TitleBar

For a list of all members of this type, see GridTitleBarImageSettings Members

GridFX.WebForms.GridTitleBarImageSettings

Remarks

Used to set the properties of the image icon for the Grid's TitleBar.


GridTitleBarImageSettings Class Members

GridTitleBarImageSettings Members

GridTitleBarImageSettings Overview

Public Properties

public property CustomUrl | Gets or sets the custom image which can be used as the image icon of the Grid's TitleBar
public property HorizontalAlignment | Gets or sets the alignment property which allows the image icon to be aligned in one of the four possible positions in the Grid's TitleBar
public property Icon | Gets or sets the image icon for the TitleBar of the Grid


CustomUrl property of class

GridTitleBarImageSettings.CustomUrl Property

Gets or sets the custom image which can be used as the image icon of the Grid's TitleBar

[Visual Basic]
Public Property CustomUrl As String[C#]
public String CustomUrl {get;set;}

Remarks

  • When using this property, the Icon property must be set to TitleBarIcon.Custom

Example

To set the icon image to an image file saved in the application:

[C#]
 Grid1.TitleBar.Image.CustomUrl = "~/hand_point3.gif";
Grid1.TitleBar.Image.Icon = TitleBarIcon.Custom;

[Visual Basic]
 Grid1.TitleBar.Image.CustomUrl = "~/hand_point3.gif"
Grid1.TitleBar.Image.Icon = GridFX.WebForms.TitleBarIcon.Custom

Applies to

GridTitleBarImageSettings

See Also

GridTitleBarImageSettings Class | GridTitleBarImageSettings Members


HorizontalAlignment property of class

GridTitleBarImageSettings.HorizontalAlignment Property

Gets or sets the alignment property which allows the image icon to be aligned in one of the four possible positions in the Grid's TitleBar

[Visual Basic]
Public Property HorizontalAlignment As TitleBarImageHorizontalAlign[C#]
public TitleBarImageHorizontalAlign HorizontalAlignment {get;set;}

Property Value

The default is LeftEdgeOfGrid.

Value | Meaning
LeftEdgeOfTitle | Description goes here
LeftEdgeOfGrid | Description goes here
RightEdgeOfTitle | Description goes here
RightEdgeOfGrid | Description goes here

Remarks

  • There are 4 possible alignments for the image icon: LeftEdgeOfGrid, LeftEdgeOfTitle, RightEdgeOfGrid, RightEdgeOfTitle.

Example

To align the icon to the right edge of the grid:

[C#]
 Grid1.TitleBar.Image.HorizontalAlignment = TitleBarImageHorizontalAlign.RightEdgeOfGrid;

[Visual Basic]
 Grid1.TitleBar.Image.HorizontalAlignment = GridFX.WebForms.TitleBarImageHorizontalAlign.RightEdgeOfGrid

Applies to

GridTitleBarImageSettings

See Also

GridTitleBarImageSettings Class | GridTitleBarImageSettings Members


Icon property of class

GridTitleBarImageSettings.Icon Property

Gets or sets the image icon for the TitleBar of the Grid

[Visual Basic]
Public Property Icon As TitleBarIcon[C#]
public TitleBarIcon Icon {get;set;}

Property Value

The default is About.

Value | Meaning
None | Description goes here
Custom | Description goes here
About | Description goes here
Address1 | Description goes here
Address2 | Description goes here
Airplane | Description goes here
Arrow1 | Description goes here
Arrow2 | Description goes here
Arrow3 | Description goes here
Arrow4 | Description goes here
Barcode | Description goes here
Battery | Description goes here
Book1 | Description goes here
Book2 | Description goes here
Book3 | Description goes here
Book4 | Description goes here
Bottle | Description goes here
Box1 | Description goes here
Box2 | Description goes here
Box3 | Description goes here
Box4 | Description goes here
Box5 | Description goes here
Box6 | Description goes here
Box7 | Description goes here
Box8 | Description goes here
Box9 | Description goes here
Briefcase1 | Description goes here
Briefcase2 | Description goes here
Building1 | Description goes here
Bulb1 | Description goes here
Bulb2 | Description goes here
Calendar | Description goes here
Calendar1 | Description goes here
Calendar2 | Description goes here
Car1 | Description goes here
Car2 | Description goes here
Car3 | Description goes here
Car4 | Description goes here
Cd | Description goes here
CdGold | Description goes here
Certificate | Description goes here
Chart1 | Description goes here
Chart2 | Description goes here
Chart3 | Description goes here
Chest | Description goes here
Clipboard | Description goes here
Clock | Description goes here
Comp1 | Description goes here
Comp2 | Description goes here
Comp3 | Description goes here
Comp4 | Description goes here
Comp5 | Description goes here
Comp6 | Description goes here
Comp7 | Description goes here
Comp8 | Description goes here
Compass | Description goes here
Contract | Description goes here
Copy | Description goes here
Cube1 | Description goes here
Cube2 | Description goes here
Cube3 | Description goes here
Cube4 | Description goes here
Cube5 | Description goes here
Cube6 | Description goes here
Data1 | Description goes here
Data2 | Description goes here
Data3 | Description goes here
Data4 | Description goes here
Dictionary | Description goes here
Doc1 | Description goes here
Doc2 | Description goes here
Doc3 | Description goes here
Doc4 | Description goes here
Doc5 | Description goes here
Doc6 | Description goes here
Doc7 | Description goes here
Earth | Description goes here
Flash | Description goes here
Folder1 | Description goes here
Folder2 | Description goes here
Folder3 | Description goes here
Folder4 | Description goes here
Folder5 | Description goes here
Folder6 | Description goes here
Folder7 | Description goes here
Folder8 | Description goes here
Font | Description goes here
Form1 | Description goes here
Form2 | Description goes here
Form3 | Description goes here
Form4 | Description goes here
Gear | Description goes here
Goldbar | Description goes here
Help | Description goes here
Home | Description goes here
Hourglass | Description goes here
IdCard1 | Description goes here
IdCard2 | Description goes here
IdCard3 | Description goes here
Import1 | Description goes here
Import2 | Description goes here
Index | Description goes here
IndexView | Description goes here
Info1 | Description goes here
Info2 | Description goes here
Key | Description goes here
Lifebelt | Description goes here
Link | Description goes here
Lock | Description goes here
Lock2 | Description goes here
Mail1 | Description goes here
Mail2 | Description goes here
Mail3 | Description goes here
Mail4 | Description goes here
Mail5 | Description goes here
Mail6 | Description goes here
Medal | Description goes here
Memory | Description goes here
Message | Description goes here
Money01 | Description goes here
Money02 | Description goes here
Money03 | Description goes here
Money04 | Description goes here
Money05 | Description goes here
Money06 | Description goes here
Money07 | Description goes here
Money08 | Description goes here
Money09 | Description goes here
Money10 | Description goes here
Money11 | Description goes here
Money12 | Description goes here
News | Description goes here
Note | Description goes here
NotePlain | Description goes here
Notebook | Description goes here
NutAndBolt | Description goes here
Palette | Description goes here
Pen1 | Description goes here
Pen2 | Description goes here
Pen3 | Description goes here
Pencil1 | Description goes here
Pencil2 | Description goes here
People01 | Description goes here
People02 | Description goes here
People03 | Description goes here
People04 | Description goes here
People05 | Description goes here
People06 | Description goes here
People07 | Description goes here
People08 | Description goes here
People09 | Description goes here
People10 | Description goes here
People11 | Description goes here
People12 | Description goes here
People13 | Description goes here
People14 | Description goes here
People15 | Description goes here
People16 | Description goes here
People17 | Description goes here
People18 | Description goes here
People19 | Description goes here
People20 | Description goes here
People21 | Description goes here
Phone1 | Description goes here
Phone2 | Description goes here
Phone3 | Description goes here
Photo1 | Description goes here
Photo2 | Description goes here
Preferences | Description goes here
Present1 | Description goes here
Present2 | Description goes here
QuestionAndAnswer | Description goes here
Recycle | Description goes here
Safe | Description goes here
Scroll | Description goes here
Server | Description goes here
ServerDoc | Description goes here
ServerId | Description goes here
ServerLock | Description goes here
ServerMail | Description goes here
Shop1 | Description goes here
Shop2 | Description goes here
Shop3 | Description goes here
Shop4 | Description goes here
Star1 | Description goes here
Star2 | Description goes here
Star3 | Description goes here
Star4 | Description goes here
Star5 | Description goes here
Stopwatch | Description goes here
TextRichColored | Description goes here
Toolbox | Description goes here
Tree | Description goes here
Tv | Description goes here
View | Description goes here
Warning | Description goes here
Weather1 | Description goes here
Weather2 | Description goes here
Window1 | Description goes here
Window2 | Description goes here
Window3 | Description goes here

Remarks

  • There are different possible icon images of type GridFX.WebForms.TitleBarIcon which can be set for the TitleBar.

Example

To set an image icon for the grid's titlebar:

[C#]
 Grid1.TitleBar.Image.Icon = TitleBarIcon.Book1;

[Visual Basic]
 Grid1.TitleBar.Image.Icon = GridFX.WebForms.TitleBarIcon.Book1

Applies to

GridTitleBarImageSettings

See Also

GridTitleBarImageSettings Class | GridTitleBarImageSettings Members


GridTitleBarSettings class

Provides access to the Grid's TitleBar

For a list of all members of this type, see GridTitleBarSettings Members

GridFX.WebForms.GridTitleBarSettings

Remarks

Used to set properties of the Grid's TitleBar.


GridTitleBarSettings Class Members

GridTitleBarSettings Members

GridTitleBarSettings Overview

Public Properties

public property Image | Gets access to the GridTitleBarImageSettings class which allows to set an image icon for the TitleBar
public property Separator | Gets access to the SideBarSeparator class which allows to set the properties of separator that divides the TitleBar from the Grid
public property Style | Gets access to the TitleBarStyle class which allows to set the style attributes of the TitleBar
public property Subtitle | Gets or sets the subtitle for the Grid
public property Title | Gets or sets the title of the Grid
public property Visible | Gets or sets the visible property which allows the TitleBar of the Grid to be displayed or hidden


Image property of class

GridTitleBarSettings.Image Property

Gets access to the GridTitleBarImageSettings class which allows to set an image icon for the TitleBar

[Visual Basic]
Public ReadOnly Property Image As GridTitleBarImageSettings[C#]
public GridTitleBarImageSettings Image {get;}

Remarks

  • Please refer to the GridTitleBarImageSettings class for more information on this property.

Example

To set the image icon for the TitleBar:

[C#]
 Grid1.TitleBar.Image.Icon = TitleBarIcon.Book1;

[Visual Basic]
 Grid1.TitleBar.Image.Icon = GridFX.WebForms.TitleBarIcon.Book1

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members | GridTitleBarImageSettings Class Class


Separator property of class

GridTitleBarSettings.Separator Property

Gets access to the SideBarSeparator class which allows to set the properties of separator that divides the TitleBar from the Grid

[Visual Basic]
Public ReadOnly Property Separator As SideBarSeparator[C#]
public SideBarSeparator Separator {get;}

Example

To set the color of the TitleBar separator:

[C#]
 Grid1.TitleBar.Separator.Visible = true;
Grid1.TitleBar.Separator.BackColor = Color.DarkOrchid;

[Visual Basic]
 Grid1.TitleBar.Separator.Visible = true
Grid1.TitleBar.Separator.BackColor = System.Drawing.Color.DarkOrchid

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members | SideBarSeparator Class Class


Style property of class

GridTitleBarSettings.Style Property

Gets access to the TitleBarStyle class which allows to set the style attributes of the TitleBar

[Visual Basic]
Public ReadOnly Property Style As TitleBarStyle[C#]
public TitleBarStyle Style {get;}

Example

To set the backcolor of the TitleBar:

[C#]
 Grid1.TitleBar.Style.BackColor = Color.MediumTurquoise;

[Visual Basic]
 Grid1.TitleBar.Style.BackColor = System.Drawing.Color.MediumTurquoise

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members | TitleBarStyle Class Class


Subtitle property of class

GridTitleBarSettings.Subtitle Property

Gets or sets the subtitle for the Grid

[Visual Basic]
Public Property Subtitle As String[C#]
public String Subtitle {get;set;}

Example

To set the subtitle of the grid:

[C#]
 Grid1.TitleBar.Subtitle = "Subtitle of Grid";

[Visual Basic]
 Grid1.TitleBar.Subtitle = "Subtitle of Grid"

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members


Title property of class

GridTitleBarSettings.Title Property

Gets or sets the title of the Grid

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

Example

To set the title of the Grid:

[C#]
 Grid1.TitleBar.Title = "Grid Title";

[Visual Basic]
 Grid1.TitleBar.Title = "Grid Title"

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members


Visible property of class

GridTitleBarSettings.Visible Property

Gets or sets the visible property which allows the TitleBar of the Grid to be displayed or hidden

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Example

To hide the TitleBar:

[C#]
 Grid1.TitleBar.Visible = false;

[Visual Basic]
 Grid1.TitleBar.Visible = false

Applies to

GridTitleBarSettings

See Also

GridTitleBarSettings Class | GridTitleBarSettings Members


GridToolbarSettings class

Provides access to the Grid's Toolbar

For a list of all members of this type, see GridToolbarSettings Members

GridFX.WebForms.GridToolbarSettings

Remarks

Used to set the properties of the Grid's toolbar


GridToolbarSettings Class Members

GridToolbarSettings Members

GridToolbarSettings Overview

Public Properties

public property Buttons | Gets access to the GridToolbarButtons class which allows access to the different buttons in the Grid's Toolbar
public property Separator | Gets access to the SideBarSeparator class that allows to set the attributes of the sidebar that separates the toolbar from the grid items
public property Visible | Gets or sets the visible property which allows the Grid toolbar to be displayed or hidden


Buttons property of class

GridToolbarSettings.Buttons Property

Gets access to the GridToolbarButtons class which allows access to the different buttons in the Grid's Toolbar

[Visual Basic]
Public ReadOnly Property Buttons As GridToolbarButtons[C#]
public GridToolbarButtons Buttons {get;}

Remarks

  • This property is used to either show or hide the different buttons in the Grid's Toolbar.

Example

To enable the ChangePalette button in the toolbar:

[C#]
 Grid1.ToolBar.Buttons.ChangePalette.Visible = true;

[Visual Basic]
 Grid1.ToolBar.Buttons.ChangePalette.Visible = true

Applies to

GridToolbarSettings

See Also

GridToolbarSettings Class | GridToolbarSettings Members | Property | GridToolbarButtons Class Class


Separator property of class

GridToolbarSettings.Separator Property

Gets access to the SideBarSeparator class that allows to set the attributes of the sidebar that separates the toolbar from the grid items

[Visual Basic]
Public ReadOnly Property Separator As SideBarSeparator[C#]
public SideBarSeparator Separator {get;}

Remarks

  • Please refer to the SideBarSeparator class for additional information.

Example

To show the toolbar separator:

[C#]
 Grid1.ToolBar.Separator.Visible = true;

[Visual Basic]
 Grid1.ToolBar.Separator.Visible = true

Applies to

GridToolbarSettings

See Also

GridToolbarSettings Class | GridToolbarSettings Members | SideBarSeparator Class Class


Visible property of class

GridToolbarSettings.Visible Property

Gets or sets the visible property which allows the Grid toolbar to be displayed or hidden

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Example

To hide the toolbar:

[C#]
 Grid1.ToolBar.Visible = false;

[Visual Basic]
 Grid1.ToolBar.Visible = false

Applies to

GridToolbarSettings

See Also

GridToolbarSettings Class | GridToolbarSettings Members


GroupInterval class

Provides access to the GroupInterval object

For a list of all members of this type, see GroupInterval Members

GridFX.WebForms.GroupInterval

Remarks

Use this object to define an interval used to create data groups.


GroupInterval Class Members

GroupInterval Members

GroupInterval Overview

Public Properties

public property HideData Allows to hide the field name of the records.


GroupLevel class

Provides access to the GroupLevel object

For a list of all members of this type, see GroupLevel Members

GridFX.WebForms.GroupLevel

Remarks

GroupLevel object represent the entry level in the grouped data hierarchy.


GroupLevel Class Members

GroupLevel Members

GroupLevel Overview

Public Properties

public property ChildLevel | Gets or sets a child grouping level.
public property CollapsedFootersVisible | Gets or sets the footers when the groups are collapsed.
public property Expanded | Gets or sets the expanded view of the groups at the grid startup.
public property Field | Gets or sets the field that will be used to group the records.
public property Interval | Gets or sets the interval to be used for grouping.
public property Style | Gets or sets the appearance attributes of the groups.


ChildLevel property of class

GroupLevel.ChildLevel Property

Gets or sets a child grouping level.

[Visual Basic]
Public Property ChildLevel As GroupLevel[C#]
public GroupLevel ChildLevel {get;set;}

Remarks

  • This property is useful when a nested type of grouping is desired.

  • The root level should be created before adding a child level.

Example

To create and add a child level:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.Length = 2000;
Grid1.Grouping.RootLevel.Interval = fni;
FixedNumberInterval fni0 = new FixedNumberInterval();
fni0.Length = 500;
Grid1.Grouping.RootLevel.ChildLevel.Field = Grid1.Fields["FieldName"];
Grid1.Grouping.RootLevel.ChildLevel.Interval = fni0;

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


CollapsedFootersVisible property of class

GroupLevel.CollapsedFootersVisible Property

Gets or sets the footers when the groups are collapsed.

[Visual Basic]
Public Property CollapsedFootersVisible As Boolean[C#]
public Boolean CollapsedFootersVisible {get;set;}

Remarks

  • If the groups have a footer defined, this will determine whether the footer cell is visible when the group is collapsed.

Example

To prevent the footers from displaying when the groups are collapsed:

[C#]
 Grid1.Grouping.RootLevel.ChildLevel.CollapsedFootersVisible = false;

[Visual Basic]
 Grid1.Grouping.RootLevel.ChildLevel.CollapsedFootersVisible = false

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


Expanded property of class

GroupLevel.Expanded Property

Gets or sets the expanded view of the groups at the grid startup.

[Visual Basic]
Public Property Expanded As Boolean[C#]
public Boolean Expanded {get;set;}

Remarks

Example

To enable the initial expansion of the groups:

[C#]
 Grid1.Grouping.RootLevel.Expanded = true;

[Visual Basic]
 Grid1.Grouping.RootLevel.Expanded = true

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


Field property of class

GroupLevel.Field Property

Gets or sets the field that will be used to group the records.

[Visual Basic]
Public Property Field As DataField[C#]
public DataField Field {get;set;}

Example

To set the field:

[C#]
 Grid1.Grouping.RootLevel.Field = Grid1.Fields["FieldName"];

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


Interval property of class

GroupLevel.Interval Property

Gets or sets the interval to be used for grouping.

[Visual Basic]
Public Property Interval As GroupInterval[C#]
public GroupInterval Interval {get;set;}

Example

To set the groups' interval to fixed number intervals:

[C#]
 FixedNumberInterval fni = new FixedNumberInterval();
fni.Length = 2000;
Grid1.Grouping.RootLevel.Interval = fni;

[Visual Basic]
 Dim fni As GridFX.WebForms.FixedNumberInterval
fni = New GridFX.WebForms.FixedNumberInterval
fni.Length = 2000
Grid1.Grouping.RootLevel.Interval = fni

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


Style property of class

GroupLevel.Style Property

Gets or sets the appearance attributes of the groups.

[Visual Basic]
Public ReadOnly Property Style As GroupLevelStyle[C#]
public GroupLevelStyle Style {get;}

Example

To underline the root level group titles:

[C#]
 Grid1.Grouping.RootLevel.Style.Underline = true;

[Visual Basic]
 Grid1.Grouping.RootLevel.Style.Underline = true

Applies to

GroupLevel

See Also

GroupLevel Class | GroupLevel Members


GroupLevelStyle class

Provides access to the GroupLevelStyle object

For a list of all members of this type, see GroupLevelStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.CellStyle
GridFX.WebForms.GroupLevelStyle

Remarks

GroupLevelStyle object allows to configure effects and enhance visual appearance of GroupLevel objects.


GroupLevelStyle Class Members

GroupLevelStyle Members

GroupLevelStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property Footer | Gets the style applied to the cells in the column footer.
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property Header | Gets the style applied to the cells in the column header.
public property HorizontalAlign (inherited from CellStyle) | Gets or sets the horizontal alignment used by a CellStyle
public property Indent | Gets the style applied to the cells in the grid items.
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Overflow (inherited from CellStyle) | Gets or sets whether the cell text will be clipped or not.
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property VerticalAlign (inherited from CellStyle) | Gets or sets the vertical alignment used by a CellStyle
public property Wrap (inherited from CellStyle) | Gets or sets whether the text contents of the cell will be wrapped or not.


Footer property of class

GroupLevelStyle.Footer Property

Gets the style applied to the cells in the column footer.

[Visual Basic]
Public ReadOnly Property Footer As CellStyle[C#]
public CellStyle Footer {get;}

Example

To change the footer text font to italics:

[C#]
 Grid1.Grouping.RootLevel.Style.Footer.Italic = true;

[Visual Basic]
 Grid1.Grouping.RootLevel.Style.Footer.Italic = true

Applies to

GroupLevelStyle

See Also

GroupLevelStyle Class | GroupLevelStyle Members


Header property of class

GroupLevelStyle.Header Property

Gets the style applied to the cells in the column header.

[Visual Basic]
Public ReadOnly Property Header As CellStyle[C#]
public CellStyle Header {get;}

Example

To change the header text font to italics:

[C#]
 Grid1.Grouping.RootLevel.Style.Header.Italic = true;

[Visual Basic]
 Grid1.Grouping.RootLevel.Style.Header.Italic = true

Applies to

GroupLevelStyle

See Also

GroupLevelStyle Class | GroupLevelStyle Members


Indent property of class

GroupLevelStyle.Indent Property

Gets the style applied to the cells in the grid items.

[Visual Basic]
Public ReadOnly Property Indent As CellStyle[C#]
public CellStyle Indent {get;}

Example

To change the back color of the indentation to yellow:

[C#]
 Grid1.Grouping.RootLevel.Style.Indent.BackColor = System.Drawing.Color.Yellow;

[Visual Basic]
 Grid1.Grouping.RootLevel.Style.Indent.BackColor = System.Drawing.Color.Yellow

Applies to

GroupLevelStyle

See Also

GroupLevelStyle Class | GroupLevelStyle Members


ImageField class

Provides access to the ImageField Class.

For a list of all members of this type, see ImageField Members

GridFX.WebForms.DataField
GridFX.WebForms.ImageField

Remarks

An ImageField does not allow sorting or grouping, unless it's a URL. Image Data can come in three different ways:

The actual bytes for the image. This is typically for when images are stored in the database.

An image object. This is typically for when the grid is bound to a business object and that object has a property that is an image.

URL string fragment. Any data types that aren't byte[] or System.Drawing.Image are used to construct a URL for the image.

If the data contains the exact link, you don't need to do anything. If there is some format to the URL, you must set the Url property. If you are using this method, it is not recommended that you apply effects to the image (this includes sizing) or the thumbnail because the source bytes will be downloaded, which could downgrade performance.


ImageField Class Members

ImageField Members

ImageField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Gets and sets attributes to format the ImageField on the Grid.
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property ThumbnailUrl | Gets or sets the URL for the thumbnail image.
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Url | Gets or sets the format string for the url of the full size original image.
public property VerifyUrlExists | Gets or sets a value indicating if the grid checks each image url to ensure the image exists or not, which lets the field display a nice "no image found" image rather than the default browser red 'X'.
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Format property of class

ImageField.Format Property

Gets and sets attributes to format the ImageField on the Grid.

[Visual Basic]
Public ReadOnly Property Format As ImageFormatter[C#]
public ImageFormatter Format {get;}

Example

To set the ImageField to use thumbnails:

[C#]
 ImageField imField = new ImageField();
Grid1.Fields.Add(imField);
imField.Format.UseThumbnail = true;

Applies to

ImageField

See Also

ImageField Class | ImageField Members | Property


ThumbnailUrl property of class

ImageField.ThumbnailUrl Property

Gets or sets the URL for the thumbnail image.

[Visual Basic]
Public Property ThumbnailUrl As String[C#]
public String ThumbnailUrl {get;set;}

Remarks

  • This url should be used when the thumbnails have already been generated. Some systems create a thumbnail when images are added. This will be ignored if the data in the field is an Thumbnail source (byte array or Thumbnail object). Unlike Url, when you set a thumbnail url no effects will be applied. This prevents accidental thumbnail downloading.

Example

Set the Url for the Thumbnail Image:

[C#]
 ImageField imField = new ImageField();
Grid1.Fields.Add(imField);
imField.ThumbnailUrl = "http://www.mydomain.com/thumbnailImage.jpg";

Applies to

ImageField

See Also

ImageField Class | ImageField Members


Url property of class

ImageField.Url Property

Gets or sets the format string for the url of the full size original image.

[Visual Basic]
Public Property Url As String[C#]
public String Url {get;set;}

Remarks

  • This will be ignored if the data in the field is an image source (byte array or Image object). If the data type is IConvertible, this should be used to format the url.

  • If the data value is itself a url, you don't have to set this. If you apply any effects to the image in Format.FullSize, the image bytes will be downloaded by the grid, so if the URL points to a remote location, we strongly advice you don't apply any effects.

Example

Set the Url where the Image is located:

[C#]
 ImageField imField = new ImageField();
Grid1.Fields.Add(imField);
imField.Url = "http://www.mydomain.com/image.jpg";

Applies to

ImageField

See Also

ImageField Class | ImageField Members


VerifyUrlExists property of class

ImageField.VerifyUrlExists Property

Gets or sets a value indicating if the grid checks each image url to ensure the image exists or not, which lets the field display a nice "no image found" image rather than the default browser red 'X'.

[Visual Basic]
Public Property VerifyUrlExists As Boolean[C#]
public Boolean VerifyUrlExists {get;set;}

Remarks

  • This is only relevant when using url-based images and thumbnails and borders are not used. The grid will try and use the file system if possible; otherwise it uses a web request.

  • Web requests can severely slow down the system and therefore it's not recommended to set this to true when using URLs that are not from the file system.

Example

Verify if given URL is valid:

[C#]
 ImageField imField = new ImageField();
Grid1.Fields.Add(imField);
imField.VerifyUrlExists = true;

Applies to

ImageField

See Also

ImageField Class | ImageField Members


ItemHeader class

Description goes here

For a list of all members of this type, see ItemHeader Members

GridFX.WebForms.ItemHeader

Remarks

Description goes here


ItemHeader Class Members

ItemHeader Members

ItemHeader Overview

Public Properties

public property Style | Description goes here
public property Visible | Description goes here


Style property of class

ItemHeader.Style Property

Description goes here

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Applies to

ItemHeader

See Also

ItemHeader Class | ItemHeader Members


Visible property of class

ItemHeader.Visible Property

Description goes here

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Applies to

ItemHeader

See Also

ItemHeader Class | ItemHeader Members


LayoutCell class

Provides access to the appearance of the grid cell.

For a list of all members of this type, see LayoutCell Members

GridFX.WebForms.LayoutCell

Remarks

Allows to set the properties for a grid field multicell column which can be used to improve the layout of the grid.


LayoutCell Class Members

LayoutCell Members

LayoutCell Overview

Public Properties

public property ColumnSpan | Gets or sets the number of columns that a grid field cell will span.
public property RowSpan | Gets or sets the number of rows a grid field cell will span.
public property Visible | Gets or sets the visible property which allows the cell to be displayed or hidden.


LookupDataSourceInfo class

Provides access to the LookupDataSourceInfo Class.

For a list of all members of this type, see LookupDataSourceInfo Members

GridFX.WebForms.LookupDataSourceInfo

Remarks

The LookupDataSourceInfo Class contains settings used to lookup data for a LookupField on a secondary DataSource.


LookupDataSourceInfo Class Members

LookupDataSourceInfo Members

LookupDataSourceInfo Overview

Public Properties

public property Caching | Gets or sets a value indicating the cache setting used by a LookupField.
public property ControlID | Gets or sets the ID of the secondary data source in which the LookupField retrieves its list of values.
public property TextDataPath | Gets or sets the name of the field on the secondary data source used to display the values within a LookupField.
public property ValueDataPath | Gets or sets the name of the field in the secondary data source that is linked to values on the grid's main data source.


Caching property of class

LookupDataSourceInfo.Caching Property

Gets or sets a value indicating the cache setting used by a LookupField.

[Visual Basic]
Public Property Caching As LookupDataCaching[C#]
public LookupDataCaching Caching {get;set;}

Property Value

The default is PageLife.

Value | Meaning
None | Description goes here
PageLife | Description goes here
WebCache | Description goes here

Remarks

  • When the Caching property is set to PageLife, the lookup data is retrieved once for each page hit. This is very useful when the data changes frequently.

  • If the data is static, then the recommended setting is WebCache.

Example

Set the cache setting of the LookupField to PageLife:

[C#]
 LookupField lookField = new LookupField();
lookField.LookupDataSource.Caching = LookupDataCaching.PageLife;

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.LookupDataSource.Caching = GridFX.WebForms.LookupDataCaching.PageLife

Applies to

LookupDataSourceInfo

See Also

LookupDataSourceInfo Class | LookupDataSourceInfo Members


ControlID property of class

LookupDataSourceInfo.ControlID Property

Gets or sets the ID of the secondary data source in which the LookupField retrieves its list of values.

[Visual Basic]
Public Property ControlID As String[C#]
public String ControlID {get;set;}

Example

Set the ControlID for a LookupField:

[C#]
 LookupField lookField = new LookupField();
lookField.LookupDataSource.ControlID = "AccessDataSource2";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.LookupDataSource.ControlID = "AccessDataSource2"

Applies to

LookupDataSourceInfo

See Also

LookupDataSourceInfo Class | LookupDataSourceInfo Members


TextDataPath property of class

LookupDataSourceInfo.TextDataPath Property

Gets or sets the name of the field on the secondary data source used to display the values within a LookupField.

[Visual Basic]
Public Property TextDataPath As String[C#]
public String TextDataPath {get;set;}

Remarks

  • The TextDataPath property will show the values that have matching lookup data.

  • The lookup data for a LookupField is the field on the secondary data source that is associated to a field on the grid's main data source.

Example

Show the Sales field that has matching dates between the grid's main data source and the secondary one:

              [C#]
LookupField lookField = new LookupField();
lookField.DataPath = "Date";
lookField.LookupDataSource.ControlID = "AccessDataSource2";
lookField.LookupDataSource.ValueDataPath = "Date";
lookField.LookupDataSource.TextDataPath = "Sales";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.DataPath = "Date"
lookField.LookupDataSource.ControlID = "AccessDataSource2"
lookField.LookupDataSource.ValueDataPath = "Date"
lookField.LookupDataSource.TextDataPath = "Sales"

Applies to

LookupDataSourceInfo

See Also

LookupDataSourceInfo Class | LookupDataSourceInfo Members


ValueDataPath property of class

LookupDataSourceInfo.ValueDataPath Property

Gets or sets the name of the field in the secondary data source that is linked to values on the grid's main data source.

[Visual Basic]
Public Property ValueDataPath As String[C#]
public String ValueDataPath {get;set;}

Remarks

  • The ValueDataPath property takes on the field name in the secondary data source which is linked to an existing field of the same type, on the grid's main data source.

  • The DataPath property of the LookupField is used to set the field located on the main data source.

    • Grid FX

Example

Set the ValueDataPath for a LookupField:

[C#]
 LookupField lookField = new LookupField();
lookField.DataPath = "Date";
lookField.LookupDataSource.ControlID = "AccessDataSource2";
lookField.LookupDataSource.ValueDataPath = "Date";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.DataPath = "Date"
lookField.LookupDataSource.ControlID = "AccessDataSource2"
lookField.LookupDataSource.ValueDataPath = "Date"

Applies to

LookupDataSourceInfo

See Also

LookupDataSourceInfo Class | LookupDataSourceInfo Members


LookupField class

Provides access to the LookupField Class.

For a list of all members of this type, see LookupField Members

GridFX.WebForms.DataField
GridFX.WebForms.LookupField

Remarks

Allows the user to modify and display more meaningful values. LookupFields are particularly useful, especially if the user needs to look up data on a DataSource other than the one already bound to the Grid.

For example, the user will set the DataPath of the LookupField to a field within the main DataSource. The ValueDataPath of the LookupField will be attached to a field on a separate DataSource that has a relationship to the primary DataSource; then, by setting the TextDataPath to a field that belongs to the secondary DataSource, the Grid will display within the LookupField all the values that match both the DataPath and the ValueDataPath, respectively.


LookupField Class Members

LookupField Members

LookupField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Allows the user to get or set a Custom Format for a LookupField.
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property Input | Allows the user to determine if the input for a LookupField is required.
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property LookupDataSource | Allows the user to get or set a value that represents that DataSource being looked at by the LookupField.
public property LookupItems | Allows the user to create a collection of LookupItems that are used within a LookupField.
public property MissingValueText | Allows the user to get or set a text string that is shown to the user when a data value has no corresponding Lookup Value.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Format property of class

LookupField.Format Property

Allows the user to get or set a Custom Format for a LookupField.

[Visual Basic]
Public Property Format As FieldValueFormatter[C#]
public FieldValueFormatter Format {get;set;}

Remarks

  • The Format Property for a LookupField is type independent. It will take on the Formatter Type of the value being looked up.

  • If the ValueDataPath of the LookField.LookupDataSource points to a Field of Text, then the TextFormatter will be assigned to the Format Property.

Example

Set the Formatter Type for a LookupField that is of type NumberField:

[C#]
 LookupField lookField = new LookupField();
lookField.LookupDataSource.ControlID ="AccessDataSource1";
lookField.LookupDataSource.TextDataPath = "SampleFinancial2";
lookField.LookupDataSource.ValueDataPath = "Closed";

NumberFormatter numFormat = new NumberFormatter();
numFormat.ValueFormat = NumericValueFormat.Percentage;
lookField.Format = numFormat;

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.LookupDataSource.ControlID = "AccessDataSource1"
lookField.LookupDataSource.TextDataPath = "SampleFinancial2"
lookField.LookupDataSource.ValueDataPath = "Closed"
Dim numFormat As GridFX.WebForms.NumberFormatter
numFormat = New GridFX.WebForms.NumberFormatter
numFormat.ValueFormat = GridFX.WebForms.NumericValueFormat.Percentage
lookField.Format = numFormat

Applies to

LookupField

See Also

LookupField Class | LookupField Members


Input property of class

LookupField.Input Property

Allows the user to determine if the input for a LookupField is required.

[Visual Basic]
Public ReadOnly Property Input As LookupFieldInputSettings[C#]
public LookupFieldInputSettings Input {get;}

Remarks

  • If the Input Property is required, then the user can set the NullOptionText to display a message within the LookupField advising the user that input for this field is required.

  • The user can also set the ControlType Attribute of the Input Property to show a DropDown Box, a ListBox, or a RadioButtonList within the LookupField.

Example

Require Input for this LookupField and display error message if not set:

[C#]
 LookupField lookField = new LookupField();
lookField.Input.AllowNullInput = false;
lookField.Input.NullOptionText = "Input is required";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.Input.AllowNullInput = false
lookField.Input.NullOptionText = "Input is required"

Applies to

LookupField

See Also

LookupField Class | LookupField Members | LookupFieldInputSettings Class


LookupDataSource property of class

LookupField.LookupDataSource Property

Allows the user to get or set a value that represents that DataSource being looked at by the LookupField.

[Visual Basic]
Public ReadOnly Property LookupDataSource As LookupDataSourceInfo[C#]
public LookupDataSourceInfo LookupDataSource {get;}

Remarks

  • The user can set the DataSource already bound to the Grid or a different DataSource that belongs to the Grid Project.

  • The DataPath Property of the LookupField needs to be set to a field on the primary DataSource, then the ValueDataPath and TextDataPath of the LookupDataSource Property will contain the field being looked up on the secondary DataSource, and the field that will be displayed within the LookupField.

Example

Setting the ControlID for a LookupField:

[C#]
 LookupField lookField = new LookupField();
lookField.DataPath = "Date";
lookField.LookupDataSource.ControlID = "DataSource1";
lookField.LookupDataSource.TextDataPath = "Temperature";
lookField.LookupDataSource.ValueDataPath = "Date";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.DataPath = "Date"
lookField.LookupDataSource.ControlID = "DataSource1"
lookField.LookupDataSource.TextDataPath = "Temperature"
lookField.LookupDataSource.ValueDataPath = "Date"

Applies to

LookupField

See Also

LookupField Class | LookupField Members | LookupDataSourceInfo Class


LookupItems property of class

LookupField.LookupItems Property

Allows the user to create a collection of LookupItems that are used within a LookupField.

[Visual Basic]
Public ReadOnly Property LookupItems As LookupItemCollection[C#]
public LookupItemCollection LookupItems {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Remarks

  • The LookupItems Property should be used when the Lookup Values hardly ever change.

  • If the LookupItems Property is set, then the Grid will ignore the TextDataPath and ValueDataPath of the LookupDataSource Property.

Example

Create a LookItem and add it to the LookupItems Collection of a LookupField:

              [C#]
LookupField lookField = new LookupField();

LookupItem lookItem = new LookupItem();
        lookItem.Text = "Item 1";
lookItem.Value = "100";

lookField.LookupItems.Add(lookItem);

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
Dim lookItem As GridFX.WebForms.LookupItem
lookItem = New GridFX.WebForms.LookupItem
lookItem.Text = "Item 1"
lookItem.Value = "100"
lookField.LookupItems.Add(lookItem)

Applies to

LookupField

See Also

LookupField Class | LookupField Members


MissingValueText property of class

LookupField.MissingValueText Property

Allows the user to get or set a text string that is shown to the user when a data value has no corresponding Lookup Value.

[Visual Basic]
Public Property MissingValueText As String[C#]
public String MissingValueText {get;set;}

Example

Set MissingValueText of a LookupField:

[C#]
 LookupField lookField = new LookupField();
lookField.MissingValueText = "LookupField data not available";

[Visual Basic]
 Dim lookField As GridFX.WebForms.LookupField
lookField = New GridFX.WebForms.LookupField
lookField.MissingValueText = "LookupField data not available"

Applies to

LookupField

See Also

LookupField Class | LookupField Members


LookupFieldInputSettings class

Provides access to the LookupFieldInputSettings Class.

For a list of all members of this type, see LookupFieldInputSettings Members

GridFX.WebForms.LookupFieldInputSettings

Remarks

The LookupFieldInputSettings provides formatting options for input controls within a LookupField.


LookupFieldInputSettings Class Members

LookupFieldInputSettings Members

LookupFieldInputSettings Overview

Public Properties

public property AllowNullInput | Gets or sets a value indicating whether null values are allowed in input.
public property ControlType | Gets or sets the input ControlType used by a LookupField.
public property NullOptionText | Gets or sets a text string that is displayed when null values are not allowed.


AllowNullInput property of class

LookupFieldInputSettings.AllowNullInput Property

Gets or sets a value indicating whether null values are allowed in input.

[Visual Basic]
Public Property AllowNullInput As Boolean[C#]
public Boolean AllowNullInput {get;set;}

Remarks

  • When this property is set to true, null values in the LookupField are allowed.

Example

Not allowing null values in a LookupField:

[C#]
 LookupField lookField = (LookupField)Grid1.Fields[1];
lookField.Input.AllowNullInput = false;

Applies to

LookupFieldInputSettings

See Also

LookupFieldInputSettings Class | LookupFieldInputSettings Members


ControlType property of class

LookupFieldInputSettings.ControlType Property

Gets or sets the input ControlType used by a LookupField.

[Visual Basic]
Public Property ControlType As LookupFieldControlType[C#]
public LookupFieldControlType ControlType {get;set;}

Value | Meaning
DropDown | Description goes here
ListBox | Description goes here
RadioButtonList | Description goes here

Example

Set input ControlType to RadioButtonList:

[C#]
 LookupField lookField = (LookupField)Grid1.Fields[1];
lookField.Input.ControlType = LookupFieldControlType.RadioButtonList;

Applies to

LookupFieldInputSettings

See Also

LookupFieldInputSettings Class | LookupFieldInputSettings Members


NullOptionText property of class

LookupFieldInputSettings.NullOptionText Property

Gets or sets a text string that is displayed when null values are not allowed.

[Visual Basic]
Public Property NullOptionText As String[C#]
public String NullOptionText {get;set;}

Example

Display message if null values not allowed:

[C#]
 LookupField lookField = (LookupField)Grid1.Fields[1];
lookField.Input.AllowNullInput = false;
lookField.Input.NullOptionText = "Null values are not allowed";

Applies to

LookupFieldInputSettings

See Also

LookupFieldInputSettings Class | LookupFieldInputSettings Members


LookupItem class

Provides access to the LookupItem Class.

For a list of all members of this type, see LookupItem Members

GridFX.WebForms.LookupItem

Remarks

The LookupItem Class allows to manually add or change values within a LookupField.


LookupItem Class Members

LookupItem Members

LookupItem Overview

Public Properties

public property Text | Gets or sets a value that will be added to a LookupField.
public property Value | Gets or sets a value that is used by the LookupItem to update data within a LookupField.


Text property of class

LookupItem.Text Property

Gets or sets a value that will be added to a LookupField.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • If the LookupField already contains a value, then such value is changed with the value provided by the LookupItem.

Example

Changing an existing value in a LookupField:

[C#]
 LookupField lookField = (LookupField)Grid1.Fields[1];
lookField.DataPath = "Date";
lookField.LookupDataSource.TextDataPath = "Field3";
lookField.LookupDataSource.ValueDataPath = "Date";

LookupItem lookItem = new LookupItem();
lookItem.Value = "4/3/2001";
lookItem.Text = "193.74";

lookField.LookupItems.Add(lookItem);

Applies to

LookupItem

See Also

LookupItem Class | LookupItem Members


Value property of class

LookupItem.Value Property

Gets or sets a value that is used by the LookupItem to update data within a LookupField.

[Visual Basic]
Public Property Value As String[C#]
public String Value {get;set;}

Remarks

  • If the value of the LookupItem does not exist in the LookupField's DataPath, then no data will be updated for that LookupField.

Example

Set the value of a LookupItem:

[C#]
 LookupItem lookItem = new LookupItem();
lookItem.Value = "4/3/2001";

[Visual Basic]
 Dim lookItem As GridFX.WebForms.LookupItem
lookItem = New GridFX.WebForms.LookupItem
lookItem.Value = "4/3/2001"

Applies to

LookupItem

See Also

LookupItem Class | LookupItem Members


MonthInterval class

Provides access to the MonthInterval object.

For a list of all members of this type, see MonthInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.MonthInterval

Remarks

This class is used to group records by months.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


MonthInterval Class Members

MonthInterval Members

MonthInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Start (inherited from DateTimeIncrementInterval) | Gets or sets the start for the group.
public property StartSource (inherited from DateTimeIncrementInterval) | Gets or sets how the groups will start.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.


MultiCellColumn class

Defines a column within the grid's body. Columns span any headers, items, and footers.

For a list of all members of this type, see MultiCellColumn Members

GridFX.WebForms.GridColumn
GridFX.WebForms.MultiCellColumn

Remarks

A column is the primary division in the grid's body. Within each column are Cells, which determine the column's contents for headers, items, and footers. A column is nothing without at least one object in Cells. The number of columns in Grid.Columns will not necessarily match the number of columns shown in the grid's output. Outer bars, row header, expandable area, and tiling can all add more columns to the output table.


MultiCellColumn Class Members

MultiCellColumn Members

MultiCellColumn Overview

Public Properties

public property Cells | Gets access to the ColumnCellCollection class which allows cells to be added to the MultiCellColumn.
public property Visible | Gets or sets the visible property which allows the MultiCellColumn to be displayed or hidden.
public property Width (inherited from GridColumn) | Gets or sets a value determining the column width in pixels.


Cells property of class

MultiCellColumn.Cells Property

Gets access to the ColumnCellCollection class which allows cells to be added to the MultiCellColumn.

[Visual Basic]
Public ReadOnly Property Cells As ColumnCellCollection[C#]
public ColumnCellCollection Cells {get;}

Parameters

Parameter | Type | Meaning
index | Int32 | Description goes here

Remarks

  • A MultiCellColumn is defined as a column in the Grid. Any of the following ColumnCells: FieldCell, TemplateCell, EmptyCell can be added within a MultiCellColumn.

Example

To add a FieldCell to a MultiCellColumn:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
mc.Cells.Add(cell);

Applies to

MultiCellColumn

See Also

MultiCellColumn Class | MultiCellColumn Members | ColumnCellCollection Class Class


Visible property of class

MultiCellColumn.Visible Property

Gets or sets the visible property which allows the MultiCellColumn to be displayed or hidden.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • By setting the visible property to false, the MultiCellColumn will be hidden as shown below:

    [C#]
     GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
    grid1.Columns.Add(mc);
    GridFX.WebForms.FieldCell cell = new FieldCell();
    cell.Field = grid1.Fields["DateField"];
    mc.Cells.Add(cell);
    mc.Visible = false;

Example

To set the visible property of the MultiCellColumn to false:

[C#]
 GridFX.WebForms.MultiCellColumn mc = new MultiCellColumn();
grid1.Columns.Add(mc);
GridFX.WebForms.FieldCell cell = new FieldCell();
cell.Field = grid1.Fields["DateField"];
mc.Cells.Add(cell);
mc.Visible = false;

Applies to

MultiCellColumn

See Also

MultiCellColumn Class | MultiCellColumn Members


NumberField class

The NumberField Class allows a user to customize settings for a particular NumberField on the Grid.

For a list of all members of this type, see NumberField Members

GridFX.WebForms.DataField
GridFX.WebForms.NumberField

Remarks

The user can set a particular Format to display the data, as well as the input requirements for such Field. You can also set the Min and Max for a specific NumberField. This class can be particularly useful when using Gauges to display the data values.


NumberField Class Members

NumberField Members

NumberField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Allows the user to format the data passed to a NumberField.
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property Input | Allows the user to determine if the input for a NumberField is required.
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property Max | Allows the user to set the maximum value for the scale of the Gauge control when the Display format is set to Gauge.
public property Min | Allows the user to set the minimum value for the scale of the Gauge control when the Display format is set to Gauge.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Format property of class

NumberField.Format Property

Allows the user to format the data passed to a NumberField.

[Visual Basic]
Public ReadOnly Property Format As NumberFormatter[C#]
public NumberFormatter Format {get;}

Remarks

  • This property can be used to format the way the numeric data is shown on the grid. For details on the formatting option please refer to the NumberFormatter Class.

Example

Setting the ValueFormat of an existing NumberField:

[Visual Basic]
 Dim numField As NumberField = Grid1.Fields(1)
numField.Format.ValueFormat = NumericValueFormat.Currency
numField.Format.Decimals = 2

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Format.ValueFormat = NumericValueFormat.Currency;
numField.Format.Decimals = 2;

Applies to

NumberField

See Also

NumberField Class | NumberField Members | Property | NumberFomatter Class


Input property of class

NumberField.Input Property

Allows the user to determine if the input for a NumberField is required.

[Visual Basic]
Public ReadOnly Property Input As NumberFieldInputSettings[C#]
public NumberFieldInputSettings Input {get;}

Example

Set the input of an existing NumberField to be required and show Error Message, if needed:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Input.Required = NumericFieldRequiredInput.Always;
numField.Input.RequiredErrorMessage = "Data must be provided for this Field";

Applies to

NumberField

See Also

NumberField Class | NumberField Members | Property | NumberFieldInputSettings Class


Max property of class

NumberField.Max Property

Allows the user to set the maximum value for the scale of the Gauge control when the Display format is set to Gauge.

[Visual Basic]
Public Property Max As Number[C#]
public Number Max {get;set;}

Remarks

  • The Max Property can be applied only to a NumberField, and will only have an effect when displaying the data using Gauge controls.

  • In order for the Max setting to show on the Gauge, it is required that you set the Min value also.

  • Setting the Max property will force the Gauge's scale to the specified number. When using horizontal, vertical or radial gauge, the marker or needle will be restricted to that range. Therefore, any values greater than the max setting will be shown as the Maximum number.

  • If no Max is specified, GridFX will automatically set a maximum value according to the data provided; you can use this property to read or write this default value.

Example

Setting the Max value of a FieldColumn:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Max = 500;

Applies to

NumberField

See Also

NumberField Class | NumberField Members


Min property of class

NumberField.Min Property

Allows the user to set the minimum value for the scale of the Gauge control when the Display format is set to Gauge.

[Visual Basic]
Public Property Min As Number[C#]
public Number Min {get;set;}

Remarks

  • The Min Property can be applied only to a NumberField, and will only have an effect when displaying the data using Gauge controls.

  • In order for the Min setting to show on the Gauge, it is required that you set the Max value also.

  • Setting the Min property will force the Gauge's scale to the specified number. When using horizontal, vertical or radial gauge, the marker or needle will be restricted to that range. Therefore, any values greater than the min setting will be shown as the Minimum number.

  • If no Min is specified, GridFX will automatically set a minimum value according to the data provided; you can use this property to read or write this default value.

Example

Setting the Min value of a FieldColumn:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1]; numField.Min = 100;

Applies to

NumberField

See Also

NumberField Class | NumberField Members


NumberFieldInputSettings class

Provides access to the NumberFieldInputSettings Class.

For a list of all members of this type, see NumberFieldInputSettings Members

GridFX.WebForms.NumberFieldInputSettings

Remarks

These are settings for input controls given to the user. The members of the NumberFieldInputSettings Class allow the user to make the input of a NumberField to be required, allow negative values within the Field, as well as showing an error message if no data is passed to such Field.


NumberFieldInputSettings Class Members

NumberFieldInputSettings Members

NumberFieldInputSettings Overview

Public Properties

public property AllowNegativeValues | Allows the user to set a boolean value that determines if a NumberField can receive negative values.
public property Required | Allows the user to check is data for a NumberField is always required.
public property RequiredErrorMessage | Allows the user to set an error message for a required NumberField.


AllowNegativeValues property of class

NumberFieldInputSettings.AllowNegativeValues Property

Allows the user to set a boolean value that determines if a NumberField can receive negative values.

[Visual Basic]
Public Property AllowNegativeValues As Boolean[C#]
public Boolean AllowNegativeValues {get;set;}

Example

Set a NumberField to not allow negative values:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
  numField.Title = "Age";
numField.Input.AllowNegativeValues = false;

Applies to

NumberFieldInputSettings

See Also

NumberFieldInputSettings Class | NumberFieldInputSettings Members


Required property of class

NumberFieldInputSettings.Required Property

Allows the user to check is data for a NumberField is always required.

[Visual Basic]
Public Property Required As NumberFieldRequiredInput[C#]
public NumberFieldRequiredInput Required {get;set;}

Property Value

The default is Never.

Value | Meaning
Always | Description goes here
AlwaysExceptNull | Description goes here
AlwaysExceptNullOrMin | Description goes here
Never | Description goes here

Example

Set NumberField to always require data:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
  numField.Title = "Hourly Rate";
numField.Input.Required = NumericFieldRequiredInput.Always;

Applies to

NumberFieldInputSettings

See Also

NumberFieldInputSettings Class | NumberFieldInputSettings Members


RequiredErrorMessage property of class

NumberFieldInputSettings.RequiredErrorMessage Property

Allows the user to set an error message for a required NumberField.

[Visual Basic]
Public Property RequiredErrorMessage As String[C#]
public String RequiredErrorMessage {get;set;}

Remarks

  • The RequiredErrorMessage Property will only work is the Required Property is set to True.

Example

Show an Error Message is no data is available:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Rate";
numField.Input.RequiredErrorMessage = "Data must be provided for this FieldColumn";

Applies to

NumberFieldInputSettings

See Also

NumberFieldInputSettings Class | NumberFieldInputSettings Members | Property


NumberFormatter class

The NumberFormatter Class allows the user to format a particular NumberField on the Grid.

For a list of all members of this type, see NumberFormatter Members

GridFX.WebForms.FieldValueFormatter
GridFX.WebForms.NumberFormatter

Remarks

The user can format a NumberField by changing different properties exposed to such field; these properties range from setting the decimal place for a data value, displaying a Gauge Control to show the data, setting a CustomFormat for the value, as well as setting a ValueFormat for displaying such data values.


NumberFormatter Class Members

NumberFormatter Members

NumberFormatter Overview

Public Properties

public property CustomFormat | Allows the user to get or set a custom format for a selected NumberField.
public property Decimals | Allows the user to get or set how many digits after the decimal point will be shown in a NumberField.
public property Display | Allows the user to set the type of display to be shown for a particular NumberField. This can be either Text (Default) or Gauge.
public property Gauge | Allows the user to have access to all of the properties that pertain to the Gauge Component.
public property NullText | Allows the user to set a pre-defined message to show on a particular NumberField whenever a data value is null.
public property TreatMinAsNull | Allows the user to treat the minimum value for a NumberField as if it was a Null value.
public property ValueFormat | Allows the user to set a NumericValueFormat to a NumberField.


CustomFormat property of class

NumberFormatter.CustomFormat Property

Allows the user to get or set a custom format for a selected NumberField.

[Visual Basic]
Public Property CustomFormat As String[C#]
public String CustomFormat {get;set;}

Remarks

  • A custom .NET Number Format string that is applied to data values. In order for CustomFormat to be used, ValueFormat must be set to Custom.

  • When CustomFormat is used, the Decimals property is ignored.

Example

Set an expression separator for a NumberField:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Hourly Rate";

NumberFormatter numFormat = numField.Format;
numFormat.CustomFormat = "$#,##0;($#,##0)";
numFormat.ValueFormat = NumericValueFormat.Custom;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


Decimals property of class

NumberFormatter.Decimals Property

Allows the user to get or set how many digits after the decimal point will be shown in a NumberField.

[Visual Basic]
Public Property Decimals As Int32[C#]
public Int32 Decimals {get;set;}

Example

Set the NumberField to two decimal points:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Hourly Rate";

NumberFormatter numFormat = numField.Format;
numFormat.Decimals = 2;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


Display property of class

NumberFormatter.Display Property

Allows the user to set the type of display to be shown for a particular NumberField. This can be either Text (Default) or Gauge.

[Visual Basic]
Public Property Display As NumberDisplayType[C#]
public NumberDisplayType Display {get;set;}

Property Value

The default is Text.

Value | Meaning
Text | Description goes here
Gauge | Description goes here

Example

Set the display to a Gauge Control:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Temperature";

NumberFormatter numFormat = numField.Format;
numFormat.Display = NumberDisplayType.Gauge;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


Gauge property of class

NumberFormatter.Gauge Property

Allows the user to have access to all of the properties that pertain to the Gauge Component.

[Visual Basic]
Public Property Gauge As BaseGauge[C#]
public BaseGauge Gauge {get;set;}

Remarks

  • A ChartFX Gauges License is needed when trying to implement a Gauge Property through the API; with the GridFX License, however, the user has access only to the Gauge Properties exposed to the Property Grid at Design-Time.

  • In order for the gauges to show, it is required to set the Display property to Gauge.

Example

Set the Gauge BackColor:

[C#]
 NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Temperature";

NumberFormatter numFormat = numField.Format;
numFormat.Gauge.BackColor = Color.OrangeRed;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


NullText property of class

NumberFormatter.NullText Property

Allows the user to set a pre-defined message to show on a particular NumberField whenever a data value is null.

[Visual Basic]
Public Property NullText As String[C#]
public String NullText {get;set;}

Example

Show "Not Available" when data is null:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Hourly Rate";

NumberFormatter numFormat = numField.Format;
numFormat.Decimals = 2;
numFormat.NullText = "Data Not Available";

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


TreatMinAsNull property of class

NumberFormatter.TreatMinAsNull Property

Allows the user to treat the minimum value for a NumberField as if it was a Null value.

[Visual Basic]
Public Property TreatMinAsNull As Boolean[C#]
public Boolean TreatMinAsNull {get;set;}

Example

Disabling minimum value to be treated as Null:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Temperature";

NumberFormatter numFormat = numField.Format;
numFormat.TreatMinAsNull = false;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


ValueFormat property of class

NumberFormatter.ValueFormat Property

Allows the user to set a NumericValueFormat to a NumberField.

[Visual Basic]
Public Property ValueFormat As NumericValueFormat[C#]
public NumericValueFormat ValueFormat {get;set;}

Property Value

The default is FixedPoint.

Value | Meaning
Default | Description goes here
Currency | Description goes here
Percentage | Description goes here
Scientific | Description goes here
Custom | Description goes here
Number | Description goes here
FixedPoint | Description goes here
General | Description goes here

Example

Set the NumberField to Currency:

              [C#]
NumberField numField = (NumberField)Grid1.Fields[1];
numField.Title = "Hourly Rate";

NumberFormatter numFormat = numField.Format;
numFormat.Decimals = 2;
numFormat.ValueFormat = NumericValueFormat.Currency;

Applies to

NumberFormatter

See Also

NumberFormatter Class | NumberFormatter Members


NumberRange class

Provides access to the NumberRange object.

For a list of all members of this type, see NumberRange Members

GridFX.WebForms.NumberRange

Remarks

This class is to be used along with the NumberRangesInterval class in order to provide variable range grouping. The Ranges are defined by adding NumberRange objects to the Ranges Collection of the NumberRangesInterval object.


NumberRange Class Members

NumberRange Members

NumberRange Overview

Public Properties

public property IncludeFieldTitleInTitle | Gets or sets whether the field name will be used in the range's title.
public property IncludeItemCountInTitle | Gets or sets whether the item count will be used in the range's title.
public property LowerBound | Gets or sets the start value for the range.
public property SplitLength | Gets or sets the range's grouping length.
public property Title | Gets or sets the title for the range.


IncludeFieldTitleInTitle property of class

NumberRange.IncludeFieldTitleInTitle Property

Gets or sets whether the field name will be used in the range's title.

[Visual Basic]
Public Property IncludeFieldTitleInTitle As Boolean[C#]
public Boolean IncludeFieldTitleInTitle {get;set;}

Example

To sets the field name in the range's title:

[C#]
 NumberRange nr0 = new NumberRange();
nr0.IncludeFieldTitleInTitle = true;

[Visual Basic]
 Dim nr0 As GridFX.WebForms.NumberRange
nr0 = New GridFX.WebForms.NumberRange
nr0.IncludeFieldTitleInTitle = true

Applies to

NumberRange

See Also

NumberRange Class | NumberRange Members


IncludeItemCountInTitle property of class

NumberRange.IncludeItemCountInTitle Property

Gets or sets whether the item count will be used in the range's title.

[Visual Basic]
Public Property IncludeItemCountInTitle As Boolean[C#]
public Boolean IncludeItemCountInTitle {get;set;}

Example

To prevent the item count from displaying in the range's title:

[C#]
 NumberRange nr1 = new NumberRange();
nr1.IncludeItemCountInTitle = false;

[Visual Basic]
 Dim nr1 As GridFX.WebForms.NumberRange
nr1 = New GridFX.WebForms.NumberRange
nr1.IncludeItemCountInTitle = false

Applies to

NumberRange

See Also

NumberRange Class | NumberRange Members


LowerBound property of class

NumberRange.LowerBound Property

Gets or sets the start value for the range.

[Visual Basic]
Public Property LowerBound As Number[C#]
public Number LowerBound {get;set;}

Remarks

  • The range will end at the beginning of the next range, or if there is no next range, it will contain all values greater than LowerBound.

Example

To set the lower bound:

[C#]
 NumberRange nr0 = new NumberRange();
nr0.LowerBound = 1000;

[Visual Basic]
 Dim nr0 As GridFX.WebForms.NumberRange
nr0 = New GridFX.WebForms.NumberRange
nr0.LowerBound = 1000

Applies to

NumberRange

See Also

NumberRange Class | NumberRange Members


SplitLength property of class

NumberRange.SplitLength Property

Gets or sets the range's grouping length.

[Visual Basic]
Public Property SplitLength As Number[C#]
public Number SplitLength {get;set;}

Example

To set the split length to a specific value:

[C#]
 NumberRange nr0 = new NumberRange();
nr0.SplitLength = 1000;

[Visual Basic]
 Dim nr0 As GridFX.WebForms.NumberRange
nr0 = New GridFX.WebForms.NumberRange
nr0.SplitLength = 1000

Applies to

NumberRange

See Also

NumberRange Class | NumberRange Members


Title property of class

NumberRange.Title Property

Gets or sets the title for the range.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

  • By default, the title set with this property is shown in conjunction with the Field Title and the Item Count. You can disable the Field Title and the Item Count. See IncludeItemCountInTitle and IncludeFieldTitleInTitle.

Example

To set a title to a range:

[C#]
 NumberRange nr0 = new NumberRange();
nr0.Title = "Range #1";

[Visual Basic]
 Dim nr0 As GridFX.WebForms.NumberRange
nr0 = New GridFX.WebForms.NumberRange
nr0.Title = "Range #1"

Applies to

NumberRange

See Also

NumberRange Class | NumberRange Members


NumberRangesInterval class

Provides access to the NumberRangesInterval object.

For a list of all members of this type, see NumberRangesInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.NumberRangesInterval

Remarks

This class is to be used whenever a variable range grouping is desired.


NumberRangesInterval Class Members

NumberRangesInterval Members

NumberRangesInterval Overview

Public Properties

public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property HighestRangeTitle | Gets or sets the title for the group with the highest range.
public property IncludeFieldTitleInTitle | Gets or sets the field name in the groups' title.
public property IncludeItemCountInTitle | Gets or sets the item count in the groups' title.
public property LowestRangeTitle | Gets or sets the title for the group with the lowest range.
public property NullTitle | Gets or sets the title of the null values group.
public property NullTreatment | Gets or sets how null values will be treated.
public property Ranges | Gets the ranges to be used by the NumberRangesInterval.
public property Title | Gets or sets the groups' title.


HighestRangeTitle property of class

NumberRangesInterval.HighestRangeTitle Property

Gets or sets the title for the group with the highest range.

[Visual Basic]
Public Property HighestRangeTitle As String[C#]
public String HighestRangeTitle {get;set;}

Example

To set the highest range title:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.HighestRangeTitle = "Under {UpperBound}";
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
nri.HighestRangeTitle = "Under {UpperBound}"
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


IncludeFieldTitleInTitle property of class

NumberRangesInterval.IncludeFieldTitleInTitle Property

Gets or sets the field name in the groups' title.

[Visual Basic]
Public Property IncludeFieldTitleInTitle As Boolean[C#]
public Boolean IncludeFieldTitleInTitle {get;set;}

Remarks

  • By default, this property is set to true and therefore the field name will be part of the title of the group.

Example

To prevent the field name from showing in the groups' title:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.IncludeFieldTitleInTitle = false;
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
nri.IncludeFieldTitleInTitle = false
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


IncludeItemCountInTitle property of class

NumberRangesInterval.IncludeItemCountInTitle Property

Gets or sets the item count in the groups' title.

[Visual Basic]
Public Property IncludeItemCountInTitle As Boolean[C#]
public Boolean IncludeItemCountInTitle {get;set;}

Remarks

  • The item count is the number of records that fall under a group. This property offers the option to display or not display the item count in the group title. By default this property is set to True.

Example

To prevent the item count from displaying in the group title:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.IncludeItemCountInTitle = false;
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
nri.IncludeItemCountInTitle = false
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


LowestRangeTitle property of class

NumberRangesInterval.LowestRangeTitle Property

Gets or sets the title for the group with the lowest range.

[Visual Basic]
Public Property LowestRangeTitle As String[C#]
public String LowestRangeTitle {get;set;}

Example

To set the lowest range title:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.LowestRangeTitle = "Under {UpperBound}";
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
nri.LowestRangeTitle = "Under {UpperBound}"
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


NullTitle property of class

NumberRangesInterval.NullTitle Property

Gets or sets the title of the null values group.

[Visual Basic]
Public Property NullTitle As String[C#]
public String NullTitle {get;set;}

Remarks

  • This property is used when the NullTreatment is set to CreateNullGroup.

Example

To set a title to the null group:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.NullTreatment = NumberIncrementNullTreatment.CreateNullGroup;
nri.NullTitle = "No Data Specified";
Grid1.Grouping.RootLevel.Interval = nri;

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


NullTreatment property of class

NumberRangesInterval.NullTreatment Property

Gets or sets how null values will be treated.

[Visual Basic]
Public Property NullTreatment As NumberRangeIntervalNullTreatment[C#]
public NumberRangeIntervalNullTreatment NullTreatment {get;set;}

Property Value

The default is CreateNullGroup.

Value | Meaning
CreateNullGroup | Description goes here
OutOfLowerBoundsGroup | Description goes here
TreatAsZero | Description goes here

Remarks

  • By default, if a null value is found, a group for null values will be created. In order to customize the title of this group, the NullTitle property should be used.

  • The other option this property offers, is to treat null values as zero.

Example

To set the null treatment :

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.NullTreatment = NumberIncrementNullTreatment.TreatAsZero;
Grid1.Grouping.RootLevel.Interval = nri;

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


Ranges property of class

NumberRangesInterval.Ranges Property

Gets the ranges to be used by the NumberRangesInterval.

[Visual Basic]
Public ReadOnly Property Ranges As NumberRangeCollection[C#]
public NumberRangeCollection Ranges {get;}

Remarks

  • This property allows to set and add ranges to the NumberRangesInterval; each range with its own LowerBound and SplitLength.

Example

To set ranges for a NumberRangesInterval object:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
NumberRange nr0 = new NumberRange();
nr0.LowerBound = 5000;
nr0.SplitLength = 1000;
NumberRange nr1 = new NumberRange();
nr1.LowerBound = 10000;
nr1.SplitLength = 5000;
nri.Ranges.Add(nr0);
nri.Ranges.Add(nr1);
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
Dim nr0 As GridFX.WebForms.NumberRange
nr0 = New GridFX.WebForms.NumberRange
nr0.LowerBound = 5000
nr0.SplitLength = 1000
Dim nr1 As GridFX.WebForms.NumberRange
nr1 = New GridFX.WebForms.NumberRange
nr1.LowerBound = 10000
nr1.SplitLength = 5000
nri.Ranges.Add(nr0)
nri.Ranges.Add(nr1)
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members | NumberRange Class


Title property of class

NumberRangesInterval.Title Property

Gets or sets the groups' title.

[Visual Basic]
Public Property Title As String[C#]
public String Title {get;set;}

Remarks

  • This property allows customization of the group title. For instance, it lets add words before and after the dates or rearrange the order of the items in the title altogether.

Example

To set the title:

[C#]
 NumberRangesInterval nri = new NumberRangesInterval();
nri.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})";
Grid1.Grouping.RootLevel.Interval = nri;

[Visual Basic]
 Dim nri As GridFX.WebForms.NumberRangesInterval
nri = New GridFX.WebForms.NumberRangesInterval
nri.Title = "From {StartValue} To {EndValue} Count: ({ItemCount})"
Grid1.Grouping.RootLevel.Interval = nri

Applies to

NumberRangesInterval

See Also

NumberRangesInterval Class | NumberRangesInterval Members


NumericValueCondition class

Provides access to the NumericValueCondition Class.

For a list of all members of this type, see NumericValueCondition Members

GridFX.WebForms.FieldValueCondition
GridFX.WebForms.NumericValueCondition

Remarks

The NumericValueCondition evaluates a GridField by comparing its numeric data with a value.


NumericValueCondition Class Members

NumericValueCondition Members

NumericValueCondition Overview

Public Properties

public property Comparison | Gets or sets the comparison operator used to evaluate a NumericValueCondition.
public property Field (inherited from FieldValueCondition) | Gets or sets the field to which the condition will apply
public property Value | Gets or sets the numeric value used to compare data with a GridField value.


Comparison property of class

NumericValueCondition.Comparison Property

Gets or sets the comparison operator used to evaluate a NumericValueCondition.

[Visual Basic]
Public Property Comparison As NumberComparison[C#]
public NumberComparison Comparison {get;set;}

Property Value

The default is Equal.

Value | Meaning
Equal | Description goes here
NotEqual | Description goes here
GreaterThan | Description goes here
GreaterThanEqual | Description goes here
LessThan | Description goes here
LessThanEqual | Description goes here
IsNull | Description goes here
IsNotNull | Description goes here

Example

Set the comparison operator for a NumericValueCondition:

[C#]
 NumericValueCondition valueCondition = new NumericValueCondition();
valueCondition.Field = Grid1.Fields[1];
valueCondition.Comparison = NumberComparison.GreaterThanEqual;

Applies to

NumericValueCondition

See Also

NumericValueCondition Class | NumericValueCondition Members | FieldValueCondition Class


Value property of class

NumericValueCondition.Value Property

Gets or sets the numeric value used to compare data with a GridField value.

[Visual Basic]
Public Property Value As Number[C#]
public Number Value {get;set;}

Remarks

  • The Value property takes on one of the numeric types that are available through the .NET Framework.

Example

Set the value to be compared:

[C#]
 NumericValueCondition valueCondition = new NumericValueCondition();
valueCondition.Field = Grid1.Fields[1];
valueCondition.Value = 100;

Applies to

NumericValueCondition

See Also

NumericValueCondition Class | NumericValueCondition Members | FieldValueCondition Class


OutputCell class

Provides access to the OutputCell which can be any cell in the Grid.

For a list of all members of this type, see OutputCell Members

GridFX.WebForms.OutputCell

Remarks

An OutputCell can be any cell within the Grid table. One or more cells in the Grid can be defined as output cells and these cells together form an OutputCellContainer.


OutputCell Class Members

OutputCell Members

OutputCell Overview

Public Properties

public property ColumnSpan | Gets the number of columns the output cell will span
public property RowSpan | Gets the number of rows the output cell will span.
public property Style | Gets access to the CellStyle class which allows to set the style properties of the output cell.
public property Text | Gets or sets the contents of the output cell.
public property ToolTip | Gets or sets the tooltip for the OutputCell.
public property Visible | Gets or sets the visible property which allows the output cell to be displayed or hidden.

Public Methods

public method FindContainingCell | Used to find the OutputCell that contains the control
public method ResetText | Used to reset text of an OutputCell in the Grid


ColumnSpan property of class

OutputCell.ColumnSpan Property

Gets the number of columns the output cell will span

[Visual Basic]
Public ReadOnly Property ColumnSpan As Int32[C#]
public Int32 ColumnSpan {get;}

Remarks

  • This is a read-only property and therefore cannot be set using code.

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members


RowSpan property of class

OutputCell.RowSpan Property

Gets the number of rows the output cell will span.

[Visual Basic]
Public ReadOnly Property RowSpan As Int32[C#]
public Int32 RowSpan {get;}

Remarks

  • This is a read-only property and therefore cannot be set using code.

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members


Style property of class

OutputCell.Style Property

Gets access to the CellStyle class which allows to set the style properties of the output cell.

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Remarks

  • Output cell can be any cell in the Grid. The output cell can be defined only after data is bound to the grid.

Example

To show the output cell in bold and to set the color:

              [C#]
grid1.DataBound += new EventHandler(grid1_DataBound);
void grid1_DataBound(object sender, EventArgs e)
    {
outcell = (OutputCell) grid1.Items[1].Cells[2];
outcell.Style.Bold = true;
outcell.Style.ForeColor = Color.DarkBlue;
}

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members | CellStyle Class Class


Text property of class

OutputCell.Text Property

Gets or sets the contents of the output cell.

[Visual Basic]
Public Property Text As String[C#]
public String Text {get;set;}

Remarks

  • By default, the output cell will show the contents of the grid cell defined as the output cell. By setting the text property of the output cell, you can edit the contents of one particular cell in the grid.

Example

To set the text of the output cell:

[C#]
 grid1.DataBound += new EventHandler(grid1_DataBound);
void grid1_DataBound(object sender, EventArgs e)
{
outcell = (OutputCell) grid1.Items[1].Cells[2];
outcell.Text = "Output Cell";
}

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members


ToolTip property of class

OutputCell.ToolTip Property

Gets or sets the tooltip for the OutputCell.

[Visual Basic]
Public Property ToolTip As String[C#]
public String ToolTip {get;set;}

Example

To set the tooltip for the OutputCell:

[C#]
 grid1.DataBound += new EventHandler(grid1_DataBound);
void grid1_DataBound(object sender, EventArgs e)
{
outcell = (OutputCell) grid1.Items[1].Cells[2];
outcell.ToolTip = "output cell";
}

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members


Visible property of class

OutputCell.Visible Property

Gets or sets the visible property which allows the output cell to be displayed or hidden.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • By setting this property to false, the output cell contents will be empty as shown below:

    [C#]
     grid1.DataBound += new EventHandler(grid1_DataBound);
    void grid1_DataBound(object sender, EventArgs e)
    {
    outcell = (OutputCell) grid1.Items[1].Cells[2];
    outcell.Visible = false;
    }

Example

To set the visible property to false:

[C#]
 grid1.DataBound += new EventHandler(grid1_DataBound);
void grid1_DataBound(object sender, EventArgs e)
{
outcell = (OutputCell) grid1.Items[1].Cells[2];
outcell.Visible = false;
}

Applies to

OutputCell

See Also

OutputCell Class | OutputCell Members


FindContainingCell method of OutputCell class

OutputCell.FindContainingCell Method

Used to find the OutputCell that contains the control

[Visual Basic]
Public Function FindContainingCell( _
   ByVal control As Control _
) AS OutputCell[C#]
public OutputCell FindContainingCell(
   Control control
);

Parameters

Parameter | Type | Meaning
control | Control | ID of the control to be found

Example

To find the output cell that has the control:

[C#]
 OutputCell cell = OutputCell.FindContainingCell(Button1);

See Also

OutputCell Class | OutputCell Members


ResetText method of OutputCell class

OutputCell.ResetText Method

Used to reset text of an OutputCell in the Grid

[Visual Basic]
Public Sub ResetText[C#]
public Void ResetText();

Remarks

  • This method can be used to reset text of the OutputCell after the cell contents is changed.

Example

To reset text of the OutputCell:

[C#]
 OutputCell outcell = (OutputCell)Grid1.Items[1].Cells[2];
outcell.ResetText();

[Visual Basic]
 Dim outcell As GridFX.WebForms.OutputCell
outcell = Grid1.Items(1).Cells(2)
outcell.ResetText

See Also

OutputCell Class | OutputCell Members


OutputCellContainer class

Provides access to the OutputCellContainer that contains all the output cells.

For a list of all members of this type, see OutputCellContainer Members

GridFX.WebForms.GridChild
GridFX.WebForms.OutputCellContainer

Remarks

OutputCellContainer is like a container for all the cells of the OutputCell class.

One or more cells in the grid can be defined as output cells and these cells put together form the OutputCellContainer.


OutputCellContainer Class Members

OutputCellContainer Members

OutputCellContainer Overview

Public Properties

public property Cells Gets or sets the list of output cells to be added to the OutputCellContainer.


SfxDescriptionAttribute class

Description goes here

For a list of all members of this type, see SfxDescriptionAttribute Members

GridFX.WebForms.SfxDescriptionAttribute

Remarks

Description goes here


SfxDescriptionAttribute Class Members

SfxDescriptionAttribute Members

SfxDescriptionAttribute Overview

Public Properties

public property Dictionary Description goes here


Dictionary property of class

SfxDescriptionAttribute.Dictionary Property

Description goes here

[Visual Basic]
Public Property Dictionary As StringDictionary[C#]
public StringDictionary Dictionary {get;set;}

Parameters

Parameter | Type | Meaning
key | String | Description goes here

Applies to

SfxDescriptionAttribute

See Also

SfxDescriptionAttribute Class | SfxDescriptionAttribute Members


SideBar class

Provides access to the SideBar object

For a list of all members of this type, see SideBar Members

GridFX.WebForms.SideBar

Remarks

By enabling the Sidebar on the Grid control, you can easily add controls like charts, gauges or standard web controls to your grid to enhance its functionality


SideBar Class Members

SideBar Members

SideBar Overview

Public Properties

public property FlowsOverToolbarAndPager | Sets or Gets whether the Sidebar will cover the whole grid length or if it is limited to show between the toolbar and the pager.
public property Separator | Gets or sets the attributes of the element that separates the sidebar from the grid.
public property Side | Gets or sets the position of the sidebar to the Bottom, Left, Right or Top of the grid.
public property Style | Gets or sets the style attributes of the sidebar contents.
public property Visible | Gets or sets the visible property which allows the sidebar to be displayed or hidden.

Public Methods

public method FindControl Used to find a control in the sidebar and edit the properties of the control.


SideBarSeparator class

Provides access to the SideBar Separator that separates the sidebar from the grid.

For a list of all members of this type, see SideBarSeparator Members

GridFX.WebForms.SideBarSeparator

Remarks

SideBar Separator allows the developer the style settings of the section that separates the SideBar from the Grid.


SideBarSeparator Class Members

SideBarSeparator Members

SideBarSeparator Overview

Public Properties

public property BackColor | Gets or Sets the color property for the sidebar separator.
public property CssClass | Gets or sets the cssclass which allows to assign a stylesheet to the sidebar separator.
public property Visible | Gets or sets the visible property which allows the sidebar separator to be displayed or hidden.


BackColor property of class

SideBarSeparator.BackColor Property

Gets or Sets the color property for the sidebar separator.

[Visual Basic]
Public Property BackColor As Color[C#]
public Color BackColor {get;set;}

Remarks

  • By default the color of the separator is defined based on the color scheme of the grid. You can use this property to customize the color of the Separator.

                  [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Separator.BackColor = Color.DarkOrange;
grid1.SideBars.Add(sidebar);

Example

To set the sidebar backcolor to DarkOrange:

              [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Separator.BackColor = Color.DarkOrange;
    grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Separator.BackColor = System.Drawing.Color.DarkOrange
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBarSeparator

See Also

SideBarSeparator Class | SideBarSeparator Members | Class


CssClass property of class

SideBarSeparator.CssClass Property

Gets or sets the cssclass which allows to assign a stylesheet to the sidebar separator.

[Visual Basic]
Public Property CssClass As String[C#]
public String CssClass {get;set;}

Remarks

  • To use this property, make sure to reference the pre-defined style sheet in your application. Then assign the css class name to the CssClass property of the sidebar separator.

Example

To set the CssClass property to a css class named 'TestSidebar' defined in a stylesheet linked to the project:

              [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
sidebar.Separator.CssClass = "TestSidebar";
    grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Separator.CssClass = "TestSidebar"
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBarSeparator

See Also

SideBarSeparator Class | SideBarSeparator Members


Visible property of class

SideBarSeparator.Visible Property

Gets or sets the visible property which allows the sidebar separator to be displayed or hidden.

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Remarks

  • With this property set to false, there will be no visible separation between Grid and SideBar:

                  [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Separator.Visible = false;
sidebar.Separator.BackColor = Color.DarkOrange;
grid1.SideBars.Add(sidebar);

Example

To hide the sidebar separator:

              [C#]
GridFX.WebForms.TemplateBar sidebar = new GridFX.WebForms.TemplateBar();
    sidebar.Separator.Visible = false;
    sidebar.Separator.BackColor = Color.DarkOrange;
    grid1.SideBars.Add(sidebar);

[Visual Basic]
 Dim sidebar As GridFX.WebForms.TemplateBar
sidebar = New GridFX.WebForms.TemplateBar
sidebar.Separator.Visible = false
sidebar.Separator.BackColor = System.Drawing.Color.DarkOrange
grid1.SideBars.Add(CType(sidebar,GridFX.WebForms.SideBar))

Applies to

SideBarSeparator

See Also

SideBarSeparator Class | SideBarSeparator Members


SingleCellColumn class

A column that renders a single output cell per cell container.

For a list of all members of this type, see SingleCellColumn Members

GridFX.WebForms.GridColumn
GridFX.WebForms.SingleCellColumn

Remarks

A SingleCellColumn can be defined as any column in the Grid that is not defined as a MultiCellColumn.


SingleCellColumn Class Members

SingleCellColumn Members

SingleCellColumn Overview

Public Properties

public property Style | Gets access to the ColumnAreasStyle class which allows to set the style attributes of the SingleCellColumn.
public property Title | Gets or sets the title or header text of the SingleCellColumn.
public property Visible (inherited from GridColumn) | Gets or sets a boolean determining whether the column is visible or not.
public property Width (inherited from GridColumn) | Gets or sets a value determining the column width in pixels.


StyleSettings class

Description goes here

For a list of all members of this type, see StyleSettings Members

GridFX.WebForms.StyleSettings

Remarks

Provides access to the StyleSettings class which allows to set the different style properties of a SingleCellColumn in the Grid.


StyleSettings Class Members

StyleSettings Members

StyleSettings Overview

Public Properties

public property BackColor | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor | Gets or sets the text color of a SingleCellColumn in the Grid
public property Italic | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Underline | Gets or sets the Underline property of text of a SingleCellColumn in the Grid


TemplateCell class

Provides access to the TemplateCell which defines the template for the template cells.

For a list of all members of this type, see TemplateCell Members

GridFX.WebForms.LayoutCell
GridFX.WebForms.ColumnCell
GridFX.WebForms.TemplateCell

Remarks

TemplateCell is used to define templates for the header, footer and items of the grid column. Setting the TemplateCell and accessing the properties is mostly done at design-time.


TemplateCell Class Members

TemplateCell Members

TemplateCell Overview

Public Properties

public property ColumnSpan (inherited from LayoutCell) | Gets or sets the number of columns that a grid field cell will span.
public property ConvertEmptyStringToNull | Gets or sets whether a cell with empty string contents is to be considered as null or not.
public property HeaderTemplate | Gets or sets the template for the header of the template cell.
public property InsertTemplate | Gets or sets the template which allows to insert a TemplateCell to the grid.
public property ItemTemplate | Gets or sets the template for the contents of the Template cells.
public property RowSpan (inherited from LayoutCell) | Gets or sets the number of rows a grid field cell will span.
public property Style (inherited from ColumnCell) | Gets a reference to the CellStyle and StyleSettings class that allows you to set the style attributes of the ColumnCell.
public property Title (inherited from ColumnCell) | Gets or sets the title text for the grid cell.
public property UpdateTemplate | Gets or sets the Template which allows to update a TemplateCell in the grid.
public property Visible (inherited from LayoutCell) | Gets or sets the visible property which allows the cell to be displayed or hidden.


ConvertEmptyStringToNull property of class

TemplateCell.ConvertEmptyStringToNull Property

Gets or sets whether a cell with empty string contents is to be considered as null or not.

[Visual Basic]
Public Property ConvertEmptyStringToNull As Boolean[C#]
public Boolean ConvertEmptyStringToNull {get;set;}

Remarks

  • This property is mostly set at design-time using the grid properties window. If the property is set to true, an empty string will be written as Null in the database.

Example

[C#]

[Visual Basic]

Applies to

TemplateCell

See Also

TemplateCell Class | TemplateCell Members


HeaderTemplate property of class

TemplateCell.HeaderTemplate Property

Gets or sets the template for the header of the template cell.

[Visual Basic]
Public Property HeaderTemplate As ITemplate[C#]
public ITemplate HeaderTemplate {get;set;}

Remarks

  • A template needs to be defined in order to specify the header template for the template cell. Setting the header template is mostly done at design-time.

Example

[C#]

[Visual Basic]

Applies to

TemplateCell

See Also

TemplateCell Class | TemplateCell Members


InsertTemplate property of class

TemplateCell.InsertTemplate Property

Gets or sets the template which allows to insert a TemplateCell to the grid.

[Visual Basic]
Public Property InsertTemplate As ITemplate[C#]
public ITemplate InsertTemplate {get;set;}

Remarks

  • Setting the InsertTemplate is mostly done at design-time.

Applies to

TemplateCell

See Also

TemplateCell Class | TemplateCell Members


ItemTemplate property of class

TemplateCell.ItemTemplate Property

Gets or sets the template for the contents of the Template cells.

[Visual Basic]
Public Property ItemTemplate As ITemplate[C#]
public ITemplate ItemTemplate {get;set;}

Remarks

  • This property is mostly set at design-time using the Grid's properties and the Edit Template wizard.

Example

[C#]

[Visual Basic]

Applies to

TemplateCell

See Also

TemplateCell Class | TemplateCell Members


UpdateTemplate property of class

TemplateCell.UpdateTemplate Property

Gets or sets the Template which allows to update a TemplateCell in the grid.

[Visual Basic]
Public Property UpdateTemplate As ITemplate[C#]
public ITemplate UpdateTemplate {get;set;}

Remarks

  • Setting the UpdateTemplate is mostly done at design-time.

Applies to

TemplateCell

See Also

TemplateCell Class | TemplateCell Members


TextBoxStyle class

Defines settings to configure a System.Web.UI.WebControls.TextBox

For a list of all members of this type, see TextBoxStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.TextBoxStyle

Remarks

This class defines properties to set the dimensions and the type of the TextBox control. The provided properties will allow you to set the text mode to plain or password. Additionally, you can define the wrapping and the size in columns as well as the number of rows for multiline boxes.


TextBoxStyle Class Members

TextBoxStyle Members

TextBoxStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property Columns | Gets or sets the length of the TextBox control based on the number of columns.
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Rows | Gets or sets the number of rows defined for a multi-line TextBox
public property TextMode | Gets or sets the type of textbox to be used
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property Wrap | Gets or sets a value indicating whether the text inside the TextBox control will be word wrapped

Public Methods

public method ApplySettings Applies the style settings of the TextBoxes in the field to an external TextBox control.


Columns property of class

TextBoxStyle.Columns Property

Gets or sets the length of the TextBox control based on the number of columns.

[Visual Basic]
Public Property Columns As Int32[C#]
public Int32 Columns {get;set;}

Remarks

  • Use this property to set the size (length) of the TextBox control

Example

To set the length of the TextBox to 10 columns:

              [C#]
GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
        myTextField.Format.TextBox.Columns = 10;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.TextBox.Columns = 10

Applies to

TextBoxStyle

See Also

TextBoxStyle Class | TextBoxStyle Members


Rows property of class

TextBoxStyle.Rows Property

Gets or sets the number of rows defined for a multi-line TextBox

[Visual Basic]
Public Property Rows As Int32[C#]
public Int32 Rows {get;set;}

Remarks

  • Use this property to adjust the height of the TextBox based on the number of rows.

  • In order for the Textbox to show the multiple lines, you need to set the TextMode Property to multi-line. If multi-line is not set, the textBox will simply ignore the Rows setting and show one row only.

Example

To set a TextField to show a Three-row multi-line TextBox

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.Output = TextFormatterOutput.TextBox;
myTextField.Format.TextBox.TextMode = TextBoxMode.MultiLine;
myTextField.Format.TextBox.Rows = 3;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.Output = TextFormatterOutput.TextBox
myTextField.Format.TextBox.TextMode = TextBoxMode.MultiLine
myTextField.Format.TextBox.Rows = 3;

Applies to

TextBoxStyle

See Also

TextBoxStyle Class | TextBoxStyle Members | TextMode Property


TextMode property of class

TextBoxStyle.TextMode Property

Gets or sets the type of textbox to be used

[Visual Basic]
Public Property TextMode As TextBoxMode[C#]
public TextBoxMode TextMode {get;set;}

Remarks

  • Using this property, you can set the textbox to show as a regular single line box, as a multiline textbox or as a password entry box.

  • If you set TextMode to Mulitline, you need to use the Rows property to define a number of rows for the control.

Example

To set a Multiline TextBox:

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.TextBox.TextMode = TextBoxMode.MultiLine;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField
myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.TextBox.TextMode = TextBoxMode.MultiLine

Applies to

TextBoxStyle

See Also

TextBoxStyle Class | TextBoxStyle Members


Wrap property of class

TextBoxStyle.Wrap Property

Gets or sets a value indicating whether the text inside the TextBox control will be word wrapped

[Visual Basic]
Public Property Wrap As Boolean[C#]
public Boolean Wrap {get;set;}

Example

To set word wrapping to true:

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.TextBox.Wrap = true;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField
myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.TextBox.Wrap = true;

Applies to

TextBoxStyle

See Also

TextBoxStyle Class | TextBoxStyle Members


ApplySettings method of TextBoxStyle class

TextBoxStyle.ApplySettings Method

Applies the style settings of the TextBoxes in the field to an external TextBox control.

[Visual Basic]
Public Sub ApplySettings( _
   ByVal textBox As TextBox _
)[C#]
public Void ApplySettings(
   TextBox textBox
);

Parameters

Parameter | Type | Meaning
textBox | TextBox | The name of the TextBox control to apply the settings to.

Remarks

  • This method can be used to maintain the style settings of the TextBox objects in the grid throughout the whole page. Any visual setting applied to the TextBox object tied to a the field will be applied to the control passed as parameter for this method.

Example

To apply settings to a control external to the field:

[C#]
 TextBox myTextBox = new TextBox();
TextField myTextField = (TextField)grid1.Fields[2];
myTextField.Format.Display = TextDisplayType.TextBox;
myTextField.Format.TextBox.BackColor = System.Drawing.Color.Aqua;
myTextField.Format.TextBox.ApplySettings(myTextBox);

See Also

TextBoxStyle Class | TextBoxStyle Members


TextField class

Defines a GridField for string or Char data

For a list of all members of this type, see TextField Members

GridFX.WebForms.DataField
GridFX.WebForms.TextField

Remarks

The TextField object alllows to create a field that consists of string values. This object provides the necessary properties to adjust how the text will be shown in each cell and how the Grid should treat the incoming text values.

You can use this object to set the field to display the values inside a TextBox control or a ChartFX DigitalPanel Control.


TextField Class Members

TextField Members

TextField Overview

Public Properties

public property Culture (inherited from DataField) | Allows the user localize a DataField for a specific language and region.
public property DataPath (inherited from DataField) | Gets or sets the mapping string that points to the data field within a data item
public property Filtering (inherited from DataField) | Gets filtering settings for a DataField.
public property Format | Description goes here
public property Grouping (inherited from DataField) | Gets the FieldGroupingSettings object for a GridField which provides access to all grouping properties.
public property Input | Description goes here
public property IsKey (inherited from DataField) | Gets or sets whether the DataField is a Data Key.
public property ReadOnly (inherited from DataField) | Gets or sets whether a DataField is editable or not.
public property Sorting (inherited from DataField) | Provides access to the FieldSortingSettings object that allows configuring sorting options for the field
public property Title (inherited from DataField) | Gets or sets the title for a DataField
public property UniqueID (inherited from DataField) | Gets or sets a Unique Identifier for a DataField
public property Visible (inherited from DataField) | Gets or sets whether the DataField will be visible or not.


Format property of class

TextField.Format Property

Description goes here

[Visual Basic]
Public ReadOnly Property Format As TextFormatter[C#]
public TextFormatter Format {get;}

Applies to

TextField

See Also

TextField Class | TextField Members


Input property of class

TextField.Input Property

Description goes here

[Visual Basic]
Public ReadOnly Property Input As TextFieldInputSettings[C#]
public TextFieldInputSettings Input {get;}

Applies to

TextField

See Also

TextField Class | TextField Members


TextFormatter class

Defines formatting for string values

For a list of all members of this type, see TextFormatter Members

GridFX.WebForms.FieldValueFormatter
GridFX.WebForms.TextFormatter

Remarks

Provides access to the TextFormatter object which allows for manipulation of the way the text is displayed inside TextFields.

Using this class' properties, you can set the text to show as a digital panel display or inside a text box


TextFormatter Class Members

TextFormatter Members

TextFormatter Overview

Public Properties

public property Casing | Gets or sets the casing for the text.
public property DigitalPanel | Gets the Chart FX Gauges Digital Panel object that will be used to display text values
public property Display | Gets or sets the display type of the text data to be shown
public property NullText | Gets or sets the dafault value to show in case of null records
public property TextBox | Provides access to the Text Box object that will be used to display text values
public property TreatEmptyStringAsNull | Gets or sets whether empty strings will be treated as null values
public property Trimming | Provides access to the StringTrimmingSettings for the TextField


Casing property of class

TextFormatter.Casing Property

Gets or sets the casing for the text.

[Visual Basic]
Public Property Casing As StringCasing[C#]
public StringCasing Casing {get;set;}

Property Value

The default is NotSet.

Value | Meaning
NotSet | No casing, so string will be left alone.
Upper | Upper casing on all characters.
Lower | Lower casing on all characters.
Title | Title casing, which typically (depending on culture) capitalizes the first letters of each word.

Remarks

  • With this property, you can force the text to show all letters as lower case oruUpper case.

  • Setting the Casing ot Title will force only the first letter of each word to show as Upper case.

Example

To display the text using upper case:

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.Casing = GridFX.WebForms.StringCasing.Upper;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.Casing = GridFX.WebForms.StringCasing.Upper

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members


DigitalPanel property of class

TextFormatter.DigitalPanel Property

Gets the Chart FX Gauges Digital Panel object that will be used to display text values

[Visual Basic]
Public ReadOnly Property DigitalPanel As DigitalPanel[C#]
public DigitalPanel DigitalPanel {get;}

Remarks

  • In order to show the text using the DigitalPanel control, the Output format for the field needs to be previously set to DigitalPanel.

Example

To set the color of the character display to blue:

              [C#]
GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.DigitalPanel.Appearance.Color = System.Drawing.Color.Blue;

              [Visual Basic]
Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.DigitalPanel.Appearance.Color = System.Drawing.Color.Blue

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members | Output Property


Display property of class

TextFormatter.Display Property

Gets or sets the display type of the text data to be shown

[Visual Basic]
Public Property Display As TextDisplayType[C#]
public TextDisplayType Display {get;set;}

Property Value

The default is Text.

Value | Meaning
Text | Sets the string values to show as plain text.
DigitalPanel | Sets the string values to show inside a ChartFX DigitalPanel control.
TextBox | Sets the string values to show inside a Text Box control.

Remarks

  • The Display property determines how the Boolean data will be shown to the user.

  • The Data can be displayed as plain text (Default), as a DigitalPanel or inside a TextBox control.

Example

To set the DisplayType to DigitalPanel:

[C#]
 TextField myTextField = (TextField)grid1.Fields[2];
myTextField.Format.Display = TextDisplayType.DigitalPanel;

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members


NullText property of class

TextFormatter.NullText Property

Gets or sets the dafault value to show in case of null records

[Visual Basic]
Public Property NullText As String[C#]
public String NullText {get;set;}

Remarks

  • When you expect there to be null values in the text column, you can use this property to set a default value in order to avoid empty cells.

  • This property can be used with TreatEmptyStringAsNull is order ot make sure that both null and emty strings are replaced by the default string

Example

To set "Nothing" as the default string for field 1

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.NullText = "Nothing";

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.NullText = "Nothing"

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members


TextBox property of class

TextFormatter.TextBox Property

Provides access to the Text Box object that will be used to display text values

[Visual Basic]
Public ReadOnly Property TextBox As TextBoxStyle[C#]
public TextBoxStyle TextBox {get;}

Remarks

  • In order to show the text using the DigitalPanel control, the Output format for the field needs to be previously set to DigitalPanel.

Example

To change the background color of the Textbox

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextBox.Format.TextBox.BackColor = System.Drawing.Color.Azure;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextBox.Format.TextBox.BackColor = System.Drawing.Color.Azure

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members | Output Property


TreatEmptyStringAsNull property of class

TextFormatter.TreatEmptyStringAsNull Property

Gets or sets whether empty strings will be treated as null values

[Visual Basic]
Public Property TreatEmptyStringAsNull As Boolean[C#]
public Boolean TreatEmptyStringAsNull {get;set;}

Remarks

  • If true, any empty string ("") in the data source will be converted to Null.

  • You can use the NullText property to set a default value for all Null records.

Example

To set emty string values ot be treated as Null:

              [C#]
GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
        myTextField.Format.TreatEmptyStringAsNull = true;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField
myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.TreatEmptyStringAsNull = true

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members | NullText Property


Trimming property of class

TextFormatter.Trimming Property

Provides access to the StringTrimmingSettings for the TextField

[Visual Basic]
Public ReadOnly Property Trimming As StringTrimmingSettings[C#]
public StringTrimmingSettings Trimming {get;}

Remarks

  • This property allows you to configure trimming for the strings in the cells based on the number of characters

  • The Trimming properties are defined in the StringTrimmingSettings class

Example

To set the macimum length of the strings to 5 characters:

[C#]
 GridFX.WebForms.TextField myTextField = (GridFX.WebForms.TextField)Grid1.Fields[1];
myTextField.Format.Trimming.TrimLength = 5;

[Visual Basic]
 Dim myTextField As GridFX.WebForms.TextField myTextField = CType(Grid1.Fields(1),GridFX.WebForms.TextField)
myTextField.Format.Trimming.TrimLength = 5

Applies to

TextFormatter

See Also

TextFormatter Class | TextFormatter Members


ThumbnailFormat class

Contain settings to format thumbnails.

For a list of all members of this type, see ThumbnailFormat Members

GridFX.WebForms.BaseImageFormat
GridFX.WebForms.ThumbnailFormat

Remarks

Description goes here


ThumbnailFormat Class Members

ThumbnailFormat Members

ThumbnailFormat Overview

Public Properties

public property ExpandEvent | Gets or sets the event that will trigger the expansion
public property Height (inherited from BaseImageFormat) | Gets and sets the height of the image.
public property RoundCorners | Gets or sets round corner borders to the thumbnail.
public property StretchImages (inherited from BaseImageFormat) | Determines if the image will be stretched or will retain its original size.
public property UseSizeRatio (inherited from BaseImageFormat) | Locks the size ratio of the image.
public property Width (inherited from BaseImageFormat) | Gets or sets the width of the image.


ExpandEvent property of class

ThumbnailFormat.ExpandEvent Property

Gets or sets the event that will trigger the expansion

[Visual Basic]
Public Property ExpandEvent As PopupExpandEvent[C#]
public PopupExpandEvent ExpandEvent {get;set;}

Property Value

The default is Click.

Value | Meaning
Never | To disable the ExpandEvent.
Click | To expand by clicking.
Hover | To expand by hovering.
ClickOrHover | To expand either by clicking or hovering.

Remarks

  • By default, this property is set to Click.

Example

To set the ExpandEvent of an ImageField:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image"];
imageField.Format.Thumbnail.ExpandEvent = ThumbnailExpandEvent.Hover;

[Visual Basic]
 Dim imageField As ImageField
imageField = CType(Grid1.Fields("Image"), GridFX.WebForms.ImageField)
imageField.Format.Thumbnail.ExpandEvent = ThumbnailExpandEvent.Hover

Applies to

ThumbnailFormat

See Also

ThumbnailFormat Class | ThumbnailFormat Members


RoundCorners property of class

ThumbnailFormat.RoundCorners Property

Gets or sets round corner borders to the thumbnail.

[Visual Basic]
Public Property RoundCorners As Boolean[C#]
public Boolean RoundCorners {get;set;}

Remarks

  • By default, this property is set to true.

Example

To enable RoundBorders:

[C#]
 GridFX.WebForms.ImageField imageField = (GridFX.WebForms.ImageField)Grid1.Fields["Image"];
imageField.Format.Thumbnail.RoundCorners = true;

[Visual Basic]
 Dim imageField As ImageField
imageField = CType(Grid1.Fields("Url"), GridFX.WebForms.ImageField)
imageField.Format.Thumbnail.RoundCorners = True

Applies to

ThumbnailFormat

See Also

ThumbnailFormat Class | ThumbnailFormat Members


TileSeparator class

Provides access to the TileSeparator class

For a list of all members of this type, see TileSeparator Members

GridFX.WebForms.TileSeparator

Remarks

When there is more than 1 tile in the grid, TileSeparator is used to separate the different tiles in the grid


TileSeparator Class Members

TileSeparator Members

TileSeparator Overview

Public Properties

public property SpansHeaderAndFooter | Gets or sets the property which allows the TileSeparator to span the grid's header and footer or not
public property Style | Gets access to the CellStyle class that allows to set the style attributes of the TileSeparator
public property Visible | Gets or sets the visible property which allows the TileSeparator to be displayed or hidden


SpansHeaderAndFooter property of class

TileSeparator.SpansHeaderAndFooter Property

Gets or sets the property which allows the TileSeparator to span the grid's header and footer or not

[Visual Basic]
Public Property SpansHeaderAndFooter As Boolean[C#]
public Boolean SpansHeaderAndFooter {get;set;}

Example

To set the separator to span the header and footer area:

[C#]
 Grid1.Tiling.Separator.SpansHeaderAndFooter = true;

Applies to

TileSeparator

See Also

TileSeparator Class | TileSeparator Members


Style property of class

TileSeparator.Style Property

Gets access to the CellStyle class that allows to set the style attributes of the TileSeparator

[Visual Basic]
Public ReadOnly Property Style As CellStyle[C#]
public CellStyle Style {get;}

Example

To set the color of the separator:

[C#]
 Grid1.Tiling.Separator.Style.BackColor = Color.DarkKhaki;

Applies to

TileSeparator

See Also

TileSeparator Class | TileSeparator Members | CellStyle Class Class


Visible property of class

TileSeparator.Visible Property

Gets or sets the visible property which allows the TileSeparator to be displayed or hidden

[Visual Basic]
Public Property Visible As Boolean[C#]
public Boolean Visible {get;set;}

Example

To display the TileSeparator:

[C#]
 Grid1.Tiling.Separator.Visible = true;

Applies to

TileSeparator

See Also

TileSeparator Class | TileSeparator Members


TilingSettings class

Provides access to the TilingSettings class which is used to define one or more tiles in the Grid

For a list of all members of this type, see TilingSettings Members

GridFX.WebForms.TilingSettings

Remarks

Used to display the Grid items in more than one tile.


TilingSettings Class Members

TilingSettings Members

TilingSettings Overview

Public Properties

public property ColumnCount | Gets or sets the ColumnCount which specifies the number of tiles that the Grid columns repeat for
public property ColumnFillDirection | Gets or sets the ColumnFillDirection which specifies the direction how the grid items get placed in the grid
public property EmptyTileStyle | Gets access to the CellStyle class which allows to set the style attributes of the grid cells that are empty and do not have an item to be filled.
public property ItemStyleRotation | Gets or sets how the Grid ItemStyles will be rotated when there is more than one tile
public property Separator | Gets access to the TileSeparator class which allows to set attributes of the separator that separates the different column tiles


ColumnCount property of class

TilingSettings.ColumnCount Property

Gets or sets the ColumnCount which specifies the number of tiles that the Grid columns repeat for

[Visual Basic]
Public Property ColumnCount As Int32[C#]
public Int32 ColumnCount {get;set;}

Remarks

  • If the column count is 2, then the grid columns get repeated twice like in 2 tiles.

    [C#]
     grid1.Tiling.ColumnCount = 2;

Example

To set the columncount to 2:

[C#]
 Grid1.Tiling.ColumnCount = 2;

Applies to

TilingSettings

See Also

TilingSettings Class | TilingSettings Members


ColumnFillDirection property of class

TilingSettings.ColumnFillDirection Property

Gets or sets the ColumnFillDirection which specifies the direction how the grid items get placed in the grid

[Visual Basic]
Public Property ColumnFillDirection As TileColumnFillDirection[C#]
public TileColumnFillDirection ColumnFillDirection {get;set;}

Property Value

The default is Horizontal.

Value | Meaning
Horizontal | Description goes here
Vertical | Description goes here

Remarks

  • Setting the column direction to Vertical will place the first few grid items in one tile and the remaining grid items in the second tile as shown:

    [C#]
     grid1.Tiling.ColumnCount = 2;
    grid1.Tiling.ColumnFillDirection = TileColumnFillDirection.Vertical;

Example

To set the column fill direction to vertical:

[C#]
 Grid1.Tiling.ColumnFillDirection = TileColumnFillDirection.Vertical;

Applies to

TilingSettings

See Also

TilingSettings Class | TilingSettings Members


EmptyTileStyle property of class

TilingSettings.EmptyTileStyle Property

Gets access to the CellStyle class which allows to set the style attributes of the grid cells that are empty and do not have an item to be filled.

[Visual Basic]
Public ReadOnly Property EmptyTileStyle As CellStyle[C#]
public CellStyle EmptyTileStyle {get;}

Example

To set the background color of the empty cells:

[C#]
 Grid1.Tiling.EmptyTileStyle.BackColor = Color.DarkOliveGreen;

Applies to

TilingSettings

See Also

TilingSettings Class | TilingSettings Members | CellStyle Class Class


ItemStyleRotation property of class

TilingSettings.ItemStyleRotation Property

Gets or sets how the Grid ItemStyles will be rotated when there is more than one tile

[Visual Basic]
Public Property ItemStyleRotation As StyleRotation[C#]
public StyleRotation ItemStyleRotation {get;set;}

Property Value

The default is HorizontalTileStrip.

Value | Meaning
Item | Description goes here
HorizontalTileStrip | Description goes here
VerticalTileStrip | Description goes here

Remarks

  • Used to define the style of the grid items when there is more than one tile defined in the grid.

Example

To set the StyleRotation:

[C#]
 Grid1.Tiling.ItemStyleRotation = StyleRotation.VerticalTileStrip;

Applies to

TilingSettings

See Also

TilingSettings Class | TilingSettings Members


Separator property of class

TilingSettings.Separator Property

Gets access to the TileSeparator class which allows to set attributes of the separator that separates the different column tiles

[Visual Basic]
Public ReadOnly Property Separator As TileSeparator[C#]
public TileSeparator Separator {get;}

Example

To set the visible property of tiling separator:

[C#]
 Grid1.Tiling.Separator.Visible = true;

Applies to

TilingSettings

See Also

TilingSettings Class | TilingSettings Members | TileSeparator Class Class


TitleBarStyle class

Allows access to the Grid's TitleBar

For a list of all members of this type, see TitleBarStyle Members

GridFX.WebForms.StyleSettings
GridFX.WebForms.CellStyle
GridFX.WebForms.TitleBarStyle

Remarks

Provides access to the Grid's TitleBar which is used to set the style properties of the Grid's title, subtitle and the background area of the TitleBar


TitleBarStyle Class Members

TitleBarStyle Members

TitleBarStyle Overview

Public Properties

public property BackColor (inherited from StyleSettings) | Gets or sets the background color of a SingleCellColumn in the Grid
public property BackgroundImageUrl | Gets or sets the background image for the TitleBar
public property Bold (inherited from StyleSettings) | Gets or sets the Bold property which displays the text of a SingleCellColumn in bold
public property CssClass (inherited from StyleSettings) | Gets or sets the CssClass which defines the style attributes of text in a SingleCellColumn in the Grid
public property FontFamily (inherited from StyleSettings) | Gets or sets the text Font of a SingleCellColumn in the Grid
public property FontSize (inherited from StyleSettings) | Gets or sets the font size of text in a SingleCellColumn in the Grid
public property ForeColor (inherited from StyleSettings) | Gets or sets the text color of a SingleCellColumn in the Grid
public property HorizontalAlign (inherited from CellStyle) | Gets or sets the horizontal alignment used by a CellStyle
public property Italic (inherited from StyleSettings) | Gets or sets the Italic property which displays the text of a SingleCellColumn in italic
public property Overflow (inherited from CellStyle) | Gets or sets whether the cell text will be clipped or not.
public property Subtitle | Gets access to the CellStyle class which allows to set the style attributes of the Grid's subtitle
public property Title | Gets access to the CellStyle class which allows to set the style attributes of the Grid's title.
public property Underline (inherited from StyleSettings) | Gets or sets the Underline property of text of a SingleCellColumn in the Grid
public property VerticalAlign (inherited from CellStyle) | Gets or sets the vertical alignment used by a CellStyle
public property Wrap (inherited from CellStyle) | Gets or sets whether the text contents of the cell will be wrapped or not.


BackgroundImageUrl property of class

TitleBarStyle.BackgroundImageUrl Property

Gets or sets the background image for the TitleBar

[Visual Basic]
Public Property BackgroundImageUrl As String[C#]
public String BackgroundImageUrl {get;set;}

Example

To set the background image to an image file saved in the application:

[C#]
 Grid1.TitleBar.Style.BackgroundImageUrl = "~/Sunset.jpeg";

[Visual Basic]
 Grid1.TitleBar.Style.BackgroundImageUrl = "~/Sunset.jpeg"

Applies to

TitleBarStyle

See Also

TitleBarStyle Class | TitleBarStyle Members


Subtitle property of class

TitleBarStyle.Subtitle Property

Gets access to the CellStyle class which allows to set the style attributes of the Grid's subtitle

[Visual Basic]
Public ReadOnly Property Subtitle As CellStyle[C#]
public CellStyle Subtitle {get;}

Remarks

  • This property inherits some properties from the CellStyle class. Please refer to the CellStyle class for more information.

Example

To set the underline and align properties of the Grid's subtitle:

[C#]
 Grid1.TitleBar.Style.Subtitle.Underline = true;
Grid1.TitleBar.Style.Subtitle.HorizontalAlign = HorizontalAlign.Center;

[Visual Basic]
 Grid1.TitleBar.Style.Subtitle.Underline = true
Grid1.TitleBar.Style.Subtitle.HorizontalAlign = System.Web.UI.WebControls.HorizontalAlign.Center

Applies to

TitleBarStyle

See Also

TitleBarStyle Class | TitleBarStyle Members | CellStyle Class Class


Title property of class

TitleBarStyle.Title Property

Gets access to the CellStyle class which allows to set the style attributes of the Grid's title.

[Visual Basic]
Public ReadOnly Property Title As CellStyle[C#]
public CellStyle Title {get;}

Example

To set the color and underline properties of the Grid's title:

              [C#]
Grid1.TitleBar.Style.Title.ForeColor = Color.DarkRed;
Grid1.TitleBar.Style.Title.Underline = true;

[Visual Basic]
 Grid1.TitleBar.Style.Title.ForeColor = System.Drawing.Color.DarkRed
Grid1.TitleBar.Style.Title.Underline = true

Applies to

TitleBarStyle

See Also

TitleBarStyle Class | TitleBarStyle Members | CellStyle Class Class


WeekInterval class

Provides access to the WeekInterval object.

For a list of all members of this type, see WeekInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.WeekInterval

Remarks

This class is used group records by weeks.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


WeekInterval Class Members

WeekInterval Members

WeekInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property FirstDayOfWeek | Gets or sets the first day of the week.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Start (inherited from DateTimeIncrementInterval) | Gets or sets the start for the group.
public property StartSource (inherited from DateTimeIncrementInterval) | Gets or sets how the groups will start.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.


FirstDayOfWeek property of class

WeekInterval.FirstDayOfWeek Property

Gets or sets the first day of the week.

[Visual Basic]
Public Property FirstDayOfWeek As DayOfWeek[C#]
public DayOfWeek FirstDayOfWeek {get;set;}

Remarks

  • By default this property is set to sunday.

  • However, some cultures do not consider Sunday to be the first day of the week. This property allows to set the first day of the week to any particular day, to accommodate the developer's needs.

Example

To set the first day of the week to Monday:

[C#]
 WeekInterval wi = new WeekInterval();
wi.FirstDayOfWeek = DayOfWeek.Monday;
Grid1.Grouping.RootLevel.Interval = wi;

[Visual Basic]
 Dim wi As GridFX.WebForms.WeekInterval
wi = New GridFX.WebForms.WeekInterval
wi.FirstDayOfWeek = System.DayOfWeek.Monday
Grid1.Grouping.RootLevel.Interval = wi

Applies to

WeekInterval

See Also

WeekInterval Class | WeekInterval Members


YearInterval class

Provides access to the YearInterval object.

For a list of all members of this type, see YearInterval Members

GridFX.WebForms.GroupInterval
GridFX.WebForms.DateTimeIncrementInterval
GridFX.WebForms.YearInterval

Remarks

This class is used to group records by years.

It inherits its properties from the GroupInterval and DateTimeIncrementInterval classes.


YearInterval Class Members

YearInterval Members

YearInterval Overview

Public Properties

public property DateTimeFormatInTitle (inherited from DateTimeIncrementInterval) | Gets or sets how the dates will be shown in the groups title.
public property HideData (inherited from GroupInterval) | Allows to hide the field name of the records.
public property Length (inherited from DateTimeIncrementInterval) | Gets or sets the length of the Interval.
public property NullTitle (inherited from DateTimeIncrementInterval) | Gets or sets the title displayed when the date field of a record is null.
public property RelativeTitles (inherited from DateTimeIncrementInterval) | Allows the utilization of relative titles.
public property Start (inherited from DateTimeIncrementInterval) | Gets or sets the start for the group.
public property StartSource (inherited from DateTimeIncrementInterval) | Gets or sets how the groups will start.
public property Title (inherited from DateTimeIncrementInterval) | Gets or sets the groups' title.