Chart Class Members

Chart Parameters

Parameters

Description

AllSeries | Gets the global attributes which are shared across the of the chart.
Anchor | Allows you to specify the general location of the chart with respect to your desktop.
Antialiasing | Gives a smooth visual effect to the chart.
AxesStyle | Used to change the style of the axes.
AxesX | Returns the collection of the X axes of the chart.
AxesY | Returns the collection of the Y axes of the chart.
AxisX | Assigns properties specifically to the primary X axis.
AxisY | Assigns properties specifically to the primary Y axis of the chart.
AxisY2 | Assigns properties specifically to the secondary Y axis of the chart.
Caption | Modifies the caption used in the PowerGadget window
ColHeadings | Allows you to specifies which fields to use in crosstab chart as column headings.
Condition | Allows you to apply Conditional Attributes in the chart.
ConditionalAttributes | Returns the collection of objects.
Configure | Allows you to use a graphical Wizard to customize the chart.
ContextMenus | Allows you to enable or disable context sensitive menus when the user right clicks a particular chart element.
Crosshairs | Enables or Disables the cross-hairs marker in the chart.
Culture | Allows you to localize charts for a specific language and region.
DataGrid | Gets the MenuBar of the chart. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the chart and the grid at the same time.
ExtraStyle | Allows you to set additional visual attributes in the chart.
Floating | Allows you to launch a chart without a window frame.
Font | Sets the font type which will be used by default in the chart.
ForeColor | Sets the default font color of the chart.
Gallery | Sets the gallery type of the chart. The gallery type can also be accessed through the AllSeries property.
GalleryAttributes | Used to create a gallery object to assign additional attributes to the selected of the chart. The gallery attribute can also be accessed through the AllSeries property.
Glass | Allows you to configure the gauge background to be painted using Glass form.
Group | Allows you to create the chart window as a separate process and assigns an ID that allows multiple charts to share the same window.
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Label | Allows you to specify which property to use as the X labels.
LegendBox | Allows you to acces the legend box of the chart.
Location | Allows you to configure the chart's location in pixels.
MainPane | Gets the default pane of the chart.
MenuBar | Allows you to access the menu bar of the chart. Alternativelly, you can access the tool bar of the chart using ToolBar.
Modal | Allows you to block the command pipe while displaying a chart.
Name | Allows you to assign a name to chart.
Output | Allows you to generate a chart file instead of an interactive one.
Palette | Allows you to set a pre-defined palette.
Panes | Returns the collection of the defined of the chart.
PlotAreaColor | Gets and Sets the color of the PlotAreaBackground.
PlotAreaMargin | Gets and Sets the top, bottom, left and right gaps of the chart.
Points | Assigns properties directly to a specific point in the chart.
RealTime | Allows access to the RealTimeSettings supported members used to create real-time charts.
Refresh | Allows you to refresh the chart with new data by executing the same command(s) that populated the chart at the first time.
RowHeadings | Allows you to specifies which fields to use in crosstab chart as row headings.
Series | Assigns properties directly to the selected series in the chart.
Size | Allows you to specify the actual dimension of the final rendered chart.
Template | Allows you to use or save chart modifications into a template file.
Titles | Returns the collection of titles defined in the chart.
ToolBar | Allow to acces the tool bar of the chart. Alternativelly, you can access the tool bar of the chart using MenuBar.
ToolTipFields |
ToolTipFormat | Allows you to control the information to be displayed in the tooltip when the user positions the mouse over a particular data point in the chart.
ToolTips | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the chart area only.
Values | Allows you to specify which properties to chart.
View3D | Allows you to enable or disable 3D view of the chart. Also permits to customize the 3D view.

@2008 Software FX, Inc. All Rights Reserved. PowerGadgets is a registered trademark of Software FX, Inc
All other names are trademarks or registered trademarks of their respective owners.


AllSeries property of Chart Parameter

AllSeries Parameter

Gets the global attributes which are shared across the series of the chart.

Remarks

  • For performance reason, the series and the points related to the series share the same visual attributes. Therefore, to set a attribute common to all the points of the chart, AllSeries should be used. If the user wants to change a visual attribute for a particular series, Series should be used. Similarly, if the user wants to change a visual attribute for a particular point, Points should be used.

Example

Sets the gallery Pie to all the series of the chart:

out-chart -AllSeries_Gallery Pie

See Also

Chart Parameter | Chart Summary


GlobalAttributes Class Members

Chart_AllSeries Parameters

Parameters

Description

AlternateColor | Sets the Alternate Color for a all the Series.
AxisX | Assigns properties specifically to the primary X axis.
AxisY | Assigns properties specifically to the Y axis.
BarShape | Sets the Shape for the Bars.
Border | Provides access to the border attributes object.
Color | Sets the color for all series.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Gallery | Gets and sets the chart type for all Series.
Horizontal | Sets a value specifying to transpose X and Y axes in a chart.
Line | Gets the LineAttributes object for the particular point.
MarkerShape | Sets the the type used to paint markers for the selected item.
MarkerSize | Sets a value controlling the size of the markers for the selected item.
MarkerStep | Controls how frequently point markers are shown in the selected series.
MultipleColors | Gets and sets the Multiple colors to allow for independently colored data points.
Pane | Sets the Pane which will be used by the series by default.
Pattern | Sets the Pattern for all the series in a chart.
Picture | Sets a value specifying the picture associated to the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
SeparateSlice | Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.
Stacked | Sets the Stacked style in the chart.
Visible | Shows or hides all the Series.
Volume | Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


AllSeries_AlternateColor property of GlobalAttributes Parameter

AllSeries_AlternateColor Parameter

Sets the Alternate Color for a all the Series.

Remarks

  • The AlternateColor is used in combination with the Color property to achive a gradient fill effect in the Series markers. The gradient will go from the Color to the AlternateColor.

  • This property also requires the property to be set to Gradient.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set the AllSeries AlternateColor:

out-chart -AllSeries_FillMode Gradient -AllSeries_AlternateColor Red

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_AxisX property of GlobalAttributes Parameter

AllSeries_AxisX Parameter

Assigns properties specifically to the primary X axis.

Remarks

  • The AxisX property allows developers to assign attributes directly to the X axis object, use the AxisY property for the primary Y axis.

Example

Assign 4 decimal places to the X axis labels:

out-chart -AxisX_LabelsFormat_Decimals 4

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AxisX Class Members

Chart_AllSeries_AxisX Parameters

Parameters

Description

AutoScale | Instructs PowerGadgets to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.
AutoScroll | Enables or disables scrolling in an Axis.
CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
CustomSteps | Allows you to set a custom step for the selected axis.
DataFormat | Used to format the data displayed on point labels and tool tips shown at a mouseover.
FirstLabel | Sets a value used to customize the first label displayed on a selected axis.
Font | Allows you to change the label Font attributes of the selected axis.
ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Inverted | Sets a selected numerical axis max value lesser than the min value.
KeyLabels | Used to assign a key (short) legend to tickmarks in a categorical axis.
LabelAngle | Sets the text rotation for the labels in the selected axis.
Labels | Allows you to get or set tick marks labels for the selected axis.
LabelsFormat | Used to format the labels displayed on the selected axis.
LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
Line | Allows you to apply supported Line members to a selected axis line.
LineSpacing | Sets a value indicating the LineSpacing for an axis.
LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
Max | Defines the maximum value of a specific axis.
Min | Defines the minimum value of a selected axis.
MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
PixelsPerUnit | Gives you the ability to control how many pixels per unit are there in the selected axis.
Position | Specifies the placement of the axis labels and tick marks relative to the chart.
ScaleUnit | Returns or sets the scale unit of a selected axis.
ScrollPosition | Allows you to set the starting scroll position when a chart is scrollable.
Sections | Returns a selected AxisSection object.
Separation | Allows you to specify a gap in pixels between multiple axis.
Staggered | Alternates the level of the axis labels for the selected axis labels.
Step | Specifies the interval of major tick marks and gridlines on the selected axis.
Style | Allows you to add additional styles to the selected axis.
TextColor | Sets the color for text of a selected BaseAxisSection object.
Title | Sets the title for a specific axis.
Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AllSeries_AxisX_AutoScale property of Axis Parameter

AllSeries_AxisX_AutoScale Parameter

Instructs Chart FX to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.

Remarks

  • If you set a Min or Max value and new data is received by the chart when the AutoScale property is enabled, the scale values will be overwritten by PowerGadgets . This method will not affect the Step property if it has previously set to a specific value. If you want the AutoScale property to recalculate the Step value, make sure the Step property is set to zero (0).

Example

To set the AllSeries AxisX AutoScale:

out-chart -AllSeries_AxisX_AutoScale true

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_AutoScroll property of Axis Parameter

AllSeries_AxisX_AutoScroll Parameter

Enables or disables scrolling in an Axis.

Remarks

  • When the axis is a categorical axis and the number of data points (or tick marks) do not fit in one screen PowerGadgets will display a scroll bar so the end user can scroll through the data (maintaining the tick mark separation set with the property). This is particularly useful when the labels associated with tick marks are long strings but still important to improve chart's readability or when a particular marker separation is important.

    In some other cases, having a scroll bar associated with the axis is not desired and you can use this property to force PowerGadgets to display all data points in one screen. If you have a large number of points or long strings associated with tick marks this could affect the chart's readability and you'll need to reset the labels associated with the tick marks in the X axis.

  • To scroll a chart, you may use the keyboard arrows or the drag the scroll thumb with your mouse cursor.

Example

To set the AllSeries AxisX AutoScroll:

Out-Chart -AllSeries_AxisX_AutoScroll true

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_CustomGridLines_<index> property of Axis Parameter

AllSeries_AxisX_CustomGridLines_<index> Parameter

Gets the collection of CustomGridLines that belong to the Chart.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the that they are assigned to.

Example

To set the AllSeries AxisX CustomGridLines Value:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


CustomGridLine Class Members

Chart_AllSeries_AxisX_CustomGridLines Parameters

Parameters

Description

Alignment | Sets or get the Alignment for the Label in the CustomGridLine.
Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
Font | Sets the Font utilized for the Label within the CustomGridLine.
LineAlignment | Sets the alignment for the Text line relative to the CustomeGridLine.
OutsideText | Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.
ShowLine | Set the ShowLine, which shows or hides the CustomGridLine line.
ShowText | Set the Showtext, which shows or hides the CustomGridLine text.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Text | Set the Text for a label in a CustomGridLine.
TextColor | Set the Text Colot for a label in a CustomGridLine.
Value | Sets the Value for the CustomGridLine;
Width | Sets the line width for a selected line.


AllSeries_AxisX_CustomGridLines_<index>_Alignment property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_Alignment Parameter

Sets or get the Alignment for the Label in the CustomGridLine.

Remarks

  • The Alignment will position the CustomGridLine Label in the desired location.

  • The possible values are Center, Far, Near.

  • This property will also take effect, if set to Far or Near, when the OutsideText is the to true.

  • For more information on StringAlignment see the PowerShell documentation.

Example

To set the AllSeries AxisX CustomGridLines Alignment:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Alignment Center

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Color property of Line Parameter

AllSeries_AxisX_CustomGridLines_<index>_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX CustomGridLines Color:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Color Red

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_EndCap property of Line Parameter

AllSeries_AxisX_CustomGridLines_<index>_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX CustomGridLines EndCap:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Font property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_Font Parameter

Sets the Font utilized for the Label within the CustomGridLine.

Remarks

  • When setting a font for a CustomGridLine label, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=Italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

  • You can set the font for the entire chart using the Parameter property.

Example

To set the AllSeries AxisX CustomGridLines Font:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Font "Arial, 8, style=Bold"

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_LineAlignment property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_LineAlignment Parameter

Sets the alignment for the Text line relative to the CustomeGridLine.

Remarks

  • The LineAlignment will position the Text label line in the desired location.

  • he possible values are Center, Far, Near.

  • This property will also take effect when the OutsideText is the to true.

Example

To set the AllSeries AxisX CustomGridLines LineAlignment:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_LineAlignment Center

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_OutsideText property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_OutsideText Parameter

Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.

Remarks

  • When this property is set to True, the text associated with the CustomGridLine is placed outside the charting area.

  • Alignment and LineAlignment settings will still apply when this proprty is set to true.

  • In the following chart, the constant line text is set as OutsideText:

Example

To set the AllSeries AxisX CustomGridLines OutsideText:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_OutsideText true

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_ShowLine property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_ShowLine Parameter

Set the ShowLine, which shows or hides the CustomGridLine line.

Remarks

  • When you hide a CustomGridLine line using this property, any text associated with the line will remain in the chart. Use the ShowText property to show or hide the CustomGridLine text.

Example

To set the AllSeries AxisX CustomGridLines ShowLine:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_ShowLine false

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_ShowText property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_ShowText Parameter

Set the Showtext, which shows or hides the CustomGridLine text.

Remarks

  • When you hide a CustomGridLine test using this property, any Line associated will remain in the chart. Use the ShowLine property to show or hide the CustomGridLine line.

Example

To set the AllSeries AxisX CustomGridLines ShowText:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_ShowText false

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_StartCap property of Line Parameter

AllSeries_AxisX_CustomGridLines_<index>_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX CustomGridLines StartCap:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Style property of Line Parameter

AllSeries_AxisX_CustomGridLines_<index>_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the AllSeries AxisX CustomGridLines Style:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Style DashDot

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Text property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_Text Parameter

Set the Text for a label in a CustomGridLine.

Remarks

  • When the CustomGridLine line is associated with any of the Y axes, the default text alignment is Near (Left). On the other hand, if the label is associated with the X axis the default text alignment is Near (bottom). You can modify the text alignment with the Alignment property.

  • To change the font for the text laber in the CustomGridLine, use the Font property.

  • To change the text color using the TextColor property.

Example

To set the AllSeries AxisX CustomGridLines Text:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "My Custom Line"

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_TextColor property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_TextColor Parameter

Set the Text Colot for a label in a CustomGridLine.

Remarks

  • The TextColor property is used to set a color for the specified customGridLine.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX CustomGridLines TextColor:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_TextColor Red

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Value property of CustomGridLine Parameter

AllSeries_AxisX_CustomGridLines_<index>_Value Parameter

Sets the Value for the CustomGridLine;

Remarks

  • The value of the CustomGridLine goes in strict relationship with the Axis scale that is related to, as follows:

    - If the CustomGridLine is associated with a numerical axis, the value of the constant is a double according to the scale values set for that particular axis. Please remember a CustomGridLine may be associated to the X axis in an XY Plot where the X axis is a numerical axis with specific scale values.

    - If the CustomGridLine is associated with a categorical axis (X axis in charts other than XY Plots), the value is an integer specifying the point index you want to associate the CustomGridLine to. In these cases, the constant line will be drawn starting at the Major tick mark for the selected point.

  • Please note that if you set a CustomGridLine out of the range of the visible axis scale values, PowerGadgets will not recalculate the scale and you must set the Min and Max accordingly so the constant line can be seen.

    For example, if you set a value of 1000 for a constant line in the Y axis, while the Y axis scale is from 0 to 500. The constant line will not be visible and you must set a new maximum value using the Max parameter.

Example

To set the AllSeries AxisX CustomGridLines Value:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Value 5

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomGridLines_<index>_Width property of Line Parameter

AllSeries_AxisX_CustomGridLines_<index>_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the AllSeries AxisX CustomGridLines Width:

Out-Chart -AllSeries_AxisX_CustomGridLines_0_Value 5 -AllSeries_AxisX_CustomGridLines_0_Text "Custom Line" -AllSeries_AxisX_CustomGridLines_0_Width 5

See Also

Chart_AllSeries_AxisX_CustomGridLines Parameter | Chart_AllSeries_AxisX_CustomGridLines Summary


AllSeries_AxisX_CustomSteps property of Axis Parameter

AllSeries_AxisX_CustomSteps Parameter

Allows you to set a custom step for the selected axis.

Remarks

  • The CustomSteps property holds an array of numbers (double) that specifies a series of step values for the selected axis.

  • The step applied to the axis will begin to cycle if your chart contains enough points. For example, if you set the CustomStep to (5,10,20,30) the axis step would look like:

    0,5,15,35,65,70,80,100,130,135,...

Example

To set the AllSeries AxisX CustomSteps:

Out-Chart -AllSeries_AxisX_CustomSteps 5,10,20

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_DataFormat property of Axis Parameter

AllSeries_AxisX_DataFormat Parameter

Used to format the data displayed on point labels and tool tips shown at a mouseover.

Remarks

  • The LabelsFormat property can be used to format the selected axis labels.

  • Setting this property for the chart will also format data viewed via the PowerGadgets MenuBar.

Example

To set the AllSeries AxisX DataFormat Format:

Out-Chart -AllSeries_AxisX_DataFormat_Format Currency

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


ValueFormat Class Members

Chart_AllSeries_AxisX_DataFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AllSeries_AxisX_DataFormat_Culture property of ValueFormat Parameter

AllSeries_AxisX_DataFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

Out-Chart -AxisY_LabelsFormat_Culture "es-ES"

To set the X Axis labels culture to use "Chinese - China" as the Language-Country/Region:

See Also

Chart_AllSeries_AxisX_DataFormat Parameter | Chart_AllSeries_AxisX_DataFormat Summary


AllSeries_AxisX_DataFormat_CustomFormat property of ValueFormat Parameter

AllSeries_AxisX_DataFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

To set the AllSeries AxisX DataFormat CustomFormat:

Out-Chart -AllSeries_AxisX_DataFormat_CustomFormat "MMM-yy"

See Also

Chart_AllSeries_AxisX_DataFormat Parameter | Chart_AllSeries_AxisX_DataFormat Summary


AllSeries_AxisX_DataFormat_Decimals property of ValueFormat Parameter

AllSeries_AxisX_DataFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the AllSeries AxisX DataFormat Decimals:

Out-Chart -AllSeries_AxisX_DataFormat_Decimals 3

See Also

Chart_AllSeries_AxisX_DataFormat Parameter | Chart_AllSeries_AxisX_DataFormat Summary


AllSeries_AxisX_DataFormat_Format property of ValueFormat Parameter

AllSeries_AxisX_DataFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

Out-Chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisX_DataFormat Parameter | Chart_AllSeries_AxisX_DataFormat Summary


AllSeries_AxisX_FirstLabel property of Axis Parameter

AllSeries_AxisX_FirstLabel Parameter

Sets a value used to customize the first label displayed on a selected axis.

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the AllSeries AxisX FirstLabel:

Out-Chart -AllSeries_AxisX_FirstLabel 3

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Font property of Axis Parameter

AllSeries_AxisX_Font Parameter

Allows you to change the label Font attributes of the selected axis.

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Property of the object.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the PowerShell Documentation.

Example

To set the AllSeries AxisX Font:

Out-Chart -AllSeries_AxisX_Font "Arial, 14"

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_ForceZero property of Axis Parameter

AllSeries_AxisX_ForceZero Parameter

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

Remarks

  • By default, PowerGadgets will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want PowerGadgets to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Example

To set the AllSeries AxisX ForceZero:

Out-Chart -AllSeries_AxisX_ForceZero false

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Grids property of AxisSectionBase Parameter

AllSeries_AxisX_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

Out-Chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


Grids Class Members

Chart_AllSeries_AxisX_Grids Parameters

Parameters

Description

Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
InterlacedColor | Sets the AlternateColor for a selected Grids object.
Major | Provides access to the GridLine to customize the Mayor Grid.
Minor | Provides access to the GridLine to customize the Minor Grid.


AllSeries_AxisX_Grids_Interlaced property of Grids Parameter

AllSeries_AxisX_Grids_Interlaced Parameter

Creates a grid of alternating colors for a selected axis to improve chart readability.

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

Example

To set the AllSeries AxisX Grids Interlaced:

Out-Chart -AllSeries_AxisX_Grids_Interlaced true

See Also

Chart_AllSeries_AxisX_Grids Parameter | Chart_AllSeries_AxisX_Grids Summary


AllSeries_AxisX_Grids_InterlacedColor property of Grids Parameter

AllSeries_AxisX_Grids_InterlacedColor Parameter

Sets the AlternateColor for a selected Grids object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX Grids InterlacedColor:

Out-Chart -AllSeries_AxisX_Grids_InterlacedColor Red

See Also

Chart_AllSeries_AxisX_Grids Parameter | Chart_AllSeries_AxisX_Grids Summary


AllSeries_AxisX_Grids_Major property of Grids Parameter

AllSeries_AxisX_Grids_Major Parameter

Provides access to the GridLine class to customize the Mayor Grid.

Remarks

  • The Major interval is controlled by the Axis Step parameter.

Example

To set the AllSeries AxisX Grids Major Visible:

Out-Chart -AllSeries_AxisX_Grids_Major_visible false

See Also

Chart_AllSeries_AxisX_Grids Parameter | Chart_AllSeries_AxisX_Grids Summary


GridLine Class Members

Chart_AllSeries_AxisX_Grids_Major Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AllSeries_AxisX_Grids_Major_Color property of Line Parameter

AllSeries_AxisX_Grids_Major_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX Grids Major Color:

Out-Chart -AllSeries_AxisX_Grids_Major_Color Red

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_EndCap property of Line Parameter

AllSeries_AxisX_Grids_Major_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Grids Major EndCap:

Out-Chart -AllSeries_AxisX_Grids_Major_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_StartCap property of Line Parameter

AllSeries_AxisX_Grids_Major_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Grids Major StartCap:

Out-Chart -AllSeries_AxisX_Grids_Major_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_Style property of Line Parameter

AllSeries_AxisX_Grids_Major_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the AllSeries AxisX Grids Major Style:

Out-Chart -AllSeries_AxisX_Grids_Major_Style DashDot

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_TickMark property of GridLine Parameter

AllSeries_AxisX_Grids_Major_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To set the AllSeries AxisX Grids Major TickMark:

Out-Chart -AllSeries_AxisX_Grids_Major_TickMark Cross

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_Visible property of GridLine Parameter

AllSeries_AxisX_Grids_Major_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To set the AllSeries AxisX Grids Major Visible:

Out-Chart -AllSeries_AxisX_Grids_Major_Visible false

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Major_Width property of Line Parameter

AllSeries_AxisX_Grids_Major_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the AllSeries AxisX Grids Major Width:

Out-Chart -AllSeries_AxisX_Grids_Major_Width 5

See Also

Chart_AllSeries_AxisX_Grids_Major Parameter | Chart_AllSeries_AxisX_Grids_Major Summary


AllSeries_AxisX_Grids_Minor property of Grids Parameter

AllSeries_AxisX_Grids_Minor Parameter

Provides access to the GridLine class to customize the Minor Grid.

Remarks

  • The minor interval is controlled by the MinorStep parameter, which must be set in order to use the Minor Grid.

  • The minor interval is controlled by the Property, which must be set in order to use the Minor Grid.

Example

To set the AllSeries AxisX Grids Minor:

Out-Chart -AllSeries_AxisX_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisX_Grids Parameter | Chart_AllSeries_AxisX_Grids Summary


GridLine Class Members

Chart_AllSeries_AxisX_Grids_Minor Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AllSeries_AxisX_Grids_Minor_Color property of Line Parameter

AllSeries_AxisX_Grids_Minor_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX Grids Minor Color:

Out-Chart -AllSeries_AxisX_Grids_Minor_Color Red

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_EndCap property of Line Parameter

AllSeries_AxisX_Grids_Minor_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Grids Minor EndCap:

Out-Chart -AllSeries_AxisX_Grids_Minor_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_StartCap property of Line Parameter

AllSeries_AxisX_Grids_Minor_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Grids Minor StartCap:

Out-Chart -AllSeries_AxisX_Grids_Minor_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_Style property of Line Parameter

AllSeries_AxisX_Grids_Minor_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the AllSeries AxisX Grids Minor Style:

Out-Chart -AllSeries_AxisX_Grids_Minor_Style DashDot

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_TickMark property of GridLine Parameter

AllSeries_AxisX_Grids_Minor_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To set the AllSeries AxisX Grids Minor TickMark:

Out-Chart -AllSeries_AxisX_Grids_Minor_TickMark Cross

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_Visible property of GridLine Parameter

AllSeries_AxisX_Grids_Minor_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To set the AllSeries AxisX Grids Minor Visible:

Out-Chart -AllSeries_AxisX_Grids_Minor_Visible false

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Grids_Minor_Width property of Line Parameter

AllSeries_AxisX_Grids_Minor_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the AllSeries AxisX Grids Minor Width:

Out-Chart -AllSeries_AxisX_Grids_Minor_Width 5

See Also

Chart_AllSeries_AxisX_Grids_Minor Parameter | Chart_AllSeries_AxisX_Grids_Minor Summary


AllSeries_AxisX_Inverted property of Axis Parameter

AllSeries_AxisX_Inverted Parameter

Sets a selected numerical axis max value lesser than the min value.

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the X Axis in an XY plot chart. In an XY plot, the X Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

Example

To set the AllSeries AxisX Inverted:

Out-Chart -AllSeries_AxisX_Inverted true

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_KeyLabels property of Axis Parameter

AllSeries_AxisX_KeyLabels Parameter

Used to assign a key (short) legend to tickmarks in a categorical axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index specifying the tickmark you want to assign the key legend.

Remarks

  • You normally use the Labels property to assign labels to the tickmarks in the X axis (when it is categorical). However, depending on the amount of points in the chart, these labels may be too long to properly fit in the space allotted for each tickmark in the X axis.

  • You can control the frequency or how labels are displayed with other properties supported by the Axis object, sometimes you still have space limitations because of the size of the chart or the number of points.

  • This property can help you display shorter labels in the X axis while maintaining longer labels in the legend window. Let's give you an example:

    Let's suppose you have assigned the following labels to the X axis using the Label property:

    "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"

    Now, these labels may or may not fit in the space allotted for each tickmark in the X axis. If one of them does not fit, PowerGadgets will immediately display a TAG (red number) indicating that such label can not fit in the space allotted for it. This problem increases as the number of points in the chart increase.

    With this property you can assign key labels (shorter strings) like: "Jan","Feb","Mar",Apr", etc... that will be displayed in the X axis itself, while the Legend window will display both the Key Legend and the Legend set with the Label property.

Example

To set the AllSeries AxisX KeyLabels:

Out-Chart -AllSeries_AxisX_KeyLabels "Key Label"

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_LabelAngle property of Axis Parameter

AllSeries_AxisX_LabelAngle Parameter

Sets the text rotation for the labels in the selected axis.

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the property of the Parameter.

Example

To set the AllSeries AxisX LabelAngle:

Out-Chart -AllSeries_AxisX_LabelAngle 90

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Labels property of Axis Parameter

AllSeries_AxisX_Labels Parameter

Allows you to get or set tick marks labels for the selected axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index indicating the Label index for the axis.

Remarks

  • This property is used to read or write labels for a categorical axis. Normally, the X axis is a categorical axis containing labels associated with each major tick mark, while the Y axis is a numerical axis where labels are controlled by the scale (Min, Max, etc) and numerical data contained in the chart.

  • You can set as many labels as points are available in the chart. These labels will be shown in the major tick marks of the selected axis. Some of them can be left empty so no labels are shown on that specific major tick mark.

  • You can control how frequent these labels are displayed by using the Step property. Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

  • By default, PowerGadgets does not associate any labels to the categorical axis (X axis) and a "TAG" number will be shown. When you use this property, the TAG numbers will be replaced by settings specified in this property.

  • When used in conjunction with the LabelValue property, this property can be used to set string values to a numerical axis.

Example

To set the AllSeries AxisX Labels:

Out-Chart -AllSeries_AxisX_Labels "Custom Label"

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_LabelsFormat property of Axis Parameter

AllSeries_AxisX_LabelsFormat Parameter

Used to format the labels displayed on the selected axis.

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Example

To set the AllSeries AxisX LabelsFormat Format:

Out-Chart -AllSeries_AxisX_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


ValueFormat Class Members

Chart_AllSeries_AxisX_LabelsFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AllSeries_AxisX_LabelsFormat_Culture property of ValueFormat Parameter

AllSeries_AxisX_LabelsFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

Out-Chart -AxisY_LabelsFormat_Culture "es-ES"

To set the X Axis labels culture to use "Chinese - China" as the Language-Country/Region:

See Also

Chart_AllSeries_AxisX_LabelsFormat Parameter | Chart_AllSeries_AxisX_LabelsFormat Summary


AllSeries_AxisX_LabelsFormat_CustomFormat property of ValueFormat Parameter

AllSeries_AxisX_LabelsFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

To set the AllSeries AxisX LabelsFormat CustomFormat:

Out-Chart -AllSeries_AxisX_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AllSeries_AxisX_LabelsFormat Parameter | Chart_AllSeries_AxisX_LabelsFormat Summary


AllSeries_AxisX_LabelsFormat_Decimals property of ValueFormat Parameter

AllSeries_AxisX_LabelsFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the AllSeries AxisX LabelsFormat Decimals:

out-chart -AllSeries_AxisX_LabelsFormat_Decimals 3

See Also

Chart_AllSeries_AxisX_LabelsFormat Parameter | Chart_AllSeries_AxisX_LabelsFormat Summary


AllSeries_AxisX_LabelsFormat_Format property of ValueFormat Parameter

AllSeries_AxisX_LabelsFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisX_LabelsFormat Parameter | Chart_AllSeries_AxisX_LabelsFormat Summary


AllSeries_AxisX_LabelValue property of Axis Parameter

AllSeries_AxisX_LabelValue Parameter

Allows you to set associate text labels to major tick marks in a numerical axis.This property can get or set the LabelValue assigned to any of the axes.

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the Y axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default PowerGadgets will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the Y axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 PowerGadgets will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

Example

To set the AllSeries AxisX LabelValue:

out-chart -AllSeries_AxisX_LabelValue 25

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Line property of Axis Parameter

AllSeries_AxisX_Line Parameter

Allows you to apply supported Line class members to a selected axis line.

Remarks

  • You may control the , and of the selected line using the supported members of the Line Parameter.

  • The and properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the Y axis line color to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


Line Class Members

Chart_AllSeries_AxisX_Line Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Width | Sets the line width for a selected line.


AllSeries_AxisX_Line_Color property of Line Parameter

AllSeries_AxisX_Line_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries AxisX Line Color:

out-chart -AllSeries_AxisX_Line_Color Red

See Also

Chart_AllSeries_AxisX_Line Parameter | Chart_AllSeries_AxisX_Line Summary


AllSeries_AxisX_Line_EndCap property of Line Parameter

AllSeries_AxisX_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Line EndCap:

out-chart -AllSeries_AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Line Parameter | Chart_AllSeries_AxisX_Line Summary


AllSeries_AxisX_Line_StartCap property of Line Parameter

AllSeries_AxisX_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

To set the AllSeries AxisX Line StartCap:

out-chart -AllSeries_AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisX_Line Parameter | Chart_AllSeries_AxisX_Line Summary


AllSeries_AxisX_Line_Style property of Line Parameter

AllSeries_AxisX_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_AxisX_Line Parameter | Chart_AllSeries_AxisX_Line Summary


AllSeries_AxisX_Line_Width property of Line Parameter

AllSeries_AxisX_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_AxisX_Line Parameter | Chart_AllSeries_AxisX_Line Summary


AllSeries_AxisX_LineSpacing property of Axis Parameter

AllSeries_AxisX_LineSpacing Parameter

Sets a value indicating the LineSpacing for an axis.

Remarks

  • This property specifies the LineSpacing for vertical axes. The labels in the selected axis will never be painted less than the configured LineSpacing.

  • Setting the LineSpacing property to 2 will instruct the axis to use double line spacing. Setting the value to 1 instructs the chart to use single line spacing. The default value is 1.5.

Example

To configure an Axis to use double line spacing:

out-chart -AxisY_LineSpacing 2

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_LogBase property of Axis Parameter

AllSeries_AxisX_LogBase Parameter

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

Example

To set a Logarithmic scale and recalculate values as powers of 10 in the primary Y axis:

out-chart -AxisY_LogBase 10

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Max property of Axis Parameter

AllSeries_AxisX_Max Parameter

Defines the maximum value of a specific axis.Sets the Max value assigned to the specified axis.

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, PowerGadgets will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Example

To set the Max value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Min property of Axis Parameter

AllSeries_AxisX_Min Parameter

Defines the minimum value of a selected axis.Sets the Min value assigned to the specified axis.

Remarks

  • The Min property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Min property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Min property.

  • If no Min value is specified, PowerGadgets will automatically set a minimum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Min property must be lesser than the value of the Max property.

  • There is no automatic method for aligning a main and secondary axis, it is required that you set the Min and Max in order to align them manually. The generic algorithm used to find these values is the following:

Example

To set the Min value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_MinorStep property of Axis Parameter

AllSeries_AxisX_MinorStep Parameter

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the minor interval of the primary Y axis to 2:

out-chart -AxisY_MinorStep 2

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_PixelsPerUnit property of Axis Parameter

AllSeries_AxisX_PixelsPerUnit Parameter

Gives you the ability to control how many pixels per unit are there in the selected axis.This property is very useful if you want a scroll bar in the selected axis.

Remarks

  • The does not support scrolling capabilities. Therefore, this property is not supported for the Secondary Y axis.

  • If the AutoScroll property is set to False, the PixelsPerUint will not have any effect on the axis. So make sure the AutoScroll property is set to True when using the PixelsPerUint property.

Example

To separate tick marks in the X axis by 60 pixels:

out-chart -AxisX_AutoScroll true -AxisX_PixelsPerUnit 60

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Position property of Axis Parameter

AllSeries_AxisX_Position Parameter

Specifies the placement of the axis labels and tick marks relative to the chart.

Value | Meaning
Near | Specifies the axis line be placed near the chart in the following way: In a X axis, the axis line be below the chart. In Y axis, the axis line be left to the chart.
Center | Specifies that axis line placed in the center of the chart.
Far | Specifies that axis line is placed far from the chart in the following way: In a X axis, the axis line be above the chart. In a Y axis, the axis line is right to the chart.

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Multiple axes may be created using the AxesX and the properties of the Parameter.

Example

To move the labels and tick marks for the X and Y axes to the top and right of the chart:

out-chart -AxisX_Position Far -AxisY_Position Far

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_ScaleUnit property of Axis Parameter

AllSeries_AxisX_ScaleUnit Parameter

Returns or sets the scale unit of a selected axis.

Remarks

  • This constant is very useful when the values used on the Y axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the Y axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Example

To set the Scale Unit of the primary Y axis to 1000:

out-chart -AxisY_ScaleUnit 1000

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_ScrollPosition property of Axis Parameter

AllSeries_AxisX_ScrollPosition Parameter

Allows you to set the starting scroll position when a chart is scrollable.

Remarks

  • Your chart must be set to AutoScroll in order for this property to be used properly.

  • When you set the ScrollPosition, the first point included in the chart will be the configured point.

Example

Set the scroll position for the X axis to 50:

out-chart -AxisX_ScrollPosition 50

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Sections_<index> property of Axis Parameter

AllSeries_AxisX_Sections_<index> Parameter

Returns a selected AxisSection object.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection Parameter. Please see the Parameter for additional information regarding those supported members.

Example

To set the To value for a selected AxisSection object:

out-chart -AxisY_Sections_0_To 25

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AxisSection Class Members

Chart_AllSeries_AxisX_Sections Parameters

Parameters

Description

BackColor | Sets the AxisSection background color.
FontStyle | Sets additional font attributes to the axis section.
From | Sets a value indicating the beginning value of the range for a selected object.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Text | Sets the text string for a selected BaseAxisSection object.
TextColor | Sets the color for text of a selected BaseAxisSection object.
To | Sets a value indicating the ending value of the range the axis section.
Visible | Shows or hides the selected axis section.


AllSeries_AxisX_Sections_<index>_BackColor property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_BackColor Parameter

Sets the AxisSection background color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Changes the background color of the first section of to yellow:

out-chart -AxisY_Sections_0_BackColor Yellow

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_FontStyle property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_FontStyle Parameter

Sets additional font attributes to the axis section.

Remarks

Example

Specifies that the text associated with the first AxisSection object of the will be bold:

out-chart -AxisY_Sections_0_FontStyle Bold

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_From property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_From Parameter

Sets a value indicating the beginning value of the range for a selected AxisSection object.

Remarks

  • The To property is used to specify the ending value of the section range for a selected Axis Section.

  • The To property is used to specify the ending value of the section range for a selected object.

Example

To configure the From value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_From 30

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_Grids property of AxisSectionBase Parameter

AllSeries_AxisX_Sections_<index>_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_Text property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_Text Parameter

Sets the text string for a selected BaseAxisSection object.

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Example

To set text to a section, SampleSection:

out-chart -AxisY_Sections_0_Text "SampleText"

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_TextColor property of AxisSectionBase Parameter

AllSeries_AxisX_Sections_<index>_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_To property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_To Parameter

Sets a value indicating the ending value of the range the axis section.

Remarks

  • The From property is used to specify the beginning value of the section range for a selected Axis Section.

Example

To configure the To value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_To 60

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Sections_<index>_Visible property of AxisSection Parameter

AllSeries_AxisX_Sections_<index>_Visible Parameter

Shows or hides the selected axis section.

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Example

To hide the axis section:

out-chart -AxisY_Sections_0_Visible false

See Also

Chart_AllSeries_AxisX_Sections Parameter | Chart_AllSeries_AxisX_Sections Summary


AllSeries_AxisX_Separation property of Axis Parameter

AllSeries_AxisX_Separation Parameter

Allows you to specify a gap in pixels between multiple axis.

Remarks

  • This property is useful when multiple axes are configured and you need to create space for readability.

Example

To configure a 5 pixel separation on the secondary Y axis:

out-chart -AxisY_Separation 5

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Staggered property of Axis Parameter

AllSeries_AxisX_Staggered Parameter

Alternates the level of the axis labels for the selected axis labels.

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

Example

To stagger axis labels on two levels:

out-chart -AxisX_Staggered true

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Step property of Axis Parameter

AllSeries_AxisX_Step Parameter

Specifies the interval of major tick marks and gridlines on the selected axis.It also controls the gap or interval between labels in the selected axis.

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your X axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, PowerGadgets will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the major interval of the primary Y axis to 50:

out-chart -AxisY_Step 50

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Style property of Axis Parameter

AllSeries_AxisX_Style Parameter

Allows you to add additional styles to the selected axis.

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use + sign to add (bitwise Or) the property, and - sign to remove (bitwise And Not) propety.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Example

To set an interlaced Grid and Hide Labels in the primary Y Axis:

out-chart -AxisY_Style +HideText

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_TextColor property of AxisSectionBase Parameter

AllSeries_AxisX_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisX_Title property of Axis Parameter

AllSeries_AxisX_Title Parameter

Sets the title for a specific axis.

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Parameter. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's property.

  • Below is a chart with both X and Y Axis titles:

Example

This sample sets the "Unit Sales (In millions)" to the Y Axis:

out-chart -AxisY_Title_Text "Unit Sales (In Millions)"

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


Title Class Members

Chart_AllSeries_AxisX_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AllSeries_AxisX_Title_Alignment property of Title Parameter

AllSeries_AxisX_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_BackColor property of Title Parameter

AllSeries_AxisX_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_Font property of Title Parameter

AllSeries_AxisX_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_Indentation property of Title Parameter

AllSeries_AxisX_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_LineAlignment property of Title Parameter

AllSeries_AxisX_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_PlotAreaOnly property of TitleDockable Parameter

AllSeries_AxisX_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_RichText property of Title Parameter

AllSeries_AxisX_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_Separation property of Title Parameter

AllSeries_AxisX_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_Text property of Title Parameter

AllSeries_AxisX_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Title_TextColor property of Title Parameter

AllSeries_AxisX_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AllSeries_AxisX_Title Parameter | Chart_AllSeries_AxisX_Title Summary


AllSeries_AxisX_Visible property of Axis Parameter

AllSeries_AxisX_Visible Parameter

Shows or hides the lines, labels, tick marks and grids for the selected axis.

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the and tick marks are also hidden.

Example

To hide the X axis labels:

out-chart -AxisX_Visible false

See Also

Chart_AllSeries_AxisX Parameter | Chart_AllSeries_AxisX Summary


AllSeries_AxisY property of GlobalAttributes Parameter

AllSeries_AxisY Parameter

Assigns properties specifically to the Y axis.

Remarks

  • The AxisY property allows developers to assign attributes directly to the Y axis object, use the AxisX property for the primary X axis.

Example

Assign 4 decimal places to the Y axis labels:

out-chart -AxisY_LabelsFormat_Decimals 4

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AxisY Class Members

Chart_AllSeries_AxisY Parameters

Parameters

Description

AutoScale | Instructs PowerGadgets to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.
AutoScroll | Enables or disables scrolling in an Axis.
CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
CustomSteps | Allows you to set a custom step for the selected axis.
DataFormat | Used to format the data displayed on point labels and tool tips shown at a mouseover.
FirstLabel | Sets a value used to customize the first label displayed on a selected axis.
Font | Allows you to change the label Font attributes of the selected axis.
ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Inverted | Sets a selected numerical axis max value lesser than the min value.
KeyLabels | Used to assign a key (short) legend to tickmarks in a categorical axis.
LabelAngle | Sets the text rotation for the labels in the selected axis.
Labels | Allows you to get or set tick marks labels for the selected axis.
LabelsFormat | Used to format the labels displayed on the selected axis.
LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
Line | Allows you to apply supported Line members to a selected axis line.
LineSpacing | Sets a value indicating the LineSpacing for an axis.
LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
Max | Defines the maximum value of a specific axis.
Min | Defines the minimum value of a selected axis.
MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
Pane | Sets an integer value specifying the Pane for an Y Axis object.
PixelsPerUnit | Gives you the ability to control how many pixels per unit are there in the selected axis.
Position | Specifies the placement of the axis labels and tick marks relative to the chart.
ScaleUnit | Returns or sets the scale unit of a selected axis.
ScrollPosition | Allows you to set the starting scroll position when a chart is scrollable.
Sections | Returns a selected AxisSection object.
Separation | Allows you to specify a gap in pixels between multiple axis.
Staggered | Alternates the level of the axis labels for the selected axis labels.
Step | Specifies the interval of major tick marks and gridlines on the selected axis.
Style | Allows you to add additional styles to the selected axis.
TextColor | Sets the color for text of a selected BaseAxisSection object.
Title | Sets the title for a specific axis.
Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AllSeries_AxisY_AutoScale property of Axis Parameter

AllSeries_AxisY_AutoScale Parameter

Instructs Chart FX to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.

Remarks

  • If you set a Min or Max value and new data is received by the chart when the AutoScale property is enabled, the scale values will be overwritten by PowerGadgets . This method will not affect the Step property if it has previously set to a specific value. If you want the AutoScale property to recalculate the Step value, make sure the Step property is set to zero (0).

Example

To enable the AutoScale feature for the primary Y axis:

out-chart -AxisY_AutoScale true

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_AutoScroll property of Axis Parameter

AllSeries_AxisY_AutoScroll Parameter

Enables or disables scrolling in an Axis.

Remarks

  • When the axis is a categorical axis and the number of data points (or tick marks) do not fit in one screen PowerGadgets will display a scroll bar so the end user can scroll through the data (maintaining the tick mark separation set with the property). This is particularly useful when the labels associated with tick marks are long strings but still important to improve chart's readability or when a particular marker separation is important.

    In some other cases, having a scroll bar associated with the axis is not desired and you can use this property to force PowerGadgets to display all data points in one screen. If you have a large number of points or long strings associated with tick marks this could affect the chart's readability and you'll need to reset the labels associated with the tick marks in the X axis.

  • To scroll a chart, you may use the keyboard arrows or the drag the scroll thumb with your mouse cursor.

Example

To enable chart scrolling in the X axis:

out-chart -AxisX_AutoScroll true

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_CustomGridLines_<index> property of Axis Parameter

AllSeries_AxisY_CustomGridLines_<index> Parameter

Gets the collection of CustomGridLines that belong to the Chart.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the that they are assigned to.

Example

The following example show how to create a CustomGridLine on the Y Axis, located at 100 and with a "Upper Limit" text:

out-chart -AxisY_CustomGridLines_0_Value 100 -AxisY_CustomGridLines_0_Text "Upper Limit"

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


CustomGridLine Class Members

Chart_AllSeries_AxisY_CustomGridLines Parameters

Parameters

Description

Alignment | Sets or get the Alignment for the Label in the CustomGridLine.
Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
Font | Sets the Font utilized for the Label within the CustomGridLine.
LineAlignment | Sets the alignment for the Text line relative to the CustomeGridLine.
OutsideText | Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.
ShowLine | Set the ShowLine, which shows or hides the CustomGridLine line.
ShowText | Set the Showtext, which shows or hides the CustomGridLine text.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Text | Set the Text for a label in a CustomGridLine.
TextColor | Set the Text Colot for a label in a CustomGridLine.
Value | Sets the Value for the CustomGridLine;
Width | Sets the line width for a selected line.


AllSeries_AxisY_CustomGridLines_<index>_Alignment property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_Alignment Parameter

Sets or get the Alignment for the Label in the CustomGridLine.

Remarks

  • The Alignment will position the CustomGridLine Label in the desired location.

  • The possible values are Center, Far, Near.

  • This property will also take effect, if set to Far or Near, when the OutsideText is the to true.

  • For more information on StringAlignment see the PowerShell documentation.

Example

To center the CustomGridLine text:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_Alignment Center

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Color property of Line Parameter

AllSeries_AxisY_CustomGridLines_<index>_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_EndCap property of Line Parameter

AllSeries_AxisY_CustomGridLines_<index>_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Font property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_Font Parameter

Sets the Font utilized for the Label within the CustomGridLine.

Remarks

  • When setting a font for a CustomGridLine label, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=Italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

  • You can set the font for the entire chart using the Parameter property.

Example

To center the CustomGridLine text:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_Font "Arial, 14"

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_LineAlignment property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_LineAlignment Parameter

Sets the alignment for the Text line relative to the CustomeGridLine.

Remarks

  • The LineAlignment will position the Text label line in the desired location.

  • he possible values are Center, Far, Near.

  • This property will also take effect when the OutsideText is the to true.

Example

To center the CustomGridLine text Line:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_LineAlignment Center

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_OutsideText property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_OutsideText Parameter

Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.

Remarks

  • When this property is set to True, the text associated with the CustomGridLine is placed outside the charting area.

  • Alignment and LineAlignment settings will still apply when this proprty is set to true.

  • In the following chart, the constant line text is set as OutsideText:

Example

To place the CustomGridLine label outside the Chart area:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_OutsideText true

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_ShowLine property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_ShowLine Parameter

Set the ShowLine, which shows or hides the CustomGridLine line.

Remarks

  • When you hide a CustomGridLine line using this property, any text associated with the line will remain in the chart. Use the ShowText property to show or hide the CustomGridLine text.

Example

To hide the line in a CustomGridLine:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_ShowLine false

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_ShowText property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_ShowText Parameter

Set the Showtext, which shows or hides the CustomGridLine text.

Remarks

  • When you hide a CustomGridLine test using this property, any Line associated will remain in the chart. Use the ShowLine property to show or hide the CustomGridLine line.

Example

To hide the text in a CustomGridLine:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_ShowText false

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_StartCap property of Line Parameter

AllSeries_AxisY_CustomGridLines_<index>_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Style property of Line Parameter

AllSeries_AxisY_CustomGridLines_<index>_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Text property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_Text Parameter

Set the Text for a label in a CustomGridLine.

Remarks

  • When the CustomGridLine line is associated with any of the Y axes, the default text alignment is Near (Left). On the other hand, if the label is associated with the X axis the default text alignment is Near (bottom). You can modify the text alignment with the Alignment property.

  • To change the font for the text laber in the CustomGridLine, use the Font property.

  • To change the text color using the TextColor property.

Example

To add a CustomGridLine with the "Break Even" label in the X Axis:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Break Even"

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_TextColor property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_TextColor Parameter

Set the Text Colot for a label in a CustomGridLine.

Remarks

  • The TextColor property is used to set a color for the specified customGridLine.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the text Color to red:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_TextColor Red

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Value property of CustomGridLine Parameter

AllSeries_AxisY_CustomGridLines_<index>_Value Parameter

Sets the Value for the CustomGridLine;

Remarks

  • The value of the CustomGridLine goes in strict relationship with the Axis scale that is related to, as follows:

    - If the CustomGridLine is associated with a numerical axis, the value of the constant is a double according to the scale values set for that particular axis. Please remember a CustomGridLine may be associated to the X axis in an XY Plot where the X axis is a numerical axis with specific scale values.

    - If the CustomGridLine is associated with a categorical axis (X axis in charts other than XY Plots), the value is an integer specifying the point index you want to associate the CustomGridLine to. In these cases, the constant line will be drawn starting at the Major tick mark for the selected point.

  • Please note that if you set a CustomGridLine out of the range of the visible axis scale values, PowerGadgets will not recalculate the scale and you must set the Min and Max accordingly so the constant line can be seen.

    For example, if you set a value of 1000 for a constant line in the Y axis, while the Y axis scale is from 0 to 500. The constant line will not be visible and you must set a new maximum value using the Max parameter.

Example

To add a CustomGridLine to the Y Axis at 50.75:

out-chart -AxisY_CustomGridLines_0_Value 50.75 -AxisY_CustomGridLines_0_Text "Custom Line"

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomGridLines_<index>_Width property of Line Parameter

AllSeries_AxisY_CustomGridLines_<index>_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_AxisY_CustomGridLines Parameter | Chart_AllSeries_AxisY_CustomGridLines Summary


AllSeries_AxisY_CustomSteps property of Axis Parameter

AllSeries_AxisY_CustomSteps Parameter

Allows you to set a custom step for the selected axis.

Remarks

  • The CustomSteps property holds an array of numbers (double) that specifies a series of step values for the selected axis.

  • The step applied to the axis will begin to cycle if your chart contains enough points. For example, if you set the CustomStep to (5,10,20,30) the axis step would look like:

    0,5,15,35,65,70,80,100,130,135,...

Example

Set a custom step for the Y axis:

out-chart -AxisY_CustomSteps 5,10,20

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_DataFormat property of Axis Parameter

AllSeries_AxisY_DataFormat Parameter

Used to format the data displayed on point labels and tool tips shown at a mouseover.

Remarks

  • The LabelsFormat property can be used to format the selected axis labels.

  • Setting this property for the chart will also format data viewed via the PowerGadgets MenuBar.

Example

To set the data format for the Y axis data values to currency:

out-chart -AxisY_DataFormat_Format Currency

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


ValueFormat Class Members

Chart_AllSeries_AxisY_DataFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AllSeries_AxisY_DataFormat_Culture property of ValueFormat Parameter

AllSeries_AxisY_DataFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisY_LabelsFormat_Culture "es-ES"

See Also

Chart_AllSeries_AxisY_DataFormat Parameter | Chart_AllSeries_AxisY_DataFormat Summary


AllSeries_AxisY_DataFormat_CustomFormat property of ValueFormat Parameter

AllSeries_AxisY_DataFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisX_LabelsFormat_Format Date -AxisX_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AllSeries_AxisY_DataFormat Parameter | Chart_AllSeries_AxisY_DataFormat Summary


AllSeries_AxisY_DataFormat_Decimals property of ValueFormat Parameter

AllSeries_AxisY_DataFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y Axis data values:

out-chart -AxisY_DataFormat_Decimals 3

See Also

Chart_AllSeries_AxisY_DataFormat Parameter | Chart_AllSeries_AxisY_DataFormat Summary


AllSeries_AxisY_DataFormat_Format property of ValueFormat Parameter

AllSeries_AxisY_DataFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisY_DataFormat Parameter | Chart_AllSeries_AxisY_DataFormat Summary


AllSeries_AxisY_FirstLabel property of Axis Parameter

AllSeries_AxisY_FirstLabel Parameter

Sets a value used to customize the first label displayed on a selected axis.

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To make the 3rd point the first label in the X-axis:

out-chart -AxisX_FirstLabel 3

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Font property of Axis Parameter

AllSeries_AxisY_Font Parameter

Allows you to change the label Font attributes of the selected axis.

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Property of the object.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the PowerShell Documentation.

Example

If you want to change the main Y axis labels font settings:

out-chart -AxisY_Font "Arial, 14"

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_ForceZero property of Axis Parameter

AllSeries_AxisY_ForceZero Parameter

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

Remarks

  • By default, PowerGadgets will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want PowerGadgets to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Example

To force PowerGadgets to set the minimum value of the Y axis to the minimum value passed to the chart.

out-chart -AxisY_ForceZero false

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Grids property of AxisSectionBase Parameter

AllSeries_AxisY_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


Grids Class Members

Chart_AllSeries_AxisY_Grids Parameters

Parameters

Description

Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
InterlacedColor | Sets the AlternateColor for a selected Grids object.
Major | Provides access to the GridLine to customize the Mayor Grid.
Minor | Provides access to the GridLine to customize the Minor Grid.


AllSeries_AxisY_Grids_Interlaced property of Grids Parameter

AllSeries_AxisY_Grids_Interlaced Parameter

Creates a grid of alternating colors for a selected axis to improve chart readability.

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

Example

To set an Interlaced grid on the Y Axis:

out-chart -AxisY_Grids_Interlaced true

See Also

Chart_AllSeries_AxisY_Grids Parameter | Chart_AllSeries_AxisY_Grids Summary


AllSeries_AxisY_Grids_InterlacedColor property of Grids Parameter

AllSeries_AxisY_Grids_InterlacedColor Parameter

Sets the AlternateColor for a selected Grids object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To configure the Grids InterleacedColor to red:

out-chart -AxisY_Grids_InterlacedColor Red

See Also

Chart_AllSeries_AxisY_Grids Parameter | Chart_AllSeries_AxisY_Grids Summary


AllSeries_AxisY_Grids_Major property of Grids Parameter

AllSeries_AxisY_Grids_Major Parameter

Provides access to the GridLine class to customize the Mayor Grid.

Remarks

  • The Major interval is controlled by the Axis Step parameter.

Example

To show the Major gridlines for the Y Axis:

out-chart -AxisY_Grids_Major_Visible true

See Also

Chart_AllSeries_AxisY_Grids Parameter | Chart_AllSeries_AxisY_Grids Summary


GridLine Class Members

Chart_AllSeries_AxisY_Grids_Major Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AllSeries_AxisY_Grids_Major_Color property of Line Parameter

AllSeries_AxisY_Grids_Major_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_EndCap property of Line Parameter

AllSeries_AxisY_Grids_Major_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_StartCap property of Line Parameter

AllSeries_AxisY_Grids_Major_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_Style property of Line Parameter

AllSeries_AxisY_Grids_Major_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_TickMark property of GridLine Parameter

AllSeries_AxisY_Grids_Major_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y Axis:

out-chart -AxisY_Grids_Major_TickMark Cross

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_Visible property of GridLine Parameter

AllSeries_AxisY_Grids_Major_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y Axis:

out-chart -AxisY_MinorStep 5 -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Major_Width property of Line Parameter

AllSeries_AxisY_Grids_Major_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_AxisY_Grids_Major Parameter | Chart_AllSeries_AxisY_Grids_Major Summary


AllSeries_AxisY_Grids_Minor property of Grids Parameter

AllSeries_AxisY_Grids_Minor Parameter

Provides access to the GridLine class to customize the Minor Grid.

Remarks

  • The minor interval is controlled by the MinorStep parameter, which must be set in order to use the Minor Grid.

  • The minor interval is controlled by the Property, which must be set in order to use the Minor Grid.

Example

To show the Minor gridlines for the Y Axis:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisY_Grids Parameter | Chart_AllSeries_AxisY_Grids Summary


GridLine Class Members

Chart_AllSeries_AxisY_Grids_Minor Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AllSeries_AxisY_Grids_Minor_Color property of Line Parameter

AllSeries_AxisY_Grids_Minor_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_EndCap property of Line Parameter

AllSeries_AxisY_Grids_Minor_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_StartCap property of Line Parameter

AllSeries_AxisY_Grids_Minor_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_Style property of Line Parameter

AllSeries_AxisY_Grids_Minor_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_TickMark property of GridLine Parameter

AllSeries_AxisY_Grids_Minor_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y Axis:

out-chart -AxisY_Grids_Major_TickMark Cross

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_Visible property of GridLine Parameter

AllSeries_AxisY_Grids_Minor_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y Axis:

out-chart -AxisY_MinorStep 5 -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Grids_Minor_Width property of Line Parameter

AllSeries_AxisY_Grids_Minor_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_AxisY_Grids_Minor Parameter | Chart_AllSeries_AxisY_Grids_Minor Summary


AllSeries_AxisY_Inverted property of Axis Parameter

AllSeries_AxisY_Inverted Parameter

Sets a selected numerical axis max value lesser than the min value.

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the X Axis in an XY plot chart. In an XY plot, the X Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

Example

Set the Y Axis to be inverted:

out-chart -AxisY_Inverted true

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_KeyLabels property of Axis Parameter

AllSeries_AxisY_KeyLabels Parameter

Used to assign a key (short) legend to tickmarks in a categorical axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index specifying the tickmark you want to assign the key legend.

Remarks

  • You normally use the Labels property to assign labels to the tickmarks in the X axis (when it is categorical). However, depending on the amount of points in the chart, these labels may be too long to properly fit in the space allotted for each tickmark in the X axis.

  • You can control the frequency or how labels are displayed with other properties supported by the Axis object, sometimes you still have space limitations because of the size of the chart or the number of points.

  • This property can help you display shorter labels in the X axis while maintaining longer labels in the legend window. Let's give you an example:

    Let's suppose you have assigned the following labels to the X axis using the Label property:

    "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"

    Now, these labels may or may not fit in the space allotted for each tickmark in the X axis. If one of them does not fit, PowerGadgets will immediately display a TAG (red number) indicating that such label can not fit in the space allotted for it. This problem increases as the number of points in the chart increase.

    With this property you can assign key labels (shorter strings) like: "Jan","Feb","Mar",Apr", etc... that will be displayed in the X axis itself, while the Legend window will display both the Key Legend and the Legend set with the Label property.

Example

To assign a key label to the first tickmark in the X axis:

out-chart -AxisX_KeyLabels_0 "Jan"

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_LabelAngle property of Axis Parameter

AllSeries_AxisY_LabelAngle Parameter

Sets the text rotation for the labels in the selected axis.

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the property of the Parameter.

Example

To set vertical text labels in the X Axis:

out-chart -AxisX_LabelAngle 90

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Labels property of Axis Parameter

AllSeries_AxisY_Labels Parameter

Allows you to get or set tick marks labels for the selected axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index indicating the Label index for the axis.

Remarks

  • This property is used to read or write labels for a categorical axis. Normally, the X axis is a categorical axis containing labels associated with each major tick mark, while the Y axis is a numerical axis where labels are controlled by the scale (Min, Max, etc) and numerical data contained in the chart.

  • You can set as many labels as points are available in the chart. These labels will be shown in the major tick marks of the selected axis. Some of them can be left empty so no labels are shown on that specific major tick mark.

  • You can control how frequent these labels are displayed by using the Step property. Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

  • By default, PowerGadgets does not associate any labels to the categorical axis (X axis) and a "TAG" number will be shown. When you use this property, the TAG numbers will be replaced by settings specified in this property.

  • When used in conjunction with the LabelValue property, this property can be used to set string values to a numerical axis.

Example

To modify the Y axis first label for the chart:

out-chart -AxisY_Labels_0 "Custom Label"

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_LabelsFormat property of Axis Parameter

AllSeries_AxisY_LabelsFormat Parameter

Used to format the labels displayed on the selected axis.

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Example

Set the Y Axis labels to the currency format:

out-chart -AxisY_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


ValueFormat Class Members

Chart_AllSeries_AxisY_LabelsFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AllSeries_AxisY_LabelsFormat_Culture property of ValueFormat Parameter

AllSeries_AxisY_LabelsFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisY_LabelsFormat_Culture "es-ES"

See Also

Chart_AllSeries_AxisY_LabelsFormat Parameter | Chart_AllSeries_AxisY_LabelsFormat Summary


AllSeries_AxisY_LabelsFormat_CustomFormat property of ValueFormat Parameter

AllSeries_AxisY_LabelsFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisX_LabelsFormat_Format Date -AxisX_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AllSeries_AxisY_LabelsFormat Parameter | Chart_AllSeries_AxisY_LabelsFormat Summary


AllSeries_AxisY_LabelsFormat_Decimals property of ValueFormat Parameter

AllSeries_AxisY_LabelsFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y Axis data values:

out-chart -AxisY_DataFormat_Decimals 3

See Also

Chart_AllSeries_AxisY_LabelsFormat Parameter | Chart_AllSeries_AxisY_LabelsFormat Summary


AllSeries_AxisY_LabelsFormat_Format property of ValueFormat Parameter

AllSeries_AxisY_LabelsFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AllSeries_AxisY_LabelsFormat Parameter | Chart_AllSeries_AxisY_LabelsFormat Summary


AllSeries_AxisY_LabelValue property of Axis Parameter

AllSeries_AxisY_LabelValue Parameter

Allows you to set associate text labels to major tick marks in a numerical axis.This property can get or set the LabelValue assigned to any of the axes.

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the Y axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default PowerGadgets will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the Y axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 PowerGadgets will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

Example

To set a LabelValue of 25 for the primary Y axis:

out-chart -AxisY_LabelValue 25

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Line property of Axis Parameter

AllSeries_AxisY_Line Parameter

Allows you to apply supported Line class members to a selected axis line.

Remarks

  • You may control the , and of the selected line using the supported members of the Line Parameter.

  • The and properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the Y axis line color to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


Line Class Members

Chart_AllSeries_AxisY_Line Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Width | Sets the line width for a selected line.


AllSeries_AxisY_Line_Color property of Line Parameter

AllSeries_AxisY_Line_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AllSeries_AxisY_Line Parameter | Chart_AllSeries_AxisY_Line Summary


AllSeries_AxisY_Line_EndCap property of Line Parameter

AllSeries_AxisY_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Line Parameter | Chart_AllSeries_AxisY_Line Summary


AllSeries_AxisY_Line_StartCap property of Line Parameter

AllSeries_AxisY_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_AxisY_Line Parameter | Chart_AllSeries_AxisY_Line Summary


AllSeries_AxisY_Line_Style property of Line Parameter

AllSeries_AxisY_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_AxisY_Line Parameter | Chart_AllSeries_AxisY_Line Summary


AllSeries_AxisY_Line_Width property of Line Parameter

AllSeries_AxisY_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_AxisY_Line Parameter | Chart_AllSeries_AxisY_Line Summary


AllSeries_AxisY_LineSpacing property of Axis Parameter

AllSeries_AxisY_LineSpacing Parameter

Sets a value indicating the LineSpacing for an axis.

Remarks

  • This property specifies the LineSpacing for vertical axes. The labels in the selected axis will never be painted less than the configured LineSpacing.

  • Setting the LineSpacing property to 2 will instruct the axis to use double line spacing. Setting the value to 1 instructs the chart to use single line spacing. The default value is 1.5.

Example

To configure an Axis to use double line spacing:

out-chart -AxisY_LineSpacing 2

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_LogBase property of Axis Parameter

AllSeries_AxisY_LogBase Parameter

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

Example

To set a Logarithmic scale and recalculate values as powers of 10 in the primary Y axis:

out-chart -AxisY_LogBase 10

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Max property of Axis Parameter

AllSeries_AxisY_Max Parameter

Defines the maximum value of a specific axis.Sets the Max value assigned to the specified axis.

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, PowerGadgets will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Example

To set the Max value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Min property of Axis Parameter

AllSeries_AxisY_Min Parameter

Defines the minimum value of a selected axis.Sets the Min value assigned to the specified axis.

Remarks

  • The Min property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Min property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Min property.

  • If no Min value is specified, PowerGadgets will automatically set a minimum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Min property must be lesser than the value of the Max property.

  • There is no automatic method for aligning a main and secondary axis, it is required that you set the Min and Max in order to align them manually. The generic algorithm used to find these values is the following:

Example

To set the Min value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_MinorStep property of Axis Parameter

AllSeries_AxisY_MinorStep Parameter

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the minor interval of the primary Y axis to 2:

out-chart -AxisY_MinorStep 2

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Pane property of AxisY Parameter

AllSeries_AxisY_Pane Parameter

Sets an integer value specifying the Pane for an Y Axis object.

Remarks

  • Additional Y axes may be assigned to panes in a chart. Once an Y axis object is assigned to a pane, that pane will be visible in the chart area. Data also associated with the selected Y axis will also be applied to the configured pane.

Example

To set the Y axis Pane BackColor property to blue:

out-chart -AxisY_Pane_BackColor Blue

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_PixelsPerUnit property of Axis Parameter

AllSeries_AxisY_PixelsPerUnit Parameter

Gives you the ability to control how many pixels per unit are there in the selected axis.This property is very useful if you want a scroll bar in the selected axis.

Remarks

  • The does not support scrolling capabilities. Therefore, this property is not supported for the Secondary Y axis.

  • If the AutoScroll property is set to False, the PixelsPerUint will not have any effect on the axis. So make sure the AutoScroll property is set to True when using the PixelsPerUint property.

Example

To separate tick marks in the X axis by 60 pixels:

out-chart -AxisX_AutoScroll true -AxisX_PixelsPerUnit 60

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Position property of Axis Parameter

AllSeries_AxisY_Position Parameter

Specifies the placement of the axis labels and tick marks relative to the chart.

Value | Meaning
Near | Specifies the axis line be placed near the chart in the following way: In a X axis, the axis line be below the chart. In Y axis, the axis line be left to the chart.
Center | Specifies that axis line placed in the center of the chart.
Far | Specifies that axis line is placed far from the chart in the following way: In a X axis, the axis line be above the chart. In a Y axis, the axis line is right to the chart.

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Multiple axes may be created using the AxesX and the properties of the Parameter.

Example

To move the labels and tick marks for the X and Y axes to the top and right of the chart:

out-chart -AxisX_Position Far -AxisY_Position Far

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_ScaleUnit property of Axis Parameter

AllSeries_AxisY_ScaleUnit Parameter

Returns or sets the scale unit of a selected axis.

Remarks

  • This constant is very useful when the values used on the Y axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the Y axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Example

To set the Scale Unit of the primary Y axis to 1000:

out-chart -AxisY_ScaleUnit 1000

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_ScrollPosition property of Axis Parameter

AllSeries_AxisY_ScrollPosition Parameter

Allows you to set the starting scroll position when a chart is scrollable.

Remarks

  • Your chart must be set to AutoScroll in order for this property to be used properly.

  • When you set the ScrollPosition, the first point included in the chart will be the configured point.

Example

Set the scroll position for the X axis to 50:

out-chart -AxisX_ScrollPosition 50

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Sections_<index> property of Axis Parameter

AllSeries_AxisY_Sections_<index> Parameter

Returns a selected AxisSection object.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection Parameter. Please see the Parameter for additional information regarding those supported members.

Example

To set the To value for a selected AxisSection object:

out-chart -AxisY_Sections_0_To 25

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AxisSection Class Members

Chart_AllSeries_AxisY_Sections Parameters

Parameters

Description

BackColor | Sets the AxisSection background color.
FontStyle | Sets additional font attributes to the axis section.
From | Sets a value indicating the beginning value of the range for a selected object.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Text | Sets the text string for a selected BaseAxisSection object.
TextColor | Sets the color for text of a selected BaseAxisSection object.
To | Sets a value indicating the ending value of the range the axis section.
Visible | Shows or hides the selected axis section.


AllSeries_AxisY_Sections_<index>_BackColor property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_BackColor Parameter

Sets the AxisSection background color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Changes the background color of the first section of to yellow:

out-chart -AxisY_Sections_0_BackColor Yellow

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_FontStyle property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_FontStyle Parameter

Sets additional font attributes to the axis section.

Remarks

Example

Specifies that the text associated with the first AxisSection object of the will be bold:

out-chart -AxisY_Sections_0_FontStyle Bold

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_From property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_From Parameter

Sets a value indicating the beginning value of the range for a selected AxisSection object.

Remarks

  • The To property is used to specify the ending value of the section range for a selected Axis Section.

  • The To property is used to specify the ending value of the section range for a selected object.

Example

To configure the From value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_From 30

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_Grids property of AxisSectionBase Parameter

AllSeries_AxisY_Sections_<index>_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_Text property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_Text Parameter

Sets the text string for a selected BaseAxisSection object.

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Example

To set text to a section, SampleSection:

out-chart -AxisY_Sections_0_Text "SampleText"

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_TextColor property of AxisSectionBase Parameter

AllSeries_AxisY_Sections_<index>_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_To property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_To Parameter

Sets a value indicating the ending value of the range the axis section.

Remarks

  • The From property is used to specify the beginning value of the section range for a selected Axis Section.

Example

To configure the To value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_To 60

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Sections_<index>_Visible property of AxisSection Parameter

AllSeries_AxisY_Sections_<index>_Visible Parameter

Shows or hides the selected axis section.

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Example

To hide the axis section:

out-chart -AxisY_Sections_0_Visible false

See Also

Chart_AllSeries_AxisY_Sections Parameter | Chart_AllSeries_AxisY_Sections Summary


AllSeries_AxisY_Separation property of Axis Parameter

AllSeries_AxisY_Separation Parameter

Allows you to specify a gap in pixels between multiple axis.

Remarks

  • This property is useful when multiple axes are configured and you need to create space for readability.

Example

To configure a 5 pixel separation on the secondary Y axis:

out-chart -AxisY_Separation 5

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Staggered property of Axis Parameter

AllSeries_AxisY_Staggered Parameter

Alternates the level of the axis labels for the selected axis labels.

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

Example

To stagger axis labels on two levels:

out-chart -AxisX_Staggered true

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Step property of Axis Parameter

AllSeries_AxisY_Step Parameter

Specifies the interval of major tick marks and gridlines on the selected axis.It also controls the gap or interval between labels in the selected axis.

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your X axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, PowerGadgets will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the major interval of the primary Y axis to 50:

out-chart -AxisY_Step 50

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Style property of Axis Parameter

AllSeries_AxisY_Style Parameter

Allows you to add additional styles to the selected axis.

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use + sign to add (bitwise Or) the property, and - sign to remove (bitwise And Not) propety.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Example

To set an interlaced Grid and Hide Labels in the primary Y Axis:

out-chart -AxisY_Style +HideText

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_TextColor property of AxisSectionBase Parameter

AllSeries_AxisY_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_AxisY_Title property of Axis Parameter

AllSeries_AxisY_Title Parameter

Sets the title for a specific axis.

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Parameter. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's property.

  • Below is a chart with both X and Y Axis titles:

Example

This sample sets the "Unit Sales (In millions)" to the Y Axis:

out-chart -AxisY_Title_Text "Unit Sales (In Millions)"

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


Title Class Members

Chart_AllSeries_AxisY_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AllSeries_AxisY_Title_Alignment property of Title Parameter

AllSeries_AxisY_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_BackColor property of Title Parameter

AllSeries_AxisY_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_Font property of Title Parameter

AllSeries_AxisY_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_Indentation property of Title Parameter

AllSeries_AxisY_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_LineAlignment property of Title Parameter

AllSeries_AxisY_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_PlotAreaOnly property of TitleDockable Parameter

AllSeries_AxisY_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_RichText property of Title Parameter

AllSeries_AxisY_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_Separation property of Title Parameter

AllSeries_AxisY_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_Text property of Title Parameter

AllSeries_AxisY_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Title_TextColor property of Title Parameter

AllSeries_AxisY_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AllSeries_AxisY_Title Parameter | Chart_AllSeries_AxisY_Title Summary


AllSeries_AxisY_Visible property of Axis Parameter

AllSeries_AxisY_Visible Parameter

Shows or hides the lines, labels, tick marks and grids for the selected axis.

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the and tick marks are also hidden.

Example

To hide the X axis labels:

out-chart -AxisX_Visible false

See Also

Chart_AllSeries_AxisY Parameter | Chart_AllSeries_AxisY Summary


AllSeries_BarShape property of PointAttributes Parameter

AllSeries_BarShape Parameter

Sets the Shape for the Bars.

Value | Meaning
Rectangle | Sets the Bar shape to a Rectangle (Default).
Cylinder | Sets the Bar shape to a Cylinder.
Cone | Sets the Bar shape to a Cone.
Pyramid | Sets the Bar shape to a Pyramid.

Remarks

  • This property applies when the chart Gallery is set to Bar.

Example

This changes the bar shapes to cylinder for the first point.

out-chart -Points_0_BarShape Cone

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Border property of PointAttributes Parameter

AllSeries_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To remove borders for the 2nd point of all series:

out-chart -Points_1_Border_Width 5

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


BorderAttributes Class Members

Chart_AllSeries_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


AllSeries_Border_BetweenSegments property of BorderAttributes Parameter

AllSeries_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Remarks

  • For some gallery types, Area for example, turning the point markers border visible will generate the following efect on a chart:

  • When BetweenSegments is set to true, this will be the effect:

Example

To set the BetweenSegmetnts to true for all series:

out-chart -AllSeries_Border_Width 6 -AllSeries_Border_BetweenSegments true

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_Color property of BorderAttributes Parameter

AllSeries_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set to Red the Border color for all series:

out-chart -AllSeries_Border_Color Red

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_Effect property of BorderAttributes Parameter

AllSeries_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the border effect to Shadow for all series:

out-chart -AllSeries_Border_Effect Shadow

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_Style property of BorderAttributes Parameter

AllSeries_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Style of the border line to Dash:

out-chart -AllSeries_Border_Style Dash

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_UseForLines property of BorderAttributes Parameter

AllSeries_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line chart.

Remarks

  • When applied to a Line Chart, Border attributes will affect only the Point marker, where the line will remain unchanged.

  • When setting UseForLines to true, the border attributes are applied to the line too:

Example

To apply the border attributes to all the lines:

out-chart -Gallery Lines -AllSeries_Border_UseForLines true -AllSeries_Border_Width 3

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_Visible property of BorderAttributes Parameter

AllSeries_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the border visible for all series:

out-chart -AllSeries_Border_Visible true

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Border_Width property of BorderAttributes Parameter

AllSeries_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the point markers border width to 2:

out-chart -AllSeries_Border_Width 2

See Also

Chart_AllSeries_Border Parameter | Chart_AllSeries_Border Summary


AllSeries_Color property of GlobalAttributes Parameter

AllSeries_Color Parameter

Sets the color for all series.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the chart, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

Change the color for all series to red:

out-chart -AllSeries_Color Red

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_FillMode property of PointAttributes Parameter

AllSeries_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the FillMode property to Pattern for a point:

out-chart -Points_1_FillMode Pattern

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Gallery property of GlobalAttributes Parameter

AllSeries_Gallery Parameter

Gets and sets the chart type for all Series.

Default Value
The default is Bar.

Value | Meaning
Lines | Line Chart
Bar | Bar Chart
Area | Area Chart
Scatter | Scatter Chart
Pie | Pie Chart
Curve | Curve Chart
Pareto | Pareto Chart
Step | Step Chart
HighLowClose | Hi-Low-Close Chart
Surface | Surface Chart
Radar | Radar Chart
Polar | Polar Chart.
Cube | Cube Chart
Doughnut | Doughnut Chart
Pyramid | Pyramid Chart
Bubble | Bubble Chart
OpenHighLowClose | Open-High-Low-Close Chart
Candlestick | Candlestick Chart
Contour | Countour Chart
CurveArea | Curve Area Chart
Gantt | Gantt Chart

Remarks

  • When you set the gallery with this property it applies to all the series in the chart. If you want to create a Multitype (or combination chart) please refer to the Series object Gallery property.

  • When selecting a Gallery for charts, keep in mind the number of data series which will be included in the chart. Pie, Pyramid and Doughnut chart types can only display one series per chart. If you have multiple data series, you may want to select a Gallery type that supports one that one series.

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To display an AREA chart:

out-chart -AllSeries_Gallery Area

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Horizontal property of GlobalAttributes Parameter

AllSeries_Horizontal Parameter

Sets a value specifying to transpose X and Y axes in a chart.

Remarks

  • When Horizontal is True, X and Y axis objects are transposed in the chart.

  • By transposing the X and Y axes, the orientation of series in the chart is inverted. Therefore, vertical bars in a bar gallery chart are now horizontal, like in a Gantt gallery chart.

Example

To transpose the X and Y axes in a chart:

out-chart -AllSeries_Horizontal true

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Line property of PointAttributes Parameter

AllSeries_Line Parameter

Gets the LineAttributes object for the particular point.

Remarks

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

Example

To set the line width to 3 for all series in a chart:

out-chart -AllSeries_Line_Width 3

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


LineAttributes Class Members

Chart_AllSeries_Line Parameters

Parameters

Description

EndCap | Sets a marker shape at the end of a PointAttribute's Line.
StartCap | Sets a marker shape at the start of a PointAttribute's Line.
Style | Sets the style for a PointAttribute's Line.
Width | Sets the width for a PointAttribute's Line.


AllSeries_Line_EndCap property of Line Parameter

AllSeries_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AllSeries_Line Parameter | Chart_AllSeries_Line Summary


AllSeries_Line_StartCap property of Line Parameter

AllSeries_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AllSeries_Line Parameter | Chart_AllSeries_Line Summary


AllSeries_Line_Style property of Line Parameter

AllSeries_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AllSeries_Line Parameter | Chart_AllSeries_Line Summary


AllSeries_Line_Width property of Line Parameter

AllSeries_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AllSeries_Line Parameter | Chart_AllSeries_Line Summary


AllSeries_MarkerShape property of PointAttributes Parameter

AllSeries_MarkerShape Parameter

Sets the the type used to paint markers for the selected item.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

Example

To select a triangle as the marker shape for the first point in all the series:

out-chart -Points_0_MarkerShape Triangle

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_MarkerSize property of PointAttributes Parameter

AllSeries_MarkerSize Parameter

Sets a value controlling the size of the markers for the selected item.

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

Example

To increase the marker size for the first point of all the series:

out-chart -Points_0_MarkerSize 5

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_MarkerStep property of SeriesAttributes Parameter

AllSeries_MarkerStep Parameter

Controls how frequently point markers are shown in the selected series.

Remarks

  • This property is very useful when the chart contains a large number of points and the point markers disturb the chart's readability. For example, if you are showing 100 points in a line chart, the physical separation (pixels) of them is very small and probably the point markers will make the chart unreadable to the end user. In this case, you can set this property to force PowerGadgets to show point markers every 20 points.

  • Point markers will not be shown in 3D line charts.

Example

To show markers every 20 points:

out-chart -AllSeries_MarkerStep 20

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_MultipleColors property of GlobalAttributes Parameter

AllSeries_MultipleColors Parameter

Gets and sets the Multiple colors to allow for independently colored data points.

Remarks

  • When set to True all data points on a series will have a unique color. When set to False all the data points in the series will assume the same color.

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To color each data point independently:

out-chart -AllSeries_MultipleColors true

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Pane property of GlobalAttributes Parameter

AllSeries_Pane Parameter

Sets the Pane which will be used by the series by default.

Remarks

  • The MainPane property of the Chart Parameter is a shortcut to this property.

Example

To set the BackColor property of the MainPain:

out-chart -AllSeries_Pane_BackColor LightCyan

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


Pane Class Members

Chart_AllSeries_Pane Parameters

Parameters

Description

Axes | Provides access to the Y Axis Collection for the selected Pane.
AxisY | Provides access to the members of the main Y Axis for the selected Pane.
BackColor | Sets the inside color for the selected pane.
Background | Sets an ImageBackground or GradientBackground object for a pane.
Proportion | Sets a value indicating the proportional size of the selected pane.
Separation | Sets a value indicating the space in between panes.
Title | Gets the Title object for a selected chart pane.
Visible | Sets a value indicating the Pane object should be shown or not.


AllSeries_Pane_Axes property of Pane Parameter

AllSeries_Pane_Axes Parameter

Provides access to the Y Axis Collection for the selected Pane.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the Y Axis index.

Remarks

  • Use this property to mamipulate the Y Axes of the Pane.

  • The AxisY property provides direct access to the Pane's main Y axis.

Example

To add a secondary Y Axis to the Pane 1:

out-chart -Panes_0_Axes_1_Visible true

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_AxisY property of Pane Parameter

AllSeries_Pane_AxisY Parameter

Provides access to the members of the main Y Axis for the selected Pane.

Remarks

  • This property is a shortcut to the Pane's main .

Example

To invert the main Y Axis in the Pane 1:

out-chart -Panes_1_AxisY_Inverted true

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_BackColor property of Pane Parameter

AllSeries_Pane_BackColor Parameter

Sets the inside color for the selected pane.

Remarks

  • For gradient background, see the Background.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the BackColor for a selected pane:

out-chart -Panes_1_BackColor HotPink

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_Background property of Pane Parameter

AllSeries_Pane_Background Parameter

Sets an ImageBackground or GradientBackground object for a pane.

Remarks

  • Each pane present in a chart may have a unique ImageBackground or GradientBackground object configured as the background.

  • Please see the ImageBackground and GradientBackground objects for information regarding supported members.

Example

To assign a GradientBackground for a selected pane object:

out-chart -Panes_0_Background myBackground

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_Proportion property of Pane Parameter

AllSeries_Pane_Proportion Parameter

Sets a value indicating the proportional size of the selected pane.

Remarks

  • This property accepts an integer that specifies the "proportional" size of a selected pane. For Example, If you set this property to the value of 2 for a selected pane, that pane's height would be twice the size of any default pane's size. The default pane size will depend on the number of panes visible in the chart as well as the dimensions of the chart object itself.

Example

To configure the 3rd pane in a chart to be 3 times the height of a default chart pane:

out-chart -Panes_1_Proportion 3

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_Separation property of Pane Parameter

AllSeries_Pane_Separation Parameter

Sets a value indicating the space in between panes.

Remarks

  • This property is useful when multiple panes are configured and you need to create space for readability.

Example

To set a value for seperation for a selected pane:

out-chart -Panes_1_Separation 10

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pane_Title property of Pane Parameter

AllSeries_Pane_Title Parameter

Gets the Title object for a selected chart pane.

Remarks

  • This property returns a Title object. Accessing the title Parameter members you will be able to control attributes such as: Alignment, Color, Font,Text, etc.

  • Each pane may only have one title.

  • The Separation property may be used to control the space between panes. This may be useful to developers trying a change the font for a pane's title.

Example

To configure a title for the 2nd pane:

out-chart -Panes_1_Title_Text "2nd Pane Title"

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


Title Class Members

Chart_AllSeries_Pane_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AllSeries_Pane_Title_Alignment property of Title Parameter

AllSeries_Pane_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_BackColor property of Title Parameter

AllSeries_Pane_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_Font property of Title Parameter

AllSeries_Pane_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_Indentation property of Title Parameter

AllSeries_Pane_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_LineAlignment property of Title Parameter

AllSeries_Pane_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_PlotAreaOnly property of TitleDockable Parameter

AllSeries_Pane_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_RichText property of Title Parameter

AllSeries_Pane_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_Separation property of Title Parameter

AllSeries_Pane_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_Text property of Title Parameter

AllSeries_Pane_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Title_TextColor property of Title Parameter

AllSeries_Pane_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AllSeries_Pane_Title Parameter | Chart_AllSeries_Pane_Title Summary


AllSeries_Pane_Visible property of Pane Parameter

AllSeries_Pane_Visible Parameter

Sets a value indicating the Pane object should be shown or not.

Remarks

  • Hiding a Pane object will hide all the series associated to that pane, not only from the chart area but also from the Legend and the DataGrid. The hidden series objects will remain accessible but invisible.

  • Hiding a Pane object does not destroy or lose previous settings assigned by other properties.

Example

To hide the second pane:

out-chart -Panes_1_Visible false

See Also

Chart_AllSeries_Pane Parameter | Chart_AllSeries_Pane Summary


AllSeries_Pattern property of GlobalAttributes Parameter

AllSeries_Pattern Parameter

Sets the Pattern for all the series in a chart.

Remarks

  • To use this property, you must make sure the FillMode is set to either Monochrome or Pattern.

  • If the FillMode is set to Pattern you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set a pattern for all the series:

out-chart -AllSeries_FillMode Pattern -AllSeries_Pattern Cross

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Picture property of PointAttributes Parameter

AllSeries_Picture Parameter

Sets a value specifying the picture associated to the selected item.

Remarks

  • The Picture property may be used in two different ways depending on the chart's gallery and FillMode:

    1. If the chart gallery is one that uses point markers, meaning you can set the shape of the marker using the MarkerShape property, then the configured image will be used as a point marker as long as the MarkerShape for that point is set to MarkerShape.Picture.

    2. If the chart gallery is one that uses bars, area markers or pie slices (Bar, Area or Pie type charts), the image will be tiled in the selected series or point. However, in order for the tiled effect to be applied you must set the FillMode to FillMode.Pattern.

  • The Legends and DataEditor will also show the picture but with an appropriated size. Notice that if you do not set the FillMode to FillMode.Pattern, the configured picture will only be used with charts that have point markers.

  • When this property is set to a 3D chart, the sides of the markers (3D perspective) are painted with the configured series color.

Example

To set a picture for the 1st point of all the series:

out-chart -Points_0_Picture "image.bmp"

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_PointLabels property of PointAttributes Parameter

AllSeries_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To show point labels for a chart:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


PointLabelAttributes Class Members

Chart_AllSeries_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
BorderColor | Sets the border color of the point label.
BorderWidth | Sets a value indicating the width of the border surrounding the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


AllSeries_PointLabels_Alignment property of PointLabelAttributes Parameter

AllSeries_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the right of the marker:

out-chart -AllSeries_PointLabels_Alignment Near

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_Angle property of PointLabelAttributes Parameter

AllSeries_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the PointLabels angle for all the series to 45:

out-chart -AllSeries_PointLabels_Angle 45

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_BackColor property of PointLabelAttributes Parameter

AllSeries_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point label background color to yellow:

out-chart -AllSeries_PointLabels_BackColor Yellow

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_BorderColor property of PointLabelAttributes Parameter

AllSeries_PointLabels_BorderColor Parameter

Sets the border color of the point label.

Remarks

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point labels border color to Red:

out-chart -AllSeries_PointLabels_BorderColor Red

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_BorderWidth property of PointLabelAttributes Parameter

AllSeries_PointLabels_BorderWidth Parameter

Sets a value indicating the width of the border surrounding the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the point label border width to 2:

out-chart -AllSeries_PointLabels_BorderWidth 2

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_Font property of PointLabelAttributes Parameter

AllSeries_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired chart element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Set a font for all the point labels of the chart:

out-chart -AllSeries_PointLabels_Font "Arial, 12"

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_Format property of PointLabelAttributes Parameter

AllSeries_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY charts, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked charts).

    X displays the marker X value for any chart type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To use the PointLabel Format Property:

out-chart -AllSeries_PointLabels_Format "I'm point # %N"

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_LineAlignment property of PointLabelAttributes Parameter

AllSeries_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the top of the marker:

out-chart -AllSeries_PointLabels_LineAlignment Far

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_Offset property of PointLabelAttributes Parameter

AllSeries_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

The code sets the PointLabelOffset to 4 pixels up and 5 pixels to the right:

out-chart -AllSeries_PointLabels_Offset "4,5"

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_RichText property of PointLabelAttributes Parameter

AllSeries_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To use the PointLabels RichText property:

out-chart -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_RichText true -AllSeries_PointLabels_Format "I'm <b> Point </b> # %N"

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_TextColor property of PointLabelAttributes Parameter

AllSeries_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set all the point labels to red:

out-chart -AllSeries_pointLabels_TextColor Red

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_PointLabels_Visible property of PointLabelAttributes Parameter

AllSeries_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

Example

To show the labels of all the points in the chart: data points:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_AllSeries_PointLabels Parameter | Chart_AllSeries_PointLabels Summary


AllSeries_SeparateSlice property of PointAttributes Parameter

AllSeries_SeparateSlice Parameter

Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.

Remarks

  • Setting this property to 100 will make the vertex of the slice to be on the edge of the pie.

  • PowerGadgets does not provide administrative properties, such as the biggest slice in a PIE chart, so if you want to separate a particular slice based on a certain condition, you must first determine the slice to be separated based on the data contained in the chart.

Example

To separate the first slice of each series by 50%:

out-chart -Points_0_SeparateSlice 50

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Stacked property of GlobalAttributes Parameter

AllSeries_Stacked Parameter

Sets the Stacked style in the chart.

Default Value
The default is No.

Value | Meaning
No | No stacked chart.
Normal | Stacked.
Stacked100 | 100% stacked.

Remarks

  • This property applies to BAR or AREA charts only.

  • This property applies the stacked style to all series in the chart. PowerGadgets also support multistacked charts where you can stack series by pairs. For more information, please refer to the Stacked parameter in the Series object.

Example

To set a 100% stacked chart:

out-chart -AllSeries_Stacked Stacked100

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Visible property of GlobalAttributes Parameter

AllSeries_Visible Parameter

Shows or hides all the Series.

Remarks

  • Hiding the all Series does not destroy or lose previous settings assigned by other properties.

Example

To hide the all Series:

out-chart -AllSeries_Visible false

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


AllSeries_Volume property of PointAttributes Parameter

AllSeries_Volume Parameter

Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

Example

To make the first point of all the series occupy all the space allotted to them:

out-chart -Points_0_Volume 100

See Also

Chart_AllSeries Parameter | Chart_AllSeries Summary


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the chart with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the chart from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the anchor parameter to TopRight:

out-chart -anchor TopRight

See Also

Chart Parameter | Chart Summary


Antialiasing property of Chart Parameter

Antialiasing Parameter

Gives a smooth visual effect to the chart.

Remarks

  • The ExtraStyle parameter also supports a DoubleBuffer value that can prevent flickering in real-time charts.

  • The ExtraStyle property also supports a DoubleBuffer enumeration that can prevent flickering in real-time charts.

Example

To set the Antialiasing:

out-chart -Antialiasing true

See Also

Chart Parameter | Chart Summary


AxesStyle property of Chart Parameter

AxesStyle Parameter

Used to change the style of the axes.

Default Value
The default is FlatFrame.

Value | Meaning
None | No frame is displayed around the axis.
Frame3D | A 3D frame will be shown as the axis.
Math | Only tickmarks will be shown as the axis.
FlatFrame | A single, flat frame is displayed in the axis.

Remarks

  • Toggling the chart from 2D and 3D modes will produce different effects.

  • Toggling the chart from 2D and 3D will produce different effects.

Example

To display a math style frame:

out-chart -AxesStyle Math

See Also

Chart Parameter | Chart Summary


AxesX_<index> property of Chart Parameter

AxesX_<index> Parameter

Returns the collection of the X axes of the chart.

Parameters

Parameter | Type | Meaning
index | Int32 | Returns the indexed x axis.

Remarks

  • The first element of the collection is the primary X Axis of the chart.

Example

To add a new X Axis and change the Text color for that axis:

out-chart -AxesX_1_TextColor Red

See Also

Chart Parameter | Chart Summary


AxesY_<index> property of Chart Parameter

AxesY_<index> Parameter

Returns the collection of the Y axes of the chart.

Parameters

Parameter | Type | Meaning
index | Int32 | Returns the indexed y-axis.

Remarks

  • The first element of the collection is the primary Y Axis of the chart. Similarly, the second element of the collection is the secondary Y Axis of the chart.

Example

To add a new Y Axis and change the Text color for that axis:

out-chart -Series_0_AxisY AxesY_1 -AxesY_1_TextColor Red

See Also

Chart Parameter | Chart Summary


AxisX property of Chart Parameter

AxisX Parameter

Assigns properties specifically to the primary X axis.

Remarks

  • Below, the primary X axis of the chart is hidden.

Example

To set the AxisX Visible:

out-chart -AxisX_Visible False

See Also

Chart Parameter | Chart Summary


AxisX Class Members

Chart_AxisX Parameters

Parameters

Description

AutoScale | Instructs PowerGadgets to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.
AutoScroll | Enables or disables scrolling in an Axis.
CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
CustomSteps | Allows you to set a custom step for the selected axis.
DataFormat | Used to format the data displayed on point labels and tool tips shown at a mouseover.
FirstLabel | Sets a value used to customize the first label displayed on a selected axis.
Font | Allows you to change the label Font attributes of the selected axis.
ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Inverted | Sets a selected numerical axis max value lesser than the min value.
KeyLabels | Used to assign a key (short) legend to tickmarks in a categorical axis.
LabelAngle | Sets the text rotation for the labels in the selected axis.
Labels | Allows you to get or set tick marks labels for the selected axis.
LabelsFormat | Used to format the labels displayed on the selected axis.
LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
Line | Allows you to apply supported Line members to a selected axis line.
LineSpacing | Sets a value indicating the LineSpacing for an axis.
LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
Max | Defines the maximum value of a specific axis.
Min | Defines the minimum value of a selected axis.
MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
PixelsPerUnit | Gives you the ability to control how many pixels per unit are there in the selected axis.
Position | Specifies the placement of the axis labels and tick marks relative to the chart.
ScaleUnit | Returns or sets the scale unit of a selected axis.
ScrollPosition | Allows you to set the starting scroll position when a chart is scrollable.
Sections | Returns a selected AxisSection object.
Separation | Allows you to specify a gap in pixels between multiple axis.
Staggered | Alternates the level of the axis labels for the selected axis labels.
Step | Specifies the interval of major tick marks and gridlines on the selected axis.
Style | Allows you to add additional styles to the selected axis.
TextColor | Sets the color for text of a selected BaseAxisSection object.
Title | Sets the title for a specific axis.
Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AxisX_AutoScale property of Axis Parameter

AxisX_AutoScale Parameter

Instructs Chart FX to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.

Remarks

  • If you set a Min or Max value and new data is received by the chart when the AutoScale property is enabled, the scale values will be overwritten by PowerGadgets . This method will not affect the Step property if it has previously set to a specific value. If you want the AutoScale property to recalculate the Step value, make sure the Step property is set to zero (0).

Example

To enable the AutoScale feature for the primary X axis:

out-chart -AxisX_AutoScale true

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_AutoScroll property of Axis Parameter

AxisX_AutoScroll Parameter

Enables or disables scrolling in an Axis.

Remarks

  • When the axis is a categorical axis and the number of data points (or tick marks) do not fit in one screen PowerGadgets will display a scroll bar so the end user can scroll through the data (maintaining the tick mark separation set with the property). This is particularly useful when the labels associated with tick marks are long strings but still important to improve chart's readability or when a particular marker separation is important.

    In some other cases, having a scroll bar associated with the axis is not desired and you can use this property to force PowerGadgets to display all data points in one screen. If you have a large number of points or long strings associated with tick marks this could affect the chart's readability and you'll need to reset the labels associated with the tick marks in the X axis.

  • To scroll a chart, you may use the keyboard arrows or the drag the scroll thumb with your mouse cursor.

Example

To enable chart scrolling in the X axis:

out-chart -AxisX_AutoScroll true

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_CustomGridLines_<index> property of Axis Parameter

AxisX_CustomGridLines_<index> Parameter

Gets the collection of CustomGridLines that belong to the Chart.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the that they are assigned to.

Example

The following example show how to create a CustomGridLine on the X Axis, located at 100 and with a "Upper Limit" text:

out-chart -AxisX_CustomGridLines_0_Value 100 -AxisX_CustomGridLines_0_Text "Upper Limit"

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


CustomGridLine Class Members

Chart_AxisX_CustomGridLines Parameters

Parameters

Description

Alignment | Sets or get the Alignment for the Label in the CustomGridLine.
Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
Font | Sets the Font utilized for the Label within the CustomGridLine.
LineAlignment | Sets the alignment for the Text line relative to the CustomeGridLine.
OutsideText | Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.
ShowLine | Set the ShowLine, which shows or hides the CustomGridLine line.
ShowText | Set the Showtext, which shows or hides the CustomGridLine text.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Text | Set the Text for a label in a CustomGridLine.
TextColor | Set the Text Colot for a label in a CustomGridLine.
Value | Sets the Value for the CustomGridLine;
Width | Sets the line width for a selected line.


AxisX_CustomGridLines_<index>_Alignment property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_Alignment Parameter

Sets or get the Alignment for the Label in the CustomGridLine.

Remarks

  • The Alignment will position the CustomGridLine Label in the desired location.

  • The possible values are Center, Far, Near.

  • This property will also take effect, if set to Far or Near, when the OutsideText is the to true.

  • For more information on StringAlignment see the PowerShell documentation.

Example

To center the CustomGridLine text:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_Alignment Center

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Color property of Line Parameter

AxisX_CustomGridLines_<index>_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_EndCap property of Line Parameter

AxisX_CustomGridLines_<index>_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Font property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_Font Parameter

Sets the Font utilized for the Label within the CustomGridLine.

Remarks

  • When setting a font for a CustomGridLine label, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=Italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

  • You can set the font for the entire chart using the Parameter property.

Example

To center the CustomGridLine text:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_Font "Arial, 14"

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_LineAlignment property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_LineAlignment Parameter

Sets the alignment for the Text line relative to the CustomeGridLine.

Remarks

  • The LineAlignment will position the Text label line in the desired location.

  • he possible values are Center, Far, Near.

  • This property will also take effect when the OutsideText is the to true.

Example

To center the CustomGridLine text Line:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_LineAlignment Center

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_OutsideText property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_OutsideText Parameter

Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.

Remarks

  • When this property is set to True, the text associated with the CustomGridLine is placed outside the charting area.

  • Alignment and LineAlignment settings will still apply when this proprty is set to true.

  • In the following chart, the constant line text is set as OutsideText:

Example

To place the CustomGridLine label outside the Chart area:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_OutsideText true

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_ShowLine property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_ShowLine Parameter

Set the ShowLine, which shows or hides the CustomGridLine line.

Remarks

  • When you hide a CustomGridLine line using this property, any text associated with the line will remain in the chart. Use the ShowText property to show or hide the CustomGridLine text.

Example

To hide the line in a CustomGridLine:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_ShowLine false

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_ShowText property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_ShowText Parameter

Set the Showtext, which shows or hides the CustomGridLine text.

Remarks

  • When you hide a CustomGridLine test using this property, any Line associated will remain in the chart. Use the ShowLine property to show or hide the CustomGridLine line.

Example

To hide the text in a CustomGridLine:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_ShowText false

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_StartCap property of Line Parameter

AxisX_CustomGridLines_<index>_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Style property of Line Parameter

AxisX_CustomGridLines_<index>_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the X Axis line:

out-chart -AxisX_Line_Style DashDot

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Text property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_Text Parameter

Set the Text for a label in a CustomGridLine.

Remarks

  • When the CustomGridLine line is associated with any of the Y axes, the default text alignment is Near (Left). On the other hand, if the label is associated with the X axis the default text alignment is Near (bottom). You can modify the text alignment with the Alignment property.

  • To change the font for the text laber in the CustomGridLine, use the Font property.

  • To change the text color using the TextColor property.

Example

To add a CustomGridLine with the "Break Even" label in the X Axis:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Break Even"

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_TextColor property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_TextColor Parameter

Set the Text Colot for a label in a CustomGridLine.

Remarks

  • The TextColor property is used to set a color for the specified customGridLine.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the text Color to red:

out-chart -AxisX_CustomGridLines_0_Value 50 -AxisX_CustomGridLines_0_Text "Custom Line" -AxisX_CustomGridLines_0_TextColor Red

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Value property of CustomGridLine Parameter

AxisX_CustomGridLines_<index>_Value Parameter

Sets the Value for the CustomGridLine;

Remarks

  • The value of the CustomGridLine goes in strict relationship with the Axis scale that is related to, as follows:

    - If the CustomGridLine is associated with a numerical axis, the value of the constant is a double according to the scale values set for that particular axis. Please remember a CustomGridLine may be associated to the X axis in an XY Plot where the X axis is a numerical axis with specific scale values.

    - If the CustomGridLine is associated with a categorical axis (X axis in charts other than XY Plots), the value is an integer specifying the point index you want to associate the CustomGridLine to. In these cases, the constant line will be drawn starting at the Major tick mark for the selected point.

  • Please note that if you set a CustomGridLine out of the range of the visible axis scale values, PowerGadgets will not recalculate the scale and you must set the Min and Max accordingly so the constant line can be seen.

    For example, if you set a value of 1000 for a constant line in the X axis, while the X axis scale is from 0 to 500. The constant line will not be visible and you must set a new maximum value using the Max parameter.

Example

To add a CustomGridLine to the X Axis at 50.75:

out-chart -AxisX_CustomGridLines_0_Value 50.75 -AxisX_CustomGridLines_0_Text "Custom Line"

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomGridLines_<index>_Width property of Line Parameter

AxisX_CustomGridLines_<index>_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the X Axis:

out-chart -AxisX_Line_Width 5

See Also

Chart_AxisX_CustomGridLines Parameter | Chart_AxisX_CustomGridLines Summary


AxisX_CustomSteps property of Axis Parameter

AxisX_CustomSteps Parameter

Allows you to set a custom step for the selected axis.

Remarks

  • The CustomSteps property holds an array of numbers (double) that specifies a series of step values for the selected axis.

  • The step applied to the axis will begin to cycle if your chart contains enough points. For example, if you set the CustomStep to (5,10,20,30) the axis step would look like:

    0,5,15,35,65,70,80,100,130,135,...

Example

Set a custom step for the X axis:

out-chart -AxisX_CustomSteps 5,10,20

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_DataFormat property of Axis Parameter

AxisX_DataFormat Parameter

Used to format the data displayed on point labels and tool tips shown at a mouseover.

Remarks

  • The LabelsFormat property can be used to format the selected axis labels.

  • Setting this property for the chart will also format data viewed via the PowerGadgets MenuBar.

Example

To set the data format for the X axis data values to currency:

out-chart -AxisX_DataFormat_Format Currency

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


ValueFormat Class Members

Chart_AxisX_DataFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisX_DataFormat_Culture property of ValueFormat Parameter

AxisX_DataFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the X axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the X Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisX_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisX_DataFormat Parameter | Chart_AxisX_DataFormat Summary


AxisX_DataFormat_CustomFormat property of ValueFormat Parameter

AxisX_DataFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisX_LabelsFormat_Format Date -AxisX_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisX_DataFormat Parameter | Chart_AxisX_DataFormat Summary


AxisX_DataFormat_Decimals property of ValueFormat Parameter

AxisX_DataFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the X Axis data values:

out-chart -AxisX_DataFormat_Decimals 3

See Also

Chart_AxisX_DataFormat Parameter | Chart_AxisX_DataFormat Summary


AxisX_DataFormat_Format property of ValueFormat Parameter

AxisX_DataFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the X axis are formatted as to the US currency:

  • Similarly, the labels of the X axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AxisX_DataFormat Parameter | Chart_AxisX_DataFormat Summary


AxisX_FirstLabel property of Axis Parameter

AxisX_FirstLabel Parameter

Sets a value used to customize the first label displayed on a selected axis.

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To make the 3rd point the first label in the X-axis:

out-chart -AxisX_FirstLabel 3

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Font property of Axis Parameter

AxisX_Font Parameter

Allows you to change the label Font attributes of the selected axis.

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Property of the object.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the PowerShell Documentation.

Example

If you want to change the main X axis labels font settings:

out-chart -AxisX_Font "Arial, 14"

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_ForceZero property of Axis Parameter

AxisX_ForceZero Parameter

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

Remarks

  • By default, PowerGadgets will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want PowerGadgets to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Example

To force PowerGadgets to set the minimum value of the X axis to the minimum value passed to the chart.

out-chart -AxisX_ForceZero false

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Grids property of AxisSectionBase Parameter

AxisX_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisX_Grids_Minor_Visible true

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


Grids Class Members

Chart_AxisX_Grids Parameters

Parameters

Description

Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
InterlacedColor | Sets the AlternateColor for a selected Grids object.
Major | Provides access to the GridLine to customize the Mayor Grid.
Minor | Provides access to the GridLine to customize the Minor Grid.


AxisX_Grids_Interlaced property of Grids Parameter

AxisX_Grids_Interlaced Parameter

Creates a grid of alternating colors for a selected axis to improve chart readability.

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

Example

To set an Interlaced grid on the X Axis:

out-chart -AxisX_Grids_Interlaced true

See Also

Chart_AxisX_Grids Parameter | Chart_AxisX_Grids Summary


AxisX_Grids_InterlacedColor property of Grids Parameter

AxisX_Grids_InterlacedColor Parameter

Sets the AlternateColor for a selected Grids object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To configure the Grids InterleacedColor to red:

out-chart -AxisX_Grids_InterlacedColor Red

See Also

Chart_AxisX_Grids Parameter | Chart_AxisX_Grids Summary


AxisX_Grids_Major property of Grids Parameter

AxisX_Grids_Major Parameter

Provides access to the GridLine class to customize the Mayor Grid.

Remarks

  • The Major interval is controlled by the Axis Step parameter.

Example

To show the Major gridlines for the X Axis:

out-chart -AxisX_Grids_Major_Visible true

See Also

Chart_AxisX_Grids Parameter | Chart_AxisX_Grids Summary


GridLine Class Members

Chart_AxisX_Grids_Major Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisX_Grids_Major_Color property of Line Parameter

AxisX_Grids_Major_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_EndCap property of Line Parameter

AxisX_Grids_Major_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_StartCap property of Line Parameter

AxisX_Grids_Major_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_Style property of Line Parameter

AxisX_Grids_Major_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the X Axis line:

out-chart -AxisX_Line_Style DashDot

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_TickMark property of GridLine Parameter

AxisX_Grids_Major_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the X Axis:

out-chart -AxisX_Grids_Major_TickMark Cross

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_Visible property of GridLine Parameter

AxisX_Grids_Major_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the X Axis:

out-chart -AxisX_MinorStep 5 -AxisX_Grids_Minor_Visible true

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Major_Width property of Line Parameter

AxisX_Grids_Major_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the X Axis:

out-chart -AxisX_Line_Width 5

See Also

Chart_AxisX_Grids_Major Parameter | Chart_AxisX_Grids_Major Summary


AxisX_Grids_Minor property of Grids Parameter

AxisX_Grids_Minor Parameter

Provides access to the GridLine class to customize the Minor Grid.

Remarks

  • The minor interval is controlled by the MinorStep parameter, which must be set in order to use the Minor Grid.

  • The minor interval is controlled by the Property, which must be set in order to use the Minor Grid.

Example

To show the Minor gridlines for the X Axis:

out-chart -AxisX_Grids_Minor_Visible true

See Also

Chart_AxisX_Grids Parameter | Chart_AxisX_Grids Summary


GridLine Class Members

Chart_AxisX_Grids_Minor Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisX_Grids_Minor_Color property of Line Parameter

AxisX_Grids_Minor_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_EndCap property of Line Parameter

AxisX_Grids_Minor_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_StartCap property of Line Parameter

AxisX_Grids_Minor_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_Style property of Line Parameter

AxisX_Grids_Minor_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the X Axis line:

out-chart -AxisX_Line_Style DashDot

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_TickMark property of GridLine Parameter

AxisX_Grids_Minor_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the X Axis:

out-chart -AxisX_Grids_Major_TickMark Cross

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_Visible property of GridLine Parameter

AxisX_Grids_Minor_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the X Axis:

out-chart -AxisX_MinorStep 5 -AxisX_Grids_Minor_Visible true

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Grids_Minor_Width property of Line Parameter

AxisX_Grids_Minor_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the X Axis:

out-chart -AxisX_Line_Width 5

See Also

Chart_AxisX_Grids_Minor Parameter | Chart_AxisX_Grids_Minor Summary


AxisX_Inverted property of Axis Parameter

AxisX_Inverted Parameter

Sets a selected numerical axis max value lesser than the min value.

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the X Axis in an XY plot chart. In an XY plot, the X Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

Example

Set the X Axis to be inverted:

out-chart -AxisX_Inverted true

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_KeyLabels property of Axis Parameter

AxisX_KeyLabels Parameter

Used to assign a key (short) legend to tickmarks in a categorical axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index specifying the tickmark you want to assign the key legend.

Remarks

  • You normally use the Labels property to assign labels to the tickmarks in the X axis (when it is categorical). However, depending on the amount of points in the chart, these labels may be too long to properly fit in the space allotted for each tickmark in the X axis.

  • You can control the frequency or how labels are displayed with other properties supported by the Axis object, sometimes you still have space limitations because of the size of the chart or the number of points.

  • This property can help you display shorter labels in the X axis while maintaining longer labels in the legend window. Let's give you an example:

    Let's suppose you have assigned the following labels to the X axis using the Label property:

    "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"

    Now, these labels may or may not fit in the space allotted for each tickmark in the X axis. If one of them does not fit, PowerGadgets will immediately display a TAG (red number) indicating that such label can not fit in the space allotted for it. This problem increases as the number of points in the chart increase.

    With this property you can assign key labels (shorter strings) like: "Jan","Feb","Mar",Apr", etc... that will be displayed in the X axis itself, while the Legend window will display both the Key Legend and the Legend set with the Label property.

Example

To assign a key label to the first tickmark in the X axis:

out-chart -AxisX_KeyLabels_0 "Jan"

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_LabelAngle property of Axis Parameter

AxisX_LabelAngle Parameter

Sets the text rotation for the labels in the selected axis.

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the property of the Parameter.

Example

To set vertical text labels in the X Axis:

out-chart -AxisX_LabelAngle 90

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Labels property of Axis Parameter

AxisX_Labels Parameter

Allows you to get or set tick marks labels for the selected axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index indicating the Label index for the axis.

Remarks

  • This property is used to read or write labels for a categorical axis. Normally, the X axis is a categorical axis containing labels associated with each major tick mark, while the X axis is a numerical axis where labels are controlled by the scale (Min, Max, etc) and numerical data contained in the chart.

  • You can set as many labels as points are available in the chart. These labels will be shown in the major tick marks of the selected axis. Some of them can be left empty so no labels are shown on that specific major tick mark.

  • You can control how frequent these labels are displayed by using the Step property. Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

  • By default, PowerGadgets does not associate any labels to the categorical axis (X axis) and a "TAG" number will be shown. When you use this property, the TAG numbers will be replaced by settings specified in this property.

  • When used in conjunction with the LabelValue property, this property can be used to set string values to a numerical axis.

Example

To modify the X axis first label for the chart:

out-chart -AxisX_Labels_0 "Custom Label"

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_LabelsFormat property of Axis Parameter

AxisX_LabelsFormat Parameter

Used to format the labels displayed on the selected axis.

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Example

Set the X Axis labels to the currency format:

out-chart -AxisX_LabelsFormat_Format Currency

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


ValueFormat Class Members

Chart_AxisX_LabelsFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisX_LabelsFormat_Culture property of ValueFormat Parameter

AxisX_LabelsFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the X axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its X axis labels set to the "Chinese-China" culture:

Example

To set the X Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisX_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisX_LabelsFormat Parameter | Chart_AxisX_LabelsFormat Summary


AxisX_LabelsFormat_CustomFormat property of ValueFormat Parameter

AxisX_LabelsFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the X axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisX_LabelsFormat_Format Date -AxisX_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisX_LabelsFormat Parameter | Chart_AxisX_LabelsFormat Summary


AxisX_LabelsFormat_Decimals property of ValueFormat Parameter

AxisX_LabelsFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the X Axis data values:

out-chart -AxisX_DataFormat_Decimals 3

See Also

Chart_AxisX_LabelsFormat Parameter | Chart_AxisX_LabelsFormat Summary


AxisX_LabelsFormat_Format property of ValueFormat Parameter

AxisX_LabelsFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the X axis are formatted as to the US currency:

  • Similarly, the labels of the X axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary X axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisX_LabelsFormat_Culture "fr-FR" -AxisX_LabelsFormat_Format Currency

See Also

Chart_AxisX_LabelsFormat Parameter | Chart_AxisX_LabelsFormat Summary


AxisX_LabelValue property of Axis Parameter

AxisX_LabelValue Parameter

Allows you to set associate text labels to major tick marks in a numerical axis.This property can get or set the LabelValue assigned to any of the axes.

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the X axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default PowerGadgets will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the X axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 PowerGadgets will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

Example

To set a LabelValue of 25 for the primary X axis:

out-chart -AxisX_LabelValue 25

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Line property of Axis Parameter

AxisX_Line Parameter

Allows you to apply supported Line class members to a selected axis line.

Remarks

  • You may control the , and of the selected line using the supported members of the Line Parameter.

  • The and properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the X axis line color to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


Line Class Members

Chart_AxisX_Line Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Width | Sets the line width for a selected line.


AxisX_Line_Color property of Line Parameter

AxisX_Line_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the X Axis lines to Red:

out-chart -AxisX_Line_Color Red

See Also

Chart_AxisX_Line Parameter | Chart_AxisX_Line Summary


AxisX_Line_EndCap property of Line Parameter

AxisX_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_AxisX_Line Parameter | Chart_AxisX_Line Summary


AxisX_Line_StartCap property of Line Parameter

AxisX_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_AxisX_Line Parameter | Chart_AxisX_Line Summary


AxisX_Line_Style property of Line Parameter

AxisX_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the X Axis line:

out-chart -AxisX_Line_Style DashDot

See Also

Chart_AxisX_Line Parameter | Chart_AxisX_Line Summary


AxisX_Line_Width property of Line Parameter

AxisX_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the X Axis:

out-chart -AxisX_Line_Width 5

See Also

Chart_AxisX_Line Parameter | Chart_AxisX_Line Summary


AxisX_LineSpacing property of Axis Parameter

AxisX_LineSpacing Parameter

Sets a value indicating the LineSpacing for an axis.

Remarks

  • This property specifies the LineSpacing for vertical axes. The labels in the selected axis will never be painted less than the configured LineSpacing.

  • Setting the LineSpacing property to 2 will instruct the axis to use double line spacing. Setting the value to 1 instructs the chart to use single line spacing. The default value is 1.5.

Example

To configure an Axis to use double line spacing:

out-chart -AxisX_LineSpacing 2

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_LogBase property of Axis Parameter

AxisX_LogBase Parameter

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

Example

To set a Logarithmic scale and recalculate values as powers of 10 in the primary X axis:

out-chart -AxisX_LogBase 10

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Max property of Axis Parameter

AxisX_Max Parameter

Defines the maximum value of a specific axis.Sets the Max value assigned to the specified axis.

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, PowerGadgets will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Example

To set the Max value of the primary X axis to 10:

out-chart -AxisX_Min 10 -AxisX_Max 90

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Min property of Axis Parameter

AxisX_Min Parameter

Defines the minimum value of a selected axis.Sets the Min value assigned to the specified axis.

Remarks

  • The Min property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Min property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Min property.

  • If no Min value is specified, PowerGadgets will automatically set a minimum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Min property must be lesser than the value of the Max property.

  • There is no automatic method for aligning a main and secondary axis, it is required that you set the Min and Max in order to align them manually. The generic algorithm used to find these values is the following:

Example

To set the Min value of the primary X axis to 10:

out-chart -AxisX_Min 10 -AxisX_Max 90

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_MinorStep property of Axis Parameter

AxisX_MinorStep Parameter

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the minor interval of the primary X axis to 2:

out-chart -AxisX_MinorStep 2

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_PixelsPerUnit property of Axis Parameter

AxisX_PixelsPerUnit Parameter

Gives you the ability to control how many pixels per unit are there in the selected axis.This property is very useful if you want a scroll bar in the selected axis.

Remarks

  • The does not support scrolling capabilities. Therefore, this property is not supported for the Secondary X axis.

  • If the AutoScroll property is set to False, the PixelsPerUint will not have any effect on the axis. So make sure the AutoScroll property is set to True when using the PixelsPerUint property.

Example

To separate tick marks in the X axis by 60 pixels:

out-chart -AxisX_AutoScroll true -AxisX_PixelsPerUnit 60

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Position property of Axis Parameter

AxisX_Position Parameter

Specifies the placement of the axis labels and tick marks relative to the chart.

Value | Meaning
Near | Specifies the axis line be placed near the chart in the following way: In a X axis, the axis line be below the chart. In X axis, the axis line be left to the chart.
Center | Specifies that axis line placed in the center of the chart.
Far | Specifies that axis line is placed far from the chart in the following way: In a X axis, the axis line be above the chart. In a X axis, the axis line is right to the chart.

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Multiple axes may be created using the AxesX and the properties of the Parameter.

Example

To move the labels and tick marks for the X and Y axes to the top and right of the chart:

out-chart -AxisX_Position Far -AxisX_Position Far

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_ScaleUnit property of Axis Parameter

AxisX_ScaleUnit Parameter

Returns or sets the scale unit of a selected axis.

Remarks

  • This constant is very useful when the values used on the X axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the X axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Example

To set the Scale Unit of the primary X axis to 1000:

out-chart -AxisX_ScaleUnit 1000

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_ScrollPosition property of Axis Parameter

AxisX_ScrollPosition Parameter

Allows you to set the starting scroll position when a chart is scrollable.

Remarks

  • Your chart must be set to AutoScroll in order for this property to be used properly.

  • When you set the ScrollPosition, the first point included in the chart will be the configured point.

Example

Set the scroll position for the X axis to 50:

out-chart -AxisX_ScrollPosition 50

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Sections_<index> property of Axis Parameter

AxisX_Sections_<index> Parameter

Returns a selected AxisSection object.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection Parameter. Please see the Parameter for additional information regarding those supported members.

Example

To set the To value for a selected AxisSection object:

out-chart -AxisX_Sections_0_To 25

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisSection Class Members

Chart_AxisX_Sections Parameters

Parameters

Description

BackColor | Sets the AxisSection background color.
FontStyle | Sets additional font attributes to the axis section.
From | Sets a value indicating the beginning value of the range for a selected object.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Text | Sets the text string for a selected BaseAxisSection object.
TextColor | Sets the color for text of a selected BaseAxisSection object.
To | Sets a value indicating the ending value of the range the axis section.
Visible | Shows or hides the selected axis section.


AxisX_Sections_<index>_BackColor property of AxisSection Parameter

AxisX_Sections_<index>_BackColor Parameter

Sets the AxisSection background color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Changes the background color of the first section of to yellow:

out-chart -AxisX_Sections_0_BackColor Yellow

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_FontStyle property of AxisSection Parameter

AxisX_Sections_<index>_FontStyle Parameter

Sets additional font attributes to the axis section.

Remarks

Example

Specifies that the text associated with the first AxisSection object of the will be bold:

out-chart -AxisX_Sections_0_FontStyle Bold

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_From property of AxisSection Parameter

AxisX_Sections_<index>_From Parameter

Sets a value indicating the beginning value of the range for a selected AxisSection object.

Remarks

  • The To property is used to specify the ending value of the section range for a selected Axis Section.

  • The To property is used to specify the ending value of the section range for a selected object.

Example

To configure the From value for the 1st axis section of the X Axis:

out-chart -AxisX_Sections_0_From 30

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_Grids property of AxisSectionBase Parameter

AxisX_Sections_<index>_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisX_Grids_Minor_Visible true

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_Text property of AxisSection Parameter

AxisX_Sections_<index>_Text Parameter

Sets the text string for a selected BaseAxisSection object.

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Example

To set text to a section, SampleSection:

out-chart -AxisX_Sections_0_Text "SampleText"

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_TextColor property of AxisSectionBase Parameter

AxisX_Sections_<index>_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the X axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisX_Sections_0_TextColor Red

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_To property of AxisSection Parameter

AxisX_Sections_<index>_To Parameter

Sets a value indicating the ending value of the range the axis section.

Remarks

  • The From property is used to specify the beginning value of the section range for a selected Axis Section.

Example

To configure the To value for the 1st axis section of the X Axis:

out-chart -AxisX_Sections_0_To 60

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Sections_<index>_Visible property of AxisSection Parameter

AxisX_Sections_<index>_Visible Parameter

Shows or hides the selected axis section.

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Example

To hide the axis section:

out-chart -AxisX_Sections_0_Visible false

See Also

Chart_AxisX_Sections Parameter | Chart_AxisX_Sections Summary


AxisX_Separation property of Axis Parameter

AxisX_Separation Parameter

Allows you to specify a gap in pixels between multiple axis.

Remarks

  • This property is useful when multiple axes are configured and you need to create space for readability.

Example

To configure a 5 pixel separation on the secondary X axis:

out-chart -AxisX_Separation 5

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Staggered property of Axis Parameter

AxisX_Staggered Parameter

Alternates the level of the axis labels for the selected axis labels.

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

Example

To stagger axis labels on two levels:

out-chart -AxisX_Staggered true

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Step property of Axis Parameter

AxisX_Step Parameter

Specifies the interval of major tick marks and gridlines on the selected axis.It also controls the gap or interval between labels in the selected axis.

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your X axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, PowerGadgets will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • When using the FirstLabel property in the X Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When X Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the major interval of the primary X axis to 50:

out-chart -AxisX_Step 50

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Style property of Axis Parameter

AxisX_Style Parameter

Allows you to add additional styles to the selected axis.

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use + sign to add (bitwise Or) the property, and - sign to remove (bitwise And Not) propety.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Example

To set an interlaced Grid and Hide Labels in the primary X Axis:

out-chart -AxisX_Style +HideText

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_TextColor property of AxisSectionBase Parameter

AxisX_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the X axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisX_Sections_0_TextColor Red

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisX_Title property of Axis Parameter

AxisX_Title Parameter

Sets the title for a specific axis.

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Parameter. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's property.

  • Below is a chart with both X and X Axis titles:

Example

This sample sets the "Unit Sales (In millions)" to the X Axis:

out-chart -AxisX_Title_Text "Unit Sales (In Millions)"

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


Title Class Members

Chart_AxisX_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AxisX_Title_Alignment property of Title Parameter

AxisX_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_BackColor property of Title Parameter

AxisX_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_Font property of Title Parameter

AxisX_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_Indentation property of Title Parameter

AxisX_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the X axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_LineAlignment property of Title Parameter

AxisX_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_PlotAreaOnly property of TitleDockable Parameter

AxisX_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_RichText property of Title Parameter

AxisX_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_Separation property of Title Parameter

AxisX_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_Text property of Title Parameter

AxisX_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Title_TextColor property of Title Parameter

AxisX_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AxisX_Title Parameter | Chart_AxisX_Title Summary


AxisX_Visible property of Axis Parameter

AxisX_Visible Parameter

Shows or hides the lines, labels, tick marks and grids for the selected axis.

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the and tick marks are also hidden.

Example

To hide the X axis labels:

out-chart -AxisX_Visible false

See Also

Chart_AxisX Parameter | Chart_AxisX Summary


AxisY property of Chart Parameter

AxisY Parameter

Assigns properties specifically to the primary Y axis of the chart.

Remarks

  • Below, the labels of the primary Y axis are set to blue and are formatted to use 4 decimals.

Example

To set the AxisY Labels Format Decimals to 4:

out-chart -AxisY_LabelsFormat_Decimals 4

See Also

Chart Parameter | Chart Summary


AxisY Class Members

Chart_AxisY Parameters

Parameters

Description

AutoScale | Instructs PowerGadgets to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.
AutoScroll | Enables or disables scrolling in an Axis.
CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
CustomSteps | Allows you to set a custom step for the selected axis.
DataFormat | Used to format the data displayed on point labels and tool tips shown at a mouseover.
FirstLabel | Sets a value used to customize the first label displayed on a selected axis.
Font | Allows you to change the label Font attributes of the selected axis.
ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Inverted | Sets a selected numerical axis max value lesser than the min value.
KeyLabels | Used to assign a key (short) legend to tickmarks in a categorical axis.
LabelAngle | Sets the text rotation for the labels in the selected axis.
Labels | Allows you to get or set tick marks labels for the selected axis.
LabelsFormat | Used to format the labels displayed on the selected axis.
LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
Line | Allows you to apply supported Line members to a selected axis line.
LineSpacing | Sets a value indicating the LineSpacing for an axis.
LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
Max | Defines the maximum value of a specific axis.
Min | Defines the minimum value of a selected axis.
MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
Pane | Sets an integer value specifying the Pane for an Y Axis object.
PixelsPerUnit | Gives you the ability to control how many pixels per unit are there in the selected axis.
Position | Specifies the placement of the axis labels and tick marks relative to the chart.
ScaleUnit | Returns or sets the scale unit of a selected axis.
ScrollPosition | Allows you to set the starting scroll position when a chart is scrollable.
Sections | Returns a selected AxisSection object.
Separation | Allows you to specify a gap in pixels between multiple axis.
Staggered | Alternates the level of the axis labels for the selected axis labels.
Step | Specifies the interval of major tick marks and gridlines on the selected axis.
Style | Allows you to add additional styles to the selected axis.
TextColor | Sets the color for text of a selected BaseAxisSection object.
Title | Sets the title for a specific axis.
Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AxisY_AutoScale property of Axis Parameter

AxisY_AutoScale Parameter

Instructs Chart FX to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.

Remarks

  • If you set a Min or Max value and new data is received by the chart when the AutoScale property is enabled, the scale values will be overwritten by PowerGadgets . This method will not affect the Step property if it has previously set to a specific value. If you want the AutoScale property to recalculate the Step value, make sure the Step property is set to zero (0).

Example

To enable the AutoScale feature for the primary Y axis:

out-chart -AxisY_AutoScale true

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_AutoScroll property of Axis Parameter

AxisY_AutoScroll Parameter

Enables or disables scrolling in an Axis.

Remarks

  • When the axis is a categorical axis and the number of data points (or tick marks) do not fit in one screen PowerGadgets will display a scroll bar so the end user can scroll through the data (maintaining the tick mark separation set with the property). This is particularly useful when the labels associated with tick marks are long strings but still important to improve chart's readability or when a particular marker separation is important.

    In some other cases, having a scroll bar associated with the axis is not desired and you can use this property to force PowerGadgets to display all data points in one screen. If you have a large number of points or long strings associated with tick marks this could affect the chart's readability and you'll need to reset the labels associated with the tick marks in the Y axis.

  • To scroll a chart, you may use the keyboard arrows or the drag the scroll thumb with your mouse cursor.

Example

To enable chart scrolling in the Y axis:

out-chart -AxisY_AutoScroll true

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_CustomGridLines_<index> property of Axis Parameter

AxisY_CustomGridLines_<index> Parameter

Gets the collection of CustomGridLines that belong to the Chart.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the that they are assigned to.

Example

The following example show how to create a CustomGridLine on the Y Axis, located at 100 and with a "Upper Limit" text:

out-chart -AxisY_CustomGridLines_0_Value 100 -AxisY_CustomGridLines_0_Text "Upper Limit"

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


CustomGridLine Class Members

Chart_AxisY_CustomGridLines Parameters

Parameters

Description

Alignment | Sets or get the Alignment for the Label in the CustomGridLine.
Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
Font | Sets the Font utilized for the Label within the CustomGridLine.
LineAlignment | Sets the alignment for the Text line relative to the CustomeGridLine.
OutsideText | Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.
ShowLine | Set the ShowLine, which shows or hides the CustomGridLine line.
ShowText | Set the Showtext, which shows or hides the CustomGridLine text.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Text | Set the Text for a label in a CustomGridLine.
TextColor | Set the Text Colot for a label in a CustomGridLine.
Value | Sets the Value for the CustomGridLine;
Width | Sets the line width for a selected line.


AxisY_CustomGridLines_<index>_Alignment property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_Alignment Parameter

Sets or get the Alignment for the Label in the CustomGridLine.

Remarks

  • The Alignment will position the CustomGridLine Label in the desired location.

  • The possible values are Center, Far, Near.

  • This property will also take effect, if set to Far or Near, when the OutsideText is the to true.

  • For more information on StringAlignment see the PowerShell documentation.

Example

To center the CustomGridLine text:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_Alignment Center

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Color property of Line Parameter

AxisY_CustomGridLines_<index>_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y Axis lines to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_EndCap property of Line Parameter

AxisY_CustomGridLines_<index>_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_EndCap RoundAnchor

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Font property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_Font Parameter

Sets the Font utilized for the Label within the CustomGridLine.

Remarks

  • When setting a font for a CustomGridLine label, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=Italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

  • You can set the font for the entire chart using the Parameter property.

Example

To center the CustomGridLine text:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_Font "Arial, 14"

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_LineAlignment property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_LineAlignment Parameter

Sets the alignment for the Text line relative to the CustomeGridLine.

Remarks

  • The LineAlignment will position the Text label line in the desired location.

  • he possible values are Center, Far, Near.

  • This property will also take effect when the OutsideText is the to true.

Example

To center the CustomGridLine text Line:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_LineAlignment Center

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_OutsideText property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_OutsideText Parameter

Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.

Remarks

  • When this property is set to True, the text associated with the CustomGridLine is placed outside the charting area.

  • Alignment and LineAlignment settings will still apply when this proprty is set to true.

  • In the following chart, the constant line text is set as OutsideText:

Example

To place the CustomGridLine label outside the Chart area:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_OutsideText true

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_ShowLine property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_ShowLine Parameter

Set the ShowLine, which shows or hides the CustomGridLine line.

Remarks

  • When you hide a CustomGridLine line using this property, any text associated with the line will remain in the chart. Use the ShowText property to show or hide the CustomGridLine text.

Example

To hide the line in a CustomGridLine:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_ShowLine false

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_ShowText property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_ShowText Parameter

Set the Showtext, which shows or hides the CustomGridLine text.

Remarks

  • When you hide a CustomGridLine test using this property, any Line associated will remain in the chart. Use the ShowLine property to show or hide the CustomGridLine line.

Example

To hide the text in a CustomGridLine:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_ShowText false

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_StartCap property of Line Parameter

AxisY_CustomGridLines_<index>_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_StartCap RoundAnchor

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Style property of Line Parameter

AxisY_CustomGridLines_<index>_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Text property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_Text Parameter

Set the Text for a label in a CustomGridLine.

Remarks

  • When the CustomGridLine line is associated with any of the Y axes, the default text alignment is Near (Left). On the other hand, if the label is associated with the Y axis the default text alignment is Near (bottom). You can modify the text alignment with the Alignment property.

  • To change the font for the text laber in the CustomGridLine, use the Font property.

  • To change the text color using the TextColor property.

Example

To add a CustomGridLine with the "Break Even" label in the Y Axis:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Break Even"

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_TextColor property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_TextColor Parameter

Set the Text Colot for a label in a CustomGridLine.

Remarks

  • The TextColor property is used to set a color for the specified customGridLine.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the text Color to red:

out-chart -AxisY_CustomGridLines_0_Value 50 -AxisY_CustomGridLines_0_Text "Custom Line" -AxisY_CustomGridLines_0_TextColor Red

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Value property of CustomGridLine Parameter

AxisY_CustomGridLines_<index>_Value Parameter

Sets the Value for the CustomGridLine;

Remarks

  • The value of the CustomGridLine goes in strict relationship with the Axis scale that is related to, as follows:

    - If the CustomGridLine is associated with a numerical axis, the value of the constant is a double according to the scale values set for that particular axis. Please remember a CustomGridLine may be associated to the Y axis in an XY Plot where the Y axis is a numerical axis with specific scale values.

    - If the CustomGridLine is associated with a categorical axis (Y axis in charts other than XY Plots), the value is an integer specifying the point index you want to associate the CustomGridLine to. In these cases, the constant line will be drawn starting at the Major tick mark for the selected point.

  • Please note that if you set a CustomGridLine out of the range of the visible axis scale values, PowerGadgets will not recalculate the scale and you must set the Min and Max accordingly so the constant line can be seen.

    For example, if you set a value of 1000 for a constant line in the Y axis, while the Y axis scale is from 0 to 500. The constant line will not be visible and you must set a new maximum value using the Max parameter.

Example

To add a CustomGridLine to the Y Axis at 50.75:

out-chart -AxisY_CustomGridLines_0_Value 50.75 -AxisY_CustomGridLines_0_Text "Custom Line"

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomGridLines_<index>_Width property of Line Parameter

AxisY_CustomGridLines_<index>_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AxisY_CustomGridLines Parameter | Chart_AxisY_CustomGridLines Summary


AxisY_CustomSteps property of Axis Parameter

AxisY_CustomSteps Parameter

Allows you to set a custom step for the selected axis.

Remarks

  • The CustomSteps property holds an array of numbers (double) that specifies a series of step values for the selected axis.

  • The step applied to the axis will begin to cycle if your chart contains enough points. For example, if you set the CustomStep to (5,10,20,30) the axis step would look like:

    0,5,15,35,65,70,80,100,130,135,...

Example

Set a custom step for the Y axis:

out-chart -AxisY_CustomSteps 5,10,20

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_DataFormat property of Axis Parameter

AxisY_DataFormat Parameter

Used to format the data displayed on point labels and tool tips shown at a mouseover.

Remarks

  • The LabelsFormat property can be used to format the selected axis labels.

  • Setting this property for the chart will also format data viewed via the PowerGadgets MenuBar.

Example

To set the data format for the Y axis data values to currency:

out-chart -AxisY_DataFormat_Format Currency

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


ValueFormat Class Members

Chart_AxisY_DataFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisY_DataFormat_Culture property of ValueFormat Parameter

AxisY_DataFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its Y axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisY_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisY_DataFormat Parameter | Chart_AxisY_DataFormat Summary


AxisY_DataFormat_CustomFormat property of ValueFormat Parameter

AxisY_DataFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the Y axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisY_LabelsFormat_Format Date -AxisY_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisY_DataFormat Parameter | Chart_AxisY_DataFormat Summary


AxisY_DataFormat_Decimals property of ValueFormat Parameter

AxisY_DataFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y Axis data values:

out-chart -AxisY_DataFormat_Decimals 3

See Also

Chart_AxisY_DataFormat Parameter | Chart_AxisY_DataFormat Summary


AxisY_DataFormat_Format property of ValueFormat Parameter

AxisY_DataFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary Y axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisY_LabelsFormat_Culture "fr-FR" -AxisY_LabelsFormat_Format Currency

See Also

Chart_AxisY_DataFormat Parameter | Chart_AxisY_DataFormat Summary


AxisY_FirstLabel property of Axis Parameter

AxisY_FirstLabel Parameter

Sets a value used to customize the first label displayed on a selected axis.

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the Y Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y Axis values range >1, then the axis' Step is used for this calcuation.

Example

To make the 3rd point the first label in the Y-axis:

out-chart -AxisY_FirstLabel 3

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Font property of Axis Parameter

AxisY_Font Parameter

Allows you to change the label Font attributes of the selected axis.

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Property of the object.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the PowerShell Documentation.

Example

If you want to change the main Y axis labels font settings:

out-chart -AxisY_Font "Arial, 14"

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_ForceZero property of Axis Parameter

AxisY_ForceZero Parameter

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

Remarks

  • By default, PowerGadgets will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want PowerGadgets to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Example

To force PowerGadgets to set the minimum value of the Y axis to the minimum value passed to the chart.

out-chart -AxisY_ForceZero false

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Grids property of AxisSectionBase Parameter

AxisY_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


Grids Class Members

Chart_AxisY_Grids Parameters

Parameters

Description

Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
InterlacedColor | Sets the AlternateColor for a selected Grids object.
Major | Provides access to the GridLine to customize the Mayor Grid.
Minor | Provides access to the GridLine to customize the Minor Grid.


AxisY_Grids_Interlaced property of Grids Parameter

AxisY_Grids_Interlaced Parameter

Creates a grid of alternating colors for a selected axis to improve chart readability.

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

Example

To set an Interlaced grid on the Y Axis:

out-chart -AxisY_Grids_Interlaced true

See Also

Chart_AxisY_Grids Parameter | Chart_AxisY_Grids Summary


AxisY_Grids_InterlacedColor property of Grids Parameter

AxisY_Grids_InterlacedColor Parameter

Sets the AlternateColor for a selected Grids object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To configure the Grids InterleacedColor to red:

out-chart -AxisY_Grids_InterlacedColor Red

See Also

Chart_AxisY_Grids Parameter | Chart_AxisY_Grids Summary


AxisY_Grids_Major property of Grids Parameter

AxisY_Grids_Major Parameter

Provides access to the GridLine class to customize the Mayor Grid.

Remarks

  • The Major interval is controlled by the Axis Step parameter.

Example

To show the Major gridlines for the Y Axis:

out-chart -AxisY_Grids_Major_Visible true

See Also

Chart_AxisY_Grids Parameter | Chart_AxisY_Grids Summary


GridLine Class Members

Chart_AxisY_Grids_Major Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisY_Grids_Major_Color property of Line Parameter

AxisY_Grids_Major_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y Axis lines to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_EndCap property of Line Parameter

AxisY_Grids_Major_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_EndCap RoundAnchor

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_StartCap property of Line Parameter

AxisY_Grids_Major_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_StartCap RoundAnchor

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_Style property of Line Parameter

AxisY_Grids_Major_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_TickMark property of GridLine Parameter

AxisY_Grids_Major_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y Axis:

out-chart -AxisY_Grids_Major_TickMark Cross

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_Visible property of GridLine Parameter

AxisY_Grids_Major_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y Axis:

out-chart -AxisY_MinorStep 5 -AxisY_Grids_Minor_Visible true

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Major_Width property of Line Parameter

AxisY_Grids_Major_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AxisY_Grids_Major Parameter | Chart_AxisY_Grids_Major Summary


AxisY_Grids_Minor property of Grids Parameter

AxisY_Grids_Minor Parameter

Provides access to the GridLine class to customize the Minor Grid.

Remarks

  • The minor interval is controlled by the MinorStep parameter, which must be set in order to use the Minor Grid.

  • The minor interval is controlled by the Property, which must be set in order to use the Minor Grid.

Example

To show the Minor gridlines for the Y Axis:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AxisY_Grids Parameter | Chart_AxisY_Grids Summary


GridLine Class Members

Chart_AxisY_Grids_Minor Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisY_Grids_Minor_Color property of Line Parameter

AxisY_Grids_Minor_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y Axis lines to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_EndCap property of Line Parameter

AxisY_Grids_Minor_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_EndCap RoundAnchor

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_StartCap property of Line Parameter

AxisY_Grids_Minor_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_StartCap RoundAnchor

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_Style property of Line Parameter

AxisY_Grids_Minor_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_TickMark property of GridLine Parameter

AxisY_Grids_Minor_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y Axis:

out-chart -AxisY_Grids_Major_TickMark Cross

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_Visible property of GridLine Parameter

AxisY_Grids_Minor_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y Axis:

out-chart -AxisY_MinorStep 5 -AxisY_Grids_Minor_Visible true

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Grids_Minor_Width property of Line Parameter

AxisY_Grids_Minor_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AxisY_Grids_Minor Parameter | Chart_AxisY_Grids_Minor Summary


AxisY_Inverted property of Axis Parameter

AxisY_Inverted Parameter

Sets a selected numerical axis max value lesser than the min value.

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the Y Axis in an XY plot chart. In an XY plot, the Y Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

Example

Set the Y Axis to be inverted:

out-chart -AxisY_Inverted true

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_KeyLabels property of Axis Parameter

AxisY_KeyLabels Parameter

Used to assign a key (short) legend to tickmarks in a categorical axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index specifying the tickmark you want to assign the key legend.

Remarks

  • You normally use the Labels property to assign labels to the tickmarks in the Y axis (when it is categorical). However, depending on the amount of points in the chart, these labels may be too long to properly fit in the space allotted for each tickmark in the Y axis.

  • You can control the frequency or how labels are displayed with other properties supported by the Axis object, sometimes you still have space limitations because of the size of the chart or the number of points.

  • This property can help you display shorter labels in the Y axis while maintaining longer labels in the legend window. Let's give you an example:

    Let's suppose you have assigned the following labels to the Y axis using the Label property:

    "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"

    Now, these labels may or may not fit in the space allotted for each tickmark in the Y axis. If one of them does not fit, PowerGadgets will immediately display a TAG (red number) indicating that such label can not fit in the space allotted for it. This problem increases as the number of points in the chart increase.

    With this property you can assign key labels (shorter strings) like: "Jan","Feb","Mar",Apr", etc... that will be displayed in the Y axis itself, while the Legend window will display both the Key Legend and the Legend set with the Label property.

Example

To assign a key label to the first tickmark in the Y axis:

out-chart -AxisY_KeyLabels_0 "Jan"

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_LabelAngle property of Axis Parameter

AxisY_LabelAngle Parameter

Sets the text rotation for the labels in the selected axis.

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the property of the Parameter.

Example

To set vertical text labels in the Y Axis:

out-chart -AxisY_LabelAngle 90

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Labels property of Axis Parameter

AxisY_Labels Parameter

Allows you to get or set tick marks labels for the selected axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index indicating the Label index for the axis.

Remarks

  • This property is used to read or write labels for a categorical axis. Normally, the Y axis is a categorical axis containing labels associated with each major tick mark, while the Y axis is a numerical axis where labels are controlled by the scale (Min, Max, etc) and numerical data contained in the chart.

  • You can set as many labels as points are available in the chart. These labels will be shown in the major tick marks of the selected axis. Some of them can be left empty so no labels are shown on that specific major tick mark.

  • You can control how frequent these labels are displayed by using the Step property. Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

  • By default, PowerGadgets does not associate any labels to the categorical axis (Y axis) and a "TAG" number will be shown. When you use this property, the TAG numbers will be replaced by settings specified in this property.

  • When used in conjunction with the LabelValue property, this property can be used to set string values to a numerical axis.

Example

To modify the Y axis first label for the chart:

out-chart -AxisY_Labels_0 "Custom Label"

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_LabelsFormat property of Axis Parameter

AxisY_LabelsFormat Parameter

Used to format the labels displayed on the selected axis.

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Example

Set the Y Axis labels to the currency format:

out-chart -AxisY_LabelsFormat_Format Currency

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


ValueFormat Class Members

Chart_AxisY_LabelsFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisY_LabelsFormat_Culture property of ValueFormat Parameter

AxisY_LabelsFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its Y axis labels set to the "Chinese-China" culture:

Example

To set the Y Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -AxisY_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisY_LabelsFormat Parameter | Chart_AxisY_LabelsFormat Summary


AxisY_LabelsFormat_CustomFormat property of ValueFormat Parameter

AxisY_LabelsFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the Y axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -AxisY_LabelsFormat_Format Date -AxisY_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisY_LabelsFormat Parameter | Chart_AxisY_LabelsFormat Summary


AxisY_LabelsFormat_Decimals property of ValueFormat Parameter

AxisY_LabelsFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y Axis data values:

out-chart -AxisY_DataFormat_Decimals 3

See Also

Chart_AxisY_LabelsFormat Parameter | Chart_AxisY_LabelsFormat Summary


AxisY_LabelsFormat_Format property of ValueFormat Parameter

AxisY_LabelsFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y axis are formatted as to the US currency:

  • Similarly, the labels of the Y axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary Y axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -AxisY_LabelsFormat_Culture "fr-FR" -AxisY_LabelsFormat_Format Currency

See Also

Chart_AxisY_LabelsFormat Parameter | Chart_AxisY_LabelsFormat Summary


AxisY_LabelValue property of Axis Parameter

AxisY_LabelValue Parameter

Allows you to set associate text labels to major tick marks in a numerical axis.This property can get or set the LabelValue assigned to any of the axes.

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the Y axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default PowerGadgets will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the Y axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 PowerGadgets will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

Example

To set a LabelValue of 25 for the primary Y axis:

out-chart -AxisY_LabelValue 25

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Line property of Axis Parameter

AxisY_Line Parameter

Allows you to apply supported Line class members to a selected axis line.

Remarks

  • You may control the , and of the selected line using the supported members of the Line Parameter.

  • The and properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the Y axis line color to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


Line Class Members

Chart_AxisY_Line Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Width | Sets the line width for a selected line.


AxisY_Line_Color property of Line Parameter

AxisY_Line_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y Axis lines to Red:

out-chart -AxisY_Line_Color Red

See Also

Chart_AxisY_Line Parameter | Chart_AxisY_Line Summary


AxisY_Line_EndCap property of Line Parameter

AxisY_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_EndCap RoundAnchor

See Also

Chart_AxisY_Line Parameter | Chart_AxisY_Line Summary


AxisY_Line_StartCap property of Line Parameter

AxisY_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y axis line to a 'RoundAnchor' shape:

out-chart -AxisY_Line_StartCap RoundAnchor

See Also

Chart_AxisY_Line Parameter | Chart_AxisY_Line Summary


AxisY_Line_Style property of Line Parameter

AxisY_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_AxisY_Line Parameter | Chart_AxisY_Line Summary


AxisY_Line_Width property of Line Parameter

AxisY_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_AxisY_Line Parameter | Chart_AxisY_Line Summary


AxisY_LineSpacing property of Axis Parameter

AxisY_LineSpacing Parameter

Sets a value indicating the LineSpacing for an axis.

Remarks

  • This property specifies the LineSpacing for vertical axes. The labels in the selected axis will never be painted less than the configured LineSpacing.

  • Setting the LineSpacing property to 2 will instruct the axis to use double line spacing. Setting the value to 1 instructs the chart to use single line spacing. The default value is 1.5.

Example

To configure an Axis to use double line spacing:

out-chart -AxisY_LineSpacing 2

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_LogBase property of Axis Parameter

AxisY_LogBase Parameter

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

Example

To set a Logarithmic scale and recalculate values as powers of 10 in the primary Y axis:

out-chart -AxisY_LogBase 10

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Max property of Axis Parameter

AxisY_Max Parameter

Defines the maximum value of a specific axis.Sets the Max value assigned to the specified axis.

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, PowerGadgets will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Example

To set the Max value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Min property of Axis Parameter

AxisY_Min Parameter

Defines the minimum value of a selected axis.Sets the Min value assigned to the specified axis.

Remarks

  • The Min property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Min property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Min property.

  • If no Min value is specified, PowerGadgets will automatically set a minimum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Min property must be lesser than the value of the Max property.

  • There is no automatic method for aligning a main and secondary axis, it is required that you set the Min and Max in order to align them manually. The generic algorithm used to find these values is the following:

Example

To set the Min value of the primary Y axis to 10:

out-chart -AxisY_Min 10 -AxisY_Max 90

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_MinorStep property of Axis Parameter

AxisY_MinorStep Parameter

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the Y Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the minor interval of the primary Y axis to 2:

out-chart -AxisY_MinorStep 2

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Pane property of AxisY Parameter

AxisY_Pane Parameter

Sets an integer value specifying the Pane for an Y Axis object.

Remarks

  • Additional Y axes may be assigned to panes in a chart. Once an Y axis object is assigned to a pane, that pane will be visible in the chart area. Data also associated with the selected Y axis will also be applied to the configured pane.

Example

To set the Y axis Pane BackColor property to blue:

out-chart -AxisY_Pane_BackColor Blue

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_PixelsPerUnit property of Axis Parameter

AxisY_PixelsPerUnit Parameter

Gives you the ability to control how many pixels per unit are there in the selected axis.This property is very useful if you want a scroll bar in the selected axis.

Remarks

  • The does not support scrolling capabilities. Therefore, this property is not supported for the Secondary Y axis.

  • If the AutoScroll property is set to False, the PixelsPerUint will not have any effect on the axis. So make sure the AutoScroll property is set to True when using the PixelsPerUint property.

Example

To separate tick marks in the Y axis by 60 pixels:

out-chart -AxisY_AutoScroll true -AxisY_PixelsPerUnit 60

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Position property of Axis Parameter

AxisY_Position Parameter

Specifies the placement of the axis labels and tick marks relative to the chart.

Value | Meaning
Near | Specifies the axis line be placed near the chart in the following way: In a Y axis, the axis line be below the chart. In Y axis, the axis line be left to the chart.
Center | Specifies that axis line placed in the center of the chart.
Far | Specifies that axis line is placed far from the chart in the following way: In a Y axis, the axis line be above the chart. In a Y axis, the axis line is right to the chart.

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Multiple axes may be created using the AxesX and the properties of the Parameter.

Example

To move the labels and tick marks for the X and Y axes to the top and right of the chart:

out-chart -AxisY_Position Far -AxisY_Position Far

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_ScaleUnit property of Axis Parameter

AxisY_ScaleUnit Parameter

Returns or sets the scale unit of a selected axis.

Remarks

  • This constant is very useful when the values used on the Y axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the Y axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Example

To set the Scale Unit of the primary Y axis to 1000:

out-chart -AxisY_ScaleUnit 1000

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_ScrollPosition property of Axis Parameter

AxisY_ScrollPosition Parameter

Allows you to set the starting scroll position when a chart is scrollable.

Remarks

  • Your chart must be set to AutoScroll in order for this property to be used properly.

  • When you set the ScrollPosition, the first point included in the chart will be the configured point.

Example

Set the scroll position for the Y axis to 50:

out-chart -AxisY_ScrollPosition 50

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Sections_<index> property of Axis Parameter

AxisY_Sections_<index> Parameter

Returns a selected AxisSection object.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection Parameter. Please see the Parameter for additional information regarding those supported members.

Example

To set the To value for a selected AxisSection object:

out-chart -AxisY_Sections_0_To 25

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisSection Class Members

Chart_AxisY_Sections Parameters

Parameters

Description

BackColor | Sets the AxisSection background color.
FontStyle | Sets additional font attributes to the axis section.
From | Sets a value indicating the beginning value of the range for a selected object.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Text | Sets the text string for a selected BaseAxisSection object.
TextColor | Sets the color for text of a selected BaseAxisSection object.
To | Sets a value indicating the ending value of the range the axis section.
Visible | Shows or hides the selected axis section.


AxisY_Sections_<index>_BackColor property of AxisSection Parameter

AxisY_Sections_<index>_BackColor Parameter

Sets the AxisSection background color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Changes the background color of the first section of to yellow:

out-chart -AxisY_Sections_0_BackColor Yellow

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_FontStyle property of AxisSection Parameter

AxisY_Sections_<index>_FontStyle Parameter

Sets additional font attributes to the axis section.

Remarks

Example

Specifies that the text associated with the first AxisSection object of the will be bold:

out-chart -AxisY_Sections_0_FontStyle Bold

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_From property of AxisSection Parameter

AxisY_Sections_<index>_From Parameter

Sets a value indicating the beginning value of the range for a selected AxisSection object.

Remarks

  • The To property is used to specify the ending value of the section range for a selected Axis Section.

  • The To property is used to specify the ending value of the section range for a selected object.

Example

To configure the From value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_From 30

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_Grids property of AxisSectionBase Parameter

AxisY_Sections_<index>_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -AxisY_Grids_Minor_Visible true

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_Text property of AxisSection Parameter

AxisY_Sections_<index>_Text Parameter

Sets the text string for a selected BaseAxisSection object.

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Example

To set text to a section, SampleSection:

out-chart -AxisY_Sections_0_Text "SampleText"

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_TextColor property of AxisSectionBase Parameter

AxisY_Sections_<index>_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_To property of AxisSection Parameter

AxisY_Sections_<index>_To Parameter

Sets a value indicating the ending value of the range the axis section.

Remarks

  • The From property is used to specify the beginning value of the section range for a selected Axis Section.

Example

To configure the To value for the 1st axis section of the Y Axis:

out-chart -AxisY_Sections_0_To 60

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Sections_<index>_Visible property of AxisSection Parameter

AxisY_Sections_<index>_Visible Parameter

Shows or hides the selected axis section.

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Example

To hide the axis section:

out-chart -AxisY_Sections_0_Visible false

See Also

Chart_AxisY_Sections Parameter | Chart_AxisY_Sections Summary


AxisY_Separation property of Axis Parameter

AxisY_Separation Parameter

Allows you to specify a gap in pixels between multiple axis.

Remarks

  • This property is useful when multiple axes are configured and you need to create space for readability.

Example

To configure a 5 pixel separation on the secondary Y axis:

out-chart -AxisY_Separation 5

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Staggered property of Axis Parameter

AxisY_Staggered Parameter

Alternates the level of the axis labels for the selected axis labels.

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

Example

To stagger axis labels on two levels:

out-chart -AxisY_Staggered true

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Step property of Axis Parameter

AxisY_Step Parameter

Specifies the interval of major tick marks and gridlines on the selected axis.It also controls the gap or interval between labels in the selected axis.

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your Y axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, PowerGadgets will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • When using the FirstLabel property in the Y Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the major interval of the primary Y axis to 50:

out-chart -AxisY_Step 50

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Style property of Axis Parameter

AxisY_Style Parameter

Allows you to add additional styles to the selected axis.

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use + sign to add (bitwise Or) the property, and - sign to remove (bitwise And Not) propety.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Example

To set an interlaced Grid and Hide Labels in the primary Y Axis:

out-chart -AxisY_Style +HideText

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_TextColor property of AxisSectionBase Parameter

AxisY_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -AxisY_Sections_0_TextColor Red

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY_Title property of Axis Parameter

AxisY_Title Parameter

Sets the title for a specific axis.

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Parameter. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's property.

  • Below is a chart with both X and Y Axis titles:

Example

This sample sets the "Unit Sales (In millions)" to the Y Axis:

out-chart -AxisY_Title_Text "Unit Sales (In Millions)"

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


Title Class Members

Chart_AxisY_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AxisY_Title_Alignment property of Title Parameter

AxisY_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the Y axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the Y axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_BackColor property of Title Parameter

AxisY_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_Font property of Title Parameter

AxisY_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_Indentation property of Title Parameter

AxisY_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_LineAlignment property of Title Parameter

AxisY_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_PlotAreaOnly property of TitleDockable Parameter

AxisY_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_RichText property of Title Parameter

AxisY_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_Separation property of Title Parameter

AxisY_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the Y axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_Text property of Title Parameter

AxisY_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Title_TextColor property of Title Parameter

AxisY_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AxisY_Title Parameter | Chart_AxisY_Title Summary


AxisY_Visible property of Axis Parameter

AxisY_Visible Parameter

Shows or hides the lines, labels, tick marks and grids for the selected axis.

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the and tick marks are also hidden.

Example

To hide the Y axis labels:

out-chart -AxisY_Visible false

See Also

Chart_AxisY Parameter | Chart_AxisY Summary


AxisY2 property of Chart Parameter

AxisY2 Parameter

Assigns properties specifically to the secondary Y2 axis of the chart.

Remarks

  • By default, the secondary Y2 axis is not visible. This axis needs to be associated to a series in order to be rendered by the chart.

  • Below, the second series of the chart is associated to the secondary Y2 axis.

Example

Sets the second series to the secondary Y2 axis. The scale of this axis is also changed.

out-chart -Series_1_AxisY2 AxisY2 -AxisY2_Min 10 -AxisY2_Max 500

See Also

Chart Parameter | Chart Summary


AxisY Class Members

Chart_AxisY2 Parameters

Parameters

Description

AutoScale | Instructs PowerGadgets to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.
AutoScroll | Enables or disables scrolling in an Axis.
CustomGridLines | Gets the collection of CustomGridLines that belong to the Chart.
CustomSteps | Allows you to set a custom step for the selected axis.
DataFormat | Used to format the data displayed on point labels and tool tips shown at a mouseover.
FirstLabel | Sets a value used to customize the first label displayed on a selected axis.
Font | Allows you to change the label Font attributes of the selected axis.
ForceZero | Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Inverted | Sets a selected numerical axis max value lesser than the min value.
KeyLabels | Used to assign a key (short) legend to tickmarks in a categorical axis.
LabelAngle | Sets the text rotation for the labels in the selected axis.
Labels | Allows you to get or set tick marks labels for the selected axis.
LabelsFormat | Used to format the labels displayed on the selected axis.
LabelValue | Allows you to set associate text labels to major tick marks in a numerical axis.
Line | Allows you to apply supported Line members to a selected axis line.
LineSpacing | Sets a value indicating the LineSpacing for an axis.
LogBase | Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.
Max | Defines the maximum value of a specific axis.
Min | Defines the minimum value of a selected axis.
MinorStep | Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.
Pane | Sets an integer value specifying the Pane for an Y Axis object.
PixelsPerUnit | Gives you the ability to control how many pixels per unit are there in the selected axis.
Position | Specifies the placement of the axis labels and tick marks relative to the chart.
ScaleUnit | Returns or sets the scale unit of a selected axis.
ScrollPosition | Allows you to set the starting scroll position when a chart is scrollable.
Sections | Returns a selected AxisSection object.
Separation | Allows you to specify a gap in pixels between multiple axis.
Staggered | Alternates the level of the axis labels for the selected axis labels.
Step | Specifies the interval of major tick marks and gridlines on the selected axis.
Style | Allows you to add additional styles to the selected axis.
TextColor | Sets the color for text of a selected BaseAxisSection object.
Title | Sets the title for a specific axis.
Visible | Shows or hides the lines, labels, tick marks and grids for the selected axis.


AxisY2_AutoScale property of Axis Parameter

AxisY2_AutoScale Parameter

Instructs Chart FX to always recalculate the specified Axis scale values (Min, Max) when new values are set to the chart.

Remarks

  • If you set a Min or Max value and new data is received by the chart when the AutoScale property is enabled, the scale values will be overwritten by PowerGadgets . This method will not affect the Step property if it has previously set to a specific value. If you want the AutoScale property to recalculate the Step value, make sure the Step property is set to zero (0).

Example

To enable the AutoScale feature for the primary Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_AutoScale true

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_AutoScroll property of Axis Parameter

AxisY2_AutoScroll Parameter

Enables or disables scrolling in an Axis.

Remarks

  • When the axis is a categorical axis and the number of data points (or tick marks) do not fit in one screen PowerGadgets will display a scroll bar so the end user can scroll through the data (maintaining the tick mark separation set with the property). This is particularly useful when the labels associated with tick marks are long strings but still important to improve chart's readability or when a particular marker separation is important.

    In some other cases, having a scroll bar associated with the axis is not desired and you can use this property to force PowerGadgets to display all data points in one screen. If you have a large number of points or long strings associated with tick marks this could affect the chart's readability and you'll need to reset the labels associated with the tick marks in the Y2 axis.

  • To scroll a chart, you may use the keyboard arrows or the drag the scroll thumb with your mouse cursor.

Example

To enable chart scrolling in the Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_AutoScroll true

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_CustomGridLines_<index> property of Axis Parameter

AxisY2_CustomGridLines_<index> Parameter

Gets the collection of CustomGridLines that belong to the Chart.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the CustomGridLine to get or set.

Remarks

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the Axis that they are assigned to.

  • CustomGridLines are lines that you can draw anywhere in the chart area and they associate themselves with a particular value in the that they are assigned to.

Example

The following example show how to create a CustomGridLine on the Y2 Axis, located at 100 and with a "Upper Limit" text:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 100 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Upper Limit"

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


CustomGridLine Class Members

Chart_AxisY2_CustomGridLines Parameters

Parameters

Description

Alignment | Sets or get the Alignment for the Label in the CustomGridLine.
Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
Font | Sets the Font utilized for the Label within the CustomGridLine.
LineAlignment | Sets the alignment for the Text line relative to the CustomeGridLine.
OutsideText | Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.
ShowLine | Set the ShowLine, which shows or hides the CustomGridLine line.
ShowText | Set the Showtext, which shows or hides the CustomGridLine text.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Text | Set the Text for a label in a CustomGridLine.
TextColor | Set the Text Colot for a label in a CustomGridLine.
Value | Sets the Value for the CustomGridLine;
Width | Sets the line width for a selected line.


AxisY2_CustomGridLines_<index>_Alignment property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_Alignment Parameter

Sets or get the Alignment for the Label in the CustomGridLine.

Remarks

  • The Alignment will position the CustomGridLine Label in the desired location.

  • The possible values are Center, Far, Near.

  • This property will also take effect, if set to Far or Near, when the OutsideText is the to true.

  • For more information on StringAlignment see the PowerShell documentation.

Example

To center the CustomGridLine text:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Alignment Center

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Color property of Line Parameter

AxisY2_CustomGridLines_<index>_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y2 Axis lines to Red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Color Red

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_EndCap property of Line Parameter

AxisY2_CustomGridLines_<index>_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_EndCap RoundAnchor

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Font property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_Font Parameter

Sets the Font utilized for the Label within the CustomGridLine.

Remarks

  • When setting a font for a CustomGridLine label, you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=Italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

  • You can set the font for the entire chart using the Parameter property.

Example

To center the CustomGridLine text:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Font "Arial, 14"

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_LineAlignment property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_LineAlignment Parameter

Sets the alignment for the Text line relative to the CustomeGridLine.

Remarks

  • The LineAlignment will position the Text label line in the desired location.

  • he possible values are Center, Far, Near.

  • This property will also take effect when the OutsideText is the to true.

Example

To center the CustomGridLine text Line:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_LineAlignment Center

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_OutsideText property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_OutsideText Parameter

Set the OutsideText which controls the positioning of the CustomGridLine label outside the chart area.

Remarks

  • When this property is set to True, the text associated with the CustomGridLine is placed outside the charting area.

  • Alignment and LineAlignment settings will still apply when this proprty is set to true.

  • In the following chart, the constant line text is set as OutsideText:

Example

To place the CustomGridLine label outside the Chart area:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_OutsideText true

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_ShowLine property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_ShowLine Parameter

Set the ShowLine, which shows or hides the CustomGridLine line.

Remarks

  • When you hide a CustomGridLine line using this property, any text associated with the line will remain in the chart. Use the ShowText property to show or hide the CustomGridLine text.

Example

To hide the line in a CustomGridLine:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_ShowLine false

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_ShowText property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_ShowText Parameter

Set the Showtext, which shows or hides the CustomGridLine text.

Remarks

  • When you hide a CustomGridLine test using this property, any Line associated will remain in the chart. Use the ShowLine property to show or hide the CustomGridLine line.

Example

To hide the text in a CustomGridLine:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_ShowText false

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_StartCap property of Line Parameter

AxisY2_CustomGridLines_<index>_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_StartCap RoundAnchor

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Style property of Line Parameter

AxisY2_CustomGridLines_<index>_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y2 Axis line:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Style DashDot

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Text property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_Text Parameter

Set the Text for a label in a CustomGridLine.

Remarks

  • When the CustomGridLine line is associated with any of the Y axes, the default text alignment is Near (Left). On the other hand, if the label is associated with the Y2 axis the default text alignment is Near (bottom). You can modify the text alignment with the Alignment property.

  • To change the font for the text laber in the CustomGridLine, use the Font property.

  • To change the text color using the TextColor property.

Example

To add a CustomGridLine with the "Break Even" label in the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Break Even"

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_TextColor property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_TextColor Parameter

Set the Text Colot for a label in a CustomGridLine.

Remarks

  • The TextColor property is used to set a color for the specified customGridLine.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the text Color to red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line" -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_TextColor Red

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Value property of CustomGridLine Parameter

AxisY2_CustomGridLines_<index>_Value Parameter

Sets the Value for the CustomGridLine;

Remarks

  • The value of the CustomGridLine goes in strict relationship with the Axis scale that is related to, as follows:

    - If the CustomGridLine is associated with a numerical axis, the value of the constant is a double according to the scale values set for that particular axis. Please remember a CustomGridLine may be associated to the Y2 axis in an XY Plot where the Y2 axis is a numerical axis with specific scale values.

    - If the CustomGridLine is associated with a categorical axis (Y2 axis in charts other than XY Plots), the value is an integer specifying the point index you want to associate the CustomGridLine to. In these cases, the constant line will be drawn starting at the Major tick mark for the selected point.

  • Please note that if you set a CustomGridLine out of the range of the visible axis scale values, PowerGadgets will not recalculate the scale and you must set the Min and Max accordingly so the constant line can be seen.

    For example, if you set a value of 1000 for a constant line in the Y2 axis, while the Y2 axis scale is from 0 to 500. The constant line will not be visible and you must set a new maximum value using the Max parameter.

Example

To add a CustomGridLine to the Y2 Axis at 50.75:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Value 50.75 -Series_0_AxisY AxisY2 -AxisY2_CustomGridLines_0_Text "Custom Line"

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomGridLines_<index>_Width property of Line Parameter

AxisY2_CustomGridLines_<index>_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Width 5

See Also

Chart_AxisY2_CustomGridLines Parameter | Chart_AxisY2_CustomGridLines Summary


AxisY2_CustomSteps property of Axis Parameter

AxisY2_CustomSteps Parameter

Allows you to set a custom step for the selected axis.

Remarks

  • The CustomSteps property holds an array of numbers (double) that specifies a series of step values for the selected axis.

  • The step applied to the axis will begin to cycle if your chart contains enough points. For example, if you set the CustomStep to (5,10,20,30) the axis step would look like:

    0,5,15,35,65,70,80,100,130,135,...

Example

Set a custom step for the Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_CustomSteps 5,10,20

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_DataFormat property of Axis Parameter

AxisY2_DataFormat Parameter

Used to format the data displayed on point labels and tool tips shown at a mouseover.

Remarks

  • The LabelsFormat property can be used to format the selected axis labels.

  • Setting this property for the chart will also format data viewed via the PowerGadgets MenuBar.

Example

To set the data format for the Y2 axis data values to currency:

out-chart -Series_0_AxisY AxisY2 -AxisY2_DataFormat_Format Currency

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


ValueFormat Class Members

Chart_AxisY2_DataFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisY2_DataFormat_Culture property of ValueFormat Parameter

AxisY2_DataFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y2 axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its Y2 axis labels set to the "Chinese-China" culture:

Example

To set the Y2 Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisY2_DataFormat Parameter | Chart_AxisY2_DataFormat Summary


AxisY2_DataFormat_CustomFormat property of ValueFormat Parameter

AxisY2_DataFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the Y2 axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Format Date -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisY2_DataFormat Parameter | Chart_AxisY2_DataFormat Summary


AxisY2_DataFormat_Decimals property of ValueFormat Parameter

AxisY2_DataFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y2 Axis data values:

out-chart -Series_0_AxisY AxisY2 -AxisY2_DataFormat_Decimals 3

See Also

Chart_AxisY2_DataFormat Parameter | Chart_AxisY2_DataFormat Summary


AxisY2_DataFormat_Format property of ValueFormat Parameter

AxisY2_DataFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y2 axis are formatted as to the US currency:

  • Similarly, the labels of the Y2 axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary Y2 axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Culture "fr-FR" -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Format Currency

See Also

Chart_AxisY2_DataFormat Parameter | Chart_AxisY2_DataFormat Summary


AxisY2_FirstLabel property of Axis Parameter

AxisY2_FirstLabel Parameter

Sets a value used to customize the first label displayed on a selected axis.

Remarks

  • The setting must be an integer specifying where you want labels to begin. The axis will then follow the Step associated with it to display subsequent labels.

  • When using this property in the Y2 Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y2 Axis values range >1, then the axis' Step is used for this calcuation.

Example

To make the 3rd point the first label in the Y2-axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_FirstLabel 3

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Font property of Axis Parameter

AxisY2_Font Parameter

Allows you to change the label Font attributes of the selected axis.

Remarks

  • The Font property is used to change the font settings for the labels in the selected axis, if you're trying to change the font settings for the axis title, please refer to the Property of the object.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • For more information regarding the Font type, please refer to the PowerShell Documentation.

Example

If you want to change the main Y2 axis labels font settings:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Font "Arial, 14"

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_ForceZero property of Axis Parameter

AxisY2_ForceZero Parameter

Used to set the minimum value of a numerical axis to zero even if the data minimum value does not start at zero.

Remarks

  • By default, PowerGadgets will set the minimum value of a numerical axis to zero even if the data set starts at a greater value. If you want PowerGadgets to automatically set the minimum value of the axis to the minimum value in the data passed, set this property to FALSE.

  • This property applies to numerical axes only.

Example

To force PowerGadgets to set the minimum value of the Y2 axis to the minimum value passed to the chart.

out-chart -Series_0_AxisY AxisY2 -AxisY2_ForceZero false

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Grids property of AxisSectionBase Parameter

AxisY2_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Minor_Visible true

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


Grids Class Members

Chart_AxisY2_Grids Parameters

Parameters

Description

Interlaced | Creates a grid of alternating colors for a selected axis to improve chart readability.
InterlacedColor | Sets the AlternateColor for a selected Grids object.
Major | Provides access to the GridLine to customize the Mayor Grid.
Minor | Provides access to the GridLine to customize the Minor Grid.


AxisY2_Grids_Interlaced property of Grids Parameter

AxisY2_Grids_Interlaced Parameter

Creates a grid of alternating colors for a selected axis to improve chart readability.

Remarks

  • When you set this property to True, a grid with alternating colors is created for the selected axis. This visual attribute helps the end user distinguish the different value ranges in the chart and easily recognize the value of a particular point.

  • If you use this property for both the X and Y axes, the results show overlapping interlaced grids.

Example

To set an Interlaced grid on the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Interlaced true

See Also

Chart_AxisY2_Grids Parameter | Chart_AxisY2_Grids Summary


AxisY2_Grids_InterlacedColor property of Grids Parameter

AxisY2_Grids_InterlacedColor Parameter

Sets the AlternateColor for a selected Grids object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To configure the Grids InterleacedColor to red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_InterlacedColor Red

See Also

Chart_AxisY2_Grids Parameter | Chart_AxisY2_Grids Summary


AxisY2_Grids_Major property of Grids Parameter

AxisY2_Grids_Major Parameter

Provides access to the GridLine class to customize the Mayor Grid.

Remarks

  • The Major interval is controlled by the Axis Step parameter.

Example

To show the Major gridlines for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Major_Visible true

See Also

Chart_AxisY2_Grids Parameter | Chart_AxisY2_Grids Summary


GridLine Class Members

Chart_AxisY2_Grids_Major Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisY2_Grids_Major_Color property of Line Parameter

AxisY2_Grids_Major_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y2 Axis lines to Red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Color Red

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_EndCap property of Line Parameter

AxisY2_Grids_Major_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_EndCap RoundAnchor

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_StartCap property of Line Parameter

AxisY2_Grids_Major_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_StartCap RoundAnchor

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_Style property of Line Parameter

AxisY2_Grids_Major_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y2 Axis line:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Style DashDot

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_TickMark property of GridLine Parameter

AxisY2_Grids_Major_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Major_TickMark Cross

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_Visible property of GridLine Parameter

AxisY2_Grids_Major_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_MinorStep 5 -Series_0_AxisY AxisY2 -AxisY2_Grids_Minor_Visible true

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Major_Width property of Line Parameter

AxisY2_Grids_Major_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Width 5

See Also

Chart_AxisY2_Grids_Major Parameter | Chart_AxisY2_Grids_Major Summary


AxisY2_Grids_Minor property of Grids Parameter

AxisY2_Grids_Minor Parameter

Provides access to the GridLine class to customize the Minor Grid.

Remarks

  • The minor interval is controlled by the MinorStep parameter, which must be set in order to use the Minor Grid.

  • The minor interval is controlled by the Property, which must be set in order to use the Minor Grid.

Example

To show the Minor gridlines for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Minor_Visible true

See Also

Chart_AxisY2_Grids Parameter | Chart_AxisY2_Grids Summary


GridLine Class Members

Chart_AxisY2_Grids_Minor Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
TickMark | Sets the style for the tick marks of an GridLine object.
Visible | Sets a value indicating whether the grid line for the selected Gridline will be visible.
Width | Sets the line width for a selected line.


AxisY2_Grids_Minor_Color property of Line Parameter

AxisY2_Grids_Minor_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y2 Axis lines to Red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Color Red

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_EndCap property of Line Parameter

AxisY2_Grids_Minor_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_EndCap RoundAnchor

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_StartCap property of Line Parameter

AxisY2_Grids_Minor_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_StartCap RoundAnchor

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_Style property of Line Parameter

AxisY2_Grids_Minor_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y2 Axis line:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Style DashDot

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_TickMark property of GridLine Parameter

AxisY2_Grids_Minor_TickMark Parameter

Sets the style for the tick marks of an GridLine object.

Default Value
The default is Outside.

Value | Meaning
None | Hides tick marks for the selected axis.
Outside | Displays tick marks on the outside of the selected axis.
Inside | Displays tick marks on the inside of the selected axis.
Cross | Displays tick marks that cross inside and outside the selected axis.

Remarks

  • The tick mark is not the gridline that crosses the entire chart, it is just a reference line that appears on every tick of the minor unit of the axis. If you want to display a gridline that crosses the chart, please refer to the property.

  • The major unit is controlled by the property, the minor unit is controled by the property.

Example

To configure the TickMark style as Cross for the Major step in the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Major_TickMark Cross

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_Visible property of GridLine Parameter

AxisY2_Grids_Minor_Visible Parameter

Sets a value indicating whether the grid line for the selected Gridline will be visible.

Remarks

  • By default, this property is set to true. You will need to configure the grid line's Visible property to True in order to see the object in the chart.

Example

To turn on the Minor gridlines for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_MinorStep 5 -Series_0_AxisY AxisY2 -AxisY2_Grids_Minor_Visible true

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Grids_Minor_Width property of Line Parameter

AxisY2_Grids_Minor_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Width 5

See Also

Chart_AxisY2_Grids_Minor Parameter | Chart_AxisY2_Grids_Minor Summary


AxisY2_Inverted property of Axis Parameter

AxisY2_Inverted Parameter

Sets a selected numerical axis max value lesser than the min value.

Remarks

  • This property should be applied to a numerical axis. Assignment to categorical axes will not have an effect.

  • This property can only be applied to the Y2 Axis in an XY plot chart. In an XY plot, the Y2 Axis is a numerical axis rather than categorical.

  • When a selected axis is inverted, the alignment of the categorical axis of the chart will be reversed to make the chart more readable.

Example

Set the Y2 Axis to be inverted:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Inverted true

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_KeyLabels property of Axis Parameter

AxisY2_KeyLabels Parameter

Used to assign a key (short) legend to tickmarks in a categorical axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index specifying the tickmark you want to assign the key legend.

Remarks

  • You normally use the Labels property to assign labels to the tickmarks in the Y2 axis (when it is categorical). However, depending on the amount of points in the chart, these labels may be too long to properly fit in the space allotted for each tickmark in the Y2 axis.

  • You can control the frequency or how labels are displayed with other properties supported by the Axis object, sometimes you still have space limitations because of the size of the chart or the number of points.

  • This property can help you display shorter labels in the Y2 axis while maintaining longer labels in the legend window. Let's give you an example:

    Let's suppose you have assigned the following labels to the Y2 axis using the Label property:

    "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"

    Now, these labels may or may not fit in the space allotted for each tickmark in the Y2 axis. If one of them does not fit, PowerGadgets will immediately display a TAG (red number) indicating that such label can not fit in the space allotted for it. This problem increases as the number of points in the chart increase.

    With this property you can assign key labels (shorter strings) like: "Jan","Feb","Mar",Apr", etc... that will be displayed in the Y2 axis itself, while the Legend window will display both the Key Legend and the Legend set with the Label property.

Example

To assign a key label to the first tickmark in the Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_KeyLabels_0 "Jan"

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_LabelAngle property of Axis Parameter

AxisY2_LabelAngle Parameter

Sets the text rotation for the labels in the selected axis.

Remarks

  • This property uses an integer (degrees) ranging from [-90,90], depending on the rotation angle you want to set. Set this property to 90 to show labels vertically.

  • In order to set this property you must make sure the font type associated with the axis is a True Type Font.

  • Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

  • If you would like to change the angle of PointLabels, you can use the property of the Parameter.

Example

To set vertical text labels in the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelAngle 90

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Labels property of Axis Parameter

AxisY2_Labels Parameter

Allows you to get or set tick marks labels for the selected axis.

Parameters

Parameter | Type | Meaning
i | Int32 | A zero based index indicating the Label index for the axis.

Remarks

  • This property is used to read or write labels for a categorical axis. Normally, the Y2 axis is a categorical axis containing labels associated with each major tick mark, while the Y2 axis is a numerical axis where labels are controlled by the scale (Min, Max, etc) and numerical data contained in the chart.

  • You can set as many labels as points are available in the chart. These labels will be shown in the major tick marks of the selected axis. Some of them can be left empty so no labels are shown on that specific major tick mark.

  • You can control how frequent these labels are displayed by using the Step property. Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

  • By default, PowerGadgets does not associate any labels to the categorical axis (Y2 axis) and a "TAG" number will be shown. When you use this property, the TAG numbers will be replaced by settings specified in this property.

  • When used in conjunction with the LabelValue property, this property can be used to set string values to a numerical axis.

Example

To modify the Y2 axis first label for the chart:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Labels_0 "Custom Label"

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_LabelsFormat property of Axis Parameter

AxisY2_LabelsFormat Parameter

Used to format the labels displayed on the selected axis.

Remarks

  • This property allows you to format axis labels without effecting the format of the data values contained in the chart.

Example

Set the Y2 Axis labels to the currency format:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Format Currency

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


ValueFormat Class Members

Chart_AxisY2_LabelsFormat Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
CustomFormat | Sets a custom format to the selected label, mouseover tip or value.
Decimals | Sets the number of decimals for the selected label, mouseover tip or value.
Format | Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.


AxisY2_LabelsFormat_Culture property of ValueFormat Parameter

AxisY2_LabelsFormat_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • Culture attributes set with this property will effect only selected data and labels, to set localization attributes for the entire chart, please use the Culture parameter of the chart Type.

  • Below is the Y2 axis labels set to the "Spanish-Spain" culture:

    Similarly, the following chart has its Y2 axis labels set to the "Chinese-China" culture:

Example

To set the Y2 Axis labels culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Culture "es-ES"

See Also

Chart_AxisY2_LabelsFormat Parameter | Chart_AxisY2_LabelsFormat Summary


AxisY2_LabelsFormat_CustomFormat property of ValueFormat Parameter

AxisY2_LabelsFormat_CustomFormat Parameter

Sets a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

  • Below, the labels of the Y2 axis display the name of the month as well as the year:

Example

If the Format has been set as Date, this line of code will display the name of the month as well as the year:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Format Date -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_CustomFormat "MMM-yy"

See Also

Chart_AxisY2_LabelsFormat Parameter | Chart_AxisY2_LabelsFormat Summary


AxisY2_LabelsFormat_Decimals property of ValueFormat Parameter

AxisY2_LabelsFormat_Decimals Parameter

Sets the number of decimals for the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

Example

To set the decimals to 1 for the Y2 Axis data values:

out-chart -Series_0_AxisY AxisY2 -AxisY2_DataFormat_Decimals 3

See Also

Chart_AxisY2_LabelsFormat Parameter | Chart_AxisY2_LabelsFormat Summary


AxisY2_LabelsFormat_Format property of ValueFormat Parameter

AxisY2_LabelsFormat_Format Parameter

Used to format the selected label, mouseover tip or value to numbers, date, time, scientific or currency.

Default Value
The default is None.

Value | Meaning
None | Displays a Number without formatting.
Number | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Date | Displays a Short Date, as defined in the International section of the Control Panel.
LongDate | Displays a Long Date, as defined in the International section of the Control Panel.
Time | Displays Time, as defined in the International section of the Control Panel.
DateTime | Displays Date-Time, as defined in the International section of the Control Panel.

Remarks

  • Below, the labels of the Y2 axis are formatted as to the US currency:

  • Similarly, the labels of the Y2 axis are here formatted as to the Euro currency when the culture is "France":

Example

To set the format of the Primary Y2 axis labels to 'Currency' when the language is "french" and the culture is "France":

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Culture "fr-FR" -Series_0_AxisY AxisY2 -AxisY2_LabelsFormat_Format Currency

See Also

Chart_AxisY2_LabelsFormat Parameter | Chart_AxisY2_LabelsFormat Summary


AxisY2_LabelValue property of Axis Parameter

AxisY2_LabelValue Parameter

Allows you to set associate text labels to major tick marks in a numerical axis.This property can get or set the LabelValue assigned to any of the axes.

Remarks

  • Normally, labels in a numerical axis are automatically controlled and displayed according to the Min, Max and Step properties. In some cases, you'll need to associate text labels with a numerical axis (using the Labels property), but when any of the scale values (Min, Max, Step, etc) change, these labels will no longer serve their purpose as the tick marks will be recalculated according to scale settings.

  • For example, if you have a chart where the Y2 axis ranges from Min=0 to Max=100 and Step=25, you'll have 4 tick marks on 25,50,75 and 100. By default PowerGadgets will display numbers (as labels) associated with each tick mark.

    Now let's say you want to associate text labels (instead of the number) with each tick mark in the Y2 axis and you use the Label Property to set the following text labels: "Twenty-Five", "Fifty", "Seventy-Five", "One Hundred".

    When you do this, everything will work out fine and the 4 tick marks will be labeled accordingly. However, if during the execution of your program or through user interaction, the Step suddenly changes from 25 to 12.5, you'll have 8 tick marks instead of 4 and because you used the Label property with indexes 0,1,2 and 3, the "Fifty" tickmark will no longer correspond to the 50 value.

    If you would have set the LabelValue Property to 25, when the Step changes from 25 to 12.5 PowerGadgets will label every other tick mark and the labels will correspond to their initial setting.

  • Label visual attributes like rotation, color and font are also accessible through the LabelAngle, , and Font properties, respectively.

Example

To set a LabelValue of 25 for the primary Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LabelValue 25

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Line property of Axis Parameter

AxisY2_Line Parameter

Allows you to apply supported Line class members to a selected axis line.

Remarks

  • You may control the , and of the selected line using the supported members of the Line Parameter.

  • The and properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

To set the Y2 axis line color to Red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Color Red

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


Line Class Members

Chart_AxisY2_Line Parameters

Parameters

Description

Color | Sets or Gets the line color for a selected line.
EndCap | Sets a marker shape at the ending of a selected line.
StartCap | Sets a marker shape at the beginning of a selected line.
Style | Sets the line style for a selected line.
Width | Sets the line width for a selected line.


AxisY2_Line_Color property of Line Parameter

AxisY2_Line_Color Parameter

Sets or Gets the line color for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line color using this property both axes lines above and below the chart area are colored.

  • You may also control the Width and Style of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of the Y2 Axis lines to Red:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Color Red

See Also

Chart_AxisY2_Line Parameter | Chart_AxisY2_Line Summary


AxisY2_Line_EndCap property of Line Parameter

AxisY2_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_EndCap RoundAnchor

See Also

Chart_AxisY2_Line Parameter | Chart_AxisY2_Line Summary


AxisY2_Line_StartCap property of Line Parameter

AxisY2_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the Y2 axis line to a 'RoundAnchor' shape:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_StartCap RoundAnchor

See Also

Chart_AxisY2_Line Parameter | Chart_AxisY2_Line Summary


AxisY2_Line_Style property of Line Parameter

AxisY2_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y2 Axis line:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Style DashDot

See Also

Chart_AxisY2_Line Parameter | Chart_AxisY2_Line Summary


AxisY2_Line_Width property of Line Parameter

AxisY2_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the Y2 axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Line_Width 5

See Also

Chart_AxisY2_Line Parameter | Chart_AxisY2_Line Summary


AxisY2_LineSpacing property of Axis Parameter

AxisY2_LineSpacing Parameter

Sets a value indicating the LineSpacing for an axis.

Remarks

  • This property specifies the LineSpacing for vertical axes. The labels in the selected axis will never be painted less than the configured LineSpacing.

  • Setting the LineSpacing property to 2 will instruct the axis to use double line spacing. Setting the value to 1 instructs the chart to use single line spacing. The default value is 1.5.

Example

To configure an Axis to use double line spacing:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LineSpacing 2

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_LogBase property of Axis Parameter

AxisY2_LogBase Parameter

Used to set a logarithmic scale for a numerical axis and recalculate the values as powers equal to the setting of this property.

Remarks

  • The LogBase property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The LogBase property is a member of the axis object, therefore the axis object must be referenced in order to properly access the LogBase property.

  • No zeros or negative data values are permitted in logarithmic charts.

  • The Step and MinorStep properties setting must be equal or greater than the LogBase property setting.

Example

To set a Logarithmic scale and recalculate values as powers of 10 in the primary Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_LogBase 10

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Max property of Axis Parameter

AxisY2_Max Parameter

Defines the maximum value of a specific axis.Sets the Max value assigned to the specified axis.

Remarks

  • The Max property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Max property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Max property.

  • If no Max value is specified, PowerGadgets will automatically set a maximum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Max property must be greater than the value of the Min property.

Example

To set the Max value of the primary Y2 axis to 10:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Min 10 -Series_0_AxisY AxisY2 -AxisY2_Max 90

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Min property of Axis Parameter

AxisY2_Min Parameter

Defines the minimum value of a selected axis.Sets the Min value assigned to the specified axis.

Remarks

  • The Min property can be applied only to a numerical axis, a categorical axis will ignore this setting.

  • The Min property is a member of the axis object, therefore the axis object must be referenced in order to properly access the Min property.

  • If no Min value is specified, PowerGadgets will automatically set a minimum value according to the data provided, you can use this property to read or write this default value.

  • The value of the Min property must be lesser than the value of the Max property.

  • There is no automatic method for aligning a main and secondary axis, it is required that you set the Min and Max in order to align them manually. The generic algorithm used to find these values is the following:

Example

To set the Min value of the primary Y2 axis to 10:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Min 10 -Series_0_AxisY AxisY2 -AxisY2_Max 90

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_MinorStep property of Axis Parameter

AxisY2_MinorStep Parameter

Specifies the increment you want between minor tick marks and minor gridlines (if they are displayed) on the selected axis.

Remarks

  • This property is used to control the interval of minor tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0-100 and you have specified a Step value of 10, labels and gridlines will appear at 10, 20, 30, etc. If you would like to have 5 minor tick marks in each major interval, set the MinorStep to 2. Please note the values for the Step and MinorStep properties are data related.

  • Labels will not appear at minor tick marks.

  • The value of the MinorStep Property must be lesser than the value of the Step property.

  • When using the FirstLabel property in the Y2 Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y2 Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the minor interval of the primary Y2 axis to 2:

out-chart -Series_0_AxisY AxisY2 -AxisY2_MinorStep 2

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Pane property of AxisY Parameter

AxisY2_Pane Parameter

Sets an integer value specifying the Pane for an Y2 Axis object.

Remarks

  • Additional Y axes may be assigned to panes in a chart. Once an Y2 axis object is assigned to a pane, that pane will be visible in the chart area. Data also associated with the selected Y2 axis will also be applied to the configured pane.

Example

To set the Y2 axis Pane BackColor property to blue:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Pane_BackColor Blue

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_PixelsPerUnit property of Axis Parameter

AxisY2_PixelsPerUnit Parameter

Gives you the ability to control how many pixels per unit are there in the selected axis.This property is very useful if you want a scroll bar in the selected axis.

Remarks

  • The does not support scrolling capabilities. Therefore, this property is not supported for the Secondary Y2 axis.

  • If the AutoScroll property is set to False, the PixelsPerUint will not have any effect on the axis. So make sure the AutoScroll property is set to True when using the PixelsPerUint property.

Example

To separate tick marks in the Y2 axis by 60 pixels:

out-chart -Series_0_AxisY AxisY2 -AxisY2_AutoScroll true -Series_0_AxisY AxisY2 -AxisY2_PixelsPerUnit 60

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Position property of Axis Parameter

AxisY2_Position Parameter

Specifies the placement of the axis labels and tick marks relative to the chart.

Value | Meaning
Near | Specifies the axis line be placed near the chart in the following way: In a Y2 axis, the axis line be below the chart. In Y2 axis, the axis line be left to the chart.
Center | Specifies that axis line placed in the center of the chart.
Far | Specifies that axis line is placed far from the chart in the following way: In a Y2 axis, the axis line be above the chart. In a Y2 axis, the axis line is right to the chart.

Remarks

  • The Position property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

  • Multiple axes may be created using the AxesX and the properties of the Parameter.

Example

To move the labels and tick marks for the X and Y axes to the top and right of the chart:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Position Far -Series_0_AxisY AxisY2 -AxisY2_Position Far

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_ScaleUnit property of Axis Parameter

AxisY2_ScaleUnit Parameter

Returns or sets the scale unit of a selected axis.

Remarks

  • This constant is very useful when the values used on the Y2 axis are too big (i.e. 10,000,000) in this case you can use a 1,000,000 scale and the values on the Y2 axis will be divided by this scale.

  • The ScaleUnit property is a member of the axis object, therefore the axis object must be referenced in order to set the property correctly.

Example

To set the Scale Unit of the primary Y2 axis to 1000:

out-chart -Series_0_AxisY AxisY2 -AxisY2_ScaleUnit 1000

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_ScrollPosition property of Axis Parameter

AxisY2_ScrollPosition Parameter

Allows you to set the starting scroll position when a chart is scrollable.

Remarks

  • Your chart must be set to AutoScroll in order for this property to be used properly.

  • When you set the ScrollPosition, the first point included in the chart will be the configured point.

Example

Set the scroll position for the Y2 axis to 50:

out-chart -Series_0_AxisY AxisY2 -AxisY2_ScrollPosition 50

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Sections_<index> property of Axis Parameter

AxisY2_Sections_<index> Parameter

Returns a selected AxisSection object.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the AxisSection item.

Remarks

  • This property exposes the members of the AxisSection Parameter. Please see the Parameter for additional information regarding those supported members.

Example

To set the To value for a selected AxisSection object:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_To 25

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisSection Class Members

Chart_AxisY2_Sections Parameters

Parameters

Description

BackColor | Sets the AxisSection background color.
FontStyle | Sets additional font attributes to the axis section.
From | Sets a value indicating the beginning value of the range for a selected object.
Grids | Allows customization of grid lines by providing access to the supported members of the Grids .
Text | Sets the text string for a selected BaseAxisSection object.
TextColor | Sets the color for text of a selected BaseAxisSection object.
To | Sets a value indicating the ending value of the range the axis section.
Visible | Shows or hides the selected axis section.


AxisY2_Sections_<index>_BackColor property of AxisSection Parameter

AxisY2_Sections_<index>_BackColor Parameter

Sets the AxisSection background color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Changes the background color of the first section of to yellow:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_BackColor Yellow

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_FontStyle property of AxisSection Parameter

AxisY2_Sections_<index>_FontStyle Parameter

Sets additional font attributes to the axis section.

Remarks

Example

Specifies that the text associated with the first AxisSection object of the will be bold:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_FontStyle Bold

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_From property of AxisSection Parameter

AxisY2_Sections_<index>_From Parameter

Sets a value indicating the beginning value of the range for a selected AxisSection object.

Remarks

  • The To property is used to specify the ending value of the section range for a selected Axis Section.

  • The To property is used to specify the ending value of the section range for a selected object.

Example

To configure the From value for the 1st axis section of the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_From 30

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_Grids property of AxisSectionBase Parameter

AxisY2_Sections_<index>_Grids Parameter

Allows customization of grid lines by providing access to the supported members of the Grids class.

Remarks

  • Lines across the Axes can be added at the major and minor steps by setting and Gridlines.

  • Lines across the Axes can be added at specific points by adding a .

  • Below, the Minor gridline of the Axis Y is set to visible:

Example

To set a Minor gridline visible:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Grids_Minor_Visible true

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_Text property of AxisSection Parameter

AxisY2_Sections_<index>_Text Parameter

Sets the text string for a selected BaseAxisSection object.

Remarks

  • This should be used if you would like to label the sections you create for clarity.

  • This title appears as a tooltip for the user.

Example

To set text to a section, SampleSection:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_Text "SampleText"

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_TextColor property of AxisSectionBase Parameter

AxisY2_Sections_<index>_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y2 axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_TextColor Red

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_To property of AxisSection Parameter

AxisY2_Sections_<index>_To Parameter

Sets a value indicating the ending value of the range the axis section.

Remarks

  • The From property is used to specify the beginning value of the section range for a selected Axis Section.

Example

To configure the To value for the 1st axis section of the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_To 60

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Sections_<index>_Visible property of AxisSection Parameter

AxisY2_Sections_<index>_Visible Parameter

Shows or hides the selected axis section.

Remarks

  • Hiding the axis section does not destroy or lose previous settings assigned by other properties.

Example

To hide the axis section:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_Visible false

See Also

Chart_AxisY2_Sections Parameter | Chart_AxisY2_Sections Summary


AxisY2_Separation property of Axis Parameter

AxisY2_Separation Parameter

Allows you to specify a gap in pixels between multiple axis.

Remarks

  • This property is useful when multiple axes are configured and you need to create space for readability.

Example

To configure a 5 pixel separation on the secondary Y2 axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Separation 5

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Staggered property of Axis Parameter

AxisY2_Staggered Parameter

Alternates the level of the axis labels for the selected axis labels.

Remarks

  • Staggering axis labels can help improve chart readability when axis label strings are long.

Example

To stagger axis labels on two levels:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Staggered true

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Step property of Axis Parameter

AxisY2_Step Parameter

Specifies the interval of major tick marks and gridlines on the selected axis.It also controls the gap or interval between labels in the selected axis.

Remarks

  • Normally, you use this property to control the interval of labels, tick marks and gridlines in the selected axis. For example, if the selected axis ranges from 0 -100 and you want to show labels, tick marks or gridlines every 10 units the appropriate setting for the Step property is 10.

  • This property can also be used for a categorical axis. For example, if your Y2 axis displays labels ranging from January to December and you set the Step property to 2, then the categorical axis will display legends every other month.

  • You can also control a minor interval with the MinorStep property.

  • If no Step value is specified, PowerGadgets will automatically set a Step according to the data provided, you can use this property to read or write this default value.

  • The value of the Step Property must be greater than the value of the MinorStep property.

  • When using the FirstLabel property in the Y2 Axis of a chart with values ranging from 0 to 1, the axis' MinorStep is used to calculate which label is the first, second, third, etc. When Y2 Axis values range >1, then the axis' Step is used for this calcuation.

Example

To set the major interval of the primary Y2 axis to 50:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Step 50

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Style property of Axis Parameter

AxisY2_Style Parameter

Allows you to add additional styles to the selected axis.

Remarks

  • This property is a mask property. This means all settings represent a bit in the word that you need to turn on or off according to what you want. For this purpose you will need to use + sign to add (bitwise Or) the property, and - sign to remove (bitwise And Not) propety.

  • The Axis.Style property supports a flag called AutoFirstLabel (Default=ON) which automatically positions the first label to the closest number rounded to the axis step. For example, if a numeric axis starts at 7 with a Step of 10 and the AutoFirstLabel property is ON, the axis will show labels at 10,20,30 and so on. If the AutoFirstLabel property is turned off labels will be shown at 7,17,27 and so on.

    Note: If the axis contains dates (Date Axis) the AutoFirstLabel property will position the first label at the end of the month. If the AutoFirstLabel is turned OFF, the labels will be shown using the first avaialble date and advanced using the Step property setting.

Example

To set an interlaced Grid and Hide Labels in the primary Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Style +HideText

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_TextColor property of AxisSectionBase Parameter

AxisY2_TextColor Parameter

Sets the color for text of a selected BaseAxisSection object.

Remarks

  • The TextColor property is used to set a color for the specified AxisSection labels. Please refer to the TextColor property of the Title object to customize the color for the axis title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • Below, the Y2 axis section textcolor is set to red:

Example

To set the text to red for an AxisSection object:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Sections_0_TextColor Red

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


AxisY2_Title property of Axis Parameter

AxisY2_Title Parameter

Sets the title for a specific axis.

Remarks

  • The Title property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Title property.

  • This property receives or returns a Parameter. Accessing the title object properties you will be able to change attributes like: Alignment, Color, Font,Text, etc.

  • This property is used to get or set the axis title. To set the chart top title, please refer to the chart's property.

  • Below is a chart with both X and Y2 Axis titles:

Example

This sample sets the "Unit Sales (In millions)" to the Y2 Axis:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Title_Text "Unit Sales (In Millions)"

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


Title Class Members

Chart_AxisY2_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


AxisY2_Title_Alignment property of Title Parameter

AxisY2_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the Y2 axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the Y2 axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_BackColor property of Title Parameter

AxisY2_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_Font property of Title Parameter

AxisY2_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_Indentation property of Title Parameter

AxisY2_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y2 axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_LineAlignment property of Title Parameter

AxisY2_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_PlotAreaOnly property of TitleDockable Parameter

AxisY2_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_RichText property of Title Parameter

AxisY2_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_Separation property of Title Parameter

AxisY2_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the Y2 axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_Text property of Title Parameter

AxisY2_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Title_TextColor property of Title Parameter

AxisY2_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_AxisY2_Title Parameter | Chart_AxisY2_Title Summary


AxisY2_Visible property of Axis Parameter

AxisY2_Visible Parameter

Shows or hides the lines, labels, tick marks and grids for the selected axis.

Remarks

  • The Visible property is a member of the axis object; therefore, the axis object must be referenced in order to properly utilize the Visible property.

  • By hiding the labels for the specified axis using the Visible property, other attributes such as the and tick marks are also hidden.

Example

To hide the Y2 axis labels:

out-chart -Series_0_AxisY AxisY2 -AxisY2_Visible false

See Also

Chart_AxisY2 Parameter | Chart_AxisY2 Summary


BackColor property of Chart Parameter

BackColor Parameter

Sets the background color of the chart.

Remarks

  • A gradient may be assigned to the background using the Background property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the chart background color to yellow:

out-chart -BackColor Yellow

See Also

Chart Parameter | Chart Summary


Caption property of Chart Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the caption in the PowerGadget window:

out-chart -Caption "My PowerGadget"

See Also

Chart Parameter | Chart Summary


ColHeadings property of Chart Parameter

ColHeadings Parameter

Allows you to specifies which fields to use in crosstab chart as column headings.

Remarks

  • Use ColHeadings to specifies which fields to use in crosstab chart as column headings.

  • Use RowHeadings to specifies which fields to use in crosstab chart as column headings.

Example

To configure the ColHeadings parameter to use the Handles and WorkingSet:

ps | out-chart -ColHeadings Handles,WorkingSet

See Also

Chart Parameter | Chart Summary


Condition property of Chart Parameter

Condition Parameter

Allows you to apply Conditional Attributes in the chart.

Remarks

  • Use Condition to apply Condiotional Attributes to the chart.

  • The ConditionalAttributes parameter is another way to apply Conditional Attributes to the chart.

Example

To configure a chart populated with images (*.bmp) grater than 1000 KB:

dir *.bmp | out-chart -values Length -condition {$_.Length -gt 1000} -Gallery Bar

See Also

Chart Parameter | Chart Summary


ConditionalAttributes Parameter

Remarks

The members of the ConditionalAttributes Parameter allow developers to control when special attributes should be applied to the chart and what chart elements will be taken into consideration when they are applied.

Once the Parameter has been configured with the desired attributes, the object may be assigned to a chart's point, based on the configured conditions. The value of each point in the chart is evaluated based on the conditions of each ConditionalAttributes item. Points that meet the conditions of a particular conditional attribute item will be retain the settings of that item. For more information regarding the configuration of the conditions, please see the Parameter.

The conditional attributes must be defined before the is populated.


ConditionalAttributes Class Members

Chart_ConditionalAttributes Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
BarShape | Sets the Shape for the Bars.
Border | Provides access to the border attributes object.
Color | Allows you to set a color for the selected item.
Condition | Returns a Condition object for the specified ConditionalAttributes object.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Line | Gets the LineAttributes object for the particular point.
MarkerShape | Sets the the type used to paint markers for the selected item.
MarkerSize | Sets a value controlling the size of the markers for the selected item.
Pattern | Sets a value specifying the pattern for the selected item.
Picture | Sets a value specifying the picture associated to the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
SeparateSlice | Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.
Series | Sets a value indicating which series index the ConditionalAttribute will be applied.
Text | Sets a value for labeling the point or series attribute.
Volume | Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


ConditionalAttributes_<index>_AlternateColor property of PointAttributes Parameter

ConditionalAttributes_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To create a Gradient on the point marker (0,0) using the colors Red and Bisque:

out-chart -AllSeries_FillMode Gradient -Points_0_0_Color Red -Points_0_0_AlternateColor Bisque

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_BarShape property of PointAttributes Parameter

ConditionalAttributes_<index>_BarShape Parameter

Sets the Shape for the Bars.

Value | Meaning
Rectangle | Sets the Bar shape to a Rectangle (Default).
Cylinder | Sets the Bar shape to a Cylinder.
Cone | Sets the Bar shape to a Cone.
Pyramid | Sets the Bar shape to a Pyramid.

Remarks

  • This property applies when the chart Gallery is set to Bar.

Example

This changes the bar shapes to cylinder for the first point.

out-chart -Points_0_BarShape Cone

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Border property of PointAttributes Parameter

ConditionalAttributes_<index>_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To remove borders for the 2nd point of all series:

out-chart -Points_1_Border_Width 5

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


BorderAttributes Class Members

Chart_ConditionalAttributes_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


ConditionalAttributes_<index>_Border_BetweenSegments property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Remarks

  • For some gallery types, Area for example, turning the point markers border visible will generate the following efect on a chart:

  • When BetweenSegments is set to true, this will be the effect:

Example

To set the BetweenSegmetnts to true for all series:

out-chart -AllSeries_Border_Width 6 -AllSeries_Border_BetweenSegments true

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_Color property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set to Red the Border color for all series:

out-chart -AllSeries_Border_Color Red

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_Effect property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the border effect to Shadow for all series:

out-chart -AllSeries_Border_Effect Shadow

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_Style property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Style of the border line to Dash:

out-chart -AllSeries_Border_Style Dash

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_UseForLines property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line chart.

Remarks

  • When applied to a Line Chart, Border attributes will affect only the Point marker, where the line will remain unchanged.

  • When setting UseForLines to true, the border attributes are applied to the line too:

Example

To apply the border attributes to all the lines:

out-chart -Gallery Lines -AllSeries_Border_UseForLines true -AllSeries_Border_Width 3

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_Visible property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the border visible for all series:

out-chart -AllSeries_Border_Visible true

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Border_Width property of BorderAttributes Parameter

ConditionalAttributes_<index>_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the point markers border width to 2:

out-chart -AllSeries_Border_Width 2

See Also

Chart_ConditionalAttributes_Border Parameter | Chart_ConditionalAttributes_Border Summary


ConditionalAttributes_<index>_Color property of PointAttributes Parameter

ConditionalAttributes_<index>_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the chart, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color for the 1st point in all the series to blue:

out-chart -Points_0_Color Blue

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Condition property of ConditionalAttributes Parameter

ConditionalAttributes_<index>_Condition Parameter

Returns a Condition object for the specified ConditionalAttributes object.

Remarks

  • You may use this object to manipulate the conditions in which the ConditionalAttribute applies.

Example

To configure a ConditionalAttributes object:

out-chart -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


Condition Class Members

Chart_ConditionalAttributes_Condition Parameters

Parameters

Description

Active | Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.
DataElement | Sets the data value that the specified ConditionalAttribute will evaluate.
From | Sets a value indicating the beginning value of the conditional range for a selected object.
FromOpen | Sets a value indicating whether or not to include the configured From value in the range.
Inverse | Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.
To | Sets a value indicating the ending value of the conditional range for a selected object.
ToOpen | Sets a value indicating whether or not to include the configured To value in the range.


ConditionalAttributes_<index>_Condition_Active property of Condition Parameter

ConditionalAttributes_<index>_Condition_Active Parameter

Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

Example

To configure the 1st Conditional attribute as inactive:

out-chart -ConditionalAttributes_0_Condition_Active false

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_DataElement property of Condition Parameter

ConditionalAttributes_<index>_Condition_DataElement Parameter

Sets the data value that the specified ConditionalAttribute will evaluate.

Default Value
The default is YValue.

Value | Meaning
YValue | Instructs the chart to treat the selected field as a number. Therefore an additional data series.
XValue | Instructs the chart to treat the selected field as a number to be used as the X axis coordinate. Use this option if you are creating XY Plots.
IniValue | Instructs the chart to treat the selected field as a number to be used to set initial values for data points to achieve floating bars and area charts.

Remarks

  • By default, the YValue for the chart is evaluated for a condition. You can use this property to select to evaluate the IniValue or XValue for each point contained in the chart.

  • Use the Active property to specify if a selected ConditionalAttributes object may be applied to a chart.

  • The To property is used to specify the ending value of the conditional range for a selected object. The ToOpen property indicates whether or not to include the configured To value in the range.

  • The From property is used to specify the beginning value of the conditional range for a selected object. The FromOpen property indicates whether or not to include the configured From value in the range.

  • Use the Inverse property to reverse the configured To and From attributes and create the opposite condition configured.

Example

To evaluate the XValue to apply the 1st conditional attribute:

out-chart -ConditionalAttributes_0_Condition_DataElement XValue

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_From property of Condition Parameter

ConditionalAttributes_<index>_Condition_From Parameter

Sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set 80 as the From attribute.

out-chart -ConditionalAttributes_0_Condition_From 80 -ConditionalAttributes_0_Color Red

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_FromOpen property of Condition Parameter

ConditionalAttributes_<index>_Condition_FromOpen Parameter

Sets a value indicating whether or not to include the configured From value in the range.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set FromOpen to true for a conditional attribute:

out-chart -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50 -ConditionalAttributes_0_Condition_FromOpen true

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_Inverse property of Condition Parameter

ConditionalAttributes_<index>_Condition_Inverse Parameter

Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To configure the 1st ConditionalAttribute to be inversed:

out-chart -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50 -ConditionalAttributes_0_Condition_Inverse true

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_To property of Condition Parameter

ConditionalAttributes_<index>_Condition_To Parameter

Sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set 30 as the To attribute for the 1st ConditionalAttribute:

out-chart -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_To 30

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_ToOpen property of Condition Parameter

ConditionalAttributes_<index>_Condition_ToOpen Parameter

Sets a value indicating whether or not to include the configured To value in the range.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set ToOpen to true for the 1st conditional attribute:

out-chart -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_To 50 -ConditionalAttributes_0_Condition_ToOpen true

See Also

Chart_ConditionalAttributes_Condition Parameter | Chart_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_FillMode property of PointAttributes Parameter

ConditionalAttributes_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the FillMode property to Pattern for a point:

out-chart -Points_1_FillMode Pattern

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Line property of PointAttributes Parameter

ConditionalAttributes_<index>_Line Parameter

Gets the LineAttributes object for the particular point.

Remarks

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

Example

To set the line width to 3 for all series in a chart:

out-chart -AllSeries_Line_Width 3

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


LineAttributes Class Members

Chart_ConditionalAttributes_Line Parameters

Parameters

Description

EndCap | Sets a marker shape at the end of a PointAttribute's Line.
StartCap | Sets a marker shape at the start of a PointAttribute's Line.
Style | Sets the style for a PointAttribute's Line.
Width | Sets the width for a PointAttribute's Line.


ConditionalAttributes_<index>_Line_EndCap property of Line Parameter

ConditionalAttributes_<index>_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_ConditionalAttributes_Line Parameter | Chart_ConditionalAttributes_Line Summary


ConditionalAttributes_<index>_Line_StartCap property of Line Parameter

ConditionalAttributes_<index>_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_ConditionalAttributes_Line Parameter | Chart_ConditionalAttributes_Line Summary


ConditionalAttributes_<index>_Line_Style property of Line Parameter

ConditionalAttributes_<index>_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_ConditionalAttributes_Line Parameter | Chart_ConditionalAttributes_Line Summary


ConditionalAttributes_<index>_Line_Width property of Line Parameter

ConditionalAttributes_<index>_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_ConditionalAttributes_Line Parameter | Chart_ConditionalAttributes_Line Summary


ConditionalAttributes_<index>_MarkerShape property of PointAttributes Parameter

ConditionalAttributes_<index>_MarkerShape Parameter

Sets the the type used to paint markers for the selected item.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

Example

To select a triangle as the marker shape for the first point in all the series:

out-chart -Points_0_MarkerShape Triangle

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_MarkerSize property of PointAttributes Parameter

ConditionalAttributes_<index>_MarkerSize Parameter

Sets a value controlling the size of the markers for the selected item.

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

Example

To increase the marker size for the first point of all the series:

out-chart -Points_0_MarkerSize 5

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Pattern property of PointAttributes Parameter

ConditionalAttributes_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the chart FillMode is set to either B&W or colored patterns.

  • If the chart's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • Below, the second series pattern is set to cross:

Example

To set a pattern for the first point of all the series:

out-chart -Points_0_Pattern Cross

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Picture property of PointAttributes Parameter

ConditionalAttributes_<index>_Picture Parameter

Sets a value specifying the picture associated to the selected item.

Remarks

  • The Picture property may be used in two different ways depending on the chart's gallery and FillMode:

    1. If the chart gallery is one that uses point markers, meaning you can set the shape of the marker using the MarkerShape property, then the configured image will be used as a point marker as long as the MarkerShape for that point is set to MarkerShape.Picture.

    2. If the chart gallery is one that uses bars, area markers or pie slices (Bar, Area or Pie type charts), the image will be tiled in the selected series or point. However, in order for the tiled effect to be applied you must set the FillMode to FillMode.Pattern.

  • The Legends and DataEditor will also show the picture but with an appropriated size. Notice that if you do not set the FillMode to FillMode.Pattern, the configured picture will only be used with charts that have point markers.

  • When this property is set to a 3D chart, the sides of the markers (3D perspective) are painted with the configured series color.

Example

To set a picture for the 1st point of all the series:

out-chart -Points_0_Picture "image.bmp"

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_PointLabels property of PointAttributes Parameter

ConditionalAttributes_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To show point labels for a chart:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_SeparateSlice property of PointAttributes Parameter

ConditionalAttributes_<index>_SeparateSlice Parameter

Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.

Remarks

  • Setting this property to 100 will make the vertex of the slice to be on the edge of the pie.

  • PowerGadgets does not provide administrative properties, such as the biggest slice in a PIE chart, so if you want to separate a particular slice based on a certain condition, you must first determine the slice to be separated based on the data contained in the chart.

Example

To separate the first slice of each series by 50%:

out-chart -Points_0_SeparateSlice 50

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Series_<index> property of ConditionalAttributes Parameter

ConditionalAttributes_<index>_Series_<index> Parameter

Sets a value indicating which series index the ConditionalAttribute will be applied.

Remarks

  • By default, ConditionalAttributes are applied to all series in the chart. To reset a ConditionalAttribute to be applied to all series, set the Series property to -1.

Example

To instruct PowerGadgets to apply the selected ConditionalAttribute to the 2nd series only:

out-chart -ConditionalAttributes_1_Series 1

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Text property of PointAttributes Parameter

ConditionalAttributes_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set strings to be used as legend in a 2 series chart:

out-chart -Series_0_Text "Text 0" -Series_1_Text "Text 1" -LegendBox_Visible true

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


ConditionalAttributes_<index>_Volume property of PointAttributes Parameter

ConditionalAttributes_<index>_Volume Parameter

Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

Example

To make the first point of all the series occupy all the space allotted to them:

out-chart -Points_0_Volume 100

See Also

Chart_ConditionalAttributes Parameter | Chart_ConditionalAttributes Summary


Configure property of Chart Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the chart.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for chart.

  • This Wizard has two tabs, one called Chart Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the Chart Wizard tab.

Example

To use a graphical wizard to customize the chart:

out-chart -configure

See Also

Chart Parameter | Chart Summary


ContextMenus property of Chart Parameter

ContextMenus Parameter

Allows you to enable or disable context sensitive menus when the user right clicks a particular chart element.

Remarks

  • This property allows the end user to easily alter various chart elements rather than finding the appropriate dialog in the chart tabbed dialog. Therefore, we strongly recommend the use of this setting.

  • This is the context menu activated when right-clicking on a point marker while the ContextMenus property is set to True:

Example

To turn off the ContextMenus:

out-chart -ContextMenus false

See Also

Chart Parameter | Chart Summary


Crosshairs property of Chart Parameter

Crosshairs Parameter

Enables or Disables the cross-hairs marker in the chart.

Remarks

  • If enabled, the end user will view a Cross-Hairs marker and a tooltip showing the point index and the value, when he presses the left button of the mouse. The Cross-Hairs marker will disappear when the user releases the button.

Example

To view the Cross-Hairs markers:

out-chart -Crosshairs true

See Also

Chart Parameter | Chart Summary


Culture property of Chart Parameter

Culture Parameter

Allows you to localize charts for a specific language and region.

Remarks

  • The Parameter supports a property that allows you to set the culture for axes and values, not the entire chart.

Example

To set the Chart culture to use "Spanish - Spain" as the Language-Country/Region:

out-chart -Culture "es-ES"

See Also

Chart Parameter | Chart Summary


DataGrid property of Chart Parameter

DataGrid Parameter

Gets the MenuBar of the chart. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the chart and the grid at the same time.

Remarks

  • Below, the DataGrid is visible:

Example

Displays the DataGrid:

out-chart -DataGrid_Visible true

See Also

Chart Parameter | Chart Summary


DataGrid Class Members

Chart_DataGrid Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
BackColorData | Sets the background color of the cells on the MenuBar.
BackColorDataAlternate | Assigns the alternate color for displaying the DataGrid rows or columns.
BackColorHeader | Sets the background color of the header for the MenuBar.
Border | Allows the developer to specify the border style.
Cells | Gets the collection of CellAttributes that belong to the DataGrid.
ContentLayout | Allows you to align the MenuBar in the bottom of the chart area.
Dock | Sets the position of the MenuBar.
Font | Allows you to set the font used throughout the MenuBar.
Height | Sets the height of the dockable bar in pixels.
HideXValues | Used to hide the XValues in the MenuBar of an XY plot chart.
HorizontalGridColor | Allows you to set the Horizontal color for the gridlines displayed in the MenuBar.
Interlaced | Alternates the background color of on the MenuBar to improve readability.
MaxSizePercentage | Allows you to specify the maximum percentage of the chart area the MenuBar may occupy.
ReadOnly | Permits values to be changed through the MenuBar.
ScrollPosition | Scrolls the data horizontally to the specific column in the Grid.
ShowHeader | Sets a value indicating the header of the columns should be visible or not.
ShowHiddenSeries | Sets a value indicating hidden series should be visible in MenuBar.
ShowMarkers | Sets a value indicating if serie markers should be visible in the serie headers.
TextColorData | Sets the text color of the cells on the MenuBar.
TextColorDataAlternate | Sets the alternate text color for text in the MenuBar cells.
TextColorHeader | Sets the text color of the headers on the MenuBar.
UseRawData | Sets a value indicating whether to use raw data or use calculated values in the DataEditor.
VerticalGridColor | Allows you to select the Vertical line color for the gridline displayed at the MenuBar box.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.
XValuesAsHeaders | Sets a value instructing that XValues be used as the headers in the MenuBar.


DataGrid_AutoSize property of DockableBar Parameter

DataGrid_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a chart.

Example

To disable the AutoSize property for the MenuBar:

out-chart -DataGrid_AutoSize false

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_BackColor property of DockableBar Parameter

DataGrid_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of the MenuBar to red:

out-chart -DataGrid_BackColor Red

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_BackColorData property of DataGrid Parameter

DataGrid_BackColorData Parameter

Sets the background color of the cells on the MenuBar.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColorData property. Use property to enable the MenuBar.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of MenuBar Cells to Blue:

out-chart -DataGrid_Visible true -DataGrid_BackColorData Blue

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_BackColorDataAlternate property of DataGrid Parameter

DataGrid_BackColorDataAlternate Parameter

Assigns the alternate color for displaying the DataGrid rows or columns.

Remarks

  • When viewing and interpreting DataGrids with muliple points or series, sometimes it is difficult to distinguish one row from another or one column from the other. With this prorperty you can specify the alternating color for the DataGrid.

  • You should specify the direction of the alternating colors by using the Interlaced property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the alternate color for an interlaced MenuBar.

out-chart -DataGrid_Visible true -DataGrid_Interlaced Horizontal -DataGrid_BackColorDataAlternate Red

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_BackColorHeader property of DataGrid Parameter

DataGrid_BackColorHeader Parameter

Sets the background color of the header for the MenuBar.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColorHeader property. Use property to enable the dataGrid.

  • You can set the dataGird background and MenuBar cells background with and BackColorData property, respectively.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of MenuBar Headers to Blue:

out-chart -DataGrid_Visible true -DataGrid_BackColorHeader Blue

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Border property of DockableBar Parameter

DataGrid_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

Sets the Border to External:

out-chart -DataGrid_Border External

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Cells property of DataGrid Parameter

DataGrid_Cells Parameter

Gets the collection of CellAttributes that belong to the DataGrid.

Parameters

Parameter | Type | Meaning
row | Int32 | The series index
column | Int32 | The point index

Parameter | Type | Meaning
row | Int32 | The point index

Remarks

  • The Parameter allows to modify the attributes of a particular Cell or entire Row in the .

  • Cell Attributtes are background, border and text colors,font styles and Border widths.

Example

The following example shows how to set a particular Cell in the Datagrid just with a red back color:

out-chart -DataGrid_Visible true -DataGrid_Cells_1_0_BackColor Red

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


CellAttributes Class Members

Chart_DataGrid_Cells Parameters

Parameters

Description

BackColor | Sets the background color for a particular Cell or entire Row in the DataGrid.
BorderColor | Allows you to set the color of the border for a particular Cell or entire Row in the DataGrid.
BorderWidth | Allows you to set the width of the Cell border in pixels for a particular Cell or entire Row in the DataGrid.
FontStyle | Allows you to set the style of the font for a particular Cell or entire Row in the DataGrid.
TextColor | Allows you to set the text color for a particular Cell or entire Row in the DataGrid.


DataGrid_Cells_BackColor property of CellAttributes Parameter

DataGrid_Cells_BackColor Parameter

Sets the background color for a particular Cell or entire Row in the DataGrid.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColor property. Use property to enable the MenuBar.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of cell in the MenuBar to red:

out-chart -DataGrid_Visible true -DataGrid_Cells_0_1_BackColor Red

See Also

Chart_DataGrid_Cells Parameter | Chart_DataGrid_Cells Summary


DataGrid_Cells_BorderColor property of CellAttributes Parameter

DataGrid_Cells_BorderColor Parameter

Allows you to set the color of the border for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the border color of cell in the MenuBar to red:

out-chart -DataGrid_Visible true -DataGrid_Cells_0_1_BorderColor Red

See Also

Chart_DataGrid_Cells Parameter | Chart_DataGrid_Cells Summary


DataGrid_Cells_BorderWidth property of CellAttributes Parameter

DataGrid_Cells_BorderWidth Parameter

Allows you to set the width of the Cell border in pixels for a particular Cell or entire Row in the DataGrid.

Remarks

  • This property allows you to configure the width of the DataGrid Cell border using units other than pixels.

Example

To set the border with of a Cell in the DataGrid to 3 pixels:

out-chart -DataGrid_Visible true -DataGrid_Cells_0_1_BorderWidth 3

See Also

Chart_DataGrid_Cells Parameter | Chart_DataGrid_Cells Summary


DataGrid_Cells_FontStyle property of CellAttributes Parameter

DataGrid_Cells_FontStyle Parameter

Allows you to set the style of the font for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

The following code illustrates this property:

out-chart -DataGrid_Cells_0_0_FontStyle +Bold

See Also

Chart_DataGrid_Cells Parameter | Chart_DataGrid_Cells Summary


DataGrid_Cells_TextColor property of CellAttributes Parameter

DataGrid_Cells_TextColor Parameter

Allows you to set the text color for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Text of a cell in the DataGrid to Red:

out-chart -DataGrid_Visible true -DataGrid_Cells_0_0_TextColor Red

See Also

Chart_DataGrid_Cells Parameter | Chart_DataGrid_Cells Summary


DataGrid_ContentLayout property of DataGrid Parameter

DataGrid_ContentLayout Parameter

Allows you to align the MenuBar in the bottom of the chart area.

Default Value
The default is Spread.

Value | Meaning
Spread | Stretches the selected object in the configured position.
Near | Left justifies the selected object in the configured position.
Center | Centers the selected object in the configured position.
Far | Right justifies the selected object in the configured position.

Remarks

  • The property needs to be true to see the effects of this property.

  • Note, when the DataGrid is docked on the left or right:

    Near = Top

    Far = Bottom

Example

To center the MenuBar under the chart:

out-chart -DataGrid_Visible true -DataGrid_ContentLayout Center

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Font property of DataGrid Parameter

DataGrid_Font Parameter

Allows you to set the font used throughout the MenuBar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the MenuBar font settings:

out-chart -DataGrid_Visible true -DataGrid_Font "Arial, 10"

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Dock property of DockableBar Parameter

DataGrid_Dock Parameter

Sets the position of the MenuBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To dock the to the right margin:

out-chart -DataGrid_Dock Right

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Height property of DockableBar Parameter

DataGrid_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the height for the MenuBar to 300 pixels:

out-chart -DataGrid_Height 300

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_HideXValues property of DataGrid Parameter

DataGrid_HideXValues Parameter

Used to hide the XValues in the MenuBar of an XY plot chart.

Remarks

  • Normally when you generate an XY plot, both the X and Y values for each series are displayed in the dataGrid. This property allows you to hide the XValues displayed by the tool.

Example

To hide the XValues in the MenuBar of an XY plot:

out-chart -DataGrid_HideXValues true

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_HorizontalGridColor property of DataGrid Parameter

DataGrid_HorizontalGridColor Parameter

Allows you to set the Horizontal color for the gridlines displayed in the MenuBar.

Remarks

  • The MenuBar must be in order to see the these changes.

  • You can set the Vertical line color of the MenuBar gridline with VerticalGridColor property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To show the MenuBar and change the gridlines color to blue:

out-chart -DataGrid_Visible true -DataGrid_HorizontalGridColor Blue

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Interlaced property of DataGrid Parameter

DataGrid_Interlaced Parameter

Alternates the background color of on the MenuBar to improve readability.

Default Value
The default is None.

Value | Meaning
None | No interlaced grid.
Horizontal | Creates a horizontal interlaced grid in the MenuBar.
Vertical | Creates a vertical interlaced grid in the MenuBar.

Remarks

  • If you want to alternate the color for every series, then use Interlaced.Horizontal. For alternating the color of the points, use Interlaced.Vertical.

    With only a few series and points it is easier to read without Interlaced.

  • Use the BackColorData and BackColorDataAlternate properties to set the colors for the Interlaced property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set Interlaced property to vertical:

out-chart -DataGrid_Visible true -DataGrid_BackColorDataAlternate Red -DataGrid_Interlaced Horizontal

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_MaxSizePercentage property of DataGrid Parameter

DataGrid_MaxSizePercentage Parameter

Allows you to specify the maximum percentage of the chart area the MenuBar may occupy.

Remarks

  • This property is especially useful when developing with web applications and generating images. Because you cannot scroll the MenuBar when generating an image, This property allows you to specify the max size so you can make sure to view all values in the MenuBar.

  • This property may be configured with values ranging from 0 - 100. Specifying 0 will instruct PowerGadgets to calculate the size. Specifying 100 will instruct PowerGadgets that the whole chart may be covered by the MenuBar if needed.

Example

To set the MaxSizePercentage to 35%:

out-chart -DataGrid_Visible true -DataGrid_MaxSizePercentage 35

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_ReadOnly property of DataGrid Parameter

DataGrid_ReadOnly Parameter

Permits values to be changed through the MenuBar.

Remarks

  • To change a value, simply double click the cell you wish to change.

Example

To set the DataGrid ReadOnly property to true:

out-chart -DataGrid_Visible true -DataGrid_ReadOnly true

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_ScrollPosition property of DataGrid Parameter

DataGrid_ScrollPosition Parameter

Scrolls the data horizontally to the specific column in the Grid.

Remarks

  • This applies only when the MenuBar is docked to the Bottom or Top.

Example

To set the MenuBar scroll position to 2:

out-chart -DataGrid_Visible true -DataGrid_ScrollPosition 2

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_ShowHeader property of DataGrid Parameter

DataGrid_ShowHeader Parameter

Sets a value indicating the header of the columns should be visible or not.

Remarks

  • The ShowMarkers property shows or hides the series indicator displayed on the side of the dataGirid.

  • You may modify the color of the header using the BackColorHeader property.

Example

Hide the MenuBar header:

out-chart -DataGrid_ShowHeader false

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_ShowHiddenSeries property of DataGrid Parameter

DataGrid_ShowHiddenSeries Parameter

Sets a value indicating hidden series should be visible in MenuBar.

Remarks

  • A series can be marked hidden by setting the Visible property of the SeriesAttributes Parameter, however you may want to still show this series in the MenuBar using this property.

Example

To show hidden series in the MenuBar:

out-chart -DataGrid_ShowHiddenSeries true

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_ShowMarkers property of DataGrid Parameter

DataGrid_ShowMarkers Parameter

Sets a value indicating if serie markers should be visible in the serie headers.

Remarks

  • When the marker is hidden, only text is shown to label the series.

  • The property may be used to show or hide the dataGrid header.

Example

To remove the markers from the MenuBar:

out-chart -DataGrid_Visible true -DataGrid_ShowMarkers false

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_TextColorData property of DataGrid Parameter

DataGrid_TextColorData Parameter

Sets the text color of the cells on the MenuBar.

Remarks

  • This property does not change the color of the header text, you can set the header text color of the dataGrid with TextColorHeader property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the text color of MenuBar Cells to Blue:

out-chart -DataGrid_Visible true -DataGrid_TextColorData Blue

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_TextColorDataAlternate property of DataGrid Parameter

DataGrid_TextColorDataAlternate Parameter

Sets the alternate text color for text in the MenuBar cells.

Remarks

  • This property is useful when the Interlaced property is used.

  • The initial color of the text in the dataGrid cells can be set using the TextColorData property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Set the alternate text color for the MenuBar to red:

out-chart -DataGrid_Visible true -DataGrid_Interlaced Horizontal -DataGrid_TextColorDataAlternate Red

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_TextColorHeader property of DataGrid Parameter

DataGrid_TextColorHeader Parameter

Sets the text color of the headers on the MenuBar.

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use property to enable the MenuBar.

  • You can set the other cells text color of the dataGird with TextColorData property.

  • You can change the color of a specific cell by using property

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change MenuBar headers text color to Orange:

out-chart -DataGrid_Visible true -DataGrid_TextColorHeader Orange

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_UseRawData property of DataGrid Parameter

DataGrid_UseRawData Parameter

Sets a value indicating whether to use raw data or use calculated values in the DataEditor.

Remarks

  • Some gallery types, such as the BoxPlot and Histogram, manipulate data values displayed in the MenuBar. If you would like to actually see the data passed to the chart, you can set this property to true. This property will not affect all gallery types.

Example

To configure the DataEditor to use raw data:

out-chart -DataGrid_Visible true -DataGrid_UseRawData true

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_VerticalGridColor property of DataGrid Parameter

DataGrid_VerticalGridColor Parameter

Allows you to select the Vertical line color for the gridline displayed at the MenuBar box.

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use property to enable the MenuBar.

  • You can set the Horizontal line color of the MenuBar gridline with HorizontalGridColor property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To show the MenuBar and change the gridlines color to Red:

out-chart -DataGrid_Visible true -DataGrid_VerticalGridColor Red

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Visible property of DockableBar Parameter

DataGrid_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To hide the MenuBar:

out-chart -DataGrid_Visible false

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_Width property of DockableBar Parameter

DataGrid_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the width for the MenuBar to 300 pixels:

out-chart -DataGrid_Width 300

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DataGrid_XValuesAsHeaders property of DataGrid Parameter

DataGrid_XValuesAsHeaders Parameter

Sets a value instructing that XValues be used as the headers in the MenuBar.

Remarks

  • When set to true, the XValues passed to a chart will be used for the point headers in the dataGrid.

  • In order for this property to affect the chart, the chart must include XValues (XY plot).

Example

To use XValues as Headers in the DataEditor:

out-chart -DataGrid_XValuesAsHeaders true

See Also

Chart_DataGrid Parameter | Chart_DataGrid Summary


DrillDown Class Members

Chart_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on a chart point.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on a chart point.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on a chart point.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-chart.

Example

To use the DrillDown_Script parameter:

ps | out-chart -DrillDown_Script ProcessDetails.ps1 -DrillDown_Parameter {$_.Id}

See Also

Chart_DrillDown Parameter | Chart_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on a chart point.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

Example

To use the DrillDown_Parameter:

ps | out-chart -DrillDown_Parameter {$_.ProcessName}

See Also

Chart_DrillDown Parameter | Chart_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

ps | out-chart -DrillDown_Parameter {$_.ProcessName} -DrillDown_Script get-process -DrillDown_Console

See Also

Chart_DrillDown Parameter | Chart_DrillDown Summary


ExtraStyle property of Chart Parameter

ExtraStyle Parameter

Allows you to set additional visual attributes in the chart.

Value | Meaning
TrackMouse | This constant has to be included for those charts you want to capture mouse tracking.
DoubleBuffer | The chart will refresh itself using a double buffering technique. The effect will be a less flickering.
NoLegInvalidate | Useful for RealTime charts. Is this flag is ON, the chart will not be invalidated when the legends are set.
PaintMarker | This constant will turn on message event for customize chart drawing process.
OnlyChart | Makes the chart to hide everything outside the chart area such a axis,titles,etc.This feature is very useful when you want to overlap charts.
SideBySide | For 2D MultiType charts, makes the bars to be side-by-side instead of overlapped.
Monochrome | Turn ON will show a Black & White chart and it won't be possible to change chart colors.
CacheImage | When true, chart images will be cached in memory. (PSS features)
ExportXValues | If this flag is ON, the X values are exported to the clipboard every time you export the chart as data.
FastLegends | ChartStyleEx_FastLegendsDisable the legend size computation. Use this flag to improve speed on setting the legends. You must set this flag on BEFORE setting any legend. You can not show a legend box if the legends are set while this flag is on. If you are going to set a new set of legends you must call the ClearLegend property before starting to set the legends in order to get the best performance.
Crosshairs | Turn on or off the cross-hairs feature.
ToolTips | Turn on or off the tool-tips feature.
MenusOnDemand | See ContextMenus property.
Default | Sets default settings.
ScrollBars | When OFF, it will hide the Scrollbars.
AllowScroll | When OFF, none of the Axes will allow scroll.
ForceDataDriven | Description goes here

Remarks

  • This property uses bitwise operators to turn on and off settings. To combine two flags. use the 'Or' bitwise operator.

Example

For example, the correct way to turn on the Monochrome setting is the following:

out-chart -ExtraStyle +Monochrome

See Also

Chart Parameter | Chart Summary


Floating property of Chart Parameter

Floating Parameter

Allows you to launch a chart without a window frame.

Remarks

  • Use Floating to launch a chart without a window frame making the chart appear as it were floating over the desktop.

Example

To launch a chart without a window frame:

out-chart -floating

See Also

Chart Parameter | Chart Summary


Font property of Chart Parameter

Font Parameter

Sets the font type which will be used by default in the chart.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Sets a Times New Roman font, italic, and of size 12:

out-chart -Font "Times News Roman,12,style=Italic"

See Also

Chart Parameter | Chart Summary


ForeColor property of Chart Parameter

ForeColor Parameter

Sets the default font color of the chart.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Sets the default font of the chart to green:

out-chart -ForeColor Green

See Also

Chart Parameter | Chart Summary


Gallery property of Chart Parameter

Gallery Parameter

Sets the gallery type of the chart. The gallery type can also be accessed through the AllSeries property.

Default Value
The default is Bar.

Value | Meaning
Lines | Line Chart
Bar | Bar Chart
Area | Area Chart
Scatter | Scatter Chart
Pie | Pie Chart
Curve | Curve Chart
Pareto | Pareto Chart
Step | Step Chart
HighLowClose | Hi-Low-Close Chart
Surface | Surface Chart
Radar | Radar Chart
Polar | Polar Chart.
Cube | Cube Chart
Doughnut | Doughnut Chart
Pyramid | Pyramid Chart
Bubble | Bubble Chart
OpenHighLowClose | Open-High-Low-Close Chart
Candlestick | Candlestick Chart
Contour | Countour Chart
CurveArea | Curve Area Chart
Gantt | Gantt Chart

Remarks

  • When selecting a Gallery for charts, keep in mind the number of data series which will be included in the chart. Pie, Pyramid and Doughnut chart types can only display one series per chart. If you have multiple data series, you may want to select a Gallery type that supports one that one series.

  • GalleryAttributes allows you to assign additional attributes to selected gallery types.

Example

To display an AREA chart:

out-chart -Gallery Area

See Also

Chart Parameter | Chart Summary


GalleryAttributes property of Chart Parameter

GalleryAttributes Parameter

Used to create a gallery object to assign additional attributes to the selected gallery type of the chart. The gallery attribute can also be accessed through the AllSeries property.

Remarks

  • This property returns an object which allows assignment of special properties to be set for the selected gallery. Note that not all gallery types support additional properties.

  • Below, the attributes of the Pie gallery are modified to render a 3D effect:

Example

Set a shadow for a 2D pie:

out-chart -Gallery Pie -GalleryAttributes_Shadows true

See Also

Chart Parameter | Chart Summary


Bubble Parameter

Remarks

A Bubble chart compares a set of two series with the second of the series specifying the size of the bubble marker, and the first series specifying the location in Y axis where the bubble center is painted.

When configures bubble charts, you must be aware that the property has a specific effect on the way bubble charts are displayed as the Size will be divided by the setting in the Volume property. For example, if the property is set to 50, it means that PowerGadgets will force the marker to occupy 1/2 of the space allotted. When you set the bubble size to 100, you would expect the bubble to occupy the entire space allotted; however in this case the bubble will only occupy 1/2 of the space allotted. Similarly, if the Volume is set to 50 and the bubble size is 50, the bubble will occupy 1/4 of the space allotted.


Bubble Class Members

Chart_GalleryAttributes_Bubble Parameter Parameters

Parameters

Description
MaximumBubbleSize Sets the maximum size a bubble can be in the Bubble chart.


GalleryAttributes_Bubble Parameter_MaximumBubbleSize property of Bubble Parameter

GalleryAttributes_Bubble Parameter_MaximumBubbleSize Parameter

Sets the maximum size a bubble can be in the Bubble chart.

Remarks

  • The values are relative; so a MaxSize of 50 shows bubbles smaller than a MaxSize of 100.

  • There is no limit to the MaxSize, however 100 usually creates a bubble the size of the chart and any larger values would simply occupy the chart screen reducing the charts usefulness.

Example

To set the maximum bubble size to 12:

out-chart -Gallery Bubble -GalleryAttributes_MaximumBubbleSize 12

See Also

Chart_GalleryAttributes_Bubble Parameter Parameter | Chart_GalleryAttributes_Bubble Parameter Summary


Curve Parameter

Remarks

Using this property you can assign special attributes for the Bubble gallery type in your chart.


Curve Class Members

Chart_GalleryAttributes_Curve Parameter Parameters

Parameters

Description
Tension Sets the Tension variable for the Cubic Spline curve algorithm.


GalleryAttributes_Curve Parameter_Tension property of Curve Parameter

GalleryAttributes_Curve Parameter_Tension Parameter

Sets the Tension variable for the Cubic Spline curve algorithm.

Remarks

  • Using this property, you can create curves series drawn with 'loose' or 'tight' tension value. Think of the curve series as points connected by a rope. As you increase tension on the rope, the curves become more 'tight'. Decreasing the tension creates a more 'loose' looping curve.

Example

To configure the Tension for the curve to 2:

out-chart -Gallery Curve -GalleryAttributes_Tension 2

See Also

Chart_GalleryAttributes_Curve Parameter Parameter | Chart_GalleryAttributes_Curve Parameter Summary


Pie Parameter

Remarks

The properties of the Pie Parameter allow you to customize the visual attributes of a Pie chart.

By default, if PowerGadgets concludes that drawing a label inside a Pie chart will make the readalibility of the chart harder, this label is drawn outside the chart. You can set LabelsInside to false to force PowerGadgets to draw all the labels outside the Chart. The following chart illustrates the default behaviour of the Pie chart:

The gallery of the chart can also be set to a Doughnut. The attributes object of the Doughnut gallery is of type Pie:


Pie Class Members

Chart_GalleryAttributes_Pie Parameter Parameters

Parameters

Description

DoughnutThickness | Controls the thickness of the doughnut as a percentage of the outside radius.
ExplodingMode | Allows you to set how the slices of a pie chart are displayed.
LabelLineBreak | Controls how the line which connects the label and the pie/doughnut chart is broken. Notice that the LabelsInside property should be set to false.
LabelsInside | Instructs PogerGadgets to try to paint the point labels directly on the corresponding slice of a Pie chart.
MaximumLabelMargin | Sets the maximium allowed margin (in pixels) between the labels and the borders of the pie chart.
Shadows | Adds a shadow effect to a 2D pie chart.
ShowLines | Shows or hides lines which connect the point labels to a a Pie chart.
SliceSeparation | Sets the pie slice separation (in pixels) when using the ExplodingMode property.
Square | Forces Pie charts to be contained in a perfect square (no matter the window proportion).
Stacked | Sets a Boolean value specifying whether or not to stack a pie/doughnut chart.
StartAngle | Sets a value specifying the starting angle of the first slice in a pie chart.


GalleryAttributes_Pie Parameter_DoughnutThickness property of Pie Parameter

GalleryAttributes_Pie Parameter_DoughnutThickness Parameter

Controls the thickness of the doughnut as a percentage of the outside radius.

Remarks

  • The default value is 50 which means the radius of the hole is half of the radius of the outer wall. As this value decreases, the doughnut becomes thinner.

  • When the Stacked property is set to true, a multi-series pie/doughnut chart will draw each series on top of each other (2D Only) instead of side-by-side:

    The property may be used to control the size of each series. Series 0 is painted behind the others, so it should be set as the largest (e.g. Volume = 100).

Example

Here is an example of creating a stacked Pie chart:

out-chart -Gallery Doughnut -GalleryAttributes_Stacked true -GalleryAttributes_DoughnutThickness 10

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_ExplodingMode property of Pie Parameter

GalleryAttributes_Pie Parameter_ExplodingMode Parameter

Allows you to set how the slices of a pie chart are displayed.

Default Value
The default is None.

Value | Meaning
None | Pie slices are not separated.
All | All pie slices are separated.
First | Only first pie slice is separated.
Last | Only last pie slice is separated.

Remarks

  • You can set the distance a slice will be separated from the pie chart using the SliceSeparation property.

  • Below, the pie is set to the Full exploding mode:

    Alternativelly, the Pie chart is here set to the First exploding mode:

Example

Use the explode all option to separate all slices of the pie chart:

out-chart -Gallery Doughnut -GalleryAttributes_ExplodingMode All -GalleryAttributes_SliceSeparation 20

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_LabelLineBreak property of Pie Parameter

GalleryAttributes_Pie Parameter_LabelLineBreak Parameter

Controls how the line which connects the label and the pie/doughnut chart is broken. Notice that the LabelsInside property should be set to false.

Remarks

  • Below is a pie chart with a LabelLineBreak equal to 10 (default value):

    Below is a pie chart with a LabelLineBreak equal to 0. Notice that the line does not break:

    Below is a pie chart with a LabelLineBreak equal to 20:

Example

To set the LabelLineBreak property to 20:

out-chart -Gallery Pie -AllSeries_PointLabels_Visible true -GalleryAttributes_LabelsInside false -GalleryAttributes_LabelLineBreak 20

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_LabelsInside property of Pie Parameter

GalleryAttributes_Pie Parameter_LabelsInside Parameter

Instructs PogerGadgets to try to paint the point labels directly on the corresponding slice of a Pie chart.

Remarks

  • When point labels are painted outside of the Pie chart, lines will be added to improve chart readability. You can control how the lines break by using the LabelLineBreak property.

  • Below is a pie chart where the labels are inside. Notice that the size of the label font has been made smaller. If PowerGadgets concludes that drawing a label inside a Pie chart will make the readalibility of the chart harder, this label is drawn outside the chart.

    Below is a pie chart where the labels are outside:

Example

Set the labels outside for a pie chart:

out-chart -Gallery Pie -AllSeries_PointLabels_Visible true -GalleryAttributes_LabelsInside false

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_MaximumLabelMargin property of Pie Parameter

GalleryAttributes_Pie Parameter_MaximumLabelMargin Parameter

Sets the maximium allowed margin (in pixels) between the labels and the borders of the pie chart.

Remarks

  • Alternativelly, you can control the margins between the plot area and the border of the chart by using the property of the Chart Parameter.

Example

Sets the maximum allowed margin to 5 pixels:

out-chart -Gallery Pie -GalleryAttributes_MaximumLabelMargin 5

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_Shadows property of Pie Parameter

GalleryAttributes_Pie Parameter_Shadows Parameter

Adds a shadow effect to a 2D pie chart.

Remarks

  • When the Shadows property is applied to a 2D Pie chart, the outside edges of the pie appear rounded:

  • The pie chart must be in 2D mode for this property to have an effect.

  • The default value for this property is true.

Example

To set the shadow effect to false:

out-chart -Gallery Pie -GalleryAttributes_Shadows false

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_ShowLines property of Pie Parameter

GalleryAttributes_Pie Parameter_ShowLines Parameter

Shows or hides lines which connect the point labels to a a Pie chart.

Remarks

  • When used in conjunction with a Pie chart, this property shows or hides the lines drawn from point labels to their corresponding pie slice. If the labels are inside the pie (i.e., LabelsInside = true) , this property will have not effect on the chart.

Example

To hide the lines in a Pie chart:

out-chart -Gallery Pie -GalleryAttributes_ShowLines false

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_SliceSeparation property of Pie Parameter

GalleryAttributes_Pie Parameter_SliceSeparation Parameter

Sets the pie slice separation (in pixels) when using the ExplodingMode property.

Remarks

  • Below is a Pie chart with SliceSeparation equal to 10:

    Below is a Pie chart with SliceSeparation equal to 25:

Example

To set the SliceSeparation to 25:

out-chart -Gallery Doughnut -GalleryAttributes_ExplodingMode All -GalleryAttributes_SliceSeparation 25

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_Square property of Pie Parameter

GalleryAttributes_Pie Parameter_Square Parameter

Forces Pie charts to be contained in a perfect square (no matter the window proportion).

Remarks

Example

To not apply the square style to a Pie chart:

out-chart -Gallery Pie -GalleryAttributes_Square false

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_Stacked property of Pie Parameter

GalleryAttributes_Pie Parameter_Stacked Parameter

Sets a Boolean value specifying whether or not to stack a pie/doughnut chart.

Remarks

  • When set to true, a multi-series pie/dougnut chart will draw each series on top of each other (2D Only) instead of side-by-side.

  • For more information on how to use Stacked, please refer to the documentation of the DoughnutThickness property.

Example

To Stack a pie or doughnut chart:

out-chart -Gallery Pie -GalleryAttributes_Stacked true

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


GalleryAttributes_Pie Parameter_StartAngle property of Pie Parameter

GalleryAttributes_Pie Parameter_StartAngle Parameter

Sets a value specifying the starting angle of the first slice in a pie chart.

Remarks

  • This property may be configued with a value from 0 to 360.

Example

To configure the starting angle to 180:

out-chart -Gallery Pie -GalleryAttributes_StartAngle 180

See Also

Chart_GalleryAttributes_Pie Parameter Parameter | Chart_GalleryAttributes_Pie Parameter Summary


Radar Parameter

Remarks

The properties of the Radar Parameter allow you to customize the visual attributes of a Radar chart.


Radar Class Members

Chart_GalleryAttributes_Radar Parameter Parameters

Parameters

Description

Circular | Sets a value specifying to draw the Radar chart in a round or polygonal shape.
Clockwise | Sets a value indicating to plot points in a clockwise or counter-clockwise direction.
Closed | Sets a value indicating whether or not to connect the first and last points in a radar chart.
FillArea | Fills the inside areas of a Radar chart.
Shadows | Sets a value indicating whether or not shadowing is applied for a 2D radar chart.
ShowLines | Shows or Hides the lines connecting eqch point in the radar Chart.


GalleryAttributes_Radar Parameter_Circular property of Radar Parameter

GalleryAttributes_Radar Parameter_Circular Parameter

Sets a value specifying to draw the Radar chart in a round or polygonal shape.

Remarks

  • When set to false, the radar will contain as many sides as points are present in the chart. The outer boundry of the Radar chart will be a polygon shape.

  • The Shadows property may be used to remove the default shadow applied to 2D Radar charts.

  • The property of the Parameter is used to access the GalleryAttributes object for a chart. The Radar object is a GalleryAttributes object.

Example

To configure the Radar chart to have straight outside edges:

out-chart -Gallery Radar -GalleryAttributes_Circular true

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


GalleryAttributes_Radar Parameter_Clockwise property of Radar Parameter

GalleryAttributes_Radar Parameter_Clockwise Parameter

Sets a value indicating to plot points in a clockwise or counter-clockwise direction.

Remarks

  • When XValues are configured in a radar chart, the chart is actaully converted to a Polar chart that supports XValues between 0 and 360.

  • The ShowLines property allows you to show or hide the connecting lines between the points in a radar chart.

  • The Circular property is used to set a circular border for the radar chart.

  • The property of the Parameter is used to access the GalleryAttributes object for a chart. The Radar object is a GalleryAttributes object.

Example

To configure a radar chart to plot counter-clockwise:

out-chart -Gallery Radar -GalleryAttributes_Clockwise false

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


GalleryAttributes_Radar Parameter_Closed property of Radar Parameter

GalleryAttributes_Radar Parameter_Closed Parameter

Sets a value indicating whether or not to connect the first and last points in a radar chart.

Remarks

  • By default this property is set to true. To create a radar chart with open ended series, set this property to false.

  • The ShowLines property allows you to show or hide the connecting lines between the points in a radar chart.

  • The Circular property is used to set a circular border for the radar chart.

  • The property of the Parameter is used to access the GalleryAttributes object for a chart. The Radar object is a GalleryAttributes object.

Example

To configure a Radar chart to have open ended series:

out-chart -Gallery Radar -GalleryAttributes_Closed false

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


GalleryAttributes_Radar Parameter_FillArea property of Radar Parameter

GalleryAttributes_Radar Parameter_FillArea Parameter

Fills the inside areas of a Radar chart.

Remarks

  • The property of the Parameter is used to access the GalleryAttributes object for a chart. The Radar object is a GalleryAttributes object.

Example

To fill the inside areas of a Radar chart:

out-chart -Gallery Radar -GalleryAttributes_FillArea true

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


GalleryAttributes_Radar Parameter_Shadows property of Radar Parameter

GalleryAttributes_Radar Parameter_Shadows Parameter

Sets a value indicating whether or not shadowing is applied for a 2D radar chart.

Remarks

  • Shadowing is always applied to 3D radar charts. The property of the Parameter may be used to toggle 3D views for a chart.

  • The Circular property is used to set a circular border for the radar chart.

  • The ClockWise property is used to control the direction of a radar plot.

  • The property of the Parameter is used to access the GalleryAttributes object for a chart. The Radar object is a GalleryAttributes object.

Example

To configure the Radar chart to have shadow:

out-chart -Gallery Radar -GalleryAttributes_Shadows true

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


GalleryAttributes_Radar Parameter_ShowLines property of Radar Parameter

GalleryAttributes_Radar Parameter_ShowLines Parameter

Shows or Hides the lines connecting eqch point in the radar Chart.

Remarks

  • Below, the lines in the Radar chart are hidden:

Example

To hide the lines in a radar chart:

out-chart -Gallery Radar -GalleryAttributes_ShowLines false

See Also

Chart_GalleryAttributes_Radar Parameter Parameter | Chart_GalleryAttributes_Radar Parameter Summary


Surface Parameter

Remarks

The properties of the Surface Parameter allow you to customize the visual attributes of a Curve chart.

The Surface plot is usually displayed in a 3D representation. The number of points determines the width of the chart while the number of series determines the depth of the chart. You can enable the 3D view using the d property of the Parameter:

The Contour gallery offers a bettwe alterntive to a Surface graph when the chart should be rendered in 2D. The Surface Parameter also allows changing the specific properties of the Contour gallery. Notice that the tool bar item related to the 3D view are disabled when the gallery type is switched to Contour:


Surface Class Members

Chart_GalleryAttributes_Surface Parameter Parameters

Parameters

Description

ShowContourLines | Shows or hides the contour lines for Contour charts.
ShowGridLines | Shows or hides the Grid lines of surface charts in the chart area.
Step | Set the Step for a Surface chart. The lower the Step, the smother the surface.


GalleryAttributes_Surface Parameter_ShowContourLines property of Surface Parameter

GalleryAttributes_Surface Parameter_ShowContourLines Parameter

Shows or hides the contour lines for Contour charts.

Remarks

  • This property works only in Contour-type charts. Setting this property in Surface charts causes no change.

Example

To enable the contour lines on a contour chart:

out-chart -Gallery Surface -GalleryAttributes_ShowContourLines true

See Also

Chart_GalleryAttributes_Surface Parameter Parameter | Chart_GalleryAttributes_Surface Parameter Summary


GalleryAttributes_Surface Parameter_ShowGridLines property of Surface Parameter

GalleryAttributes_Surface Parameter_ShowGridLines Parameter

Shows or hides the Grid lines of surface charts in the chart area.

Remarks

  • When the surface plot is set to one color, it can be difficult to see the variation in the chart. Setting the ShowGridLines property allows you to see the changes in the surface chart easily.

  • You can change the color of the grid lines using the and the properties of the Parameter. The Effect property must be set to none for the properties to take effect.

  • Below is a Surface chart which renders the Grid lines:

    Similarly, this is the result when the gallery type is switched to Contour:

Example

To show the grid lines of a Surface chart:

out-chart -Gallery Surface -GalleryAttributes_ShowGridLines true

See Also

Chart_GalleryAttributes_Surface Parameter Parameter | Chart_GalleryAttributes_Surface Parameter Summary


GalleryAttributes_Surface Parameter_Step property of Surface Parameter

GalleryAttributes_Surface Parameter_Step Parameter

Set the Step for a Surface chart. The lower the Step, the smother the surface.

Remarks

  • You can set a Step for the Surface wich is different to the Chart's to affect the colors without affecting the chart's labels.

  • Below is a surface chart with the Step property equal to 5:

    Below is a surface chart with the Step property equal to 20:

    Below is a surface chart with the Step property equal to 60:

Example

To set the Step to 5:

out-chart -Gallery Surface -GalleryAttributes_Step 5

See Also

Chart_GalleryAttributes_Surface Parameter Parameter | Chart_GalleryAttributes_Surface Parameter Summary


Glass property of Chart Parameter

Glass Parameter

Allows you to configure the gauge background to be painted using Glass form.

Remarks

  • When running in Windows Vista, the chart background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-chart -Glass

See Also

Chart Parameter | Chart Summary


Group property of Chart Parameter

Group Parameter

Allows you to create the chart window as a separate process and assigns an ID that allows multiple charts to share the same window.

Remarks

  • If a group already exists, PowerGadgets will introduce a navigation bar on the bottom right hand corner of the gadget window allowing you to easily switch through the various gadgets in the group. You can also use the play button to automatically cycle through the gadgets every few seconds.

  • Use the Name parameter to assign a name to the chart.

Example

To use the Group parameter to have multiple charts in the same window:

out-chart -group "My Gadgets"

See Also

Chart Parameter | Chart Summary


HideFromAltTab property of Chart Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-chart -HideFromAltTab

See Also

Chart Parameter | Chart Summary


Label property of Chart Parameter

Label Parameter

Allows you to specify which property to use as the X labels.

Remarks

  • Use Label to determine which property to use as the X labels in the chart.

Example

To specify the ID as X label in a chart populated with the processes (PS>get-process ):

ps | out-chart -values Handles -label ID

See Also

Chart Parameter | Chart Summary


LegendBox Parameter

Remarks

A legend box is a tool within a chart that contains relevant information to explain what is being depicted in a chart.

The LegendBox can show legends from , , , , etc.

You must make the legend box in order to see any of the visual attributes configured using the properties of the Parameter.

The legend box inherites from . Therefore, some visual properties of the legend box can be accessed using the properties implemented by .


LegendBox Class Members

Chart_LegendBox Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
ContentLayout | Allows you to align the content for the legend box.
CustomItems | Returns the collection of the custom items in the legend box.
Dock | Sets the position of the LegendBox.
Font | Sets the font of the Legend Box.
Height | Sets the height of the dockable bar in pixels.
MarginX | Sets a value specifying the margin width for a LegendBox.
MarginY | Sets a value specifying the margin height for a LegendBox.
PlotAreaOnly | Allows the legend box margins to go outside of the chart's drawing area.
Style | Sets the style of the legend box.
TextColor | Sets the color used for the text in the legend box.
Titles | Returns or sets a title object for the legend box.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


LegendBox_AutoSize property of DockableBar Parameter

LegendBox_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a chart.

Example

To disable the AutoSize property for the LegendBox:

out-chart -LegendBox_AutoSize false

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_BackColor property of DockableBar Parameter

LegendBox_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of the LegendBox to red:

out-chart -LegendBox_BackColor Red

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Border property of DockableBar Parameter

LegendBox_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

Sets the Border to External:

out-chart -LegendBox_Border External

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_ContentLayout property of LegendBox Parameter

LegendBox_ContentLayout Parameter

Allows you to align the content for the legend box.

Default Value
The default is Center.

Value | Meaning
Spread | Stretches the selected object in the configured position.
Near | Left justifies the selected object in the configured position.
Center | Centers the selected object in the configured position.
Far | Right justifies the selected object in the configured position.

Remarks

  • When the Leyend box is doked at the lefy or right of the Chart, Near means Top, and Far means Bottom.

Example

Sets the alignment for legend box to Far:

out-chart -LegendBox_ContentLayout Far

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_CustomItems_<index> property of LegendBox Parameter

LegendBox_CustomItems_<index> Parameter

Returns the collection of the custom items in the legend box.

Remarks

Example

To add a Custom Legend item:

out-chart -LegendBox_CustomItems_0_Text "Custom Item" -LegendBox_CustomItems_0_Color Orange

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


CustomLegendItem Class Members

Chart_LegendBox_CustomItems Parameters

Parameters

Description

AlternateColor | Sets the background color of a custom legend item marker when a pattern is configured using the MarkerShape property.
Attributes | Sets the PointAttributes object for the custom legend item.
Border | Gets a BorderAttributes object allowing you to modify the border properties for this CustomLegendItem.
Color | Sets the Color for the marker of the Custoem Legend Item.
MarkerShape | Sets the shape of the marker.
Pattern | Sets a HatchStyle pattern for the marker of the custom item.
Picture | Sets an image to be used as a marker for the legend item.
ShowLine | Sets a value used to display a line marker for the custom item.
Text | Sets the text string of the custom legend item.


LegendBox_CustomItems_<index>_AlternateColor property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_AlternateColor Parameter

Sets the background color of a custom legend item marker when a pattern is configured using the MarkerShape property.

Remarks

  • The forecolor of the pattern is configured using the Color property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the alternate color to a custom Legend item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Pattern BackwardDiagonal -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_AlternateColor Blue

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Attributes property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Attributes Parameter

Sets the PointAttributes object for the custom legend item.

Remarks

  • The Attributes property is used to obtain the object for a CustomLegendItem. This allows the developer to apply unique visual attributes for the legend item.

  • Please see the the Parameter for additional information regarding the suppored members.

Example

To select to 3 the marker size for the custom legend item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_Attributes_MarkerShape Triangle

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


PointAttributes Class Members

Chart_LegendBox_CustomItems_Attributes Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
BarShape | Sets the Shape for the Bars.
Border | Provides access to the border attributes object.
Color | Allows you to set a color for the selected item.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Line | Gets the LineAttributes object for the particular point.
MarkerShape | Sets the the type used to paint markers for the selected item.
MarkerSize | Sets a value controlling the size of the markers for the selected item.
Pattern | Sets a value specifying the pattern for the selected item.
Picture | Sets a value specifying the picture associated to the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
SeparateSlice | Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.
Text | Sets a value for labeling the point or series attribute.
Volume | Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


LegendBox_CustomItems_<index>_Attributes_AlternateColor property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To create a Gradient on the point marker (0,0) using the colors Red and Bisque:

out-chart -AllSeries_FillMode Gradient -Points_0_0_Color Red -Points_0_0_AlternateColor Bisque

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_BarShape property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_BarShape Parameter

Sets the Shape for the Bars.

Value | Meaning
Rectangle | Sets the Bar shape to a Rectangle (Default).
Cylinder | Sets the Bar shape to a Cylinder.
Cone | Sets the Bar shape to a Cone.
Pyramid | Sets the Bar shape to a Pyramid.

Remarks

  • This property applies when the chart Gallery is set to Bar.

Example

This changes the bar shapes to cylinder for the first point.

out-chart -Points_0_BarShape Cone

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Border property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To remove borders for the 2nd point of all series:

out-chart -Points_1_Border_Width 5

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Color property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the chart, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color for the 1st point in all the series to blue:

out-chart -Points_0_Color Blue

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_FillMode property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the FillMode property to Pattern for a point:

out-chart -Points_1_FillMode Pattern

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Line property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Line Parameter

Gets the LineAttributes object for the particular point.

Remarks

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

Example

To set the line width to 3 for all series in a chart:

out-chart -AllSeries_Line_Width 3

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_MarkerShape property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_MarkerShape Parameter

Sets the the type used to paint markers for the selected item.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

Example

To select a triangle as the marker shape for the first point in all the series:

out-chart -Points_0_MarkerShape Triangle

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_MarkerSize property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_MarkerSize Parameter

Sets a value controlling the size of the markers for the selected item.

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

Example

To increase the marker size for the first point of all the series:

out-chart -Points_0_MarkerSize 5

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Pattern property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the chart FillMode is set to either B&W or colored patterns.

  • If the chart's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • Below, the second series pattern is set to cross:

Example

To set a pattern for the first point of all the series:

out-chart -Points_0_Pattern Cross

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Picture property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Picture Parameter

Sets a value specifying the picture associated to the selected item.

Remarks

  • The Picture property may be used in two different ways depending on the chart's gallery and FillMode:

    1. If the chart gallery is one that uses point markers, meaning you can set the shape of the marker using the MarkerShape property, then the configured image will be used as a point marker as long as the MarkerShape for that point is set to MarkerShape.Picture.

    2. If the chart gallery is one that uses bars, area markers or pie slices (Bar, Area or Pie type charts), the image will be tiled in the selected series or point. However, in order for the tiled effect to be applied you must set the FillMode to FillMode.Pattern.

  • The Legends and DataEditor will also show the picture but with an appropriated size. Notice that if you do not set the FillMode to FillMode.Pattern, the configured picture will only be used with charts that have point markers.

  • When this property is set to a 3D chart, the sides of the markers (3D perspective) are painted with the configured series color.

Example

To set a picture for the 1st point of all the series:

out-chart -Points_0_Picture "image.bmp"

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_PointLabels property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To show point labels for a chart:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_SeparateSlice property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_SeparateSlice Parameter

Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.

Remarks

  • Setting this property to 100 will make the vertex of the slice to be on the edge of the pie.

  • PowerGadgets does not provide administrative properties, such as the biggest slice in a PIE chart, so if you want to separate a particular slice based on a certain condition, you must first determine the slice to be separated based on the data contained in the chart.

Example

To separate the first slice of each series by 50%:

out-chart -Points_0_SeparateSlice 50

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Text property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set strings to be used as legend in a 2 series chart:

out-chart -Series_0_Text "Text 0" -Series_1_Text "Text 1" -LegendBox_Visible true

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Volume property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Volume Parameter

Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

Example

To make the first point of all the series occupy all the space allotted to them:

out-chart -Points_0_Volume 100

See Also

Chart_LegendBox_CustomItems_Attributes Parameter | Chart_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Border property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Border Parameter

Gets a BorderAttributes object allowing you to modify the border properties for this CustomLegendItem.

Remarks

Example

To change the color of the border of the first Custom Legend Item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Yellow -LegendBox_CustomItems_0_Border_Color DarkRed

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


BorderAttributes Class Members

Chart_LegendBox_CustomItems_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


LegendBox_CustomItems_<index>_Border_BetweenSegments property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Remarks

  • For some gallery types, Area for example, turning the point markers border visible will generate the following efect on a chart:

  • When BetweenSegments is set to true, this will be the effect:

Example

To set the BetweenSegmetnts to true for all series:

out-chart -AllSeries_Border_Width 6 -AllSeries_Border_BetweenSegments true

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_Color property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set to Red the Border color for all series:

out-chart -AllSeries_Border_Color Red

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_Effect property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the border effect to Shadow for all series:

out-chart -AllSeries_Border_Effect Shadow

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_Style property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Style of the border line to Dash:

out-chart -AllSeries_Border_Style Dash

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_UseForLines property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line chart.

Remarks

  • When applied to a Line Chart, Border attributes will affect only the Point marker, where the line will remain unchanged.

  • When setting UseForLines to true, the border attributes are applied to the line too:

Example

To apply the border attributes to all the lines:

out-chart -Gallery Lines -AllSeries_Border_UseForLines true -AllSeries_Border_Width 3

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_Visible property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the border visible for all series:

out-chart -AllSeries_Border_Visible true

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Border_Width property of BorderAttributes Parameter

LegendBox_CustomItems_<index>_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the point markers border width to 2:

out-chart -AllSeries_Border_Width 2

See Also

Chart_LegendBox_CustomItems_Border Parameter | Chart_LegendBox_CustomItems_Border Summary


LegendBox_CustomItems_<index>_Color property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Color Parameter

Sets the Color for the marker of the Custoem Legend Item.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the Custom Legend Item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_MarkerShape property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_MarkerShape Parameter

Sets the shape of the marker.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • vamoIf you hide the markers using the MarkerShape.None property, labels will be numbered.

  • Borders may be applied to markers using the Color property. Be sure to set MarkerShape to None when assigning a border color.

Example

Selects an inverted triangles as the marker shape for the first custom legend item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_MarkerShape Triangle

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Pattern property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Pattern Parameter

Sets a HatchStyle pattern for the marker of the custom item.

Remarks

  • The forecolor of the pattern is configured using the Color property. The background color of the pattern is configured using the AlternateColor property.

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • See HatchStyle in the PowerShell .

Example

Creates a custom legend box item, adds it to the legend box, and sets a BackwardDiagonal pattern:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Pattern BackwardDiagonal -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_AlternateColor Blue

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Picture property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Picture Parameter

Sets an image to be used as a marker for the legend item.

Remarks

  • Setting this property will override any settings configured using the MarkerShape property.

Example

Sets the first custom item marker to an image:

out-chart -LegendBox_CustomItems_0_Picture "MyImage.png"

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_ShowLine property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_ShowLine Parameter

Sets a value used to display a line marker for the custom item.

Remarks

  • The MarkerShape property may be used in combination with this property to display a different marker shape.

Example

To display a diferent marker shape, a circle with a line:

out-chart -LegendBox_CustomItems_0_Text "Custom Item 1" -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_MarkerShape Circle -LegendBox_CustomItems_0_ShowLine true

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Text property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Text Parameter

Sets the text string of the custom legend item.

Remarks

Example

To add a custom legend item:

out-chart -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red

See Also

Chart_LegendBox_CustomItems Parameter | Chart_LegendBox_CustomItems Summary


LegendBox_Dock property of DockableBar Parameter

LegendBox_Dock Parameter

Sets the position of the LegendBox.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To dock the to the right margin:

out-chart -LegendBox_Dock Right

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Font property of LegendBox Parameter

LegendBox_Font Parameter

Sets the font of the Legend Box.

Remarks

  • You can set the font for the entire chart using the property.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired chart element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To change the font for the series legend box text:

out-chart -LegendBox_Font "Arial, 12"

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Height property of DockableBar Parameter

LegendBox_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the height for the LegendBox to 300 pixels:

out-chart -LegendBox_Height 300

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_MarginX property of LegendBox Parameter

LegendBox_MarginX Parameter

Sets a value specifying the margin width for a LegendBox.

Remarks

  • The MarginY property may be used to control the margin height for a LegendBox.

  • The property of the Parameter is used to return the chart's LegendBox object.

Example

To configure the X Margin for a legendbox to 50:

out-chart -LegendBox_MarginX 50

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_MarginY property of LegendBox Parameter

LegendBox_MarginY Parameter

Sets a value specifying the margin height for a LegendBox.

Remarks

  • The MarginX property may be used to control the margin width for a LegendBox.

  • The property of the Parameter is used to return the chart's LegendBox object.

Example

To configure the Y Margin for a legendbox to 50:

out-chart -LegendBox_MarginY 50

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_PlotAreaOnly property of LegendBox Parameter

LegendBox_PlotAreaOnly Parameter

Allows the legend box margins to go outside of the chart's drawing area.

Remarks

  • If there is enough space and the legend is centered (default), there will be no noticeable difference when this property is configured. The difference is visible when there are many legend values, the drawing area is too small, the opposite gaps (e.g. top and bottom) are different or the legend is not centered.

  • By default the legends are drawn inside the chart drawing area, for example when the legend box is at the right, the first legend will be at the top of the chart area, it will not use the margin on top. If you set PlotAreaOnly to false, the margins will also be available for the legend.

Example

To set the DrawingArea property to false:

out-chart -LegendBox_PlotAreaOnly false

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Style property of LegendBox Parameter

LegendBox_Style Parameter

Sets the style of the legend box.

Value | Meaning
Wordbreak | Wraps text when the legend alignment is set to spread.
ShowMenu | Enables the context menu for the legend.
Default | Default legend settings.
RightAlign | Right aligns the text in the legend. Used with Languages written from right to left.
NoColor | No Colors are used for markers in legend.
HidePartial | Description goes here

Remarks

  • This property uses bitwise operators to turn on and off settings. To combine two flags. use the 'Or' bitwise operator.

Example

Configures the legend box to enables the context menu:

out-chart -LegendBox_Style +ShowMenu

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_TextColor property of LegendBox Parameter

LegendBox_TextColor Parameter

Sets the color used for the text in the legend box.

Remarks

  • Before you can see the text color assignments, the selected legend box must be visible.

  • You can assign the text for the values legend box using the or properties.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the legend box text to red:

out-chart -LegendBox_TextColor Red

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Titles_<index> property of LegendBox Parameter

LegendBox_Titles_<index> Parameter

Returns or sets a title object for the legend box.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index for the selected legend box.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

  • The property may be used to get or set the color of the title text; the Property can be used to configure a new font object for the title.

Example

To set a title in bold at the top of the LegendBox:

out-chart -LegendBox_Titles_0_Text "My Title" -LegendBox_Titles_0_font "Arial, 10, style=bold"

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


TitleDockable Class Members

Chart_LegendBox_Titles Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Dock | Sets or Gets the Dock property, which allows set where the title will be docked.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
PlotAreaOnly | Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


LegendBox_Titles_<index>_Alignment property of Title Parameter

LegendBox_Titles_<index>_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_BackColor property of Title Parameter

LegendBox_Titles_<index>_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_Dock property of TitleDockable Parameter

LegendBox_Titles_<index>_Dock Parameter

Sets or Gets the Dock property, which allows set where the title will be docked.

Default Value
The default is Top.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • This property allows you to dock the chart at the top, bottom, left or right of the chart.

Example

To dock the title at the bottom of the chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Dock Bottom

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_Font property of Title Parameter

LegendBox_Titles_<index>_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_Indentation property of Title Parameter

LegendBox_Titles_<index>_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_LineAlignment property of Title Parameter

LegendBox_Titles_<index>_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_PlotAreaOnly property of TitleDockable Parameter

LegendBox_Titles_<index>_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_RichText property of Title Parameter

LegendBox_Titles_<index>_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_Separation property of Title Parameter

LegendBox_Titles_<index>_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_Text property of Title Parameter

LegendBox_Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Titles_<index>_TextColor property of Title Parameter

LegendBox_Titles_<index>_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_LegendBox_Titles Parameter | Chart_LegendBox_Titles Summary


LegendBox_Visible property of DockableBar Parameter

LegendBox_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To hide the LegendBox:

out-chart -LegendBox_Visible false

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


LegendBox_Width property of DockableBar Parameter

LegendBox_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the width for the LegendBox to 300 pixels:

out-chart -LegendBox_Width 300

See Also

Chart_LegendBox Parameter | Chart_LegendBox Summary


Location property of Chart Parameter

Location Parameter

Allows you to configure the chart's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the chart from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a location for the chart:

out-chart -location 10,10

See Also

Chart Parameter | Chart Summary


MainPane property of Chart Parameter

MainPane Parameter

Gets the default pane of the chart.

Remarks

  • The default pane can also be accessed through the AllSeries property.

Example

Set the back color of the main pane to Blue:

out-chart -MainPane_BackColor Blue

See Also

Chart Parameter | Chart Summary


Pane Class Members

Chart_MainPane Parameters

Parameters

Description

Axes | Provides access to the Y Axis Collection for the selected Pane.
AxisY | Provides access to the members of the main Y Axis for the selected Pane.
BackColor | Sets the inside color for the selected pane.
Background | Sets an ImageBackground or GradientBackground object for a pane.
Proportion | Sets a value indicating the proportional size of the selected pane.
Separation | Sets a value indicating the space in between panes.
Title | Gets the Title object for a selected chart pane.
Visible | Sets a value indicating the Pane object should be shown or not.


MainPane_Axes property of Pane Parameter

MainPane_Axes Parameter

Provides access to the Y Axis Collection for the selected Pane.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the Y Axis index.

Remarks

  • Use this property to mamipulate the Y Axes of the Pane.

  • The AxisY property provides direct access to the Pane's main Y axis.

Example

To add a secondary Y Axis to the Pane 1:

out-chart -Panes_0_Axes_1_Visible true

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_AxisY property of Pane Parameter

MainPane_AxisY Parameter

Provides access to the members of the main Y Axis for the selected Pane.

Remarks

  • This property is a shortcut to the Pane's main .

Example

To invert the main Y Axis in the Pane 1:

out-chart -Panes_1_AxisY_Inverted true

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_BackColor property of Pane Parameter

MainPane_BackColor Parameter

Sets the inside color for the selected pane.

Remarks

  • For gradient background, see the Background.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the BackColor for a selected pane:

out-chart -Panes_1_BackColor HotPink

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_Background property of Pane Parameter

MainPane_Background Parameter

Sets an ImageBackground or GradientBackground object for a pane.

Remarks

  • Each pane present in a chart may have a unique ImageBackground or GradientBackground object configured as the background.

  • Please see the ImageBackground and GradientBackground objects for information regarding supported members.

Example

To assign a GradientBackground for a selected pane object:

out-chart -Panes_0_Background myBackground

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_Proportion property of Pane Parameter

MainPane_Proportion Parameter

Sets a value indicating the proportional size of the selected pane.

Remarks

  • This property accepts an integer that specifies the "proportional" size of a selected pane. For Example, If you set this property to the value of 2 for a selected pane, that pane's height would be twice the size of any default pane's size. The default pane size will depend on the number of panes visible in the chart as well as the dimensions of the chart object itself.

Example

To configure the 3rd pane in a chart to be 3 times the height of a default chart pane:

out-chart -Panes_1_Proportion 3

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_Separation property of Pane Parameter

MainPane_Separation Parameter

Sets a value indicating the space in between panes.

Remarks

  • This property is useful when multiple panes are configured and you need to create space for readability.

Example

To set a value for seperation for a selected pane:

out-chart -Panes_1_Separation 10

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MainPane_Title property of Pane Parameter

MainPane_Title Parameter

Gets the Title object for a selected chart pane.

Remarks

  • This property returns a Title object. Accessing the title Parameter members you will be able to control attributes such as: Alignment, Color, Font,Text, etc.

  • Each pane may only have one title.

  • The Separation property may be used to control the space between panes. This may be useful to developers trying a change the font for a pane's title.

Example

To configure a title for the 2nd pane:

out-chart -Panes_1_Title_Text "2nd Pane Title"

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


Title Class Members

Chart_MainPane_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


MainPane_Title_Alignment property of Title Parameter

MainPane_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_BackColor property of Title Parameter

MainPane_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_Font property of Title Parameter

MainPane_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_Indentation property of Title Parameter

MainPane_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_LineAlignment property of Title Parameter

MainPane_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_PlotAreaOnly property of TitleDockable Parameter

MainPane_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_RichText property of Title Parameter

MainPane_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_Separation property of Title Parameter

MainPane_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_Text property of Title Parameter

MainPane_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Title_TextColor property of Title Parameter

MainPane_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_MainPane_Title Parameter | Chart_MainPane_Title Summary


MainPane_Visible property of Pane Parameter

MainPane_Visible Parameter

Sets a value indicating the Pane object should be shown or not.

Remarks

  • Hiding a Pane object will hide all the series associated to that pane, not only from the chart area but also from the Legend and the DataGrid. The hidden series objects will remain accessible but invisible.

  • Hiding a Pane object does not destroy or lose previous settings assigned by other properties.

Example

To hide the second pane:

out-chart -Panes_1_Visible false

See Also

Chart_MainPane Parameter | Chart_MainPane Summary


MenuBar property of Chart Parameter

MenuBar Parameter

Allows you to access the menu bar of the chart. Alternativelly, you can access the tool bar of the chart using ToolBar.

Remarks

  • Although the chart is displayed in a bounding rectangle, PowerGadgets is capable of displaying a menu bar as part of the chart.

Example

To show the menu bar:

out-chart -MenuBar_Visible true

See Also

Chart Parameter | Chart Summary


ToolBar Class Members

Chart_MenuBar Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
Dock | Sets the position of the ToolBar.
Height | Sets the height of the dockable bar in pixels.
ShowImages | Sets a value indicating whether to show or hide images for ToolBarItems.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


MenuBar_AutoSize property of DockableBar Parameter

MenuBar_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a chart.

Example

To disable the AutoSize property for the MenuBar:

out-chart -MenuBar_AutoSize false

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_BackColor property of DockableBar Parameter

MenuBar_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of the MenuBar to red:

out-chart -MenuBar_BackColor Red

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_Border property of DockableBar Parameter

MenuBar_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

Sets the Border to External:

out-chart -MenuBar_Border External

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_Dock property of DockableBar Parameter

MenuBar_Dock Parameter

Sets the position of the MenuBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To dock the to the right margin:

out-chart -MenuBar_Dock Right

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_Height property of DockableBar Parameter

MenuBar_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the height for the MenuBar to 300 pixels:

out-chart -MenuBar_Height 300

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_ShowImages property of ToolBar Parameter

MenuBar_ShowImages Parameter

Sets a value indicating whether to show or hide images for ToolBarItems.

Remarks

  • The property is used to access the ToolBar object of a chart.

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_Visible property of DockableBar Parameter

MenuBar_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To hide the MenuBar:

out-chart -MenuBar_Visible false

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


MenuBar_Width property of DockableBar Parameter

MenuBar_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the width for the MenuBar to 300 pixels:

out-chart -MenuBar_Width 300

See Also

Chart_MenuBar Parameter | Chart_MenuBar Summary


Modal property of Chart Parameter

Modal Parameter

Allows you to block the command pipe while displaying a chart.

Remarks

  • Use Modal to block the command pipe while displaying a chart.

Example

To create a chart blocking the command pipe while dit's displaying:

out-chart -modal

See Also

Chart Parameter | Chart Summary


Name property of Chart Parameter

Name Parameter

Allows you to assign a name to chart.

Remarks

  • Use the Name parameter to assign a name to the chart.

Example

To configure the chart name into a group:

out-chart -group "My Group" -name "Sales Chart"

See Also

Chart Parameter | Chart Summary


Output property of Chart Parameter

Output Parameter

Allows you to generate a chart file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a chart file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate a image (.png) of the chart:

out-chart -output test.png

See Also

Chart Parameter | Chart Summary


Palette property of Chart Parameter

Palette Parameter

Allows you to set a pre-defined palette.

Remarks

  • When changing the palette, all the properties related to changing colors in the chart will also be affected as PowerGadgets will change the windows palette for the chart window. So if you previously set a color using any of the PowerGadgets supported properties (ForeColor, BackColor, etc) this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • Below is a list of PowerGadgets palettes:

    Default
    Natural.Sky
    ChartFX6.EarthTones
    ChartFX6.ModernBusiness
    DarkPastels.Pastels
    Mesa.Mesa
    Natural.Adventure
    HighContrast.HighContrast
    Vivid
    ChartFX6.Alternate
    ChartFX6.Windows
    ChartFX6.ChartFX6

    The schemes supported by PowerGadgets are:

    Schemes.Colorful
    Schemes.Classic
    Schemes.Simple
    Schemes.Professional
    Schemes2.Autumn
    Schemes2.Oceanica
    Schemes2.Brown Sugar
    Schemes2.Slate
    Schemes3.Sand & Sky
    Schemes3.Rainy Day
    Schemes3.Snowy Pine
    Schemes3.Lilacs in Mist
    Schemes4.Mocha
    Schemes4.Black&Blue1

    Note: To properly load these palettes, you will simply use their string names (e.g. “DarkPastels.Pastels").

Example

To set the EarthTones palette:

out-chart -Palette "ChartFX6.EarthTones"

See Also

Chart Parameter | Chart Summary


Panes_<index> property of Chart Parameter

Panes_<index> Parameter

Returns the collection of the defined panes of the chart.

Parameters

Parameter | Type | Meaning
n | Int32 | Zero based index specifying the Panes item.

Remarks

  • The Main Pane of the chart is the first indexed pane of the collection.

Example

The main pane is the first indexed pane of the collection:

out-chart -MainPane_BackColor Yellow

See Also

Chart Parameter | Chart Summary


Pane Class Members

Chart_Panes Parameters

Parameters

Description

Axes | Provides access to the Y Axis Collection for the selected Pane.
AxisY | Provides access to the members of the main Y Axis for the selected Pane.
BackColor | Sets the inside color for the selected pane.
Background | Sets an ImageBackground or GradientBackground object for a pane.
Proportion | Sets a value indicating the proportional size of the selected pane.
Separation | Sets a value indicating the space in between panes.
Title | Gets the Title object for a selected chart pane.
Visible | Sets a value indicating the Pane object should be shown or not.


Panes_<index>_Axes property of Pane Parameter

Panes_<index>_Axes Parameter

Provides access to the Y Axis Collection for the selected Pane.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the Y Axis index.

Remarks

  • Use this property to mamipulate the Y Axes of the Pane.

  • The AxisY property provides direct access to the Pane's main Y axis.

Example

To add a secondary Y Axis to the Pane 1:

out-chart -Panes_0_Axes_1_Visible true

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_AxisY property of Pane Parameter

Panes_<index>_AxisY Parameter

Provides access to the members of the main Y Axis for the selected Pane.

Remarks

  • This property is a shortcut to the Pane's main .

Example

To invert the main Y Axis in the Pane 1:

out-chart -Panes_1_AxisY_Inverted true

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_BackColor property of Pane Parameter

Panes_<index>_BackColor Parameter

Sets the inside color for the selected pane.

Remarks

  • For gradient background, see the Background.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the BackColor for a selected pane:

out-chart -Panes_1_BackColor HotPink

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_Background property of Pane Parameter

Panes_<index>_Background Parameter

Sets an ImageBackground or GradientBackground object for a pane.

Remarks

  • Each pane present in a chart may have a unique ImageBackground or GradientBackground object configured as the background.

  • Please see the ImageBackground and GradientBackground objects for information regarding supported members.

Example

To assign a GradientBackground for a selected pane object:

out-chart -Panes_0_Background myBackground

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_Proportion property of Pane Parameter

Panes_<index>_Proportion Parameter

Sets a value indicating the proportional size of the selected pane.

Remarks

  • This property accepts an integer that specifies the "proportional" size of a selected pane. For Example, If you set this property to the value of 2 for a selected pane, that pane's height would be twice the size of any default pane's size. The default pane size will depend on the number of panes visible in the chart as well as the dimensions of the chart object itself.

Example

To configure the 3rd pane in a chart to be 3 times the height of a default chart pane:

out-chart -Panes_1_Proportion 3

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_Separation property of Pane Parameter

Panes_<index>_Separation Parameter

Sets a value indicating the space in between panes.

Remarks

  • This property is useful when multiple panes are configured and you need to create space for readability.

Example

To set a value for seperation for a selected pane:

out-chart -Panes_1_Separation 10

See Also

Chart_Panes Parameter | Chart_Panes Summary


Panes_<index>_Title property of Pane Parameter

Panes_<index>_Title Parameter

Gets the Title object for a selected chart pane.

Remarks

  • This property returns a Title object. Accessing the title Parameter members you will be able to control attributes such as: Alignment, Color, Font,Text, etc.

  • Each pane may only have one title.

  • The Separation property may be used to control the space between panes. This may be useful to developers trying a change the font for a pane's title.

Example

To configure a title for the 2nd pane:

out-chart -Panes_1_Title_Text "2nd Pane Title"

See Also

Chart_Panes Parameter | Chart_Panes Summary


Title Class Members

Chart_Panes_Title Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


Panes_<index>_Title_Alignment property of Title Parameter

Panes_<index>_Title_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_BackColor property of Title Parameter

Panes_<index>_Title_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_Font property of Title Parameter

Panes_<index>_Title_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_Indentation property of Title Parameter

Panes_<index>_Title_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_LineAlignment property of Title Parameter

Panes_<index>_Title_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_PlotAreaOnly property of TitleDockable Parameter

Panes_<index>_Title_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_RichText property of Title Parameter

Panes_<index>_Title_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_Separation property of Title Parameter

Panes_<index>_Title_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_Text property of Title Parameter

Panes_<index>_Title_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Title_TextColor property of Title Parameter

Panes_<index>_Title_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_Panes_Title Parameter | Chart_Panes_Title Summary


Panes_<index>_Visible property of Pane Parameter

Panes_<index>_Visible Parameter

Sets a value indicating the Pane object should be shown or not.

Remarks

  • Hiding a Pane object will hide all the series associated to that pane, not only from the chart area but also from the Legend and the DataGrid. The hidden series objects will remain accessible but invisible.

  • Hiding a Pane object does not destroy or lose previous settings assigned by other properties.

Example

To hide the second pane:

out-chart -Panes_1_Visible false

See Also

Chart_Panes Parameter | Chart_Panes Summary


PlotAreaColor property of Chart Parameter

PlotAreaColor Parameter

Gets and Sets the color of the PlotAreaBackground. Alternatively, the color can be access using the Color property of the PlotAreaBackground object.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • When the chart renders several panes, setting the color of the plot area is equivalent to setting the of the panes individually.

    Below, the color of the plot area is set to purple:

  • PlotAreaColor supports transparency. When the PlotArea is transparent, the background of the PlotArea is rendered by the Background and BackColor properties. In this screenshot, the PlotAreaColor is set to transparent and the BackColor is set to blue:

Example

Sets the color of the plot area to purple:

out-chart -PlotAreaColor Purple

See Also

Chart Parameter | Chart Summary


PlotAreaMargin property of Chart Parameter

PlotAreaMargin Parameter

Gets and Sets the top, bottom, left and right gaps of the chart.

Remarks

  • A gap is defined as the margin between the chart and the bounding rectangle in pixels. Each chart has a top, bottom, left and right gaps.

Example

Sets the bottom gap of the chart to 100. The other gaps are set to 0.

out-chart -PlotAreaMargin_Top 0 -PlotAreaMargin_Bottom 100 -PlotAreaMargin_Right 0 -PlotAreaMargin_Left 0

See Also

Chart Parameter | Chart Summary


Margins Class Members

Chart_PlotAreaMargin Parameters

Parameters

Description

Bottom | Sets the distance in pixels between the bottom border of the bounding rectangle and the bottom border of the of the chart.
Left | Sets the distance in pixels between the left border of the bounding rectangle and the left border of the of the chart.
Right | Sets the distance in pixels between the right border of the bounding rectangle and the right border of the of the chart.
Top | Sets the distance in pixels between the top border of the bounding rectangle and the top border of the of the chart.


PlotAreaMargin_Bottom property of Margins Parameter

PlotAreaMargin_Bottom Parameter

Sets the distance in pixels between the bottom border of the bounding rectangle and the bottom border of the plot area of the chart.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a chart.

Example

Sets the bottom margin to 100 pixels:

out-chart -PlotAreaMargin_Bottom 100

See Also

Chart_PlotAreaMargin Parameter | Chart_PlotAreaMargin Summary


PlotAreaMargin_Left property of Margins Parameter

PlotAreaMargin_Left Parameter

Sets the distance in pixels between the left border of the bounding rectangle and the left border of the plot area of the chart.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a chart.

Example

Sets the left margin to 100 pixels:

out-chart -PlotAreaMargin_Left 100

See Also

Chart_PlotAreaMargin Parameter | Chart_PlotAreaMargin Summary


PlotAreaMargin_Right property of Margins Parameter

PlotAreaMargin_Right Parameter

Sets the distance in pixels between the right border of the bounding rectangle and the right border of the plot area of the chart.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a chart.

Example

Sets the right margin to 100 pixels:

out-chart -PlotAreaMargin_Right 100

See Also

Chart_PlotAreaMargin Parameter | Chart_PlotAreaMargin Summary


PlotAreaMargin_Top property of Margins Parameter

PlotAreaMargin_Top Parameter

Sets the distance in pixels between the top border of the bounding rectangle and the top border of the plot area of the chart.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a chart.

Example

Sets the top margin to 100 pixels:

out-chart -PlotAreaMargin_Top 100

See Also

Chart_PlotAreaMargin Parameter | Chart_PlotAreaMargin Summary


Points_<index> property of Chart Parameter

Points_<index> Parameter

Assigns properties directly to a specific point in the chart.

Parameters

Parameter | Type | Meaning
series | Int32 | A zero based index indicating the data series in a chart.
point | Int32 | A zero based index indicating the data point in a chart.

Parameter | Type | Meaning
point | Int32 | A zero based index indicating the data point in a chart. When a chart only has one series, only a point index is required.

Remarks

  • Allows you to assign supported properties directly to the specified data point. For supported properties, please see the Parameter.

  • If you want to change the markers and the labels for all the points of the same series, please refer to the Series property.

Example

Changes the second series, third point color to black:

out-chart -Points_1_2_Color Black

See Also

Chart Parameter | Chart Summary


PointAttributes Class Members

Chart_Points Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
BarShape | Sets the Shape for the Bars.
Border | Provides access to the border attributes object.
Color | Allows you to set a color for the selected item.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Line | Gets the LineAttributes object for the particular point.
MarkerShape | Sets the the type used to paint markers for the selected item.
MarkerSize | Sets a value controlling the size of the markers for the selected item.
Pattern | Sets a value specifying the pattern for the selected item.
Picture | Sets a value specifying the picture associated to the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
SeparateSlice | Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.
Text | Sets a value for labeling the point or series attribute.
Volume | Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


Points_<index>_AlternateColor property of PointAttributes Parameter

Points_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To create a Gradient on the point marker (0,0) using the colors Red and Bisque:

out-chart -AllSeries_FillMode Gradient -Points_0_0_Color Red -Points_0_0_AlternateColor Bisque

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_BarShape property of PointAttributes Parameter

Points_<index>_BarShape Parameter

Sets the Shape for the Bars.

Value | Meaning
Rectangle | Sets the Bar shape to a Rectangle (Default).
Cylinder | Sets the Bar shape to a Cylinder.
Cone | Sets the Bar shape to a Cone.
Pyramid | Sets the Bar shape to a Pyramid.

Remarks

  • This property applies when the chart Gallery is set to Bar.

Example

This changes the bar shapes to cylinder for the first point.

out-chart -Points_0_BarShape Cone

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Border property of PointAttributes Parameter

Points_<index>_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To remove borders for the 2nd point of all series:

out-chart -Points_1_Border_Width 5

See Also

Chart_Points Parameter | Chart_Points Summary


BorderAttributes Class Members

Chart_Points_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


Points_<index>_Border_BetweenSegments property of BorderAttributes Parameter

Points_<index>_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Remarks

  • For some gallery types, Area for example, turning the point markers border visible will generate the following efect on a chart:

  • When BetweenSegments is set to true, this will be the effect:

Example

To set the BetweenSegmetnts to true for all series:

out-chart -AllSeries_Border_Width 6 -AllSeries_Border_BetweenSegments true

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_Color property of BorderAttributes Parameter

Points_<index>_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set to Red the Border color for all series:

out-chart -AllSeries_Border_Color Red

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_Effect property of BorderAttributes Parameter

Points_<index>_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the border effect to Shadow for all series:

out-chart -AllSeries_Border_Effect Shadow

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_Style property of BorderAttributes Parameter

Points_<index>_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Style of the border line to Dash:

out-chart -AllSeries_Border_Style Dash

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_UseForLines property of BorderAttributes Parameter

Points_<index>_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line chart.

Remarks

  • When applied to a Line Chart, Border attributes will affect only the Point marker, where the line will remain unchanged.

  • When setting UseForLines to true, the border attributes are applied to the line too:

Example

To apply the border attributes to all the lines:

out-chart -Gallery Lines -AllSeries_Border_UseForLines true -AllSeries_Border_Width 3

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_Visible property of BorderAttributes Parameter

Points_<index>_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the border visible for all series:

out-chart -AllSeries_Border_Visible true

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Border_Width property of BorderAttributes Parameter

Points_<index>_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the point markers border width to 2:

out-chart -AllSeries_Border_Width 2

See Also

Chart_Points_Border Parameter | Chart_Points_Border Summary


Points_<index>_Color property of PointAttributes Parameter

Points_<index>_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the chart, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color for the 1st point in all the series to blue:

out-chart -Points_0_Color Blue

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_FillMode property of PointAttributes Parameter

Points_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the FillMode property to Pattern for a point:

out-chart -Points_1_FillMode Pattern

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Line property of PointAttributes Parameter

Points_<index>_Line Parameter

Gets the LineAttributes object for the particular point.

Remarks

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

Example

To set the line width to 3 for all series in a chart:

out-chart -AllSeries_Line_Width 3

See Also

Chart_Points Parameter | Chart_Points Summary


LineAttributes Class Members

Chart_Points_Line Parameters

Parameters

Description

EndCap | Sets a marker shape at the end of a PointAttribute's Line.
StartCap | Sets a marker shape at the start of a PointAttribute's Line.
Style | Sets the style for a PointAttribute's Line.
Width | Sets the width for a PointAttribute's Line.


Points_<index>_Line_EndCap property of Line Parameter

Points_<index>_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_Points_Line Parameter | Chart_Points_Line Summary


Points_<index>_Line_StartCap property of Line Parameter

Points_<index>_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_Points_Line Parameter | Chart_Points_Line Summary


Points_<index>_Line_Style property of Line Parameter

Points_<index>_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_Points_Line Parameter | Chart_Points_Line Summary


Points_<index>_Line_Width property of Line Parameter

Points_<index>_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_Points_Line Parameter | Chart_Points_Line Summary


Points_<index>_MarkerShape property of PointAttributes Parameter

Points_<index>_MarkerShape Parameter

Sets the the type used to paint markers for the selected item.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

Example

To select a triangle as the marker shape for the first point in all the series:

out-chart -Points_0_MarkerShape Triangle

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_MarkerSize property of PointAttributes Parameter

Points_<index>_MarkerSize Parameter

Sets a value controlling the size of the markers for the selected item.

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

Example

To increase the marker size for the first point of all the series:

out-chart -Points_0_MarkerSize 5

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Pattern property of PointAttributes Parameter

Points_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the chart FillMode is set to either B&W or colored patterns.

  • If the chart's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • Below, the second series pattern is set to cross:

Example

To set a pattern for the first point of all the series:

out-chart -Points_0_Pattern Cross

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Picture property of PointAttributes Parameter

Points_<index>_Picture Parameter

Sets a value specifying the picture associated to the selected item.

Remarks

  • The Picture property may be used in two different ways depending on the chart's gallery and FillMode:

    1. If the chart gallery is one that uses point markers, meaning you can set the shape of the marker using the MarkerShape property, then the configured image will be used as a point marker as long as the MarkerShape for that point is set to MarkerShape.Picture.

    2. If the chart gallery is one that uses bars, area markers or pie slices (Bar, Area or Pie type charts), the image will be tiled in the selected series or point. However, in order for the tiled effect to be applied you must set the FillMode to FillMode.Pattern.

  • The Legends and DataEditor will also show the picture but with an appropriated size. Notice that if you do not set the FillMode to FillMode.Pattern, the configured picture will only be used with charts that have point markers.

  • When this property is set to a 3D chart, the sides of the markers (3D perspective) are painted with the configured series color.

Example

To set a picture for the 1st point of all the series:

out-chart -Points_0_Picture "image.bmp"

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_PointLabels property of PointAttributes Parameter

Points_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To show point labels for a chart:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_Points Parameter | Chart_Points Summary


PointLabelAttributes Class Members

Chart_Points_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
BorderColor | Sets the border color of the point label.
BorderWidth | Sets a value indicating the width of the border surrounding the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


Points_<index>_PointLabels_Alignment property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the right of the marker:

out-chart -AllSeries_PointLabels_Alignment Near

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_Angle property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the PointLabels angle for all the series to 45:

out-chart -AllSeries_PointLabels_Angle 45

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_BackColor property of PointLabelAttributes Parameter

Points_<index>_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point label background color to yellow:

out-chart -AllSeries_PointLabels_BackColor Yellow

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_BorderColor property of PointLabelAttributes Parameter

Points_<index>_PointLabels_BorderColor Parameter

Sets the border color of the point label.

Remarks

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point labels border color to Red:

out-chart -AllSeries_PointLabels_BorderColor Red

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_BorderWidth property of PointLabelAttributes Parameter

Points_<index>_PointLabels_BorderWidth Parameter

Sets a value indicating the width of the border surrounding the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the point label border width to 2:

out-chart -AllSeries_PointLabels_BorderWidth 2

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_Font property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired chart element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Set a font for all the point labels of the chart:

out-chart -AllSeries_PointLabels_Font "Arial, 12"

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_Format property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY charts, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked charts).

    X displays the marker X value for any chart type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To use the PointLabel Format Property:

out-chart -AllSeries_PointLabels_Format "I'm point # %N"

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_LineAlignment property of PointLabelAttributes Parameter

Points_<index>_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the top of the marker:

out-chart -AllSeries_PointLabels_LineAlignment Far

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_Offset property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

The code sets the PointLabelOffset to 4 pixels up and 5 pixels to the right:

out-chart -AllSeries_PointLabels_Offset "4,5"

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_RichText property of PointLabelAttributes Parameter

Points_<index>_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To use the PointLabels RichText property:

out-chart -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_RichText true -AllSeries_PointLabels_Format "I'm <b> Point </b> # %N"

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_TextColor property of PointLabelAttributes Parameter

Points_<index>_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set all the point labels to red:

out-chart -AllSeries_pointLabels_TextColor Red

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_PointLabels_Visible property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

Example

To show the labels of all the points in the chart: data points:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_Points_PointLabels Parameter | Chart_Points_PointLabels Summary


Points_<index>_SeparateSlice property of PointAttributes Parameter

Points_<index>_SeparateSlice Parameter

Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.

Remarks

  • Setting this property to 100 will make the vertex of the slice to be on the edge of the pie.

  • PowerGadgets does not provide administrative properties, such as the biggest slice in a PIE chart, so if you want to separate a particular slice based on a certain condition, you must first determine the slice to be separated based on the data contained in the chart.

Example

To separate the first slice of each series by 50%:

out-chart -Points_0_SeparateSlice 50

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Text property of PointAttributes Parameter

Points_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set strings to be used as legend in a 2 series chart:

out-chart -Series_0_Text "Text 0" -Series_1_Text "Text 1" -LegendBox_Visible true

See Also

Chart_Points Parameter | Chart_Points Summary


Points_<index>_Volume property of PointAttributes Parameter

Points_<index>_Volume Parameter

Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

Example

To make the first point of all the series occupy all the space allotted to them:

out-chart -Points_0_Volume 100

See Also

Chart_Points Parameter | Chart_Points Summary


RealTime property of Chart Parameter

RealTime Parameter

Allows access to the RealTimeSettings class supported members used to create real-time charts.

Remarks

  • You can set a buffer size to allocate memory for the realtime chart using the property. Setting a buffer will create a Limited real-time chart which is the fastest real-time chart. Excluding the buffer will instruct PowerGadgets to create an Unlimited real-time chart.

  • The loop marker may be customized using the property in conjunction with the supported Line Parameter properties. , , , and attributes may be assigned using the Parameter.

  • Use the Refresh paramter to refresh the chart with new data by executing the same command(s) that populated the chart at the first time.

Example

Sets the buffer size to 20 for a real-time chart:

out-chart -RealTime_BufferSize 20

See Also

Chart Parameter | Chart Summary


RealTimeSettings Class Members

Chart_RealTime Parameters

Parameters

Description

BufferSize | Sets the buffer size for real-time charts. When setting this property, the data array will be cleared.
FastScroll | Sets the Fast Scrolling feature.
LoopMarker | Allows you to apply the supported members to the real-time loop marker.
Mode | Sets or Gets the RealTime Mode.


RealTime_BufferSize property of RealTimeSettings Parameter

RealTime_BufferSize Parameter

Sets the buffer size for real-time charts. When setting this property, the data array will be cleared.

Remarks

  • This property allocates a circular buffer that PowerGadgets will use to handle limited real-time charts. By using this property, you gain performance in real-time charts and avoid data overflow.

  • Below, the buffer size is set to 400:

    Similarly, the buffer size is here set to 150:

Example

To set the buffer size to 400:

out-chart -RealTime_BufferSize 400

See Also

Chart_RealTime Parameter | Chart_RealTime Summary


RealTime_FastScroll property of RealTimeSettings Parameter

RealTime_FastScroll Parameter

Sets the Fast Scrolling feature.

Remarks

  • This feature scrolls a portion of the chart as a whole picture and simply paints a single value, instead of redrawing all the points.

  • This technique may prove very helpful when you have a large number of points or series.

Example

To turn this feature on for your chart:

out-chart -RealTime_FastScroll true

See Also

Chart_RealTime Parameter | Chart_RealTime Summary


RealTime_LoopMarker property of RealTimeSettings Parameter

RealTime_LoopMarker Parameter

Allows you to apply the supported Lineclass members to the real-time loop marker.

Remarks

  • Below, the loop-marker is render as a green dashed line:

Example

Sets the loop-marker as a green dashed line:

out-chart -RealTime_LoopMarker_Color Green -RealTime_LoopMarker_Style Dash

See Also

Chart_RealTime Parameter | Chart_RealTime Summary


RealTime_Mode property of RealTimeSettings Parameter

RealTime_Mode Parameter

Sets or Gets the RealTime Mode.

Remarks

  • Loop Mode should be used if you prefer for a loop marker to move across the chart from left to right updating the values as it passes.

  • Scroll Mode should be used if you prefer the chart’s data line/curve moving across from right to left updating the values on the right-most part of the chart.

Example

To set the mode to scroll:

out-chart -RealTime_Mode Scroll

See Also

Chart_RealTime Parameter | Chart_RealTime Summary


Refresh property of Chart Parameter

Refresh Parameter

Allows you to refresh the chart with new data by executing the same command(s) that populated the chart at the first time.

Remarks

  • If the command returns a single value per each series, the chart will add a new point to the end. Otherwise, the whole chart data is replaced with the new data.

Example

To refresh every 1 second the chart populated with the processes (PS>get-process ):

ps | out-chart -refresh 0:0:1

See Also

Chart Parameter | Chart Summary


RowHeadings property of Chart Parameter

RowHeadings Parameter

Allows you to specifies which fields to use in crosstab chart as row headings.

Remarks

  • Use RowHeadings to specifies which fields to use in crosstab chart as column headings.

  • Use ColHeadings to specifies which fields to use in crosstab chart as column headings.

Example

To configure the RowHeadings parameter to use the Handles and WorkingSet:

ps | out-chart -rowHeadings Handles,WorkingSet

See Also

Chart Parameter | Chart Summary


Series_<index> property of Chart Parameter

Series_<index> Parameter

Assigns properties directly to the selected series in the chart.

Parameters

Parameter | Type | Meaning
n | Int32 | A zero based index indicating the data series in the chart.

Remarks

  • AllSeries allows to set properties common to all the Series or/and Points of the chart.

  • The Series property allows you to create charts with mixed types and assign specific colors to each series.

Example

Create a multi-gallery chart:

out-chart -Series_0_Gallery Lines -Series_1_Gallery Bar -Series_2_Gallery Area

See Also

Chart Parameter | Chart Summary


SeriesAttributes Class Members

Chart_Series Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
AxisX | Sets a value indicating the AxisX the series is connected to.
AxisY | Sets a value indicating the AxisY the series is connected to.
BarShape | Sets the Shape for the Bars.
Border | Provides access to the border attributes object.
Color | Sets a Color for the selected series.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Gallery | Sets a gallery type for a particular series. All chart types are available in both 2D and 3D modes.
Line | Gets the LineAttributes object for the particular point.
MarkerShape | Sets the the type used to paint markers for the selected item.
MarkerSize | Sets a value controlling the size of the markers for the selected item.
MarkerStep | Controls how frequently point markers are shown in the selected series.
Pane | Sets the which the series belongs to.
Pattern | Sets a value specifying the pattern for the selected item.
Picture | Sets a value specifying the picture associated to the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
SeparateSlice | Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.
Stacked | Sets a value allowing you to stack the selected series with the previous series to achieve multi-stacked charts.
Text | Sets a value for labeling the point or series attribute.
Visible | Sets a value allowing you to show or hide the series.
Volume | Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.


Series_<index>_AlternateColor property of PointAttributes Parameter

Series_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To create a Gradient on the point marker (0,0) using the colors Red and Bisque:

out-chart -AllSeries_FillMode Gradient -Points_0_0_Color Red -Points_0_0_AlternateColor Bisque

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_AxisX property of SeriesAttributes Parameter

Series_<index>_AxisX Parameter

Sets a value indicating the AxisX the series is connected to.

Remarks

  • You may only assign a series to an AxisX object if the series contains XY data. The X property of the DataValues Parameter allows you to assign XValues in a chart.

  • The property is used to access the AxisXCollection for a chart. The AxisX property is used to assign a data series to one of the existing AxisX items in the AxisXCollection.

  • The AxisY property gets or sets a value indicating the AxisY the series is connected to.

  • Here is an example of a chart with a secondary X Axis. Each series is connected to a different XAxis:

    Also notice interesting options such as axis to help axis affiliation.

Example

To connect the first series to the second AxisX of the chart:

out-chart -Series_0_AxisX AxesX_1

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_AxisY property of SeriesAttributes Parameter

Series_<index>_AxisY Parameter

Sets a value indicating the AxisY the series is connected to.

Remarks

  • The property is used to access the AxisYCollection for a chart. The AxisY property is used to assign a data series to one of the existing AxisY items in the AxisYCollection.

  • The AxisX property gets or sets a value indicating the AxisX the series is connected to.

Example

To connect the first series to the second AxisY of the chart:

out-chart -Series_0_AxisY AxesY_1

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_BarShape property of PointAttributes Parameter

Series_<index>_BarShape Parameter

Sets the Shape for the Bars.

Value | Meaning
Rectangle | Sets the Bar shape to a Rectangle (Default).
Cylinder | Sets the Bar shape to a Cylinder.
Cone | Sets the Bar shape to a Cone.
Pyramid | Sets the Bar shape to a Pyramid.

Remarks

  • This property applies when the chart Gallery is set to Bar.

Example

This changes the bar shapes to cylinder for the first point.

out-chart -Points_0_BarShape Cone

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Border property of PointAttributes Parameter

Series_<index>_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To remove borders for the 2nd point of all series:

out-chart -Points_1_Border_Width 5

See Also

Chart_Series Parameter | Chart_Series Summary


BorderAttributes Class Members

Chart_Series_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


Series_<index>_Border_BetweenSegments property of BorderAttributes Parameter

Series_<index>_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Remarks

  • For some gallery types, Area for example, turning the point markers border visible will generate the following efect on a chart:

  • When BetweenSegments is set to true, this will be the effect:

Example

To set the BetweenSegmetnts to true for all series:

out-chart -AllSeries_Border_Width 6 -AllSeries_Border_BetweenSegments true

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_Color property of BorderAttributes Parameter

Series_<index>_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set to Red the Border color for all series:

out-chart -AllSeries_Border_Color Red

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_Effect property of BorderAttributes Parameter

Series_<index>_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the border effect to Shadow for all series:

out-chart -AllSeries_Border_Effect Shadow

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_Style property of BorderAttributes Parameter

Series_<index>_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Style of the border line to Dash:

out-chart -AllSeries_Border_Style Dash

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_UseForLines property of BorderAttributes Parameter

Series_<index>_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line chart.

Remarks

  • When applied to a Line Chart, Border attributes will affect only the Point marker, where the line will remain unchanged.

  • When setting UseForLines to true, the border attributes are applied to the line too:

Example

To apply the border attributes to all the lines:

out-chart -Gallery Lines -AllSeries_Border_UseForLines true -AllSeries_Border_Width 3

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_Visible property of BorderAttributes Parameter

Series_<index>_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the border visible for all series:

out-chart -AllSeries_Border_Visible true

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Border_Width property of BorderAttributes Parameter

Series_<index>_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the point markers border width to 2:

out-chart -AllSeries_Border_Width 2

See Also

Chart_Series_Border Parameter | Chart_Series_Border Summary


Series_<index>_Color property of SeriesAttributes Parameter

Series_<index>_Color Parameter

Sets a Color for the selected series.

Remarks

  • If no colors are specified, The default color is automatically selected by PowerGadgets when you create the chart, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Change the color of the first series to HotPink:

out-chart -Series_0_Color HotPink

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_FillMode property of PointAttributes Parameter

Series_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the charts. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the chart.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the FillMode property to Pattern for a point:

out-chart -Points_1_FillMode Pattern

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Gallery property of SeriesAttributes Parameter

Series_<index>_Gallery Parameter

Sets a gallery type for a particular series. All chart types are available in both 2D and 3D modes.

Value | Meaning
Lines | Line Chart
Bar | Bar Chart
Area | Area Chart
Scatter | Scatter Chart
Pie | Pie Chart
Curve | Curve Chart
Pareto | Pareto Chart
Step | Step Chart
HighLowClose | Hi-Low-Close Chart
Surface | Surface Chart
Radar | Radar Chart
Polar | Polar Chart.
Cube | Cube Chart
Doughnut | Doughnut Chart
Pyramid | Pyramid Chart
Bubble | Bubble Chart
OpenHighLowClose | Open-High-Low-Close Chart
Candlestick | Candlestick Chart
Contour | Countour Chart
CurveArea | Curve Area Chart
Gantt | Gantt Chart

Remarks

  • Applying this property to a specific series will create a MultiType chart, where different Chart Types can be combined in the same chart.

    You must be careful of the chart types you select to combine as not all of them will produce desirable results. For example, combining a chart that does not have numerical axis (e.g. Pie Chart) with a chart that has a numerical axis (e.g. Line Chart) will produce a chart that can't be read by the end user.

    A rule of thumb is that you can combine axis charts with similar types and non-axis charts with similar types, as follows:

    Axis Charts:

    Lines, Bar, Curve, Scatter, Area, Step, HiLowClose, Cube, Bubble, CandleStick, CurveArea, OpenHiLowClose, Pareto.

    Non-axis charts:

    Pie, Radar, DoughNut, Pyramid

    Note: Gantt, Surface and Contour can't be combined with other chart types

  • Another important issue to keep in mind when creating MultiType charts is the number of series each chart type requires to properly plot the data. For example, an Open-Hi-Lo-Close chart requires 4 consecutive series to properly plot the data, so if you want to combine this chart type with a line chart, the series containing the data for the line chart must be either the first or the last series in the data set.

Example

To set the 2nd series to line:

out-chart -Series_1_Gallery Lines

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Line property of PointAttributes Parameter

Series_<index>_Line Parameter

Gets the LineAttributes object for the particular point.

Remarks

  • LineAttributes will produce a different efect to each Gallery type. For a example, setting the Line.Width in a Bar chart will set widht the line that goes arround the bar, while in a Line chart, it will set the width of the line that conects the points.

Example

To set the line width to 3 for all series in a chart:

out-chart -AllSeries_Line_Width 3

See Also

Chart_Series Parameter | Chart_Series Summary


LineAttributes Class Members

Chart_Series_Line Parameters

Parameters

Description

EndCap | Sets a marker shape at the end of a PointAttribute's Line.
StartCap | Sets a marker shape at the start of a PointAttribute's Line.
Style | Sets the style for a PointAttribute's Line.
Width | Sets the width for a PointAttribute's Line.


Series_<index>_Line_EndCap property of Line Parameter

Series_<index>_Line_EndCap Parameter

Sets a marker shape at the ending of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis EndCap using this property both axes lines above and below the chart area are modified.

  • An starting marker shape may be applied to lines using the StartCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the ending marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_EndCap RoundAnchor

See Also

Chart_Series_Line Parameter | Chart_Series_Line Summary


Series_<index>_Line_StartCap property of Line Parameter

Series_<index>_Line_StartCap Parameter

Sets a marker shape at the beginning of a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis StartCap using this property both axes lines above and below the chart area are modified.

  • An ending marker shape may be applied to lines using the EndCap property.

  • You can also control Color, Style and Width for a selected line object using the supported members of the Line Parameter.

  • These are the supported styles:
    AnchorMask
    ArrowAnchor
    Custom
    DiamondAnchor
    Flat
    NoAnchor
    Round
    RoundAnchor
    Square
    SquareAnchor
    Triangle

Example

Set the starting marker shape for the X axis line to a 'RoundAnchor' shape:

out-chart -AxisX_Line_StartCap RoundAnchor

See Also

Chart_Series_Line Parameter | Chart_Series_Line Summary


Series_<index>_Line_Style property of Line Parameter

Series_<index>_Line_Style Parameter

Sets the line style for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line style using this property both axes lines above and below the chart area are effected.

  • You may also control the Width and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

  • These are the supported DashStyles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

Set the line style for the Y Axis line:

out-chart -AxisY_Line_Style DashDot

See Also

Chart_Series_Line Parameter | Chart_Series_Line Summary


Series_<index>_Line_Width property of Line Parameter

Series_<index>_Line_Width Parameter

Sets the line width for a selected line.

Remarks

  • When this property is applied to an axis line, both the primary and secondary axes are affected. For instance, when you change the X axis line width using this property both axes lines above and below the chart area are effected.

  • You may also control the Style and Color of the selected line using the supported members of the Line Parameter.

  • The EndCap and StartCap properties allow you to configured various shapes at the beginning and ending of a selected line.

Example

Set the line width for the Y Axis:

out-chart -AxisY_Line_Width 5

See Also

Chart_Series_Line Parameter | Chart_Series_Line Summary


Series_<index>_MarkerShape property of PointAttributes Parameter

Series_<index>_MarkerShape Parameter

Sets the the type used to paint markers for the selected item.

Value | Meaning
None | Do not display point markers.
Rect | Displays a rectangle.
Circle | Displays a circle.
Triangle | Displays a triangle.
Diamond | Displays a diamond.
Marble | Displays a 3D marble.
HorizontalLine | Displays a horizontal line.
VerticalLine | Displays a vertical line.
Cross | Displays a cross.
InvertedTriangle | Displays a rotated triangle.
X | Displays an X.
Many | Selects a combination of the above.
Picture | Displays a configured picture.

Remarks

  • Point markers will not be shown in 3D line charts.

  • This property applies only to: LINES, CURVE, SCATTER, PARETO, STEP and RADAR charts.

Example

To select a triangle as the marker shape for the first point in all the series:

out-chart -Points_0_MarkerShape Triangle

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_MarkerSize property of PointAttributes Parameter

Series_<index>_MarkerSize Parameter

Sets a value controlling the size of the markers for the selected item.

Remarks

  • This property sets the radius of the marker in physical units (pixels). You must make sure the MarkerShape Property is set to a valid point type for this property to take effect.

  • Point markers will not be shown in 3D line charts.

Example

To increase the marker size for the first point of all the series:

out-chart -Points_0_MarkerSize 5

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_MarkerStep property of SeriesAttributes Parameter

Series_<index>_MarkerStep Parameter

Controls how frequently point markers are shown in the selected series.

Remarks

  • This property is very useful when the chart contains a large number of points and the point markers disturb the chart's readability. For example, if you are showing 100 points in a line chart, the physical separation (pixels) of them is very small and probably the point markers will make the chart unreadable to the end user. In this case, you can set this property to force PowerGadgets to show point markers every 20 points.

  • Point markers will not be shown in 3D line charts.

Example

To show markers every 20 points:

out-chart -AllSeries_MarkerStep 20

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Pane property of SeriesAttributes Parameter

Series_<index>_Pane Parameter

Sets the Pane which the series belongs to.

Remarks

  • Once a series is assigned to a , this will be visible.

Example

To assign the first series to a new Pane:

out-chart -Series_0_Pane Panes_1

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Pattern property of PointAttributes Parameter

Series_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the chart FillMode is set to either B&W or colored patterns.

  • If the chart's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • Below, the second series pattern is set to cross:

Example

To set a pattern for the first point of all the series:

out-chart -Points_0_Pattern Cross

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Picture property of PointAttributes Parameter

Series_<index>_Picture Parameter

Sets a value specifying the picture associated to the selected item.

Remarks

  • The Picture property may be used in two different ways depending on the chart's gallery and FillMode:

    1. If the chart gallery is one that uses point markers, meaning you can set the shape of the marker using the MarkerShape property, then the configured image will be used as a point marker as long as the MarkerShape for that point is set to MarkerShape.Picture.

    2. If the chart gallery is one that uses bars, area markers or pie slices (Bar, Area or Pie type charts), the image will be tiled in the selected series or point. However, in order for the tiled effect to be applied you must set the FillMode to FillMode.Pattern.

  • The Legends and DataEditor will also show the picture but with an appropriated size. Notice that if you do not set the FillMode to FillMode.Pattern, the configured picture will only be used with charts that have point markers.

  • When this property is set to a 3D chart, the sides of the markers (3D perspective) are painted with the configured series color.

Example

To set a picture for the 1st point of all the series:

out-chart -Points_0_Picture "image.bmp"

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_PointLabels property of PointAttributes Parameter

Series_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To show point labels for a chart:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_Series Parameter | Chart_Series Summary


PointLabelAttributes Class Members

Chart_Series_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
BorderColor | Sets the border color of the point label.
BorderWidth | Sets a value indicating the width of the border surrounding the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


Series_<index>_PointLabels_Alignment property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the right of the marker:

out-chart -AllSeries_PointLabels_Alignment Near

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_Angle property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the PointLabels angle for all the series to 45:

out-chart -AllSeries_PointLabels_Angle 45

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_BackColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point label background color to yellow:

out-chart -AllSeries_PointLabels_BackColor Yellow

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_BorderColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BorderColor Parameter

Sets the border color of the point label.

Remarks

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the point labels border color to Red:

out-chart -AllSeries_PointLabels_BorderColor Red

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_BorderWidth property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BorderWidth Parameter

Sets a value indicating the width of the border surrounding the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the point label border width to 2:

out-chart -AllSeries_PointLabels_BorderWidth 2

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_Font property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired chart element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Set a font for all the point labels of the chart:

out-chart -AllSeries_PointLabels_Font "Arial, 12"

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_Format property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY charts, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked charts).

    X displays the marker X value for any chart type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To use the PointLabel Format Property:

out-chart -AllSeries_PointLabels_Format "I'm point # %N"

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_LineAlignment property of PointLabelAttributes Parameter

Series_<index>_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the point labels to the top of the marker:

out-chart -AllSeries_PointLabels_LineAlignment Far

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_Offset property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

The code sets the PointLabelOffset to 4 pixels up and 5 pixels to the right:

out-chart -AllSeries_PointLabels_Offset "4,5"

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_RichText property of PointLabelAttributes Parameter

Series_<index>_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To use the PointLabels RichText property:

out-chart -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_RichText true -AllSeries_PointLabels_Format "I'm <b> Point </b> # %N"

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_TextColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set all the point labels to red:

out-chart -AllSeries_pointLabels_TextColor Red

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_PointLabels_Visible property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

Example

To show the labels of all the points in the chart: data points:

out-chart -AllSeries_PointLabels_Visible true

See Also

Chart_Series_PointLabels Parameter | Chart_Series_PointLabels Summary


Series_<index>_SeparateSlice property of PointAttributes Parameter

Series_<index>_SeparateSlice Parameter

Sets a value allowing you to separate a slice of a Pie or Doughnut chart for a selected item.

Remarks

  • Setting this property to 100 will make the vertex of the slice to be on the edge of the pie.

  • PowerGadgets does not provide administrative properties, such as the biggest slice in a PIE chart, so if you want to separate a particular slice based on a certain condition, you must first determine the slice to be separated based on the data contained in the chart.

Example

To separate the first slice of each series by 50%:

out-chart -Points_0_SeparateSlice 50

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Stacked property of SeriesAttributes Parameter

Series_<index>_Stacked Parameter

Sets a value allowing you to stack the selected series with the previous series to achieve multi-stacked charts.

Remarks

  • Stacked options apply only to Bar and Area charts. So before applying this property, you must make sure the previous series and the selected series are of the same type (Bar or Area).

Example

To set a stacked chart for the 1st and 2nd series:

out-chart -Series_0_Stacked true -Series_1_Stacked true

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Text property of PointAttributes Parameter

Series_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set strings to be used as legend in a 2 series chart:

out-chart -Series_0_Text "Text 0" -Series_1_Text "Text 1" -LegendBox_Visible true

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Visible property of SeriesAttributes Parameter

Series_<index>_Visible Parameter

Sets a value allowing you to show or hide the series.

Remarks

  • Hiding an Series will:

    - not recalculate any of the scale values for the axis.

    - not remove the data associated with it.

    - hide the legend associated with it from the Series Legend.

    - hide all the data points in the DataGrid.

Example

Hide the 1st series:

out-chart -Series_0_Visible false

See Also

Chart_Series Parameter | Chart_Series Summary


Series_<index>_Volume property of PointAttributes Parameter

Series_<index>_Volume Parameter

Sets a value indicating a volume for a data point markers in supported galleries. By adjusting the volume, you can modify the amount of space you want between the items.

Remarks

  • The larger the value, the lesser the distance between the selected point and its neighbors.

  • This property has a dual functionality depending on the clustered status of the chart, as follows:

    If the chart is clustered, this property is used to specify the amount of space between the selected point and its neighbors in the z-axis (a.k.a. Gap Depth). When used in this context, this property is used for any chart type that supports clustered options (Including Multi-Type charts)

    When the chart is not clustered, this property controls the amount of space between the selected point and its neighbors in the x-axis (a.k.a. Gap Width). When used in this context, this property applies to any chart type that allows side to side positioning of the series (BAR, BUBBLE, CANDLESTICK, HI-LO-CLOSE, OPEN-HI-LOW-CLOSE and CUBES).

Example

To make the first point of all the series occupy all the space allotted to them:

out-chart -Points_0_Volume 100

See Also

Chart_Series Parameter | Chart_Series Summary


Size property of Chart Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered chart.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered chart.

Example

To configure the size of the chart:

out-chart -size 800,600

See Also

Chart Parameter | Chart Summary


Template property of Chart Parameter

Template Parameter

Allows you to use or save chart modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for chart.

Example

To use a pre-configured template called MyProcesses:

out-chart -template MyProcesses

See Also

Chart Parameter | Chart Summary


Titles_<index> property of Chart Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the chart.

Parameters

Parameter | Type | Meaning
n | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set a title in bold at the top of the chart:

out-chart -Titles_0_Text "Sales" -Titles_0_Font "Arial,10,style=bold" -Titles_0_Dock Top

See Also

Chart Parameter | Chart Summary


TitleDockable Class Members

Chart_Titles Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Dock | Sets or Gets the Dock property, which allows set where the title will be docked.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
PlotAreaOnly | Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


Titles_<index>_Alignment property of Title Parameter

Titles_<index>_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the chart from left to right, Near will be to the left and Far will be to the right.

  • Below, the alignment of the X axis is set to Far (i.e., right aligned):

    Similarly, the alignment of the X axis is here set to Center:

    Finally, the alignment is set to Near (i.e., left aligned):

Example

Set the first title on a chart to be left aligned:

out-chart -Titles-0_Text "Chart Titles" -Titles_0_Alignment Near

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_BackColor property of Title Parameter

Titles_<index>_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a chart a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the back color of the first chart title to yellow:

out-chart -Titles_0_Text "Chart Title" -Titles_0_BackColor Yellow

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_Dock property of TitleDockable Parameter

Titles_<index>_Dock Parameter

Sets or Gets the Dock property, which allows set where the title will be docked.

Default Value
The default is Top.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • This property allows you to dock the chart at the top, bottom, left or right of the chart.

Example

To dock the title at the bottom of the chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Dock Bottom

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Assign the "Arial" font of size 12 to the first chart title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Font "Arial, 12"

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_Indentation property of Title Parameter

Titles_<index>_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

  • Below, the Indentation property for the title of the Y axis is set to 50:

    Alternatively, the Indentation property is here set to 100:

Example

Create a Indentation of 5 for the first title:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Indentation 5

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_LineAlignment property of Title Parameter

Titles_<index>_LineAlignment Parameter

Sets the vertical alignment for the lines of the chart title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the chart.

Example

To center the lines:

out-chart -Titles_0_Text "Chart Title" -Titles_0_LineAlignment Center

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_PlotAreaOnly property of TitleDockable Parameter

Titles_<index>_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the chart's plot area. When set to False, title may be drawn across the entire chart including margins.

Example

To set the Title PlotAreaOnly property to false:

out-chart -Titles_0_Text "Very looooooooooooooonnnng Title" -Titles_0_PlotAreaOnly false

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_RichText property of Title Parameter

Titles_<index>_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

Add title "3rd Quarter Sales" with the word "Sales" bold and underlined:

out-chart -Titles_0_Text "3rd Quarter <b><u>Sales</u></b>" -Titles_0_RichText true

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_Separation property of Title Parameter

Titles_<index>_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

  • Below, the Separation property for the title of the X axis is set to 20:

    Alternatively, the Separation property is here set to 50:

Example

To set a Separation of 5 for the top title of a chart:

out-chart -Titles_0_Text "Chart Title" -Titles_0_Separation 5

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

Add title "3rd Quarter Sales" to the chart:

out-chart -Titles_0_Text "3rd Quarter Sales"

See Also

Chart_Titles Parameter | Chart_Titles Summary


Titles_<index>_TextColor property of Title Parameter

Titles_<index>_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the title's text to red:

out-chart -Titles_0_Text "Chart Title" -Titles_0_TextColor Red

See Also

Chart_Titles Parameter | Chart_Titles Summary


ToolBar property of Chart Parameter

ToolBar Parameter

Allow to acces the tool bar of the chart. Alternativelly, you can access the tool bar of the chart using MenuBar.

Remarks

  • Below is a chart with the ToolBar enabled:

Example

Makes the ToolBar visible:

out-chart -ToolBar_Visible true

See Also

Chart Parameter | Chart Summary


ToolBar Class Members

Chart_ToolBar Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
Dock | Sets the position of the ToolBar.
Height | Sets the height of the dockable bar in pixels.
ShowImages | Sets a value indicating whether to show or hide images for ToolBarItems.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


ToolBar_AutoSize property of DockableBar Parameter

ToolBar_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a chart.

Example

To disable the AutoSize property for the ToolBar:

out-chart -ToolBar_AutoSize false

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_BackColor property of DockableBar Parameter

ToolBar_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of the ToolBar to red:

out-chart -ToolBar_BackColor Red

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_Border property of DockableBar Parameter

ToolBar_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

Sets the Border to External:

out-chart -ToolBar_Border External

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_Dock property of DockableBar Parameter

ToolBar_Dock Parameter

Sets the position of the ToolBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To dock the to the right margin:

out-chart -ToolBar_Dock Right

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_Height property of DockableBar Parameter

ToolBar_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the height for the ToolBar to 300 pixels:

out-chart -ToolBar_Height 300

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_ShowImages property of ToolBar Parameter

ToolBar_ShowImages Parameter

Sets a value indicating whether to show or hide images for ToolBarItems.

Remarks

  • The property is used to access the ToolBar object of a chart.

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_Visible property of DockableBar Parameter

ToolBar_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To hide the ToolBar:

out-chart -ToolBar_Visible false

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolBar_Width property of DockableBar Parameter

ToolBar_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the width for the ToolBar to 300 pixels:

out-chart -ToolBar_Width 300

See Also

Chart_ToolBar Parameter | Chart_ToolBar Summary


ToolTipFields property of Chart Parameter

ToolTipFields Parameter

Specifies which properties to use in the tooltips. Multiple properties can be separated by commas.

Remarks

  • Use Values to specifie the properties to consider for plotting data. Only numeric properties can be plotted. If omitted, all the numeric properties are plo tted or the properties specified by default views file.

Example

To set the ToolTipFields parameter:

ps | out-chart -Values Hand les -Label ProcessName -ToolTipFields CPU

See Also

Chart Parameter | Chart Summary


ToolTipFormat property of Chart Parameter

ToolTipFormat Parameter

Allows you to control the information to be displayed in the tooltip when the user positions the mouse over a particular data point in the chart.

Remarks

  • ToolTips toggle on/off the tooltip in the chart.

  • The syntax for this property is the same as the one used in the property. Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY charts, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked charts).

    X displays the marker X value for any chart type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the Text property of the object.

Example

Shows a custom text, the series legend and the data value though the tooltip:

out-chart -Tooltips true -ToolTipFormat "I'm series: %S my value is:%v"

See Also

Chart Parameter | Chart Summary


ToolTips property of Chart Parameter

ToolTips Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the chart area only.

Remarks

  • This property does not affect whether if the Toolbar ToolTips will appear or not when the user positions the mouse over a particular button or element in the Toolbar. For more information on how to disable Toolbar tooltips, please refer to the ToolTips property in the Parameter.

Example

To disable tool tips:

out-chart -ToolTips false

See Also

Chart Parameter | Chart Summary


Values property of Chart Parameter

Values Parameter

Allows you to specify which properties to chart.

Remarks

  • Use the Values parameter to specify which properties will be used to populate the chart.

Example

To specify the Handles as value in a chart populated with the processes (PS>get-process ):

ps | out-chart -values Handles

See Also

Chart Parameter | Chart Summary


View3D property of Chart Parameter

View3D Parameter

Allows you to enable or disable 3D view of the chart. Also permits to customize the 3D view.

Remarks

  • When this property is set to True, you can apply a rotation angle or perspective with the AngleX, AngleY and Perspective parameters of the View3D object.

Example

Enables the chart's 3D View:

out-chart -View3D_Enabled true

See Also

Chart Parameter | Chart Summary


Attributes3D Class Members

Chart_View3D Parameters

Parameters

Description

AngleX | Sets the 3D rotation angle around the X-axis.
AngleY | Sets a 3D rotation angle around the Y-axis.
BoxThickness | Sets the thickness for the box surrounding the chart.
Cluster | Displays a z-clustered 3D chart.
Depth | Sets the thickness along the Z-axis for the series.
Enabled | Sets a value indicating whether 3D effects should be applied.
Perspective | Allows you to set a 3D perspective to control the view of the chart depth.
Rotated | Sets a value indicating the chart is Rotated.
Shadow | Sets a value indicating the type of shading to display when rotating the chart.


View3D_AngleX property of Attributes3D Parameter

View3D_AngleX Parameter

Sets the 3D rotation angle around the X-axis.

Remarks

  • The value can be set to an integer between [0-90] or [270-360] indicating the degree of rotation around the X-axis.

  • Negative values or values greater than 360 are automatically reduced to a value in the range of 0 to 359.

  • This property can only be used when the chart is in 3D view. So, be sure the properties is set to Visible.

  • To avoid jagged lines we recommend you use prominent angles (for example: 0,30,45,60,90, etc).

  • To set a Y-axis rotation angle, please refer to the AngleY property.

Example

To set an X-axis angle of 60 degrees:

out-chart -View3D_AngleX 60

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_AngleY property of Attributes3D Parameter

View3D_AngleY Parameter

Sets a 3D rotation angle around the Y-axis.

Remarks

  • The value can be set to an integer between [0-90] or [270-360] indicating the degree of rotation around the Y-axis.

  • Negative values or values greater than 360 are automatically reduced to a value in the range of 0 to 359.

  • This property can only be used when the chart is in 3D view. So, be sure the Enabled property is set to True.

  • To avoid jagged lines we recommend you use prominent angles (for example: 0,30,45,60,90, etc).

  • To set a X-axis rotation angle, please refer to the AngleX property.

Example

To set an Y-axis angle of 60 degrees:

out-chart -View3D_AngleY 60

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_BoxThickness property of Attributes3D Parameter

View3D_BoxThickness Parameter

Sets the thickness for the box surrounding the chart.

Remarks

  • Here is a chart with BoxThickness of 10.

Example

Here is a sample setting the BoxThickness to 20.

out-chart -View3D_BoxThickness 10

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Cluster property of Attributes3D Parameter

View3D_Cluster Parameter

Displays a z-clustered 3D chart.When set to True the chart will show as clustered, when set to False the chart displays the series side-by-side.

Remarks

  • When setting this property you must make sure the chart is displayed in 3D mode (by setting the Enabled property to true) and that the chart is cluster capable (BAR, LINES or GANTT chart).

  • When displaying a clustered chart, each series will have its own position in the Z axis. This means, if this property is set to true each data series will occupy one row of data along the Z-axis

  • AREA charts are always clustered as there is no way to paint different series side by side. On the other hand, if you have a BAR chart, it is possible to paint bars side-by-side and not clustered in the z-axis.

Example

To display a clustered chart:

out-chart -View3D_Cluster true

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Depth property of Attributes3D Parameter

View3D_Depth Parameter

Sets the thickness along the Z-axis for the series.

Remarks

  • Here are two examples demonstrating the differences when using Depth of 0 and Depth of 150.

    Depth value of 0:

    Depth value of 150:

Example

Here we double the default depth value to 200.

out-chart -View3D_Depth 200

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Enabled property of Attributes3D Parameter

View3D_Enabled Parameter

Sets a value indicating whether 3D effects should be applied.

Remarks

Example

Here we enable the 3D effects for chart1.

out-chart -View3D_Enabled true

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Perspective property of Attributes3D Parameter

View3D_Perspective Parameter

Allows you to set a 3D perspective to control the view of the chart depth.

Remarks

  • The perspective value specifies the ratio of the front of the chart to the back of the chart. It ranges from 0 (default) degrees to 100 degrees.

  • In order to apply a perspective the chart must be 3D Enabled.

Example

To set a perspective of 45 degrees:

out-chart -View3D_Perspective 45

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Rotated property of Attributes3D Parameter

View3D_Rotated Parameter

Sets a value indicating the chart is Rotated.

Remarks

  • Allows you to enable or disable a Rotated view in a 3D chart.

  • When a chart is Rotated, angles and perspective attribute are also applied.

Example

Here we enable rotation capabilities.

out-chart -View3D_Rotated true

See Also

Chart_View3D Parameter | Chart_View3D Summary


View3D_Shadow property of Attributes3D Parameter

View3D_Shadow Parameter

Sets a value indicating the type of shading to display when rotating the chart.

Default Value
The default is Fixed.

Value | Meaning
None | No light.
Fixed | Normal Light.
Realistic | Realistic lights.

Remarks

  • There are 3 options for this property.

    Fixed (default):

    Sets standard shading for crevasses exposed in 3D charts such as the boxes surrounding the.

    None:

    Removes all shading features. Note, this may reduce the 3D effect of the chart.

    Realistic:

    PowerGadgets adjusts the shading depending on the angle and rotation settings.

Example

Here we turn off all shading.

out-chart -View3D_Shadow None

See Also

Chart_View3D Parameter | Chart_View3D Summary


RadialGauge Parameter

Remarks

A RadialGauge is a circular gauge that includes a circular scale. or indicators are used to display values for a RadialGauge scale. RadialScales may include multiple scales and multiple indicators per scale object. Below is an example of a RadialGauge:


RadialGauge Class Members

Radial Parameters

Parameters

Description

Anchor | Allows you to specify the general location of the gauge with respect to your desktop.
Antialiasing | Sets the smooth visual effect for a gauge.
Border | Allows you to determine the border settings for a radial gauge.
Caption | Modifies the caption used in the PowerGadget window
Configure | Allows you to use a graphical Wizard to customize the gauge.
Culture | Allows you to localize gauges for a specific language and region.
Floating | Allows you to launch a gauge without a window frame.
Font | Sets the font type which will be used by default in the gauge.
Glass | Allows you to configure the gauge background to be painted using Glass form.
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Images | Allows you to accesss the images for a gauge.
InnerGauges | The collection of InnerGauges currently associated with the gauge.
MainIndicator | Sets the main Indicator. The available indicators for a are the and the . As for the , the and the are the two possible types of indicators.
MainScale | Returns the main scale of a radial gauge.
MainValue | Sets the main value for a gauge. It is a shortcut to the value of the .
Modal | Allows you to block the command pipe while displaying a gauge.
Output | Allows you to generate a gauge file instead of an interactive one.
Palette | Allows you to set a PowerGadgets pre-defined palette.
Refresh | Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.
Scales | Returns the RadialScaleCollection for the RadialGauge object.
Shadow | Sets a value indicating to whether to display a shadow in a gauge.
Size | Allows you to specify the actual dimension of the final rendered gauge.
Style | Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.
Template | Allows you to use or save gauge modifications into a template file.
Titles | Returns the collection of titles defined in the gauge.
ToolTip | Sets the tool tip text.
ToolTipEnabled | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.
Value | Allows you to specify which property to plot in the gauge.


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the gauge with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the Anchor parameter to TopRight:

out-gauge -Anchor TopRight

See Also

Radial Parameter | Radial Summary


Antialiasing property of BaseGauge Parameter

Antialiasing Parameter

Sets the smooth visual effect for a gauge.

Default Value
The default is All.

Value | Meaning
None | No smoothing applied.
Text | Smoothing applied to text objects only.
Graphic | Smoothing applied to graphic objects only.
All | Smoothing applied to all gauge elements.

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Example

To set the Antialiasing property for a gauge to None:

out-gauge -Antialiasing None

See Also

Radial Parameter | Radial Summary


Border property of RadialGauge Parameter

Border Parameter

Allows you to determine the border settings for a radial gauge.

Remarks

  • The RadialBorder is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges.

Example

To set the Border Style to a rectangular border:

out-gauge -Border_Style RectangularBorder04

See Also

Radial Parameter | Radial Summary


RadialBorder Class Members

Radial_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Glare | Sets a value indicating whether to use a lighting effect for a border.
InsideColor | Sets the inside color for a gauge border.
InsideEffects | Enables or disables border shadow and gradient.
Style | Sets the style for a RadialBorder object.
Visible | Sets a value indicating whether an object is visible or not.


Border_Color property of BaseColorable Parameter

Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border Color

out-gauge -Border_Color Blue

See Also

Radial_Border Parameter | Radial_Border Summary


Border_Glare property of Border Parameter

Border_Glare Parameter

Sets a value indicating whether to use a lighting effect for a border.

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

Example

To turn on the Border Glare effect for a gauge:

out-gauge -Border_Glare false

See Also

Radial_Border Parameter | Radial_Border Summary


Border_InsideColor property of Border Parameter

Border_InsideColor Parameter

Sets the inside color for a gauge border.

Remarks

  • This property is used to configure the inner color value for a Border object.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border InsideColor

out-gauge -Border_InsideColor Red

See Also

Radial_Border Parameter | Radial_Border Summary


Border_InsideEffects property of Border Parameter

Border_InsideEffects Parameter

Enables or disables border shadow and gradient.

Remarks

  • A natural gradient is applied when there is no specific background image.

Example

To Disable the Border InsideEffects:

out-gauge -Border_InsideEffects false

See Also

Radial_Border Parameter | Radial_Border Summary


Border_Style property of RadialBorder Parameter

Border_Style Parameter

Sets the style for a RadialBorder object.

Value | Meaning
CircularBorder01 | Set the border style to CircularBorder01.
CircularBorder02 | Set the border style to CircularBorder02.
CircularBorder03 | Set the border style to CircularBorder03.
CircularBorder04 | Set the border style to CircularBorder04.
CircularBorder05 | Set the border style to CircularBorder05.
CircularBorder06 | Set the border style to CircularBorder06.
CircularBorder07 | Set the border style to CircularBorder07.
CircularBorder08 | Set the border style to CircularBorder08.
CircularBorder09 | Set the border style to CircularBorder09.
CircularBorder10 | Set the border style to CircularBorder10.
CircularBorder11 | Set the border style to CircularBorder11.
CircularBorder12 | Set the border style to CircularBorder12.
CircularBorder13 | Set the border style to CircularBorder13.
CircularBorder14 | Set the border style to CircularBorder14.
CircularBorder15 | Set the border style to CircularBorder15.
CircularBorder16 | Set the border style to CircularBorder16.
CircularBorder17 | Set the border style to CircularBorder17.
CircularBorder18 | Set the border style to CircularBorder18.
CircularBorder19 | Set the border style to CircularBorder19.
SemiCircularBorder01 | Set the border style to SemiCircularBorder01.
SemiCircularBorder02 | Set the border style to SemiCircularBorder02.
SemiCircularBorder03 | Set the border style to SemiCircularBorder03.
SemiCircularBorder04 | Set the border style to SemiCircularBorder04.
SemiCircularBorder05 | Set the border style to SemiCircularBorder05.
SemiCircularBorder06 | Set the border style to SemiCircularBorder06.
SemiCircularBorder07 | Set the border style to SemiCircularBorder07.
RectangularBorder01 | Set the border style to RectangularBorder01.
RectangularBorder02 | Set the border style to RectangularBorder02.
RectangularBorder03 | Set the border style to RectangularBorder03.
RectangularBorder04 | Set the border style to RectangularBorder04.

Remarks

  • The RadialBorder is the outer ring encasing a radial gauge. There are a myriad of different frame designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported RadialBorderStyle types.

Example

To set the Border Style:

out-gauge -Border_Style SemiCircularBorder01

See Also

Radial_Border Parameter | Radial_Border Summary


Border_Visible property of BaseViewable Parameter

Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Border Visible to false:

out-gauge -Border_Visible false

See Also

Radial_Border Parameter | Radial_Border Summary


Caption property of BaseGauge Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the Caption in the PowerGadget window:

out-gauge -Caption "My PowerGadget"

See Also

Radial Parameter | Radial Summary


Configure property of BaseGauge Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the gauge.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

  • This Wizard has two tabs, one called gauge Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the gauge Wizard tab.

Example

To use a graphical wizard to Configure the gauge:

out-gauge -Configure

See Also

Radial Parameter | Radial Summary


Culture property of BaseGauge Parameter

Culture Parameter

Allows you to localize gauges for a specific language and region.

Remarks

  • Culture attributes set with this property will effect the entire gauge, if no attributes are set using this property then PowerGadgets inherits the current Thread culture.

Example

To set the Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Culture "es-ES"

See Also

Radial Parameter | Radial Summary


DrillDown Class Members

Radial_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-gauge.

Example

To use the DrillDown_Script parameter:

ps | out-gauge -DrillDown_Script ProcessDetails.ps1 -DrillDown_Parameter {$_.Id}

See Also

Radial_DrillDown Parameter | Radial_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

  • In most cases this parameter is not necessary when implementing drilldown with gauges.

Example

To use the DrillDown_Parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName}

See Also

Radial_DrillDown Parameter | Radial_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName} -DrillDown_Script get-process -DrillDown_Console

See Also

Radial_DrillDown Parameter | Radial_DrillDown Summary


Floating property of BaseGauge Parameter

Floating Parameter

Allows you to launch a gauge without a window frame.

Remarks

  • Use Floating to launch a gauge without a window frame making the gauge appear as it were floating over the desktop.

Example

To launch a gauge without a window frame configuring the Floating parameter:

out-gauge -Floating

See Also

Radial Parameter | Radial Summary


Font property of BaseGauge Parameter

Font Parameter

Sets the font type which will be used by default in the gauge.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To configure the Font

out-gauge -Font "Arial, 5"

See Also

Radial Parameter | Radial Summary


Glass property of gauge Parameter

Glass Parameter

Allows you to configure the gauge background to b painted using Glass form.

Remarks

  • When running in Windows Vista, the chart background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-gauge -Glass

See Also

Radial Parameter | Radial Summary


HideFromAltTab property of BaseGauge Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-gauge -HideFromAltTab

See Also

Radial Parameter | Radial Summary


Images_<index> property of BaseGauge Parameter

Images_<index> Parameter

Allows you to accesss the images for a gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • You'll have to add an image item ("Bitmap" or "Vector") in order to configure a particular Image:

    -Images_Add Bitmap or -Images_Add Vector.

  • This parameter allows you to configure a particular image. You may also specifying an index value to access a specific image item in Gauge.

Example

To add and configure a Images angle:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 10

See Also

Radial Parameter | Radial Summary


BitmapImage Class Members

Radial_Images Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Image | Represents the actual Image object in the gauge.
Layout | Allows you to access the layout object for an Annotation.
Size | A numeric size modifier applied in conjunction with a Custom setting.
SizeMode | Defines the display size options for the background image.
Visible | Sets a value indicating whether an object is visible or not.


Images_<index>_Angle property of Annotation Parameter

Images_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Images Angle to 45 degrees:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 45

See Also

Radial_Images Parameter | Radial_Images Summary


Images_<index>_Image property of BitmapImage Parameter

Images_<index>_Image Parameter

Represents the actual Image object in the gauge.

Remarks

  • Images that are larger than the gauge are not automatically scaled.

  • Use the Image parameter to configure the image path.

Example

Here is an example of setting the Images Image

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png"

See Also

Radial_Images Parameter | Radial_Images Summary


Images_<index>_Layout property of Annotation Parameter

Images_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_Images Parameter | Radial_Images Summary


LayoutAttributes Class Members

Radial_Images_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Images_<index>_Layout_Alignment property of LayoutAttributes Parameter

Images_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Images Layout Alignment to the MiddleCenter:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Alignment MiddleCenter

See Also

Radial_Images_Layout Parameter | Radial_Images_Layout Summary


Images_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Images_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Images Layout AnchorPoint to a specific position:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Target AnchorPoint -Images_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_Images_Layout Parameter | Radial_Images_Layout Summary


Images_<index>_Layout_Target property of LayoutAttributes Parameter

Images_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_Images_Layout Parameter | Radial_Images_Layout Summary


Images_<index>_Size property of BaseImage Parameter

Images_<index>_Size Parameter

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Example

To set the Images Size:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Custom -Images_0_Size 1.2

See Also

Radial_Images Parameter | Radial_Images Summary


Images_<index>_SizeMode property of BaseImage Parameter

Images_<index>_SizeMode Parameter

Defines the display size options for the background image.

Default Value
The default is Normal.

Value | Meaning
Normal | The image is placed in the center of the container, in its original size. The image is clipped if it is larger than the container.
Stretch | The image is stretched or shrunk to fit the size of the container.
Custom | The image size will be custom set by the Size property.

Remarks

  • When using the Custom value a size can be specified using the Size property.

Example

To set the Images SizeMode to Stretch:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Stretch

See Also

Radial_Images Parameter | Radial_Images Summary


Images_<index>_Visible property of BaseViewable Parameter

Images_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Images Visible to false:

out-gauge -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Visible false

See Also

Radial_Images Parameter | Radial_Images Summary


InnerGauges_<index> property of BaseGauge Parameter

InnerGauges_<index> Parameter

The collection of InnerGauges currently associated with the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

See Also

Radial Parameter | Radial Summary


InnerDigitalPanel Parameter

Remarks

With the InnerDigitalPanel Parameter, users may embed a inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.

To add an inner Radial gauge to a particular gauge you'll need to write this in the PowerShell prompt: out-gauge -InnerGauges_Add Digital


InnerDigitalPanel Class Members

Radial_InnerGauges_InnerDigitalPanel Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
DigitalPanel | Returns the DigitalPanel object for an inner digital meter.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_Angle 45

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_DigitalPanel property of InnerDigitalPanel Parameter

InnerGauges_<index>_DigitalPanel Parameter

Returns the DigitalPanel object for an inner digital meter.

Remarks

  • This property is used to return the DigitalPanel object for an inner digital Panel. For additional information regarding supported members, please see the Parameter.

Example

To configure the InnerGauges DigitalPanel Font:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_DigitalPanel_Font "Arial, 5"

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


LayoutAttributes Class Members

Radial_InnerGauges_InnerDigitalPanel_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Radial_InnerGauges_InnerDigitalPanel_Layout Parameter | Radial_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_InnerGauges_InnerDigitalPanel_Layout Parameter | Radial_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_InnerGauges_InnerDigitalPanel_Layout Parameter | Radial_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_LinkToMainValue true

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_Size "0.3, 0.5"

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -InnerGauges_Add Digital -InnerGauges_0_Visible false

See Also

Radial_InnerGauges_InnerDigitalPanel Parameter | Radial_InnerGauges_InnerDigitalPanel Summary


InnerHorizontalGauge Parameter

Remarks

With the InnerHorizontalGauge Parameter, users may embed a inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.

To add an inner Horizontal gauge to a particular gauge you'll need to write this in the PowerShell prompt: out-gauge -InnerGauges_Add Horizontal


InnerHorizontalGauge Class Members

Radial_InnerGauges_InnerHorizontalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
HorizontalGauge | Exposes the HorizontalGauge properties of the InnerGauge.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_Angle 45

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_HorizontalGauge property of InnerHorizontalGauge Parameter

InnerGauges_<index>_HorizontalGauge Parameter

Exposes the HorizontalGauge properties of the InnerGauge.

Remarks

  • This property is used to return the HorizontalGauge object for an inner horizontal gauge. For additional information regarding supported members, please see the Parameter.

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


LayoutAttributes Class Members

Radial_InnerGauges_InnerHorizontalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Radial_InnerGauges_InnerHorizontalGauge_Layout Parameter | Radial_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_InnerGauges_InnerHorizontalGauge_Layout Parameter | Radial_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_InnerGauges_InnerHorizontalGauge_Layout Parameter | Radial_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_LinkToMainValue true

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_Size "0.3, 0.5"

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -InnerGauges_Add Horizontal -InnerGauges_0_Visible false

See Also

Radial_InnerGauges_InnerHorizontalGauge Parameter | Radial_InnerGauges_InnerHorizontalGauge Summary


InnerRadialGauge Parameter

Remarks

With the InnerRadialGauge Parameter, users may embed a inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.

To add an inner Radial gauge to a particular gauge you'll need to write this in the PowerShell prompt: out-gauge -InnerGauges_Add Radial


InnerRadialGauge Class Members

Radial_InnerGauges_InnerRadialGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
RadialGauge | Returns the RadialGauge object for an inner radial gauge.
Size | Sets the InnerGauge size
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_Angle 45

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


LayoutAttributes Class Members

Radial_InnerGauges_InnerRadialGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Radial_InnerGauges_InnerRadialGauge_Layout Parameter | Radial_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_InnerGauges_InnerRadialGauge_Layout Parameter | Radial_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_InnerGauges_InnerRadialGauge_Layout Parameter | Radial_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_LinkToMainValue true

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_RadialGauge property of InnerRadialGauge Parameter

InnerGauges_<index>_RadialGauge Parameter

Returns the RadialGauge object for an inner radial gauge.

Remarks

  • This property is used to return the RadialGauge object for an inner radial gauge. For additional information regarding supported members, please see the Parameter.

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Size property of InnerRadialGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the InnerGauge size

Remarks

  • The InnerGauge is scaled based on the value provided in this property. A value of 2.0 or greater will scale the InnerGauge larger than the Main Gauge.

Example

To set the InnerGauges Size value for a Inner Radial Gauge:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_Size 0.4

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -InnerGauges_Add Radial -InnerGauges_0_Visible false

See Also

Radial_InnerGauges_InnerRadialGauge Parameter | Radial_InnerGauges_InnerRadialGauge Summary


InnerVerticalGauge Parameter

Remarks

With the InnerVerticalGauge Parameter, users may embed a inside another gauge object. Inner gauges are not required to be the same type as the parent gauge.

To add an inner Vertical gauge to a particular gauge you'll need to write this in the PowerShell prompt: out-gauge -InnerGauges_Add Vertical


InnerVerticalGauge Class Members

Radial_InnerGauges_InnerVerticalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
VerticalGauge | Returns the LinearGauge object for an inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_Angle 45

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


LayoutAttributes Class Members

Radial_InnerGauges_InnerVerticalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Radial_InnerGauges_InnerVerticalGauge_Layout Parameter | Radial_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_InnerGauges_InnerVerticalGauge_Layout Parameter | Radial_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_InnerGauges_InnerVerticalGauge_Layout Parameter | Radial_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_LinkToMainValue true

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_Size "0.3, 0.5"

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_VerticalGauge property of InnerVerticalGauge Parameter

InnerGauges_<index>_VerticalGauge Parameter

Returns the LinearGauge object for an inner linear gauge.

Remarks

  • This property is used to return the LinearGauge object for an inner linear gauge. For additional information regarding supported members, please see the Parameter.

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -InnerGauges_Add Vertical -InnerGauges_0_Visible false

See Also

Radial_InnerGauges_InnerVerticalGauge Parameter | Radial_InnerGauges_InnerVerticalGauge Summary


Location property of gauge Parameter

Location Parameter

Allows you to configure the gauge's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a Location for the gauge:

out-gauge -Location 10,10

See Also

Radial Parameter | Radial Summary


MainIndicator property of Gauge Parameter

MainIndicator Parameter

Sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.

Remarks

  • A gauge may have many indicators, however only one MainIndicator.

  • The MainValue property is used to obtain the value of the MainIndicator.

Example

To set the MainIndicator Vale to 35:

out-gauge -MainIndicator_Value 35

See Also

Radial Parameter | Radial Summary


Marker Parameter

Remarks

The supported members of the Marker class may be used to configure Labels, Text, Size, Position and Style.


Marker Class Members

Radial_MainIndicator_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -MainIndicator Marker -MainIndicator_AnimationSpan 0:0:2

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -MainIndicator Marker -MainIndicator_Color Blue

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


ValueFormat Class Members

Radial_MainIndicator_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Marker -MainIndicator_Format_Culture "es-ES"

See Also

Radial_MainIndicator_Marker_Format Parameter | Radial_MainIndicator_Marker_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Radial_MainIndicator_Marker_Format Parameter | Radial_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainIndicator_Marker_Format Parameter | Radial_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -MainIndicator Marker -MainIndicator_Format_FormatType Percentage

See Also

Radial_MainIndicator_Marker_Format Parameter | Radial_MainIndicator_Marker_Format Summary


MainIndicator_Label property of Marker Parameter

MainIndicator_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainIndicator Label Color:

out-gauge -MainIndicator Marker -MainIndicator_Label_Color Red

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


LabelAttributes Class Members

Radial_MainIndicator_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_Label_Color property of BaseColorable Parameter

MainIndicator_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Label Color

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Color Blue

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Label_Font property of LabelAttributes Parameter

MainIndicator_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainIndicator Label Font to Arial 5:

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Font "Arial, 5"

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Label_Orientation property of LabelAttributes Parameter

MainIndicator_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainIndicator Label Orientation to Tangent

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Orientation Tangent

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Label_Position property of LabelAttributes Parameter

MainIndicator_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label Position to Bottom:

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Position Bottom

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Label_PositionCustom property of LabelAttributes Parameter

MainIndicator_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label PositionCustom to 5:

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Custom -MainIndicator_Label_PositionCustom 5

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Label_Visible property of BaseViewable Parameter

MainIndicator_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Label Visible to false:

out-gauge -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Visible false

See Also

Radial_MainIndicator_Marker_Label Parameter | Radial_MainIndicator_Marker_Label Summary


MainIndicator_Position property of Marker Parameter

MainIndicator_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainIndicator Position to Bottom:

out-gauge -MainIndicator Marker -MainIndicator_Position Bottom

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_PositionCustom property of Marker Parameter

MainIndicator_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator PositionCustom:

out-gauge -MainIndicator Marker -MainIndicator_Position Custom -MainIndicator_PositionCustom 0.05

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Size property of Marker Parameter

MainIndicator_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainIndicator Size to 5:

out-gauge -MainIndicator Marker -MainIndicator_Size 5

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -MainIndicator Marker -MainIndicator_Snap 5

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Style property of Marker Parameter

MainIndicator_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator Style to Marker02;

out-gauge -MainIndicator Marker -MainIndicator_Style Marker02

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Text property of Marker Parameter

MainIndicator_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainIndicator Text:

out-gauge -MainIndicator Marker -MainIndicator_Text "My Value"

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -MainIndicator Marker -MainIndicator_Value 25

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Marker -MainIndicator_VerticalPosition BehindTickmarks

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -MainIndicator Marker -MainIndicator_Visible false

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


Needle Parameter

Remarks

The supported members of the Needle class may be used to configure the Size and Style for needles.


Needle Class Members

Radial_MainIndicator_Needle Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Size | Sets a value to control the size of a needle.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a radial indicator needle.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -MainIndicator Needle -MainIndicator_AnimationSpan 0:0:2

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -MainIndicator Needle -MainIndicator_Color Blue

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -MainIndicator Needle -MainIndicator_Format_Decimals 3

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


ValueFormat Class Members

Radial_MainIndicator_Needle_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Needle -MainIndicator_Format_Culture "es-ES"

See Also

Radial_MainIndicator_Needle_Format Parameter | Radial_MainIndicator_Needle_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -MainIndicator Needle -MainIndicator_Format_Decimals 3

See Also

Radial_MainIndicator_Needle_Format Parameter | Radial_MainIndicator_Needle_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainIndicator_Needle_Format Parameter | Radial_MainIndicator_Needle_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -MainIndicator Needle -MainIndicator_Format_FormatType Percentage

See Also

Radial_MainIndicator_Needle_Format Parameter | Radial_MainIndicator_Needle_Format Summary


MainIndicator_Size property of Needle Parameter

MainIndicator_Size Parameter

Sets a value to control the size of a needle.

Remarks

  • When set to zero, the needle is not visible in a radial gauge. This is a ratio property, therefore the overall size of a radial gauge is also a factor when rendering the needle.

Example

To set the MainIndicator Size to 1:

out-gauge -MainIndicator Needle -MainIndicator_Size 1

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -MainIndicator Needle -MainIndicator_Snap 5

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Style property of Needle Parameter

MainIndicator_Style Parameter

Sets the style for a radial indicator needle.

Value | Meaning
Needle01 | Set the needle style to Needle01.
Needle02 | Set the needle style to Needle02.
Needle03 | Set the needle style to Needle03.
Needle04 | Set the needle style to Needle04.
Needle05 | Set the needle style to Needle05.
Needle06 | Set the needle style to Needle06.
Needle07 | Set the needle style to Needle07.
Needle08 | Set the needle style to Needle08.
Needle09 | Set the needle style to Needle09.
Needle10 | Set the needle style to Needle10.
Needle11 | Set the needle style to Needle11.
Needle12 | Set the needle style to Needle12.
Needle13 | Set the needle style to Needle13.
Needle14 | Set the needle style to Needle14.
Needle15 | Set the needle style to Needle15.
Needle16 | Set the needle style to Needle16.
Needle17 | Set the needle style to Needle17.
Needle18 | Set the needle style to Needle18.
Needle19 | Set the needle style to Needle19.
Needle20 | Set the needle style to Needle20.

Remarks

  • A needle is an indicator in a radial gauge which marks a value. There are several different needle designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported NeedleStyle enumeration types.

Example

To set the MainIndicator Style to Needle5:

out-gauge -MainIndicator Needle -MainIndicator_Style Needle05

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -MainIndicator Needle -MainIndicator_Value 25

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Needle -MainIndicator_VerticalPosition BehindTickmarks

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -MainIndicator Needle -MainIndicator_Visible false

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainScale property of RadialGauge Parameter

MainScale Parameter

Returns the main scale of a radial gauge.

Remarks

  • A scale for a radial gauge is the range of values which a gauge can indicate a value. Indicators mark values in a given scale.

Example

To set the MainScale Color to Red:

out-gauge -MainScale_Color Red

See Also

Radial Parameter | Radial Summary


RadialScale Class Members

Radial_MainScale Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Cap | Returns the RadialCap object for a selected RadialScale.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
Indicators | The collection of Indicators currently associated with the scale.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Pivot | Sets the position of the scale within the gauge.
Radius | Sets the radius for a RadialScale object.
Sections | Returns the SectionCollection for a scale object.
StartAngle | Sets the starting angle in degrees for a RadialScale.
Stripes | The collection of Stripes currently associated with the scale.
SweepAngle | Sets the starting angle in degrees for a RadialScale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar property of Scale Parameter

MainScale_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the MainScale Bar Color to Red:

out-gauge -MainScale_Bar_Color Red

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


ScaleBar Class Members

Radial_MainScale_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border property of ScaleBar Parameter

MainScale_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -MainScale_Bar_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Radial_MainScale_Bar Parameter | Radial_MainScale_Bar Summary


BarBorder Class Members

Radial_MainScale_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border_Color property of BaseColorable Parameter

MainScale_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Bar Border Color

out-gauge -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Color Blue

See Also

Radial_MainScale_Bar_Border Parameter | Radial_MainScale_Bar_Border Summary


MainScale_Bar_Border_Thickness property of BarBorder Parameter

MainScale_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Radial_MainScale_Bar_Border Parameter | Radial_MainScale_Bar_Border Summary


MainScale_Bar_Border_Visible property of BaseViewable Parameter

MainScale_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Border Visible to false:

out-gauge -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Visible false

See Also

Radial_MainScale_Bar_Border Parameter | Radial_MainScale_Bar_Border Summary


MainScale_Bar_Color property of BaseSectionBar Parameter

MainScale_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Radial_MainScale_Bar Parameter | Radial_MainScale_Bar Summary


MainScale_Bar_Visible property of BaseViewable Parameter

MainScale_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Visible to false:

out-gauge -MainScale_Bar_Visible true -MainScale_Bar_Visible false

See Also

Radial_MainScale_Bar Parameter | Radial_MainScale_Bar Summary


MainScale_Cap property of RadialScale Parameter

MainScale_Cap Parameter

Returns the RadialCap object for a selected RadialScale.

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

Example

To set the MainScale Cap Style to RadialCap2:

out-gauge -MainScale_Cap_Style RotatingCap02

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


RadialCap Class Members

Radial_MainScale_Cap Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Size | Sets a value to control the size of a RadialCap.
Style | Sets the styles for a RadialCap.
VerticalPosition | Sets the positioning of the Radial Cap to behind or above the Indicator(s).
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Cap_Color property of BaseColorable Parameter

MainScale_Cap_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Cap Color

out-gauge -MainScale_Cap_Color Blue

See Also

Radial_MainScale_Cap Parameter | Radial_MainScale_Cap Summary


MainScale_Cap_Size property of RadialCap Parameter

MainScale_Cap_Size Parameter

Sets a value to control the size of a RadialCap.

Example

To set the MainScale Cap Size:

out-gauge -MainScale_Cap_Size 0.2

See Also

Radial_MainScale_Cap Parameter | Radial_MainScale_Cap Summary


MainScale_Cap_Style property of RadialCap Parameter

MainScale_Cap_Style Parameter

Sets the styles for a RadialCap.

Value | Meaning
Cap01 | Set the cap style to Cap01.
Cap02 | Set the cap style to Cap02.
Cap03 | Set the cap style to Cap03.
Cap04 | Set the cap style to Cap04.
Cap05 | Set the cap style to Cap05.
Cap06 | Set the cap style to Cap06.
Cap07 | Set the cap style to Cap07.
Cap08 | Set the cap style to Cap08.
Cap09 | Set the cap style to Cap09.
Cap10 | Set the cap style to Cap10.
Cap11 | Set the cap style to Cap11.
Cap12 | Set the cap style to Cap12.
Cap13 | Set the cap style to Cap13.
Cap14 | Set the cap style to Cap14.
Cap15 | Set the cap style to Cap15.
Cap16 | Set the cap style to Cap16.
Cap17 | Set the cap style to Cap17.
Cap18 | Set the cap style to Cap18.
RotatingCap01 | Set the cap style to RotatingCap01.
RotatingCap02 | Set the cap style to RotatingCap02.
RotatingCap03 | Set the cap style to RotatingCap03.

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

Example

To set the MainScale Cap Style:

out-gauge -MainScale_Cap_Style Cap02

See Also

Radial_MainScale_Cap Parameter | Radial_MainScale_Cap Summary


MainScale_Cap_VerticalPosition property of RadialCap Parameter

MainScale_Cap_VerticalPosition Parameter

Sets the positioning of the Radial Cap to behind or above the Indicator(s).

Default Value
The default is AboveNeedles.

Value | Meaning
AboveNeedles | Positions the Cap on top of the Needle.
BehindNeedles | Positions the Cap inder the Needle.

Remarks

  • This is merely an aesthetic feature, but will change the order of the .

Example

Set the Radial Cap position to behind the Indicator needle.

out-gauge -MainScale_Cap_VerticalPosition BehindNeedles

See Also

Radial_MainScale_Cap Parameter | Radial_MainScale_Cap Summary


MainScale_Cap_Visible property of BaseViewable Parameter

MainScale_Cap_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Cap Visible to false:

out-gauge -MainScale_Cap_Visible false

See Also

Radial_MainScale_Cap Parameter | Radial_MainScale_Cap Summary


MainScale_Color property of BaseColorable Parameter

MainScale_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Color

out-gauge -MainScale_Color Blue

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_CustomLabels property of Scale Parameter

MainScale_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the MainScale CustomLabels for the value '40':

out-gauge -MainScale_CustomLabels_40 "Label at 40"

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Indicators_<index> property of Scale Parameter

MainScale_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the MainScale Indicators Color to AliceBlue:

out-gauge -MainScale_Indicators_0_Color AliceBlue

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


Marker Class Members

Radial_MainScale_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Color Blue

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


ValueFormat Class Members

Radial_MainScale_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Radial_MainScale_Indicators_Marker_Format Parameter | Radial_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Radial_MainScale_Indicators_Marker_Format Parameter | Radial_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainScale_Indicators_Marker_Format Parameter | Radial_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Radial_MainScale_Indicators_Marker_Format Parameter | Radial_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Label property of Marker Parameter

MainScale_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainScale Indicators Label Color:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Color Red

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


LabelAttributes Class Members

Radial_MainScale_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_Label_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Label Color

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Color Blue

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Font property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Indicators Label Font to Arial 5:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Font "Arial, 5"

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Indicators Label Orientation to Tangent

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Orientation Tangent

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Position property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label Position to Bottom:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Position Bottom

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label PositionCustom to 5:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Custom -MainScale_Indicators_0_Label_PositionCustom 5

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Label Visible to false:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Visible false

See Also

Radial_MainScale_Indicators_Marker_Label Parameter | Radial_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Position property of Marker Parameter

MainScale_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Indicators Position to Bottom:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Position Bottom

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_PositionCustom property of Marker Parameter

MainScale_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators PositionCustom:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Position Custom -MainScale_Indicators_0_PositionCustom 0.05

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Size property of Marker Parameter

MainScale_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainScale Indicators Size to 5:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Size 5

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Snap 5

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Style property of Marker Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators Style to Marker02;

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Style Marker02

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Text property of Marker Parameter

MainScale_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainScale Indicators Text:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Text "My Value"

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Value 25

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Visible false

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


Needle Class Members

Radial_MainScale_Indicators_Needle Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Size | Sets a value to control the size of a needle.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a radial indicator needle.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Color Blue

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Format_Decimals 3

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


ValueFormat Class Members

Radial_MainScale_Indicators_Needle_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Radial_MainScale_Indicators_Needle_Format Parameter | Radial_MainScale_Indicators_Needle_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Format_Decimals 3

See Also

Radial_MainScale_Indicators_Needle_Format Parameter | Radial_MainScale_Indicators_Needle_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainScale_Indicators_Needle_Format Parameter | Radial_MainScale_Indicators_Needle_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Radial_MainScale_Indicators_Needle_Format Parameter | Radial_MainScale_Indicators_Needle_Format Summary


MainScale_Indicators_<index>_Size property of Needle Parameter

MainScale_Indicators_<index>_Size Parameter

Sets a value to control the size of a needle.

Remarks

  • When set to zero, the needle is not visible in a radial gauge. This is a ratio property, therefore the overall size of a radial gauge is also a factor when rendering the needle.

Example

To set the MainScale Indicators Size to 1:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Size 1

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Snap 5

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Style property of Needle Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a radial indicator needle.

Value | Meaning
Needle01 | Set the needle style to Needle01.
Needle02 | Set the needle style to Needle02.
Needle03 | Set the needle style to Needle03.
Needle04 | Set the needle style to Needle04.
Needle05 | Set the needle style to Needle05.
Needle06 | Set the needle style to Needle06.
Needle07 | Set the needle style to Needle07.
Needle08 | Set the needle style to Needle08.
Needle09 | Set the needle style to Needle09.
Needle10 | Set the needle style to Needle10.
Needle11 | Set the needle style to Needle11.
Needle12 | Set the needle style to Needle12.
Needle13 | Set the needle style to Needle13.
Needle14 | Set the needle style to Needle14.
Needle15 | Set the needle style to Needle15.
Needle16 | Set the needle style to Needle16.
Needle17 | Set the needle style to Needle17.
Needle18 | Set the needle style to Needle18.
Needle19 | Set the needle style to Needle19.
Needle20 | Set the needle style to Needle20.

Remarks

  • A needle is an indicator in a radial gauge which marks a value. There are several different needle designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported NeedleStyle enumeration types.

Example

To set the MainScale Indicators Style to Needle5:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Style Needle05

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Value 25

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Visible false

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Max property of Range Parameter

MainScale_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Max to 50:

out-gauge -MainScale_Max 50

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale MaxAlwaysDisplayed to false:

out-gauge -MainScale_MaxAlwaysDisplayed false

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Min property of Range Parameter

MainScale_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Min to 10:

out-gauge -MainScale_Min 10

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale MinAlwaysDisplayed to false:

out-gauge -MainScale_MinAlwaysDisplayed false

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Pivot property of RadialScale Parameter

MainScale_Pivot Parameter

Sets the position of the scale within the gauge.

Remarks

  • The coordinate system for positioning the scale mirrors a Unit Circle. The center point is (0,0). The top-center point is (0,1) and the bottom-center point is (0,-1). The left-center point is (-1,0) and the right-center point is (1,0).

Example

To set the MainScale Pivot:

out-gauge -MainScale_Pivot "0.01, 0.08"

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Radius property of RadialScale Parameter

MainScale_Radius Parameter

Sets the radius for a RadialScale object.

Remarks

  • This property is used to control the size of a RadialScale object.

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for Radial Scales, multiple Radia lScale objects may be displayed in a single radial gauge object.

Example

To set the MainScale Radius to 5:

out-gauge -MainScale_Radius 0.5

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Sections_<index> property of Scale Parameter

MainScale_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the MainScale Sections Color to Red:

out-gauge -MainScale_Sections_0_Color Red

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


Section Class Members

Radial_MainScale_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar property of Section Parameter

MainScale_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the MainScale Sections Bar Color to Red:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Color Red

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


SectionBar Class Members

Radial_MainScale_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

MainScale_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Radial_MainScale_Sections_Bar Parameter | Radial_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Bar_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Bar Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Visible true -MainScale_Sections_0_Bar_Visible false

See Also

Radial_MainScale_Sections_Bar Parameter | Radial_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Color Blue

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_Sections_<index>_Max property of Range Parameter

MainScale_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Sections Max to 50:

out-gauge -MainScale_Sections_0_Max 50

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MaxAlwaysDisplayed to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MaxAlwaysDisplayed false

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_Sections_<index>_Min property of Range Parameter

MainScale_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Sections Min to 10:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Min 10

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MinAlwaysDisplayed to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MinAlwaysDisplayed false

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_Sections_<index>_Tickmarks property of BaseSection Parameter

MainScale_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


TickmarkSet Class Members

Radial_MainScale_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


ValueFormat Class Members

Radial_MainScale_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_MainScale_Sections_Tickmarks_Format Parameter | Radial_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Sections Tickmarks Format Decimals to 3:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Decimals 3

See Also

Radial_MainScale_Sections_Tickmarks_Format Parameter | Radial_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainScale_Sections_Tickmarks_Format Parameter | Radial_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Sections Tickmarks Format FormatType to Percentage

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Radial_MainScale_Sections_Tickmarks_Format Parameter | Radial_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Sections Tickmarks Major size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 5

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Major Label Color to Red:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Radial_MainScale_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Major Label Font to Arial 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Major Label Orientation to Tangent

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Custom -MainScale_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Major_Label Parameter | Radial_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major PositionCustom to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 2.5

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Step to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Step 5

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Major Style:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Major Parameter | Radial_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Sections Tickmarks Medium size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 5

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Label Color to Red:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Custom -MainScale_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Medium_Label Parameter | Radial_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium PositionCustom to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Step to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Step 5

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Style:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Medium Parameter | Radial_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Sections Tickmarks Minor size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 5

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Label Color to Red:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Color

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Custom -MainScale_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Minor_Label Parameter | Radial_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Position to Bottom:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor PositionCustom to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Size to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Step to 5:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Step 5

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Style:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Visible false

See Also

Radial_MainScale_Sections_Tickmarks_Minor Parameter | Radial_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Visible false

See Also

Radial_MainScale_Sections_Tickmarks Parameter | Radial_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Visible to false:

out-gauge -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Visible false

See Also

Radial_MainScale_Sections Parameter | Radial_MainScale_Sections Summary


MainScale_StartAngle property of RadialScale Parameter

MainScale_StartAngle Parameter

Sets the starting angle in degrees for a RadialScale.

Remarks

  • This property supports a configuration value between 0 and 360.

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The SweepAngle property is used to get or set the angle at the ending value for a scale.

Example

To set the MainScale StartAngle to 275:

out-gauge -MainScale_StartAngle 275

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Stripes_<index> property of RadialScale Parameter

MainScale_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the MainScale Stripes Max to 30:

out-gauge -MainScale_Stripes_0_Max 30

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


RadialStrip Class Members

Radial_MainScale_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Radius | Sets the radius for a RadialStrip object.
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_AlternateColor property of Strip Parameter

MainScale_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the MainScale Stripes AlternateColor to Yellow:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Gradient -MainScale_Stripes_0_AlternateColor Yellow

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Border property of Strip Parameter

MainScale_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the MainScale Stripes Border Color to red:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Red

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


BarBorder Class Members

Radial_MainScale_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_Border_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Border Color

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Blue

See Also

Radial_MainScale_Stripes_Border Parameter | Radial_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Thickness property of BarBorder Parameter

MainScale_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Stripes Border Thickness to 0.003:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Thickness 0.003

See Also

Radial_MainScale_Stripes_Border Parameter | Radial_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Border Visible to false:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Visible false

See Also

Radial_MainScale_Stripes_Border Parameter | Radial_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Color

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Color Blue

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_FillType property of Strip Parameter

MainScale_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the MainScale Stripes FillType to Gradient:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_AlternateColor Yellow -MainScale_Stripes_0_FillType Gradient

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Max property of Range Parameter

MainScale_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Stripes Max to 50:

out-gauge -MainScale_Stripes_0_Max 50

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Min property of Range Parameter

MainScale_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Stripes Min to 10:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Min 10

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Pattern property of Strip Parameter

MainScale_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the MainScale Stripes Pattern to BackwardDiagonal:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Pattern -MainScale_Stripes_0_Pattern BackwardDiagonal

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Radius property of RadialStrip Parameter

MainScale_Stripes_<index>_Radius Parameter

Sets the radius for a RadialStrip object.

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for Radial Stripe, multiple Radial Strips may be displayed over the same range of the Radial Scale in the gauge.

  • This property is used to control the size of a RadialStrip object.

Example

To set the MainScale Stripes Radius to 1:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Radius 1

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Thickness property of Strip Parameter

MainScale_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the MainScale Stripes Thickness to 0.25:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Thickness 0.25

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

MainScale_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_Stripes_<index>_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Visible to false:

out-gauge -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Visible false

See Also

Radial_MainScale_Stripes Parameter | Radial_MainScale_Stripes Summary


MainScale_SweepAngle property of RadialScale Parameter

MainScale_SweepAngle Parameter

Sets the starting angle in degrees for a RadialScale.

Remarks

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The StartAngle property is used to get or set the ending angle in degrees for a RadialScale.

Example

To set the MainScale SweepAngle to -225:

out-gauge -MainScale_SweepAngle -225

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Thickness property of Scale Parameter

MainScale_Thickness Parameter

Sets the width for a scale.

Example

To set the MainScale Thickness to 0.05:

out-gauge -MainScale_Thickness 0.05

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainScale_Tickmarks property of BaseSection Parameter

MainScale_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


TickmarkSet Class Members

Radial_MainScale_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Color property of BaseColorable Parameter

MainScale_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Color

out-gauge -MainScale_Tickmarks_Color Blue

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


MainScale_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


ValueFormat Class Members

Radial_MainScale_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Radial_MainScale_Tickmarks_Format Parameter | Radial_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Tickmarks Format Decimals to 3:

out-gauge -MainScale_Tickmarks_Format_Decimals 3

See Also

Radial_MainScale_Tickmarks_Format Parameter | Radial_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_MainScale_Tickmarks_Format Parameter | Radial_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Tickmarks Format FormatType to Percentage

out-gauge -MainScale_Tickmarks_Format_FormatType Percentage

See Also

Radial_MainScale_Tickmarks_Format Parameter | Radial_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Tickmarks Major size to 5:

out-gauge -MainScale_Tickmarks_Major_Size 5

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Color

out-gauge -MainScale_Tickmarks_Major_Color Blue

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Major Label Color to Red:

out-gauge -MainScale_Tickmarks_Major_Label_Color Red

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


LabelAttributes Class Members

Radial_MainScale_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Label Color

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Color Blue

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Major Label Font to Arial 5:

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Major Label Orientation to Tangent

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Orientation Tangent

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label Position to Bottom:

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Position Bottom

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label PositionCustom to 5:

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Custom -MainScale_Tickmarks_Major_Label_PositionCustom 5

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Label Visible to false:

out-gauge -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Visible false

See Also

Radial_MainScale_Tickmarks_Major_Label Parameter | Radial_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Position to Bottom:

out-gauge -MainScale_Tickmarks_Major_Position Bottom

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major PositionCustom to false:

out-gauge -MainScale_Tickmarks_Major_Position Custom -MainScale_Tickmarks_Major_PositionCustom 0.2

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Size to 5:

out-gauge -MainScale_Tickmarks_Major_Size 2.5

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Step to 5:

out-gauge -MainScale_Tickmarks_Major_Step 5

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Major Style:

out-gauge -MainScale_Tickmarks_Major_Style Tickmark10_3

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Visible to false:

out-gauge -MainScale_Tickmarks_Major_Visible false

See Also

Radial_MainScale_Tickmarks_Major Parameter | Radial_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Tickmarks Medium size to 5:

out-gauge -MainScale_Tickmarks_Medium_Size 5

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Color

out-gauge -MainScale_Tickmarks_Medium_Color Blue

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Medium Label Color to Red:

out-gauge -MainScale_Tickmarks_Medium_Label_Color Red

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


LabelAttributes Class Members

Radial_MainScale_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Label Color

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Color Blue

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Medium Label Font to Arial 5:

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Medium Label Orientation to Tangent

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Orientation Tangent

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label Position to Bottom:

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Position Bottom

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label PositionCustom to 5:

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Custom -MainScale_Tickmarks_Medium_Label_PositionCustom 5

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Label Visible to false:

out-gauge -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Visible false

See Also

Radial_MainScale_Tickmarks_Medium_Label Parameter | Radial_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Position to Bottom:

out-gauge -MainScale_Tickmarks_Medium_Position Bottom

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium PositionCustom to false:

out-gauge -MainScale_Tickmarks_Medium_Position Custom -MainScale_Tickmarks_Medium_PositionCustom 0.2

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Size to 5:

out-gauge -MainScale_Tickmarks_Medium_Size 2.5

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Step to 5:

out-gauge -MainScale_Tickmarks_Medium_Step 5

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Medium Style:

out-gauge -MainScale_Tickmarks_Medium_Style Tickmark10_3

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Visible to false:

out-gauge -MainScale_Tickmarks_Medium_Visible false

See Also

Radial_MainScale_Tickmarks_Medium Parameter | Radial_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Tickmarks Minor size to 5:

out-gauge -MainScale_Tickmarks_Minor_Size 5

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


Tickmark Class Members

Radial_MainScale_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Color

out-gauge -MainScale_Tickmarks_Minor_Color Blue

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Minor Label Color to Red:

out-gauge -MainScale_Tickmarks_Minor_Label_Color Red

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


LabelAttributes Class Members

Radial_MainScale_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Label Color

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Color Blue

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Minor Label Font to Arial 5:

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Minor Label Orientation to Tangent

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Orientation Tangent

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label Position to Bottom:

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Position Bottom

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label PositionCustom to 5:

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Custom -MainScale_Tickmarks_Minor_Label_PositionCustom 5

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Label Visible to false:

out-gauge -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Visible false

See Also

Radial_MainScale_Tickmarks_Minor_Label Parameter | Radial_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Position to Bottom:

out-gauge -MainScale_Tickmarks_Minor_Position Bottom

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor PositionCustom to false:

out-gauge -MainScale_Tickmarks_Minor_Position Custom -MainScale_Tickmarks_Minor_PositionCustom 0.2

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Size to 5:

out-gauge -MainScale_Tickmarks_Minor_Size 2.5

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Step to 5:

out-gauge -MainScale_Tickmarks_Minor_Step 5

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Minor Style:

out-gauge -MainScale_Tickmarks_Minor_Style Tickmark10_3

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Visible to false:

out-gauge -MainScale_Tickmarks_Minor_Visible false

See Also

Radial_MainScale_Tickmarks_Minor Parameter | Radial_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Visible to false:

out-gauge -MainScale_Tickmarks_Visible false

See Also

Radial_MainScale_Tickmarks Parameter | Radial_MainScale_Tickmarks Summary


MainScale_Visible property of BaseViewable Parameter

MainScale_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Visible to false:

out-gauge -MainScale_Visible false

See Also

Radial_MainScale Parameter | Radial_MainScale Summary


MainValue property of Gauge Parameter

MainValue Parameter

Sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.

Remarks

  • A gauge may display several values, for example a radial gauge may have multiple indicator needles. This property is used to configure the value displayed as the main value of a gauge object.

  • The MainIndicator method is used to obtain access to the main indicator.

Example

To set the MainValue to 7:

out-gauge -MainValue 7

See Also

Radial Parameter | Radial Summary


Modal property of gauge Parameter

Modal Parameter

Allows you to block the command pipe while displaying a gauge.

Remarks

  • Use Modal to block the command pipe while displaying a gauge.

Example

To create a gauge blocking the command pipe by configuinr the Modal parameter:

out-gauge -Modal

See Also

Radial Parameter | Radial Summary


Output property of gauge Parameter

Output Parameter

Allows you to generate a gauge file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a gauge file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate an Output image (.png) of the gauge:

out-gauge -Output test.png

See Also

Radial Parameter | Radial Summary


Palette property of BaseGauge Parameter

Palette Parameter

Allows you to set a Chart FX pre-defined palette.

Value | Meaning
Default | Set the palette to Default.
Alternate | Set the palette to Alternate.
Autumn | Set the palette to an Autumn scheme.
BrownSugar | Set the palette to a BrownSugar scheme.
ChartFX6 | Set the palette to the ChartFX 6 scheme.
Classic | Set the palette to Classic.
Colorful | Set the palette to a Colorful scheme.
DarkPastels | Set the palette to a DarkPastels scheme.
Earthtones | Set the palette to an Earthtones scheme.
HighContrast | Set the palette to a HighContrast scheme.
LilacsInMist | Set the palette to LilacsInMist scheme.
Mesa | Set the palette to Mesa scheme.
ModernBusiness | Set the palette to a ModernBusiness scheme.
NatureAdventure | Set the palette to a NatureAdventure scheme.
NatureSky | Set the palette to a NatureSky scheme.
Oceanica | Set the palette to Oceanica scheme.
Professional | Set the palette to a Professional scheme.
RainyDay | Set the palette to a RainyDay scheme.
SandAndSky | Set the palette to a SandAndSky scheme.
Simple | Set the palette to a Simple scheme.
Slate | Set the palette to Slate scheme.
SnowyPine | Set the palette to SnowyPine.
Vivid | Set the palette to a Vivid scheme.
Windows | Set the palette to a Windows scheme.

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as PowerGadgets will change the windows palette for the chart window. So if you previously set a color using any of the PowerGadgets supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Example

To set the Palette to NatureSky:

out-gauge -Palette NatureSky

See Also

Radial Parameter | Radial Summary


Refresh property of gauge Parameter

Refresh Parameter

Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.

Remarks

  • If the command returns a single value per each series, the gauge will add a new point to the end. Otherwise, the whole gauge data is replaced with the new data.

Example

To Refresh every 1 second the gauge populated with the processes (PS>get-process ):

ps | out-gauge -Refresh 0:0:1

See Also

Radial Parameter | Radial Summary


Scales_<index> property of RadialGauge Parameter

Scales_<index> Parameter

Returns the RadialScaleCollection for the RadialGauge object.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The MainScale property is used to obtain the main scale for a selected RadialGauge.

Example

To set the Scales Color to Red:

out-gauge -Scales_0_Color Red

See Also

Radial Parameter | Radial Summary


RadialScale Class Members

Radial_Scales Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Cap | Returns the RadialCap object for a selected RadialScale.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
Indicators | The collection of Indicators currently associated with the scale.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Pivot | Sets the position of the scale within the gauge.
Radius | Sets the radius for a RadialScale object.
Sections | Returns the SectionCollection for a scale object.
StartAngle | Sets the starting angle in degrees for a RadialScale.
Stripes | The collection of Stripes currently associated with the scale.
SweepAngle | Sets the starting angle in degrees for a RadialScale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar property of Scale Parameter

Scales_<index>_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the Scales Bar Color to Red:

out-gauge -Scales_0_Bar_Color Red

See Also

Radial_Scales Parameter | Radial_Scales Summary


ScaleBar Class Members

Radial_Scales_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border property of ScaleBar Parameter

Scales_<index>_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Scales_0_Bar_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Radial_Scales_Bar Parameter | Radial_Scales_Bar Summary


BarBorder Class Members

Radial_Scales_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border_Color property of BaseColorable Parameter

Scales_<index>_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Bar Border Color

out-gauge -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Color Blue

See Also

Radial_Scales_Bar_Border Parameter | Radial_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Thickness property of BarBorder Parameter

Scales_<index>_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Radial_Scales_Bar_Border Parameter | Radial_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Border Visible to false:

out-gauge -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Visible false

See Also

Radial_Scales_Bar_Border Parameter | Radial_Scales_Bar_Border Summary


Scales_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Radial_Scales_Bar Parameter | Radial_Scales_Bar Summary


Scales_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Visible to false:

out-gauge -Scales_0_Bar_Visible true -Scales_0_Bar_Visible false

See Also

Radial_Scales_Bar Parameter | Radial_Scales_Bar Summary


Scales_<index>_Cap property of RadialScale Parameter

Scales_<index>_Cap Parameter

Returns the RadialCap object for a selected RadialScale.

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

Example

To set the Scales Cap Style to RadialCap2:

out-gauge -Scales_0_Cap_Style RotatingCap02

See Also

Radial_Scales Parameter | Radial_Scales Summary


RadialCap Class Members

Radial_Scales_Cap Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Size | Sets a value to control the size of a RadialCap.
Style | Sets the styles for a RadialCap.
VerticalPosition | Sets the positioning of the Radial Cap to behind or above the Indicator(s).
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Cap_Color property of BaseColorable Parameter

Scales_<index>_Cap_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Cap Color

out-gauge -Scales_0_Cap_Color Blue

See Also

Radial_Scales_Cap Parameter | Radial_Scales_Cap Summary


Scales_<index>_Cap_Size property of RadialCap Parameter

Scales_<index>_Cap_Size Parameter

Sets a value to control the size of a RadialCap.

Example

To set the Scales Cap Size:

out-gauge -Scales_0_Cap_Size 0.2

See Also

Radial_Scales_Cap Parameter | Radial_Scales_Cap Summary


Scales_<index>_Cap_Style property of RadialCap Parameter

Scales_<index>_Cap_Style Parameter

Sets the styles for a RadialCap.

Value | Meaning
Cap01 | Set the cap style to Cap01.
Cap02 | Set the cap style to Cap02.
Cap03 | Set the cap style to Cap03.
Cap04 | Set the cap style to Cap04.
Cap05 | Set the cap style to Cap05.
Cap06 | Set the cap style to Cap06.
Cap07 | Set the cap style to Cap07.
Cap08 | Set the cap style to Cap08.
Cap09 | Set the cap style to Cap09.
Cap10 | Set the cap style to Cap10.
Cap11 | Set the cap style to Cap11.
Cap12 | Set the cap style to Cap12.
Cap13 | Set the cap style to Cap13.
Cap14 | Set the cap style to Cap14.
Cap15 | Set the cap style to Cap15.
Cap16 | Set the cap style to Cap16.
Cap17 | Set the cap style to Cap17.
Cap18 | Set the cap style to Cap18.
RotatingCap01 | Set the cap style to RotatingCap01.
RotatingCap02 | Set the cap style to RotatingCap02.
RotatingCap03 | Set the cap style to RotatingCap03.

Remarks

  • The RadialCap is the object that connects an indictor to a RadialScale object. The RadialCap is located at the center of a RadialScale.

Example

To set the Scales Cap Style:

out-gauge -Scales_0_Cap_Style Cap02

See Also

Radial_Scales_Cap Parameter | Radial_Scales_Cap Summary


Scales_<index>_Cap_VerticalPosition property of RadialCap Parameter

Scales_<index>_Cap_VerticalPosition Parameter

Sets the positioning of the Radial Cap to behind or above the Indicator(s).

Default Value
The default is AboveNeedles.

Value | Meaning
AboveNeedles | Positions the Cap on top of the Needle.
BehindNeedles | Positions the Cap inder the Needle.

Remarks

  • This is merely an aesthetic feature, but will change the order of the .

Example

Set the Radial Cap position to behind the Indicator needle.

out-gauge -MainScale_Cap_VerticalPosition BehindNeedles

See Also

Radial_Scales_Cap Parameter | Radial_Scales_Cap Summary


Scales_<index>_Cap_Visible property of BaseViewable Parameter

Scales_<index>_Cap_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Cap Visible to false:

out-gauge -Scales_0_Cap_Visible false

See Also

Radial_Scales_Cap Parameter | Radial_Scales_Cap Summary


Scales_<index>_Color property of BaseColorable Parameter

Scales_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Color

out-gauge -Scales_0_Color Blue

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_CustomLabels property of Scale Parameter

Scales_<index>_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the Scales CustomLabels for the value '40':

out-gauge -Scales_0_CustomLabels_40 "Label at 40"

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Indicators_<index> property of Scale Parameter

Scales_<index>_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the Scales Indicators Color to AliceBlue:

out-gauge -Scales_0_Indicators_0_Color AliceBlue

See Also

Radial_Scales Parameter | Radial_Scales Summary


Marker Class Members

Radial_Scales_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Color Blue

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


ValueFormat Class Members

Radial_Scales_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Radial_Scales_Indicators_Marker_Format Parameter | Radial_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Radial_Scales_Indicators_Marker_Format Parameter | Radial_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_Scales_Indicators_Marker_Format Parameter | Radial_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Radial_Scales_Indicators_Marker_Format Parameter | Radial_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Label property of Marker Parameter

Scales_<index>_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the Scales Indicators Label Color:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Color Red

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


LabelAttributes Class Members

Radial_Scales_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_Label_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Label Color

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Color Blue

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Font property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Indicators Label Font to Arial 5:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Font "Arial, 5"

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Indicators Label Orientation to Tangent

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Orientation Tangent

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Position property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label Position to Bottom:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Position Bottom

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label PositionCustom to 5:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Custom -Scales_0_Indicators_0_Label_PositionCustom 5

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Label Visible to false:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Visible false

See Also

Radial_Scales_Indicators_Marker_Label Parameter | Radial_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Position property of Marker Parameter

Scales_<index>_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Indicators Position to Bottom:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Position Bottom

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_PositionCustom property of Marker Parameter

Scales_<index>_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators PositionCustom:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Position Custom -Scales_0_Indicators_0_PositionCustom 0.05

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Size property of Marker Parameter

Scales_<index>_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the Scales Indicators Size to 5:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Size 5

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Snap 5

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Style property of Marker Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators Style to Marker02;

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Style Marker02

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Text property of Marker Parameter

Scales_<index>_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the Scales Indicators Text:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Text "My Value"

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Value 25

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Visible false

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Needle Class Members

Radial_Scales_Indicators_Needle Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Size | Sets a value to control the size of a needle.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a radial indicator needle.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Color Blue

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Format_Decimals 3

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


ValueFormat Class Members

Radial_Scales_Indicators_Needle_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Radial_Scales_Indicators_Needle_Format Parameter | Radial_Scales_Indicators_Needle_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Format_Decimals 3

See Also

Radial_Scales_Indicators_Needle_Format Parameter | Radial_Scales_Indicators_Needle_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_Scales_Indicators_Needle_Format Parameter | Radial_Scales_Indicators_Needle_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Radial_Scales_Indicators_Needle_Format Parameter | Radial_Scales_Indicators_Needle_Format Summary


Scales_<index>_Indicators_<index>_Size property of Needle Parameter

Scales_<index>_Indicators_<index>_Size Parameter

Sets a value to control the size of a needle.

Remarks

  • When set to zero, the needle is not visible in a radial gauge. This is a ratio property, therefore the overall size of a radial gauge is also a factor when rendering the needle.

Example

To set the Scales Indicators Size to 1:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Size 1

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Snap 5

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Style property of Needle Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a radial indicator needle.

Value | Meaning
Needle01 | Set the needle style to Needle01.
Needle02 | Set the needle style to Needle02.
Needle03 | Set the needle style to Needle03.
Needle04 | Set the needle style to Needle04.
Needle05 | Set the needle style to Needle05.
Needle06 | Set the needle style to Needle06.
Needle07 | Set the needle style to Needle07.
Needle08 | Set the needle style to Needle08.
Needle09 | Set the needle style to Needle09.
Needle10 | Set the needle style to Needle10.
Needle11 | Set the needle style to Needle11.
Needle12 | Set the needle style to Needle12.
Needle13 | Set the needle style to Needle13.
Needle14 | Set the needle style to Needle14.
Needle15 | Set the needle style to Needle15.
Needle16 | Set the needle style to Needle16.
Needle17 | Set the needle style to Needle17.
Needle18 | Set the needle style to Needle18.
Needle19 | Set the needle style to Needle19.
Needle20 | Set the needle style to Needle20.

Remarks

  • A needle is an indicator in a radial gauge which marks a value. There are several different needle designs and styles that may be used to customize the display of radial gauges. This property may be configured to any of the supported NeedleStyle enumeration types.

Example

To set the Scales Indicators Style to Needle5:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Style Needle05

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Value 25

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Visible false

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Max property of Range Parameter

Scales_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Max to 50:

out-gauge -Scales_0_Max 50

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales MaxAlwaysDisplayed to false:

out-gauge -Scales_0_MaxAlwaysDisplayed false

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Min property of Range Parameter

Scales_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Min to 10:

out-gauge -Scales_0_Min 10

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales MinAlwaysDisplayed to false:

out-gauge -Scales_0_MinAlwaysDisplayed false

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Pivot property of RadialScale Parameter

Scales_<index>_Pivot Parameter

Sets the position of the scale within the gauge.

Remarks

  • The coordinate system for positioning the scale mirrors a Unit Circle. The center point is (0,0). The top-center point is (0,1) and the bottom-center point is (0,-1). The left-center point is (-1,0) and the right-center point is (1,0).

Example

To set the Scales Pivot:

out-gauge -Scales_0_Pivot "0.01, 0.08"

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Radius property of RadialScale Parameter

Scales_<index>_Radius Parameter

Sets the radius for a RadialScale object.

Remarks

  • This property is used to control the size of a RadialScale object.

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for Radial Scales, multiple Radia lScale objects may be displayed in a single radial gauge object.

Example

To set the Scales Radius to 5:

out-gauge -Scales_0_Radius 0.5

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Sections_<index> property of Scale Parameter

Scales_<index>_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the Scales Sections Color to Red:

out-gauge -Scales_0_Sections_0_Color Red

See Also

Radial_Scales Parameter | Radial_Scales Summary


Section Class Members

Radial_Scales_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar property of Section Parameter

Scales_<index>_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the Scales Sections Bar Color to Red:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Color Red

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


SectionBar Class Members

Radial_Scales_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Radial_Scales_Sections_Bar Parameter | Radial_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Bar Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Visible true -Scales_0_Sections_0_Bar_Visible false

See Also

Radial_Scales_Sections_Bar Parameter | Radial_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Color Blue

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_Sections_<index>_Max property of Range Parameter

Scales_<index>_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Sections Max to 50:

out-gauge -Scales_0_Sections_0_Max 50

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MaxAlwaysDisplayed to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MaxAlwaysDisplayed false

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_Sections_<index>_Min property of Range Parameter

Scales_<index>_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Sections Min to 10:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Min 10

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MinAlwaysDisplayed to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MinAlwaysDisplayed false

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_Sections_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


TickmarkSet Class Members

Radial_Scales_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Color Blue

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


ValueFormat Class Members

Radial_Scales_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_Scales_Sections_Tickmarks_Format Parameter | Radial_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Sections Tickmarks Format Decimals to 3:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Decimals 3

See Also

Radial_Scales_Sections_Tickmarks_Format Parameter | Radial_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_Scales_Sections_Tickmarks_Format Parameter | Radial_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Sections Tickmarks Format FormatType to Percentage

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Radial_Scales_Sections_Tickmarks_Format Parameter | Radial_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Sections Tickmarks Major size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 5

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Major Label Color to Red:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Radial_Scales_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Major Label Font to Arial 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Major Label Orientation to Tangent

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Major_Label Parameter | Radial_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major PositionCustom to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 2.5

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Step to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Step 5

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Major Style:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Major Parameter | Radial_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Sections Tickmarks Medium size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 5

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Medium Label Color to Red:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Radial_Scales_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Medium_Label Parameter | Radial_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium PositionCustom to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Step to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Step 5

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Medium Style:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Medium Parameter | Radial_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Sections Tickmarks Minor size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 5

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Minor Label Color to Red:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Radial_Scales_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Color

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Minor_Label Parameter | Radial_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Position to Bottom:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor PositionCustom to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Size to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Step to 5:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Step 5

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Minor Style:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Visible false

See Also

Radial_Scales_Sections_Tickmarks_Minor Parameter | Radial_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Visible false

See Also

Radial_Scales_Sections_Tickmarks Parameter | Radial_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Visible to false:

out-gauge -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Visible false

See Also

Radial_Scales_Sections Parameter | Radial_Scales_Sections Summary


Scales_<index>_StartAngle property of RadialScale Parameter

Scales_<index>_StartAngle Parameter

Sets the starting angle in degrees for a RadialScale.

Remarks

  • This property supports a configuration value between 0 and 360.

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The SweepAngle property is used to get or set the angle at the ending value for a scale.

Example

To set the Scales StartAngle to 275:

out-gauge -Scales_0_StartAngle 275

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Stripes_<index> property of RadialScale Parameter

Scales_<index>_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the Scales Stripes Max to 30:

out-gauge -Scales_0_Stripes_0_Max 30

See Also

Radial_Scales Parameter | Radial_Scales Summary


RadialStrip Class Members

Radial_Scales_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Radius | Sets the radius for a RadialStrip object.
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_AlternateColor property of Strip Parameter

Scales_<index>_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the Scales Stripes AlternateColor to Yellow:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Gradient -Scales_0_Stripes_0_AlternateColor Yellow

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Border property of Strip Parameter

Scales_<index>_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the Scales Stripes Border Color to red:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Red

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


BarBorder Class Members

Radial_Scales_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_Border_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Border Color

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Blue

See Also

Radial_Scales_Stripes_Border Parameter | Radial_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Thickness property of BarBorder Parameter

Scales_<index>_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Stripes Border Thickness to 0.003:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Thickness 0.003

See Also

Radial_Scales_Stripes_Border Parameter | Radial_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Border Visible to false:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Visible false

See Also

Radial_Scales_Stripes_Border Parameter | Radial_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Color

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Color Blue

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_FillType property of Strip Parameter

Scales_<index>_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the Scales Stripes FillType to Gradient:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_AlternateColor Yellow -Scales_0_Stripes_0_FillType Gradient

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Max property of Range Parameter

Scales_<index>_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Stripes Max to 50:

out-gauge -Scales_0_Stripes_0_Max 50

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Min property of Range Parameter

Scales_<index>_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Stripes Min to 10:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Min 10

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Pattern property of Strip Parameter

Scales_<index>_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the Scales Stripes Pattern to BackwardDiagonal:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Pattern -Scales_0_Stripes_0_Pattern BackwardDiagonal

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Radius property of RadialStrip Parameter

Scales_<index>_Stripes_<index>_Radius Parameter

Sets the radius for a RadialStrip object.

Remarks

  • The Radius property may be configured to values between 0 and 1. By configuring offsetting radius values for Radial Stripe, multiple Radial Strips may be displayed over the same range of the Radial Scale in the gauge.

  • This property is used to control the size of a RadialStrip object.

Example

To set the Scales Stripes Radius to 1:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Radius 1

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Thickness property of Strip Parameter

Scales_<index>_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the Scales Stripes Thickness to 0.25:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Thickness 0.25

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

Scales_<index>_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Visible to false:

out-gauge -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Visible false

See Also

Radial_Scales_Stripes Parameter | Radial_Scales_Stripes Summary


Scales_<index>_SweepAngle property of RadialScale Parameter

Scales_<index>_SweepAngle Parameter

Sets the starting angle in degrees for a RadialScale.

Remarks

  • The Radius property is used to configure the radius of a RadialScale. By staggering the radius of scales, multiple scales may be displayed clearly in the same radial gauge.

  • The StartAngle property is used to get or set the ending angle in degrees for a RadialScale.

Example

To set the Scales SweepAngle to -225:

out-gauge -Scales_0_SweepAngle -225

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Thickness property of Scale Parameter

Scales_<index>_Thickness Parameter

Sets the width for a scale.

Example

To set the Scales Thickness to 0.05:

out-gauge -Scales_0_Thickness 0.05

See Also

Radial_Scales Parameter | Radial_Scales Summary


Scales_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Radial_Scales Parameter | Radial_Scales Summary


TickmarkSet Class Members

Radial_Scales_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Color

out-gauge -Scales_0_Tickmarks_Color Blue

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


Scales_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


ValueFormat Class Members

Radial_Scales_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Radial_Scales_Tickmarks_Format Parameter | Radial_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Tickmarks Format Decimals to 3:

out-gauge -Scales_0_Tickmarks_Format_Decimals 3

See Also

Radial_Scales_Tickmarks_Format Parameter | Radial_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Radial_Scales_Tickmarks_Format Parameter | Radial_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Tickmarks Format FormatType to Percentage

out-gauge -Scales_0_Tickmarks_Format_FormatType Percentage

See Also

Radial_Scales_Tickmarks_Format Parameter | Radial_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Tickmarks Major size to 5:

out-gauge -Scales_0_Tickmarks_Major_Size 5

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Color

out-gauge -Scales_0_Tickmarks_Major_Color Blue

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Major Label Color to Red:

out-gauge -Scales_0_Tickmarks_Major_Label_Color Red

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


LabelAttributes Class Members

Radial_Scales_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Label Color

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Color Blue

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Major Label Font to Arial 5:

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Major Label Orientation to Tangent

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label Position to Bottom:

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Position Bottom

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label PositionCustom to 5:

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Custom -Scales_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Label Visible to false:

out-gauge -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Visible false

See Also

Radial_Scales_Tickmarks_Major_Label Parameter | Radial_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Position to Bottom:

out-gauge -Scales_0_Tickmarks_Major_Position Bottom

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major PositionCustom to false:

out-gauge -Scales_0_Tickmarks_Major_Position Custom -Scales_0_Tickmarks_Major_PositionCustom 0.2

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Size to 5:

out-gauge -Scales_0_Tickmarks_Major_Size 2.5

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Step to 5:

out-gauge -Scales_0_Tickmarks_Major_Step 5

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Major Style:

out-gauge -Scales_0_Tickmarks_Major_Style Tickmark10_3

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Visible to false:

out-gauge -Scales_0_Tickmarks_Major_Visible false

See Also

Radial_Scales_Tickmarks_Major Parameter | Radial_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Tickmarks Medium size to 5:

out-gauge -Scales_0_Tickmarks_Medium_Size 5

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Color

out-gauge -Scales_0_Tickmarks_Medium_Color Blue

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Medium Label Color to Red:

out-gauge -Scales_0_Tickmarks_Medium_Label_Color Red

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


LabelAttributes Class Members

Radial_Scales_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Label Color

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Color Blue

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Medium Label Font to Arial 5:

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Medium Label Orientation to Tangent

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label Position to Bottom:

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Position Bottom

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label PositionCustom to 5:

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Label Visible to false:

out-gauge -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Visible false

See Also

Radial_Scales_Tickmarks_Medium_Label Parameter | Radial_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Position to Bottom:

out-gauge -Scales_0_Tickmarks_Medium_Position Bottom

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium PositionCustom to false:

out-gauge -Scales_0_Tickmarks_Medium_Position Custom -Scales_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Size to 5:

out-gauge -Scales_0_Tickmarks_Medium_Size 2.5

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Step to 5:

out-gauge -Scales_0_Tickmarks_Medium_Step 5

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Medium Style:

out-gauge -Scales_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Visible to false:

out-gauge -Scales_0_Tickmarks_Medium_Visible false

See Also

Radial_Scales_Tickmarks_Medium Parameter | Radial_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Tickmarks Minor size to 5:

out-gauge -Scales_0_Tickmarks_Minor_Size 5

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


Tickmark Class Members

Radial_Scales_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Color

out-gauge -Scales_0_Tickmarks_Minor_Color Blue

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Minor Label Color to Red:

out-gauge -Scales_0_Tickmarks_Minor_Label_Color Red

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


LabelAttributes Class Members

Radial_Scales_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Label Color

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Color Blue

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Minor Label Font to Arial 5:

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Minor Label Orientation to Tangent

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label Position to Bottom:

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Position Bottom

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label PositionCustom to 5:

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Label Visible to false:

out-gauge -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Visible false

See Also

Radial_Scales_Tickmarks_Minor_Label Parameter | Radial_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Position to Bottom:

out-gauge -Scales_0_Tickmarks_Minor_Position Bottom

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor PositionCustom to false:

out-gauge -Scales_0_Tickmarks_Minor_Position Custom -Scales_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Size to 5:

out-gauge -Scales_0_Tickmarks_Minor_Size 2.5

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Step to 5:

out-gauge -Scales_0_Tickmarks_Minor_Step 5

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Minor Style:

out-gauge -Scales_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Visible to false:

out-gauge -Scales_0_Tickmarks_Minor_Visible false

See Also

Radial_Scales_Tickmarks_Minor Parameter | Radial_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Visible to false:

out-gauge -Scales_0_Tickmarks_Visible false

See Also

Radial_Scales_Tickmarks Parameter | Radial_Scales_Tickmarks Summary


Scales_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Visible to false:

out-gauge -Scales_0_Visible false

See Also

Radial_Scales Parameter | Radial_Scales Summary


Shadow property of Gauge Parameter

Shadow Parameter

Sets a value indicating to whether to display a shadow in a gauge.

Default Value
The default is None.

Value | Meaning
None | No shadow effect.
Plain | A plain shadow effect.
Realistic | A realistic shadow effect.

Example

To set the Shadow to Realistic:

out-gauge -Shadow Realistic

See Also

Radial Parameter | Radial Summary


Size property of gauge Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered gauge.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered gauge.

Example

To configure the Size of the gauge:

out-gauge -Size 800,600

See Also

Radial Parameter | Radial Summary


Style property of gauge Parameter

Style Parameter

Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.

Remarks

  • There are 14 different styles for radial gauges: Style 0 through Style 14.

  • Styles do not include color settings, thus palette colors are used.

Example

To set the Style parameter to use the fourth style:

out-gauge -Style 4

See Also

Radial Parameter | Radial Summary


Template property of gauge Parameter

Template Parameter

Allows you to use or save gauge modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

Example

To use a pre-configured template called MyProcesses:

out-gauge -template MyProcesses

To use a graphical Wizard to configure a Tamplate gauge:

out-gauge -configure -template MyProcesses

See Also

Radial Parameter | Radial Summary


Titles_<index> property of BaseGauge Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set the Titles Color to Red:

out-gauge -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Radial Parameter | Radial Summary


Title Class Members

Radial_Titles Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Color | Sets the color of text for the specified title.
Font | Sets the Gauge Font object for a gauge title.
Layout | Allows you to access the layout object for an Annotation.
Text | Sets the text for the selected title.
Visible | Sets a value indicating whether an object is visible or not.


Titles_<index>_Angle property of Annotation Parameter

Titles_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Titles Angle to 45 degrees:

out-gauge -Titles_0_Text "My Text" -Titles_0_Angle 45

See Also

Radial_Titles Parameter | Radial_Titles Summary


Titles_<index>_Color property of Title Parameter

Titles_<index>_Color Parameter

Sets the color of text for the specified title.

Remarks

  • The Text propety is used to set the caption for a title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles Color to Red:

out-gauge -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Radial_Titles Parameter | Radial_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Sets the Gauge Font object for a gauge title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Titles Font:

out-gauge -Titles_0_Text "My Text" -Titles_0_Font "Arial, 5"

See Also

Radial_Titles Parameter | Radial_Titles Summary


Titles_<index>_Layout property of Annotation Parameter

Titles_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Radial_Titles Parameter | Radial_Titles Summary


LayoutAttributes Class Members

Radial_Titles_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Titles_<index>_Layout_Alignment property of LayoutAttributes Parameter

Titles_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Titles Layout Alignment to the MiddleCenter:

out-gauge -Titles_0_Text "My Text" -Titles_0_Layout_Alignment MiddleCenter

See Also

Radial_Titles_Layout Parameter | Radial_Titles_Layout Summary


Titles_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Titles_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Titles Layout AnchorPoint to a specific position:

out-gauge -Titles_0_Text "My Text" -Titles_0_Layout_Target AnchorPoint -Titles_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Radial_Titles_Layout Parameter | Radial_Titles_Layout Summary


Titles_<index>_Layout_Target property of LayoutAttributes Parameter

Titles_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Radial_Titles_Layout Parameter | Radial_Titles_Layout Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To set the Titles Text:

out-gauge -Titles_0_Text "My Text"

See Also

Radial_Titles Parameter | Radial_Titles Summary


Titles_<index>_Visible property of BaseViewable Parameter

Titles_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Titles Visible to false:

out-gauge -Titles_0_Text "My Text" -Titles_0_Visible false

See Also

Radial_Titles Parameter | Radial_Titles Summary


ToolTip property of BaseGauge Parameter

ToolTip Parameter

Sets the tool tip text.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

  • The ToolTipEnabled property may be used to control whether or not a tool tip will be diplayed for a gauge.

Example

To set the ToolTip:

out-gauge -ToolTip "My Text"

See Also

Radial Parameter | Radial Summary


ToolTipEnabled property of BaseGauge Parameter

ToolTipEnabled Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Remarks

  • Tooltips allow the user to easily recognize the appropriate PowerGadgets element.

Example

To set the ToolTipEnabled to false:

out-gauge -ToolTipEnabled false

See Also

Radial Parameter | Radial Summary


Type property of gauge Parameter

Type Parameter

Allows you to specify the gauge type (Radial, Horizontal, Vertical and Digital).

Remarks

  • Use the Type parameter to specify the Gauge Type. This are the types: Radial, Horizontal, Vertical and Digital.

  • If the Type parameter is not configured the gauge Type would be Radial.

Example

To configure the Type parameter to get a Horizontal:

out-gauge -Type Horizontal

To configure the Type parameter to get a Vertical:

out-gauge -Type Vertical

To configure the Type parameter to get a Digital:

out-gauge -Type Digital

See Also

Radial Parameter | Radial Summary


Value property of gauge Parameter

Value Parameter

Allows you to specify which propertie to plot in the gauge.

Remarks

  • Use the Value parameter to specifie which property must be used as indicator. Only a numeric property can be used.

Example

To specify the Handles as Value in a gauge populated with the processes (PS>get-process ):

ps | out-gauge -Value Handles

See Also

Radial Parameter | Radial Summary


HorizontalGauge Parameter

Remarks

A HorizontalGauge includes scales that are configured in a horizontal position. Supported members of the HorizontalGauge class allow developers to configure a border, colors, sections, flip the gradient color scheme, access to the scale and indicator objects, etc.

Below is an example of a HorizontalGauge:


HorizontalGauge Class Members

Horizontal Parameters

Parameters

Description

Anchor | Allows you to specify the general location of the gauge with respect to your desktop.
Antialiasing | Sets the smooth visual effect for a gauge.
Border | Returns the LinearBorder object for a linear gauge.
Caption | Modifies the caption used in the PowerGadget window
Configure | Allows you to use a graphical Wizard to customize the gauge.
Culture | Allows you to localize gauges for a specific language and region.
Floating | Allows you to launch a gauge without a window frame.
Font | Sets the font type which will be used by default in the gauge.
Glass |
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Images | Allows you to accesss the images for a gauge.
InnerGauges | The collection of InnerGauges currently associated with the gauge.
MainIndicator | Sets the main Indicator. The available indicators for a are the and the . As for the , the and the are the two possible types of indicators.
MainScale | Returns the main scale of a linear gauge.
MainValue | Sets the main value for a gauge. It is a shortcut to the value of the .
Modal | Allows you to block the command pipe while displaying a gauge.
Output | Allows you to generate a gauge file instead of an interactive one.
Palette | Allows you to set a PowerGadgets pre-defined palette.
Refresh | Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.
Scales | Returns the LinearScaleCollection for a linear gauge.
Shadow | Sets a value indicating to whether to display a shadow in a gauge.
Size | Allows you to specify the actual dimension of the final rendered gauge.
Style |
Template | Allows you to use or save gauge modifications into a template file.
Titles | Returns the collection of titles defined in the gauge.
ToolTip | Sets the tool tip text.
ToolTipEnabled | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.
Type |
Value | Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the gauge with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the Anchor parameter to TopRight:

out-gauge -Type Horizontal -Anchor TopRight

See Also

Horizontal Parameter | Horizontal Summary


Antialiasing property of BaseGauge Parameter

Antialiasing Parameter

Sets the smooth visual effect for a gauge.

Default Value
The default is All.

Value | Meaning
None | No smoothing applied.
Text | Smoothing applied to text objects only.
Graphic | Smoothing applied to graphic objects only.
All | Smoothing applied to all gauge elements.

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Example

To set the Antialiasing property for a gauge to None:

out-gauge -Type Horizontal -Antialiasing None

See Also

Horizontal Parameter | Horizontal Summary


Border property of LinearGauge Parameter

Border Parameter

Returns the LinearBorder object for a linear gauge.

Remarks

  • The Linear Border is the outer frame encasing a linear gauge. The Style property may be used to configure any of the supported Linear Border Style types.

Example

To set the Border Style to LinearBorder01:

out-gauge -Type Horizontal -Border_Style LinearBorder01

See Also

Horizontal Parameter | Horizontal Summary


LinearBorder Class Members

Horizontal_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Glare | Sets a value indicating whether to use a lighting effect for a border.
InsideColor | Sets the inside color for a gauge border.
InsideEffects | Enables or disables border shadow and gradient.
Inverted | Set a property to invert the Border of a Linear Gauge
Style | Sets the style for a LinearBorder object.
Visible | Sets a value indicating whether an object is visible or not.


Border_Color property of BaseColorable Parameter

Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border Color

out-gauge -Type Horizontal -Border_Color Blue

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_Glare property of Border Parameter

Border_Glare Parameter

Sets a value indicating whether to use a lighting effect for a border.

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

Example

To turn on the Border Glare effect for a gauge:

out-gauge -Type Horizontal -Border_Glare false

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_InsideColor property of Border Parameter

Border_InsideColor Parameter

Sets the inside color for a gauge border.

Remarks

  • This property is used to configure the inner color value for a Border object.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border InsideColor

out-gauge -Type Horizontal -Border_InsideColor Red

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_InsideEffects property of Border Parameter

Border_InsideEffects Parameter

Enables or disables border shadow and gradient.

Remarks

  • A natural gradient is applied when there is no specific background image.

Example

To Disable the Border InsideEffects:

out-gauge -Type Horizontal -Border_InsideEffects false

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_Inverted property of LinearBorder Parameter

Border_Inverted Parameter

Set a property to invert the Border of a Linear Gauge

Remarks

  • The following is a HorizontalGauge with Inverted = false:

  • The following is the same HorizontalGauge with Inverted = true:

Example

To set the Border Inverted to false:

out-gauge -Type Horizontal -Border_Inverted false

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_Style property of LinearBorder Parameter

Border_Style Parameter

Sets the style for a LinearBorder object.

Value | Meaning
LinearBorder01 | Set the border style to LinearBorder01.
LinearBorder02 | Set the border style to LinearBorder02.
LinearBorder03 | Set the border style to LinearBorder03.
LinearBorder04 | Set the border style to LinearBorder04.
LinearBorder05 | Set the border style to LinearBorder05.
LinearBorder06 | Set the border style to LinearBorder06.
LinearBorder07 | Set the border style to LinearBorder07.
LinearBorder08 | Set the border style to LinearBorder08.
LinearBorder09 | Set the border style to LinearBorder09.
LinearBorder10 | Set the border style to LinearBorder10.
LinearBorder11 | Set the border style to LinearBorder11.
LinearBorder12 | Set the border style to LinearBorder12.
LinearBorder13 | Set the border style to LinearBorder13.
LinearBorder14 | Set the border style to LinearBorder14.
LinearBorder15 | Set the border style to LinearBorder15.
LinearBorder16 | Set the border style to LinearBorder16.
LinearBorder17 | Set the border style to LinearBorder17.
Thermometer01 | Set the border style to Thermometer01.
Thermometer02 | Set the border style to Thermometer02.
Thermometer03 | Set the border style to Thermometer03.

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. This property may be used to configure any of the supported LinearBorderStyle enumeration types.

Example

To set the Border Style to Thermometer:

out-gauge -Type Horizontal -Border_Style Thermometer01

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Border_Visible property of BaseViewable Parameter

Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Border Visible to false:

out-gauge -Type Horizontal -Border_Visible false

See Also

Horizontal_Border Parameter | Horizontal_Border Summary


Caption property of gauge Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the Caption in the PowerGadget window:

out-gauge -Type Horizontal -Caption "My PowerGadget"

See Also

Horizontal Parameter | Horizontal Summary


Configure property of gauge Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the gauge.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

  • This Wizard has two tabs, one called gauge Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the gauge Wizard tab.

Example

To use a graphical wizard to Configure the gauge:

out-gauge -Type Horizontal -Configure

See Also

Horizontal Parameter | Horizontal Summary


Culture property of BaseGauge Parameter

Culture Parameter

Allows you to localize gauges for a specific language and region.

Remarks

  • Culture attributes set with this property will effect the entire gauge, if no attributes are set using this property then PowerGadgets inherits the current Thread culture.

Example

To set the Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -Culture "es-ES"

See Also

Horizontal Parameter | Horizontal Summary


DrillDown Parameter

Remarks

@2008 Software FX, Inc. All Rights Reserved. PowerGadgets is a registered trademark of Software FX, Inc
All other names are trademarks or registered trademarks of their respective owners.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-gauge.

Example

To use the DrillDown_Script parameter:

ps | out-gauge -DrillDown_Script ProcessDetails.ps1 -DrillDown_Parameter {$_.Id}

See Also

Horizontal_DrillDown Parameter | Horizontal_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

  • In most cases this parameter is not necessary when implementing drilldown with gauges.

Example

To use the DrillDown_Parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName}

See Also

Horizontal_DrillDown Parameter | Horizontal_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName} -DrillDown_Script get-process -DrillDown_Console

See Also

Horizontal_DrillDown Parameter | Horizontal_DrillDown Summary


Floating property of gauge Parameter

Floating Parameter

Allows you to launch a gauge without a window frame.

Remarks

  • Use Floating to launch a gauge without a window frame making the gauge appear as it were floating over the desktop.

Example

To launch a gauge without a window frame configuring the Floating parameter:

out-gauge -Type Horizontal -Floating

See Also

Horizontal Parameter | Horizontal Summary


Font property of BaseGauge Parameter

Font Parameter

Sets the font type which will be used by default in the gauge.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To configure the Font

out-gauge -Type Horizontal -Font "Arial, 5"

See Also

Horizontal Parameter | Horizontal Summary


Glass property of gauge Parameter

Glass Parameter

Allows you to configure the gauge background to b painted using Glass form.

Remarks

  • When running in Windows Vista, the chart background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-gauge -Type Horizontal -Glass

See Also

Horizontal Parameter | Horizontal Summary


HideFromAltTab property of BaseGauge Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-gauge -Type Horizontal -HideFromAltTab

See Also

Horizontal Parameter | Horizontal Summary


Images_<index> property of BaseGauge Parameter

Images_<index> Parameter

Allows you to accesss the images for a gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • You'll have to add an image item ("Bitmap" or "Vector") in order to configure a particular Image:

    -Images_Add Bitmap or -Images_Add Vector.

  • This parameter allows you to configure a particular image. You may also specifying an index value to access a specific image item in Gauge.

Example

To add and configure a Images angle:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 10

See Also

Horizontal Parameter | Horizontal Summary


BitmapImage Class Members

Horizontal_Images Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Image | Represents the actual Image object in the gauge.
Layout | Allows you to access the layout object for an Annotation.
Size | A numeric size modifier applied in conjunction with a Custom setting.
SizeMode | Defines the display size options for the background image.
Visible | Sets a value indicating whether an object is visible or not.


Images_<index>_Angle property of Annotation Parameter

Images_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Images Angle to 45 degrees:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 45

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


Images_<index>_Image property of BitmapImage Parameter

Images_<index>_Image Parameter

Represents the actual Image object in the gauge.

Remarks

  • Images that are larger than the gauge are not automatically scaled.

  • Use the Image parameter to configure the image path.

Example

Here is an example of setting the Images Image

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png"

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


Images_<index>_Layout property of Annotation Parameter

Images_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


LayoutAttributes Class Members

Horizontal_Images_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Images_<index>_Layout_Alignment property of LayoutAttributes Parameter

Images_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Images Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Alignment MiddleCenter

See Also

Horizontal_Images_Layout Parameter | Horizontal_Images_Layout Summary


Images_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Images_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Images Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Target AnchorPoint -Images_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_Images_Layout Parameter | Horizontal_Images_Layout Summary


Images_<index>_Layout_Target property of LayoutAttributes Parameter

Images_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_Images_Layout Parameter | Horizontal_Images_Layout Summary


Images_<index>_Size property of BaseImage Parameter

Images_<index>_Size Parameter

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Example

To set the Images Size:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Custom -Images_0_Size 1.2

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


Images_<index>_SizeMode property of BaseImage Parameter

Images_<index>_SizeMode Parameter

Defines the display size options for the background image.

Default Value
The default is Normal.

Value | Meaning
Normal | The image is placed in the center of the container, in its original size. The image is clipped if it is larger than the container.
Stretch | The image is stretched or shrunk to fit the size of the container.
Custom | The image size will be custom set by the Size property.

Remarks

  • When using the Custom value a size can be specified using the Size property.

Example

To set the Images SizeMode to Stretch:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Stretch

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


Images_<index>_Visible property of BaseViewable Parameter

Images_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Images Visible to false:

out-gauge -Type Horizontal -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Visible false

See Also

Horizontal_Images Parameter | Horizontal_Images Summary


InnerGauges_<index> property of BaseGauge Parameter

InnerGauges_<index> Parameter

The collection of InnerGauges currently associated with the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

See Also

Horizontal Parameter | Horizontal Summary


InnerDigitalPanel Class Members

Horizontal_InnerGauges_InnerDigitalPanel Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
DigitalPanel | Returns the DigitalPanel object for an inner digital meter.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_Angle 45

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_DigitalPanel property of InnerDigitalPanel Parameter

InnerGauges_<index>_DigitalPanel Parameter

Returns the DigitalPanel object for an inner digital meter.

Remarks

  • This property is used to return the DigitalPanel object for an inner digital Panel. For additional information regarding supported members, please see the Parameter.

Example

To configure the InnerGauges DigitalPanel Font:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_DigitalPanel_Font "Arial, 5"

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


LayoutAttributes Class Members

Horizontal_InnerGauges_InnerDigitalPanel_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Horizontal_InnerGauges_InnerDigitalPanel_Layout Parameter | Horizontal_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_InnerGauges_InnerDigitalPanel_Layout Parameter | Horizontal_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_InnerGauges_InnerDigitalPanel_Layout Parameter | Horizontal_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_LinkToMainValue true

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_Size "0.3, 0.5"

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Horizontal -InnerGauges_Add Digital -InnerGauges_0_Visible false

See Also

Horizontal_InnerGauges_InnerDigitalPanel Parameter | Horizontal_InnerGauges_InnerDigitalPanel Summary


InnerHorizontalGauge Class Members

Horizontal_InnerGauges_InnerHorizontalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
HorizontalGauge | Exposes the HorizontalGauge properties of the InnerGauge.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_Angle 45

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_HorizontalGauge property of InnerHorizontalGauge Parameter

InnerGauges_<index>_HorizontalGauge Parameter

Exposes the HorizontalGauge properties of the InnerGauge.

Remarks

  • This property is used to return the HorizontalGauge object for an inner horizontal gauge. For additional information regarding supported members, please see the Parameter.

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


LayoutAttributes Class Members

Horizontal_InnerGauges_InnerHorizontalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Horizontal_InnerGauges_InnerHorizontalGauge_Layout Parameter | Horizontal_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_InnerGauges_InnerHorizontalGauge_Layout Parameter | Horizontal_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_InnerGauges_InnerHorizontalGauge_Layout Parameter | Horizontal_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_LinkToMainValue true

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_Size "0.3, 0.5"

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Horizontal -InnerGauges_Add Horizontal -InnerGauges_0_Visible false

See Also

Horizontal_InnerGauges_InnerHorizontalGauge Parameter | Horizontal_InnerGauges_InnerHorizontalGauge Summary


InnerRadialGauge Class Members

Horizontal_InnerGauges_InnerRadialGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
RadialGauge | Returns the RadialGauge object for an inner radial gauge.
Size | Sets the InnerGauge size
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_Angle 45

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


LayoutAttributes Class Members

Horizontal_InnerGauges_InnerRadialGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Horizontal_InnerGauges_InnerRadialGauge_Layout Parameter | Horizontal_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_InnerGauges_InnerRadialGauge_Layout Parameter | Horizontal_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_InnerGauges_InnerRadialGauge_Layout Parameter | Horizontal_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_LinkToMainValue true

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_RadialGauge property of InnerRadialGauge Parameter

InnerGauges_<index>_RadialGauge Parameter

Returns the RadialGauge object for an inner radial gauge.

Remarks

  • This property is used to return the RadialGauge object for an inner radial gauge. For additional information regarding supported members, please see the Parameter.

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Size property of InnerRadialGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the InnerGauge size

Remarks

  • The InnerGauge is scaled based on the value provided in this property. A value of 2.0 or greater will scale the InnerGauge larger than the Main Gauge.

Example

To set the InnerGauges Size value for a Inner Radial Gauge:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_Size 0.4

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Horizontal -InnerGauges_Add Radial -InnerGauges_0_Visible false

See Also

Horizontal_InnerGauges_InnerRadialGauge Parameter | Horizontal_InnerGauges_InnerRadialGauge Summary


InnerVerticalGauge Class Members

Horizontal_InnerGauges_InnerVerticalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
VerticalGauge | Returns the LinearGauge object for an inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_Angle 45

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


LayoutAttributes Class Members

Horizontal_InnerGauges_InnerVerticalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Horizontal_InnerGauges_InnerVerticalGauge_Layout Parameter | Horizontal_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_InnerGauges_InnerVerticalGauge_Layout Parameter | Horizontal_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_InnerGauges_InnerVerticalGauge_Layout Parameter | Horizontal_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_LinkToMainValue true

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_Size "0.3, 0.5"

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_VerticalGauge property of InnerVerticalGauge Parameter

InnerGauges_<index>_VerticalGauge Parameter

Returns the LinearGauge object for an inner linear gauge.

Remarks

  • This property is used to return the LinearGauge object for an inner linear gauge. For additional information regarding supported members, please see the Parameter.

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Horizontal -InnerGauges_Add Vertical -InnerGauges_0_Visible false

See Also

Horizontal_InnerGauges_InnerVerticalGauge Parameter | Horizontal_InnerGauges_InnerVerticalGauge Summary


Location property of gauge Parameter

Location Parameter

Allows you to configure the gauge's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a Location for the gauge:

out-gauge -Type Horizontal -Location 10,10

See Also

Horizontal Parameter | Horizontal Summary


MainIndicator property of Gauge Parameter

MainIndicator Parameter

Sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.

Remarks

  • A gauge may have many indicators, however only one MainIndicator.

  • The MainValue property is used to obtain the value of the MainIndicator.

Example

To set the MainIndicator Vale to 35:

out-gauge -Type Horizontal -MainIndicator_Value 35

See Also

Horizontal Parameter | Horizontal Summary


Marker Class Members

Horizontal_MainIndicator_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_AnimationSpan 0:0:2

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Color Blue

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


ValueFormat Class Members

Horizontal_MainIndicator_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Format_Culture "es-ES"

See Also

Horizontal_MainIndicator_Marker_Format Parameter | Horizontal_MainIndicator_Marker_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Horizontal_MainIndicator_Marker_Format Parameter | Horizontal_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainIndicator_Marker_Format Parameter | Horizontal_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Format_FormatType Percentage

See Also

Horizontal_MainIndicator_Marker_Format Parameter | Horizontal_MainIndicator_Marker_Format Summary


MainIndicator_Label property of Marker Parameter

MainIndicator_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainIndicator Label Color:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Color Red

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


LabelAttributes Class Members

Horizontal_MainIndicator_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_Label_Color property of BaseColorable Parameter

MainIndicator_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Label Color

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Color Blue

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Label_Font property of LabelAttributes Parameter

MainIndicator_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainIndicator Label Font to Arial 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Font "Arial, 5"

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Label_Orientation property of LabelAttributes Parameter

MainIndicator_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainIndicator Label Orientation to Tangent

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Orientation Tangent

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Label_Position property of LabelAttributes Parameter

MainIndicator_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Position Bottom

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Label_PositionCustom property of LabelAttributes Parameter

MainIndicator_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label PositionCustom to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Custom -MainIndicator_Label_PositionCustom 5

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Label_Visible property of BaseViewable Parameter

MainIndicator_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Label Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Visible false

See Also

Horizontal_MainIndicator_Marker_Label Parameter | Horizontal_MainIndicator_Marker_Label Summary


MainIndicator_Position property of Marker Parameter

MainIndicator_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainIndicator Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Position Bottom

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_PositionCustom property of Marker Parameter

MainIndicator_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator PositionCustom:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Position Custom -MainIndicator_PositionCustom 0.05

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Size property of Marker Parameter

MainIndicator_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainIndicator Size to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Size 5

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Snap 5

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Style property of Marker Parameter

MainIndicator_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator Style to Marker02;

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Style Marker02

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Text property of Marker Parameter

MainIndicator_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainIndicator Text:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Text "My Value"

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Value 25

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_VerticalPosition BehindTickmarks

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Visible false

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


Filler Parameter

Remarks

The Filler object is the bar marker that has a beggining and ending value.

The following is a sample of a Filler in a :

PowerGadgets Gauges provides several Filler , in diferent shapes and forms, the following is a example of a HorizontaGauge with a repeat filler:


Filler Class Members

Horizontal_MainIndicator_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_AnimationSpan 0:0:2

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Color Blue

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Format_Decimals 3

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


ValueFormat Class Members

Horizontal_MainIndicator_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Format_Culture "es-ES"

See Also

Horizontal_MainIndicator_Filler_Format Parameter | Horizontal_MainIndicator_Filler_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Format_Decimals 3

See Also

Horizontal_MainIndicator_Filler_Format Parameter | Horizontal_MainIndicator_Filler_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainIndicator_Filler_Format Parameter | Horizontal_MainIndicator_Filler_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Format_FormatType Percentage

See Also

Horizontal_MainIndicator_Filler_Format Parameter | Horizontal_MainIndicator_Filler_Format Summary


MainIndicator_Origin property of Filler Parameter

MainIndicator_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator Origin:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Origin OriginAtMin

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_OriginCustom property of Filler Parameter

MainIndicator_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator OriginCustom to 15:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_OriginCustom 15

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Snap 5

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Style property of Filler Parameter

MainIndicator_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the MainIndicator Style:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Style Filler02

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_UseFillerAsBar property of Filler Parameter

MainIndicator_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator UseFillerAsBar to true:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_UseFillerAsBar true

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Value 25

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_VerticalPosition BehindTickmarks

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Visible false

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainScale property of LinearGauge Parameter

MainScale Parameter

Returns the main scale of a linear gauge.

Remarks

  • A scale for a linear gauge is the range of values which a gauge can indicate a value. The indicator marks a value in a given scale.

  • The Scales property may be used to obtain the LinearScaleCollection for a linear gauge. The MainScale property is used to return the main scale object in the collection. By default, the main scale is the first scale of the collection.

Example

To set the MainScale Max to 200

out-gauge -Type Horizontal -MainScale_Max 200

See Also

Horizontal Parameter | Horizontal Summary


LinearScale Class Members

Horizontal_MainScale Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
FillerVolume | Sets the Filler size within a Linear Gauge
Indicators | The collection of Indicators currently associated with the scale.
Inverted | Gets amd set a boolean flag to invert the scale
Layout | Gets the layout object for a LinearScale
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Sections | Returns the SectionCollection for a scale object.
Size | Sets the size for a Linear Scale.
Stripes | The collection of Stripes currently associated with the scale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar property of Scale Parameter

MainScale_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the MainScale Bar Color to Red:

out-gauge -Type Horizontal -MainScale_Bar_Color Red

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


ScaleBar Class Members

Horizontal_MainScale_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border property of ScaleBar Parameter

MainScale_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -Type Horizontal -MainScale_Bar_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Horizontal_MainScale_Bar Parameter | Horizontal_MainScale_Bar Summary


BarBorder Class Members

Horizontal_MainScale_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border_Color property of BaseColorable Parameter

MainScale_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Bar Border Color

out-gauge -Type Horizontal -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Color Blue

See Also

Horizontal_MainScale_Bar_Border Parameter | Horizontal_MainScale_Bar_Border Summary


MainScale_Bar_Border_Thickness property of BarBorder Parameter

MainScale_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -Type Horizontal -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Horizontal_MainScale_Bar_Border Parameter | Horizontal_MainScale_Bar_Border Summary


MainScale_Bar_Border_Visible property of BaseViewable Parameter

MainScale_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Border Visible to false:

out-gauge -Type Horizontal -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Visible false

See Also

Horizontal_MainScale_Bar_Border Parameter | Horizontal_MainScale_Bar_Border Summary


MainScale_Bar_Color property of BaseSectionBar Parameter

MainScale_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Horizontal_MainScale_Bar Parameter | Horizontal_MainScale_Bar Summary


MainScale_Bar_Visible property of BaseViewable Parameter

MainScale_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Visible to false:

out-gauge -Type Horizontal -MainScale_Bar_Visible true -MainScale_Bar_Visible false

See Also

Horizontal_MainScale_Bar Parameter | Horizontal_MainScale_Bar Summary


MainScale_Color property of BaseColorable Parameter

MainScale_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Color

out-gauge -Type Horizontal -MainScale_Color Blue

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_CustomLabels property of Scale Parameter

MainScale_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the MainScale CustomLabels for the value '40':

out-gauge -Type Horizontal -MainScale_CustomLabels_40 "Label at 40"

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_FillerVolume property of LinearScale Parameter

MainScale_FillerVolume Parameter

Sets the Filler size within a Linear Gauge

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Example

To set the MainScale FillerVolume to 25:;

out-gauge -Type Horizontal -MainScale_FillerVolume 25

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Indicators_<index> property of Scale Parameter

MainScale_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the MainScale Indicators Color to AliceBlue:

out-gauge -Type Horizontal -MainScale_Indicators_0_Color AliceBlue

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


Marker Class Members

Horizontal_MainScale_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Color Blue

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


ValueFormat Class Members

Horizontal_MainScale_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Indicators_Marker_Format Parameter | Horizontal_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Horizontal_MainScale_Indicators_Marker_Format Parameter | Horizontal_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainScale_Indicators_Marker_Format Parameter | Horizontal_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Horizontal_MainScale_Indicators_Marker_Format Parameter | Horizontal_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Label property of Marker Parameter

MainScale_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainScale Indicators Label Color:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Color Red

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


LabelAttributes Class Members

Horizontal_MainScale_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_Label_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Label Color

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Color Blue

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Font property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Indicators Label Font to Arial 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Indicators Label Orientation to Tangent

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Orientation Tangent

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Position property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Position Bottom

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label PositionCustom to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Custom -MainScale_Indicators_0_Label_PositionCustom 5

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Label Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Visible false

See Also

Horizontal_MainScale_Indicators_Marker_Label Parameter | Horizontal_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Position property of Marker Parameter

MainScale_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Indicators Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Position Bottom

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_PositionCustom property of Marker Parameter

MainScale_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators PositionCustom:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Position Custom -MainScale_Indicators_0_PositionCustom 0.05

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Size property of Marker Parameter

MainScale_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainScale Indicators Size to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Size 5

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Snap 5

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Style property of Marker Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators Style to Marker02;

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Style Marker02

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Text property of Marker Parameter

MainScale_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainScale Indicators Text:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Text "My Value"

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Value 25

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Visible false

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


Filler Class Members

Horizontal_MainScale_Indicators_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Color Blue

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Format_Decimals 3

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


ValueFormat Class Members

Horizontal_MainScale_Indicators_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Indicators_Filler_Format Parameter | Horizontal_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Format_Decimals 3

See Also

Horizontal_MainScale_Indicators_Filler_Format Parameter | Horizontal_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainScale_Indicators_Filler_Format Parameter | Horizontal_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Horizontal_MainScale_Indicators_Filler_Format Parameter | Horizontal_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Origin property of Filler Parameter

MainScale_Indicators_<index>_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators Origin:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Origin OriginAtMin

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_OriginCustom property of Filler Parameter

MainScale_Indicators_<index>_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators OriginCustom to 15:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_OriginCustom 15

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Snap 5

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Style property of Filler Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the MainScale Indicators Style:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Style Filler02

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_UseFillerAsBar property of Filler Parameter

MainScale_Indicators_<index>_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators UseFillerAsBar to true:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_UseFillerAsBar true

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Value 25

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Visible false

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Inverted property of LinearScale Parameter

MainScale_Inverted Parameter

Gets amd set a boolean flag to invert the scale

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Example

To set the MainScale Inverted to true:

out-gauge -Type Horizontal -MainScale_Inverted true

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Layout property of LinearScale Parameter

MainScale_Layout Parameter

Gets the layout object for a LinearScale

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Example

To set the MainScale Layout Alignment to BottomCenter:

out-gauge -Type Horizontal -MainScale_Layout_Alignment BottomCenter

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


LayoutAttributes Class Members

Horizontal_MainScale_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


MainScale_Layout_Alignment property of LayoutAttributes Parameter

MainScale_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the MainScale Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -MainScale_Layout_Alignment MiddleCenter

See Also

Horizontal_MainScale_Layout Parameter | Horizontal_MainScale_Layout Summary


MainScale_Layout_AnchorPoint property of LayoutAttributes Parameter

MainScale_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the MainScale Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -MainScale_Layout_Target AnchorPoint -MainScale_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_MainScale_Layout Parameter | Horizontal_MainScale_Layout Summary


MainScale_Layout_Target property of LayoutAttributes Parameter

MainScale_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_MainScale_Layout Parameter | Horizontal_MainScale_Layout Summary


MainScale_Max property of Range Parameter

MainScale_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Max to 50:

out-gauge -Type Horizontal -MainScale_Max 50

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale MaxAlwaysDisplayed to false:

out-gauge -Type Horizontal -MainScale_MaxAlwaysDisplayed false

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Min property of Range Parameter

MainScale_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Min to 10:

out-gauge -Type Horizontal -MainScale_Min 10

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale MinAlwaysDisplayed to false:

out-gauge -Type Horizontal -MainScale_MinAlwaysDisplayed false

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Sections_<index> property of Scale Parameter

MainScale_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the MainScale Sections Color to Red:

out-gauge -Type Horizontal -MainScale_Sections_0_Color Red

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


Section Class Members

Horizontal_MainScale_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar property of Section Parameter

MainScale_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the MainScale Sections Bar Color to Red:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Color Red

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


SectionBar Class Members

Horizontal_MainScale_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

MainScale_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Horizontal_MainScale_Sections_Bar Parameter | Horizontal_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Bar_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Bar Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Visible true -MainScale_Sections_0_Bar_Visible false

See Also

Horizontal_MainScale_Sections_Bar Parameter | Horizontal_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Color Blue

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Sections_<index>_Max property of Range Parameter

MainScale_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Sections Max to 50:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 50

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MaxAlwaysDisplayed to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MaxAlwaysDisplayed false

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Sections_<index>_Min property of Range Parameter

MainScale_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Sections Min to 10:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Min 10

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MinAlwaysDisplayed to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MinAlwaysDisplayed false

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Sections_<index>_Tickmarks property of BaseSection Parameter

MainScale_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


TickmarkSet Class Members

Horizontal_MainScale_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


ValueFormat Class Members

Horizontal_MainScale_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Sections_Tickmarks_Format Parameter | Horizontal_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Sections Tickmarks Format Decimals to 3:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Decimals 3

See Also

Horizontal_MainScale_Sections_Tickmarks_Format Parameter | Horizontal_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainScale_Sections_Tickmarks_Format Parameter | Horizontal_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Sections Tickmarks Format FormatType to Percentage

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Horizontal_MainScale_Sections_Tickmarks_Format Parameter | Horizontal_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Sections Tickmarks Major size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 5

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Major Label Color to Red:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Major Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Major Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Custom -MainScale_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 2.5

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Step to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Step 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Major Style:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Major Parameter | Horizontal_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Sections Tickmarks Medium size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 5

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Label Color to Red:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Custom -MainScale_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Step to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Step 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Style:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Medium Parameter | Horizontal_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Sections Tickmarks Minor size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 5

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Label Color to Red:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Color

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Custom -MainScale_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Position to Bottom:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Size to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Step to 5:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Step 5

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Style:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks_Minor Parameter | Horizontal_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Visible false

See Also

Horizontal_MainScale_Sections_Tickmarks Parameter | Horizontal_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Visible to false:

out-gauge -Type Horizontal -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Visible false

See Also

Horizontal_MainScale_Sections Parameter | Horizontal_MainScale_Sections Summary


MainScale_Size property of LinearScale Parameter

MainScale_Size Parameter

Sets the size for a Linear Scale.

Remarks

  • This property is used to control the size of the scale in a Linear Gauge.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

Example

To set the MainScale Size to 0.75:

out-gauge -Type Horizontal -MainScale_Size 0.75

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Stripes_<index> property of LinearScale Parameter

MainScale_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the MainScale Stripes Max to 30:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


LinearStrip Class Members

Horizontal_MainScale_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Offset | Set the offset of a Strip respect ot the Scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_AlternateColor property of Strip Parameter

MainScale_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the MainScale Stripes AlternateColor to Yellow:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Gradient -MainScale_Stripes_0_AlternateColor Yellow

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Border property of Strip Parameter

MainScale_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the MainScale Stripes Border Color to red:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Red

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


BarBorder Class Members

Horizontal_MainScale_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_Border_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Border Color

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Blue

See Also

Horizontal_MainScale_Stripes_Border Parameter | Horizontal_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Thickness property of BarBorder Parameter

MainScale_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Stripes Border Thickness to 0.003:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Thickness 0.003

See Also

Horizontal_MainScale_Stripes_Border Parameter | Horizontal_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Border Visible to false:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Visible false

See Also

Horizontal_MainScale_Stripes_Border Parameter | Horizontal_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Color

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Color Blue

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_FillType property of Strip Parameter

MainScale_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the MainScale Stripes FillType to Gradient:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_AlternateColor Yellow -MainScale_Stripes_0_FillType Gradient

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Max property of Range Parameter

MainScale_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Stripes Max to 50:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 50

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Min property of Range Parameter

MainScale_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Stripes Min to 10:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Min 10

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Offset property of LinearStrip Parameter

MainScale_Stripes_<index>_Offset Parameter

Set the offset of a Strip respect ot the Scale.

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Example

To display a strip on the center of the main Sclale:

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Pattern property of Strip Parameter

MainScale_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the MainScale Stripes Pattern to BackwardDiagonal:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Pattern -MainScale_Stripes_0_Pattern BackwardDiagonal

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Thickness property of Strip Parameter

MainScale_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the MainScale Stripes Thickness to 0.25:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Thickness 0.25

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

MainScale_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Stripes_<index>_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Visible to false:

out-gauge -Type Horizontal -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Visible false

See Also

Horizontal_MainScale_Stripes Parameter | Horizontal_MainScale_Stripes Summary


MainScale_Thickness property of Scale Parameter

MainScale_Thickness Parameter

Sets the width for a scale.

Example

To set the MainScale Thickness to 0.05:

out-gauge -Type Horizontal -MainScale_Thickness 0.05

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainScale_Tickmarks property of BaseSection Parameter

MainScale_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


TickmarkSet Class Members

Horizontal_MainScale_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Color property of BaseColorable Parameter

MainScale_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Color Blue

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


MainScale_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


ValueFormat Class Members

Horizontal_MainScale_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_MainScale_Tickmarks_Format Parameter | Horizontal_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Tickmarks Format Decimals to 3:

out-gauge -Type Horizontal -MainScale_Tickmarks_Format_Decimals 3

See Also

Horizontal_MainScale_Tickmarks_Format Parameter | Horizontal_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_MainScale_Tickmarks_Format Parameter | Horizontal_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Tickmarks Format FormatType to Percentage

out-gauge -Type Horizontal -MainScale_Tickmarks_Format_FormatType Percentage

See Also

Horizontal_MainScale_Tickmarks_Format Parameter | Horizontal_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Tickmarks Major size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Size 5

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Major Label Color to Red:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Color Red

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


LabelAttributes Class Members

Horizontal_MainScale_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Label Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Major Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Major Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Orientation Tangent

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Custom -MainScale_Tickmarks_Major_Label_PositionCustom 5

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Label Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Visible false

See Also

Horizontal_MainScale_Tickmarks_Major_Label Parameter | Horizontal_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Position Custom -MainScale_Tickmarks_Major_PositionCustom 0.2

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Size 2.5

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Step to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Step 5

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Major Style:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Style Tickmark10_3

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Major_Visible false

See Also

Horizontal_MainScale_Tickmarks_Major Parameter | Horizontal_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Tickmarks Medium size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Size 5

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Medium Label Color to Red:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Color Red

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


LabelAttributes Class Members

Horizontal_MainScale_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Label Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Orientation Tangent

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Custom -MainScale_Tickmarks_Medium_Label_PositionCustom 5

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Label Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Visible false

See Also

Horizontal_MainScale_Tickmarks_Medium_Label Parameter | Horizontal_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Position Custom -MainScale_Tickmarks_Medium_PositionCustom 0.2

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Size 2.5

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Step to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Step 5

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Medium Style:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Style Tickmark10_3

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Medium_Visible false

See Also

Horizontal_MainScale_Tickmarks_Medium Parameter | Horizontal_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Tickmarks Minor size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Size 5

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


Tickmark Class Members

Horizontal_MainScale_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Minor Label Color to Red:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Color Red

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


LabelAttributes Class Members

Horizontal_MainScale_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Label Color

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Color Blue

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Orientation Tangent

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Custom -MainScale_Tickmarks_Minor_Label_PositionCustom 5

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Label Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Visible false

See Also

Horizontal_MainScale_Tickmarks_Minor_Label Parameter | Horizontal_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Position to Bottom:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Position Bottom

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor PositionCustom to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Position Custom -MainScale_Tickmarks_Minor_PositionCustom 0.2

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Size to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Size 2.5

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Step to 5:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Step 5

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Minor Style:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Style Tickmark10_3

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Minor_Visible false

See Also

Horizontal_MainScale_Tickmarks_Minor Parameter | Horizontal_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Visible to false:

out-gauge -Type Horizontal -MainScale_Tickmarks_Visible false

See Also

Horizontal_MainScale_Tickmarks Parameter | Horizontal_MainScale_Tickmarks Summary


MainScale_Visible property of BaseViewable Parameter

MainScale_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Visible to false:

out-gauge -Type Horizontal -MainScale_Visible false

See Also

Horizontal_MainScale Parameter | Horizontal_MainScale Summary


MainValue property of Gauge Parameter

MainValue Parameter

Sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.

Remarks

  • A gauge may display several values, for example a radial gauge may have multiple indicator needles. This property is used to configure the value displayed as the main value of a gauge object.

  • The MainIndicator method is used to obtain access to the main indicator.

Example

To set the MainValue to 7:

out-gauge -Type Horizontal -MainValue 7

See Also

Horizontal Parameter | Horizontal Summary


Modal property of gauge Parameter

Modal Parameter

Allows you to block the command pipe while displaying a gauge.

Remarks

  • Use Modal to block the command pipe while displaying a gauge.

Example

To create a gauge blocking the command pipe by configuinr the Modal parameter:

out-gauge -Type Horizontal -Modal

See Also

Horizontal Parameter | Horizontal Summary


Output property of gauge Parameter

Output Parameter

Allows you to generate a gauge file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a gauge file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate an Output image (.png) of the gauge:

out-gauge -Type Horizontal -Output test.png

See Also

Horizontal Parameter | Horizontal Summary


Palette property of BaseGauge Parameter

Palette Parameter

Allows you to set a Chart FX pre-defined palette.

Value | Meaning
Default | Set the palette to Default.
Alternate | Set the palette to Alternate.
Autumn | Set the palette to an Autumn scheme.
BrownSugar | Set the palette to a BrownSugar scheme.
ChartFX6 | Set the palette to the ChartFX 6 scheme.
Classic | Set the palette to Classic.
Colorful | Set the palette to a Colorful scheme.
DarkPastels | Set the palette to a DarkPastels scheme.
Earthtones | Set the palette to an Earthtones scheme.
HighContrast | Set the palette to a HighContrast scheme.
LilacsInMist | Set the palette to LilacsInMist scheme.
Mesa | Set the palette to Mesa scheme.
ModernBusiness | Set the palette to a ModernBusiness scheme.
NatureAdventure | Set the palette to a NatureAdventure scheme.
NatureSky | Set the palette to a NatureSky scheme.
Oceanica | Set the palette to Oceanica scheme.
Professional | Set the palette to a Professional scheme.
RainyDay | Set the palette to a RainyDay scheme.
SandAndSky | Set the palette to a SandAndSky scheme.
Simple | Set the palette to a Simple scheme.
Slate | Set the palette to Slate scheme.
SnowyPine | Set the palette to SnowyPine.
Vivid | Set the palette to a Vivid scheme.
Windows | Set the palette to a Windows scheme.

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as PowerGadgets will change the windows palette for the chart window. So if you previously set a color using any of the PowerGadgets supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Example

To set the Palette to NatureSky:

out-gauge -Type Horizontal -Palette NatureSky

See Also

Horizontal Parameter | Horizontal Summary


Refresh property of gauge Parameter

Refresh Parameter

Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.

Remarks

  • If the command returns a single value per each series, the gauge will add a new point to the end. Otherwise, the whole gauge data is replaced with the new data.

Example

To Refresh every 1 second the gauge populated with the processes (PS>get-process ):

ps | out-gauge -Type Horizontal -Refresh 0:0:1

See Also

Horizontal Parameter | Horizontal Summary


Scales_<index> property of LinearGauge Parameter

Scales_<index> Parameter

Returns the LinearScaleCollection for a linear gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The MainScale property is used to obtain the main scale for a selected LinearGauge.

Example

To set the Scales Color to Red

out-gauge -Type Horizontal -Scales_0_Color Red

See Also

Horizontal Parameter | Horizontal Summary


LinearScale Class Members

Horizontal_Scales Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
FillerVolume | Sets the Filler size within a Linear Gauge
Indicators | The collection of Indicators currently associated with the scale.
Inverted | Gets amd set a boolean flag to invert the scale
Layout | Gets the layout object for a LinearScale
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Sections | Returns the SectionCollection for a scale object.
Size | Sets the size for a Linear Scale.
Stripes | The collection of Stripes currently associated with the scale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar property of Scale Parameter

Scales_<index>_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the Scales Bar Color to Red:

out-gauge -Type Horizontal -Scales_0_Bar_Color Red

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


ScaleBar Class Members

Horizontal_Scales_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border property of ScaleBar Parameter

Scales_<index>_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Type Horizontal -Scales_0_Bar_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Horizontal_Scales_Bar Parameter | Horizontal_Scales_Bar Summary


BarBorder Class Members

Horizontal_Scales_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border_Color property of BaseColorable Parameter

Scales_<index>_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Bar Border Color

out-gauge -Type Horizontal -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Color Blue

See Also

Horizontal_Scales_Bar_Border Parameter | Horizontal_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Thickness property of BarBorder Parameter

Scales_<index>_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Type Horizontal -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Horizontal_Scales_Bar_Border Parameter | Horizontal_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Border Visible to false:

out-gauge -Type Horizontal -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Visible false

See Also

Horizontal_Scales_Bar_Border Parameter | Horizontal_Scales_Bar_Border Summary


Scales_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Horizontal_Scales_Bar Parameter | Horizontal_Scales_Bar Summary


Scales_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Visible to false:

out-gauge -Type Horizontal -Scales_0_Bar_Visible true -Scales_0_Bar_Visible false

See Also

Horizontal_Scales_Bar Parameter | Horizontal_Scales_Bar Summary


Scales_<index>_Color property of BaseColorable Parameter

Scales_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Color

out-gauge -Type Horizontal -Scales_0_Color Blue

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_CustomLabels property of Scale Parameter

Scales_<index>_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the Scales CustomLabels for the value '40':

out-gauge -Type Horizontal -Scales_0_CustomLabels_40 "Label at 40"

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_FillerVolume property of LinearScale Parameter

Scales_<index>_FillerVolume Parameter

Sets the Filler size within a Linear Gauge

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Example

To set the Scales FillerVolume to 25:;

out-gauge -Type Horizontal -Scales_0_FillerVolume 25

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Indicators_<index> property of Scale Parameter

Scales_<index>_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the Scales Indicators Color to AliceBlue:

out-gauge -Type Horizontal -Scales_0_Indicators_0_Color AliceBlue

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Marker Class Members

Horizontal_Scales_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Color Blue

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


ValueFormat Class Members

Horizontal_Scales_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Horizontal_Scales_Indicators_Marker_Format Parameter | Horizontal_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Horizontal_Scales_Indicators_Marker_Format Parameter | Horizontal_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_Scales_Indicators_Marker_Format Parameter | Horizontal_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Horizontal_Scales_Indicators_Marker_Format Parameter | Horizontal_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Label property of Marker Parameter

Scales_<index>_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the Scales Indicators Label Color:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Color Red

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


LabelAttributes Class Members

Horizontal_Scales_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_Label_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Label Color

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Color Blue

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Font property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Indicators Label Font to Arial 5:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Indicators Label Orientation to Tangent

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Orientation Tangent

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Position property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Position Bottom

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label PositionCustom to 5:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Custom -Scales_0_Indicators_0_Label_PositionCustom 5

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Label Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Visible false

See Also

Horizontal_Scales_Indicators_Marker_Label Parameter | Horizontal_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Position property of Marker Parameter

Scales_<index>_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Indicators Position to Bottom:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Position Bottom

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_PositionCustom property of Marker Parameter

Scales_<index>_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators PositionCustom:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Position Custom -Scales_0_Indicators_0_PositionCustom 0.05

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Size property of Marker Parameter

Scales_<index>_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the Scales Indicators Size to 5:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Size 5

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Snap 5

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Style property of Marker Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators Style to Marker02;

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Style Marker02

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Text property of Marker Parameter

Scales_<index>_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the Scales Indicators Text:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Text "My Value"

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Value 25

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Visible false

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Filler Class Members

Horizontal_Scales_Indicators_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Draggable | Sets a value indicating whether the indicator is movable via user interface.
DraggableCursor | Sets the mouse cursor displayed when dragging an indicator.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Color Blue

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Format_Decimals 3

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


ValueFormat Class Members

Horizontal_Scales_Indicators_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Horizontal_Scales_Indicators_Filler_Format Parameter | Horizontal_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Format_Decimals 3

See Also

Horizontal_Scales_Indicators_Filler_Format Parameter | Horizontal_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_Scales_Indicators_Filler_Format Parameter | Horizontal_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Horizontal_Scales_Indicators_Filler_Format Parameter | Horizontal_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Origin property of Filler Parameter

Scales_<index>_Indicators_<index>_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators Origin:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Origin OriginAtMin

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_OriginCustom property of Filler Parameter

Scales_<index>_Indicators_<index>_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators OriginCustom to 15:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_OriginCustom 15

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Snap 5

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Style property of Filler Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the Scales Indicators Style:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Style Filler02

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_UseFillerAsBar property of Filler Parameter

Scales_<index>_Indicators_<index>_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators UseFillerAsBar to true:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_UseFillerAsBar true

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Value 25

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Visible false

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Inverted property of LinearScale Parameter

Scales_<index>_Inverted Parameter

Gets amd set a boolean flag to invert the scale

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Example

To set the Scales Inverted to true:

out-gauge -Type Horizontal -Scales_0_Inverted true

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Layout property of LinearScale Parameter

Scales_<index>_Layout Parameter

Gets the layout object for a LinearScale

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Example

To set the Scales Layout Alignment to BottomCenter:

out-gauge -Type Horizontal -Scales_0_Layout_Alignment BottomCenter

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


LayoutAttributes Class Members

Horizontal_Scales_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Scales_<index>_Layout_Alignment property of LayoutAttributes Parameter

Scales_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Scales Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -Scales_0_Layout_Alignment MiddleCenter

See Also

Horizontal_Scales_Layout Parameter | Horizontal_Scales_Layout Summary


Scales_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Scales_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Scales Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -Scales_0_Layout_Target AnchorPoint -Scales_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_Scales_Layout Parameter | Horizontal_Scales_Layout Summary


Scales_<index>_Layout_Target property of LayoutAttributes Parameter

Scales_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_Scales_Layout Parameter | Horizontal_Scales_Layout Summary


Scales_<index>_Max property of Range Parameter

Scales_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Max to 50:

out-gauge -Type Horizontal -Scales_0_Max 50

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales MaxAlwaysDisplayed to false:

out-gauge -Type Horizontal -Scales_0_MaxAlwaysDisplayed false

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Min property of Range Parameter

Scales_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Min to 10:

out-gauge -Type Horizontal -Scales_0_Min 10

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales MinAlwaysDisplayed to false:

out-gauge -Type Horizontal -Scales_0_MinAlwaysDisplayed false

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Sections_<index> property of Scale Parameter

Scales_<index>_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the Scales Sections Color to Red:

out-gauge -Type Horizontal -Scales_0_Sections_0_Color Red

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Section Class Members

Horizontal_Scales_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar property of Section Parameter

Scales_<index>_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the Scales Sections Bar Color to Red:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Color Red

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


SectionBar Class Members

Horizontal_Scales_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Horizontal_Scales_Sections_Bar Parameter | Horizontal_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Bar Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Visible true -Scales_0_Sections_0_Bar_Visible false

See Also

Horizontal_Scales_Sections_Bar Parameter | Horizontal_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Color Blue

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Sections_<index>_Max property of Range Parameter

Scales_<index>_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Sections Max to 50:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 50

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MaxAlwaysDisplayed to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MaxAlwaysDisplayed false

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Sections_<index>_Min property of Range Parameter

Scales_<index>_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Sections Min to 10:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Min 10

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MinAlwaysDisplayed to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MinAlwaysDisplayed false

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Sections_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


TickmarkSet Class Members

Horizontal_Scales_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


ValueFormat Class Members

Horizontal_Scales_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_Scales_Sections_Tickmarks_Format Parameter | Horizontal_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Sections Tickmarks Format Decimals to 3:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Decimals 3

See Also

Horizontal_Scales_Sections_Tickmarks_Format Parameter | Horizontal_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_Scales_Sections_Tickmarks_Format Parameter | Horizontal_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Sections Tickmarks Format FormatType to Percentage

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Horizontal_Scales_Sections_Tickmarks_Format Parameter | Horizontal_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Sections Tickmarks Major size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 5

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Major Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Major Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Major Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Major_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 2.5

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Step to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Step 5

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Major Style:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Major Parameter | Horizontal_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Sections Tickmarks Medium size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 5

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Medium Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Step to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Step 5

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Medium Style:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Medium Parameter | Horizontal_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Sections Tickmarks Minor size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 5

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Minor Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Color

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Size to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Step to 5:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Step 5

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Minor Style:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks_Minor Parameter | Horizontal_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Visible false

See Also

Horizontal_Scales_Sections_Tickmarks Parameter | Horizontal_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Visible to false:

out-gauge -Type Horizontal -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Visible false

See Also

Horizontal_Scales_Sections Parameter | Horizontal_Scales_Sections Summary


Scales_<index>_Size property of LinearScale Parameter

Scales_<index>_Size Parameter

Sets the size for a Linear Scale.

Remarks

  • This property is used to control the size of the scale in a Linear Gauge.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

Example

To set the Scales Size to 0.75:

out-gauge -Type Horizontal -Scales_0_Size 0.75

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Stripes_<index> property of LinearScale Parameter

Scales_<index>_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the Scales Stripes Max to 30:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


LinearStrip Class Members

Horizontal_Scales_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Offset | Set the offset of a Strip respect ot the Scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_AlternateColor property of Strip Parameter

Scales_<index>_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the Scales Stripes AlternateColor to Yellow:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Gradient -Scales_0_Stripes_0_AlternateColor Yellow

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Border property of Strip Parameter

Scales_<index>_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the Scales Stripes Border Color to red:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Red

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


BarBorder Class Members

Horizontal_Scales_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_Border_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Border Color

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Blue

See Also

Horizontal_Scales_Stripes_Border Parameter | Horizontal_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Thickness property of BarBorder Parameter

Scales_<index>_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Stripes Border Thickness to 0.003:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Thickness 0.003

See Also

Horizontal_Scales_Stripes_Border Parameter | Horizontal_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Border Visible to false:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Visible false

See Also

Horizontal_Scales_Stripes_Border Parameter | Horizontal_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Color

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Color Blue

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_FillType property of Strip Parameter

Scales_<index>_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the Scales Stripes FillType to Gradient:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_AlternateColor Yellow -Scales_0_Stripes_0_FillType Gradient

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Max property of Range Parameter

Scales_<index>_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Stripes Max to 50:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 50

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Min property of Range Parameter

Scales_<index>_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Stripes Min to 10:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Min 10

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Offset property of LinearStrip Parameter

Scales_<index>_Stripes_<index>_Offset Parameter

Set the offset of a Strip respect ot the Scale.

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Example

To display a strip on the center of the main Sclale:

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Pattern property of Strip Parameter

Scales_<index>_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the Scales Stripes Pattern to BackwardDiagonal:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Pattern -Scales_0_Stripes_0_Pattern BackwardDiagonal

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Thickness property of Strip Parameter

Scales_<index>_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the Scales Stripes Thickness to 0.25:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Thickness 0.25

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

Scales_<index>_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Visible to false:

out-gauge -Type Horizontal -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Visible false

See Also

Horizontal_Scales_Stripes Parameter | Horizontal_Scales_Stripes Summary


Scales_<index>_Thickness property of Scale Parameter

Scales_<index>_Thickness Parameter

Sets the width for a scale.

Example

To set the Scales Thickness to 0.05:

out-gauge -Type Horizontal -Scales_0_Thickness 0.05

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Scales_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


TickmarkSet Class Members

Horizontal_Scales_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Color Blue

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


Scales_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


ValueFormat Class Members

Horizontal_Scales_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Horizontal_Scales_Tickmarks_Format Parameter | Horizontal_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Tickmarks Format Decimals to 3:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Format_Decimals 3

See Also

Horizontal_Scales_Tickmarks_Format Parameter | Horizontal_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Horizontal_Scales_Tickmarks_Format Parameter | Horizontal_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Tickmarks Format FormatType to Percentage

out-gauge -Type Horizontal -Scales_0_Tickmarks_Format_FormatType Percentage

See Also

Horizontal_Scales_Tickmarks_Format Parameter | Horizontal_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Tickmarks Major size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Size 5

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Color Blue

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Major Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Color Red

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


LabelAttributes Class Members

Horizontal_Scales_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Label Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Color Blue

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Major Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Major Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Custom -Scales_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Visible false

See Also

Horizontal_Scales_Tickmarks_Major_Label Parameter | Horizontal_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Position Custom -Scales_0_Tickmarks_Major_PositionCustom 0.2

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Size 2.5

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Step to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Step 5

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Major Style:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Style Tickmark10_3

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Major_Visible false

See Also

Horizontal_Scales_Tickmarks_Major Parameter | Horizontal_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Tickmarks Medium size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Size 5

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Color Blue

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Medium Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Color Red

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


LabelAttributes Class Members

Horizontal_Scales_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Label Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Color Blue

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Visible false

See Also

Horizontal_Scales_Tickmarks_Medium_Label Parameter | Horizontal_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Position Custom -Scales_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Size 2.5

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Step to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Step 5

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Medium Style:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Medium_Visible false

See Also

Horizontal_Scales_Tickmarks_Medium Parameter | Horizontal_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Tickmarks Minor size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Size 5

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


Tickmark Class Members

Horizontal_Scales_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Color Blue

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Minor Label Color to Red:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Color Red

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


LabelAttributes Class Members

Horizontal_Scales_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Label Color

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Color Blue

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Label Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Visible false

See Also

Horizontal_Scales_Tickmarks_Minor_Label Parameter | Horizontal_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Position to Bottom:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Position Bottom

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor PositionCustom to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Position Custom -Scales_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Size to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Size 2.5

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Step to 5:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Step 5

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Minor Style:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Minor_Visible false

See Also

Horizontal_Scales_Tickmarks_Minor Parameter | Horizontal_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Visible to false:

out-gauge -Type Horizontal -Scales_0_Tickmarks_Visible false

See Also

Horizontal_Scales_Tickmarks Parameter | Horizontal_Scales_Tickmarks Summary


Scales_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Visible to false:

out-gauge -Type Horizontal -Scales_0_Visible false

See Also

Horizontal_Scales Parameter | Horizontal_Scales Summary


Shadow property of Gauge Parameter

Shadow Parameter

Sets a value indicating to whether to display a shadow in a gauge.

Default Value
The default is None.

Value | Meaning
None | No shadow effect.
Plain | A plain shadow effect.
Realistic | A realistic shadow effect.

Example

To set the Shadow to Realistic:

out-gauge -Type Horizontal -Shadow Realistic

See Also

Horizontal Parameter | Horizontal Summary


Size property of gauge Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered gauge.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered gauge.

Example

To configure the Size of the gauge:

out-gauge -Type Horizontal -Size 800,600

See Also

Horizontal Parameter | Horizontal Summary


Style property of gauge Parameter

Style Parameter

Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.

Remarks

  • There are 10 different styles for radial gauges: Style 0 through Style 10.

  • Styles do not include color settings, thus palette colors are used.

Example

To set the Style parameter to use the fourth style:

out-gauge -Type Horizontal -Style 4

See Also

Horizontal Parameter | Horizontal Summary


Template property of gauge Parameter

Template Parameter

Allows you to use or save gauge modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

Example

To use a pre-configured template called MyProcesses:

out-gauge -template MyProcesses

To use a graphical Wizard to configure a Tamplate gauge:

out-gauge -configure -template MyProcesses

See Also

Horizontal Parameter | Horizontal Summary


Titles_<index> property of BaseGauge Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set the Titles Color to Red:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Horizontal Parameter | Horizontal Summary


Title Class Members

Horizontal_Titles Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Color | Sets the color of text for the specified title.
Font | Sets the Gauge Font object for a gauge title.
Layout | Allows you to access the layout object for an Annotation.
Text | Sets the text for the selected title.
Visible | Sets a value indicating whether an object is visible or not.


Titles_<index>_Angle property of Annotation Parameter

Titles_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Titles Angle to 45 degrees:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Angle 45

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


Titles_<index>_Color property of Title Parameter

Titles_<index>_Color Parameter

Sets the color of text for the specified title.

Remarks

  • The Text propety is used to set the caption for a title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles Color to Red:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Sets the Gauge Font object for a gauge title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Titles Font:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Font "Arial, 5"

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


Titles_<index>_Layout property of Annotation Parameter

Titles_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


LayoutAttributes Class Members

Horizontal_Titles_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Titles_<index>_Layout_Alignment property of LayoutAttributes Parameter

Titles_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Titles Layout Alignment to the MiddleCenter:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Layout_Alignment MiddleCenter

See Also

Horizontal_Titles_Layout Parameter | Horizontal_Titles_Layout Summary


Titles_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Titles_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Titles Layout AnchorPoint to a specific position:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Layout_Target AnchorPoint -Titles_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Horizontal_Titles_Layout Parameter | Horizontal_Titles_Layout Summary


Titles_<index>_Layout_Target property of LayoutAttributes Parameter

Titles_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Horizontal_Titles_Layout Parameter | Horizontal_Titles_Layout Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To set the Titles Text:

out-gauge -Type Horizontal -Titles_0_Text "My Text"

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


Titles_<index>_Visible property of BaseViewable Parameter

Titles_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Titles Visible to false:

out-gauge -Type Horizontal -Titles_0_Text "My Text" -Titles_0_Visible false

See Also

Horizontal_Titles Parameter | Horizontal_Titles Summary


ToolTip property of BaseGauge Parameter

ToolTip Parameter

Sets the tool tip text.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

  • The ToolTipEnabled property may be used to control whether or not a tool tip will be diplayed for a gauge.

Example

To set the ToolTip:

out-gauge -Type Horizontal -ToolTip "My Text"

See Also

Horizontal Parameter | Horizontal Summary


ToolTipEnabled property of BaseGauge Parameter

ToolTipEnabled Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Remarks

  • Tooltips allow the user to easily recognize the appropriate PowerGadgets element.

Example

To set the ToolTipEnabled to false:

out-gauge -Type Horizontal -ToolTipEnabled false

See Also

Horizontal Parameter | Horizontal Summary


Type property of gauge Parameter

Type Parameter

Allows you to specify the gauge type (Radial, Horizontal, Vertical and Digital).

Remarks

  • Use the Type parameter to specify the Gauge Type. This are the types: Radial, Horizontal, Vertical and Digital.

  • If the Type parameter is not configured the gauge Type would be Radial.

Example

To configure the Type parameter to get a Horizontal:

out-gauge -Type Horizontal

To configure the Type parameter to get a Vertical:

out-gauge -Type Vertical

To configure the Type parameter to get a Digital:

out-gauge -Type Digital

See Also

Horizontal Parameter | Horizontal Summary


Value property of gauge Parameter

Value Parameter

Allows you to specify which propertie to plot in the gauge.

Remarks

  • Use the Value parameter to specifie which property must be used as indicator. Only a numeric property can be used.

Example

To specify the Handles as Value in a gauge populated with the processes (PS>get-process ):

ps | out-gauge -Type Horizontal -Value Handles

See Also

Horizontal Parameter | Horizontal Summary


VerticalGauge Parameter

Remarks

A LinearGauge includes scales that may be configured in a vertical or horizontal position. Supported members of the LinearGauge class allow developers to configure a border, scale orientation, flip the gradient color scheme and access to the scale and indicator objects. Below is an example of a LinearGauge.


VerticalGauge Class Members

Vertical Parameters

Parameters

Description

Anchor | Allows you to specify the general location of the gauge with respect to your desktop.
Antialiasing | Sets the smooth visual effect for a gauge.
Border | Returns the LinearBorder object for a linear gauge.
Caption | Modifies the caption used in the PowerGadget window
Configure | Allows you to use a graphical Wizard to customize the gauge.
Culture | Allows you to localize gauges for a specific language and region.
Floating | Allows you to launch a gauge without a window frame.
Font | Sets the font type which will be used by default in the gauge.
Glass | Allows you to configure the gauge background to be painted using Glass form.
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Images | Allows you to accesss the images for a gauge.
InnerGauges | The collection of InnerGauges currently associated with the gauge.
MainIndicator | Sets the main Indicator. The available indicators for a are the and the . As for the , the and the are the two possible types of indicators.
MainScale | Returns the main scale of a linear gauge.
MainValue | Sets the main value for a gauge. It is a shortcut to the value of the .
Modal | Allows you to block the command pipe while displaying a gauge.
Output | Allows you to generate a gauge file instead of an interactive one.
Palette | Allows you to set a PowerGadgets pre-defined palette.
Refresh | Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.
Scales | Returns the LinearScaleCollection for a linear gauge.
Shadow | Sets a value indicating to whether to display a shadow in a gauge.
Size | Allows you to specify the actual dimension of the final rendered gauge.
Style | Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.
Template | Allows you to use or save gauge modifications into a template file.
Titles | Returns the collection of titles defined in the gauge.
ToolTip | Sets the tool tip text.
ToolTipEnabled | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.
Value | Allows you to specify which property to plot in the gauge.

@2006 PowerGadgets, LLC. All Rights Reserved. PowerGadgets is a registered trademark of PowerGadgets, LLC


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the gauge with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the Anchor parameter to TopRight:

out-gauge -Type Vertical -Anchor TopRight

See Also

Vertical Parameter | Vertical Summary


Antialiasing property of BaseGauge Parameter

Antialiasing Parameter

Sets the smooth visual effect for a gauge.

Default Value
The default is All.

Value | Meaning
None | No smoothing applied.
Text | Smoothing applied to text objects only.
Graphic | Smoothing applied to graphic objects only.
All | Smoothing applied to all gauge elements.

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Example

To set the Antialiasing property for a gauge to None:

out-gauge -Type Vertical -Antialiasing None

See Also

Vertical Parameter | Vertical Summary


Border property of LinearGauge Parameter

Border Parameter

Returns the LinearBorder object for a linear gauge.

Remarks

  • The Linear Border is the outer frame encasing a linear gauge. The Style property may be used to configure any of the supported Linear Border Style types.

Example

To set the Border Style to LinearBorder01:

out-gauge -Type Vertical -Border_Style LinearBorder01

See Also

Vertical Parameter | Vertical Summary


LinearBorder Class Members

Vertical_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Glare | Sets a value indicating whether to use a lighting effect for a border.
InsideColor | Sets the inside color for a gauge border.
InsideEffects | Enables or disables border shadow and gradient.
Inverted | Set a property to invert the Border of a Linear Gauge
Style | Sets the style for a LinearBorder object.
Visible | Sets a value indicating whether an object is visible or not.


Border_Color property of BaseColorable Parameter

Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border Color

out-gauge -Type Vertical -Border_Color Blue

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_Glare property of Border Parameter

Border_Glare Parameter

Sets a value indicating whether to use a lighting effect for a border.

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

Example

To turn on the Border Glare effect for a gauge:

out-gauge -Type Vertical -Border_Glare false

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_InsideColor property of Border Parameter

Border_InsideColor Parameter

Sets the inside color for a gauge border.

Remarks

  • This property is used to configure the inner color value for a Border object.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border InsideColor

out-gauge -Type Vertical -Border_InsideColor Red

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_InsideEffects property of Border Parameter

Border_InsideEffects Parameter

Enables or disables border shadow and gradient.

Remarks

  • A natural gradient is applied when there is no specific background image.

Example

To Disable the Border InsideEffects:

out-gauge -Type Vertical -Border_InsideEffects false

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_Inverted property of LinearBorder Parameter

Border_Inverted Parameter

Set a property to invert the Border of a Linear Gauge

Remarks

  • The following is a HorizontalGauge with Inverted = false:

  • The following is the same HorizontalGauge with Inverted = true:

Example

To set the Border Inverted to false:

out-gauge -Type Vertical -Border_Inverted false

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_Style property of LinearBorder Parameter

Border_Style Parameter

Sets the style for a LinearBorder object.

Value | Meaning
LinearBorder01 | Set the border style to LinearBorder01.
LinearBorder02 | Set the border style to LinearBorder02.
LinearBorder03 | Set the border style to LinearBorder03.
LinearBorder04 | Set the border style to LinearBorder04.
LinearBorder05 | Set the border style to LinearBorder05.
LinearBorder06 | Set the border style to LinearBorder06.
LinearBorder07 | Set the border style to LinearBorder07.
LinearBorder08 | Set the border style to LinearBorder08.
LinearBorder09 | Set the border style to LinearBorder09.
LinearBorder10 | Set the border style to LinearBorder10.
LinearBorder11 | Set the border style to LinearBorder11.
LinearBorder12 | Set the border style to LinearBorder12.
LinearBorder13 | Set the border style to LinearBorder13.
LinearBorder14 | Set the border style to LinearBorder14.
LinearBorder15 | Set the border style to LinearBorder15.
LinearBorder16 | Set the border style to LinearBorder16.
LinearBorder17 | Set the border style to LinearBorder17.
Thermometer01 | Set the border style to Thermometer01.
Thermometer02 | Set the border style to Thermometer02.
Thermometer03 | Set the border style to Thermometer03.

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. This property may be used to configure any of the supported LinearBorderStyle enumeration types.

Example

To set the Border Style to Thermometer:

out-gauge -Type Vertical -Border_Style Thermometer01

See Also

Vertical_Border Parameter | Vertical_Border Summary


Border_Visible property of BaseViewable Parameter

Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Border Visible to false:

out-gauge -Type Vertical -Border_Visible false

See Also

Vertical_Border Parameter | Vertical_Border Summary


Caption property of gauge Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the Caption in the PowerGadget window:

out-gauge -Type Vertical -Caption "My PowerGadget"

See Also

Vertical Parameter | Vertical Summary


Configure property of gauge Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the gauge.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

  • This Wizard has two tabs, one called gauge Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the gauge Wizard tab.

Example

To use a graphical wizard to Configure the gauge:

out-gauge -Type Vertical -Configure

See Also

Vertical Parameter | Vertical Summary


Culture property of BaseGauge Parameter

Culture Parameter

Allows you to localize gauges for a specific language and region.

Remarks

  • Culture attributes set with this property will effect the entire gauge, if no attributes are set using this property then PowerGadgets inherits the current Thread culture.

Example

To set the Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -Culture "es-ES"

See Also

Vertical Parameter | Vertical Summary


DrillDown Class Members

Vertical_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-gauge.

Example

To use the DrillDown_Script parameter:

ps | out-gauge -DrillDown_Script ProcessDetails.ps1 -DrillDown_Parameter {$_.Id}

See Also

Vertical_DrillDown Parameter | Vertical_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

  • In most cases this parameter is not necessary when implementing drilldown with gauges.

Example

To use the DrillDown_Parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName}

See Also

Vertical_DrillDown Parameter | Vertical_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName} -DrillDown_Script get-process -DrillDown_Console

See Also

Vertical_DrillDown Parameter | Vertical_DrillDown Summary


Floating property of gauge Parameter

Floating Parameter

Allows you to launch a gauge without a window frame.

Remarks

  • Use Floating to launch a gauge without a window frame making the gauge appear as it were floating over the desktop.

Example

To launch a gauge without a window frame configuring the Floating parameter:

out-gauge -Type Vertical -Floating

See Also

Vertical Parameter | Vertical Summary


Font property of BaseGauge Parameter

Font Parameter

Sets the font type which will be used by default in the gauge.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To configure the Font

out-gauge -Type Vertical -Font "Arial, 5"

See Also

Vertical Parameter | Vertical Summary


Glass property of gauge Parameter

Glass Parameter

Allows you to configure the gauge background to b painted using Glass form.

Remarks

  • When running in Windows Vista, the chart background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-gauge -Type Vertical -Glass

See Also

Vertical Parameter | Vertical Summary


HideFromAltTab property of BaseGauge Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-gauge -Type Vertical -HideFromAltTab

See Also

Vertical Parameter | Vertical Summary


Images_<index> property of BaseGauge Parameter

Images_<index> Parameter

Allows you to accesss the images for a gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • You'll have to add an image item ("Bitmap" or "Vector") in order to configure a particular Image:

    -Images_Add Bitmap or -Images_Add Vector.

  • This parameter allows you to configure a particular image. You may also specifying an index value to access a specific image item in Gauge.

Example

To add and configure a Images angle:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 10

See Also

Vertical Parameter | Vertical Summary


BitmapImage Class Members

Vertical_Images Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Image | Represents the actual Image object in the gauge.
Layout | Allows you to access the layout object for an Annotation.
Size | A numeric size modifier applied in conjunction with a Custom setting.
SizeMode | Defines the display size options for the background image.
Visible | Sets a value indicating whether an object is visible or not.


Images_<index>_Angle property of Annotation Parameter

Images_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Images Angle to 45 degrees:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 45

See Also

Vertical_Images Parameter | Vertical_Images Summary


Images_<index>_Image property of BitmapImage Parameter

Images_<index>_Image Parameter

Represents the actual Image object in the gauge.

Remarks

  • Images that are larger than the gauge are not automatically scaled.

  • Use the Image parameter to configure the image path.

Example

Here is an example of setting the Images Image

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png"

See Also

Vertical_Images Parameter | Vertical_Images Summary


Images_<index>_Layout property of Annotation Parameter

Images_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_Images Parameter | Vertical_Images Summary


LayoutAttributes Class Members

Vertical_Images_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Images_<index>_Layout_Alignment property of LayoutAttributes Parameter

Images_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Images Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Alignment MiddleCenter

See Also

Vertical_Images_Layout Parameter | Vertical_Images_Layout Summary


Images_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Images_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Images Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Target AnchorPoint -Images_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_Images_Layout Parameter | Vertical_Images_Layout Summary


Images_<index>_Layout_Target property of LayoutAttributes Parameter

Images_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_Images_Layout Parameter | Vertical_Images_Layout Summary


Images_<index>_Size property of BaseImage Parameter

Images_<index>_Size Parameter

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Example

To set the Images Size:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Custom -Images_0_Size 1.2

See Also

Vertical_Images Parameter | Vertical_Images Summary


Images_<index>_SizeMode property of BaseImage Parameter

Images_<index>_SizeMode Parameter

Defines the display size options for the background image.

Default Value
The default is Normal.

Value | Meaning
Normal | The image is placed in the center of the container, in its original size. The image is clipped if it is larger than the container.
Stretch | The image is stretched or shrunk to fit the size of the container.
Custom | The image size will be custom set by the Size property.

Remarks

  • When using the Custom value a size can be specified using the Size property.

Example

To set the Images SizeMode to Stretch:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Stretch

See Also

Vertical_Images Parameter | Vertical_Images Summary


Images_<index>_Visible property of BaseViewable Parameter

Images_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Images Visible to false:

out-gauge -Type Vertical -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Visible false

See Also

Vertical_Images Parameter | Vertical_Images Summary


InnerGauges_<index> property of BaseGauge Parameter

InnerGauges_<index> Parameter

The collection of InnerGauges currently associated with the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

See Also

Vertical Parameter | Vertical Summary


InnerDigitalPanel Class Members

Vertical_InnerGauges_InnerDigitalPanel Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
DigitalPanel | Returns the DigitalPanel object for an inner digital meter.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_Angle 45

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_DigitalPanel property of InnerDigitalPanel Parameter

InnerGauges_<index>_DigitalPanel Parameter

Returns the DigitalPanel object for an inner digital meter.

Remarks

  • This property is used to return the DigitalPanel object for an inner digital Panel. For additional information regarding supported members, please see the Parameter.

Example

To configure the InnerGauges DigitalPanel Font:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_DigitalPanel_Font "Arial, 5"

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


LayoutAttributes Class Members

Vertical_InnerGauges_InnerDigitalPanel_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Vertical_InnerGauges_InnerDigitalPanel_Layout Parameter | Vertical_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_InnerGauges_InnerDigitalPanel_Layout Parameter | Vertical_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_InnerGauges_InnerDigitalPanel_Layout Parameter | Vertical_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_LinkToMainValue true

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_Size "0.3, 0.5"

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Vertical -InnerGauges_Add Digital -InnerGauges_0_Visible false

See Also

Vertical_InnerGauges_InnerDigitalPanel Parameter | Vertical_InnerGauges_InnerDigitalPanel Summary


InnerHorizontalGauge Class Members

Vertical_InnerGauges_InnerHorizontalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
HorizontalGauge | Exposes the HorizontalGauge properties of the InnerGauge.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_Angle 45

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_HorizontalGauge property of InnerHorizontalGauge Parameter

InnerGauges_<index>_HorizontalGauge Parameter

Exposes the HorizontalGauge properties of the InnerGauge.

Remarks

  • This property is used to return the HorizontalGauge object for an inner horizontal gauge. For additional information regarding supported members, please see the Parameter.

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Vertical_InnerGauges_InnerHorizontalGauge_Layout Parameter | Vertical_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_InnerGauges_InnerHorizontalGauge_Layout Parameter | Vertical_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_InnerGauges_InnerHorizontalGauge_Layout Parameter | Vertical_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_LinkToMainValue true

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_Size "0.3, 0.5"

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Vertical -InnerGauges_Add Horizontal -InnerGauges_0_Visible false

See Also

Vertical_InnerGauges_InnerHorizontalGauge Parameter | Vertical_InnerGauges_InnerHorizontalGauge Summary


InnerRadialGauge Class Members

Vertical_InnerGauges_InnerRadialGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
RadialGauge | Returns the RadialGauge object for an inner radial gauge.
Size | Sets the InnerGauge size
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_Angle 45

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


LayoutAttributes Class Members

Vertical_InnerGauges_InnerRadialGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Vertical_InnerGauges_InnerRadialGauge_Layout Parameter | Vertical_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_InnerGauges_InnerRadialGauge_Layout Parameter | Vertical_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_InnerGauges_InnerRadialGauge_Layout Parameter | Vertical_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_LinkToMainValue true

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_RadialGauge property of InnerRadialGauge Parameter

InnerGauges_<index>_RadialGauge Parameter

Returns the RadialGauge object for an inner radial gauge.

Remarks

  • This property is used to return the RadialGauge object for an inner radial gauge. For additional information regarding supported members, please see the Parameter.

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Size property of InnerRadialGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the InnerGauge size

Remarks

  • The InnerGauge is scaled based on the value provided in this property. A value of 2.0 or greater will scale the InnerGauge larger than the Main Gauge.

Example

To set the InnerGauges Size value for a Inner Radial Gauge:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_Size 0.4

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Vertical -InnerGauges_Add Radial -InnerGauges_0_Visible false

See Also

Vertical_InnerGauges_InnerRadialGauge Parameter | Vertical_InnerGauges_InnerRadialGauge Summary


InnerVerticalGauge Class Members

Vertical_InnerGauges_InnerVerticalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
VerticalGauge | Returns the LinearGauge object for an inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_Angle 45

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


LayoutAttributes Class Members

Vertical_InnerGauges_InnerVerticalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Vertical_InnerGauges_InnerVerticalGauge_Layout Parameter | Vertical_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_InnerGauges_InnerVerticalGauge_Layout Parameter | Vertical_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_InnerGauges_InnerVerticalGauge_Layout Parameter | Vertical_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_LinkToMainValue true

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_Size "0.3, 0.5"

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_VerticalGauge property of InnerVerticalGauge Parameter

InnerGauges_<index>_VerticalGauge Parameter

Returns the LinearGauge object for an inner linear gauge.

Remarks

  • This property is used to return the LinearGauge object for an inner linear gauge. For additional information regarding supported members, please see the Parameter.

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Vertical -InnerGauges_Add Vertical -InnerGauges_0_Visible false

See Also

Vertical_InnerGauges_InnerVerticalGauge Parameter | Vertical_InnerGauges_InnerVerticalGauge Summary


Location property of gauge Parameter

Location Parameter

Allows you to configure the gauge's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a Location for the gauge:

out-gauge -Type Vertical -Location 10,10

See Also

Vertical Parameter | Vertical Summary


MainIndicator property of Gauge Parameter

MainIndicator Parameter

Sets the main Indicator. The available indicators for a RadialGauge are the Needle and the Marker. As for the LinearGauge, the Filler and the Marker are the two possible types of indicators.

Remarks

  • A gauge may have many indicators, however only one MainIndicator.

  • The MainValue property is used to obtain the value of the MainIndicator.

Example

To set the MainIndicator Vale to 35:

out-gauge -Type Vertical -MainIndicator_Value 35

See Also

Vertical Parameter | Vertical Summary


Marker Class Members

Vertical_MainIndicator_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_AnimationSpan 0:0:2

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Color Blue

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


ValueFormat Class Members

Vertical_MainIndicator_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Format_Culture "es-ES"

See Also

Vertical_MainIndicator_Marker_Format Parameter | Vertical_MainIndicator_Marker_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Format_Decimals 3

See Also

Vertical_MainIndicator_Marker_Format Parameter | Vertical_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainIndicator_Marker_Format Parameter | Vertical_MainIndicator_Marker_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Format_FormatType Percentage

See Also

Vertical_MainIndicator_Marker_Format Parameter | Vertical_MainIndicator_Marker_Format Summary


MainIndicator_Label property of Marker Parameter

MainIndicator_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainIndicator Label Color:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Color Red

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


LabelAttributes Class Members

Vertical_MainIndicator_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_Label_Color property of BaseColorable Parameter

MainIndicator_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Label Color

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Color Blue

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Label_Font property of LabelAttributes Parameter

MainIndicator_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainIndicator Label Font to Arial 5:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Font "Arial, 5"

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Label_Orientation property of LabelAttributes Parameter

MainIndicator_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainIndicator Label Orientation to Tangent

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Orientation Tangent

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Label_Position property of LabelAttributes Parameter

MainIndicator_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Position Bottom

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Label_PositionCustom property of LabelAttributes Parameter

MainIndicator_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainIndicator Label PositionCustom to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Custom -MainIndicator_Label_PositionCustom 5

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Label_Visible property of BaseViewable Parameter

MainIndicator_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Label Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Label_Visible true -MainIndicator_Label_Position Bottom -MainIndicator_Label_Visible false

See Also

Vertical_MainIndicator_Marker_Label Parameter | Vertical_MainIndicator_Marker_Label Summary


MainIndicator_Position property of Marker Parameter

MainIndicator_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainIndicator Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Position Bottom

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_PositionCustom property of Marker Parameter

MainIndicator_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator PositionCustom:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Position Custom -MainIndicator_PositionCustom 0.05

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Size property of Marker Parameter

MainIndicator_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainIndicator Size to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Size 5

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Snap 5

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Style property of Marker Parameter

MainIndicator_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainIndicator Style to Marker02;

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Style Marker02

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Text property of Marker Parameter

MainIndicator_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainIndicator Text:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Text "My Value"

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Value 25

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_VerticalPosition BehindTickmarks

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -MainIndicator_Visible false

See Also

Vertical_MainIndicator_Marker Parameter | Vertical_MainIndicator_Marker Summary


Filler Class Members

Vertical_MainIndicator_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainIndicator_AnimationSpan property of Indicator Parameter

MainIndicator_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainIndicator AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_AnimationSpan 0:0:2

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Color property of BaseColorable Parameter

MainIndicator_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainIndicator Color

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Color Blue

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Format property of Indicator Parameter

MainIndicator_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Format_Decimals 3

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


ValueFormat Class Members

Vertical_MainIndicator_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainIndicator_Format_Culture property of ValueFormat Parameter

MainIndicator_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainIndicator Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Format_Culture "es-ES"

See Also

Vertical_MainIndicator_Filler_Format Parameter | Vertical_MainIndicator_Filler_Format Summary


MainIndicator_Format_Decimals property of ValueFormat Parameter

MainIndicator_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainIndicator Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Format_Decimals 3

See Also

Vertical_MainIndicator_Filler_Format Parameter | Vertical_MainIndicator_Filler_Format Summary


MainIndicator_Format_FormatCustom property of ValueFormat Parameter

MainIndicator_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainIndicator_Filler_Format Parameter | Vertical_MainIndicator_Filler_Format Summary


MainIndicator_Format_FormatType property of ValueFormat Parameter

MainIndicator_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainIndicator Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Format_FormatType Percentage

See Also

Vertical_MainIndicator_Filler_Format Parameter | Vertical_MainIndicator_Filler_Format Summary


MainIndicator_Origin property of Filler Parameter

MainIndicator_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator Origin:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Origin OriginAtMin

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_OriginCustom property of Filler Parameter

MainIndicator_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator OriginCustom to 15:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_OriginCustom 15

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Snap property of Indicator Parameter

MainIndicator_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainIndicator Snap to 5:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Snap 5

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Style property of Filler Parameter

MainIndicator_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the MainIndicator Style:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Style Filler02

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_ToolTip property of Indicator Parameter

MainIndicator_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_UseFillerAsBar property of Filler Parameter

MainIndicator_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainIndicator UseFillerAsBar to true:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_UseFillerAsBar true

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_UseRangeColor property of Indicator Parameter

MainIndicator_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Value property of Indicator Parameter

MainIndicator_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainIndicator Valueto 25:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Value 25

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_VerticalPosition property of Indicator Parameter

MainIndicator_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainIndicator VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_VerticalPosition BehindTickmarks

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainIndicator_Visible property of BaseViewable Parameter

MainIndicator_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainIndicator Visible to false:

out-gauge -Type Vertical -MainIndicator Filler -MainIndicator_Visible false

See Also

Vertical_MainIndicator_Filler Parameter | Vertical_MainIndicator_Filler Summary


MainScale property of LinearGauge Parameter

MainScale Parameter

Returns the main scale of a linear gauge.

Remarks

  • A scale for a linear gauge is the range of values which a gauge can indicate a value. The indicator marks a value in a given scale.

  • The Scales property may be used to obtain the LinearScaleCollection for a linear gauge. The MainScale property is used to return the main scale object in the collection. By default, the main scale is the first scale of the collection.

Example

To set the MainScale Max to 200

out-gauge -Type Vertical -MainScale_Max 200

See Also

Vertical Parameter | Vertical Summary


LinearScale Class Members

Vertical_MainScale Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
FillerVolume | Sets the Filler size within a Linear Gauge
Indicators | The collection of Indicators currently associated with the scale.
Inverted | Gets amd set a boolean flag to invert the scale
Layout | Gets the layout object for a LinearScale
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Sections | Returns the SectionCollection for a scale object.
Size | Sets the size for a Linear Scale.
Stripes | The collection of Stripes currently associated with the scale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar property of Scale Parameter

MainScale_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the MainScale Bar Color to Red:

out-gauge -Type Vertical -MainScale_Bar_Color Red

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


ScaleBar Class Members

Vertical_MainScale_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border property of ScaleBar Parameter

MainScale_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -Type Vertical -MainScale_Bar_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Vertical_MainScale_Bar Parameter | Vertical_MainScale_Bar Summary


BarBorder Class Members

Vertical_MainScale_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Bar_Border_Color property of BaseColorable Parameter

MainScale_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Bar Border Color

out-gauge -Type Vertical -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Color Blue

See Also

Vertical_MainScale_Bar_Border Parameter | Vertical_MainScale_Bar_Border Summary


MainScale_Bar_Border_Thickness property of BarBorder Parameter

MainScale_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Bar Border Thickness to 0.003:

out-gauge -Type Vertical -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Thickness 0.003

See Also

Vertical_MainScale_Bar_Border Parameter | Vertical_MainScale_Bar_Border Summary


MainScale_Bar_Border_Visible property of BaseViewable Parameter

MainScale_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Border Visible to false:

out-gauge -Type Vertical -MainScale_Bar_Border_Visible true -MainScale_Bar_Border_Visible false

See Also

Vertical_MainScale_Bar_Border Parameter | Vertical_MainScale_Bar_Border Summary


MainScale_Bar_Color property of BaseSectionBar Parameter

MainScale_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Vertical_MainScale_Bar Parameter | Vertical_MainScale_Bar Summary


MainScale_Bar_Visible property of BaseViewable Parameter

MainScale_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Bar Visible to false:

out-gauge -Type Vertical -MainScale_Bar_Visible true -MainScale_Bar_Visible false

See Also

Vertical_MainScale_Bar Parameter | Vertical_MainScale_Bar Summary


MainScale_Color property of BaseColorable Parameter

MainScale_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Color

out-gauge -Type Vertical -MainScale_Color Blue

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_CustomLabels property of Scale Parameter

MainScale_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the MainScale CustomLabels for the value '40':

out-gauge -Type Vertical -MainScale_CustomLabels_40 "Label at 40"

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_FillerVolume property of LinearScale Parameter

MainScale_FillerVolume Parameter

Sets the Filler size within a Linear Gauge

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Example

To set the MainScale FillerVolume to 25:;

out-gauge -Type Vertical -MainScale_FillerVolume 25

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Indicators_<index> property of Scale Parameter

MainScale_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the MainScale Indicators Color to AliceBlue:

out-gauge -Type Vertical -MainScale_Indicators_0_Color AliceBlue

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


Marker Class Members

Vertical_MainScale_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Color Blue

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


ValueFormat Class Members

Vertical_MainScale_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Vertical_MainScale_Indicators_Marker_Format Parameter | Vertical_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Format_Decimals 3

See Also

Vertical_MainScale_Indicators_Marker_Format Parameter | Vertical_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainScale_Indicators_Marker_Format Parameter | Vertical_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Vertical_MainScale_Indicators_Marker_Format Parameter | Vertical_MainScale_Indicators_Marker_Format Summary


MainScale_Indicators_<index>_Label property of Marker Parameter

MainScale_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the MainScale Indicators Label Color:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Color Red

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


LabelAttributes Class Members

Vertical_MainScale_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_Label_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Label Color

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Color Blue

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Font property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Indicators Label Font to Arial 5:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Indicators Label Orientation to Tangent

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Orientation Tangent

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Position property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Position Bottom

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Indicators Label PositionCustom to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Custom -MainScale_Indicators_0_Label_PositionCustom 5

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Label_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Label Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Label_Visible true -MainScale_Indicators_0_Label_Position Bottom -MainScale_Indicators_0_Label_Visible false

See Also

Vertical_MainScale_Indicators_Marker_Label Parameter | Vertical_MainScale_Indicators_Marker_Label Summary


MainScale_Indicators_<index>_Position property of Marker Parameter

MainScale_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Indicators Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Position Bottom

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_PositionCustom property of Marker Parameter

MainScale_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators PositionCustom:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Position Custom -MainScale_Indicators_0_PositionCustom 0.05

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Size property of Marker Parameter

MainScale_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the MainScale Indicators Size to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Size 5

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Snap 5

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Style property of Marker Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the MainScale Indicators Style to Marker02;

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Style Marker02

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Text property of Marker Parameter

MainScale_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the MainScale Indicators Text:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Text "My Value"

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Value 25

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -MainScale_Indicators_0_Visible false

See Also

Vertical_MainScale_Indicators_Marker Parameter | Vertical_MainScale_Indicators_Marker Summary


Filler Class Members

Vertical_MainScale_Indicators_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Indicators_<index>_AnimationSpan property of Indicator Parameter

MainScale_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the MainScale Indicators AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_AnimationSpan 0:0:2

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Color property of BaseColorable Parameter

MainScale_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Indicators Color

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Color Blue

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Format property of Indicator Parameter

MainScale_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Format_Decimals 3

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


ValueFormat Class Members

Vertical_MainScale_Indicators_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Indicators_<index>_Format_Culture property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Format_Culture "es-ES"

See Also

Vertical_MainScale_Indicators_Filler_Format Parameter | Vertical_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Format_Decimals 3

See Also

Vertical_MainScale_Indicators_Filler_Format Parameter | Vertical_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainScale_Indicators_Filler_Format Parameter | Vertical_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

MainScale_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Indicators Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Format_FormatType Percentage

See Also

Vertical_MainScale_Indicators_Filler_Format Parameter | Vertical_MainScale_Indicators_Filler_Format Summary


MainScale_Indicators_<index>_Origin property of Filler Parameter

MainScale_Indicators_<index>_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators Origin:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Origin OriginAtMin

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_OriginCustom property of Filler Parameter

MainScale_Indicators_<index>_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators OriginCustom to 15:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_OriginCustom 15

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Snap property of Indicator Parameter

MainScale_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the MainScale Indicators Snap to 5:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Snap 5

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Style property of Filler Parameter

MainScale_Indicators_<index>_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the MainScale Indicators Style:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Style Filler02

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_ToolTip property of Indicator Parameter

MainScale_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_UseFillerAsBar property of Filler Parameter

MainScale_Indicators_<index>_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the MainScale Indicators UseFillerAsBar to true:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_UseFillerAsBar true

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_UseRangeColor property of Indicator Parameter

MainScale_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Value property of Indicator Parameter

MainScale_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the MainScale Indicators Valueto 25:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Value 25

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_VerticalPosition property of Indicator Parameter

MainScale_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the MainScale Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_VerticalPosition BehindTickmarks

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Visible property of BaseViewable Parameter

MainScale_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Indicators Visible to false:

out-gauge -Type Vertical -MainIndicator Filler -MainScale_Indicators_0_Visible false

See Also

Vertical_MainScale_Indicators_Filler Parameter | Vertical_MainScale_Indicators_Filler Summary


MainScale_Inverted property of LinearScale Parameter

MainScale_Inverted Parameter

Gets amd set a boolean flag to invert the scale

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Example

To set the MainScale Inverted to true:

out-gauge -Type Vertical -MainScale_Inverted true

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Layout property of LinearScale Parameter

MainScale_Layout Parameter

Gets the layout object for a LinearScale

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Example

To set the MainScale Layout Alignment to BottomCenter:

out-gauge -Type Vertical -MainScale_Layout_Alignment BottomCenter

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


LayoutAttributes Class Members

Vertical_MainScale_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


MainScale_Layout_Alignment property of LayoutAttributes Parameter

MainScale_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the MainScale Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -MainScale_Layout_Alignment MiddleCenter

See Also

Vertical_MainScale_Layout Parameter | Vertical_MainScale_Layout Summary


MainScale_Layout_AnchorPoint property of LayoutAttributes Parameter

MainScale_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the MainScale Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -MainScale_Layout_Target AnchorPoint -MainScale_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_MainScale_Layout Parameter | Vertical_MainScale_Layout Summary


MainScale_Layout_Target property of LayoutAttributes Parameter

MainScale_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_MainScale_Layout Parameter | Vertical_MainScale_Layout Summary


MainScale_Max property of Range Parameter

MainScale_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Max to 50:

out-gauge -Type Vertical -MainScale_Max 50

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale MaxAlwaysDisplayed to false:

out-gauge -Type Vertical -MainScale_MaxAlwaysDisplayed false

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Min property of Range Parameter

MainScale_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Min to 10:

out-gauge -Type Vertical -MainScale_Min 10

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale MinAlwaysDisplayed to false:

out-gauge -Type Vertical -MainScale_MinAlwaysDisplayed false

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Sections_<index> property of Scale Parameter

MainScale_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the MainScale Sections Color to Red:

out-gauge -Type Vertical -MainScale_Sections_0_Color Red

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


Section Class Members

Vertical_MainScale_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar property of Section Parameter

MainScale_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the MainScale Sections Bar Color to Red:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Color Red

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


SectionBar Class Members

Vertical_MainScale_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

MainScale_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Vertical_MainScale_Sections_Bar Parameter | Vertical_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Bar_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Bar Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Bar_Visible true -MainScale_Sections_0_Bar_Visible false

See Also

Vertical_MainScale_Sections_Bar Parameter | Vertical_MainScale_Sections_Bar Summary


MainScale_Sections_<index>_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Color Blue

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Sections_<index>_Max property of Range Parameter

MainScale_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Sections Max to 50:

out-gauge -Type Vertical -MainScale_Sections_0_Max 50

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MaxAlwaysDisplayed to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MaxAlwaysDisplayed false

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Sections_<index>_Min property of Range Parameter

MainScale_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Sections Min to 10:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Min 10

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

MainScale_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the MainScale Sections MinAlwaysDisplayed to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_MinAlwaysDisplayed false

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Sections_<index>_Tickmarks property of BaseSection Parameter

MainScale_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


TickmarkSet Class Members

Vertical_MainScale_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


ValueFormat Class Members

Vertical_MainScale_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_MainScale_Sections_Tickmarks_Format Parameter | Vertical_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Sections Tickmarks Format Decimals to 3:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_Decimals 3

See Also

Vertical_MainScale_Sections_Tickmarks_Format Parameter | Vertical_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainScale_Sections_Tickmarks_Format Parameter | Vertical_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Sections Tickmarks Format FormatType to Percentage

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Vertical_MainScale_Sections_Tickmarks_Format Parameter | Vertical_MainScale_Sections_Tickmarks_Format Summary


MainScale_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Sections Tickmarks Major size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 5

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Major Label Color to Red:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Major Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Major Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Custom -MainScale_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Label Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Label_Visible true -MainScale_Sections_0_Tickmarks_Major_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Major_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Major_Label Summary


MainScale_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major PositionCustom to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Size 2.5

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Major Step to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Step 5

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Major Style:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Major Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Major_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Major Parameter | Vertical_MainScale_Sections_Tickmarks_Major Summary


MainScale_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Sections Tickmarks Medium size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 5

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Label Color to Red:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Custom -MainScale_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Label Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Label_Visible true -MainScale_Sections_0_Tickmarks_Medium_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Medium_Label Summary


MainScale_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium PositionCustom to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Medium Step to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Step 5

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Medium Style:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Medium Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Medium_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Medium Parameter | Vertical_MainScale_Sections_Tickmarks_Medium Summary


MainScale_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Sections Tickmarks Minor size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 5

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Label Color to Red:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Color

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Custom -MainScale_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Label Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Label_Visible true -MainScale_Sections_0_Tickmarks_Minor_Label_Position Bottom -MainScale_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Sections_Tickmarks_Minor_Label Summary


MainScale_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Position to Bottom:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor PositionCustom to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Position Custom -MainScale_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Size to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Sections Tickmarks Minor Step to 5:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Step 5

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Sections Tickmarks Minor Style:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Minor Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Minor_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks_Minor Parameter | Vertical_MainScale_Sections_Tickmarks_Minor Summary


MainScale_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Tickmarks Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Tickmarks_Visible false

See Also

Vertical_MainScale_Sections_Tickmarks Parameter | Vertical_MainScale_Sections_Tickmarks Summary


MainScale_Sections_<index>_Visible property of BaseViewable Parameter

MainScale_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Sections Visible to false:

out-gauge -Type Vertical -MainScale_Sections_0_Max 30 -MainScale_Sections_0_Visible false

See Also

Vertical_MainScale_Sections Parameter | Vertical_MainScale_Sections Summary


MainScale_Size property of LinearScale Parameter

MainScale_Size Parameter

Sets the size for a Linear Scale.

Remarks

  • This property is used to control the size of the scale in a Linear Gauge.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

Example

To set the MainScale Size to 0.75:

out-gauge -Type Vertical -MainScale_Size 0.75

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Stripes_<index> property of LinearScale Parameter

MainScale_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the MainScale Stripes Max to 30:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


LinearStrip Class Members

Vertical_MainScale_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Offset | Set the offset of a Strip respect ot the Scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_AlternateColor property of Strip Parameter

MainScale_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the MainScale Stripes AlternateColor to Yellow:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Gradient -MainScale_Stripes_0_AlternateColor Yellow

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Border property of Strip Parameter

MainScale_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the MainScale Stripes Border Color to red:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Red

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


BarBorder Class Members

Vertical_MainScale_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Stripes_<index>_Border_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Border Color

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Color Blue

See Also

Vertical_MainScale_Stripes_Border Parameter | Vertical_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Thickness property of BarBorder Parameter

MainScale_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the MainScale Stripes Border Thickness to 0.003:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Thickness 0.003

See Also

Vertical_MainScale_Stripes_Border Parameter | Vertical_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Border_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Border Visible to false:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Border_Visible false

See Also

Vertical_MainScale_Stripes_Border Parameter | Vertical_MainScale_Stripes_Border Summary


MainScale_Stripes_<index>_Color property of BaseColorable Parameter

MainScale_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Stripes Color

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Color Blue

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_FillType property of Strip Parameter

MainScale_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the MainScale Stripes FillType to Gradient:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_AlternateColor Yellow -MainScale_Stripes_0_FillType Gradient

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Max property of Range Parameter

MainScale_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the MainScale Stripes Max to 50:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 50

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Min property of Range Parameter

MainScale_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the MainScale Stripes Min to 10:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Min 10

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Offset property of LinearStrip Parameter

MainScale_Stripes_<index>_Offset Parameter

Set the offset of a Strip respect ot the Scale.

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Example

To display a strip on the center of the main Sclale:

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Pattern property of Strip Parameter

MainScale_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the MainScale Stripes Pattern to BackwardDiagonal:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_FillType Pattern -MainScale_Stripes_0_Pattern BackwardDiagonal

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Thickness property of Strip Parameter

MainScale_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the MainScale Stripes Thickness to 0.25:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Thickness 0.25

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

MainScale_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Stripes_<index>_Visible property of BaseViewable Parameter

MainScale_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Stripes Visible to false:

out-gauge -Type Vertical -MainScale_Stripes_0_Max 30 -MainScale_Stripes_0_Visible false

See Also

Vertical_MainScale_Stripes Parameter | Vertical_MainScale_Stripes Summary


MainScale_Thickness property of Scale Parameter

MainScale_Thickness Parameter

Sets the width for a scale.

Example

To set the MainScale Thickness to 0.05:

out-gauge -Type Vertical -MainScale_Thickness 0.05

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainScale_Tickmarks property of BaseSection Parameter

MainScale_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


TickmarkSet Class Members

Vertical_MainScale_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Color property of BaseColorable Parameter

MainScale_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Color

out-gauge -Type Vertical -MainScale_Tickmarks_Color Blue

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


MainScale_Tickmarks_Format property of TickmarkSet Parameter

MainScale_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


ValueFormat Class Members

Vertical_MainScale_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


MainScale_Tickmarks_Format_Culture property of ValueFormat Parameter

MainScale_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the MainScale Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainScale_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_MainScale_Tickmarks_Format Parameter | Vertical_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_Decimals property of ValueFormat Parameter

MainScale_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the MainScale Tickmarks Format Decimals to 3:

out-gauge -Type Vertical -MainScale_Tickmarks_Format_Decimals 3

See Also

Vertical_MainScale_Tickmarks_Format Parameter | Vertical_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_MainScale_Tickmarks_Format Parameter | Vertical_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Format_FormatType property of ValueFormat Parameter

MainScale_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the MainScale Tickmarks Format FormatType to Percentage

out-gauge -Type Vertical -MainScale_Tickmarks_Format_FormatType Percentage

See Also

Vertical_MainScale_Tickmarks_Format Parameter | Vertical_MainScale_Tickmarks_Format Summary


MainScale_Tickmarks_Major property of TickmarkSet Parameter

MainScale_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the MainScale Tickmarks Major size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Size 5

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Color

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Color Blue

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Label property of Tickmark Parameter

MainScale_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Major Label Color to Red:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Color Red

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


LabelAttributes Class Members

Vertical_MainScale_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Major_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Major Label Color

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Color Blue

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Major Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Major Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Orientation Tangent

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Custom -MainScale_Tickmarks_Major_Label_PositionCustom 5

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Label Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Label_Visible true -MainScale_Tickmarks_Major_Label_Position Bottom -MainScale_Tickmarks_Major_Label_Visible false

See Also

Vertical_MainScale_Tickmarks_Major_Label Parameter | Vertical_MainScale_Tickmarks_Major_Label Summary


MainScale_Tickmarks_Major_Position property of Tickmark Parameter

MainScale_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major PositionCustom to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Position Custom -MainScale_Tickmarks_Major_PositionCustom 0.2

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Size property of Tickmark Parameter

MainScale_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Size 2.5

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Step property of Tickmark Parameter

MainScale_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Major Step to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Step 5

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Style property of Tickmark Parameter

MainScale_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Major Style:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Style Tickmark10_3

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Major_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Major Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Major_Visible false

See Also

Vertical_MainScale_Tickmarks_Major Parameter | Vertical_MainScale_Tickmarks_Major Summary


MainScale_Tickmarks_Medium property of TickmarkSet Parameter

MainScale_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the MainScale Tickmarks Medium size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Size 5

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Color

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Color Blue

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Label property of Tickmark Parameter

MainScale_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Medium Label Color to Red:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Color Red

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


LabelAttributes Class Members

Vertical_MainScale_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Medium Label Color

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Color Blue

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Orientation Tangent

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Custom -MainScale_Tickmarks_Medium_Label_PositionCustom 5

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Label Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Label_Visible true -MainScale_Tickmarks_Medium_Label_Position Bottom -MainScale_Tickmarks_Medium_Label_Visible false

See Also

Vertical_MainScale_Tickmarks_Medium_Label Parameter | Vertical_MainScale_Tickmarks_Medium_Label Summary


MainScale_Tickmarks_Medium_Position property of Tickmark Parameter

MainScale_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium PositionCustom to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Position Custom -MainScale_Tickmarks_Medium_PositionCustom 0.2

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Size property of Tickmark Parameter

MainScale_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Size 2.5

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Step property of Tickmark Parameter

MainScale_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Medium Step to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Step 5

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Style property of Tickmark Parameter

MainScale_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Medium Style:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Style Tickmark10_3

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Medium_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Medium Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Medium_Visible false

See Also

Vertical_MainScale_Tickmarks_Medium Parameter | Vertical_MainScale_Tickmarks_Medium Summary


MainScale_Tickmarks_Minor property of TickmarkSet Parameter

MainScale_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the MainScale Tickmarks Minor size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Size 5

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


Tickmark Class Members

Vertical_MainScale_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Color

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Color Blue

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Label property of Tickmark Parameter

MainScale_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the MainScale Tickmarks Minor Label Color to Red:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Color Red

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


LabelAttributes Class Members

Vertical_MainScale_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


MainScale_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

MainScale_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the MainScale Tickmarks Minor Label Color

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Color Blue

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the MainScale Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the MainScale Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Orientation Tangent

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

MainScale_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the MainScale Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Custom -MainScale_Tickmarks_Minor_Label_PositionCustom 5

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Label Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Label_Visible true -MainScale_Tickmarks_Minor_Label_Position Bottom -MainScale_Tickmarks_Minor_Label_Visible false

See Also

Vertical_MainScale_Tickmarks_Minor_Label Parameter | Vertical_MainScale_Tickmarks_Minor_Label Summary


MainScale_Tickmarks_Minor_Position property of Tickmark Parameter

MainScale_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Position to Bottom:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Position Bottom

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

MainScale_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor PositionCustom to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Position Custom -MainScale_Tickmarks_Minor_PositionCustom 0.2

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Size property of Tickmark Parameter

MainScale_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Size to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Size 2.5

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Step property of Tickmark Parameter

MainScale_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the MainScale Tickmarks Minor Step to 5:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Step 5

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Style property of Tickmark Parameter

MainScale_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the MainScale Tickmarks Minor Style:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Style Tickmark10_3

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Minor_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Minor Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Minor_Visible false

See Also

Vertical_MainScale_Tickmarks_Minor Parameter | Vertical_MainScale_Tickmarks_Minor Summary


MainScale_Tickmarks_Visible property of BaseViewable Parameter

MainScale_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Tickmarks Visible to false:

out-gauge -Type Vertical -MainScale_Tickmarks_Visible false

See Also

Vertical_MainScale_Tickmarks Parameter | Vertical_MainScale_Tickmarks Summary


MainScale_Visible property of BaseViewable Parameter

MainScale_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the MainScale Visible to false:

out-gauge -Type Vertical -MainScale_Visible false

See Also

Vertical_MainScale Parameter | Vertical_MainScale Summary


MainValue property of Gauge Parameter

MainValue Parameter

Sets the main value for a gauge. It is a shortcut to the value of the MainIndicator.

Remarks

  • A gauge may display several values, for example a radial gauge may have multiple indicator needles. This property is used to configure the value displayed as the main value of a gauge object.

  • The MainIndicator method is used to obtain access to the main indicator.

Example

To set the MainValue to 7:

out-gauge -Type Vertical -MainValue 7

See Also

Vertical Parameter | Vertical Summary


Modal property of gauge Parameter

Modal Parameter

Allows you to block the command pipe while displaying a gauge.

Remarks

  • Use Modal to block the command pipe while displaying a gauge.

Example

To create a gauge blocking the command pipe by configuinr the Modal parameter:

out-gauge -Type Vertical -Modal

See Also

Vertical Parameter | Vertical Summary


Output property of gauge Parameter

Output Parameter

Allows you to generate a gauge file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a gauge file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate an Output image (.png) of the gauge:

out-gauge -Type Vertical -Output test.png

See Also

Vertical Parameter | Vertical Summary


Palette property of BaseGauge Parameter

Palette Parameter

Allows you to set a Chart FX pre-defined palette.

Value | Meaning
Default | Set the palette to Default.
Alternate | Set the palette to Alternate.
Autumn | Set the palette to an Autumn scheme.
BrownSugar | Set the palette to a BrownSugar scheme.
ChartFX6 | Set the palette to the ChartFX 6 scheme.
Classic | Set the palette to Classic.
Colorful | Set the palette to a Colorful scheme.
DarkPastels | Set the palette to a DarkPastels scheme.
Earthtones | Set the palette to an Earthtones scheme.
HighContrast | Set the palette to a HighContrast scheme.
LilacsInMist | Set the palette to LilacsInMist scheme.
Mesa | Set the palette to Mesa scheme.
ModernBusiness | Set the palette to a ModernBusiness scheme.
NatureAdventure | Set the palette to a NatureAdventure scheme.
NatureSky | Set the palette to a NatureSky scheme.
Oceanica | Set the palette to Oceanica scheme.
Professional | Set the palette to a Professional scheme.
RainyDay | Set the palette to a RainyDay scheme.
SandAndSky | Set the palette to a SandAndSky scheme.
Simple | Set the palette to a Simple scheme.
Slate | Set the palette to Slate scheme.
SnowyPine | Set the palette to SnowyPine.
Vivid | Set the palette to a Vivid scheme.
Windows | Set the palette to a Windows scheme.

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as PowerGadgets will change the windows palette for the chart window. So if you previously set a color using any of the PowerGadgets supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Example

To set the Palette to NatureSky:

out-gauge -Type Vertical -Palette NatureSky

See Also

Vertical Parameter | Vertical Summary


Refresh property of gauge Parameter

Refresh Parameter

Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.

Remarks

  • If the command returns a single value per each series, the gauge will add a new point to the end. Otherwise, the whole gauge data is replaced with the new data.

Example

To Refresh every 1 second the gauge populated with the processes (PS>get-process ):

ps | out-gauge -Type Vertical -Refresh 0:0:1

See Also

Vertical Parameter | Vertical Summary


Scales_<index> property of LinearGauge Parameter

Scales_<index> Parameter

Returns the LinearScaleCollection for a linear gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying the scale item in the collection.

Remarks

  • The MainScale property is used to obtain the main scale for a selected LinearGauge.

Example

To set the Scales Color to Red

out-gauge -Type Vertical -Scales_0_Color Red

See Also

Vertical Parameter | Vertical Summary


LinearScale Class Members

Vertical_Scales Parameters

Parameters

Description

Bar | Returns the ScaleBar object for a section.
Color | Sets the color for a gauge element.
CustomLabels | The collection of Custom Labels currently associated with the scale.
FillerVolume | Sets the Filler size within a Linear Gauge
Indicators | The collection of Indicators currently associated with the scale.
Inverted | Gets amd set a boolean flag to invert the scale
Layout | Gets the layout object for a LinearScale
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Sections | Returns the SectionCollection for a scale object.
Size | Sets the size for a Linear Scale.
Stripes | The collection of Stripes currently associated with the scale.
Thickness | Sets the width for a scale.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar property of Scale Parameter

Scales_<index>_Bar Parameter

Returns the ScaleBar object for a section.

Remarks

  • The Bar object is the colored band for a section object. The supported members of the SectionBar Parameter are used to customize this object.

Example

To set the Scales Bar Color to Red:

out-gauge -Type Vertical -Scales_0_Bar_Color Red

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


ScaleBar Class Members

Vertical_Scales_Bar Parameters

Parameters

Description

Border | Allows you to access the Bar Border object for a gauge bar object.
Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border property of ScaleBar Parameter

Scales_<index>_Bar_Border Parameter

Allows you to access the Bar Border object for a gauge bar object.

Remarks

  • The Thickness parameter of the Border object is used to control the width of a Bar border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Type Vertical -Scales_0_Bar_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Vertical_Scales_Bar Parameter | Vertical_Scales_Bar Summary


BarBorder Class Members

Vertical_Scales_Bar_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Bar_Border_Color property of BaseColorable Parameter

Scales_<index>_Bar_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Bar Border Color

out-gauge -Type Vertical -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Color Blue

See Also

Vertical_Scales_Bar_Border Parameter | Vertical_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Thickness property of BarBorder Parameter

Scales_<index>_Bar_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Bar Border Thickness to 0.003:

out-gauge -Type Vertical -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Thickness 0.003

See Also

Vertical_Scales_Bar_Border Parameter | Vertical_Scales_Bar_Border Summary


Scales_<index>_Bar_Border_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Border Visible to false:

out-gauge -Type Vertical -Scales_0_Bar_Border_Visible true -Scales_0_Bar_Border_Visible false

See Also

Vertical_Scales_Bar_Border Parameter | Vertical_Scales_Bar_Border Summary


Scales_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Vertical_Scales_Bar Parameter | Vertical_Scales_Bar Summary


Scales_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Bar Visible to false:

out-gauge -Type Vertical -Scales_0_Bar_Visible true -Scales_0_Bar_Visible false

See Also

Vertical_Scales_Bar Parameter | Vertical_Scales_Bar Summary


Scales_<index>_Color property of BaseColorable Parameter

Scales_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Color

out-gauge -Type Vertical -Scales_0_Color Blue

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_CustomLabels property of Scale Parameter

Scales_<index>_CustomLabels Parameter

The collection of Custom Labels currently associated with the scale.

Parameters

Parameter | Type | Meaning
key | Double | References the Scale value where a label will be placed.

Remarks

  • If no labels are set, then the default numeric values are used.

Example

To set the Scales CustomLabels for the value '40':

out-gauge -Type Vertical -Scales_0_CustomLabels_40 "Label at 40"

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_FillerVolume property of LinearScale Parameter

Scales_<index>_FillerVolume Parameter

Sets the Filler size within a Linear Gauge

Remarks

  • The Max value is 1 which fills the entire scale area. A value of 0.5 will shrink the Filler volume by half.

Example

To set the Scales FillerVolume to 25:;

out-gauge -Type Vertical -Scales_0_FillerVolume 25

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Indicators_<index> property of Scale Parameter

Scales_<index>_Indicators_<index> Parameter

The collection of Indicators currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • If a gauge contains only (1) indicator, then the MainIndicator property of the gauge references the same Indicator as the 0-index of this collection.

Example

To set the Scales Indicators Color to AliceBlue:

out-gauge -Type Vertical -Scales_0_Indicators_0_Color AliceBlue

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Marker Class Members

Vertical_Scales_Indicators_Marker Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Label | Gets the LabelAttributes object for a Marker.
Position | Sets the position for a marker.
PositionCustom | Sets a custom position for a Marker object.
Size | Sets a value to control the size of a marker.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a indicator marker.
Text | Sets text for a marker.
ToolTip | Sets the tool tip text for an Indicator.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Color Blue

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


ValueFormat Class Members

Vertical_Scales_Indicators_Marker_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Vertical_Scales_Indicators_Marker_Format Parameter | Vertical_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Format_Decimals 3

See Also

Vertical_Scales_Indicators_Marker_Format Parameter | Vertical_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_Scales_Indicators_Marker_Format Parameter | Vertical_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Vertical_Scales_Indicators_Marker_Format Parameter | Vertical_Scales_Indicators_Marker_Format Summary


Scales_<index>_Indicators_<index>_Label property of Marker Parameter

Scales_<index>_Indicators_<index>_Label Parameter

Gets the LabelAttributes object for a Marker.

Remarks

Example

To set the Scales Indicators Label Color:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Color Red

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


LabelAttributes Class Members

Vertical_Scales_Indicators_Marker_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_Label_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Label Color

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Color Blue

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Font property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Indicators Label Font to Arial 5:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Font "Arial, 5"

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Indicators Label Orientation to Tangent

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Orientation Tangent

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Position property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Position Bottom

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Indicators_<index>_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Indicators Label PositionCustom to 5:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Custom -Scales_0_Indicators_0_Label_PositionCustom 5

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Label_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Label Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Label_Visible true -Scales_0_Indicators_0_Label_Position Bottom -Scales_0_Indicators_0_Label_Visible false

See Also

Vertical_Scales_Indicators_Marker_Label Parameter | Vertical_Scales_Indicators_Marker_Label Summary


Scales_<index>_Indicators_<index>_Position property of Marker Parameter

Scales_<index>_Indicators_<index>_Position Parameter

Sets the position for a marker.

Default Value
The default is Center.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where a marker will be displayed in refernece to the scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Indicators Position to Bottom:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Position Bottom

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_PositionCustom property of Marker Parameter

Scales_<index>_Indicators_<index>_PositionCustom Parameter

Sets a custom position for a Marker object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. Th Style property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators PositionCustom:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Position Custom -Scales_0_Indicators_0_PositionCustom 0.05

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Size property of Marker Parameter

Scales_<index>_Indicators_<index>_Size Parameter

Sets a value to control the size of a marker.

Remarks

  • When set to zero, the marker is not visible in a radial gauge. This is a ratio property, therefore the overall size of a gauge is also a factor when rendering the marker.

Example

To set the Scales Indicators Size to 5:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Size 5

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Snap 5

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Style property of Marker Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a indicator marker.

Value | Meaning
Marker01 | Set the marker style or Marker01.
Marker02 | Set the marker style or Marker02.
Marker03 | Set the marker style or Marker03.
Marker04 | Set the marker style or Marker04.
Marker05 | Set the marker style or Marker05.
Marker06 | Set the marker style or Marker06.
Marker07 | Set the marker style or Marker07.
Marker08 | Set the marker style or Marker08.
Marker09 | Set the marker style or Marker09.

Remarks

  • A marker is an indicator in a gauge which marks a value. There are several different marker designs and styles that may be used to customize the display of gauges. This property may be configured to any of the supported MarkerStyle enumeration types.

Example

To set the Scales Indicators Style to Marker02;

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Style Marker02

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Text property of Marker Parameter

Scales_<index>_Indicators_<index>_Text Parameter

Sets text for a marker.

Remarks

  • The Value property may be used to configure a value for selected marker.

Example

To set the Scales Indicators Text:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Text "My Value"

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Value 25

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -Type Vertical -MainIndicator Marker -Scales_0_Indicators_0_Visible false

See Also

Vertical_Scales_Indicators_Marker Parameter | Vertical_Scales_Indicators_Marker Summary


Filler Class Members

Vertical_Scales_Indicators_Filler Parameters

Parameters

Description

AnimationSpan | Sets the time span value between each movement of an indicator.
Color | Sets the color for a gauge element.
Format | Returns the ValueFormat object for a selected indicator.
Origin | Sets the starting value of a filler indicator type.
OriginCustom | Sets the custom origin for a filler indicator.
Snap | Set the Snapping for an indicator.
Style | Sets the style for a filler indicator.
ToolTip | Sets the tool tip text for an Indicator.
UseFillerAsBar | Sets a value indicating to use the Filler as the background in a linear gauge.
UseRangeColor | Sets a value specifying wether to set an indicator to the same color as a section or stripe.
Value | Sets the value for an indicator.
VerticalPosition | Sets the positioning of the Indicator to behind or above the tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Indicators_<index>_AnimationSpan property of Indicator Parameter

Scales_<index>_Indicators_<index>_AnimationSpan Parameter

Sets the time span value between each movement of an indicator.

Remarks

  • A value of 0:0:1 (h:m:s) will force the Indicator to take 1 second to complete movement from the current Value to the next Value.

  • The Animation allows you to manipulate the movement of the Indicators when they change values. Inteast of having the to "jump" from one value to another, you can enable the Indicator to "animate" the transition, and controling the speed of the movement.

Example

To set the Scales Indicators AnimationSpan to 2 seconds:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_AnimationSpan 0:0:2

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Color property of BaseColorable Parameter

Scales_<index>_Indicators_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Indicators Color

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Color Blue

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Format property of Indicator Parameter

Scales_<index>_Indicators_<index>_Format Parameter

Returns the ValueFormat object for a selected indicator.

Remarks

  • The Value property may be used to configure a value for selected indicator.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Format_Decimals 3

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


ValueFormat Class Members

Vertical_Scales_Indicators_Filler_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Indicators_<index>_Format_Culture property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Indicators Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Format_Culture "es-ES"

See Also

Vertical_Scales_Indicators_Filler_Format Parameter | Vertical_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Indicators Format Decimals to 3:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Format_Decimals 3

See Also

Vertical_Scales_Indicators_Filler_Format Parameter | Vertical_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_Scales_Indicators_Filler_Format Parameter | Vertical_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Indicators_<index>_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Indicators Format FormatType to Percentage

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Format_FormatType Percentage

See Also

Vertical_Scales_Indicators_Filler_Format Parameter | Vertical_Scales_Indicators_Filler_Format Summary


Scales_<index>_Indicators_<index>_Origin property of Filler Parameter

Scales_<index>_Indicators_<index>_Origin Parameter

Sets the starting value of a filler indicator type.

Default Value
The default is OriginAtMin.

Value | Meaning
OriginAtMin | The origin of the Filler is at the start value.
CustomOrigin | The origin of the Filler is custom defined.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The OriginCustom property is used to configure a custom starting value when the Origin property is configured to OriginCustom.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators Origin:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Origin OriginAtMin

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_OriginCustom property of Filler Parameter

Scales_<index>_Indicators_<index>_OriginCustom Parameter

Sets the custom origin for a filler indicator.

Remarks

  • In order for the OriginCustom value to be realized, the Origin property must be configured to FillerOriginType.OriginCustom.

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators OriginCustom to 15:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_OriginCustom 15

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Snap property of Indicator Parameter

Scales_<index>_Indicators_<index>_Snap Parameter

Set the Snapping for an indicator.

Remarks

  • When the snap is set to anything but 0 (zero), then indicator will be snapped to the closest value in the scale that can be divided by the selected snap value.

    Examples:

    Indicator Value: 21, Snap: 2, Indicator will be snapped to 22.

    Indicator Value: 93, Snap: 5, Indicator will be snapped to 95.

    Indicator Value: 93, Snap: 10, Indicator will be snapped to 100.

  • Snapping is always to the ceiling.

Example

To set the Scales Indicators Snap to 5:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Snap 5

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Style property of Filler Parameter

Scales_<index>_Indicators_<index>_Style Parameter

Sets the style for a filler indicator.

Value | Meaning
Filler01 | Set the filler style to Filler01.
Filler02 | Set the filler style to Filler02.
Filler03 | Set the filler style to Filler03.
Filler04 | Set the filler style to Filler04.
Filler05 | Set the filler style to Filler05.
Filler06 | Set the filler style to Filler06.
Filler07 | Set the filler style to Filler07.
Filler08 | Set the filler style to Filler08.
Filler09 | Set the filler style to Filler09.
Filler10 | Set the filler style to Filler10.
Filler11 | Set the filler style to Filler11.
Filler12 | Set the filler style to Filler12.
Repeater01 | Set the filler style to Repeater01.
Repeater02 | Set the filler style to Repeater02.
Repeater03 | Set the filler style to Repeater03.
Repeater04 | Set the filler style to Repeater04.
Repeater05 | Set the filler style to Repeater05.
Repeater06 | Set the filler style to Repeater06.
Repeater07 | Set the filler style to Repeater07.
Repeater08 | Set the filler style to Repeater08.
Repeater09 | Set the filler style to Repeater09.
Repeater10 | Set the filler style to Repeater10.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

Example

To set the Scales Indicators Style:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Style Filler02

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_ToolTip property of Indicator Parameter

Scales_<index>_Indicators_<index>_ToolTip Parameter

Sets the tool tip text for an Indicator.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the Indicator.

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_UseFillerAsBar property of Filler Parameter

Scales_<index>_Indicators_<index>_UseFillerAsBar Parameter

Sets a value indicating to use the Filler as the background in a linear gauge.

Remarks

  • A filler indicator is a bar that has a starting and ending value. The Origin property is used to configure whether the starting value will for the filler to be at the starting, ending or custom value in a linear scale.

  • The Style property may be used to configure the style for a filler object.

Example

To set the Scales Indicators UseFillerAsBar to true:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_UseFillerAsBar true

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_UseRangeColor property of Indicator Parameter

Scales_<index>_Indicators_<index>_UseRangeColor Parameter

Sets a value specifying wether to set an indicator to the same color as a section or stripe.

Default Value
The default is None.

Value | Meaning
None | Indicator uses their color.
Section | Indicator will use the color from the Section.
Strip | Indicator will take the color from the Strip.

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Value property of Indicator Parameter

Scales_<index>_Indicators_<index>_Value Parameter

Sets the value for an indicator.

Remarks

  • This property is used to configure the value for a selected indicator. This value will position the indicator based on the range of the parent Scale object.

Example

To set the Scales Indicators Valueto 25:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Value 25

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_VerticalPosition property of Indicator Parameter

Scales_<index>_Indicators_<index>_VerticalPosition Parameter

Sets the positioning of the Indicator to behind or above the tick marks.

Default Value
The default is AboveTickmarks.

Value | Meaning
AboveTickmarks | Place the indicator above the scale.
BehindTickmarks | Place the indicator behind the scale.

Remarks

Example

To set the Scales Indicators VerticalPosition to BehindTickmarks:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_VerticalPosition BehindTickmarks

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Indicators_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Indicators Visible to false:

out-gauge -Type Vertical -MainIndicator Filler -Scales_0_Indicators_0_Visible false

See Also

Vertical_Scales_Indicators_Filler Parameter | Vertical_Scales_Indicators_Filler Summary


Scales_<index>_Inverted property of LinearScale Parameter

Scales_<index>_Inverted Parameter

Gets amd set a boolean flag to invert the scale

Remarks

  • By default, the Scale in Linear Gauges goes from Left to Rigth or from Bottom to Top.

  • Setting this property to true will invert the scale to Left to Right or Top to Bottom.

Example

To set the Scales Inverted to true:

out-gauge -Type Vertical -Scales_0_Inverted true

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Layout property of LinearScale Parameter

Scales_<index>_Layout Parameter

Gets the layout object for a LinearScale

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an LinearScale inside the Gauge.

Example

To set the Scales Layout Alignment to BottomCenter:

out-gauge -Type Vertical -Scales_0_Layout_Alignment BottomCenter

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


LayoutAttributes Class Members

Vertical_Scales_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Scales_<index>_Layout_Alignment property of LayoutAttributes Parameter

Scales_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Scales Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -Scales_0_Layout_Alignment MiddleCenter

See Also

Vertical_Scales_Layout Parameter | Vertical_Scales_Layout Summary


Scales_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Scales_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Scales Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -Scales_0_Layout_Target AnchorPoint -Scales_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_Scales_Layout Parameter | Vertical_Scales_Layout Summary


Scales_<index>_Layout_Target property of LayoutAttributes Parameter

Scales_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_Scales_Layout Parameter | Vertical_Scales_Layout Summary


Scales_<index>_Max property of Range Parameter

Scales_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Max to 50:

out-gauge -Type Vertical -Scales_0_Max 50

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales MaxAlwaysDisplayed to false:

out-gauge -Type Vertical -Scales_0_MaxAlwaysDisplayed false

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Min property of Range Parameter

Scales_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Min to 10:

out-gauge -Type Vertical -Scales_0_Min 10

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales MinAlwaysDisplayed to false:

out-gauge -Type Vertical -Scales_0_MinAlwaysDisplayed false

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Sections_<index> property of Scale Parameter

Scales_<index>_Sections_<index> Parameter

Returns the SectionCollection for a scale object.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index specifying the scale item.

Remarks

  • A section is a range of values for a selected scale.

Example

To set the Scales Sections Color to Red:

out-gauge -Type Vertical -Scales_0_Sections_0_Color Red

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Section Class Members

Vertical_Scales_Sections Parameters

Parameters

Description

Bar | Returns the SectionBar object for a section.
Color | Sets the color for a gauge element.
Max | Get or set the Maximum value of the gauge scale.
MaxAlwaysDisplayed | Sets a value indicating whether to display the ending value of a section.
Min | Get or set the Minimum value for the gauge scale.
MinAlwaysDisplayed | Sets a value indicating whether to display the starting value of a section.
Tickmarks | Allows you to access the Tickmark properties for a section.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar property of Section Parameter

Scales_<index>_Sections_<index>_Bar Parameter

Returns the SectionBar object for a section.

Remarks

  • The Max property may be used to configure the ending range value for a section object. The Min property is used to configure the starting range value.

Example

To set the Scales Sections Bar Color to Red:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Color Red

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


SectionBar Class Members

Vertical_Scales_Sections_Bar Parameters

Parameters

Description

Color | Get or set the color of the section bar.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Bar_Color property of BaseSectionBar Parameter

Scales_<index>_Sections_<index>_Bar_Color Parameter

Get or set the color of the section bar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

See Also

Vertical_Scales_Sections_Bar Parameter | Vertical_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Bar_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Bar_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Bar Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Bar_Visible true -Scales_0_Sections_0_Bar_Visible false

See Also

Vertical_Scales_Sections_Bar Parameter | Vertical_Scales_Sections_Bar Summary


Scales_<index>_Sections_<index>_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Color Blue

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Sections_<index>_Max property of Range Parameter

Scales_<index>_Sections_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Sections Max to 50:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 50

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Sections_<index>_MaxAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MaxAlwaysDisplayed Parameter

Sets a value indicating whether to display the ending value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Max property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MaxAlwaysDisplayed to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MaxAlwaysDisplayed false

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Sections_<index>_Min property of Range Parameter

Scales_<index>_Sections_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Sections Min to 10:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Min 10

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Sections_<index>_MinAlwaysDisplayed property of BaseSection Parameter

Scales_<index>_Sections_<index>_MinAlwaysDisplayed Parameter

Sets a value indicating whether to display the starting value of a section.

Remarks

  • The property may be used to configure the ending range value for a section object.

  • The Min property may be used to configure the ending range value for a section object.

Example

To set the Scales Sections MinAlwaysDisplayed to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_MinAlwaysDisplayed false

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Sections_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Sections_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


TickmarkSet Class Members

Vertical_Scales_Sections_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


ValueFormat Class Members

Vertical_Scales_Sections_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Sections_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Sections Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_Scales_Sections_Tickmarks_Format Parameter | Vertical_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Sections Tickmarks Format Decimals to 3:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_Decimals 3

See Also

Vertical_Scales_Sections_Tickmarks_Format Parameter | Vertical_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_Scales_Sections_Tickmarks_Format Parameter | Vertical_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Sections_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Sections Tickmarks Format FormatType to Percentage

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Format_FormatType Percentage

See Also

Vertical_Scales_Sections_Tickmarks_Format Parameter | Vertical_Scales_Sections_Tickmarks_Format Summary


Scales_<index>_Sections_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Sections Tickmarks Major size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 5

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Sections_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Major Label Color to Red:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Color Red

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


LabelAttributes Class Members

Vertical_Scales_Sections_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Major Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Major Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Label Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Label_Visible true -Scales_0_Sections_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Major_Label_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Major_Label Parameter | Vertical_Scales_Sections_Tickmarks_Major_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Major_PositionCustom 0.2

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Size 2.5

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Major Step to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Step 5

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Major Style:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Style Tickmark10_3

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Major Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Major_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Major Parameter | Vertical_Scales_Sections_Tickmarks_Major Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Sections Tickmarks Medium size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 5

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Sections_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Medium Label Color to Red:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Red

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


LabelAttributes Class Members

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Label Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible true -Scales_0_Sections_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Medium_Label_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Medium_Label Parameter | Vertical_Scales_Sections_Tickmarks_Medium_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Size 2.5

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Medium Step to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Step 5

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Medium Style:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Medium Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Medium_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Medium Parameter | Vertical_Scales_Sections_Tickmarks_Medium Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Sections Tickmarks Minor size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 5

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Sections_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Sections Tickmarks Minor Label Color to Red:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Red

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


LabelAttributes Class Members

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Color

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Color Blue

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Sections Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Sections Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Sections Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Label Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible true -Scales_0_Sections_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Sections_0_Tickmarks_Minor_Label_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Minor_Label Parameter | Vertical_Scales_Sections_Tickmarks_Minor_Label Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Position to Bottom:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Position Bottom

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Position Custom -Scales_0_Sections_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Size to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Size 2.5

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Sections Tickmarks Minor Step to 5:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Step 5

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Sections Tickmarks Minor Style:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Minor Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Minor_Visible false

See Also

Vertical_Scales_Sections_Tickmarks_Minor Parameter | Vertical_Scales_Sections_Tickmarks_Minor Summary


Scales_<index>_Sections_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Tickmarks Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Tickmarks_Visible false

See Also

Vertical_Scales_Sections_Tickmarks Parameter | Vertical_Scales_Sections_Tickmarks Summary


Scales_<index>_Sections_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Sections_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Sections Visible to false:

out-gauge -Type Vertical -Scales_0_Sections_0_Max 30 -Scales_0_Sections_0_Visible false

See Also

Vertical_Scales_Sections Parameter | Vertical_Scales_Sections Summary


Scales_<index>_Size property of LinearScale Parameter

Scales_<index>_Size Parameter

Sets the size for a Linear Scale.

Remarks

  • This property is used to control the size of the scale in a Linear Gauge.

  • Setting this property to 1 means that the scale will eocupy 100% of the container, setting this property to 0.5 means the sacle will ocupy half of the container.

Example

To set the Scales Size to 0.75:

out-gauge -Type Vertical -Scales_0_Size 0.75

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Stripes_<index> property of LinearScale Parameter

Scales_<index>_Stripes_<index> Parameter

The collection of Stripes currently associated with the scale.

Parameters

Parameter | Type | Meaning
index | Int32 | A numeric expression that specifies the position of an element of the collection.

Remarks

  • The entire collection may be returned or a specific Strip instance referenced via the index.

Example

To set the Scales Stripes Max to 30:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


LinearStrip Class Members

Vertical_Scales_Stripes Parameters

Parameters

Description

AlternateColor | Sets the second color used in strip gradients or patterns.
Border | Allows you to access the BarBorder object for a Strip object.
Color | Sets the color for a gauge element.
FillType | Sets the fill style for a strip solid, gradient or pattern.
Max | Get or set the Maximum value of the gauge scale.
Min | Get or set the Minimum value for the gauge scale.
Offset | Set the offset of a Strip respect ot the Scale.
Pattern | Get or Set the Windows-Style pattern applied to the Strip
Thickness | Sets the width for a strip object.
UseFullRangeForGradient | Apply the gradient effect over the range of the scale.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_AlternateColor property of Strip Parameter

Scales_<index>_Stripes_<index>_AlternateColor Parameter

Sets the second color used in strip gradients or patterns.

Remarks

  • The FillType property is used to configure a strip to display as solid, gradient or pattern.

Example

To set the Scales Stripes AlternateColor to Yellow:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Gradient -Scales_0_Stripes_0_AlternateColor Yellow

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Border property of Strip Parameter

Scales_<index>_Stripes_<index>_Border Parameter

Allows you to access the BarBorder object for a Strip object.

Remarks

  • Use the Border parameter to configure the border properties for a strip object.

Example

To set the Scales Stripes Border Color to red:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Red

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


BarBorder Class Members

Vertical_Scales_Stripes_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Thickness | Sets the width for the Bar Border object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Stripes_<index>_Border_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Border Color

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Color Blue

See Also

Vertical_Scales_Stripes_Border Parameter | Vertical_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Thickness property of BarBorder Parameter

Scales_<index>_Stripes_<index>_Border_Thickness Parameter

Sets the width for the Bar Border object.

Remarks

  • The BarBorder is the outline around a Scale Bar. This property is used to configure the width of the bar's border.

Example

To set the Scales Stripes Border Thickness to 0.003:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Thickness 0.003

See Also

Vertical_Scales_Stripes_Border Parameter | Vertical_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Border_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Border Visible to false:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Border_Visible false

See Also

Vertical_Scales_Stripes_Border Parameter | Vertical_Scales_Stripes_Border Summary


Scales_<index>_Stripes_<index>_Color property of BaseColorable Parameter

Scales_<index>_Stripes_<index>_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Stripes Color

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Color Blue

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_FillType property of Strip Parameter

Scales_<index>_Stripes_<index>_FillType Parameter

Sets the fill style for a strip solid, gradient or pattern.

Default Value
The default is Solid.

Value | Meaning
Solid | The fill type is Solid.
Gradient | The fill type is Gradient.
Pattern | The fill type is Pattern.

Remarks

  • The AlternateColor and Color properties are used for the strip fill when the FillType is configured as gradient or pattern.

  • The Thickness property is used to configure the width for a strip.

Example

To set the Scales Stripes FillType to Gradient:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_AlternateColor Yellow -Scales_0_Stripes_0_FillType Gradient

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Max property of Range Parameter

Scales_<index>_Stripes_<index>_Max Parameter

Get or set the Maximum value of the gauge scale.

Example

To set the Scales Stripes Max to 50:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 50

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Min property of Range Parameter

Scales_<index>_Stripes_<index>_Min Parameter

Get or set the Minimum value for the gauge scale.

Example

To set the Scales Stripes Min to 10:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Min 10

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Offset property of LinearStrip Parameter

Scales_<index>_Stripes_<index>_Offset Parameter

Set the offset of a Strip respect ot the Scale.

Remarks

  • The default value is 0.25

  • Offset = 0.00 will display the Strip in the center of the scale.

  • Offset = 0.5 will display the Strip at the Bottom or Left of the scale; Offset = -0.5 will display the Strip at the Top or Right of the scale.

Example

To display a strip on the center of the main Sclale:

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Pattern property of Strip Parameter

Scales_<index>_Stripes_<index>_Pattern Parameter

Get or Set the Windows-Style pattern applied to the Strip

Remarks

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • An AlternateColor may also be specified for use with Patterns.

Example

To set the Scales Stripes Pattern to BackwardDiagonal:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_FillType Pattern -Scales_0_Stripes_0_Pattern BackwardDiagonal

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Thickness property of Strip Parameter

Scales_<index>_Stripes_<index>_Thickness Parameter

Sets the width for a strip object.

Remarks

  • Use the Thickness parameter to control the width of a strip object.

Example

To set the Scales Stripes Thickness to 0.25:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Thickness 0.25

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_UseFullRangeForGradient property of Strip Parameter

Scales_<index>_Stripes_<index>_UseFullRangeForGradient Parameter

Apply the gradient effect over the range of the scale.

Remarks

  • If a strip is smaller than the full length of the scale, then the entire gradient will not be shown if this property is set to True.

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Stripes_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Stripes_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Stripes Visible to false:

out-gauge -Type Vertical -Scales_0_Stripes_0_Max 30 -Scales_0_Stripes_0_Visible false

See Also

Vertical_Scales_Stripes Parameter | Vertical_Scales_Stripes Summary


Scales_<index>_Thickness property of Scale Parameter

Scales_<index>_Thickness Parameter

Sets the width for a scale.

Example

To set the Scales Thickness to 0.05:

out-gauge -Type Vertical -Scales_0_Thickness 0.05

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Scales_<index>_Tickmarks property of BaseSection Parameter

Scales_<index>_Tickmarks Parameter

Allows you to access the Tickmark properties for a section.

Remarks

  • Use the Tickmarks parameter to access the Tickmark members in the gauge.

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


TickmarkSet Class Members

Vertical_Scales_Tickmarks Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Format | Sets the ValueFormat object for selected tickmark object.
Major | Allows for configuration of the Major tick marks.
Medium | Allows for configuration of the Medium tick marks.
Minor | Allows for configuration of the Minor tick marks.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Color Blue

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


Scales_<index>_Tickmarks_Format property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Format Parameter

Sets the ValueFormat object for selected tickmark object.

Remarks

  • The Format parameter supports members to allow developers to configure Culture, Decimals, FormatType and CustomFormat for selected labels.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


ValueFormat Class Members

Vertical_Scales_Tickmarks_Format Parameters

Parameters

Description

Culture | Allows you to localize labels and data for a specific language and region.
Decimals | Sets the number of decimals for a label.
FormatCustom | Allows you to set a custom format to the selected label, mouseover tip or value.
FormatType | Sets the value Type for which to get a formatting object.


Scales_<index>_Tickmarks_Format_Culture property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Culture Parameter

Allows you to localize labels and data for a specific language and region.

Remarks

  • When setting this property, you may need the Culture Name or Culture Identifier constants for the desired culture.

Example

To set the Scales Tickmarks Format Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Vertical -Scales_0_Tickmarks_Format_Culture "es-ES"

See Also

Vertical_Scales_Tickmarks_Format Parameter | Vertical_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_Decimals property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_Decimals Parameter

Sets the number of decimals for a label.

Remarks

  • When a FormatCustom is applied, formatting assigned using the Decimals property will be ignored.

Example

To set the Scales Tickmarks Format Decimals to 3:

out-gauge -Type Vertical -Scales_0_Tickmarks_Format_Decimals 3

See Also

Vertical_Scales_Tickmarks_Format Parameter | Vertical_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatCustom property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatCustom Parameter

Allows you to set a custom format to the selected label, mouseover tip or value.

Remarks

  • When a CustomFormat is applied to a selected axis, any formatting assigned using the Decimals property will be ignored.

  • The following table shows the characters you can use to create user-defined number formats and the meaning of each:

  • Character 0 ( Digit placeholder).

    Display a digit or a zero. If there is a digit in the expression being formatted in the position where the 0 appears in the format string, display it; otherwise, display a zero in that position. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to the left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.

  • Character # (Digit placeholder)

    Display a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, display it; otherwise, display nothing in that position. This symbol works like the 0 digit placeholder, except that leading and trailing zeros aren't displayed if the number has the same or fewer digits than there are # characters on either side of the decimal separator in the format expression.

  • Character . (Decimal placeholder)

    The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator. If the format expression contains only number signs to the left of this symbol, numbers smaller than 1 begin with a decimal separator. If you want a leading zero to always be displayed with fractional numbers, use 0 as the first digit placeholder to the left of the decimal separator instead. The actual character used as a decimal placeholder in the formatted output depends on the Number Format specified for the development workstation. For some countries, a comma is used as the decimal separator.

  • Character , (Thousand separator)

    The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Standard use of the thousand separator is specified if the format contains a comma surrounded by digit placeholders (0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means "scale the number by dividing it by 1000, rounding as needed." You can scale large numbers using this technique. For example, you can use the format string "##0,," to represent 100 million as 100. Numbers smaller than 1 million are displayed as 0. Two adjacent commas in any position other than immediately to the left of the decimal separator are treated simply as specifying the use of a thousand separator. The actual character used as the thousand separator in the formatted output depends on the Number Format specified in the International section of the Control Panel. For some countries, a period is used as the thousand separator.

  • Character ; (expression separator)

    The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values. "$#,##0;($#,##0)"

    If you include semicolons with nothing between them, the missing section is printed using the default format. For example, the following format displays positive as currency and negative values using the default format: "$#,##0;"

  • The following table shows the characters you can use to create user-defined date/time formats and the meaning of each, but check PowerShell documentation for a updated information:

    Character C

    Display the date as ddddd and display the time as t t t t t, in that order. Only date information is displayed if there is no fractional part to the date serial number; only time information is displayed if there is no integer portion.

    Date Parameters:

    Character d

    Display the day as a number without a leading zero (1-31).

    Character dd

    Display the day as a number with a leading zero (01-31).

    Character ddd

    Display the day as an abbreviation (Sun-Sat).

    Character dddd

    Display the day as a full name (Sunday-Saturday).

    Character ddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Short Date setting in the International section of the Windows Control Panel. The default Short Date format is m/d/yy.

    Character dddddd

    Display a date serial number as a complete date (including day, month, and year) formatted according to the Long Date setting in the International section of the Control Panel. The default Long Date format is mmmm dd, yyyy.

    Character M

    Display the month as a number without a leading zero (1-12).

    Character MM

    Display the month as a number with a leading zero (01-12).

    Character MMM

    Display the month as an abbreviation (Jan-Dec).

    Character MMMM

    Display the month as a full month name (January-December).

    Character y

    Display the day of the year as a number (1-366).

    Character yy

    Display the year as a two-digit number (00-99).

    Character yyyy Display the year as a four-digit number (100-9999).

    Time Parameters:

    Character h

    Display the hour as a number without leading zeros (0-11) using a 12-hour clock

    Character hh

    Display the hour as a number with leading zeros (00-11) using a 12-hour clock

    Character H

    Display the hour as a number (0-23) using a 24-hour clock.

    Character HH

    Display the hour as a number with leading zeros (00-23) using a 24-hour clock.

    Character m

    Display the minute as a number without leading zeros (0-59).

    Character mm

    Display the minute as a number with leading zeros (00-59).

    Character s

    Display the second as a number without leading zeros (0-59).

    Character ss

    Display the second as a number with leading zeros (00-59).

    Character t

    One character time-marker string, such as A or P

    Character tt

    Multicharacter time-marker string such as AM or PM

  • Format Display

    m/d/yy 12/7/58

    d-MMMM-yy 7-December-58

    d-MMMM 7 December

    MMMM-yy December 58

    h:mm 20:50

    h:mm:ss 20:50:35

    m/d/yy h:mm 12/7/58 20:50

See Also

Vertical_Scales_Tickmarks_Format Parameter | Vertical_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Format_FormatType property of ValueFormat Parameter

Scales_<index>_Tickmarks_Format_FormatType Parameter

Sets the value Type for which to get a formatting object.

Value | Meaning
Numeric | Displays a Number, as defined in the International section of the Control Panel.
Currency | Displays Currency, as defined in the International section of the Control Panel.
Scientific | Displays standard scientific notation.
Percentage | Displays numbers multiplied by 100 with a percent sign (%) appended to the right; display two digits to the right of the decimal separator.
Custom | Displays as defined in the CustomFormat property.

Remarks

  • The FormatType property is used to configure numeric, currency, scientific or percentage format for a ValueFormat object.

  • The Decimals property is used to configure the number of decimals for a label.

Example

To set the Scales Tickmarks Format FormatType to Percentage

out-gauge -Type Vertical -Scales_0_Tickmarks_Format_FormatType Percentage

See Also

Vertical_Scales_Tickmarks_Format Parameter | Vertical_Scales_Tickmarks_Format Summary


Scales_<index>_Tickmarks_Major property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Major Parameter

Allows for configuration of the Major tick marks.

Remarks

  • On a default gauge only the Major tick marks have numeric labels.

Example

To set the Scales Tickmarks Major size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Size 5

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Tickmarks_Major Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Color Blue

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Major Label Color to Red:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Color Red

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


LabelAttributes Class Members

Vertical_Scales_Tickmarks_Major_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Major_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Major_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Major Label Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Color Blue

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Major Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Font "Arial, 5"

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Major Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Orientation Tangent

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Position Bottom

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Major_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Major Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Custom -Scales_0_Tickmarks_Major_Label_PositionCustom 5

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Label Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Label_Visible true -Scales_0_Tickmarks_Major_Label_Position Bottom -Scales_0_Tickmarks_Major_Label_Visible false

See Also

Vertical_Scales_Tickmarks_Major_Label Parameter | Vertical_Scales_Tickmarks_Major_Label Summary


Scales_<index>_Tickmarks_Major_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Position Bottom

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Position Custom -Scales_0_Tickmarks_Major_PositionCustom 0.2

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Size 2.5

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Major Step to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Step 5

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Major_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Major Style:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Style Tickmark10_3

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Major_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Major_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Major Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Major_Visible false

See Also

Vertical_Scales_Tickmarks_Major Parameter | Vertical_Scales_Tickmarks_Major Summary


Scales_<index>_Tickmarks_Medium property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Medium Parameter

Allows for configuration of the Medium tick marks.

Remarks

  • On a default gauge the Medium tick marks are the second largest and second-most visible. Normally positioned directly in the middle of two Major tick marks.

Example

To set the Scales Tickmarks Medium size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Size 5

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Tickmarks_Medium Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Color Blue

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Medium Label Color to Red:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Color Red

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


LabelAttributes Class Members

Vertical_Scales_Tickmarks_Medium_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Medium_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Medium_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Medium Label Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Color Blue

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Medium Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Font "Arial, 5"

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Medium Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Orientation Tangent

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Position Bottom

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Medium_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Medium Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Custom -Scales_0_Tickmarks_Medium_Label_PositionCustom 5

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Label Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Label_Visible true -Scales_0_Tickmarks_Medium_Label_Position Bottom -Scales_0_Tickmarks_Medium_Label_Visible false

See Also

Vertical_Scales_Tickmarks_Medium_Label Parameter | Vertical_Scales_Tickmarks_Medium_Label Summary


Scales_<index>_Tickmarks_Medium_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Position Bottom

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Position Custom -Scales_0_Tickmarks_Medium_PositionCustom 0.2

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Size 2.5

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Medium Step to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Step 5

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Medium_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Medium Style:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Style Tickmark10_3

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Medium_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Medium_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Medium Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Medium_Visible false

See Also

Vertical_Scales_Tickmarks_Medium Parameter | Vertical_Scales_Tickmarks_Medium Summary


Scales_<index>_Tickmarks_Minor property of TickmarkSet Parameter

Scales_<index>_Tickmarks_Minor Parameter

Allows for configuration of the Minor tick marks.

Remarks

  • On a default gauge the minor tick marks are smallest and least visible. Typically are found a quarter of the distance between Major tick marks.

Example

To set the Scales Tickmarks Minor size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Size 5

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


Tickmark Class Members

Vertical_Scales_Tickmarks_Minor Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Label | Returns the LabelAttributes object for a tickmark.
Position | Sets the position for tickmarks in a scale.
PositionCustom | Sets a custom position for a Tickmark object.
Size | Sets a value to control the size of tickmarks.
Step | Sets a value indicating the interval for tickmark display.
Style | Sets the tickmark style.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Color Blue

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Label property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Label Parameter

Returns the LabelAttributes object for a tickmark.

Remarks

  • This property provides access to the Label object for a tickmark.

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

Example

To set the Scales Tickmarks Minor Label Color to Red:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Color Red

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


LabelAttributes Class Members

Vertical_Scales_Tickmarks_Minor_Label Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Font | Sets the font for a label.
Orientation | Sets the orientation for labels of scale tick marks.
Position | Sets the location of labels for a selected scale.
PositionCustom | Sets a custom position for a LabelAttributes object.
Visible | Sets a value indicating whether an object is visible or not.


Scales_<index>_Tickmarks_Minor_Label_Color property of BaseColorable Parameter

Scales_<index>_Tickmarks_Minor_Label_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Scales Tickmarks Minor Label Color

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Color Blue

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Font property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Font Parameter

Sets the font for a label.

Remarks

  • The Orientation, Position and PositionCustom property are used to configure the location of labels for a selected scale.

Example

To set the Scales Tickmarks Minor Label Font to Arial 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Font "Arial, 5"

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Orientation property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Orientation Parameter

Sets the orientation for labels of scale tick marks.

Value | Meaning
Horizontal | Set the label to Horizontal orientation.
Tangent | Set the label to Tangent orientation.
Perpendicular | Set the label to Perpendicular orientation.

Remarks

  • This property allows you to control the alignment of labels in their configured Position.

  • The Position property is used to configure the location of labels for a selected scale.

  • The PositionCustom property is used to configure the location of labels when the Position property is configured to Custom.

Example

To set the Scales Tickmarks Minor Label Orientation to Tangent

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Orientation Tangent

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Position property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_Position Parameter

Sets the location of labels for a selected scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Position Bottom

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_PositionCustom property of LabelAttributes Parameter

Scales_<index>_Tickmarks_Minor_Label_PositionCustom Parameter

Sets a custom position for a LabelAttributes object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Orientation property is used to configure the alignment for labels based on their configured Position.

Example

To set the Scales Tickmarks Minor Label PositionCustom to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Custom -Scales_0_Tickmarks_Minor_Label_PositionCustom 5

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Label_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Label_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Label Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Label_Visible true -Scales_0_Tickmarks_Minor_Label_Position Bottom -Scales_0_Tickmarks_Minor_Label_Visible false

See Also

Vertical_Scales_Tickmarks_Minor_Label Parameter | Vertical_Scales_Tickmarks_Minor_Label Summary


Scales_<index>_Tickmarks_Minor_Position property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Position Parameter

Sets the position for tickmarks in a scale.

Value | Meaning
Top | Positions element to Top.
Bottom | Positions element to Bottom.
Center | Positions element to Center.
Custom | Position is Custom defined.

Remarks

  • When this property is configured to Custom, the PositionCustom property may be used to configure where the labels will be displayed in refernece to the scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Position to Bottom:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Position Bottom

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_PositionCustom property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_PositionCustom Parameter

Sets a custom position for a Tickmark object.

Remarks

  • The Position property MUST be configured to Custom in order for this property to be realized in a gauge.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor PositionCustom to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Position Custom -Scales_0_Tickmarks_Minor_PositionCustom 0.2

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Size property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Size Parameter

Sets a value to control the size of tickmarks.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Step property is used to configure the interval for tickmark display.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Size to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Size 2.5

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Step property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Step Parameter

Sets a value indicating the interval for tickmark display.

Remarks

  • The Position property is used to configure the positioning of tickmarks in a scale.

  • The Style property is used to configure style for a selected tickmark object.

Example

To set the Scales Tickmarks Minor Step to 5:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Step 5

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Style property of Tickmark Parameter

Scales_<index>_Tickmarks_Minor_Style Parameter

Sets the tickmark style.

Value | Meaning
Tickmark01_1 | Set the tickmark style to Tickmark01_1.
Tickmark01_2 | Set the tickmark style to Tickmark01_2.
Tickmark01_3 | Set the tickmark style to Tickmark01_3.
Tickmark01_4 | Set the tickmark style to Tickmark01_4.
Tickmark02_1 | Set the tickmark style to Tickmark02_1.
Tickmark02_2 | Set the tickmark style to Tickmark02_2.
Tickmark02_3 | Set the tickmark style to Tickmark02_3.
Tickmark02_4 | Set the tickmark style to Tickmark02_4.
Tickmark03_1 | Set the tickmark style to Tickmark03_1.
Tickmark03_2 | Set the tickmark style to Tickmark03_2.
Tickmark03_3 | Set the tickmark style to Tickmark03_3.
Tickmark03_4 | Set the tickmark style to Tickmark03_4.
Tickmark04_1 | Set the tickmark style to Tickmark04_1.
Tickmark04_2 | Set the tickmark style to Tickmark04_2.
Tickmark04_3 | Set the tickmark style to Tickmark04_3.
Tickmark04_4 | Set the tickmark style to Tickmark04_4.
Tickmark05_1 | Set the tickmark style to Tickmark05_1.
Tickmark05_2 | Set the tickmark style to Tickmark05_2.
Tickmark05_3 | Set the tickmark style to Tickmark05_3.
Tickmark05_4 | Set the tickmark style to Tickmark05_4.
Tickmark06_1 | Set the tickmark style to Tickmark06_1.
Tickmark06_2 | Set the tickmark style to Tickmark06_2.
Tickmark06_3 | Set the tickmark style to Tickmark06_3.
Tickmark06_4 | Set the tickmark style to Tickmark06_4.
Tickmark07_1 | Set the tickmark style to Tickmark07_1.
Tickmark07_2 | Set the tickmark style to Tickmark07_2.
Tickmark07_3 | Set the tickmark style to Tickmark07_3.
Tickmark07_4 | Set the tickmark style to Tickmark07_4.
Tickmark08_1 | Set the tickmark style to Tickmark08_1.
Tickmark08_2 | Set the tickmark style to Tickmark08_2.
Tickmark08_3 | Set the tickmark style to Tickmark08_3.
Tickmark08_4 | Set the tickmark style to Tickmark08_4.
Tickmark09_1 | Set the tickmark style to Tickmark09_1.
Tickmark09_2 | Set the tickmark style to Tickmark09_2.
Tickmark09_3 | Set the tickmark style to Tickmark09_3.
Tickmark09_4 | Set the tickmark style to Tickmark09_4.
Tickmark10_1 | Set the tickmark style to Tickmark10_1.
Tickmark10_2 | Set the tickmark style to Tickmark10_2.
Tickmark10_3 | Set the tickmark style to Tickmark10_3.
Tickmark10_4 | Set the tickmark style to Tickmark10_4.
Tickmark11_1 | Set the tickmark style to Tickmark11_1.
Tickmark11_2 | Set the tickmark style to Tickmark11_2.
Tickmark11_3 | Set the tickmark style to Tickmark11_3.
Tickmark11_4 | Set the tickmark style to Tickmark11_4.
Tickmark12_1 | Set the tickmark style to Tickmark12_1.
Tickmark12_2 | Set the tickmark style to Tickmark12_2.
Tickmark12_3 | Set the tickmark style to Tickmark12_3.
Tickmark12_4 | Set the tickmark style to Tickmark12_4.
None | Set the tickmark style to None.

Remarks

  • The Position and PositionCustom property are used to control the location tickmark display.

Example

To set the Scales Tickmarks Minor Style:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Style Tickmark10_3

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Minor_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Minor_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Minor Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Minor_Visible false

See Also

Vertical_Scales_Tickmarks_Minor Parameter | Vertical_Scales_Tickmarks_Minor Summary


Scales_<index>_Tickmarks_Visible property of BaseViewable Parameter

Scales_<index>_Tickmarks_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Tickmarks Visible to false:

out-gauge -Type Vertical -Scales_0_Tickmarks_Visible false

See Also

Vertical_Scales_Tickmarks Parameter | Vertical_Scales_Tickmarks Summary


Scales_<index>_Visible property of BaseViewable Parameter

Scales_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Scales Visible to false:

out-gauge -Type Vertical -Scales_0_Visible false

See Also

Vertical_Scales Parameter | Vertical_Scales Summary


Shadow property of Gauge Parameter

Shadow Parameter

Sets a value indicating to whether to display a shadow in a gauge.

Default Value
The default is None.

Value | Meaning
None | No shadow effect.
Plain | A plain shadow effect.
Realistic | A realistic shadow effect.

Example

To set the Shadow to Realistic:

out-gauge -Type Vertical -Shadow Realistic

See Also

Vertical Parameter | Vertical Summary


Size property of gauge Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered gauge.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered gauge.

Example

To configure the Size of the gauge:

out-gauge -Type Vertical -Size 800,600

See Also

Vertical Parameter | Vertical Summary


Style property of gauge Parameter

Style Parameter

Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.

Remarks

  • There are 10 different styles for radial gauges: Style 0 through Style 10.

  • Styles do not include color settings, thus palette colors are used.

Example

To set the Style parameter to use the fourth style:

out-gauge -Type Vertical -Style 4

See Also

Vertical Parameter | Vertical Summary


Template property of gauge Parameter

Template Parameter

Allows you to use or save gauge modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

Example

To use a pre-configured template called MyProcesses:

out-gauge -template MyProcesses

To use a graphical Wizard to configure a Tamplate gauge:

out-gauge -configure -template MyProcesses

See Also

Vertical Parameter | Vertical Summary


Titles_<index> property of BaseGauge Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set the Titles Color to Red:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Vertical Parameter | Vertical Summary


Title Class Members

Vertical_Titles Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Color | Sets the color of text for the specified title.
Font | Sets the Gauge Font object for a gauge title.
Layout | Allows you to access the layout object for an Annotation.
Text | Sets the text for the selected title.
Visible | Sets a value indicating whether an object is visible or not.


Titles_<index>_Angle property of Annotation Parameter

Titles_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Titles Angle to 45 degrees:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Angle 45

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


Titles_<index>_Color property of Title Parameter

Titles_<index>_Color Parameter

Sets the color of text for the specified title.

Remarks

  • The Text propety is used to set the caption for a title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles Color to Red:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Sets the Gauge Font object for a gauge title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Titles Font:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Font "Arial, 5"

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


Titles_<index>_Layout property of Annotation Parameter

Titles_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


LayoutAttributes Class Members

Vertical_Titles_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Titles_<index>_Layout_Alignment property of LayoutAttributes Parameter

Titles_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Titles Layout Alignment to the MiddleCenter:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Layout_Alignment MiddleCenter

See Also

Vertical_Titles_Layout Parameter | Vertical_Titles_Layout Summary


Titles_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Titles_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Titles Layout AnchorPoint to a specific position:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Layout_Target AnchorPoint -Titles_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Vertical_Titles_Layout Parameter | Vertical_Titles_Layout Summary


Titles_<index>_Layout_Target property of LayoutAttributes Parameter

Titles_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Vertical_Titles_Layout Parameter | Vertical_Titles_Layout Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To set the Titles Text:

out-gauge -Type Vertical -Titles_0_Text "My Text"

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


Titles_<index>_Visible property of BaseViewable Parameter

Titles_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Titles Visible to false:

out-gauge -Type Vertical -Titles_0_Text "My Text" -Titles_0_Visible false

See Also

Vertical_Titles Parameter | Vertical_Titles Summary


ToolTip property of BaseGauge Parameter

ToolTip Parameter

Sets the tool tip text.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

  • The ToolTipEnabled property may be used to control whether or not a tool tip will be diplayed for a gauge.

Example

To set the ToolTip:

out-gauge -Type Vertical -ToolTip "My Text"

See Also

Vertical Parameter | Vertical Summary


ToolTipEnabled property of BaseGauge Parameter

ToolTipEnabled Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Remarks

  • Tooltips allow the user to easily recognize the appropriate PowerGadgets element.

Example

To set the ToolTipEnabled to false:

out-gauge -Type Vertical -ToolTipEnabled false

See Also

Vertical Parameter | Vertical Summary


Type property of gauge Parameter

Type Parameter

Allows you to specify the gauge type (Radial, Horizontal, Vertical and Digital).

Remarks

  • Use the Type parameter to specify the Gauge Type. This are the types: Radial, Horizontal, Vertical and Digital.

  • If the Type parameter is not configured the gauge Type would be Radial.

Example

To configure the Type parameter to get a Horizontal:

out-gauge -Type Horizontal

To configure the Type parameter to get a Vertical:

out-gauge -Type Vertical

To configure the Type parameter to get a Digital:

out-gauge -Type Digital

See Also

Vertical Parameter | Vertical Summary


Value property of gauge Parameter

Value Parameter

Allows you to specify which property to plot in the gauge.

Remarks

  • Use the Value parameter to specifie which property must be used as indicator. Only a numeric property can be used.

Example

To specify the Handles as Value in a gauge populated with the processes (PS>get-process ):

ps | out-gauge -Type Vertical -Value Handles

See Also

Vertical Parameter | Vertical Summary


DigitalPanel Parameter

Remarks

The DigitalPanel gauge is a digital representation of values using 7 Segments, 14Segments or LEDs.

7 Segments can represent only numeric values, while 14 Segments and LEDs can represent numbers, tesxt and dates.

Here is an example of a 7 segment DigitalPanel:

Here is an example of a 14 segment DigitalPanel:

Here is an example of an LED DigitalPanel:


DigitalPanel Class Members

Digital Parameters

Parameters

Description

Anchor | Allows you to specify the general location of the gauge with respect to your desktop.
Antialiasing | Sets the smooth visual effect for a gauge.
Appearance | Returns the DigitalAppearance for a Digital Panel.
Border | Gets the Border object for a Digital Panel.
Caption | Modifies the caption used in the PowerGadget window
Configure | Allows you to use a graphical Wizard to customize the gauge.
Culture | Allows you to localize gauges for a specific language and region.
Floating | Allows you to launch a gauge without a window frame.
Glass |
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Font | Sets the font type which will be used by default in the gauge.
Images | Allows you to accesss the images for a gauge.
InnerGauges | The collection of InnerGauges currently associated with the gauge.
Modal | Allows you to block the command pipe while displaying a gauge.
Output | Allows you to generate a gauge file instead of an interactive one.
Palette | Allows you to set a PowerGadgets pre-defined palette.
Refresh | Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.
Size | Allows you to specify the actual dimension of the final rendered gauge.
Style |
Template | Allows you to use or save gauge modifications into a template file.
Titles | Returns the collection of titles defined in the gauge.
ToolTip | Sets the tool tip text.
ToolTipEnabled | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.
Type |
Value | Allows you to configure the gauge background to b painted using Glass form.
ValueFormat | Sets the numeric format string for a Digital Panel.
ValuePadding | Sets the number of digit placeholders in the panel.


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the gauge with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the Anchor parameter to TopRight:

out-gauge -Type Digital -Anchor TopRight

See Also

Digital Parameter | Digital Summary


Antialiasing property of BaseGauge Parameter

Antialiasing Parameter

Sets the smooth visual effect for a gauge.

Default Value
The default is All.

Value | Meaning
None | No smoothing applied.
Text | Smoothing applied to text objects only.
Graphic | Smoothing applied to graphic objects only.
All | Smoothing applied to all gauge elements.

Remarks

  • This property can be used to configure or remove smooth drawing for the gauge and/or included text.

Example

To set the Antialiasing property for a gauge to None:

out-gauge -Type Digital -Antialiasing None

See Also

Digital Parameter | Digital Summary


Appearance property of DigitalPanel Parameter

Appearance Parameter

Returns the DigitalAppearance for a Digital Panel.

Remarks

  • This property is used to obtain access to the Appearance for a Digital Panel. This object is the section of a digital panel that contains the segment or LEDs characters. The supported members of the DigitalAppearance may be used to customize the display of digits in the Digital Panel.

See Also

Digital Parameter | Digital Summary


DigitalAppearance Class Members

Digital_Appearance Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Layout | Allows you to configure the layout for a DigitContainer.
OffDigitTransparency | Sets the transparency for segments and LEDs not used to create a digit's current value.
Size | Sets the size of Digits in a Digital Container.
Style | Sets the Style for the characters displyed in a DigitalPanel.
Visible | Sets a value indicating whether an object is visible or not.


Appearance_Color property of BaseColorable Parameter

Appearance_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Appearance Color

out-gauge -Type Digital -Appearance_Color Blue

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


Appearance_Layout property of DigitalAppearance Parameter

Appearance_Layout Parameter

Allows you to configure the layout for a DigitContainer.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of Digits inside the DigitalPanel.

Example

To set the Appearance Layout Alignment to TopLeft:

out-gauge -Type Digital -Appearance_Layout_Alignment TopLeft

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


LayoutAttributes Class Members

Digital_Appearance_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Appearance_Layout_Alignment property of LayoutAttributes Parameter

Appearance_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Appearance Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -Appearance_Layout_Alignment MiddleCenter

See Also

Digital_Appearance_Layout Parameter | Digital_Appearance_Layout Summary


Appearance_Layout_AnchorPoint property of LayoutAttributes Parameter

Appearance_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Appearance Layout AnchorPoint to a specific position:

out-gauge -Type Digital -Appearance_Layout_Target AnchorPoint -Appearance_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_Appearance_Layout Parameter | Digital_Appearance_Layout Summary


Appearance_Layout_Target property of LayoutAttributes Parameter

Appearance_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_Appearance_Layout Parameter | Digital_Appearance_Layout Summary


Appearance_OffDigitTransparency property of DigitalAppearance Parameter

Appearance_OffDigitTransparency Parameter

Sets the transparency for segments and LEDs not used to create a digit's current value.

Remarks

  • This property controls the transparency of LEDs and Segments which are not used to display digit values.
    For example, when displaying a value of one in a seven-segment style digit, only the two right vertical segements are used to diplay the value. The others will utilize the OffDigitTransparency setting.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Example

To set the Appearance OffDigitTransparency to 25:

out-gauge -Type Digital -Appearance_OffDigitTransparency 25

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


Appearance_Size property of DigitalAppearance Parameter

Appearance_Size Parameter

Sets the size of Digits in a Digital Container.

Remarks

  • This property is used to control the size of segment or LED digits displayed in a Digital Container.

  • The Style property is used to configure the type of Digits to display (LEDs or Segments).

  • The OffDigitTransparency property controls the transparency of LEDs and Segments which are not used to display digit values.

  • The Layout property is used to position and align a Digital Container object inside the Digit Panel.

Example

To set the Appearance Size to 0.1

out-gauge -Type Digital -Appearance_Size 0.1

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


Appearance_Style property of DigitalAppearance Parameter

Appearance_Style Parameter

Sets the Style for the characters displyed in a DigitalPanel.

Value | Meaning
SevenSegments01 | Seven segment style 01.
SevenSegments02 | Seven segment style 02.
SevenSegments03 | Seven segment style 03.
SevenSegments04 | Seven segment style 04.
SevenSegments05 | Seven segment style 05.
SevenSegments06 | Seven segment style 06.
SevenSegments07 | Seven segment style 07.
FourteenSegments01 | Fourteen segment style 01.
FourteenSegments02 | Fourteen segment style 02.
FourteenSegments03 | Fourteen segment style 03.
FourteenSegments04 | Fourteen segment style 04.
FourteenSegments05 | Fourteen segment style 05.
FourteenSegments06 | Fourteen segment style 06.
FourteenSegments07 | Fourteen segment style 07.
FourteenSegments08 | Fourteen segment style 08.
Led01 | LED style 01.
Led02 | LED style 02.
Led03 | LED style 03.
Led04 | LED style 04.
Led05 | LED style 05.
Led06 | LED style 06.
Led07 | LED style 07.
Led08 | LED style 08.

Remarks

  • Thsi property is used to select which type of charartere is going to be displayes on the DigitalPanel: 7-Segment, 14-Segment or LED.

  • The 7-segment styles provide display sets of the ten numerals, plus the following symbods: . , - , : and '.

  • The 14-segment styles provids a display set of 44 commonly used characters, including the ten numerals, the uppercase alphabet and other symbols.

  • The LED styles provide the same alphanumeric character set as a 14-Segment display plus lower case alphabet.

  • All 3 types include diferent variations and formats: italic, rounded, square, etc.

Example

To set the Appearance Style to LED:

out-gauge -Type Digital -Appearance_Style Led01

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


Appearance_Visible property of BaseViewable Parameter

Appearance_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Appearance Visible to false:

out-gauge -Type Digital -Appearance_Visible false

See Also

Digital_Appearance Parameter | Digital_Appearance Summary


Border property of DigitalPanel Parameter

Border Parameter

Gets the Border object for a Digital Panel.

Remarks

  • The Border is the outer object encasing a Digital Panel. There are a myriad of different frame designs and styles that may be used to customize the display of Digital Panels.

  • This property returns a LinearBorder object. For additional information regarding supported members, please see the class.

Example

To obtain the LinearBorder object for a Digital Panel:

See Also

Digital Parameter | Digital Summary


LinearBorder Class Members

Digital_Border Parameters

Parameters

Description

Color | Sets the color for a gauge element.
Glare | Sets a value indicating whether to use a lighting effect for a border.
InsideColor | Sets the inside color for a gauge border.
InsideEffects | Enables or disables border shadow and gradient.
Inverted | Set a property to invert the Border of a Linear Gauge
Style | Sets the style for a LinearBorder object.
Visible | Sets a value indicating whether an object is visible or not.


Border_Color property of BaseColorable Parameter

Border_Color Parameter

Sets the color for a gauge element.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border Color

out-gauge -Type Digital -Border_Color Blue

See Also

Digital_Border Parameter | Digital_Border Summary


Border_Glare property of Border Parameter

Border_Glare Parameter

Sets a value indicating whether to use a lighting effect for a border.

Remarks

  • Setting this property to True specifies to include a lighting effect to mimic glare from a light source.

Example

To turn on the Border Glare effect for a gauge:

out-gauge -Type Digital -Border_Glare false

See Also

Digital_Border Parameter | Digital_Border Summary


Border_InsideColor property of Border Parameter

Border_InsideColor Parameter

Sets the inside color for a gauge border.

Remarks

  • This property is used to configure the inner color value for a Border object.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Here is an example of setting the Border InsideColor

out-gauge -Type Digital -Border_InsideColor Red

See Also

Digital_Border Parameter | Digital_Border Summary


Border_InsideEffects property of Border Parameter

Border_InsideEffects Parameter

Enables or disables border shadow and gradient.

Remarks

  • A natural gradient is applied when there is no specific background image.

Example

To Disable the Border InsideEffects:

out-gauge -Type Digital -Border_InsideEffects false

See Also

Digital_Border Parameter | Digital_Border Summary


Border_Inverted property of LinearBorder Parameter

Border_Inverted Parameter

Set a property to invert the Border of a Linear Gauge

Remarks

  • The following is a HorizontalGauge with Inverted = false:

  • The following is the same HorizontalGauge with Inverted = true:

Example

To set the Border Inverted to false:

out-gauge -Type Digital -Border_Inverted false

See Also

Digital_Border Parameter | Digital_Border Summary


Border_Style property of LinearBorder Parameter

Border_Style Parameter

Sets the style for a LinearBorder object.

Value | Meaning
LinearBorder01 | Set the border style to LinearBorder01.
LinearBorder02 | Set the border style to LinearBorder02.
LinearBorder03 | Set the border style to LinearBorder03.
LinearBorder04 | Set the border style to LinearBorder04.
LinearBorder05 | Set the border style to LinearBorder05.
LinearBorder06 | Set the border style to LinearBorder06.
LinearBorder07 | Set the border style to LinearBorder07.
LinearBorder08 | Set the border style to LinearBorder08.
LinearBorder09 | Set the border style to LinearBorder09.
LinearBorder10 | Set the border style to LinearBorder10.
LinearBorder11 | Set the border style to LinearBorder11.
LinearBorder12 | Set the border style to LinearBorder12.
LinearBorder13 | Set the border style to LinearBorder13.
LinearBorder14 | Set the border style to LinearBorder14.
LinearBorder15 | Set the border style to LinearBorder15.
LinearBorder16 | Set the border style to LinearBorder16.
LinearBorder17 | Set the border style to LinearBorder17.
Thermometer01 | Set the border style to Thermometer01.
Thermometer02 | Set the border style to Thermometer02.
Thermometer03 | Set the border style to Thermometer03.

Remarks

  • The LinearBorder is the outer frame encasing a linear gauge. This property may be used to configure any of the supported LinearBorderStyle enumeration types.

Example

To set the Border Style to Thermometer:

out-gauge -Type Digital -Border_Style Thermometer01

See Also

Digital_Border Parameter | Digital_Border Summary


Border_Visible property of BaseViewable Parameter

Border_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Border Visible to false:

out-gauge -Type Digital -Border_Visible false

See Also

Digital_Border Parameter | Digital_Border Summary


Caption property of gauge Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the Caption in the PowerGadget window:

out-gauge -Type Digital -Caption "My PowerGadget"

See Also

Digital Parameter | Digital Summary


Configure property of gauge Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the gauge.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

  • This Wizard has two tabs, one called gauge Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the gauge Wizard tab.

Example

To use a graphical wizard to Configure the gauge:

out-gauge -Type Digital -Configure

See Also

Digital Parameter | Digital Summary


Culture property of BaseGauge Parameter

Culture Parameter

Allows you to localize gauges for a specific language and region.

Remarks

  • Culture attributes set with this property will effect the entire gauge, if no attributes are set using this property then PowerGadgets inherits the current Thread culture.

Example

To set the Culture to use "Spanish - Spain" as the Language-Country/Region:

out-gauge -Type Digital -Culture "es-ES"

See Also

Digital Parameter | Digital Summary


DrillDown Class Members

Digital_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-gauge.

Example

To use the DrillDown_Script parameter:

ps | out-gauge -DrillDown_Script ProcessDetails.ps1 -DrillDown_Parameter {$_.Id}

See Also

Digital_DrillDown Parameter | Digital_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

  • In most cases this parameter is not necessary when implementing drilldown with gauges.

Example

To use the DrillDown_Parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName}

See Also

Digital_DrillDown Parameter | Digital_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

ps | out-gauge -DrillDown_Parameter {$_.ProcessName} -DrillDown_Script get-process -DrillDown_Console

See Also

Digital_DrillDown Parameter | Digital_DrillDown Summary


Floating property of gauge Parameter

Floating Parameter

Allows you to launch a gauge without a window frame.

Remarks

  • Use Floating to launch a gauge without a window frame making the gauge appear as it were floating over the desktop.

Example

To launch a gauge without a window frame configuring the Floating parameter:

out-gauge -Type Digital -Floating

See Also

Digital Parameter | Digital Summary


Font property of BaseGauge Parameter

Font Parameter

Sets the font type which will be used by default in the gauge.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To configure the Font

out-gauge -Type Digital -Font "Arial, 5"

See Also

Digital Parameter | Digital Summary


Glass property of gauge Parameter

Glass Parameter

Allows you to configure the gauge background to b painted using Glass form.

Remarks

  • When running in Windows Vista, the chart background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-gauge -Type Digital -Glass

See Also

Digital Parameter | Digital Summary


HideFromAltTab property of BaseGauge Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-gauge -Type Digital -HideFromAltTab

See Also

Digital Parameter | Digital Summary


Images_<index> property of BaseGauge Parameter

Images_<index> Parameter

Allows you to accesss the images for a gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | Zero based index specifying an ImageAnnotation item in the collection.

Remarks

  • You'll have to add an image item ("Bitmap" or "Vector") in order to configure a particular Image:

    -Images_Add Bitmap or -Images_Add Vector.

  • This parameter allows you to configure a particular image. You may also specifying an index value to access a specific image item in Gauge.

Example

To add and configure a Images angle:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 10

See Also

Digital Parameter | Digital Summary


BitmapImage Class Members

Digital_Images Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Image | Represents the actual Image object in the gauge.
Layout | Allows you to access the layout object for an Annotation.
Size | A numeric size modifier applied in conjunction with a Custom setting.
SizeMode | Defines the display size options for the background image.
Visible | Sets a value indicating whether an object is visible or not.


Images_<index>_Angle property of Annotation Parameter

Images_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Images Angle to 45 degrees:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Angle 45

See Also

Digital_Images Parameter | Digital_Images Summary


Images_<index>_Image property of BitmapImage Parameter

Images_<index>_Image Parameter

Represents the actual Image object in the gauge.

Remarks

  • Images that are larger than the gauge are not automatically scaled.

  • Use the Image parameter to configure the image path.

Example

Here is an example of setting the Images Image

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png"

See Also

Digital_Images Parameter | Digital_Images Summary


Images_<index>_Layout property of Annotation Parameter

Images_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_Images Parameter | Digital_Images Summary


LayoutAttributes Class Members

Digital_Images_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Images_<index>_Layout_Alignment property of LayoutAttributes Parameter

Images_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Images Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Alignment MiddleCenter

See Also

Digital_Images_Layout Parameter | Digital_Images_Layout Summary


Images_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Images_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Images Layout AnchorPoint to a specific position:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Layout_Target AnchorPoint -Images_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_Images_Layout Parameter | Digital_Images_Layout Summary


Images_<index>_Layout_Target property of LayoutAttributes Parameter

Images_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_Images_Layout Parameter | Digital_Images_Layout Summary


Images_<index>_Size property of BaseImage Parameter

Images_<index>_Size Parameter

A numeric size modifier applied in conjunction with a Custom SizeMode setting.

Remarks

  • This value scales the image to the inner gauge radius. If a circular image is used and the Size is set to 1, then the image will fit nicely in the middle of the gauge.

Example

To set the Images Size:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Custom -Images_0_Size 1.2

See Also

Digital_Images Parameter | Digital_Images Summary


Images_<index>_SizeMode property of BaseImage Parameter

Images_<index>_SizeMode Parameter

Defines the display size options for the background image.

Default Value
The default is Normal.

Value | Meaning
Normal | The image is placed in the center of the container, in its original size. The image is clipped if it is larger than the container.
Stretch | The image is stretched or shrunk to fit the size of the container.
Custom | The image size will be custom set by the Size property.

Remarks

  • When using the Custom value a size can be specified using the Size property.

Example

To set the Images SizeMode to Stretch:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_SizeMode Stretch

See Also

Digital_Images Parameter | Digital_Images Summary


Images_<index>_Visible property of BaseViewable Parameter

Images_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Images Visible to false:

out-gauge -Type Digital -Images_Add Bitmap -Images_0_Image "MyImage.png" -Images_0_Visible false

See Also

Digital_Images Parameter | Digital_Images Summary


InnerGauges_<index> property of BaseGauge Parameter

InnerGauges_<index> Parameter

The collection of InnerGauges currently associated with the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | The zero-based index of the element to get.

Remarks

  • The entire collection may be returned or a specific InnerGauge instance referenced via the index.

See Also

Digital Parameter | Digital Summary


InnerDigitalPanel Class Members

Digital_InnerGauges_InnerDigitalPanel Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
DigitalPanel | Returns the DigitalPanel object for an inner digital meter.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_Angle 45

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_DigitalPanel property of InnerDigitalPanel Parameter

InnerGauges_<index>_DigitalPanel Parameter

Returns the DigitalPanel object for an inner digital meter.

Remarks

  • This property is used to return the DigitalPanel object for an inner digital Panel. For additional information regarding supported members, please see the Parameter.

Example

To configure the InnerGauges DigitalPanel Font:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_DigitalPanel_Font "Arial, 5"

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


LayoutAttributes Class Members

Digital_InnerGauges_InnerDigitalPanel_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Digital_InnerGauges_InnerDigitalPanel_Layout Parameter | Digital_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_InnerGauges_InnerDigitalPanel_Layout Parameter | Digital_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_InnerGauges_InnerDigitalPanel_Layout Parameter | Digital_InnerGauges_InnerDigitalPanel_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_LinkToMainValue true

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_Size "0.3, 0.5"

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Digital -InnerGauges_Add Digital -InnerGauges_0_Visible false

See Also

Digital_InnerGauges_InnerDigitalPanel Parameter | Digital_InnerGauges_InnerDigitalPanel Summary


InnerHorizontalGauge Class Members

Digital_InnerGauges_InnerHorizontalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
HorizontalGauge | Exposes the HorizontalGauge properties of the InnerGauge.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_Angle 45

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_HorizontalGauge property of InnerHorizontalGauge Parameter

InnerGauges_<index>_HorizontalGauge Parameter

Exposes the HorizontalGauge properties of the InnerGauge.

Remarks

  • This property is used to return the HorizontalGauge object for an inner horizontal gauge. For additional information regarding supported members, please see the Parameter.

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


LayoutAttributes Class Members

Digital_InnerGauges_InnerHorizontalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Digital_InnerGauges_InnerHorizontalGauge_Layout Parameter | Digital_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_InnerGauges_InnerHorizontalGauge_Layout Parameter | Digital_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_InnerGauges_InnerHorizontalGauge_Layout Parameter | Digital_InnerGauges_InnerHorizontalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_LinkToMainValue true

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_Size "0.3, 0.5"

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Digital -InnerGauges_Add Horizontal -InnerGauges_0_Visible false

See Also

Digital_InnerGauges_InnerHorizontalGauge Parameter | Digital_InnerGauges_InnerHorizontalGauge Summary


InnerRadialGauge Class Members

Digital_InnerGauges_InnerRadialGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
RadialGauge | Returns the RadialGauge object for an inner radial gauge.
Size | Sets the InnerGauge size
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_Angle 45

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


LayoutAttributes Class Members

Digital_InnerGauges_InnerRadialGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Digital_InnerGauges_InnerRadialGauge_Layout Parameter | Digital_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_InnerGauges_InnerRadialGauge_Layout Parameter | Digital_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_InnerGauges_InnerRadialGauge_Layout Parameter | Digital_InnerGauges_InnerRadialGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_LinkToMainValue true

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_RadialGauge property of InnerRadialGauge Parameter

InnerGauges_<index>_RadialGauge Parameter

Returns the RadialGauge object for an inner radial gauge.

Remarks

  • This property is used to return the RadialGauge object for an inner radial gauge. For additional information regarding supported members, please see the Parameter.

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Size property of InnerRadialGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the InnerGauge size

Remarks

  • The InnerGauge is scaled based on the value provided in this property. A value of 2.0 or greater will scale the InnerGauge larger than the Main Gauge.

Example

To set the InnerGauges Size value for a Inner Radial Gauge:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_Size 0.4

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Digital -InnerGauges_Add Radial -InnerGauges_0_Visible false

See Also

Digital_InnerGauges_InnerRadialGauge Parameter | Digital_InnerGauges_InnerRadialGauge Summary


InnerVerticalGauge Class Members

Digital_InnerGauges_InnerVerticalGauge Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Layout | Allows you to access the layout object for an Annotation.
LinkToMainValue | Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.
Size | Sets the size for a inner linear gauge.
VerticalGauge | Returns the LinearGauge object for an inner linear gauge.
Visible | Sets a value indicating whether an object is visible or not.


InnerGauges_<index>_Angle property of Annotation Parameter

InnerGauges_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the InnerGauges Angle to 45 degrees:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_Angle 45

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Layout property of Annotation Parameter

InnerGauges_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


LayoutAttributes Class Members

Digital_InnerGauges_InnerVerticalGauge_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


InnerGauges_<index>_Layout_Alignment property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the InnerGauges Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_Layout_Alignment MiddleCenter

See Also

Digital_InnerGauges_InnerVerticalGauge_Layout Parameter | Digital_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the InnerGauges Layout AnchorPoint to a specific position:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_Layout_Target AnchorPoint -InnerGauges_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_InnerGauges_InnerVerticalGauge_Layout Parameter | Digital_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_Layout_Target property of LayoutAttributes Parameter

InnerGauges_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_InnerGauges_InnerVerticalGauge_Layout Parameter | Digital_InnerGauges_InnerVerticalGauge_Layout Summary


InnerGauges_<index>_LinkToMainValue property of InnerBaseGauge Parameter

InnerGauges_<index>_LinkToMainValue Parameter

Sets a value indicating whether to display the value of a parent gauge as the inner gauge value.

Remarks

  • When set the True, the value of the MainIndicator of a gauge will be used for the value in a inner gauge.

Example

To configure the inner gauge value to the value of the parent gauge:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_LinkToMainValue true

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Size property of InnerBaseLinearGauge Parameter

InnerGauges_<index>_Size Parameter

Sets the size for a inner linear gauge.

Remarks

  • Use the Size parameter to configure the size for an inner Linear (Horizontal, Vertical or Digital) gauge.

Example

To set the InnerGauges Size:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_Size "0.3, 0.5"

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_VerticalGauge property of InnerVerticalGauge Parameter

InnerGauges_<index>_VerticalGauge Parameter

Returns the LinearGauge object for an inner linear gauge.

Remarks

  • This property is used to return the LinearGauge object for an inner linear gauge. For additional information regarding supported members, please see the Parameter.

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


InnerGauges_<index>_Visible property of BaseViewable Parameter

InnerGauges_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the InnerGauges Visible to false:

out-gauge -Type Digital -InnerGauges_Add Vertical -InnerGauges_0_Visible false

See Also

Digital_InnerGauges_InnerVerticalGauge Parameter | Digital_InnerGauges_InnerVerticalGauge Summary


Location property of gauge Parameter

Location Parameter

Allows you to configure the gauge's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the gauge from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a Location for the gauge:

out-gauge -Type Digital -Location 10,10

See Also

Digital Parameter | Digital Summary


Modal property of gauge Parameter

Modal Parameter

Allows you to block the command pipe while displaying a gauge.

Remarks

  • Use Modal to block the command pipe while displaying a gauge.

Example

To create a gauge blocking the command pipe by configuinr the Modal parameter:

out-gauge -Type Digital -Modal

See Also

Digital Parameter | Digital Summary


Output property of gauge Parameter

Output Parameter

Allows you to generate a gauge file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a gauge file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate an Output image (.png) of the gauge:

out-gauge -Type Digital -Output test.png

See Also

Digital Parameter | Digital Summary


Palette property of BaseGauge Parameter

Palette Parameter

Allows you to set a Chart FX pre-defined palette.

Value | Meaning
Default | Set the palette to Default.
Alternate | Set the palette to Alternate.
Autumn | Set the palette to an Autumn scheme.
BrownSugar | Set the palette to a BrownSugar scheme.
ChartFX6 | Set the palette to the ChartFX 6 scheme.
Classic | Set the palette to Classic.
Colorful | Set the palette to a Colorful scheme.
DarkPastels | Set the palette to a DarkPastels scheme.
Earthtones | Set the palette to an Earthtones scheme.
HighContrast | Set the palette to a HighContrast scheme.
LilacsInMist | Set the palette to LilacsInMist scheme.
Mesa | Set the palette to Mesa scheme.
ModernBusiness | Set the palette to a ModernBusiness scheme.
NatureAdventure | Set the palette to a NatureAdventure scheme.
NatureSky | Set the palette to a NatureSky scheme.
Oceanica | Set the palette to Oceanica scheme.
Professional | Set the palette to a Professional scheme.
RainyDay | Set the palette to a RainyDay scheme.
SandAndSky | Set the palette to a SandAndSky scheme.
Simple | Set the palette to a Simple scheme.
Slate | Set the palette to Slate scheme.
SnowyPine | Set the palette to SnowyPine.
Vivid | Set the palette to a Vivid scheme.
Windows | Set the palette to a Windows scheme.

Remarks

  • When changing the palette, all the properties related to changing colors in the gauge will also be affected as PowerGadgets will change the windows palette for the chart window. So if you previously set a color using any of the PowerGadgets supported properties this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • For the most updated list of supported palettes, check the Palette property in the design time Property dialog.

Example

To set the Palette to NatureSky:

out-gauge -Type Digital -Palette NatureSky

See Also

Digital Parameter | Digital Summary


Refresh property of gauge Parameter

Refresh Parameter

Allows you to refresh the gauge with new data by executing the same command(s) that populated the gauge at the first time.

Remarks

  • If the command returns a single value per each series, the gauge will add a new point to the end. Otherwise, the whole gauge data is replaced with the new data.

Example

To Refresh every 1 second the gauge populated with the processes (PS>get-process ):

ps | out-gauge -Type Digital -Refresh 0:0:1

See Also

Digital Parameter | Digital Summary


Size property of gauge Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered gauge.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered gauge.

Example

To configure the Size of the gauge:

out-gauge -Type Digital -Size 800,600

See Also

Digital Parameter | Digital Summary


Style property of gauge Parameter

Style Parameter

Allows you to set different styles for the gauge. A style defines a particular look in a gauge by combining a number of properties in an aesthetically pleasant way.

Remarks

  • There are 10 different styles for radial gauges: Style 0 through Style 10.

  • Styles do not include color settings, thus palette colors are used.

Example

To set the Style parameter to use the fourth style:

out-gauge -Type Digital -Style 4

See Also

Digital Parameter | Digital Summary


Template property of gauge Parameter

Template Parameter

Allows you to use or save gauge modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for gauge.

Example

To use a pre-configured template called MyProcesses:

out-gauge -template MyProcesses

To use a graphical Wizard to configure a Tamplate gauge:

out-gauge -configure -template MyProcesses

See Also

Digital Parameter | Digital Summary


Titles_<index> property of BaseGauge Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the gauge.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set the Titles Color to Red:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Digital Parameter | Digital Summary


Title Class Members

Digital_Titles Parameters

Parameters

Description

Angle | Sets the rotation angle in degrees for an annotation.
Color | Sets the color of text for the specified title.
Font | Sets the Gauge Font object for a gauge title.
Layout | Allows you to access the layout object for an Annotation.
Text | Sets the text for the selected title.
Visible | Sets a value indicating whether an object is visible or not.


Titles_<index>_Angle property of Annotation Parameter

Titles_<index>_Angle Parameter

Sets the rotation angle in degrees for an annotation.

Example

To set the Titles Angle to 45 degrees:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Angle 45

See Also

Digital_Titles Parameter | Digital_Titles Summary


Titles_<index>_Color property of Title Parameter

Titles_<index>_Color Parameter

Sets the color of text for the specified title.

Remarks

  • The Text propety is used to set the caption for a title.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles Color to Red:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Color Red

See Also

Digital_Titles Parameter | Digital_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Sets the Gauge Font object for a gauge title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Titles Font:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Font "Arial, 5"

See Also

Digital_Titles Parameter | Digital_Titles Summary


Titles_<index>_Layout property of Annotation Parameter

Titles_<index>_Layout Parameter

Allows you to access the layout object for an Annotation.

Remarks

  • The Layout object allows you to manipulate the Aligment and Anchoring position of an Annotation inside the Gauge.

See Also

Digital_Titles Parameter | Digital_Titles Summary


LayoutAttributes Class Members

Digital_Titles_Layout Parameters

Parameters

Description

Alignment | Sets the alignment for a layout object.
AnchorPoint | Sets the location for a Layout object.
Target | Set the Target of a Layout object.


Titles_<index>_Layout_Alignment property of LayoutAttributes Parameter

Titles_<index>_Layout_Alignment Parameter

Sets the alignment for a layout object.

Remarks

  • The Aligment property is used to align objects based off of the configured Target.

  • When the target is set to AnchorPoint, the object will be "Anchored" in the selected custom position.

Example

To set the Titles Layout Alignment to the MiddleCenter:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Layout_Alignment MiddleCenter

See Also

Digital_Titles_Layout Parameter | Digital_Titles_Layout Summary


Titles_<index>_Layout_AnchorPoint property of LayoutAttributes Parameter

Titles_<index>_Layout_AnchorPoint Parameter

Sets the location for a Layout object.

Remarks

  • The AnchorPoint is used to freely position a Layout object inside a Gauge. The top right corner of a gauge is (0,0), the center is (5,5), and the lower left corner is (10,10).

  • The AnchorPoint is ony used if the Target is set to AnchorPoint.

Example

To set the Titles Layout AnchorPoint to a specific position:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Layout_Target AnchorPoint -Titles_0_Layout_AnchorPoint "0.4, 0.5"

See Also

Digital_Titles_Layout Parameter | Digital_Titles_Layout Summary


Titles_<index>_Layout_Target property of LayoutAttributes Parameter

Titles_<index>_Layout_Target Parameter

Set the Target of a Layout object.

Default Value
The default is Border.

Value | Meaning
AnchorPoint | Layout is related to the Anchor Point.
Border | Layout is related to the Border.

Remarks

  • The Target wil determine the behaviour of the Alignment.

  • When the target is set to AnchorPoint, the AnchorPoint should be used to position the layout object.

See Also

Digital_Titles_Layout Parameter | Digital_Titles_Layout Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The Color property allows you to change the color of the specified title text.

  • The Font property may be used to modify the font for a title.

Example

To set the Titles Text:

out-gauge -Type Digital -Titles_0_Text "My Text"

See Also

Digital_Titles Parameter | Digital_Titles Summary


Titles_<index>_Visible property of BaseViewable Parameter

Titles_<index>_Visible Parameter

Sets a value indicating whether an object is visible or not.

Remarks

  • When set the false, the object is not visible.

Example

Here is an example of setting the Titles Visible to false:

out-gauge -Type Digital -Titles_0_Text "My Text" -Titles_0_Visible false

See Also

Digital_Titles Parameter | Digital_Titles Summary


ToolTip property of BaseGauge Parameter

ToolTip Parameter

Sets the tool tip text.

Remarks

  • The configured tool tip value will be displayed when a user hovers their mouse cursor over the gauge object. This tool tip will be displayed when the cursor is moved over any section of the gauge.

  • The ToolTipEnabled property may be used to control whether or not a tool tip will be diplayed for a gauge.

Example

To set the ToolTip:

out-gauge -Type Digital -ToolTip "My Text"

See Also

Digital Parameter | Digital Summary


ToolTipEnabled property of BaseGauge Parameter

ToolTipEnabled Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the gauge area.

Remarks

  • Tooltips allow the user to easily recognize the appropriate PowerGadgets element.

Example

To set the ToolTipEnabled to false:

out-gauge -Type Digital -ToolTipEnabled false

See Also

Digital Parameter | Digital Summary


Type property of gauge Parameter

Type Parameter

Allows you to specify the gauge type (Radial, Horizontal, Vertical and Digital).

Remarks

  • Use the Type parameter to specify the Gauge Type. This are the types: Radial, Horizontal, Vertical and Digital.

  • If the Type parameter is not configured the gauge Type would be Radial.

Example

To configure the Type parameter to get a Horizontal:

out-gauge -Type Horizontal

To configure the Type parameter to get a Vertical:

out-gauge -Type Vertical

To configure the Type parameter to get a Digital:

out-gauge -Type Digital

See Also

Digital Parameter | Digital Summary


Value property of DigitalPanel Parameter

Value Parameter

Sets the value for a Digital Panel.

Remarks

  • This property is used to control the value for a Digital Panel. The default value is 100.

  • The Appearance property is used to return the DigitalAppearance for a Digital Panel. The is used to customize the display of segents or LEDs.

  • The ValueFormat property may be used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

Example

To set the value for a digital panel:

See Also

Digital Parameter | Digital Summary


ValueFormat property of DigitalPanel Parameter

ValueFormat Parameter

Sets the numeric format string for a Digital Panel.

Remarks

  • This property is used to configure a string mask to format the display of values. Please see Custom Numeric Format in your development environment documentation.

  • The Value property to control the value for a Digital Panel. The default value is 100.

Example

To set the ValueFormat:

out-gauge -Type Digital -ValueFormat "###.00"

See Also

Digital Parameter | Digital Summary


ValuePadding property of DigitalPanel Parameter

ValuePadding Parameter

Sets the number of digit placeholders in the panel.

Remarks

  • If no padding value is specified, then the gauge will format the display based on the current value.

See Also

Digital Parameter | Digital Summary


Chart Class Members

Map Parameters

Parameters

Description

AllSeries | Gets the global attributes which are shared across the of the chart.
Anchor | Allows you to specify the general location of the chart with respect to your desktop.
Antialiasing | Gives a smooth visual effect to the chart.
BackColor | Sets the background color of the chart.
Caption | Modifies the caption used in the PowerGadget window
ColHeadings | Allows you to specifies which fields to use in crosstab chart as column headings.
ColorFrom | Allows you to set the beginning color for the range of colors to use with the various groups.
ColorTo | Allows you to set the ending color for the range of colors to use with the various groups.
Condition | Allows you to apply Conditional Attributes in the chart.
ConditionalAttributes | Returns the collection of objects.
Configure | Allows you to use a graphical Wizard to customize the chart.
ContextMenus | Allows you to enable or disable context sensitive menus when the user right clicks a particular chart element.
CreateLabelLinkFile | Used to create an initial file for linking and associating incoming data values to the map object name.
Crosshairs | Enables or Disables the cross-hairs marker in the chart.
Culture | Allows you to localize charts for a specific language and region.
DataGrid | Gets the MenuBar of the chart. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the chart and the grid at the same time.
DefaultAttributes | Allows you to configure the DefaultAttributes object for the map.
DrillDownMode | Sets the DrillDown mode for a map.
ExtraStyle | Allows you to set additional visual attributes in the chart.
Floating | Allows you to launch a chart without a window frame.
Font | Sets the font type which will be used by default in the chart.
ForeColor | Sets the default font color of the chart.
Glass | Allows you to configure the gauge background to be painted using Glass form.
Group | Allows you to create the chart window as a separate process and assigns an ID that allows multiple charts to share the same window.
HideFromAltTab | If specified, the gadget will not appear when the user presses Alt-Tab.
Label | Allows you to specify which property to use as the X labels.
LabelLinkFile | Sets a path for an XML file of the LabelLink attributes.
LabelStyles | Flag property that allows setting attributes for map labels contained in the map extension.
LabelStylesSettings | Used to access the LabelStylesSettings object for the map.
LegendBox | Allows you to acces the legend box of the chart.
ListObjects | Lists all the objects available in the currently selected mapsource where data can be bound and associated to.
Location | Allows you to configure the chart's location in pixels.
MapSource | Sets the SVG to be used for the Map object.
MenuBar | Allows you to access the menu bar of the chart. Alternativelly, you can access the tool bar of the chart using ToolBar.
Modal | Allows you to block the command pipe while displaying a chart.
Name | Allows you to assign a name to chart.
Output | Allows you to generate a chart file instead of an interactive one.
Palette | Allows you to set a pre-defined palette.
PlotAreaMargin | Gets and Sets the top, bottom, left and right gaps of the chart.
Points | Assigns properties directly to a specific point in the chart.
Refresh | Allows you to refresh the chart with new data by executing the same command(s) that populated the chart at the first time.
RegionAlternateTextColor | Get or set the color used for all complex labels in a map.
RowHeadings | Allows you to specifies which fields to use in crosstab chart as row headings.
Series | Assigns properties directly to the selected series in the chart.
Size | Allows you to specify the actual dimension of the final rendered chart.
Steps | Allows you to set the number of equal size ranges designated to spanning from the minimum value to the maximum value of the data.
Template | Allows you to use or save chart modifications into a template file.
Titles | Returns the collection of titles defined in the chart.
TitleFont | Used to assign a new font object for double DrillDown titles.
ToolBar | Allow to acces the tool bar of the chart. Alternativelly, you can access the tool bar of the chart using MenuBar.
ToolTipFields | Use Values to specifie the properties to consider for plotting data. Only numeric properties can be plotted. If omitted, all the numeric properties are plo tted or the properties specified by default views file.
ToolTipFormat | Allows you to control the information to be displayed in the tooltip when the user positions the mouse over a particular data point in the chart.
ToolTips | Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the chart area only.
Values | Allows you to specify which properties to chart.
WinnerSeriesType | Sets the mode which the winning series is determined.

@2006 PowerGadgets LLC. All Rights Reserved. PowerGadgets is a registered trademark of PowerGadgets, LLC


AllSeries property of Chart Parameter

AllSeries Parameter

Gets the global attributes which are shared across the series of the map.

Remarks

  • For performance reason, the series and the points related to the series share the same visual attributes. Therefore, to set a attribute common to all the points of the map, AllSeries should be used. If the user wants to change a visual attribute for a particular series, Series should be used. Similarly, if the user wants to change a visual attribute for a particular point, Points should be used.

Example

To set the FillMode to Pattern:

Out-Map -AllSeries_FillMode Pattern

See Also

Map Parameter | Map Summary


GlobalAttributes Class Members

Map_AllSeries Parameters

Parameters

Description

AlternateColor | Sets the Alternate Color for a all the Series.
Color | Sets the color for all series.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
MultipleColors | Gets and sets the Multiple colors to allow for independently colored data points.
Pattern | Sets the Pattern for all the series in a chart.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.


AllSeries_AlternateColor property of GlobalAttributes Parameter

AllSeries_AlternateColor Parameter

Sets the Alternate Color for a all the Series.

Remarks

  • The AlternateColor is used in combination with the Color property to achive a gradient fill effect in the Series markers. The gradient will go from the Color to the AlternateColor.

  • This property also requires the property to be set to Gradient.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set the AllSeries AlternateColor:

Out-Map -AllSeries_FillMode Gradient -AllSeries_AlternateColor Red

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


AllSeries_Color property of GlobalAttributes Parameter

AllSeries_Color Parameter

Sets the color for all series.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the map, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set the AllSeries Color:

Out-Map -AllSeries_Color Red

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


AllSeries_FillMode property of PointAttributes Parameter

AllSeries_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the maps. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the map.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the AllSeries FillMode:

Out-Map -AllSeries_FillMode Pattern

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


AllSeries_MultipleColors property of GlobalAttributes Parameter

AllSeries_MultipleColors Parameter

Gets and sets the Multiple colors to allow for independently colored data points.

Remarks

  • When set to True all data points on a series will have a unique color. When set to False all the data points in the series will assume the same color.

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set the AllSeries MultipleColors:

Out-Map -AllSeries_MultipleColors true

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


AllSeries_Pattern property of GlobalAttributes Parameter

AllSeries_Pattern Parameter

Sets the Pattern for all the series in a map.

Remarks

  • To use this property, you must make sure the FillMode is set to either Monochrome or Pattern.

  • If the FillMode is set to Pattern you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • This property applies to all series. You can then override this value by setting the same property for a specific series.

Example

To set the AllSeries Pattern:

Out-Map -AllSeries_Pattern Cross

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


AllSeries_PointLabels property of PointAttributes Parameter

AllSeries_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To set the AllSeries PointLabels Visible:

Out-Map -AllSeries_PointLabels_Visible true

See Also

Map_AllSeries Parameter | Map_AllSeries Summary


PointLabelAttributes Class Members

Map_AllSeries_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


AllSeries_PointLabels_Alignment property of PointLabelAttributes Parameter

AllSeries_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the AllSeries PointLabels Alignment:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_Alignment Near

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_Angle property of PointLabelAttributes Parameter

AllSeries_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the AllSeries PointLabels Angle:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_Angle 45

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_BackColor property of PointLabelAttributes Parameter

AllSeries_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries PointLabels BackColor:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_BackColor Yellow

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_Font property of PointLabelAttributes Parameter

AllSeries_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired map element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the AllSeries PointLabels Font:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_Font "Arial, 12"

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_Format property of PointLabelAttributes Parameter

AllSeries_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY maps, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked maps).

    X displays the marker X value for any map type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To set the AllSeries PointLabels Format:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_Format "I'm point # %N"

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_LineAlignment property of PointLabelAttributes Parameter

AllSeries_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the AllSeries PointLabels LineAlignment:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_LineAlignment Far

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_Offset property of PointLabelAttributes Parameter

AllSeries_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

To set the AllSeries PointLabels Offset:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_Offset "4, 5"

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_RichText property of PointLabelAttributes Parameter

AllSeries_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To set the AllSeries PointLabels RichText:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_RichText true

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_TextColor property of PointLabelAttributes Parameter

AllSeries_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the AllSeries PointLabels TextColor:

Out-Map -AllSeries_PointLabels_Visible true -AllSeries_PointLabels_TextColor Red

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


AllSeries_PointLabels_Visible property of PointLabelAttributes Parameter

AllSeries_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the AllSeries PointLabels Visible:

Out-Map -AllSeries_PointLabels_Visible true

See Also

Map_AllSeries_PointLabels Parameter | Map_AllSeries_PointLabels Summary


Anchor property of Chart Parameter

Anchor Parameter

Allows you to specify the general location of the map with respect to your desktop.

Remarks

  • If you anchor topleft and wish to offset the map from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

  • There are four locations where it may be anchored: topleft (default), topright, bottomleft, bottomright

Example

To set the anchor parameter to TopRight:

Out-Map -anchor TopRight

See Also

Map Parameter | Map Summary


Antialiasing property of Chart Parameter

Antialiasing Parameter

Gives a smooth visual effect to the map.

Remarks

  • The ExtraStyle parameter also supports a DoubleBuffer value that can prevent flickering in real-time maps.

  • The ExtraStyle property also supports a DoubleBuffer enumeration that can prevent flickering in real-time maps.

Example

To set the Antialiasing:

Out-Map -Antialiasing true

See Also

Map Parameter | Map Summary


BackColor property of Chart Parameter

BackColor Parameter

Sets the background color of the map.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the BackColor:

Out-Map -BackColor Blue

See Also

Map Parameter | Map Summary


Caption property of Chart Parameter

Caption Parameter

Modifies the caption used in the PowerGadget window

Remarks

  • Use Caption to configure the PowerGadget window caption.

Example

To configure the caption in the PowerGadget window:

Out-Map -Caption "My PowerGadget"

See Also

Map Parameter | Map Summary


ColHeadings property of Chart Parameter

ColHeadings Parameter

Allows you to specifies which fields to use in crosstab map as column headings.

Remarks

  • Use ColHeadings to specifies which fields to use in crosstab map as column headings.

  • Use RowHeadings to specifies which fields to use in crosstab map as column headings.

Example

To configure the ColHeadings parameter to use the Handles and WorkingSet:

ps | Out-Map -ColHeadings Handles,WorkingSet

See Also

Map Parameter | Map Summary


ColorFrom property of Chart Parameter

ColorFrom Parameter

Allows you to set the beginning color for the range of colors to use with the various groups.

Remarks

  • When defining steps (see Steps), the color of each range can be customized by using this parameter in conjunction with the ColorTo parameter.

  • If only ColorFrom is set, then gradient colors will be formed similar and close to the color selected.

  • ColorFrom and ColorTo will override colors specified in conditional attributes unless both colors from conditionalattributes are set

Example

To set the ColorFrom parameter to Red:

Out-Map -ColorFrom Red

See Also

Map Parameter | Map Summary


ColorTo property of Chart Parameter

ColorTo Parameter

Allows you to set the ending color for the range of colors to use with the various groups.

Remarks

  • When defining steps (see Steps), the color of each range can be customized by using this parameter in conjunction with the ColorFrom parameter.

  • If only ColorTo is set, then gradient colors will be formed similar and close to the color selected.

  • ColorFrom and ColorTo will override colors specified in conditional attributes unless both colors from conditionalattributes are set

Example

To set the ColorTo parameter to Red:

Out-Map -ColorTo Yellow

See Also

Map Parameter | Map Summary


Condition property of Chart Parameter

Condition Parameter

Allows you to apply Conditional Attributes in the map.

Remarks

  • Use Condition to apply Condiotional Attributes to the map.

  • The ConditionalAttributes parameter is another way to apply Conditional Attributes to the map.

Example

To configure a map populated with images (*.bmp) grater than 1000 KB:

dir *.bmp | Out-Map -values Length -condition {$_.Length -gt 1000} -Gallery Bar

See Also

Map Parameter | Map Summary


ConditionalAttributes Parameter

Remarks

The members of the ConditionalAttributes Parameter allow developers to control when special attributes should be applied to the map and what map elements will be taken into consideration when they are applied.

Once the Parameter has been configured with the desired attributes, the object may be assigned to a map's point, based on the configured conditions. The value of each point in the map is evaluated based on the conditions of each ConditionalAttributes item. Points that meet the conditions of a particular conditional attribute item will be retain the settings of that item. For more information regarding the configuration of the conditions, please see the Parameter.

The conditional attributes must be defined before the is populated.


ConditionalAttributes Class Members

Map_ConditionalAttributes Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
Color | Allows you to set a color for the selected item.
Condition | Returns a Condition object for the specified ConditionalAttributes object.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Pattern | Sets a value specifying the pattern for the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
Series | Sets a value indicating which series index the ConditionalAttribute will be applied.
Text | Sets a value for labeling the point or series attribute.


ConditionalAttributes_<index>_AlternateColor property of PointAttributes Parameter

ConditionalAttributes_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To set the ConditionalAttributes AlternateColor:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_FillType Gradient -ConditionalAttributes_0_AlternateColor Red

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


ConditionalAttributes_<index>_Color property of PointAttributes Parameter

ConditionalAttributes_<index>_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the map, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the ConditionalAttributes Color:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_Color Green

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


ConditionalAttributes_<index>_Condition property of ConditionalAttributes Parameter

ConditionalAttributes_<index>_Condition Parameter

Returns a Condition object for the specified ConditionalAttributes object.

Remarks

  • You may use this object to manipulate the conditions in which the ConditionalAttribute applies.

Example

To configure a ConditionalAttributes object:

Out-Map -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


Condition Class Members

Map_ConditionalAttributes_Condition Parameters

Parameters

Description

Active | Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.
DataElement | Sets the data value that the specified ConditionalAttribute will evaluate.
From | Sets a value indicating the beginning value of the conditional range for a selected object.
FromOpen | Sets a value indicating whether or not to include the configured From value in the range.
Inverse | Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.
To | Sets a value indicating the ending value of the conditional range for a selected object.
ToOpen | Sets a value indicating whether or not to include the configured To value in the range.


ConditionalAttributes_<index>_Condition_Active property of Condition Parameter

ConditionalAttributes_<index>_Condition_Active Parameter

Sets a value indicating whether the specified ConditionalAttribute is enabled or disabled.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

Example

To configure the 1st Conditional attribute as inactive:

Out-Map -ConditionalAttributes_0_Condition_Active false

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_DataElement property of Condition Parameter

ConditionalAttributes_<index>_Condition_DataElement Parameter

Sets the data value that the specified ConditionalAttribute will evaluate.

Default Value
The default is YValue.

Value | Meaning
YValue | Instructs the chart to treat the selected field as a number. Therefore an additional data series.
XValue | Instructs the chart to treat the selected field as a number to be used as the X axis coordinate. Use this option if you are creating XY Plots.
IniValue | Instructs the chart to treat the selected field as a number to be used to set initial values for data points to achieve floating bars and area charts.

Remarks

  • By default, the YValue for the map is evaluated for a condition. You can use this property to select to evaluate the IniValue or XValue for each point contained in the map.

  • Use the Active property to specify if a selected ConditionalAttributes object may be applied to a map.

  • The To property is used to specify the ending value of the conditional range for a selected object. The ToOpen property indicates whether or not to include the configured To value in the range.

  • The From property is used to specify the beginning value of the conditional range for a selected object. The FromOpen property indicates whether or not to include the configured From value in the range.

  • Use the Inverse property to reverse the configured To and From attributes and create the opposite condition configured.

Example

To evaluate the XValue to apply the 1st conditional attribute:

Out-Map -ConditionalAttributes_0_Condition_DataElement XValue

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_From property of Condition Parameter

ConditionalAttributes_<index>_Condition_From Parameter

Sets a value indicating the beginning value of the conditional range for a selected ConditionalAttributes object.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set 80 as the From attribute.

Out-Map -ConditionalAttributes_0_Condition_From 80 -ConditionalAttributes_0_Color Red

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_FromOpen property of Condition Parameter

ConditionalAttributes_<index>_Condition_FromOpen Parameter

Sets a value indicating whether or not to include the configured From value in the range.

Remarks

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set FromOpen to true for a conditional attribute:

Out-Map -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50 -ConditionalAttributes_0_Condition_FromOpen true

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_Inverse property of Condition Parameter

ConditionalAttributes_<index>_Condition_Inverse Parameter

Sets a value indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To configure the 1st ConditionalAttribute to be inversed:

Out-Map -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_From 50 -ConditionalAttributes_0_Condition_Inverse true

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_To property of Condition Parameter

ConditionalAttributes_<index>_Condition_To Parameter

Sets a value indicating the ending value of the conditional range for a selected ConditionalAttributes object.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set 30 as the To attribute for the 1st ConditionalAttribute:

Out-Map -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_To 30

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_Condition_ToOpen property of Condition Parameter

ConditionalAttributes_<index>_Condition_ToOpen Parameter

Sets a value indicating whether or not to include the configured To value in the range.

Remarks

  • The To property gets or sets a value indicating the ending value of the conditional range for a selected object. The ToOpen property is a boolean indicating whether or not to include the configured To value in the range.

  • The From property gets or sets a value indicating the beginning value of the conditional range for a selected object. The FromOpen property is a boolean indicating whether or not to include the configured From value in the range.

  • The Inverse property is a boolean indicating whether to reverse the configured To and From attributes for a selected ConditionalAttributes object.

  • The DataElement property is used to configure what data value will be evaluated when determining the assignment of conditional attributes.

  • The Active property is a boolean indicating whether the specified ConditionalAttribute is enabled or disabled.

Example

To set ToOpen to true for the 1st conditional attribute:

Out-Map -ConditionalAttributes_0_Color Red -ConditionalAttributes_0_Condition_To 50 -ConditionalAttributes_0_Condition_ToOpen true

See Also

Map_ConditionalAttributes_Condition Parameter | Map_ConditionalAttributes_Condition Summary


ConditionalAttributes_<index>_FillMode property of PointAttributes Parameter

ConditionalAttributes_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the maps. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the map.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the ConditionalAttributes FillMode:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_FillMode Pattern

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


ConditionalAttributes_<index>_Pattern property of PointAttributes Parameter

ConditionalAttributes_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the map FillMode is set to either B&W or colored patterns.

  • If the map's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

Example

To set the ConditionalAttributes Pattern:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_Pattern Cross

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


ConditionalAttributes_<index>_PointLabels property of PointAttributes Parameter

ConditionalAttributes_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To set the ConditionalAttributes PointLabels Visible:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


PointLabelAttributes Class Members

Map_ConditionalAttributes_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


ConditionalAttributes_<index>_PointLabels_Alignment property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the ConditionalAttributes PointLabels Alignment:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_Alignment Near

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_Angle property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the ConditionalAttributes PointLabels Angle:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_Angle 45

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_BackColor property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the ConditionalAttributes PointLabels BackColor:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_BackColor Yellow

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_Font property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired map element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the ConditionalAttributes PointLabels Font:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_Font "Arial, 12"

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_Format property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY maps, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked maps).

    X displays the marker X value for any map type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To set the ConditionalAttributes PointLabels Format:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_Format "I'm point # %N"

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_LineAlignment property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the ConditionalAttributes PointLabels LineAlignment:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_LineAlignment Far

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_Offset property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

To set the ConditionalAttributes PointLabels Offset:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_Offset "4, 5"

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_RichText property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To set the ConditionalAttributes PointLabels RichText:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_RichText true

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_TextColor property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the ConditionalAttributes PointLabels TextColor:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true -ConditionalAttributes_0_PointLabels_TextColor Red

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_PointLabels_Visible property of PointLabelAttributes Parameter

ConditionalAttributes_<index>_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the ConditionalAttributes PointLabels Visible:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_PointLabels_Visible true

See Also

Map_ConditionalAttributes_PointLabels Parameter | Map_ConditionalAttributes_PointLabels Summary


ConditionalAttributes_<index>_Series_<index> property of ConditionalAttributes Parameter

ConditionalAttributes_<index>_Series_<index> Parameter

Sets a value indicating which series index the ConditionalAttribute will be applied.

Remarks

  • By default, ConditionalAttributes are applied to all series in the map. To reset a ConditionalAttribute to be applied to all series, set the Series property to -1.

Example

To instruct PowerGadgets to apply the selected ConditionalAttribute to the 2nd series only:

Out-Map -ConditionalAttributes_1_Series 1

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


ConditionalAttributes_<index>_Text property of PointAttributes Parameter

ConditionalAttributes_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set the ConditionalAttributes Text:

Out-Map -ConditionalAttributes_0_Condition_From 20 -ConditionalAttributes_0_Condition_To 60 -ConditionalAttributes_0_Text "Text 0"

See Also

Map_ConditionalAttributes Parameter | Map_ConditionalAttributes Summary


Configure property of Chart Parameter

Configure Parameter

Allows you to use a graphical Wizard to customize the map.

Remarks

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for map.

  • This Wizard has two tabs, one called Map Wizard and the other called Advanced Settings. Hours of usability testing has been summarized into one easy to use set of actions listed within the Map Wizard tab.

Example

To use a graphical wizard to customize the map:

Out-Map -configure

To use a graphical Wizard to configure a Tamplate map:

Out-Map -configure -template MyProcesses

See Also

Map Parameter | Map Summary


ContextMenus property of Chart Parameter

ContextMenus Parameter

Allows you to enable or disable context sensitive menus when the user right clicks a particular map element.

Remarks

  • This property allows the end user to easily alter various map elements rather than finding the appropriate dialog in the map tabbed dialog. Therefore, we strongly recommend the use of this setting.

Example

To turn off the ContextMenus:

Out-Map -ContextMenus false

See Also

Map Parameter | Map Summary


CreateLabelLinkFile property of Map Parameter

CreateLabelLinkFile Parameter

Used to create an initial file for linking and associating incoming data values to the map object name.

Remarks

  • Sometimes the SVG labels do not match the property name for identifying the data, and thus this mapping must be preconfigured through this file.

Example

To create a Label Link file:

out-map -CreateLabelLinkFile "myLabelLinkFile.xml"

See Also

Map Parameter | Map Summary


Crosshairs property of Chart Parameter

Crosshairs Parameter

Enables or Disables the cross-hairs marker in the map.

Remarks

  • If enabled, the end user will view a Cross-Hairs marker and a tooltip showing the point index and the value, when he presses the left button of the mouse. The Cross-Hairs marker will disappear when the user releases the button.

Example

To view the Cross-Hairs markers:

Out-Map -Crosshairs true

See Also

Map Parameter | Map Summary


Culture property of Chart Parameter

Culture Parameter

Allows you to localize maps for a specific language and region.

Remarks

  • The Parameter supports a property that allows you to set the culture for axes and values, not the entire map.

Example

To set the Map culture to use "Spanish - Spain" as the Language-Country/Region:

Out-Map -Culture "es-ES"

See Also

Map Parameter | Map Summary


DataGrid property of Chart Parameter

DataGrid Parameter

Gets the MenuBar of the map. The Data Gird is a spreadsheet that shows the data points in tabular format. When shown, it allows the user to see both the map and the grid at the same time.

Example

Displays the DataGrid:

Out-Map -DataGrid_Visible true

See Also

Map Parameter | Map Summary


DataGrid Class Members

Map_DataGrid Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
BackColorData | Sets the background color of the cells on the MenuBar.
BackColorDataAlternate | Assigns the alternate color for displaying the DataGrid rows or columns.
BackColorHeader | Sets the background color of the header for the MenuBar.
Border | Allows the developer to specify the border style.
Cells | Gets the collection of CellAttributes that belong to the DataGrid.
ContentLayout | Allows you to align the MenuBar in the bottom of the chart area.
Dock | Sets the position of the MenuBar.
Font | Allows you to set the font used throughout the MenuBar.
Height | Sets the height of the dockable bar in pixels.
HideXValues | Used to hide the XValues in the MenuBar of an XY plot chart.
HorizontalGridColor | Allows you to set the Horizontal color for the gridlines displayed in the MenuBar.
Interlaced | Alternates the background color of on the MenuBar to improve readability.
MaxSizePercentage | Allows you to specify the maximum percentage of the chart area the MenuBar may occupy.
ReadOnly | Permits values to be changed through the MenuBar.
ScrollPosition | Scrolls the data horizontally to the specific column in the Grid.
ShowHeader | Sets a value indicating the header of the columns should be visible or not.
ShowHiddenSeries | Sets a value indicating hidden series should be visible in MenuBar.
ShowMarkers | Sets a value indicating if serie markers should be visible in the serie headers.
TextColorData | Sets the text color of the cells on the MenuBar.
TextColorDataAlternate | Sets the alternate text color for text in the MenuBar cells.
TextColorHeader | Sets the text color of the headers on the MenuBar.
UseRawData | Sets a value indicating whether to use raw data or use calculated values in the DataEditor.
VerticalGridColor | Allows you to select the Vertical line color for the gridline displayed at the MenuBar box.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.
XValuesAsHeaders | Sets a value instructing that XValues be used as the headers in the MenuBar.


DataGrid_AutoSize property of DockableBar Parameter

DataGrid_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a map.

Example

To set the DataGrid AutoSize:

Out-Map -DataGrid_Visible true -DataGrid_AutoSize true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_BackColor property of DockableBar Parameter

DataGrid_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the DataGrid BackColor:

Out-Map -DataGrid_Visible true -DataGrid_BackColor Redf

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_BackColorData property of DataGrid Parameter

DataGrid_BackColorData Parameter

Sets the background color of the cells on the MenuBar.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColorData property. Use property to enable the MenuBar.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of MenuBar Cells to Blue:

Out-Map -DataGrid_Visible true -DataGrid_BackColorData Blue

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_BackColorDataAlternate property of DataGrid Parameter

DataGrid_BackColorDataAlternate Parameter

Assigns the alternate color for displaying the DataGrid rows or columns.

Remarks

  • When viewing and interpreting DataGrids with muliple points or series, sometimes it is difficult to distinguish one row from another or one column from the other. With this prorperty you can specify the alternating color for the DataGrid.

  • You should specify the direction of the alternating colors by using the Interlaced property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the alternate color for an interlaced MenuBar.

Out-Map -DataGrid_Visible true -DataGrid_Interlaced Horizontal -DataGrid_BackColorDataAlternate Red

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_BackColorHeader property of DataGrid Parameter

DataGrid_BackColorHeader Parameter

Sets the background color of the header for the MenuBar.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColorHeader property. Use property to enable the dataGrid.

  • You can set the dataGird background and MenuBar cells background with and BackColorData property, respectively.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the color of MenuBar Headers to Blue:

Out-Map -DataGrid_Visible true -DataGrid_BackColorHeader Blue

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Border property of DockableBar Parameter

DataGrid_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

To set the DataGrid Border:

Out-Map -DataGrid_Visible true -DataGrid_Border External

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Cells property of DataGrid Parameter

DataGrid_Cells Parameter

Gets the collection of CellAttributes that belong to the DataGrid.

Parameters

Parameter | Type | Meaning
row | Int32 | The series index
column | Int32 | The point index

Parameter | Type | Meaning
row | Int32 | The point index

Remarks

  • The Parameter allows to modify the attributes of a particular Cell or entire Row in the .

  • Cell Attributtes are background, border and text colors,font styles and Border widths.

Example

The following example shows how to set a particular Cell in the Datagrid just with a red back color:

Out-Map -DataGrid_Visible true -DataGrid_Cells_1_0_BackColor Red

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


CellAttributes Class Members

Map_DataGrid_Cells Parameters

Parameters

Description

BackColor | Sets the background color for a particular Cell or entire Row in the DataGrid.
BorderColor | Allows you to set the color of the border for a particular Cell or entire Row in the DataGrid.
BorderWidth | Allows you to set the width of the Cell border in pixels for a particular Cell or entire Row in the DataGrid.
FontStyle | Allows you to set the style of the font for a particular Cell or entire Row in the DataGrid.
TextColor | Allows you to set the text color for a particular Cell or entire Row in the DataGrid.


DataGrid_Cells_BackColor property of CellAttributes Parameter

DataGrid_Cells_BackColor Parameter

Sets the background color for a particular Cell or entire Row in the DataGrid.

Remarks

  • You need to have the MenuBar visible in order to see the changes made with BackColor property. Use property to enable the MenuBar.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the background color of cell in the MenuBar to red:

Out-Map -DataGrid_Visible true -DataGrid_Cells_0_1_BackColor Red

See Also

Map_DataGrid_Cells Parameter | Map_DataGrid_Cells Summary


DataGrid_Cells_BorderColor property of CellAttributes Parameter

DataGrid_Cells_BorderColor Parameter

Allows you to set the color of the border for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the border color of cell in the MenuBar to red:

Out-Map -DataGrid_Visible true -DataGrid_Cells_0_1_BorderColor Red

See Also

Map_DataGrid_Cells Parameter | Map_DataGrid_Cells Summary


DataGrid_Cells_BorderWidth property of CellAttributes Parameter

DataGrid_Cells_BorderWidth Parameter

Allows you to set the width of the Cell border in pixels for a particular Cell or entire Row in the DataGrid.

Remarks

  • This property allows you to configure the width of the DataGrid Cell border using units other than pixels.

Example

To set the border with of a Cell in the DataGrid to 3 pixels:

Out-Map -DataGrid_Visible true -DataGrid_Cells_0_1_BorderWidth 3

See Also

Map_DataGrid_Cells Parameter | Map_DataGrid_Cells Summary


DataGrid_Cells_FontStyle property of CellAttributes Parameter

DataGrid_Cells_FontStyle Parameter

Allows you to set the style of the font for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

The following code illustrates this property:

Out-Map -DataGrid_Cells_0_0_FontStyle +Bold

You can also use this property with bitwise or to combine FontStyles.

Out-Map -DataGrid_Visible true -DataGrid_Cells_0_0_FontStyle +Bold -DataGrid_Cells_0_0_FontStyle +Italic

See Also

Map_DataGrid_Cells Parameter | Map_DataGrid_Cells Summary


DataGrid_Cells_TextColor property of CellAttributes Parameter

DataGrid_Cells_TextColor Parameter

Allows you to set the text color for a particular Cell or entire Row in the DataGrid.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Text of a cell in the DataGrid to Red:

Out-Map -DataGrid_Visible true -DataGrid_Cells_0_0_TextColor Red

See Also

Map_DataGrid_Cells Parameter | Map_DataGrid_Cells Summary


DataGrid_ContentLayout property of DataGrid Parameter

DataGrid_ContentLayout Parameter

Allows you to align the MenuBar in the bottom of the map area.

Default Value
The default is Spread.

Value | Meaning
Spread | Stretches the selected object in the configured position.
Near | Left justifies the selected object in the configured position.
Center | Centers the selected object in the configured position.
Far | Right justifies the selected object in the configured position.

Remarks

  • The property needs to be true to see the effects of this property.

  • Note, when the DataGrid is docked on the left or right:

    Near = Top

    Far = Bottom

Example

To center the MenuBar under the map:

Out-Map -DataGrid_Visible true -DataGrid_ContentLayout Center

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Font property of DataGrid Parameter

DataGrid_Font Parameter

Allows you to set the font used throughout the MenuBar.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the MenuBar font settings:

Out-Map -DataGrid_Visible true -DataGrid_Font "Arial, 10"

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Dock property of DockableBar Parameter

DataGrid_Dock Parameter

Sets the position of the MenuBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To set the DataGrid Dock:

Out-Map -DataGrid_Visible true -DataGrid_Dock Right

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Height property of DockableBar Parameter

DataGrid_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the DataGrid Height:

Out-Map -DataGrid_Visible true -DataGrid_Height 300

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_HideXValues property of DataGrid Parameter

DataGrid_HideXValues Parameter

Used to hide the XValues in the MenuBar of an XY plot map.

Remarks

  • Normally when you generate an XY plot, both the X and Y values for each series are displayed in the dataGrid. This property allows you to hide the XValues displayed by the tool.

Example

To hide the XValues in the MenuBar of an XY plot:

Out-Map -DataGrid_HideXValues true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_HorizontalGridColor property of DataGrid Parameter

DataGrid_HorizontalGridColor Parameter

Allows you to set the Horizontal color for the gridlines displayed in the MenuBar.

Remarks

  • The MenuBar must be in order to see the these changes.

  • You can set the Vertical line color of the MenuBar gridline with VerticalGridColor property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To show the MenuBar and change the gridlines color to blue:

Out-Map -DataGrid_Visible true -DataGrid_HorizontalGridColor Blue

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Interlaced property of DataGrid Parameter

DataGrid_Interlaced Parameter

Alternates the background color of on the MenuBar to improve readability.

Default Value
The default is None.

Value | Meaning
None | No interlaced grid.
Horizontal | Creates a horizontal interlaced grid in the MenuBar.
Vertical | Creates a vertical interlaced grid in the MenuBar.

Remarks

  • If you want to alternate the color for every series, then use Interlaced.Horizontal. For alternating the color of the points, use Interlaced.Vertical.

    With only a few series and points it is easier to read without Interlaced.

  • Use the BackColorData and BackColorDataAlternate properties to set the colors for the Interlaced property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set Interlaced property to vertical:

Out-Map -DataGrid_Visible true -DataGrid_BackColorDataAlternate Red -DataGrid_Interlaced Horizontal

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_MaxSizePercentage property of DataGrid Parameter

DataGrid_MaxSizePercentage Parameter

Allows you to specify the maximum percentage of the map area the MenuBar may occupy.

Remarks

  • This property is especially useful when developing with web applications and generating images. Because you cannot scroll the MenuBar when generating an image, This property allows you to specify the max size so you can make sure to view all values in the MenuBar.

  • This property may be configured with values ranging from 0 - 100. Specifying 0 will instruct PowerGadgets to calculate the size. Specifying 100 will instruct PowerGadgets that the whole map may be covered by the MenuBar if needed.

Example

To set the MaxSizePercentage to 35%:

Out-Map -DataGrid_Visible true -DataGrid_MaxSizePercentage 35

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_ReadOnly property of DataGrid Parameter

DataGrid_ReadOnly Parameter

Permits values to be changed through the MenuBar.

Remarks

  • To change a value, simply double click the cell you wish to change.

Example

To set the DataGrid ReadOnly property to true:

Out-Map -DataGrid_Visible true -DataGrid_ReadOnly true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_ScrollPosition property of DataGrid Parameter

DataGrid_ScrollPosition Parameter

Scrolls the data horizontally to the specific column in the Grid.

Remarks

  • This applies only when the MenuBar is docked to the Bottom or Top.

Example

To set the MenuBar scroll position to 2:

Out-Map -DataGrid_Visible true -DataGrid_ScrollPosition 2

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_ShowHeader property of DataGrid Parameter

DataGrid_ShowHeader Parameter

Sets a value indicating the header of the columns should be visible or not.

Remarks

  • The ShowMarkers property shows or hides the series indicator displayed on the side of the dataGirid.

  • You may modify the color of the header using the BackColorHeader property.

Example

Hide the MenuBar header:

Out-Map -DataGrid_ShowHeader false

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_ShowHiddenSeries property of DataGrid Parameter

DataGrid_ShowHiddenSeries Parameter

Sets a value indicating hidden series should be visible in MenuBar.

Remarks

  • A series can be marked hidden by setting the Visible property of the SeriesAttributes Parameter, however you may want to still show this series in the MenuBar using this property.

Example

To show hidden series in the MenuBar:

Out-Map -DataGrid_ShowHiddenSeries true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_ShowMarkers property of DataGrid Parameter

DataGrid_ShowMarkers Parameter

Sets a value indicating if serie markers should be visible in the serie headers.

Remarks

  • When the marker is hidden, only text is shown to label the series.

  • The property may be used to show or hide the dataGrid header.

Example

To remove the markers from the MenuBar:

Out-Map -DataGrid_Visible true -DataGrid_ShowMarkers false

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_TextColorData property of DataGrid Parameter

DataGrid_TextColorData Parameter

Sets the text color of the cells on the MenuBar.

Remarks

  • This property does not change the color of the header text, you can set the header text color of the dataGrid with TextColorHeader property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change the text color of MenuBar Cells to Blue:

Out-Map -DataGrid_Visible true -DataGrid_TextColorData Blue

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_TextColorDataAlternate property of DataGrid Parameter

DataGrid_TextColorDataAlternate Parameter

Sets the alternate text color for text in the MenuBar cells.

Remarks

  • This property is useful when the Interlaced property is used.

  • The initial color of the text in the dataGrid cells can be set using the TextColorData property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Set the alternate text color for the MenuBar to red:

Out-Map -DataGrid_Visible true -DataGrid_Interlaced Horizontal -DataGrid_TextColorDataAlternate Red

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_TextColorHeader property of DataGrid Parameter

DataGrid_TextColorHeader Parameter

Sets the text color of the headers on the MenuBar.

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use property to enable the MenuBar.

  • You can set the other cells text color of the dataGird with TextColorData property.

  • You can change the color of a specific cell by using property

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To change MenuBar headers text color to Orange:

Out-Map -DataGrid_Visible true -DataGrid_TextColorHeader Orange

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_UseRawData property of DataGrid Parameter

DataGrid_UseRawData Parameter

Sets a value indicating whether to use raw data or use calculated values in the DataEditor.

Remarks

  • Some gallery types, such as the BoxPlot and Histogram, manipulate data values displayed in the MenuBar. If you would like to actually see the data passed to the map, you can set this property to true. This property will not affect all gallery types.

Example

To configure the DataEditor to use raw data:

Out-Map -DataGrid_Visible true -DataGrid_UseRawData true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_VerticalGridColor property of DataGrid Parameter

DataGrid_VerticalGridColor Parameter

Allows you to select the Vertical line color for the gridline displayed at the MenuBar box.

Remarks

  • You need to have the dataGrid visible in order to see the changes. Use property to enable the MenuBar.

  • You can set the Horizontal line color of the MenuBar gridline with HorizontalGridColor property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To show the MenuBar and change the gridlines color to Red:

Out-Map -DataGrid_Visible true -DataGrid_VerticalGridColor Red

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Visible property of DockableBar Parameter

DataGrid_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To set the DataGrid Visible:

Out-Map -DataGrid_Visible false

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_Width property of DockableBar Parameter

DataGrid_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the DataGrid Width:

Out-Map -DataGrid_Visible true -DataGrid_Width 300

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DataGrid_XValuesAsHeaders property of DataGrid Parameter

DataGrid_XValuesAsHeaders Parameter

Sets a value instructing that XValues be used as the headers in the MenuBar.

Remarks

  • When set to true, the XValues passed to a map will be used for the point headers in the dataGrid.

  • In order for this property to affect the map, the map must include XValues (XY plot).

Example

To use XValues as Headers in the DataEditor:

Out-Map -DataGrid_XValuesAsHeaders true

See Also

Map_DataGrid Parameter | Map_DataGrid Summary


DefaultAttributes property of Map Parameter

DefaultAttributes Parameter

Allows you to configure the DefaultAttributes object for the map.

Remarks

  • The DefaultAttributes object is applied to map regions which no conditional attributes or default series attributes were assigned. The only time DefaultAttributes are applied is when a map region has no configured data value or if a DrillDown occurs (applied to non focus regions). If data has been configured for a region, then the default SeriesAttributes for the series object are applied.

Example

To configure the default color for map regions as Violet:

out-map -DefaultAttributes_Color Violets

See Also

Map Parameter | Map Summary


DetailLevel property of Map Parameter

DetailLevel Parameter

Sets the detail level used to display the map.

Remarks

  • The DetailLevel of a map refers to the grouping scheme of the SVG MapSource. By creating groups in the SVG map, developers create parent groups which individual map regions may be a part. PowerGadgets Maps will automatically calculate a total for all the map regions which are grouped together when the DetailLevel changes.

    An example of this grouping can be seen in the US Regional map. All the US states are grouped together per region, i.e. SouthEast, NorthWest, etc.

    This grouping must be configured in the SVG map used by PowerGadgets Maps.

Example

To set the DetailLevel to 1:

out-map -DetailLevel 1

See Also

Map Parameter | Map Summary


DrillDown Class Members

Map_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on a map object.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on a map object.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


DrillDown_Script property of DrillDown Parameter

DrillDown_Script Parameter

Specifies the script that will be invoked when the user double-clicks on a map object.

Remarks

  • The parameters passed should be handled in the script through the args array, e.g. args[0].

  • If this parameter is not specified, the drilldown will be executed using the portion of the piped commands previous to out-map.

Example

To use the DrillDown_Script parameter:

import-csv PopulationByState.csv | out-map -Values Population -Label State -DrillDown_Script PopulationByCounties.ps1 -DrillDown_Paramter {$_.State}

See Also

Map_DrillDown Parameter | Map_DrillDown Summary


DrillDown_Parameter property of DrillDown Parameter

DrillDown_Parameter Parameter

Specifies the properties that will be passed as parameters when user double-clicks on a map object.

Remarks

  • The properties must be comma separated and specified in the format {$_.property}

Example

To use the DrillDown_Parameter:

import-csv PopulationByState.csv | out-map -Values Population -Label State -DrillDown_Paramter {$_.State}

See Also

Map_DrillDown Parameter | Map_DrillDown Summary


DrillDown_Console property of DrillDown Parameter

DrillDown_Console Parameter

If specified, the drilldown will show the PowerShell command screen when executed.

Remarks

  • By default, the command screen is hidden to avoid a flash effect when the drilldown is executed, but in certain circumstances, the command screen needs to appear. Essentially, this parameter needs to be specified if the drilldown script executes a command that requires PowerShell screen output, such as get-process.

Example

To use the DrillDown_Console parameter:

import-csv PopulationByState.csv | out-map -Values Population -Label State -DrillDown_Script ShowPopulationByCounties.ps1 -DrillDown_Paramter {$_.State} -DrillDown_Console

See Also

Map_DrillDown Parameter | Map_DrillDown Summary


DrillDownMode property of Map Parameter

DrillDownMode Parameter

Sets the DrillDown mode for a map.

Remarks

  • Setting this property to Hide, will only display the DrillDown region in the map.

  • Setting this property to ShowDefault will show all surrounding regions in the Map when a DrillDown occurs, however, all the regions not part of the selected DrillDown MapRegion will have the DefaultAttributes applied.

Example

To set the DrillDownMode to Hide:

out-map -DrillDownMode Hide

See Also

Map Parameter | Map Summary


ExtraStyle property of Chart Parameter

ExtraStyle Parameter

Allows you to set additional visual attributes in the map.

Value | Meaning
TrackMouse | This constant has to be included for those charts you want to capture mouse tracking.
DoubleBuffer | The chart will refresh itself using a double buffering technique. The effect will be a less flickering.
NoLegInvalidate | Useful for RealTime charts. Is this flag is ON, the chart will not be invalidated when the legends are set.
PaintMarker | This constant will turn on message event for customize chart drawing process.
OnlyChart | Makes the chart to hide everything outside the chart area such a axis,titles,etc.This feature is very useful when you want to overlap charts.
SideBySide | For 2D MultiType charts, makes the bars to be side-by-side instead of overlapped.
Monochrome | Turn ON will show a Black & White chart and it won't be possible to change chart colors.
CacheImage | When true, chart images will be cached in memory. (PSS features)
ExportXValues | If this flag is ON, the X values are exported to the clipboard every time you export the chart as data.
FastLegends | ChartStyleEx_FastLegendsDisable the legend size computation. Use this flag to improve speed on setting the legends. You must set this flag on BEFORE setting any legend. You can not show a legend box if the legends are set while this flag is on. If you are going to set a new set of legends you must call the ClearLegend property before starting to set the legends in order to get the best performance.
Crosshairs | Turn on or off the cross-hairs feature.
ToolTips | Turn on or off the tool-tips feature.
MenusOnDemand | See ContextMenus property.
Default | Sets default settings.
ScrollBars | When OFF, it will hide the Scrollbars.
AllowScroll | When OFF, none of the Axes will allow scroll.
ForceDataDriven | Description goes here

Remarks

  • This property uses bitwise operators to turn on and off settings. To combine two flags. use the 'Or' bitwise operator.

Example

For example, the correct way to turn on the Monochrome setting is the following:

Out-Map -ExtraStyle +Monochrome

To force a square pie map:

Out-Map -ExtraStyle +SideBySide

The following code is WRONG (it will erase all other settings in the property causing an erratic behavior of the library and an incorrect setting of the individual properties which also control these flags):

Out-Map -ExtraStyle Monochrome

See Also

Map Parameter | Map Summary


Floating property of Chart Parameter

Floating Parameter

Allows you to launch a map without a window frame.

Remarks

  • Use Floating to launch a map without a window frame making the map appear as it were floating over the desktop.

Example

To launch a map without a window frame:

Out-Map -floating

See Also

Map Parameter | Map Summary


Font property of Chart Parameter

Font Parameter

Sets the font type which will be used by default in the map.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Font to a Times New Roman font, italic, bold, and of size 12:

Out-Map -Font "Times News Roman,12,style=italic,Bold"

See Also

Map Parameter | Map Summary


ForeColor property of Chart Parameter

ForeColor Parameter

Sets the default font color of the map.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the ForeColor to Green:

Out-Map -ForeColor Green

See Also

Map Parameter | Map Summary


Glass property of Chart Parameter

Glass Parameter

Allows you to configure the gauge background to be painted using Glass form.

Remarks

  • When running in Windows Vista, the map background is painted using Glass form. Ignored in any other Operating System.

Example

To configure the Glass parameter:

out-map -Glass

See Also

Map Parameter | Map Summary


Group property of Chart Parameter

Group Parameter

Allows you to create the map window as a separate process and assigns an ID that allows multiple maps to share the same window.

Remarks

  • If a group already exists, PowerGadgets will introduce a navigation bar on the bottom right hand corner of the gadget window allowing you to easily switch through the various gadgets in the group. You can also use the play button to automatically cycle through the gadgets every few seconds.

  • Use the Name parameter to assign a name to the map.

Example

To use the Group parameter to have multiple maps in the same window:

Out-Map -group "My Gadgets"

See Also

Map Parameter | Map Summary


HideFromAltTab property of Chart Parameter

HideFromAltTab Parameter

If specified, the gadget will not appear when the user presses Alt-Tab.

Remarks

  • This is particularly useful when there are a number of gadgets visible at the same time, as it will not clutter the Alt-Tab dialog.

  • It only applies when the gadget is shown on the desktop (not in the Sidebar)

Example

To configure the HideFromAltTab parameter:

out-map -HideFromAltTab

See Also

Map Parameter | Map Summary


Label property of Chart Parameter

Label Parameter

Allows you to specify which property to use as the X labels.

Remarks

  • Use Label to determine which property to use as the X labels in the map.

Example

To specify the ID as X label in a map populated with the processes (PS>get-process ):

ps | Out-Map -values Handles -label ID

See Also

Map Parameter | Map Summary


LabelLinkFile property of Map Parameter

LabelLinkFile Parameter

Sets a path for an XML file of the LabelLink attributes.

Remarks

  • By default, PowerGadgets Maps assumes that labels passed with map data match the text labels that exist in the configured SVG . For instances when these labels do not correspond, a conversion table is used to connect the data labels to SVG labels. This table is referred to as the LabelLinks collection.

  • If you have a large number of required conversions, you may set this property to an valid XML file containing the necessary attributes. Below is the supported format for the XML:

Example

To configure the LabelLinkFile:

To configure the LabelLinkFile:

out-map -LabelLinkFile "c:\MyLabelLinks.xml"

See Also

Map Parameter | Map Summary


LabelStyles property of Map Parameter

LabelStyles Parameter

Flag property that allows setting attributes for map labels contained in the map extension.

Remarks

  • This property uses bitwise operators to turn on and off settings. To combine two flags. use the 'Or' bitwise operator.

Example

To turn on the ShowThisLevelOnly flag:

out-map -LabelStyles +ShowThisLevelOnly

See Also

Map Parameter | Map Summary


LabelStylesSettings property of Map Parameter

LabelStylesSettings Parameter

Used to access the LabelStylesSettings object for the map.

Remarks

  • This property returns the LabelStylesSettings object for the map which exposes properties which allow you to control the style in which labels are displayed for map regions.

  • The LabelStyles property allows you to set these same attributes as flags using bitwise operators.

Example

To use the LabelStylesSettings property to assing label attributes:

out-map -LabelStylesSettings.ShowThisLevelOnly True

See Also

Map Parameter | Map Summary


LegendBox Parameter

Remarks

A legend box is a tool within a map that contains relevant information to explain what is being depicted in a map.

The LegendBox can show legends from , , , , etc.

You must make the legend box in order to see any of the visual attributes configured using the properties of the Parameter.

The legend box inherites from . Therefore, some visual properties of the legend box can be accessed using the properties implemented by .


LegendBox Class Members

Map_LegendBox Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
ContentLayout | Allows you to align the content for the legend box.
CustomItems | Returns the collection of the custom items in the legend box.
Dock | Sets the position of the LegendBox.
Font | Sets the font of the Legend Box.
Height | Sets the height of the dockable bar in pixels.
MarginX | Sets a value specifying the margin width for a LegendBox.
MarginY | Sets a value specifying the margin height for a LegendBox.
PlotAreaOnly | Allows the legend box margins to go outside of the chart's drawing area.
Style | Sets the style of the legend box.
TextColor | Sets the color used for the text in the legend box.
Titles | Returns or sets a title object for the legend box.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


LegendBox_AutoSize property of DockableBar Parameter

LegendBox_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a map.

Example

To set the LegendBox AutoSize:

Out-Map -LegendBox_AutoSize true

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_BackColor property of DockableBar Parameter

LegendBox_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the LegendBox BackColor:

Out-Map -LegendBox_BackColor Redf

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Border property of DockableBar Parameter

LegendBox_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

To set the LegendBox Border:

Out-Map -LegendBox_Border External

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_ContentLayout property of LegendBox Parameter

LegendBox_ContentLayout Parameter

Allows you to align the content for the legend box.

Default Value
The default is Center.

Value | Meaning
Spread | Stretches the selected object in the configured position.
Near | Left justifies the selected object in the configured position.
Center | Centers the selected object in the configured position.
Far | Right justifies the selected object in the configured position.

Remarks

  • When the Leyend box is doked at the lefy or right of the Map, Near means Top, and Far means Bottom.

Example

Sets the alignment for legend box to Far:

Out-Map -LegendBox_ContentLayout Far

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_CustomItems_<index> property of LegendBox Parameter

LegendBox_CustomItems_<index> Parameter

Returns the collection of the custom items in the legend box.

Example

To add a Custom Legend item:

Out-Map -LegendBox_CustomItems_0_Text "Custom Item" -LegendBox_CustomItems_0_Color Orange

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


CustomLegendItem Class Members

Map_LegendBox_CustomItems Parameters

Parameters

Description

AlternateColor | Sets the background color of a custom legend item marker when a pattern is configured using the MarkerShape property.
Attributes | Sets the PointAttributes object for the custom legend item.
Color | Sets the Color for the marker of the Custoem Legend Item.
Pattern | Sets a HatchStyle pattern for the marker of the custom item.
Picture | Sets an image to be used as a marker for the legend item.
ShowLine | Sets a value used to display a line marker for the custom item.
Text | Sets the text string of the custom legend item.


LegendBox_CustomItems_<index>_AlternateColor property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_AlternateColor Parameter

Sets the background color of a custom legend item marker when a pattern is configured using the MarkerShape property.

Remarks

  • The forecolor of the pattern is configured using the Color property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the alternate color to a custom Legend item:

Out-Map -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Pattern BackwardDiagonal -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_AlternateColor Blue

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Attributes property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Attributes Parameter

Sets the PointAttributes object for the custom legend item.

Remarks

  • The Attributes property is used to obtain the object for a CustomLegendItem. This allows the developer to apply unique visual attributes for the legend item.

  • Please see the the Parameter for additional information regarding the suppored members.

Example

To select to 3 the marker size for the custom legend item:

Out-Map -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_Attributes_MarkerShape Triangle

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


PointAttributes Class Members

Map_LegendBox_CustomItems_Attributes Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
Color | Allows you to set a color for the selected item.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Pattern | Sets a value specifying the pattern for the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
Text | Sets a value for labeling the point or series attribute.


LegendBox_CustomItems_<index>_Attributes_AlternateColor property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To set the LegendBox CustomItems Attributes AlternateColor:

Out-Map -LegendBox_CustomItems_0_Attributes_AlternateColor Red

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Color property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the map, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the LegendBox CustomItems Attributes Color:

Out-Map -LegendBox_CustomItems_0_Attributes_Color Green

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_FillMode property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the maps. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the map.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the LegendBox CustomItems Attributes FillMode:

Out-Map -LegendBox_CustomItems_0_Attributes_FillMode Pattern

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Pattern property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the map FillMode is set to either B&W or colored patterns.

  • If the map's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

Example

To set the LegendBox CustomItems Attributes Pattern:

Out-Map -LegendBox_CustomItems_0_Attributes_Pattern Cross

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_PointLabels property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To set the LegendBox CustomItems Attributes PointLabels Visible:

Out-Map -LegendBox_CustomItems_0_Attributes_PointLabels_Visible true

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Attributes_Text property of PointAttributes Parameter

LegendBox_CustomItems_<index>_Attributes_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set the LegendBox CustomItems Attributes Text:

Out-Map -LegendBox_CustomItems_0_Attributes_Text "Text 0"

See Also

Map_LegendBox_CustomItems_Attributes Parameter | Map_LegendBox_CustomItems_Attributes Summary


LegendBox_CustomItems_<index>_Color property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Color Parameter

Sets the Color for the marker of the Custoem Legend Item.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the color of the Custom Legend Item:

Out-Map -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Pattern property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Pattern Parameter

Sets a HatchStyle pattern for the marker of the custom item.

Remarks

  • The forecolor of the pattern is configured using the Color property. The background color of the pattern is configured using the AlternateColor property.

  • These are the supported styles:

    Horizontal
    Min
    Vertical
    ForwardDiagonal
    BackwardDiagonal
    Cross
    LargeGrid
    Max
    DiagonalCross
    Percent05
    Percent10
    Percent20
    Percent25
    Percent30
    Percent40
    Percent50
    Percent60
    Percent70
    Percent75
    Percent80
    Percent90
    LightDownwardDiagonal
    LightUpwardDiagonal
    DarkDownwardDiagonal
    DarkUpwardDiagonal
    WideDownwardDiagonal
    WideUpwardDiagonal
    LightVertical
    LightHorizontal
    NarrowVertical
    NarrowHorizontal
    DarkVertical
    DarkHorizontal
    DashedDownwardDiagonal
    DashedUpwardDiagonal
    DashedHorizontal
    DashedVertical
    SmallConfetti
    LargeConfetti
    ZigZag
    Wave
    DiagonalBrick
    HorizontalBrick
    Weave
    Plaid
    Divot
    DottedGrid
    DottedDiamond
    Shingle
    Trellis
    Sphere
    SmallGrid
    SmallCheckerBoard
    LargeCheckerBoard
    OutlinedDiamond
    SolidDiamond

  • See HatchStyle in the PowerShell .

Example

Creates a custom legend box item, adds it to the legend box, and sets a BackwardDiagonal pattern:

Out-Map -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Pattern BackwardDiagonal -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_AlternateColor Blue

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Picture property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Picture Parameter

Sets an image to be used as a marker for the legend item.

Remarks

Example

Sets the first custom item marker to an image:

Out-Map -LegendBox_CustomItems_0_Picture "MyImage.png"

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_ShowLine property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_ShowLine Parameter

Sets a value used to display a line marker for the custom item.

Remarks

Example

To display a diferent marker shape, a circle with a line:

Out-Map -LegendBox_CustomItems_0_Text "Custom Item 1" -LegendBox_CustomItems_0_Color Red -LegendBox_CustomItems_0_MarkerShape Circle -LegendBox_CustomItems_0_ShowLine true

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_CustomItems_<index>_Text property of CustomLegendItem Parameter

LegendBox_CustomItems_<index>_Text Parameter

Sets the text string of the custom legend item.

Remarks

Example

To add a custom legend item:

Out-Map -LegendBox_CustomItems_0_Text "CustomItem" -LegendBox_CustomItems_0_Color Red

See Also

Map_LegendBox_CustomItems Parameter | Map_LegendBox_CustomItems Summary


LegendBox_Dock property of DockableBar Parameter

LegendBox_Dock Parameter

Sets the position of the LegendBox.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To set the LegendBox Dock:

Out-Map -LegendBox_Dock Right

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Font property of LegendBox Parameter

LegendBox_Font Parameter

Sets the font of the Legend Box.

Remarks

  • You can set the font for the entire map using the property.

  • When setting a font in PowerGadgets , you must create a new font object with the desired attributes and assign that object to the desired map element every time you want to change the font.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To change the font for the series legend box text:

Out-Map -LegendBox_Font "Arial, 12"

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Height property of DockableBar Parameter

LegendBox_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the LegendBox Height:

Out-Map -LegendBox_Height 300

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_MarginX property of LegendBox Parameter

LegendBox_MarginX Parameter

Sets a value specifying the margin width for a LegendBox.

Remarks

  • The MarginY property may be used to control the margin height for a LegendBox.

  • The property of the Parameter is used to return the map's LegendBox object.

Example

To configure the X Margin for a legendbox to 50:

Out-Map -LegendBox_MarginX 50

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_MarginY property of LegendBox Parameter

LegendBox_MarginY Parameter

Sets a value specifying the margin height for a LegendBox.

Remarks

  • The MarginX property may be used to control the margin width for a LegendBox.

  • The property of the Parameter is used to return the map's LegendBox object.

Example

To configure the Y Margin for a legendbox to 50:

Out-Map -LegendBox_MarginY 50

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_PlotAreaOnly property of LegendBox Parameter

LegendBox_PlotAreaOnly Parameter

Allows the legend box margins to go outside of the map's drawing area.

Remarks

  • If there is enough space and the legend is centered (default), there will be no noticeable difference when this property is configured. The difference is visible when there are many legend values, the drawing area is too small, the opposite gaps (e.g. top and bottom) are different or the legend is not centered.

  • By default the legends are drawn inside the map drawing area, for example when the legend box is at the right, the first legend will be at the top of the map area, it will not use the margin on top. If you set PlotAreaOnly to false, the margins will also be available for the legend.

Example

To set the DrawingArea property to false:

Out-Map -LegendBox_PlotAreaOnly false

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Style property of LegendBox Parameter

LegendBox_Style Parameter

Sets the style of the legend box.

Value | Meaning
Wordbreak | Wraps text when the legend alignment is set to spread.
ShowMenu | Enables the context menu for the legend.
Default | Default legend settings.
RightAlign | Right aligns the text in the legend. Used with Languages written from right to left.
NoColor | No Colors are used for markers in legend.
HidePartial | Description goes here

Remarks

  • This property uses bitwise operators to turn on and off settings. To combine two flags. use the 'Or' bitwise operator.

Example

Configures the legend box to enables the context menu:

Out-Map -LegendBox_Style +ShowMenu

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_TextColor property of LegendBox Parameter

LegendBox_TextColor Parameter

Sets the color used for the text in the legend box.

Remarks

  • Before you can see the text color assignments, the selected legend box must be visible.

  • You can assign the text for the values legend box using the or properties.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the legend box text to red:

Out-Map -LegendBox_TextColor Red

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Titles_<index> property of LegendBox Parameter

LegendBox_Titles_<index> Parameter

Returns or sets a title object for the legend box.

Parameters

Parameter | Type | Meaning
index | Int32 | A zero based index indicating the title index for the selected legend box.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

  • The property may be used to get or set the color of the title text; the Property can be used to configure a new font object for the title.

Example

To set a title in bold at the top of the LegendBox:

Out-Map -LegendBox_Titles_0_Text "My Title" -LegendBox_Titles_0_font "Arial, 10, style=bold"

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


TitleDockable Class Members

Map_LegendBox_Titles Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Dock | Sets or Gets the Dock property, which allows set where the title will be docked.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
PlotAreaOnly | Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


LegendBox_Titles_<index>_Alignment property of Title Parameter

LegendBox_Titles_<index>_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the map from left to right, Near will be to the left and Far will be to the right.

Example

To set the LegendBox Titles Alignment:

Out-Map -LegendBox_Titles_0_Alignment Near

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_BackColor property of Title Parameter

LegendBox_Titles_<index>_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a map a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the LegendBox Titles BackColor:

Out-Map -LegendBox_Titles_0_BackColor Yellow

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_Dock property of TitleDockable Parameter

LegendBox_Titles_<index>_Dock Parameter

Sets or Gets the Dock property, which allows set where the title will be docked.

Default Value
The default is Top.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • This property allows you to dock the map at the top, bottom, left or right of the map.

Example

To set the LegendBox Titles Dock:

Out-Map -LegendBox_Titles_0_Dock Bottom

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_Font property of Title Parameter

LegendBox_Titles_<index>_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the LegendBox Titles Font:

Out-Map -LegendBox_Titles_0_Font "Arial, 12"

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_Indentation property of Title Parameter

LegendBox_Titles_<index>_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

Example

To set the LegendBox Titles Indentation:

Out-Map -LegendBox_Titles_0_Indentation 5

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_LineAlignment property of Title Parameter

LegendBox_Titles_<index>_LineAlignment Parameter

Sets the vertical alignment for the lines of the map title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the map.

Example

To set the LegendBox Titles LineAlignment:

Out-Map -LegendBox_Titles_0_LineAlignment Center

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_PlotAreaOnly property of TitleDockable Parameter

LegendBox_Titles_<index>_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the map, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the map's plot area. When set to False, title may be drawn across the entire map including margins.

Example

To set the LegendBox Titles PlotAreaOnly:

Out-Map -LegendBox_Titles_0_PlotAreaOnly false

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_RichText property of Title Parameter

LegendBox_Titles_<index>_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

To set the LegendBox Titles RichText:

Out-Map -LegendBox_Titles_0_RichText true

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_Separation property of Title Parameter

LegendBox_Titles_<index>_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

Example

To set the LegendBox Titles Separation:

Out-Map -LegendBox_Titles_0_Separation 5

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_Text property of Title Parameter

LegendBox_Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

To set the LegendBox Titles Text:

Out-Map -LegendBox_Titles_0_Text "3rd Quarter Sales"

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Titles_<index>_TextColor property of Title Parameter

LegendBox_Titles_<index>_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the LegendBox Titles TextColor:

Out-Map -LegendBox_Titles_0_TextColor Red

See Also

Map_LegendBox_Titles Parameter | Map_LegendBox_Titles Summary


LegendBox_Visible property of DockableBar Parameter

LegendBox_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To set the LegendBox Visible:

Out-Map -LegendBox_Visible false

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


LegendBox_Width property of DockableBar Parameter

LegendBox_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the LegendBox Width:

Out-Map -LegendBox_Width 300

See Also

Map_LegendBox Parameter | Map_LegendBox Summary


ListObjects property of Map Parameter

ListObjects Parameter

Lists all the objects available in the currently selected mapsource where data can be bound and associated to.

Remarks

  • You must use the Label property to inform out-map which property corresponds and contains the value matching the object within the map.

  • If the incoming values do not match the objects available in the map, you should use the CreateLabelLinkFile to associate your incoming data to the object names present in the map.

Example

To list all the objects avaible in the default mapsource:

out-map -ListObjects

See Also

Map Parameter | Map Summary


Location property of Chart Parameter

Location Parameter

Allows you to configure the map's location in pixels.

Remarks

  • Use Location to specifies the horizontal and vertical offset from the screen edge relative to the anchor position.

  • If you Anchor topleft and wish to offset the map from the edges 10 pixes from the top and 10 pixes from the left, you can use the -location parameter with a value of 10,10

Example

To set a location for the map:

Out-Map -location 10,10

See Also

Map Parameter | Map Summary


MapSource property of Map Parameter

MapSource Parameter

Sets the SVG to be used for the Map object.

Remarks

  • The file specified as the MapSource must be SVG format.

  • By default, PowerGadgets Maps assumes that labels passed with map data match the text labels that exist in the configured SVG MapSource. For instances when these labels do not correspond, a conversion table is used to connect the data labels to SVG labels.

  • The LabelLinkFile property is used to configure an XML file consisting of the LabelLink object attributes.

  • There are many maps available and to facilitate selecting the appropiate map, we have created a special profile script for automatic tab completion. To make use of this, you will need to copy the PSConfiguration folder, residing within the PowerGadgets installation folder, to the MyDocuments folder and restard power shell with power gadgets shell. Now, when typing -mapsource followed by a space you can use tab repetitively to view the various maps available. You need to use the path separator '\' in conjunction with tab to see the various nested maps.

Example

To configure the MapSource for a Map object:

out-map -MapSource "US\Counties\FL Counties.svg"

See Also

Map Parameter | Map Summary


MenuBar property of Chart Parameter

MenuBar Parameter

Allows you to access the menu bar of the map. Alternativelly, you can access the tool bar of the map using ToolBar.

Remarks

  • Although the map is displayed in a bounding rectangle, PowerGadgets is capable of displaying a menu bar as part of the map.

Example

To show the menu bar:

Out-Map -MenuBar_Visible true

See Also

Map Parameter | Map Summary


ToolBar Class Members

Map_MenuBar Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
Dock | Sets the position of the ToolBar.
Height | Sets the height of the dockable bar in pixels.
ShowImages | Sets a value indicating whether to show or hide images for ToolBarItems.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


MenuBar_AutoSize property of DockableBar Parameter

MenuBar_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a map.

Example

To set the MenuBar AutoSize:

Out-Map -MenuBar_Visible true -MenuBar_AutoSize true

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_BackColor property of DockableBar Parameter

MenuBar_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the MenuBar BackColor:

Out-Map -MenuBar_Visible true -MenuBar_BackColor Redf

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_Border property of DockableBar Parameter

MenuBar_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

To set the MenuBar Border:

Out-Map -MenuBar_Visible true -MenuBar_Border External

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_Dock property of DockableBar Parameter

MenuBar_Dock Parameter

Sets the position of the MenuBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To set the MenuBar Dock:

Out-Map -MenuBar_Visible true -MenuBar_Dock Right

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_Height property of DockableBar Parameter

MenuBar_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the MenuBar Height:

Out-Map -MenuBar_Visible true -MenuBar_Height 300

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_ShowImages property of ToolBar Parameter

MenuBar_ShowImages Parameter

Sets a value indicating whether to show or hide images for ToolBarItems.

Remarks

  • The property is used to access the ToolBar object of a map.

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_Visible property of DockableBar Parameter

MenuBar_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To set the MenuBar Visible:

Out-Map -MenuBar_Visible false

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


MenuBar_Width property of DockableBar Parameter

MenuBar_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the MenuBar Width:

Out-Map -MenuBar_Visible true -MenuBar_Width 300

See Also

Map_MenuBar Parameter | Map_MenuBar Summary


Modal property of Chart Parameter

Modal Parameter

Allows you to block the command pipe while displaying a map.

Remarks

  • Use Modal to block the command pipe while displaying a map.

Example

To create a map blocking the command pipe while dit's displaying:

Out-Map -modal

See Also

Map Parameter | Map Summary


Name property of Chart Parameter

Name Parameter

Allows you to assign a name to map.

Remarks

  • Use the Name parameter to assign a name to the map.

Example

To configure the map name into a group:

Out-Map -group "My Group" -name "Sales Map"

See Also

Map Parameter | Map Summary


Output property of Chart Parameter

Output Parameter

Allows you to generate a map file instead of an interactive one.

Remarks

  • Use the Output parameter to generate a map file instead of an interactive one. Supported extensions are bmp, png and wmf

Example

To generate a image (.png) of the map:

Out-Map -output test.png

See Also

Map Parameter | Map Summary


Palette property of Map Parameter

Palette Parameter

Allows you to set a pre-defined palette.

Remarks

  • When changing the palette, all the properties related to changing colors in the map will also be affected as PowerGadgets will change the windows palette for the map window. So if you previously set a color using any of the PowerGadgets supported properties (ForeColor, BackColor, etc) this color may not be part of the applied palette and therefore will be replaced by a color in the selected palette.

  • Below is a list of PowerGadgets palettes:

    Default
    Natural.Sky
    ChartFX6.EarthTones
    ChartFX6.ModernBusiness
    DarkPastels.Pastels
    Mesa.Mesa
    Natural.Adventure
    HighContrast.HighContrast
    Vivid
    ChartFX6.Alternate
    ChartFX6.Windows
    ChartFX6.ChartFX6

    The schemes supported by PowerGadgets are:

    Schemes.Colorful
    Schemes.Classic
    Schemes.Simple
    Schemes.Professional
    Schemes2.Autumn
    Schemes2.Oceanica
    Schemes2.Brown Sugar
    Schemes2.Slate
    Schemes3.Sand & Sky
    Schemes3.Rainy Day
    Schemes3.Snowy Pine
    Schemes3.Lilacs in Mist
    Schemes4.Mocha
    Schemes4.Black&Blue1

    Note: To properly load these palettes, you will simply use their string names (e.g. “DarkPastels.Pastels").

Example

To set the EarthTones palette:

out-Map -Palette "ChartFX6.EarthTones"

See Also

Map Parameter | Map Summary


PlotAreaMargin property of Chart Parameter

PlotAreaMargin Parameter

Gets and Sets the top, bottom, left and right gaps of the map.

Remarks

  • A gap is defined as the margin between the map and the bounding rectangle in pixels. Each map has a top, bottom, left and right gaps.

Example

Sets the bottom gap of the map to 100. The other gaps are set to 0.

Out-Map -PlotAreaMargin_Top 0 -PlotAreaMargin_Bottom 100 -PlotAreaMargin_Right 0 -PlotAreaMargin_Left 0

See Also

Map Parameter | Map Summary


Margins Class Members

Map_PlotAreaMargin Parameters

Parameters

Description

Bottom | Sets the distance in pixels between the bottom border of the bounding rectangle and the bottom border of the of the chart.
Left | Sets the distance in pixels between the left border of the bounding rectangle and the left border of the of the chart.
Right | Sets the distance in pixels between the right border of the bounding rectangle and the right border of the of the chart.
Top | Sets the distance in pixels between the top border of the bounding rectangle and the top border of the of the chart.


PlotAreaMargin_Bottom property of Margins Parameter

PlotAreaMargin_Bottom Parameter

Sets the distance in pixels between the bottom border of the bounding rectangle and the bottom border of the plot area of the map.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a map.

Example

Sets the bottom margin to 100 pixels:

Out-Map -PlotAreaMargin_Bottom 100

See Also

Map_PlotAreaMargin Parameter | Map_PlotAreaMargin Summary


PlotAreaMargin_Left property of Margins Parameter

PlotAreaMargin_Left Parameter

Sets the distance in pixels between the left border of the bounding rectangle and the left border of the plot area of the map.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a map.

Example

Sets the left margin to 100 pixels:

Out-Map -PlotAreaMargin_Left 100

See Also

Map_PlotAreaMargin Parameter | Map_PlotAreaMargin Summary


PlotAreaMargin_Right property of Margins Parameter

PlotAreaMargin_Right Parameter

Sets the distance in pixels between the right border of the bounding rectangle and the right border of the plot area of the map.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a map.

Example

Sets the right margin to 100 pixels:

Out-Map -PlotAreaMargin_Right 100

See Also

Map_PlotAreaMargin Parameter | Map_PlotAreaMargin Summary


PlotAreaMargin_Top property of Margins Parameter

PlotAreaMargin_Top Parameter

Sets the distance in pixels between the top border of the bounding rectangle and the top border of the plot area of the map.

Remarks

  • The property of the Parameter is used to obtain the Margins object for a map.

Example

Sets the top margin to 100 pixels:

Out-Map -PlotAreaMargin_Top 100

See Also

Map_PlotAreaMargin Parameter | Map_PlotAreaMargin Summary


Points_<index> property of Chart Parameter

Points_<index> Parameter

Assigns properties directly to a specific point in the map.

Parameters

Parameter | Type | Meaning
series | Int32 | A zero based index indicating the data series in a map.
point | Int32 | A zero based index indicating the data point in a map.

Parameter | Type | Meaning
point | Int32 | A zero based index indicating the data point in a map. When a map only has one series, only a point index is required.

Remarks

  • Allows you to assign supported properties directly to the specified data point. For supported properties, please see the Parameter.

  • If you want to change the markers and the labels for all the points of the same series, please refer to the Series property.

Example

Changes the second series, third point color to black:

Out-Map -Points_1_2_Color Black

Turns on the point label for the third point in a one series map:

Out-Map -Points_2_PointLabels_Visible true

See Also

Map Parameter | Map Summary


PointAttributes Class Members

Map_Points Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
Color | Allows you to set a color for the selected item.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Pattern | Sets a value specifying the pattern for the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
Text | Sets a value for labeling the point or series attribute.


Points_<index>_AlternateColor property of PointAttributes Parameter

Points_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To set the Points AlternateColor:

Out-Map -Points_0_AlternateColor Red

See Also

Map_Points Parameter | Map_Points Summary


Points_<index>_Border property of PointAttributes Parameter

Points_<index>_Border Parameter

Provides access to the border attributes object.

Remarks

  • The members of the BorderAttributes Parameter allow customization of the border for Points and Series.

  • Color, Effect, Style, Width, etc, are some of the configurable attributes for Borders.

Example

To set the Points Border Width:

Out-Map -Points_0_Border_Width 5

See Also

Map_Points Parameter | Map_Points Summary


BorderAttributes Class Members

Map_Points_Border Parameters

Parameters

Description

BetweenSegments | Sets a property which makes the border to be shown between segments.
Color | Sets the color of the border of a point marker.
Effect | Sets a BorderEffect for point marker border.
Style | Sets a DashStyle for the point marker border
UseForLines | Get or set a property which applies the Border attributes to the lines of a line chart.
Visible | Sets a value making the border visible or not.
Width | Sets a value setting the width in pixels.


Points_<index>_Border_BetweenSegments property of BorderAttributes Parameter

Points_<index>_Border_BetweenSegments Parameter

Sets a property which makes the border to be shown between segments.

Example

To set the Points Border BetweenSegments:

Out-Map -Points_0_Border_BetweenSegments true

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_Color property of BorderAttributes Parameter

Points_<index>_Border_Color Parameter

Sets the color of the border of a point marker.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Points Border Color:

Out-Map -Points_0_Border_Color Pink

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_Effect property of BorderAttributes Parameter

Points_<index>_Border_Effect Parameter

Sets a BorderEffect for point marker border.

Value | Meaning
None | No border effect is applied. The border effect must be None for the BorderColor property to take effect.
Raised | The border has raised inner and outer edges.
Light | Apply light color to the border using the series/points color.
Dark | Apply dark color to the border using the series/points color.
Opposite | Chooses between dark and light border depending on the object color. If the color is dark the chart will choose a light border color. If the color is light the chart will choose a dark border color.
Shadow | The border will have shadow.

Remarks

  • The Effect property must be set to BorderEffect.None for the Color property to have any effect on the selected item border.

Example

To set the Points Border Effect:

Out-Map -Points_0_Border_Effect Shadow

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_Style property of BorderAttributes Parameter

Points_<index>_Border_Style Parameter

Sets a DashStyle for the point marker border

Remarks

  • Supported Dash Styles:
    Custom
    Dash
    DashDot
    DashDotDot
    Dot
    Solid

Example

To set the Points Border Style:

Out-Map -Points_0_Border_Style Dash

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_UseForLines property of BorderAttributes Parameter

Points_<index>_Border_UseForLines Parameter

Get or set a property which applies the Border attributes to the lines of a line map.

Example

To set the Points Border UseForLines:

Out-Map -Points_0_Border_UseForLines

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_Visible property of BorderAttributes Parameter

Points_<index>_Border_Visible Parameter

Sets a value making the border visible or not.

Remarks

  • Point markers Borders are Visible by default.

Example

To set the Points Border Visible:

Out-Map -Points_0_Border_Visible false

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Border_Width property of BorderAttributes Parameter

Points_<index>_Border_Width Parameter

Sets a value setting the width in pixels.

Remarks

  • This property allows you to configure the width of point markers border.

Example

To set the Points Border Width:

Out-Map -Points_0_Border_Width 2

See Also

Map_Points_Border Parameter | Map_Points_Border Summary


Points_<index>_Color property of PointAttributes Parameter

Points_<index>_Color Parameter

Allows you to set a color for the selected item.

Remarks

  • If no colors are specified, the default color is automatically selected by PowerGadgets when you create the map, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Points Color:

Out-Map -Points_0_Color Green

See Also

Map_Points Parameter | Map_Points Summary


Points_<index>_FillMode property of PointAttributes Parameter

Points_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the maps. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the map.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the Points FillMode:

Out-Map -Points_0_FillMode Pattern

See Also

Map_Points Parameter | Map_Points Summary


Points_<index>_Pattern property of PointAttributes Parameter

Points_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the map FillMode is set to either B&W or colored patterns.

  • If the map's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

Example

To set the Points Pattern:

Out-Map -Points_0_Pattern Cross

See Also

Map_Points Parameter | Map_Points Summary


Points_<index>_PointLabels property of PointAttributes Parameter

Points_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To set the Points PointLabels Visible:

Out-Map -Points_0_PointLabels_Visible true

See Also

Map_Points Parameter | Map_Points Summary


PointLabelAttributes Class Members

Map_Points_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


Points_<index>_PointLabels_Alignment property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the Points PointLabels Alignment:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_Alignment Near

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_Angle property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the Points PointLabels Angle:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_Angle 45

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_BackColor property of PointLabelAttributes Parameter

Points_<index>_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Points PointLabels BackColor:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_BackColor Yellow

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_Font property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired map element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Points PointLabels Font:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_Font "Arial, 12"

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_Format property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY maps, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked maps).

    X displays the marker X value for any map type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To set the Points PointLabels Format:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_Format "I'm point # %N"

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_LineAlignment property of PointLabelAttributes Parameter

Points_<index>_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the Points PointLabels LineAlignment:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_LineAlignment Far

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_Offset property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

To set the Points PointLabels Offset:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_Offset "4, 5"

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_RichText property of PointLabelAttributes Parameter

Points_<index>_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To set the Points PointLabels RichText:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_RichText true

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_TextColor property of PointLabelAttributes Parameter

Points_<index>_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Points PointLabels TextColor:

Out-Map -Points_0_PointLabels_Visible true -Points_0_PointLabels_TextColor Red

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_PointLabels_Visible property of PointLabelAttributes Parameter

Points_<index>_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the Points PointLabels Visible:

Out-Map -Points_0_PointLabels_Visible true

See Also

Map_Points_PointLabels Parameter | Map_Points_PointLabels Summary


Points_<index>_Text property of PointAttributes Parameter

Points_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set the Points Text:

Out-Map -Points_0_Text "Text 0"

See Also

Map_Points Parameter | Map_Points Summary


RealTime property of Map Parameter

RealTime Parameter

Allows access to the RealTime Settings supported paramaters used to create real-time maps.

Remarks

  • You can set a buffer size to allocate memory for the realtime map using the property. Setting a buffer will create a Limited real-time map which is the fastest real-time map. Excluding the buffer will instruct PowerGadgets to create an Unlimited real-time map.

  • The loop marker may be customized using the property in conjunction with the supported Line Parameter properties, and attributes may be assigned using the Parameter.

  • Use the Refresh paramter to refresh the map with new data by executing the same command(s) that populated the map at the first time.

Example

Sets the buffer size to 20 for a real-time map:

Out-Map -RealTime_BufferSize 20

See Also

Map Parameter | Map Summary


RealTimeSettings Class Members

Map_RealTime Parameters

Parameters

Description

BufferSize | Sets the buffer size for real-time charts. When setting this property, the data array will be cleared.
FastScroll | Sets the Fast Scrolling feature.
LoopMarker | Allows you to apply the supported members to the real-time loop marker.
Mode | Sets or Gets the RealTime Mode.


RealTime_BufferSize property of RealTimeSettings Parameter

RealTime_BufferSize Parameter

Sets the buffer size for real-time maps. When setting this property, the data array will be cleared.

Remarks

  • This property allocates a circular buffer that PowerGadgets will use to handle limited real-time maps. By using this property, you gain performance in real-time maps and avoid data overflow.

Example

To set the buffer size to 400:

Out-Map -RealTime_BufferSize 400

See Also

Map_RealTime Parameter | Map_RealTime Summary


RealTime_FastScroll property of RealTimeSettings Parameter

RealTime_FastScroll Parameter

Sets the Fast Scrolling feature.

Remarks

  • This feature scrolls a portion of the map as a whole picture and simply paints a single value, instead of redrawing all the points.

  • This technique may prove very helpful when you have a large number of points or series.

Example

To turn this feature on for your map:

Out-Map -RealTime_FastScroll true

See Also

Map_RealTime Parameter | Map_RealTime Summary


RealTime_LoopMarker property of RealTimeSettings Parameter

RealTime_LoopMarker Parameter

Allows you to apply the supported Lineclass members to the real-time loop marker.

Example

Sets the loop-marker as a green dashed line:

Out-Map -RealTime_LoopMarker_Color Green -RealTime_LoopMarker_Style Dash

See Also

Map_RealTime Parameter | Map_RealTime Summary


RealTime_Mode property of RealTimeSettings Parameter

RealTime_Mode Parameter

Sets or Gets the RealTime Mode.

Remarks

  • Loop Mode should be used if you prefer for a loop marker to move across the map from left to right updating the values as it passes.

  • Scroll Mode should be used if you prefer the map’s data line/curve moving across from right to left updating the values on the right-most part of the map.

Example

To set the mode to scroll:

Out-Map -RealTime_Mode Scroll

See Also

Map_RealTime Parameter | Map_RealTime Summary


Refresh property of Chart Parameter

Refresh Parameter

Allows you to refresh the map with new data by executing the same command(s) that populated the map at the first time.

Remarks

  • If the command returns a single value per each series, the map will add a new point to the end. Otherwise, the whole map data is replaced with the new data.

Example

To refresh every 1 second the map populated with the processes (PS>get-process ):

ps | Out-Map -refresh 0:0:1

See Also

Map Parameter | Map Summary


RegionAlternateTextColor property of Map Parameter

RegionAlternateTextColor Parameter

Get or set the color used for all complex labels in a map.

Remarks

  • A complex label is defined as a label with a path or multiple paths (a line with a label that points to a region). A complex label is usually required when a region is smaller than the text label configured.

  • This scope of this setting is global for the entire map object.

See Also

Map Parameter | Map Summary


RowHeadings property of Chart Parameter

RowHeadings Parameter

Allows you to specifies which fields to use in crosstab map as row headings.

Remarks

  • Use RowHeadings to specifies which fields to use in crosstab map as column headings.

  • Use ColHeadings to specifies which fields to use in crosstab map as column headings.

Example

To configure the RowHeadings parameter to use the Handles and WorkingSet:

ps | Out-Map -rowHeadings Handles,WorkingSet

See Also

Map Parameter | Map Summary


Series_<index> property of Chart Parameter

Series_<index> Parameter

Assigns properties directly to the selected series in the map.

Parameters

Parameter | Type | Meaning
n | Int32 | A zero based index indicating the data series in the map.

Remarks

  • AllSeries allows to set properties common to all the Series or/and Points of the map.

  • The Series property allows you to create maps with mixed types and assign specific colors to each series.

Example

Create a multi-gallery map:

Out-Map -Series_0_Gallery Lines -Series_1_Gallery Bar -Series_2_Gallery Area

See Also

Map Parameter | Map Summary


SeriesAttributes Class Members

Map_Series Parameters

Parameters

Description

AlternateColor | Sets the alternate color for a selected item when using gradient FillMode.
Color | Sets a Color for the selected series.
FillMode | Sets a value indicating how PowerGadgets should fill the area representing the point.
Pattern | Sets a value specifying the pattern for the selected item.
PointLabels | Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.
Text | Sets a value for labeling the point or series attribute.


Series_<index>_AlternateColor property of PointAttributes Parameter

Series_<index>_AlternateColor Parameter

Sets the alternate color for a selected item when using gradient FillMode.

Remarks

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

  • To create a gradient for an item, you first need to set an initial color using the Color property. Then you can assign a AlternateColor to complete the gradient assignment.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

  • This property is used in conjunction with FillMode property. You need to set the FillMode to gradient in order to use AlternateColor property.

Example

To set the Series AlternateColor:

Out-Map -Series_0_AlternateColor Red

See Also

Map_Series Parameter | Map_Series Summary


Series_<index>_Color property of SeriesAttributes Parameter

Series_<index>_Color Parameter

Sets a Color for the selected series.

Remarks

  • If no colors are specified, The default color is automatically selected by PowerGadgets when you create the map, and chosen according to the current palette and its position in the series array.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

Change the color of the first series to HotPink:

Out-Map -Series_0_Color HotPink

See Also

Map_Series Parameter | Map_Series Summary


Series_<index>_FillMode property of PointAttributes Parameter

Series_<index>_FillMode Parameter

Sets a value indicating how Chart FX should fill the area representing the point.

Value | Meaning
Solid | Use solid colors.
Monochrome | Use Black & White patterns.
Pattern | Use colored patterns.
Gradient | Use Gradient when painting the chart series

Remarks

  • The default value is Solid.

  • The difference between colored patterns and black & white patterns, also known as hatched paterns, is that hatched patterns are defined by windows and they can be resized when printing the maps. However, there are limited hatched patterns available.

  • A general rule of thumb is to use colored patterns for the screen and black & white patterns when printing the map.

  • When creating gradients on point or series markers, the FillMode must be set to FillMode.Gradient. The Color and AlternateColor properties can be set to create the desired gradient colors.

Example

To set the Series FillMode:

Out-Map -Series_0_FillMode Pattern

See Also

Map_Series Parameter | Map_Series Summary


Series_<index>_Pattern property of PointAttributes Parameter

Series_<index>_Pattern Parameter

Sets a value specifying the pattern for the selected item.

Remarks

  • To use this property, you must make sure the map FillMode is set to either B&W or colored patterns.

  • If the map's fill mode is set to colored patterns you can set both the background and foreground color of the pattern with the Color and AlternateColor properties, respectively.

Example

To set the Series Pattern:

Out-Map -Series_0_Pattern Cross

See Also

Map_Series Parameter | Map_Series Summary


Series_<index>_PointLabels property of PointAttributes Parameter

Series_<index>_PointLabels Parameter

Provides access to PointLabelAttributes allowing for the manipulation of attributes pertaining to the point label.

Remarks

  • The members allows customization of the Point labels at the , and level.

Example

To set the Series PointLabels Visible:

Out-Map -Series_0_PointLabels_Visible true

See Also

Map_Series Parameter | Map_Series Summary


PointLabelAttributes Class Members

Map_Series_PointLabels Parameters

Parameters

Description

Alignment | Sets the vertical alignment for the point label.
Angle | Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.
BackColor | Sets the backgrond color of the point label.
BorderColor | Sets the border color of the point label.
BorderWidth | Sets a value indicating the width of the border surrounding the point label.
Font | Sets a Font object to use as rendering font for the point label.
Format | Sets a string pattern mask used to format the label.
LineAlignment | Sets the horizontal alignment for the point label.
Offset | Allows you to customize the point label position by configuring its coordinates.
RichText | Sets or Gets a value indicating the Text will be treated as RichText
TextColor | Sets a value for the point label color.
Visible | Sets a value indicating if point label should be displayed or not.


Series_<index>_PointLabels_Alignment property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Alignment Parameter

Sets the vertical alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the Series PointLabels Alignment:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_Alignment Near

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_Angle property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Angle Parameter

Sets the angle of the point label. The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Remarks

  • The default rotation angle is 0 degree (i.e., horizontal). Use a positive number to rotate the labels from lower left to upper right. Use negative degrees to rotate text from upper left to lower right.

Example

To set the Series PointLabels Angle:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_Angle 45

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_BackColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BackColor Parameter

Sets the backgrond color of the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Series PointLabels BackColor:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_BackColor Yellow

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_BorderColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BorderColor Parameter

Sets the border color of the point label.

Remarks

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

  • The Alignment property is used to control the vertical alignment for the point label.

  • The Visible property is a boolean indicating if point label should be displayed or not.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Series PointLabels BorderColor:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_BorderColor Red

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_BorderWidth property of PointLabelAttributes Parameter

Series_<index>_PointLabels_BorderWidth Parameter

Sets a value indicating the width of the border surrounding the point label.

Remarks

  • The BorderColor property gets or sets the border color of the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

Example

To set the Series PointLabels BorderWidth:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_BorderWidth 2

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_Font property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Font Parameter

Sets a Font object to use as rendering font for the point label.

Remarks

  • When setting a font, you must create a new font object with the desired attributes and assign that object to the desired map element every time.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Series PointLabels Font:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_Font "Arial, 12"

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_Format property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Format Parameter

Sets a string pattern mask used to format the label.

Remarks

  • Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY maps, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked maps).

    X displays the marker X value for any map type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the property of the object.

Example

To set the Series PointLabels Format:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_Format "I'm point # %N"

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_LineAlignment property of PointLabelAttributes Parameter

Series_<index>_PointLabels_LineAlignment Parameter

Sets the horizontal alignment for the point label.

Remarks

  • The possible values are Center, Far, Near.

Example

To set the Series PointLabels LineAlignment:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_LineAlignment Far

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_Offset property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Offset Parameter

Allows you to customize the point label position by configuring its coordinates.

Remarks

  • X represents the offset in pixel of the label related to the X Axis. Y represents the offset in pixel of the label related to the Y Axis. X and Y can be either positive or negative.

Example

To set the Series PointLabels Offset:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_Offset "4, 5"

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_RichText property of PointLabelAttributes Parameter

Series_<index>_PointLabels_RichText Parameter

Sets or Gets a value indicating the Text will be treated as RichText

Remarks

  • The TextColor property is used to get or set a value for the point label color.

  • The Visible property is a boolean indicating if point label should be displayed or not.

Example

To set the Series PointLabels RichText:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_RichText true

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_TextColor property of PointLabelAttributes Parameter

Series_<index>_PointLabels_TextColor Parameter

Sets a value for the point label color.

Remarks

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Series PointLabels TextColor:

Out-Map -Series_0_PointLabels_Visible true -Series_0_PointLabels_TextColor Red

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_PointLabels_Visible property of PointLabelAttributes Parameter

Series_<index>_PointLabels_Visible Parameter

Sets a value indicating if point label should be displayed or not.

Remarks

  • The Alignment property is used to control the vertical alignment for the point label.

  • The BackColor property gets or sets the backgrond color of the point label.

  • The BorderColor property gets or sets the border color of the point label.

  • The BorderWidth property gets or sets a value indicating the width of the border surrounding the point label.

Example

To set the Series PointLabels Visible:

Out-Map -Series_0_PointLabels_Visible true

See Also

Map_Series_PointLabels Parameter | Map_Series_PointLabels Summary


Series_<index>_Text property of PointAttributes Parameter

Series_<index>_Text Parameter

Sets a value for labeling the point or series attribute.

Remarks

  • For Points, Text will be used to asign a string to the point, which can be used as a PointLabels, in a Tooltip, etc.

Example

To set the Series Text:

Out-Map -Series_0_Text "Text 0"

See Also

Map_Series Parameter | Map_Series Summary


Size property of Chart Parameter

Size Parameter

Allows you to specify the actual dimension of the final rendered map.

Remarks

  • Use the Size prameter to specify the dimension (Width and Height) of the rendered map.

Example

To configure the size of the map:

Out-Map -size 800,600

See Also

Map Parameter | Map Summary


Steps property of Chart Parameter

Steps Parameter

Allows you to set the number of equal size ranges designated to spanning from the minimum value to the maximum value of the data.

Remarks

  • By default, five equal size ranges are designated spanning from the minimum value to the maximum value of the data. With the Steps parameter you can change the number of those equal size ranges.

  • To change the default color assigned to the ranges, see ColorFrom and ColorTo parameters

Example

To set the Steps parameter to 7:

Out-Map -Steps 7

See Also

Map Parameter | Map Summary


Template property of Chart Parameter

Template Parameter

Allows you to use or save map modifications into a template file.

Remarks

  • This parameter uses or saves the specified template. If no path is specified, the default path will be "My Documents".

  • Use Configure to activate a powerful graphical Wizard allowing advanced customization for map.

Example

To use a pre-configured template called MyProcesses:

Out-Map -template MyProcesses

To use a graphical Wizard to configure a Tamplate map:

Out-Map -configure -template MyProcesses

See Also

Map Parameter | Map Summary


Titles_<index> property of Chart Parameter

Titles_<index> Parameter

Returns the collection of titles defined in the map.

Parameters

Parameter | Type | Meaning
n | Int32 | A zero based index indicating the title index.

Remarks

  • Using the numerical index, you can access multiple items of this collection.

Example

To set a title in bold at the top of the map:

Out-Map -Titles_0_Text "Sales" -Titles_0_Font "Arial,10,style=bold" -Titles_0_Dock Top

See Also

Map Parameter | Map Summary


TitleDockable Class Members

Map_Titles Parameters

Parameters

Description

Alignment | Allows you to set the alignment of the specified title.
BackColor | Sets the color background of the specified title.
Dock | Sets or Gets the Dock property, which allows set where the title will be docked.
Font | Assigns a font to the specified title.
Indentation | Specify the space in pixels to the front and back of the selected title when read from top to bottom.
LineAlignment | Sets the vertical alignment for the lines of the chart title.
PlotAreaOnly | Sets a value indicating whether the title may use the entire length of the chart, or only above the plot area.
RichText | Sets or Get the RichText property for the selected Title.
Separation | Specify the space in pixels above and below the selected title text when read from right to left.
Text | Sets the text for the selected title.
TextColor | Sets the color of text for the specified title.


Titles_<index>_Alignment property of Title Parameter

Titles_<index>_Alignment Parameter

Allows you to set the alignment of the specified title.

Remarks

  • The alignment of a specified title may be assigned to Near, Center or Far using this property. Reading the map from left to right, Near will be to the left and Far will be to the right.

Example

To set the Titles Alignment:

Out-Map -Titles_0_Alignment Near

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_BackColor property of Title Parameter

Titles_<index>_BackColor Parameter

Sets the color background of the specified title.

Remarks

  • This property gives the titles of a map a highlighted effect. It is best to select colors that contrast to the TextColor in order to view the titles clearly.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles BackColor:

Out-Map -Titles_0_BackColor Yellow

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_Dock property of TitleDockable Parameter

Titles_<index>_Dock Parameter

Sets or Gets the Dock property, which allows set where the title will be docked.

Default Value
The default is Top.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • This property allows you to dock the map at the top, bottom, left or right of the map.

Example

To set the Titles Dock:

Out-Map -Titles_0_Dock Bottom

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_Font property of Title Parameter

Titles_<index>_Font Parameter

Assigns a font to the specified title.

Remarks

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

To set the Titles Font:

Out-Map -Titles_0_Font "Arial, 12"

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_Indentation property of Title Parameter

Titles_<index>_Indentation Parameter

Specify the space in pixels to the front and back of the selected title when read from top to bottom.

Remarks

  • The Separation property may be used to add space in pixels above and below the title string when read from right to left.

Example

To set the Titles Indentation:

Out-Map -Titles_0_Indentation 5

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_LineAlignment property of Title Parameter

Titles_<index>_LineAlignment Parameter

Sets the vertical alignment for the lines of the map title.

Remarks

  • By changing the LineAlignment value, you can control distance from the title to the map.

Example

To set the Titles LineAlignment:

Out-Map -Titles_0_LineAlignment Center

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_PlotAreaOnly property of TitleDockable Parameter

Titles_<index>_PlotAreaOnly Parameter

Sets a value indicating whether the title may use the entire length of the map, or only above the plot area.

Remarks

  • When set to True, the title header is the same width as the map's plot area. When set to False, title may be drawn across the entire map including margins.

Example

To set the Titles PlotAreaOnly:

Out-Map -Titles_0_PlotAreaOnly false

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_RichText property of Title Parameter

Titles_<index>_RichText Parameter

Sets or Get the RichText property for the selected Title.

Remarks

  • When this property is set to true, the Title Text can be enhanced by adding basic HTML markup.

  • The available markup tags are:

    Bold: <b>text</b>

    Underline: <u>text</u>

    Italic: <i>text</i>

    Strike:<s>text</s>

    Font: <font color="#FF0000" face="Arial>text</font>

    All markup tags must be closed.

  • <font> has two attributes: color, to set the color in html format (i.e. #00FF66), and face, to set the font name.

Example

To set the Titles RichText:

Out-Map -Titles_0_RichText true

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_Separation property of Title Parameter

Titles_<index>_Separation Parameter

Specify the space in pixels above and below the selected title text when read from right to left.

Remarks

  • This property assigns space in pixels around a Title string in reference to the title orientation. If the Title text reads horizontally (top title), space will be assigned above and below the string.

  • The Indentation property may be used to add space in pixels to the front and back of the title string when read from right to left.

Example

To set the Titles Separation:

Out-Map -Titles_0_Separation 5

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_Text property of Title Parameter

Titles_<index>_Text Parameter

Sets the text for the selected title.

Remarks

  • The TextColor property allows you to change the color of the specified title text.

  • Text can be enhanced buy setting the RichText property true. Bold, Italic, Underline, Font Face and Color can be set by adding basic HTML markup to the text.

Example

To set the Titles Text:

Out-Map -Titles_0_Text "3rd Quarter Sales"

See Also

Map_Titles Parameter | Map_Titles Summary


Titles_<index>_TextColor property of Title Parameter

Titles_<index>_TextColor Parameter

Sets the color of text for the specified title.

Remarks

  • The TextColor property is used in conjunction with the Text property.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the Titles TextColor:

Out-Map -Titles_0_TextColor Red

See Also

Map_Titles Parameter | Map_Titles Summary


TitleFont property of Map Parameter

TitleFont Parameter

Used to assign a new font object for double DrillDown titles.

Remarks

  • The TitleFont property is used to apply a new font object for DrillDown titles, but only when a double DrillDown has occured. Otherwise, the region font from the SVG is used.

  • The TitleSeparator property is used to specify the character used to separate DrillDown titles in the map.

  • Fonts can be specified by using the standard string notation for fully or partially qualifying a font object. For example, "Verdana,12,style=italic,Bold" produces a font of type Verdana, point size of 12 and font style of Italic and Bold.

Example

Set the font for the DrillDown Titles:

out-map -TitleFont "Arial,12"

See Also

Map Parameter | Map Summary


TitleSeparator property of Map Parameter

TitleSeparator Parameter

Sets the string used to separate titles.

Remarks

  • The only time a TitleSeparator is visible is when a double DrillDown has occured. The TitleFont is also only used when a double drilldown has occured.

  • This property accepts a string to be used as the separator for titles in the map extension.

Example

To configure a new TitleSeparator character:

out-map -TitleSeparator *

See Also

Map Parameter | Map Summary


ToolBar property of Chart Parameter

ToolBar Parameter

Allow to acces the tool bar of the map. Alternativelly, you can access the tool bar of the map using MenuBar.

Remarks

Example

Makes the ToolBar visible:

Out-Map -ToolBar_Visible true

See Also

Map Parameter | Map Summary


ToolBar Class Members

Map_ToolBar Parameters

Parameters

Description

AutoSize | Allows PowerGadgets to calculate the best size according to the tool position.
BackColor | Sets a value for the background color of a dockable bar.
Border | Allows the developer to specify the border style.
Dock | Sets the position of the ToolBar.
Height | Sets the height of the dockable bar in pixels.
ShowImages | Sets a value indicating whether to show or hide images for ToolBarItems.
Visible | Sets a value indicating the Dockablebar object should be shown or not.
Width | Sets the height in pixels.


ToolBar_AutoSize property of DockableBar Parameter

ToolBar_AutoSize Parameter

Allows Chart FX to calculate the best size according to the tool position.

Remarks

  • When the user moves a dockable bar from one docked position to another (e.g. Docked-Right to Docked-Top), the object must be resized accordingly to fit. When this property is set to True, you will not need to set the Width or Height as PowerGadgets will calculate those values for you.

  • The Width and Height properties may be used to manually control the size of a DockableBar, however they should only be used when the AutoSize is configured to False.

  • The Dock property may be used to position a DockableBar object in a map.

Example

To set the ToolBar AutoSize:

Out-Map -ToolBar_Visible true -ToolBar_AutoSize true

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_BackColor property of DockableBar Parameter

ToolBar_BackColor Parameter

Sets a value for the background color of a dockable bar.

Remarks

  • The effect of this property is to change the background behind any dockable bar object such as the DataGrid.

  • Named color are supported (e.g. Red), to use Hex notation you have to use quotes (e.g. "#FF00FF").

Example

To set the ToolBar BackColor:

Out-Map -ToolBar_Visible true -ToolBar_BackColor Redf

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_Border property of DockableBar Parameter

ToolBar_Border Parameter

Allows the developer to specify the border style.

Remarks

  • Allows you to specify the border for any DockableBar to be External, Internal or None.

Example

To set the ToolBar Border:

Out-Map -ToolBar_Visible true -ToolBar_Border External

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_Dock property of DockableBar Parameter

ToolBar_Dock Parameter

Sets the position of the ToolBar.

Value | Meaning
Left | Docks the object to the left margin.
Top | Docks the object to the top margin.
Right | Docks the object to the right margin.
Bottom | Docks the object to the bottom margin.

Remarks

  • All tools in PowerGadgets are created (by default) with the AutoSize property set to True. When this property is set to True and the end user moves a Dockable Bar to another position, PowerGadgets will calculate the appropriate width and height.

Example

To set the ToolBar Dock:

Out-Map -ToolBar_Visible true -ToolBar_Dock Right

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_Height property of DockableBar Parameter

ToolBar_Height Parameter

Sets the height of the dockable bar in pixels.

Remarks

  • Use the Height property to configure the height for the dockable bar object.

Example

To set the ToolBar Height:

Out-Map -ToolBar_Visible true -ToolBar_Height 300

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_ShowImages property of ToolBar Parameter

ToolBar_ShowImages Parameter

Sets a value indicating whether to show or hide images for ToolBarItems.

Remarks

  • The property is used to access the ToolBar object of a map.

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_Visible property of DockableBar Parameter

ToolBar_Visible Parameter

Sets a value indicating the Dockablebar object should be shown or not.

Remarks

  • Hiding a DockableBar object not destroy or lose previous settings assigned by other properties.

Example

To set the ToolBar Visible:

Out-Map -ToolBar_Visible false

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolBar_Width property of DockableBar Parameter

ToolBar_Width Parameter

Sets the height in pixels.

Remarks

  • When you modify the width, the AutoSize property will be set to False.

Example

To set the ToolBar Width:

Out-Map -ToolBar_Visible true -ToolBar_Width 300

See Also

Map_ToolBar Parameter | Map_ToolBar Summary


ToolTipFields property of Chart Parameter

ToolTipFields Parameter

Specifies which properties to use in the tooltips. Multiple properties can be separated by commas.

Remarks

  • Use Values to specifie the properties to consider for plotting data. Only numeric properties can be plotted. If omitted, all the numeric properties are plo tted or the properties specified by default views file.

Example

To set the ToolTipFields parameter:

ps | Out-Map -Values Hand les -Label ProcessName -ToolTipFields CPU

See Also

Map Parameter | Map Summary


ToolTipFormat property of Chart Parameter

ToolTipFormat Parameter

Allows you to control the information to be displayed in the tooltip when the user positions the mouse over a particular data point in the map.

Remarks

  • ToolTips toggle on/off the tooltip in the map.

  • The syntax for this property is the same as the one used in the property. Variables can be accessed using the % following the variable you want to include:

    l Shows X-Axis Legend.

    k Shows X-Axis Key Legend.

    s Shows Series Legend.

    S Shows the Series Index.

    x Shows XValue (XY maps, when they were set with X values).

    i Shows IniValues (Gantt).

    v Shows Data Value.

    v <n> For types that require more than one series, these are replaced by the value of each one. (n represents an index).

    t Series Total (Sum of all points in this series).

    p Percentage of total this point represents (Pie).

    T Point Total (Sum of all series for this point).

    P Percentage of total this series represents (Used in stacked maps).

    X displays the marker X value for any map type including those that do not support X values such as bar.

    N Shows the index for the point.

    L Shows the Text property of the object.

Example

Shows a custom text, the series legend and the data value though the tooltip:

Out-Map -Tooltips true -ToolTipFormat "I'm series: %S my value is:%v"

See Also

Map Parameter | Map Summary


ToolTips property of Chart Parameter

ToolTips Parameter

Allows you to enable or disable tooltips when the user positions the mouse over a particular element in the map area only.

Remarks

  • This property does not affect whether if the Toolbar ToolTips will appear or not when the user positions the mouse over a particular button or element in the Toolbar. For more information on how to disable Toolbar tooltips, please refer to the ToolTips property in the Parameter.

Example

To disable tool tips:

Out-Map -ToolTips false

See Also

Map Parameter | Map Summary


Values property of Chart Parameter

Values Parameter

Allows you to specify which properties to map.

Remarks

  • Use the Values parameter to specify which properties will be used to populate the map.

Example

To specify the Handles as value in a map populated with the processes (PS>get-process ):

ps | Out-Map -values Handles

See Also

Map Parameter | Map Summary


WinnerSeriesType property of Map Parameter

WinnerSeriesType Parameter

Sets the mode which the winning series is determined.

Remarks

Example

To configure the WinnerSeriesType to Min:

out-map -WinnerSeriesType Min

See Also

Map Parameter | Map Summary


Invoke-Sql property of PowerGadget Parameter

Invoke-Sql Parameter

Allows for convenient access to database data through common SQL syntax.

Example

To retrieve data from a SQL Server database:

invoke-sql -server DBServer -sql "Select Product,QtySold,QtyInInventory FROM Products"

To retrieve data from a SQL Server using a Store Procedure (spName) with parameters (iParamValue1):

invoke-sql -server MyDBServer -DataBase MyDatabase -user userx -sql "spName paramValue1"

To retrieve data from an Access database:

invoke-sql -connection "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=c:\MyAccessDB.mdb" -sql "Select * FROM MyTable"


Title Class Members

Invoke-Sql Parameters

Parameters

Description

Server | Sets the server or IP address to connect to.
Database | Sets the SQL Server database name.
Sql | Sets the Transact-SQL statement, table name or stored procedure to execute at the data source.
ConnectionString | Specifies the full connection string for connecting to the database.
User | Sets the SQL Server User name.
Password | Sets the SQL server password name.


Server property of PowerGadget Parameter

Server Parameter

Sets the server or IP address to connect to.

Example

To retrieve data from a SQL Server database:

invoke-sql -server DBServer -sql "Select Product,QtySold,QtyInInventory FROM Products"


DataBase property of PowerGadget Parameter

DataBase Parameter

Sets the SQL Server database name.

Example

To retrieve data from a SQL Server using a Store Procedure (spName) with parameters (paramValue1):

invoke-sql -server MyDBServer -DataBase MyDatabase -user userx -sql "spName paramValue1"


Sql property of PowerGadget Parameter

Sql Parameter

Sets the Transact-SQL statement, table name or stored procedure to execute at the data source.

Example

To retrieve data from a SQL Server database:

invoke-sql -server DBServer -SQL "Select Product,QtySold,QtyInInventory FROM Products"


ConnectionString property of PowerGadget Parameter

ConnectionString Parameter

Specifies the full connection string for connecting to the database.

Example

To retrieve data from an Access database:

invoke-sql -connection "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=c:\MyAccessDB.mdb" -sql "Select * FROM MyTable"


User property of PowerGadget Parameter

User Parameter

Sets the SQL Server User name.

Remarks

  • Use the User parameter for standard SQL authentication. If no username and no password are supplied, Windows authentication is used with the currently logged on user.

Example

To retrieve data from a SQL Server using a Store Procedure (spName) with parameters (paramValue1):

invoke-sql -server MyDBServer -DataBase MyDatabase -user userx -sql "spName paramValue1"


Password property of PowerGadget Parameter

Password Parameter

Sets the SQL server password name

Remarks

  • Use the Password parameter for standard SQL authentication. If no username and no password are supplied, Windows authentication is used with the currently logged on user.

Example

To retrieve data from a SQL Server using a Store Procedure (spName) with parameters (paramValue1):

invoke-sql -server MyDBServer -DataBase MyDatabase -user userx -Password MyPassword -sql "spName paramValue1"


Invoke-WebService property of PowerGadget Parameter

Invoke-WebService Parameter

Allows you to easily obtain data from web services.

Example

To invoke a Web Service:

invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployee


Title Class Members

Invoke-WebService Parameters

Parameters

Description

Wsdl | Specifies the web service description lenguage either in the form of a web based URL or file based URI
Method | Sets the name of the method to execute.
Parameters | Sets the parameters required by the selected method.
Service | allows you to specify the service (or class) to use.


Wsdl property of PowerGadget Parameter

Wsdl Parameter

Specifies the web service description lenguage either in the form of a web based URL or file based URI.

Remarks

  • Use Wsdl to specify the public URL where the web service can be found.

  • If you are referencing .NET web services typically ending with .ASMX extension, you need to append the "?WSDL" at the end of the URL so the result is in WSDL complient format.

Example

To invoke a Web Service:

invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployee


Method property of PowerGadget Parameter

Method Parameter

Sets the name of the method to execute.

Remarks

  • The service exposes various public methods available for execution. You specify the desire mathod to execute using this parameter. Simply supply the method name.

Example

To invoke a method in a Web Service:

invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployee


Parameters property of PowerGadget Parameter

Parameters Parameter

Sets the parameters required by the selected method.

Remarks

  • Multiple parameters should be separated by comma.

  • This parameter is optional, you can supply the parameters right after the method name:
    -invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployeeInfo paramValue1, paramValue2

Example

To invoke a Method with parameters in a Web Service:

invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployeeInfo -Parameters paramValue1, paramValue2


Service property of PowerGadget Parameter

Service Parameter

allows you to specify the service (or class) to use.

Remarks

  • In most cases, there is one service per URL in .NET so this parameter is no required, however on other platforms you may find multiple services available with a single URL.

Example

To invoke a Web Service with multiple services available:

invoke-webservice -wsdl http://www.tempuri.org/employee.wsdl -method GetEmployee -Service EmployeeInfo


Send-Mail property of PowerGadgets Parameter

Send-Mail Parameter

Allows you to deliver an email with the gadget's image representation.

Remarks

  • Email address can be either a single email as "johndoe@softwarefx.com" or a name/email combination such as "John Doe <johndoe@softwarefx.com>". By using the name/email combination, the name appears when the recipient reads the email - making the email more legible.

  • Many times the sender and the server will never change, hence you want to configure default values for these parameters. To do this, simply edit the GlobalSettings.xml file located in your AppData folder of your profile as shown where userx is the username of the currently logged in user.

    In Windows Vista, the path would be as follows:
    c:\Users\userx\AppData\Roaming\PowerGadgets

    In Windows XP, the path would be as follows:
    c:\Documents and Settings\userx\Application Data\PowerGadgets.

    For more information about send-email see the PowerGadgets Quick start Guide.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


Title Class Members

Send-Mail Parameters

Parameters

Description

To | Sets the recipient or recipients of the email.
From | Sets the sender of the email.
Subject | Sets the subject of the email.
Server | Sets the server or IP address to use as the delivery server.
Text | The text or body of the email in plain text.
Attachments | Sets any related file attachments to the email.


To property of PowerGadgets Parameter

To Parameter

Sets the recipient or recipients of the email.

Remarks

  • The value can be a simple email address or a combination of a name and email address if formatted as follows: John Doe [johndoe@someserver.com]

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


From property of PowerGadgets Parameter

From Parameter

Sets the sender of the email.

Remarks

  • Email address can be either a single email as "johndoe@softwarefx.com" or a name/email combination such as "John Doe <johndoe@softwarefx.com>". By using the name/email combination, the name appears when the recipient reads the email - making the email more legible.

  • Many times the sender and the server will never change, hence you want to configure default values for these parameters. To do this, simply edit the GlobalSettings.xml file located in your AppData folder of your profile as shown where userx is the username of the currently logged in user.

    In Windows Vista, the path would be as follows:
    c:\Users\userx\AppData\Roaming\PowerGadgets

    In Windows XP, the path would be as follows:
    c:\Documents and Settings\userx\Application Data\PowerGadgets.

    For more information about send-email see the PowerGadgets Quick start Guide.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


Subject property of PowerGadgets Parameter

Subject Parameter

Sets the subject of the email.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


send-mail_Server property of PowerGadgets Parameter

send-mail_Server Parameter

Sets the server or IP address to use as the delivery server.

Remarks

  • This should point to your local mailserver or a server accepting SMTP connections for delivery.

  • Many times the sender and the server will never change, hence you want to configure default values for these parameters. To do this, simply edit the GlobalSettings.xml file located in your AppData folder of your profile as shown where userx is the username of the currently logged in user.

    In Windows Vista, the path would be as follows:
    c:\Users\userx\AppData\Roaming\PowerGadgets

    In Windows XP, the path would be as follows:
    c:\Documents and Settings\userx\Application Data\PowerGadgets.

    For more information about send-email see the PowerGadgets Quick start Guide.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


Text property of PowerGadgets Parameter

Text Parameter

Sets the text or body of the email in plain text.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver


Attachments property of PowerGadget Parameter

Attachments Parameter

Sets any related file attachments to the email.

Remarks

  • Files should be absolute paths to each file. Multiple files should be separated by comma.

Example

To send an email with a PowerGadgets chart image:

ps | out-chart | send-mail -From sender@softwarefx.com -To johndoe@softwarefx.com -subject "Sample Subject" - Text "This is a sample process chart" -server mailserver -Attachments "c:\MyZipFile.zip"


Chart Parameter

Remarks

General chart properties are provided to set general attributes in the chart. For example, you may use properties to show or hide tools in the chart window or to apply a specific line style to all lines in a line chart.

There may be a case in which a general property is also found in a specific object. For example, you may use a general property called property to change the chart type displayed (for in the chart), but if you use the Gallery property supported by the object you will change the chart type for a particular series (thus creating a MultiType chart) instead of all series in the chart. You may even go a step further by assigning properties directly to specific points rather than series using the object.

Some properties of the Chart object act as a mechanism for assigning attributes directly to other objects that exist in the chart. Some of these properties include LegendBox, ToolBar, MenuBar, and DataGrid. If you want to assign individual properties to elements in the chart, you may refer to the different objects available.

The chart can be rendered in 3D. property provides access the 3D customization of the chart.


DrillDown Class Members

Horizontal_DrillDown Parameters

Parameters

Description

Script | Specifies the script that will be invoked when the user double-clicks on the gauge or any of its indicators.
Parameter | Specifies the properties that will be passed as parameters when user double-clicks on the gauge or any of its indicators.
Console | If specified, the drilldown will show the PowerShell command screen when executed.


MainIndicator_Draggable property of Indicator Parameter

MainIndicator_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainIndicator Draggable:

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_Draggable true

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_DraggableCursor property of Indicator Parameter

MainIndicator_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainIndicator DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Filler -MainIndicator_DraggableCursor PanWest

See Also

Horizontal_MainIndicator_Filler Parameter | Horizontal_MainIndicator_Filler Summary


MainIndicator_Draggable property of Indicator Parameter

MainIndicator_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainIndicator Draggable:

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_Draggable true

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainIndicator_DraggableCursor property of Indicator Parameter

MainIndicator_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainIndicator DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Marker -MainIndicator_DraggableCursor PanWest

See Also

Horizontal_MainIndicator_Marker Parameter | Horizontal_MainIndicator_Marker Summary


MainScale_Indicators_<index>_Draggable property of Indicator Parameter

MainScale_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainScale Indicators Draggable:

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_Draggable true

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_DraggableCursor property of Indicator Parameter

MainScale_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainScale Indicators DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Filler -MainScale_Indicators_0_DraggableCursor PanWest

See Also

Horizontal_MainScale_Indicators_Filler Parameter | Horizontal_MainScale_Indicators_Filler Summary


MainScale_Indicators_<index>_Draggable property of Indicator Parameter

MainScale_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainScale Indicators Draggable:

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_Draggable true

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_DraggableCursor property of Indicator Parameter

MainScale_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainScale Indicators DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Marker -MainScale_Indicators_0_DraggableCursor PanWest

See Also

Horizontal_MainScale_Indicators_Marker Parameter | Horizontal_MainScale_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Draggable property of Indicator Parameter

Scales_<index>_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the Scales Indicators Draggable:

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_Draggable true

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_DraggableCursor property of Indicator Parameter

Scales_<index>_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the Scales Indicators DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Filler -Scales_0_Indicators_0_DraggableCursor PanWest

See Also

Horizontal_Scales_Indicators_Filler Parameter | Horizontal_Scales_Indicators_Filler Summary


Scales_<index>_Indicators_<index>_Draggable property of Indicator Parameter

Scales_<index>_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the Scales Indicators Draggable:

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_Draggable true

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_DraggableCursor property of Indicator Parameter

Scales_<index>_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the Scales Indicators DraggableCursor to PanWest

out-gauge -Type Horizontal -MainIndicator Marker -Scales_0_Indicators_0_DraggableCursor PanWest

See Also

Horizontal_Scales_Indicators_Marker Parameter | Horizontal_Scales_Indicators_Marker Summary


Chart Parameter

Map Parameter

Remarks

General map properties are provided to set general attributes in the map. For example, you may use properties to show or hide tools in the map window or to apply a specific line style to all lines in a line map.

There may be a case in which a general property is also found in a specific object. For example, you may use a general property called property to change the map type displayed (for in the map), but if you use the Gallery property supported by the object you will change the map type for a particular series (thus creating a MultiType map) instead of all series in the map. You may even go a step further by assigning properties directly to specific points rather than series using the object.

Some properties of the Map object act as a mechanism for assigning attributes directly to other objects that exist in the map. Some of these properties include LegendBox, ToolBar, MenuBar, and DataGrid. If you want to assign individual properties to elements in the map, you may refer to the different objects available.

The map can be rendered in 3D. property provides access the 3D customization of the map.


MainIndicator_Draggable property of Indicator Parameter

MainIndicator_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainIndicator Draggable:

out-gauge -MainIndicator Marker -MainIndicator_Draggable true

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_DraggableCursor property of Indicator Parameter

MainIndicator_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainIndicator DraggableCursor to PanWest

out-gauge -MainIndicator Marker -MainIndicator_DraggableCursor PanWest

See Also

Radial_MainIndicator_Marker Parameter | Radial_MainIndicator_Marker Summary


MainIndicator_Draggable property of Indicator Parameter

MainIndicator_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainIndicator Draggable:

out-gauge -MainIndicator Needle -MainIndicator_Draggable true

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainIndicator_DraggableCursor property of Indicator Parameter

MainIndicator_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainIndicator DraggableCursor to PanWest

out-gauge -MainIndicator Needle -MainIndicator_DraggableCursor PanWest

See Also

Radial_MainIndicator_Needle Parameter | Radial_MainIndicator_Needle Summary


MainScale_Indicators_<index>_Draggable property of Indicator Parameter

MainScale_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainScale Indicators Draggable:

out-gauge -MainIndicator Marker -MainScale_Indicators_0_Draggable true

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_DraggableCursor property of Indicator Parameter

MainScale_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainScale Indicators DraggableCursor to PanWest

out-gauge -MainIndicator Marker -MainScale_Indicators_0_DraggableCursor PanWest

See Also

Radial_MainScale_Indicators_Marker Parameter | Radial_MainScale_Indicators_Marker Summary


MainScale_Indicators_<index>_Draggable property of Indicator Parameter

MainScale_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the MainScale Indicators Draggable:

out-gauge -MainIndicator Needle -MainScale_Indicators_0_Draggable true

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


MainScale_Indicators_<index>_DraggableCursor property of Indicator Parameter

MainScale_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the MainScale Indicators DraggableCursor to PanWest

out-gauge -MainIndicator Needle -MainScale_Indicators_0_DraggableCursor PanWest

See Also

Radial_MainScale_Indicators_Needle Parameter | Radial_MainScale_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_Draggable property of Indicator Parameter

Scales_<index>_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the Scales Indicators Draggable:

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_Draggable true

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_DraggableCursor property of Indicator Parameter

Scales_<index>_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the Scales Indicators DraggableCursor to PanWest

out-gauge -MainIndicator Marker -Scales_0_Indicators_0_DraggableCursor PanWest

See Also

Radial_Scales_Indicators_Marker Parameter | Radial_Scales_Indicators_Marker Summary


Scales_<index>_Indicators_<index>_Draggable property of Indicator Parameter

Scales_<index>_Indicators_<index>_Draggable Parameter

Sets a value indicating whether the indicator is movable via user interface.

Remarks

  • When set to true, users may drag an indicator to a selected value by holding the left mouse button and moving the cursor.

Example

To set the Scales Indicators Draggable:

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_Draggable true

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary


Scales_<index>_Indicators_<index>_DraggableCursor property of Indicator Parameter

Scales_<index>_Indicators_<index>_DraggableCursor Parameter

Sets the mouse cursor displayed when dragging an indicator.

Remarks

  • The default set of Windows Cursors may be used or a custom cursor may also be implemented.

Example

To set the Scales Indicators DraggableCursor to PanWest

out-gauge -MainIndicator Needle -Scales_0_Indicators_0_DraggableCursor PanWest

See Also

Radial_Scales_Indicators_Needle Parameter | Radial_Scales_Indicators_Needle Summary