Introduction

StarBurn SDK (Software Development Kit)
Introduction
Topics
Collapse All

The architecture of this toolkit makes it possible to access a wide variety of CD/DVD/Blu-Ray/HD-DVD devices using a simple interface. Support for peripheral devices in Windows 95, Windows 98, Windows Me (Millennium Edition), Windows NT, Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008 R2 and Windows 7, Windows 2012 R2, Windows 8, Windows Server 2016, Windows 10 is normally achieved through device specific drivers layered on top of the operating systems’ native SCSI support. Because of the great diversity of CD/DVD/Blu-Ray/HD-DVD devices, no driver can support all of them. Instead, different ways are needed for supporting each major class of installed CD/DVD/Blu-Ray/HD-DVD device. This toolkit isolates such a different handling inside and export the functions that allow the user to handle all of CD/DVD/Blu-Ray/HD-DVD devices in “generic” way when the user uses the same routines for example to burn the CD/DVD/Blu-Ray/HD-DVD on the devices that really requires very different actions to be performed for real process of burning. The goal of the toolkit is to hide all the differences in hardware from the user and provide easy and ready to go mechanism for working with CD/DVD/Blu-Ray/HD-DVD devices.

Before you begin your development efforts, be sure that you have a solid understanding of the SCSI and MMC specifications. You should understand what SCSI sense data is and how to treat the different conditions that can happen during CD/DVD/Blu-Ray/HD-DVD burning or grabbing process. Much of your success in developing a CD/DVD/Blu-Ray/HD-DVD burning, grabbing or mastering module is dependent on your understanding of these specifications.

Topics
Name | Description
Copyright | Copyright © Rocket Division Software 2001-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of Rocket Division Software. Copyright © StarBurn Software 2009-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of StarBurn Software.
Trademarks | "StarBurn Software", “Rocket Division Software”, “StarBurn”, “StarBurn SDK” and the StarBurn Software, Rocket Division Software, StarBurn, StarBurn SDK logos are trademarks of Rocket Division Software and StarBurn Software which may be registered in some jurisdictions. All other trademarks are owned by their respective owners.
Changes | The material in this document is for information only and is subject to change without notice. While reasonable efforts have been made in the preparation of this document to assure its accuracy, StarBurn Software assumes no liability resulting from errors or omissions in this document, or from the use of the information contained herein. StarBurn Software reserves the right to make changes in the product design without reservation and without notification to its users.
Technical support and service | If you have questions about installing or using this software, check this and other documents first - you will find answers to most of your questions here or there. If you need further assistance, please contact us.
Links
Topics
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.
Contents | Index | Home
What do you think about this topic? Send feedback!


Copyright

Copyright
Introduction
Collapse All

Copyright © Rocket Division Software 2001-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of Rocket Division Software.

Copyright © StarBurn Software 2009-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of StarBurn Software.

Group

Introduction

Links
Introduction
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Trademarks

Trademarks
Introduction
Collapse All

"StarBurn Software", “Rocket Division Software”, “StarBurn”, “StarBurn SDK” and the StarBurn Software, Rocket Division Software, StarBurn, StarBurn SDK logos are trademarks of Rocket Division Software and StarBurn Software which may be registered in some jurisdictions. All other trademarks are owned by their respective owners.

Group

Introduction

Links
Introduction
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Changes

Changes
Introduction
Collapse All

The material in this document is for information only and is subject to change without notice. While reasonable efforts have been made in the preparation of this document to assure its accuracy, StarBurn Software assumes no liability resulting from errors or omissions in this document, or from the use of the information contained herein. StarBurn Software reserves the right to make changes in the product design without reservation and without notification to its users.

Group

Introduction

Links
Introduction
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Technical support and service

Technical support and service
Introduction
Collapse All

If you have questions about installing or using this software, check this and other documents first - you will find answers to most of your questions here or there. If you need further assistance, please contact us.

Group

Introduction

Links
Introduction
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Functions

Functions
Functions | Legend
Collapse All

The following table lists functions in this documentation.

Functions
Name | Description
StarBurn_CdvdBurnerGrabber_AuthorizeDVD | This function authorizes DVD that has CSS protection system.
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx | This function authorizes DVD that has CSS protection system and keeps bus key for disc key.
StarBurn_CdvdBurnerGrabber_Blank | This function erases the rewritable media inserted into CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormat | This function formats Blu-Ray rewritable media (BD-RE) inserted into the Blu-Ray burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery | This function queries available Blu-Ray formats for the currently inserted Blu-Ray rewritable media (BD-RE).
StarBurn_CdvdBurnerGrabber_Cancel | This function cancels current read or write process on the CD/DVD/Blu-Ray/HD-DVD burner.
StarBurn_CdvdBurnerGrabber_CloseSession | This function closes session on on CD/DVD/Blu-Ray/HD-DVD burner device after something was written using StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile.
StarBurn_CdvdBurnerGrabber_Create | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD releated actions.
StarBurn_CdvdBurnerGrabber_CreateEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTI (SCSI Pass Through Interface) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_CreateExEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTD (SCSI Pass Through Direct) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode | This API accepts track names in Unicode format and does AUDIO only DAO burn.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_Eject | This function ejects the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ExecuteGeneric | This function executes custom CDB (Command Descriptor Block) on CD/DVD/Blu-Ray/HD-DVD burner device object. This could be used to deal with the propriatry hardware or execute some special code StarBurn does not support out-of-box.
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetBUP | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device supports BUP (Buffer Underrun Protection) or not and what is BUP current status (if supported). This information can be used later to set BUP status before starting write operations.
StarBurn_CdvdBurnerGrabber_GetDeviceInformation | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode | This is function StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode.
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem | This function detects recorded optical disc file system.
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace | This function gets disc free space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscInformation | This function gets disc information of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace | This function gets disc used space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem | This function gets DVD protection system of inserted DVD media into DVD device.
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask | This function gets DVD region mask from DVD media inserted to CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType | This function returns inserted to CD/DVD/Blu-Ray/HD-DVD burner device disc type. This data can be used to report it to the user and to select the stream type to record.
StarBurn_CdvdBurnerGrabber_GetLastAddress | This function gets last recorded address from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such an address could be used for already recorded session import with the UDF mastering.
StarBurn_CdvdBurnerGrabber_GetLastTrack | This function gets last recorded track from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such a track number could be used for already recorded session import.
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions | This function gets mechanical options (is device capable of programmatically load/eject and lock/unlock etc) from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus | This function gets media (inserted or not) and tray (opened or closed) statuses from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors | This function gets number of system descriptors in system structures stream. This value is used for updating head of the image when creating signle track session import code.
StarBurn_CdvdBurnerGrabber_GetRPC | This function gets RPC (region play code) and some additional DVD region management information from "DVD part" of the CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetSpeeds | This function gets current read and write and top supported read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device. This speeds later will be used to set current speeds during all read and write operations.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx | This function returns DVD+R(W) burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx | This function returns DVD+R(W) burner device object extended extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetTOCInformation | This function gets TOC information of the currently inserted disc in the CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformation | This function gets track information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx | This function gets track extended information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabCD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format.
StarBurn_CdvdBurnerGrabber_GrabDVD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files.
StarBurn_CdvdBurnerGrabber_GrabDVDEx | This function grabs disc image (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. StarBurn_CdvdBurnerGrabber_GrabDVDEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabDVDFast | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. Works faster than StarBurn_CdvdBurnerGrabber_GrabDVD
StarBurn_CdvdBurnerGrabber_GrabRange | This function grabs range of logical blocks from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrack | This function grabs track from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrackEx | This function grabs track (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device. StarBurn_CdvdBurnerGrabber_GrabTrackEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode | This is function StarBurn_CdvdBurnerGrabber_GrabTrackUnicode.
StarBurn_CdvdBurnerGrabber_IsDiscBlank | This function detect blank state of currently inserted disc in CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_Load | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_LoadEx | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device. Unlike StarBurn_CdvdBurnerGrabber_Load(...) this API call allows to control should it return immediately or wait until the drive would become into ready state.
StarBurn_CdvdBurnerGrabber_Lock | This function locks the media inside the CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_MSFToLBA | This function converts MSF (minute:second:frame) address into the LBA (logical block address).
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadATIP | This function reads ATIP information from the media currently inserted into CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_ReadCooked | This function reads one or more logical block(s) from the currently inserted CD/DVD/Blu-Ray/HD-DVD in cooked format.
StarBurn_CdvdBurnerGrabber_ReadLB | This function reads one logical block from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadRaw | This function reads one or more logical block(s) from the currently inserted CD in RAW format.
StarBurn_CdvdBurnerGrabber_Release | This function releases the media inside the CD/DVD/Blu-Ray/HD-DVD device after the media was locked before.
StarBurn_CdvdBurnerGrabber_SendOPC | This function sends OPC (Optimum Power Calibration) for current write speed on CD/DVD/Blu-Ray/HD-DVD burner device and current CD/DVD/Blu-Ray/HD-DVD media. The set laser level will be used later during all write operations.
StarBurn_CdvdBurnerGrabber_SessionAtOnce | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create or ISO image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW | This function records raw image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in raw Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode.
StarBurn_CdvdBurnerGrabber_SetBUP | This function sets BUP (Buffer Underrun Protection) on CD/DVD/Blu-Ray/HD-DVD burner device that supports BUP. BUP must be enabled for successful completion of write operations.
StarBurn_CdvdBurnerGrabber_SetCDTextItem | Sets CD-Text item for the specified CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_SetReadSpeed | This function sets read speed for CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_SetSpeeds | This function sets current read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device This speeds later will be used during all read and write operations.
StarBurn_CdvdBurnerGrabber_StopPlayScan | This function resets media state inside CD/DVD/Blu-Ray/HD-DVD burner device object. This actions allow to update disc content w/o need to eject the disc. Could be used for multiple burnings w/o disc eject or manual disc data verification.
StarBurn_CdvdBurnerGrabber_SuperVideoCD | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode.
StarBurn_CdvdBurnerGrabber_TestUnitReady | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations.
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. The only difference between this and simple StarBurn_CdvdBurnerGrabber_TestUnitReady() is that this code passed parameter to wait for unit to become ready. And "simple" code uses default timeout of 20 seconds.
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. This "double extended" variant of the call also can wait for particular amount of seconds and do "fast exit" if there's no disc in drive.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode | This API call deals with audio tracks with Unicode names only.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx | This API call deals with audio tracks with Unicode names only. Also it allows to set track-to-track pause length.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode. If audio content is recorded this API call can change default Track-At-Once track-to-track pause length from 150 logical blocks (2 seconds) to any passed one.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe | This function records ISO9660 or Joliet file system image located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx | This function records ISO9660 or Joliet file system image or audio stream located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup | This function parses the UDF file system on disc and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx | This function parses the UDF file system on disc and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_VerifyFile | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileEx | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode.
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileUnicode.
StarBurn_CdvdBurnerGrabber_VerifyTree | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyTreeEx | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VideoCD | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_VideoCDEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDUnicode.
StarBurn_CorrectISO9660Name_Default | This function generates next ISO9660 file name to make it unique.
StarBurn_CorrectJolietName_Default | This function generates next Joliet file name to make it unique.
StarBurn_CreatePipe | This function creates pipe for all of the StarBurn pipe operations and returns both "read" and "write" handles for it.
StarBurn_Destroy | This function frees allocated memory in the way of destroying the object that toolkit created internally. This is universal call, it frees all the objects and does not care about object type.
StarBurn_DestroyPipe | This function closes both "read" and "write" pipe handles.
StarBurn_DownShut | This function uninitialize burning toolkit. It's expected to be called after very last function call before exiting from StarBurn client application. It's a good idea to gather the trash before exiting. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used.
StarBurn_DVDVideo_Create | This function creates DVD-Video file system object from passed pointer to VIDEO_TS directory with DVD corresponding files.
StarBurn_DVDVideo_CreateUnicode | This is function StarBurn_DVDVideo_CreateUnicode.
StarBurn_DVDVideo_Destroy | This function destroys DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetSizeInUCHARs | This function gets file system content size in UCHARs from DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetTreePointer | This function returns pointer to ISO9660 file tree object embedded to DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_PatchHeader | This function patches IFO/BUF file header RBA for BUP.
StarBurn_DVDVideo_PatchTable | This function patches IFO/BUF file table RBAs.
StarBurn_DVDVideo_Read | This function reads requested number of UCHARs from DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) from it's current read position.
StarBurn_DVDVideo_SeekToBegin | This function moves DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) current read position to the very beginning.
StarBurn_ElTorito_BootCatalogAddSection | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_BootCatalogAddSectionUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_ElTorito_CreateBootCatalog | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_CreateBootCatalogUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_FileClose | This fucntion closes file handle embedded to file object.
StarBurn_FileCreate | This function creates new file from the passed file path and name.
StarBurn_FileInitialize | This function initializes file handle embedded to file object with bad file handle value.
StarBurn_FileOpen | This function opens existing file from the passed file path and name.
StarBurn_FileOpenEx | This function opens existing file from the passed file path and name.
StarBurn_FileRead | This function reads asked amount of unsigned chars from file at current seek position.
StarBurn_FileReWind | This function rewinds file position in unsigned chars to the very beginning for the file.
StarBurn_FileSeek | This function sets file position in unsigned chars to required one.
StarBurn_FileSeekRead | This function sets file position in unsigned chars to required one and reads requested amounts unsigned chars.
StarBurn_FileSizeInUCHARsGet | This function gets file size in unsigned chars.
StarBurn_FileUnicodeCreate | This function creates new file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpen | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpenEx | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileWrite | This function writes asked amount of unsigned chars to file at current seek position
StarBurn_FindDevice | This function finds device of the specified device type.
StarBurn_GetAudioFileStreamSizeInUCHARs | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast | This is function StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast.
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode | This is function StarBurn_GetAudioFileStreamSizeInUCHARsUnicode.
StarBurn_GetBufferUnderrunTimeOutInMs | This function returns buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_GetDeviceLetter | This function returns device letter (device root path) for a device name, like the one used in StarBurn_CdvdBurnerGrabber_CreateEx(...) API call.
StarBurn_GetDeviceLetterUnicode | This is function StarBurn_GetDeviceLetterUnicode.
StarBurn_GetDeviceNameByDeviceAddress | This function gets device name by device address.
StarBurn_GetDeviceTimeOutByDeviceAddress | This function gets device timeout in seconds by device SCSI address.
StarBurn_GetDVDPadding | This function returns is DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) enabled (TRUE) or disabled (FALSE).
StarBurn_GetDVDPLUSRDLCompatibleMode | This function returns is DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) enabled (TRUE) or disabled (FALSE).
StarBurn_GetEjectAfterFail | This function returns is so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) enabled (TRUE) or disabled (FALSE).
StarBurn_GetFastReadTOC | This function returns is so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn trys to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode enabled (TRUE) or disabled (FALSE).
StarBurn_GetId | This function gets ASPI layer ID strings.
StarBurn_GetIs64KBIO | This function returns is so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) currently enabled (TRUE) or disabled (FALSE).
StarBurn_GetIsCollisionDetectionDisabled | This function returns is collision detection disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_GetIsSafeGrabbingEnabled | This function returns is so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) enabled (TRUE) or disabled (FALSE).
StarBurn_GetVersion | This function returns a 32-bit unsigned long value that contains packed numbers that represent the year, the month and the date of the toolkit build. So 10th of March, year of 1978 will look like 0x19780310.
StarBurn_GetVolumeIDs | This function gets volume ID from ISO9660/Joliet volume name.
StarBurn_ImageFile_UDFFileSystemLookup | This function parses the UDF file system inside image file and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_ImageFile_UDFFileSystemLookupEx | This function parses the UDF file system inside image file and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_IsAudioFileSupported | This function returns is currently passed file supported as source audio file.
StarBurn_IsAudioFileSupportedUnicode | This is function StarBurn_IsAudioFileSupportedUnicode.
StarBurn_IsLocalDateTimeUsed | This is function StarBurn_IsLocalDateTimeUsed.
StarBurn_ISO2_Check1999Name | This function checks if given string valid ISO9660:1999 file (or directory) name
StarBurn_ISO2_CheckJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name
StarBurn_ISO2_CheckLevel1Name | This function checks if given string valid ISO9660 Level 1 file (or directory) name
StarBurn_ISO2_CheckLevel2Name | This function checks if given string valid ISO9660 Level 2 file (or directory) name
StarBurn_ISO2_CheckRelaxedJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name with less restrictions: names may contain more than one dot.
StarBurn_ISO2_CreateNewName | This function creates new ANSI name by adding ~XX (where XX is a number (Seed)) at the end of file name.
StarBurn_ISO2_DirectoryBrowse | This function browses ISO9660 directory content.
StarBurn_ISO2_DirectoryCreate | This function creates ISO9660 directory.
StarBurn_ISO2_DirectoryDestroy | This function destroys created ISO9660 directory object.
StarBurn_ISO2_DirectoryProcess | This function processes single ISO9660 directory.
StarBurn_ISO2_DirectoryQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_DirectoryRootCreate | This function creates root ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeCreate | This function creates UNICODE ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeProcess | This function processes single UNICODE ISO9660 directory.
StarBurn_ISO2_FileCreate | This function creates ISO9660 file.
StarBurn_ISO2_FileDestroy | This function destroys created ISO9660 file object.
StarBurn_ISO2_FileDirectoryDateTimeGet | This function gets date and time from created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryDateTimeSet | This function sets date and time on created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryNameSet | This function set new name for ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for ISO9660 file or directory object.
StarBurn_ISO2_FileMemoryCreate | This function creates ISO9660 memory file.
StarBurn_ISO2_FileMemoryUnicodeCreate | This function creates Unicode ISO9660 memory file.
StarBurn_ISO2_FileQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_FileSetAttributes | This function sets attributes for ISO9660 file.
StarBurn_ISO2_FileUnicodeCreate | This function creates UNICODE ISO9660 file.
StarBurn_ISO2_ImpVolumeCreate | This function processes contents of single UNICODE ISO9660 directory. __stdcall StarBurn_ISO2_DirectoryContentsUnicodeProcess( const unsigned short *UnicodePathName, unsigned long *GUID, void *Root, PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Callback, const void *Context, STARBURN_ISO2_FILE_DATE_TIME *DateTime ); This function creates ISO9660 import volume.
StarBurn_ISO2_ImpVolumeDestroy | This function destroys created ISO9660 import volume object.
StarBurn_ISO2_ImpVolumeImport | This function imports ISO9660 import volume content.
StarBurn_ISO2_ISO9660FileTreeCreate | This function create ISO image from already created ISO9660 volume.
StarBurn_ISO2_VolumeCreate | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateBoot | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateBootElTorito | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateEx | This function creates ISO9660 volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateExBoot | This function creates ISO9660 bootable volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateUnicode | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateUnicodeBoot | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeDescriptorsBufferGet | This function get ISO9660 volume descriptors buffer.
StarBurn_ISO2_VolumeDestroy | This function destroys created ISO9660 volume object.
StarBurn_ISO2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_ISO2_VolumeSizeInUCHARsGet | This function get ISO9660 volume size in unsigned chars.
StarBurn_ISO9660JolietFileTree_Add | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddEx | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddMemory | This function adds the node created from the memory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddW | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations. Unlike other tree management calls this one deals with Unicode names (wide char variant of basic call).
StarBurn_ISO9660JolietFileTree_AddZeroFile | This function adds the new "filled with zeros" file to already created ISO9660 or Joliet file tree. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_BuildImage | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_BuildImageEx | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media. It's identical to StarBurn_ISO9660JolietFileTree_BuildImage except has some extra parameter to put into file system descriptor.
StarBurn_ISO9660JolietFileTree_Cancel | This function cancel ISO9660 or Joliet file tree creation process.
StarBurn_ISO9660JolietFileTree_Create | This function allocates in the memory and initializes ISO9660 or Joliet file tree. Later this file tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be recorder directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate buffering operations on the hard disk.
StarBurn_ISO9660JolietFileTree_GetAttributes | This function returns ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_GetAutoSorting | This function returns ISO9660 or Joliet file tree node sorting mode.
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs | This function returns ISO9660 or Joliet file tree file size in UCHARs.
StarBurn_ISO9660JolietFileTree_GetFirstKid | This function returns ISO9660 or Joliet file tree node first kid pointer.
StarBurn_ISO9660JolietFileTree_GetFullPath | This function returns full path to ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetKidType | This function returns type of ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetLevel | This function returns ISO9660 or Joliet file tree level. The number of levels in the created tree.
StarBurn_ISO9660JolietFileTree_GetNames | This function returns ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_ISO9660JolietFileTree_GetNamesEx | This function returns ISO9660 or Joliet file tree node names (long, short and absolute). Also it returns file system dependent names in ANSI and Unicode.
StarBurn_ISO9660JolietFileTree_GetNamesW | StarBurn_ISO9660JolietFileTree_GetNamesW function is not documented
StarBurn_ISO9660JolietFileTree_GetNextKid | This function returns ISO9660 or Joliet file tree root node next kid pointer.
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime | This function returns ISO9660 or Joliet file tree node ISO9660 time stamp (date and time).
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs | This function returns ISO9660 or Joliet file tree node power (file size) in UCHARs.
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA | This function returns ISO9660 or Joliet file tree node starting LBA after the image was built.
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime | This function returns ISO9660 or Joliet file tree node SYSTEMTIME.
StarBurn_ISO9660JolietFileTree_GetParent | This function returns ISO9660 or Joliet file tree node parent pointer.
StarBurn_ISO9660JolietFileTree_GetRoot | This function returns ISO9660 or Joliet file tree root node pointer.
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs | This function returns ISO9660 or Joliet built file system image size in UCHARs.
StarBurn_ISO9660JolietFileTree_ImportFile | This function imports file for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_ImportTrack | This function imports track for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_Read | This function reads ISO9660 or Joliet file system image from current offset into the user's data buffer. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized. The data that is read can be either stored in the file on the hard disk or directly written to CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_Remove | This function deletes ISO9660 or Joliet file tree node and all it's kids.
StarBurn_ISO9660JolietFileTree_SeekToBegin | This function seeks the ISO9660 or Joliet file system image from current offset to the very beginning so read operation will start from the 0 offset of the file system image. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized.
StarBurn_ISO9660JolietFileTree_SetAttributes | This function sets ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_SetAutoSorting | This function sets ISO9660 or Joliet file tree node auto sorting mode.
StarBurn_ISO9660JolietFileTree_SetBootImage | This function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetBootImageEx | This extended function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetNames | This function sets ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_SetBufferUnderrunTimeOutInMs | This function sets buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_SetDeviceTimeOutByDeviceAddress | This function sets device timeout in seconds by device SCSI address.
StarBurn_SetDVDPadding | This function sets DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetDVDPLUSRDLCompatibleMode | This function sets DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetEjectAfterFail | This function sets so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetFastReadTOC | This function sets so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn try to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode to enabled (TRUE) or disabled (FALSE).
StarBurn_SetIs64KBIO | This function sets current so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) to enabled (TRUE) or disabled (FALSE) state.
StarBurn_SetIsCollisionDetectionDisabled | This function sets collision detection to disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_SetIsSafeGrabbingEnabled | This function sets so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetUsingLocalDateTime | This is function StarBurn_SetUsingLocalDateTime.
StarBurn_SetUsingUTCDateTime | This is function StarBurn_SetUsingUTCDateTime.
StarBurn_sprintf_s | This function wrap runtime sprintf_s function. In Visual Studio 2003 function sprintf_s not present.
StarBurn_SPTD_GetVersion | This function checks if the SPTD (SCSI Pass Through Direct) driver is present and gets SPTD driver version.
StarBurn_StarPort_DeviceAddLocal | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceAddLocalEx | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be added persistent.
StarBurn_StarPort_DeviceAddRemote | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be mount persistent.
StarBurn_StarPort_DeviceAddRemoteEx | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceListQueryLocal | This function gets device list from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Unlike StarBurn_StarPort_DeviceListQueryRemote API call which retrieves information about REMOTE device list this call gets information about LOCAL device list.
StarBurn_StarPort_DeviceListQueryRemote | This function gets device list from remote StarWind iSCSI target. StarWind exports RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) targets. Unlike StarBurn_StarPort_DeviceListQueryLocal API call which retreives information about LOCAL device list this call gets information about REMOTE device list.
StarBurn_StarPort_DeviceRemove | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceRemoveEx | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_GetDeviceInformation | This function retrieves device type, vendor ID, product ID and revision for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceLetter | This function retrieves device letter (symbolic link) for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceSCSIAddress | This function retrieves device SCSI address for StarPort device by its target ID.
StarBurn_StarPort_GetVersion | This function checks if the StarPortLite driver is installed and that its API version is equal to the one StarBurn was built with.
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek | This function seeks all of the internal object pointers to the very beginning of it so following read operations would start from the very beginning instead of the currently set position.
StarBurn_StarWave_CompressedFileReaderObjectCreate | This function creates compressed file reader object from passed compressed audio file name.
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode.
StarBurn_StarWave_CompressedFileReaderObjectDestroy | This function destroys compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectRead | This function reads uncompressed payload data chunk from underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate | This is function StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate.
StarBurn_StarWave_CompressedFileRecompress | This function recompresse already compressed file to new one with another compression.
StarBurn_StarWave_CompressedFileRecompressUnicode | This is function StarBurn_StarWave_CompressedFileRecompressUnicode.
StarBurn_StarWave_CompressedFileSupportedIs | This function checks is file name actually points to supported compressed audio file.
StarBurn_StarWave_CompressedFileUncompress | This function uncompresses compressed file to either WAV or RAW PCM.
StarBurn_StarWave_CompressedFileUncompressUnicode | This is function StarBurn_StarWave_CompressedFileUncompressUnicode.
StarBurn_StarWave_CompressedFileWriterObjectCreate | This function creates compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode.
StarBurn_StarWave_CompressedFileWriterObjectDestroy | This function destroys compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectWrite | This function writes uncompressed data chunk to compressed file writer object.
StarBurn_StarWave_UncompressedFileCompress | This function compresses uncompressed file to new one with asked compression.
StarBurn_StarWave_UncompressedFileCompressUnicode | This is function StarBurn_StarWave_UncompressedFileCompressUnicode.
StarBurn_StarWave_UncompressedFileSupportedIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_VersionGet | This function returns StarWave library version.
StarBurn_StarWave2_Convert | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertEx | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertExUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_EncodeMP3OGGFromWAV | This function compress audio file from WAV (44100Hz, 16, stereo) format to MP3 and OGG format.
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode | This is function StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode.
StarBurn_StarWave2_IsFileSupported | This function determines audio file by StarWave2 library supported is.
StarBurn_StarWave2_IsFileSupportedUnicode | This function determines audio file by StarWave2 library supported is.
StarBurn_strcpy_s | This function wrap runtime strcpy_s function. In Visual Studio 2003 function strcpy_s not present.
StarBurn_swprintf_s | This function wrap runtime swprintf_s function. In Visual Studio 2003 oriinal swprintf_s not present.
StarBurn_UDF_Add | Creates the UDF Tree Node
StarBurn_UDF_AddUnicode | This is function StarBurn_UDF_AddUnicode.
StarBurn_UDF_CleanUp | This function removes created UDF tree from the pointed UDF tree node sequentially. Processes file formatted UDF nodes and either closes file handles or frees memory (non-cached vs. cached content).
StarBurn_UDF_Create | StarBurn_UDF_Create() function is obsolete. Use StarBurn_UDF_CreatEx() instead of it
StarBurn_UDF_CreateEx | This function creates UDF tree from the allocated data buffers.
StarBurn_UDF_CreateExUnicode | This is function StarBurn_UDF_CreateExUnicode.
StarBurn_UDF_CreateUnicode | This is function StarBurn_UDF_CreateUnicode.
StarBurn_UDF_Destroy | This function devastates created UDF tree from the pointed root recursively.
StarBurn_UDF_DestroyNodeAndKids | Destroys UDF Tree Node and all its kids
StarBurn_UDF_FormatTreeItemAsDirectory | This function formats UDF tree item as directory.
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode | This is function StarBurn_UDF_FormatTreeItemAsDirectoryUnicode.
StarBurn_UDF_FormatTreeItemAsFile | This function formats UDF tree item as file.
StarBurn_UDF_FormatTreeItemAsFileUnicode | This is function StarBurn_UDF_FormatTreeItemAsFileUnicode.
StarBurn_UDF_GetFirstChild | This function returns the pointer to first child node
StarBurn_UDF_GetNextSibling | This function returns the pointer to next sibling node
StarBurn_UDF_GetNodeObject | Returns the object to current Tree Node
StarBurn_UDF_GetParent | This function returns the pointer to next parent node
StarBurn_UDF_GetPreviousSibling | This function returns the pointer to previous sibling node
StarBurn_UDF2_DirectoryBrowse | This function browses UDF directory content.
StarBurn_UDF2_DirectoryContentsProcess | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsProcessEx | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcess | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryCreate | This function creates UDF directory.
StarBurn_UDF2_DirectoryDestroy | This function destroys created UDF directory object.
StarBurn_UDF2_DirectoryProcess | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessExEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryQuery | This function does query for UDF directory properties.
StarBurn_UDF2_DirectoryRootCreate | This function creates root UDF directory.
StarBurn_UDF2_DirectoryUnicodeCreate | This function creates UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcess | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessExEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_FileBootCreate | This function creates UDF boot file.
StarBurn_UDF2_FileBootUnicodeCreate | This function creates UNICODE UDF boot file.
StarBurn_UDF2_FileCreate | This function creates UDF file.
StarBurn_UDF2_FileDestroy | This function destroys created UDF file object.
StarBurn_UDF2_FileDirectoryDateTimeGet | This function gets date and time from created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeGetEx | This function gets date and time from created UDF file or directory object. It may get creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryDateTimeSet | This function sets date and time on created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeSetEx | This function sets date and time on created UDF file or directory object. It may set creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryNameSet | This function set new name for UDF file or directory object.
StarBurn_UDF2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for UDF file or directory object.
StarBurn_UDF2_FileMemoryCreate | This function creates UDF memory file.
StarBurn_UDF2_FileMemoryUnicodeCreate | This function creates UNICODE UDF memory file.
StarBurn_UDF2_FileQuery | This function do query for UDF file properties.
StarBurn_UDF2_FileSetAttributes | This function sets attributes for UDF file.
StarBurn_UDF2_FileSystemGetSizes | This function calculates UDF file system sizes in Bytes and LBS on the fly ( without build volume ).
StarBurn_UDF2_FileUnicodeCreate | This function creates UNICODE UDF file.
StarBurn_UDF2_ImpVolumeCreate | This function creates UDF import volume.
StarBurn_UDF2_ImpVolumeDestroy | This function destroys created UDF import volume object.
StarBurn_UDF2_ImpVolumeImport | This function imports UDF import volume content.
StarBurn_UDF2_ISO9660FileTreeCreate | This function create ISO image from already created UDF volume.
StarBurn_UDF2_ISO9660FileTreeCreateEx | This function create ISO image from already created UDF volume.
StarBurn_UDF2_VolumeAnchorGet | This function gets first anchor volume descriptor pointer we'll have to replace on rewritable media.
StarBurn_UDF2_VolumeCreate | This function creates UDF 1.02 volume.
StarBurn_UDF2_VolumeCreateBoot | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateEx | This function creates UDF volume.
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeDestroy | This function destroys created UDF volume object.
StarBurn_UDF2_VolumeInitialSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_UDF2_VolumeSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSizeInUCHARsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeStore | This function stores UDF volume to file.
StarBurn_UDF2_VolumeUnicodeCreate | This function creates UDF 1.02 UNICODE volume.
StarBurn_UDF2_VolumeUnicodeCreateBoot | This function creates UDF Unicode Bootable volume.
StarBurn_UDF2_VolumeUnicodeCreateEx | This function creates UDF UNICODE volume.
StarBurn_UDFBridge_CreateEx | This is function StarBurn_UDFBridge_CreateEx.
StarBurn_UDFBridge_CreateExUnicode | This is function StarBurn_UDFBridge_CreateExUnicode.
StarBurn_UpStart | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. License file StarBurn.key is assumed to be located near main application executable. Since StarBurn SDK V12 it's possible to use this call again. It will just enable using embedded evaluational StarBurn SDK key (file shipped with StarBurn SDK... more
StarBurn_UpStartEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. The difference between this call and call to StarBurn_UpStart(...) is that this particular call assumes StarBurn key is being embedded to the application binary and StarBurn_UpStart(...) always looks for StarBurn.key near application executable. Use this API... more
StarBurn_UpStartExEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Unlike StarBurn_UpStartEx(...) API call this one allows to use custom debug output control. See StarBurn_UpStartEx(...) API call for more information about this topic.
Links
Functions, Legend
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_AuthorizeDVD Function

StarBurn_CdvdBurnerGrabber_AuthorizeDVD Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_AuthorizeDVD(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function authorizes DVD that has CSS protection system.

Remarks

Please see the GrabDisc sample to see how to grab DVD disc into MDS format and how StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem can be used to determine protection system of currently inserted DVD disc and how StarBurn_CdvdBurnerGrabber_AuthorizeDVD() can be used to authorize CSS protected DVD.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem

Example

This example allocates CdvdBurnerGrabber object, gets protection system, authorizes DVD disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to authorize the DVD disc (it's expected that DVD disc has CSS protection)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_AuthorizeDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx Function

StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__BusKeyForDiscKey
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__BusKeyForDiscKey | Pointer to bus key for disc key.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function authorizes DVD that has CSS protection system and keeps bus key for disc key.

Remarks

Please see the GrabDisc sample to see how to grab DVD disc into MDS format and how StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem can be used to determine protection system of currently inserted DVD disc and how StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx() can be used to authorize CSS protected DVD.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem

Example

This example allocates CdvdBurnerGrabber object, gets protection system, authorizes DVD disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;
UCHAR l__UCHAR__BusKeyForDiscKey[ 5 ] = { 0, 0, 0, 0, 0 };

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to authorize the DVD disc (it's expected that DVD disc has CSS protection) and keep bus key for disc key
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__BusKeyForDiscKey
    );

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Blank Function

StarBurn_CdvdBurnerGrabber_Blank Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Blank(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ERASE_TYPE p__ERASE_TYPE
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ERASE_TYPE p__ERASE_TYPE | Erase type (ERASE_TYPE_BLANK_DISC_FULL and ERASE_TYPE_BLANK_DISC_FAST supported for now).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function erases the rewritable media inserted into CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the Blank sample that will demonstrate how to erase the rewrittable disc.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, ERASE_TYPE

Example

This example allocates CdvdBurnerGrabber object, erases the media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to erase the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Blank(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ERASE_TYPE_BLANK_DISC_FAST
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_BluRayFormat Function

StarBurn_CdvdBurnerGrabber_BluRayFormat Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_BluRayFormat(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ULONG p__ULONG__FormatProfileNumber
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ULONG p__ULONG__FormatProfileNumber | Format profile number to use.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function formats Blu-Ray rewritable media (BD-RE) inserted into the Blu-Ray burner device.

Remarks

Please see the BluRayFormat sample that will demonstrate how to format rewrittable Blu-Ray disc (BD-RE).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_BluRayFormatQuery, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, formats the BD-RE media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__FormatProfileNumber = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check for the BD-RE media inserted

// Get possible format profiles and pick up format profile number

// Try to format the Blu-Ray rewrittable media (BD-RE)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_BluRayFormat(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__ULONG__FormatProfileNumber
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_BluRayFormatQuery Function

StarBurn_CdvdBurnerGrabber_BluRayFormatQuery Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_BluRayFormatQuery(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__FormatProfileBuffer,
    OUT PULONG p__PULONG__FormatProfileBufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__FormatProfileBuffer | Pointer to the profile format buffer.
p__PULONG__FormatProfileBufferSizeInUCHARS | Pointer to the format profile buffer size in UCHAR(s).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes). If the passed buffer size is too small StarBurn will set p__PULONG__FormatProfileBufferSizeInUCHARs to the required buffer size in UCHAR(s). After completion p__PULONG__FormatProfileBufferSizeInUCHARs will be set to the number of UCHAR(s) copied.

Description

This function queries available Blu-Ray formats for the currently inserted Blu-Ray rewritable media (BD-RE).

Remarks

Please see the BluRayFormat sample that will demonstrate how to format rewrittable Blu-Ray media (BD-RE) and query all available format profiles.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_BluRayFormat, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, queries available Blu-Ray formats and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__FormatProfileBuffer[ PAGE_SIZE_IN_UCHARS ];
ULONG l__ULONG__FormatProfileBufferSizeInUCHARs = sizeof( l__UCHAR__FormatProfileBuffer );

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check for the BD-RE media inserted

// Query available Blu-Ray formats
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__FormatProfileBuffer,
    &l__ULONG__FormatProfileBufferSizeInUCHARs
    );

// Try to format the Blu-Ray rewrittable media

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Cancel Function

StarBurn_CdvdBurnerGrabber_Cancel Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_Cancel(
    IN PVOID p__PVOID__CdvdBurnerGrabber
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
Returns

Nothing. This function cannot fail.

Description

This function cancels current read or write process on the CD/DVD/Blu-Ray/HD-DVD burner.

Remarks

There is no sample provided for this code so please check the code below.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_GrabTrack, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD

Example

This example allocates CdvdBurnerGrabber object, cancels current I/O process and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Initiate some I/O process here

// Cancel initiated I/O process
StarBurn_CdvdBurnerGrabber_Cancel();

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_CloseSession Function

StarBurn_CdvdBurnerGrabber_CloseSession Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_CloseSession(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function closes session on on CD/DVD/Blu-Ray/HD-DVD burner device after something was written using StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burnon the CD/DVD/Blu-Ray/HD-DVD media and with the help of the StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe and how session can be closed with the help of StarBurn_CdvdBurnerGrabber_CloseSession.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media, closes session and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\ISO9660.ISO",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to close session
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CloseSession(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Create Function

StarBurn_CdvdBurnerGrabber_Create Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Create(
    OUT PVOID * p__PPVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCALLBACK p__PCALLBACK,
    IN PVOID p__PVOID__Context,
    IN UCHAR p__UCHAR__PortID,
    IN UCHAR p__UCHAR__BusID,
    IN UCHAR p__UCHAR__TargetID,
    IN UCHAR p__UCHAR__LUN,
    IN LONG p__LONG__CacheSizeInMBs
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CdvdBurnerGrabber | Pointer to pointer to the object that toolkit will set to the CdvdBurnerGrabber object it will allocate.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCALLBACK p__PCALLBACK | Callback that will be called to indicate progress of various actions.
IN PVOID p__PVOID__Context | Context value that will be passed to callback function.
IN UCHAR p__UCHAR__PortID | SCSI port ID device is located at.
IN UCHAR p__UCHAR__BusID | SCSI bus ID device is located at.
IN UCHAR p__UCHAR__TargetID | SCSI bus target device is located at.
IN UCHAR p__UCHAR__LUN | SCSI LUN device is located at.
IN LONG p__LONG__CacheSizeInMBs | Cache size to use during I/O operations, 0 is a special value that tells the toolkit to allocate default cache size.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function creates CD/DVD/Blu-Ray/HD-DVD burner device object. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD releated actions.

Remarks

Please take a look at FindDevice sample to find out how StarBurn_CdvdBurnerGrabber_CreateEx could be used to create CD/DVD/Blu-Ray/HD-DVD burner object. Please note that StarBurn_CdvdBurnerGrabber_Create would create ASPI device thus would work not only under Windows NT/2000/XP/2000 but also under Windows 95/98/Me. ASPI is natively supported under Windows 95/98/Me and we provide own ASPI-to-SPTI wrapper for StarBurn). If you don't need Windows 95/98/Me support it's a good idea to use new extended variant of the call StarBurn_CdvdBurnerGrabber_CreateEx as it creates device handle using SPTI transport.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_CreateEx Function

StarBurn_CdvdBurnerGrabber_CreateEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_CreateEx(
    OUT PVOID * p__PPVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCALLBACK p__PCALLBACK,
    IN PVOID p__PVOID__Context,
    IN PCHAR p__PCHAR__DeviceName,
    IN LONG p__LONG__CacheSizeInMBs
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CdvdBurnerGrabber | Pointer to pointer to the object that toolkit will set to the CdvdBurnerGrabber object it will allocate.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCALLBACK p__PCALLBACK | Callback that will be called to indicate progress of various actions.
IN PVOID p__PVOID__Context | Context value that will be passed to callback function.
IN PCHAR p__PCHAR__DeviceName | Pointer to device symbolic link name we'll use. Make sure it DOES NOT include any slashes. So the name should be either "CdRom0" or say "F:" but NOT "\.CdRom0" or "\.F:".
IN LONG p__LONG__CacheSizeInMBs | Cache size to use during I/O operations, 0 is a special value that tells the toolkit to allocate default cache size.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTI (SCSI Pass Through Interface) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.

Remarks

Please take a look at FindDeviceEx sample to find out how StarBurn_CdvdBurnerGrabber_CreateEx could be used to create CD/DVD/Blu-Ray/HD-DVD burner object. Please note that StarBurn_CdvdBurnerGrabber_CreateEx would create SPTI device thus would work only under Windows NT/2000/XP/2003. If you need Windows 95/98/Me compatibility please use StarBurn_CdvdBurnerGrabber_Create legacy call as it's for ASPI transport (ASPI is natively supported under Windows 95/98/Me and we provide own ASPI-to-SPTI wrapper for StarBurn).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateExEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber using name "D:" with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CreateEx(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    "D:",
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_CreateExEx Function

StarBurn_CdvdBurnerGrabber_CreateExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_CreateExEx(
    OUT PVOID * p__PPVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCALLBACK p__PCALLBACK,
    IN PVOID p__PVOID__Context,
    IN PWCHAR p__PWCHAR__DeviceName,
    IN BOOLEAN p__BOOLEAN__IsExclusiveAccess,
    IN LONG p__LONG__CacheSizeInMBs
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CdvdBurnerGrabber | Pointer to pointer to the object that toolkit will set to the CdvdBurnerGrabber object it will allocate.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCALLBACK p__PCALLBACK | Callback that will be called to indicate progress of various actions.
IN PVOID p__PVOID__Context | Context value that will be passed to callback function.
IN PWCHAR p__PWCHAR__DeviceName | Pointer to device symbolic link name we'll use.
IN BOOLEAN p__BOOLEAN__IsExclusiveAccess | Is device open with exclusive access
IN LONG p__LONG__CacheSizeInMBs | Cache size to use during I/O operations, 0 is a special value that tells the toolkit to allocate default cache size.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTD (SCSI Pass Through Direct) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.

Remarks

Please take a look at FindDeviceExEx sample to find out how StarBurn_CdvdBurnerGrabber_CreateExEx could be used to create CD/DVD/Blu-Ray/HD-DVD burner object. Please note that StarBurn_CdvdBurnerGrabber_CreateExEx would create SPTD device thus would work only under Windows NT/2000/XP/2003. If you need Windows 95/98/Me compatibility please use StarBurn_CdvdBurnerGrabber_Create legacy call as it's for ASPI transport (ASPI is natively supported under Windows 95/98/Me and we provide own ASPI-to-SPTI wrapper for StarBurn). ATTENTION! SPTD applications must be digitally signed. That's why only dynamic linking with the StarBurn.DLL is possible if SPTD must be used (unless you'll directly license SPTD layer from Duplex Secure and will get signer for your EXE from them).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber using name "CdRom0" with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CreateExEx(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    L"CdRom0",
    TRUE,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile Function

StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT | Pointer to preinitialized DAO disc layout.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE if next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired | BOOLEAN set to TRUE if you want library to repair broken sub-channel in the image and FALSE otherwise (if you want to burn all the data AS IS -- maybe required to keep working "special" software titles).
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.

Remarks

Please see the DiscAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image (also it can be one sound file or full set of sound files if an audio CD is mastered) can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare DAO disc layout
RtlZeroMemory(
    &l__DAO_DISC_LAYOUT,
    sizeof( l__DAO_DISC_LAYOUT )
    );

// Set file name
strcpy(
    l__DAO_DISC_LAYOUT.m__DAO_DISC_LAYOUT_ENTRY.m__CHAR__TrackName,
    "C:\ISO9660.ISO"
    );

// Set number of tracks
l__DAO_DISC_LAYOUT.m__LONG__NumberOfTracks = 1;

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once PQ mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    FALSE, // No sub-channel repair
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode Function

StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree Function

StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__ISO9660FileTree,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE if next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree object.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.

Remarks

Please see the DiscAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image located in a file tree object can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile

Example

This example allocates CdvdBurnerGrabber object, creates ISO9660 or Joliet file system image located in a file tree object and burns it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and initialize ISO9660 or Joliet file tree object here pointed by l__PVOID__ISO9660JolietFileTree

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once PQ mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__ISO9660JolietFileTree,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile Function

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT | Pointer to preinitialized DAO disc layout.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media. p__BOOLEAN__IsSubChannelRepairRequired -- BOOLEAN set to TRUE if you want library to repair broken sub-channel in the image and FALSE otherwise (if you want to burn all the data AS IS -- maybe required to keep working "special" software titles).
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.

Remarks

Please see the DiscAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image (also it can be one sound file or full set of sound files if an audio CD is mastered) can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare DAO disc layout
RtlZeroMemory(
    &l__DAO_DISC_LAYOUT,
    sizeof( l__DAO_DISC_LAYOUT )
    );

// Set file name
strcpy(
    l__DAO_DISC_LAYOUT.m__DAO_DISC_LAYOUT_ENTRY.m__CHAR__TrackName,
    "C:\ISO9660.ISO"
    );

// Set number of tracks
l__DAO_DISC_LAYOUT.m__LONG__NumberOfTracks = 1;

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    FALSE, // No sub-channel repair
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode Function

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to CStarBurn_CdvdBurnerGrabber object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB failure information.
IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT | Pointer to DAO disc layout.
IN BOOLEAN p__BOOLEAN__IsXA | Is this CDROM XA or just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | Is this test write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | Is next session allowed.
IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired | Is subchannel repair required.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Exception number

Description

This API accepts track names in Unicode format and does AUDIO only DAO burn.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode Function

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDAO_DISC_LAYOUT p__PDAO_DISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN BOOLEAN p__BOOLEAN__IsSubChannelRepairRequired,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree Function

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__ISO9660FileTree,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE if next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree object.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.

Remarks

Please see the DiscAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image located in a file tree object can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile

Example

This example allocates CdvdBurnerGrabber object, creates ISO9660 or Joliet file system image located in a file tree object and burns it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and initialize ISO9660 or Joliet file tree object here pointed by l__PVOID__ISO9660JolietFileTree

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__ISO9660JolietFileTree,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Eject Function

StarBurn_CdvdBurnerGrabber_Eject Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Eject(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function ejects the media on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_Eject can be used to eject the CD/DVD/Blu-Ray/HD-DVD media to initiate file system unmount/mount sequence (to refresh contents of just burn CD/DVD/Blu-Ray/HD-DVD media).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, ejects the media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Eject(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ExecuteGeneric Function

StarBurn_CdvdBurnerGrabber_ExecuteGeneric Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ExecuteGeneric(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PUCHAR p__PUCHAR__CDB,
    IN ULONG p__ULONG__CDBSizeInUCHARs,
    IN OUT PUCHAR p__PUCHAR__DataBuffer,
    IN ULONG p__ULONG__DataBufferSizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsDirectionToScsiTarget
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PUCHAR p__PUCHAR__CDB | Pointer to CDB we want to execute.
IN ULONG p__ULONG__CDBSizeInUCHARs | CDB size in UCHARs.
IN OUT PUCHAR p__PUCHAR__DataBuffer | Pointer to I/O data buffer.
IN ULONG p__ULONG__DataBufferSizeInUCHARs | I/O data buffer size in UCHARs.
IN BOOLEAN p__BOOLEAN__IsDirectionToScsiTarget | Is data moved from memory-to-target (TRUE) or from target-to-memory (FALSE).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function executes custom CDB (Command Descriptor Block) on CD/DVD/Blu-Ray/HD-DVD burner device object. This could be used to deal with the propriatry hardware or execute some special code StarBurn does not support out-of-box.

Remarks

Please see ExecuteGeneric sample on how to send custom SCSI commands to CD/DVD/Blu-Ray/HD-DVD burner device.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_ImportTrack

Example

This example allocates CdvdBurnerGrabber object, sends custom command and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__CDB[ 12 ];
UCHAR l__UCHAR__Data[ 0x2000 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format CDB and data buffer here...

// Try to send custom CDB to CD/DVD/Blu-Ray/HD-DVD burner device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ExecuteGeneric(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__CDB,
    sizeof( l__UCHAR__CDB ),
    &l__UCHAR__Data,
    sizeof( l__UCHAR__Data ),
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats Function

StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS p__PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create() or StarBurn_CdvdBurnerGrabber_CreateEx() API calls.
IN PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS p__PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Pointer to pre-allocated and pre-initialized structure containing set of capabilities flags.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what use can be taken from CdvdBurnerGrabber device extended information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx

Example

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Prepare advanced supported media formats
RtlZeroMemory(
    &l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS,
    sizeof( l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS )
    );

// Set structure size in UCHARs
l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS.m__ULONG__SizeInUCHARs = sizeof( l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS );

// Get CdvdBurnerGrabber device extended information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats(
    l__PVOID__CdvdBurnerGrabber,
    &l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetBUP Function

StarBurn_CdvdBurnerGrabber_GetBUP Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetBUP(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsBUPEnabled,
    OUT PBOOLEAN p__PBOOLEAN__IsBUPSupported
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PBOOLEAN p__PBOOLEAN__IsBUPEnabled | Pointer to the BOOLEAN variable that will be set to TRUE if BUP is currently enabled on the CD/DVD/Blu-Ray/HD-DVD device, set to FALSE if BUP is disabled.
OUT PBOOLEAN p__PBOOLEAN__IsBUPSupported | Pointer to the BOOLEAN variable that will be set to TRUE if BUP is generally supported by the CD/DVD/Blu-Ray/HD-DVD device, set to FALSE if BUP is not supported.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function tests is CD/DVD/Blu-Ray/HD-DVD burner device supports BUP (Buffer Underrun Protection) or not and what is BUP current status (if supported). This information can be used later to set BUP status before starting write operations.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what StarBurn_CdvdBurnerGrabber_GetBUP can be used for.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets BUP status and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsBUPEnabled;
BOOLEAN l__BOOLEAN__IsBUPSupported;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsBUPEnabled,
    &l__BOOLEAN__IsBUPSupported
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDeviceInformation Function

StarBurn_CdvdBurnerGrabber_GetDeviceInformation Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_GetDeviceInformation(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__VendorID,
    OUT PCHAR p__PCHAR__ProductID,
    OUT PCHAR p__PCHAR__ProductRevisionLevel,
    OUT PULONG p__PULONG__BufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
OUT PCHAR p__PCHAR__VendorID | Pointer to array of CHARs that will be used to store vendor ID string.
OUT PCHAR p__PCHAR__ProductID | Pointer to array of CHARs that will be used to store product ID string.
OUT PCHAR p__PCHAR__ProductRevisionLevel | Pointer to array of CHARs that will be used to store product revision level string.
OUT PULONG p__PULONG__BufferSizeInUCHARs | Pointer to ULONG that will contain the device internal cache buffer size in UCHARs.
Returns

None. This function cannot fail.

Description

This function returns CD/DVD/Blu-Ray/HD-DVD burner device object information. This data can be used to report the capabilities of the device to the user.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what use can be taken from CdvdBurnerGrabber device information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, retrieves device information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
CHAR l__CHAR__VendorID[ 1024 ];
CHAR l__CHAR__ProductID[ 1024 ];
CHAR l__CHAR__ProductRevisionLevel[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare vendor ID and product ID and product revision level buffers

RtlZeroMemory(
    &l__CHAR__VendorID,
    sizeof( l__CHAR__VendorID )
    );

RtlZeroMemory(
    &l__CHAR__ProductID,
    sizeof( l__CHAR__ProductID )
    );

RtlZeroMemory(
    &l__CHAR__ProductRevisionLevel,
    sizeof( l__CHAR__ProductRevisionLevel )
    );

// Get CdvdBurnerGrabber device information
StarBurn_CdvdBurnerGrabber_GetDeviceInformation(
    l__PVOID__CdvdBurnerGrabber,
    ( PCHAR )( &l__CHAR__VendorID ),
    ( PCHAR )( &l__CHAR__ProductID ),
    ( PCHAR )( &l__CHAR__ProductRevisionLevel ),
    &l__ULONG__CacheBufferSizeInUCHARs
    );

// Do something with CdvdBurnerGrabber device object and it's information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode Function

StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PWCHAR p__PCHAR__VendorID,
    OUT PWCHAR p__PCHAR__ProductID,
    OUT PWCHAR p__PCHAR__ProductRevisionLevel,
    OUT PULONG p__PULONG__BufferSizeInUCHARs
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDiscFileSystem Function

StarBurn_CdvdBurnerGrabber_GetDiscFileSystem Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDiscFileSystem(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PDISC_FILESYSTEM p__PDISC_FILESYSTEM
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PDISC_FILESYSTEM p__PDISC_FILESYSTEM | Pointer to structure to receive disc file system flags.
Returns

Execution status.

Description

This function detects recorded optical disc file system.

Example

Please see GUI DataBurner sample as example how to use StarBurn_GetDiscFileSystem API call.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace Function

StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN STARBURN_CD_MODE p__CD_MODE,
    OUT PLONG p__PLONG__FreeSpaceInLBs,
    OUT PLARGE_INTEGER p__PLARGE_INTEGER__FreeSpaceInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
IN STARBURN_CD_MODE p__CD_MODE | CD mode. Ignored if currently inserted disc type is DVD.
OUT PLONG p__PLONG__FreeSpaceInLBs | Pointer to the LONG will be filled with number of free logical blocks on the disc.
p__PLARGE_INTEGER__FreeSpaceInUCHARS | Pointer to the LARGE_INTEGER will be filled with free space in UCHARs on the disc.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets disc free space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

If currently inserted disc type is DVD then parameter p__CD_MODE is ignored.For DVD disc type default LB size is 2048 UCHARs. If p__CD_MODE set to CD_MODE_UNKNOWN or CD_MODE_RESERVED function return p__PLARGE_INTEGER__FreeSpaceInUCHARS is zero.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets free disc space and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
CD_MODE l__CD_MODE(CD_MODE_DATA);
LONG l__LONG__FreeSpaceInLBs(0);
LARGE_INTEGER l__LARGE_INTEGER__FreeSpaceInUCHARs;

l__LARGE_INTEGER__FreeSpaceInUCHARs.QuadPart = 0;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current disc free space
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace(
l__PVOID__CdvdBurnerGrabber,
l__CD_MODE,
&l__LONG__FreeSpaceInLBs,
&l__LARGE_INTEGER__FreeSpaceInUCHARs
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDiscInformation Function

StarBurn_CdvdBurnerGrabber_GetDiscInformation Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDiscInformation(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PSTARBURN_DISC_INFORMATION p__PSTARBURN_DISC_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PSTARBURN_DISC_INFORMATION p__PSTARBURN_DISC_INFORMATION | Pointer to the disc information.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets disc information of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetDiscInformation can be used to get current disc information on the CD/DVD/Blu-Ray/HD-DVD media to check parameters of the disc for validness (is disc blank, last session status etc).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetTrackInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets disc information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_DISC_INFORMATION l__STARBURN_DISC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare disc information buffer
RtlZeroMemory(
    &l__STARBURN_DISC_INFORMATION,
    sizeof( l__STARBURN_DISC_INFORMATION )
    );

// Try to get current disc information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PSTARBURN_DISC_INFORMATION )( &l__STARBURN_DISC_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace Function

StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PLARGE_INTEGER p__PLARGE_INTEGER__UsedSpace
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PLARGE_INTEGER p__PLARGE_INTEGER__UsedSpace | Pointer to the used space of disc.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets disc used space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets used disc space and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LARGE_INTEGER l__LARGE_INTEGER__UsedSpace;

l__LARGE_INTEGER__UsedSpace.QuadPart = 0;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current disc used space
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
&l__LARGE_INTEGER__UsedSpace
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem Function

StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__DVDProtectionSystem
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__DVDProtectionSystem | Pointer to UCHAR that will keep DVD protection system in case of success.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets DVD protection system of inserted DVD media into DVD device.

Remarks

Please see the GrabDisc sample to see how to grab DVD disc into MDS format and how StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem can be used to determine protection system of currently inserted DVD disc.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem

Example

This example allocates CdvdBurnerGrabber object, gets protection system and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDVDRegionMask Function

StarBurn_CdvdBurnerGrabber_GetDVDRegionMask Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetDVDRegionMask(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__DVDRegionMask
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__DVDRegionMask | Pointer to the variable to receive DVD region mask.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets DVD region mask from DVD media inserted to CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.

Remarks

Please see the GrabDisc sample that will demonstrate how DVD region mask could be get from DVD media with the help of the StarBurn_CdvdBurnerGrabber_GetDVDRegionMask API call.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_GetRPC, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets DVD region and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDRegionMask;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get DVD region mask from DVD media inserted to device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDRegionMask
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetInsertedDiscType Function

StarBurn_CdvdBurnerGrabber_GetInsertedDiscType Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API DISC_TYPE StarBurn_CdvdBurnerGrabber_GetInsertedDiscType(
    IN PVOID p__PVOID__CdvdBurnerGrabber
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create(...) or StarBurn_CdvdBurnerGrabber_CreateEx(...) API calls.
Returns

Inserted disc type. This function cannot fail.

Description

This function returns inserted to CD/DVD/Blu-Ray/HD-DVD burner device disc type. This data can be used to report it to the user and to select the stream type to record.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what use can be taken from inserted disc type information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, retrieves inserted disc type and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DISC_TYPE l__DISC_TYPE = DISC_TYPE_UNKNOWN;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get inserted disc type
l__DISC_TYPE = StarBurn_CdvdBurnerGrabber_GetInsertedDiscType( l__PVOID__CdvdBurnerGrabber );

// Do something with CdvdBurnerGrabber device object and it's inserted disc type here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetLastAddress Function

StarBurn_CdvdBurnerGrabber_GetLastAddress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetLastAddress(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PULONG p__PULONG__LBA
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PULONG p__PULONG__LBA | Pointer to the variable to receive last recorded address.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets last recorded address from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such an address could be used for already recorded session import with the UDF mastering.

Remarks

Please see UDF2ImportBurn sample that will demonstrate how UDF file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetLastAddress can be used to get last recorded address.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_GetLastTrack

Example

This example allocates CdvdBurnerGrabber object, gets last recorded address and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__LastRecordedLBA = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get last recorded address
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetLastAddress(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__ULONG__LastRecordedLBA
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetLastTrack Function

StarBurn_CdvdBurnerGrabber_GetLastTrack Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetLastTrack(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__LastTrack
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__LastTrack | Pointer to the variable to receive last track number.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets last recorded track from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such a track number could be used for already recorded session import.

Remarks

Please see TrackAtOnceFromTreeWithImport sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetLastTrack can be used to get last recorded track number.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_ImportTrack

Example

This example allocates CdvdBurnerGrabber object, gets last recorded track number and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__LastRecordedTrackNumber;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get last recorded track number
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetLastTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__LastRecordedTrackNumber
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetMechanicalOptions Function

StarBurn_CdvdBurnerGrabber_GetMechanicalOptions Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetMechanicalOptions(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsLockUnLockSupported,
    OUT PBOOLEAN p__PBOOLEAN__IsLocked,
    OUT PBOOLEAN p__PBOOLEAN__IsLoadEjectSupported,
    OUT PUCHAR p__PUCHAR__LoadingMechanismType
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PBOOLEAN p__PBOOLEAN__IsLockUnLockSupported | Pointer to the variable to receive is device capable of programmatically lock/unlock.
OUT PBOOLEAN p__PBOOLEAN__IsLocked | Pointer to the variable to receive is media inside device locked right now.
OUT PBOOLEAN p__PBOOLEAN__IsLoadEjectSupported | Pointer to the variable to receive is device capable of programmatically load/eject.
OUT PUCHAR p__PUCHAR__LoadingMechanismType | Pointer to the variable to receive device loading mechanism type.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets mechanical options (is device capable of programmatically load/eject and lock/unlock etc) from CD/DVD/Blu-Ray/HD-DVD burner device object.

Remarks

Please see the TrackAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be burn to the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetMechanicalOptions() can be used to determine device media control capabilities.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx, StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus

Example

This example allocates CdvdBurnerGrabber object, gets mechanical options and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsLockUnLockSupported = FALSE;
BOOLEAN l__BOOLEAN__IsLocked = FALSE;
BOOLEAN l__BOOLEAN__IsLoadEjectSupported = FALSE;
UCHAR l__UCHAR__LoadingMechanismType = 0x00;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get media and tray statuses
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsLockUnLockSupported,
    &l__BOOLEAN__IsLocked,
    &l__BOOLEAN__IsLoadEjectSupported,
    &l__UCHAR__LoadingMechanismType
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus Function

StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsMediaPresent,
    OUT PBOOLEAN p__PBOOLEAN__IsDoorOrTrayOpen
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PBOOLEAN p__PBOOLEAN__IsMediaPresent | Is media inserted (TRUE) or not (FALSE).
OUT PBOOLEAN p__PBOOLEAN__IsDoorOrTrayOpen | Is tray or door opened (TRUE) or closed (FALSE).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets media (inserted or not) and tray (opened or closed) statuses from CD/DVD/Blu-Ray/HD-DVD burner device object.

Remarks

Please see the TrackAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be burn to the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus can be used to determine media and tray status.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx

Example

This example allocates CdvdBurnerGrabber object, gets media and tray statuses and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsMediaPresent;
BOOLEAN l__BOOLEAN__IsDoorOrTrayOpen;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get media and tray statuses
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsMediaPresent,
    &l__BOOLEAN__IsDoorOrTrayOpen
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors Function

StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN PUCHAR p__PUCHAR__SystemStructures,
    IN LONG p__LONG__SystemStructuresSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
IN PUCHAR p__PUCHAR__SystemStructures | Pointer to system structures pre-read into memory buffer.
IN LONG p__LONG__SystemStructuresSizeInLBs | System structures size in logical blocks.
Returns

Number of system descriptors. This code cannot fail.

Description

This function gets number of system descriptors in system structures stream. This value is used for updating head of the image when creating signle track session import code.

Remarks

Please see BuildImageWithImportFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be imported from hard disk ISO disk image and how StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors(...) can be used to get number of system descriptors when updating system image head.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create

Example

This example allocates CdvdBurnerGrabber object, gets number of system descriptors and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
LONG l__LONG__NumberOfSystemDescriptors = 0;
PUCHAR l__PUCHAR__SystemStructures = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Allocate enough memory for system structures in l__PUCHAR__SystemStructures here...

// Read system structures from the optical disc to l__PUCHAR__SystemStructures buffer here...

// Try to get number of system descriptors
l__LONG__NumberOfSystemDescriptors =
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors(
    l__PVOID__CdvdBurnerGrabber,
    l__PUCHAR__SystemStructures,
    SYSTEM_STRUCTURES_SIZE_IN_LOGICAL_BLOCKS
    );

// Do something with l__LONG__NumberOfSystemDescriptors here...

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetRPC Function

StarBurn_CdvdBurnerGrabber_GetRPC Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetRPC(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__TypeCode,
    OUT PUCHAR p__PUCHAR__NumberOfVendorResetsAvailable,
    OUT PUCHAR p__PUCHAR__NumberOfUserControlledChangesAvailable,
    OUT PUCHAR p__PUCHAR__RegionMask,
    OUT PUCHAR p__PUCHAR__RPCScheme
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__TypeCode | Pointer to the variable to receive type code.
OUT PUCHAR p__PUCHAR__NumberOfVendorResetsAvailable | Pointer to the variable to receive number of vendor-controlled region code resets.
OUT PUCHAR p__PUCHAR__NumberOfUserControlledChangesAvailable | Pointer to the variable to receive number of user-controlled region code changes.
OUT PUCHAR p__PUCHAR__RegionMask | Pointer to the variable to receive "hardware" region code mask.
OUT PUCHAR p__PUCHAR__RPCScheme | Pointer to the variable to receive RPC management scheme.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets RPC (region play code) and some additional DVD region management information from "DVD part" of the CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.

Remarks

Please see GrabDisc sample that will demonstrate how DVD region management information could be get from DVD device with the help of the StarBurn_CdvdBurnerGrabber_GetRPC API call.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDRegionMask

Example

This example allocates CdvdBurnerGrabber object, gets DVD region management information from CD/DVD/Blu-Ray/HD-DVD device object and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__TypeCode;
UCHAR l__UCHAR__NumberOfVendorResetsAvailable;
UCHAR l__UCHAR__NumberOfUserControlledChangesAvailable;
UCHAR l__UCHAR__RegionMask;
UCHAR l__UCHAR__RPCScheme;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get DVD region management information from DVD device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetRPC(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__TypeCode,
    &l__UCHAR__NumberOfVendorResetsAvailable,
    &l__UCHAR__NumberOfUserControlledChangesAvailable,
    &l__UCHAR__RegionMask,
    &l__UCHAR__RPCScheme
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetSpeeds Function

StarBurn_CdvdBurnerGrabber_GetSpeeds Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetSpeeds(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PULONG p__PULONG__CurrentReadSpeed,
    OUT PULONG p__PULONG__MaximumReadSpeed,
    OUT PULONG p__PULONG__CurrentWriteSpeed,
    OUT PULONG p__PULONG__MaximumWriteSpeed
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PULONG p__PULONG__CurrentReadSpeed | Pointer to ULONG that will receive current read speed.
OUT PULONG p__PULONG__MaximumReadSpeed | Pointer to ULONG that will receive maximum read speed.
OUT PULONG p__PULONG__CurrentWriteSpeed | Pointer to ULONG that will receive current write speed.
OUT PULONG p__PULONG__MaximumWriteSpeed | Pointer to ULONG that will receive maximum write speed.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets current read and write and top supported read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device. This speeds later will be used to set current speeds during all read and write operations.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how StarBurn_CdvdBurnerGrabber_GetSpeeds can be used to determine current and top supported CD/DVD/Blu-Ray/HD-DVD device read and write speeds and how StarBurn_CdvdBurnerGrabber_SetSpeeds can be used to set top supported speeds.

[ WARNING! It's required to have media inserted for this function to work properly! ]

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets all (current and top supported) read and write speeds and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__CurrentReadSpeed;
ULONG l__ULONG__MaximumReadSpeed;
ULONG l__ULONG__CurrentWriteSpeed;
ULONG l__ULONG__MaximumWriteSpeed;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current and top supported CD/DVD/Blu-Ray/HD-DVD read/write speeds on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetSpeeds(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__ULONG__CurrentReadSpeed,
    &l__ULONG__MaximumReadSpeed,
    &l__ULONG__CurrentWriteSpeed,
    &l__ULONG__MaximumWriteSpeed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and it's speeds here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats Function

StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PBOOLEAN p__PBOOLEAN__IsCDRRead,
    OUT PBOOLEAN p__PBOOLEAN__IsCDERead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDROMRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDRRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDRAMRead,
    OUT PBOOLEAN p__PBOOLEAN__IsTestWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsCDRWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsCDEWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDRWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDRAMWrite
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
OUT PBOOLEAN p__PBOOLEAN__IsCDRRead | Pointer to the boolean variable that will receive is device capable of reading CD-R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsCDERead | Pointer to the boolean variable that will receive is device capable of reading CD-RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDROMRead | Pointer to the boolean variable that will receive is device capable of reading DVD-ROM discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDRRead | Pointer to the boolean variable that will receive is device capable of reading DVD-R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDRAMRead | Pointer to the boolean variable that will receive is device capable of reading DVD-RAM discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsTestWrite | Pointer to the boolean variable that will receive is device capable of test recording or not.
OUT PBOOLEAN p__PBOOLEAN__IsCDRWrite | Pointer to the boolean variable that will receive is device capable of writing CD-R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsCDEWrite | Pointer to the boolean variable that will receive is device capable of writing CD-RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDRWrite | Pointer to the boolean variable that will receive is device capable of writing DVD-R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDRAMWrite | Pointer to the boolean variable that will receive is device capable of writing DVD-RAM discs or not.
Returns

None. This function cannot fail.

Description

This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what use can be taken from CdvdBurnerGrabber device extended information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx

Example

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsCDRRead;
BOOLEAN l__BOOLEAN__IsCDERead;
BOOLEAN l__BOOLEAN__IsDVDROMRead;
BOOLEAN l__BOOLEAN__IsDVDRRead;
BOOLEAN l__BOOLEAN__IsDVDRAMRead;
BOOLEAN l__BOOLEAN__IsTestWrite;
BOOLEAN l__BOOLEAN__IsCDRWrite;
BOOLEAN l__BOOLEAN__IsCDEWrite;
BOOLEAN l__BOOLEAN__IsDVDRWrite;
BOOLEAN l__BOOLEAN__IsDVDRAMWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsCDRRead,
    &l__BOOLEAN__IsCDERead,
    &l__BOOLEAN__IsDVDROMRead,
    &l__BOOLEAN__IsDVDRRead,
    &l__BOOLEAN__IsDVDRAMRead,
    &l__BOOLEAN__IsTestWrite,
    &l__BOOLEAN__IsCDRWrite,
    &l__BOOLEAN__IsCDEWrite,
    &l__BOOLEAN__IsDVDRWrite,
    &l__BOOLEAN__IsDVDRAMWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx Function

StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWrite
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWRead | Pointer to the boolean variable that will receive is device capable of reading DVD+RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRRead | Pointer to the boolean variable that will receive is device capable of reading DVD+R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWWrite | Pointer to the boolean variable that will receive is device capable of writing DVD+RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWrite | Pointer to the boolean variable that will receive is device capable of writing DVD+R discs or not.
Returns

None. This function cannot fail.

Description

This function returns DVD+R(W) burner device object extended information. This data can be used to report the capabilities of the device to the user.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the DVD+R(W) media and what use can be taken from CdvdBurnerGrabber device extended information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats

Example

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsDVDPLUSRWRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsDVDPLUSRWRead,
    &l__BOOLEAN__IsDVDPLUSRRead,
    &l__BOOLEAN__IsDVDPLUSRWWrite,
    &l__BOOLEAN__IsDVDPLUSRWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx Function

StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRDLRead,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWrite,
    OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRDLWrite
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWRead | Pointer to the boolean variable that will receive is device capable of reading DVD+RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRRead | Pointer to the boolean variable that will receive is device capable of reading DVD+R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRDLRead | Pointer to the boolean variable that will receive is device capable of reading DVD+R DL discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWWrite | Pointer to the boolean variable that will receive is device capable of writing DVD+RW discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRWrite | Pointer to the boolean variable that will receive is device capable of writing DVD+R discs or not.
OUT PBOOLEAN p__PBOOLEAN__IsDVDPLUSRDLWrite | Pointer to the boolean variable that will receive is device capable of writing DVD+R DL discs or not.
Returns

None. This function cannot fail.

Description

This function returns DVD+R(W) burner device object extended extended information. This data can be used to report the capabilities of the device to the user.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the DVD+R(W) media and what use can be taken from CdvdBurnerGrabber device extended information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats

Example

This example allocates CdvdBurnerGrabber object, retrieves device extended extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsDVDPLUSRWRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRDLRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRDLWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsDVDPLUSRWRead,
    &l__BOOLEAN__IsDVDPLUSRRead,
    &l__BOOLEAN__IsDVDPLUSRDLRead,
    &l__BOOLEAN__IsDVDPLUSRWWrite,
    &l__BOOLEAN__IsDVDPLUSRWrite,
    &l__BOOLEAN__IsDVDPLUSRDLWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetTOCInformation Function

StarBurn_CdvdBurnerGrabber_GetTOCInformation Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetTOCInformation(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PTOC_INFORMATION p__PTOC_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PTOC_INFORMATION p__PTOC_INFORMATION | Pointer to the TOC information.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets TOC information of the currently inserted disc in the CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the GrabTrack sample that will demonstrate how ISO9660 or Joliet file system image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetTOCInformation can be used to get current TOC information on the CD/DVD/Blu-Ray/HD-DVD media to determine session information.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY

Example

This example allocates CdvdBurnerGrabber object, gets TOC information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Try to get current TOC information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTOCInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PTOC_INFORMATION )( &l__TOC_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetTrackInformation Function

StarBurn_CdvdBurnerGrabber_GetTrackInformation Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetTrackInformation(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN LONG p__LONG__TrackNumber,
    OUT PSTARBURN_TRACK_INFORMATION p__PSTARBURN_TRACK_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN LONG p__LONG__TrackNumber | Track number to get information about.
OUT PSTARBURN_TRACK_INFORMATION p__PSTARBURN_TRACK_INFORMATION | Pointer to the track information.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets track information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetTrackInformation can be used to get "invisible" track information on the CD/DVD/Blu-Ray/HD-DVD media to check parameters of the track for validness (is track blank, number of free logical blocks etc).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_DISC_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets "invisible" track information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_TRACK_INFORMATION l__STARBURN_TRACK_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare track information buffer
RtlZeroMemory(
    &l__STARBURN_TRACK_INFORMATION,
    sizeof( l__STARBURN_TRACK_INFORMATION )
    );

// Try to get "invisible" track information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTrackInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRACK_NUMBER_INVISIBLE,
    ( PSTARBURN_TRACK_INFORMATION )( &l__STARBURN_TRACK_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and track information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetTrackInformationEx Function

StarBurn_CdvdBurnerGrabber_GetTrackInformationEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GetTrackInformationEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN LONG p__LONG__TrackNumber,
    OUT PSTARBURN_TRACK_INFORMATION_EX p__PSTARBURN_TRACK_INFORMATION_EX
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN LONG p__LONG__TrackNumber | Track number to get information about.
OUT PSTARBURN_TRACK_INFORMATION_EX p__PSTARBURN_TRACK_INFORMATION_EX | Pointer to the track extended information.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function gets track extended information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GetTrackInformation can be used to get "invisible" track information on the CD/DVD/Blu-Ray/HD-DVD media to check parameters of the track for validness (is track blank, number of free logical blocks etc).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_TRACK_INFORMATION_EX, STARBURN_TRACK_INFORMATION, STARBURN_DISC_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets "invisible" track information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_TRACK_INFORMATION_EX l__STARBURN_TRACK_INFORMATION_EX;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare track information buffer
RtlZeroMemory(
&l__STARBURN_TRACK_INFORMATION_EX,
sizeof( l__STARBURN_TRACK_INFORMATION_EX )
);

// Try to get "invisible" track information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
TRACK_NUMBER_INVISIBLE,
( PSTARBURN_TRACK_INFORMATION_EX )( &l__STARBURN_TRACK_INFORMATION_EX )
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and track information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabCD Function

StarBurn_CdvdBurnerGrabber_GrabCD Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabCD(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__FileName,
    IN READ_MODE p__READ_MODE,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsDisableHardwareErrorCorrection
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__FileName | Pointer to file name disc will be stored to (basic name, other one will be generated from it).
IN READ_MODE p__READ_MODE | Read mode (raw, raw + PQ sub-channel or raw + raw P-W sub-channel).
IN LONG p__LONG__Retries | Number of retries on bad block hit.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format.

Remarks

Please see the GrabDisc sample that will demonstrate how whole disc image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabCD can be used to grab disc from the CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack

Example

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, also use fast software error correction
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    READ_MODE_RAW,
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS,
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabDVD Function

StarBurn_CdvdBurnerGrabber_GrabDVD Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabDVD(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__SplitFileSizeInMBs,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__FileName | Pointer to file name disc will be stored to (basic name, other one will be generated from it).
IN LONG p__LONG__SplitFileSizeInMBs | Split file size in megabytes.
IN LONG p__LONG__Retries | Number of retries on bad block hit.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files.

Remarks

Please see the GrabDisc sample that will demonstrate how whole disc image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabDVD can be used to grab disc from the CD/DVD/Blu-Ray/HD-DVD media. For now only DVD media can be grabbed with this [Split] variant of grabbing code.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack

Example

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    1024, // 1GB
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabDVDEx Function

StarBurn_CdvdBurnerGrabber_GrabDVDEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabDVDEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK,
    IN PSTARBURN_SET_FILE_POINTER_CALLBACK p__PSTARBURN_SET_FILE_POINTER_CALLBACK,
    IN PSTARBURN_READFILE_CALLBACK p__PSTARBURN_READFILE_CALLBACK,
    IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK,
    IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK,
    IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK,
    IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__SplitFileSizeInMBs,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK | Callback for "create file"
IN PSTARBURN_SET_FILE_POINTER_CALLBACK p__PSTARBURN_SET_FILE_POINTER_CALLBACK | Callback for "set file pointer"
IN PSTARBURN_READFILE_CALLBACK p__PSTARBURN_READFILE_CALLBACK | Callback for "read file"
IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK | Callback for "write file"
IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | Callback for "flush file buffer"
IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK | Callback for "close handle"
IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK | Callback for "delete file"
IN PCHAR p__PCHAR__FileName | Pointer to file name disc will be stored to (basic name, other one will be generated from it).
IN LONG p__LONG__SplitFileSizeInMBs | Split file size in megabytes.
IN LONG p__LONG__Retries | Number of retries on bad block hit.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs disc image (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. StarBurn_CdvdBurnerGrabber_GrabDVDEx function for all I/O files operations use user's callback functions.

Remarks

Please see the GrabDiscEx sample that will demonstrate how whole disc image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabDVDEx can be used to grab disc from the CD/DVD/Blu-Ray/HD-DVD media. For now only DVD media can be grabbed with this [Split] variant of grabbing code.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrackEx

Example

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
&l__TOC_INFORMATION,
sizeof( l__TOC_INFORMATION )
);

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
(PSTARBURN_CREATEFILE_CALLBACK)CallbackCreateFile,
(PSTARBURN_SET_FILE_POINTER_CALLBACK)CallbackSetFilePointer,
(PSTARBURN_READFILE_CALLBACK)CallbackReadFile,
(PSTARBURN_WRITEFILE_CALLBACK)CallbackWriteFile,
(PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK )CallbackFlushFileBuffers,
(PSTARBURN_CLOSEHANDLE_CALLBACK)CallbackCloseHandle,
(PSTARBURN_DELETEFILE_CALLBACK)CallbackDeleteFile,
"disc01",
1024, // 1GB
NUMBER_OF_READ_RETRIES,
TRUE,
FALSE,
READ_REPORT_DELAY_IN_SECONDS
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabDVDFast Function

StarBurn_CdvdBurnerGrabber_GrabDVDFast Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabDVDFast(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK,
    IN PSTARBURN_SET_FILE_POINTER_CALLBACK p__PSTARBURN_SET_FILE_POINTER_CALLBACK,
    IN PSTARBURN_READFILE_CALLBACK p__PSTARBURN_READFILE_CALLBACK,
    IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK,
    IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK,
    IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK,
    IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__SplitFileSizeInMBs,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK | Callback for "create file"
IN PSTARBURN_SET_FILE_POINTER_CALLBACK p__PSTARBURN_SET_FILE_POINTER_CALLBACK | Callback for "set file pointer"
IN PSTARBURN_READFILE_CALLBACK p__PSTARBURN_READFILE_CALLBACK | Callback for "read file"
IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK | Callback for "write file"
IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | Callback for "flush file buffer"
IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK | Callback for "close handle"
IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK | Callback for "delete file"
IN PCHAR p__PCHAR__FileName | Pointer to file name disc will be stored to (basic name, other one will be generated from it).
IN LONG p__LONG__SplitFileSizeInMBs | Split file size in megabytes.
IN LONG p__LONG__Retries | Number of retries on bad block hit.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. Works faster than StarBurn_CdvdBurnerGrabber_GrabDVD

Remarks

Please see the GrabDisc sample that will demonstrate how whole disc image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabDVD can be used to grab disc from the CD/DVD/Blu-Ray/HD-DVD media. For now only DVD media can be grabbed with this [Split] variant of grabbing code.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack

Example

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    1024, // 1GB
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabRange Function

StarBurn_CdvdBurnerGrabber_GrabRange Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabRange(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN LONG p__LONG__StartingLBA,
    IN LONG p__LONG__EndingLBA,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN LONG p__LONG__StartingLBA | Beginning of the LBA range to grab.
IN LONG p__LONG__EndingLBA | Ending of the LBA range to grab.
IN PCHAR p__PCHAR__FileName | Pointer to file name track will be stored to.
IN LONG p__LONG__Retries | Number of retries.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs range of logical blocks from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the GrabTrack sample that will demonstrate how ISO9660 or Joliet file system image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabTrack can be used to grab track actually from the CD/DVD/Blu-Ray/HD-DVD media. To grab not whole track but just range of logical blocks TOC must be get first by call to StarBurn_CdvdBurnerGrabber_GetTOCInformation and after this StarBurn_CdvdBurnerGrabber_GrabRange can be used to grab range of logical blocks. Attention! Care should be taken b/s the range is inclusive. So grabbing the range 10 - 100 will take 91 logical blocks from 10 and up to 100.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD

Example

This example allocates CdvdBurnerGrabber object, grabs range of logical blocks track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the range of 1001 logical blocks (range is both sides inclusive) (from TOC we know that this range 0 = 1000 is
// valid) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabRange(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0,
    1000,
    "track01range",
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabTrack Function

StarBurn_CdvdBurnerGrabber_GrabTrack Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabTrack(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN UCHAR p__UCHAR__TrackNumber,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN UCHAR p__UCHAR__TrackNumber | Track number to grab.
IN PCHAR p__PCHAR__FileName | Pointer to file name track will be stored to.
IN LONG p__LONG__Retries | Number of retries.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs track from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the GrabTrack sample that will demonstrate how ISO9660 or Joliet file system image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabTrack can be used to grab track actually from the CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD

Example

This example allocates CdvdBurnerGrabber object, grabs first track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the track (from TOC we know that this is audio track) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    1,
    "track01.mp3",
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabTrackEx Function

StarBurn_CdvdBurnerGrabber_GrabTrackEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabTrackEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK,
    IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK,
    IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK,
    IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK,
    IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK,
    IN UCHAR p__UCHAR__TrackNumber,
    IN PCHAR p__PCHAR__FileName,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PSTARBURN_CREATEFILE_CALLBACK p__PSTARBURN_CREATEFILE_CALLBACK | Callback for "create file"
IN PSTARBURN_WRITEFILE_CALLBACK p__PSTARBURN_WRITEFILE_CALLBACK | Callback for "write file"
IN PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK p__PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | Callback for "flush file buffer"
IN PSTARBURN_CLOSEHANDLE_CALLBACK p__PSTARBURN_CLOSEHANDLE_CALLBACK | Callback for "close handle"
IN PSTARBURN_DELETEFILE_CALLBACK p__PSTARBURN_DELETEFILE_CALLBACK | Callback for "delete file"
IN UCHAR p__UCHAR__TrackNumber | Track number to grab.
IN PCHAR p__PCHAR__FileName | Pointer to file name track will be stored to.
IN LONG p__LONG__Retries | Number of retries.
IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore | Is bad block ignore.
IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced | Is single LB transfer forced.
IN ULONG p__ULONG__ReadReportDelayInSeconds | Read report delay in seconds.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function grabs track (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device. StarBurn_CdvdBurnerGrabber_GrabTrackEx function for all I/O files operations use user's callback functions.

Remarks

Please see the GrabTrackEx sample that will demonstrate how ISO9660 or Joliet file system image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_GrabTrackEx can be used to grab track actually from the CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabDVDEx, StarBurn_CdvdBurnerGrabber_GrabDVDFast

Example

This example allocates CdvdBurnerGrabber object, grabs first track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
&l__TOC_INFORMATION,
sizeof( l__TOC_INFORMATION )
);

// Get TOC information here and analyze it...

// Try to grab the track (from TOC we know that this is audio track) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabTrackEx(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
(PSTARBURN_CREATEFILE_CALLBACK)CallbackCreateFile,
(PSTARBURN_WRITEFILE_CALLBACK)CallbackWriteFile,
(PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK )CallbackFlushFileBuffers,
(PSTARBURN_CLOSEHANDLE_CALLBACK)CallbackCloseHandle,
(PSTARBURN_DELETEFILE_CALLBACK)CallbackDeleteFile,
1,
"track01.mp3",
NUMBER_OF_READ_RETRIES,
TRUE,
FALSE,
READ_REPORT_DELAY_IN_SECONDS
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabTrackUnicode Function

StarBurn_CdvdBurnerGrabber_GrabTrackUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_GrabTrackUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN UCHAR p__UCHAR__TrackNumber,
    IN PWCHAR p__PWCHAR__FileName,
    IN LONG p__LONG__Retries,
    IN BOOLEAN p__BOOLEAN__IsBadBlockIgnore,
    IN BOOLEAN p__BOOLEAN__IsSingleLBTransferForced,
    IN ULONG p__ULONG__ReadReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_GrabTrackUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_IsDiscBlank Function

StarBurn_CdvdBurnerGrabber_IsDiscBlank Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_IsDiscBlank(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsBlank
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PBOOLEAN p__PBOOLEAN__IsBlank | Pointer to the BOOLEAN will be set to TRUE if the disc is blank and FALSE otherwise.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function detect blank state of currently inserted disc in CD/DVD/Blu-Ray/HD-DVD burner device.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, detect is disc blank and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsDiscBlank(FALSE);

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to detect is disc blank
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_IsDiscBlank(
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
&l__BOOLEAN__IsDiscBlank
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Load Function

StarBurn_CdvdBurnerGrabber_Load Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Load(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the DiscOnceFromTree sample demonstrating how ISO9660 or Joliet file system image can be burnt on the CD media and how StarBurn_CdvdBurnerGrabber_Load can be used to load the CD media to initiate file system mount sequence.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_LoadEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, ejects the media, loads it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media here...

// Try to load the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Load(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_LoadEx Function

StarBurn_CdvdBurnerGrabber_LoadEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_LoadEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN BOOLEAN p__BOOLEAN__IsWaitRequired
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN BOOLEAN p__BOOLEAN__IsWaitRequired | Should the library wait for CD/DVD/Blu-Ray/HD-DVD drive to become into ready state.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device. Unlike StarBurn_CdvdBurnerGrabber_Load(...) this API call allows to control should it return immediately or wait until the drive would become into ready state.

Remarks

Please see the DiscAtOnceFromTree sample demonstrating how ISO9660 or Joliet file system image can be burnt to the CD media and how StarBurn_CdvdBurnerGrabber_Load can be used to load the CD media to initiate file system mount sequence.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_Load, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, ejects the media, loads it (waiting for the drive to become into ready state) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media here...

// Try to load the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_LoadEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRUE // We want to return only after drive would become into ready state
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Lock Function

StarBurn_CdvdBurnerGrabber_Lock Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Lock(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function locks the media inside the CD/DVD/Blu-Ray/HD-DVD device.

Remarks

Please see the TrackAtOnceFromFile and TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media. StarBurn_CdvdBurnerGrabber_Lock can be used to lock the CD/DVD/Blu-Ray/HD-DVD media to prevent media removal from the device while burning (or any I/O process) is in progress.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_Release

Example

This example allocates CdvdBurnerGrabber object, locks it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to lock the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Lock(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_MSFToLBA Function

StarBurn_CdvdBurnerGrabber_MSFToLBA Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_CdvdBurnerGrabber_MSFToLBA(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN UCHAR p__UCHAR__M,
    IN UCHAR p__UCHAR__S,
    IN UCHAR p__UCHAR__F,
    IN BOOLEAN p__BOOLEAN__IsForcePositive
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to CD/DVD/Blu-Ray/HD-DVD burner/grabber object.
IN UCHAR p__UCHAR__M | Minute of MSF address.
IN UCHAR p__UCHAR__S | Second of MSF address.
IN UCHAR p__UCHAR__F | Frame of MSF address.
IN BOOLEAN p__BOOLEAN__IsForcePositive | TRUE if resulting LBA should be forced to be positive or FALSE if it could be negative.
Returns

LBA (logical block address).

Description

This function converts MSF (minute:second:frame) address into the LBA (logical block address).

Remarks

No remarks.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx

Example

Please see DiscAtOnceFromFile sample to see how to use StarBurn_MSFToLBA API call should be used.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes Function

StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsCooked,
    OUT PBOOLEAN p__PBOOLEAN__IsRaw,
    OUT PBOOLEAN p__PBOOLEAN__IsRawQ,
    OUT PBOOLEAN p__PBOOLEAN__IsRawRawPW,
    OUT PBOOLEAN p__PBOOLEAN__IsPQ,
    OUT PBOOLEAN p__PBOOLEAN__IsRawPW
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
p__BOOLEAN__IsCooked | Is cooked mode supported.
p__BOOLEAN__IsRaw | Is raw mode supported.
p__BOOLEAN__IsRawPQ | Is raw + PQ sub-channel mode supported.
p__BOOLEAN__IsRawRawPW | Is raw + raw P-W sub-channel mode supported.
p__BOOLEAN__IsPQ | Is PQ sub-channel mode supported.
p__BOOLEAN__IsRawPW | Is raw P-W sub-channel mode supported.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the GrabDisc sample that will demonstrate how whole disc image can be grabbed from the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes can be used to determine supported read modes.

[ WARNING! It's required to have media inserted for this function to work properly! ]

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD

Example

This example allocates CdvdBurnerGrabber object, probes supported read modes and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsCooked = FALSE;
BOOLEAN l__BOOLEAN__IsRaw = FALSE;
BOOLEAN l__BOOLEAN__IsRawPQ = FALSE;
BOOLEAN l__BOOLEAN__IsRawRawPW = FALSE;
BOOLEAN l__BOOLEAN__IsPQ = FALSE;
BOOLEAN l__BOOLEAN__IsRawPW = FALSE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to probe supported read modes
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsCooked,
    &l__BOOLEAN__IsRaw,
    &l__BOOLEAN__IsRawPQ,
    &l__BOOLEAN__IsRawRawPW,
    &l__BOOLEAN__IsPQ,
    &l__BOOLEAN__IsRawPW
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and supported read modes information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes Function

StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PBOOLEAN p__PBOOLEAN__IsTrackAtOnce,
    OUT PBOOLEAN p__PBOOLEAN__IsSessionAtOnce,
    OUT PBOOLEAN p__PBOOLEAN__IsDiscAtOncePQ,
    OUT PBOOLEAN p__PBOOLEAN__IsDiscAtOnceRawPW
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
p__BOOLEAN__IsTrackAtOnce | Is Track-At-Once supported.
p__BOOLEAN__IsSessionAtOnce | Is Session-At-Once supported.
p__BOOLEAN__IsDiscAtOncePQ | Is Disc-At-Once PQ supported.
p__BOOLEAN__IsDiscAtOnceRawPW | Is Disc-At-Once raw PW supported.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the burning samples that will demonstrate how disc can be recorded and how StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes can be used to determine supported write modes.

[ WARNING! It's required to have media inserted for this function to work properly! ]

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe

Example

This example allocates CdvdBurnerGrabber object, probes supported write modes and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsTrackAtOnce = FALSE;
BOOLEAN l__BOOLEAN__IsSessionAtOnce = FALSE;
BOOLEAN l__BOOLEAN__IsDiscAtOncePQ = FALSE;
BOOLEAN l__BOOLEAN__IsDiscAtOnceRawPW = FALSE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to probe supported write modes
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsTrackAtOnce,
    &l__BOOLEAN__IsSessionAtOnce,
    &l__BOOLEAN__IsDiscAtOncePQ,
    &l__BOOLEAN__IsDiscAtOnceRawPW
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and supported write modes information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ReadATIP Function

StarBurn_CdvdBurnerGrabber_ReadATIP Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ReadATIP(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__ATIP,
    IN ULONG p__ULONG__ATIPSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__ATIP | Pointer to the buffer to receive ATIP information.
IN ULONG p__ULONG__ATIPSizeInUCHARs | ATIP information buffer size in UCHARs.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function reads ATIP information from the media currently inserted into CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.

Remarks

Please see the DiscAtOnceFromTree sample that will demonstrate how ATIP information could be read from the media with the help of the StarBurn_CdvdBurnerGrabber_ReadATIP API call.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, reads ATIP information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__ATIP[ 4096 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get ATIP information from device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadATIP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__ATIP,
    sizeof( l__UCHAR__ATIP )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ReadCooked Function

StarBurn_CdvdBurnerGrabber_ReadCooked Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ReadCooked(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    OUT PUCHAR p__PUCHAR__Read,
    IN ULONG p__ULONG__ReadSizeInUCHARs,
    IN LONG p__LONG__LBA,
    IN ULONG p__ULONG__TransferSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
OUT PUCHAR p__PUCHAR__Read | Pointer to data buffer to receive read data to.
IN ULONG p__ULONG__ReadSizeInUCHARs | Read size in unsigned char(s).
IN LONG p__LONG__LBA | Starting LBA to read from.
IN ULONG p__ULONG__TransferSizeInLBs | Whole transfer size in logical block(s).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function reads one or more logical block(s) from the currently inserted CD/DVD/Blu-Ray/HD-DVD in cooked format.

Remarks

Make sure your data buffer is page-aligned, transfer size is less then 64KB and all of the input parameters are valid.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange, StarBurn_CdvdBurnerGrabber_ReadLB, StarBurn_CdvdBurnerGrabber_ReadRaw

Example

This example allocates CdvdBurnerGrabber object, reads 2 (two) cooked logical blocks and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;
UCHAR l__UCHAR__Buffer[ 8192 ]; // We do allocate buffer on the stack but it's not correct. Page-aligned memory must be used.

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Prepare the buffer
RtlZeroMemory(
    &l__UCHAR__Buffer,
    sizeof( l__UCHAR__Buffer )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it

// Get currently inserted disc and analyze it

// Try to grab two cooked logical blocks starting from LBA 100 (from TOC we know that address 100 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadCooked(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PUCHAR )( &l__UCHAR__Buffer ),    // Pointer to data buffer to receive the payload
    sizeof( l__UCHAR__Buffer ),         // Data buffer size in unsigned char(s)
    100,                                // Start from logical block number 100
    2                                   // 2 logical blocks
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and read sectors here

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ReadLB Function

StarBurn_CdvdBurnerGrabber_ReadLB Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ReadLB(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN LONG p__LONG__LBA,
    IN PUCHAR p__PUCHAR__Buffer,
    IN LONG p__ULONG__BufferSize
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN LONG p__LONG__LBA | LBA of logical block to read.
IN PUCHAR p__PUCHAR__Buffer | Pointer to output buffer.
IN LONG p__ULONG__BufferSize | Output buffer size.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function reads one logical block from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange

Example

This example allocates CdvdBurnerGrabber object, reads one logical block and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Allocate buffer
UCHAR l__UCHAR__Buffer[4096];

// Try to grab one logical block with address 1000 (from TOC we know that this address 1000 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadLB(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    1000,
    l__UCHAR__Buffer,
    4096
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_ReadRaw Function

StarBurn_CdvdBurnerGrabber_ReadRaw Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_ReadRaw(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN UCHAR p__UCHAR__ExpectedLBType,
    IN LONG p__LONG__LBA,
    IN ULONG p__ULONG__DataBufferSizeInLBs,
    IN UCHAR p__UCHAR__ErrorField,
    IN BOOLEAN p__BOOLEAN__IsEDC_ECC,
    IN BOOLEAN p__BOOLEAN__IsUserData,
    IN UCHAR p__UCHAR__HeaderCodes,
    IN BOOLEAN p__BOOLEAN__IsSYNC,
    IN UCHAR p__UCHAR__SubChannelSelectionBits,
    OUT PUCHAR p__PUCHAR__DataBuffer,
    IN ULONG p__ULONG__DataBufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN UCHAR p__UCHAR__ExpectedLBType | Expected logical block type. See EXPECTED_LB_TYPE_XXX constants.
IN LONG p__LONG__LBA | Starting logical block number to read from.
IN ULONG p__ULONG__DataBufferSizeInLBs | Data buffer/request size in logical block(s).
IN UCHAR p__UCHAR__ErrorField | Error format. See ERROR_FIELD_XXX constants.
IN BOOLEAN p__BOOLEAN__IsEDC_ECC | TRUE if you want EDC/ECC data included in the output stream, FALSE if you don't want EDC/ECC.
IN BOOLEAN p__BOOLEAN__IsUserData | TRUE if you want user data (main payload) included in the output stream, FALSE if you don't want user data.
IN UCHAR p__UCHAR__HeaderCodes | Header format. See HEADER_CODE_XXX constants.
IN BOOLEAN p__BOOLEAN__IsSYNC | TRUE if you want SYNC pattern included in the output stream, FALSE if you don't want SYNC pattern.
IN UCHAR p__UCHAR__SubChannelSelectionBits | Sub-channel selection. See SUBCHANNEL_XXX constants.
OUT PUCHAR p__PUCHAR__DataBuffer | Pointer to data buffer to receive the payload.
IN ULONG p__ULONG__DataBufferSizeInUCHARs | Data buffer size in unsigned char(s).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function reads one or more logical block(s) from the currently inserted CD in RAW format.

Remarks

Make sure your data buffer is page-aligned, transfer size is less then 64KB and all of the input parameters are valid.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange, StarBurn_CdvdBurnerGrabber_ReadLB, StarBurn_CdvdBurnerGrabber_ReadCooked

Example

This example allocates CdvdBurnerGrabber object, reads 2 (two) RAW logical blocks and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;
UCHAR l__UCHAR__Buffer[ 8192 ]; // We do allocate buffer on the stack but it's not correct. Page-aligned memory must be used.

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Prepare the buffer
RtlZeroMemory(
    &l__UCHAR__Buffer,
    sizeof( l__UCHAR__Buffer )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it

// Get currently inserted disc and analyze it. We can do RAW read from CD media only

// Probe supported read modes as we need to read in the ones drive really supports

// Try to grab two RAW logical blocks starting from LBA 100 (from TOC we know that address 100 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadRaw(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    EXPECTED_LB_TYPE_ANY,               // Accept any logical blocks
    100,                                // Start from logical block number 100
    2,                                  // 2 logical blocks only
    ERROR_FIELD_NO_ERROR,               // No error data included
    TRUE,                               // YES, we need EDC/ECC data
    TRUE,                               // YES, we need user data
    HEADER_CODE_ALL_HEADERS,            // We need ALL of the headers
    TRUE,                               // YES, we need SYNC pattern
    SUBCHANNEL_RAW_PW,                  // Read RAW P-W sub-channel from the disc
    ( PUCHAR )( &l__UCHAR__Buffer ),    // Pointer to data buffer to receive the payload
    sizeof( l__UCHAR__Buffer )          // Data buffer size in unsigned char(s)
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and read sectors here

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_Release Function

StarBurn_CdvdBurnerGrabber_Release Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_Release(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function releases the media inside the CD/DVD/Blu-Ray/HD-DVD device after the media was locked before.

Remarks

Please see the TrackAtOnceFromFile and TrackAtOnceFromTree sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media. StarBurn_CdvdBurnerGrabber_Lock can be used to lock the CD/DVD/Blu-Ray/HD-DVD media to prevent media removal from the device while burning (or any I/O process) is in progress. StarBurn_CdvdBurnerGrabber_Release can be used to release (unlock) the media that was locked before.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_Lock

Example

This example allocates CdvdBurnerGrabber object, locks it, releases (unlocks) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to lock media here...

// Try to release (unlock) the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Release(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SendOPC Function

StarBurn_CdvdBurnerGrabber_SendOPC Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SendOPC(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function sends OPC (Optimum Power Calibration) for current write speed on CD/DVD/Blu-Ray/HD-DVD burner device and current CD/DVD/Blu-Ray/HD-DVD media. The set laser level will be used later during all write operations.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_SendOPC can be used to set optimum laser level on CD/DVD/Blu-Ray/HD-DVD device for current write speed and CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, sends optimum power calibration for current write speed and current CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to send optimum power calibration
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SendOPC(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnce Function

StarBurn_CdvdBurnerGrabber_SessionAtOnce Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SessionAtOnce(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDISC_LAYOUT p__PDISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PDISC_LAYOUT p__PDISC_LAYOUT | Pointer to disc layout filled with file tree specific data.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is a just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create or ISO image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Session-At-Once mode.

Remarks

Please see the SessionAtOnceFromTree sample that will demonstrate how "virtual" ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_SessionAtOnce. SessionAtOnceFromFile sample shows how to burn ISO image.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image from file tree to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
DISC_LAYOUT l__DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to create ISO9660 or Joliet file system image with help of StarBurn_ISO9660JolietFileTree_Create and
// StarBurn_ISO9660JolietFileTree_BuildImage, l__PVOID__FileTree used as the pointer to the object...

// Fill DISC_LAYOUT structure here

RtlZeroMemory(
    &l__DISC_LAYOUT,
    sizeof( l__DISC_LAYOUT )
    );

l__DISC_LAYOUT.m__LONG__NumberOfEntries = 1;

l__DISC_LAYOUT.m__DISC_LAYOUT_ENTRY[ 0 ].m__PVOID__ISO9660JolietFileTree = l__PVOID__FileTree;

// Try to record the ISO9660 or Joliet file system image in Session-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SessionAtOnce(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DISC_LAYOUT,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW Function

StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__MDS,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsRawSaoSubManualLeadIn,
    IN BOOLEAN p__BOOLEAN__IsAmplifyWeak
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__MDS | Pointer to MDS file name.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN BOOLEAN p__BOOLEAN__IsRawSaoSubManualLeadIn | Should we write lead-in manually (TRUE) or should we rely on the drive doing this (FALSE).
IN BOOLEAN p__BOOLEAN__IsAmplifyWeak | Should we amplify weak patterns (TRUE) or just forward all the data to the drive "AS IS" (FALSE).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records raw image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in raw Session-At-Once mode.

Remarks

Please see the SessionAtOnceRawRawPW sample that will demonstrate how burn raw image to CD media in RAW SAO + SUB (raw Session-At-Once) mode.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW

Example

This example allocates CdvdBurnerGrabber object, records raw image to the CD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the raw image in RAW SUB Session-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "Image.MDS",
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    TRUE,   // Write lead-in manually
    TRUE    // Amplify weak
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode Function

StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__MDS,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsRawSaoSubManualLeadIn,
    IN BOOLEAN p__BOOLEAN__IsAmplifyWeak
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode Function

StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PDISC_LAYOUT p__PDISC_LAYOUT,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SetBUP Function

StarBurn_CdvdBurnerGrabber_SetBUP Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SetBUP(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN BOOLEAN p__BOOLEAN__IsBUPEnabled
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN BOOLEAN p__BOOLEAN__IsBUPEnabled | BOOLEAN variable that keeps TRUE if BUP is must be enabled on the CD/DVD/Blu-Ray/HD-DVD device, FALSE if BUP must be disabled.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function sets BUP (Buffer Underrun Protection) on CD/DVD/Blu-Ray/HD-DVD burner device that supports BUP. BUP must be enabled for successful completion of write operations.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what StarBurn_CdvdBurnerGrabber_GetBUP can be used for.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetBUP, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, gets BUP status and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsBUPEnabled;
BOOLEAN l__BOOLEAN__IsBUPSupported;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsBUPEnabled,
    &l__BOOLEAN__IsBUPSupported
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check is BUP supported, if yes - try to enable it
if ( l__BOOLEAN__IsBUPSupported == TRUE )
{

// Try to set BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SetCDTextItem Function

StarBurn_CdvdBurnerGrabber_SetCDTextItem Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SetCDTextItem(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN CHAR p__CHAR__TrackIndex,
    IN const PCHAR p__PCHAR__Artist,
    IN const PCHAR p__PCHAR__Title,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to CStarBurn_CdvdBurnerGrabber object.
IN CHAR p__CHAR__TrackIndex | 1-based track number. Or 0 for the common DISC information. PCHAR p__PCHAR__Artist - Pointer to zero-terminated string with the name of artist/performer/singer. PCHAR p__PCHAR__Title - Pointer to zero-terminated string with the track title/song name.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to buffer for exception text.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
Returns

Exception number

Description

Sets CD-Text item for the specified CD/DVD/Blu-Ray/HD-DVD device.

Remarks

Please check DiscAtOnceFromFile sample to find out how to use StarBurn_CdvdBurnerGrabber_SetCDTextItem() in the right way. Note, that this function is used to burn CD-TEXT for audio discs using StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile.

See Also

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile, StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx

Example

This example allocates CdvdBurnerGrabber object, specifies the CD-Text for a disc and for 3 track and burns the disc.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add files to burn here by filling l__DAO_DISC_LAYOUT information

// Try to set CD-Text information for 3d track
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetCDTextItem(
    l__PVOID__CdvdBurnerGrabber,
    3,
    "My band",
    "My new song",
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status
    );

// Check for success
if (l__EXCEPTION_NUMBER != EN_SUCCESS)
{
// Handle error here...
}

// Try to set CD-Text information for the whole disc
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetCDTextItem(
    l__PVOID__CdvdBurnerGrabber,
    0,
    "My band",
    "My first album",
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status
    );

// Check for success
if (l__EXCEPTION_NUMBER != EN_SUCCESS)
{
// Handle error here...
}

// Try to burn ISO/sound/MDS image to the disc as CDROM XA (MODE2 Form1) or CDDA (CD digital audio) in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE,
    l__BOOLEAN__IsTestWrite,
    FALSE, // Next session allowed
    FALSE, // Do NOT repair broken sub-channel
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SetReadSpeed Function

StarBurn_CdvdBurnerGrabber_SetReadSpeed Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SetReadSpeed(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ULONG p__ULONG__ReadSpeedInKBps
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ULONG p__ULONG__ReadSpeedInKBps | Read speed in kilobytes per second.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function sets read speed for CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object.

Remarks

There are no examples of using StarBurn_CdvdBurnerGrabber_SetReadSpeed however this call is nearly identical to more generic one called StarBurn_CdvdBurnerGrabber_SetSpeeds. Current one sets only read speed and generic one sets both read and write speeds at the same time.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_GetSpeeds

Example

This example allocates CdvdBurnerGrabber object, sets maximum allowed read speed and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to set maximum allowed read speed
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetReadSpeed(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0xFFFF
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SetSpeeds Function

StarBurn_CdvdBurnerGrabber_SetSpeeds Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SetSpeeds(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ULONG p__ULONG__ReadSpeed,
    IN ULONG p__ULONG__WriteSpeed
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ULONG p__ULONG__ReadSpeed | ULONG with read speed to set.
IN ULONG p__ULONG__WriteSpeed | ULONG with write speed to set.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function sets current read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device This speeds later will be used during all read and write operations.

Remarks

Please see the TrackAtOnceFromTree, TrackAtOnceFromFile, GrabTrack, GrabDisc samples that will demonstrate how StarBurn_CdvdBurnerGrabber_SetSpeeds can be used for setting CD/DVD/Blu-Ray/HD-DVD device read and write speeds.

[ WARNING! It's required to have media inserted for this function to work properly! ]

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_SetReadSpeed, StarBurn_CdvdBurnerGrabber_GetSpeeds

Example

This example allocates CdvdBurnerGrabber object, sets top supported read and write speeds and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to set top supported CD/DVD/Blu-Ray/HD-DVD read/write speeds on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetSpeeds(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0xFFFF,
    0xFFFF
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_StopPlayScan Function

StarBurn_CdvdBurnerGrabber_StopPlayScan Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_StopPlayScan(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function resets media state inside CD/DVD/Blu-Ray/HD-DVD burner device object. This actions allow to update disc content w/o need to eject the disc. Could be used for multiple burnings w/o disc eject or manual disc data verification.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media. Adding call to StarBurn_CdvdBurnerGrabber_StopPlayScan and some of the manual media read commands would allow faster (maybe better) recorded image verifications then built-in into the library.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile

Example

This example allocates CdvdBurnerGrabber object, burns something and does manual verification and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn image here...

// Try to update device state
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_StopPlayScan(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Manually verify recorded image here...

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCD Function

StarBurn_CdvdBurnerGrabber_SuperVideoCD Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCD(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName | Pointer to SVCD/MPEG2 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device.

Remarks

Please see the SuperVideoCD sample that will demonstrate how SVCD/MPEG2 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_SuperVideoCD with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VideoCD

Example

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__Status;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Track-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\MOVIE.MPEG2",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDEx Function

StarBurn_CdvdBurnerGrabber_SuperVideoCDEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCDEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN WRITE_MODE p__WRITE_MODE,
    IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN WRITE_MODE p__WRITE_MODE | Write mode to use.
IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName | Pointer to SVCD/MPEG2 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.

Remarks

Please see the SuperVideoCDEx sample that will demonstrate how SVCD/MPEG2 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_SuperVideoCDEx with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_VideoCDEx

Example

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG2",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx Function

StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName,
    IN PCHAR p__PCHAR__TemplatePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__MPEG2ImagePathAndFileName | Pointer to SVCD/MPEG2 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
p__WRITE_MODE | Write mode to use.
p__PCHAR__TemplateImagePathAndFileName | Pointer to template file name StarBurn would record as first data track.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.

Remarks

Please see the SuperVideoCDEx sample that will demonstrate how SVCD/MPEG2 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_SuperVideoCDEx with currently set write speed and currently set optimum power calibration. This sample is for legacy call, StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx is basically the same API call except it allows to pass user-defined data track StarBurn would record to SVCD as first track (MPEG2 file is second track on VCD).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_VideoCDExEx, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx

Example

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more. Custom user file name is passed to have own data track on resulting SVCD.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG2",  // Second MPEG2 track
    "C:\DATA.ISO",     // First DATA track
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode Function

StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__MPEG2ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__TemplatePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode Function

StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN WRITE_MODE p__WRITE_MODE,
    IN PWCHAR p__PWCHAR__MPEG2ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode Function

StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__MPEG2ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TestUnitReady Function

StarBurn_CdvdBurnerGrabber_TestUnitReady Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TestUnitReady(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what StarBurn_CdvdBurnerGrabber_TestUnitReady can be used for. Also it's a good idea to use extended and "double extended" variants of this call (StarBurn_CdvdBurnerGrabber_TestUnitReadyEx and StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx) when required.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx, StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx

Example

This example allocates CdvdBurnerGrabber object, tests unit ready and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReady(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TestUnitReadyEx Function

StarBurn_CdvdBurnerGrabber_TestUnitReadyEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TestUnitReadyEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ULONG p__ULONG__NumberOfSecondsToWait
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ULONG p__ULONG__NumberOfSecondsToWait | Number of seconds to wait (not less than the number, maybe more) until the unit would not become into ready state.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. The only difference between this and simple StarBurn_CdvdBurnerGrabber_TestUnitReady() is that this code passed parameter to wait for unit to become ready. And "simple" code uses default timeout of 20 seconds.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what StarBurn_CdvdBurnerGrabber_TestUnitReady and it's more extended "clone" StarBurn_CdvdBurnerGrabber_TestUnitReadyEx and "double extended" StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx can be used for.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx

Example

This example allocates CdvdBurnerGrabber object, tests unit ready for 10 seconds (instead of default 20) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready for 10 seconds
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    10 // 10 seconds to test unit to become into ready state
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx Function

StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN ULONG p__ULONG__NumberOfSecondsToWait,
    IN BOOLEAN p__BOOLEAN__IsFastExitUsed
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN ULONG p__ULONG__NumberOfSecondsToWait | Number of seconds to wait (not less than the number, maybe more) for device to become into ready state.
IN BOOLEAN p__BOOLEAN__IsFastExitUsed | Should StarBurn do "fast exit" if there's no disc in drive.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. This "double extended" variant of the call also can wait for particular amount of seconds and do "fast exit" if there's no disc in drive.

Remarks

Please see the TrackAtOnceFromTree and TrackAtOnceFromFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and what StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx can be used for. Also it's a good idea to check either normal StarBurn_CdvdBurnerGrabber_TestUnitReady or basic extended variant of this call called StarBurn_CdvdBurnerGrabber_TestUnitReadyEx. Some of them may work better in particular situation.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx

Example

This example allocates CdvdBurnerGrabber object, tests unit ready and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    5,      // 5 seconds to wait for device to become ready
    TRUE    // Fast exit if there's no disc in drive
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__ISOSoundImagePathAndFileName,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__ISOSoundImagePathAndFileName | Pointer to ISO9660 or Joliet file system image or sound file located in a file and stored on the hard disk.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\ISO9660.ISO",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__SoundImagePathAndFileName,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to CStarBurn_CdvdBurnerGrabber object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB failure information.
IN PWCHAR p__PWCHAR__SoundImagePathAndFileName | Pointer to sound path and file name in Unicode format.
IN BOOLEAN p__BOOLEAN__IsXA | Is this CDROM XA or just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | Is this test write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | Is next session allowed.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Exception number

Description

This API call deals with audio tracks with Unicode names only.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__SoundImagePathAndFileName,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN USHORT p__USHORT__AudioPauseLengthInLBs,
    IN BOOLEAN p__BOOLEAN__IsAudioPauseChange
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to CStarBurn_CdvdBurnerGrabber object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB failure information.
IN PWCHAR p__PWCHAR__SoundImagePathAndFileName | Pointer to sound path and file name in Unicode format.
IN BOOLEAN p__BOOLEAN__IsXA | Is this CDROM XA or just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | Is this test write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | Is next session allowed.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN USHORT p__USHORT__AudioPauseLengthInLBs | Audio pause length in logical blocks.
IN BOOLEAN p__BOOLEAN__IsAudioPauseChange | Should we change audio pause length.
Returns

Exception number

Description

This API call deals with audio tracks with Unicode names only. Also it allows to set track-to-track pause length.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__ISOSoundImagePathAndFileName,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN USHORT p__USHORT__AudioPauseLengthInLBs,
    IN BOOLEAN p__BOOLEAN__IsAudioPauseChange
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__ISOSoundImagePathAndFileName | Pointer to ISO9660 or Joliet file system image or sound file located in a file and stored on the hard disk.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN USHORT p__USHORT__AudioPauseLengthInLBs | Audio pause length in logical blocks.
IN BOOLEAN p__BOOLEAN__IsAudioPauseChange | Is audio pause change.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile with currently set write speed and currently set optimum power calibration. The same sample uses extended version of the call to control audio pause length.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, records sound track image to the CD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to sound track image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\TRACK.WAV",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    0x0000, // Zero-sized pause between tracks
    TRUE    // Yes, apply pause change
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__ISOSoundImagePathAndFileName,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN OUT PVOID p__PVOID__MemoryRegion,
    IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsAudio
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN OUT PVOID p__PVOID__MemoryRegion | Pointer to memory region containing data.
IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs | Memory region size in UCHARs.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN BOOLEAN p__BOOLEAN__IsAudio | Is this audio stream (TRUE) or data stream (FALSE).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromPipe and TrackAtOnceFromPipeEx API calls to find out how to deal with content generated on-the-fly and not statically stored in the memory.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx

Example

This example allocates CdvdBurnerGrabber object, reads ISO9660 or Joliet file system image to the memory, records it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PUCHAR l__PUCHAR__MemoryRegion;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in memory. Pointer would be
// stored in l__UCHAR__MemoryRegion and memory region size would be stored in
// l__LARGE_INTEGER__SizeInUCHARs variable

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PVOID )( l__PUCHAR__MemoryRegion ),
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    FALSE // We burn data compilation
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN OUT PVOID p__PVOID__MemoryRegion,
    IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsAudio,
    IN USHORT p__USHORT__AudioPauseLengthInLBs,
    IN BOOLEAN p__BOOLEAN__IsAudioPauseChange
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN OUT PVOID p__PVOID__MemoryRegion | Pointer to memory region containing data.
IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs | Memory region size in UCHARs.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN BOOLEAN p__BOOLEAN__IsAudio | Is this audio stream (TRUE) or data stream (FALSE).
IN USHORT p__USHORT__AudioPauseLengthInLBs | Audio pause length in logical blocks.
IN BOOLEAN p__BOOLEAN__IsAudioPauseChange | Is audio pause change.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode. If audio content is recorded this API call can change default Track-At-Once track-to-track pause length from 150 logical blocks (2 seconds) to any passed one.

Remarks

Please see the TrackAtOnceFromPipe and TrackAtOnceFromPipeEx API calls to find out how to deal with content generated on-the-fly and not statically stored in the memory.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory

Example

This example allocates CdvdBurnerGrabber object, reads audio track content to the memory, records it to the CD recordable media and destroys the device object after it's not needed any more. Also it sets track-to-track pause to zero.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PUCHAR l__PUCHAR__MemoryRegion = NULL;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare audio track and store it to the memory. Pointer would be
// stored in l__UCHAR__MemoryRegion and memory region size would be stored in
// l__LARGE_INTEGER__SizeInUCHARs variable

// Try to record the audio track in Track-At-Once mode and set zero-sized track-to-track pause
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PVOID )( l__PUCHAR__MemoryRegion ),
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    TRUE,   // We burn audio compilation
    0,      // Track-to-track pause length of ZERO
    TRUE    // Yes, please alter default pause length
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN HANDLE p__HANDLE,
    IN LARGE_INTEGER p__LARGE_INTEGER__SizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN HANDLE p__HANDLE | Handle to ISO9660 or Joliet file system image or sound file located in a pipe.
IN LARGE_INTEGER p__LARGE_INTEGER__SizeInUCHARs | Pipe contents size in UCHARs.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromPipeEx API call as it allows to burn not only data but also audio compilations from pipes.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
HANDLE l__HANDLE__Pipe = INVALID_HANDLE_VALUE;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in pipe

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__HANDLE__Pipe,
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN HANDLE p__HANDLE,
    IN LARGE_INTEGER p__LARGE_INTEGER__SizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN BOOLEAN p__BOOLEAN__IsAudio
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN HANDLE p__HANDLE | Handle to ISO9660 or Joliet file system image or sound file located in a pipe.
IN LARGE_INTEGER p__LARGE_INTEGER__SizeInUCHARs | Pipe contents size in UCHARs.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN BOOLEAN p__BOOLEAN__IsAudio | Is this audio stream (TRUE) or data stream (FALSE).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image or audio stream located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromPipe API call as it's simplified variant of extended call allowing to burn data compilations only.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
HANDLE l__HANDLE__Pipe = INVALID_HANDLE_VALUE;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in pipe

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__HANDLE__Pipe,
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    FALSE // We burn data compilation
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__FileTree,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PVOID p__PVOID__FileTree | Pointer to ISO9660 or Joliet file system image located in a file tree.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is a just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how "virtual" ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image from file tree to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to create ISO9660 or Joliet file system image with help of StarBurn_ISO9660JolietFileTree_Create and
// StarBurn_ISO9660JolietFileTree_BuildImage, l__PVOID__FileTree used as the pointer to the object...

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx Function

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__FileTree,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds,
    IN ULONG p__ULONG__Custom_NWA
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PVOID p__PVOID__FileTree | Pointer to ISO9660 or Joliet file system image located in a file tree.
IN BOOLEAN p__BOOLEAN__IsXA | BOOLEAN set to TRUE if this is CDROM XA, FALSE if this is a just ordinary CDROM/CDDA.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN BOOLEAN p__BOOLEAN__IsNextSessionAllowed | BOOLEAN set to TRUE is next session is allowed on this media, FALSE if next session will not be allowed on this media.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
IN ULONG p__ULONG__Custom_NWA | Next Writable Address value.
p__ULONG__Custom_Padding_Size | Custom padding size value.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the TrackAtOnceFromTree sample that will demonstrate how "virtual" ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup Function

StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCALLBACK p__PCALLBACK__Callback,
    IN PVOID p__PVOID__CallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | CdvdBurnerGrabber object.
p__PCALLBACK_Callback | Pointer to callback function that receives information about found files.
p__PVOID_CallbackContext | Callback context
Returns

Execution status.

Description

This function parses the UDF file system on disc and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.

Remarks

Works correctly on pre-recorded media (DVD-ROM, BD-ROM). Information that is passed to callback function should be copied and stored on client side. Strings may not be valid outside callback function.

Example

Please see UDFLookup sample as example how to use StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup API call.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx Function

StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCALLBACK p__PCALLBACK__Callback,
    IN PVOID p__PVOID__CallbackContext,
    IN ULONG p__ULONG__StartLBA,
    IN ULONG p__ULONG__EndLBA
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | CdvdBurnerGrabber object.
p__PCALLBACK_Callback | Pointer to callback function that receives information about found files.
p__PVOID_CallbackContext | Callback context
Returns

Execution status.

Description

This function parses the UDF file system on disc and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.

Remarks

Works correctly on pre-recorded media (DVD-ROM, BD-ROM). Information that is passed to callback function should be copied and stored on client side. Strings may not be valid outside callback function.

Example

Please see UDFLookup sample as example how to use StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup API call.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFile Function

StarBurn_CdvdBurnerGrabber_VerifyFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyFile(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__ImageFileName,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__ImageFileName | Pointer to image file name we'll open and read from to compare the data with recorded disc.
IN LONG p__LONG__StartingLBA | LBA (logical block address) used to start recording from.
OUT PLONG p__PLONG__FailedLBA | Pointer to the variable to contain failed LBA (number of sector failed verification process).
IN ULONG p__ULONG__ReportDelayInLBs | Number of logical blocks verified before progress callback would be called.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.

Remarks

Please see the TrackAtOnceFromFile and VerifyFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_VerifyFile can be used for verification of the recorded content.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyTree

Example

This example allocates CdvdBurnerGrabber object, burns image "IMAGE.ISO", verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn prepared file system image "IMAGE.ISO" here

// Try to verify file image
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "IMAGE.ISO",
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFileEx Function

StarBurn_CdvdBurnerGrabber_VerifyFileEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyFileEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__ImageFileName,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs,
    IN LONG p__LONG__NumberOfRetries
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__ImageFileName | Pointer to image file name we'll open and read from to compare the data with recorded disc.
IN LONG p__LONG__StartingLBA | LBA (logical block address) used to start recording from.
OUT PLONG p__PLONG__FailedLBA | Pointer to the variable to contain failed LBA (number of sector failed verification process).
IN ULONG p__ULONG__ReportDelayInLBs | Number of logical blocks verified before progress callback would be called.
IN LONG p__LONG__NumberOfRetries | Number of read retries allowed to do on logical block failed to be readen from optical media.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.

Remarks

Please see the TrackAtOnceFromFile and VerifyFile samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_VerifyFile can be used for verification of the recorded content.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyTree, StarBurn_CdvdBurnerGrabber_VerifyFile

Example

This example allocates CdvdBurnerGrabber object, burns image "IMAGE.ISO", verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn prepared file system image "IMAGE.ISO" here

// Try to verify file image
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyFileEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "IMAGE.ISO",
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000, // Call progress callback after every 1000 logical blocks processed
    10 // Allow up to 10 attempts to read failed logical block
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode Function

StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__ImageFileName,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs,
    IN LONG p__LONG__NumberOfRetries
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFileUnicode Function

StarBurn_CdvdBurnerGrabber_VerifyFileUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyFileUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__ImageFileName,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_VerifyFileUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyTree Function

StarBurn_CdvdBurnerGrabber_VerifyTree Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyTree(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__FileTree,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PVOID p__PVOID__FileTree | Pointer to file system tree used for recording.
IN LONG p__LONG__StartingLBA | LBA (logical block address) used to start recording from.
OUT PLONG p__PLONG__FailedLBA | Pointer to the variable to contain failed LBA (number of sector failed verification process).
IN ULONG p__ULONG__ReportDelayInLBs | Number of logical blocks verified before progress callback would be called.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.

Remarks

Please see the TrackAtOnceFromTree and DiscAtOnceFromTree samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_VerifyTree can be used for verification of the recorded content. Also it's a good idea to use extended variant of this call StarBurn_CdvdBurnerGrabber_VerifyTreeEx when there's need to know how many retries for single failed logical block could be allowed.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyFile

Example

This example allocates CdvdBurnerGrabber object, burns file tree, verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and burn ISO9660 or Joliet file tree here

// Try to verify file tree
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyTreeEx Function

StarBurn_CdvdBurnerGrabber_VerifyTreeEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VerifyTreeEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PVOID p__PVOID__FileTree,
    IN LONG p__LONG__StartingLBA,
    OUT PLONG p__PLONG__FailedLBA,
    IN ULONG p__ULONG__ReportDelayInLBs,
    IN LONG p__LONG__NumberOfRetries
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PVOID p__PVOID__FileTree | Pointer to file system tree used for recording.
IN LONG p__LONG__StartingLBA | LBA (logical block address) used to start recording from.
OUT PLONG p__PLONG__FailedLBA | Pointer to the variable to contain failed LBA (number of sector failed verification process).
IN ULONG p__ULONG__ReportDelayInLBs | Number of logical blocks verified before progress callback would be called.
IN LONG p__LONG__NumberOfRetries | Number of read retries allowed to do on logical block failed to be readen from optical media.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.

Remarks

Please see the TrackAtOnceFromTree and DiscAtOnceFromTree samples that will demonstrate how ISO9660 or Joliet file system image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and how StarBurn_CdvdBurnerGrabber_VerifyTree can be used for verification of the recorded content (extended variant of the call is basically the same except it allows to control number of read retries). Also it's a good idea to use simplified variant of this call StarBurn_CdvdBurnerGrabber_VerifyTree when there's no need to know how many retries for single failed logical block could be allowed.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTree, StarBurn_CdvdBurnerGrabber_VerifyFile

Example

This example allocates CdvdBurnerGrabber object, burns file tree, verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and burn ISO9660 or Joliet file tree here

// Try to verify file tree
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyTreeEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed,
    10 // Allow up to 10 attempts to read failed logical block
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCD Function

StarBurn_CdvdBurnerGrabber_VideoCD Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCD(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName | Pointer to VCD/MPEG1 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.

Remarks

Please see the VideoCD sample that will demonstrate how VCD/MPEG1 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_VideoCD with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD

Example

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Track-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\MOVIE.MPEG1",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDEx Function

StarBurn_CdvdBurnerGrabber_VideoCDEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCDEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN WRITE_MODE p__WRITE_MODE,
    IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN WRITE_MODE p__WRITE_MODE | Write mode to use.
IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName | Pointer to VCD/MPEG1 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.

Remarks

Please see the VideoCDEx sample that will demonstrate how VCD/MPEG1 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_VideoCDEx with currently set write speed and currently set optimum power calibration.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx

Example

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG1",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDExEx Function

StarBurn_CdvdBurnerGrabber_VideoCDExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCDExEx(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName,
    IN PCHAR p__PCHAR__TemplateImagePathAndFileName,
    IN PCHAR p__PCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION | Pointer to CDB_FAILURE_INFORMATION that will be filled with appropriate values.
IN PCHAR p__PCHAR__MPEG1ImagePathAndFileName | Pointer to VCD/MPEG1 image file located in a file and stored on the hard disk.
IN PCHAR p__PCHAR__TemplateImagePathAndFileName | Pointer to template file name StarBurn would record as first data track.
IN PCHAR p__PCHAR__AlbumIdentifier | Pointer to album identifier.
IN USHORT p__USHORT__NumberOfVolumesInAlbum | Number of volumes in album.
IN USHORT p__USHORT__AlbumSetSequenceNumber | Album set sequence number.
IN BOOLEAN p__BOOLEAN__IsTestWrite | BOOLEAN set to TRUE if this is test write, FALSE if this is a real write.
IN ULONG p__ULONG__WriteReportDelayInSeconds | Write report delay in seconds (time between 2 WRITE_PACKET callbacks).
IN ULONG p__ULONG__BufferStatusReportDelayInSeconds | Buffer status report delay in seconds (time between 2 BUFFER_STATUS callbacks).
p__WRITE_MODE | Write mode to use.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.

Remarks

Please see the VideoCDEx sample that will demonstrate how VCD/MPEG1 image can be burn on the CD/DVD/Blu-Ray/HD-DVD media and with the help of StarBurn_CdvdBurnerGrabber_VideoCDEx with currently set write speed and currently set optimum power calibration. This sample is for legacy call, StarBurn_CdvdBurnerGrabber_VideoCDExEx is basically the same API call except it allows to pass user-defined data track StarBurn would record to VCD as first track (MPEG1 file is second track on VCD).

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx, StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx, StarBurn_CdvdBurnerGrabber_VideoCDEx

Example

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more. Custom user file name is passed to have own data track on resulting VCD.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCDExEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG1",  // Second MPEG1 track
    "C:\DATA.ISO",     // First DATA track
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode Function

StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__MPEG1ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__TemplateImagePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDExUnicode Function

StarBurn_CdvdBurnerGrabber_VideoCDExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCDExUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN WRITE_MODE p__WRITE_MODE,
    IN PWCHAR p__PWCHAR__MPEG1ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_VideoCDExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDUnicode Function

StarBurn_CdvdBurnerGrabber_VideoCDUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_CdvdBurnerGrabber_VideoCDUnicode(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    OUT PCDB_FAILURE_INFORMATION p__PCDB_FAILURE_INFORMATION,
    IN PWCHAR p__PWCHAR__MPEG1ImagePathAndFileName,
    IN PWCHAR p__PWCHAR__AlbumIdentifier,
    IN USHORT p__USHORT__NumberOfVolumesInAlbum,
    IN USHORT p__USHORT__AlbumSetSequenceNumber,
    IN BOOLEAN p__BOOLEAN__IsTestWrite,
    IN ULONG p__ULONG__WriteReportDelayInSeconds,
    IN ULONG p__ULONG__BufferStatusReportDelayInSeconds
);
File

StarBurn.h

Description

This is function StarBurn_CdvdBurnerGrabber_VideoCDUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CorrectISO9660Name_Default Function

StarBurn_CorrectISO9660Name_Default Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CorrectISO9660Name_Default(
    IN OUT PCHAR p__PCHAR__Name
);
File

StarBurn.h

Parameters
Parameters | Description
IN OUT PCHAR p__PCHAR__Name | Pointer to current name.
Returns

Nothing.

Description

This function generates next ISO9660 file name to make it unique.

Remarks

N/A

See Also

StarBurn_CorrectJolietName_Default

Example

N/A

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CorrectJolietName_Default Function

StarBurn_CorrectJolietName_Default Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_CorrectJolietName_Default(
    IN OUT PWCHAR p__PWCHAR__Name
);
File

StarBurn.h

Parameters
Parameters | Description
IN OUT PWCHAR p__PWCHAR__Name | Pointer to current name.
Returns

Nothing.

Description

This function generates next Joliet file name to make it unique.

Remarks

N/A

See Also

StarBurn_CorrectISO9660Name_Default

Example

N/A

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CreatePipe Function

StarBurn_CreatePipe Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_CreatePipe(
    OUT PHANDLE p__PHANDLE__ReadPipe,
    OUT PHANDLE p__PHANDLE__WritePipe
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PHANDLE p__PHANDLE__ReadPipe | pointer to the output "read" pipe handle.
OUT PHANDLE p__PHANDLE__WritePipe | pointer to the output "write" pipe handle.
Returns

Win32 execution status.

Description

This function creates pipe for all of the StarBurn pipe operations and returns both "read" and "write" handles for it.

Remarks

Used with all of the StarBurn pipe-related API calls.

See Also

StarBurn_DestroyPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx

Example

This example allocates both "read" and "write" handles for the same pipe, does some I/O and closes them both later.

// Somewhere in the data region
HANDLE l__HANDLE__ReadPipe = INVALID_HANDLE_VALUE;
HANDLE l__HANDLE__WritePipe = INVALID_HANDLE_VALUE;
ULONG l__ULONG__Status = ERROR_SUCCESS;

// Try to create pipe
l__ULONG__Status =
StarBurn_CreatePipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );

// Check for success
if ( l__ULONG__Status != ERROR_SUCCESS )
{
// Handle error here...
}

// Do something with the pipe handles here...

// Close both "read" and "write" pipe handles
StarBurn_DestroyPipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_Destroy Function

StarBurn_Destroy Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_Destroy(
    IN OUT PVOID * p__PPVOID__StarBurnObject
);
File

StarBurn.h

Parameters
Parameters | Description
IN OUT PVOID * p__PPVOID__StarBurnObject | Pointer to pointer to the object that toolkit allocated before.
Returns

None.

Description

This function frees allocated memory in the way of destroying the object that toolkit created internally. This is universal call, it frees all the objects and does not care about object type.

Remarks

This call does not check for passed parameter validness. It's up to user to provide the toolkit with correct pointers to objects. After return from this call the object pointer will be NULL.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_CdvdBurnerGrabber_Create

Example

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    TRUE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DestroyPipe Function

StarBurn_DestroyPipe Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_DestroyPipe(
    IN PHANDLE p__PHANDLE__ReadPipe,
    IN PHANDLE p__PHANDLE__WritePipe
);
File

StarBurn.h

Parameters
Parameters | Description
IN PHANDLE p__PHANDLE__ReadPipe | pointer to the input "read" pipe handle.
IN PHANDLE p__PHANDLE__WritePipe | pointer to the input "write" pipe handle.
Returns

Nothing.

Description

This function closes both "read" and "write" pipe handles.

Remarks

Used with all of the StarBurn pipe-related API calls.

See Also

StarBurn_CreatePipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx

Example

This example allocates both "read" and "write" handles for the same pipe, does some I/O and closes them both later.

// Somewhere in the data region
HANDLE l__HANDLE__ReadPipe = INVALID_HANDLE_VALUE;
HANDLE l__HANDLE__WritePipe = INVALID_HANDLE_VALUE;
ULONG l__ULONG__Status = ERROR_SUCCESS;

// Try to create pipe
l__ULONG__Status =
StarBurn_CreatePipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );

// Check for success
if ( l__ULONG__Status != ERROR_SUCCESS )
{
// Handle error here...
}

// Do something with the pipe handles here...

// Close both "read" and "write" pipe handles
StarBurn_DestroyPipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DownShut Function

StarBurn_DownShut Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DownShut(
    IN VOID
);
File

StarBurn.h

Returns

Execution status. EN_SUCCESS if uninitialization process completed successfully.

Description

This function uninitialize burning toolkit. It's expected to be called after very last function call before exiting from StarBurn client application. It's a good idea to gather the trash before exiting. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used.

Remarks

See samples for details how and when call StarBurn_DownShut() function.

See Also

See samples for details how and when call StarBurn_DownShut() function.

Example

This example just uninitialize toolkit.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;

// Try to uninitialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_DownShut();

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_Create Function

StarBurn_DVDVideo_Create Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_Create(
    OUT PVOID * p__PPVOID__DVDVideo,
    IN PCHAR p__PCHAR__VideoTsDirectory,
    IN BOOLEAN p__BOOLEAN__IsPatchingEnabled,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__VolumeLabel,
    IN PCHAR p__PCHAR__PublisherPreparerName,
    IN PCHAR p__PCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__DVDVideo | Pointer to pointer to resulting DVD-Video file system object.
IN PCHAR p__PCHAR__VideoTsDirectory | Pointer to VIDEO_TS directory with corresponding DVD files.
IN BOOLEAN p__BOOLEAN__IsPatchingEnabled | Should be set to TRUE to allow StarBurn core to modify IFO/BUP files and FALSE otherwise.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to buffer to receive formatted error message in case of exception.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Error text buffer size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error value (if function would return EN_SYSTEM_CALL_FAILED).
IN PCHAR p__PCHAR__VolumeLabel | Pointer to volume label resulting DVD-Video compilation would receive.
IN PCHAR p__PCHAR__PublisherPreparerName | Pointer to publisher and preparer name resulting DVD-Video compilation would receive.
IN PCHAR p__PCHAR__ApplicationName | Pointer to application name resulting DVD-Video compilation would receive.
IN LONG p__LONG__Year | Year which would be set as DVD-Video compilation creation year.
IN LONG p__LONG__Month | Month which would be set as DVD-Video compilation creation month.
IN LONG p__LONG__Day | Day which would be set as DVD-Video compilation creation day.
IN LONG p__LONG__Hour | Hour which would be set as DVD-Video compilation creation hour.
IN LONG p__LONG__Minute | Minute which would be set as DVD-Video compilation creation minute.
IN LONG p__LONG__Second | Second which would be set as DVD-Video compilation creation second.
IN LONG p__LONG__MilliSecond | Millisecond which would be set as DVD-Video compilation creation millisecond.
Returns

Execution status.

Description

This function creates DVD-Video file system object from passed pointer to VIDEO_TS directory with DVD corresponding files.

Remarks

None.

See Also

StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Create API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_CreateUnicode Function

StarBurn_DVDVideo_CreateUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_CreateUnicode(
    OUT PVOID * p__PPVOID__DVDVideo,
    IN CONST WCHAR* p__PWCHAR__VideoTsDirectory,
    IN BOOLEAN p__BOOLEAN__IsPatchingEnabled,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN CONST WCHAR* p__PWCHAR__VolumeLabel,
    IN CONST WCHAR* p__PWCHAR__PublisherPreparerName,
    IN CONST WCHAR* p__PWCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Description

This is function StarBurn_DVDVideo_CreateUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_Destroy Function

StarBurn_DVDVideo_Destroy Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_DVDVideo_Destroy(
    IN PVOID p__PVOID__DVDVideo
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__DVDVideo | Pointer to source DVD-Video file system object we need to deallocate.
Returns

Nothing.

Description

This function destroys DVD-Video file system object created with StarBurn_DVDVideo_Create API call.

Remarks

None.

See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Destroy API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_GetSizeInUCHARs Function

StarBurn_DVDVideo_GetSizeInUCHARs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_GetSizeInUCHARs(
    IN PVOID p__PVOID__DVDVideo,
    OUT PLARGE_INTEGER p__PLARGE_INTEGER__SizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__DVDVideo | Pointer to source DVD-Video file system object we need to get payload size in UCHARs.
OUT PLARGE_INTEGER p__PLARGE_INTEGER__SizeInUCHARs | Pointer to the variable to receive file system payload size in UCHARs.
Returns

Execution status.

Description

This function gets file system content size in UCHARs from DVD-Video file system object created with StarBurn_DVDVideo_Create API call.

Remarks

None.

See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetTreePointer

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_GetSizeInUCHARs API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_GetTreePointer Function

StarBurn_DVDVideo_GetTreePointer Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_GetTreePointer(
    IN PVOID p__PVOID__DVDVideo,
    OUT PVOID * p__PPVOID__ISO9660JolietFileTree
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__DVDVideo | Pointer to source DVD-Video file system object we need to get ISO9660 file tree object pointer.
OUT PVOID * p__PPVOID__ISO9660JolietFileTree | Pointer to the variable to receive ISO9660 file tree object pointer.
Returns

Execution status.

Description

This function returns pointer to ISO9660 file tree object embedded to DVD-Video file system object created with StarBurn_DVDVideo_Create API call.

Remarks

None.

See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_GetTreePointer API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_PatchHeader Function

StarBurn_DVDVideo_PatchHeader Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_DVDVideo_PatchHeader(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    IN ULONG p__ULONG__BUPLastTouchedRBA,
    IN BOOLEAN p__BOOLEAN__IsMenuVob
);
File

StarBurn.h

Parameters
Parameters | Description
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM | Pointer to tree item to process.
IN ULONG p__ULONG__BUPLastTouchedRBA | BUF last touched RBA.
IN BOOLEAN p__BOOLEAN__IsMenuVob | Is menu VOB file present.
Returns

Nothing.

Description

This function patches IFO/BUF file header RBA for BUP.

Example

See the DVDVideoBuildImage example.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_PatchTable Function

StarBurn_DVDVideo_PatchTable Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_DVDVideo_PatchTable(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    IN PDVD_VIDEO_CONTROL_BLOCK p__PDVD_VIDEO_CONTROL_BLOCK
);
File

StarBurn.h

Parameters
Parameters | Description
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM | Pointer to tree item to process.
IN PDVD_VIDEO_CONTROL_BLOCK p__PDVD_VIDEO_CONTROL_BLOCK | Pointer to DVD-Video control block.
Returns

Nothing.

Description

This function patches IFO/BUF file table RBAs.

Example

See the DVDVideoBuildImage example.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_Read Function

StarBurn_DVDVideo_Read Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_Read(
    IN PVOID p__PVOID__DVDVideo,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN LARGE_INTEGER p__LARGE_INTEGER__IoTransferSizeInUCHARs,
    OUT PUCHAR p__PUCHAR__DataBuffer
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__DVDVideo | Pointer to source DVD-Video file system object we need to read data from.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to buffer to receive formatted error message in case of exception.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Error text buffer size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error value (if function would return EN_SYSTEM_CALL_FAILED).
IN LARGE_INTEGER p__LARGE_INTEGER__IoTransferSizeInUCHARs | Number of UCHARs we want to read from file system object.
OUT PUCHAR p__PUCHAR__DataBuffer | Pointer to output data buffer we want file system object data to be placed after read.
Returns

Execution status.

Description

This function reads requested number of UCHARs from DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) from it's current read position.

Remarks

None.

See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Read API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_SeekToBegin Function

StarBurn_DVDVideo_SeekToBegin Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_DVDVideo_SeekToBegin(
    IN PVOID p__PVOID__DVDVideo,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__DVDVideo | Pointer to source DVD-Video file system object we need to rewind.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to buffer to receive formatted error message in case of exception.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Error text buffer size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error value (if function would return EN_SYSTEM_CALL_FAILED).
Returns

Execution status.

Description

This function moves DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) current read position to the very beginning.

Remarks

None.

See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer

Example

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_SeekToBegin API call and all of the companion DVD-Video sub-API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_BootCatalogAddSection Function

StarBurn_ElTorito_BootCatalogAddSection Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ElTorito_BootCatalogAddSection(
    void * BootCatalog,
    const char * SectionIdentifier,
    unsigned short BootEntriesCount,
    STARBURN_ELTORITO_PLATFORM PlatformIdentifier,
    const char ** BootImageFileNames,
    unsigned char * SystemTypes,
    STARBURN_ELTORITO_MEDIA * EmulationTypes,
    unsigned short * SectorsToLoads,
    unsigned short * LoadSegments
);
File

StarBurn.h

Parameters
Parameters | Description
void * BootCatalog | Pointer to pointer to boot catalog object.
const char * SectionIdentifier | Pointer to zero-terminated string with system identifier.
unsigned short BootEntriesCount | Count of boot entries in section
STARBURN_ELTORITO_PLATFORM PlatformIdentifier | A value from STARBURN_ELTORITO_PLATFORM enumeration.
const char ** BootImageFileNames | Pointer to zero-terminated Unicode string with boot image file path.
unsigned char * SystemTypes | array of MBR partition type.
STARBURN_ELTORITO_MEDIA * EmulationTypes | array of STARBURN_ELTORITO_MEDIA enumeration values.
unsigned short * SectorsToLoads | array of Number of sectors to load from boot image.
unsigned short * LoadSegments | array of Load segment
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ElTorito boot catalog (ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_BootCatalogAddSectionUnicode Function

StarBurn_ElTorito_BootCatalogAddSectionUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ElTorito_BootCatalogAddSectionUnicode(
    void * BootCatalog,
    const unsigned short * SectionIdentifier,
    unsigned short BootEntriesCount,
    STARBURN_ELTORITO_PLATFORM PlatformIdentifier,
    const unsigned short ** BootImageFileNames,
    unsigned char * SystemTypes,
    STARBURN_ELTORITO_MEDIA * EmulationTypes,
    unsigned short * SectorsToLoads,
    unsigned short * LoadSegments
);
File

StarBurn.h

Parameters
Parameters | Description
void * BootCatalog | Pointer to pointer to boot catalog object.
const unsigned short * SectionIdentifier | Pointer to zero-terminated string with system identifier.
unsigned short BootEntriesCount | Count of boot entries in section.
STARBURN_ELTORITO_PLATFORM PlatformIdentifier | A value from STARBURN_ELTORITO_PLATFORM enumeration.
const unsigned short ** BootImageFileNames | Pointer to zero-terminated Unicode string with boot image file path.
unsigned char * SystemTypes | array of MBR partition type.
STARBURN_ELTORITO_MEDIA * EmulationTypes | array of STARBURN_ELTORITO_MEDIA enumeration values.
unsigned short * SectorsToLoads | array of Number of sectors to load from boot image.
unsigned short * LoadSegments | array of Load segment
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ElTorito boot catalog (UNICODE names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_CreateBootCatalog Function

StarBurn_ElTorito_CreateBootCatalog Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ElTorito_CreateBootCatalog(
    void ** BootCatalog,
    const char * BootImageFileName,
    const char * ValidationIdentifier,
    STARBURN_ELTORITO_PLATFORM PlatformIdentifier,
    unsigned char SystemType,
    STARBURN_ELTORITO_MEDIA EmulationType,
    unsigned short SectorsToLoad,
    unsigned short LoadSegment
);
File

StarBurn.h

Parameters
Parameters | Description
void ** BootCatalog | Pointer to pointer to boot catalog object.
const char * BootImageFileName | Pointer to zero-terminated Unicode string with boot image file path.
const char * ValidationIdentifier | Pointer to zero-terminated string with system identifier.
STARBURN_ELTORITO_PLATFORM PlatformIdentifier | A value from STARBURN_ELTORITO_PLATFORM enumeration
unsigned char SystemType | MBR partition type.
STARBURN_ELTORITO_MEDIA EmulationType | A value from STARBURN_ELTORITO_MEDIA enumeration
unsigned short SectorsToLoad | Number of sectors to load from boot image.
unsigned short LoadSegment | Load segment
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ElTorito boot catalog (ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_CreateBootCatalogUnicode Function

StarBurn_ElTorito_CreateBootCatalogUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ElTorito_CreateBootCatalogUnicode(
    void ** BootCatalog,
    const unsigned short * BootImageFileName,
    const unsigned short * ValidationIdentifier,
    STARBURN_ELTORITO_PLATFORM PlatformIdentifier,
    unsigned char SystemType,
    STARBURN_ELTORITO_MEDIA EmulationType,
    unsigned short SectorsToLoad,
    unsigned short LoadSegment
);
File

StarBurn.h

Parameters
Parameters | Description
void ** BootCatalog | Pointer to pointer to boot catalog object.
const unsigned short * BootImageFileName | Pointer to zero-terminated Unicode string with boot image file path.
const unsigned short * ValidationIdentifier | Pointer to zero-terminated string with system identifier.
STARBURN_ELTORITO_PLATFORM PlatformIdentifier | A value from STARBURN_ELTORITO_PLATFORM enumeration
unsigned char SystemType | MBR partition type.
STARBURN_ELTORITO_MEDIA EmulationType | A value from STARBURN_ELTORITO_MEDIA enumeration
unsigned short SectorsToLoad | Number of sectors to load from boot image.
unsigned short LoadSegment | Load segment
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ElTorito boot catalog (UNICODE names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileClose Function

StarBurn_FileClose Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_FileClose(
    PSTARBURN_FILE_OBJECT FileObject
);
File

StarBurn.h

Returns

Nothing

Description

This fucntion closes file handle embedded to file object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileCreate Function

StarBurn_FileCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileCreate(
    PSTARBURN_FILE_OBJECT FileObject,
    const char * PathName
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const char * PathName | Pointer to file path and name.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates new file from the passed file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileInitialize Function

StarBurn_FileInitialize Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_FileInitialize(
    PSTARBURN_FILE_OBJECT FileObject
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
Returns

Nothing

Description

This function initializes file handle embedded to file object with bad file handle value.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileOpen Function

StarBurn_FileOpen Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileOpen(
    PSTARBURN_FILE_OBJECT FileObject,
    const char * PathName
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const char * PathName | Pointer to file path and name.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function opens existing file from the passed file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileOpenEx Function

StarBurn_FileOpenEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileOpenEx(
    PSTARBURN_FILE_OBJECT FileObject,
    const char * PathName,
    BOOL IsWrite
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const char * PathName | Pointer to file path and name.
BOOL IsWrite | Is write access required.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function opens existing file from the passed file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileRead Function

StarBurn_FileRead Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileRead(
    PSTARBURN_FILE_OBJECT FileObject,
    void * Buffer,
    unsigned long BufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
void * Buffer | Pointer to data buffer to read file contents to.
unsigned long BufferSizeInUCHARs | Buffer size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function reads asked amount of unsigned chars from file at current seek position.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileReWind Function

StarBurn_FileReWind Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileReWind(
    PSTARBURN_FILE_OBJECT FileObject
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function rewinds file position in unsigned chars to the very beginning for the file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileSeek Function

StarBurn_FileSeek Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileSeek(
    PSTARBURN_FILE_OBJECT FileObject,
    unsigned __int64 PositionInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
unsigned __int64 PositionInUCHARs | Position in unsigned chars within a file.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function sets file position in unsigned chars to required one.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileSeekRead Function

StarBurn_FileSeekRead Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileSeekRead(
    PSTARBURN_FILE_OBJECT FileObject,
    unsigned __int64 PositionInUCHARs,
    void * Buffer,
    unsigned long BufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
unsigned __int64 PositionInUCHARs | Position in unsigned chars within a file.
void * Buffer | Pointer to data buffer to read file contents to.
unsigned long BufferSizeInUCHARs | Buffer size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function sets file position in unsigned chars to required one and reads requested amounts unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileSizeInUCHARsGet Function

StarBurn_FileSizeInUCHARsGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileSizeInUCHARsGet(
    PSTARBURN_FILE_OBJECT FileObject,
    unsigned __int64 * SizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
unsigned __int64 * SizeInUCHARs | Pointer to file size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function gets file size in unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileUnicodeCreate Function

StarBurn_FileUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileUnicodeCreate(
    PSTARBURN_FILE_OBJECT FileObject,
    const unsigned short * UnicodePathName
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const unsigned short * UnicodePathName | Pointer to UNICODE file path and name.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates new file from the passed UNICODE file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileUnicodeOpen Function

StarBurn_FileUnicodeOpen Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileUnicodeOpen(
    PSTARBURN_FILE_OBJECT FileObject,
    const unsigned short * UnicodePathName
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const unsigned short * UnicodePathName | Pointer to UNICODE file path and name.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function opens existing file from the passed UNICODE file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileUnicodeOpenEx Function

StarBurn_FileUnicodeOpenEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileUnicodeOpenEx(
    PSTARBURN_FILE_OBJECT FileObject,
    const unsigned short * UnicodePathName,
    BOOL IsWrite
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to preallocated file object.
const unsigned short * UnicodePathName | Pointer to UNICODE file path and name.
BOOL IsWrite | Is write access required.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function opens existing file from the passed UNICODE file path and name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FileWrite Function

StarBurn_FileWrite Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_FileWrite(
    PSTARBURN_FILE_OBJECT FileObject,
    const void * Buffer,
    unsigned long BufferSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
PSTARBURN_FILE_OBJECT FileObject | Pointer to file object.
const void * Buffer | Pointer to data buffer to write to file.
unsigned long BufferSizeInUCHARs | Buffer size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function writes asked amount of unsigned chars to file at current seek position

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_FindDevice Function

StarBurn_FindDevice Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_FindDevice(
    IN UCHAR p__UCHAR__DeviceType,
    IN BOOLEAN p__BOOLEAN__IsFindFirst,
    IN PCALLBACK p__CALLBACK,
    IN PVOID p__PVOID__CallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
IN UCHAR p__UCHAR__DeviceType | SCSI device type to find
IN BOOLEAN p__BOOLEAN__IsFindFirst | TRUE if the function will return after locating first device, FALSE to process all the devices.
IN PVOID p__PVOID__CallbackContext | Callback context that will be passed as second parameter into call to p__PCALLBACK.
p__PCALLBACK | Callback function that will be called with FIND_DEVICE CALLBACK_NUMBER, callback context and adapter ID and Target ID of the device.
Returns

Number of devices found. If zero - nothing was found.

Description

This function finds device of the specified device type.

Remarks

Please see the FindDevice sample that will demonstrate how to find CD/DVD/Blu-Ray/HD-DVD devices installed in the system.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION

Example

This example finds first first CD/DVD/Blu-Ray/HD-DVD device, allocates CdvdBurnerGrabber object, and destroys the device object after it's not needed any more.

VOID
__stdcall
Find_Callback(
    IN CALLBACK_NUMBER p__CALLBACK_NUMBER,
    IN PVOID p__PVOID__CallbackContext,
    IN PVOID p__PVOID__CallbackSpecial1,
    IN PVOID p__PVOID__CallbackSpecial2
    )
{

PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on passed address (bus ID is always 0 in case of ASPI and LUN cannot be probed so
// always 0 as well) with 32MB of cache)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    ( UCHAR )( p__PVOID__CallbackSpecial1) ,
    0,
    ( UCHAR )( p__PVOID__CallbackSpecial2) ,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}

}

// Somewhere in the code

// Try to find device
if (
StarBurn_FindDevice(
    SCSI_DEVICE_RO_DIRECT_ACCESS,
    TRUE,
    ( PCALLBACK )( Find_Callback ),
    NULL
    ) == 0
)
{
// Handle error here...
}
else
{
// All actions are in the callback function...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARs Function

StarBurn_GetAudioFileStreamSizeInUCHARs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetAudioFileStreamSizeInUCHARs(
    IN PCHAR p__PCHAR__AudioFilePathAndName,
    OUT PLONG p__PLONG__StreamSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__AudioFilePathAndName | Pointer to full path and name of supported audio file.
OUT PLONG p__PLONG__StreamSizeInUCHARs | Pointer to the variable to receive audio stream size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error (if function would return EN_SYSTEM_CALL_FAILED).
Returns

Execution status.

Description

This function returns audio stream size in UCHARs for passed supported as source audio file.

Remarks

This call is nearly obsolete and supported only for legacy software. It's *STRONGLY* recommended to use StarWave API calls to deal with compressed and uncompressed audio streams.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_GetAudioFileStreamSizeInUCHARs_Fast

Example

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARs_Fast Function

StarBurn_GetAudioFileStreamSizeInUCHARs_Fast Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetAudioFileStreamSizeInUCHARs_Fast(
    IN PCHAR p__PCHAR__AudioFilePathAndName,
    OUT PLONG p__PLONG__StreamSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__AudioFilePathAndName | Pointer to full path and name of supported audio file.
OUT PLONG p__PLONG__StreamSizeInUCHARs | Pointer to the variable to receive audio stream size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error (if function would return EN_SYSTEM_CALL_FAILED).
Returns

Execution status.

Description

This function returns audio stream size in UCHARs for passed supported as source audio file.

Remarks

This call is nearly obsolete and supported only for legacy software. It's *STRONGLY* recommended to use StarWave API calls to deal with compressed and uncompressed audio streams.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_GetAudioFileStreamSizeInUCHARs

Example

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast Function

StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast(
    IN PWCHAR p__PWCHAR__AudioFilePathAndName,
    OUT PLONG p__PLONG__StreamSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Description

This is function StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARsUnicode Function

StarBurn_GetAudioFileStreamSizeInUCHARsUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetAudioFileStreamSizeInUCHARsUnicode(
    IN PWCHAR p__PWCHAR__AudioFilePathAndName,
    OUT PLONG p__PLONG__StreamSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Description

This is function StarBurn_GetAudioFileStreamSizeInUCHARsUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetBufferUnderrunTimeOutInMs Function

StarBurn_GetBufferUnderrunTimeOutInMs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_GetBufferUnderrunTimeOutInMs(
    IN VOID
);
File

StarBurn.h

Returns

Buffer underrun timeout in milliseconds.

Description

This function returns buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.

Remarks

Having large timeout would allow StarBurn to grab more information into software cache, at the same time having timeout small and disc burning speed MUCH faster then reading speed from the source media (say slow hard disk or network) would produce a lot of BUP errors, start-stop cycles and resulting recorded disc quality would be very low. In general it's a good idea not to touch buffer underrun timeout value at all and keep everything AS IS. It's value for "hardcore tuning".

See Also

StarBurn_SetBufferUnderrunTimeOutInMs

Example

There are no samples for StarBurn_GetBufferUnderrunTimeOutInMs(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDeviceLetter Function

StarBurn_GetDeviceLetter Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetDeviceLetter(
    IN PCHAR p__PCHAR__DeviceName,
    OUT PCHAR p__PCHAR__DeviceLetter,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__DeviceName | Device name to return the letter for.
OUT PCHAR p__PCHAR__DeviceLetter | Buffer to receive device root path.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function returns device letter (device root path) for a device name, like the one used in StarBurn_CdvdBurnerGrabber_CreateEx(...) API call.

See Also

StarBurn_CdvdBurnerGrabber_CreateEx.

Example

Please see GUI samples as example how to use StarBurn_GetDeviceLetter API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDeviceLetterUnicode Function

StarBurn_GetDeviceLetterUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetDeviceLetterUnicode(
    IN PWCHAR p__PCHAR__DeviceName,
    OUT PWCHAR p__PCHAR__DeviceLetter,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Description

This is function StarBurn_GetDeviceLetterUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDeviceNameByDeviceAddress Function

StarBurn_GetDeviceNameByDeviceAddress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetDeviceNameByDeviceAddress(
    IN UCHAR p__UCHAR__DevicePort,
    IN UCHAR p__UCHAR__DeviceBus,
    IN UCHAR p__UCHAR__DeviceID,
    IN UCHAR p__UCHAR__DeviceLUN,
    OUT PCHAR p__PCHAR__DeviceName
);
File

StarBurn.h

Parameters
Parameters | Description
IN UCHAR p__UCHAR__DevicePort | Device port.
IN UCHAR p__UCHAR__DeviceBus | Device bus.
IN UCHAR p__UCHAR__DeviceID | Device ID.
IN UCHAR p__UCHAR__DeviceLUN | Device LUN.
OUT PCHAR p__PCHAR__DeviceName | Pointer to the buffer device name will be copied to.
Returns

Execution status. EN_SUCCESS if device name was located by device address.

Description

This function gets device name by device address.

Remarks

Good idea is to fill the device name with zeros before submitting it to this function. Buffer must be large enough to hold all the device name.

See Also

StarBurn_GetVersion, StarBurn_CdvdBurnerGrabber_Create

Example

This example gets device name by device address.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
CHAR l__CHAR__DeviceName[ MAX_PATH ];

// Prepare device name
RtlZeroMemory(
    &l__CHAR__DeviceName,
    sizeof( l__CHAR__DeviceName )
    );

// Try to get device name by device address 0:0:1:0
l__EXCEPTION_NUMBER =
StarBurn_GetDeviceNameByDeviceAddress(
    0,
    1,
    0,
    0,
    ( PCHAR )( &l__CHAR__DeviceName )
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with device name here...
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDeviceTimeOutByDeviceAddress Function

StarBurn_GetDeviceTimeOutByDeviceAddress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetDeviceTimeOutByDeviceAddress(
    IN UCHAR p__UCHAR__DevicePort,
    IN UCHAR p__UCHAR__DeviceBus,
    IN UCHAR p__UCHAR__DeviceID,
    IN UCHAR p__UCHAR__DeviceLUN,
    OUT PULONG p__PULONG__DeviceTimeOutInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN UCHAR p__UCHAR__DevicePort | Device port.
IN UCHAR p__UCHAR__DeviceBus | Device SCSI bus.
IN UCHAR p__UCHAR__DeviceID | Device SCSI ID.
IN UCHAR p__UCHAR__DeviceLUN | Device LUN.
OUT PULONG p__PULONG__DeviceTimeOutInSeconds | Pointer to the variable to receive device timeout in seconds.
Returns

Execution status.

Description

This function gets device timeout in seconds by device SCSI address.

Remarks

This one is for ASPI devices only.

See Also

StarBurn_SetDeviceTimeOutByDeviceAddress

Example

Please see FindDevice sample as example how to use StarBurn_GetDeviceTimeOutByDeviceAddress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDVDPadding Function

StarBurn_GetDVDPadding Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetDVDPadding(
    IN VOID
);
File

StarBurn.h

Returns

Is DVD padding mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) enabled (TRUE) or disabled (FALSE).

Remarks

"Padding mode" should be always enabled for DVD-Video compilations (or resulting disc would not be playable on standalone DVD players) and should be always disabled for generic data discs (or quite a lot of disc capacity would be simply wasted).

See Also

StarBurn_SetDVDPadding

Example

There are no examples for StarBurn_GetDVDPadding(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDVDPLUSRDLCompatibleMode Function

StarBurn_GetDVDPLUSRDLCompatibleMode Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetDVDPLUSRDLCompatibleMode(
    IN VOID
);
File

StarBurn.h

Returns

Is DVD+R DL compatible mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) enabled (TRUE) or disabled (FALSE).

Remarks

"Compatible mode" should be always enabled for DVD-Video compilations (or resulting disc would not be playable on standalone DVD players) and should be always disabled for generic data discs (or quite a lot of disc capacity would be simply wasted).

See Also

StarBurn_SetDVDPLUSRDLCompatibleMode

Example

There are no examples for StarBurn_GetDVDPLUSRDLCompatibleMode(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetEjectAfterFail Function

StarBurn_GetEjectAfterFail Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetEjectAfterFail(
    IN VOID
);
File

StarBurn.h

Returns

Is "eject after fail" mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) enabled (TRUE) or disabled (FALSE).

Remarks

It's a good idea to keep everything AS IS, however if StarBurn is used with automatic loaders or whatever sometimes it's required to keep manual control over eject process.

See Also

StarBurn_SetEjectAfterFail

Example

There are no examples for StarBurn_GetEjectAfterFail(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetFastReadTOC Function

StarBurn_GetFastReadTOC Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetFastReadTOC(
    IN VOID
);
File

StarBurn.h

Returns

Is "fast read TOC" mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn trys to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode enabled (TRUE) or disabled (FALSE).

Remarks

It's a good idea to keep everything AS IS, however if StarBurn takes a lot of time to analyze the disc (it can happen when drive hardware error correction cannot be disabled and reading pre-gap and post-gap of the track is DOG SLOW) "fast read TOC" could be switched ON.

See Also

StarBurn_SetFastReadTOC

Example

Please see GrabTrack sample no how to use StarBurn_GetFastReadTOC(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetId Function

StarBurn_GetId Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_GetId(
    OUT PULONG p__PULONG__SystemError,
    OUT PULONG p__PULONG__Version,
    OUT PCHAR p__PCHAR__VersionText,
    IN ULONG p__ULONG__VersionTextSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PULONG p__PULONG__SystemError | Pointer to system error value (if function would return EN_SYSTEM_CALL_FAILED).
OUT PULONG p__PULONG__Version | Pointer to the variable to receive ASPI layer version number.
OUT PCHAR p__PCHAR__VersionText | Pointer to the buffer to receive ASPI layer version text.
IN ULONG p__ULONG__VersionTextSizeInUCHARs | Version text buffer size in UCHARs.
Returns

Execution status.

Description

This function gets ASPI layer ID strings.

Remarks

This one is for Rocket Division Software ASPI layer only.

See Also

There are no companion API calls for this one.

Example

Please see FindDevice sample as example how to use StarBurn_GetId API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetIs64KBIO Function

StarBurn_GetIs64KBIO Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetIs64KBIO(
    IN VOID
);
File

StarBurn.h

Returns

Is "64KB I/O" mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) currently enabled (TRUE) or disabled (FALSE).

Remarks

There's no need to play with this parameter unless you really have broken device you will to force 32KB I/O requests for.

See Also

StarBurn_SetIs64KBIO

Example

There are no examples for StarBurn_GetIs64KBIO(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetIsCollisionDetectionDisabled Function

StarBurn_GetIsCollisionDetectionDisabled Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetIsCollisionDetectionDisabled(
    IN VOID
);
File

StarBurn.h

Returns

Is collision detection mode disabled (TRUE) or enabled (FALSE).

Description

This function returns is collision detection disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.

Remarks

If new image is created from the content stored on the hard disk - there's no way for file names to be the same. So file system image creation process could be speed up quite a lot by turning collision detection OFF (especially if there are a lot of files inside each directory). In other cases it's not recommended to play with this option.

See Also

StarBurn_SetIsCollisionDetectionDisabled

Example

Please see BuildImage sample to find out how collision detection could be disabled and enabled during file system image creation.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetIsSafeGrabbingEnabled Function

StarBurn_GetIsSafeGrabbingEnabled Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_GetIsSafeGrabbingEnabled(
    IN VOID
);
File

StarBurn.h

Returns

Is "safe grabbing" mode enabled (TRUE) or disabled (FALSE).

Description

This function returns is so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) enabled (TRUE) or disabled (FALSE).

Remarks

There's no need to play with this parameter unless you really have ATAPI device in external USB enclosure and it hangs under heavy I/O load.

See Also

StarBurn_SetIsSafeGrabbingEnabled

Example

There are no examples for StarBurn_GetIsSafeGrabbingEnabled(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetVersion Function

StarBurn_GetVersion Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_GetVersion(
    IN VOID
);
File

StarBurn.h

Returns

ULONG with the packed date. This function cannot fail.

Description

This function returns a 32-bit unsigned long value that contains packed numbers that represent the year, the month and the date of the toolkit build. So 10th of March, year of 1978 will look like 0x19780310.

Remarks

Actually it's a good idea to check for supported toolkit version before performing any actions.

See Also

Samples for more details about differences between newer and older toolkit versions.

Example

This example checks for the toolkit version.

// Somewhere in the data region
ULONG l__ULONG__Version;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetVolumeIDs Function

StarBurn_GetVolumeIDs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_GetVolumeIDs(
    IN PCHAR p__PCHAR__VolumeName,
    OUT PCHAR p__PCHAR__VolumeID
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__VolumeName | ISO9660/Joliet name we'd like to query.
OUT PCHAR p__PCHAR__VolumeID | Pointer to destination buffer volume ID would be copied to.
Returns

Execution status.

Description

This function gets volume ID from ISO9660/Joliet volume name.

Remarks

This one is for ISO9660/Joliet volumes only.

See Also

There are no companion API calls for this one.

Example

Please see BuildImageWithImportFromFile sample as example how to use StarBurn_GetVolumeIDs API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ImageFile_UDFFileSystemLookup Function

StarBurn_ImageFile_UDFFileSystemLookup Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ImageFile_UDFFileSystemLookup(
    IN PCHAR p__PCHAR__ISOFileName,
    IN PCALLBACK p__Callback,
    IN PVOID p__CallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__ISOFileName | File name of the file to parse.
p__PCALLBACK_Callback | Pointer to callback function that receives information about found files.
p__PVOID_CallbackContext | Callback context.
Returns

Execution status.

Description

This function parses the UDF file system inside image file and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.

Remarks

Information that is passed to callback function should be copied and stored on client side. Strings may not be valid outside callback function.

Example

Please see UDFLookupISO sample as example how to use StarBurn_ImageFile_UDFFileSystemLookup API call.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ImageFile_UDFFileSystemLookupEx Function

StarBurn_ImageFile_UDFFileSystemLookupEx Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ImageFile_UDFFileSystemLookupEx(
    IN PCHAR p__PCHAR__ISOFileName,
    IN PCALLBACK p__Callback,
    IN PVOID p__CallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__ISOFileName | File name of the file to parse.
p__PCALLBACK_Callback | Pointer to callback function that receives information about found files.
p__PVOID_CallbackContext | Callback context.
Returns

Execution status.

Description

This function parses the UDF file system inside image file and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.

Remarks

Information that is passed to callback function should be copied and stored on client side. Strings may not be valid outside callback function.

Example

Please see UDFLookupISO sample as example how to use StarBurn_ImageFile_UDFFileSystemLookup API call.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_IsAudioFileSupported Function

StarBurn_IsAudioFileSupported Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_IsAudioFileSupported(
    IN LPCSTR p__PCHAR__AudioFilePathAndName
);
File

StarBurn.h

Parameters
Parameters | Description
IN LPCSTR p__PCHAR__AudioFilePathAndName | Pointer to full path and name of "suspected" audio file.
Returns

Execution status.

Description

This function returns is currently passed file supported as source audio file.

Remarks

This call is nearly obsolete and supported only for legacy software. It's *STRONGLY* recommended to use StarWave API calls to deal with compressed and uncompressed audio streams (StarBurn_StarWave_UncompressedFileSupportedIs and of course it's companion StarBurn_StarWave_CompressedFileSupportedIs).

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs

Example

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_IsAudioFileSupportedUnicode Function

StarBurn_IsAudioFileSupportedUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_IsAudioFileSupportedUnicode(
    IN LPCWSTR p__PWCHAR__AudioFilePathAndName
);
File

StarBurn.h

Description

This is function StarBurn_IsAudioFileSupportedUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_IsLocalDateTimeUsed Function

StarBurn_IsLocalDateTimeUsed Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_IsLocalDateTimeUsed();
File

StarBurn.h

Description

This is function StarBurn_IsLocalDateTimeUsed.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_Check1999Name Function

StarBurn_ISO2_Check1999Name Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_Check1999Name(
    const char* Name,
    BOOL bIsDirectory
);
File

StarBurn.h

Parameters
Parameters | Description
const char* Name | Pointer to zero terminated string with file or directory name.
BOOL bIsDirectory | TRUE - check directory name, FALSE - check file name.
Returns

TRUE if given string is a valid ISO9660:1999 file/directory name. FALSE otherwise.

Description

This function checks if given string valid ISO9660:1999 file (or directory) name

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_CheckJolietName Function

StarBurn_ISO2_CheckJolietName Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_CheckJolietName(
    const unsigned short* UnicodeName,
    BOOL bIsDirectory
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodeName | Pointer to zero terminated string (Unicode) with file or directory name.
BOOL bIsDirectory | TRUE - check directory name, FALSE - check file name.
Returns

TRUE if given string is a valid ISO9660 Joliet file/directory name. FALSE otherwise.

Description

This function checks if given string valid ISO9660 Joliet file (or directory) name

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_CheckLevel1Name Function

StarBurn_ISO2_CheckLevel1Name Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_CheckLevel1Name(
    const char* Name,
    BOOL bIsDirectory
);
File

StarBurn.h

Parameters
Parameters | Description
const char* Name | Pointer to zero terminated string with file or directory name.
BOOL bIsDirectory | TRUE - check directory name, FALSE - check file name.
Returns

TRUE if given string is a valid ISO9660 Level 1 file/directory name. FALSE otherwise.

Description

This function checks if given string valid ISO9660 Level 1 file (or directory) name

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_CheckLevel2Name Function

StarBurn_ISO2_CheckLevel2Name Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_CheckLevel2Name(
    const char* Name,
    BOOL bIsDirectory
);
File

StarBurn.h

Parameters
Parameters | Description
const char* Name | Pointer to zero terminated string with file or directory name.
BOOL bIsDirectory | TRUE - check directory name, FALSE - check file name.
Returns

TRUE if given string is a valid ISO9660 Level 2 file/directory name. FALSE otherwise.

Description

This function checks if given string valid ISO9660 Level 2 file (or directory) name

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_CheckRelaxedJolietName Function

StarBurn_ISO2_CheckRelaxedJolietName Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_CheckRelaxedJolietName(
    const unsigned short* UnicodeName,
    BOOL bIsDirectory
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodeName | Pointer to zero terminated string (Unicode) with file or directory name.
BOOL bIsDirectory | TRUE - check directory name, FALSE - check file name.
Returns

TRUE if given string is a valid ISO9660 Joliet file/directory name. FALSE otherwise.

Description

This function checks if given string valid ISO9660 Joliet file (or directory) name

with less restrictions: names may contain more than one dot.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_CreateNewName Function

StarBurn_ISO2_CreateNewName Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_ISO2_CreateNewName(
    char* Name,
    unsigned long Seed
);
File

StarBurn.h

Parameters
Parameters | Description
char* Name | Pointer to zero terminated string (ANSI) with file or directory name.
unsigned long Seed | Number that is added to file name.
Returns

TRUE if file name modified successfully. FALSE otherwise.

Description

This function creates new ANSI name by adding ~XX (where XX is a number (Seed)) at the end of file name.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryBrowse Function

StarBurn_ISO2_DirectoryBrowse Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void * StarBurn_ISO2_DirectoryBrowse(
    void * Directory,
    void * Last
);
File

StarBurn.h

Parameters
Parameters | Description
void * Directory | Pointer to ISO9660 directory object.
void * Last | Pointer to last processed kid node (or NULL if we need first kid node in the kids list).
Returns

Pointer to currently processed kid node (or NULL if we've reached end of the kids list).

Description

This function browses ISO9660 directory content.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryCreate Function

StarBurn_ISO2_DirectoryCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_DirectoryCreate(
    void ** Directory,
    const char * Name,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
const char * Name | Pointer to zero-terminated directory name.
unsigned long GUID | GUID value.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryDestroy Function

StarBurn_ISO2_DirectoryDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_DirectoryDestroy(
    void * Directory
);
File

StarBurn.h

Parameters
Parameters | Description
void * Directory | Pointer to directory object to destroy.
Returns

Nothing

Description

This function destroys created ISO9660 directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryProcess Function

StarBurn_ISO2_DirectoryProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_DirectoryProcess(
    PVOID * NewDir,
    const char * Name,
    const unsigned short * UnicodePathName,
    unsigned long * GUID,
    void * Parent,
    PSTARBURN_ISO2_PROGRESS_CALLBACK ProgressCallback,
    PVOID ProgressCallbackContext,
    PSTARBURN_ISO2_COLLISION_CALLBACK CollisionCallback,
    PVOID CollisionCallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
const char * Name | Directory name itself (zero-terminated string).
const unsigned short * UnicodePathName | Directory path and name (zero-terminated Unicode string).
unsigned long * GUID | GUID value
void * Parent | Pointer to parent directory.
PSTARBURN_ISO2_PROGRESS_CALLBACK ProgressCallback | Callback function that is called on addition of file/directory
PVOID ProgressCallbackContext | Callback context passed to ProgressCallback
PSTARBURN_ISO2_COLLISION_CALLBACK CollisionCallback | Callback function that is called on name collision
PVOID CollisionCallbackContext | Callback context passed to CollisionCallback
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single ISO9660 directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryQuery Function

StarBurn_ISO2_DirectoryQuery Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_DirectoryQuery(
    void * Directory,
    STARBURN_ISO9660_DIRECTORY_INFO * Info
);
File

StarBurn.h

Parameters
Parameters | Description
STARBURN_ISO9660_DIRECTORY_INFO * Info | Pointer to ISO9660 directory information structure.
File | Pointer to ISO9660 directory object.
Returns

Nothing

Description

This function do query for ISO9660 file properties.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryRootCreate Function

StarBurn_ISO2_DirectoryRootCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_DirectoryRootCreate(
    void ** Directory,
    unsigned long GUID,
    unsigned char Type
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
unsigned long GUID | GUID value
unsigned char Type | Type of created tree.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates root ISO9660 directory.

Remarks

Type can be one of the following values:

STARBURN_ISO9660_TYPE_LEVEL1 - ISO 9660 Level 1

STARBURN_ISO9660_TYPE_LEVEL2 - ISO 9660 Level 2

STARBURN_ISO9660_TYPE_1999 - ISO 9660:1990

STARBURN_ISO9660_TYPE_JOLIET - ISO 9660 with Joliet extension

STARBURN_ISO9660_TYPE_JOLIET_RELAXED - ISO 9660 with Joliet extension (less restrictions)

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryUnicodeCreate Function

StarBurn_ISO2_DirectoryUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_DirectoryUnicodeCreate(
    void ** Directory,
    const unsigned short * UnicodeName,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
const unsigned short * UnicodeName | Pointer to zero-terminated directory name (UNICODE format).
unsigned long GUID | GUID value.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE ISO9660 directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_DirectoryUnicodeProcess Function

StarBurn_ISO2_DirectoryUnicodeProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_DirectoryUnicodeProcess(
    PVOID * NewDir,
    const unsigned short * UnicodeName,
    const unsigned short * UnicodePathName,
    unsigned long * GUID,
    void * Parent,
    PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK ProgressUnicodeCallback,
    PVOID ProgressCallbackContext,
    PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK CollisionUnicodeCallback,
    PVOID CollisionCallbackContext
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short * UnicodeName | Directory name itself (zero-terminated string in UNICODE format).
const unsigned short * UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long * GUID | GUID value
void * Parent | Pointer to parent directory.
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK ProgressUnicodeCallback | Callback function that is called on addition of file/directory
PVOID ProgressCallbackContext | Callback context passed to ProgressCallback
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK CollisionUnicodeCallback | Callback function that is called on name collision
PVOID CollisionCallbackContext | Callback context passed to CollisionCallback
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UNICODE ISO9660 directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileCreate Function

StarBurn_ISO2_FileCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileCreate(
    void ** File,
    const char * Name,
    const unsigned short * UnicodePathName,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const char * Name | Pointer to zero-terminated name.
const unsigned short * UnicodePathName | Pointer to zero-terminated path and name (Unicode format).
unsigned long GUID | GUID value
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileDestroy Function

StarBurn_ISO2_FileDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_FileDestroy(
    void * File
);
File

StarBurn.h

Parameters
Parameters | Description
void * File | Pointer to file object to destroy.
Returns

Nothing

Description

This function destroys created ISO9660 file object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileDirectoryDateTimeGet Function

StarBurn_ISO2_FileDirectoryDateTimeGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileDirectoryDateTimeGet(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to output file date and time.
Returns

Operation status

Description

This function gets date and time from created ISO9660 file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileDirectoryDateTimeSet Function

StarBurn_ISO2_FileDirectoryDateTimeSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileDirectoryDateTimeSet(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to input file date and time.
Returns

Nothing

Description

This function sets date and time on created ISO9660 file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileDirectoryNameSet Function

StarBurn_ISO2_FileDirectoryNameSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileDirectoryNameSet(
    void * FileDirectory,
    const char * Name
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to ISO9660 file or directory object.
const char * Name | Pointer to new file or directory name.
Returns

Operation status

Description

This function set new name for ISO9660 file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileDirectoryUnicodeNameSet Function

StarBurn_ISO2_FileDirectoryUnicodeNameSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileDirectoryUnicodeNameSet(
    void * FileDirectory,
    const unsigned short * UnicodeName
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to ISO9660 file or directory object.
const unsigned short * UnicodeName | Pointer to new file or directory UNICODE name.
Returns

Nothing

Description

This function set new UNICODE name for ISO9660 file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileMemoryCreate Function

StarBurn_ISO2_FileMemoryCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileMemoryCreate(
    void ** File,
    const char * Name,
    void * MemoryRegion,
    unsigned long MemoryRegionSizeInUCHARs,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const char * Name | Pointer to zero-terminated name.
void * MemoryRegion | Pointer to memory region containing file contents.
unsigned long MemoryRegionSizeInUCHARs | Memory region size in unsigned chars.
unsigned long GUID | GUID value
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 memory file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileMemoryUnicodeCreate Function

StarBurn_ISO2_FileMemoryUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileMemoryUnicodeCreate(
    void ** File,
    const unsigned short * UnicodeName,
    void * MemoryRegion,
    unsigned long MemoryRegionSizeInUCHARs,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const unsigned short * UnicodeName | Pointer to zero-terminated name (Unicode).
void * MemoryRegion | Pointer to memory region containing file contents.
unsigned long MemoryRegionSizeInUCHARs | Memory region size in unsigned chars.
unsigned long GUID | GUID value
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates Unicode ISO9660 memory file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileQuery Function

StarBurn_ISO2_FileQuery Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_FileQuery(
    void * File,
    STARBURN_ISO9660_FILE_INFO * Info
);
File

StarBurn.h

Parameters
Parameters | Description
void * File | Pointer to ISO9660 file object.
STARBURN_ISO9660_FILE_INFO * Info | Pointer to ISO9660 file information structure.
Returns

Nothing

Description

This function do query for ISO9660 file properties.

Remarks

Some structure fields are valid only for imported or non-imported nodes. Refer to structure description.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileSetAttributes Function

StarBurn_ISO2_FileSetAttributes Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_FileSetAttributes(
    void* File,
    unsigned long Attributes
);
File

StarBurn.h

Parameters
Parameters | Description
void* File | Pointer to ISO9660 file object.
unsigned long Attributes | File attributes bit mask.
Returns

Nothing.

Description

This function sets attributes for ISO9660 file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_FileUnicodeCreate Function

StarBurn_ISO2_FileUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_FileUnicodeCreate(
    void ** File,
    const unsigned short * UnicodeName,
    const unsigned short * UnicodePathName,
    unsigned long GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const unsigned short * UnicodeName | Pointer to zero-terminated name (UNICODE format).
const unsigned short * UnicodePathName | Pointer to zero-terminated path and name (UNICODE format).
unsigned long GUID | GUID value
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE ISO9660 file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_ImpVolumeCreate Function

StarBurn_ISO2_ImpVolumeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_ImpVolumeCreate(
    void ** Volume,
    void * Root,
    unsigned long * GUID,
    PSTARBURN_ISO9660_READ_CALLBACK ImportCallback,
    void * CallbackContext,
    unsigned long VolumeBeginLBA,
    PSTARBURN_ISO2_COLLISION_CALLBACK CollisionCallback,
    const void * CollisionContext,
    PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK UnicodeCollisionCallback,
    const void * UnicodeCollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to ISO9660 import volume object.
void * Root | Pointer to directory where contents should be added. Pointer to root directory.
unsigned long * GUID | GUID value GUID value
PSTARBURN_ISO9660_READ_CALLBACK ImportCallback | Pointer to import callback.
void * CallbackContext | Pointer to callback context.
PSTARBURN_ISO2_COLLISION_CALLBACK CollisionCallback | Callback function for name collisions handling (for ANSI names).
const void * CollisionContext | User context for CollisionCallback.
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK UnicodeCollisionCallback | Callback function for name collisions handling (for Unicode names).
const void * UnicodeCollisionContext | User context for UnicodeCollisionCallback.
UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
Callback | Pointer to ISO9660 UNICODE progress callback.
Context | Pointer to context value.
DateTime | Pointer to date and time structure.
VolumeSizeInLBs | Volume size in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

STARBURN_IMPEX_API

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes contents of single UNICODE ISO9660 directory.

__stdcall StarBurn_ISO2_DirectoryContentsUnicodeProcess( const unsigned short *UnicodePathName, unsigned long *GUID, void *Root, PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Callback, const void *Context, STARBURN_ISO2_FILE_DATE_TIME *DateTime );

This function creates ISO9660 import volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_ImpVolumeDestroy Function

StarBurn_ISO2_ImpVolumeDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_ImpVolumeDestroy(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to ISO9660 import volume object to destroy.
Returns

Nothing.

Description

This function destroys created ISO9660 import volume object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_ImpVolumeImport Function

StarBurn_ISO2_ImpVolumeImport Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_ImpVolumeImport(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to the ISO9660 import volume object.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function imports ISO9660 import volume content.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_ISO9660FileTreeCreate Function

StarBurn_ISO2_ISO9660FileTreeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_ISO9660FileTreeCreate(
    void ** ISO9660FileTree,
    void * ISO9660Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void ** ISO9660FileTree | Pointer to pointer to the object that toolkit will set to the ISO 9660 File Tree object it will allocate.
void * ISO9660Volume | Pointer to ISO9660 volume object that toolkit allocated before.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function create ISO image from already created ISO9660 volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreate Function

StarBurn_ISO2_VolumeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreate(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const char * SystemIdentifier | Pointer to zero-terminated string with system identifier.
const char * VolumeSetIdentifier | Pointer to zero-terminated string with volume set identifier.
const char * PublisherIdentifier | Pointer to zero-terminated string with publisher identifier.
const char * DataPreparerIdentifier | Pointer to zero-terminated string with data preparer identifier.
const char * ApplicationIdentifier | Pointer to zero-terminated string with application identifier.
const char * CopyrightFileIdentifier | Pointer to zero-terminated string with copyright file identifier.
const char * AbstractFileIdentifier | Pointer to zero-terminated string with abstract file identifier.
const char * BibliographicFileIdentifier | Pointer to zero-terminated string with bibliographic file identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateBoot Function

StarBurn_ISO2_VolumeCreateBoot Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateBoot(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const unsigned short * BootImageFileName,
    unsigned char EmulationType,
    unsigned short SectorsToLoad,
    unsigned short LoadSegment,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const unsigned short * BootImageFileName | Pointer to zero-terminated Unicode string with boot image file path.
unsigned char EmulationType | Media type of bootable volume.
unsigned short SectorsToLoad | Number of sectors to load from boot image.
unsigned short LoadSegment | Load segment
const char * SystemIdentifier | Pointer to zero-terminated string with system identifier.
const char * VolumeSetIdentifier | Pointer to zero-terminated string with volume set identifier.
const char * PublisherIdentifier | Pointer to zero-terminated string with publisher identifier.
const char * DataPreparerIdentifier | Pointer to zero-terminated string with data preparer identifier.
const char * ApplicationIdentifier | Pointer to zero-terminated string with application identifier.
const char * CopyrightFileIdentifier | Pointer to zero-terminated string with copyright file identifier.
const char * AbstractFileIdentifier | Pointer to zero-terminated string with abstract file identifier.
const char * BibliographicFileIdentifier | Pointer to zero-terminated string with bibliographic file identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 bootable volume (ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateBootElTorito Function

StarBurn_ISO2_VolumeCreateBootElTorito Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateBootElTorito(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    void * BootCatalog,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
void * BootCatalog | Pointer to ElTorito boot catalog
const char * SystemIdentifier | Pointer to zero-terminated string with system identifier.
const char * VolumeSetIdentifier | Pointer to zero-terminated string with volume set identifier.
const char * PublisherIdentifier | Pointer to zero-terminated string with publisher identifier.
const char * DataPreparerIdentifier | Pointer to zero-terminated string with data preparer identifier.
const char * ApplicationIdentifier | Pointer to zero-terminated string with application identifier.
const char * CopyrightFileIdentifier | Pointer to zero-terminated string with copyright file identifier.
const char * AbstractFileIdentifier | Pointer to zero-terminated string with abstract file identifier.
const char * BibliographicFileIdentifier | Pointer to zero-terminated string with bibliographic file identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 bootable volume (ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateEx Function

StarBurn_ISO2_VolumeCreateEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateEx(
    void ** Volume,
    void * Root,
    const char * Name,
    const unsigned short * UnicodeName,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier,
    const unsigned short * UnicodeSystemIdentifier,
    const unsigned short * UnicodeVolumeSetIdentifier,
    const unsigned short * UnicodePublisherIdentifier,
    const unsigned short * UnicodeDataPreparerIdentifier,
    const unsigned short * UnicodeApplicationIdentifier,
    const unsigned short * UnicodeCopyrightFileIdentifier,
    const unsigned short * UnicodeAbstractFileIdentifier,
    const unsigned short * UnicodeBibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
const unsigned short * UnicodeName | Pointer to zero-terminated string with volume name (in UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const char * SystemIdentifier | Pointer to zero-terminated string with system identifier.
const char * VolumeSetIdentifier | Pointer to zero-terminated string with volume set identifier.
const char * PublisherIdentifier | Pointer to zero-terminated string with publisher identifier.
const char * DataPreparerIdentifier | Pointer to zero-terminated string with data preparer identifier.
const char * ApplicationIdentifier | Pointer to zero-terminated string with application identifier.
const char * CopyrightFileIdentifier | Pointer to zero-terminated string with copyright file identifier.
const char * AbstractFileIdentifier | Pointer to zero-terminated string with abstract file identifier.
const char * BibliographicFileIdentifier | Pointer to zero-terminated string with bibliographic file identifier.
const unsigned short * UnicodeSystemIdentifier | Pointer to zero-terminated Unicode string with system identifier.
const unsigned short * UnicodeVolumeSetIdentifier | Pointer to zero-terminated Unicode string with volume set identifier.
const unsigned short * UnicodePublisherIdentifier | Pointer to zero-terminated Unicode string with publisher identifier.
const unsigned short * UnicodeDataPreparerIdentifier | Pointer to zero-terminated Unicode string with data preparer identifier.
const unsigned short * UnicodeApplicationIdentifier | Pointer to zero-terminated Unicode string with application identifier.
const unsigned short * UnicodeCopyrightFileIdentifier | Pointer to zero-terminated Unicode string with copyright file identifier.
const unsigned short * UnicodeAbstractFileIdentifier | Pointer to zero-terminated Unicode string with abstract file identifier.
const unsigned short * UnicodeBibliographicFileIdentifier | Pointer to zero-terminated Unicode string with bibliographic file identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 volume (with both Unicode and ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateExBoot Function

StarBurn_ISO2_VolumeCreateExBoot Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateExBoot(
    void ** Volume,
    void * Root,
    const char * Name,
    const unsigned short * UnicodeName,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const unsigned short * BootImageFileName,
    unsigned char EmulationType,
    unsigned short SectorsToLoad,
    unsigned short LoadSegment,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier,
    const unsigned short * UnicodeSystemIdentifier,
    const unsigned short * UnicodeVolumeSetIdentifier,
    const unsigned short * UnicodePublisherIdentifier,
    const unsigned short * UnicodeDataPreparerIdentifier,
    const unsigned short * UnicodeApplicationIdentifier,
    const unsigned short * UnicodeCopyrightFileIdentifier,
    const unsigned short * UnicodeAbstractFileIdentifier,
    const unsigned short * UnicodeBibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
const unsigned short * UnicodeName | Pointer to zero-terminated string with volume name (in UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const unsigned short * BootImageFileName | Pointer to zero-terminated Unicode string with boot image file path.
unsigned char EmulationType | Media type of bootable volume.
unsigned short SectorsToLoad | Number of sectors to load from boot image.
unsigned short LoadSegment | Load segment
const char * SystemIdentifier | Pointer to zero-terminated string with system identifier.
const char * VolumeSetIdentifier | Pointer to zero-terminated string with volume set identifier.
const char * PublisherIdentifier | Pointer to zero-terminated string with publisher identifier.
const char * DataPreparerIdentifier | Pointer to zero-terminated string with data preparer identifier.
const char * ApplicationIdentifier | Pointer to zero-terminated string with application identifier.
const char * CopyrightFileIdentifier | Pointer to zero-terminated string with copyright file identifier.
const char * AbstractFileIdentifier | Pointer to zero-terminated string with abstract file identifier.
const char * BibliographicFileIdentifier | Pointer to zero-terminated string with bibliographic file identifier.
const unsigned short * UnicodeVolumeSetIdentifier | Pointer to zero-terminated Unicode string with volume set identifier.
const unsigned short * UnicodePublisherIdentifier | Pointer to zero-terminated Unicode string with publisher identifier.
const unsigned short * UnicodeDataPreparerIdentifier | Pointer to zero-terminated Unicode string with data preparer identifier.
const unsigned short * UnicodeApplicationIdentifier | Pointer to zero-terminated Unicode string with application identifier.
const unsigned short * UnicodeCopyrightFileIdentifier | Pointer to zero-terminated Unicode string with copyright file identifier.
const unsigned short * UnicodeAbstractFileIdentifier | Pointer to zero-terminated Unicode string with abstract file identifier.
const unsigned short * UnicodeBibliographicFileIdentifier | Pointer to zero-terminated Unicode string with bibliographic file identifier.
UnicodeSytemIdentifier | Pointer to zero-terminated Unicode string with system identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 bootable volume (with both Unicode and ANSI names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateUnicode Function

StarBurn_ISO2_VolumeCreateUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateUnicode(
    void ** Volume,
    void * Root,
    const unsigned short * Name,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const unsigned short * SystemIdentifier,
    const unsigned short * VolumeSetIdentifier,
    const unsigned short * PublisherIdentifier,
    const unsigned short * DataPreparerIdentifier,
    const unsigned short * ApplicationIdentifier,
    const unsigned short * CopyrightFileIdentifier,
    const unsigned short * AbstractFileIdentifier,
    const unsigned short * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const unsigned short * Name | Pointer to zero-terminated string with volume name (Volume Identifier).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const unsigned short * SystemIdentifier | Pointer to zero-terminated Unicode string with system identifier.
const unsigned short * VolumeSetIdentifier | Pointer to zero-terminated Unicode string with volume set identifier.
const unsigned short * PublisherIdentifier | Pointer to zero-terminated Unicode string with publisher identifier.
const unsigned short * DataPreparerIdentifier | Pointer to zero-terminated Unicode string with data preparer identifier.
const unsigned short * ApplicationIdentifier | Pointer to zero-terminated Unicode string with application identifier.
const unsigned short * CopyrightFileIdentifier | Pointer to zero-terminated Unicode string with copyright file identifier.
const unsigned short * AbstractFileIdentifier | Pointer to zero-terminated Unicode string with abstract file identifier.
const unsigned short * BibliographicFileIdentifier | Pointer to zero-terminated Unicode string with bibliographic file identifier.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateUnicodeBoot Function

StarBurn_ISO2_VolumeCreateUnicodeBoot Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateUnicodeBoot(
    void ** Volume,
    void * Root,
    const unsigned short * UnicodeName,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    const unsigned short * BootImageFileName,
    unsigned char EmulationType,
    unsigned short SectorsToLoad,
    unsigned short LoadSegment,
    const unsigned short * SystemIdentifier,
    const unsigned short * VolumeSetIdentifier,
    const unsigned short * PublisherIdentifier,
    const unsigned short * DataPreparerIdentifier,
    const unsigned short * ApplicationIdentifier,
    const unsigned short * CopyrightFileIdentifier,
    const unsigned short * AbstractFileIdentifier,
    const unsigned short * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const unsigned short * UnicodeName | Pointer to zero-terminated Unicode string with volume name.
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
const unsigned short * BootImageFileName | Pointer to zero-terminated Unicode string with boot image file path.
unsigned char EmulationType | Media type of bootable volume.
unsigned short SectorsToLoad | Number of sectors to load from boot image.
unsigned short LoadSegment | Load segment
const unsigned short * SystemIdentifier | Pointer to zero-terminated Unicode string with system identifier.
const unsigned short * VolumeSetIdentifier | Pointer to zero-terminated Unicode string with volume set identifier.
const unsigned short * PublisherIdentifier | Pointer to zero-terminated Unicode string with publisher identifier.
const unsigned short * DataPreparerIdentifier | Pointer to zero-terminated Unicode string with data preparer identifier.
const unsigned short * ApplicationIdentifier | Pointer to zero-terminated Unicode string with application identifier.
const unsigned short * CopyrightFileIdentifier | Pointer to zero-terminated Unicode string with copyright file identifier.
const unsigned short * AbstractFileIdentifier | Pointer to zero-terminated Unicode string with abstract file identifier.
const unsigned short * BibliographicFileIdentifier | Pointer to zero-terminated Unicode string with bibliographic file identifier.
Name | Pointer to zero-terminated ANSI string with volume name (Volume Identifier).
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 bootable volume (Unicode names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateUnicodeBootElTorito Function

StarBurn_ISO2_VolumeCreateUnicodeBootElTorito Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeCreateUnicodeBootElTorito(
    void ** Volume,
    void * Root,
    const unsigned short * UnicodeName,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned long InitialVolumeSizeInLBs,
    void * BootCatalog,
    const unsigned short * SystemIdentifier,
    const unsigned short * VolumeSetIdentifier,
    const unsigned short * PublisherIdentifier,
    const unsigned short * DataPreparerIdentifier,
    const unsigned short * ApplicationIdentifier,
    const unsigned short * CopyrightFileIdentifier,
    const unsigned short * AbstractFileIdentifier,
    const unsigned short * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const unsigned short * UnicodeName | Pointer to zero-terminated Unicode string with volume name.
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
void * BootCatalog | pointer to ElTorito boot catalog
const unsigned short * SystemIdentifier | Pointer to zero-terminated Unicode string with system identifier.
const unsigned short * VolumeSetIdentifier | Pointer to zero-terminated Unicode string with volume set identifier.
const unsigned short * PublisherIdentifier | Pointer to zero-terminated Unicode string with publisher identifier.
const unsigned short * DataPreparerIdentifier | Pointer to zero-terminated Unicode string with data preparer identifier.
const unsigned short * ApplicationIdentifier | Pointer to zero-terminated Unicode string with application identifier.
const unsigned short * CopyrightFileIdentifier | Pointer to zero-terminated Unicode string with copyright file identifier.
const unsigned short * AbstractFileIdentifier | Pointer to zero-terminated Unicode string with abstract file identifier.
const unsigned short * BibliographicFileIdentifier | Pointer to zero-terminated Unicode string with bibliographic file identifier.
Name | Pointer to zero-terminated ANSI string with volume name (Volume Identifier).
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates ISO9660 bootable volume (Unicode names).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeDescriptorsBufferGet Function

StarBurn_ISO2_VolumeDescriptorsBufferGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeDescriptorsBufferGet(
    void * Volume,
    const unsigned char ** pBuffer,
    unsigned __int64 * SizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
const unsigned char ** pBuffer | Pointer to the variable to receive pointer to ISO9660 volume descriptors buffer.
unsigned __int64 * SizeInUCHARs | Pointer to the variable to receive ISO9660 volume descriptors size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function get ISO9660 volume descriptors buffer.

Remarks

This buffer remains valid only when the volume object is valid.

It is invalidated after call to StarBurn_ISO2_VolumeDestroy().

It should not be freed or altered.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeDestroy Function

StarBurn_ISO2_VolumeDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_ISO2_VolumeDestroy(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to ISO9660 volume object to destroy.
Returns

Nothing

Description

This function destroys created ISO9660 volume object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeSeekRead Function

StarBurn_ISO2_VolumeSeekRead Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeSeekRead(
    void * Volume,
    void * Buffer,
    unsigned long BufferSizeInLogicalBlocks,
    unsigned long OffsetInLogicalBlocks
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
void * Buffer | Pointer to data buffer to read data to.
unsigned long BufferSizeInLogicalBlocks | Buffer size in logical blocks.
unsigned long OffsetInLogicalBlocks | Offset within ISO9660 volume in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function seeks to passed offset and reads requested amount of data.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeSizeInUCHARsGet Function

StarBurn_ISO2_VolumeSizeInUCHARsGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_ISO2_VolumeSizeInUCHARsGet(
    void * Volume,
    unsigned __int64 * SizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
unsigned __int64 * SizeInUCHARs | Pointer to the variable to receive ISO9660 volume size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function get ISO9660 volume size in unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_Add Function

StarBurn_ISO9660JolietFileTree_Add Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_Add(
    OUT PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__RootDirectoryAbsolutePathAndName,
    IN PCHAR p__PCHAR__RootDirectoryNewName,
    IN FILE_TIME p__FILE_TIME,
    IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent,
    OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN PCHAR p__PCHAR__RootDirectoryAbsolutePathAndName | Pointer to directory name to build the ISO9660 or Joliet image from. This parameters can be NULL (but in this case p__PCHAR__RootDirectoryNewName cannot!!!) if virtual (non-present on the disk) directory must be added to the image.
IN PCHAR p__PCHAR__RootDirectoryNewName | Pointer to directory name to be stored in the ISO9660 or Joliet image as root name, NULL to include default name from the previous parameter.
IN FILE_TIME p__FILE_TIME | File time that will be included in file system image (See FILE_TIME).
IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent | Pointer to pointer to the file tree node we'll use as parent. This is the result of either tree walking with StarBurn_ISO9660JolietFileTree_GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). NULL can be passed instead of the result of StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild | Pointer to pointer to the new created file tree node.
Returns

Execution status. EN_SUCCESS if the tree was reallocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to reallocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx

Example

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Add(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_AddEx Function

StarBurn_ISO9660JolietFileTree_AddEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_AddEx(
    OUT PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__RootDirectoryAbsolutePathAndName,
    IN PCHAR p__PCHAR__RootDirectoryNewName,
    IN FILE_TIME p__FILE_TIME,
    IN PFILETIME p__PFILETIME,
    IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent,
    OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN PCHAR p__PCHAR__RootDirectoryAbsolutePathAndName | Pointer to directory name to build the ISO9660 or Joliet image from. This parameters can be NULL (but in this case p__PCHAR__RootDirectoryNewName cannot!!!) if virtual (non-present on the disk) directory must be added to the image.
IN PCHAR p__PCHAR__RootDirectoryNewName | Pointer to directory name to be stored in the ISO9660 or Joliet image as root name, NULL to include default name from the previous parameter.
IN FILE_TIME p__FILE_TIME | File time that will be included in file system image (See FILE_TIME).
IN PFILETIME p__PFILETIME | Pointer to FILETIME structure created node would have.
IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent | Pointer to pointer to the file tree node we'll use as parent. This is the result of either tree walking with StarBurn_ISO9660JolietFileTree_GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). NULL can be passed instead of the result of StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild | Pointer to pointer to the new created file tree node.
Returns

Execution status. EN_SUCCESS if the tree was reallocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to reallocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object and how extended variant of adding call could be used to solve the issue of passing the node with required creation times.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_Add

Example

This example allocates Joliet file tree with required time for root node and destroys the tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;
SYSTEMTIME l__SYSTEMTIME;
FILETIME l__FILETIME;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Format system time here

ZeroMemory(
    &l__SYSTEMTIME,
    sizeof( l__SYSTEMTIME )
    );

l__SYSTEMTIME.wYear = 1991;

l__SYSTEMTIME.wMonth = 3;

l__SYSTEMTIME.wDayOfWeek = 1;

l__SYSTEMTIME.wDay = 1;

l__SYSTEMTIME.wHour = 2;

l__SYSTEMTIME.wMinute = 30;

l__SYSTEMTIME.wSecond = 40;

l__SYSTEMTIME.wMilliseconds = 10;

// Covert system time to file time
SystemTimeToFileTime(
    &l__SYSTEMTIME,
    &l__FILETIME
    );

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddEx(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__FILETIME,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_AddMemory Function

StarBurn_ISO9660JolietFileTree_AddMemory Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_AddMemory(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PUCHAR p__PUCHAR__MemoryRegion,
    IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs,
    IN PCHAR p__PCHAR__Name,
    IN FILE_TIME p__FILE_TIME,
    IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent,
    OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN PUCHAR p__PUCHAR__MemoryRegion | Pointer to memory region to create node from.
IN LARGE_INTEGER p__LARGE_INTEGER__MemoryRegionSizeInUCHARs | Memory region size in UCHARs.
IN FILE_TIME p__FILE_TIME | File time that will be included in file system image (See FILE_TIME).
IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent | Pointer to pointer to the file tree node we'll use as parent. This is the result of either tree walking with StarBurn_ISO9660JolietFileTree_GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). NULL can be passed instead of the result of StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild | Pointer to pointer to the new created file tree node.
p__PCHAR__RootDirectoryNewName | Pointer to directory name to be stored in the ISO9660 or Joliet image as root name. Cannot be NULL in this case!
Returns

Execution status. EN_SUCCESS if the tree was reallocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to reallocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function adds the node created from the memory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.

Remarks

Please see the BuildImage sample that will demonstrate how memory node can be added to already created ISO9660 or Joliet file tree, progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid

Example

This example allocates Joliet file tree, adds memory node to it and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;
UCHAR l__UCHAR__MemoryNode[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__MemoryNodeSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Add(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare memory node memory
RtlZeroMemory(
    &l__UCHAR__MemoryNode,
    sizeof( l__UCHAR__MemoryNode )
    );

// Format memory node here and store all required data into l__UCHAR__MemoryNode buffer

// Set size of memory node
l__LARGE_INTEGER__MemoryNodeSizeInUCHARs.QuadPart = sizeof( l__UCHAR__MemoryNode );

// Try to add memory node as "MemoryNodeName" to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddMemory(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PUCHAR )( &l__UCHAR__MemoryNode ),
    l__LARGE_INTEGER__MemoryNodeSizeInUCHARs,
    "MemoryNodeName",
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_AddW Function

StarBurn_ISO9660JolietFileTree_AddW Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_AddW(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PWCHAR p__PWCHAR__RootDirectoryOrFileAbsolutePathAndName,
    IN PWCHAR p__PWCHAR__RootDirectoryOrFileNewName,
    IN FILE_TIME p__FILE_TIME,
    IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent,
    OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN FILE_TIME p__FILE_TIME | File time that will be included in file system image (See FILE_TIME).
IN PVOID * p__PPVOID__ISO9660JolietFileTreeNode__Parent | Pointer to pointer to the file tree node we'll use as parent. This is the result of either tree walking with StarBurn_ISO9660JolietFileTree_GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). NULL can be passed instead of the result of StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode__NewChild | Pointer to pointer to the new created file tree node.
p__PCHAR__RootDirectoryAbsolutePathAndName | Pointer to directory name to build the ISO9660 or Joliet image from. This parameters can be NULL (but in this case p__PCHAR__RootDirectoryNewName cannot!!!) if virtual (non-present on the disk) directory must be added to the image.
p__PCHAR__RootDirectoryNewName | Pointer to directory name to be stored in the ISO9660 or Joliet image as root name, NULL to include default name from the previous parameter.
Returns

Execution status. EN_SUCCESS if the tree was reallocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to reallocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations. Unlike other tree management calls this one deals with Unicode names (wide char variant of basic call).

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object. BuildImage sample shows how to add files using both ANSI and Unicode based naming conventions.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx

Example

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddW(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    L"D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_AddZeroFile Function

StarBurn_ISO9660JolietFileTree_AddZeroFile Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_AddZeroFile(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN LARGE_INTEGER p__LARGE_INTEGER__FileSizeInUCHARs,
    IN PCHAR p__PCHAR__Name,
    IN FILE_TIME p__FILE_TIME,
    IN PVOID* p__PPVOID__ISO9660JolietFileTreeNode__Parent,
    OUT PVOID* p__PPVOID__ISO9660JolietFileTreeNode__NewChild
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN LARGE_INTEGER p__LARGE_INTEGER__FileSizeInUCHARs | Size of the added file.
IN PCHAR p__PCHAR__Name | Pointer to file name.
IN FILE_TIME p__FILE_TIME | File time that will be included in file system image (See FILE_TIME).
IN PVOID* p__PPVOID__ISO9660JolietFileTreeNode__Parent | Pointer to pointer to the file tree node we'll use as parent. This is the result of either tree walking with StarBurn_ISO9660JolietFileTree_GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). NULL can be passed instead of the result of StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PVOID* p__PPVOID__ISO9660JolietFileTreeNode__NewChild | Pointer to pointer to the new created file tree node.
Returns

Execution status. EN_SUCCESS if the tree was reallocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to reallocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function adds the new "filled with zeros" file to already created ISO9660 or Joliet file tree. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx, StarBurn_ISO9660JolietFileTree_Add

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_BuildImage Function

StarBurn_ISO9660JolietFileTree_BuildImage Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_BuildImage(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN LONG p__LONG__StartingLBA,
    IN LONG p__LONG__TreeLevelToProcess,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN PCHAR p__PCHAR__VolumeSetName,
    IN PCHAR p__PCHAR__PublisherPreparerName,
    IN PCHAR p__PCHAR__ApplicationName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN LONG p__LONG__StartingLBA | Starting LBA to build the image from (it should be the next writable address of the track on the CD/DVD/Blu-Ray/HD-DVD media, 0 for empty disc).
IN LONG p__LONG__TreeLevelToProcess | Top tree level to process, levels that exceed this value will be ignored and not included into the file system image. For now this parameter is ignored and whole tree will be put into the image.
IN BOOLEAN p__BOOLEAN__IsXA | Is CDROM XA or CDROM data (do we need CDROM XA marker to be included to the the image).
IN PCHAR p__PCHAR__VolumeSetName | Pointer to the volume set.
IN PCHAR p__PCHAR__PublisherPreparerName | Pointer to the publisher and preparer name.
p__PCHAR__ApplictionName | Pointer to the application name.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be created and what parameters in general are passed into the callback function during the operations with file tree object. See ISO9660_XXX constants to verify correct string parameter lengths.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, StarBurn_ISO9660JolietFileTree_BuildImageEx

Example

This example allocates Joliet file tree from the directory, builds the image and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_BuildImageEx Function

StarBurn_ISO9660JolietFileTree_BuildImageEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_BuildImageEx(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN LONG p__LONG__StartingLBA,
    IN LONG p__LONG__TreeLevelToProcess,
    IN BOOLEAN p__BOOLEAN__IsXA,
    IN PCHAR p__PCHAR__VolumeSetName,
    IN PCHAR p__PCHAR__PublisherPreparerName,
    IN PCHAR p__PCHAR__ApplicationName,
    IN PCHAR p__PCHAR__SystemID,
    IN PCHAR p__PCHAR__CopyrightFile,
    IN PCHAR p__PCHAR__BibliographicFile,
    IN PCHAR p__PCHAR__CreationDate,
    IN PCHAR p__PCHAR__ModificationDate,
    IN PCHAR p__PCHAR__ExpirationDate,
    IN PCHAR p__PCHAR__EffectiveDate
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN LONG p__LONG__StartingLBA | Starting LBA to build the image from (it should be the next writable address of the track on the CD/DVD/Blu-Ray/HD-DVD media, 0 for empty disc).
IN LONG p__LONG__TreeLevelToProcess | Top tree level to process, levels that exceed this value will be ignored and not included into the file system image. For now this parameter is ignored and whole tree will be put into the image.
IN BOOLEAN p__BOOLEAN__IsXA | Is CDROM XA or CDROM data (do we need CDROM XA marker to be included to the the image).
IN PCHAR p__PCHAR__VolumeSetName | Pointer to the volume set.
IN PCHAR p__PCHAR__PublisherPreparerName | Pointer to the publisher and preparer name.
IN PCHAR p__PCHAR__SystemID | Pointer to system ID.
IN PCHAR p__PCHAR__CopyrightFile | Pointer to copyright file.
IN PCHAR p__PCHAR__BibliographicFile | Pointer to bibliographic file.
IN PCHAR p__PCHAR__CreationDate | Pointer to creation date.
IN PCHAR p__PCHAR__ModificationDate | Pointer to modification date.
IN PCHAR p__PCHAR__ExpirationDate | Pointer to expiration date.
IN PCHAR p__PCHAR__EffectiveDate | Pointer to effective date.
p__PCHAR__ApplictionName | Pointer to the application name.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media. It's identical to StarBurn_ISO9660JolietFileTree_BuildImage except has some extra parameter to put into file system descriptor.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be created and what parameters in general are passed into the callback function during the operations with file tree object. StarBurn_ISO9660JolietFileTree_BuildImageEx can be used instead of StarBurn_ISO9660JolietFileTree_BuildImage. See ISO9660_XXX constants to verify correct string parameter lengthes.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, StarBurn_ISO9660JolietFileTree_BuildImage

Example

This example allocates Joliet file tree from the directory, builds the image and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImageEx(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application",
    "SystemID",
    "CopyFile",
    "BiblioFile",
    "CreateDate",
    "ModifyDate",
    "ExpireDate",
    "EffectDate"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_Cancel Function

StarBurn_ISO9660JolietFileTree_Cancel Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_Cancel(
    IN PVOID p__PVOID__ISO9660JolietFileTree
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
Returns

Nothing. This function cannot fail.

Description

This function cancel ISO9660 or Joliet file tree creation process.

Remarks

Can cancel only the process initiated by call to StarBurn_ISO9660Joliet_Add, StarBurn_ISO9660JolietFileTree_BuildImage, StarBurn_ISO9660JolietFileTree_Read and StarBurn_ISO9660JolietFileTree_SeekToBegin time-expensive actions cannot be canceled with this code. Also it must be noted that StarBurn_ISO9660JolietFileTree_Cancel is supposed to be executed from the different thread that the one that calls StarBurn_ISO9660JolietFileTree_Add (original thread will be blocked processing it's call).

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_Read, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_SeekToBegin

Example

This example allocates Joliet file tree, initiates tree creation, cancels it and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Cancel tree creation process. Keep in mind that this code must be called from the different thread
StarBurn_ISO9660JolietFileTree_Cancel( l__PVOID__FileTree );

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_Create Function

StarBurn_ISO9660JolietFileTree_Create Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_Create(
    OUT PVOID * p__PPVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCALLBACK p__PCALLBACK,
    IN PVOID p__PVOID__CallbackContext,
    IN BOOLEAN p__BOOLEAN__IsInvalidKidIgnore,
    IN BOOLEAN p__BOOLEAN__IsLocked,
    IN BOOLEAN p__BOOLEAN__IsLevel2,
    IN FILE_TREE p__FILE_TREE
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__ISO9660JolietFileTree | Pointer to pointer to the object that toolkit will set to the ISO9660 or Joliet file tree object it will allocate.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN PCALLBACK p__PCALLBACK | Pointer to callback function that will be called from inside the toolkit to inform the user about the progress of this operation (See samples how to use this callback for progress indication and other useful things).
IN PVOID p__PVOID__CallbackContext | Pointer to arbitrary context value that will be passed as first PVOID parameter to the called callback function.
IN BOOLEAN p__BOOLEAN__IsInvalidKidIgnore | TRUE to ignore bad kids (files or directories that cannot be accessed), FALSE to abort on every unsuccessful attempt to access such a files or directories.
IN BOOLEAN p__BOOLEAN__IsLocked | TRUE of all files of the file tree will be locked, FALSE if they will not be locked (their file handles will not be opened all the times - FALSE must be specified if running under Win9x OSes that have opened files limitation).
IN BOOLEAN p__BOOLEAN__IsLevel2 | TRUE if Level2 ISO9660 names generation is used, FALSE if DOS 8.3 format for names generation is used.
IN FILE_TREE p__FILE_TREE | Type of file tree to build, ISO9660 or Joliet (See FILE_TREE for details).
Returns

Execution status. EN_SUCCESS if the tree was allocated successfully, E_MEMORY_ALLOCATION_FAILED if there is not enough memory to allocate the tree. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function allocates in the memory and initializes ISO9660 or Joliet file tree. Later this file tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be recorder directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate buffering operations on the hard disk.

Remarks

Please see the BuildImage sample that will demonstrate how progress indication can be build and what parameters in general are passed into the callback function during the operations with file tree object.

See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Add

Example

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    TRUE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetAttributes Function

StarBurn_ISO9660JolietFileTree_GetAttributes Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_ISO9660JolietFileTree_GetAttributes(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
Returns

Attributes. This function cannot fail.

Combination of one or more of following attributes is valid (see file attributes values in Windows SDK):

FILE_ATTRIBUTE_ARCHIVE FILE_ATTRIBUTE_COMPRESSED FILE_ATTRIBUTE_DIRECTORY FILE_ATTRIBUTE_NORMAL FILE_ATTRIBUTE_HIDDEN FILE_ATTRIBUTE_READONLY FILE_ATTRIBUTE_SYSTEM FILE_ATTRIBUTE_TEMPORARY

Description

This function returns ISO9660 or Joliet file tree node attributes.

Remarks

Attributes can be used to build correct tree to visualize enumeration of all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid

Example

This example allocates Joliet file tree, get root node, gets attributes and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
ULONG l__ULONG__Attributes;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get attributes node here
l__ULONG__Attributes =
StarBurn_ISO9660JolietFileTree_GetAttributes(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetAutoSorting Function

StarBurn_ISO9660JolietFileTree_GetAutoSorting Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_ISO9660JolietFileTree_GetAutoSorting(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
Returns

Current auto-sorting mode. This function cannot fail.

Description

This function returns ISO9660 or Joliet file tree node sorting mode.

Remarks

Auto sorting mode allows sorting sub-nodes before adding it to the image. It should be turned off if you want to specify your own order of adding files. File order determines how the LBAs would be assigned. Lower LBA would be assigned to the last added file.

See Also

StarBurn_ISO9660JolietFileTree_SetSorting, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs Function

StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PLARGE_INTEGER p__PLARGE_INTEGER__FileSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot(). The function is valid only for nodes that correspond to files.
OUT PLARGE_INTEGER p__PLARGE_INTEGER__FileSizeInUCHARs | Pointer to the variable to receive ISO9660 or Joliet file tree node file size in UCHARs.
Returns

Execution status.

Description

This function returns ISO9660 or Joliet file tree file size in UCHARs.

Remarks

This call is identical to the StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs(...) except it has a bit different semantics.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Example

This example allocates Joliet file tree, get root node, gets file size in UCHARs and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
LARGE_INTEGER l__LARGE_INTEGER__FileSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get file size in UCHARs here
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    &l__LARGE_INTEGER__FileSizeInUCHARs
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetFirstKid Function

StarBurn_ISO9660JolietFileTree_GetFirstKid Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_ISO9660JolietFileTree_GetFirstKid(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
Returns

Pointer to first kid node. NULL if no first kid node present.

Description

This function returns ISO9660 or Joliet file tree node first kid pointer.

Remarks

Kid node can be used to enumerate all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid

Example

This example allocates Joliet file tree, get root node, gets first kid and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetFullPath Function

StarBurn_ISO9660JolietFileTree_GetFullPath Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ISO9660_KIDTYPE StarBurn_ISO9660JolietFileTree_GetFullPath(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PCHAR p__PCHAR__FullName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree current node belongs to.
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to ISO9660 or Joliet file tree node to get ISO9660 time stamp for.
OUT PCHAR p__PCHAR__FullName | Pointer to the buffer to receive full path to ISO9660 or Joliet file tree node.
Returns

Kid type of ISO9660 or Joliet file tree node (where this node was taken from). This call cannot fail.

Description

This function returns full path to ISO9660 or Joliet file tree node.

Remarks

None.

See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Example

There are no examples for StarBurn_ISO9660JolietFileTree_GetFullPath(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetKidType Function

StarBurn_ISO9660JolietFileTree_GetKidType Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ISO9660_KIDTYPE StarBurn_ISO9660JolietFileTree_GetKidType(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree current node belongs to.
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to ISO9660 or Joliet file tree node to get ISO9660 time stamp for.
Returns

Kid type of ISO9660 or Joliet file tree node (where this node was taken from). This call cannot fail.

Description

This function returns type of ISO9660 or Joliet file tree node.

Remarks

None.

See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetLevel Function

StarBurn_ISO9660JolietFileTree_GetLevel Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_ISO9660JolietFileTree_GetLevel(
    IN PVOID p__PVOID__ISO9660JolietFileTree
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
Returns

Tree level. This function cannot fail.

Description

This function returns ISO9660 or Joliet file tree level. The number of levels in the created tree.

Remarks

The number of levels ISO9660 or Joliet can handle is limited to 8. Any values that exceed 8 is under your own risk.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_Destroy

Example

This example allocates Joliet file tree, checks tree level and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
LONG l__LONG__TreeLevel;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get tree level here
l__LONG__TreeLevel =
StarBurn_ISO9660JolietFileTree_GetLevel( l__PVOID__FileTree );

// Check for tree level here
if ( l__LONG__TreeLevel > 8 )
{
// Handle error here...
}

// Do something with Joliet file tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNames Function

StarBurn_ISO9660JolietFileTree_GetNames Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_GetNames(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PCHAR p__PCHAR__AbsoluteName,
    OUT PCHAR p__PCHAR__LongName,
    OUT PCHAR p__PCHAR__ShortName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PCHAR p__PCHAR__AbsoluteName | Pointer to the array of CHARs MAX_PATH in size that will be filled with absolute name.
OUT PCHAR p__PCHAR__LongName | Pointer to the array of CHARs MAX_PATH in size that will be filled with long name.
OUT PCHAR p__PCHAR__ShortName | Pointer to the array of CHARs MAX_PATH in size that will be filled with short name.
Returns

Nothing. Passed buffers will be filled with the names. This function cannot fail.

Description

This function returns ISO9660 or Joliet file tree node names (long, short and absolute).

Remarks

Names can be used to build correct tree to visualize enumeration of all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_SetNames

Example

This example allocates Joliet file tree, get root node, gets names and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNamesEx Function

StarBurn_ISO9660JolietFileTree_GetNamesEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_GetNamesEx(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PCHAR p__PCHAR__AbsoluteName,
    OUT PCHAR p__PCHAR__LongName,
    OUT PCHAR p__PCHAR__ShortName,
    OUT PCHAR p__PCHAR__FileSystemName,
    OUT PUSHORT p__PUSHORT__UnicodeFileSystemName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PCHAR p__PCHAR__AbsoluteName | Pointer to the array of CHARs MAX_PATH in size that will be filled with absolute name.
OUT PCHAR p__PCHAR__LongName | Pointer to the array of CHARs MAX_PATH in size that will be filled with long name.
OUT PCHAR p__PCHAR__ShortName | Pointer to the array of CHARs MAX_PATH in size that will be filled with short name.
OUT PCHAR p__PCHAR__FileSystemName | Pointer to the array of CHARs MAX_PATH in size that will be filled with ISO9660 name.
OUT PUSHORT p__PUSHORT__UnicodeFileSystemName | Pointer to the array of CHARs MAX_PATH in size that will be filled with Joliet name.
Returns

Nothing. Passed buffers will be filled with the names. This function cannot fail.

Description

This function returns ISO9660 or Joliet file tree node names (long, short and absolute). Also it returns file system dependent names in ANSI and Unicode.

Remarks

Names can be used to build correct tree to visualize enumeration of all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_SetNames

Example

This example allocates Joliet file tree, get root node, gets names and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];
CHAR l__CHAR__FileSystemName[ MAX_PATH ];
WCHAR l__WCHAR__FileSystemName[ MAX_PATH ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNamesEx(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName ),
    ( PCHAR )( &l__CHAR__FileSystemName ),
    ( PUSHORT )( &l__WCHAR__FileSystemName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNamesW Function

StarBurn_ISO9660JolietFileTree_GetNamesW Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_GetNamesW(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PWCHAR p__PWCHAR__AbsoluteName,
    OUT PWCHAR p__PWCHAR__LongName,
    OUT PWCHAR p__PWCHAR__ShortName
);
File

StarBurn.h

Description

StarBurn_ISO9660JolietFileTree_GetNamesW function is not documented

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNextKid Function

StarBurn_ISO9660JolietFileTree_GetNextKid Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_ISO9660JolietFileTree_GetNextKid(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode__Root,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode__PreviousKid
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode__Root | Pointer to the ISO9660 or Joliet file tree node object that is result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode__PreviousKid | the result of call to previous call to StarBurn_ISO9660JolietFileTreeNode__GetFirstKid() or StarBurn_ISO9660JolietFileTree_GetNextKid().
Returns

Pointer to next kid node. NULL if no next kid node present.

Description

This function returns ISO9660 or Joliet file tree root node next kid pointer.

Remarks

Kid node can be used to enumerate all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetFirstKid

Example

This example allocates Joliet file tree, get root node, gets first kid and next kid and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;
PVOID l__PVOID__NextKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Get next kid node node here
l__PVOID__NextKidNode =
StarBurn_ISO9660JolietFileTree_GetNextKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    l__PVOID__FirstKidNode
    );

// Check for correct response
if ( l__PVOID__NextKidNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime Function

StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PISO9660_DATE_TIME p__PISO9660_DATE_TIME
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree current node belongs to.
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to ISO9660 or Joliet file tree to get ISO9660 time stamp for.
OUT PISO9660_DATE_TIME p__PISO9660_DATE_TIME | Pointer to ISO9660 time stamp (date and time).
Returns

Execution status.

Description

This function returns ISO9660 or Joliet file tree node ISO9660 time stamp (date and time).

Remarks

None.

See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Example

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs Function

StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PLONG p__PLONG__HighPartSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PLONG p__PLONG__HighPartSizeInUCHARs | Pointer to the variable to receive high part (32 bits) of the node power (file size) in UCHARs.
Returns

Low part (32 bits ) of the node power (file size ) in UCHARs. This function cannot fail.

Description

This function returns ISO9660 or Joliet file tree node power (file size) in UCHARs.

Remarks

Node power (file size) in UCHARs can be used to build correct tree to visualize enumeration of all the kids and walk down the tree. This call is identical to the StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs(...) except the semantics.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs

Example

This example allocates Joliet file tree, get root node, gets node power in UCHARs and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
LARGE_INTEGER l__LARGE_INTEGER__NodePowerInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get node power in UCHARs here
l__LARGE_INTEGER__NodePowerInUCHARs.LowPart =
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PLONG )( &l__LARGE_INTEGER__NodePowerInUCHARs.HighPart )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA Function

StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PLONG p__PLONG__StartingLBA
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
OUT PLONG p__PLONG__StartingLBA | Pointer to the variable to receive ISO9660 or Joliet file tree node starting LBA.
Returns

Execution status.

Description

This function returns ISO9660 or Joliet file tree node starting LBA after the image was built.

Remarks

None.

See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Example

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetNodeSystemTime Function

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_GetNodeSystemTime(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    OUT PSYSTEMTIME p__PSYSTEMTIME
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree current node belongs to.
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to ISO9660 or Joliet file tree to get SYSTEMTIME for.
OUT PSYSTEMTIME p__PSYSTEMTIME | Pointer to the output SYSTEMTIME for ISO9660 or Joliet file tree node.
Returns

Execution status.

Description

This function returns ISO9660 or Joliet file tree node SYSTEMTIME.

Remarks

None.

See Also

StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs

Example

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeSystemTime(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetParent Function

StarBurn_ISO9660JolietFileTree_GetParent Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_ISO9660JolietFileTree_GetParent(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
Returns

Pointer to parent node. NULL if no parent node present (this is root node).

Description

This function returns ISO9660 or Joliet file tree node parent pointer.

Remarks

Parent node can be used to enumerate all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid

Example

This example allocates Joliet file tree, get root node, gets parent and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__ParentNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get parent node here
l__PVOID__ParentNode =
StarBurn_ISO9660JolietFileTree_GetParent(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response (MUST be NULL)
if ( l__PVOID__ParentNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetRoot Function

StarBurn_ISO9660JolietFileTree_GetRoot Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_ISO9660JolietFileTree_GetRoot(
    IN PVOID p__PVOID__ISO9660JolietFileTree
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
Returns

Pointer to root node. NULL if no root present.

Description

This function returns ISO9660 or Joliet file tree root node pointer.

Remarks

Root can be used to enumerate all the root node kids and walk down the tree. Attention! This function will return NULL if nothing was added to the tree by StarBurn_ISO9660JolietFileTree_Add() before.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_Destroy

Example

This example allocates Joliet file tree, get root node and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs Function

StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API LONG StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PLONG p__PLONG__HighPartSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create and StarBurn_ISO9660JolietFileTree_BuildImage was applied to later.
p__PULONG__HighPartSizeInUCHARs | Pointer to the 32-bit unsigned long that will receive high part of 64-bit image size.
Returns

Built ISO9660 or Joliet file system image size in UCHARs. This function cannot fail.

Description

This function returns ISO9660 or Joliet built file system image size in UCHARs.

Remarks

Used to determine the size of the built file system image so it will be clear will it fit on the CD/DVD/Blu-Ray/HD-DVD media (if burning) or on hard disk (if storing file system image as file on the disk) or not.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_BuildImage, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER

Example

This example allocates Joliet file tree from the directory, builds file system image, gets file system image size in UCHARs, checks for compatibility and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
LARGE_INTEGER l__LARGE_INTEGER__FileSystemImageSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get file system image size in UCHARs
l__LARGE_INTEGER__FileSystemImageSizeInUCHARs.LowPart =
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs(
    l__PVOID__FileTree,
    &l__LARGE_INTEGER__FileSystemImageSizeInUCHARs.HighPart
    );

// Check for enough space on the media here (either hard disk or CD/DVD/Blu-Ray/HD-DVD)
if ( l__LARGE_INTEGER__FileSystemImageSizeInUCHAR.QuadPart < ... )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_ImportFile Function

StarBurn_ISO9660JolietFileTree_ImportFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_ImportFile(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PCHAR p__PCHAR__ImportFileName,
    IN BOOLEAN p__BOOLEAN__ImportJolietStructures,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree to import track to.
IN PCHAR p__PCHAR__ImportFileName | Pointer to the file name to import file system structures from.
IN BOOLEAN p__BOOLEAN__ImportJolietStructures | Should we try to import Joliet structures (TRUE) or proceed with ISO9660 only (FALSE).
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text buffer.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function imports file for created ISO9660 or Joliet file tree.

Remarks

Please see the TrackAtOnceFromTreeWithImportFromFile sample that will demonstrate how ISO9660 or Joliet file system image can be created, existing file imported and whole result burn to the CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_ImportTrack

Example
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to import file system structures from the file
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_ImportFile(
    l__PVOID__CdvdBurnerGrabber,
    l__PVOID__ISO9660JolietFileTree,
    "Image.ISO", // Import FS structures from file called "Image.ISO"
    TRUE, // Try to proceed as Joliet
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_ImportTrack Function

StarBurn_ISO9660JolietFileTree_ImportTrack Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_ImportTrack(
    IN PVOID p__PVOID__CdvdBurnerGrabber,
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN UCHAR p__UCHAR__TrackNumber,
    IN BOOLEAN p__BOOLEAN__ImportJolietStructures,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CdvdBurnerGrabber | Pointer to the CdvdBurnerGrabber object that toolkit allocated before with the call to StarBurn_CdvdBurnerGrabber_Create().
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree to import track to.
IN UCHAR p__UCHAR__TrackNumber | Track number to import.
IN BOOLEAN p__BOOLEAN__ImportJolietStructures | Should we try to import Joliet structures (TRUE) or proceed with ISO9660 only (FALSE).
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text buffer.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message. If the exception number will be EN_SCSI_CDB_FAILED, CDB_FAILURE_INFORMATION will be filled with appropriate values (CDB that failed, CDB size, SCSI sense data, SCSI sense data size, SCSI transport, device and host adapter status codes).

Description

This function imports track for created ISO9660 or Joliet file tree.

Remarks

Please see the TrackAtOnceFromTreeWithImport sample that will demonstrate how ISO9660 or Joliet file system image can be created, existing track imported and whole result burn to the CD/DVD/Blu-Ray/HD-DVD media.

If you use your own file order, when auto-sorting option is turned off (see StarBurn_ISO9660JolietFileTree_SetAutoSorting), boot image will be added to ISO image as a file in root directory. So if you want boot image file to have the least LBA, call StarBurn_ISO9660JolietFileTree_SetBootImage after adding all other files.

[ WARNING! It's required to create empty file tree, import existing disc content into it and only after this add new or delete existing file tree nodes. Reversed direction should not be tried! ]

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_ImportFile

Example
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to import file system structures from the track
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_ImportTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__PVOID__ISO9660JolietFileTree,
    0x01, // First track,
    TRUE, // Try to proceed as Joliet
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_Read Function

StarBurn_ISO9660JolietFileTree_Read Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_Read(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN LONG p__LONG__IoTransferSizeInUCHARs,
    OUT PUCHAR p__PUCHAR__DataBuffer
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create and StarBurn_ISO9660FileTree_BuildImage was applied to.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
IN LONG p__LONG__IoTransferSizeInUCHARs | Number of UCHARs to read from the image from the current offset.
OUT PUCHAR p__PUCHAR__DataBuffer | Pointer to data buffer readen UCHARs will be stored.
Returns

Execution status. EN_SUCCESS if the operation successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function reads ISO9660 or Joliet file system image from current offset into the user's data buffer. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized. The data that is read can be either stored in the file on the hard disk or directly written to CD/DVD/Blu-Ray/HD-DVD media.

Remarks

Please see the BuildImage sample that will demonstrate how file system image can be stored on the hard disk drive and either burn later to CD/DVD/Blu-Ray/HD-DVD media or used with CD/DVD/Blu-Ray/HD-DVD emulation software packages. Also TrackAtOnceFromTree sample can be checked out to see how ISO9660 or Joliet image can be recorded on the CD/DVD/Blu-Ray/HD-DVD media w/o intermediate buffering on the hard disk.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_BuildImage, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER

Example

This example allocates Joliet file tree from the directory, builds file system image, reads some data from it and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
UCHAR l__UCHAR__DataBuffer[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__NumberOfUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Prepare data buffer
RtlZeroMemory(
    &l__UCHAR__DataBuffer,
    sizeof( l__UCHAR__DataBuffer )
    );

// Set transfer size
l__LARGE_INTEGER__NumberOfUCHARs.QuadPart = sizeof( l__UCHAR__DataBuffer );

// Try to read
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Read(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    l__LARGE_INTEGER__NumberOfUCHARs.LowPart,
    ( PUCHAR )( &l__UCHAR__DataBuffer )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with data buffer here...

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_Remove Function

StarBurn_ISO9660JolietFileTree_Remove Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_ISO9660JolietFileTree_Remove(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN OUT PVOID * p__PPVOID__ISO9660JolietFileTreeNode | Pointer to pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
Returns

TRUE if the node was destroyed, FALSE if node was not destroyed.

Description

This function deletes ISO9660 or Joliet file tree node and all it's kids.

Remarks

You cannot delete root node - FALSE will be returned in this case.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_Add

Example

This example allocates Joliet file tree, get root node, gets first kid, deletes first node and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Try to delete first kid
if (
StarBurn_ISO9660JolietFileTree_Remove(
    l__PVOID__ISO9660JolietFileTree,
    &l__PVOID__FirstKidNode
    ) == FALSE
)
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SeekToBegin Function

StarBurn_ISO9660JolietFileTree_SeekToBegin Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_SeekToBegin(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660FileTree_Create or StarBurn_JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_CreateFromRoot and StarBurn_ISO9660FileTree_BuildImage was applied to.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to array of CHARs that will be used to store formatted exception description message.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Size of the array of CHARs used to be formatted exception message storage.
OUT PULONG p__PULONG__SystemError | Pointer to ULONG that will contain the system error (if some will occur).
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function seeks the ISO9660 or Joliet file system image from current offset to the very beginning so read operation will start from the 0 offset of the file system image. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized.

Remarks

Please see the BuildImage sample that will demonstrate how file system image can be stored on the hard disk drive and either burn later to CD/DVD/Blu-Ray/HD-DVD media or used with CD/DVD/Blu-Ray/HD-DVD emulation software packages. StarBurn_ISO9660JolietFileTree_SeekToBegin is used to rewind the file system image after some part of it was read. Rewinding can be used when the user will want to write the same file system image to the media multiple times.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Read, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER,

Example

This example allocates Joliet file tree from the directory, builds file system image, reads some stuff from it and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
UCHAR l__UCHAR__DataBuffer[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__NumberOfUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Prepare data buffer
RtlZeroMemory(
    &l__UCHAR__DataBuffer,
    sizeof( l__UCHAR__DataBuffer )
    );

// Set transfer size
l__LARGE_INTEGER__NumberOfUCHARs.QuadPart = sizeof( l__UCHAR__DataBuffer );

// Try to read
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Read(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    l__LARGE_INTEGER__NumberOfUCHARs.LowPart,
    ( PUCHAR )( &l__UCHAR__DataBuffer )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with data buffer here...

// Try to seek to the very beging of the "virtual" file system image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SeekToBegin(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with image once again...

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SetAttributes Function

StarBurn_ISO9660JolietFileTree_SetAttributes Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_SetAttributes(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    IN ULONG p__ULONG__Attributes
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
IN ULONG p__ULONG__Attributes | New attributes
Returns

None. This function cannot fail.

Description

This function sets ISO9660 or Joliet file tree node attributes.

Remarks

Attributes can be used to build correct tree to visualize enumeration of all the kids and walk down the tree.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid

Example

This example allocates Joliet file tree, get root node, gets attributes and destroys it (tree) after it's not needed any more.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SetAutoSorting Function

StarBurn_ISO9660JolietFileTree_SetAutoSorting Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_ISO9660JolietFileTree_SetAutoSorting(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    IN BOOLEAN p__BOOLEAN__IsSorting
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
IN BOOLEAN p__BOOLEAN__IsSorting | New auto-sorting mode
Returns

None. This function cannot fail.

Description

This function sets ISO9660 or Joliet file tree node auto sorting mode.

Remarks

Auto sorting mode allows sorting sub-nodes before adding it to the image. It should be turned off if you want to specify your own order of adding files.

File order determines how the LBAs would be assigned. Lower LBA would be assigned to the last added file.

It may be used to ensure that boot image has low LBA. See StarBurn_ISO9660JolietFileTree_SetBootImage or StarBurn_ISO9660JolietFileTree_SetBootImageEx.

See Also

StarBurn_ISO9660JolietFileTree_GetSorting, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SetBootImage Function

StarBurn_ISO9660JolietFileTree_SetBootImage Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_SetBootImage(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PCHAR p__PCHAR__AbsoluteFileName,
    IN UCHAR p__UCHAR__SystemType,
    IN UCHAR p__UCHAR__MediaType,
    IN UCHAR p__UCHAR__SectorsToLoad,
    IN BOOLEAN p__BOOLEAN__HideNode,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree to add boot image to.
IN PCHAR p__PCHAR__AbsoluteFileName | Pointer to absolute file name of the boot image.
IN UCHAR p__UCHAR__SystemType | System type value.
IN UCHAR p__UCHAR__MediaType | Media type value.
IN UCHAR p__UCHAR__SectorsToLoad | Number of sectors to load
IN BOOLEAN p__BOOLEAN__HideNode | Indicates will the node be present in the root folder or not
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text buffer.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function sets boot image for created ISO9660 or Joliet file tree.

Remarks

Please see the TrackAtOnceFromTreeWithBoot sample that will demonstrate how ISO9660 or Joliet file system image can be created, boot image added and whole result burn to the CD/DVD/Blu-Ray/HD-DVD media.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce

Example
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to set boot image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SetBootImage(
    l__PVOID__ISO9660JolietFileTree,
    "C:\bootimage.bin", // Here is our boot image we gonna use
    6, // Just stick with 6 here...
    ELTORITO_MEDIA_FLOPPY144,
    1,// set only one sector to load
    FALSE, // don't hide the file
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SetBootImageEx Function

StarBurn_ISO9660JolietFileTree_SetBootImageEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_ISO9660JolietFileTree_SetBootImageEx(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PCHAR p__PCHAR__AbsoluteFileName,
    IN PCHAR p__PCHAR__BootImageFileName,
    IN ULONG p__ULONG__BootImageFileAttributes,
    IN UCHAR p__UCHAR__SystemType,
    IN UCHAR p__UCHAR__MediaType,
    IN UCHAR p__UCHAR__SectorsToLoad,
    IN USHORT p__USHORT__LoadSegment,
    IN BOOLEAN p__BOOLEAN__IsHideNode,
    IN BOOLEAN p__BOOLEAN__IsBootInformationPatch,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to ISO9660 or Joliet file tree to add boot image to.
IN PCHAR p__PCHAR__AbsoluteFileName | Pointer to absolute file name of the boot image.
IN PCHAR p__PCHAR__BootImageFileName | Pointer to boot image file name with that be saved on disc.
IN ULONG p__ULONG__BootImageFileAttributes | Boot image file attributes.
IN UCHAR p__UCHAR__SystemType | System type value.
IN UCHAR p__UCHAR__MediaType | Media type value.
IN UCHAR p__UCHAR__SectorsToLoad | Number of sectors to load
IN USHORT p__USHORT__LoadSegment | Physical address of the memory where will be written code from the first sector of boot image.
IN BOOLEAN p__BOOLEAN__IsHideNode | Indicates will the node be present in the root folder or not
IN BOOLEAN p__BOOLEAN__IsBootInformationPatch | Is recalculate CRC of the boot image.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text buffer.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This extended function sets boot image for created ISO9660 or Joliet file tree.

Remarks

Please see the TrackAtOnceFromTreeWithBoot sample that will demonstrate how ISO9660 or Joliet file system image can be created, boot image added and whole result burn to the CD/DVD/Blu-Ray/HD-DVD media.

If you use your own file order, when auto-sorting option is turned off (see StarBurn_ISO9660JolietFileTree_SetAutoSorting), boot image will be added to ISO image as a file in root directory. So if you want boot image file to have the least LBA, call StarBurn_ISO9660JolietFileTree_SetBootImage after adding all other files.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce

Example
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to set boot image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SetBootImageEx(
l__PVOID__ISO9660JolietFileTree,
"C:\bootimage.bin", // Here is our boot image we gonna use
"boot.img",
0, //Attributes
6, // Just stick with 6 here...
ELTORITO_MEDIA_CUSTOM, //No emulation
4,// set four sector to load
ELTORITO_DEF_LOAD_SEGMENT,
TRUE, // hide the file
FALSE, //No recalculation CRC
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError
);

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO9660JolietFileTree_SetNames Function

StarBurn_ISO9660JolietFileTree_SetNames Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOLEAN StarBurn_ISO9660JolietFileTree_SetNames(
    IN PVOID p__PVOID__ISO9660JolietFileTree,
    IN PVOID p__PVOID__ISO9660JolietFileTreeNode,
    IN PCHAR p__PCHAR__AbsoluteName,
    IN PCHAR p__PCHAR__LongName,
    IN PCHAR p__PCHAR__ShortName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__ISO9660JolietFileTree | Pointer to the ISO9660 or Joliet file tree object that toolkit allocated during call to StarBurn_ISO9660JolietFileTree_Create().
IN PVOID p__PVOID__ISO9660JolietFileTreeNode | Pointer to the ISO9660 or Joliet file tree node object that is either result of previous tree node kids enumeration with StarBurn_ISO9660JolietFileTree_GetFirstKid() and StarBurn_ISO9660JolietFileTree_GetNextKid() or the result of call to StarBurn_ISO9660JolietFileTree_GetRoot().
IN PCHAR p__PCHAR__AbsoluteName | Pointer to the array of CHARs MAX_PATH in size that will be passed as absolute name.
IN PCHAR p__PCHAR__LongName | Pointer to the array of CHARs MAX_PATH in size that will be passed as long name.
IN PCHAR p__PCHAR__ShortName | Pointer to the array of CHARs MAX_PATH in size that will be passed as short name.
Returns

Nothing. Passed buffers will be copied to the internal file tree node. This function cannot fail. Attention! For now only long file name can be changed (short and absolute file names will be ignored).

Description

This function sets ISO9660 or Joliet file tree node names (long, short and absolute).

Remarks

Names can be used to build correct tree to visualize enumeration of all the kids and walk down the tree. Changing the names can allow to store the files or directories under different names.

See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_GetNames

Example

This example allocates Joliet file tree, get root node, gets names, sets new ones and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];
INT l__INT__NameSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Change long name

l__INT__NameSizeInUCHARs = strlen( l__CHAR__LongName );

RtlZeroMemory(
&l__CHAR__LongName,
sizeof( l__CHAR__LongName )
);

strncpy(
l__CHAR__LongName,
"New name",
l__INT__NameSizeInUCHARs
);

// Set names here
StarBurn_ISO9660JolietFileTree_SetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetBufferUnderrunTimeOutInMs Function

StarBurn_SetBufferUnderrunTimeOutInMs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetBufferUnderrunTimeOutInMs(
    IN LONG p__LONG__NewBufferUnderrunTimeOutInMs
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.

Remarks

Having large timeout would allow StarBurn to grab more information into software cache, at the same time having timeout small and disc burning speed MUCH faster then reading speed from the source media (say slow hard disk or network) would produce a lot of BUP errors, start-stop cycles and resulting recorded disc quality would be very low. In general it's a good idea not to touch buffer underrun timeout value at all and keep everything AS IS. It's value for "hardcore tuning".

See Also

StarBurn_GetBufferUnderrunTimeOutInMs

Example

There are no samples for StarBurn_SetBufferUnderrunTimeOutInMs(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetDeviceTimeOutByDeviceAddress Function

StarBurn_SetDeviceTimeOutByDeviceAddress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_SetDeviceTimeOutByDeviceAddress(
    IN UCHAR p__UCHAR__DevicePort,
    IN UCHAR p__UCHAR__DeviceBus,
    IN UCHAR p__UCHAR__DeviceID,
    IN UCHAR p__UCHAR__DeviceLUN,
    IN ULONG p__ULONG__DeviceTimeOutInSeconds
);
File

StarBurn.h

Parameters
Parameters | Description
IN UCHAR p__UCHAR__DevicePort | Device port.
IN UCHAR p__UCHAR__DeviceBus | Device SCSI bus.
IN UCHAR p__UCHAR__DeviceID | Device SCSI ID.
IN UCHAR p__UCHAR__DeviceLUN | Device LUN.
IN ULONG p__ULONG__DeviceTimeOutInSeconds | New device timeout in seconds.
Returns

Execution status.

Description

This function sets device timeout in seconds by device SCSI address.

Remarks

This one is for ASPI devices only.

See Also

StarBurn_GetDeviceTimeOutByDeviceAddress

Example

Please see FindDevice sample as example how to use StarBurn_SetDeviceTimeOutByDeviceAddress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetDVDPadding Function

StarBurn_SetDVDPadding Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetDVDPadding(
    IN BOOLEAN p__BOOLEAN__NewDVDPadding
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) to enabled (TRUE) or disabled (FALSE).

Remarks

"Padding mode" should be always enabled for DVD-Video compilations (or resulting disc would not be playable on standalone DVD players) and should be always disabled for generic data discs (or quite a lot of disc capacity would be simply wasted).

See Also

StarBurn_GetDVDPadding

Example

There are no examples for StarBurn_SetDVDPadding(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetDVDPLUSRDLCompatibleMode Function

StarBurn_SetDVDPLUSRDLCompatibleMode Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetDVDPLUSRDLCompatibleMode(
    IN BOOLEAN p__BOOLEAN__NewDVDPLUSRDLCompatibleMode
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) to enabled (TRUE) or disabled (FALSE).

Remarks

"Compatible mode" should be always enabled for DVD-Video compilations (or resulting disc would not be playable on standalone DVD players) and should be always disabled for generic data discs (or quite a lot of disc capacity would be simply wasted).

See Also

StarBurn_GetDVDPLUSRDLCompatibleMode

Example

There are no examples for StarBurn_SetDVDPLUSRDLCompatibleMode(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetEjectAfterFail Function

StarBurn_SetEjectAfterFail Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetEjectAfterFail(
    IN BOOLEAN p__BOOLEAN__NewEjectAfterFail
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) to enabled (TRUE) or disabled (FALSE).

Remarks

It's a good idea to keep everything AS IS, however if StarBurn is used with automatic loaders or whatever sometimes it's required to keep manual control over eject process.

See Also

StarBurn_GetEjectAfterFail

Example

There are no examples for StarBurn_SetEjectAfterFail(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetFastReadTOC Function

StarBurn_SetFastReadTOC Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetFastReadTOC(
    IN BOOLEAN p__BOOLEAN__NewFastReadTOC
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn try to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode to enabled (TRUE) or disabled (FALSE).

Remarks

It's a good idea to keep everything AS IS, however if StarBurn takes a lot of time to analyze the disc (it can happen when drive hardware error correction cannot be disabled and reading pre-gap and post-gap of the track is DOG SLOW) "fast read TOC" could be switched ON.

See Also

StarBurn_GetFastReadTOC

Example

Please see GrabTrack sample no how to use StarBurn_SetFastReadTOC(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetIs64KBIO Function

StarBurn_SetIs64KBIO Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetIs64KBIO(
    IN BOOLEAN p__BOOLEAN__NewIs64KBIO
);
File

StarBurn.h

Parameters
Parameters | Description
IN BOOLEAN p__BOOLEAN__NewIs64KBIO | Current "64KB I/O" enabled (TRUE) or disabled (FALSE).
Returns

Nothing.

Description

This function sets current so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) to enabled (TRUE) or disabled (FALSE) state.

Remarks

There's no need to play with this parameter unless you really have broken device you will to force 32KB I/O requests for.

See Also

StarBurn_GetIs64KBIO

Example

There are no examples for StarBurn_SetIs64KBIO(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetIsCollisionDetectionDisabled Function

StarBurn_SetIsCollisionDetectionDisabled Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetIsCollisionDetectionDisabled(
    IN BOOLEAN p__BOOLEAN__NewIsCollisionDetectionDisabled
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets collision detection to disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.

Remarks

If new image is created from the content stored on the hard disk - there's no way for file names to be the same. So file system image creation process could be speed up quite a lot by turning collision detection OFF (especially if there are a lot of files inside each directory). In other cases it's not recommended to play with this option.

See Also

StarBurn_GetIsCollisionDetectionDisabled

Example

Please see BuildImage sample to find out how collision detection could be disabled and enabled during file system image creation.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetIsSafeGrabbingEnabled Function

StarBurn_SetIsSafeGrabbingEnabled Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetIsSafeGrabbingEnabled(
    IN BOOLEAN p__BOOLEAN__NewIsSafeGrabbingEnabled
);
File

StarBurn.h

Returns

Nothing.

Description

This function sets so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) to enabled (TRUE) or disabled (FALSE).

Remarks

There's no need to play with this parameter unless you really have ATAPI device in external USB enclosure and it hangs under heavy I/O load.

See Also

StarBurn_GetIsSafeGrabbingEnabled

Example

There are no examples for StarBurn_SetIsSafeGrabbingEnabled(...) API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetUsingLocalDateTime Function

StarBurn_SetUsingLocalDateTime Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetUsingLocalDateTime();
File

StarBurn.h

Description

This is function StarBurn_SetUsingLocalDateTime.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SetUsingUTCDateTime Function

StarBurn_SetUsingUTCDateTime Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_SetUsingUTCDateTime();
File

StarBurn.h

Description

This is function StarBurn_SetUsingUTCDateTime.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_sprintf_s Function

StarBurn_sprintf_s Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_sprintf_s(
    char * buffer,
    size_t sizeOfBuffer,
    const char * format,
    ...
);
File

StarBurn.h

Parameters
Parameters | Description
char * buffer | Storage location for output.
size_t sizeOfBuffer | Maximum number of characters to store.
const char * format | Format-control string.
argument | Optional arguments.
Description

This function wrap runtime sprintf_s function. In Visual Studio 2003 function sprintf_s not present.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_SPTD_GetVersion Function

StarBurn_SPTD_GetVersion Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_SPTD_GetVersion(
    OUT PUCHAR p__PUCHAR__SptdMajorVersion,
    OUT PUCHAR p__PUCHAR__SptdMinorVersion,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PUCHAR p__PUCHAR__SptdMajorVersion | Pointer to the major SPTD driver version.
OUT PUCHAR p__PUCHAR__SptdMinorVersion | Pointer to the minor SPTD driver version.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status. EN_SUCCESS if everythins is OK.

Description

This function checks if the SPTD (SCSI Pass Through Direct) driver is present and gets SPTD driver version.

See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_CreateExEx, EXCEPTION_NUMBER

Example

This example just checks for the SPTD presence and queries SPTD driver version.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
UCHAR l__UCHAR__Major = 0;
UCHAR l__UCHAR__Minor = 0;

// Try to get SPTD driver version
l__EXCEPTION_NUMBER =
StarBurn_SPTD_GetVersion(
&l__UCHAR__Major,
&l__UCHAR__Minor,
&l__ULONG__SystemError
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the SPTD here...
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceAddLocal Function

StarBurn_StarPort_DeviceAddLocal Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceAddLocal(
    IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE,
    IN PCHAR p__PCHAR__StarPortDeviceName,
    OUT PLONG p__PLONG__StarPortDeviceTargetId,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE | StarPort device type (See STARPORT_DEVICE_TYPE enum for more information).
IN PCHAR p__PCHAR__StarPortDeviceName | Pointer to device name we want to add.
OUT PLONG p__PLONG__StarPortDeviceTargetId | Pointer to the variable to receive StarPort device TargetId after device object creation.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.

Remarks

This one is for Enterprise or Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocalEx, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceAddRemoteEx

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddLocal API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceAddLocalEx Function

StarBurn_StarPort_DeviceAddLocalEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceAddLocalEx(
    IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE,
    IN PCHAR p__PCHAR__StarPortDeviceName,
    OUT PLONG p__PLONG__StarPortDeviceTargetId,
    IN BOOLEAN p__BOOLEAN__Persistent,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE | StarPort device type (See STARPORT_DEVICE_TYPE enum for more information).
IN PCHAR p__PCHAR__StarPortDeviceName | Pointer to device name we want to add.
OUT PLONG p__PLONG__StarPortDeviceTargetId | Pointer to the variable to receive StarPort device TargetId after device object creation.
IN BOOLEAN p__BOOLEAN__Persistent | Is device will be added persistent.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be added persistent.

Remarks

This one is for Enterprise or Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal,StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceAddRemoteEx

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddLocal API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceAddRemote Function

StarBurn_StarPort_DeviceAddRemote Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceAddRemote(
    IN PCHAR p__PCHAR__TargetAddress,
    IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE,
    IN PCHAR p__PCHAR__StarPortDeviceName,
    OUT PLONG p__PLONG__StarPortDeviceTargetId,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__TargetAddress | Pointer to the IP:port string corresponding to iSCSI target we'd like to add.
IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE | StarPort device type (See STARPORT_DEVICE_TYPE enum for more information).
IN PCHAR p__PCHAR__StarPortDeviceName | Pointer to iSCSI target device name we want to add.
OUT PLONG p__PLONG__StarPortDeviceTargetId | Pointer to the variable to receive StarPort device TargetId after device object creation.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be mount persistent.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddRemoteEx, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceAddLocalEx

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddRemote API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceAddRemoteEx Function

StarBurn_StarPort_DeviceAddRemoteEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceAddRemoteEx(
    IN PCHAR p__PCHAR__TargetAddress,
    IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE,
    IN PCHAR p__PCHAR__StarPortDeviceName,
    OUT PLONG p__PLONG__StarPortDeviceTargetId,
    IN BOOLEAN p__BOOLEAN__Persistent,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__TargetAddress | Pointer to the IP:port string corresponding to iSCSI target we'd like to add.
IN STARPORT_DEVICE_TYPE p__STARPORT_DEVICE_TYPE | StarPort device type (See STARPORT_DEVICE_TYPE enum for more information).
IN PCHAR p__PCHAR__StarPortDeviceName | Pointer to iSCSI target device name we want to add.
OUT PLONG p__PLONG__StarPortDeviceTargetId | Pointer to the variable to receive StarPort device TargetId after device object creation.
IN BOOLEAN p__BOOLEAN__Persistent | Is device will be mount persistent.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceAddLocalEx

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddRemote API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceListQueryLocal Function

StarBurn_StarPort_DeviceListQueryLocal Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceListQueryLocal(
    OUT PSTARPORT_DEVICE_LIST p__PSTARPORT_DEVICE_LIST,
    IN ULONG p__ULONG__StarPortDeviceListSizeInUCHARs,
    OUT PLONG p__PLONG__NumberOfTargets,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PSTARPORT_DEVICE_LIST p__PSTARPORT_DEVICE_LIST | Pointer to the STARPORT_DEVICE_LIST structure drive would fill with StarPort device list information.
IN ULONG p__ULONG__StarPortDeviceListSizeInUCHARs | True STARPORT_DEVICE_LIST structure size in UCHARs.
OUT PLONG p__PLONG__NumberOfTargets | Pointer to the variable to receive number of targets StarPort would enumerate during this call.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function gets device list from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Unlike StarBurn_StarPort_DeviceListQueryRemote API call which retrieves information about REMOTE device list this call gets information about LOCAL device list.

Remarks

This one is for Enterprise or Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceListQueryLocal API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceListQueryRemote Function

StarBurn_StarPort_DeviceListQueryRemote Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceListQueryRemote(
    IN PCHAR p__PCHAR__TargetAddress,
    OUT PSTARPORT_DEVICE_LIST p__PSTARPORT_DEVICE_LIST,
    IN ULONG p__ULONG__StarPortDeviceListSizeInUCHARs,
    OUT PLONG p__PLONG__NumberOfTargets,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__TargetAddress | Pointer to IP:port string which corresponds to the iSCSI target we'd like to query.
OUT PSTARPORT_DEVICE_LIST p__PSTARPORT_DEVICE_LIST | Pointer to the STARPORT_DEVICE_LIST structure drive would fill with StarPort device list information.
IN ULONG p__ULONG__StarPortDeviceListSizeInUCHARs | True STARPORT_DEVICE_LIST structure size in UCHARs.
OUT PLONG p__PLONG__NumberOfTargets | Pointer to the variable to receive number of targets StarPort would enumerate during this call.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function gets device list from remote StarWind iSCSI target. StarWind exports RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) targets. Unlike StarBurn_StarPort_DeviceListQueryLocal API call which retreives information about LOCAL device list this call gets information about REMOTE device list.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceListQueryRemote API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceRemove Function

StarBurn_StarPort_DeviceRemove Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceRemove(
    IN LONG p__LONG__StarPortDeviceTargetId,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN LONG p__LONG__StarPortDeviceTargetId | StarPort device TargetId we want to remove from the system.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.

Remarks

This one is for Enterprise or Network license holders only.

See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemoveEx

Example

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceRemove API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_DeviceRemoveEx Function

StarBurn_StarPort_DeviceRemoveEx Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_DeviceRemoveEx(
    IN LONG p__LONG__StarPortDeviceTargetId,
    IN BOOLEAN p__BOOLEAN_ForceRemove,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN LONG p__LONG__StarPortDeviceTargetId | StarPort device TargetId we want to remove from the system.
IN BOOLEAN p__BOOLEAN_ForceRemove | FALSE - Eject (safe mode, can fail if the device is in use)
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
TRUE | Remove (always succeed, but may lead to data corruption if the device is in use)
Returns

Execution status.

Description

This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.

Remarks

This one is for Enterprise or Network license holders only.

See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_GetDeviceInformation Function

StarBurn_StarPort_GetDeviceInformation Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_GetDeviceInformation(
    IN LONG p__LONG__StarPortDeviceTargetId,
    OUT PSTARPORT_DEVICE_TYPE p__PSTARPORT_DEVICE_TYPE,
    OUT PCHAR p__PCHAR__VendorID,
    IN ULONG p__ULONG__VendorIDSizeInUCHARs,
    OUT PCHAR p__PCHAR__ProductID,
    IN ULONG p__ULONG__ProductIDSizeInUCHARs,
    OUT PCHAR p__PCHAR__Revision,
    IN ULONG p__ULONG__RevisionSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN LONG p__LONG__StarPortDeviceTargetId | StarPort device TargetId we want to get device letter for.
OUT PSTARPORT_DEVICE_TYPE p__PSTARPORT_DEVICE_TYPE | Pointer to the STARPORT_DEVICE_TYPE variable to store the device type.
OUT PCHAR p__PCHAR__VendorID | Pointer to the buffer to receive vendor ID.
IN ULONG p__ULONG__VendorIDSizeInUCHARs | The size of the buffer to receive vendor ID.
OUT PCHAR p__PCHAR__ProductID | Pointer to the buffer to receive product ID.
IN ULONG p__ULONG__ProductIDSizeInUCHARs | The size of the buffer to receive product ID.
OUT PCHAR p__PCHAR__Revision | Pointer to the buffer to receive revision.
IN ULONG p__ULONG__RevisionSizeInUCHARs | The size of the buffer to receive revision.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function retrieves device type, vendor ID, product ID and revision for StarPort device by its target ID.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter, StarBurn_StarPort_GetVersion.

Example

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceInformation API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_GetDeviceLetter Function

StarBurn_StarPort_GetDeviceLetter Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_GetDeviceLetter(
    IN LONG p__LONG__StarPortDeviceTargetId,
    OUT PCHAR p__PCHAR__DeviceLetter,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN LONG p__LONG__StarPortDeviceTargetId | StarPort device TargetId we want to get device letter for.
OUT PCHAR p__PCHAR__DeviceLetter | Pointer to the CHAR variable to store the device letter.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function retrieves device letter (symbolic link) for StarPort device by its target ID.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote

Example

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceLetter API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_GetDeviceSCSIAddress Function

StarBurn_StarPort_GetDeviceSCSIAddress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_GetDeviceSCSIAddress(
    IN LONG p__LONG__StarPortDeviceTargetId,
    OUT PSCSI_DEVICE_ADDRESS p__PSCSI_DEVICE_ADDRESS,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN LONG p__LONG__StarPortDeviceTargetId | StarPort device TargetId we want to get device letter for.
OUT PSCSI_DEVICE_ADDRESS p__PSCSI_DEVICE_ADDRESS | Pointer to the variable to receive device SCSI address.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function retrieves device SCSI address for StarPort device by its target ID.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter, StarBurn_StarPort_GetVersion, StarBurn_StarPort_GetDeviceLetter

Example

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceSCSIAddress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarPort_GetVersion Function

StarBurn_StarPort_GetVersion Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarPort_GetVersion(
    OUT PULONG p__PULONG__BuildVersion,
    OUT PULONG p__PULONG__ApiVersion,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PULONG p__PULONG__BuildVersion | StarPortLite driver build version.
OUT PULONG p__PULONG__ApiVersion | StarPortLite driver API version.
OUT PULONG p__PULONG__SystemError | Pointer to the variable to receive system error if function would return anything except EN_SUCCESS.
Returns

Execution status.

Description

This function checks if the StarPortLite driver is installed and that its API version is equal to the one StarBurn was built with.

Remarks

This one is for Network license holders only.

See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter

Example

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetVersion API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectBeginSeek Function

StarBurn_StarWave_CompressedFileReaderObjectBeginSeek Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectBeginSeek(
    IN PVOID p__PVOID__CompressedFileReaderObject
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CompressedFileReaderObject | Pointer to compressed file reader object.
Returns

Execution status.

Description

This function seeks all of the internal object pointers to the very beginning of it so following read operations would start from the very beginning instead of the currently set position.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectBeginSeek API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectCreate Function

StarBurn_StarWave_CompressedFileReaderObjectCreate Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectCreate(
    OUT PVOID * p__PPVOID__CompressedFileReaderObject,
    IN PCHAR p__PCHAR__CompressedFileName
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CompressedFileReaderObject | Pointer to pointer to compressed file reader object after it's creation.
IN PCHAR p__PCHAR__CompressedFileName | Pointer to compressed file name to create compressed file reader object from.
Returns

Execution status.

Description

This function creates compressed file reader object from passed compressed audio file name.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectCreate API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode Function

StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode(
    OUT PVOID * p__PPVOID__CompressedFileReaderObject,
    IN PWCHAR p__PWCHAR__CompressedFileName
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectDestroy Function

StarBurn_StarWave_CompressedFileReaderObjectDestroy Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectDestroy(
    OUT PVOID * p__PPVOID__CompressedFileReaderObject
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CompressedFileReaderObject | Pointer to pointer to compressed file reader object to destroy.
Returns

Execution status.

Description

This function destroys compressed file reader object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectDestroy API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectRead Function

StarBurn_StarWave_CompressedFileReaderObjectRead Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectRead(
    IN PVOID p__PVOID__CompressedFileReaderObject,
    OUT PVOID p__PVOID__ReadDataBuffer,
    IN ULONG p__ULONG__ReadSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CompressedFileReaderObject | Pointer to compressed file reader object.
OUT PVOID p__PVOID__ReadDataBuffer | Pointer to output buffer to handle just read uncompressed data.
IN ULONG p__ULONG__ReadSizeInUCHARs | Data chunk (uncompressed) to read size in UCHARs.
Returns

Execution status.

Description

This function reads uncompressed payload data chunk from underlying compressed file reader object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectRead API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet Function

StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet(
    IN PVOID p__PVOID__CompressedFileReaderObject,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CompressedFileReaderObject | Pointer to compressed file reader object.
OUT PULONG p__PULONG__UncompressedSizeInUCHARs | Pointer to the variable to receive uncompressed payload size in UCHARs.
Returns

Execution status.

Description

This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast Function

StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast(
    IN PVOID p__PVOID__CompressedFileReaderObject,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__CompressedFileReaderObject | Pointer to compressed file reader object.
OUT PULONG p__PULONG__UncompressedSizeInUCHARs | Pointer to the variable to receive uncompressed payload size in UCHARs.
Returns

Execution status.

Description

This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate Function

StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate(
    OUT PVOID * p__PPVOID__CompressedFileReaderObject,
    IN PWCHAR p__PWCHAR__CompressedFileName
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileRecompress Function

StarBurn_StarWave_CompressedFileRecompress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileRecompress(
    IN PCHAR p__PCHAR__SourceCompressedFileName,
    IN PCHAR p__PCHAR__DestinationRecompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__SourceCompressedFileName | Pointer to source compressed file name.
IN PCHAR p__PCHAR__DestinationRecompressedFileName | Pointer to destination compressed file name.
IN ULONG p__ULONG__WorkingBufferSizeInUCHARs | Working buffer size in UCHARs (recommended to have it equal to STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS).
OUT PULONG p__PULONG__UncompressedSizeInUCHARs | Pointer to the variable to receive uncompressed source stream size in UCHARs.
IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK | Pointer to callback function to process progress indication and I/O cancellation.
IN PVOID p__PVOID__Context | Pointer to the context value passed to callback function.
IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION | Compression template.
Returns

Execution status.

Description

This function recompresse already compressed file to new one with another compression.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileSupportedIs

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileRecompress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileRecompressUnicode Function

StarBurn_StarWave_CompressedFileRecompressUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileRecompressUnicode(
    IN PWCHAR p__PWCHAR__SourceCompressedFileName,
    IN PWCHAR p__PWCHAR__DestinationRecompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_CompressedFileRecompressUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileSupportedIs Function

StarBurn_StarWave_CompressedFileSupportedIs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileSupportedIs(
    IN PCHAR p__PCHAR__CompressedFileName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__CompressedFileName | Pointer to compressed file name.
Returns

Execution status.

Description

This function checks is file name actually points to supported compressed audio file.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileSupportedIs API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileUncompress Function

StarBurn_StarWave_CompressedFileUncompress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileUncompress(
    IN PCHAR p__PCHAR__SourceCompressedFileName,
    IN PCHAR p__PCHAR__DestinationUncompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsWavHeaderRequired,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__SourceCompressedFileName | Pointer to source compressed file name.
IN PCHAR p__PCHAR__DestinationUncompressedFileName | Pointer to destination uncompressed file name.
IN ULONG p__ULONG__WorkingBufferSizeInUCHARs | Working buffer size in UCHARs (recommended to have it equal to STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS).
IN BOOLEAN p__BOOLEAN__IsWavHeaderRequired | Is WAV header required for destination file (WAV would be result) or not (RAW would be result).
OUT PULONG p__PULONG__UncompressedSizeInUCHARs | Pointer to the variable to receive uncompressed payload size in UCHARs.
IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK | Pointer to callback function to process progress indication and I/O cancellation.
IN PVOID p__PVOID__Context | Pointer to the context value passed to callback function.
Returns

Execution status.

Description

This function uncompresses compressed file to either WAV or RAW PCM.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileUncompress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileUncompressUnicode Function

StarBurn_StarWave_CompressedFileUncompressUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileUncompressUnicode(
    IN PWCHAR p__PWCHAR__SourceCompressedFileName,
    IN PWCHAR p__PWCHAR__DestinationUncompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    IN BOOLEAN p__BOOLEAN__IsWavHeaderRequired,
    OUT PULONG p__PULONG__UncompressedSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_CompressedFileUncompressUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileWriterObjectCreate Function

StarBurn_StarWave_CompressedFileWriterObjectCreate Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileWriterObjectCreate(
    OUT PVOID * p__PPVOID__CompressedFileWriterObject,
    IN PCHAR p__PCHAR__CompressedFileName,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CompressedFileWriterObject | Pointer to pointer to compressed file writer object.
IN PCHAR p__PCHAR__CompressedFileName | Pointer to compressed file name.
IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION | Compression template.
Returns

Execution status.

Description

This function creates compressed file writer object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress,

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectCreate API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode Function

StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode(
    OUT PVOID * p__PPVOID__CompressedFileWriterObject,
    IN PWCHAR p__PWCHAR__CompressedFileName,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileWriterObjectDestroy Function

StarBurn_StarWave_CompressedFileWriterObjectDestroy Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileWriterObjectDestroy(
    OUT PVOID * p__PPVOID__CompressedFileWriterObject
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID * p__PPVOID__CompressedFileWriterObject | Pointer to pointer to compressed file writer object.
Returns

Execution status.

Description

This function destroys compressed file writer object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileSupportedIs

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectDestroy API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileWriterObjectWrite Function

StarBurn_StarWave_CompressedFileWriterObjectWrite Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_CompressedFileWriterObjectWrite(
    OUT PVOID p__PVOID__CompressedFileWriterObject,
    IN PVOID p__PVOID__WriterDataBuffer,
    IN ULONG p__ULONG__WriterSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PVOID p__PVOID__CompressedFileWriterObject | Pointer to compressed file writer object.
IN PVOID p__PVOID__WriterDataBuffer | Pointer to data buffer to write.
p__ULONG__WriteSizeInUCHARs | Data buffer to write size in UCHARs.
Returns

Execution status.

Description

This function writes uncompressed data chunk to compressed file writer object.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectWrite API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileCompress Function

StarBurn_StarWave_UncompressedFileCompress Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_UncompressedFileCompress(
    IN PCHAR p__PCHAR__SourceUncompressedFileName,
    IN PCHAR p__PCHAR__DestinationCompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__SourceUncompressedFileName | Pointer to source uncompressed file name.
IN PCHAR p__PCHAR__DestinationCompressedFileName | Pointer to destination compressed file name.
IN ULONG p__ULONG__WorkingBufferSizeInUCHARs | Working buffer size in UCHARs (recommended to have it equal to STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS).
IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK | Pointer to callback function to process progress indication and I/O cancellation.
IN PVOID p__PVOID__Context | Pointer to the context value passed to callback function.
IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION | Compression template.
Returns

Execution status.

Description

This function compresses uncompressed file to new one with asked compression.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_UncompressedFileCompress API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileCompressUnicode Function

StarBurn_StarWave_UncompressedFileCompressUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_UncompressedFileCompressUnicode(
    IN PWCHAR p__PWCHAR__SourceUncompressedFileName,
    IN PWCHAR p__PWCHAR__DestinationCompressedFileName,
    IN ULONG p__ULONG__WorkingBufferSizeInUCHARs,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__Context,
    IN STARBURN_STARWAVE_COMPRESSION p__STARBURN_STARWAVE_COMPRESSION
);
File

StarBurn.h

Description

This is function StarBurn_StarWave_UncompressedFileCompressUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileSupportedIs Function

StarBurn_StarWave_UncompressedFileSupportedIs Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_UncompressedFileSupportedIs(
    IN PCHAR p__PCHAR__UncompressedFileName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR__UncompressedFileName | Pointer to uncompressed file name.
Returns

Execution status.

Description

This function checks is file name actually points to supported uncompressed audio file.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_UncompressedFileSupportedIs API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileSupportedUnicodeIs Function

StarBurn_StarWave_UncompressedFileSupportedUnicodeIs Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_UncompressedFileSupportedUnicodeIs(
    IN PWCHAR p__PWCHAR__UncompressedFileName
);
File

StarBurn.h

Parameters
Parameters | Description
IN PWCHAR p__PWCHAR__UncompressedFileName | Pointer to uncompressed Unicode file name.
Returns

Execution status.

Description

This function checks is file name actually points to supported uncompressed audio file.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx Function

StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx Function
StarBurn.h | Functions | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx(
    IN PWCHAR p__PWCHAR__UncompressedFileName,
    OUT PULONG p__PULONG__HeaderSizeInUCHARs,
    OUT PULONG p__PULONG__DataSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PWCHAR p__PWCHAR__UncompressedFileName | Pointer to uncompressed Unicode file name.
Returns

Execution status.

Description

This function checks is file name actually points to supported uncompressed audio file.

Remarks

None.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_UncompressedFileSupportedUnicodeIs

Group

Functions

Links
StarBurn.h, Functions, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_VersionGet Function

StarBurn_StarWave_VersionGet Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave_VersionGet(
    OUT PULONG p__PULONG__StarWaveVersion
);
File

StarBurn.h

Parameters
Parameters | Description
OUT PULONG p__PULONG__StarWaveVersion | Pointer to the variable to receive StarWave build version.
Returns

Execution status. This call cannot fail unless wrong pointer is passed as input parameter.

Description

This function returns StarWave library version.

Remarks

Actually StarWave version build number is synchronized with StarBurn build number. So there's no real use in calling this API call any more.

See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs

Example

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_VersionGet API call.

Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_Convert Function

StarBurn_StarWave2_Convert Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_StarWave2_Convert(
    PCHAR p__PCHAR__InputFileName,
    PCHAR p__PCHAR__OutputFileName,
    PSTARWAVE2_COMPRESSION_PROFILE p__PSTARWAVE2_COMPRESSION_PROFILE
);
File

StarBurn.h

Parameters
Parameters | Description
i_input_file_name | Pointer to CHAR array with input file name.
i_output_file_name | Pointer to CHAR array with output file name.
ip_convert_settings | Pointer to conversion settings structure. It depends on file writer.
Returns

True if convertion was successfull. False otherwice.

Description

This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)

Remarks

To use FLAC format you should register StarWaveFlac.dll via StarBurn_StarWave2_RegisterCustomConverter.

Example

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_Convert is similar with obvious changes.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_ConvertEx Function

StarBurn_StarWave2_ConvertEx Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_StarWave2_ConvertEx(
    CFuncStarWaveConversionCallback i_callback_function,
    PVOID ip_user_data,
    PCHAR i_input_file_name,
    PCHAR i_output_file_name,
    ULONG i_buffer_size,
    PSTARWAVE2_COMPRESSION_PROFILE p__PSTARWAVE2_COMPRESSION_PROFILE
);
File

StarBurn.h

Parameters
Parameters | Description
CFuncStarWaveConversionCallback i_callback_function | Address of callback function for notify about progress and force to stop process of conversion.
PVOID ip_user_data | Pointer to data that is passed to callback function
PCHAR i_input_file_name | Pointer to CHAR array with input file name.
PCHAR i_output_file_name | Pointer to CHAR array with output file name.
ULONG i_buffer_size | Size of intermediate buffer. If this parameter is 0 size will be 50000 byte.
ip_convert_settings | Pointer to conversion settings structure. It depends on file writer.
Returns

True if convertion was successfull. False otherwice.

Description

This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)

Remarks

To use FLAC format you should register StarWaveFlac.dll via StarBurn_StarWave2_RegisterCustomConverter.

Example

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_ConvertEx is similar with obvious changes.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_ConvertExUnicode Function

StarBurn_StarWave2_ConvertExUnicode Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_StarWave2_ConvertExUnicode(
    CFuncStarWaveConversionCallback i_callback_function,
    PVOID ip_user_data,
    PWCHAR i_input_file_name,
    PWCHAR i_output_file_name,
    ULONG i_buffer_size,
    PSTARWAVE2_COMPRESSION_PROFILE p__PSTARWAVE2_COMPRESSION_PROFILE
);
File

StarBurn.h

Parameters
Parameters | Description
CFuncStarWaveConversionCallback i_callback_function | Address of callback function for notify about progress and force to stop process of conversion.
PVOID ip_user_data | Pointer to data that is passed to callback function
PWCHAR i_input_file_name | Pointer to WCHAR array with input file name.
PWCHAR i_output_file_name | Pointer to WCHAR array with output file name.
ULONG i_buffer_size | Size of intermediate buffer. If this parameter is 0 size will be 50000 byte.
PSTARWAVE2_COMPRESSION_PROFILE p__PSTARWAVE2_COMPRESSION_PROFILE | Pointer to conversion settings structure. It depends on file writer.
Returns

True if convertion was successfull. False otherwice.

Description

This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)

Remarks

To use FLAC format you should register StarWaveFlac.dll via StarBurn_StarWave2_RegisterCustomConverter.

Example

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertEx. Use of StarBurn_StarWave2_ConvertExUnicode is similar with obvious changes.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_ConvertUnicode Function

StarBurn_StarWave2_ConvertUnicode Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API BOOL StarBurn_StarWave2_ConvertUnicode(
    PWCHAR p__PWCHAR__InputFileName,
    PWCHAR p__PWCHAR__OutputFileName,
    PSTARWAVE2_COMPRESSION_PROFILE p__PSTARWAVE2_COMPRESSION_PROFILE
);
File

StarBurn.h

Parameters
Parameters | Description
i_input_file_name | Pointer to WCHAR array with input file name.
i_output_file_name | Pointer to WCHAR array with output file name.
ip_convert_settings | Pointer to conversion settings structure. It depends on file writer.
Returns

True if convertion was successfull. False otherwice.

Description

This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)

Remarks

To use FLAC format you should register StarWaveFlac.dll via StarBurn_StarWave2_RegisterCustomConverter.

Example

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_ConvertUnicode is similar with obvious changes.

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_EncodeMP3OGGFromWAV Function

StarBurn_StarWave2_EncodeMP3OGGFromWAV Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarWave2_EncodeMP3OGGFromWAV(
    IN PCHAR p__PCHAR_SrcFileName,
    IN PCHAR p__PCHAR_DstFileName,
    IN PSTARBURN_STARWAVE2_INIT_PARAMS p_PSTARBURN_STARWAVE2_INIT_PARAMS,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__CallbackContext,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Parameters
Parameters | Description
IN PCHAR p__PCHAR_SrcFileName | Pointer to source file full path (WAV file)
IN PCHAR p__PCHAR_DstFileName | Pointer to destination file full path (MP3 or OGG file)
IN PSTARBURN_STARWAVE2_INIT_PARAMS p_PSTARBURN_STARWAVE2_INIT_PARAMS | Pointer to initialization structure (See STARBURN_STARWAVE2_INIT_PARAMS)
IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK | Pointer to callback function.
IN PVOID p__PVOID__CallbackContext | Pointer to callback context.
OUT PCHAR p__PCHAR__ExceptionText | Error text buffer size in UCHARs.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Error text buffer size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error value (error code WIN32/Vorbis/Nlame). For detailed information see p__PCHAR__ExceptionText.
Returns

Return true if finish successful, otherwise false. If function return false see error code (p__PULONG__SystemError), and error detailed information (p__PCHAR__ExceptionText).

Description

This function compress audio file from WAV (44100Hz, 16, stereo) format to MP3 and OGG format.

Remarks

None.

Example

See AudioCompressor StarBurn sample applications as an example how to use

Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode Function

StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode(
    IN PWCHAR p__PWCHAR_SrcFileName,
    IN PWCHAR p__PWCHAR_DstFileName,
    IN PSTARBURN_STARWAVE2_INIT_PARAMS p_PSTARBURN_STARWAVE2_INIT_PARAMS,
    IN PSTARBURN_STARWAVE_CALLBACK p__PSTARBURN_STARWAVE_CALLBACK,
    IN PVOID p__PVOID__CallbackContext,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError
);
File

StarBurn.h

Description

This is function StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_IsFileSupported Function

StarBurn_StarWave2_IsFileSupported Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave2_IsFileSupported(
    PCHAR i_input_file_name
);
File

StarBurn.h

Parameters
Parameters | Description
i_filename | Pointer to CHAR array with file name.
Returns

Windows error. ERROR_SUCCESS if file is supported. ERROR_NOT_SUPPORTED otherwise.

Description

This function determines audio file by StarWave2 library supported is.

Remarks

None.

Example
ULONG res = StarBurn_StarWave2_IsFileSupported("track1.wav");

if(res == ERROR_SUCCESS)
{
    ... //doing smth with file
}
Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_IsFileSupportedUnicode Function

StarBurn_StarWave2_IsFileSupportedUnicode Function
StarBurn.h | Functions | Example
Collapse All
C++
__stdcall STARBURN_IMPEX_API ULONG StarBurn_StarWave2_IsFileSupportedUnicode(
    PWCHAR i_input_file_name
);
File

StarBurn.h

Parameters
Parameters | Description
i_filename | Pointer to WCHAR array with file name.
Returns

Windows error. ERROR_SUCCESS if file is supported. ERROR_NOT_SUPPORTED otherwise.

Description

This function determines audio file by StarWave2 library supported is.

Remarks

None.

Example
ULONG res = StarBurn_StarWave2_IsFileSupportedUnicode(CA2W("track1.wav"));

if(res == ERROR_SUCCESS)
{
    ... //doing smth with file
}
Group

Functions

Links
StarBurn.h, Functions, Example
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_strcpy_s Function

StarBurn_strcpy_s Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_strcpy_s(
    char * strDestination,
    size_t numberOfElements,
    const char * strSource
);
File

StarBurn.h

Parameters
Parameters | Description
char * strDestination | Location of destination string buffer.
size_t numberOfElements | Size of the destination string buffer.
const char * strSource | Null-terminated source string buffer.
Description

This function wrap runtime strcpy_s function. In Visual Studio 2003 function strcpy_s not present.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_swprintf_s Function

StarBurn_swprintf_s Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_swprintf_s(
    wchar_t * buffer,
    size_t sizeOfBuffer,
    const wchar_t * format,
    ...
);
File

StarBurn.h

Parameters
Parameters | Description
wchar_t * buffer | Storage location for output.
size_t sizeOfBuffer | Maximum number of characters to store.
const wchar_t * format | Format-control string.
argument | Optional arguments.
Description

This function wrap runtime swprintf_s function. In Visual Studio 2003 oriinal swprintf_s not present.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_Add Function

StarBurn_UDF_Add Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_Add(
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__DirectoryOrFileAbsolutePathAndName,
    IN PCHAR p__PCHAR__DirectoryOrFileNewName,
    IN PVOID p__PVOID__UDF__Parent,
    OUT PVOID * p__PPVOID__UDF__NewChild
);
File

StarBurn.h

Returns

Exception number

Description

Creates the UDF Tree Node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_AddUnicode Function

StarBurn_UDF_AddUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_AddUnicode(
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PWCHAR p__PWCHAR__DirectoryOrFileAbsolutePathAndName,
    IN PWCHAR p__PWCHAR__DirectoryOrFileNewName,
    IN PVOID p__PVOID__UDF__Parent,
    OUT PVOID * p__PPVOID__UDF__NewChild
);
File

StarBurn.h

Description

This is function StarBurn_UDF_AddUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CleanUp Function

StarBurn_UDF_CleanUp Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF_CleanUp(
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    unsigned long p__ULONG__NumberOfTreeItems
);
File

StarBurn.h

Parameters
Parameters | Description
PUDF_TREE_ITEM p__PUDF_TREE_ITEM | Pointer to allocated and formatted as file UDF tree root node.
unsigned long p__ULONG__NumberOfTreeItems | Number of tree items to process.
Returns

Nothing. This function cannot fail.

Description

This function removes created UDF tree from the pointed UDF tree node sequentially. Processes file formatted UDF nodes and either closes file handles or frees memory (non-cached vs. cached content).

Remarks

Please check DVDVideoBuildImage and DVDVideoTrackAtOnceFromTree samples to find out how to use StarBurn_UDF_CleanUp() in the right way.

See Also

StarBurn_UDF_CreateEx, StarBurn_UDF_Destroy, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile

Example

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_TREE_ITEM l__UDF_TREE_ITEM__File[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff
StarBurn_UDF_CleanUp(
    &l__UDF_TREE_ITEN__File[ 0 ],
    10
    );

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_Create Function

StarBurn_UDF_Create Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_Create(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootVideo,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootAudio,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__VolumeLabel
);
File

StarBurn.h

Description

StarBurn_UDF_Create() function is obsolete. Use StarBurn_UDF_CreatEx() instead of it

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CreateEx Function

StarBurn_UDF_CreateEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_CreateEx(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootVideo,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootAudio,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__VolumeLabel,
    IN PCHAR p__PCHAR__PublisherPreparerName,
    IN PCHAR p__PCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Parameters
Parameters | Description
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot | Pointer to UDF root node.
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootVideo | Pointer to UDF root node for VIDEO_TS directory.
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootAudio | Pointer to UDF root node for AUDIO_TS directory.
IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK | Pointer to UDF control block.
OUT PCHAR p__PCHAR__ExceptionText | Pointer to exception text.
IN ULONG p__ULONG__ExceptionTextSizeInUCHARs | Exception text size in UCHARs.
OUT PULONG p__PULONG__SystemError | Pointer to system error.
IN PCHAR p__PCHAR__VolumeLabel | Pointer to volume label for UDF image.
IN PCHAR p__PCHAR__PublisherPreparerName | Pointer to publisher and preparer name.
IN PCHAR p__PCHAR__ApplicationName | Pointer to application name.
IN LONG p__LONG__Year | Year of creation.
IN LONG p__LONG__Month | Month of creation.
IN LONG p__LONG__Day | Day of creation.
IN LONG p__LONG__Hour | Hour of creation.
IN LONG p__LONG__Minute | Minute of creation.
IN LONG p__LONG__Second | Second of creation.
IN LONG p__LONG__MilliSecond | Millisecond of creation.
Returns

Execution status. EN_SUCCESS if the operation completed successfully. If the exception number will be EN_SYSTEM_CALL_FAILED, variable that SystemError points to will be filled with system error. If something other then EN_SUCCESS will be returned buffer that ExceptionText will point to will be filled with formatted exception message.

Description

This function creates UDF tree from the allocated data buffers.

Remarks

Please check DVDVideoBuildImage and DVDVideoTrackAtOnceFromTree samples to find out how to use StarBurn_UDF_CreateEx() in the right way.

See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile

Example

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

unsigned char g__UCHAR__FileSystemHead[ ( UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemTail[ ( UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemStructures[ ( 1024 * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];

UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CreateExUnicode Function

StarBurn_UDF_CreateExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_CreateExUnicode(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootVideo,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootAudio,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PWCHAR p__PWCHAR__VolumeLabel,
    IN PWCHAR p__PWCHAR__PublisherPreparerName,
    IN PWCHAR p__PWCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Description

This is function StarBurn_UDF_CreateExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CreateUnicode Function

StarBurn_UDF_CreateUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_CreateUnicode(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootVideo,
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__ISO9660UDFBridgeRootAudio,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PWCHAR p__PWCHAR__VolumeLabel
);
File

StarBurn.h

Description

This is function StarBurn_UDF_CreateUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_Destroy Function

StarBurn_UDF_Destroy Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API VOID StarBurn_UDF_Destroy(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Root,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK
);
File

StarBurn.h

Parameters
Parameters | Description
IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Root | Pointer to allocated and formatted UDF tree root node.
IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK | Pointer to UDF control block.
Returns

Nothing. This function cannot fail.

Description

This function devastates created UDF tree from the pointed root recursively.

Remarks

Please check DVDVideoBuildImage and DVDVideoTrackAtOnceFromTree samples to find out how to use StarBurn_UDF_Destroy() in the right way.

See Also

StarBurn_UDF_CreateEx, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile

Example

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Director[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_DestroyNodeAndKids Function

StarBurn_UDF_DestroyNodeAndKids Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDF_DestroyNodeAndKids(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Returns

Exception number

Description

Destroys UDF Tree Node and all its kids

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsDirectory Function

StarBurn_UDF_FormatTreeItemAsDirectory Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF_FormatTreeItemAsDirectory(
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    unsigned long p__ULONG__GUID,
    char * p__PCHAR__Name,
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
PUDF_TREE_ITEM p__PUDF_TREE_ITEM | Pointer to UDF tree item to format as file.
unsigned long p__ULONG__GUID | Globally unique identifier.
char * p__PCHAR__Name | Pointer to name of the node to use in UDF volume.
PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent | Pointer to parent node.
Returns

Nothing. This function cannot fail.

Description

This function formats UDF tree item as directory.

Remarks

Please check DVDVideoBuildImage and DVDVideoTrackAtOnceFromTree samples to find out how to use StarBurn_UDF_FormatTreeItemAsDirectory() in the right way.

See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsFile

Example

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

unsigned char g__UCHAR__FileSystemHead[ ( UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemTail[ ( UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemStructures[ ( 1024 * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];

UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format VIDEO_TS directory
StarBurn_UDF_FormatTreeItemAsDirectory(
    &l__UDF_TREE_ITEM__Directory[ 2 ],
    ( ++l__ULONG__GUID ),
    "VIDEO_TS",
    &l__UDF_TREE_ITEM__Directory[ 1 ]
    );

// Format file node 1 as file
l__ULONG__SystemError =
StarBurn_UDF_FormatTreeItemAsFile(
    &g__UDF_TREE_ITEM__File[ 1 ],
    ( ++l__ULONG__GUID ),
    "video_ts.ifo",
    "c:\VOB\video_ts.ifo",
    &l__UDF_TREE_ITEM__Directory[ 2 ]
    );

// Handle error case here if l__ULONG__SystemError is not NO_ERROR...

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    ( PUCHAR )( &g__UCHAR__FileSystemHead ),
    sizeof( g__UCHAR__FileSystemHead ),
    ( PUCHAR )( &g__UCHAR__FileSystemTail ),
    sizeof( g__UCHAR__FileSystemTail ),
    ( PUCHAR )( &g__UCHAR__FileSystemStructures ),
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsDirectoryUnicode Function

StarBurn_UDF_FormatTreeItemAsDirectoryUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF_FormatTreeItemAsDirectoryUnicode(
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    unsigned long p__ULONG__GUID,
    WCHAR * p__PWCHAR__Name,
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent
);
File

StarBurn.h

Description

This is function StarBurn_UDF_FormatTreeItemAsDirectoryUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsFile Function

StarBurn_UDF_FormatTreeItemAsFile Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API unsigned long StarBurn_UDF_FormatTreeItemAsFile(
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    unsigned long p__ULONG__GUID,
    char * p__PCHAR__Name,
    char * p__PCHAR__FullPath,
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
PUDF_TREE_ITEM p__PUDF_TREE_ITEM | Pointer to UDF tree item to format as file.
unsigned long p__ULONG__GUID | Globally unique identifier.
char * p__PCHAR__Name | Pointer to name of the node to use in UDF volume.
char * p__PCHAR__FullPath | Pointer to file path on the disk.
PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent | Pointer to parent node.
Returns

Execution status. NO_ERROR means everything is OK and Win32 system error is returned otherwise.

Description

This function formats UDF tree item as file.

Remarks

Please check DVDVideoBuildImage and DVDVideoTrackAtOnceFromTree samples to find out how to use StarBurn_UDF_FormatTreeItemAsFile() in the right way.

See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory

Example

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;
UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format file node 1 as file
l__ULONG__SystemError =
StarBurn_UDF_FormatTreeItemAsFile(
    &g__UDF_TREE_ITEM__File[ 1 ],
    ( ++l__ULONG__GUID ),
    "video_ts.ifo",
    "c:\VOB\video_ts.ifo",
    &l__UDF_TREE_ITEM__Directory[ 2 ]
    );

// Handle error case here if l__ULONG__SystemError is not NO_ERROR...

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsFileUnicode Function

StarBurn_UDF_FormatTreeItemAsFileUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API unsigned long StarBurn_UDF_FormatTreeItemAsFileUnicode(
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM,
    unsigned long p__ULONG__GUID,
    CONST WCHAR * p__PWCHAR__Name,
    CONST WCHAR * p__PWCHAR__FullPath,
    PUDF_TREE_ITEM p__PUDF_TREE_ITEM__Parent
);
File

StarBurn.h

Description

This is function StarBurn_UDF_FormatTreeItemAsFileUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_GetFirstChild Function

StarBurn_UDF_GetFirstChild Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_UDF_GetFirstChild(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__UDF__Parent | Pointer to file tree node
Returns

Pointer to first child node of passed node

Description

This function returns the pointer to first child node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_GetNextSibling Function

StarBurn_UDF_GetNextSibling Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_UDF_GetNextSibling(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__UDF__Parent | Pointer to file tree node
Returns

Pointer to next sibling of passed node

Description

This function returns the pointer to next sibling node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_GetNodeObject Function

StarBurn_UDF_GetNodeObject Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API PUDF_TREE_ITEM StarBurn_UDF_GetNodeObject(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Returns

Pointer to UDF_TREE_ITEM object associated with passed node

Description

Returns the object to current Tree Node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_GetParent Function

StarBurn_UDF_GetParent Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_UDF_GetParent(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__UDF__Parent | Pointer to file tree node
Returns

Pointer to parent node of passed node

Description

This function returns the pointer to next parent node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_GetPreviousSibling Function

StarBurn_UDF_GetPreviousSibling Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API PVOID StarBurn_UDF_GetPreviousSibling(
    IN PVOID p__PVOID__UDF__Parent
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__UDF__Parent | Pointer to file tree node
Returns

Pointer to next sibling of passed node

Description

This function returns the pointer to previous sibling node

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryBrowse Function

StarBurn_UDF2_DirectoryBrowse Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void * StarBurn_UDF2_DirectoryBrowse(
    void * Directory,
    void * Last
);
File

StarBurn.h

Parameters
Parameters | Description
void * Directory | Pointer to UDF directory object.
void * Last | Pointer to last processed kid node (or NULL if we need first kid node in the kids list).
Returns

Pointer to currently processed kid node (or NULL if we've reached end of the kids list).

Description

This function browses UDF directory content.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryContentsProcess Function

StarBurn_UDF2_DirectoryContentsProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryContentsProcess(
    const char * PathName,
    unsigned long * GUID,
    void * Root,
    PSTARBURN_UDF2_PROGRESS_CALLBACK Callback,
    const void * Context,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
const char * PathName | Directory path and name (zero-terminated string).
unsigned long * GUID | Pointer to GUID.
void * Root | Pointer to directory where contents should be added.
PSTARBURN_UDF2_PROGRESS_CALLBACK Callback | Pointer to progress callback.
const void * Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to date and time structure.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes contents of single UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryContentsProcessEx Function

StarBurn_UDF2_DirectoryContentsProcessEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryContentsProcessEx(
    const char * PathName,
    unsigned long * GUID,
    void * Root,
    PSTARBURN_UDF2_PROGRESS_CALLBACK Callback,
    const void * Context,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    PSTARBURN_UDF2_COLLISION_CALLBACK_EX CollisionCallback,
    const void* CollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
const char * PathName | Directory path and name (zero-terminated string).
unsigned long * GUID | Pointer to GUID.
void * Root | Pointer to directory where contents should be added.
PSTARBURN_UDF2_PROGRESS_CALLBACK Callback | Pointer to progress callback.
const void * Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to date and time structure.
PSTARBURN_UDF2_COLLISION_CALLBACK_EX CollisionCallback | Pointer to name collision callback
const void* CollisionContext | Pointer to context value.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes contents of single UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryContentsUnicodeProcess Function

StarBurn_UDF2_DirectoryContentsUnicodeProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryContentsUnicodeProcess(
    const unsigned short* UnicodePathName,
    unsigned long* GUID,
    void* Root,
    PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK ProgressCallback,
    const void* ProgressContext,
    STARBURN_UDF2_FILE_DATE_TIME* DateTime,
    PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX CollisionCallback,
    const void* CollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long* GUID | Pointer to GUID.
void* Root | Pointer to directory where contents should be added.
STARBURN_UDF2_FILE_DATE_TIME* DateTime | Pointer to date and time structure.
Callback | Pointer to UDF UNICODE progress callback.
Context | Pointer to context value.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes contents of single UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryContentsUnicodeProcessEx Function

StarBurn_UDF2_DirectoryContentsUnicodeProcessEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryContentsUnicodeProcessEx(
    const unsigned short* UnicodePathName,
    unsigned long* GUID,
    void* Root,
    PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK ProgressCallback,
    const void* ProgressContext,
    STARBURN_UDF2_FILE_DATE_TIME* DateTime,
    PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX CollisionCallback,
    const void* CollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long* GUID | Pointer to GUID.
void* Root | Pointer to directory where contents should be added.
STARBURN_UDF2_FILE_DATE_TIME* DateTime | Pointer to date and time structure.
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX CollisionCallback | Pointer to name collision callback
const void* CollisionContext | Pointer to context value.
Callback | Pointer to UDF UNICODE progress callback.
Context | Pointer to context value.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes contents of single UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryCreate Function

StarBurn_UDF2_DirectoryCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryCreate(
    void ** Directory,
    const char * Name,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
const char * Name | Pointer to zero-terminated directory name.
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryDestroy Function

StarBurn_UDF2_DirectoryDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_DirectoryDestroy(
    void * Directory
);
File

StarBurn.h

Parameters
Parameters | Description
void * Directory | Pointer to directory object to destroy.
Returns

Nothing

Description

This function destroys created UDF directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryProcess Function

StarBurn_UDF2_DirectoryProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryProcess(
    const char * Name,
    const char * PathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
const char * Name | Directory name itself (zero-terminated string).
const char * PathName | Directory path and name (zero-terminated string).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryProcessEx Function

StarBurn_UDF2_DirectoryProcessEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryProcessEx(
    const char * Name,
    const char * PathName,
    unsigned long * GUID,
    void * Parent,
    PSTARBURN_UDF2_PROGRESS_CALLBACK Callback,
    const void * Context,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
const char * Name | Directory name itself (zero-terminated string).
const char * PathName | Directory path and name (zero-terminated string).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
PSTARBURN_UDF2_PROGRESS_CALLBACK Callback | Pointer to progress callback.
const void * Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to date and time structure.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryProcessExEx Function

StarBurn_UDF2_DirectoryProcessExEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryProcessExEx(
    const char * Name,
    const char * PathName,
    unsigned long * GUID,
    void * Parent,
    PSTARBURN_UDF2_PROGRESS_CALLBACK Callback,
    const void * Context,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    PSTARBURN_UDF2_COLLISION_CALLBACK_EX CollisionCallback,
    const void* CollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
const char * Name | Directory name itself (zero-terminated string).
const char * PathName | Directory path and name (zero-terminated string).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
PSTARBURN_UDF2_PROGRESS_CALLBACK Callback | Pointer to progress callback.
const void * Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to date and time structure.
PSTARBURN_UDF2_COLLISION_CALLBACK_EX CollisionCallback | Pointer to name collision callback
const void* CollisionContext | Pointer to context value.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryQuery Function

StarBurn_UDF2_DirectoryQuery Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_DirectoryQuery(
    void * Directory,
    STARBURN_UDF2_DIRECTORY_INFO * Info
);
File

StarBurn.h

Parameters
Parameters | Description
void * Directory | Pointer to UDF directory object.
STARBURN_UDF2_DIRECTORY_INFO * Info | Pointer to UDF directory information structure.
Returns

Nothing

Description

This function does query for UDF directory properties.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryRootCreate Function

StarBurn_UDF2_DirectoryRootCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryRootCreate(
    void ** Directory,
    unsigned long * GUID
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
unsigned long * GUID | Pointer to GUID.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates root UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryUnicodeCreate Function

StarBurn_UDF2_DirectoryUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryUnicodeCreate(
    void ** Directory,
    const unsigned short * UnicodeName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Directory | Pointer to pointer to directory object.
const unsigned short * UnicodeName | Pointer to zero-terminated directory name (UNICODE format).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryUnicodeProcess Function

StarBurn_UDF2_DirectoryUnicodeProcess Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryUnicodeProcess(
    const unsigned short * UnicodeName,
    const unsigned short * UnicodePathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short * UnicodeName | Directory name itself (zero-terminated string in UNICODE format).
const unsigned short * UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryUnicodeProcessEx Function

StarBurn_UDF2_DirectoryUnicodeProcessEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryUnicodeProcessEx(
    const unsigned short* UnicodeName,
    const unsigned short* UnicodePathName,
    unsigned long* GUID,
    void* Parent,
    PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Callback,
    const void* Context,
    STARBURN_UDF2_FILE_DATE_TIME* DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodeName | Directory name itself (zero-terminated string in UNICODE format).
const unsigned short* UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long* GUID | Pointer to GUID.
void* Parent | Pointer to parent directory.
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Callback | Pointer to UDF UNICODE progress callback.
const void* Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME* DateTime | Pointer to date and time structure.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_DirectoryUnicodeProcessExEx Function

StarBurn_UDF2_DirectoryUnicodeProcessExEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_DirectoryUnicodeProcessExEx(
    const unsigned short* UnicodeName,
    const unsigned short* UnicodePathName,
    unsigned long* GUID,
    void* Parent,
    PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Callback,
    const void* Context,
    STARBURN_UDF2_FILE_DATE_TIME* DateTime,
    PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX CollisionCallback,
    const void* CollisionContext
);
File

StarBurn.h

Parameters
Parameters | Description
const unsigned short* UnicodeName | Directory name itself (zero-terminated string in UNICODE format).
const unsigned short* UnicodePathName | Directory path and name (zero-terminated string in UNICODE format).
unsigned long* GUID | Pointer to GUID.
void* Parent | Pointer to parent directory.
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Callback | Pointer to UDF UNICODE progress callback.
const void* Context | Pointer to context value.
STARBURN_UDF2_FILE_DATE_TIME* DateTime | Pointer to date and time structure.
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX CollisionCallback | Pointer to name collision callback
const void* CollisionContext | Pointer to context value.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function processes single UNICODE UDF directory.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileBootCreate Function

StarBurn_UDF2_FileBootCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileBootCreate(
    void ** File,
    const char * Name,
    const char * PathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const char * Name | Pointer to zero-terminated name.
const char * PathName | Pointer to zero-terminated path and name.
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF boot file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileBootUnicodeCreate Function

StarBurn_UDF2_FileBootUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileBootUnicodeCreate(
    void ** File,
    const unsigned short * UnicodeName,
    const unsigned short * UnicodePathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const unsigned short * UnicodeName | Pointer to zero-terminated name (UNICODE format).
const unsigned short * UnicodePathName | Pointer to zero-terminated path and name (UNICODE format).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE UDF boot file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileCreate Function

StarBurn_UDF2_FileCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileCreate(
    void ** File,
    const char * Name,
    const char * PathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const char * Name | Pointer to zero-terminated name.
const char * PathName | Pointer to zero-terminated path and name.
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDestroy Function

StarBurn_UDF2_FileDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDestroy(
    void * File
);
File

StarBurn.h

Parameters
Parameters | Description
void * File | Pointer to file object to destroy.
Returns

Nothing

Description

This function destroys created UDF file object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryDateTimeGet Function

StarBurn_UDF2_FileDirectoryDateTimeGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryDateTimeGet(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to output file date and time.
Returns

Nothing

Description

This function gets date and time from created UDF file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryDateTimeGetEx Function

StarBurn_UDF2_FileDirectoryDateTimeGetEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryDateTimeGetEx(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    STARBURN_UDF2_FILE_DATE_TIME_TYPE Type
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to input file date and time.
DateType | Type of date and time to be set
Returns

Nothing

Description

This function gets date and time from created UDF file or directory object.

It may get creation, last access, or last write date and time.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryDateTimeSet Function

StarBurn_UDF2_FileDirectoryDateTimeSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryDateTimeSet(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to input file date and time.
Returns

Nothing

Description

This function sets date and time on created UDF file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryDateTimeSetEx Function

StarBurn_UDF2_FileDirectoryDateTimeSetEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryDateTimeSetEx(
    void * FileDirectory,
    STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    STARBURN_UDF2_FILE_DATE_TIME_TYPE DateType
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to file or directory object.
STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to input file date and time.
STARBURN_UDF2_FILE_DATE_TIME_TYPE DateType | Type of date and time to be set
Returns

Nothing

Description

This function sets date and time on created UDF file or directory object.

It may set creation, last access, or last write date and time.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryNameSet Function

StarBurn_UDF2_FileDirectoryNameSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryNameSet(
    void * FileDirectory,
    const char * Name
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to UDF file or directory object.
const char * Name | Pointer to new file or directory name.
Returns

Nothing

Description

This function set new name for UDF file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileDirectoryUnicodeNameSet Function

StarBurn_UDF2_FileDirectoryUnicodeNameSet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileDirectoryUnicodeNameSet(
    void * FileDirectory,
    const unsigned short * UnicodeName
);
File

StarBurn.h

Parameters
Parameters | Description
void * FileDirectory | Pointer to UDF file or directory object.
const unsigned short * UnicodeName | Pointer to new file or directory UNICODE name.
Returns

Nothing

Description

This function set new UNICODE name for UDF file or directory object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileMemoryCreate Function

StarBurn_UDF2_FileMemoryCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileMemoryCreate(
    void ** File,
    const char * Name,
    const void * MemoryRegion,
    unsigned long MemoryRegionSizeInUCHARs,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const char * Name | Pointer to zero-terminated name.
const void * MemoryRegion | Pointer to memory region.
unsigned long MemoryRegionSizeInUCHARs | Memory region size in unsigned chars.
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF memory file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileMemoryUnicodeCreate Function

StarBurn_UDF2_FileMemoryUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileMemoryUnicodeCreate(
    void ** File,
    const unsigned short * UnicodeName,
    const void * MemoryRegion,
    unsigned long MemoryRegionSizeInUCHARs,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const unsigned short * UnicodeName | Pointer to zero-terminated name (UNICODE format).
const void * MemoryRegion | Pointer to memory region.
unsigned long MemoryRegionSizeInUCHARs | Memory region size in unsigned chars.
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE UDF memory file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileQuery Function

StarBurn_UDF2_FileQuery Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileQuery(
    void * File,
    STARBURN_UDF2_FILE_INFO * Info
);
File

StarBurn.h

Parameters
Parameters | Description
void * File | Pointer to UDF file object.
STARBURN_UDF2_FILE_INFO * Info | Pointer to UDF file information structure.
Returns

Nothing

Description

This function do query for UDF file properties.

Remarks

Some structure fields are valid only for imported or non-imported nodes. Refer to structure description.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileSetAttributes Function

StarBurn_UDF2_FileSetAttributes Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_FileSetAttributes(
    void* File,
    unsigned long Attributes
);
File

StarBurn.h

Parameters
Parameters | Description
void* File | Pointer to UDF file object.
unsigned long Attributes | File attributes bit mask.
Returns

Nothing.

Description

This function sets attributes for UDF file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileSystemGetSizes Function

StarBurn_UDF2_FileSystemGetSizes Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileSystemGetSizes(
    void * Root,
    UDF_VERSION Version,
    unsigned long * VolumeSizeInLBs,
    unsigned long long * VolumeSizeInBytes
);
File

StarBurn.h

Parameters
Parameters | Description
void * Root | Pointer to root directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function calculates UDF file system sizes in Bytes and LBS on the fly ( without build volume ).

Version

UDF version (use only constants defined in versions like NAPALM_UDF_VERSION_1_02)

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_FileUnicodeCreate Function

StarBurn_UDF2_FileUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_FileUnicodeCreate(
    void ** File,
    const unsigned short * UnicodeName,
    const unsigned short * UnicodePathName,
    unsigned long * GUID,
    void * Parent
);
File

StarBurn.h

Parameters
Parameters | Description
void ** File | Pointer to pointer to file object.
const unsigned short * UnicodeName | Pointer to zero-terminated name (UNICODE format).
const unsigned short * UnicodePathName | Pointer to zero-terminated path and name (UNICODE format).
unsigned long * GUID | Pointer to GUID.
void * Parent | Pointer to parent directory.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UNICODE UDF file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_ImpVolumeCreate Function

StarBurn_UDF2_ImpVolumeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_ImpVolumeCreate(
    void ** Volume,
    void * Root,
    unsigned long * GUID,
    PSTARBURN_UDF2_IMPORT_CALLBACK ImportCallback,
    void * CallbackContext,
    unsigned long VolumeSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to UDF import volume object.
void * Root | Pointer to root directory.
unsigned long * GUID | Pointer to GUID.
PSTARBURN_UDF2_IMPORT_CALLBACK ImportCallback | Pointer to import callback.
void * CallbackContext | Pointer to callback context.
unsigned long VolumeSizeInLBs | Volume size in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF import volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_ImpVolumeDestroy Function

StarBurn_UDF2_ImpVolumeDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_ImpVolumeDestroy(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to UDF import volume object to destroy.
Returns

Nothing.

Description

This function destroys created UDF import volume object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_ImpVolumeImport Function

StarBurn_UDF2_ImpVolumeImport Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_ImpVolumeImport(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to the UDF import volume object.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function imports UDF import volume content.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_ISO9660FileTreeCreate Function

StarBurn_UDF2_ISO9660FileTreeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_ISO9660FileTreeCreate(
    void ** ISO9660FileTree,
    void * UdfVolume
);
File

StarBurn.h

Parameters
Parameters | Description
void ** ISO9660FileTree | Pointer to pointer to the object that toolkit will set to the ISO 9660 File Tree object it will allocate.
void * UdfVolume | Pointer to UDF volume object that toolkit allocated before.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function create ISO image from already created UDF volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_ISO9660FileTreeCreateEx Function

StarBurn_UDF2_ISO9660FileTreeCreateEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_ISO9660FileTreeCreateEx(
    void ** ISO9660FileTree,
    void ** UdfVolumes,
    UINT numVolumes
);
File

StarBurn.h

Parameters
Parameters | Description
void ** ISO9660FileTree | Pointer to pointer to the object that toolkit will set to the ISO 9660 File Tree object it will allocate.
UdfVolume | Pointer to UDF volume object that toolkit allocated before.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function create ISO image from already created UDF volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeAnchorGet Function

StarBurn_UDF2_VolumeAnchorGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeAnchorGet(
    void * Volume,
    void * Descriptor,
    unsigned long DescriptorSizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
void * Descriptor | Pointer to descriptor buffer to read data to.
unsigned long DescriptorSizeInUCHARs | Descriptor buffer size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function gets first anchor volume descriptor pointer we'll have to replace on rewritable media.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreate Function

StarBurn_UDF2_VolumeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeCreate(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned char OSClass,
    unsigned long InitialVolumeSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name.
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned char OSClass | OS class to assign to the volume.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF 1.02 volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreateBoot Function

StarBurn_UDF2_VolumeCreateBoot Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeCreateBoot(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs,
    const char * SystemIdentifier,
    const char * VolumeIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier,
    const char * ValidationIdentifier,
    unsigned char BootMediaType,
    unsigned short LoadSegment,
    unsigned char SystemType,
    unsigned char SectorCount
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name.
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF Bootable volume.

Version

UDF version.

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

SystemIdentifier - Pointer to zero-terminated string with volume name system identifier.

VolumeIdentifier - Pointer to zero-terminated string with volume identifier.

VolumeSetIdentifier - Pointer to zero-terminated string with volume set identifier.

PublisherIdentifier - Pointer to zero-terminated string with publisher identifier.

DataPreparerIdentifier - Pointer to zero-terminated string with data preparer identifier.

ApplicationIdentifier - Pointer to zero-terminated string with application identifier.

CopyrightFileIdentifier - Pointer to zero-terminated string with copyright file identifier.

AbstractFileIdentifier - Pointer to zero-terminated string with abstract file identifier.

BibliographicFileIdentifier - Pointer to zero-terminated string with bibliographic file identifier.

ValidationIdentifier - Pointer to zero-terminated string with volume name validation identifier.

BootMediaType - Media type of bootable volume.

LoadSegment - Load segment

SystemType - System type

SectorCount - Number of sectors to load from boot image.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreateBootElTorito Function

StarBurn_UDF2_VolumeCreateBootElTorito Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeCreateBootElTorito(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs,
    void * BootCatalog,
    const char * SystemIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name.
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF Bootable volume.

Version

UDF version.

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

BootCatalog - Pointer to ElTorito boot catalog

SystemIdentifier - Pointer to zero-terminated string with volume name system identifier.

VolumeSetIdentifier - Pointer to zero-terminated string with volume set identifier.

PublisherIdentifier - Pointer to zero-terminated string with publisher identifier.

DataPreparerIdentifier - Pointer to zero-terminated string with data preparer identifier.

ApplicationIdentifier - Pointer to zero-terminated string with application identifier.

CopyrightFileIdentifier - Pointer to zero-terminated string with copyright file identifier.

AbstractFileIdentifier - Pointer to zero-terminated string with abstract file identifier.

BibliographicFileIdentifier - Pointer to zero-terminated string with bibliographic file identifier.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreateEx Function

StarBurn_UDF2_VolumeCreateEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeCreateEx(
    void ** Volume,
    void * Root,
    const char * Name,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const char * Name | Pointer to zero-terminated string with volume name.
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF volume.

Version

UDF version (use only constants defined in versions like NAPALM_UDF_VERSION_1_02)

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreateUnicodeBootElTorito Function

StarBurn_UDF2_VolumeCreateUnicodeBootElTorito Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeCreateUnicodeBootElTorito(
    void ** Volume,
    void * Root,
    unsigned short * UnicodeName,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs,
    void * BootCatalog,
    unsigned short * SystemIdentifier,
    unsigned short * VolumeSetIdentifier,
    unsigned short * PublisherIdentifier,
    unsigned short * DataPreparerIdentifier,
    unsigned short * ApplicationIdentifier,
    unsigned short * CopyrightFileIdentifier,
    unsigned short * AbstractFileIdentifier,
    unsigned short * BibliographicFileIdentifier
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Name | Pointer to zero-terminated string with volume name.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF Bootable volume.

Version

UDF version.

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

BootCatalog - Pointer to ElTorito boot catalog

SystemIdentifier - Pointer to zero-terminated string with volume name system identifier.

VolumeSetIdentifier - Pointer to zero-terminated string with volume set identifier.

PublisherIdentifier - Pointer to zero-terminated string with publisher identifier.

DataPreparerIdentifier - Pointer to zero-terminated string with data preparer identifier.

ApplicationIdentifier - Pointer to zero-terminated string with application identifier.

CopyrightFileIdentifier - Pointer to zero-terminated string with copyright file identifier.

AbstractFileIdentifier - Pointer to zero-terminated string with abstract file identifier.

BibliographicFileIdentifier - Pointer to zero-terminated string with bibliographic file identifier.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeDestroy Function

StarBurn_UDF2_VolumeDestroy Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API void StarBurn_UDF2_VolumeDestroy(
    void * Volume
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to UDF volume object to destroy.
Returns

Nothing

Description

This function destroys created UDF volume object.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeInitialSizeInLBsGet Function

StarBurn_UDF2_VolumeInitialSizeInLBsGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeInitialSizeInLBsGet(
    void * Volume,
    long * InitialSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
SizeInUCHARs | Pointer to the variable to receive UDF volume initial size in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function get UDF volume size in unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeSeekRead Function

StarBurn_UDF2_VolumeSeekRead Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeSeekRead(
    void * Volume,
    void * Buffer,
    unsigned long BufferSizeInLogicalBlocks,
    unsigned long OffsetInLogicalBlocks
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
void * Buffer | Pointer to data buffer to read data to.
unsigned long BufferSizeInLogicalBlocks | Buffer size in logical blocks.
unsigned long OffsetInLogicalBlocks | Offset within UDF volume in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function seeks to passed offset and reads requested amount of data.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeSizeInLBsGet Function

StarBurn_UDF2_VolumeSizeInLBsGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeSizeInLBsGet(
    void * Volume,
    unsigned long * SizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
SizeInUCHARs | Pointer to the variable to receive UDF volume size in logical blocks.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function get UDF volume size in unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeSizeInUCHARsGet Function

StarBurn_UDF2_VolumeSizeInUCHARsGet Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeSizeInUCHARsGet(
    void * Volume,
    unsigned __int64 * SizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
unsigned __int64 * SizeInUCHARs | Pointer to the variable to receive UDF volume size in unsigned chars.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function get UDF volume size in unsigned chars.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeStore Function

StarBurn_UDF2_VolumeStore Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeStore(
    void * Volume,
    const char * Name
);
File

StarBurn.h

Parameters
Parameters | Description
void * Volume | Pointer to volume object.
const char * Name | Pointer to zero-terminated string with file name to store volume to.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function stores UDF volume to file.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeUnicodeCreate Function

StarBurn_UDF2_VolumeUnicodeCreate Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeUnicodeCreate(
    void ** Volume,
    void * Root,
    const unsigned short * UnicodeName,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    unsigned char OSClass,
    unsigned long InitialVolumeSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const unsigned short * UnicodeName | Pointer to zero-terminated string with volume name (in UNICODE).
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
unsigned char OSClass | OS class to assign to the volume.
unsigned long InitialVolumeSizeInLBs | Initial volume size in logical blocks (offset to build volume from).
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF 1.02 UNICODE volume.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeUnicodeCreateBoot Function

StarBurn_UDF2_VolumeUnicodeCreateBoot Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeUnicodeCreateBoot(
    void ** Volume,
    void * Root,
    unsigned short * UnicodeName,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs,
    const char * SystemIdentifier,
    const char * VolumeIdentifier,
    const char * VolumeSetIdentifier,
    const char * PublisherIdentifier,
    const char * DataPreparerIdentifier,
    const char * ApplicationIdentifier,
    const char * CopyrightFileIdentifier,
    const char * AbstractFileIdentifier,
    const char * BibliographicFileIdentifier,
    const char * ValidationIdentifier,
    unsigned char BootMediaType,
    unsigned short LoadSegment,
    unsigned char SystemType,
    unsigned char SectorCount
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
unsigned short * UnicodeName | Pointer to zero-terminated string with volume name (in UNICODE).
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF Unicode Bootable volume.

Version

UDF version.

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

SystemIdentifier - Pointer to zero-terminated string with volume name system identifier.

VolumeIdentifier - Pointer to zero-terminated string with volume identifier.

VolumeSetIdentifier - Pointer to zero-terminated string with volume set identifier.

PublisherIdentifier - Pointer to zero-terminated string with publisher identifier.

DataPreparerIdentifier - Pointer to zero-terminated string with data preparer identifier.

ApplicationIdentifier - Pointer to zero-terminated string with application identifier.

CopyrightFileIdentifier - Pointer to zero-terminated string with copyright file identifier.

AbstractFileIdentifier - Pointer to zero-terminated string with abstract file identifier.

BibliographicFileIdentifier - Pointer to zero-terminated string with bibliographic file identifier.

ValidationIdentifier - Pointer to zero-terminated string with volume name validation identifier.

BootMediaType - Media type of bootable volume.

LoadSegment - Load segment

SystemType - System type

SectorCount - Number of sectors to load from boot image.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeUnicodeCreateEx Function

StarBurn_UDF2_VolumeUnicodeCreateEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API long StarBurn_UDF2_VolumeUnicodeCreateEx(
    void ** Volume,
    void * Root,
    const unsigned short * UnicodeName,
    BOOL IsUnicode,
    BOOL IsGlobalDateTime,
    const STARBURN_UDF2_FILE_DATE_TIME * DateTime,
    UDF_OS_CLASS OSClass,
    UDF_VERSION Version,
    unsigned long InitialVolumeSizeInLBs
);
File

StarBurn.h

Parameters
Parameters | Description
void ** Volume | Pointer to pointer to volume object.
void * Root | Pointer to root directory.
const unsigned short * UnicodeName | Pointer to zero-terminated string with volume name (in UNICODE).
BOOL IsUnicode | Is UNICODE (should we convert single character nodes to UNICODE).
BOOL IsGlobalDateTime | Is global date and time (should we set all files and directories on the volume to global date and time).
const STARBURN_UDF2_FILE_DATE_TIME * DateTime | Pointer to volume global date and time structure.
UDF_OS_CLASS OSClass | OS class to assign to the volume.
Returns

If success then returns ERROR_SUCCESS, otherwise error code.

Description

This function creates UDF UNICODE volume.

Version

UDF version.

InitialVolumeSizeInLBs - Initial volume size in logical blocks (offset to build volume from).

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDFBridge_CreateEx Function

StarBurn_UDFBridge_CreateEx Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDFBridge_CreateEx(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN STARBURN_UDF_BRIDGE_TYPE p__UDF_BRIDGE_TYPE,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PCHAR p__PCHAR__VolumeLabel,
    IN PCHAR p__PCHAR__PublisherPreparerName,
    IN PCHAR p__PCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Description

This is function StarBurn_UDFBridge_CreateEx.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDFBridge_CreateExUnicode Function

StarBurn_UDFBridge_CreateExUnicode Function
StarBurn.h | Functions
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UDFBridge_CreateExUnicode(
    IN PUDF_TREE_ITEM p__PUDF_TREE_ITEM__UDFRoot,
    IN STARBURN_UDF_BRIDGE_TYPE p__UDF_BRIDGE_TYPE,
    IN PUDF_CONTROL_BLOCK p__PUDF_CONTROL_BLOCK,
    OUT PCHAR p__PCHAR__ExceptionText,
    IN ULONG p__ULONG__ExceptionTextSizeInUCHARs,
    OUT PULONG p__PULONG__SystemError,
    IN PWCHAR p__PWCHAR__VolumeLabel,
    IN PWCHAR p__PWCHAR__PublisherPreparerName,
    IN PWCHAR p__PWCHAR__ApplicationName,
    IN LONG p__LONG__Year,
    IN LONG p__LONG__Month,
    IN LONG p__LONG__Day,
    IN LONG p__LONG__Hour,
    IN LONG p__LONG__Minute,
    IN LONG p__LONG__Second,
    IN LONG p__LONG__MilliSecond
);
File

StarBurn.h

Description

This is function StarBurn_UDFBridge_CreateExUnicode.

Group

Functions

Links
StarBurn.h, Functions
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UpStart Function

StarBurn_UpStart Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UpStart(
    IN VOID
);
File

StarBurn.h

Returns

Execution status. EN_SUCCESS if initialization process completed successfully.

Description

This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. License file StarBurn.key is assumed to be located near main application executable. Since StarBurn SDK V12 it's possible to use this call again. It will just enable using embedded evaluational StarBurn SDK key (file shipped with StarBurn SDK and called StarBurnKey.h).

Remarks

See samples for details how and when call StarBurn_UpStart() function.

See Also

See samples for details how and when call StarBurn_UpStart() function.

Example

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStart();

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UpStartEx Function

StarBurn_UpStartEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UpStartEx(
    IN PVOID p__PVOID__RegistrationKey,
    IN ULONG p__ULONG__RegistrationKeySizeInUCHARs
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__RegistrationKey | Pointer to registration key.
IN ULONG p__ULONG__RegistrationKeySizeInUCHARs | Registration key size in UCHARs.
Returns

Execution status. EN_SUCCESS if initialization process completed successfully.

Description

This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. The difference between this call and call to StarBurn_UpStart(...) is that this particular call assumes StarBurn key is being embedded to the application binary and StarBurn_UpStart(...) always looks for StarBurn.key near application executable. Use this API call to initialize your application using registry-stored debug parameters, use StarBurn_UpStart(...) API call to initialize your app with embedded evaluational key and use advanced StarBurn_UpStartExEx(...) API call to pass user-defined extended debug parameters (unique to all burning applications using the same StarBurn SDK on the same machine).

Remarks

See samples for details how and when call StarBurn_UpStartEx() and StarBurn_UpStart() functions.

See Also

See samples for details how and when call StarBurn_UpStart() and StarBurn_UpStartEx() functions.

Example

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
UCHAR l__UCHAR__RegistrationKey[ ] = { ... }; // Registration key goes here

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStartEx(
    ( PVOID )( &l__UCHAR__RegistrationKey ),
    sizeof( l__UCHAR__RegistrationKey )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UpStartExEx Function

StarBurn_UpStartExEx Function
StarBurn.h | Functions | Example | See Also
Collapse All
C++
__stdcall STARBURN_IMPEX_API EXCEPTION_NUMBER StarBurn_UpStartExEx(
    IN PVOID p__PVOID__RegistrationKey,
    IN ULONG p__ULONG__RegistrationKeySizeInUCHARs,
    IN ULONG p__ULONG__DebugFacility,
    IN PCHAR p__PCHAR__DebugFileName,
    IN HANDLE p__HANDLE__DebugCustomHandle
);
File

StarBurn.h

Parameters
Parameters | Description
IN PVOID p__PVOID__RegistrationKey | Pointer to registration key.
IN ULONG p__ULONG__RegistrationKeySizeInUCHARs | Registration key size in UCHARs.
IN ULONG p__ULONG__DebugFacility | Debug facility (None, debug output, log file, system console or custom). Please use next constant: STARBURN_DEBUG_FACILITY_NONE, STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT, STARBURN_DEBUG_FACILITY_LOG_FILE, STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE, STARBURN_DEBUG_FACILITY_CUSTOM
IN PCHAR p__PCHAR__DebugFileName | Debug log file name (used with log file debug facility).
IN HANDLE p__HANDLE__DebugCustomHandle | Debug file handle (used with custom debug facility).
Returns

Execution status. EN_SUCCESS if initialization process completed successfully.

Description

This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Unlike StarBurn_UpStartEx(...) API call this one allows to use custom debug output control. See StarBurn_UpStartEx(...) API call for more information about this topic.

Remarks

See samples for details how and when call StarBurn_UpStartEx() and StarBurn_UpStart() functions.

See Also

See samples for details how and when call StarBurn_UpStart() and StarBurn_UpStartEx() functions.

Example

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
UCHAR l__UCHAR__RegistrationKey[ ] = { ... }; // Registration key goes here
HANDLE l__HANDLE__DebugLogFile = INVALID_HANDLE_VALUE;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// We assume l__HANDLE__DebugLogFile was initialized before

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStartExEx(
    ( PVOID )( &l__UCHAR__RegistrationKey ),
    sizeof( l__UCHAR__RegistrationKey ),
    STARBURN_DEBUG_FACILITY_CUSTOM,
    NULL,
    l__HANDLE__DebugLogFile
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}
Group

Functions

Links
StarBurn.h, Functions, Example, See Also
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Structs, Records, Enums

Structs, Records, Enums
Enumerations | Legend | Structures
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
_CALLBACK_NUMBER | Enum that represents callback number
_DISC_TYPE | Enum that represents inserted disc type
_ERASE_TYPE | Enum that represents erase type
_EXCEPTION_NUMBER | Enum that represents exception number
_FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
_FILE_TREE | Enum that represents file tree
_ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
_NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
_READ_MODE | Enum that represents raw read modes
_STARBURN_CD_MODE | Enum that represents CD modes type
_STARBURN_ELTORITO_MEDIA | Media emulation types
_STARBURN_ELTORITO_PLATFORM | ElTorito platform types
_STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
_STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
_STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
_STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
_STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
_STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
_STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
_STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_UDF_OS_CLASS | UDF OS class
_UDF_VERSION | Enum that represents UDF version
_WRITE_MODE | Enum that represents write modes
CALLBACK_NUMBER | Enum that represents callback number
DISC_TYPE | Enum that represents inserted disc type
ERASE_TYPE | Enum that represents erase type
EXCEPTION_NUMBER | Enum that represents exception number
FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
FILE_TREE | Enum that represents file tree
ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PCALLBACK_NUMBER | Enum that represents callback number
PDISC_TYPE | Enum that represents inserted disc type
PERASE_TYPE | Enum that represents erase type
PEXCEPTION_NUMBER | Enum that represents exception number
PFILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
PFILE_TREE | Enum that represents file tree
PISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
PNAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PPSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PPSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PPSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PPSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PREAD_MODE | Enum that represents raw read modes
PSTARBURN_CD_MODE | Enum that represents CD modes type
PSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PSTARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
PSTARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
PSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PWRITE_MODE | Enum that represents write modes
READ_MODE | Enum that represents raw read modes
STARBURN_CD_MODE | Enum that represents CD modes type
STARBURN_ELTORITO_MEDIA | Media emulation types
STARBURN_ELTORITO_PLATFORM | ElTorito platform types
STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
UDF_OS_CLASS | UDF OS class
UDF_VERSION | Enum that represents UDF version
WRITE_MODE | Enum that represents write modes
Structures
Name | Description
_CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
_DAO_DISC_LAYOUT | Structure that represents DAO disc layout
_DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
_DISC_FILESYSTEM | Structure with disc file system flags
_DISC_LAYOUT | Structure that represents disc layout
_DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
_DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
_FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
_ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
_NAME_COLLISION_INFO | Structure that represents information about name collision
_PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
_SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
_STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
_STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
_STARBURN_DISC_INFORMATION | Structure that represents Disc information
_STARBURN_ISO9660_DIRECTORY_INFO | This is record _STARBURN_ISO9660_DIRECTORY_INFO.
_STARBURN_ISO9660_FILE_INFO | ISO9660 file information
_STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
_STARBURN_TRACK_INFORMATION | Structure that represents Track information
_STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
_STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
_STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
_STARBURN_UDF2_FILE_INFO | UDF file information
_STARPORT_DEVICE_LIST | Structure that represents StarPort device list
_STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
_STARWAVE2_COMPRESSION_PROFILE |
_TOC_ENTRY | Structure that represents TOC entry
_TOC_INFORMATION | Structure that represents TOC information
_UDF_CONTROL_BLOCK | Structure that represents UDF control block
_UDF_FILE_EXTENT | Structure that describes a single file extent
_UDF_FILE_HANDLE | Structure that represents UDF file handle
_UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
_UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_TREE_ITEM | Structure that represents UDF tree item
_WAVE_FILE_HEADER | Structure that represents WAVE file header
_WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
DAO_DISC_LAYOUT | Structure that represents DAO disc layout
DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
DISC_FILESYSTEM | Structure with disc file system flags
DISC_LAYOUT | Structure that represents disc layout
DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
NAME_COLLISION_INFO | Structure that represents information about name collision
PCDB_FAILURE_INFORMATION | Structure that represents CDB failure information
PDAO_DISC_LAYOUT | Structure that represents DAO disc layout
PDAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
PDISC_FILESYSTEM | Structure with disc file system flags
PDISC_LAYOUT | Structure that represents disc layout
PDISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
PDVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
PFULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
PISO9660_DATE_TIME | Structure that represents ISO9660 date and time
PNAME_COLLISION_INFO | Structure that represents information about name collision
PPQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PPSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PPSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PPSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PPSTARWAVE2_COMPRESSION_PROFILE |
PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PSCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
PSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PSTARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
PSTARBURN_DISC_INFORMATION | Structure that represents Disc information
PSTARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
PSTARBURN_TRACK_INFORMATION | Structure that represents Track information
PSTARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
PSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PSTARWAVE2_COMPRESSION_PROFILE |
PTOC_ENTRY | Structure that represents TOC entry
PTOC_INFORMATION | Structure that represents TOC information
PUDF_CONTROL_BLOCK | Structure that represents UDF control block
PUDF_FILE_EXTENT | Structure that describes a single file extent
PUDF_FILE_HANDLE | Structure that represents UDF file handle
PUDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
PUDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_TREE_ITEM | Structure that represents UDF tree item
PWAVE_FILE_HEADER | Structure that represents WAVE file header
PWAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
STARBURN_DISC_INFORMATION | Structure that represents Disc information
STARBURN_ISO9660_DIRECTORY_INFO | This is type STARBURN_ISO9660_DIRECTORY_INFO.
STARBURN_ISO9660_FILE_INFO | ISO9660 file information
STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
STARBURN_TRACK_INFORMATION | Structure that represents Track information
STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
STARBURN_UDF2_FILE_INFO | UDF file information
STARPORT_DEVICE_LIST | Structure that represents StarPort device list
STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
STARWAVE2_COMPRESSION_PROFILE |
TOC_ENTRY | Structure that represents TOC entry
TOC_INFORMATION | Structure that represents TOC information
UDF_CONTROL_BLOCK | Structure that represents UDF control block
UDF_FILE_EXTENT | Structure that describes a single file extent
UDF_FILE_HANDLE | Structure that represents UDF file handle
UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_TREE_ITEM | Structure that represents UDF tree item
WAVE_FILE_HEADER | Structure that represents WAVE file header
WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
Links
Enumerations, Legend, Structures
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_CALLBACK_NUMBER Enumeration

_CALLBACK_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _CALLBACK_NUMBER {
  CN_FILE_TREE_PROGRESS_ADD = 0,
  CN_FILE_TREE_PROGRESS_REMOVE,
  CN_FILE_TREE_PROGRESS_IGNORE,
  CN_FILE_TREE_PROGRESS_NAME_COLLISION,
  CN_TARGET_FILE_ANALYZE_BEGIN,
  CN_TARGET_FILE_ANALYZE_END,
  CN_WAIT_CACHE_FULL_BEGIN,
  CN_WAIT_CACHE_FULL_END,
  CN_SYNCHRONIZE_CACHE_BEGIN,
  CN_SYNCHRONIZE_CACHE_END,
  CN_FIND_DEVICE,
  CN_CDVD_READ_PROGRESS,
  CN_CDVD_WRITE_PROGRESS,
  CN_CDVD_BUFFER_STATUS,
  CN_CDVD_TRACK_BEGIN,
  CN_CDVD_TRACK_END,
  CN_CDVD_SPLIT_BEGIN,
  CN_CDVD_SPLIT_END,
  CN_CDVD_READ_BAD_BLOCK_HIT,
  CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT,
  CN_CDVD_READ_RETRY,
  CN_DVDPLUSRW_FORMAT_BEGIN,
  CN_DVDPLUSRW_FORMAT_END,
  CN_DVDRAM_FORMAT_BEGIN,
  CN_DVDRAM_FORMAT_END,
  CN_BUFFER_UNDERRUN,
  CN_DVD_MEDIA_PADDING_SIZE,
  CN_DVD_MEDIA_PADDING_BEGIN,
  CN_DVD_MEDIA_PADDING_END,
  CN_CDVD_READ_CANCEL_QUERY,
  CN_DVDRW_QUICK_FORMAT_BEGIN,
  CN_DVDRW_QUICK_FORMAT_END,
  CN_DVD_TEST_WRITE_DISABLED,
  CN_CDVD_DPM_BEGIN,
  CN_CDVD_DPM_END,
  CN_CDVD_DPM_PROGRESS,
  CN_CDVD_VERIFY_PROGRESS,
  CN_SAO_TRACK_WRITE_BEGIN,
  CN_SAO_TRACK_WRITE_END,
  CN_DVD_MEDIA_PADDING_WRITE_PROGRESS,
  CN_CDVD_WRITE_BEGIN,
  CN_CDVD_WRITE_END,
  CN_CDVD_VERIFY_BEGIN,
  CN_CDVD_VERIFY_END,
  CN_BDRE_FORMAT_BEGIN,
  CN_BDRE_FORMAT_END,
  CN_UDF_FILE_LOOKUP,
  CN_UDF_LOOKUP_FILE,
  CN_UDF_LOOKUP_DIR,
  CN_CDVD_BLANKAREA_PROGRESS
};
File

StarBurn.h

Description

Enum that represents callback number

Member | Definition
CN_FILE_TREE_PROGRESS_ADD | Item was add to the file tree
CN_FILE_TREE_PROGRESS_REMOVE | Item was removed from the file tree
CN_FILE_TREE_PROGRESS_IGNORE | Item was ignored during processing file tree
CN_FILE_TREE_PROGRESS_NAME... | There are two nodes which have the same name
CN_TARGET_FILE_ANALYZE_BEGIN | File internal structure (size, type etc) analyze started
CN_TARGET_FILE_ANALYZE_END | File structure analyze completed
CN_WAIT_CACHE_FULL_BEGIN | Toolkit started to wait for cache to become full
CN_WAIT_CACHE_FULL_END | Toolkit finished to wait for cache fullness
CN_SYNCHRONIZE_CACHE_BEGIN | Cache flushing to the media started
CN_SYNCHRONIZE_CACHE_END | Cache flushing to the media completed
CN_FIND_DEVICE | Find device operation completed
CD_CDVD_READ_PROGRESS | CD/DVD/Blu-Ray/HD-DVD read operation progress
CN_CDVD_WRITE_PROGRESS | CD/DVD/Blu-Ray/HD-DVD write operation progress
CN_CDVD_BUFFER_STATUS | CD/DVD/Blu-Ray/HD-DVD buffer status information queried
CN_CDVD_TRACK_BEGIN | CD/DVD/Blu-Ray/HD-DVD track processing started
CN_CDVD_TRACK_END | CD/DVD/Blu-Ray/HD-DVD track processing completed
CN_CDVD_SPLIT_BEGIN | CD/DVD/Blu-Ray/HD-DVD split section processing started
CN_CDVD_SPLIT_END | CD/DVD/Blu-Ray/HD-DVD split section processing completed
CN_CDVD_READ_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a bad (unrecoverable) block
CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a ECC/EDC bad (recoverable) block
CN_CDVD_READ_RETRY | CD/DVD/Blu-Ray/HD-DVD read operation was retried
CN_DVDPLUSRW_FORMAT_BEGIN | DVD+RW format operation started
CN_DVDPLUSRW_FORMAT_EDN | DVD+RW format operation completed
CN_DVDRAM_FORMAT_BEGIN | DVD-RAM format operation started
CN_DVDRAM_FORMAT_EDN | DVD-RAM format operation completed
CN_BUFFER_UNDERRUN | Buffer underrun condition happened
CN_DVD_MEDIA_PADDING_SIZE | DVD media would be padded to 1GB size, additional info passed
CN_DVD_MEDIA_PADDING_BEGIN | DVD media padding burn process started
CN_DVD_MEDIA_PADDING_END | DVD media padding burn process completed
CN_CDVD_READ_CANCEL_QUERY | CD/DVD/Blu-Ray/HD-DVD media processing plug-in queries cancel status
CN_DVDRW_QUICK_FORMAT_BEGIN | DVD-RW quick format operation started
CN_DVDRW_QUICK_FORMAT_END | DVD-RW quick format operation completed
CN_DVD_TEST_WRITE_DISABLED | Test write is disabled (for DVD+R/RW, DVD-RAM or multisession DVD-RW)
CN_CDVD_DPM_BEGIN | CD/DVD/Blu-Ray/HD-DVD DPM processing started
CN_CDVD_DPM_END | CD/DVD/Blu-Ray/HD-DVD DPM processing completed
CD_CDVD_DPM_PROGRESS | CD/DVD/Blu-Ray/HD-DVD DPM operation progress
CN_CDVD_VERIFY_PROGRESS | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_SAO_TRACK_WRITE_BEGIN | SAO track write started
CN_SAO_TRACK_WRITE_END | SAO track write completed
CN_DVD_MEDIA_PADDING_WRITE_PRO... | DVD media padding burn progress indication
CN_CDVD_WRITE_BEGIN | CD/DVD/Blu-Ray/HD-DVD write operation started
CN_CDVD_WRITE_END | CD/DVD/Blu-Ray/HD-DVD write operation completed
CN_CDVD_VERIFY_BEGIN | CD/DVD/Blu-Ray/HD-DVD verify operation started
CN_CDVD_VERIFY_END | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_BDRE_FORMAT_BEGIN | BD-RE format operation started
CN_BDRE_FORMAT_END | BD-RE format operation completed
CN_UDF_FILE_LOOKUP | UDF file found during fast lookup
CN_UDF_LOOKUP_FILE | UDF file found during fast lookup
CN_UDF_LOOKUP_DIR | UDF directory found during fast lookup
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_CDB_FAILURE_INFORMATION Structure

_CDB_FAILURE_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _CDB_FAILURE_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__CDBSizeInUCHARs;
  UCHAR m__UCHAR__CDB[ 16 ];
  UCHAR m__UCHAR__SenseSizeInUCHARs;
  UCHAR m__UCHAR__Sense[ 32 ];
  UCHAR m__UCHAR__TransportStatus;
  UCHAR m__UCHAR__TargetStatus;
  UCHAR m__UCHAR__HostAdapterStatus;
};
File

StarBurn.h

Description

Structure that represents CDB failure information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__CDBSizeInUCHARs | CDB size in UCHARs
m__UCHAR__CDB[ 16 ] | CDB dump
m__UCHAR__SenseSizeInUCHARs | SCSI sense size in UCHARs
m__UCHAR__Sense[ 32 ] | SCSI sense dump
m__UCHAR__TransportStatus | SCSI transport status
m__UCHAR__TargetStatus | SCSI target status
m__UCHAR__HostAdapterStatus | SCSI host adapter status
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DAO_DISC_LAYOUT Structure

_DAO_DISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DAO_DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DAO_DISC_LAYOUT_ENTRY m__DAO_DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
};
File

StarBurn.h

Description

Structure that represents DAO disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DAO_DISC_LAYOUT_ENTRY | DAO disc layout entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DAO_DISC_LAYOUT_ENTRY Structure

_DAO_DISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DAO_DISC_LAYOUT_ENTRY {
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__TrackStartingLBA;
  BOOLEAN m__BOOLEAN__IsUnicode;
  union {
    CHAR m__CHAR__TrackName[ (MAX_PATH * sizeof(WCHAR) ) ];
    WCHAR m__WCHAR__TrackName[ (MAX_PATH) ];
  };
  PVOID m__PVOID__File;
  BOOLEAN m__BOOLEAN__IsDataTrack;
  BOOLEAN m__BOOLEAN__IsRawTrack;
  BOOLEAN m__BOOLEAN__IsAudioExTrack;
};
File

StarBurn.h

Description

Structure that represents DAO disc layout entry (track)

Member | Definition
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__TrackStartingLBA | Track starting LBA (logical block address)
m__BOOLEAN__IsUnicode | Is name in Unicode format or not (see below)
m__CHAR__TrackName | Track name (absolute path & name) in ANSI or Unicode format (see above)
m__PVOID__File | Pointer to internally created disk file object (NULL initially)
m__BOOLEAN__IsDataTrack | Is this data track (audio otherwise)
m__BOOLEAN__IsRawTrack | Is this raw track (MDF image)
m__BOOLEAN__IsAudioExTrack | Is this extended audio track (2448 UCHARs/logical block)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DISC_FILESYSTEM Structure

_DISC_FILESYSTEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DISC_FILESYSTEM {
  BOOLEAN m__BOOLEAN__UDFPresent;
  BOOLEAN m__BOOLEAN__JolietPresent;
  BOOLEAN m__BOOLEAN__ISO9660Present;
  BOOLEAN m__BOOLEAN__ElToritoBootRecordPresent;
};
File

StarBurn.h

Description

Structure with disc file system flags

Member Definition

--------- --------------

m__BOOLEAN__UDFPresent UDF file system is present
m__BOOLEAN__ISO9660Present ISO9660 file system is present
m__BOOLEAN__JolietPresent Joliet extension for ISO9660 file system is present
m__BOOLEAN__ElToritoBootRecordPresent El Torito boot record is present
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DISC_LAYOUT Structure

_DISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DISC_LAYOUT_ENTRY m__DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
  LONG m__LONG__NumberOfRawRawPWTracks;
  LONG m__LONG__RawRawPWTrackSizeInLBs[ NUMBER_OF_TRACKS ];
};
File

StarBurn.h

Description

Structure that represents disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DISC_LAYOUT_ENTRY | Disc layout entries
m__LONG__NumberOfRawRawPWTracks | Number of raw + raw P-W sub-channel tracks
m__LONG__RawRawPWTrackSize | Raw + raw P-W sub-channel track sizes
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DISC_LAYOUT_ENTRY Structure

_DISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DISC_LAYOUT_ENTRY {
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsVideo;
  BOOLEAN m__BOOLEAN__IsRawRawPW;
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__PreGapSizeInLBs;
  LONG m__LONG__PostGapSizeInLBs;
  union {
    CHAR m__CHAR__TrackName[ MAX_PATH*sizeof(WCHAR) ];
    WCHAR m__WCHAR__TrackName[ MAX_PATH ];
  };
  PVOID m__PVOID__File;
  PVOID m__PVOID__Tree;
  PVOID m__PVOID__BackSideTree;
};
File

StarBurn.h

Description

Structure that represents disc layout entry (track)

Member | Definition
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsVideo | Is this video track
m__BOOLEAN__IsRawRawPW | Is this raw + raw P-W sub-channel track
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__PreGapSizeInLBs | PreGap size in LBs (logical blocks)
m__LONG__PostGapSizeInLBs | PostGap size in LBs (logical blocks)
m__CHAR__TrackName | Track name (absolute path & name), can be zero array if next pointer is valid
m__PVOID__File | Pointer to internally created disk file object
m__PVOID__Tree | Pointer to object created with StarBurn_ISO9660JolietFileTree_Create(), can be NULL
m__PVOID__BackSideTree | Pointer to undecorated ISO9660 file tree object
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DISC_TYPE Enumeration

_DISC_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _DISC_TYPE {
  DISC_TYPE_UNKNOWN = 0,
  DISC_TYPE_CDROM = 1,
  DISC_TYPE_CDR = 2,
  DISC_TYPE_CDRW = 3,
  DISC_TYPE_DVDROM = 4,
  DISC_TYPE_DVDR = 5,
  DISC_TYPE_DVDRAM = 6,
  DISC_TYPE_DVDRWRO = 7,
  DISC_TYPE_DVDRWSR = 8,
  DISC_TYPE_DVDPLUSRW = 9,
  DISC_TYPE_DDCDROM = 10,
  DISC_TYPE_DDCDR = 11,
  DISC_TYPE_DDCDRW = 12,
  DISC_TYPE_DVDPLUSR = 13,
  DISC_TYPE_NO_MEDIA = 14,
  DISC_TYPE_DVDPLUSR_DL = 15,
  DISC_TYPE_DVDR_DL = 16,
  DISC_TYPE_BDROM = 17,
  DISC_TYPE_BDR = 18,
  DISC_TYPE_BDRE = 19,
  DISC_TYPE_HDDVDROM = 20,
  DISC_TYPE_HDDVDR = 21,
  DISC_TYPE_HDDVDRW = 22
};
File

StarBurn.h

Description

Enum that represents inserted disc type

Member | Definition
DISC_TYPE_UNKNOWN | Unknown disc type
DISC_TYPE_CDROM, | CD-ROM
DISC_TYPE_CDR, | CD-R
DISC_TYPE_CDRW, | CD-RW
DISC_TYPE_DVDROM, | DVD-ROM
DISC_TYPE_DVDR, | DVD-R
DISC_TYPE_DVDRAM, | DVD-RAM
DISC_TYPE_DVDRWRO, | DVD-RW RO (Restricted Overwrite)
DISC_TYPE_DVDRWSR, | DVD-RW SR (Sequential Recording)
DISC_TYPE_DVDPLUSRW, | DVD+RW
DISC_TYPE_DDCDROM, | DD (Double Density) CD-ROM
DISC_TYPE_DDCDR, | DD (Double Density) CD-R
DISC_TYPE_DDCRW | DD (Double Density) CD-RW
DISC_TYPE_DVDPLUSR | DVD+R
DISC_TYPE_NO_MEDIA | No media is inserted to the disc drive
DISC_TYPE_DVDPLUSR_DL | DVD+R DL (Double Layer)
DISC_TYPE_DVDR_DL | DVD-R DL (Dual Layer)
DISC_TYPE_BDROM | BD-ROM (Blu-Ray ROM)
DISC_TYPE_BDR | BD-R (Blu-Ray Disc Recordable)
DISC_TYPE_BDRE | BD-RE (Blu-Ray Disc Recordable Erasable)
DISC_TYPE_HDDVDROM | HD-DVD ROM
DISC_TYPE_HDDVDR | HD-DVD Recordable
DISC_TYPE_HDDVDRW | HD-DVD ReWritable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_DVD_VIDEO_CONTROL_BLOCK Structure

_DVD_VIDEO_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _DVD_VIDEO_CONTROL_BLOCK {
  UDF_CONTROL_BLOCK m__UDF_CONTROL_BLOCK;
  UDF_TREE_ITEM m__UDF_TREE_ITEM__Directory[ 4 ];
  UDF_TREE_ITEM m__UDF_TREE_ITEM__File[ 1192 ];
  LONG m__LONG__NumberOfFiles;
  LONG m__LONG__NumberOfTitles;
  LONG m__LONG__VtsIndex[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ][ 2 ];
  BOOLEAN m__BOOLEAN__IsMainMenuVob;
  BOOLEAN m__BOOLEAN__IsTitleMenuVob[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ];
};
File

StarBurn.h

Description

Structure that represents DVD-Video control block and pointer to DVD-Video control block

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_ERASE_TYPE Enumeration

_ERASE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _ERASE_TYPE {
  ERASE_TYPE_BLANK_DISC_FULL = 0,
  ERASE_TYPE_BLANK_DISC_FAST,
  ERASE_TYPE_BLANK_TRACK,
  ERASE_TYPE_UNRESERVE_TRACK,
  ERASE_TYPE_BLANK_TRACK_TAIL,
  ERASE_TYPE_UNCLOSE_LAST_SESSION,
  ERASE_TYPE_BLANK_SESSION
};
File

StarBurn.h

Description

Enum that represents erase type

Member | Definition
ERASE_TYPE_BLANK_DISC_FULL | Completely erase the rewritable disc
ERASE_TYPE_BLANK_DISC_FAST | Erase only TOC, PMA and first track lead in on the rewritable disc
ERASE_TYPE_BLANK_TRACK | Erase track only
ERASE_TYPE_UNRESERVE_TRACK | Unreserve track that was reserved before
ERASE_TYPE_BLANK_TRACK_TAIL | Erase track tail
ERASE_TYPE_UNCLOSE_LAST_SESSION | Unclose last closed session
ERASE_TYPE_BLANK_SESSION | Erase last session
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_EXCEPTION_NUMBER Enumeration

_EXCEPTION_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _EXCEPTION_NUMBER {
  EN_SUCCESS = 0,
  EN_FAILURE,
  EN_INVALID_INPUT_PARAMETER,
  EN_INVALID_STATE,
  EN_MEMORY_ALLOCATION_FAILED,
  EN_SYSTEM_CALL_FAILED,
  EN_SCSI_TRANSPORT_FAILED,
  EN_SCSI_DEVICE_BUSY,
  EN_SCSI_CDB_FAILED,
  EN_SCSI_DEVICE_INVALID_TYPE,
  EN_INVALID_RESPONSE,
  EN_BUFFER_UNDERRUN,
  EN_INVALID_EXCEPTION,
  EN_ACCESS_TO_FEATURE_DENIED,
  EN_USER_EXCEPTION,
  EN_PATH_TOO_LONG,
  EN_UNDER_CONSTRUCTION,
  EN_NOT_FOUND,
  EN_FILE_TOO_BIG,
  EN_NOT_IMPLEMENTED,
  EN_RANGE,
  EN_REGISTRATION_FAILED,
  EN_UNSUPPORTED_AUDIO,
  EN_BUFFER_TOO_SMALL,
  EN_SYSTEM_CALL_FAILED_EX,
  EN_ERROR_RECOVERY_FAILED,
  EN_UNRECOGNIZED_MEDIA,
  EN_GENERAL_SEEK_ERROR,
  EN_GENERAL_READ_ERROR,
  EN_ILLEGAL_OPERATION_FOR_TRACK,
  EN_UNSUPPORTED_READ_MODE,
  EN_REQUEST_TOO_LARGE,
  EN_FULL_ERASE_REQUIRED,
  EN_VERIFY_FAILED,
  EN_DPM_FAILED,
  EN_DEVICE_SHARING_VIOLATION,
  EN_CALL_IS_OBSOLETE,
  EN_WRONG_OS_VERSION,
  EN_INVALID_FIELD_IN_CDB,
  EN_CACHE_IS_TOO_SMALL
};
File

StarBurn.h

Description

Enum that represents exception number

Member | Definition
EN_SUCCESS | Nothing really happened, operation completed successfully
EN_FAILURE | Undefined error happened, something goes really wrong
EN_INVALID_INPUT_PARAMETER | User input parameter is not valid
EN_INVALID_STATE | The state of the object is not valid for current operation
EN_MEMORY_ALLOCATION_FAILED | Memory allocation failed
EN_SYSTEM_CALL_FAILED | System call failed, check SystemError pointer to system error value
EN_SCSI_TRANSPORT_FAILED | SCSI transport internal error
EN_SCSI_DEVICE_BUSY | SCSI device is busy for a while
EN_SCSI_CDB_FAILED | SCSI CDB delivery failed, check CDB_FAILURE_INFORMATION for details
EN_SCSI_DEVICE_INVALID_TYPE | SCSI device of this type is not supported
EN_INVALID_RESPONSE | Something really unsupported returned
EN_BUFFER_UNDERRUN | Buffer underrun happened
EN_INVALID_EXCEPTION | Exception was not allocated
EN_ACCESS_TO_FEATURE_DENIED | Access to feature denied b/s of the wrong version
EN_USER_EXCEPTION | This is not a real exception just the result of user interaction
EN_PATH_TOO_LONG | File path is too long
EN_UNDER_CONSTRUCTION | This feature is still under construction
EN_NOT_FOUND | Operation could not be performed b/s either device or requested parameter not found
EN_FILE_TOO_BIG | File is too big for requested operation
EN_NOT_IMPLEMENTED | Feature is not implemented yet
EN_RANGE | Passed range is not valid
EN_REGISTRATION_FAILED | Registration procedure completed with errors
EN_UNSUPPORTED_AUDIO | Unsupported audio format used as either input or output
EN_BUFFER_TOO_SMALL | Buffer size supplied by caller is not sufficient
EN_SYSTEM_CALL_FAILED_EX | Middle-layer error happened, check SystemError pointer for specific error value
EN_ERROR_RECOVERY_FAILED | Error recovery failed
EN_UNRECOGNIZED_MEDIA | Current media type is not recognized
EN_GENERAL_SEEK_ERROR | General seek error on CD/DVD/Blu-Ray/HD-DVD media
EN_GENERAL_READ_ERROR | General read error on CD/DVD/Blu-Ray/HD-DVD media
EN_ILLEGAL_OPERATION_FOR_TRACK | Illegal operation for track
EN_UNSUPPORTED_READ_MODE | Currently selected read mode is not supported by device
EN_REQUEST_TOO_LARGE | Request size is too large to be handled
EN_FULL_ERASE_REQUIRED | Full erase required before recording to inserted media
EN_VERIFY_FAILED | Verify operation found different memory buffers
EN_DPM_FAILED | DPM associated call failed
EN_DEVICE_SHARING_VIOLATION | Device failed to open b/s of sharing violation
EN_CALL_IS_OBSOLETE | Function is obsolete
EN_WRONG_OS_VERSION | OS version is not supported
EN_INVALID_FIELD_IN_CDB | Invalid field in CDB
EN_CACHE_IS_TOO_SMALL | Allocated cache size is too small to handle "write" operations
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_FILE_TIME Enumeration

_FILE_TIME Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _FILE_TIME {
  FILE_TIME_CREATION = 0,
  FILE_TIME_LAST_ACCESS,
  FILE_TIME_LAST_WRITE
};
File

StarBurn.h

Description

Enum that represents file time that will be included in the ISO9660/Joliet image

Member | Definition
FILE_TIME_CREATION | Original creation file time will be included into the file system image
FILE_TIME_LAST_ACCESS | Last access time will be included into the file system image
FILE_TIME_LAST_WRITE | Last write tile will be included into the file system image
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_FILE_TREE Enumeration

_FILE_TREE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _FILE_TREE {
  FILE_TREE_ISO9660 = 0,
  FILE_TREE_JOLIET
};
File

StarBurn.h

Description

Enum that represents file tree

Member | Definition
FILE_TREE_ISO9660 | ISO9660 file tree
FILE_TREE_JOLIET | ISO9660 file tree + Joliet extensions
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_FULL_TOC_ENTRY_RAW Structure

_FULL_TOC_ENTRY_RAW Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _FULL_TOC_ENTRY_RAW {
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__TNO;
  UCHAR m__UCHAR__POINT;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__Zero;
  UCHAR m__UCHAR__PMIN;
  UCHAR m__UCHAR__PSEC;
  UCHAR m__UCHAR__PFRAME;
};
File

StarBurn.h

Description

Structure that represents full TOC entry

Member | Definition
m__UCHAR__SessionNumber | Session number
m__UCHAR__CONTROL : 4 | Control
m__UCHAR__ADR : 4 | Address
m__UCHAR__TNO | Track number
m__UCHAR__POINT | Point
m__UCHAR__Min | Minute
m__UCHAR__Sec | Second
m__UCHAR__Frame | Frame
m__UCHAR__Zero | Zero (always 0)
m__UCHAR__PMIN | Starting minute (from MSF)
m__UCHAR__PSEC | Starting second (from MSF)
m__UCHAR__PFRAME | Starting frame (from MSF)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_ISO9660_DATE_TIME Structure

_ISO9660_DATE_TIME Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _ISO9660_DATE_TIME {
  UCHAR m__UCHAR__Year;
  UCHAR m__UCHAR__Month;
  UCHAR m__UCHAR__Day;
  UCHAR m__UCHAR__Hour;
  UCHAR m__UCHAR__Minute;
  UCHAR m__UCHAR__Second;
  UCHAR m__UCHAR__GMTOffset;
};
File

StarBurn.h

Description

Structure that represents ISO9660 date and time

Member | Definition
m__UCHAR__Year | Year
m__UCHAR__Month | Month
M__UCHAR__Day | Day
m__UCHAR__Hour | Hour
m__UCHAR__Minute | Minute
m__UCHAR__Second | Second
m__UCHAR__GMTOffset | Offset from GMT in hours
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_ISO9660_KIDTYPE Enumeration

_ISO9660_KIDTYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _ISO9660_KIDTYPE {
  KIDTYPE_UNKNOWN,
  KIDTYPE_IMPORTED,
  KIDTYPE_FROMDISK,
  KIDTYPE_VIRTUAL
};
File

StarBurn.h

Description

Enum that represent type of ISO9660 tree node

Member | Definition
KIDTYPE_UNKNOWN | Unknown kid type
KIDTYPE_IMPORTED | Node was imported from previous track
KIDTYPE_FROMDISK | Node was added from the disk
KIDTYPE_VIRTUAL | Node was created as memory file or virtual directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_NAME_COLLISION_INFO Structure

_NAME_COLLISION_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _NAME_COLLISION_INFO {
  BOOLEAN m__BOOLEAN__IsJolietName;
  UCHAR m__UCHAR__Name[ MAX_PATH * 2 ];
  PCHAR m__PCHAR__OldAbsoluteName;
  ULONG m__ULONG__OldFileAttributes;
  PCHAR m__PCHAR__NewAbsoluteName;
  ULONG m__ULONG__NewFileAttributes;
  NAME_COLLISION_SOLUTION m__NAME_COLLISION_SOLUTION;
};
File

StarBurn.h

Description

Structure that represents information about name collision

Member | Definition
m__BOOLEAN__IsJolietName | Indicates the format of the m__UCHAR__Name
m__UCHAR__Name | The node name (CHAR for ISO9660 or USHORT for Joliet)
m__PCHAR__OldAbsoluteName | Absolute file name of the old file node
m__ULONG__OldFileAttributes | Old file attributes
m__PCHAR__NewAbsoluteName | Absolute file name of the new file node
m__ULONG__NewFileAttributes | New file attributes
m__NAME_COLLISION_SOLUTION | The solution of the collision (what action has been performed)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_NAME_COLLISION_SOLUTION Enumeration

_NAME_COLLISION_SOLUTION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _NAME_COLLISION_SOLUTION {
  NAME_COLLISION_SKIP_NEW = 0,
  NAME_COLLISION_REPLACE_OLD = 1,
  NAME_COLLISION_RENAME_NEW = 2,
  NAME_COLLISION_MERGE_FOLDERS = 3,
  NAME_COLLISION_FORCE_DWORD = 0xFFFFFFFF
};
File

StarBurn.h

Description

Enum that represents the solutions of name collisions

Member | Definition
NAME_COLLISION_SKIP_NEW | Remove new node and leave old node
NAME_COLLISION_REPLACE_OLD | Remove old node and insert new node
NAME_COLLISION_RENAME_NEW | Leave old node and insert new node with the new name
NAME_COLLISION_MERGE_FOLDERS | Add files from new folder into an old folder
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_PQ_SUBCHANNEL Structure

_PQ_SUBCHANNEL Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _PQ_SUBCHANNEL {
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__IndexNumber;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__ZERO;
  UCHAR m__UCHAR__AMIN;
  UCHAR m__UCHAR__ASEC;
  UCHAR m__UCHAR__AFRAME;
  UCHAR m__UCHAR__CRC1_Reserved1;
  UCHAR m__UCHAR__CRC2_Reserved2;
  UCHAR m__UCHAR__Reserved3[ 3 ];
  UCHAR m__UCHAR__Reserved4 : 7;
  UCHAR m__UCHAR__PSubChannel : 1;
};
File

StarBurn.h

Description

Structure that represents formatted PQ sub-channel

Member | Definition
m__UCHAR__ADR | Track ADR
m__UCHAR__CONTROL | Track CONTROL
m__UCHAR__TrackNumber | Track Number
m__UCHAR__IndexNumber | Index Number
m__UCHAR__Min | Min (from the beginning of the track)
m__UCHAR__Sec | Sec (from the beginning of the track)
m__UCHAR__Frame | Frame (from the beginning of the track)
m__UCHAR__ZERO | MBZ
m__UCHAR__AMIN | Min (from the beginning of the disc)
m__UCHAR__ASEC | Sec (from the beginning of the disc)
m__UCHAR__AFRAME | Frame (from the beginning of the disc)
m__UCHAR__CRC1_Reserved1 | CRC1 or MBZ
m__UCHAR__CRC2_Reserved2 | CRC2 or MBZ
m__UCHAR__Reserved3[ 3 ] | MBZ
m__UCHAR__Reserved4 | MBZ
m__UCHAR__PSubChannel | P sub-channel bit
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_READ_MODE Enumeration

_READ_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _READ_MODE {
  READ_MODE_COOKED = 0,
  READ_MODE_RAW,
  READ_MODE_RAW_PQ,
  READ_MODE_RAW_RAW_PW,
  READ_MODE_PQ,
  READ_MODE_RAW_PW
};
File

StarBurn.h

Description

Enum that represents raw read modes

Member | Definition
READ_MODE_COOKED | Cooked data
READ_MODE_RAW | Raw data
READ_MODE_RAW_PQ | Raw data + PQ sub-channel
READ_MODE_RAW_RAW_PW | Raw data + raw P-W sub-channel
READ_MODE_PQ | PQ sub-channel only (no main channel data)
READ_MODE_RAW_PW | Raw P-W sub-channel only (no main channel data)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_SCSI_DEVICE_ADDRESS Structure

_SCSI_DEVICE_ADDRESS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _SCSI_DEVICE_ADDRESS {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__PortID;
  UCHAR m__UCHAR__BusID;
  UCHAR m__UCHAR__TargetID;
  UCHAR m__UCHAR__LUN;
};
File

StarBurn.h

Description

Structure that represents SCSI device address

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__PortID | Port ID - Logical SCSI adapter ID if ASPI is used
m__UCHAR__BusID | Bus ID - 0 if ASPI is used
m__UCHAR__TargetID | Target ID
m__UCHAR__LUN | LUN (Logical Unit Number)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure

_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS {
  ULONG m__ULONG__SizeInUCHARs;
  BOOLEAN m__BOOLEAN__IsCDROMRead;
  BOOLEAN m__BOOLEAN__IsCDRRead;
  BOOLEAN m__BOOLEAN__IsCDRWrite;
  BOOLEAN m__BOOLEAN__IsCDRWRead;
  BOOLEAN m__BOOLEAN__IsCDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDROMRead;
  BOOLEAN m__BOOLEAN__IsDVDRRead;
  BOOLEAN m__BOOLEAN__IsDVDRWrite;
  BOOLEAN m__BOOLEAN__IsDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWRead;
  BOOLEAN m__BOOLEAN__IsDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRAMRead;
  BOOLEAN m__BOOLEAN__IsDVDRAMWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDROMRead;
  BOOLEAN m__BOOLEAN__IsBDRRead;
  BOOLEAN m__BOOLEAN__IsBDRWrite;
  BOOLEAN m__BOOLEAN__IsBDRDLRead;
  BOOLEAN m__BOOLEAN__IsBDRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDRERead;
  BOOLEAN m__BOOLEAN__IsBDREWrite;
  BOOLEAN m__BOOLEAN__IsBDREDLRead;
  BOOLEAN m__BOOLEAN__IsBDREDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDROMRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite;
};
File

StarBurn.h

Description

Structure that represents advanced supported media formats

Member Definition

--------- --------------

ULONG m__ULONG__SizeInUCHARs This structure size in UCHARs
BOOLEAN m__BOOLEAN__IsCDROMRead Is CD-ROM read capable
BOOLEAN m__BOOLEAN__IsCDRRead Is CD-R read capable
BOOLEAN m__BOOLEAN__IsCDRWrite Is CD-R write capable
BOOLEAN m__BOOLEAN__IsCDRWRead Is CD-RW read capable
BOOLEAN m__BOOLEAN__IsCDRWWrite Is CD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDROMRead Is DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsDVDRRead Is DVD-R read capable
BOOLEAN m__BOOLEAN__IsDVDRWrite Is DVD-R write capable
BOOLEAN m__BOOLEAN__IsDVDRDLRead Is DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsDVDRDLWrite Is DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsDVDRWRead Is DVD-RW read capable
BOOLEAN m__BOOLEAN__IsDVDRWWrite Is DVD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDRWDLRead Is DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDRWDLWrite Is DVD-RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDRAMRead Is DVD-RAM read capable
BOOLEAN m__BOOLEAN__IsDVDRAMWrite Is DVD-RAM write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead Is DVD+RW read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite Is DVD+RW write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead Is DVD+RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite Is DVD+RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRRead Is DVD+R read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite Is DVD+R write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead Is DVD+R DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite Is DVD+R DL write capable
BOOLEAN m__BOOLEAN__IsBDROMRead Is BD-ROM read capable
BOOLEAN m__BOOLEAN__IsBDRRead Is BD-R read capable
BOOLEAN m__BOOLEAN__IsBDRWrite Is BD-R write capable
BOOLEAN m__BOOLEAN__IsBDRDLRead Is BD-R DL read capable
BOOLEAN m__BOOLEAN__IsBDRDLWrite Is BD-R DL write capable
BOOLEAN m__BOOLEAN__IsBDRERead Is BD-RE read capable
BOOLEAN m__BOOLEAN__IsBDREWrite Is BD-RE write capable
BOOLEAN m__BOOLEAN__IsBDREDLRead Is BD-RE DL read capable
BOOLEAN m__BOOLEAN__IsBDREDLWrite Is BD-RE DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDROMMRead Is HD-DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsHDDVDRRead Is HD-DVD-R read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWrite Is HD-DVD-R write capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLRead Is HD-DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite Is HD-DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWRead Is HD-DVD-RW read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWWrite Is HD-DVD-RW write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead Is HD-DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite Is HD-DVD-RW DL write capable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_BDRE_FORMAT_PROFILE Structure

_STARBURN_BDRE_FORMAT_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_BDRE_FORMAT_PROFILE {
  LONG m__LONG__FormatProfileNumber;
  ULONG m__ULONG__NumberOfBlocksOrUserAreaDataSize;
  UCHAR m__UCHAR__CertificationType : 2;
  UCHAR m__UCHAR__FormatType : 6;
  ULONG m__ULONG__SpareAreaSizeInClustersOrBlockLength;
};
File

StarBurn.h

Description

Structure that represents format profile for BD-RE media

Member Definition

--------- --------------

LONG m__LONG__FormatProfileNumber Format profile number
UCHAR m__ULONG__NumberOfBlocksOrUserAreaDataSize Number of logical block(s) or user area data size
UCHAR m__UCHAR__CertificationType Certification type
UCHAR m__UCHAR__FormatType Format type
UCHAR m__ULONG__SpareAreaSizeInClustersOrBlockLength Spare area size in cluster(s) or block length
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_CD_MODE Enumeration

_STARBURN_CD_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_CD_MODE {
  CD_MODE_UNKNOWN = 0,
  CD_MODE_AUDIO,
  CD_MODE_VIDEO,
  CD_MODE_DATA,
  CD_MODE_RESERVED
};
File

StarBurn.h

Description

Enum that represents CD modes type

Member | Definition
CD_MODE_UNKNOWN | Unknown CD mode
CD_MODE_AUDIO | Audio CD mode
CD_MODE_VIDEO | Video CD mode
CD_MODE_DATA | Data CD mode
CD_MODE_RESERVED | Reserved
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_DISC_ATIP_INFORMATION Structure

_STARBURN_DISC_ATIP_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_DISC_ATIP_INFORMATION {
  USHORT m__USHORT__DataLength;
  UCHAR m__UCHAR__Reserved1[2];
  UCHAR m__UCHAR__RefrenceSpeed : 3;
  UCHAR m__UCHAR__Reserved2 : 1;
  UCHAR m__UCHAR__IndicativeTargetWritingPower : 4;
  UCHAR m__UCHAR__Reserved3 : 6;
  UCHAR m__UCHAR__URU : 1;
  UCHAR m__UCHAR__Zero : 1;
  UCHAR m__UCHAR__IsA3Valid : 1;
  UCHAR m__UCHAR__IsA2Valid : 1;
  UCHAR m__UCHAR__IsA1Valid : 1;
  UCHAR m__UCHAR__DiscSubType : 3;
  UCHAR m__UCHAR__DiscType : 1;
  UCHAR m__UCHAR__One : 1;
  UCHAR m__UCHAR__Reserved4;
  UCHAR m__UCHAR__LeadInStartTime[3];
  UCHAR m__UCHAR__Reserved5;
  UCHAR m__UCHAR__LastPossibleLeadOutStartTime[3];
  UCHAR m__UCHAR__Reserved6;
  UCHAR m__UCHAR__A1Values[3];
  UCHAR m__UCHAR__Reserved7;
  UCHAR m__UCHAR__A2Values[3];
  UCHAR m__UCHAR__Reserved8;
  UCHAR m__UCHAR__A3Values[3];
  UCHAR m__UCHAR__Reserved9;
  UCHAR m__UCHAR__S4Values[3];
  UCHAR m__UCHAR__Reserved10;
};
File

StarBurn.h

Description

Structure that represents Disc ATIP information

Member Definition

--------- --------------

m__USHORT__DataLength
m__UCHAR__Reserved1
m__UCHAR__RefrenceSpeed
m__UCHAR__Reserved2
m__UCHAR__IndicativeTargetWritingPower
m__UCHAR__Reserved3
m__UCHAR__URU
m__UCHAR__Zero
m__UCHAR__IsA3Valid
m__UCHAR__IsA2Valid
m__UCHAR__IsA1Valid
m__UCHAR__DiscSubType
m__UCHAR__DiscType
m__UCHAR__One
m__UCHAR__Reserved4
m__UCHAR__LeadInStartTime
m__UCHAR__Reserved5
m__UCHAR__LastPossibleLeadOutStartTime
m__UCHAR__Reserved6
m__UCHAR__A1Values
m__UCHAR__Reserved7
m__UCHAR__A2Values
m__UCHAR__Reserved8
m__UCHAR__A3Values
m__UCHAR__Reserved9
m__UCHAR__S4Values
m__UCHAR__Reserved10
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_DISC_INFORMATION Structure

_STARBURN_DISC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_DISC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__DiscStatus;
  UCHAR m__UCHAR__LastSessionStatus;
  BOOLEAN m__BOOLEAN__IsErasable;
  UCHAR m__UCHAR__FirstTrackNumber;
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__LastSessionFirstTrack;
  UCHAR m__UCHAR__LastSessionLastTrack;
  BOOLEAN m__BOOLEAN__IsGEN;
  BOOLEAN m__BOOLEAN__IsDBCValid;
  BOOLEAN m__BOOLEAN__IsDIDValid;
  UCHAR m__UCHAR__DiscType;
  UCHAR m__UCHAR__DiscIdentification[ 4 ];
  UCHAR m__UCHAR__LastSessionLeadIn[ 4 ];
  UCHAR m__UCHAR__LastPossibleStartTime[ 4 ];
  UCHAR m__UCHAR__DiscBarCode[ 8 ];
  UCHAR m__UCHAR__NumberOfOPCEntries;
};
File

StarBurn.h

Description

Structure that represents Disc information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__DiscStatus | Disc status (See DISC_STATUS_XXX constants)
m__UCHAR__LastSessionStatus | Last session status (See LAST_SESSION_XXX constants)
m__BOOLEAN__IsErasable | Is disc erasable (CD-RW or DVD-RW or DVD+RW or DVD-RAM)
m__UCHAR__FirstTrackNumber | First track number on the disc
m__UCHAR__NumberOfSessions | Number of sessions on the disc
m__UCHAR__LastSessionFirstTrack | First track number of last complete session on the disc
m__UCHAR__LastSessionLastTrack | Last track number of last complete session on the disc
m__BOOLEAN__IsGEN | Unrestricted use, when set to one - every application can write to the disc
m__BOOLEAN__IsDBCValid | Is Disc Bar Code field valid
m__BOOLEAN__IsDIDValid | Is Disc Identification field Valid
m__UCHAR__DiscType | Disc type (See DISC_TYPE_XXX constants)
m__UCHAR__DiscIdentification | Disc identification number recorded in the PMA, see m__UCHAR__IsDIDValid
m__UCHAR__LastSessionLeadId | MSF of last session lead in start time
m__UCHAR__LastPossibleStartTime | Last possible start time for lead out on this disc
m__UCHAR__DiscBarCode | Disc bar code stored here if the device is capable of reading disc bar codes
m__UCHAR__NumberOfOPCEntries | Number of optimum power calibration entries at the end of this structure
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_ELTORITO_MEDIA Enumeration

_STARBURN_ELTORITO_MEDIA Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_ELTORITO_MEDIA {
  ELTORITO_MEDIA_CUSTOM = 0x00,
  ELTORITO_MEDIA_FLOPPY120 = 0x01,
  ELTORITO_MEDIA_FLOPPY144 = 0x02,
  ELTORITO_MEDIA_FLOPPY288 = 0x03,
  ELTORITO_MEDIA_HARDDISK = 0x04
};
File

StarBurn.h

Description

Media emulation types

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_ELTORITO_PLATFORM Enumeration

_STARBURN_ELTORITO_PLATFORM Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_ELTORITO_PLATFORM {
  ELTORITO_PLATFORM_80X86 = 0x00,
  ELTORITO_PLATFORM_POWERPC = 0x01,
  ELTORITO_PLATFORM_MAC = 0x02,
  ELTORITO_PLATFORM_EFI = 0xEF
};
File

StarBurn.h

Description

ElTorito platform types

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_ISO9660_DIRECTORY_INFO Structure

_STARBURN_ISO9660_DIRECTORY_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_ISO9660_DIRECTORY_INFO {
  unsigned char ISOType;
  unsigned long NumberOfKids;
  unsigned long TotalNumberOfFiles;
  unsigned long TotalNumberOfDirs;
  unsigned __int64 TotalChildrenSizeInLBs;
};
File

StarBurn.h

Description

This is record _STARBURN_ISO9660_DIRECTORY_INFO.

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_ISO9660_FILE_INFO Structure

_STARBURN_ISO9660_FILE_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_ISO9660_FILE_INFO {
  char Name[ ( STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  unsigned short UnicodeName[ ( STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS + 1 ) ];
  unsigned short UnicodePathName[ ( STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  BOOL IsImported;
  unsigned __int64 ContentSizeInUCHARs;
  unsigned long SizeInLogicalBlocks;
  unsigned long GUID;
  unsigned long Attributes;
  unsigned long BeginLBA;
  unsigned long EndLBA;
};
File

StarBurn.h

Description

ISO9660 file information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE_CALLBACK_REASON Enumeration

_STARBURN_STARWAVE_CALLBACK_REASON Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_STARWAVE_CALLBACK_REASON {
  STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN = 0,
  STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS
};
File

StarBurn.h

Description

StarWave callback reasons we'll be using

Member | Definition
STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN | Unknown call reason
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS | Progress indication reason
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE_COMPRESSION Enumeration

_STARBURN_STARWAVE_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_STARWAVE_COMPRESSION {
  STARBURN_STARWAVE_COMPRESSION_NONE = 0,
  STARBURN_STARWAVE_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 = 10,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 = 25,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 = 50,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 = 75,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 = 90,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 = 98,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K = 32000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K = 48000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K = 64000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K = 80000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K = 96000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K = 128000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K = 160000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K = 192000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K = 256000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K = 320000
};
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Member | Definition
STARBURN_STARWAVE_COMPRESSION_NONE | Lossless PCM WAV uncompressed stream
STARBURN_STARWAVE_COMPRESSION_WMA_LOSS... | Lossless WMA compressed stream, VBR at Quality 100
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 | WMA compressed stream, VBR at Quality 10
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 | WMA compressed stream, VBR at Quality 25
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 | WMA compressed stream, VBR at Quality 50
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 | WMA compressed stream, VBR at Quality 75
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 | WMA compressed stream, VBR at Quality 90
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 | WMA compressed stream, VBR at Quality 98
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K | WMA compressed stream, CBR at 32 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K | WMA compressed stream, CBR at 48 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K | WMA compressed stream, CBR at 64 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K | WMA compressed stream, CBR at 80 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K | WMA compressed stream, CBR at 96 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K | WMA compressed stream, CBR at 128 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K | WMA compressed stream, CBR at 160 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K | WMA compressed stream, CBR at 192 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K | WMA compressed stream, CBR at 256 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K | WMA compressed stream, CBR at 320 Kbps
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration

_STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_STARWAVE2_COMPRESS_TYPE {
  COMPRESS_TYPE_INVALID_VALUE = 0,
  COMPRESS_TYPE_MP3_CBR,
  COMPRESS_TYPE_MP3_ABR,
  COMPRESS_TYPE_MP3_VBR,
  COMPRESS_TYPE_OGG_CBR,
  COMPRESS_TYPE_OGG_ABR,
  COMPRESS_TYPE_OGG_VBR,
  COMPRESS_TYPE_OGG_APPROXIMATE,
  COMPRESS_TYPE_WMA_LOSSLESS_VBR,
  COMPRESS_TYPE_WMA_CBR,
  COMPRESS_TYPE_WMA_VBR,
  COMPRESS_TYPE_UNCOMPRESSED_WAV_44100_STEREO,
  COMPRESS_TYPE_CUSTOM,
  COMPRESS_TYPE_FORCE_INT = 0xFFFFFFFF
};
File

StarBurn.h

Description

Compress settings

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE2_CONVERSION_MODE Enumeration

_STARBURN_STARWAVE2_CONVERSION_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_STARWAVE2_CONVERSION_MODE {
  STARBURN_STARWAVE2_OGG_MODE0,
  STARBURN_STARWAVE2_OGG_MODE1,
  STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_OGG_MODE_MAX = STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_MP3_MODE0,
  STARBURN_STARWAVE2_MP3_MODE1,
  STARBURN_STARWAVE2_MP3_MODE2,
  STARBURN_STARWAVE2_MP3_MODE_MAX = STARBURN_STARWAVE2_MP3_MODE2
};
File

StarBurn.h

Description

Structure that represents conversion mode

Member | Definition
OGG_MODE0 | VBR, variable bit rate
OGG_MODE1 | ABR, average bit rate
OGG_MODE2 | CBR, constant bit rate
OGG_MODE_MAX | Now equal to OGG_MODE2
MP3_MODE0 | CBR, constant bit rate
MP3_MODE1 | ABR, average bit rate
MP3_MODE2 | VBR, variable bit rate
MP3_MODE_MAX | Now equal to MP3_MODE2
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE2_INIT_PARAMS Structure

_STARBURN_STARWAVE2_INIT_PARAMS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_STARWAVE2_INIT_PARAMS {
  STARBURN_STARWAVE2_CONVERSION_MODE m__STARBURN_STARWAVE2_CONVERSION_MODE;
  FLOAT m__FLOAT__flQuality;
  LONG m__LONG__nQuality;
  LONG m__LONG__maxBitrate;
  LONG m__LONG__nominalBitrate;
  LONG m_LONG__minBitrate;
  STARBURN_STARWAVE2_QUALITY_MODE m__STARBURN_STARWAVE2_QUALITY_MODE;
};
File

StarBurn.h

Description

Structure that represents initialization parameters for audio conversion

Member | Definition
m__STARBURN_STARWAVE2_CONVERSION_MODE | Conversion mode
m__FLOAT__flQuality | Quality level from 0. (lo) to 1. (hi) (use for OGG_MODE0)
m__LONG__nQuality | Quality level from 1 to 9 (use for MP3_MODE2)
m__LONG__maxBitrate | Maximum bit rate (use for OGG_MODE1/OGG_MODE2)
m__LONG__nominalBitrate | Nominal bit rate (use for OGG_MODE1/OGG_MODE2/MP3_MODE0/MP3_MODE1)
m__LONG__minBitrate | Minimum bit rate (use for OGG_MODE1/OGG_MODE2)
m__StarBurn_StarWave2_QUALITY_MODE | Quality mode (use for /MP3_MODE0/MP3_MODE1/MP3_MODE2)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_STARWAVE2_QUALITY_MODE Enumeration

_STARBURN_STARWAVE2_QUALITY_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_STARWAVE2_QUALITY_MODE {
  STARBURN_STARWAVE2_QM_FAST = 0,
  STARBURN_STARWAVE2_QM_STANDARD,
  STARBURN_STARWAVE2_QM_HIGH
};
File

StarBurn.h

Description

Enum that represents MP3 quality for conversion

Member | Definition
StarBurn_StarWave2_QM_FAST | Fast mode
StarBurn_StarWave2_QM_STANDARD | Standard mode
StarBurn_StarWave2_QM_HIGH | High quality mode
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_TRACK_INFORMATION Structure

_STARBURN_TRACK_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_TRACK_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
};
File

StarBurn.h

Description

Structure that represents Track information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_TRACK_INFORMATION_EX Structure

_STARBURN_TRACK_INFORMATION_EX Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_TRACK_INFORMATION_EX {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__LastRecordedAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
};
File

StarBurn.h

Description

Structure that represents Track information extended

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__LastRecordedAddress | Last Recorded Address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_UDF_BRIDGE_TYPE Enumeration

_STARBURN_UDF_BRIDGE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_UDF_BRIDGE_TYPE {
  UDF_BRIDGE_TYPE_NONE = 0,
  UDF_BRIDGE_TYPE_DVDVIDEO,
  UDF_BRIDGE_TYPE_ISO9660,
  UDF_BRIDGE_TYPE_ISO9660_JOLIET,
  UDF_BRIDGE_TYPE_FORCE_DWORD = 0xFFFFFFFF
};
File

StarBurn.h

Description

Restore original structure packing

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_UDF2_DIRECTORY_INFO Structure

_STARBURN_UDF2_DIRECTORY_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_UDF2_DIRECTORY_INFO {
  unsigned long NumberOfKids;
  unsigned long NumberOfKidsDirectories;
};
File

StarBurn.h

Description

UDF directory information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_UDF2_FILE_DATE_TIME Structure

_STARBURN_UDF2_FILE_DATE_TIME Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_UDF2_FILE_DATE_TIME {
  unsigned short Year;
  unsigned char Month;
  unsigned char Day;
  unsigned char Hour;
  unsigned char Minute;
  unsigned char Second;
  unsigned char Millisecond;
  short Offset : 12;
  short IsLocal : 1;
  short Reserved : 3;
};
File

StarBurn.h

Description

Structure that represents UDF2 file date and time

Member | Definition
Year | Year
Month | Month
Day | Day
Hour | Hour
Minute | Minute
Second | Second
Millisecnd | Millisecond
Offset | UTC offset in minutes
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration

_STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARBURN_UDF2_FILE_DATE_TIME_TYPE {
  UDF_FILE_DATE_TIME_TYPE_CREATION = 0,
  UDF_FILE_DATE_TIME_TYPE_LAST_ACCESS,
  UDF_FILE_DATE_TIME_TYPE_LAST_WRITE
};
File

StarBurn.h

Description

Enum that represents StarBurn date/time type for files in UDF

Member Definition

--------- --------------

UDF_FILE_DATE_TIME_TYPE_CREATION File originally created
UDF_FILE_DATE_TIME_TYPE_LAST_ACCESS File last accessed
UDF_FILE_DATE_TIME_TYPE_LAST_WRITE File last written to
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARBURN_UDF2_FILE_INFO Structure

_STARBURN_UDF2_FILE_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARBURN_UDF2_FILE_INFO {
  CHAR Name[ ( STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  WCHAR UnicodeName[ ( STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  CHAR PathName[ ( STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS + 1 ) ];
  WCHAR UnicodePathName[ ( STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS + 1 ) ];
  BOOL IsUnicode;
  BOOL IsImported;
  unsigned __int64 ImportedContentSizeInUCHARs;
  unsigned long GUID;
  unsigned long Attributes;
  unsigned long SizeInLogicalBlocks;
  unsigned __int64 SizeInUCHARs;
  unsigned long BeginLBA;
  unsigned long EndLBA;
};
File

StarBurn.h

Description

UDF file information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARPORT_DEVICE_LIST Structure

_STARPORT_DEVICE_LIST Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARPORT_DEVICE_LIST {
  LONG m__LONG__NumberOfEntries;
  STARPORT_DEVICE_LIST_ENTRY m__STARPORT_DEVICE_LIST_ENTRY[ 1 ];
};
File

StarBurn.h

Description

Structure that represents StarPort device list

Member | Definition
m__LONG__NumberOfEntries | Number of StarPort device list entries
m__STARPORT_DEVICE_LIST_ENTRY | StarPort device list entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARPORT_DEVICE_LIST_ENTRY Structure

_STARPORT_DEVICE_LIST_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARPORT_DEVICE_LIST_ENTRY {
  LONG m__LONG__Index;
  LONG m__LONG__TargetId;
  CHAR m__CHAR__Name[ STARPORT_DEVICE_NAME_SIZE_IN_UCHARS ];
};
File

StarBurn.h

Description

Structure that represents StarPort device list entry

Member | Definition
m__LONG__Index | StarPort device index
m__LONG__TargetId | StarPort device TargetId
m__CHAR__Name | StarPort device name
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARPORT_DEVICE_TYPE Enumeration

_STARPORT_DEVICE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARPORT_DEVICE_TYPE {
  STARPORT_DEVICE_TYPE_UNKNOWN = 0,
  STARPORT_DEVICE_TYPE_RAM,
  STARPORT_DEVICE_TYPE_HDD,
  STARPORT_DEVICE_TYPE_DVD,
  STARPORT_DEVICE_TYPE_AOE,
  STARPORT_DEVICE_TYPE_ISCSI
};
File

StarBurn.h

Description

Enum that represents StarPort device type

Member | Definition
STARPORT_DEVICE_TYPE_UNKNOWN | Unknown device type
STARPORT_DEVICE_TYPE_RAM | RAM disk
STARPORT_DEVICE_TYPE_HDD | Virtual hard disk
STARPORT_DEVICE_TYPE_DVD | Virtual DVD
STARPORT_DEVICE_TYPE_AOE | AoE (ATA-over-Ethernet)
STARPORT_DEVICE_TYPE_ISCSI | iSCSI (SCSI-over-IP)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARWAVE2_COMPRESSION Enumeration

_STARWAVE2_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _STARWAVE2_COMPRESSION {
  STARWAVE2_COMPRESSION_NONE = 0,
  STARWAVE2_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARWAVE2_COMPRESSION_WMA_VBR_Q10 = 10,
  STARWAVE2_COMPRESSION_WMA_VBR_Q25 = 25,
  STARWAVE2_COMPRESSION_WMA_VBR_Q50 = 50,
  STARWAVE2_COMPRESSION_WMA_VBR_Q75 = 75,
  STARWAVE2_COMPRESSION_WMA_VBR_Q90 = 90,
  STARWAVE2_COMPRESSION_WMA_VBR_Q98 = 98,
  STARWAVE2_COMPRESSION_WMA_CBR_32K = 32000,
  STARWAVE2_COMPRESSION_WMA_CBR_48K = 48000,
  STARWAVE2_COMPRESSION_WMA_CBR_64K = 64000,
  STARWAVE2_COMPRESSION_WMA_CBR_80K = 80000,
  STARWAVE2_COMPRESSION_WMA_CBR_96K = 96000,
  STARWAVE2_COMPRESSION_WMA_CBR_128K = 128000,
  STARWAVE2_COMPRESSION_WMA_CBR_160K = 160000,
  STARWAVE2_COMPRESSION_WMA_CBR_192K = 192000,
  STARWAVE2_COMPRESSION_WMA_CBR_256K = 256000,
  STARWAVE2_COMPRESSION_WMA_CBR_320K = 320000
};
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates

All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_STARWAVE2_COMPRESSION_PROFILE Structure

_STARWAVE2_COMPRESSION_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _STARWAVE2_COMPRESSION_PROFILE {
  UINT m__UINT__CompressionType;
  PCHAR m__PCHAR__CustomFactoryID;
  union {
    int m__int__CBRBitRate;
    int m__int__VBRQuality;
  };
  int m__int__ABRBitRate;
  int m__int__MaxBitRate;
  union {
    int m__int__MinBitRate;
    int m__int__MaxFrameWindow;
  };
  LPVOID m__LPVOID__CustomData;
};
File

StarBurn.h

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_TOC_ENTRY Structure

_TOC_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _TOC_ENTRY {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  LONG m__LONG__StartingLBA;
  UCHAR m__UCHAR__StartingMSF[ 3 ];
  LONG m__LONG__EndingLBA;
  UCHAR m__UCHAR__EndingMSF[ 3 ];
  BOOLEAN m__BOOLEAN__IsMCNAvailable;
  BOOLEAN m__BOOLEAN__IsISRCAvailable;
  BOOLEAN m__BOOLEAN__IsFourChannelsAudio;
  BOOLEAN m__BOOLEAN__IsPreEmphasisAudio;
  BOOLEAN m__BOOLEAN__IsData;
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsDigitalCopyProhibited;
  UCHAR m__UCHAR__TrackMode;
  UCHAR m__UCHAR__MODE2Form;
  ULONG m__ULONG__LBSizeInUCHARs;
  LONG m__LONG__Index00;
};
File

StarBurn.h

Description

Structure that represents TOC entry

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number
m__UCHAR__SessionNumber | Session number that this track belongs to
m__LONG__StartingLBA | Starting LBA
m__UCHAR__StartingMSF | Starting MSF
m__LONG__EndingLBA | Ending LBA
m__UCHAR__EndingMSF | Ending MSF
m__BOOLEAN__IsMCNAvailable | Is Media Catalog Number available
m__BOOLEAN__IsISRCAvailable | Is International Standard Recording Code available
m__BOOLEAN__IsFourChannelsAudio | Is this four channels audio track
m__BOOLEAN__IsPreEmphasisAudio | Is this pre-emphasis audio track
m__BOOLEAN__IsData | Is this data track
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsDigitalCopy... | Is digital copy prohibited for this track
m__UCHAR__TrackMode | Track mode (0 for audio track, 1 for MODE1 and 2 for MODE2)
m__UCHAR__MODE2Form | MODE2 Form (0 for Formless, 1 for Form1 and 2 for Form2)
m__ULONG__LBSizeInUCHARs | LB (logical block) size in UCHARs on this track
m__LONG__Index00 | Index00 LBA (if present)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_TOC_INFORMATION Structure

_TOC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _TOC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  BOOLEAN m__BOOLEAN__IsDVD;
  USHORT m__USHORT__ProtectedDVDRegions;
  UCHAR m__UCHAR__BusKeyForDiscKey[ 5 ];
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__NumberOfTracks;
  UCHAR m__UCHAR__NumberOfUnsortedEntries;
  TOC_ENTRY m__TOC_ENTRY[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW__Unsorted[ NUMBER_OF_RAW_TRACKS ];
};
File

StarBurn.h

Description

Structure that represents TOC information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__BOOLEAN__IsDVD | Is this DVD media or not
m__USHORT__ProtectedDVDRegions | Number of protected DVD regions
m__UCHAR__BusKeyForDiscKey | Bus key for disc key (CSS)
m__UCHAR__NumberOfSessions | Number of sessions
m__UCHAR__NumberOfTracks | Number of tracks
m__UCHAR__NumberOfUnsortedEntries | Number of entries in unsorted raw TOC
m__TOC_ENTRY | TOC entries (decoded and extended)
m__FULL_TOC_ENTRY_RAW | Full TOC raw entries sorted, each entry corresponds to m__TOC_ENTRY with the same TNO
m__FULL_TOC_ENTRY_RAW__Unsorted | Full TOC raw entries unsorted
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_CONTROL_BLOCK Structure

_UDF_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_CONTROL_BLOCK {
  void * m__PVOID__Head;
  void * m__PVOID__SystemStructures;
  void * m__PVOID__Tail;
  void * m__PVOID__Body;
};
File

StarBurn.h

Description

Structure that represents UDF control block

Member | Definition
m__PVOID__Head | Pointer to the head of the linked list
m__PVOID__SystemStructures | Pointer to the allocated and formatted UDF system structures
m__PVOID__Tail | Pointer to the tail of the linked list
m__PVOID__Body | Pointer to block body itself
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_FILE_EXTENT Structure

_UDF_FILE_EXTENT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_FILE_EXTENT {
  ULONG m__ULONG__BeginLBA;
  ULONG m__ULONG__EndLBA;
};
File

StarBurn.h

Description

Structure that describes a single file extent

Member | Definition
m__ULONG__BeginLBA | First LBA of the extent
m__ULONG__EndLBA | Last LBA of the extent
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_FILE_HANDLE Structure

_UDF_FILE_HANDLE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_FILE_HANDLE {
  HANDLE m__HANDLE;
};
File

StarBurn.h

Description

Structure that represents UDF file handle

Member | Definition
m__HANDLE | Win32 file handle
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_FILE_LOOKUP_ENTRY Structure

_UDF_FILE_LOOKUP_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_FILE_LOOKUP_ENTRY {
  ULONG m__ULONG__Size;
  PWCHAR m__PCHAR__FileName;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
};
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function

Member | Definition
m__ULONG__Size | Entry size
m__PWCHAR__FileName | File name
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_LOOKUP_DIR_ENTRY Structure

_UDF_LOOKUP_DIR_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_LOOKUP_DIR_ENTRY {
  PWCHAR m__PWCHAR__DirName;
  PVOID m__PVOID__ParentContext;
};
File

StarBurn.h

Description

Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__PWCHAR__DirName | Directory name
m__PVOID__ParentContext | The user context assigned to this directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_LOOKUP_FILE_ENTRY Structure

_UDF_LOOKUP_FILE_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_LOOKUP_FILE_ENTRY {
  ULONG m__ULONG__EntrySize;
  PWCHAR m__PWCHAR__FileName;
  ULONGLONG m__QWORD__FileSize;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
};
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__ULONG__EntrySize | Entry size
m__PWCHAR__FileName | File name
m__QWORD__FileSize | File size in bytes
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_OS_CLASS Enumeration

_UDF_OS_CLASS Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _UDF_OS_CLASS {
  UDF_OS_CLASS_UNDEFINED = 0x00,
  UDF_OS_CLASS_DOS = 0x01,
  UDF_OS_CLASS_OS_2 = 0x02,
  UDF_OS_CLASS_MACINTOSH_OS = 0x03,
  UDF_OS_CLASS_UNIX = 0x04,
  UDF_OS_CLASS_WINDOWS_9X = 0x05,
  UDF_OS_CLASS_WINDOWS_NT = 0x06,
  UDF_OS_CLASS_OS_400 = 0x07,
  UDF_OS_CLASS_BE_OS = 0x08,
  UDF_OS_CLASS_WINDOWS_CE = 0x09
};
File

StarBurn.h

Description

UDF OS class

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_TREE_ITEM Structure

_UDF_TREE_ITEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _UDF_TREE_ITEM {
  unsigned long m__ULONG__FileEntryRBA;
  unsigned long m__ULONG__FileIdentifierRBA;
  unsigned long m__ULONG__FileIdentifierParentOrContentRBA;
  unsigned long m__ULONG__LastTouchedRBA;
  unsigned long m__ULONG__GUID;
  unsigned char m__UCHAR__IsDirectory;
  unsigned char m__UCHAR__IsCached;
  unsigned short m__USHORT__NumberOfKidsAsParents;
  char m__CHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
  UDF_FILE_HANDLE m__UDF_FILE_HANDLE;
  unsigned char * m__PUCHAR__File;
  unsigned __int64 m__ULONGLONG__SizeInUCHARs;
  unsigned long m__ULONG__SizeInLogicalBlocks;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Next;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Prev;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Kids;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Parent;
  unsigned char m__UCHAR__FileEntryDescriptor[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  unsigned char * m__PUCHAR__FileIdentifierDescriptor;
  unsigned long m__ULONG__FileIdentifierDescriptorSizeInUCHARs;
  unsigned char m__UCHAR__FileContent[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  void * m__PVOID__Context;
  ISO9660_DATE_TIME m__ISO9660_DATE_TIME;
  WCHAR m__WCHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
};
File

StarBurn.h

Description

Structure that represents UDF tree item

Member | Definition
m__ULONG__FileEntryRBA | File entry relative block address
m__ULONG__FileIdentifierRBA | File identifier relative block address
m__ULONG__FileIdentifier... | File identifier parent or content relative block address
m__ULONG__LastTouchedRBA | Last touched relative block address (last occupied)
m__ULONG__GUID | Globally unique identifier
m__UCHAR__IsDirectory | Is this directory (0x01) or file (0x00)
m__UCHAR__IsCached | Is this entry content cached (located in memory) or not cached (located on the disk)
m__USHORT_NumberOfKidsAsParents | Number of kids that have their own kids
m__CHAR__Name | Name of this node
m__UDF_FILE_HANDLE | UDF file handle of this node
m__PUCHAR__File | Pointer to file content (for cached files)
m__ULONGLONG__SizeInUCHARs | Node content size in UCHARs
m__ULONG__SizeInLogicalBlocks | Node content size in logical blocks
m__PUDF_TREE_ITEM__Next | Pointer to the next UDF tree item in the linked list
m__PUDF_TREE_ITEM__Prev | Pointer to the previous UDF tree item in the linked list
m__PUDF_TREE_ITEM__Kids | Pointer to the kids liked list
m__PUDF_TREE_ITEM__Parent | Pointer to the parent of the current UDF tree item
m__UCHAR__FileEntryDescriptor | Array if UCHARs holding UDF file entry descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for parent of the current UDF tree item
m__UCHAR__FileContent | Array of UCHARs holding file content (alternative cached data)
m__PVOID__Context | Pointer to context value
m__ISO9660_DATE_TIME | ISO9660 date and time
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_UDF_VERSION Enumeration

_UDF_VERSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _UDF_VERSION {
  UDF_VERSION_1_02 = 0,
  UDF_VERSION_1_50,
  UDF_VERSION_2_00,
  UDF_VERSION_2_01,
  UDF_VERSION_2_50,
  UDF_VERSION_2_60
};
File

StarBurn.h

Description

Enum that represents UDF version

Member | Definition
UDF_VERSION_1_02 | UDF 1.02
UDF_VERSION_1_50 | UDF 1.5
UDF_VERSION_2_00 | UDF 2.0
UDF_VERSION_2_01 | UDF 2.01
UDF_VERSION_2_50 | UDF 2.5
UDF_VERSION_2_60 | UDF 2.6
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_WAVE_FILE_HEADER Structure

_WAVE_FILE_HEADER Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _WAVE_FILE_HEADER {
  ULONG m__ULONG__Riff;
  ULONG m__ULONG__Length;
  ULONG m__ULONG__Wave;
  ULONG m__ULONG__FormatTag;
  ULONG m__ULONG__FormatLength;
  WAVE_FORMAT_CHUNK m__WAVE_FORMAT_CHUNK;
  ULONG m__ULONG__DataTag;
  ULONG m__ULONG__DataLength;
};
File

StarBurn.h

Description

Structure that represents WAVE file header

Member | Definition
m__ULONG__Riff | Riff signature
m__ULONG__Length | Length of data section (w/o header) in UCHARs
m__ULONG__Wave | Wave signature
m__ULONG__FormatTag | Format tag
m__ULONG__FormatLength | Format length (size of WAVE_FORMAT_CHUNK in UCHARs)
m__WAVE_FORMAT_CHUNK | WAVE format chunk (see WAVE_FORMAT_CHUNK for more details)
m__ULONG__DataTag | Data tag
m__ULONG__DataLenght | Data length in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_WAVE_FORMAT_CHUNK Structure

_WAVE_FORMAT_CHUNK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
struct _WAVE_FORMAT_CHUNK {
  USHORT m__USHORT__Format;
  USHORT m__USHORT__Channels;
  ULONG m__ULONG__SamplesPerSecond;
  ULONG m__ULONG__AverageSamplesPerSecond;
  USHORT m__USHORT__Alignment;
  USHORT m__USHORT__BitsPerSample;
};
File

StarBurn.h

Description

Structure that represents WAVE format chunk

Member | Definition
m__USHORT__Format | Format
m__USHORT__Channels | Number of channels
m__ULONG__SamplesPerSecond | Number of samples per second
m__ULONG__AverageSamplesPerSecond | Number of average samples per second
m__USHORT__Alignment | Alignment
m__USHORT__BitsPerSample | Number of bits in single sample
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


_WRITE_MODE Enumeration

_WRITE_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
enum _WRITE_MODE {
  WRITE_MODE_TRACK_AT_ONCE = 0,
  WRITE_MODE_SESSION_AT_ONCE,
  WRITE_MODE_DISC_AT_ONCE_PQ,
  WRITE_MODE_DISC_AT_ONCE_RAW_PW
};
File

StarBurn.h

Description

Enum that represents write modes

Member | Definition
WRITE_MODE_TRACK_AT_ONCE | Track-At-Once
WRITE_MODE_SESSION_AT_ONCE | Session-At-Once
WRITE_MODE_DISC_AT_ONCE_PQ | Disc-At-Once PQ
WRITE_MODE_DISC_AT_ONCE_RAW_PW | Disc-At-Once raw P-W
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CALLBACK_NUMBER Enumeration

CALLBACK_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _CALLBACK_NUMBER {
  CN_FILE_TREE_PROGRESS_ADD = 0,
  CN_FILE_TREE_PROGRESS_REMOVE,
  CN_FILE_TREE_PROGRESS_IGNORE,
  CN_FILE_TREE_PROGRESS_NAME_COLLISION,
  CN_TARGET_FILE_ANALYZE_BEGIN,
  CN_TARGET_FILE_ANALYZE_END,
  CN_WAIT_CACHE_FULL_BEGIN,
  CN_WAIT_CACHE_FULL_END,
  CN_SYNCHRONIZE_CACHE_BEGIN,
  CN_SYNCHRONIZE_CACHE_END,
  CN_FIND_DEVICE,
  CN_CDVD_READ_PROGRESS,
  CN_CDVD_WRITE_PROGRESS,
  CN_CDVD_BUFFER_STATUS,
  CN_CDVD_TRACK_BEGIN,
  CN_CDVD_TRACK_END,
  CN_CDVD_SPLIT_BEGIN,
  CN_CDVD_SPLIT_END,
  CN_CDVD_READ_BAD_BLOCK_HIT,
  CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT,
  CN_CDVD_READ_RETRY,
  CN_DVDPLUSRW_FORMAT_BEGIN,
  CN_DVDPLUSRW_FORMAT_END,
  CN_DVDRAM_FORMAT_BEGIN,
  CN_DVDRAM_FORMAT_END,
  CN_BUFFER_UNDERRUN,
  CN_DVD_MEDIA_PADDING_SIZE,
  CN_DVD_MEDIA_PADDING_BEGIN,
  CN_DVD_MEDIA_PADDING_END,
  CN_CDVD_READ_CANCEL_QUERY,
  CN_DVDRW_QUICK_FORMAT_BEGIN,
  CN_DVDRW_QUICK_FORMAT_END,
  CN_DVD_TEST_WRITE_DISABLED,
  CN_CDVD_DPM_BEGIN,
  CN_CDVD_DPM_END,
  CN_CDVD_DPM_PROGRESS,
  CN_CDVD_VERIFY_PROGRESS,
  CN_SAO_TRACK_WRITE_BEGIN,
  CN_SAO_TRACK_WRITE_END,
  CN_DVD_MEDIA_PADDING_WRITE_PROGRESS,
  CN_CDVD_WRITE_BEGIN,
  CN_CDVD_WRITE_END,
  CN_CDVD_VERIFY_BEGIN,
  CN_CDVD_VERIFY_END,
  CN_BDRE_FORMAT_BEGIN,
  CN_BDRE_FORMAT_END,
  CN_UDF_FILE_LOOKUP,
  CN_UDF_LOOKUP_FILE,
  CN_UDF_LOOKUP_DIR,
  CN_CDVD_BLANKAREA_PROGRESS
} * PCALLBACK_NUMBER, CALLBACK_NUMBER;
File

StarBurn.h

Description

Enum that represents callback number

Member | Definition
CN_FILE_TREE_PROGRESS_ADD | Item was add to the file tree
CN_FILE_TREE_PROGRESS_REMOVE | Item was removed from the file tree
CN_FILE_TREE_PROGRESS_IGNORE | Item was ignored during processing file tree
CN_FILE_TREE_PROGRESS_NAME... | There are two nodes which have the same name
CN_TARGET_FILE_ANALYZE_BEGIN | File internal structure (size, type etc) analyze started
CN_TARGET_FILE_ANALYZE_END | File structure analyze completed
CN_WAIT_CACHE_FULL_BEGIN | Toolkit started to wait for cache to become full
CN_WAIT_CACHE_FULL_END | Toolkit finished to wait for cache fullness
CN_SYNCHRONIZE_CACHE_BEGIN | Cache flushing to the media started
CN_SYNCHRONIZE_CACHE_END | Cache flushing to the media completed
CN_FIND_DEVICE | Find device operation completed
CD_CDVD_READ_PROGRESS | CD/DVD/Blu-Ray/HD-DVD read operation progress
CN_CDVD_WRITE_PROGRESS | CD/DVD/Blu-Ray/HD-DVD write operation progress
CN_CDVD_BUFFER_STATUS | CD/DVD/Blu-Ray/HD-DVD buffer status information queried
CN_CDVD_TRACK_BEGIN | CD/DVD/Blu-Ray/HD-DVD track processing started
CN_CDVD_TRACK_END | CD/DVD/Blu-Ray/HD-DVD track processing completed
CN_CDVD_SPLIT_BEGIN | CD/DVD/Blu-Ray/HD-DVD split section processing started
CN_CDVD_SPLIT_END | CD/DVD/Blu-Ray/HD-DVD split section processing completed
CN_CDVD_READ_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a bad (unrecoverable) block
CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a ECC/EDC bad (recoverable) block
CN_CDVD_READ_RETRY | CD/DVD/Blu-Ray/HD-DVD read operation was retried
CN_DVDPLUSRW_FORMAT_BEGIN | DVD+RW format operation started
CN_DVDPLUSRW_FORMAT_EDN | DVD+RW format operation completed
CN_DVDRAM_FORMAT_BEGIN | DVD-RAM format operation started
CN_DVDRAM_FORMAT_EDN | DVD-RAM format operation completed
CN_BUFFER_UNDERRUN | Buffer underrun condition happened
CN_DVD_MEDIA_PADDING_SIZE | DVD media would be padded to 1GB size, additional info passed
CN_DVD_MEDIA_PADDING_BEGIN | DVD media padding burn process started
CN_DVD_MEDIA_PADDING_END | DVD media padding burn process completed
CN_CDVD_READ_CANCEL_QUERY | CD/DVD/Blu-Ray/HD-DVD media processing plug-in queries cancel status
CN_DVDRW_QUICK_FORMAT_BEGIN | DVD-RW quick format operation started
CN_DVDRW_QUICK_FORMAT_END | DVD-RW quick format operation completed
CN_DVD_TEST_WRITE_DISABLED | Test write is disabled (for DVD+R/RW, DVD-RAM or multisession DVD-RW)
CN_CDVD_DPM_BEGIN | CD/DVD/Blu-Ray/HD-DVD DPM processing started
CN_CDVD_DPM_END | CD/DVD/Blu-Ray/HD-DVD DPM processing completed
CD_CDVD_DPM_PROGRESS | CD/DVD/Blu-Ray/HD-DVD DPM operation progress
CN_CDVD_VERIFY_PROGRESS | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_SAO_TRACK_WRITE_BEGIN | SAO track write started
CN_SAO_TRACK_WRITE_END | SAO track write completed
CN_DVD_MEDIA_PADDING_WRITE_PRO... | DVD media padding burn progress indication
CN_CDVD_WRITE_BEGIN | CD/DVD/Blu-Ray/HD-DVD write operation started
CN_CDVD_WRITE_END | CD/DVD/Blu-Ray/HD-DVD write operation completed
CN_CDVD_VERIFY_BEGIN | CD/DVD/Blu-Ray/HD-DVD verify operation started
CN_CDVD_VERIFY_END | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_BDRE_FORMAT_BEGIN | BD-RE format operation started
CN_BDRE_FORMAT_END | BD-RE format operation completed
CN_UDF_FILE_LOOKUP | UDF file found during fast lookup
CN_UDF_LOOKUP_FILE | UDF file found during fast lookup
CN_UDF_LOOKUP_DIR | UDF directory found during fast lookup
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CDB_FAILURE_INFORMATION Structure

CDB_FAILURE_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _CDB_FAILURE_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__CDBSizeInUCHARs;
  UCHAR m__UCHAR__CDB[ 16 ];
  UCHAR m__UCHAR__SenseSizeInUCHARs;
  UCHAR m__UCHAR__Sense[ 32 ];
  UCHAR m__UCHAR__TransportStatus;
  UCHAR m__UCHAR__TargetStatus;
  UCHAR m__UCHAR__HostAdapterStatus;
} * PCDB_FAILURE_INFORMATION, CDB_FAILURE_INFORMATION;
File

StarBurn.h

Description

Structure that represents CDB failure information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__CDBSizeInUCHARs | CDB size in UCHARs
m__UCHAR__CDB[ 16 ] | CDB dump
m__UCHAR__SenseSizeInUCHARs | SCSI sense size in UCHARs
m__UCHAR__Sense[ 32 ] | SCSI sense dump
m__UCHAR__TransportStatus | SCSI transport status
m__UCHAR__TargetStatus | SCSI target status
m__UCHAR__HostAdapterStatus | SCSI host adapter status
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DAO_DISC_LAYOUT Structure

DAO_DISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DAO_DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DAO_DISC_LAYOUT_ENTRY m__DAO_DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
} * PDAO_DISC_LAYOUT, DAO_DISC_LAYOUT;
File

StarBurn.h

Description

Structure that represents DAO disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DAO_DISC_LAYOUT_ENTRY | DAO disc layout entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DAO_DISC_LAYOUT_ENTRY Structure

DAO_DISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DAO_DISC_LAYOUT_ENTRY {
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__TrackStartingLBA;
  BOOLEAN m__BOOLEAN__IsUnicode;
  union {
    CHAR m__CHAR__TrackName[ (MAX_PATH * sizeof(WCHAR) ) ];
    WCHAR m__WCHAR__TrackName[ (MAX_PATH) ];
  }
  PVOID m__PVOID__File;
  BOOLEAN m__BOOLEAN__IsDataTrack;
  BOOLEAN m__BOOLEAN__IsRawTrack;
  BOOLEAN m__BOOLEAN__IsAudioExTrack;
} * PDAO_DISC_LAYOUT_ENTRY, DAO_DISC_LAYOUT_ENTRY;
File

StarBurn.h

Description

Structure that represents DAO disc layout entry (track)

Member | Definition
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__TrackStartingLBA | Track starting LBA (logical block address)
m__BOOLEAN__IsUnicode | Is name in Unicode format or not (see below)
m__CHAR__TrackName | Track name (absolute path & name) in ANSI or Unicode format (see above)
m__PVOID__File | Pointer to internally created disk file object (NULL initially)
m__BOOLEAN__IsDataTrack | Is this data track (audio otherwise)
m__BOOLEAN__IsRawTrack | Is this raw track (MDF image)
m__BOOLEAN__IsAudioExTrack | Is this extended audio track (2448 UCHARs/logical block)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_FILESYSTEM Structure

DISC_FILESYSTEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_FILESYSTEM {
  BOOLEAN m__BOOLEAN__UDFPresent;
  BOOLEAN m__BOOLEAN__JolietPresent;
  BOOLEAN m__BOOLEAN__ISO9660Present;
  BOOLEAN m__BOOLEAN__ElToritoBootRecordPresent;
} * PDISC_FILESYSTEM, DISC_FILESYSTEM;
File

StarBurn.h

Description

Structure with disc file system flags

Member Definition

--------- --------------

m__BOOLEAN__UDFPresent UDF file system is present
m__BOOLEAN__ISO9660Present ISO9660 file system is present
m__BOOLEAN__JolietPresent Joliet extension for ISO9660 file system is present
m__BOOLEAN__ElToritoBootRecordPresent El Torito boot record is present
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_LAYOUT Structure

DISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DISC_LAYOUT_ENTRY m__DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
  LONG m__LONG__NumberOfRawRawPWTracks;
  LONG m__LONG__RawRawPWTrackSizeInLBs[ NUMBER_OF_TRACKS ];
} * PDISC_LAYOUT, DISC_LAYOUT;
File

StarBurn.h

Description

Structure that represents disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DISC_LAYOUT_ENTRY | Disc layout entries
m__LONG__NumberOfRawRawPWTracks | Number of raw + raw P-W sub-channel tracks
m__LONG__RawRawPWTrackSize | Raw + raw P-W sub-channel track sizes
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_LAYOUT_ENTRY Structure

DISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_LAYOUT_ENTRY {
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsVideo;
  BOOLEAN m__BOOLEAN__IsRawRawPW;
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__PreGapSizeInLBs;
  LONG m__LONG__PostGapSizeInLBs;
  union {
    CHAR m__CHAR__TrackName[ MAX_PATH*sizeof(WCHAR) ];
    WCHAR m__WCHAR__TrackName[ MAX_PATH ];
  }
  PVOID m__PVOID__File;
  PVOID m__PVOID__Tree;
  PVOID m__PVOID__BackSideTree;
} * PDISC_LAYOUT_ENTRY, DISC_LAYOUT_ENTRY;
File

StarBurn.h

Description

Structure that represents disc layout entry (track)

Member | Definition
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsVideo | Is this video track
m__BOOLEAN__IsRawRawPW | Is this raw + raw P-W sub-channel track
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__PreGapSizeInLBs | PreGap size in LBs (logical blocks)
m__LONG__PostGapSizeInLBs | PostGap size in LBs (logical blocks)
m__CHAR__TrackName | Track name (absolute path & name), can be zero array if next pointer is valid
m__PVOID__File | Pointer to internally created disk file object
m__PVOID__Tree | Pointer to object created with StarBurn_ISO9660JolietFileTree_Create(), can be NULL
m__PVOID__BackSideTree | Pointer to undecorated ISO9660 file tree object
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_TYPE Enumeration

DISC_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _DISC_TYPE {
  DISC_TYPE_UNKNOWN = 0,
  DISC_TYPE_CDROM = 1,
  DISC_TYPE_CDR = 2,
  DISC_TYPE_CDRW = 3,
  DISC_TYPE_DVDROM = 4,
  DISC_TYPE_DVDR = 5,
  DISC_TYPE_DVDRAM = 6,
  DISC_TYPE_DVDRWRO = 7,
  DISC_TYPE_DVDRWSR = 8,
  DISC_TYPE_DVDPLUSRW = 9,
  DISC_TYPE_DDCDROM = 10,
  DISC_TYPE_DDCDR = 11,
  DISC_TYPE_DDCDRW = 12,
  DISC_TYPE_DVDPLUSR = 13,
  DISC_TYPE_NO_MEDIA = 14,
  DISC_TYPE_DVDPLUSR_DL = 15,
  DISC_TYPE_DVDR_DL = 16,
  DISC_TYPE_BDROM = 17,
  DISC_TYPE_BDR = 18,
  DISC_TYPE_BDRE = 19,
  DISC_TYPE_HDDVDROM = 20,
  DISC_TYPE_HDDVDR = 21,
  DISC_TYPE_HDDVDRW = 22
} * PDISC_TYPE, DISC_TYPE;
File

StarBurn.h

Description

Enum that represents inserted disc type

Member | Definition
DISC_TYPE_UNKNOWN | Unknown disc type
DISC_TYPE_CDROM, | CD-ROM
DISC_TYPE_CDR, | CD-R
DISC_TYPE_CDRW, | CD-RW
DISC_TYPE_DVDROM, | DVD-ROM
DISC_TYPE_DVDR, | DVD-R
DISC_TYPE_DVDRAM, | DVD-RAM
DISC_TYPE_DVDRWRO, | DVD-RW RO (Restricted Overwrite)
DISC_TYPE_DVDRWSR, | DVD-RW SR (Sequential Recording)
DISC_TYPE_DVDPLUSRW, | DVD+RW
DISC_TYPE_DDCDROM, | DD (Double Density) CD-ROM
DISC_TYPE_DDCDR, | DD (Double Density) CD-R
DISC_TYPE_DDCRW | DD (Double Density) CD-RW
DISC_TYPE_DVDPLUSR | DVD+R
DISC_TYPE_NO_MEDIA | No media is inserted to the disc drive
DISC_TYPE_DVDPLUSR_DL | DVD+R DL (Double Layer)
DISC_TYPE_DVDR_DL | DVD-R DL (Dual Layer)
DISC_TYPE_BDROM | BD-ROM (Blu-Ray ROM)
DISC_TYPE_BDR | BD-R (Blu-Ray Disc Recordable)
DISC_TYPE_BDRE | BD-RE (Blu-Ray Disc Recordable Erasable)
DISC_TYPE_HDDVDROM | HD-DVD ROM
DISC_TYPE_HDDVDR | HD-DVD Recordable
DISC_TYPE_HDDVDRW | HD-DVD ReWritable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_VIDEO_CONTROL_BLOCK Structure

DVD_VIDEO_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DVD_VIDEO_CONTROL_BLOCK {
  UDF_CONTROL_BLOCK m__UDF_CONTROL_BLOCK;
  UDF_TREE_ITEM m__UDF_TREE_ITEM__Directory[ 4 ];
  UDF_TREE_ITEM m__UDF_TREE_ITEM__File[ 1192 ];
  LONG m__LONG__NumberOfFiles;
  LONG m__LONG__NumberOfTitles;
  LONG m__LONG__VtsIndex[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ][ 2 ];
  BOOLEAN m__BOOLEAN__IsMainMenuVob;
  BOOLEAN m__BOOLEAN__IsTitleMenuVob[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ];
} * PDVD_VIDEO_CONTROL_BLOCK, DVD_VIDEO_CONTROL_BLOCK;
File

StarBurn.h

Description

Structure that represents DVD-Video control block and pointer to DVD-Video control block

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ERASE_TYPE Enumeration

ERASE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _ERASE_TYPE {
  ERASE_TYPE_BLANK_DISC_FULL = 0,
  ERASE_TYPE_BLANK_DISC_FAST,
  ERASE_TYPE_BLANK_TRACK,
  ERASE_TYPE_UNRESERVE_TRACK,
  ERASE_TYPE_BLANK_TRACK_TAIL,
  ERASE_TYPE_UNCLOSE_LAST_SESSION,
  ERASE_TYPE_BLANK_SESSION
} * PERASE_TYPE, ERASE_TYPE;
File

StarBurn.h

Description

Enum that represents erase type

Member | Definition
ERASE_TYPE_BLANK_DISC_FULL | Completely erase the rewritable disc
ERASE_TYPE_BLANK_DISC_FAST | Erase only TOC, PMA and first track lead in on the rewritable disc
ERASE_TYPE_BLANK_TRACK | Erase track only
ERASE_TYPE_UNRESERVE_TRACK | Unreserve track that was reserved before
ERASE_TYPE_BLANK_TRACK_TAIL | Erase track tail
ERASE_TYPE_UNCLOSE_LAST_SESSION | Unclose last closed session
ERASE_TYPE_BLANK_SESSION | Erase last session
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXCEPTION_NUMBER Enumeration

EXCEPTION_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _EXCEPTION_NUMBER {
  EN_SUCCESS = 0,
  EN_FAILURE,
  EN_INVALID_INPUT_PARAMETER,
  EN_INVALID_STATE,
  EN_MEMORY_ALLOCATION_FAILED,
  EN_SYSTEM_CALL_FAILED,
  EN_SCSI_TRANSPORT_FAILED,
  EN_SCSI_DEVICE_BUSY,
  EN_SCSI_CDB_FAILED,
  EN_SCSI_DEVICE_INVALID_TYPE,
  EN_INVALID_RESPONSE,
  EN_BUFFER_UNDERRUN,
  EN_INVALID_EXCEPTION,
  EN_ACCESS_TO_FEATURE_DENIED,
  EN_USER_EXCEPTION,
  EN_PATH_TOO_LONG,
  EN_UNDER_CONSTRUCTION,
  EN_NOT_FOUND,
  EN_FILE_TOO_BIG,
  EN_NOT_IMPLEMENTED,
  EN_RANGE,
  EN_REGISTRATION_FAILED,
  EN_UNSUPPORTED_AUDIO,
  EN_BUFFER_TOO_SMALL,
  EN_SYSTEM_CALL_FAILED_EX,
  EN_ERROR_RECOVERY_FAILED,
  EN_UNRECOGNIZED_MEDIA,
  EN_GENERAL_SEEK_ERROR,
  EN_GENERAL_READ_ERROR,
  EN_ILLEGAL_OPERATION_FOR_TRACK,
  EN_UNSUPPORTED_READ_MODE,
  EN_REQUEST_TOO_LARGE,
  EN_FULL_ERASE_REQUIRED,
  EN_VERIFY_FAILED,
  EN_DPM_FAILED,
  EN_DEVICE_SHARING_VIOLATION,
  EN_CALL_IS_OBSOLETE,
  EN_WRONG_OS_VERSION,
  EN_INVALID_FIELD_IN_CDB,
  EN_CACHE_IS_TOO_SMALL
} * PEXCEPTION_NUMBER, EXCEPTION_NUMBER;
File

StarBurn.h

Description

Enum that represents exception number

Member | Definition
EN_SUCCESS | Nothing really happened, operation completed successfully
EN_FAILURE | Undefined error happened, something goes really wrong
EN_INVALID_INPUT_PARAMETER | User input parameter is not valid
EN_INVALID_STATE | The state of the object is not valid for current operation
EN_MEMORY_ALLOCATION_FAILED | Memory allocation failed
EN_SYSTEM_CALL_FAILED | System call failed, check SystemError pointer to system error value
EN_SCSI_TRANSPORT_FAILED | SCSI transport internal error
EN_SCSI_DEVICE_BUSY | SCSI device is busy for a while
EN_SCSI_CDB_FAILED | SCSI CDB delivery failed, check CDB_FAILURE_INFORMATION for details
EN_SCSI_DEVICE_INVALID_TYPE | SCSI device of this type is not supported
EN_INVALID_RESPONSE | Something really unsupported returned
EN_BUFFER_UNDERRUN | Buffer underrun happened
EN_INVALID_EXCEPTION | Exception was not allocated
EN_ACCESS_TO_FEATURE_DENIED | Access to feature denied b/s of the wrong version
EN_USER_EXCEPTION | This is not a real exception just the result of user interaction
EN_PATH_TOO_LONG | File path is too long
EN_UNDER_CONSTRUCTION | This feature is still under construction
EN_NOT_FOUND | Operation could not be performed b/s either device or requested parameter not found
EN_FILE_TOO_BIG | File is too big for requested operation
EN_NOT_IMPLEMENTED | Feature is not implemented yet
EN_RANGE | Passed range is not valid
EN_REGISTRATION_FAILED | Registration procedure completed with errors
EN_UNSUPPORTED_AUDIO | Unsupported audio format used as either input or output
EN_BUFFER_TOO_SMALL | Buffer size supplied by caller is not sufficient
EN_SYSTEM_CALL_FAILED_EX | Middle-layer error happened, check SystemError pointer for specific error value
EN_ERROR_RECOVERY_FAILED | Error recovery failed
EN_UNRECOGNIZED_MEDIA | Current media type is not recognized
EN_GENERAL_SEEK_ERROR | General seek error on CD/DVD/Blu-Ray/HD-DVD media
EN_GENERAL_READ_ERROR | General read error on CD/DVD/Blu-Ray/HD-DVD media
EN_ILLEGAL_OPERATION_FOR_TRACK | Illegal operation for track
EN_UNSUPPORTED_READ_MODE | Currently selected read mode is not supported by device
EN_REQUEST_TOO_LARGE | Request size is too large to be handled
EN_FULL_ERASE_REQUIRED | Full erase required before recording to inserted media
EN_VERIFY_FAILED | Verify operation found different memory buffers
EN_DPM_FAILED | DPM associated call failed
EN_DEVICE_SHARING_VIOLATION | Device failed to open b/s of sharing violation
EN_CALL_IS_OBSOLETE | Function is obsolete
EN_WRONG_OS_VERSION | OS version is not supported
EN_INVALID_FIELD_IN_CDB | Invalid field in CDB
EN_CACHE_IS_TOO_SMALL | Allocated cache size is too small to handle "write" operations
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


FILE_TIME Enumeration

FILE_TIME Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _FILE_TIME {
  FILE_TIME_CREATION = 0,
  FILE_TIME_LAST_ACCESS,
  FILE_TIME_LAST_WRITE
} * PFILE_TIME, FILE_TIME;
File

StarBurn.h

Description

Enum that represents file time that will be included in the ISO9660/Joliet image

Member | Definition
FILE_TIME_CREATION | Original creation file time will be included into the file system image
FILE_TIME_LAST_ACCESS | Last access time will be included into the file system image
FILE_TIME_LAST_WRITE | Last write tile will be included into the file system image
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


FILE_TREE Enumeration

FILE_TREE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _FILE_TREE {
  FILE_TREE_ISO9660 = 0,
  FILE_TREE_JOLIET
} * PFILE_TREE, FILE_TREE;
File

StarBurn.h

Description

Enum that represents file tree

Member | Definition
FILE_TREE_ISO9660 | ISO9660 file tree
FILE_TREE_JOLIET | ISO9660 file tree + Joliet extensions
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


FULL_TOC_ENTRY_RAW Structure

FULL_TOC_ENTRY_RAW Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _FULL_TOC_ENTRY_RAW {
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__TNO;
  UCHAR m__UCHAR__POINT;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__Zero;
  UCHAR m__UCHAR__PMIN;
  UCHAR m__UCHAR__PSEC;
  UCHAR m__UCHAR__PFRAME;
} * PFULL_TOC_ENTRY_RAW, FULL_TOC_ENTRY_RAW;
File

StarBurn.h

Description

Structure that represents full TOC entry

Member | Definition
m__UCHAR__SessionNumber | Session number
m__UCHAR__CONTROL : 4 | Control
m__UCHAR__ADR : 4 | Address
m__UCHAR__TNO | Track number
m__UCHAR__POINT | Point
m__UCHAR__Min | Minute
m__UCHAR__Sec | Second
m__UCHAR__Frame | Frame
m__UCHAR__Zero | Zero (always 0)
m__UCHAR__PMIN | Starting minute (from MSF)
m__UCHAR__PSEC | Starting second (from MSF)
m__UCHAR__PFRAME | Starting frame (from MSF)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_DATE_TIME Structure

ISO9660_DATE_TIME Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _ISO9660_DATE_TIME {
  UCHAR m__UCHAR__Year;
  UCHAR m__UCHAR__Month;
  UCHAR m__UCHAR__Day;
  UCHAR m__UCHAR__Hour;
  UCHAR m__UCHAR__Minute;
  UCHAR m__UCHAR__Second;
  UCHAR m__UCHAR__GMTOffset;
} * PISO9660_DATE_TIME, ISO9660_DATE_TIME;
File

StarBurn.h

Description

Structure that represents ISO9660 date and time

Member | Definition
m__UCHAR__Year | Year
m__UCHAR__Month | Month
M__UCHAR__Day | Day
m__UCHAR__Hour | Hour
m__UCHAR__Minute | Minute
m__UCHAR__Second | Second
m__UCHAR__GMTOffset | Offset from GMT in hours
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_KIDTYPE Enumeration

ISO9660_KIDTYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _ISO9660_KIDTYPE {
  KIDTYPE_UNKNOWN,
  KIDTYPE_IMPORTED,
  KIDTYPE_FROMDISK,
  KIDTYPE_VIRTUAL
} * PISO9660_KIDTYPE, ISO9660_KIDTYPE;
File

StarBurn.h

Description

Enum that represent type of ISO9660 tree node

Member | Definition
KIDTYPE_UNKNOWN | Unknown kid type
KIDTYPE_IMPORTED | Node was imported from previous track
KIDTYPE_FROMDISK | Node was added from the disk
KIDTYPE_VIRTUAL | Node was created as memory file or virtual directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NAME_COLLISION_INFO Structure

NAME_COLLISION_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _NAME_COLLISION_INFO {
  BOOLEAN m__BOOLEAN__IsJolietName;
  UCHAR m__UCHAR__Name[ MAX_PATH * 2 ];
  PCHAR m__PCHAR__OldAbsoluteName;
  ULONG m__ULONG__OldFileAttributes;
  PCHAR m__PCHAR__NewAbsoluteName;
  ULONG m__ULONG__NewFileAttributes;
  NAME_COLLISION_SOLUTION m__NAME_COLLISION_SOLUTION;
} * PNAME_COLLISION_INFO, NAME_COLLISION_INFO;
File

StarBurn.h

Description

Structure that represents information about name collision

Member | Definition
m__BOOLEAN__IsJolietName | Indicates the format of the m__UCHAR__Name
m__UCHAR__Name | The node name (CHAR for ISO9660 or USHORT for Joliet)
m__PCHAR__OldAbsoluteName | Absolute file name of the old file node
m__ULONG__OldFileAttributes | Old file attributes
m__PCHAR__NewAbsoluteName | Absolute file name of the new file node
m__ULONG__NewFileAttributes | New file attributes
m__NAME_COLLISION_SOLUTION | The solution of the collision (what action has been performed)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NAME_COLLISION_SOLUTION Enumeration

NAME_COLLISION_SOLUTION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _NAME_COLLISION_SOLUTION {
  NAME_COLLISION_SKIP_NEW = 0,
  NAME_COLLISION_REPLACE_OLD = 1,
  NAME_COLLISION_RENAME_NEW = 2,
  NAME_COLLISION_MERGE_FOLDERS = 3,
  NAME_COLLISION_FORCE_DWORD = 0xFFFFFFFF
} * PNAME_COLLISION_SOLUTION, NAME_COLLISION_SOLUTION;
File

StarBurn.h

Description

Enum that represents the solutions of name collisions

Member | Definition
NAME_COLLISION_SKIP_NEW | Remove new node and leave old node
NAME_COLLISION_REPLACE_OLD | Remove old node and insert new node
NAME_COLLISION_RENAME_NEW | Leave old node and insert new node with the new name
NAME_COLLISION_MERGE_FOLDERS | Add files from new folder into an old folder
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PCALLBACK_NUMBER Enumeration

PCALLBACK_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _CALLBACK_NUMBER {
  CN_FILE_TREE_PROGRESS_ADD = 0,
  CN_FILE_TREE_PROGRESS_REMOVE,
  CN_FILE_TREE_PROGRESS_IGNORE,
  CN_FILE_TREE_PROGRESS_NAME_COLLISION,
  CN_TARGET_FILE_ANALYZE_BEGIN,
  CN_TARGET_FILE_ANALYZE_END,
  CN_WAIT_CACHE_FULL_BEGIN,
  CN_WAIT_CACHE_FULL_END,
  CN_SYNCHRONIZE_CACHE_BEGIN,
  CN_SYNCHRONIZE_CACHE_END,
  CN_FIND_DEVICE,
  CN_CDVD_READ_PROGRESS,
  CN_CDVD_WRITE_PROGRESS,
  CN_CDVD_BUFFER_STATUS,
  CN_CDVD_TRACK_BEGIN,
  CN_CDVD_TRACK_END,
  CN_CDVD_SPLIT_BEGIN,
  CN_CDVD_SPLIT_END,
  CN_CDVD_READ_BAD_BLOCK_HIT,
  CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT,
  CN_CDVD_READ_RETRY,
  CN_DVDPLUSRW_FORMAT_BEGIN,
  CN_DVDPLUSRW_FORMAT_END,
  CN_DVDRAM_FORMAT_BEGIN,
  CN_DVDRAM_FORMAT_END,
  CN_BUFFER_UNDERRUN,
  CN_DVD_MEDIA_PADDING_SIZE,
  CN_DVD_MEDIA_PADDING_BEGIN,
  CN_DVD_MEDIA_PADDING_END,
  CN_CDVD_READ_CANCEL_QUERY,
  CN_DVDRW_QUICK_FORMAT_BEGIN,
  CN_DVDRW_QUICK_FORMAT_END,
  CN_DVD_TEST_WRITE_DISABLED,
  CN_CDVD_DPM_BEGIN,
  CN_CDVD_DPM_END,
  CN_CDVD_DPM_PROGRESS,
  CN_CDVD_VERIFY_PROGRESS,
  CN_SAO_TRACK_WRITE_BEGIN,
  CN_SAO_TRACK_WRITE_END,
  CN_DVD_MEDIA_PADDING_WRITE_PROGRESS,
  CN_CDVD_WRITE_BEGIN,
  CN_CDVD_WRITE_END,
  CN_CDVD_VERIFY_BEGIN,
  CN_CDVD_VERIFY_END,
  CN_BDRE_FORMAT_BEGIN,
  CN_BDRE_FORMAT_END,
  CN_UDF_FILE_LOOKUP,
  CN_UDF_LOOKUP_FILE,
  CN_UDF_LOOKUP_DIR,
  CN_CDVD_BLANKAREA_PROGRESS
} * PCALLBACK_NUMBER, CALLBACK_NUMBER;
File

StarBurn.h

Description

Enum that represents callback number

Member | Definition
CN_FILE_TREE_PROGRESS_ADD | Item was add to the file tree
CN_FILE_TREE_PROGRESS_REMOVE | Item was removed from the file tree
CN_FILE_TREE_PROGRESS_IGNORE | Item was ignored during processing file tree
CN_FILE_TREE_PROGRESS_NAME... | There are two nodes which have the same name
CN_TARGET_FILE_ANALYZE_BEGIN | File internal structure (size, type etc) analyze started
CN_TARGET_FILE_ANALYZE_END | File structure analyze completed
CN_WAIT_CACHE_FULL_BEGIN | Toolkit started to wait for cache to become full
CN_WAIT_CACHE_FULL_END | Toolkit finished to wait for cache fullness
CN_SYNCHRONIZE_CACHE_BEGIN | Cache flushing to the media started
CN_SYNCHRONIZE_CACHE_END | Cache flushing to the media completed
CN_FIND_DEVICE | Find device operation completed
CD_CDVD_READ_PROGRESS | CD/DVD/Blu-Ray/HD-DVD read operation progress
CN_CDVD_WRITE_PROGRESS | CD/DVD/Blu-Ray/HD-DVD write operation progress
CN_CDVD_BUFFER_STATUS | CD/DVD/Blu-Ray/HD-DVD buffer status information queried
CN_CDVD_TRACK_BEGIN | CD/DVD/Blu-Ray/HD-DVD track processing started
CN_CDVD_TRACK_END | CD/DVD/Blu-Ray/HD-DVD track processing completed
CN_CDVD_SPLIT_BEGIN | CD/DVD/Blu-Ray/HD-DVD split section processing started
CN_CDVD_SPLIT_END | CD/DVD/Blu-Ray/HD-DVD split section processing completed
CN_CDVD_READ_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a bad (unrecoverable) block
CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT | CD/DVD/Blu-Ray/HD-DVD read operation had hit a ECC/EDC bad (recoverable) block
CN_CDVD_READ_RETRY | CD/DVD/Blu-Ray/HD-DVD read operation was retried
CN_DVDPLUSRW_FORMAT_BEGIN | DVD+RW format operation started
CN_DVDPLUSRW_FORMAT_EDN | DVD+RW format operation completed
CN_DVDRAM_FORMAT_BEGIN | DVD-RAM format operation started
CN_DVDRAM_FORMAT_EDN | DVD-RAM format operation completed
CN_BUFFER_UNDERRUN | Buffer underrun condition happened
CN_DVD_MEDIA_PADDING_SIZE | DVD media would be padded to 1GB size, additional info passed
CN_DVD_MEDIA_PADDING_BEGIN | DVD media padding burn process started
CN_DVD_MEDIA_PADDING_END | DVD media padding burn process completed
CN_CDVD_READ_CANCEL_QUERY | CD/DVD/Blu-Ray/HD-DVD media processing plug-in queries cancel status
CN_DVDRW_QUICK_FORMAT_BEGIN | DVD-RW quick format operation started
CN_DVDRW_QUICK_FORMAT_END | DVD-RW quick format operation completed
CN_DVD_TEST_WRITE_DISABLED | Test write is disabled (for DVD+R/RW, DVD-RAM or multisession DVD-RW)
CN_CDVD_DPM_BEGIN | CD/DVD/Blu-Ray/HD-DVD DPM processing started
CN_CDVD_DPM_END | CD/DVD/Blu-Ray/HD-DVD DPM processing completed
CD_CDVD_DPM_PROGRESS | CD/DVD/Blu-Ray/HD-DVD DPM operation progress
CN_CDVD_VERIFY_PROGRESS | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_SAO_TRACK_WRITE_BEGIN | SAO track write started
CN_SAO_TRACK_WRITE_END | SAO track write completed
CN_DVD_MEDIA_PADDING_WRITE_PRO... | DVD media padding burn progress indication
CN_CDVD_WRITE_BEGIN | CD/DVD/Blu-Ray/HD-DVD write operation started
CN_CDVD_WRITE_END | CD/DVD/Blu-Ray/HD-DVD write operation completed
CN_CDVD_VERIFY_BEGIN | CD/DVD/Blu-Ray/HD-DVD verify operation started
CN_CDVD_VERIFY_END | CD/DVD/Blu-Ray/HD-DVD verify operation completed
CN_BDRE_FORMAT_BEGIN | BD-RE format operation started
CN_BDRE_FORMAT_END | BD-RE format operation completed
CN_UDF_FILE_LOOKUP | UDF file found during fast lookup
CN_UDF_LOOKUP_FILE | UDF file found during fast lookup
CN_UDF_LOOKUP_DIR | UDF directory found during fast lookup
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PCDB_FAILURE_INFORMATION Structure

PCDB_FAILURE_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _CDB_FAILURE_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__CDBSizeInUCHARs;
  UCHAR m__UCHAR__CDB[ 16 ];
  UCHAR m__UCHAR__SenseSizeInUCHARs;
  UCHAR m__UCHAR__Sense[ 32 ];
  UCHAR m__UCHAR__TransportStatus;
  UCHAR m__UCHAR__TargetStatus;
  UCHAR m__UCHAR__HostAdapterStatus;
} * PCDB_FAILURE_INFORMATION, CDB_FAILURE_INFORMATION;
File

StarBurn.h

Description

Structure that represents CDB failure information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__CDBSizeInUCHARs | CDB size in UCHARs
m__UCHAR__CDB[ 16 ] | CDB dump
m__UCHAR__SenseSizeInUCHARs | SCSI sense size in UCHARs
m__UCHAR__Sense[ 32 ] | SCSI sense dump
m__UCHAR__TransportStatus | SCSI transport status
m__UCHAR__TargetStatus | SCSI target status
m__UCHAR__HostAdapterStatus | SCSI host adapter status
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDAO_DISC_LAYOUT Structure

PDAO_DISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DAO_DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DAO_DISC_LAYOUT_ENTRY m__DAO_DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
} * PDAO_DISC_LAYOUT, DAO_DISC_LAYOUT;
File

StarBurn.h

Description

Structure that represents DAO disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DAO_DISC_LAYOUT_ENTRY | DAO disc layout entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDAO_DISC_LAYOUT_ENTRY Structure

PDAO_DISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DAO_DISC_LAYOUT_ENTRY {
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__TrackStartingLBA;
  BOOLEAN m__BOOLEAN__IsUnicode;
  union {
    CHAR m__CHAR__TrackName[ (MAX_PATH * sizeof(WCHAR) ) ];
    WCHAR m__WCHAR__TrackName[ (MAX_PATH) ];
  }
  PVOID m__PVOID__File;
  BOOLEAN m__BOOLEAN__IsDataTrack;
  BOOLEAN m__BOOLEAN__IsRawTrack;
  BOOLEAN m__BOOLEAN__IsAudioExTrack;
} * PDAO_DISC_LAYOUT_ENTRY, DAO_DISC_LAYOUT_ENTRY;
File

StarBurn.h

Description

Structure that represents DAO disc layout entry (track)

Member | Definition
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__TrackStartingLBA | Track starting LBA (logical block address)
m__BOOLEAN__IsUnicode | Is name in Unicode format or not (see below)
m__CHAR__TrackName | Track name (absolute path & name) in ANSI or Unicode format (see above)
m__PVOID__File | Pointer to internally created disk file object (NULL initially)
m__BOOLEAN__IsDataTrack | Is this data track (audio otherwise)
m__BOOLEAN__IsRawTrack | Is this raw track (MDF image)
m__BOOLEAN__IsAudioExTrack | Is this extended audio track (2448 UCHARs/logical block)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDISC_FILESYSTEM Structure

PDISC_FILESYSTEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_FILESYSTEM {
  BOOLEAN m__BOOLEAN__UDFPresent;
  BOOLEAN m__BOOLEAN__JolietPresent;
  BOOLEAN m__BOOLEAN__ISO9660Present;
  BOOLEAN m__BOOLEAN__ElToritoBootRecordPresent;
} * PDISC_FILESYSTEM, DISC_FILESYSTEM;
File

StarBurn.h

Description

Structure with disc file system flags

Member Definition

--------- --------------

m__BOOLEAN__UDFPresent UDF file system is present
m__BOOLEAN__ISO9660Present ISO9660 file system is present
m__BOOLEAN__JolietPresent Joliet extension for ISO9660 file system is present
m__BOOLEAN__ElToritoBootRecordPresent El Torito boot record is present
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDISC_LAYOUT Structure

PDISC_LAYOUT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_LAYOUT {
  LONG m__LONG__NumberOfEntries;
  DISC_LAYOUT_ENTRY m__DISC_LAYOUT_ENTRY[ NUMBER_OF_TRACKS ];
  LONG m__LONG__NumberOfRawRawPWTracks;
  LONG m__LONG__RawRawPWTrackSizeInLBs[ NUMBER_OF_TRACKS ];
} * PDISC_LAYOUT, DISC_LAYOUT;
File

StarBurn.h

Description

Structure that represents disc layout

Member | Definition
m__LONG__NumberOfEntries | Number of entries
m__DISC_LAYOUT_ENTRY | Disc layout entries
m__LONG__NumberOfRawRawPWTracks | Number of raw + raw P-W sub-channel tracks
m__LONG__RawRawPWTrackSize | Raw + raw P-W sub-channel track sizes
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDISC_LAYOUT_ENTRY Structure

PDISC_LAYOUT_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DISC_LAYOUT_ENTRY {
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsVideo;
  BOOLEAN m__BOOLEAN__IsRawRawPW;
  LONG m__LONG__TrackSizeInLBs;
  LONG m__LONG__PreGapSizeInLBs;
  LONG m__LONG__PostGapSizeInLBs;
  union {
    CHAR m__CHAR__TrackName[ MAX_PATH*sizeof(WCHAR) ];
    WCHAR m__WCHAR__TrackName[ MAX_PATH ];
  }
  PVOID m__PVOID__File;
  PVOID m__PVOID__Tree;
  PVOID m__PVOID__BackSideTree;
} * PDISC_LAYOUT_ENTRY, DISC_LAYOUT_ENTRY;
File

StarBurn.h

Description

Structure that represents disc layout entry (track)

Member | Definition
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsVideo | Is this video track
m__BOOLEAN__IsRawRawPW | Is this raw + raw P-W sub-channel track
m__LONG__TrackSizeInLBs | Track size in LBs (logical blocks)
m__LONG__PreGapSizeInLBs | PreGap size in LBs (logical blocks)
m__LONG__PostGapSizeInLBs | PostGap size in LBs (logical blocks)
m__CHAR__TrackName | Track name (absolute path & name), can be zero array if next pointer is valid
m__PVOID__File | Pointer to internally created disk file object
m__PVOID__Tree | Pointer to object created with StarBurn_ISO9660JolietFileTree_Create(), can be NULL
m__PVOID__BackSideTree | Pointer to undecorated ISO9660 file tree object
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDISC_TYPE Enumeration

PDISC_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _DISC_TYPE {
  DISC_TYPE_UNKNOWN = 0,
  DISC_TYPE_CDROM = 1,
  DISC_TYPE_CDR = 2,
  DISC_TYPE_CDRW = 3,
  DISC_TYPE_DVDROM = 4,
  DISC_TYPE_DVDR = 5,
  DISC_TYPE_DVDRAM = 6,
  DISC_TYPE_DVDRWRO = 7,
  DISC_TYPE_DVDRWSR = 8,
  DISC_TYPE_DVDPLUSRW = 9,
  DISC_TYPE_DDCDROM = 10,
  DISC_TYPE_DDCDR = 11,
  DISC_TYPE_DDCDRW = 12,
  DISC_TYPE_DVDPLUSR = 13,
  DISC_TYPE_NO_MEDIA = 14,
  DISC_TYPE_DVDPLUSR_DL = 15,
  DISC_TYPE_DVDR_DL = 16,
  DISC_TYPE_BDROM = 17,
  DISC_TYPE_BDR = 18,
  DISC_TYPE_BDRE = 19,
  DISC_TYPE_HDDVDROM = 20,
  DISC_TYPE_HDDVDR = 21,
  DISC_TYPE_HDDVDRW = 22
} * PDISC_TYPE, DISC_TYPE;
File

StarBurn.h

Description

Enum that represents inserted disc type

Member | Definition
DISC_TYPE_UNKNOWN | Unknown disc type
DISC_TYPE_CDROM, | CD-ROM
DISC_TYPE_CDR, | CD-R
DISC_TYPE_CDRW, | CD-RW
DISC_TYPE_DVDROM, | DVD-ROM
DISC_TYPE_DVDR, | DVD-R
DISC_TYPE_DVDRAM, | DVD-RAM
DISC_TYPE_DVDRWRO, | DVD-RW RO (Restricted Overwrite)
DISC_TYPE_DVDRWSR, | DVD-RW SR (Sequential Recording)
DISC_TYPE_DVDPLUSRW, | DVD+RW
DISC_TYPE_DDCDROM, | DD (Double Density) CD-ROM
DISC_TYPE_DDCDR, | DD (Double Density) CD-R
DISC_TYPE_DDCRW | DD (Double Density) CD-RW
DISC_TYPE_DVDPLUSR | DVD+R
DISC_TYPE_NO_MEDIA | No media is inserted to the disc drive
DISC_TYPE_DVDPLUSR_DL | DVD+R DL (Double Layer)
DISC_TYPE_DVDR_DL | DVD-R DL (Dual Layer)
DISC_TYPE_BDROM | BD-ROM (Blu-Ray ROM)
DISC_TYPE_BDR | BD-R (Blu-Ray Disc Recordable)
DISC_TYPE_BDRE | BD-RE (Blu-Ray Disc Recordable Erasable)
DISC_TYPE_HDDVDROM | HD-DVD ROM
DISC_TYPE_HDDVDR | HD-DVD Recordable
DISC_TYPE_HDDVDRW | HD-DVD ReWritable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PDVD_VIDEO_CONTROL_BLOCK Structure

PDVD_VIDEO_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _DVD_VIDEO_CONTROL_BLOCK {
  UDF_CONTROL_BLOCK m__UDF_CONTROL_BLOCK;
  UDF_TREE_ITEM m__UDF_TREE_ITEM__Directory[ 4 ];
  UDF_TREE_ITEM m__UDF_TREE_ITEM__File[ 1192 ];
  LONG m__LONG__NumberOfFiles;
  LONG m__LONG__NumberOfTitles;
  LONG m__LONG__VtsIndex[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ][ 2 ];
  BOOLEAN m__BOOLEAN__IsMainMenuVob;
  BOOLEAN m__BOOLEAN__IsTitleMenuVob[ STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES ];
} * PDVD_VIDEO_CONTROL_BLOCK, DVD_VIDEO_CONTROL_BLOCK;
File

StarBurn.h

Description

Structure that represents DVD-Video control block and pointer to DVD-Video control block

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PERASE_TYPE Enumeration

PERASE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _ERASE_TYPE {
  ERASE_TYPE_BLANK_DISC_FULL = 0,
  ERASE_TYPE_BLANK_DISC_FAST,
  ERASE_TYPE_BLANK_TRACK,
  ERASE_TYPE_UNRESERVE_TRACK,
  ERASE_TYPE_BLANK_TRACK_TAIL,
  ERASE_TYPE_UNCLOSE_LAST_SESSION,
  ERASE_TYPE_BLANK_SESSION
} * PERASE_TYPE, ERASE_TYPE;
File

StarBurn.h

Description

Enum that represents erase type

Member | Definition
ERASE_TYPE_BLANK_DISC_FULL | Completely erase the rewritable disc
ERASE_TYPE_BLANK_DISC_FAST | Erase only TOC, PMA and first track lead in on the rewritable disc
ERASE_TYPE_BLANK_TRACK | Erase track only
ERASE_TYPE_UNRESERVE_TRACK | Unreserve track that was reserved before
ERASE_TYPE_BLANK_TRACK_TAIL | Erase track tail
ERASE_TYPE_UNCLOSE_LAST_SESSION | Unclose last closed session
ERASE_TYPE_BLANK_SESSION | Erase last session
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PEXCEPTION_NUMBER Enumeration

PEXCEPTION_NUMBER Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _EXCEPTION_NUMBER {
  EN_SUCCESS = 0,
  EN_FAILURE,
  EN_INVALID_INPUT_PARAMETER,
  EN_INVALID_STATE,
  EN_MEMORY_ALLOCATION_FAILED,
  EN_SYSTEM_CALL_FAILED,
  EN_SCSI_TRANSPORT_FAILED,
  EN_SCSI_DEVICE_BUSY,
  EN_SCSI_CDB_FAILED,
  EN_SCSI_DEVICE_INVALID_TYPE,
  EN_INVALID_RESPONSE,
  EN_BUFFER_UNDERRUN,
  EN_INVALID_EXCEPTION,
  EN_ACCESS_TO_FEATURE_DENIED,
  EN_USER_EXCEPTION,
  EN_PATH_TOO_LONG,
  EN_UNDER_CONSTRUCTION,
  EN_NOT_FOUND,
  EN_FILE_TOO_BIG,
  EN_NOT_IMPLEMENTED,
  EN_RANGE,
  EN_REGISTRATION_FAILED,
  EN_UNSUPPORTED_AUDIO,
  EN_BUFFER_TOO_SMALL,
  EN_SYSTEM_CALL_FAILED_EX,
  EN_ERROR_RECOVERY_FAILED,
  EN_UNRECOGNIZED_MEDIA,
  EN_GENERAL_SEEK_ERROR,
  EN_GENERAL_READ_ERROR,
  EN_ILLEGAL_OPERATION_FOR_TRACK,
  EN_UNSUPPORTED_READ_MODE,
  EN_REQUEST_TOO_LARGE,
  EN_FULL_ERASE_REQUIRED,
  EN_VERIFY_FAILED,
  EN_DPM_FAILED,
  EN_DEVICE_SHARING_VIOLATION,
  EN_CALL_IS_OBSOLETE,
  EN_WRONG_OS_VERSION,
  EN_INVALID_FIELD_IN_CDB,
  EN_CACHE_IS_TOO_SMALL
} * PEXCEPTION_NUMBER, EXCEPTION_NUMBER;
File

StarBurn.h

Description

Enum that represents exception number

Member | Definition
EN_SUCCESS | Nothing really happened, operation completed successfully
EN_FAILURE | Undefined error happened, something goes really wrong
EN_INVALID_INPUT_PARAMETER | User input parameter is not valid
EN_INVALID_STATE | The state of the object is not valid for current operation
EN_MEMORY_ALLOCATION_FAILED | Memory allocation failed
EN_SYSTEM_CALL_FAILED | System call failed, check SystemError pointer to system error value
EN_SCSI_TRANSPORT_FAILED | SCSI transport internal error
EN_SCSI_DEVICE_BUSY | SCSI device is busy for a while
EN_SCSI_CDB_FAILED | SCSI CDB delivery failed, check CDB_FAILURE_INFORMATION for details
EN_SCSI_DEVICE_INVALID_TYPE | SCSI device of this type is not supported
EN_INVALID_RESPONSE | Something really unsupported returned
EN_BUFFER_UNDERRUN | Buffer underrun happened
EN_INVALID_EXCEPTION | Exception was not allocated
EN_ACCESS_TO_FEATURE_DENIED | Access to feature denied b/s of the wrong version
EN_USER_EXCEPTION | This is not a real exception just the result of user interaction
EN_PATH_TOO_LONG | File path is too long
EN_UNDER_CONSTRUCTION | This feature is still under construction
EN_NOT_FOUND | Operation could not be performed b/s either device or requested parameter not found
EN_FILE_TOO_BIG | File is too big for requested operation
EN_NOT_IMPLEMENTED | Feature is not implemented yet
EN_RANGE | Passed range is not valid
EN_REGISTRATION_FAILED | Registration procedure completed with errors
EN_UNSUPPORTED_AUDIO | Unsupported audio format used as either input or output
EN_BUFFER_TOO_SMALL | Buffer size supplied by caller is not sufficient
EN_SYSTEM_CALL_FAILED_EX | Middle-layer error happened, check SystemError pointer for specific error value
EN_ERROR_RECOVERY_FAILED | Error recovery failed
EN_UNRECOGNIZED_MEDIA | Current media type is not recognized
EN_GENERAL_SEEK_ERROR | General seek error on CD/DVD/Blu-Ray/HD-DVD media
EN_GENERAL_READ_ERROR | General read error on CD/DVD/Blu-Ray/HD-DVD media
EN_ILLEGAL_OPERATION_FOR_TRACK | Illegal operation for track
EN_UNSUPPORTED_READ_MODE | Currently selected read mode is not supported by device
EN_REQUEST_TOO_LARGE | Request size is too large to be handled
EN_FULL_ERASE_REQUIRED | Full erase required before recording to inserted media
EN_VERIFY_FAILED | Verify operation found different memory buffers
EN_DPM_FAILED | DPM associated call failed
EN_DEVICE_SHARING_VIOLATION | Device failed to open b/s of sharing violation
EN_CALL_IS_OBSOLETE | Function is obsolete
EN_WRONG_OS_VERSION | OS version is not supported
EN_INVALID_FIELD_IN_CDB | Invalid field in CDB
EN_CACHE_IS_TOO_SMALL | Allocated cache size is too small to handle "write" operations
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PFILE_TIME Enumeration

PFILE_TIME Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _FILE_TIME {
  FILE_TIME_CREATION = 0,
  FILE_TIME_LAST_ACCESS,
  FILE_TIME_LAST_WRITE
} * PFILE_TIME, FILE_TIME;
File

StarBurn.h

Description

Enum that represents file time that will be included in the ISO9660/Joliet image

Member | Definition
FILE_TIME_CREATION | Original creation file time will be included into the file system image
FILE_TIME_LAST_ACCESS | Last access time will be included into the file system image
FILE_TIME_LAST_WRITE | Last write tile will be included into the file system image
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PFILE_TREE Enumeration

PFILE_TREE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _FILE_TREE {
  FILE_TREE_ISO9660 = 0,
  FILE_TREE_JOLIET
} * PFILE_TREE, FILE_TREE;
File

StarBurn.h

Description

Enum that represents file tree

Member | Definition
FILE_TREE_ISO9660 | ISO9660 file tree
FILE_TREE_JOLIET | ISO9660 file tree + Joliet extensions
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PFULL_TOC_ENTRY_RAW Structure

PFULL_TOC_ENTRY_RAW Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _FULL_TOC_ENTRY_RAW {
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__TNO;
  UCHAR m__UCHAR__POINT;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__Zero;
  UCHAR m__UCHAR__PMIN;
  UCHAR m__UCHAR__PSEC;
  UCHAR m__UCHAR__PFRAME;
} * PFULL_TOC_ENTRY_RAW, FULL_TOC_ENTRY_RAW;
File

StarBurn.h

Description

Structure that represents full TOC entry

Member | Definition
m__UCHAR__SessionNumber | Session number
m__UCHAR__CONTROL : 4 | Control
m__UCHAR__ADR : 4 | Address
m__UCHAR__TNO | Track number
m__UCHAR__POINT | Point
m__UCHAR__Min | Minute
m__UCHAR__Sec | Second
m__UCHAR__Frame | Frame
m__UCHAR__Zero | Zero (always 0)
m__UCHAR__PMIN | Starting minute (from MSF)
m__UCHAR__PSEC | Starting second (from MSF)
m__UCHAR__PFRAME | Starting frame (from MSF)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PISO9660_DATE_TIME Structure

PISO9660_DATE_TIME Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _ISO9660_DATE_TIME {
  UCHAR m__UCHAR__Year;
  UCHAR m__UCHAR__Month;
  UCHAR m__UCHAR__Day;
  UCHAR m__UCHAR__Hour;
  UCHAR m__UCHAR__Minute;
  UCHAR m__UCHAR__Second;
  UCHAR m__UCHAR__GMTOffset;
} * PISO9660_DATE_TIME, ISO9660_DATE_TIME;
File

StarBurn.h

Description

Structure that represents ISO9660 date and time

Member | Definition
m__UCHAR__Year | Year
m__UCHAR__Month | Month
M__UCHAR__Day | Day
m__UCHAR__Hour | Hour
m__UCHAR__Minute | Minute
m__UCHAR__Second | Second
m__UCHAR__GMTOffset | Offset from GMT in hours
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PISO9660_KIDTYPE Enumeration

PISO9660_KIDTYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _ISO9660_KIDTYPE {
  KIDTYPE_UNKNOWN,
  KIDTYPE_IMPORTED,
  KIDTYPE_FROMDISK,
  KIDTYPE_VIRTUAL
} * PISO9660_KIDTYPE, ISO9660_KIDTYPE;
File

StarBurn.h

Description

Enum that represent type of ISO9660 tree node

Member | Definition
KIDTYPE_UNKNOWN | Unknown kid type
KIDTYPE_IMPORTED | Node was imported from previous track
KIDTYPE_FROMDISK | Node was added from the disk
KIDTYPE_VIRTUAL | Node was created as memory file or virtual directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PNAME_COLLISION_INFO Structure

PNAME_COLLISION_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _NAME_COLLISION_INFO {
  BOOLEAN m__BOOLEAN__IsJolietName;
  UCHAR m__UCHAR__Name[ MAX_PATH * 2 ];
  PCHAR m__PCHAR__OldAbsoluteName;
  ULONG m__ULONG__OldFileAttributes;
  PCHAR m__PCHAR__NewAbsoluteName;
  ULONG m__ULONG__NewFileAttributes;
  NAME_COLLISION_SOLUTION m__NAME_COLLISION_SOLUTION;
} * PNAME_COLLISION_INFO, NAME_COLLISION_INFO;
File

StarBurn.h

Description

Structure that represents information about name collision

Member | Definition
m__BOOLEAN__IsJolietName | Indicates the format of the m__UCHAR__Name
m__UCHAR__Name | The node name (CHAR for ISO9660 or USHORT for Joliet)
m__PCHAR__OldAbsoluteName | Absolute file name of the old file node
m__ULONG__OldFileAttributes | Old file attributes
m__PCHAR__NewAbsoluteName | Absolute file name of the new file node
m__ULONG__NewFileAttributes | New file attributes
m__NAME_COLLISION_SOLUTION | The solution of the collision (what action has been performed)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PNAME_COLLISION_SOLUTION Enumeration

PNAME_COLLISION_SOLUTION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _NAME_COLLISION_SOLUTION {
  NAME_COLLISION_SKIP_NEW = 0,
  NAME_COLLISION_REPLACE_OLD = 1,
  NAME_COLLISION_RENAME_NEW = 2,
  NAME_COLLISION_MERGE_FOLDERS = 3,
  NAME_COLLISION_FORCE_DWORD = 0xFFFFFFFF
} * PNAME_COLLISION_SOLUTION, NAME_COLLISION_SOLUTION;
File

StarBurn.h

Description

Enum that represents the solutions of name collisions

Member | Definition
NAME_COLLISION_SKIP_NEW | Remove new node and leave old node
NAME_COLLISION_REPLACE_OLD | Remove old node and insert new node
NAME_COLLISION_RENAME_NEW | Leave old node and insert new node with the new name
NAME_COLLISION_MERGE_FOLDERS | Add files from new folder into an old folder
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPQ_SUBCHANNEL Structure

PPQ_SUBCHANNEL Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _PQ_SUBCHANNEL {
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__IndexNumber;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__ZERO;
  UCHAR m__UCHAR__AMIN;
  UCHAR m__UCHAR__ASEC;
  UCHAR m__UCHAR__AFRAME;
  UCHAR m__UCHAR__CRC1_Reserved1;
  UCHAR m__UCHAR__CRC2_Reserved2;
  UCHAR m__UCHAR__Reserved3[ 3 ];
  UCHAR m__UCHAR__Reserved4 : 7;
  UCHAR m__UCHAR__PSubChannel : 1;
} * PPQ_SUBCHANNEL, PQ_SUBCHANNEL;
File

StarBurn.h

Description

Structure that represents formatted PQ sub-channel

Member | Definition
m__UCHAR__ADR | Track ADR
m__UCHAR__CONTROL | Track CONTROL
m__UCHAR__TrackNumber | Track Number
m__UCHAR__IndexNumber | Index Number
m__UCHAR__Min | Min (from the beginning of the track)
m__UCHAR__Sec | Sec (from the beginning of the track)
m__UCHAR__Frame | Frame (from the beginning of the track)
m__UCHAR__ZERO | MBZ
m__UCHAR__AMIN | Min (from the beginning of the disc)
m__UCHAR__ASEC | Sec (from the beginning of the disc)
m__UCHAR__AFRAME | Frame (from the beginning of the disc)
m__UCHAR__CRC1_Reserved1 | CRC1 or MBZ
m__UCHAR__CRC2_Reserved2 | CRC2 or MBZ
m__UCHAR__Reserved3[ 3 ] | MBZ
m__UCHAR__Reserved4 | MBZ
m__UCHAR__PSubChannel | P sub-channel bit
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARBURN_BDRE_FORMAT_PROFILE Structure

PPSTARBURN_BDRE_FORMAT_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_BDRE_FORMAT_PROFILE {
  LONG m__LONG__FormatProfileNumber;
  ULONG m__ULONG__NumberOfBlocksOrUserAreaDataSize;
  UCHAR m__UCHAR__CertificationType : 2;
  UCHAR m__UCHAR__FormatType : 6;
  ULONG m__ULONG__SpareAreaSizeInClustersOrBlockLength;
} ** PPSTARBURN_BDRE_FORMAT_PROFILE, * PSTARBURN_BDRE_FORMAT_PROFILE, STARBURN_BDRE_FORMAT_PROFILE;
File

StarBurn.h

Description

Structure that represents format profile for BD-RE media

Member Definition

--------- --------------

LONG m__LONG__FormatProfileNumber Format profile number
UCHAR m__ULONG__NumberOfBlocksOrUserAreaDataSize Number of logical block(s) or user area data size
UCHAR m__UCHAR__CertificationType Certification type
UCHAR m__UCHAR__FormatType Format type
UCHAR m__ULONG__SpareAreaSizeInClustersOrBlockLength Spare area size in cluster(s) or block length
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARBURN_STARWAVE_CALLBACK_REASON Enumeration

PPSTARBURN_STARWAVE_CALLBACK_REASON Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_CALLBACK_REASON {
  STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN = 0,
  STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS
} STARBURN_STARWAVE_CALLBACK_REASON, * PSTARBURN_STARWAVE_CALLBACK_REASON, ** PPSTARBURN_STARWAVE_CALLBACK_REASON;
File

StarBurn.h

Description

StarWave callback reasons we'll be using

Member | Definition
STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN | Unknown call reason
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS | Progress indication reason
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARBURN_STARWAVE_COMPRESSION Enumeration

PPSTARBURN_STARWAVE_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_COMPRESSION {
  STARBURN_STARWAVE_COMPRESSION_NONE = 0,
  STARBURN_STARWAVE_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 = 10,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 = 25,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 = 50,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 = 75,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 = 90,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 = 98,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K = 32000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K = 48000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K = 64000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K = 80000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K = 96000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K = 128000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K = 160000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K = 192000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K = 256000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K = 320000
} STARBURN_STARWAVE_COMPRESSION, * PSTARBURN_STARWAVE_COMPRESSION, ** PPSTARBURN_STARWAVE_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Member | Definition
STARBURN_STARWAVE_COMPRESSION_NONE | Lossless PCM WAV uncompressed stream
STARBURN_STARWAVE_COMPRESSION_WMA_LOSS... | Lossless WMA compressed stream, VBR at Quality 100
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 | WMA compressed stream, VBR at Quality 10
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 | WMA compressed stream, VBR at Quality 25
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 | WMA compressed stream, VBR at Quality 50
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 | WMA compressed stream, VBR at Quality 75
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 | WMA compressed stream, VBR at Quality 90
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 | WMA compressed stream, VBR at Quality 98
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K | WMA compressed stream, CBR at 32 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K | WMA compressed stream, CBR at 48 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K | WMA compressed stream, CBR at 64 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K | WMA compressed stream, CBR at 80 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K | WMA compressed stream, CBR at 96 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K | WMA compressed stream, CBR at 128 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K | WMA compressed stream, CBR at 160 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K | WMA compressed stream, CBR at 192 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K | WMA compressed stream, CBR at 256 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K | WMA compressed stream, CBR at 320 Kbps
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARPORT_DEVICE_LIST Structure

PPSTARPORT_DEVICE_LIST Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST {
  LONG m__LONG__NumberOfEntries;
  STARPORT_DEVICE_LIST_ENTRY m__STARPORT_DEVICE_LIST_ENTRY[ 1 ];
} ** PPSTARPORT_DEVICE_LIST, * PSTARPORT_DEVICE_LIST, STARPORT_DEVICE_LIST;
File

StarBurn.h

Description

Structure that represents StarPort device list

Member | Definition
m__LONG__NumberOfEntries | Number of StarPort device list entries
m__STARPORT_DEVICE_LIST_ENTRY | StarPort device list entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARPORT_DEVICE_LIST_ENTRY Structure

PPSTARPORT_DEVICE_LIST_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST_ENTRY {
  LONG m__LONG__Index;
  LONG m__LONG__TargetId;
  CHAR m__CHAR__Name[ STARPORT_DEVICE_NAME_SIZE_IN_UCHARS ];
} ** PPSTARPORT_DEVICE_LIST_ENTRY, * PSTARPORT_DEVICE_LIST_ENTRY, STARPORT_DEVICE_LIST_ENTRY;
File

StarBurn.h

Description

Structure that represents StarPort device list entry

Member | Definition
m__LONG__Index | StarPort device index
m__LONG__TargetId | StarPort device TargetId
m__CHAR__Name | StarPort device name
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARPORT_DEVICE_TYPE Enumeration

PPSTARPORT_DEVICE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARPORT_DEVICE_TYPE {
  STARPORT_DEVICE_TYPE_UNKNOWN = 0,
  STARPORT_DEVICE_TYPE_RAM,
  STARPORT_DEVICE_TYPE_HDD,
  STARPORT_DEVICE_TYPE_DVD,
  STARPORT_DEVICE_TYPE_AOE,
  STARPORT_DEVICE_TYPE_ISCSI
} ** PPSTARPORT_DEVICE_TYPE, * PSTARPORT_DEVICE_TYPE, STARPORT_DEVICE_TYPE;
File

StarBurn.h

Description

Enum that represents StarPort device type

Member | Definition
STARPORT_DEVICE_TYPE_UNKNOWN | Unknown device type
STARPORT_DEVICE_TYPE_RAM | RAM disk
STARPORT_DEVICE_TYPE_HDD | Virtual hard disk
STARPORT_DEVICE_TYPE_DVD | Virtual DVD
STARPORT_DEVICE_TYPE_AOE | AoE (ATA-over-Ethernet)
STARPORT_DEVICE_TYPE_ISCSI | iSCSI (SCSI-over-IP)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARWAVE2_COMPRESSION Enumeration

PPSTARWAVE2_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARWAVE2_COMPRESSION {
  STARWAVE2_COMPRESSION_NONE = 0,
  STARWAVE2_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARWAVE2_COMPRESSION_WMA_VBR_Q10 = 10,
  STARWAVE2_COMPRESSION_WMA_VBR_Q25 = 25,
  STARWAVE2_COMPRESSION_WMA_VBR_Q50 = 50,
  STARWAVE2_COMPRESSION_WMA_VBR_Q75 = 75,
  STARWAVE2_COMPRESSION_WMA_VBR_Q90 = 90,
  STARWAVE2_COMPRESSION_WMA_VBR_Q98 = 98,
  STARWAVE2_COMPRESSION_WMA_CBR_32K = 32000,
  STARWAVE2_COMPRESSION_WMA_CBR_48K = 48000,
  STARWAVE2_COMPRESSION_WMA_CBR_64K = 64000,
  STARWAVE2_COMPRESSION_WMA_CBR_80K = 80000,
  STARWAVE2_COMPRESSION_WMA_CBR_96K = 96000,
  STARWAVE2_COMPRESSION_WMA_CBR_128K = 128000,
  STARWAVE2_COMPRESSION_WMA_CBR_160K = 160000,
  STARWAVE2_COMPRESSION_WMA_CBR_192K = 192000,
  STARWAVE2_COMPRESSION_WMA_CBR_256K = 256000,
  STARWAVE2_COMPRESSION_WMA_CBR_320K = 320000
} STARWAVE2_COMPRESSION, * PSTARWAVE2_COMPRESSION, ** PPSTARWAVE2_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates

All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PPSTARWAVE2_COMPRESSION_PROFILE Structure

PPSTARWAVE2_COMPRESSION_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARWAVE2_COMPRESSION_PROFILE {
  UINT m__UINT__CompressionType;
  PCHAR m__PCHAR__CustomFactoryID;
  union {
    int m__int__CBRBitRate;
    int m__int__VBRQuality;
  }
  int m__int__ABRBitRate;
  int m__int__MaxBitRate;
  union {
    int m__int__MinBitRate;
    int m__int__MaxFrameWindow;
  }
  LPVOID m__LPVOID__CustomData;
} STARWAVE2_COMPRESSION_PROFILE, * PSTARWAVE2_COMPRESSION_PROFILE, ** PPSTARWAVE2_COMPRESSION_PROFILE;
File

StarBurn.h

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PQ_SUBCHANNEL Structure

PQ_SUBCHANNEL Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _PQ_SUBCHANNEL {
  UCHAR m__UCHAR__ADR : 4;
  UCHAR m__UCHAR__CONTROL : 4;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__IndexNumber;
  UCHAR m__UCHAR__Min;
  UCHAR m__UCHAR__Sec;
  UCHAR m__UCHAR__Frame;
  UCHAR m__UCHAR__ZERO;
  UCHAR m__UCHAR__AMIN;
  UCHAR m__UCHAR__ASEC;
  UCHAR m__UCHAR__AFRAME;
  UCHAR m__UCHAR__CRC1_Reserved1;
  UCHAR m__UCHAR__CRC2_Reserved2;
  UCHAR m__UCHAR__Reserved3[ 3 ];
  UCHAR m__UCHAR__Reserved4 : 7;
  UCHAR m__UCHAR__PSubChannel : 1;
} * PPQ_SUBCHANNEL, PQ_SUBCHANNEL;
File

StarBurn.h

Description

Structure that represents formatted PQ sub-channel

Member | Definition
m__UCHAR__ADR | Track ADR
m__UCHAR__CONTROL | Track CONTROL
m__UCHAR__TrackNumber | Track Number
m__UCHAR__IndexNumber | Index Number
m__UCHAR__Min | Min (from the beginning of the track)
m__UCHAR__Sec | Sec (from the beginning of the track)
m__UCHAR__Frame | Frame (from the beginning of the track)
m__UCHAR__ZERO | MBZ
m__UCHAR__AMIN | Min (from the beginning of the disc)
m__UCHAR__ASEC | Sec (from the beginning of the disc)
m__UCHAR__AFRAME | Frame (from the beginning of the disc)
m__UCHAR__CRC1_Reserved1 | CRC1 or MBZ
m__UCHAR__CRC2_Reserved2 | CRC2 or MBZ
m__UCHAR__Reserved3[ 3 ] | MBZ
m__UCHAR__Reserved4 | MBZ
m__UCHAR__PSubChannel | P sub-channel bit
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PREAD_MODE Enumeration

PREAD_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _READ_MODE {
  READ_MODE_COOKED = 0,
  READ_MODE_RAW,
  READ_MODE_RAW_PQ,
  READ_MODE_RAW_RAW_PW,
  READ_MODE_PQ,
  READ_MODE_RAW_PW
} * PREAD_MODE, READ_MODE;
File

StarBurn.h

Description

Enum that represents raw read modes

Member | Definition
READ_MODE_COOKED | Cooked data
READ_MODE_RAW | Raw data
READ_MODE_RAW_PQ | Raw data + PQ sub-channel
READ_MODE_RAW_RAW_PW | Raw data + raw P-W sub-channel
READ_MODE_PQ | PQ sub-channel only (no main channel data)
READ_MODE_RAW_PW | Raw P-W sub-channel only (no main channel data)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSCSI_DEVICE_ADDRESS Structure

PSCSI_DEVICE_ADDRESS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _SCSI_DEVICE_ADDRESS {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__PortID;
  UCHAR m__UCHAR__BusID;
  UCHAR m__UCHAR__TargetID;
  UCHAR m__UCHAR__LUN;
} * PSCSI_DEVICE_ADDRESS, SCSI_DEVICE_ADDRESS;
File

StarBurn.h

Description

Structure that represents SCSI device address

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__PortID | Port ID - Logical SCSI adapter ID if ASPI is used
m__UCHAR__BusID | Bus ID - 0 if ASPI is used
m__UCHAR__TargetID | Target ID
m__UCHAR__LUN | LUN (Logical Unit Number)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure

PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS {
  ULONG m__ULONG__SizeInUCHARs;
  BOOLEAN m__BOOLEAN__IsCDROMRead;
  BOOLEAN m__BOOLEAN__IsCDRRead;
  BOOLEAN m__BOOLEAN__IsCDRWrite;
  BOOLEAN m__BOOLEAN__IsCDRWRead;
  BOOLEAN m__BOOLEAN__IsCDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDROMRead;
  BOOLEAN m__BOOLEAN__IsDVDRRead;
  BOOLEAN m__BOOLEAN__IsDVDRWrite;
  BOOLEAN m__BOOLEAN__IsDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWRead;
  BOOLEAN m__BOOLEAN__IsDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRAMRead;
  BOOLEAN m__BOOLEAN__IsDVDRAMWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDROMRead;
  BOOLEAN m__BOOLEAN__IsBDRRead;
  BOOLEAN m__BOOLEAN__IsBDRWrite;
  BOOLEAN m__BOOLEAN__IsBDRDLRead;
  BOOLEAN m__BOOLEAN__IsBDRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDRERead;
  BOOLEAN m__BOOLEAN__IsBDREWrite;
  BOOLEAN m__BOOLEAN__IsBDREDLRead;
  BOOLEAN m__BOOLEAN__IsBDREDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDROMRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite;
} * PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS, STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS;
File

StarBurn.h

Description

Structure that represents advanced supported media formats

Member Definition

--------- --------------

ULONG m__ULONG__SizeInUCHARs This structure size in UCHARs
BOOLEAN m__BOOLEAN__IsCDROMRead Is CD-ROM read capable
BOOLEAN m__BOOLEAN__IsCDRRead Is CD-R read capable
BOOLEAN m__BOOLEAN__IsCDRWrite Is CD-R write capable
BOOLEAN m__BOOLEAN__IsCDRWRead Is CD-RW read capable
BOOLEAN m__BOOLEAN__IsCDRWWrite Is CD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDROMRead Is DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsDVDRRead Is DVD-R read capable
BOOLEAN m__BOOLEAN__IsDVDRWrite Is DVD-R write capable
BOOLEAN m__BOOLEAN__IsDVDRDLRead Is DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsDVDRDLWrite Is DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsDVDRWRead Is DVD-RW read capable
BOOLEAN m__BOOLEAN__IsDVDRWWrite Is DVD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDRWDLRead Is DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDRWDLWrite Is DVD-RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDRAMRead Is DVD-RAM read capable
BOOLEAN m__BOOLEAN__IsDVDRAMWrite Is DVD-RAM write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead Is DVD+RW read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite Is DVD+RW write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead Is DVD+RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite Is DVD+RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRRead Is DVD+R read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite Is DVD+R write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead Is DVD+R DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite Is DVD+R DL write capable
BOOLEAN m__BOOLEAN__IsBDROMRead Is BD-ROM read capable
BOOLEAN m__BOOLEAN__IsBDRRead Is BD-R read capable
BOOLEAN m__BOOLEAN__IsBDRWrite Is BD-R write capable
BOOLEAN m__BOOLEAN__IsBDRDLRead Is BD-R DL read capable
BOOLEAN m__BOOLEAN__IsBDRDLWrite Is BD-R DL write capable
BOOLEAN m__BOOLEAN__IsBDRERead Is BD-RE read capable
BOOLEAN m__BOOLEAN__IsBDREWrite Is BD-RE write capable
BOOLEAN m__BOOLEAN__IsBDREDLRead Is BD-RE DL read capable
BOOLEAN m__BOOLEAN__IsBDREDLWrite Is BD-RE DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDROMMRead Is HD-DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsHDDVDRRead Is HD-DVD-R read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWrite Is HD-DVD-R write capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLRead Is HD-DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite Is HD-DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWRead Is HD-DVD-RW read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWWrite Is HD-DVD-RW write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead Is HD-DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite Is HD-DVD-RW DL write capable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_BDRE_FORMAT_PROFILE Structure

PSTARBURN_BDRE_FORMAT_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_BDRE_FORMAT_PROFILE {
  LONG m__LONG__FormatProfileNumber;
  ULONG m__ULONG__NumberOfBlocksOrUserAreaDataSize;
  UCHAR m__UCHAR__CertificationType : 2;
  UCHAR m__UCHAR__FormatType : 6;
  ULONG m__ULONG__SpareAreaSizeInClustersOrBlockLength;
} ** PPSTARBURN_BDRE_FORMAT_PROFILE, * PSTARBURN_BDRE_FORMAT_PROFILE, STARBURN_BDRE_FORMAT_PROFILE;
File

StarBurn.h

Description

Structure that represents format profile for BD-RE media

Member Definition

--------- --------------

LONG m__LONG__FormatProfileNumber Format profile number
UCHAR m__ULONG__NumberOfBlocksOrUserAreaDataSize Number of logical block(s) or user area data size
UCHAR m__UCHAR__CertificationType Certification type
UCHAR m__UCHAR__FormatType Format type
UCHAR m__ULONG__SpareAreaSizeInClustersOrBlockLength Spare area size in cluster(s) or block length
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_CD_MODE Enumeration

PSTARBURN_CD_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_CD_MODE {
  CD_MODE_UNKNOWN = 0,
  CD_MODE_AUDIO,
  CD_MODE_VIDEO,
  CD_MODE_DATA,
  CD_MODE_RESERVED
} * PSTARBURN_CD_MODE, STARBURN_CD_MODE;
File

StarBurn.h

Description

Enum that represents CD modes type

Member | Definition
CD_MODE_UNKNOWN | Unknown CD mode
CD_MODE_AUDIO | Audio CD mode
CD_MODE_VIDEO | Video CD mode
CD_MODE_DATA | Data CD mode
CD_MODE_RESERVED | Reserved
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_DISC_ATIP_INFORMATION Structure

PSTARBURN_DISC_ATIP_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_DISC_ATIP_INFORMATION {
  USHORT m__USHORT__DataLength;
  UCHAR m__UCHAR__Reserved1[2];
  UCHAR m__UCHAR__RefrenceSpeed : 3;
  UCHAR m__UCHAR__Reserved2 : 1;
  UCHAR m__UCHAR__IndicativeTargetWritingPower : 4;
  UCHAR m__UCHAR__Reserved3 : 6;
  UCHAR m__UCHAR__URU : 1;
  UCHAR m__UCHAR__Zero : 1;
  UCHAR m__UCHAR__IsA3Valid : 1;
  UCHAR m__UCHAR__IsA2Valid : 1;
  UCHAR m__UCHAR__IsA1Valid : 1;
  UCHAR m__UCHAR__DiscSubType : 3;
  UCHAR m__UCHAR__DiscType : 1;
  UCHAR m__UCHAR__One : 1;
  UCHAR m__UCHAR__Reserved4;
  UCHAR m__UCHAR__LeadInStartTime[3];
  UCHAR m__UCHAR__Reserved5;
  UCHAR m__UCHAR__LastPossibleLeadOutStartTime[3];
  UCHAR m__UCHAR__Reserved6;
  UCHAR m__UCHAR__A1Values[3];
  UCHAR m__UCHAR__Reserved7;
  UCHAR m__UCHAR__A2Values[3];
  UCHAR m__UCHAR__Reserved8;
  UCHAR m__UCHAR__A3Values[3];
  UCHAR m__UCHAR__Reserved9;
  UCHAR m__UCHAR__S4Values[3];
  UCHAR m__UCHAR__Reserved10;
} * PSTARBURN_DISC_ATIP_INFORMATION, STARBURN_DISC_ATIP_INFORMATION;
File

StarBurn.h

Description

Structure that represents Disc ATIP information

Member Definition

--------- --------------

m__USHORT__DataLength
m__UCHAR__Reserved1
m__UCHAR__RefrenceSpeed
m__UCHAR__Reserved2
m__UCHAR__IndicativeTargetWritingPower
m__UCHAR__Reserved3
m__UCHAR__URU
m__UCHAR__Zero
m__UCHAR__IsA3Valid
m__UCHAR__IsA2Valid
m__UCHAR__IsA1Valid
m__UCHAR__DiscSubType
m__UCHAR__DiscType
m__UCHAR__One
m__UCHAR__Reserved4
m__UCHAR__LeadInStartTime
m__UCHAR__Reserved5
m__UCHAR__LastPossibleLeadOutStartTime
m__UCHAR__Reserved6
m__UCHAR__A1Values
m__UCHAR__Reserved7
m__UCHAR__A2Values
m__UCHAR__Reserved8
m__UCHAR__A3Values
m__UCHAR__Reserved9
m__UCHAR__S4Values
m__UCHAR__Reserved10
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_DISC_INFORMATION Structure

PSTARBURN_DISC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_DISC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__DiscStatus;
  UCHAR m__UCHAR__LastSessionStatus;
  BOOLEAN m__BOOLEAN__IsErasable;
  UCHAR m__UCHAR__FirstTrackNumber;
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__LastSessionFirstTrack;
  UCHAR m__UCHAR__LastSessionLastTrack;
  BOOLEAN m__BOOLEAN__IsGEN;
  BOOLEAN m__BOOLEAN__IsDBCValid;
  BOOLEAN m__BOOLEAN__IsDIDValid;
  UCHAR m__UCHAR__DiscType;
  UCHAR m__UCHAR__DiscIdentification[ 4 ];
  UCHAR m__UCHAR__LastSessionLeadIn[ 4 ];
  UCHAR m__UCHAR__LastPossibleStartTime[ 4 ];
  UCHAR m__UCHAR__DiscBarCode[ 8 ];
  UCHAR m__UCHAR__NumberOfOPCEntries;
} * PSTARBURN_DISC_INFORMATION, STARBURN_DISC_INFORMATION;
File

StarBurn.h

Description

Structure that represents Disc information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__DiscStatus | Disc status (See DISC_STATUS_XXX constants)
m__UCHAR__LastSessionStatus | Last session status (See LAST_SESSION_XXX constants)
m__BOOLEAN__IsErasable | Is disc erasable (CD-RW or DVD-RW or DVD+RW or DVD-RAM)
m__UCHAR__FirstTrackNumber | First track number on the disc
m__UCHAR__NumberOfSessions | Number of sessions on the disc
m__UCHAR__LastSessionFirstTrack | First track number of last complete session on the disc
m__UCHAR__LastSessionLastTrack | Last track number of last complete session on the disc
m__BOOLEAN__IsGEN | Unrestricted use, when set to one - every application can write to the disc
m__BOOLEAN__IsDBCValid | Is Disc Bar Code field valid
m__BOOLEAN__IsDIDValid | Is Disc Identification field Valid
m__UCHAR__DiscType | Disc type (See DISC_TYPE_XXX constants)
m__UCHAR__DiscIdentification | Disc identification number recorded in the PMA, see m__UCHAR__IsDIDValid
m__UCHAR__LastSessionLeadId | MSF of last session lead in start time
m__UCHAR__LastPossibleStartTime | Last possible start time for lead out on this disc
m__UCHAR__DiscBarCode | Disc bar code stored here if the device is capable of reading disc bar codes
m__UCHAR__NumberOfOPCEntries | Number of optimum power calibration entries at the end of this structure
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE_CALLBACK_REASON Enumeration

PSTARBURN_STARWAVE_CALLBACK_REASON Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_CALLBACK_REASON {
  STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN = 0,
  STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS
} STARBURN_STARWAVE_CALLBACK_REASON, * PSTARBURN_STARWAVE_CALLBACK_REASON, ** PPSTARBURN_STARWAVE_CALLBACK_REASON;
File

StarBurn.h

Description

StarWave callback reasons we'll be using

Member | Definition
STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN | Unknown call reason
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS | Progress indication reason
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE_COMPRESSION Enumeration

PSTARBURN_STARWAVE_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_COMPRESSION {
  STARBURN_STARWAVE_COMPRESSION_NONE = 0,
  STARBURN_STARWAVE_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 = 10,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 = 25,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 = 50,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 = 75,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 = 90,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 = 98,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K = 32000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K = 48000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K = 64000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K = 80000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K = 96000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K = 128000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K = 160000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K = 192000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K = 256000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K = 320000
} STARBURN_STARWAVE_COMPRESSION, * PSTARBURN_STARWAVE_COMPRESSION, ** PPSTARBURN_STARWAVE_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Member | Definition
STARBURN_STARWAVE_COMPRESSION_NONE | Lossless PCM WAV uncompressed stream
STARBURN_STARWAVE_COMPRESSION_WMA_LOSS... | Lossless WMA compressed stream, VBR at Quality 100
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 | WMA compressed stream, VBR at Quality 10
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 | WMA compressed stream, VBR at Quality 25
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 | WMA compressed stream, VBR at Quality 50
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 | WMA compressed stream, VBR at Quality 75
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 | WMA compressed stream, VBR at Quality 90
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 | WMA compressed stream, VBR at Quality 98
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K | WMA compressed stream, CBR at 32 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K | WMA compressed stream, CBR at 48 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K | WMA compressed stream, CBR at 64 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K | WMA compressed stream, CBR at 80 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K | WMA compressed stream, CBR at 96 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K | WMA compressed stream, CBR at 128 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K | WMA compressed stream, CBR at 160 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K | WMA compressed stream, CBR at 192 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K | WMA compressed stream, CBR at 256 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K | WMA compressed stream, CBR at 320 Kbps
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE2_CONVERSION_MODE Enumeration

PSTARBURN_STARWAVE2_CONVERSION_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE2_CONVERSION_MODE {
  STARBURN_STARWAVE2_OGG_MODE0,
  STARBURN_STARWAVE2_OGG_MODE1,
  STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_OGG_MODE_MAX = STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_MP3_MODE0,
  STARBURN_STARWAVE2_MP3_MODE1,
  STARBURN_STARWAVE2_MP3_MODE2,
  STARBURN_STARWAVE2_MP3_MODE_MAX = STARBURN_STARWAVE2_MP3_MODE2
} STARBURN_STARWAVE2_CONVERSION_MODE, * PSTARBURN_STARWAVE2_CONVERSION_MODE;
File

StarBurn.h

Description

Structure that represents conversion mode

Member | Definition
OGG_MODE0 | VBR, variable bit rate
OGG_MODE1 | ABR, average bit rate
OGG_MODE2 | CBR, constant bit rate
OGG_MODE_MAX | Now equal to OGG_MODE2
MP3_MODE0 | CBR, constant bit rate
MP3_MODE1 | ABR, average bit rate
MP3_MODE2 | VBR, variable bit rate
MP3_MODE_MAX | Now equal to MP3_MODE2
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE2_INIT_PARAMS Structure

PSTARBURN_STARWAVE2_INIT_PARAMS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_STARWAVE2_INIT_PARAMS {
  STARBURN_STARWAVE2_CONVERSION_MODE m__STARBURN_STARWAVE2_CONVERSION_MODE;
  FLOAT m__FLOAT__flQuality;
  LONG m__LONG__nQuality;
  LONG m__LONG__maxBitrate;
  LONG m__LONG__nominalBitrate;
  LONG m_LONG__minBitrate;
  STARBURN_STARWAVE2_QUALITY_MODE m__STARBURN_STARWAVE2_QUALITY_MODE;
} STARBURN_STARWAVE2_INIT_PARAMS, * PSTARBURN_STARWAVE2_INIT_PARAMS;
File

StarBurn.h

Description

Structure that represents initialization parameters for audio conversion

Member | Definition
m__STARBURN_STARWAVE2_CONVERSION_MODE | Conversion mode
m__FLOAT__flQuality | Quality level from 0. (lo) to 1. (hi) (use for OGG_MODE0)
m__LONG__nQuality | Quality level from 1 to 9 (use for MP3_MODE2)
m__LONG__maxBitrate | Maximum bit rate (use for OGG_MODE1/OGG_MODE2)
m__LONG__nominalBitrate | Nominal bit rate (use for OGG_MODE1/OGG_MODE2/MP3_MODE0/MP3_MODE1)
m__LONG__minBitrate | Minimum bit rate (use for OGG_MODE1/OGG_MODE2)
m__StarBurn_StarWave2_QUALITY_MODE | Quality mode (use for /MP3_MODE0/MP3_MODE1/MP3_MODE2)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE2_QUALITY_MODE Enumeration

PSTARBURN_STARWAVE2_QUALITY_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE2_QUALITY_MODE {
  STARBURN_STARWAVE2_QM_FAST = 0,
  STARBURN_STARWAVE2_QM_STANDARD,
  STARBURN_STARWAVE2_QM_HIGH
} STARBURN_STARWAVE2_QUALITY_MODE, * PSTARBURN_STARWAVE2_QUALITY_MODE;
File

StarBurn.h

Description

Enum that represents MP3 quality for conversion

Member | Definition
StarBurn_StarWave2_QM_FAST | Fast mode
StarBurn_StarWave2_QM_STANDARD | Standard mode
StarBurn_StarWave2_QM_HIGH | High quality mode
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_TRACK_INFORMATION Structure

PSTARBURN_TRACK_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_TRACK_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
} * PSTARBURN_TRACK_INFORMATION, STARBURN_TRACK_INFORMATION;
File

StarBurn.h

Description

Structure that represents Track information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_TRACK_INFORMATION_EX Structure

PSTARBURN_TRACK_INFORMATION_EX Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_TRACK_INFORMATION_EX {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__LastRecordedAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
} * PSTARBURN_TRACK_INFORMATION_EX, STARBURN_TRACK_INFORMATION_EX;
File

StarBurn.h

Description

Structure that represents Track information extended

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__LastRecordedAddress | Last Recorded Address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARPORT_DEVICE_LIST Structure

PSTARPORT_DEVICE_LIST Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST {
  LONG m__LONG__NumberOfEntries;
  STARPORT_DEVICE_LIST_ENTRY m__STARPORT_DEVICE_LIST_ENTRY[ 1 ];
} ** PPSTARPORT_DEVICE_LIST, * PSTARPORT_DEVICE_LIST, STARPORT_DEVICE_LIST;
File

StarBurn.h

Description

Structure that represents StarPort device list

Member | Definition
m__LONG__NumberOfEntries | Number of StarPort device list entries
m__STARPORT_DEVICE_LIST_ENTRY | StarPort device list entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARPORT_DEVICE_LIST_ENTRY Structure

PSTARPORT_DEVICE_LIST_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST_ENTRY {
  LONG m__LONG__Index;
  LONG m__LONG__TargetId;
  CHAR m__CHAR__Name[ STARPORT_DEVICE_NAME_SIZE_IN_UCHARS ];
} ** PPSTARPORT_DEVICE_LIST_ENTRY, * PSTARPORT_DEVICE_LIST_ENTRY, STARPORT_DEVICE_LIST_ENTRY;
File

StarBurn.h

Description

Structure that represents StarPort device list entry

Member | Definition
m__LONG__Index | StarPort device index
m__LONG__TargetId | StarPort device TargetId
m__CHAR__Name | StarPort device name
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARPORT_DEVICE_TYPE Enumeration

PSTARPORT_DEVICE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARPORT_DEVICE_TYPE {
  STARPORT_DEVICE_TYPE_UNKNOWN = 0,
  STARPORT_DEVICE_TYPE_RAM,
  STARPORT_DEVICE_TYPE_HDD,
  STARPORT_DEVICE_TYPE_DVD,
  STARPORT_DEVICE_TYPE_AOE,
  STARPORT_DEVICE_TYPE_ISCSI
} ** PPSTARPORT_DEVICE_TYPE, * PSTARPORT_DEVICE_TYPE, STARPORT_DEVICE_TYPE;
File

StarBurn.h

Description

Enum that represents StarPort device type

Member | Definition
STARPORT_DEVICE_TYPE_UNKNOWN | Unknown device type
STARPORT_DEVICE_TYPE_RAM | RAM disk
STARPORT_DEVICE_TYPE_HDD | Virtual hard disk
STARPORT_DEVICE_TYPE_DVD | Virtual DVD
STARPORT_DEVICE_TYPE_AOE | AoE (ATA-over-Ethernet)
STARPORT_DEVICE_TYPE_ISCSI | iSCSI (SCSI-over-IP)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARWAVE2_COMPRESSION Enumeration

PSTARWAVE2_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARWAVE2_COMPRESSION {
  STARWAVE2_COMPRESSION_NONE = 0,
  STARWAVE2_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARWAVE2_COMPRESSION_WMA_VBR_Q10 = 10,
  STARWAVE2_COMPRESSION_WMA_VBR_Q25 = 25,
  STARWAVE2_COMPRESSION_WMA_VBR_Q50 = 50,
  STARWAVE2_COMPRESSION_WMA_VBR_Q75 = 75,
  STARWAVE2_COMPRESSION_WMA_VBR_Q90 = 90,
  STARWAVE2_COMPRESSION_WMA_VBR_Q98 = 98,
  STARWAVE2_COMPRESSION_WMA_CBR_32K = 32000,
  STARWAVE2_COMPRESSION_WMA_CBR_48K = 48000,
  STARWAVE2_COMPRESSION_WMA_CBR_64K = 64000,
  STARWAVE2_COMPRESSION_WMA_CBR_80K = 80000,
  STARWAVE2_COMPRESSION_WMA_CBR_96K = 96000,
  STARWAVE2_COMPRESSION_WMA_CBR_128K = 128000,
  STARWAVE2_COMPRESSION_WMA_CBR_160K = 160000,
  STARWAVE2_COMPRESSION_WMA_CBR_192K = 192000,
  STARWAVE2_COMPRESSION_WMA_CBR_256K = 256000,
  STARWAVE2_COMPRESSION_WMA_CBR_320K = 320000
} STARWAVE2_COMPRESSION, * PSTARWAVE2_COMPRESSION, ** PPSTARWAVE2_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates

All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARWAVE2_COMPRESSION_PROFILE Structure

PSTARWAVE2_COMPRESSION_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARWAVE2_COMPRESSION_PROFILE {
  UINT m__UINT__CompressionType;
  PCHAR m__PCHAR__CustomFactoryID;
  union {
    int m__int__CBRBitRate;
    int m__int__VBRQuality;
  }
  int m__int__ABRBitRate;
  int m__int__MaxBitRate;
  union {
    int m__int__MinBitRate;
    int m__int__MaxFrameWindow;
  }
  LPVOID m__LPVOID__CustomData;
} STARWAVE2_COMPRESSION_PROFILE, * PSTARWAVE2_COMPRESSION_PROFILE, ** PPSTARWAVE2_COMPRESSION_PROFILE;
File

StarBurn.h

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PTOC_ENTRY Structure

PTOC_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _TOC_ENTRY {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  LONG m__LONG__StartingLBA;
  UCHAR m__UCHAR__StartingMSF[ 3 ];
  LONG m__LONG__EndingLBA;
  UCHAR m__UCHAR__EndingMSF[ 3 ];
  BOOLEAN m__BOOLEAN__IsMCNAvailable;
  BOOLEAN m__BOOLEAN__IsISRCAvailable;
  BOOLEAN m__BOOLEAN__IsFourChannelsAudio;
  BOOLEAN m__BOOLEAN__IsPreEmphasisAudio;
  BOOLEAN m__BOOLEAN__IsData;
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsDigitalCopyProhibited;
  UCHAR m__UCHAR__TrackMode;
  UCHAR m__UCHAR__MODE2Form;
  ULONG m__ULONG__LBSizeInUCHARs;
  LONG m__LONG__Index00;
} * PTOC_ENTRY, TOC_ENTRY;
File

StarBurn.h

Description

Structure that represents TOC entry

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number
m__UCHAR__SessionNumber | Session number that this track belongs to
m__LONG__StartingLBA | Starting LBA
m__UCHAR__StartingMSF | Starting MSF
m__LONG__EndingLBA | Ending LBA
m__UCHAR__EndingMSF | Ending MSF
m__BOOLEAN__IsMCNAvailable | Is Media Catalog Number available
m__BOOLEAN__IsISRCAvailable | Is International Standard Recording Code available
m__BOOLEAN__IsFourChannelsAudio | Is this four channels audio track
m__BOOLEAN__IsPreEmphasisAudio | Is this pre-emphasis audio track
m__BOOLEAN__IsData | Is this data track
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsDigitalCopy... | Is digital copy prohibited for this track
m__UCHAR__TrackMode | Track mode (0 for audio track, 1 for MODE1 and 2 for MODE2)
m__UCHAR__MODE2Form | MODE2 Form (0 for Formless, 1 for Form1 and 2 for Form2)
m__ULONG__LBSizeInUCHARs | LB (logical block) size in UCHARs on this track
m__LONG__Index00 | Index00 LBA (if present)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PTOC_INFORMATION Structure

PTOC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _TOC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  BOOLEAN m__BOOLEAN__IsDVD;
  USHORT m__USHORT__ProtectedDVDRegions;
  UCHAR m__UCHAR__BusKeyForDiscKey[ 5 ];
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__NumberOfTracks;
  UCHAR m__UCHAR__NumberOfUnsortedEntries;
  TOC_ENTRY m__TOC_ENTRY[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW__Unsorted[ NUMBER_OF_RAW_TRACKS ];
} * PTOC_INFORMATION, TOC_INFORMATION;
File

StarBurn.h

Description

Structure that represents TOC information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__BOOLEAN__IsDVD | Is this DVD media or not
m__USHORT__ProtectedDVDRegions | Number of protected DVD regions
m__UCHAR__BusKeyForDiscKey | Bus key for disc key (CSS)
m__UCHAR__NumberOfSessions | Number of sessions
m__UCHAR__NumberOfTracks | Number of tracks
m__UCHAR__NumberOfUnsortedEntries | Number of entries in unsorted raw TOC
m__TOC_ENTRY | TOC entries (decoded and extended)
m__FULL_TOC_ENTRY_RAW | Full TOC raw entries sorted, each entry corresponds to m__TOC_ENTRY with the same TNO
m__FULL_TOC_ENTRY_RAW__Unsorted | Full TOC raw entries unsorted
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_CONTROL_BLOCK Structure

PUDF_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_CONTROL_BLOCK {
  void * m__PVOID__Head;
  void * m__PVOID__SystemStructures;
  void * m__PVOID__Tail;
  void * m__PVOID__Body;
} * PUDF_CONTROL_BLOCK, UDF_CONTROL_BLOCK;
File

StarBurn.h

Description

Structure that represents UDF control block

Member | Definition
m__PVOID__Head | Pointer to the head of the linked list
m__PVOID__SystemStructures | Pointer to the allocated and formatted UDF system structures
m__PVOID__Tail | Pointer to the tail of the linked list
m__PVOID__Body | Pointer to block body itself
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_FILE_EXTENT Structure

PUDF_FILE_EXTENT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_EXTENT {
  ULONG m__ULONG__BeginLBA;
  ULONG m__ULONG__EndLBA;
} UDF_FILE_EXTENT, * PUDF_FILE_EXTENT;
File

StarBurn.h

Description

Structure that describes a single file extent

Member | Definition
m__ULONG__BeginLBA | First LBA of the extent
m__ULONG__EndLBA | Last LBA of the extent
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_FILE_HANDLE Structure

PUDF_FILE_HANDLE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_HANDLE {
  HANDLE m__HANDLE;
} * PUDF_FILE_HANDLE, UDF_FILE_HANDLE;
File

StarBurn.h

Description

Structure that represents UDF file handle

Member | Definition
m__HANDLE | Win32 file handle
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_FILE_LOOKUP_ENTRY Structure

PUDF_FILE_LOOKUP_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_LOOKUP_ENTRY {
  ULONG m__ULONG__Size;
  PWCHAR m__PCHAR__FileName;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
} UDF_FILE_LOOKUP_ENTRY, * PUDF_FILE_LOOKUP_ENTRY;
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function

Member | Definition
m__ULONG__Size | Entry size
m__PWCHAR__FileName | File name
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_LOOKUP_DIR_ENTRY Structure

PUDF_LOOKUP_DIR_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_LOOKUP_DIR_ENTRY {
  PWCHAR m__PWCHAR__DirName;
  PVOID m__PVOID__ParentContext;
} UDF_LOOKUP_DIR_ENTRY, * PUDF_LOOKUP_DIR_ENTRY;
File

StarBurn.h

Description

Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__PWCHAR__DirName | Directory name
m__PVOID__ParentContext | The user context assigned to this directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_LOOKUP_FILE_ENTRY Structure

PUDF_LOOKUP_FILE_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_LOOKUP_FILE_ENTRY {
  ULONG m__ULONG__EntrySize;
  PWCHAR m__PWCHAR__FileName;
  ULONGLONG m__QWORD__FileSize;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
} UDF_LOOKUP_FILE_ENTRY, * PUDF_LOOKUP_FILE_ENTRY;
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__ULONG__EntrySize | Entry size
m__PWCHAR__FileName | File name
m__QWORD__FileSize | File size in bytes
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PUDF_TREE_ITEM Structure

PUDF_TREE_ITEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_TREE_ITEM {
  unsigned long m__ULONG__FileEntryRBA;
  unsigned long m__ULONG__FileIdentifierRBA;
  unsigned long m__ULONG__FileIdentifierParentOrContentRBA;
  unsigned long m__ULONG__LastTouchedRBA;
  unsigned long m__ULONG__GUID;
  unsigned char m__UCHAR__IsDirectory;
  unsigned char m__UCHAR__IsCached;
  unsigned short m__USHORT__NumberOfKidsAsParents;
  char m__CHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
  UDF_FILE_HANDLE m__UDF_FILE_HANDLE;
  unsigned char * m__PUCHAR__File;
  unsigned __int64 m__ULONGLONG__SizeInUCHARs;
  unsigned long m__ULONG__SizeInLogicalBlocks;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Next;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Prev;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Kids;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Parent;
  unsigned char m__UCHAR__FileEntryDescriptor[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  unsigned char * m__PUCHAR__FileIdentifierDescriptor;
  unsigned long m__ULONG__FileIdentifierDescriptorSizeInUCHARs;
  unsigned char m__UCHAR__FileContent[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  void * m__PVOID__Context;
  ISO9660_DATE_TIME m__ISO9660_DATE_TIME;
  WCHAR m__WCHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
} * PUDF_TREE_ITEM, UDF_TREE_ITEM;
File

StarBurn.h

Description

Structure that represents UDF tree item

Member | Definition
m__ULONG__FileEntryRBA | File entry relative block address
m__ULONG__FileIdentifierRBA | File identifier relative block address
m__ULONG__FileIdentifier... | File identifier parent or content relative block address
m__ULONG__LastTouchedRBA | Last touched relative block address (last occupied)
m__ULONG__GUID | Globally unique identifier
m__UCHAR__IsDirectory | Is this directory (0x01) or file (0x00)
m__UCHAR__IsCached | Is this entry content cached (located in memory) or not cached (located on the disk)
m__USHORT_NumberOfKidsAsParents | Number of kids that have their own kids
m__CHAR__Name | Name of this node
m__UDF_FILE_HANDLE | UDF file handle of this node
m__PUCHAR__File | Pointer to file content (for cached files)
m__ULONGLONG__SizeInUCHARs | Node content size in UCHARs
m__ULONG__SizeInLogicalBlocks | Node content size in logical blocks
m__PUDF_TREE_ITEM__Next | Pointer to the next UDF tree item in the linked list
m__PUDF_TREE_ITEM__Prev | Pointer to the previous UDF tree item in the linked list
m__PUDF_TREE_ITEM__Kids | Pointer to the kids liked list
m__PUDF_TREE_ITEM__Parent | Pointer to the parent of the current UDF tree item
m__UCHAR__FileEntryDescriptor | Array if UCHARs holding UDF file entry descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for parent of the current UDF tree item
m__UCHAR__FileContent | Array of UCHARs holding file content (alternative cached data)
m__PVOID__Context | Pointer to context value
m__ISO9660_DATE_TIME | ISO9660 date and time
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PWAVE_FILE_HEADER Structure

PWAVE_FILE_HEADER Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _WAVE_FILE_HEADER {
  ULONG m__ULONG__Riff;
  ULONG m__ULONG__Length;
  ULONG m__ULONG__Wave;
  ULONG m__ULONG__FormatTag;
  ULONG m__ULONG__FormatLength;
  WAVE_FORMAT_CHUNK m__WAVE_FORMAT_CHUNK;
  ULONG m__ULONG__DataTag;
  ULONG m__ULONG__DataLength;
} * PWAVE_FILE_HEADER, WAVE_FILE_HEADER;
File

StarBurn.h

Description

Structure that represents WAVE file header

Member | Definition
m__ULONG__Riff | Riff signature
m__ULONG__Length | Length of data section (w/o header) in UCHARs
m__ULONG__Wave | Wave signature
m__ULONG__FormatTag | Format tag
m__ULONG__FormatLength | Format length (size of WAVE_FORMAT_CHUNK in UCHARs)
m__WAVE_FORMAT_CHUNK | WAVE format chunk (see WAVE_FORMAT_CHUNK for more details)
m__ULONG__DataTag | Data tag
m__ULONG__DataLenght | Data length in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PWAVE_FORMAT_CHUNK Structure

PWAVE_FORMAT_CHUNK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _WAVE_FORMAT_CHUNK {
  USHORT m__USHORT__Format;
  USHORT m__USHORT__Channels;
  ULONG m__ULONG__SamplesPerSecond;
  ULONG m__ULONG__AverageSamplesPerSecond;
  USHORT m__USHORT__Alignment;
  USHORT m__USHORT__BitsPerSample;
} * PWAVE_FORMAT_CHUNK, WAVE_FORMAT_CHUNK;
File

StarBurn.h

Description

Structure that represents WAVE format chunk

Member | Definition
m__USHORT__Format | Format
m__USHORT__Channels | Number of channels
m__ULONG__SamplesPerSecond | Number of samples per second
m__ULONG__AverageSamplesPerSecond | Number of average samples per second
m__USHORT__Alignment | Alignment
m__USHORT__BitsPerSample | Number of bits in single sample
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PWRITE_MODE Enumeration

PWRITE_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _WRITE_MODE {
  WRITE_MODE_TRACK_AT_ONCE = 0,
  WRITE_MODE_SESSION_AT_ONCE,
  WRITE_MODE_DISC_AT_ONCE_PQ,
  WRITE_MODE_DISC_AT_ONCE_RAW_PW
} * PWRITE_MODE, WRITE_MODE;
File

StarBurn.h

Description

Enum that represents write modes

Member | Definition
WRITE_MODE_TRACK_AT_ONCE | Track-At-Once
WRITE_MODE_SESSION_AT_ONCE | Session-At-Once
WRITE_MODE_DISC_AT_ONCE_PQ | Disc-At-Once PQ
WRITE_MODE_DISC_AT_ONCE_RAW_PW | Disc-At-Once raw P-W
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


READ_MODE Enumeration

READ_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _READ_MODE {
  READ_MODE_COOKED = 0,
  READ_MODE_RAW,
  READ_MODE_RAW_PQ,
  READ_MODE_RAW_RAW_PW,
  READ_MODE_PQ,
  READ_MODE_RAW_PW
} * PREAD_MODE, READ_MODE;
File

StarBurn.h

Description

Enum that represents raw read modes

Member | Definition
READ_MODE_COOKED | Cooked data
READ_MODE_RAW | Raw data
READ_MODE_RAW_PQ | Raw data + PQ sub-channel
READ_MODE_RAW_RAW_PW | Raw data + raw P-W sub-channel
READ_MODE_PQ | PQ sub-channel only (no main channel data)
READ_MODE_RAW_PW | Raw P-W sub-channel only (no main channel data)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_ADDRESS Structure

SCSI_DEVICE_ADDRESS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _SCSI_DEVICE_ADDRESS {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__PortID;
  UCHAR m__UCHAR__BusID;
  UCHAR m__UCHAR__TargetID;
  UCHAR m__UCHAR__LUN;
} * PSCSI_DEVICE_ADDRESS, SCSI_DEVICE_ADDRESS;
File

StarBurn.h

Description

Structure that represents SCSI device address

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__PortID | Port ID - Logical SCSI adapter ID if ASPI is used
m__UCHAR__BusID | Bus ID - 0 if ASPI is used
m__UCHAR__TargetID | Target ID
m__UCHAR__LUN | LUN (Logical Unit Number)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure

STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS {
  ULONG m__ULONG__SizeInUCHARs;
  BOOLEAN m__BOOLEAN__IsCDROMRead;
  BOOLEAN m__BOOLEAN__IsCDRRead;
  BOOLEAN m__BOOLEAN__IsCDRWrite;
  BOOLEAN m__BOOLEAN__IsCDRWRead;
  BOOLEAN m__BOOLEAN__IsCDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDROMRead;
  BOOLEAN m__BOOLEAN__IsDVDRRead;
  BOOLEAN m__BOOLEAN__IsDVDRWrite;
  BOOLEAN m__BOOLEAN__IsDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWRead;
  BOOLEAN m__BOOLEAN__IsDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDRAMRead;
  BOOLEAN m__BOOLEAN__IsDVDRAMWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead;
  BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDROMRead;
  BOOLEAN m__BOOLEAN__IsBDRRead;
  BOOLEAN m__BOOLEAN__IsBDRWrite;
  BOOLEAN m__BOOLEAN__IsBDRDLRead;
  BOOLEAN m__BOOLEAN__IsBDRDLWrite;
  BOOLEAN m__BOOLEAN__IsBDRERead;
  BOOLEAN m__BOOLEAN__IsBDREWrite;
  BOOLEAN m__BOOLEAN__IsBDREDLRead;
  BOOLEAN m__BOOLEAN__IsBDREDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDROMRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWWrite;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead;
  BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite;
} * PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS, STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS;
File

StarBurn.h

Description

Structure that represents advanced supported media formats

Member Definition

--------- --------------

ULONG m__ULONG__SizeInUCHARs This structure size in UCHARs
BOOLEAN m__BOOLEAN__IsCDROMRead Is CD-ROM read capable
BOOLEAN m__BOOLEAN__IsCDRRead Is CD-R read capable
BOOLEAN m__BOOLEAN__IsCDRWrite Is CD-R write capable
BOOLEAN m__BOOLEAN__IsCDRWRead Is CD-RW read capable
BOOLEAN m__BOOLEAN__IsCDRWWrite Is CD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDROMRead Is DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsDVDRRead Is DVD-R read capable
BOOLEAN m__BOOLEAN__IsDVDRWrite Is DVD-R write capable
BOOLEAN m__BOOLEAN__IsDVDRDLRead Is DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsDVDRDLWrite Is DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsDVDRWRead Is DVD-RW read capable
BOOLEAN m__BOOLEAN__IsDVDRWWrite Is DVD-RW write capable
BOOLEAN m__BOOLEAN__IsDVDRWDLRead Is DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDRWDLWrite Is DVD-RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDRAMRead Is DVD-RAM read capable
BOOLEAN m__BOOLEAN__IsDVDRAMWrite Is DVD-RAM write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWRead Is DVD+RW read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWWrite Is DVD+RW write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLRead Is DVD+RW DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWDLWrite Is DVD+RW DL write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRRead Is DVD+R read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRWrite Is DVD+R write capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLRead Is DVD+R DL read capable
BOOLEAN m__BOOLEAN__IsDVDPLUSRDLWrite Is DVD+R DL write capable
BOOLEAN m__BOOLEAN__IsBDROMRead Is BD-ROM read capable
BOOLEAN m__BOOLEAN__IsBDRRead Is BD-R read capable
BOOLEAN m__BOOLEAN__IsBDRWrite Is BD-R write capable
BOOLEAN m__BOOLEAN__IsBDRDLRead Is BD-R DL read capable
BOOLEAN m__BOOLEAN__IsBDRDLWrite Is BD-R DL write capable
BOOLEAN m__BOOLEAN__IsBDRERead Is BD-RE read capable
BOOLEAN m__BOOLEAN__IsBDREWrite Is BD-RE write capable
BOOLEAN m__BOOLEAN__IsBDREDLRead Is BD-RE DL read capable
BOOLEAN m__BOOLEAN__IsBDREDLWrite Is BD-RE DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDROMMRead Is HD-DVD-ROM read capable
BOOLEAN m__BOOLEAN__IsHDDVDRRead Is HD-DVD-R read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWrite Is HD-DVD-R write capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLRead Is HD-DVD-R DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRDLWrite Is HD-DVD-R DL write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWRead Is HD-DVD-RW read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWWrite Is HD-DVD-RW write capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLRead Is HD-DVD-RW DL read capable
BOOLEAN m__BOOLEAN__IsHDDVDRWDLWrite Is HD-DVD-RW DL write capable
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_PROFILE Structure

STARBURN_BDRE_FORMAT_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_BDRE_FORMAT_PROFILE {
  LONG m__LONG__FormatProfileNumber;
  ULONG m__ULONG__NumberOfBlocksOrUserAreaDataSize;
  UCHAR m__UCHAR__CertificationType : 2;
  UCHAR m__UCHAR__FormatType : 6;
  ULONG m__ULONG__SpareAreaSizeInClustersOrBlockLength;
} ** PPSTARBURN_BDRE_FORMAT_PROFILE, * PSTARBURN_BDRE_FORMAT_PROFILE, STARBURN_BDRE_FORMAT_PROFILE;
File

StarBurn.h

Description

Structure that represents format profile for BD-RE media

Member Definition

--------- --------------

LONG m__LONG__FormatProfileNumber Format profile number
UCHAR m__ULONG__NumberOfBlocksOrUserAreaDataSize Number of logical block(s) or user area data size
UCHAR m__UCHAR__CertificationType Certification type
UCHAR m__UCHAR__FormatType Format type
UCHAR m__ULONG__SpareAreaSizeInClustersOrBlockLength Spare area size in cluster(s) or block length
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CD_MODE Enumeration

STARBURN_CD_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_CD_MODE {
  CD_MODE_UNKNOWN = 0,
  CD_MODE_AUDIO,
  CD_MODE_VIDEO,
  CD_MODE_DATA,
  CD_MODE_RESERVED
} * PSTARBURN_CD_MODE, STARBURN_CD_MODE;
File

StarBurn.h

Description

Enum that represents CD modes type

Member | Definition
CD_MODE_UNKNOWN | Unknown CD mode
CD_MODE_AUDIO | Audio CD mode
CD_MODE_VIDEO | Video CD mode
CD_MODE_DATA | Data CD mode
CD_MODE_RESERVED | Reserved
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_ATIP_INFORMATION Structure

STARBURN_DISC_ATIP_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_DISC_ATIP_INFORMATION {
  USHORT m__USHORT__DataLength;
  UCHAR m__UCHAR__Reserved1[2];
  UCHAR m__UCHAR__RefrenceSpeed : 3;
  UCHAR m__UCHAR__Reserved2 : 1;
  UCHAR m__UCHAR__IndicativeTargetWritingPower : 4;
  UCHAR m__UCHAR__Reserved3 : 6;
  UCHAR m__UCHAR__URU : 1;
  UCHAR m__UCHAR__Zero : 1;
  UCHAR m__UCHAR__IsA3Valid : 1;
  UCHAR m__UCHAR__IsA2Valid : 1;
  UCHAR m__UCHAR__IsA1Valid : 1;
  UCHAR m__UCHAR__DiscSubType : 3;
  UCHAR m__UCHAR__DiscType : 1;
  UCHAR m__UCHAR__One : 1;
  UCHAR m__UCHAR__Reserved4;
  UCHAR m__UCHAR__LeadInStartTime[3];
  UCHAR m__UCHAR__Reserved5;
  UCHAR m__UCHAR__LastPossibleLeadOutStartTime[3];
  UCHAR m__UCHAR__Reserved6;
  UCHAR m__UCHAR__A1Values[3];
  UCHAR m__UCHAR__Reserved7;
  UCHAR m__UCHAR__A2Values[3];
  UCHAR m__UCHAR__Reserved8;
  UCHAR m__UCHAR__A3Values[3];
  UCHAR m__UCHAR__Reserved9;
  UCHAR m__UCHAR__S4Values[3];
  UCHAR m__UCHAR__Reserved10;
} * PSTARBURN_DISC_ATIP_INFORMATION, STARBURN_DISC_ATIP_INFORMATION;
File

StarBurn.h

Description

Structure that represents Disc ATIP information

Member Definition

--------- --------------

m__USHORT__DataLength
m__UCHAR__Reserved1
m__UCHAR__RefrenceSpeed
m__UCHAR__Reserved2
m__UCHAR__IndicativeTargetWritingPower
m__UCHAR__Reserved3
m__UCHAR__URU
m__UCHAR__Zero
m__UCHAR__IsA3Valid
m__UCHAR__IsA2Valid
m__UCHAR__IsA1Valid
m__UCHAR__DiscSubType
m__UCHAR__DiscType
m__UCHAR__One
m__UCHAR__Reserved4
m__UCHAR__LeadInStartTime
m__UCHAR__Reserved5
m__UCHAR__LastPossibleLeadOutStartTime
m__UCHAR__Reserved6
m__UCHAR__A1Values
m__UCHAR__Reserved7
m__UCHAR__A2Values
m__UCHAR__Reserved8
m__UCHAR__A3Values
m__UCHAR__Reserved9
m__UCHAR__S4Values
m__UCHAR__Reserved10
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_INFORMATION Structure

STARBURN_DISC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_DISC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__DiscStatus;
  UCHAR m__UCHAR__LastSessionStatus;
  BOOLEAN m__BOOLEAN__IsErasable;
  UCHAR m__UCHAR__FirstTrackNumber;
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__LastSessionFirstTrack;
  UCHAR m__UCHAR__LastSessionLastTrack;
  BOOLEAN m__BOOLEAN__IsGEN;
  BOOLEAN m__BOOLEAN__IsDBCValid;
  BOOLEAN m__BOOLEAN__IsDIDValid;
  UCHAR m__UCHAR__DiscType;
  UCHAR m__UCHAR__DiscIdentification[ 4 ];
  UCHAR m__UCHAR__LastSessionLeadIn[ 4 ];
  UCHAR m__UCHAR__LastPossibleStartTime[ 4 ];
  UCHAR m__UCHAR__DiscBarCode[ 8 ];
  UCHAR m__UCHAR__NumberOfOPCEntries;
} * PSTARBURN_DISC_INFORMATION, STARBURN_DISC_INFORMATION;
File

StarBurn.h

Description

Structure that represents Disc information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__DiscStatus | Disc status (See DISC_STATUS_XXX constants)
m__UCHAR__LastSessionStatus | Last session status (See LAST_SESSION_XXX constants)
m__BOOLEAN__IsErasable | Is disc erasable (CD-RW or DVD-RW or DVD+RW or DVD-RAM)
m__UCHAR__FirstTrackNumber | First track number on the disc
m__UCHAR__NumberOfSessions | Number of sessions on the disc
m__UCHAR__LastSessionFirstTrack | First track number of last complete session on the disc
m__UCHAR__LastSessionLastTrack | Last track number of last complete session on the disc
m__BOOLEAN__IsGEN | Unrestricted use, when set to one - every application can write to the disc
m__BOOLEAN__IsDBCValid | Is Disc Bar Code field valid
m__BOOLEAN__IsDIDValid | Is Disc Identification field Valid
m__UCHAR__DiscType | Disc type (See DISC_TYPE_XXX constants)
m__UCHAR__DiscIdentification | Disc identification number recorded in the PMA, see m__UCHAR__IsDIDValid
m__UCHAR__LastSessionLeadId | MSF of last session lead in start time
m__UCHAR__LastPossibleStartTime | Last possible start time for lead out on this disc
m__UCHAR__DiscBarCode | Disc bar code stored here if the device is capable of reading disc bar codes
m__UCHAR__NumberOfOPCEntries | Number of optimum power calibration entries at the end of this structure
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ELTORITO_MEDIA Enumeration

STARBURN_ELTORITO_MEDIA Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_ELTORITO_MEDIA {
  ELTORITO_MEDIA_CUSTOM = 0x00,
  ELTORITO_MEDIA_FLOPPY120 = 0x01,
  ELTORITO_MEDIA_FLOPPY144 = 0x02,
  ELTORITO_MEDIA_FLOPPY288 = 0x03,
  ELTORITO_MEDIA_HARDDISK = 0x04
} STARBURN_ELTORITO_MEDIA;
File

StarBurn.h

Description

Media emulation types

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ELTORITO_PLATFORM Enumeration

STARBURN_ELTORITO_PLATFORM Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_ELTORITO_PLATFORM {
  ELTORITO_PLATFORM_80X86 = 0x00,
  ELTORITO_PLATFORM_POWERPC = 0x01,
  ELTORITO_PLATFORM_MAC = 0x02,
  ELTORITO_PLATFORM_EFI = 0xEF
} STARBURN_ELTORITO_PLATFORM;
File

StarBurn.h

Description

ElTorito platform types

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_DIRECTORY_INFO Structure

STARBURN_ISO9660_DIRECTORY_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_ISO9660_DIRECTORY_INFO {
  unsigned char ISOType;
  unsigned long NumberOfKids;
  unsigned long TotalNumberOfFiles;
  unsigned long TotalNumberOfDirs;
  unsigned __int64 TotalChildrenSizeInLBs;
} STARBURN_ISO9660_DIRECTORY_INFO;
File

StarBurn.h

Description

This is type STARBURN_ISO9660_DIRECTORY_INFO.

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_INFO Structure

STARBURN_ISO9660_FILE_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_ISO9660_FILE_INFO {
  char Name[ ( STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  unsigned short UnicodeName[ ( STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS + 1 ) ];
  unsigned short UnicodePathName[ ( STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  BOOL IsImported;
  unsigned __int64 ContentSizeInUCHARs;
  unsigned long SizeInLogicalBlocks;
  unsigned long GUID;
  unsigned long Attributes;
  unsigned long BeginLBA;
  unsigned long EndLBA;
} STARBURN_ISO9660_FILE_INFO;
File

StarBurn.h

Description

ISO9660 file information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE_CALLBACK_REASON Enumeration

STARBURN_STARWAVE_CALLBACK_REASON Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_CALLBACK_REASON {
  STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN = 0,
  STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS
} STARBURN_STARWAVE_CALLBACK_REASON, * PSTARBURN_STARWAVE_CALLBACK_REASON, ** PPSTARBURN_STARWAVE_CALLBACK_REASON;
File

StarBurn.h

Description

StarWave callback reasons we'll be using

Member | Definition
STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN | Unknown call reason
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS | Progress indication reason
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE_COMPRESSION Enumeration

STARBURN_STARWAVE_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE_COMPRESSION {
  STARBURN_STARWAVE_COMPRESSION_NONE = 0,
  STARBURN_STARWAVE_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 = 10,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 = 25,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 = 50,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 = 75,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 = 90,
  STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 = 98,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K = 32000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K = 48000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K = 64000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K = 80000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K = 96000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K = 128000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K = 160000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K = 192000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K = 256000,
  STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K = 320000
} STARBURN_STARWAVE_COMPRESSION, * PSTARBURN_STARWAVE_COMPRESSION, ** PPSTARBURN_STARWAVE_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Member | Definition
STARBURN_STARWAVE_COMPRESSION_NONE | Lossless PCM WAV uncompressed stream
STARBURN_STARWAVE_COMPRESSION_WMA_LOSS... | Lossless WMA compressed stream, VBR at Quality 100
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 | WMA compressed stream, VBR at Quality 10
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 | WMA compressed stream, VBR at Quality 25
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 | WMA compressed stream, VBR at Quality 50
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 | WMA compressed stream, VBR at Quality 75
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 | WMA compressed stream, VBR at Quality 90
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 | WMA compressed stream, VBR at Quality 98
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K | WMA compressed stream, CBR at 32 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K | WMA compressed stream, CBR at 48 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K | WMA compressed stream, CBR at 64 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K | WMA compressed stream, CBR at 80 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K | WMA compressed stream, CBR at 96 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K | WMA compressed stream, CBR at 128 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K | WMA compressed stream, CBR at 160 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K | WMA compressed stream, CBR at 192 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K | WMA compressed stream, CBR at 256 Kbps
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K | WMA compressed stream, CBR at 320 Kbps
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration

STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE2_COMPRESS_TYPE {
  COMPRESS_TYPE_INVALID_VALUE = 0,
  COMPRESS_TYPE_MP3_CBR,
  COMPRESS_TYPE_MP3_ABR,
  COMPRESS_TYPE_MP3_VBR,
  COMPRESS_TYPE_OGG_CBR,
  COMPRESS_TYPE_OGG_ABR,
  COMPRESS_TYPE_OGG_VBR,
  COMPRESS_TYPE_OGG_APPROXIMATE,
  COMPRESS_TYPE_WMA_LOSSLESS_VBR,
  COMPRESS_TYPE_WMA_CBR,
  COMPRESS_TYPE_WMA_VBR,
  COMPRESS_TYPE_UNCOMPRESSED_WAV_44100_STEREO,
  COMPRESS_TYPE_CUSTOM,
  COMPRESS_TYPE_FORCE_INT = 0xFFFFFFFF
} STARBURN_STARWAVE2_COMPRESS_TYPE;
File

StarBurn.h

Description

Compress settings

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE2_CONVERSION_MODE Enumeration

STARBURN_STARWAVE2_CONVERSION_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE2_CONVERSION_MODE {
  STARBURN_STARWAVE2_OGG_MODE0,
  STARBURN_STARWAVE2_OGG_MODE1,
  STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_OGG_MODE_MAX = STARBURN_STARWAVE2_OGG_MODE2,
  STARBURN_STARWAVE2_MP3_MODE0,
  STARBURN_STARWAVE2_MP3_MODE1,
  STARBURN_STARWAVE2_MP3_MODE2,
  STARBURN_STARWAVE2_MP3_MODE_MAX = STARBURN_STARWAVE2_MP3_MODE2
} STARBURN_STARWAVE2_CONVERSION_MODE, * PSTARBURN_STARWAVE2_CONVERSION_MODE;
File

StarBurn.h

Description

Structure that represents conversion mode

Member | Definition
OGG_MODE0 | VBR, variable bit rate
OGG_MODE1 | ABR, average bit rate
OGG_MODE2 | CBR, constant bit rate
OGG_MODE_MAX | Now equal to OGG_MODE2
MP3_MODE0 | CBR, constant bit rate
MP3_MODE1 | ABR, average bit rate
MP3_MODE2 | VBR, variable bit rate
MP3_MODE_MAX | Now equal to MP3_MODE2
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE2_INIT_PARAMS Structure

STARBURN_STARWAVE2_INIT_PARAMS Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_STARWAVE2_INIT_PARAMS {
  STARBURN_STARWAVE2_CONVERSION_MODE m__STARBURN_STARWAVE2_CONVERSION_MODE;
  FLOAT m__FLOAT__flQuality;
  LONG m__LONG__nQuality;
  LONG m__LONG__maxBitrate;
  LONG m__LONG__nominalBitrate;
  LONG m_LONG__minBitrate;
  STARBURN_STARWAVE2_QUALITY_MODE m__STARBURN_STARWAVE2_QUALITY_MODE;
} STARBURN_STARWAVE2_INIT_PARAMS, * PSTARBURN_STARWAVE2_INIT_PARAMS;
File

StarBurn.h

Description

Structure that represents initialization parameters for audio conversion

Member | Definition
m__STARBURN_STARWAVE2_CONVERSION_MODE | Conversion mode
m__FLOAT__flQuality | Quality level from 0. (lo) to 1. (hi) (use for OGG_MODE0)
m__LONG__nQuality | Quality level from 1 to 9 (use for MP3_MODE2)
m__LONG__maxBitrate | Maximum bit rate (use for OGG_MODE1/OGG_MODE2)
m__LONG__nominalBitrate | Nominal bit rate (use for OGG_MODE1/OGG_MODE2/MP3_MODE0/MP3_MODE1)
m__LONG__minBitrate | Minimum bit rate (use for OGG_MODE1/OGG_MODE2)
m__StarBurn_StarWave2_QUALITY_MODE | Quality mode (use for /MP3_MODE0/MP3_MODE1/MP3_MODE2)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE2_QUALITY_MODE Enumeration

STARBURN_STARWAVE2_QUALITY_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_STARWAVE2_QUALITY_MODE {
  STARBURN_STARWAVE2_QM_FAST = 0,
  STARBURN_STARWAVE2_QM_STANDARD,
  STARBURN_STARWAVE2_QM_HIGH
} STARBURN_STARWAVE2_QUALITY_MODE, * PSTARBURN_STARWAVE2_QUALITY_MODE;
File

StarBurn.h

Description

Enum that represents MP3 quality for conversion

Member | Definition
StarBurn_StarWave2_QM_FAST | Fast mode
StarBurn_StarWave2_QM_STANDARD | Standard mode
StarBurn_StarWave2_QM_HIGH | High quality mode
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_TRACK_INFORMATION Structure

STARBURN_TRACK_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_TRACK_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
} * PSTARBURN_TRACK_INFORMATION, STARBURN_TRACK_INFORMATION;
File

StarBurn.h

Description

Structure that represents Track information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_TRACK_INFORMATION_EX Structure

STARBURN_TRACK_INFORMATION_EX Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_TRACK_INFORMATION_EX {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  UCHAR m__UCHAR__TrackMode;
  BOOLEAN m__BOOLEAN__IsCopy;
  BOOLEAN m__BOOLEAN__IsDamage;
  UCHAR m__UCHAR__DataMode;
  BOOLEAN m__BOOLEAN__IsFixedPacket;
  BOOLEAN m__BOOLEAN__IsPacket;
  BOOLEAN m__BOOLEAN__IsBlank;
  BOOLEAN m__BOOLEAN__IsReserved;
  BOOLEAN m__BOOLEAN__IsNextWritableAddressValid;
  LONG m__LONG__TrackStartAddress;
  LONG m__LONG__LastRecordedAddress;
  LONG m__LONG__NextWritableAddress;
  LONG m__LONG__FreeLBs;
  LONG m__LONG__FixedPacketSizeInLBs;
} * PSTARBURN_TRACK_INFORMATION_EX, STARBURN_TRACK_INFORMATION_EX;
File

StarBurn.h

Description

Structure that represents Track information extended

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number of this track
m__UCHAR__SessionNumber | Session number that contains this track
m__UCHAR__TrackMode | Track mode
m__BOOLEAN__IsCopy | Is this track second or higher generation copy
m__BOOLEAN__IsDamage | Is track damaged
m__UCHAR__DataMode | Data mode on the track
m__BOOLEAN__IsFixedPacket | Is fixed packet used on this track
m__BOOLEAN__IsPacket | Is packet recording used on the track
m__BOOLEAN__IsBlank | Is track blank
m__BOOLEAN__IsReserved | Is track reserved
m__BOOLEAN__IsNextWritable... | Is NWA (Next Writable Address) valid
m__LONG__TrackStartAddress | Starting address (LBA or MSF) for this track
m__LONG__LastRecordedAddress | Last Recorded Address (LBA or MSF) for this track
m__LONG__NextWritableAddress | NWA (Next Writable Address)
m__LONG__FreeLBs | Free logical blocks on this track
m__LONG__FixedPacketSize... | Fixed packet size in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF_BRIDGE_TYPE Enumeration

STARBURN_UDF_BRIDGE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_UDF_BRIDGE_TYPE {
  UDF_BRIDGE_TYPE_NONE = 0,
  UDF_BRIDGE_TYPE_DVDVIDEO,
  UDF_BRIDGE_TYPE_ISO9660,
  UDF_BRIDGE_TYPE_ISO9660_JOLIET,
  UDF_BRIDGE_TYPE_FORCE_DWORD = 0xFFFFFFFF
} STARBURN_UDF_BRIDGE_TYPE;
File

StarBurn.h

Description

Restore original structure packing

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_DIRECTORY_INFO Structure

STARBURN_UDF2_DIRECTORY_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_UDF2_DIRECTORY_INFO {
  unsigned long NumberOfKids;
  unsigned long NumberOfKidsDirectories;
} STARBURN_UDF2_DIRECTORY_INFO;
File

StarBurn.h

Description

UDF directory information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_FILE_DATE_TIME Structure

STARBURN_UDF2_FILE_DATE_TIME Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_UDF2_FILE_DATE_TIME {
  unsigned short Year;
  unsigned char Month;
  unsigned char Day;
  unsigned char Hour;
  unsigned char Minute;
  unsigned char Second;
  unsigned char Millisecond;
  short Offset : 12;
  short IsLocal : 1;
  short Reserved : 3;
} STARBURN_UDF2_FILE_DATE_TIME;
File

StarBurn.h

Description

Structure that represents UDF2 file date and time

Member | Definition
Year | Year
Month | Month
Day | Day
Hour | Hour
Minute | Minute
Second | Second
Millisecnd | Millisecond
Offset | UTC offset in minutes
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration

STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARBURN_UDF2_FILE_DATE_TIME_TYPE {
  UDF_FILE_DATE_TIME_TYPE_CREATION = 0,
  UDF_FILE_DATE_TIME_TYPE_LAST_ACCESS,
  UDF_FILE_DATE_TIME_TYPE_LAST_WRITE
} STARBURN_UDF2_FILE_DATE_TIME_TYPE;
File

StarBurn.h

Description

Enum that represents StarBurn date/time type for files in UDF

Member Definition

--------- --------------

UDF_FILE_DATE_TIME_TYPE_CREATION File originally created
UDF_FILE_DATE_TIME_TYPE_LAST_ACCESS File last accessed
UDF_FILE_DATE_TIME_TYPE_LAST_WRITE File last written to
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_FILE_INFO Structure

STARBURN_UDF2_FILE_INFO Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARBURN_UDF2_FILE_INFO {
  CHAR Name[ ( STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  WCHAR UnicodeName[ ( STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS + 1 ) ];
  CHAR PathName[ ( STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS + 1 ) ];
  WCHAR UnicodePathName[ ( STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS + 1 ) ];
  BOOL IsUnicode;
  BOOL IsImported;
  unsigned __int64 ImportedContentSizeInUCHARs;
  unsigned long GUID;
  unsigned long Attributes;
  unsigned long SizeInLogicalBlocks;
  unsigned __int64 SizeInUCHARs;
  unsigned long BeginLBA;
  unsigned long EndLBA;
} STARBURN_UDF2_FILE_INFO;
File

StarBurn.h

Description

UDF file information

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARPORT_DEVICE_LIST Structure

STARPORT_DEVICE_LIST Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST {
  LONG m__LONG__NumberOfEntries;
  STARPORT_DEVICE_LIST_ENTRY m__STARPORT_DEVICE_LIST_ENTRY[ 1 ];
} ** PPSTARPORT_DEVICE_LIST, * PSTARPORT_DEVICE_LIST, STARPORT_DEVICE_LIST;
File

StarBurn.h

Description

Structure that represents StarPort device list

Member | Definition
m__LONG__NumberOfEntries | Number of StarPort device list entries
m__STARPORT_DEVICE_LIST_ENTRY | StarPort device list entries
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARPORT_DEVICE_LIST_ENTRY Structure

STARPORT_DEVICE_LIST_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARPORT_DEVICE_LIST_ENTRY {
  LONG m__LONG__Index;
  LONG m__LONG__TargetId;
  CHAR m__CHAR__Name[ STARPORT_DEVICE_NAME_SIZE_IN_UCHARS ];
} ** PPSTARPORT_DEVICE_LIST_ENTRY, * PSTARPORT_DEVICE_LIST_ENTRY, STARPORT_DEVICE_LIST_ENTRY;
File

StarBurn.h

Description

Structure that represents StarPort device list entry

Member | Definition
m__LONG__Index | StarPort device index
m__LONG__TargetId | StarPort device TargetId
m__CHAR__Name | StarPort device name
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARPORT_DEVICE_TYPE Enumeration

STARPORT_DEVICE_TYPE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARPORT_DEVICE_TYPE {
  STARPORT_DEVICE_TYPE_UNKNOWN = 0,
  STARPORT_DEVICE_TYPE_RAM,
  STARPORT_DEVICE_TYPE_HDD,
  STARPORT_DEVICE_TYPE_DVD,
  STARPORT_DEVICE_TYPE_AOE,
  STARPORT_DEVICE_TYPE_ISCSI
} ** PPSTARPORT_DEVICE_TYPE, * PSTARPORT_DEVICE_TYPE, STARPORT_DEVICE_TYPE;
File

StarBurn.h

Description

Enum that represents StarPort device type

Member | Definition
STARPORT_DEVICE_TYPE_UNKNOWN | Unknown device type
STARPORT_DEVICE_TYPE_RAM | RAM disk
STARPORT_DEVICE_TYPE_HDD | Virtual hard disk
STARPORT_DEVICE_TYPE_DVD | Virtual DVD
STARPORT_DEVICE_TYPE_AOE | AoE (ATA-over-Ethernet)
STARPORT_DEVICE_TYPE_ISCSI | iSCSI (SCSI-over-IP)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVE2_COMPRESSION Enumeration

STARWAVE2_COMPRESSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _STARWAVE2_COMPRESSION {
  STARWAVE2_COMPRESSION_NONE = 0,
  STARWAVE2_COMPRESSION_WMA_LOSSLESS_VBR_Q100 = 1,
  STARWAVE2_COMPRESSION_WMA_VBR_Q10 = 10,
  STARWAVE2_COMPRESSION_WMA_VBR_Q25 = 25,
  STARWAVE2_COMPRESSION_WMA_VBR_Q50 = 50,
  STARWAVE2_COMPRESSION_WMA_VBR_Q75 = 75,
  STARWAVE2_COMPRESSION_WMA_VBR_Q90 = 90,
  STARWAVE2_COMPRESSION_WMA_VBR_Q98 = 98,
  STARWAVE2_COMPRESSION_WMA_CBR_32K = 32000,
  STARWAVE2_COMPRESSION_WMA_CBR_48K = 48000,
  STARWAVE2_COMPRESSION_WMA_CBR_64K = 64000,
  STARWAVE2_COMPRESSION_WMA_CBR_80K = 80000,
  STARWAVE2_COMPRESSION_WMA_CBR_96K = 96000,
  STARWAVE2_COMPRESSION_WMA_CBR_128K = 128000,
  STARWAVE2_COMPRESSION_WMA_CBR_160K = 160000,
  STARWAVE2_COMPRESSION_WMA_CBR_192K = 192000,
  STARWAVE2_COMPRESSION_WMA_CBR_256K = 256000,
  STARWAVE2_COMPRESSION_WMA_CBR_320K = 320000
} STARWAVE2_COMPRESSION, * PSTARWAVE2_COMPRESSION, ** PPSTARWAVE2_COMPRESSION;
File

StarBurn.h

Description

Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates

All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVE2_COMPRESSION_PROFILE Structure

STARWAVE2_COMPRESSION_PROFILE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _STARWAVE2_COMPRESSION_PROFILE {
  UINT m__UINT__CompressionType;
  PCHAR m__PCHAR__CustomFactoryID;
  union {
    int m__int__CBRBitRate;
    int m__int__VBRQuality;
  }
  int m__int__ABRBitRate;
  int m__int__MaxBitRate;
  union {
    int m__int__MinBitRate;
    int m__int__MaxFrameWindow;
  }
  LPVOID m__LPVOID__CustomData;
} STARWAVE2_COMPRESSION_PROFILE, * PSTARWAVE2_COMPRESSION_PROFILE, ** PPSTARWAVE2_COMPRESSION_PROFILE;
File

StarBurn.h

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TOC_ENTRY Structure

TOC_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _TOC_ENTRY {
  BOOLEAN m__BOOLEAN__IsValid;
  UCHAR m__UCHAR__TrackNumber;
  UCHAR m__UCHAR__SessionNumber;
  LONG m__LONG__StartingLBA;
  UCHAR m__UCHAR__StartingMSF[ 3 ];
  LONG m__LONG__EndingLBA;
  UCHAR m__UCHAR__EndingMSF[ 3 ];
  BOOLEAN m__BOOLEAN__IsMCNAvailable;
  BOOLEAN m__BOOLEAN__IsISRCAvailable;
  BOOLEAN m__BOOLEAN__IsFourChannelsAudio;
  BOOLEAN m__BOOLEAN__IsPreEmphasisAudio;
  BOOLEAN m__BOOLEAN__IsData;
  BOOLEAN m__BOOLEAN__IsAudio;
  BOOLEAN m__BOOLEAN__IsDigitalCopyProhibited;
  UCHAR m__UCHAR__TrackMode;
  UCHAR m__UCHAR__MODE2Form;
  ULONG m__ULONG__LBSizeInUCHARs;
  LONG m__LONG__Index00;
} * PTOC_ENTRY, TOC_ENTRY;
File

StarBurn.h

Description

Structure that represents TOC entry

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__UCHAR__TrackNumber | Track number
m__UCHAR__SessionNumber | Session number that this track belongs to
m__LONG__StartingLBA | Starting LBA
m__UCHAR__StartingMSF | Starting MSF
m__LONG__EndingLBA | Ending LBA
m__UCHAR__EndingMSF | Ending MSF
m__BOOLEAN__IsMCNAvailable | Is Media Catalog Number available
m__BOOLEAN__IsISRCAvailable | Is International Standard Recording Code available
m__BOOLEAN__IsFourChannelsAudio | Is this four channels audio track
m__BOOLEAN__IsPreEmphasisAudio | Is this pre-emphasis audio track
m__BOOLEAN__IsData | Is this data track
m__BOOLEAN__IsAudio | Is this audio track
m__BOOLEAN__IsDigitalCopy... | Is digital copy prohibited for this track
m__UCHAR__TrackMode | Track mode (0 for audio track, 1 for MODE1 and 2 for MODE2)
m__UCHAR__MODE2Form | MODE2 Form (0 for Formless, 1 for Form1 and 2 for Form2)
m__ULONG__LBSizeInUCHARs | LB (logical block) size in UCHARs on this track
m__LONG__Index00 | Index00 LBA (if present)
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TOC_INFORMATION Structure

TOC_INFORMATION Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _TOC_INFORMATION {
  BOOLEAN m__BOOLEAN__IsValid;
  BOOLEAN m__BOOLEAN__IsDVD;
  USHORT m__USHORT__ProtectedDVDRegions;
  UCHAR m__UCHAR__BusKeyForDiscKey[ 5 ];
  UCHAR m__UCHAR__NumberOfSessions;
  UCHAR m__UCHAR__NumberOfTracks;
  UCHAR m__UCHAR__NumberOfUnsortedEntries;
  TOC_ENTRY m__TOC_ENTRY[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW[ NUMBER_OF_TRACKS ];
  FULL_TOC_ENTRY_RAW m__FULL_TOC_ENTRY_RAW__Unsorted[ NUMBER_OF_RAW_TRACKS ];
} * PTOC_INFORMATION, TOC_INFORMATION;
File

StarBurn.h

Description

Structure that represents TOC information

Member | Definition
m__BOOLEAN__IsValid | Is this data valid (structure was really filled)
m__BOOLEAN__IsDVD | Is this DVD media or not
m__USHORT__ProtectedDVDRegions | Number of protected DVD regions
m__UCHAR__BusKeyForDiscKey | Bus key for disc key (CSS)
m__UCHAR__NumberOfSessions | Number of sessions
m__UCHAR__NumberOfTracks | Number of tracks
m__UCHAR__NumberOfUnsortedEntries | Number of entries in unsorted raw TOC
m__TOC_ENTRY | TOC entries (decoded and extended)
m__FULL_TOC_ENTRY_RAW | Full TOC raw entries sorted, each entry corresponds to m__TOC_ENTRY with the same TNO
m__FULL_TOC_ENTRY_RAW__Unsorted | Full TOC raw entries unsorted
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_CONTROL_BLOCK Structure

UDF_CONTROL_BLOCK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_CONTROL_BLOCK {
  void * m__PVOID__Head;
  void * m__PVOID__SystemStructures;
  void * m__PVOID__Tail;
  void * m__PVOID__Body;
} * PUDF_CONTROL_BLOCK, UDF_CONTROL_BLOCK;
File

StarBurn.h

Description

Structure that represents UDF control block

Member | Definition
m__PVOID__Head | Pointer to the head of the linked list
m__PVOID__SystemStructures | Pointer to the allocated and formatted UDF system structures
m__PVOID__Tail | Pointer to the tail of the linked list
m__PVOID__Body | Pointer to block body itself
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FILE_EXTENT Structure

UDF_FILE_EXTENT Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_EXTENT {
  ULONG m__ULONG__BeginLBA;
  ULONG m__ULONG__EndLBA;
} UDF_FILE_EXTENT, * PUDF_FILE_EXTENT;
File

StarBurn.h

Description

Structure that describes a single file extent

Member | Definition
m__ULONG__BeginLBA | First LBA of the extent
m__ULONG__EndLBA | Last LBA of the extent
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FILE_HANDLE Structure

UDF_FILE_HANDLE Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_HANDLE {
  HANDLE m__HANDLE;
} * PUDF_FILE_HANDLE, UDF_FILE_HANDLE;
File

StarBurn.h

Description

Structure that represents UDF file handle

Member | Definition
m__HANDLE | Win32 file handle
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FILE_LOOKUP_ENTRY Structure

UDF_FILE_LOOKUP_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_FILE_LOOKUP_ENTRY {
  ULONG m__ULONG__Size;
  PWCHAR m__PCHAR__FileName;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
} UDF_FILE_LOOKUP_ENTRY, * PUDF_FILE_LOOKUP_ENTRY;
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function

Member | Definition
m__ULONG__Size | Entry size
m__PWCHAR__FileName | File name
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_LOOKUP_DIR_ENTRY Structure

UDF_LOOKUP_DIR_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_LOOKUP_DIR_ENTRY {
  PWCHAR m__PWCHAR__DirName;
  PVOID m__PVOID__ParentContext;
} UDF_LOOKUP_DIR_ENTRY, * PUDF_LOOKUP_DIR_ENTRY;
File

StarBurn.h

Description

Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__PWCHAR__DirName | Directory name
m__PVOID__ParentContext | The user context assigned to this directory
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_LOOKUP_FILE_ENTRY Structure

UDF_LOOKUP_FILE_ENTRY Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_LOOKUP_FILE_ENTRY {
  ULONG m__ULONG__EntrySize;
  PWCHAR m__PWCHAR__FileName;
  ULONGLONG m__QWORD__FileSize;
  UINT m__UINT__ExtentCount;
  PUDF_FILE_EXTENT m__Extents;
} UDF_LOOKUP_FILE_ENTRY, * PUDF_LOOKUP_FILE_ENTRY;
File

StarBurn.h

Description

Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function

Member | Definition
m__ULONG__EntrySize | Entry size
m__PWCHAR__FileName | File name
m__QWORD__FileSize | File size in bytes
m__UINT__ExtentCount | Number of file extents
m__Extents | Array of file extents
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_OS_CLASS Enumeration

UDF_OS_CLASS Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _UDF_OS_CLASS {
  UDF_OS_CLASS_UNDEFINED = 0x00,
  UDF_OS_CLASS_DOS = 0x01,
  UDF_OS_CLASS_OS_2 = 0x02,
  UDF_OS_CLASS_MACINTOSH_OS = 0x03,
  UDF_OS_CLASS_UNIX = 0x04,
  UDF_OS_CLASS_WINDOWS_9X = 0x05,
  UDF_OS_CLASS_WINDOWS_NT = 0x06,
  UDF_OS_CLASS_OS_400 = 0x07,
  UDF_OS_CLASS_BE_OS = 0x08,
  UDF_OS_CLASS_WINDOWS_CE = 0x09
} UDF_OS_CLASS;
File

StarBurn.h

Description

UDF OS class

Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_TREE_ITEM Structure

UDF_TREE_ITEM Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _UDF_TREE_ITEM {
  unsigned long m__ULONG__FileEntryRBA;
  unsigned long m__ULONG__FileIdentifierRBA;
  unsigned long m__ULONG__FileIdentifierParentOrContentRBA;
  unsigned long m__ULONG__LastTouchedRBA;
  unsigned long m__ULONG__GUID;
  unsigned char m__UCHAR__IsDirectory;
  unsigned char m__UCHAR__IsCached;
  unsigned short m__USHORT__NumberOfKidsAsParents;
  char m__CHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
  UDF_FILE_HANDLE m__UDF_FILE_HANDLE;
  unsigned char * m__PUCHAR__File;
  unsigned __int64 m__ULONGLONG__SizeInUCHARs;
  unsigned long m__ULONG__SizeInLogicalBlocks;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Next;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Prev;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Kids;
  struct _UDF_TREE_ITEM * m__PUDF_TREE_ITEM__Parent;
  unsigned char m__UCHAR__FileEntryDescriptor[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  unsigned char * m__PUCHAR__FileIdentifierDescriptor;
  unsigned long m__ULONG__FileIdentifierDescriptorSizeInUCHARs;
  unsigned char m__UCHAR__FileContent[ UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ];
  void * m__PVOID__Context;
  ISO9660_DATE_TIME m__ISO9660_DATE_TIME;
  WCHAR m__WCHAR__Name[ UDF_NAME_SIZE_IN_UCHARS ];
} * PUDF_TREE_ITEM, UDF_TREE_ITEM;
File

StarBurn.h

Description

Structure that represents UDF tree item

Member | Definition
m__ULONG__FileEntryRBA | File entry relative block address
m__ULONG__FileIdentifierRBA | File identifier relative block address
m__ULONG__FileIdentifier... | File identifier parent or content relative block address
m__ULONG__LastTouchedRBA | Last touched relative block address (last occupied)
m__ULONG__GUID | Globally unique identifier
m__UCHAR__IsDirectory | Is this directory (0x01) or file (0x00)
m__UCHAR__IsCached | Is this entry content cached (located in memory) or not cached (located on the disk)
m__USHORT_NumberOfKidsAsParents | Number of kids that have their own kids
m__CHAR__Name | Name of this node
m__UDF_FILE_HANDLE | UDF file handle of this node
m__PUCHAR__File | Pointer to file content (for cached files)
m__ULONGLONG__SizeInUCHARs | Node content size in UCHARs
m__ULONG__SizeInLogicalBlocks | Node content size in logical blocks
m__PUDF_TREE_ITEM__Next | Pointer to the next UDF tree item in the linked list
m__PUDF_TREE_ITEM__Prev | Pointer to the previous UDF tree item in the linked list
m__PUDF_TREE_ITEM__Kids | Pointer to the kids liked list
m__PUDF_TREE_ITEM__Parent | Pointer to the parent of the current UDF tree item
m__UCHAR__FileEntryDescriptor | Array if UCHARs holding UDF file entry descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for current UDF tree item
m__UCHAR__FileIdentifier... | Array of UCHARs holding UDF file identifier descriptor for parent of the current UDF tree item
m__UCHAR__FileContent | Array of UCHARs holding file content (alternative cached data)
m__PVOID__Context | Pointer to context value
m__ISO9660_DATE_TIME | ISO9660 date and time
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_VERSION Enumeration

UDF_VERSION Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _UDF_VERSION {
  UDF_VERSION_1_02 = 0,
  UDF_VERSION_1_50,
  UDF_VERSION_2_00,
  UDF_VERSION_2_01,
  UDF_VERSION_2_50,
  UDF_VERSION_2_60
} UDF_VERSION;
File

StarBurn.h

Description

Enum that represents UDF version

Member | Definition
UDF_VERSION_1_02 | UDF 1.02
UDF_VERSION_1_50 | UDF 1.5
UDF_VERSION_2_00 | UDF 2.0
UDF_VERSION_2_01 | UDF 2.01
UDF_VERSION_2_50 | UDF 2.5
UDF_VERSION_2_60 | UDF 2.6
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_HEADER Structure

WAVE_FILE_HEADER Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _WAVE_FILE_HEADER {
  ULONG m__ULONG__Riff;
  ULONG m__ULONG__Length;
  ULONG m__ULONG__Wave;
  ULONG m__ULONG__FormatTag;
  ULONG m__ULONG__FormatLength;
  WAVE_FORMAT_CHUNK m__WAVE_FORMAT_CHUNK;
  ULONG m__ULONG__DataTag;
  ULONG m__ULONG__DataLength;
} * PWAVE_FILE_HEADER, WAVE_FILE_HEADER;
File

StarBurn.h

Description

Structure that represents WAVE file header

Member | Definition
m__ULONG__Riff | Riff signature
m__ULONG__Length | Length of data section (w/o header) in UCHARs
m__ULONG__Wave | Wave signature
m__ULONG__FormatTag | Format tag
m__ULONG__FormatLength | Format length (size of WAVE_FORMAT_CHUNK in UCHARs)
m__WAVE_FORMAT_CHUNK | WAVE format chunk (see WAVE_FORMAT_CHUNK for more details)
m__ULONG__DataTag | Data tag
m__ULONG__DataLenght | Data length in UCHARs
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FORMAT_CHUNK Structure

WAVE_FORMAT_CHUNK Structure
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef struct _WAVE_FORMAT_CHUNK {
  USHORT m__USHORT__Format;
  USHORT m__USHORT__Channels;
  ULONG m__ULONG__SamplesPerSecond;
  ULONG m__ULONG__AverageSamplesPerSecond;
  USHORT m__USHORT__Alignment;
  USHORT m__USHORT__BitsPerSample;
} * PWAVE_FORMAT_CHUNK, WAVE_FORMAT_CHUNK;
File

StarBurn.h

Description

Structure that represents WAVE format chunk

Member | Definition
m__USHORT__Format | Format
m__USHORT__Channels | Number of channels
m__ULONG__SamplesPerSecond | Number of samples per second
m__ULONG__AverageSamplesPerSecond | Number of average samples per second
m__USHORT__Alignment | Alignment
m__USHORT__BitsPerSample | Number of bits in single sample
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WRITE_MODE Enumeration

WRITE_MODE Enumeration
StarBurn.h | Structs, Records, Enums
Collapse All
C++
typedef enum _WRITE_MODE {
  WRITE_MODE_TRACK_AT_ONCE = 0,
  WRITE_MODE_SESSION_AT_ONCE,
  WRITE_MODE_DISC_AT_ONCE_PQ,
  WRITE_MODE_DISC_AT_ONCE_RAW_PW
} * PWRITE_MODE, WRITE_MODE;
File

StarBurn.h

Description

Enum that represents write modes

Member | Definition
WRITE_MODE_TRACK_AT_ONCE | Track-At-Once
WRITE_MODE_SESSION_AT_ONCE | Session-At-Once
WRITE_MODE_DISC_AT_ONCE_PQ | Disc-At-Once PQ
WRITE_MODE_DISC_AT_ONCE_RAW_PW | Disc-At-Once raw P-W
Group

Structs, Records, Enums

Links
StarBurn.h, Structs, Records, Enums
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Types

Types
Types
Collapse All

The following table lists types in this documentation.

Types
Name | Description
CFuncStarWaveConversionCallback | type of callback function
PCALLBACK | Callback type (function of this type must be passed as callback)
PSTARBURN_CLOSEHANDLE_CALLBACK | This is type PSTARBURN_CLOSEHANDLE_CALLBACK.
PSTARBURN_CREATEFILE_CALLBACK | This is type PSTARBURN_CREATEFILE_CALLBACK.
PSTARBURN_DELETEFILE_CALLBACK | This is type PSTARBURN_DELETEFILE_CALLBACK.
PSTARBURN_FILE_OBJECT | Structure that represents StarBurn file object used internally with file I/O
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | This is type PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK.
PSTARBURN_ISO2_COLLISION_CALLBACK | StarBurn ISO name collision handling callback
PSTARBURN_ISO2_PROGRESS_CALLBACK | StarBurn ISO progress callback
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK | StarBurn ISO Unicode name collision handling callback
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK | StarBurn ISO UNICODE progress callback
PSTARBURN_ISO9660_READ_CALLBACK | StarBurn ISO2 read callback (for import)
PSTARBURN_READFILE_CALLBACK | This is type PSTARBURN_READFILE_CALLBACK.
PSTARBURN_SET_FILE_POINTER_CALLBACK | This is type PSTARBURN_SET_FILE_POINTER_CALLBACK.
PSTARBURN_STARWAVE_CALLBACK | StarWave callback passed to I/O functions. Return anything except zero from it to cancel I/O operation
PSTARBURN_UDF2_COLLISION_CALLBACK_EX | StarBurn UDF ansi name collision handling callback
PSTARBURN_UDF2_IMPORT_CALLBACK | StarBurn UDF2 import callback
PSTARBURN_UDF2_PROGRESS_CALLBACK | StarBurn UDF2 progress callback
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX | StarBurn UDF Unicode name collision handling callback
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK | StarBurn UDF2 UNICODE progress callback
PSTARBURN_WRITEFILE_CALLBACK | This is type PSTARBURN_WRITEFILE_CALLBACK.
Links
Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CFuncStarWaveConversionCallback Type

CFuncStarWaveConversionCallback Type
StarBurn.h | Types
Collapse All
C++
typedef void (__stdcall * CFuncStarWaveConversionCallback)(BYTE i_progress, BOOL* op_stop, PVOID ip_user_data);
File

StarBurn.h

Description

type of callback function

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PCALLBACK Type

PCALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef VOID (__stdcall * PCALLBACK)(IN CALLBACK_NUMBER p__CALLBACK_NUMBER, IN PVOID p__PVOID__CallbackContext, OUT PVOID p__PVOID__CallbackSpecial1, OUT PVOID p__PVOID__CallbackSpecial2);
File

StarBurn.h

Parameters
Parameters | Description
p__CALLBACK_NUMBER | Callback number
p__PVOID__CallbackContext | Passed callback context
p__PVOID__CallbackSpecial1 | Special parameter 1
p__PVOID__CallbackSpecial2 | Special parameter 2
Description

Callback type (function of this type must be passed as callback)

Remarks
Callback number | Special parameter 1 | Special parameter 2
CN_FILE_TREE_PROGRESS_ADD | (PCHAR) Adding item name | Not used
CN_FILE_TREE_PROGRESS_REMOVE | (PCHAR) Removing item name | Not used
CN_FILE_TREE_PROGRESS_IGNORE | (PCHAR) Ignoring item name | Not used
CN_FILE_TREE_PROGRESS_NAME_COLLISION | (PNAME_COLLISION_INFO) Collision info | Not used
CN_TARGET_FILE_ANALYZE_BEGIN | Not used | Not used
CN_TARGET_FILE_ANALYZE_END | (PLARGE_INTEGER) Target file size in UCHARs | (PLARGE_INTEGER) Target file size in LBs
CN_WAIT_CACHE_FULL_BEGIN | (PULONG) Wait time in milliseconds | Not used
CN_WAIT_CACHE_FULL_END | Not used | Not used
CN_SYNCHRONIZE_CACHE_BEGIN | Not used | Not used
CN_SYNCHRONIZE_CACHE_END | Not used | Not used
CN_FIND_DEVICE | (PSCSI_DEVICE_ADDRESS) SCSI device address | Not used
CN_CDVD_READ_PROGRESS | (PLARGE_INTEGER) Track size in LBs | (PLARGE_INTEGER) LBs readen
CN_CDVD_WRITE_PROGRESS | (PLARGE_INTEGER) File size in LBs | (PLARGE_INTEGER) LBs written
CN_CDVD_BUFFER_STATUS | (PULONG) Buffer size in UCHARs | (PULONG) Buffer free size in UCHARs
CN_CDVD_TRACK_BEGIN | (PULONG) Started track number | (PULONG) Total number of tracks
CN_CDVD_TRACK_END | (PULONG) Completed track number | (PULONG) Total number of track
CN_CDVD_SPLIT_BEGIN | (PLONG) Started split section number | (PLONG) Total number of tracks
CN_CDVD_SPLIT_END | (PLONG) Completed split section number | (PLONG) Total number of tracks
CN_CDVD_READ_BAD_BLOCK_HIT | (PLONG) LBA of bad blocks | (PULONG) Number of bad blocks
CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT | (PLONG) LBA of ECC/EDC bad blocks | (PULONG) Number of ECC/EDC bad blocks
CN_CDVD_READ_RETRY | (PLONG) LBA of retry reading blocks | (PULONG) Number of retry reading LBs
CN_DVDPLUSRW_FORMAT_BEGIN | Not used | Not used
CN_DVDPLUSRW_FORMAT_END | Not used | Not used
CN_DVDRAM_FORMAT_BEGIN | Not used | Not used
CN_DVDRAM_FORMAT_END | Not used | Not used
CN_BUFFER_UNDERRUN | Not used | Not used
CN_DVD_MEDIA_PADDING_SIZE | (PLARGE_INTEGER) Target file size in LBs | (PULONG) Track padding size in LBs
CN_DVD_MEDIA_PADDING_BEGIN | Not used | Not used
CN_DVD_MEDIA_PADDING_END | Not used | Not used
CN_CDVD_READ_CANCEL_QUERY | Undocumented | Undocumented
CN_DVDRW_QUICK_FORMAT_BEGIN | Not used | Not used
CN_DVDRW_QUICK_FORMAT_END | Not used | Not used
CN_DVD_TEST_WRITE_DISABLED | Not used | Not used
CN_CDVD_DPM_BEGIN | Undocumented | Undocumented
CN_CDVD_DPM_END | Undocumented | Undocumented
CN_CDVD_DPM_PROGRESS | Undocumented | Undocumented
CN_CDVD_VERIFY_PROGRESS | (PLONG) Processed LBs | (PLONG) Size in LBs
CN_SAO_TRACK_WRITE_BEGIN | (PLONG) Track index | Not used
CN_SAO_TRACK_WRITE_END | (PLONG) Track index | Not used
CN_DVD_MEDIA_PADDING_WRITE_PROGRESS | (PULONG) Track padding size in LBs | (PLONG) Padding left in LBs
CN_CDVD_WRITE_BEGIN | Not used | Not used
CN_CDVD_WRITE_END | Not used | Not used
CN_CDVD_VERIFY_BEGIN | Not used | Not used
CN_CDVD_VERIFY_END | Not used | Not used
CN_UDF_FILE_LOOKUP | (PUDF_FILE_LOOKUP_ENTRY) File information | Not used
Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_CLOSEHANDLE_CALLBACK Type

PSTARBURN_CLOSEHANDLE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef BOOL (__stdcall * PSTARBURN_CLOSEHANDLE_CALLBACK)(HANDLE hObject, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_CLOSEHANDLE_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_CREATEFILE_CALLBACK Type

PSTARBURN_CREATEFILE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef HANDLE (__stdcall * PSTARBURN_CREATEFILE_CALLBACK)(LPCSTR lpFileName, DWORD dwDesiredAccess, DWORD dwShareMode, DWORD dwCreationDisposition, DWORD dwFlagsAndAttributes, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_CREATEFILE_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_DELETEFILE_CALLBACK Type

PSTARBURN_DELETEFILE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef BOOL (__stdcall * PSTARBURN_DELETEFILE_CALLBACK)(LPCSTR lpFileName, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_DELETEFILE_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_FILE_OBJECT Type

PSTARBURN_FILE_OBJECT Type
StarBurn.h | Types
Collapse All
C++
typedef struct _STARBURN_FILE_OBJECT * PSTARBURN_FILE_OBJECT;
File

StarBurn.h

Description

Structure that represents StarBurn file object used internally with file I/O

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK Type

PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef BOOL (__stdcall * PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK)(HANDLE hFile, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ISO2_COLLISION_CALLBACK Type

PSTARBURN_ISO2_COLLISION_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_ISO2_COLLISION_CALLBACK)(char *p__PCHAR__NameBuffer, unsigned long p__ULONG__BufferSize, unsigned char p__UCHAR__IsDirectory, long p__LONG__CollisionError, const void *p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PCHAR__NameBuffer | Pointer to the file name (zero-terminated ANSI string)
p__ULONG__BufferSize | Size of Name buffer in UCHARs
p__UCHAR__IsDirectory | Non-zero if it is a directory, zero if it is a file
p__LONG__CollisionError | Size of Name buffer in UCHARs
p__PVOID__Context | Passed callback context
Description

StarBurn ISO name collision handling callback

Remarks

Check StarBurn_ISO2_DirectoryProcess(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ISO2_PROGRESS_CALLBACK Type

PSTARBURN_ISO2_PROGRESS_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_ISO2_PROGRESS_CALLBACK)(const char *p__PCHAR__Name, const unsigned short *p__PUSHORT__UnicodePathName, long p__LONG__Result, const void *p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PCHAR__Name | Pointer to the file name added
p__PUSHORT__UnicodePathName | Pointer to the full path & name of the file added (Unicode)
p__LONG__Result | result code of file adding
p__PVOID__Context | Passed callback context
Description

StarBurn ISO progress callback

Remarks

Check StarBurn_ISO2_DirectoryProcess(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK Type

PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK)(unsigned short *p__PUSHORT__NameBuffer, unsigned long p__ULONG__BufferSize, unsigned char p__UCHAR__IsDirectory, long p__LONG__CollisionError, const void *p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PUSHORT__NameBuffer | Pointer to the file name (zero-terminated Unicode string)
p__ULONG__BufferSize | Size of Name buffer in UCHARs
p__UCHAR__IsDirectory | Non-zero if it is a directory, zero if it is a file
p__LONG__CollisionError | Size of Name buffer in UCHARs
p__PVOID__Context | Passed callback context
Description

StarBurn ISO Unicode name collision handling callback

Remarks

Check StarBurn_ISO2_DirectoryProcess(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Type

PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK)(const unsigned short *p__PUSHORT__UnicodeName, const unsigned short *p__PUSHORT__UnicodePathName, long p__LONG__Result, const void *p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PUSHORT__UnicodeName | Pointer to the UNICODE file name added
p__PUSHORT__UnicodePathName | Pointer to the UNICODE full path & name of the file added
p__LONG__Result | result code of file adding
p__PVOID__Context | Passed callback context
Description

StarBurn ISO UNICODE progress callback

Remarks

Check StarBurn_ISO2_DirectoryUnicodeProcess(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_ISO9660_READ_CALLBACK Type

PSTARBURN_ISO9660_READ_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_ISO9660_READ_CALLBACK)(LONG p__LONG__LBA, PVOID p__PVOID_Buffer, ULONG p__ULONG__BufferSizeInUCHARs, PVOID p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__LONG__LBA | Logical block address to read content from
p__PVOID__Buffer | Pointer to buffer to store read content to
p__ULONG__BufferSizeInUCHARs | Buffer size in unsigned chars
p__PVOID__Context | Passed callback context
Description

StarBurn ISO2 read callback (for import)

Remarks

Check StarBurn_ISO2_ImpVolumeImport(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_READFILE_CALLBACK Type

PSTARBURN_READFILE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef BOOL (__stdcall * PSTARBURN_READFILE_CALLBACK)(HANDLE hFile, LPVOID lpBuffer, DWORD nNumberOfBytesToRead, LPDWORD lpNumberOfBytesRead, LPOVERLAPPED lpOverlapped, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_READFILE_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_SET_FILE_POINTER_CALLBACK Type

PSTARBURN_SET_FILE_POINTER_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef DWORD (__stdcall * PSTARBURN_SET_FILE_POINTER_CALLBACK)(HANDLE hFile, LONG lDistanceToMove, PLONG lpDistanceToMoveHigh, DWORD dwMoveMethod, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_SET_FILE_POINTER_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_STARWAVE_CALLBACK Type

PSTARBURN_STARWAVE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef ULONG (__stdcall * PSTARBURN_STARWAVE_CALLBACK)(IN ULONG p__ULONG__Reason, IN ULONG p__ULONG__Parameter, IN PVOID p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__ULONG__Reason | Callback reason (see STARBURN_STARWAVE_CALLBACK_REASON enumeration)
p__ULONG__Parameter | Callback parameter
p__PVOID__Context | Passed callback context
Description

StarWave callback passed to I/O functions. Return anything except zero from it to cancel I/O operation

Remarks
Callback reason | Callback parameter
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS | Completion percent
Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_UDF2_COLLISION_CALLBACK_EX Type

PSTARBURN_UDF2_COLLISION_CALLBACK_EX Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_UDF2_COLLISION_CALLBACK_EX)(char *NameBuffer, unsigned long BufferSize, unsigned char IsDirectory, long CollisionError, const void *Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PUSHORT__NameBuffer | Pointer to the file name (zero-terminated ansi string)
p__ULONG__BufferSize | Size of Name buffer in UCHARs
p__UCHAR__IsDirectory | Non-zero if it is a directory, zero if it is a file
p__LONG__CollisionError | Size of Name buffer in UCHARs
p__PVOID__Context | Passed callback context
Description

StarBurn UDF ansi name collision handling callback

Remarks

Check StarBurn_UDF2_DirectoryContentsUnicodeProcessEx(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_UDF2_IMPORT_CALLBACK Type

PSTARBURN_UDF2_IMPORT_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_UDF2_IMPORT_CALLBACK)(LONG p__LONG__LBA, PVOID p__PVOID_Buffer, ULONG p__ULONG__BufferSizeInUCHARs, PVOID p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__LONG__LBA | Logical block address to read content from
p__PVOID__Buffer | Pointer to buffer to store read content to
p__ULONG__BufferSizeInUCHARs | Buffer size in unsigned chars
p__PVOID__Context | Passed callback context
Description

StarBurn UDF2 import callback

Remarks

Check StarBurn_UDF2_ImpVolumeImport(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_UDF2_PROGRESS_CALLBACK Type

PSTARBURN_UDF2_PROGRESS_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_UDF2_PROGRESS_CALLBACK)(PCHAR p__PCHAR__Name, PCHAR p__PCHAR__PathName, PVOID p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PCHAR__Name | Pointer to the file name added
p__PCHAR__PathName | Pointer to the full path & name of the file added
p__PVOID__Context | Passed callback context
Description

StarBurn UDF2 progress callback

Remarks

Check StarBurn_UDF2_DirectoryProcessEx(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX Type

PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX)(unsigned short* p__PUSHORT__NameBuffer, unsigned long p__ULONG__BufferSize, unsigned char p__UCHAR__IsDirectory, long p__LONG__CollisionError, const void* p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PUSHORT__NameBuffer | Pointer to the file name (zero-terminated Unicode string)
p__ULONG__BufferSize | Size of Name buffer in UCHARs
p__UCHAR__IsDirectory | Non-zero if it is a directory, zero if it is a file
p__LONG__CollisionError | Size of Name buffer in UCHARs
p__PVOID__Context | Passed callback context
Description

StarBurn UDF Unicode name collision handling callback

Remarks

Check StarBurn_UDF2_DirectoryContentsUnicodeProcessEx(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Type

PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef LONG (__stdcall * PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK)(PUSHORT p__PUSHORT__UnicodeName, PUSHORT p__PUSHORT__UnicodePathName, PVOID p__PVOID__Context);
File

StarBurn.h

Parameters
Parameters | Description
p__PUSHORT__UnicodeName | Pointer to the UNICODE file name added
p__PUSHORT__UnicodePathName | Pointer to the UNICODE full path & name of the file added
p__PVOID__Context | Passed callback context
Description

StarBurn UDF2 UNICODE progress callback

Remarks

Check StarBurn_UDF2_DirectoryUnicodeProcessEx(...) API call

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PSTARBURN_WRITEFILE_CALLBACK Type

PSTARBURN_WRITEFILE_CALLBACK Type
StarBurn.h | Types
Collapse All
C++
typedef BOOL (__stdcall * PSTARBURN_WRITEFILE_CALLBACK)(HANDLE hFile, LPCVOID lpBuffer, DWORD nNumberOfBytesToWrite, LPDWORD lpNumberOfBytesWritten, LPOVERLAPPED lpOverlapped, PDWORD pdwError);
File

StarBurn.h

Description

This is type PSTARBURN_WRITEFILE_CALLBACK.

Group

Types

Links
StarBurn.h, Types
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Macros

Macros
Macros
Collapse All

The following table lists macros in this documentation.

Macros
Name | Description
__STARBURN_H__ | Define StarBurn.h to avoid including it more then once
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS | ASPI safe buffer size in UCHARs. ASPI is assumed to support at least 64KB large transfer per time. 64KB - PAGE_SIZE_IN_UCHARS was old default value. Now we'll use DVD_ECC_BLOCK_SIZE_IN_UCHARS as it's smaller and produce better results when dealing with DVD media
AUDIO_LB_SIZE_IN_UCHARS | Audio LB (logical block) size in UCHARs
BLURAY_SPEED_IN_KBPS_1X | Actually 4495.5
BLURAY_SPEED_IN_KBPS_2X | 2X Blu-Ray speed constant (BD-R and BD-RE)
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS | Default buffer status report delay in seconds
CACHE_SIZE_IN_MBS | 64
CD_SPEED_IN_KBPS_10X | 10X CD speed constant
CD_SPEED_IN_KBPS_12X | 12X CD speed constant
CD_SPEED_IN_KBPS_16X | 16X CD speed constant
CD_SPEED_IN_KBPS_1X | 1X CD speed constant
CD_SPEED_IN_KBPS_20X | 20X CD speed constant
CD_SPEED_IN_KBPS_24X | 24X CD speed constant
CD_SPEED_IN_KBPS_2P2X | 2.2X CD speed constant
CD_SPEED_IN_KBPS_2X | 2X CD speed constant
CD_SPEED_IN_KBPS_32X | 32X CD speed constant
CD_SPEED_IN_KBPS_36X | 36X CD speed constant
CD_SPEED_IN_KBPS_3X | 3X CD speed constant
CD_SPEED_IN_KBPS_40X | 40X CD speed constant
CD_SPEED_IN_KBPS_44X | 44X CD speed constant
CD_SPEED_IN_KBPS_48X | 48X CD speed constant
CD_SPEED_IN_KBPS_4X | 4X CD speed constant
CD_SPEED_IN_KBPS_52X | 52X CD speed constant
CD_SPEED_IN_KBPS_56X | 56X CD speed
CD_SPEED_IN_KBPS_6X | 6X CD speed constant
CD_SPEED_IN_KBPS_72X | 72X CD speed
CD_SPEED_IN_KBPS_8X | 8X CD speed constant
CDVD_SPEED_IS_KBPS_MAXIMUM | Top supported CD/DVD/Blu-Ray/HD-DVD speed constant (wildcard)
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES | Default number of read retries during verification process
DEVICES_PER_BUS | Top number of SCSI devices per logical SCSI bus (was 15 originally)
DISC_STATUS_COMPLETE | Disc is complete
DISC_STATUS_EMPTY | Disc is empty
DISC_STATUS_INCOMPLETE | Disc is incomplete
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Doubled...
DVD_ECC_BLOCK_SIZE_IN_LBS | DVD ECC block size in logical blocks (2048 UCHARs each)
DVD_ECC_BLOCK_SIZE_IN_UCHARS | DVD ECC block size in UCHARs. This is true "hardware" logical block size on DVD. It's recommended to have transfers of this size and this size aligned
DVD_PROTECTION_CPRM | DVD with CPRM (Copy-Protected Removable Media) protection
DVD_PROTECTION_CSS | DVD with CSS (Content Scrambling System) protection
DVD_PROTECTION_NONE | DVD w/o any protection system
DVD_SPEED_IN_KBPS_10X | 10X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_12X | 12X DVD speed constant (DVD-R, DVD+R)
DVD_SPEED_IN_KBPS_16X | 16X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_18X | 18X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_1X | 1X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_20X | 20X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_22X | 22X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_24X | 24X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_2DOT4X | 2.4X DVD speed constant (DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_2X | 2X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_32X | 32X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_3X | 3X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_40X | 40X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_48X | 48X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_4X | 4X DVD speed constant (DVD-R, DVD-R DL, DVD-RW, DVD+R, DVD+R DL, DVD+RW and DVD-RAM)
DVD_SPEED_IN_KBPS_50X | 50X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_5X | 5X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_6X | 6X DVD speed constant (DVD-RW)
DVD_SPEED_IN_KBPS_8X | 8X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
ELTORITO_BOOTABLE | Bootable disc ID
ELTORITO_BOOTSYSTEM_ID | Bootable specification signature
ELTORITO_DEF_LOAD_SEGMENT | Real mode code load segment
ELTORITO_NON_BOOTABLE | Non-bootable disc ID
ERROR_FIELD_C2_AND_BLOCK_ERROR | C2 and block error information
ERROR_FIELD_C2_ERROR | C2 error information
ERROR_FIELD_NO_ERROR | No error information
ERROR_FIELD_RESERVED | Reserved
EXPECTED_LB_TYPE_ANY | Accept all LBs
EXPECTED_LB_TYPE_CDDA | Accept only CDDA (CD digital audio) LBs
EXPECTED_LB_TYPE_MODE1 | Accept only MODE1 LBs
EXPECTED_LB_TYPE_MODE2 | Accept only MODE2 LBs (both Form1 and Form2)
EXPECTED_LB_TYPE_MODE2_FORM1 | Accept only MODE2 Form1 LBs
EXPECTED_LB_TYPE_MODE2_FORM2 | Accept only MODE2 Form2 LBs
HARD_DISK_LB_SIZE_IN_UCHARS | Hard disk LB (logical block) size in UCHARs
HEADER_CODE_ALL_HEADERS | Both header and subheader
HEADER_CODE_HEADER_ONLY | 4-byte header
HEADER_CODE_NONE | No header
HEADER_CODE_SUBHEADER_ONLY | MODE2 Form1 or Form2 subheader
ISO9660_DATE_SIZE_IN_UCHARS | ISO9660 date size in UCHARs
ISO9660_FILE_SIZE_IN_UCHARS | ISO9660 file size in UCHARs
ISO9660_NAME_SIZE_IN_UCHARS | ISO9660 name size in UCHARs
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS | ISO9660 volume descriptor system and volume ID size in UCHARs
ISO9660_TREE_LEVEL | ISO9660 top supported file tree level
LAST_SESSION_COMPLETE | Last session is complete
LAST_SESSION_EMPTY | Last session is empty
LAST_SESSION_INCOMPLETE | Last session is incomplete
MODE1_LB_SIZE_IN_UCHARS | MODE1 LB (logical block) size in UCHARs
MODE2_FORM1_LB_SIZE_IN_UCHARS | MODE2 Form1 LB (logical block) size in UCHARs
MODE2_FORM2_LB_SIZE_IN_UCHARS | MODE2 Form2 LB (logical block) size in UCHARs
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS | MODE2 Form2 + 8 UCHARs of subheader LB (logical block) size in UCHARs
MODE2_FORMLESS_LB_SIZE_IN_UCHARS | MODE2 Formless LB (logical block) size in UCHARS
NUMBER_OF_RAW_TRACKS | Top number of raw tracks (including maintenance tracks) on CD/DVD/Blu-Ray/HD-DVD disc. This is calculated based on the worst CD case when all tracks will be in a separate sessions. We need this approximate value to avoid allocating TOC_INFORMATION structure dynamically.
NUMBER_OF_READ_RETRIES | Default number of retries on read operations (if bad block was possibly hit, was 2 originally)
NUMBER_OF_SUBCHANNELS | sub-channels from P to W
NUMBER_OF_TRACKS | Top number of tracks (or border-in/border-out zones) on CD/DVD/Blu-Ray/HD-DVD disc
PAGE_SIZE_IN_UCHARS | Small page size in UCHARs on x86 machines (default allocatable storage)
RAW_LB_PQ_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with PQ sub-channel size in UCHARs
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with RAW P-W sub-channel size in UCHARs
RAW_LB_SIZE_IN_UCHARS | RAW LB (logical block) size in UCHARs
READ_REPORT_DELAY_IN_SECONDS | Default read report delay in seconds
SCSI_DEVICE_DIRECT_ACCESS | SCSI disk device
SCSI_DEVICE_MAGNETO_OPTICAL | SCSI MO (Magneto-Optical) disk device
SCSI_DEVICE_MEDIUM_CHANGER | SCSI jukebox (disc changer) device
SCSI_DEVICE_NETWORK | SCSI network device
SCSI_DEVICE_PRINTER | SCSI printer device
SCSI_DEVICE_PROCESSOR | SCSI processor device
SCSI_DEVICE_RO_DIRECT_ACCESS | SCSI CD/DVD/Blu-Ray/HD-DVD device
SCSI_DEVICE_SCANNER | SCSI scanner device
SCSI_DEVICE_SEQUENTIAL_ACCESS | SCSI tape device
SCSI_DEVICE_UNPRESENT | SCSI device... Is gone!
SCSI_DEVICE_WILDCARD | SCSI device any (wildcard for StarBurn_FindDevice() function)
SCSI_DEVICE_WORM | SCSI WORM (Write-Once-Read-Multiple) device
SHORT_RAW_LB_SIZE_IN_UCHARS | Short (w/o sync and header) RAW LB (logical block) size in UCHARs
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Number of logical blocks on single layer DVD
SMALLEST_CACHE_SIZE_IN_MBS | Smallest cache size in MBs that toolkit will allow to use to buffer "write" operations
SMALLEST_CACHE_SIZE_IN_UCHARS | Smallest cache size in UCHARs that toolkit will allow to use to buffer "write" operations
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_FULL.
STARBURN_BDRE_FORMAT_CERTIFICATION_NO | BD-RE format certification types
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK.
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED.
STARBURN_BDRE_FORMAT_DEFAULT | BD-RE format types
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION | This is macro STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION.
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITH_SPARE_AREA.
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA.
STARBURN_CACHE_SIZE_READ_ONLY | Default cache size for I/O operations
STARBURN_CACHE_SIZE_READ_WRITE | This is macro STARBURN_CACHE_SIZE_READ_WRITE.
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED.
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY | File attributes ( flags for Attributes member of STARBURN_UDF2_FILE_INFO & STARBURN_ISO2_FILE_INFO )
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN.
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT | This is macro StarBurn_CdvdBurnerGrabber_GetDeviceInformationT.
StarBurn_CdvdBurnerGrabber_GrabTrackT | This is macro StarBurn_CdvdBurnerGrabber_GrabTrackT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDT.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT | This is macro StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT.
StarBurn_CdvdBurnerGrabber_VerifyFileExT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileExT.
StarBurn_CdvdBurnerGrabber_VerifyFileT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileT.
StarBurn_CdvdBurnerGrabber_VideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExExT.
StarBurn_CdvdBurnerGrabber_VideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExT.
StarBurn_CdvdBurnerGrabber_VideoCDT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDT.
STARBURN_DEBUG_FACILITY_ALLMESSAGES | Debug facility: Permit All Messages
STARBURN_DEBUG_FACILITY_ALLTARGETS | Debug facility: All targets
STARBURN_DEBUG_FACILITY_CUSTOM | Debug facility: Custom
STARBURN_DEBUG_FACILITY_DEBUG | Debug facility: Permit Debug Messages
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT | Debug facility: Debug output
STARBURN_DEBUG_FACILITY_ERROR | Debug facility: Permit Error Messages
STARBURN_DEBUG_FACILITY_LOG_FILE | Debug facility: Log file
STARBURN_DEBUG_FACILITY_NONE | Debug facility: None
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE | Debug facility: System console
STARBURN_DEBUG_FACILITY_TRACE | Debug facility: Permit Trace Messages
STARBURN_DEBUG_FACILITY_WARNING | Debug facility: Permit Warning Messages
STARBURN_DISC_TYPE_CDDA | Disc type is CDDA (CD-ROM or Digital Audio)
STARBURN_DISC_TYPE_CDI | Disc type is CDI
STARBURN_DISC_TYPE_UNDEFINED | Disc type is undefined
STARBURN_DISC_TYPE_XA | Disc type is CD-ROM XA
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES | DVD-Video maximum number of titles
StarBurn_DVDVideo_CreateT | This is macro StarBurn_DVDVideo_CreateT.
StarBurn_ElTorito_BootCatalogAddSectionT | This is macro StarBurn_ElTorito_BootCatalogAddSectionT.
StarBurn_ElTorito_CreateBootCatalogT | This is macro StarBurn_ElTorito_CreateBootCatalogT.
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARs_FastT.
StarBurn_GetAudioFileStreamSizeInUCHARsT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARsT.
StarBurn_GetDeviceLetterT | TCHAR functions
STARBURN_IMPEX_API | declspec( dllexport )
StarBurn_IsAudioFileSupportedT | This is macro StarBurn_IsAudioFileSupportedT.
StarBurn_ISO2_VolumeCreateBootElToritoT | This is macro StarBurn_ISO2_VolumeCreateBootElToritoT.
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE | This is macro STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE.
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY | This is macro STARBURN_ISO9660_FILE_FLAGS_DIRECTORY.
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE | This is macro STARBURN_ISO9660_FILE_FLAGS_EXISTENCE.
STARBURN_ISO9660_FILE_FLAGS_NONE | ISO9660 file attributes flags
STARBURN_ISO9660_FILE_FLAGS_RECORD | This is macro STARBURN_ISO9660_FILE_FLAGS_RECORD.
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS | ( 4GB - 1 )
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS | This is macro STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS.
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS |
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS | ISO9660 constants (begin)
STARBURN_ISO9660_TYPE_1999 | This is macro STARBURN_ISO9660_TYPE_1999.
STARBURN_ISO9660_TYPE_JOLIET | This is macro STARBURN_ISO9660_TYPE_JOLIET.
STARBURN_ISO9660_TYPE_JOLIET_RELAXED | This is macro STARBURN_ISO9660_TYPE_JOLIET_RELAXED.
STARBURN_ISO9660_TYPE_LEVEL1 | ISO9660 file system type
STARBURN_ISO9660_TYPE_LEVEL2 | This is macro STARBURN_ISO9660_TYPE_LEVEL2.
STARBURN_LOADING_MECHANISM_TYPE_CADDY | Loading mechanism type constants
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE | This is macro STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE.
STARBURN_LOADING_MECHANISM_TYPE_CHANGER | This is macro STARBURN_LOADING_MECHANISM_TYPE_CHANGER.
STARBURN_LOADING_MECHANISM_TYPE_POP_UP | This is macro STARBURN_LOADING_MECHANISM_TYPE_POP_UP.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED1.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED2.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED3.
STARBURN_LOADING_MECHANISM_TYPE_TRAY | This is macro STARBURN_LOADING_MECHANISM_TYPE_TRAY.
STARBURN_PIPE_SIZE_IN_UCHARS | 60, 64 or 32 KB I/O packets
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS | StarBurn smallest split file size in megabytes
StarBurn_StarWave_CompressedFileReaderObjectCreateT | This is macro StarBurn_StarWave_CompressedFileReaderObjectCreateT.
StarBurn_StarWave_CompressedFileRecompressT | This is macro StarBurn_StarWave_CompressedFileRecompressT.
StarBurn_StarWave_CompressedFileUncompressT | This is macro StarBurn_StarWave_CompressedFileUncompressT.
StarBurn_StarWave_CompressedFileWriterObjectCreateT | This is macro StarBurn_StarWave_CompressedFileWriterObjectCreateT.
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS | StarWave recommended I/O buffer size in UCHARs. It's *STRONGLY* recommended to use either it or multiplications of STARWAVE_IO_BUFFER_SIZE_IN_UCHARS as internal calculations and indexations are integer rather then float based
StarBurn_StarWave_UncompressedFileCompressT | This is macro StarBurn_StarWave_UncompressedFileCompressT.
StarBurn_StarWave_UncompressedFileSupportedIsT | This is macro StarBurn_StarWave_UncompressedFileSupportedIsT.
StarBurn_StarWave2_ConvertExT | This is macro StarBurn_StarWave2_ConvertExT.
StarBurn_StarWave2_EncodeMP3OGGFromWAVT | This is macro StarBurn_StarWave2_EncodeMP3OGGFromWAVT.
StarBurn_StarWave2_GetFileReaderAndFactoryT | This is macro StarBurn_StarWave2_GetFileReaderAndFactoryT.
StarBurn_UDF_AddT | This is macro StarBurn_UDF_AddT.
StarBurn_UDF_CreateExT | This is macro StarBurn_UDF_CreateExT.
StarBurn_UDF_CreateT | This is macro StarBurn_UDF_CreateT.
StarBurn_UDF_FormatTreeItemAsDirectoryT | This is macro StarBurn_UDF_FormatTreeItemAsDirectoryT.
StarBurn_UDF_FormatTreeItemAsFileT | This is macro StarBurn_UDF_FormatTreeItemAsFileT.
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS | Name constants
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS | This is macro STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS.
StarBurn_UDF2_VolumeCreateBootElToritoT | This is macro StarBurn_UDF2_VolumeCreateBootElToritoT.
StarBurn_UDFBridge_CreateExT | This is macro StarBurn_UDFBridge_CreateExT.
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS | StarPort device name size in UCHARs
STARWAVEFACTORY_ID_DSHOW | This is macro STARWAVEFACTORY_ID_DSHOW.
STARWAVEFACTORY_ID_MP3 | This is macro STARWAVEFACTORY_ID_MP3.
STARWAVEFACTORY_ID_OGG | This is macro STARWAVEFACTORY_ID_OGG.
STARWAVEFACTORY_ID_WAV | StarWave2 factory ids
STARWAVEFACTORY_ID_WMA | This is macro STARWAVEFACTORY_ID_WMA.
SUBCHANNEL_NO | No sub-channel
SUBCHANNEL_PQ | PQ sub-channel
SUBCHANNEL_PQ_SIZE_IN_UCHARS | PQ sub-channel size in UCHARs
SUBCHANNEL_RAW_PW | RAW P-W sub-channel
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS | Raw P-W sub-channel size in UCHARs
SUBCHANNEL_RESERVED | Reserved
SUBCHANNEL_RW | R-W sub-channel
SUBCHANNEL_SIZE_IN_UCHARS | Sub-channel size in UCHARs
TRACK_NUMBER_INVISIBLE | Special "invisible" track number
TYPE_CODE_LAST_CHANCE | Logical Unit region is set. Additional restrictions required to make a change
TYPE_CODE_NONE | No Logical Unit region setting
TYPE_CODE_PERM | Logical Unit region has been set permanently, but may be reset by vendor if necessery
TYPE_CODE_SET | Logical Unit region is set
UDF_FILE_SET_DESCRIPTOR_LBA | UDF file set descriptor logical block address
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA | UDF file set descriptor terminator logical block address
UDF_FIRST_ANCHOR_LBA | First anchor volume descriptor pointer LBA
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS | UDF head size in logical blocks
UDF_ISO9660_FILE_SYSTEM_LBA | UDF/ISO9660 bridge file system logical block address
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS | define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 6
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS | UDF logical block size in UCHARs
UDF_NAME_SIZE_IN_UCHARS | UDF longest name size in UCHARs
UDF_NAME_SIZE_IN_UCHARS_ACTUAL | This is macro UDF_NAME_SIZE_IN_UCHARS_ACTUAL.
UDF_NSR_DESCRIPTOR_LBA | UDF NSR descriptor pointer LBA
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS | UDF tail size in logical blocks
WAVE_FILE_ALIGNMENT | WAVE file data alignment (4 UCHARs, 1 ULONG)
WAVE_FILE_BITS_PER_SAMPLE | WAVE file bits per sample
WAVE_FILE_CHANNELS | WAVE file number of channels
WAVE_FILE_DATA_SIGNATURE | WAVE file DATA signature
WAVE_FILE_RIFF_SIGNATURE | WAVE file RIFF signature
WAVE_FILE_SAMPLES_PER_SECOND | WAVE file samples per second
WAVE_FILE_TAG_SIGNATURE | WAVE file TAG signature
WAVE_FILE_WAVE_FORMAT | WAVE file WAVE format
WAVE_FILE_WAVE_SIGNATURE | WAVE file WAVE signature
WRITE_REPORT_DELAY_IN_SECONDS | Default write report delay in seconds
Links
Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


__STARBURN_H__ Macro

__STARBURN_H__ Macro
StarBurn.h | Macros
Collapse All
C++
#define __STARBURN_H__
File

StarBurn.h

Description

Define StarBurn.h to avoid including it more then once

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ASPI_SAFE_BUFFER_SIZE_IN_UCHARS Macro

ASPI_SAFE_BUFFER_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define ASPI_SAFE_BUFFER_SIZE_IN_UCHARS 65536
File

StarBurn.h

Description

ASPI safe buffer size in UCHARs. ASPI is assumed to support at least 64KB large transfer per time. 64KB - PAGE_SIZE_IN_UCHARS was old default value. Now we'll use DVD_ECC_BLOCK_SIZE_IN_UCHARS as it's smaller and produce better results when dealing with DVD media

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


AUDIO_LB_SIZE_IN_UCHARS Macro

AUDIO_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define AUDIO_LB_SIZE_IN_UCHARS 2352
File

StarBurn.h

Description

Audio LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


BLURAY_SPEED_IN_KBPS_1X Macro

BLURAY_SPEED_IN_KBPS_1X Macro
StarBurn.h | Macros
Collapse All
C++
#define BLURAY_SPEED_IN_KBPS_1X 4495 // Actually 4495.5
File

StarBurn.h

Description

Actually 4495.5

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


BLURAY_SPEED_IN_KBPS_2X Macro

BLURAY_SPEED_IN_KBPS_2X Macro
StarBurn.h | Macros
Collapse All
C++
#define BLURAY_SPEED_IN_KBPS_2X 8991
File

StarBurn.h

Description

2X Blu-Ray speed constant (BD-R and BD-RE)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


BUFFER_STATUS_REPORT_DELAY_IN_SECONDS Macro

BUFFER_STATUS_REPORT_DELAY_IN_SECONDS Macro
StarBurn.h | Macros
Collapse All
C++
#define BUFFER_STATUS_REPORT_DELAY_IN_SECONDS 5
File

StarBurn.h

Description

Default buffer status report delay in seconds

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CACHE_SIZE_IN_MBS Macro

CACHE_SIZE_IN_MBS Macro
StarBurn.h | Macros
Collapse All
C++
#define CACHE_SIZE_IN_MBS 160 // 64
File

StarBurn.h

Description

64

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_10X Macro

CD_SPEED_IN_KBPS_10X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_10X 1760
File

StarBurn.h

Description

10X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_12X Macro

CD_SPEED_IN_KBPS_12X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_12X 2112
File

StarBurn.h

Description

12X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_16X Macro

CD_SPEED_IN_KBPS_16X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_16X 2800
File

StarBurn.h

Description

16X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_1X Macro

CD_SPEED_IN_KBPS_1X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_1X 176
File

StarBurn.h

Description

1X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_20X Macro

CD_SPEED_IN_KBPS_20X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_20X 3250
File

StarBurn.h

Description

20X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_24X Macro

CD_SPEED_IN_KBPS_24X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_24X 4224
File

StarBurn.h

Description

24X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_2P2X Macro

CD_SPEED_IN_KBPS_2P2X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_2P2X 387
File

StarBurn.h

Description

2.2X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_2X Macro

CD_SPEED_IN_KBPS_2X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_2X 353
File

StarBurn.h

Description

2X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_32X Macro

CD_SPEED_IN_KBPS_32X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_32X 5632
File

StarBurn.h

Description

32X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_36X Macro

CD_SPEED_IN_KBPS_36X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_36X 6336
File

StarBurn.h

Description

36X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_3X Macro

CD_SPEED_IN_KBPS_3X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_3X 528
File

StarBurn.h

Description

3X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_40X Macro

CD_SPEED_IN_KBPS_40X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_40X 7040
File

StarBurn.h

Description

40X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_44X Macro

CD_SPEED_IN_KBPS_44X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_44X 7744
File

StarBurn.h

Description

44X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_48X Macro

CD_SPEED_IN_KBPS_48X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_48X 8448
File

StarBurn.h

Description

48X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_4X Macro

CD_SPEED_IN_KBPS_4X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_4X 706
File

StarBurn.h

Description

4X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_52X Macro

CD_SPEED_IN_KBPS_52X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_52X 9152
File

StarBurn.h

Description

52X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_56X Macro

CD_SPEED_IN_KBPS_56X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_56X 9600
File

StarBurn.h

Description

56X CD speed

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_6X Macro

CD_SPEED_IN_KBPS_6X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_6X 1056
File

StarBurn.h

Description

6X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_72X Macro

CD_SPEED_IN_KBPS_72X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_72X 11300
File

StarBurn.h

Description

72X CD speed

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CD_SPEED_IN_KBPS_8X Macro

CD_SPEED_IN_KBPS_8X Macro
StarBurn.h | Macros
Collapse All
C++
#define CD_SPEED_IN_KBPS_8X 1400
File

StarBurn.h

Description

8X CD speed constant

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


CDVD_SPEED_IS_KBPS_MAXIMUM Macro

CDVD_SPEED_IS_KBPS_MAXIMUM Macro
StarBurn.h | Macros
Collapse All
C++
#define CDVD_SPEED_IS_KBPS_MAXIMUM 0xFFFF
File

StarBurn.h

Description

Top supported CD/DVD/Blu-Ray/HD-DVD speed constant (wildcard)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES Macro

DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES Macro
StarBurn.h | Macros
Collapse All
C++
#define DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES 10
File

StarBurn.h

Description

Default number of read retries during verification process

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DEVICES_PER_BUS Macro

DEVICES_PER_BUS Macro
StarBurn.h | Macros
Collapse All
C++
#define DEVICES_PER_BUS 63
File

StarBurn.h

Description

Top number of SCSI devices per logical SCSI bus (was 15 originally)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_STATUS_COMPLETE Macro

DISC_STATUS_COMPLETE Macro
StarBurn.h | Macros
Collapse All
C++
#define DISC_STATUS_COMPLETE 0x02
File

StarBurn.h

Description

Disc is complete

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_STATUS_EMPTY Macro

DISC_STATUS_EMPTY Macro
StarBurn.h | Macros
Collapse All
C++
#define DISC_STATUS_EMPTY 0x00
File

StarBurn.h

Description

Disc is empty

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DISC_STATUS_INCOMPLETE Macro

DISC_STATUS_INCOMPLETE Macro
StarBurn.h | Macros
Collapse All
C++
#define DISC_STATUS_INCOMPLETE 0x01
File

StarBurn.h

Description

Disc is incomplete

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro

DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro
StarBurn.h | Macros
Collapse All
C++
#define DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS ( SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS * 2 ) // Doubled...
File

StarBurn.h

Description

Doubled...

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_ECC_BLOCK_SIZE_IN_LBS Macro

DVD_ECC_BLOCK_SIZE_IN_LBS Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_ECC_BLOCK_SIZE_IN_LBS 16
File

StarBurn.h

Description

DVD ECC block size in logical blocks (2048 UCHARs each)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_ECC_BLOCK_SIZE_IN_UCHARS Macro

DVD_ECC_BLOCK_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_ECC_BLOCK_SIZE_IN_UCHARS 32768
File

StarBurn.h

Description

DVD ECC block size in UCHARs. This is true "hardware" logical block size on DVD. It's recommended to have transfers of this size and this size aligned

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_PROTECTION_CPRM Macro

DVD_PROTECTION_CPRM Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_PROTECTION_CPRM 0x02
File

StarBurn.h

Description

DVD with CPRM (Copy-Protected Removable Media) protection

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_PROTECTION_CSS Macro

DVD_PROTECTION_CSS Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_PROTECTION_CSS 0x01
File

StarBurn.h

Description

DVD with CSS (Content Scrambling System) protection

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_PROTECTION_NONE Macro

DVD_PROTECTION_NONE Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_PROTECTION_NONE 0x00
File

StarBurn.h

Description

DVD w/o any protection system

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_10X Macro

DVD_SPEED_IN_KBPS_10X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_10X 13850
File

StarBurn.h

Description

10X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_12X Macro

DVD_SPEED_IN_KBPS_12X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_12X 16620
File

StarBurn.h

Description

12X DVD speed constant (DVD-R, DVD+R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_16X Macro

DVD_SPEED_IN_KBPS_16X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_16X 22160
File

StarBurn.h

Description

16X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_18X Macro

DVD_SPEED_IN_KBPS_18X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_18X 24930
File

StarBurn.h

Description

18X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_1X Macro

DVD_SPEED_IN_KBPS_1X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_1X 1385
File

StarBurn.h

Description

1X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_20X Macro

DVD_SPEED_IN_KBPS_20X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_20X 27700
File

StarBurn.h

Description

20X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_22X Macro

DVD_SPEED_IN_KBPS_22X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_22X 30470
File

StarBurn.h

Description

22X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_24X Macro

DVD_SPEED_IN_KBPS_24X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_24X 33240
File

StarBurn.h

Description

24X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_2DOT4X Macro

DVD_SPEED_IN_KBPS_2DOT4X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_2DOT4X 3324
File

StarBurn.h

Description

2.4X DVD speed constant (DVD+R, DVD+R DL and DVD+RW)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_2X Macro

DVD_SPEED_IN_KBPS_2X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_2X 2770
File

StarBurn.h

Description

2X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_32X Macro

DVD_SPEED_IN_KBPS_32X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_32X DVD_SPEED_IN_KBPS_1X * 32
File

StarBurn.h

Description

32X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_3X Macro

DVD_SPEED_IN_KBPS_3X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_3X 4155
File

StarBurn.h

Description

3X DVD speed constant (DVD-RAM)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_40X Macro

DVD_SPEED_IN_KBPS_40X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_40X DVD_SPEED_IN_KBPS_1X * 40
File

StarBurn.h

Description

40X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_48X Macro

DVD_SPEED_IN_KBPS_48X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_48X DVD_SPEED_IN_KBPS_1X * 48
File

StarBurn.h

Description

48X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_4X Macro

DVD_SPEED_IN_KBPS_4X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_4X 5540
File

StarBurn.h

Description

4X DVD speed constant (DVD-R, DVD-R DL, DVD-RW, DVD+R, DVD+R DL, DVD+RW and DVD-RAM)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_50X Macro

DVD_SPEED_IN_KBPS_50X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_50X DVD_SPEED_IN_KBPS_1X * 50
File

StarBurn.h

Description

50X DVD speed constant (DVD+R and DVD-R)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_5X Macro

DVD_SPEED_IN_KBPS_5X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_5X 6925
File

StarBurn.h

Description

5X DVD speed constant (DVD-RAM)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_6X Macro

DVD_SPEED_IN_KBPS_6X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_6X 8310
File

StarBurn.h

Description

6X DVD speed constant (DVD-RW)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


DVD_SPEED_IN_KBPS_8X Macro

DVD_SPEED_IN_KBPS_8X Macro
StarBurn.h | Macros
Collapse All
C++
#define DVD_SPEED_IN_KBPS_8X 11080
File

StarBurn.h

Description

8X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ELTORITO_BOOTABLE Macro

ELTORITO_BOOTABLE Macro
StarBurn.h | Macros
Collapse All
C++
#define ELTORITO_BOOTABLE 0x88
File

StarBurn.h

Description

Bootable disc ID

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ELTORITO_BOOTSYSTEM_ID Macro

ELTORITO_BOOTSYSTEM_ID Macro
StarBurn.h | Macros
Collapse All
C++
#define ELTORITO_BOOTSYSTEM_ID "EL TORITO SPECIFICATION"
File

StarBurn.h

Description

Bootable specification signature

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ELTORITO_DEF_LOAD_SEGMENT Macro

ELTORITO_DEF_LOAD_SEGMENT Macro
StarBurn.h | Macros
Collapse All
C++
#define ELTORITO_DEF_LOAD_SEGMENT 0x07C0
File

StarBurn.h

Description

Real mode code load segment

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ELTORITO_NON_BOOTABLE Macro

ELTORITO_NON_BOOTABLE Macro
StarBurn.h | Macros
Collapse All
C++
#define ELTORITO_NON_BOOTABLE 0x00
File

StarBurn.h

Description

Non-bootable disc ID

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ERROR_FIELD_C2_AND_BLOCK_ERROR Macro

ERROR_FIELD_C2_AND_BLOCK_ERROR Macro
StarBurn.h | Macros
Collapse All
C++
#define ERROR_FIELD_C2_AND_BLOCK_ERROR 0x02 // C2 and block error information
File

StarBurn.h

Description

C2 and block error information

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ERROR_FIELD_C2_ERROR Macro

ERROR_FIELD_C2_ERROR Macro
StarBurn.h | Macros
Collapse All
C++
#define ERROR_FIELD_C2_ERROR 0x01 // C2 error information
File

StarBurn.h

Description

C2 error information

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ERROR_FIELD_NO_ERROR Macro

ERROR_FIELD_NO_ERROR Macro
StarBurn.h | Macros
Collapse All
C++
#define ERROR_FIELD_NO_ERROR 0x00 // No error information
File

StarBurn.h

Description

No error information

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ERROR_FIELD_RESERVED Macro

ERROR_FIELD_RESERVED Macro
StarBurn.h | Macros
Collapse All
C++
#define ERROR_FIELD_RESERVED 0x03 // Reserved
File

StarBurn.h

Description

Reserved

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_ANY Macro

EXPECTED_LB_TYPE_ANY Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_ANY 0x00 // Accept all LBs
File

StarBurn.h

Description

Accept all LBs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_CDDA Macro

EXPECTED_LB_TYPE_CDDA Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_CDDA 0x01 // Accept only CDDA (CD digital audio) LBs
File

StarBurn.h

Description

Accept only CDDA (CD digital audio) LBs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_MODE1 Macro

EXPECTED_LB_TYPE_MODE1 Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_MODE1 0x02 // Accept only MODE1 LBs
File

StarBurn.h

Description

Accept only MODE1 LBs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_MODE2 Macro

EXPECTED_LB_TYPE_MODE2 Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_MODE2 0x03 // Accept only MODE2 LBs (both Form1 and Form2)
File

StarBurn.h

Description

Accept only MODE2 LBs (both Form1 and Form2)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_MODE2_FORM1 Macro

EXPECTED_LB_TYPE_MODE2_FORM1 Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_MODE2_FORM1 0x04 // Accept only MODE2 Form1 LBs
File

StarBurn.h

Description

Accept only MODE2 Form1 LBs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


EXPECTED_LB_TYPE_MODE2_FORM2 Macro

EXPECTED_LB_TYPE_MODE2_FORM2 Macro
StarBurn.h | Macros
Collapse All
C++
#define EXPECTED_LB_TYPE_MODE2_FORM2 0x05 // Accept only MODE2 Form2 LBs
File

StarBurn.h

Description

Accept only MODE2 Form2 LBs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


HARD_DISK_LB_SIZE_IN_UCHARS Macro

HARD_DISK_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define HARD_DISK_LB_SIZE_IN_UCHARS 512
File

StarBurn.h

Description

Hard disk LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


HEADER_CODE_ALL_HEADERS Macro

HEADER_CODE_ALL_HEADERS Macro
StarBurn.h | Macros
Collapse All
C++
#define HEADER_CODE_ALL_HEADERS 0x03 // Both header and subheader
File

StarBurn.h

Description

Both header and subheader

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


HEADER_CODE_HEADER_ONLY Macro

HEADER_CODE_HEADER_ONLY Macro
StarBurn.h | Macros
Collapse All
C++
#define HEADER_CODE_HEADER_ONLY 0x01 // 4-byte header
File

StarBurn.h

Description

4-byte header

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


HEADER_CODE_NONE Macro

HEADER_CODE_NONE Macro
StarBurn.h | Macros
Collapse All
C++
#define HEADER_CODE_NONE 0x00 // No header
File

StarBurn.h

Description

No header

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


HEADER_CODE_SUBHEADER_ONLY Macro

HEADER_CODE_SUBHEADER_ONLY Macro
StarBurn.h | Macros
Collapse All
C++
#define HEADER_CODE_SUBHEADER_ONLY 0x02 // MODE2 Form1 or Form2 subheader
File

StarBurn.h

Description

MODE2 Form1 or Form2 subheader

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_DATE_SIZE_IN_UCHARS Macro

ISO9660_DATE_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define ISO9660_DATE_SIZE_IN_UCHARS 17
File

StarBurn.h

Description

ISO9660 date size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_FILE_SIZE_IN_UCHARS Macro

ISO9660_FILE_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define ISO9660_FILE_SIZE_IN_UCHARS 37
File

StarBurn.h

Description

ISO9660 file size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_NAME_SIZE_IN_UCHARS Macro

ISO9660_NAME_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define ISO9660_NAME_SIZE_IN_UCHARS 128
File

StarBurn.h

Description

ISO9660 name size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS Macro

ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS 32
File

StarBurn.h

Description

ISO9660 volume descriptor system and volume ID size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


ISO9660_TREE_LEVEL Macro

ISO9660_TREE_LEVEL Macro
StarBurn.h | Macros
Collapse All
C++
#define ISO9660_TREE_LEVEL 8
File

StarBurn.h

Description

ISO9660 top supported file tree level

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


LAST_SESSION_COMPLETE Macro

LAST_SESSION_COMPLETE Macro
StarBurn.h | Macros
Collapse All
C++
#define LAST_SESSION_COMPLETE 0x03
File

StarBurn.h

Description

Last session is complete

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


LAST_SESSION_EMPTY Macro

LAST_SESSION_EMPTY Macro
StarBurn.h | Macros
Collapse All
C++
#define LAST_SESSION_EMPTY 0x00
File

StarBurn.h

Description

Last session is empty

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


LAST_SESSION_INCOMPLETE Macro

LAST_SESSION_INCOMPLETE Macro
StarBurn.h | Macros
Collapse All
C++
#define LAST_SESSION_INCOMPLETE 0x01
File

StarBurn.h

Description

Last session is incomplete

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


MODE1_LB_SIZE_IN_UCHARS Macro

MODE1_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define MODE1_LB_SIZE_IN_UCHARS 2048
File

StarBurn.h

Description

MODE1 LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


MODE2_FORM1_LB_SIZE_IN_UCHARS Macro

MODE2_FORM1_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define MODE2_FORM1_LB_SIZE_IN_UCHARS 2048
File

StarBurn.h

Description

MODE2 Form1 LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


MODE2_FORM2_LB_SIZE_IN_UCHARS Macro

MODE2_FORM2_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define MODE2_FORM2_LB_SIZE_IN_UCHARS 2324
File

StarBurn.h

Description

MODE2 Form2 LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS Macro

MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS 2332
File

StarBurn.h

Description

MODE2 Form2 + 8 UCHARs of subheader LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


MODE2_FORMLESS_LB_SIZE_IN_UCHARS Macro

MODE2_FORMLESS_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define MODE2_FORMLESS_LB_SIZE_IN_UCHARS 2336
File

StarBurn.h

Description

MODE2 Formless LB (logical block) size in UCHARS

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NUMBER_OF_RAW_TRACKS Macro

NUMBER_OF_RAW_TRACKS Macro
StarBurn.h | Macros
Collapse All
C++
#define NUMBER_OF_RAW_TRACKS ( NUMBER_OF_TRACKS * 4 + 1 )
File

StarBurn.h

Description

Top number of raw tracks (including maintenance tracks) on CD/DVD/Blu-Ray/HD-DVD disc.

This is calculated based on the worst CD case when all tracks will be in a separate sessions. We need this approximate value to avoid allocating TOC_INFORMATION structure dynamically.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NUMBER_OF_READ_RETRIES Macro

NUMBER_OF_READ_RETRIES Macro
StarBurn.h | Macros
Collapse All
C++
#define NUMBER_OF_READ_RETRIES 1
File

StarBurn.h

Description

Default number of retries on read operations (if bad block was possibly hit, was 2 originally)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NUMBER_OF_SUBCHANNELS Macro

NUMBER_OF_SUBCHANNELS Macro
StarBurn.h | Macros
Collapse All
C++
#define NUMBER_OF_SUBCHANNELS 8 // sub-channels from P to W
File

StarBurn.h

Description

sub-channels from P to W

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


NUMBER_OF_TRACKS Macro

NUMBER_OF_TRACKS Macro
StarBurn.h | Macros
Collapse All
C++
#define NUMBER_OF_TRACKS 100
File

StarBurn.h

Description

Top number of tracks (or border-in/border-out zones) on CD/DVD/Blu-Ray/HD-DVD disc

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


PAGE_SIZE_IN_UCHARS Macro

PAGE_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define PAGE_SIZE_IN_UCHARS 4096
File

StarBurn.h

Description

Small page size in UCHARs on x86 machines (default allocatable storage)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


RAW_LB_PQ_SUB_SIZE_IN_UCHARS Macro

RAW_LB_PQ_SUB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define RAW_LB_PQ_SUB_SIZE_IN_UCHARS 2368
File

StarBurn.h

Description

RAW LB (logical block) with PQ sub-channel size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS Macro

RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS 2448
File

StarBurn.h

Description

RAW LB (logical block) with RAW P-W sub-channel size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


RAW_LB_SIZE_IN_UCHARS Macro

RAW_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define RAW_LB_SIZE_IN_UCHARS 2352
File

StarBurn.h

Description

RAW LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


READ_REPORT_DELAY_IN_SECONDS Macro

READ_REPORT_DELAY_IN_SECONDS Macro
StarBurn.h | Macros
Collapse All
C++
#define READ_REPORT_DELAY_IN_SECONDS 1
File

StarBurn.h

Description

Default read report delay in seconds

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_DIRECT_ACCESS Macro

SCSI_DEVICE_DIRECT_ACCESS Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_DIRECT_ACCESS 0x00
File

StarBurn.h

Description

SCSI disk device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_MAGNETO_OPTICAL Macro

SCSI_DEVICE_MAGNETO_OPTICAL Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_MAGNETO_OPTICAL 0x07
File

StarBurn.h

Description

SCSI MO (Magneto-Optical) disk device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_MEDIUM_CHANGER Macro

SCSI_DEVICE_MEDIUM_CHANGER Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_MEDIUM_CHANGER 0x08
File

StarBurn.h

Description

SCSI jukebox (disc changer) device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_NETWORK Macro

SCSI_DEVICE_NETWORK Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_NETWORK 0x09
File

StarBurn.h

Description

SCSI network device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_PRINTER Macro

SCSI_DEVICE_PRINTER Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_PRINTER 0x02
File

StarBurn.h

Description

SCSI printer device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_PROCESSOR Macro

SCSI_DEVICE_PROCESSOR Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_PROCESSOR 0x03
File

StarBurn.h

Description

SCSI processor device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_RO_DIRECT_ACCESS Macro

SCSI_DEVICE_RO_DIRECT_ACCESS Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_RO_DIRECT_ACCESS 0x05
File

StarBurn.h

Description

SCSI CD/DVD/Blu-Ray/HD-DVD device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_SCANNER Macro

SCSI_DEVICE_SCANNER Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_SCANNER 0x06
File

StarBurn.h

Description

SCSI scanner device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_SEQUENTIAL_ACCESS Macro

SCSI_DEVICE_SEQUENTIAL_ACCESS Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_SEQUENTIAL_ACCESS 0x01
File

StarBurn.h

Description

SCSI tape device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_UNPRESENT Macro

SCSI_DEVICE_UNPRESENT Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_UNPRESENT 0x7F
File

StarBurn.h

Description

SCSI device... Is gone!

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_WILDCARD Macro

SCSI_DEVICE_WILDCARD Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_WILDCARD 0xFF
File

StarBurn.h

Description

SCSI device any (wildcard for StarBurn_FindDevice() function)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SCSI_DEVICE_WORM Macro

SCSI_DEVICE_WORM Macro
StarBurn.h | Macros
Collapse All
C++
#define SCSI_DEVICE_WORM 0x04
File

StarBurn.h

Description

SCSI WORM (Write-Once-Read-Multiple) device

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SHORT_RAW_LB_SIZE_IN_UCHARS Macro

SHORT_RAW_LB_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define SHORT_RAW_LB_SIZE_IN_UCHARS 2336
File

StarBurn.h

Description

Short (w/o sync and header) RAW LB (logical block) size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro

SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro
StarBurn.h | Macros
Collapse All
C++
#define SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS 2298495 // Number of logical blocks on single layer DVD
File

StarBurn.h

Description

Number of logical blocks on single layer DVD

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SMALLEST_CACHE_SIZE_IN_MBS Macro

SMALLEST_CACHE_SIZE_IN_MBS Macro
StarBurn.h | Macros
Collapse All
C++
#define SMALLEST_CACHE_SIZE_IN_MBS 64
File

StarBurn.h

Description

Smallest cache size in MBs that toolkit will allow to use to buffer "write" operations

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SMALLEST_CACHE_SIZE_IN_UCHARS Macro

SMALLEST_CACHE_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define SMALLEST_CACHE_SIZE_IN_UCHARS ( SMALLEST_CACHE_SIZE_IN_MBS * 1024 * 1024 )
File

StarBurn.h

Description

Smallest cache size in UCHARs that toolkit will allow to use to buffer "write" operations

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_CERTIFICATION_FULL Macro

STARBURN_BDRE_FORMAT_CERTIFICATION_FULL Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_CERTIFICATION_FULL 0x01
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_FULL.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_CERTIFICATION_NO Macro

STARBURN_BDRE_FORMAT_CERTIFICATION_NO Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_CERTIFICATION_NO 0x00
File

StarBurn.h

Description

BD-RE format certification types

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK Macro

STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK 0x02
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED Macro

STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED 0x03
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_DEFAULT Macro

STARBURN_BDRE_FORMAT_DEFAULT Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_DEFAULT 0x00
File

StarBurn.h

Description

BD-RE format types

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION Macro

STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION 0x01
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_WITH_SPARE_AREA Macro

STARBURN_BDRE_FORMAT_WITH_SPARE_AREA Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_WITH_SPARE_AREA 0x30
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_WITH_SPARE_AREA.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA Macro

STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA 0x31
File

StarBurn.h

Description

This is macro STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CACHE_SIZE_READ_ONLY Macro

STARBURN_CACHE_SIZE_READ_ONLY Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CACHE_SIZE_READ_ONLY 1
File

StarBurn.h

Description

Default cache size for I/O operations

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CACHE_SIZE_READ_WRITE Macro

STARBURN_CACHE_SIZE_READ_WRITE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CACHE_SIZE_READ_WRITE 0
File

StarBurn.h

Description

This is macro STARBURN_CACHE_SIZE_READ_WRITE.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED Macro

STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED 0x00000008
File

StarBurn.h

Description

This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY Macro

STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY 0x00000001
File

StarBurn.h

Description

File attributes ( flags for Attributes member of STARBURN_UDF2_FILE_INFO & STARBURN_ISO2_FILE_INFO )

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN Macro

STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN 0x00000004
File

StarBurn.h

Description

This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED Macro

STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED 0x00000002
File

StarBurn.h

Description

This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT Macro

StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT Macro

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GetDeviceInformationT Macro

StarBurn_CdvdBurnerGrabber_GetDeviceInformationT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_GetDeviceInformationT StarBurn_CdvdBurnerGrabber_GetDeviceInformation
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_GetDeviceInformationT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_GrabTrackT Macro

StarBurn_CdvdBurnerGrabber_GrabTrackT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_GrabTrackT StarBurn_CdvdBurnerGrabber_GrabTrack
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_GrabTrackT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT Macro

StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SessionAtOnceT Macro

StarBurn_CdvdBurnerGrabber_SessionAtOnceT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_SessionAtOnceT StarBurn_CdvdBurnerGrabber_SessionAtOnce
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT Macro

StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDExT Macro

StarBurn_CdvdBurnerGrabber_SuperVideoCDExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_SuperVideoCDExT StarBurn_CdvdBurnerGrabber_SuperVideoCDEx
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_SuperVideoCDT Macro

StarBurn_CdvdBurnerGrabber_SuperVideoCDT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_SuperVideoCDT StarBurn_CdvdBurnerGrabber_SuperVideoCD
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT Macro

StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFileExT Macro

StarBurn_CdvdBurnerGrabber_VerifyFileExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_VerifyFileExT StarBurn_CdvdBurnerGrabber_VerifyFileEx
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_VerifyFileExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VerifyFileT Macro

StarBurn_CdvdBurnerGrabber_VerifyFileT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_VerifyFileT StarBurn_CdvdBurnerGrabber_VerifyFile
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_VerifyFileT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDExExT Macro

StarBurn_CdvdBurnerGrabber_VideoCDExExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_VideoCDExExT StarBurn_CdvdBurnerGrabber_VideoCDExEx
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_VideoCDExExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDExT Macro

StarBurn_CdvdBurnerGrabber_VideoCDExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_VideoCDExT StarBurn_CdvdBurnerGrabber_VideoCDEx
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_VideoCDExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_CdvdBurnerGrabber_VideoCDT Macro

StarBurn_CdvdBurnerGrabber_VideoCDT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_CdvdBurnerGrabber_VideoCDT StarBurn_CdvdBurnerGrabber_VideoCD
File

StarBurn.h

Description

This is macro StarBurn_CdvdBurnerGrabber_VideoCDT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_ALLMESSAGES Macro

STARBURN_DEBUG_FACILITY_ALLMESSAGES Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_ALLMESSAGES 0xFFF00000
File

StarBurn.h

Description

Debug facility: Permit All Messages

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_ALLTARGETS Macro

STARBURN_DEBUG_FACILITY_ALLTARGETS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_ALLTARGETS 0x00000FFF
File

StarBurn.h

Description

Debug facility: All targets

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_CUSTOM Macro

STARBURN_DEBUG_FACILITY_CUSTOM Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_CUSTOM 0x00000008
File

StarBurn.h

Description

Debug facility: Custom

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_DEBUG Macro

STARBURN_DEBUG_FACILITY_DEBUG Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_DEBUG 0x00200000
File

StarBurn.h

Description

Debug facility: Permit Debug Messages

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT Macro

STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT 0x00000001
File

StarBurn.h

Description

Debug facility: Debug output

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_ERROR Macro

STARBURN_DEBUG_FACILITY_ERROR Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_ERROR 0x00800000
File

StarBurn.h

Description

Debug facility: Permit Error Messages

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_LOG_FILE Macro

STARBURN_DEBUG_FACILITY_LOG_FILE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_LOG_FILE 0x00000002
File

StarBurn.h

Description

Debug facility: Log file

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_NONE Macro

STARBURN_DEBUG_FACILITY_NONE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_NONE 0x00000000
File

StarBurn.h

Description

Debug facility: None

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE Macro

STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE 0x00000004
File

StarBurn.h

Description

Debug facility: System console

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_TRACE Macro

STARBURN_DEBUG_FACILITY_TRACE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_TRACE 0x00100000
File

StarBurn.h

Description

Debug facility: Permit Trace Messages

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DEBUG_FACILITY_WARNING Macro

STARBURN_DEBUG_FACILITY_WARNING Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DEBUG_FACILITY_WARNING 0x00400000
File

StarBurn.h

Description

Debug facility: Permit Warning Messages

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_TYPE_CDDA Macro

STARBURN_DISC_TYPE_CDDA Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DISC_TYPE_CDDA 0x01
File

StarBurn.h

Description

Disc type is CDDA (CD-ROM or Digital Audio)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_TYPE_CDI Macro

STARBURN_DISC_TYPE_CDI Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DISC_TYPE_CDI 0x10
File

StarBurn.h

Description

Disc type is CDI

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_TYPE_UNDEFINED Macro

STARBURN_DISC_TYPE_UNDEFINED Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DISC_TYPE_UNDEFINED 0xFF
File

StarBurn.h

Description

Disc type is undefined

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DISC_TYPE_XA Macro

STARBURN_DISC_TYPE_XA Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DISC_TYPE_XA 0x20
File

StarBurn.h

Description

Disc type is CD-ROM XA

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES Macro

STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES 99
File

StarBurn.h

Description

DVD-Video maximum number of titles

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_DVDVideo_CreateT Macro

StarBurn_DVDVideo_CreateT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_DVDVideo_CreateT StarBurn_DVDVideo_Create
File

StarBurn.h

Description

This is macro StarBurn_DVDVideo_CreateT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_BootCatalogAddSectionT Macro

StarBurn_ElTorito_BootCatalogAddSectionT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_ElTorito_BootCatalogAddSectionT StarBurn_ElTorito_BootCatalogAddSection
File

StarBurn.h

Description

This is macro StarBurn_ElTorito_BootCatalogAddSectionT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ElTorito_CreateBootCatalogT Macro

StarBurn_ElTorito_CreateBootCatalogT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_ElTorito_CreateBootCatalogT StarBurn_ElTorito_CreateBootCatalog
File

StarBurn.h

Description

This is macro StarBurn_ElTorito_CreateBootCatalogT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARs_FastT Macro

StarBurn_GetAudioFileStreamSizeInUCHARs_FastT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_GetAudioFileStreamSizeInUCHARs_FastT StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast
File

StarBurn.h

Description

This is macro StarBurn_GetAudioFileStreamSizeInUCHARs_FastT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetAudioFileStreamSizeInUCHARsT Macro

StarBurn_GetAudioFileStreamSizeInUCHARsT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_GetAudioFileStreamSizeInUCHARsT StarBurn_GetAudioFileStreamSizeInUCHARs
File

StarBurn.h

Description

This is macro StarBurn_GetAudioFileStreamSizeInUCHARsT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_GetDeviceLetterT Macro

StarBurn_GetDeviceLetterT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_GetDeviceLetterT StarBurn_GetDeviceLetter
File

StarBurn.h

Description

TCHAR functions

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_IMPEX_API Macro

STARBURN_IMPEX_API Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_IMPEX_API
File

StarBurn.h

Description

declspec( dllexport )

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_IsAudioFileSupportedT Macro

StarBurn_IsAudioFileSupportedT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_IsAudioFileSupportedT StarBurn_IsAudioFileSupported
File

StarBurn.h

Description

This is macro StarBurn_IsAudioFileSupportedT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_ISO2_VolumeCreateBootElToritoT Macro

StarBurn_ISO2_VolumeCreateBootElToritoT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_ISO2_VolumeCreateBootElToritoT StarBurn_ISO2_VolumeCreateBootElTorito
File

StarBurn.h

Description

This is macro StarBurn_ISO2_VolumeCreateBootElToritoT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE Macro

STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE 0x04
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_FLAGS_DIRECTORY Macro

STARBURN_ISO9660_FILE_FLAGS_DIRECTORY Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_FLAGS_DIRECTORY 0x02
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_FILE_FLAGS_DIRECTORY.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_FLAGS_EXISTENCE Macro

STARBURN_ISO9660_FILE_FLAGS_EXISTENCE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_FLAGS_EXISTENCE 0x01
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_FILE_FLAGS_EXISTENCE.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_FLAGS_NONE Macro

STARBURN_ISO9660_FILE_FLAGS_NONE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_FLAGS_NONE 0x00
File

StarBurn.h

Description

ISO9660 file attributes flags

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_FLAGS_RECORD Macro

STARBURN_ISO9660_FILE_FLAGS_RECORD Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_FLAGS_RECORD 0x08
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_FILE_FLAGS_RECORD.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS Macro

STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS ( LONGLONG )( 0xFFFFFFFF ) // ( 4GB - 1 )
File

StarBurn.h

Description

( 4GB - 1 )

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS Macro

STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS 128
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS Macro

STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS 108 // TODO: Check it!!!
File

StarBurn.h

Todo

Check it!!!

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS Macro

STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS 256
File

StarBurn.h

Description

ISO9660 constants (begin)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_TYPE_1999 Macro

STARBURN_ISO9660_TYPE_1999 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_TYPE_1999 2
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_TYPE_1999.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_TYPE_JOLIET Macro

STARBURN_ISO9660_TYPE_JOLIET Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_TYPE_JOLIET 4
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_TYPE_JOLIET.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_TYPE_JOLIET_RELAXED Macro

STARBURN_ISO9660_TYPE_JOLIET_RELAXED Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_TYPE_JOLIET_RELAXED 12
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_TYPE_JOLIET_RELAXED.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_TYPE_LEVEL1 Macro

STARBURN_ISO9660_TYPE_LEVEL1 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_TYPE_LEVEL1 0
File

StarBurn.h

Description

ISO9660 file system type

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_ISO9660_TYPE_LEVEL2 Macro

STARBURN_ISO9660_TYPE_LEVEL2 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_ISO9660_TYPE_LEVEL2 1
File

StarBurn.h

Description

This is macro STARBURN_ISO9660_TYPE_LEVEL2.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_CADDY Macro

STARBURN_LOADING_MECHANISM_TYPE_CADDY Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_CADDY 0x00
File

StarBurn.h

Description

Loading mechanism type constants

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE Macro

STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE 0x05
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_CHANGER Macro

STARBURN_LOADING_MECHANISM_TYPE_CHANGER Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_CHANGER 0x04
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_CHANGER.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_POP_UP Macro

STARBURN_LOADING_MECHANISM_TYPE_POP_UP Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_POP_UP 0x02
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_POP_UP.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 Macro

STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 0x03
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED1.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 Macro

STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 0x06
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED2.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 Macro

STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 0x07
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED3.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_LOADING_MECHANISM_TYPE_TRAY Macro

STARBURN_LOADING_MECHANISM_TYPE_TRAY Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_LOADING_MECHANISM_TYPE_TRAY 0x01
File

StarBurn.h

Description

This is macro STARBURN_LOADING_MECHANISM_TYPE_TRAY.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_PIPE_SIZE_IN_UCHARS Macro

STARBURN_PIPE_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_PIPE_SIZE_IN_UCHARS ( 60 * 64 * 1024 ) // 60, 64 or 32 KB I/O packets
File

StarBurn.h

Description

60, 64 or 32 KB I/O packets

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS Macro

STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS 200
File

StarBurn.h

Description

StarBurn smallest split file size in megabytes

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileReaderObjectCreateT Macro

StarBurn_StarWave_CompressedFileReaderObjectCreateT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_CompressedFileReaderObjectCreateT StarBurn_StarWave_CompressedFileReaderObjectCreate
File

StarBurn.h

Description

This is macro StarBurn_StarWave_CompressedFileReaderObjectCreateT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileRecompressT Macro

StarBurn_StarWave_CompressedFileRecompressT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_CompressedFileRecompressT StarBurn_StarWave_CompressedFileRecompress
File

StarBurn.h

Description

This is macro StarBurn_StarWave_CompressedFileRecompressT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileUncompressT Macro

StarBurn_StarWave_CompressedFileUncompressT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_CompressedFileUncompressT StarBurn_StarWave_CompressedFileUncompress
File

StarBurn.h

Description

This is macro StarBurn_StarWave_CompressedFileUncompressT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_CompressedFileWriterObjectCreateT Macro

StarBurn_StarWave_CompressedFileWriterObjectCreateT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_CompressedFileWriterObjectCreateT StarBurn_StarWave_CompressedFileWriterObjectCreate
File

StarBurn.h

Description

This is macro StarBurn_StarWave_CompressedFileWriterObjectCreateT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS Macro

STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS ( 44100 * 2 * 2 )
File

StarBurn.h

Description

StarWave recommended I/O buffer size in UCHARs. It's *STRONGLY* recommended to use either it or multiplications of STARWAVE_IO_BUFFER_SIZE_IN_UCHARS as internal calculations and indexations are integer rather then float based

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileCompressT Macro

StarBurn_StarWave_UncompressedFileCompressT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_UncompressedFileCompressT StarBurn_StarWave_UncompressedFileCompress
File

StarBurn.h

Description

This is macro StarBurn_StarWave_UncompressedFileCompressT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave_UncompressedFileSupportedIsT Macro

StarBurn_StarWave_UncompressedFileSupportedIsT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave_UncompressedFileSupportedIsT StarBurn_StarWave_UncompressedFileSupportedIs
File

StarBurn.h

Description

This is macro StarBurn_StarWave_UncompressedFileSupportedIsT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_ConvertExT Macro

StarBurn_StarWave2_ConvertExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave2_ConvertExT StarBurn_StarWave2_ConvertEx
File

StarBurn.h

Description

This is macro StarBurn_StarWave2_ConvertExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_EncodeMP3OGGFromWAVT Macro

StarBurn_StarWave2_EncodeMP3OGGFromWAVT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave2_EncodeMP3OGGFromWAVT StarBurn_StarWave2_EncodeMP3OGGFromWAV
File

StarBurn.h

Description

This is macro StarBurn_StarWave2_EncodeMP3OGGFromWAVT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_StarWave2_GetFileReaderAndFactoryT Macro

StarBurn_StarWave2_GetFileReaderAndFactoryT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_StarWave2_GetFileReaderAndFactoryT StarBurn_StarWave2_GetFileReaderAndFactory
File

StarBurn.h

Description

This is macro StarBurn_StarWave2_GetFileReaderAndFactoryT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_AddT Macro

StarBurn_UDF_AddT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF_AddT StarBurn_UDF_Add
File

StarBurn.h

Description

This is macro StarBurn_UDF_AddT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CreateExT Macro

StarBurn_UDF_CreateExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF_CreateExT StarBurn_UDF_CreateEx
File

StarBurn.h

Description

This is macro StarBurn_UDF_CreateExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_CreateT Macro

StarBurn_UDF_CreateT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF_CreateT StarBurn_UDF_Create
File

StarBurn.h

Description

This is macro StarBurn_UDF_CreateT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsDirectoryT Macro

StarBurn_UDF_FormatTreeItemAsDirectoryT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF_FormatTreeItemAsDirectoryT StarBurn_UDF_FormatTreeItemAsDirectory
File

StarBurn.h

Description

This is macro StarBurn_UDF_FormatTreeItemAsDirectoryT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF_FormatTreeItemAsFileT Macro

StarBurn_UDF_FormatTreeItemAsFileT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF_FormatTreeItemAsFileT StarBurn_UDF_FormatTreeItemAsFile
File

StarBurn.h

Description

This is macro StarBurn_UDF_FormatTreeItemAsFileT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS Macro

STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS 255
File

StarBurn.h

Description

Name constants

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS Macro

STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS 2048
File

StarBurn.h

Description

This is macro STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDF2_VolumeCreateBootElToritoT Macro

StarBurn_UDF2_VolumeCreateBootElToritoT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDF2_VolumeCreateBootElToritoT StarBurn_UDF2_VolumeCreateBootElTorito
File

StarBurn.h

Description

This is macro StarBurn_UDF2_VolumeCreateBootElToritoT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn_UDFBridge_CreateExT Macro

StarBurn_UDFBridge_CreateExT Macro
StarBurn.h | Macros
Collapse All
C++
#define StarBurn_UDFBridge_CreateExT StarBurn_UDFBridge_CreateEx
File

StarBurn.h

Description

This is macro StarBurn_UDFBridge_CreateExT.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARPORT_DEVICE_NAME_SIZE_IN_UCHARS Macro

STARPORT_DEVICE_NAME_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define STARPORT_DEVICE_NAME_SIZE_IN_UCHARS 1024
File

StarBurn.h

Description

StarPort device name size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVEFACTORY_ID_DSHOW Macro

STARWAVEFACTORY_ID_DSHOW Macro
StarBurn.h | Macros
Collapse All
C++
#define STARWAVEFACTORY_ID_DSHOW "9674798D-F70F-4034-920E-54520F76B3CE"
File

StarBurn.h

Description

This is macro STARWAVEFACTORY_ID_DSHOW.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVEFACTORY_ID_MP3 Macro

STARWAVEFACTORY_ID_MP3 Macro
StarBurn.h | Macros
Collapse All
C++
#define STARWAVEFACTORY_ID_MP3 "C72EBA33-7D5E-42d8-8017-C497103B34B5"
File

StarBurn.h

Description

This is macro STARWAVEFACTORY_ID_MP3.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVEFACTORY_ID_OGG Macro

STARWAVEFACTORY_ID_OGG Macro
StarBurn.h | Macros
Collapse All
C++
#define STARWAVEFACTORY_ID_OGG "6DE5E9B0-7D81-480b-94F4-F3C96C172C38"
File

StarBurn.h

Description

This is macro STARWAVEFACTORY_ID_OGG.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVEFACTORY_ID_WAV Macro

STARWAVEFACTORY_ID_WAV Macro
StarBurn.h | Macros
Collapse All
C++
#define STARWAVEFACTORY_ID_WAV "242C65F5-9B18-4a9b-BA0F-FF498A2E7AB7"
File

StarBurn.h

Description

StarWave2 factory ids

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


STARWAVEFACTORY_ID_WMA Macro

STARWAVEFACTORY_ID_WMA Macro
StarBurn.h | Macros
Collapse All
C++
#define STARWAVEFACTORY_ID_WMA "DFE900CD-DC98-493a-A0C5-EC3F7A8A6724"
File

StarBurn.h

Description

This is macro STARWAVEFACTORY_ID_WMA.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_NO Macro

SUBCHANNEL_NO Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_NO 0x00 // No sub-channel
File

StarBurn.h

Description

No sub-channel

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_PQ Macro

SUBCHANNEL_PQ Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_PQ 0x02 // PQ sub-channel
File

StarBurn.h

Description

PQ sub-channel

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_PQ_SIZE_IN_UCHARS Macro

SUBCHANNEL_PQ_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_PQ_SIZE_IN_UCHARS 16 // PQ sub-channel size in UCHARs
File

StarBurn.h

Description

PQ sub-channel size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_RAW_PW Macro

SUBCHANNEL_RAW_PW Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_RAW_PW 0x01 // RAW P-W sub-channel
File

StarBurn.h

Description

RAW P-W sub-channel

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS Macro

SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS 96 // Raw P-W sub-channel size in UCHARs
File

StarBurn.h

Description

Raw P-W sub-channel size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_RESERVED Macro

SUBCHANNEL_RESERVED Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_RESERVED 0x03 // Reserved
File

StarBurn.h

Description

Reserved

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_RW Macro

SUBCHANNEL_RW Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_RW 0x04 // R-W sub-channel
File

StarBurn.h

Description

R-W sub-channel

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


SUBCHANNEL_SIZE_IN_UCHARS Macro

SUBCHANNEL_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define SUBCHANNEL_SIZE_IN_UCHARS 12 // Sub-channel size in UCHARs
File

StarBurn.h

Description

Sub-channel size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TRACK_NUMBER_INVISIBLE Macro

TRACK_NUMBER_INVISIBLE Macro
StarBurn.h | Macros
Collapse All
C++
#define TRACK_NUMBER_INVISIBLE 0xFF
File

StarBurn.h

Description

Special "invisible" track number

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TYPE_CODE_LAST_CHANCE Macro

TYPE_CODE_LAST_CHANCE Macro
StarBurn.h | Macros
Collapse All
C++
#define TYPE_CODE_LAST_CHANCE 0x02 // Logical Unit region is set. Additional restrictions required to make a change
File

StarBurn.h

Description

Logical Unit region is set. Additional restrictions required to make a change

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TYPE_CODE_NONE Macro

TYPE_CODE_NONE Macro
StarBurn.h | Macros
Collapse All
C++
#define TYPE_CODE_NONE 0x00 // No Logical Unit region setting
File

StarBurn.h

Description

No Logical Unit region setting

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TYPE_CODE_PERM Macro

TYPE_CODE_PERM Macro
StarBurn.h | Macros
Collapse All
C++
#define TYPE_CODE_PERM 0x03 // Logical Unit region has been set permanently, but may be reset by vendor if necessery
File

StarBurn.h

Description

Logical Unit region has been set permanently, but may be reset by vendor if necessery

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


TYPE_CODE_SET Macro

TYPE_CODE_SET Macro
StarBurn.h | Macros
Collapse All
C++
#define TYPE_CODE_SET 0x01 // Logical Unit region is set
File

StarBurn.h

Description

Logical Unit region is set

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FILE_SET_DESCRIPTOR_LBA Macro

UDF_FILE_SET_DESCRIPTOR_LBA Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_FILE_SET_DESCRIPTOR_LBA ( UDF_ISO9660_FILE_SYSTEM_LBA + UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS )
File

StarBurn.h

Description

UDF file set descriptor logical block address

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA Macro

UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA ( 1 + UDF_FILE_SET_DESCRIPTOR_LBA )
File

StarBurn.h

Description

UDF file set descriptor terminator logical block address

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_FIRST_ANCHOR_LBA Macro

UDF_FIRST_ANCHOR_LBA Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_FIRST_ANCHOR_LBA 256
File

StarBurn.h

Description

First anchor volume descriptor pointer LBA

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS Macro

UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS ( UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA + 1 )
File

StarBurn.h

Description

UDF head size in logical blocks

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_ISO9660_FILE_SYSTEM_LBA Macro

UDF_ISO9660_FILE_SYSTEM_LBA Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_ISO9660_FILE_SYSTEM_LBA 257
File

StarBurn.h

Description

UDF/ISO9660 bridge file system logical block address

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS Macro

UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 0
File

StarBurn.h

Description

define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 6

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS Macro

UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS 2048
File

StarBurn.h

Description

UDF logical block size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_NAME_SIZE_IN_UCHARS Macro

UDF_NAME_SIZE_IN_UCHARS Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_NAME_SIZE_IN_UCHARS 255
File

StarBurn.h

Description

UDF longest name size in UCHARs

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_NAME_SIZE_IN_UCHARS_ACTUAL Macro

UDF_NAME_SIZE_IN_UCHARS_ACTUAL Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_NAME_SIZE_IN_UCHARS_ACTUAL 127
File

StarBurn.h

Description

This is macro UDF_NAME_SIZE_IN_UCHARS_ACTUAL.

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_NSR_DESCRIPTOR_LBA Macro

UDF_NSR_DESCRIPTOR_LBA Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_NSR_DESCRIPTOR_LBA 17
File

StarBurn.h

Description

UDF NSR descriptor pointer LBA

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS Macro

UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS Macro
StarBurn.h | Macros
Collapse All
C++
#define UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS 256
File

StarBurn.h

Description

UDF tail size in logical blocks

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_ALIGNMENT Macro

WAVE_FILE_ALIGNMENT Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_ALIGNMENT 4
File

StarBurn.h

Description

WAVE file data alignment (4 UCHARs, 1 ULONG)

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_BITS_PER_SAMPLE Macro

WAVE_FILE_BITS_PER_SAMPLE Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_BITS_PER_SAMPLE 16
File

StarBurn.h

Description

WAVE file bits per sample

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_CHANNELS Macro

WAVE_FILE_CHANNELS Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_CHANNELS 2
File

StarBurn.h

Description

WAVE file number of channels

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_DATA_SIGNATURE Macro

WAVE_FILE_DATA_SIGNATURE Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_DATA_SIGNATURE ( ULONG )( 'atad' )
File

StarBurn.h

Description

WAVE file DATA signature

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_RIFF_SIGNATURE Macro

WAVE_FILE_RIFF_SIGNATURE Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_RIFF_SIGNATURE ( ULONG )( 'FFIR' )
File

StarBurn.h

Description

WAVE file RIFF signature

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_SAMPLES_PER_SECOND Macro

WAVE_FILE_SAMPLES_PER_SECOND Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_SAMPLES_PER_SECOND 44100
File

StarBurn.h

Description

WAVE file samples per second

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_TAG_SIGNATURE Macro

WAVE_FILE_TAG_SIGNATURE Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_TAG_SIGNATURE ( ULONG )( ' tmf' )
File

StarBurn.h

Description

WAVE file TAG signature

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_WAVE_FORMAT Macro

WAVE_FILE_WAVE_FORMAT Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_WAVE_FORMAT 1
File

StarBurn.h

Description

WAVE file WAVE format

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WAVE_FILE_WAVE_SIGNATURE Macro

WAVE_FILE_WAVE_SIGNATURE Macro
StarBurn.h | Macros
Collapse All
C++
#define WAVE_FILE_WAVE_SIGNATURE ( ULONG )( 'EVAW' )
File

StarBurn.h

Description

WAVE file WAVE signature

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


WRITE_REPORT_DELAY_IN_SECONDS Macro

WRITE_REPORT_DELAY_IN_SECONDS Macro
StarBurn.h | Macros
Collapse All
C++
#define WRITE_REPORT_DELAY_IN_SECONDS 1
File

StarBurn.h

Description

Default write report delay in seconds

Group

Macros

Links
StarBurn.h, Macros
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


Files

Files
Files
Collapse All

The following table lists files in this documentation.

Files
Name | Description
StarBurn.h | This is file StarBurn.h.
Links
Files
Copyright (c) 2001-2016 Rocket Division Software, StarBurn Software. All rights reserved.


StarBurn.h

StarBurn.h
Enumerations | Functions | Files | Legend | Macros | Structures | Types
Collapse All

This is file StarBurn.h.

Enumerations
Name | Description
_CALLBACK_NUMBER | Enum that represents callback number
_DISC_TYPE | Enum that represents inserted disc type
_ERASE_TYPE | Enum that represents erase type
_EXCEPTION_NUMBER | Enum that represents exception number
_FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
_FILE_TREE | Enum that represents file tree
_ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
_NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
_READ_MODE | Enum that represents raw read modes
_STARBURN_CD_MODE | Enum that represents CD modes type
_STARBURN_ELTORITO_MEDIA | Media emulation types
_STARBURN_ELTORITO_PLATFORM | ElTorito platform types
_STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
_STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
_STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
_STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
_STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
_STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
_STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
_STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_UDF_OS_CLASS | UDF OS class
_UDF_VERSION | Enum that represents UDF version
_WRITE_MODE | Enum that represents write modes
CALLBACK_NUMBER | Enum that represents callback number
DISC_TYPE | Enum that represents inserted disc type
ERASE_TYPE | Enum that represents erase type
EXCEPTION_NUMBER | Enum that represents exception number
FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
FILE_TREE | Enum that represents file tree
ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PCALLBACK_NUMBER | Enum that represents callback number
PDISC_TYPE | Enum that represents inserted disc type
PERASE_TYPE | Enum that represents erase type
PEXCEPTION_NUMBER | Enum that represents exception number
PFILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
PFILE_TREE | Enum that represents file tree
PISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
PNAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PPSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PPSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PPSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PPSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PREAD_MODE | Enum that represents raw read modes
PSTARBURN_CD_MODE | Enum that represents CD modes type
PSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PSTARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
PSTARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
PSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PWRITE_MODE | Enum that represents write modes
READ_MODE | Enum that represents raw read modes
STARBURN_CD_MODE | Enum that represents CD modes type
STARBURN_ELTORITO_MEDIA | Media emulation types
STARBURN_ELTORITO_PLATFORM | ElTorito platform types
STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
UDF_OS_CLASS | UDF OS class
UDF_VERSION | Enum that represents UDF version
WRITE_MODE | Enum that represents write modes
Functions
Name | Description
StarBurn_CdvdBurnerGrabber_AuthorizeDVD | This function authorizes DVD that has CSS protection system.
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx | This function authorizes DVD that has CSS protection system and keeps bus key for disc key.
StarBurn_CdvdBurnerGrabber_Blank | This function erases the rewritable media inserted into CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormat | This function formats Blu-Ray rewritable media (BD-RE) inserted into the Blu-Ray burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery | This function queries available Blu-Ray formats for the currently inserted Blu-Ray rewritable media (BD-RE).
StarBurn_CdvdBurnerGrabber_Cancel | This function cancels current read or write process on the CD/DVD/Blu-Ray/HD-DVD burner.
StarBurn_CdvdBurnerGrabber_CloseSession | This function closes session on on CD/DVD/Blu-Ray/HD-DVD burner device after something was written using StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile.
StarBurn_CdvdBurnerGrabber_Create | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD releated actions.
StarBurn_CdvdBurnerGrabber_CreateEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTI (SCSI Pass Through Interface) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_CreateExEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTD (SCSI Pass Through Direct) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode | This API accepts track names in Unicode format and does AUDIO only DAO burn.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_Eject | This function ejects the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ExecuteGeneric | This function executes custom CDB (Command Descriptor Block) on CD/DVD/Blu-Ray/HD-DVD burner device object. This could be used to deal with the propriatry hardware or execute some special code StarBurn does not support out-of-box.
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetBUP | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device supports BUP (Buffer Underrun Protection) or not and what is BUP current status (if supported). This information can be used later to set BUP status before starting write operations.
StarBurn_CdvdBurnerGrabber_GetDeviceInformation | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode | This is function StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode.
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem | This function detects recorded optical disc file system.
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace | This function gets disc free space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscInformation | This function gets disc information of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace | This function gets disc used space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem | This function gets DVD protection system of inserted DVD media into DVD device.
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask | This function gets DVD region mask from DVD media inserted to CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType | This function returns inserted to CD/DVD/Blu-Ray/HD-DVD burner device disc type. This data can be used to report it to the user and to select the stream type to record.
StarBurn_CdvdBurnerGrabber_GetLastAddress | This function gets last recorded address from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such an address could be used for already recorded session import with the UDF mastering.
StarBurn_CdvdBurnerGrabber_GetLastTrack | This function gets last recorded track from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such a track number could be used for already recorded session import.
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions | This function gets mechanical options (is device capable of programmatically load/eject and lock/unlock etc) from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus | This function gets media (inserted or not) and tray (opened or closed) statuses from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors | This function gets number of system descriptors in system structures stream. This value is used for updating head of the image when creating signle track session import code.
StarBurn_CdvdBurnerGrabber_GetRPC | This function gets RPC (region play code) and some additional DVD region management information from "DVD part" of the CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetSpeeds | This function gets current read and write and top supported read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device. This speeds later will be used to set current speeds during all read and write operations.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx | This function returns DVD+R(W) burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx | This function returns DVD+R(W) burner device object extended extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetTOCInformation | This function gets TOC information of the currently inserted disc in the CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformation | This function gets track information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx | This function gets track extended information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabCD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format.
StarBurn_CdvdBurnerGrabber_GrabDVD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files.
StarBurn_CdvdBurnerGrabber_GrabDVDEx | This function grabs disc image (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. StarBurn_CdvdBurnerGrabber_GrabDVDEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabDVDFast | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. Works faster than StarBurn_CdvdBurnerGrabber_GrabDVD
StarBurn_CdvdBurnerGrabber_GrabRange | This function grabs range of logical blocks from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrack | This function grabs track from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrackEx | This function grabs track (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device. StarBurn_CdvdBurnerGrabber_GrabTrackEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode | This is function StarBurn_CdvdBurnerGrabber_GrabTrackUnicode.
StarBurn_CdvdBurnerGrabber_IsDiscBlank | This function detect blank state of currently inserted disc in CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_Load | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_LoadEx | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device. Unlike StarBurn_CdvdBurnerGrabber_Load(...) this API call allows to control should it return immediately or wait until the drive would become into ready state.
StarBurn_CdvdBurnerGrabber_Lock | This function locks the media inside the CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_MSFToLBA | This function converts MSF (minute:second:frame) address into the LBA (logical block address).
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadATIP | This function reads ATIP information from the media currently inserted into CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_ReadCooked | This function reads one or more logical block(s) from the currently inserted CD/DVD/Blu-Ray/HD-DVD in cooked format.
StarBurn_CdvdBurnerGrabber_ReadLB | This function reads one logical block from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadRaw | This function reads one or more logical block(s) from the currently inserted CD in RAW format.
StarBurn_CdvdBurnerGrabber_Release | This function releases the media inside the CD/DVD/Blu-Ray/HD-DVD device after the media was locked before.
StarBurn_CdvdBurnerGrabber_SendOPC | This function sends OPC (Optimum Power Calibration) for current write speed on CD/DVD/Blu-Ray/HD-DVD burner device and current CD/DVD/Blu-Ray/HD-DVD media. The set laser level will be used later during all write operations.
StarBurn_CdvdBurnerGrabber_SessionAtOnce | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create or ISO image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW | This function records raw image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in raw Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode.
StarBurn_CdvdBurnerGrabber_SetBUP | This function sets BUP (Buffer Underrun Protection) on CD/DVD/Blu-Ray/HD-DVD burner device that supports BUP. BUP must be enabled for successful completion of write operations.
StarBurn_CdvdBurnerGrabber_SetCDTextItem | Sets CD-Text item for the specified CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_SetReadSpeed | This function sets read speed for CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_SetSpeeds | This function sets current read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device This speeds later will be used during all read and write operations.
StarBurn_CdvdBurnerGrabber_StopPlayScan | This function resets media state inside CD/DVD/Blu-Ray/HD-DVD burner device object. This actions allow to update disc content w/o need to eject the disc. Could be used for multiple burnings w/o disc eject or manual disc data verification.
StarBurn_CdvdBurnerGrabber_SuperVideoCD | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode.
StarBurn_CdvdBurnerGrabber_TestUnitReady | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations.
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. The only difference between this and simple StarBurn_CdvdBurnerGrabber_TestUnitReady() is that this code passed parameter to wait for unit to become ready. And "simple" code uses default timeout of 20 seconds.
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. This "double extended" variant of the call also can wait for particular amount of seconds and do "fast exit" if there's no disc in drive.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode | This API call deals with audio tracks with Unicode names only.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx | This API call deals with audio tracks with Unicode names only. Also it allows to set track-to-track pause length.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode. If audio content is recorded this API call can change default Track-At-Once track-to-track pause length from 150 logical blocks (2 seconds) to any passed one.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe | This function records ISO9660 or Joliet file system image located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx | This function records ISO9660 or Joliet file system image or audio stream located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup | This function parses the UDF file system on disc and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx | This function parses the UDF file system on disc and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_VerifyFile | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileEx | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode.
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileUnicode.
StarBurn_CdvdBurnerGrabber_VerifyTree | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyTreeEx | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VideoCD | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_VideoCDEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDUnicode.
StarBurn_CorrectISO9660Name_Default | This function generates next ISO9660 file name to make it unique.
StarBurn_CorrectJolietName_Default | This function generates next Joliet file name to make it unique.
StarBurn_CreatePipe | This function creates pipe for all of the StarBurn pipe operations and returns both "read" and "write" handles for it.
StarBurn_Destroy | This function frees allocated memory in the way of destroying the object that toolkit created internally. This is universal call, it frees all the objects and does not care about object type.
StarBurn_DestroyPipe | This function closes both "read" and "write" pipe handles.
StarBurn_DownShut | This function uninitialize burning toolkit. It's expected to be called after very last function call before exiting from StarBurn client application. It's a good idea to gather the trash before exiting. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used.
StarBurn_DVDVideo_Create | This function creates DVD-Video file system object from passed pointer to VIDEO_TS directory with DVD corresponding files.
StarBurn_DVDVideo_CreateUnicode | This is function StarBurn_DVDVideo_CreateUnicode.
StarBurn_DVDVideo_Destroy | This function destroys DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetSizeInUCHARs | This function gets file system content size in UCHARs from DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetTreePointer | This function returns pointer to ISO9660 file tree object embedded to DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_PatchHeader | This function patches IFO/BUF file header RBA for BUP.
StarBurn_DVDVideo_PatchTable | This function patches IFO/BUF file table RBAs.
StarBurn_DVDVideo_Read | This function reads requested number of UCHARs from DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) from it's current read position.
StarBurn_DVDVideo_SeekToBegin | This function moves DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) current read position to the very beginning.
StarBurn_ElTorito_BootCatalogAddSection | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_BootCatalogAddSectionUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_ElTorito_CreateBootCatalog | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_CreateBootCatalogUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_FileClose | This fucntion closes file handle embedded to file object.
StarBurn_FileCreate | This function creates new file from the passed file path and name.
StarBurn_FileInitialize | This function initializes file handle embedded to file object with bad file handle value.
StarBurn_FileOpen | This function opens existing file from the passed file path and name.
StarBurn_FileOpenEx | This function opens existing file from the passed file path and name.
StarBurn_FileRead | This function reads asked amount of unsigned chars from file at current seek position.
StarBurn_FileReWind | This function rewinds file position in unsigned chars to the very beginning for the file.
StarBurn_FileSeek | This function sets file position in unsigned chars to required one.
StarBurn_FileSeekRead | This function sets file position in unsigned chars to required one and reads requested amounts unsigned chars.
StarBurn_FileSizeInUCHARsGet | This function gets file size in unsigned chars.
StarBurn_FileUnicodeCreate | This function creates new file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpen | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpenEx | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileWrite | This function writes asked amount of unsigned chars to file at current seek position
StarBurn_FindDevice | This function finds device of the specified device type.
StarBurn_GetAudioFileStreamSizeInUCHARs | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast | This is function StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast.
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode | This is function StarBurn_GetAudioFileStreamSizeInUCHARsUnicode.
StarBurn_GetBufferUnderrunTimeOutInMs | This function returns buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_GetDeviceLetter | This function returns device letter (device root path) for a device name, like the one used in StarBurn_CdvdBurnerGrabber_CreateEx(...) API call.
StarBurn_GetDeviceLetterUnicode | This is function StarBurn_GetDeviceLetterUnicode.
StarBurn_GetDeviceNameByDeviceAddress | This function gets device name by device address.
StarBurn_GetDeviceTimeOutByDeviceAddress | This function gets device timeout in seconds by device SCSI address.
StarBurn_GetDVDPadding | This function returns is DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) enabled (TRUE) or disabled (FALSE).
StarBurn_GetDVDPLUSRDLCompatibleMode | This function returns is DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) enabled (TRUE) or disabled (FALSE).
StarBurn_GetEjectAfterFail | This function returns is so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) enabled (TRUE) or disabled (FALSE).
StarBurn_GetFastReadTOC | This function returns is so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn trys to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode enabled (TRUE) or disabled (FALSE).
StarBurn_GetId | This function gets ASPI layer ID strings.
StarBurn_GetIs64KBIO | This function returns is so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) currently enabled (TRUE) or disabled (FALSE).
StarBurn_GetIsCollisionDetectionDisabled | This function returns is collision detection disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_GetIsSafeGrabbingEnabled | This function returns is so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) enabled (TRUE) or disabled (FALSE).
StarBurn_GetVersion | This function returns a 32-bit unsigned long value that contains packed numbers that represent the year, the month and the date of the toolkit build. So 10th of March, year of 1978 will look like 0x19780310.
StarBurn_GetVolumeIDs | This function gets volume ID from ISO9660/Joliet volume name.
StarBurn_ImageFile_UDFFileSystemLookup | This function parses the UDF file system inside image file and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_ImageFile_UDFFileSystemLookupEx | This function parses the UDF file system inside image file and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_IsAudioFileSupported | This function returns is currently passed file supported as source audio file.
StarBurn_IsAudioFileSupportedUnicode | This is function StarBurn_IsAudioFileSupportedUnicode.
StarBurn_IsLocalDateTimeUsed | This is function StarBurn_IsLocalDateTimeUsed.
StarBurn_ISO2_Check1999Name | This function checks if given string valid ISO9660:1999 file (or directory) name
StarBurn_ISO2_CheckJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name
StarBurn_ISO2_CheckLevel1Name | This function checks if given string valid ISO9660 Level 1 file (or directory) name
StarBurn_ISO2_CheckLevel2Name | This function checks if given string valid ISO9660 Level 2 file (or directory) name
StarBurn_ISO2_CheckRelaxedJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name with less restrictions: names may contain more than one dot.
StarBurn_ISO2_CreateNewName | This function creates new ANSI name by adding ~XX (where XX is a number (Seed)) at the end of file name.
StarBurn_ISO2_DirectoryBrowse | This function browses ISO9660 directory content.
StarBurn_ISO2_DirectoryCreate | This function creates ISO9660 directory.
StarBurn_ISO2_DirectoryDestroy | This function destroys created ISO9660 directory object.
StarBurn_ISO2_DirectoryProcess | This function processes single ISO9660 directory.
StarBurn_ISO2_DirectoryQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_DirectoryRootCreate | This function creates root ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeCreate | This function creates UNICODE ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeProcess | This function processes single UNICODE ISO9660 directory.
StarBurn_ISO2_FileCreate | This function creates ISO9660 file.
StarBurn_ISO2_FileDestroy | This function destroys created ISO9660 file object.
StarBurn_ISO2_FileDirectoryDateTimeGet | This function gets date and time from created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryDateTimeSet | This function sets date and time on created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryNameSet | This function set new name for ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for ISO9660 file or directory object.
StarBurn_ISO2_FileMemoryCreate | This function creates ISO9660 memory file.
StarBurn_ISO2_FileMemoryUnicodeCreate | This function creates Unicode ISO9660 memory file.
StarBurn_ISO2_FileQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_FileSetAttributes | This function sets attributes for ISO9660 file.
StarBurn_ISO2_FileUnicodeCreate | This function creates UNICODE ISO9660 file.
StarBurn_ISO2_ImpVolumeCreate | This function processes contents of single UNICODE ISO9660 directory. __stdcall StarBurn_ISO2_DirectoryContentsUnicodeProcess( const unsigned short *UnicodePathName, unsigned long *GUID, void *Root, PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Callback, const void *Context, STARBURN_ISO2_FILE_DATE_TIME *DateTime ); This function creates ISO9660 import volume.
StarBurn_ISO2_ImpVolumeDestroy | This function destroys created ISO9660 import volume object.
StarBurn_ISO2_ImpVolumeImport | This function imports ISO9660 import volume content.
StarBurn_ISO2_ISO9660FileTreeCreate | This function create ISO image from already created ISO9660 volume.
StarBurn_ISO2_VolumeCreate | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateBoot | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateBootElTorito | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateEx | This function creates ISO9660 volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateExBoot | This function creates ISO9660 bootable volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateUnicode | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateUnicodeBoot | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeDescriptorsBufferGet | This function get ISO9660 volume descriptors buffer.
StarBurn_ISO2_VolumeDestroy | This function destroys created ISO9660 volume object.
StarBurn_ISO2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_ISO2_VolumeSizeInUCHARsGet | This function get ISO9660 volume size in unsigned chars.
StarBurn_ISO9660JolietFileTree_Add | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddEx | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddMemory | This function adds the node created from the memory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddW | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations. Unlike other tree management calls this one deals with Unicode names (wide char variant of basic call).
StarBurn_ISO9660JolietFileTree_AddZeroFile | This function adds the new "filled with zeros" file to already created ISO9660 or Joliet file tree. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_BuildImage | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_BuildImageEx | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media. It's identical to StarBurn_ISO9660JolietFileTree_BuildImage except has some extra parameter to put into file system descriptor.
StarBurn_ISO9660JolietFileTree_Cancel | This function cancel ISO9660 or Joliet file tree creation process.
StarBurn_ISO9660JolietFileTree_Create | This function allocates in the memory and initializes ISO9660 or Joliet file tree. Later this file tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be recorder directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate buffering operations on the hard disk.
StarBurn_ISO9660JolietFileTree_GetAttributes | This function returns ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_GetAutoSorting | This function returns ISO9660 or Joliet file tree node sorting mode.
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs | This function returns ISO9660 or Joliet file tree file size in UCHARs.
StarBurn_ISO9660JolietFileTree_GetFirstKid | This function returns ISO9660 or Joliet file tree node first kid pointer.
StarBurn_ISO9660JolietFileTree_GetFullPath | This function returns full path to ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetKidType | This function returns type of ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetLevel | This function returns ISO9660 or Joliet file tree level. The number of levels in the created tree.
StarBurn_ISO9660JolietFileTree_GetNames | This function returns ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_ISO9660JolietFileTree_GetNamesEx | This function returns ISO9660 or Joliet file tree node names (long, short and absolute). Also it returns file system dependent names in ANSI and Unicode.
StarBurn_ISO9660JolietFileTree_GetNamesW | StarBurn_ISO9660JolietFileTree_GetNamesW function is not documented
StarBurn_ISO9660JolietFileTree_GetNextKid | This function returns ISO9660 or Joliet file tree root node next kid pointer.
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime | This function returns ISO9660 or Joliet file tree node ISO9660 time stamp (date and time).
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs | This function returns ISO9660 or Joliet file tree node power (file size) in UCHARs.
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA | This function returns ISO9660 or Joliet file tree node starting LBA after the image was built.
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime | This function returns ISO9660 or Joliet file tree node SYSTEMTIME.
StarBurn_ISO9660JolietFileTree_GetParent | This function returns ISO9660 or Joliet file tree node parent pointer.
StarBurn_ISO9660JolietFileTree_GetRoot | This function returns ISO9660 or Joliet file tree root node pointer.
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs | This function returns ISO9660 or Joliet built file system image size in UCHARs.
StarBurn_ISO9660JolietFileTree_ImportFile | This function imports file for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_ImportTrack | This function imports track for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_Read | This function reads ISO9660 or Joliet file system image from current offset into the user's data buffer. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized. The data that is read can be either stored in the file on the hard disk or directly written to CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_Remove | This function deletes ISO9660 or Joliet file tree node and all it's kids.
StarBurn_ISO9660JolietFileTree_SeekToBegin | This function seeks the ISO9660 or Joliet file system image from current offset to the very beginning so read operation will start from the 0 offset of the file system image. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized.
StarBurn_ISO9660JolietFileTree_SetAttributes | This function sets ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_SetAutoSorting | This function sets ISO9660 or Joliet file tree node auto sorting mode.
StarBurn_ISO9660JolietFileTree_SetBootImage | This function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetBootImageEx | This extended function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetNames | This function sets ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_SetBufferUnderrunTimeOutInMs | This function sets buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_SetDeviceTimeOutByDeviceAddress | This function sets device timeout in seconds by device SCSI address.
StarBurn_SetDVDPadding | This function sets DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetDVDPLUSRDLCompatibleMode | This function sets DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetEjectAfterFail | This function sets so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetFastReadTOC | This function sets so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn try to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode to enabled (TRUE) or disabled (FALSE).
StarBurn_SetIs64KBIO | This function sets current so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) to enabled (TRUE) or disabled (FALSE) state.
StarBurn_SetIsCollisionDetectionDisabled | This function sets collision detection to disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_SetIsSafeGrabbingEnabled | This function sets so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetUsingLocalDateTime | This is function StarBurn_SetUsingLocalDateTime.
StarBurn_SetUsingUTCDateTime | This is function StarBurn_SetUsingUTCDateTime.
StarBurn_sprintf_s | This function wrap runtime sprintf_s function. In Visual Studio 2003 function sprintf_s not present.
StarBurn_SPTD_GetVersion | This function checks if the SPTD (SCSI Pass Through Direct) driver is present and gets SPTD driver version.
StarBurn_StarPort_DeviceAddLocal | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceAddLocalEx | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be added persistent.
StarBurn_StarPort_DeviceAddRemote | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be mount persistent.
StarBurn_StarPort_DeviceAddRemoteEx | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceListQueryLocal | This function gets device list from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Unlike StarBurn_StarPort_DeviceListQueryRemote API call which retrieves information about REMOTE device list this call gets information about LOCAL device list.
StarBurn_StarPort_DeviceListQueryRemote | This function gets device list from remote StarWind iSCSI target. StarWind exports RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) targets. Unlike StarBurn_StarPort_DeviceListQueryLocal API call which retreives information about LOCAL device list this call gets information about REMOTE device list.
StarBurn_StarPort_DeviceRemove | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceRemoveEx | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_GetDeviceInformation | This function retrieves device type, vendor ID, product ID and revision for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceLetter | This function retrieves device letter (symbolic link) for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceSCSIAddress | This function retrieves device SCSI address for StarPort device by its target ID.
StarBurn_StarPort_GetVersion | This function checks if the StarPortLite driver is installed and that its API version is equal to the one StarBurn was built with.
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek | This function seeks all of the internal object pointers to the very beginning of it so following read operations would start from the very beginning instead of the currently set position.
StarBurn_StarWave_CompressedFileReaderObjectCreate | This function creates compressed file reader object from passed compressed audio file name.
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode.
StarBurn_StarWave_CompressedFileReaderObjectDestroy | This function destroys compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectRead | This function reads uncompressed payload data chunk from underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate | This is function StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate.
StarBurn_StarWave_CompressedFileRecompress | This function recompresse already compressed file to new one with another compression.
StarBurn_StarWave_CompressedFileRecompressUnicode | This is function StarBurn_StarWave_CompressedFileRecompressUnicode.
StarBurn_StarWave_CompressedFileSupportedIs | This function checks is file name actually points to supported compressed audio file.
StarBurn_StarWave_CompressedFileUncompress | This function uncompresses compressed file to either WAV or RAW PCM.
StarBurn_StarWave_CompressedFileUncompressUnicode | This is function StarBurn_StarWave_CompressedFileUncompressUnicode.
StarBurn_StarWave_CompressedFileWriterObjectCreate | This function creates compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode.
StarBurn_StarWave_CompressedFileWriterObjectDestroy | This function destroys compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectWrite | This function writes uncompressed data chunk to compressed file writer object.
StarBurn_StarWave_UncompressedFileCompress | This function compresses uncompressed file to new one with asked compression.
StarBurn_StarWave_UncompressedFileCompressUnicode | This is function StarBurn_StarWave_UncompressedFileCompressUnicode.
StarBurn_StarWave_UncompressedFileSupportedIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_VersionGet | This function returns StarWave library version.
StarBurn_StarWave2_Convert | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertEx | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertExUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_EncodeMP3OGGFromWAV | This function compress audio file from WAV (44100Hz, 16, stereo) format to MP3 and OGG format.
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode | This is function StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode.
StarBurn_StarWave2_IsFileSupported | This function determines audio file by StarWave2 library supported is.
StarBurn_StarWave2_IsFileSupportedUnicode | This function determines audio file by StarWave2 library supported is.
StarBurn_strcpy_s | This function wrap runtime strcpy_s function. In Visual Studio 2003 function strcpy_s not present.
StarBurn_swprintf_s | This function wrap runtime swprintf_s function. In Visual Studio 2003 oriinal swprintf_s not present.
StarBurn_UDF_Add | Creates the UDF Tree Node
StarBurn_UDF_AddUnicode | This is function StarBurn_UDF_AddUnicode.
StarBurn_UDF_CleanUp | This function removes created UDF tree from the pointed UDF tree node sequentially. Processes file formatted UDF nodes and either closes file handles or frees memory (non-cached vs. cached content).
StarBurn_UDF_Create | StarBurn_UDF_Create() function is obsolete. Use StarBurn_UDF_CreatEx() instead of it
StarBurn_UDF_CreateEx | This function creates UDF tree from the allocated data buffers.
StarBurn_UDF_CreateExUnicode | This is function StarBurn_UDF_CreateExUnicode.
StarBurn_UDF_CreateUnicode | This is function StarBurn_UDF_CreateUnicode.
StarBurn_UDF_Destroy | This function devastates created UDF tree from the pointed root recursively.
StarBurn_UDF_DestroyNodeAndKids | Destroys UDF Tree Node and all its kids
StarBurn_UDF_FormatTreeItemAsDirectory | This function formats UDF tree item as directory.
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode | This is function StarBurn_UDF_FormatTreeItemAsDirectoryUnicode.
StarBurn_UDF_FormatTreeItemAsFile | This function formats UDF tree item as file.
StarBurn_UDF_FormatTreeItemAsFileUnicode | This is function StarBurn_UDF_FormatTreeItemAsFileUnicode.
StarBurn_UDF_GetFirstChild | This function returns the pointer to first child node
StarBurn_UDF_GetNextSibling | This function returns the pointer to next sibling node
StarBurn_UDF_GetNodeObject | Returns the object to current Tree Node
StarBurn_UDF_GetParent | This function returns the pointer to next parent node
StarBurn_UDF_GetPreviousSibling | This function returns the pointer to previous sibling node
StarBurn_UDF2_DirectoryBrowse | This function browses UDF directory content.
StarBurn_UDF2_DirectoryContentsProcess | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsProcessEx | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcess | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryCreate | This function creates UDF directory.
StarBurn_UDF2_DirectoryDestroy | This function destroys created UDF directory object.
StarBurn_UDF2_DirectoryProcess | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessExEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryQuery | This function does query for UDF directory properties.
StarBurn_UDF2_DirectoryRootCreate | This function creates root UDF directory.
StarBurn_UDF2_DirectoryUnicodeCreate | This function creates UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcess | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessExEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_FileBootCreate | This function creates UDF boot file.
StarBurn_UDF2_FileBootUnicodeCreate | This function creates UNICODE UDF boot file.
StarBurn_UDF2_FileCreate | This function creates UDF file.
StarBurn_UDF2_FileDestroy | This function destroys created UDF file object.
StarBurn_UDF2_FileDirectoryDateTimeGet | This function gets date and time from created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeGetEx | This function gets date and time from created UDF file or directory object. It may get creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryDateTimeSet | This function sets date and time on created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeSetEx | This function sets date and time on created UDF file or directory object. It may set creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryNameSet | This function set new name for UDF file or directory object.
StarBurn_UDF2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for UDF file or directory object.
StarBurn_UDF2_FileMemoryCreate | This function creates UDF memory file.
StarBurn_UDF2_FileMemoryUnicodeCreate | This function creates UNICODE UDF memory file.
StarBurn_UDF2_FileQuery | This function do query for UDF file properties.
StarBurn_UDF2_FileSetAttributes | This function sets attributes for UDF file.
StarBurn_UDF2_FileSystemGetSizes | This function calculates UDF file system sizes in Bytes and LBS on the fly ( without build volume ).
StarBurn_UDF2_FileUnicodeCreate | This function creates UNICODE UDF file.
StarBurn_UDF2_ImpVolumeCreate | This function creates UDF import volume.
StarBurn_UDF2_ImpVolumeDestroy | This function destroys created UDF import volume object.
StarBurn_UDF2_ImpVolumeImport | This function imports UDF import volume content.
StarBurn_UDF2_ISO9660FileTreeCreate | This function create ISO image from already created UDF volume.
StarBurn_UDF2_ISO9660FileTreeCreateEx | This function create ISO image from already created UDF volume.
StarBurn_UDF2_VolumeAnchorGet | This function gets first anchor volume descriptor pointer we'll have to replace on rewritable media.
StarBurn_UDF2_VolumeCreate | This function creates UDF 1.02 volume.
StarBurn_UDF2_VolumeCreateBoot | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateEx | This function creates UDF volume.
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeDestroy | This function destroys created UDF volume object.
StarBurn_UDF2_VolumeInitialSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_UDF2_VolumeSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSizeInUCHARsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeStore | This function stores UDF volume to file.
StarBurn_UDF2_VolumeUnicodeCreate | This function creates UDF 1.02 UNICODE volume.
StarBurn_UDF2_VolumeUnicodeCreateBoot | This function creates UDF Unicode Bootable volume.
StarBurn_UDF2_VolumeUnicodeCreateEx | This function creates UDF UNICODE volume.
StarBurn_UDFBridge_CreateEx | This is function StarBurn_UDFBridge_CreateEx.
StarBurn_UDFBridge_CreateExUnicode | This is function StarBurn_UDFBridge_CreateExUnicode.
StarBurn_UpStart | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. License file StarBurn.key is assumed to be located near main application executable. Since StarBurn SDK V12 it's possible to use this call again. It will just enable using embedded evaluational StarBurn SDK key (file shipped with StarBurn SDK... more
StarBurn_UpStartEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. The difference between this call and call to StarBurn_UpStart(...) is that this particular call assumes StarBurn key is being embedded to the application binary and StarBurn_UpStart(...) always looks for StarBurn.key near application executable. Use this API... more
StarBurn_UpStartExEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Unlike StarBurn_UpStartEx(...) API call this one allows to use custom debug output control. See StarBurn_UpStartEx(...) API call for more information about this topic.
Group

Files

Macros
Name | Description
__STARBURN_H__ | Define StarBurn.h to avoid including it more then once
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS | ASPI safe buffer size in UCHARs. ASPI is assumed to support at least 64KB large transfer per time. 64KB - PAGE_SIZE_IN_UCHARS was old default value. Now we'll use DVD_ECC_BLOCK_SIZE_IN_UCHARS as it's smaller and produce better results when dealing with DVD media
AUDIO_LB_SIZE_IN_UCHARS | Audio LB (logical block) size in UCHARs
BLURAY_SPEED_IN_KBPS_1X | Actually 4495.5
BLURAY_SPEED_IN_KBPS_2X | 2X Blu-Ray speed constant (BD-R and BD-RE)
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS | Default buffer status report delay in seconds
CACHE_SIZE_IN_MBS | 64
CD_SPEED_IN_KBPS_10X | 10X CD speed constant
CD_SPEED_IN_KBPS_12X | 12X CD speed constant
CD_SPEED_IN_KBPS_16X | 16X CD speed constant
CD_SPEED_IN_KBPS_1X | 1X CD speed constant
CD_SPEED_IN_KBPS_20X | 20X CD speed constant
CD_SPEED_IN_KBPS_24X | 24X CD speed constant
CD_SPEED_IN_KBPS_2P2X | 2.2X CD speed constant
CD_SPEED_IN_KBPS_2X | 2X CD speed constant
CD_SPEED_IN_KBPS_32X | 32X CD speed constant
CD_SPEED_IN_KBPS_36X | 36X CD speed constant
CD_SPEED_IN_KBPS_3X | 3X CD speed constant
CD_SPEED_IN_KBPS_40X | 40X CD speed constant
CD_SPEED_IN_KBPS_44X | 44X CD speed constant
CD_SPEED_IN_KBPS_48X | 48X CD speed constant
CD_SPEED_IN_KBPS_4X | 4X CD speed constant
CD_SPEED_IN_KBPS_52X | 52X CD speed constant
CD_SPEED_IN_KBPS_56X | 56X CD speed
CD_SPEED_IN_KBPS_6X | 6X CD speed constant
CD_SPEED_IN_KBPS_72X | 72X CD speed
CD_SPEED_IN_KBPS_8X | 8X CD speed constant
CDVD_SPEED_IS_KBPS_MAXIMUM | Top supported CD/DVD/Blu-Ray/HD-DVD speed constant (wildcard)
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES | Default number of read retries during verification process
DEVICES_PER_BUS | Top number of SCSI devices per logical SCSI bus (was 15 originally)
DISC_STATUS_COMPLETE | Disc is complete
DISC_STATUS_EMPTY | Disc is empty
DISC_STATUS_INCOMPLETE | Disc is incomplete
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Doubled...
DVD_ECC_BLOCK_SIZE_IN_LBS | DVD ECC block size in logical blocks (2048 UCHARs each)
DVD_ECC_BLOCK_SIZE_IN_UCHARS | DVD ECC block size in UCHARs. This is true "hardware" logical block size on DVD. It's recommended to have transfers of this size and this size aligned
DVD_PROTECTION_CPRM | DVD with CPRM (Copy-Protected Removable Media) protection
DVD_PROTECTION_CSS | DVD with CSS (Content Scrambling System) protection
DVD_PROTECTION_NONE | DVD w/o any protection system
DVD_SPEED_IN_KBPS_10X | 10X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_12X | 12X DVD speed constant (DVD-R, DVD+R)
DVD_SPEED_IN_KBPS_16X | 16X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_18X | 18X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_1X | 1X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_20X | 20X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_22X | 22X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_24X | 24X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_2DOT4X | 2.4X DVD speed constant (DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_2X | 2X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_32X | 32X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_3X | 3X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_40X | 40X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_48X | 48X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_4X | 4X DVD speed constant (DVD-R, DVD-R DL, DVD-RW, DVD+R, DVD+R DL, DVD+RW and DVD-RAM)
DVD_SPEED_IN_KBPS_50X | 50X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_5X | 5X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_6X | 6X DVD speed constant (DVD-RW)
DVD_SPEED_IN_KBPS_8X | 8X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
ELTORITO_BOOTABLE | Bootable disc ID
ELTORITO_BOOTSYSTEM_ID | Bootable specification signature
ELTORITO_DEF_LOAD_SEGMENT | Real mode code load segment
ELTORITO_NON_BOOTABLE | Non-bootable disc ID
ERROR_FIELD_C2_AND_BLOCK_ERROR | C2 and block error information
ERROR_FIELD_C2_ERROR | C2 error information
ERROR_FIELD_NO_ERROR | No error information
ERROR_FIELD_RESERVED | Reserved
EXPECTED_LB_TYPE_ANY | Accept all LBs
EXPECTED_LB_TYPE_CDDA | Accept only CDDA (CD digital audio) LBs
EXPECTED_LB_TYPE_MODE1 | Accept only MODE1 LBs
EXPECTED_LB_TYPE_MODE2 | Accept only MODE2 LBs (both Form1 and Form2)
EXPECTED_LB_TYPE_MODE2_FORM1 | Accept only MODE2 Form1 LBs
EXPECTED_LB_TYPE_MODE2_FORM2 | Accept only MODE2 Form2 LBs
HARD_DISK_LB_SIZE_IN_UCHARS | Hard disk LB (logical block) size in UCHARs
HEADER_CODE_ALL_HEADERS | Both header and subheader
HEADER_CODE_HEADER_ONLY | 4-byte header
HEADER_CODE_NONE | No header
HEADER_CODE_SUBHEADER_ONLY | MODE2 Form1 or Form2 subheader
ISO9660_DATE_SIZE_IN_UCHARS | ISO9660 date size in UCHARs
ISO9660_FILE_SIZE_IN_UCHARS | ISO9660 file size in UCHARs
ISO9660_NAME_SIZE_IN_UCHARS | ISO9660 name size in UCHARs
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS | ISO9660 volume descriptor system and volume ID size in UCHARs
ISO9660_TREE_LEVEL | ISO9660 top supported file tree level
LAST_SESSION_COMPLETE | Last session is complete
LAST_SESSION_EMPTY | Last session is empty
LAST_SESSION_INCOMPLETE | Last session is incomplete
MODE1_LB_SIZE_IN_UCHARS | MODE1 LB (logical block) size in UCHARs
MODE2_FORM1_LB_SIZE_IN_UCHARS | MODE2 Form1 LB (logical block) size in UCHARs
MODE2_FORM2_LB_SIZE_IN_UCHARS | MODE2 Form2 LB (logical block) size in UCHARs
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS | MODE2 Form2 + 8 UCHARs of subheader LB (logical block) size in UCHARs
MODE2_FORMLESS_LB_SIZE_IN_UCHARS | MODE2 Formless LB (logical block) size in UCHARS
NUMBER_OF_RAW_TRACKS | Top number of raw tracks (including maintenance tracks) on CD/DVD/Blu-Ray/HD-DVD disc. This is calculated based on the worst CD case when all tracks will be in a separate sessions. We need this approximate value to avoid allocating TOC_INFORMATION structure dynamically.
NUMBER_OF_READ_RETRIES | Default number of retries on read operations (if bad block was possibly hit, was 2 originally)
NUMBER_OF_SUBCHANNELS | sub-channels from P to W
NUMBER_OF_TRACKS | Top number of tracks (or border-in/border-out zones) on CD/DVD/Blu-Ray/HD-DVD disc
PAGE_SIZE_IN_UCHARS | Small page size in UCHARs on x86 machines (default allocatable storage)
RAW_LB_PQ_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with PQ sub-channel size in UCHARs
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with RAW P-W sub-channel size in UCHARs
RAW_LB_SIZE_IN_UCHARS | RAW LB (logical block) size in UCHARs
READ_REPORT_DELAY_IN_SECONDS | Default read report delay in seconds
SCSI_DEVICE_DIRECT_ACCESS | SCSI disk device
SCSI_DEVICE_MAGNETO_OPTICAL | SCSI MO (Magneto-Optical) disk device
SCSI_DEVICE_MEDIUM_CHANGER | SCSI jukebox (disc changer) device
SCSI_DEVICE_NETWORK | SCSI network device
SCSI_DEVICE_PRINTER | SCSI printer device
SCSI_DEVICE_PROCESSOR | SCSI processor device
SCSI_DEVICE_RO_DIRECT_ACCESS | SCSI CD/DVD/Blu-Ray/HD-DVD device
SCSI_DEVICE_SCANNER | SCSI scanner device
SCSI_DEVICE_SEQUENTIAL_ACCESS | SCSI tape device
SCSI_DEVICE_UNPRESENT | SCSI device... Is gone!
SCSI_DEVICE_WILDCARD | SCSI device any (wildcard for StarBurn_FindDevice() function)
SCSI_DEVICE_WORM | SCSI WORM (Write-Once-Read-Multiple) device
SHORT_RAW_LB_SIZE_IN_UCHARS | Short (w/o sync and header) RAW LB (logical block) size in UCHARs
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Number of logical blocks on single layer DVD
SMALLEST_CACHE_SIZE_IN_MBS | Smallest cache size in MBs that toolkit will allow to use to buffer "write" operations
SMALLEST_CACHE_SIZE_IN_UCHARS | Smallest cache size in UCHARs that toolkit will allow to use to buffer "write" operations
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_FULL.
STARBURN_BDRE_FORMAT_CERTIFICATION_NO | BD-RE format certification types
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK.
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED.
STARBURN_BDRE_FORMAT_DEFAULT | BD-RE format types
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION | This is macro STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION.
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITH_SPARE_AREA.
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA.
STARBURN_CACHE_SIZE_READ_ONLY | Default cache size for I/O operations
STARBURN_CACHE_SIZE_READ_WRITE | This is macro STARBURN_CACHE_SIZE_READ_WRITE.
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED.
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY | File attributes ( flags for Attributes member of STARBURN_UDF2_FILE_INFO & STARBURN_ISO2_FILE_INFO )
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN.
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT | This is macro StarBurn_CdvdBurnerGrabber_GetDeviceInformationT.
StarBurn_CdvdBurnerGrabber_GrabTrackT | This is macro StarBurn_CdvdBurnerGrabber_GrabTrackT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDT.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT | This is macro StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT.
StarBurn_CdvdBurnerGrabber_VerifyFileExT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileExT.
StarBurn_CdvdBurnerGrabber_VerifyFileT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileT.
StarBurn_CdvdBurnerGrabber_VideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExExT.
StarBurn_CdvdBurnerGrabber_VideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExT.
StarBurn_CdvdBurnerGrabber_VideoCDT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDT.
STARBURN_DEBUG_FACILITY_ALLMESSAGES | Debug facility: Permit All Messages
STARBURN_DEBUG_FACILITY_ALLTARGETS | Debug facility: All targets
STARBURN_DEBUG_FACILITY_CUSTOM | Debug facility: Custom
STARBURN_DEBUG_FACILITY_DEBUG | Debug facility: Permit Debug Messages
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT | Debug facility: Debug output
STARBURN_DEBUG_FACILITY_ERROR | Debug facility: Permit Error Messages
STARBURN_DEBUG_FACILITY_LOG_FILE | Debug facility: Log file
STARBURN_DEBUG_FACILITY_NONE | Debug facility: None
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE | Debug facility: System console
STARBURN_DEBUG_FACILITY_TRACE | Debug facility: Permit Trace Messages
STARBURN_DEBUG_FACILITY_WARNING | Debug facility: Permit Warning Messages
STARBURN_DISC_TYPE_CDDA | Disc type is CDDA (CD-ROM or Digital Audio)
STARBURN_DISC_TYPE_CDI | Disc type is CDI
STARBURN_DISC_TYPE_UNDEFINED | Disc type is undefined
STARBURN_DISC_TYPE_XA | Disc type is CD-ROM XA
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES | DVD-Video maximum number of titles
StarBurn_DVDVideo_CreateT | This is macro StarBurn_DVDVideo_CreateT.
StarBurn_ElTorito_BootCatalogAddSectionT | This is macro StarBurn_ElTorito_BootCatalogAddSectionT.
StarBurn_ElTorito_CreateBootCatalogT | This is macro StarBurn_ElTorito_CreateBootCatalogT.
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARs_FastT.
StarBurn_GetAudioFileStreamSizeInUCHARsT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARsT.
StarBurn_GetDeviceLetterT | TCHAR functions
STARBURN_IMPEX_API | declspec( dllexport )
StarBurn_IsAudioFileSupportedT | This is macro StarBurn_IsAudioFileSupportedT.
StarBurn_ISO2_VolumeCreateBootElToritoT | This is macro StarBurn_ISO2_VolumeCreateBootElToritoT.
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE | This is macro STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE.
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY | This is macro STARBURN_ISO9660_FILE_FLAGS_DIRECTORY.
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE | This is macro STARBURN_ISO9660_FILE_FLAGS_EXISTENCE.
STARBURN_ISO9660_FILE_FLAGS_NONE | ISO9660 file attributes flags
STARBURN_ISO9660_FILE_FLAGS_RECORD | This is macro STARBURN_ISO9660_FILE_FLAGS_RECORD.
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS | ( 4GB - 1 )
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS | This is macro STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS.
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS |
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS | ISO9660 constants (begin)
STARBURN_ISO9660_TYPE_1999 | This is macro STARBURN_ISO9660_TYPE_1999.
STARBURN_ISO9660_TYPE_JOLIET | This is macro STARBURN_ISO9660_TYPE_JOLIET.
STARBURN_ISO9660_TYPE_JOLIET_RELAXED | This is macro STARBURN_ISO9660_TYPE_JOLIET_RELAXED.
STARBURN_ISO9660_TYPE_LEVEL1 | ISO9660 file system type
STARBURN_ISO9660_TYPE_LEVEL2 | This is macro STARBURN_ISO9660_TYPE_LEVEL2.
STARBURN_LOADING_MECHANISM_TYPE_CADDY | Loading mechanism type constants
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE | This is macro STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE.
STARBURN_LOADING_MECHANISM_TYPE_CHANGER | This is macro STARBURN_LOADING_MECHANISM_TYPE_CHANGER.
STARBURN_LOADING_MECHANISM_TYPE_POP_UP | This is macro STARBURN_LOADING_MECHANISM_TYPE_POP_UP.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED1.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED2.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED3.
STARBURN_LOADING_MECHANISM_TYPE_TRAY | This is macro STARBURN_LOADING_MECHANISM_TYPE_TRAY.
STARBURN_PIPE_SIZE_IN_UCHARS | 60, 64 or 32 KB I/O packets
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS | StarBurn smallest split file size in megabytes
StarBurn_StarWave_CompressedFileReaderObjectCreateT | This is macro StarBurn_StarWave_CompressedFileReaderObjectCreateT.
StarBurn_StarWave_CompressedFileRecompressT | This is macro StarBurn_StarWave_CompressedFileRecompressT.
StarBurn_StarWave_CompressedFileUncompressT | This is macro StarBurn_StarWave_CompressedFileUncompressT.
StarBurn_StarWave_CompressedFileWriterObjectCreateT | This is macro StarBurn_StarWave_CompressedFileWriterObjectCreateT.
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS | StarWave recommended I/O buffer size in UCHARs. It's *STRONGLY* recommended to use either it or multiplications of STARWAVE_IO_BUFFER_SIZE_IN_UCHARS as internal calculations and indexations are integer rather then float based
StarBurn_StarWave_UncompressedFileCompressT | This is macro StarBurn_StarWave_UncompressedFileCompressT.
StarBurn_StarWave_UncompressedFileSupportedIsT | This is macro StarBurn_StarWave_UncompressedFileSupportedIsT.
StarBurn_StarWave2_ConvertExT | This is macro StarBurn_StarWave2_ConvertExT.
StarBurn_StarWave2_EncodeMP3OGGFromWAVT | This is macro StarBurn_StarWave2_EncodeMP3OGGFromWAVT.
StarBurn_StarWave2_GetFileReaderAndFactoryT | This is macro StarBurn_StarWave2_GetFileReaderAndFactoryT.
StarBurn_UDF_AddT | This is macro StarBurn_UDF_AddT.
StarBurn_UDF_CreateExT | This is macro StarBurn_UDF_CreateExT.
StarBurn_UDF_CreateT | This is macro StarBurn_UDF_CreateT.
StarBurn_UDF_FormatTreeItemAsDirectoryT | This is macro StarBurn_UDF_FormatTreeItemAsDirectoryT.
StarBurn_UDF_FormatTreeItemAsFileT | This is macro StarBurn_UDF_FormatTreeItemAsFileT.
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS | Name constants
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS | This is macro STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS.
StarBurn_UDF2_VolumeCreateBootElToritoT | This is macro StarBurn_UDF2_VolumeCreateBootElToritoT.
StarBurn_UDFBridge_CreateExT | This is macro StarBurn_UDFBridge_CreateExT.
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS | StarPort device name size in UCHARs
STARWAVEFACTORY_ID_DSHOW | This is macro STARWAVEFACTORY_ID_DSHOW.
STARWAVEFACTORY_ID_MP3 | This is macro STARWAVEFACTORY_ID_MP3.
STARWAVEFACTORY_ID_OGG | This is macro STARWAVEFACTORY_ID_OGG.
STARWAVEFACTORY_ID_WAV | StarWave2 factory ids
STARWAVEFACTORY_ID_WMA | This is macro STARWAVEFACTORY_ID_WMA.
SUBCHANNEL_NO | No sub-channel
SUBCHANNEL_PQ | PQ sub-channel
SUBCHANNEL_PQ_SIZE_IN_UCHARS | PQ sub-channel size in UCHARs
SUBCHANNEL_RAW_PW | RAW P-W sub-channel
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS | Raw P-W sub-channel size in UCHARs
SUBCHANNEL_RESERVED | Reserved
SUBCHANNEL_RW | R-W sub-channel
SUBCHANNEL_SIZE_IN_UCHARS | Sub-channel size in UCHARs
TRACK_NUMBER_INVISIBLE | Special "invisible" track number
TYPE_CODE_LAST_CHANCE | Logical Unit region is set. Additional restrictions required to make a change
TYPE_CODE_NONE | No Logical Unit region setting
TYPE_CODE_PERM | Logical Unit region has been set permanently, but may be reset by vendor if necessery
TYPE_CODE_SET | Logical Unit region is set
UDF_FILE_SET_DESCRIPTOR_LBA | UDF file set descriptor logical block address
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA | UDF file set descriptor terminator logical block address
UDF_FIRST_ANCHOR_LBA | First anchor volume descriptor pointer LBA
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS | UDF head size in logical blocks
UDF_ISO9660_FILE_SYSTEM_LBA | UDF/ISO9660 bridge file system logical block address
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS | define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 6
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS | UDF logical block size in UCHARs
UDF_NAME_SIZE_IN_UCHARS | UDF longest name size in UCHARs
UDF_NAME_SIZE_IN_UCHARS_ACTUAL | This is macro UDF_NAME_SIZE_IN_UCHARS_ACTUAL.
UDF_NSR_DESCRIPTOR_LBA | UDF NSR descriptor pointer LBA
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS | UDF tail size in logical blocks
WAVE_FILE_ALIGNMENT | WAVE file data alignment (4 UCHARs, 1 ULONG)
WAVE_FILE_BITS_PER_SAMPLE | WAVE file bits per sample
WAVE_FILE_CHANNELS | WAVE file number of channels
WAVE_FILE_DATA_SIGNATURE | WAVE file DATA signature
WAVE_FILE_RIFF_SIGNATURE | WAVE file RIFF signature
WAVE_FILE_SAMPLES_PER_SECOND | WAVE file samples per second
WAVE_FILE_TAG_SIGNATURE | WAVE file TAG signature
WAVE_FILE_WAVE_FORMAT | WAVE file WAVE format
WAVE_FILE_WAVE_SIGNATURE | WAVE file WAVE signature
WRITE_REPORT_DELAY_IN_SECONDS | Default write report delay in seconds
Structures
Name | Description
_CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
_DAO_DISC_LAYOUT | Structure that represents DAO disc layout
_DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
_DISC_FILESYSTEM | Structure with disc file system flags
_DISC_LAYOUT | Structure that represents disc layout
_DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
_DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
_FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
_ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
_NAME_COLLISION_INFO | Structure that represents information about name collision
_PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
_SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
_STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
_STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
_STARBURN_DISC_INFORMATION | Structure that represents Disc information
_STARBURN_ISO9660_DIRECTORY_INFO | This is record _STARBURN_ISO9660_DIRECTORY_INFO.
_STARBURN_ISO9660_FILE_INFO | ISO9660 file information
_STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
_STARBURN_TRACK_INFORMATION | Structure that represents Track information
_STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
_STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
_STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
_STARBURN_UDF2_FILE_INFO | UDF file information
_STARPORT_DEVICE_LIST | Structure that represents StarPort device list
_STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
_STARWAVE2_COMPRESSION_PROFILE |
_TOC_ENTRY | Structure that represents TOC entry
_TOC_INFORMATION | Structure that represents TOC information
_UDF_CONTROL_BLOCK | Structure that represents UDF control block
_UDF_FILE_EXTENT | Structure that describes a single file extent
_UDF_FILE_HANDLE | Structure that represents UDF file handle
_UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
_UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_TREE_ITEM | Structure that represents UDF tree item
_WAVE_FILE_HEADER | Structure that represents WAVE file header
_WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
DAO_DISC_LAYOUT | Structure that represents DAO disc layout
DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
DISC_FILESYSTEM | Structure with disc file system flags
DISC_LAYOUT | Structure that represents disc layout
DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
NAME_COLLISION_INFO | Structure that represents information about name collision
PCDB_FAILURE_INFORMATION | Structure that represents CDB failure information
PDAO_DISC_LAYOUT | Structure that represents DAO disc layout
PDAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
PDISC_FILESYSTEM | Structure with disc file system flags
PDISC_LAYOUT | Structure that represents disc layout
PDISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
PDVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
PFULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
PISO9660_DATE_TIME | Structure that represents ISO9660 date and time
PNAME_COLLISION_INFO | Structure that represents information about name collision
PPQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PPSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PPSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PPSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PPSTARWAVE2_COMPRESSION_PROFILE |
PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PSCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
PSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PSTARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
PSTARBURN_DISC_INFORMATION | Structure that represents Disc information
PSTARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
PSTARBURN_TRACK_INFORMATION | Structure that represents Track information
PSTARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
PSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PSTARWAVE2_COMPRESSION_PROFILE |
PTOC_ENTRY | Structure that represents TOC entry
PTOC_INFORMATION | Structure that represents TOC information
PUDF_CONTROL_BLOCK | Structure that represents UDF control block
PUDF_FILE_EXTENT | Structure that describes a single file extent
PUDF_FILE_HANDLE | Structure that represents UDF file handle
PUDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
PUDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_TREE_ITEM | Structure that represents UDF tree item
PWAVE_FILE_HEADER | Structure that represents WAVE file header
PWAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
STARBURN_DISC_INFORMATION | Structure that represents Disc information
STARBURN_ISO9660_DIRECTORY_INFO | This is type STARBURN_ISO9660_DIRECTORY_INFO.
STARBURN_ISO9660_FILE_INFO | ISO9660 file information
STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
STARBURN_TRACK_INFORMATION | Structure that represents Track information
STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
STARBURN_UDF2_FILE_INFO | UDF file information
STARPORT_DEVICE_LIST | Structure that represents StarPort device list
STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
STARWAVE2_COMPRESSION_PROFILE |
TOC_ENTRY | Structure that represents TOC entry
TOC_INFORMATION | Structure that represents TOC information
UDF_CONTROL_BLOCK | Structure that represents UDF control block
UDF_FILE_EXTENT | Structure that describes a single file extent
UDF_FILE_HANDLE | Structure that represents UDF file handle
UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_TREE_ITEM | Structure that represents UDF tree item
WAVE_FILE_HEADER | Structure that represents WAVE file header
WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
Types
Name | Description
CFuncStarWaveConversionCallback | type of callback function
PCALLBACK | Callback type (function of this type must be passed as callback)
PSTARBURN_CLOSEHANDLE_CALLBACK | This is type PSTARBURN_CLOSEHANDLE_CALLBACK.
PSTARBURN_CREATEFILE_CALLBACK | This is type PSTARBURN_CREATEFILE_CALLBACK.
PSTARBURN_DELETEFILE_CALLBACK | This is type PSTARBURN_DELETEFILE_CALLBACK.
PSTARBURN_FILE_OBJECT | Structure that represents StarBurn file object used internally with file I/O
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | This is type PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK.
PSTARBURN_ISO2_COLLISION_CALLBACK | StarBurn ISO name collision handling callback
PSTARBURN_ISO2_PROGRESS_CALLBACK | StarBurn ISO progress callback
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK | StarBurn ISO Unicode name collision handling callback
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK | StarBurn ISO UNICODE progress callback
PSTARBURN_ISO9660_READ_CALLBACK | StarBurn ISO2 read callback (for import)
PSTARBURN_READFILE_CALLBACK | This is type PSTARBURN_READFILE_CALLBACK.
PSTARBURN_SET_FILE_POINTER_CALLBACK | This is type PSTARBURN_SET_FILE_POINTER_CALLBACK.
PSTARBURN_STARWAVE_CALLBACK | StarWave callback passed to I/O functions. Return anything except zero from it to cancel I/O operation
PSTARBURN_UDF2_COLLISION_CALLBACK_EX | StarBurn UDF ansi name collision handling callback
PSTARBURN_UDF2_IMPORT_CALLBACK | StarBurn UDF2 import callback
PSTARBURN_UDF2_PROGRESS_CALLBACK | StarBurn UDF2 progress callback
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX | StarBurn UDF Unicode name collision handling callback
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK | StarBurn UDF2 UNICODE progress callback
PSTARBURN_WRITEFILE_CALLBACK | This is type PSTARBURN_WRITEFILE_CALLBACK.
Links
Enumerations, Functions, Files, Legend, Macros, Structures, Types


Files

Files
Files
Files
Name | Description
StarBurn.h | This is file StarBurn.h.


Functions

Functions
Functions | Legend
Functions
Name | Description
StarBurn_CdvdBurnerGrabber_AuthorizeDVD | This function authorizes DVD that has CSS protection system.
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx | This function authorizes DVD that has CSS protection system and keeps bus key for disc key.
StarBurn_CdvdBurnerGrabber_Blank | This function erases the rewritable media inserted into CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormat | This function formats Blu-Ray rewritable media (BD-RE) inserted into the Blu-Ray burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery | This function queries available Blu-Ray formats for the currently inserted Blu-Ray rewritable media (BD-RE).
StarBurn_CdvdBurnerGrabber_Cancel | This function cancels current read or write process on the CD/DVD/Blu-Ray/HD-DVD burner.
StarBurn_CdvdBurnerGrabber_CloseSession | This function closes session on on CD/DVD/Blu-Ray/HD-DVD burner device after something was written using StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile.
StarBurn_CdvdBurnerGrabber_Create | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD releated actions.
StarBurn_CdvdBurnerGrabber_CreateEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTI (SCSI Pass Through Interface) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_CreateExEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTD (SCSI Pass Through Direct) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode | This API accepts track names in Unicode format and does AUDIO only DAO burn.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_Eject | This function ejects the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ExecuteGeneric | This function executes custom CDB (Command Descriptor Block) on CD/DVD/Blu-Ray/HD-DVD burner device object. This could be used to deal with the propriatry hardware or execute some special code StarBurn does not support out-of-box.
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetBUP | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device supports BUP (Buffer Underrun Protection) or not and what is BUP current status (if supported). This information can be used later to set BUP status before starting write operations.
StarBurn_CdvdBurnerGrabber_GetDeviceInformation | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode | This is function StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode.
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem | This function detects recorded optical disc file system.
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace | This function gets disc free space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscInformation | This function gets disc information of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace | This function gets disc used space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem | This function gets DVD protection system of inserted DVD media into DVD device.
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask | This function gets DVD region mask from DVD media inserted to CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType | This function returns inserted to CD/DVD/Blu-Ray/HD-DVD burner device disc type. This data can be used to report it to the user and to select the stream type to record.
StarBurn_CdvdBurnerGrabber_GetLastAddress | This function gets last recorded address from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such an address could be used for already recorded session import with the UDF mastering.
StarBurn_CdvdBurnerGrabber_GetLastTrack | This function gets last recorded track from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such a track number could be used for already recorded session import.
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions | This function gets mechanical options (is device capable of programmatically load/eject and lock/unlock etc) from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus | This function gets media (inserted or not) and tray (opened or closed) statuses from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors | This function gets number of system descriptors in system structures stream. This value is used for updating head of the image when creating signle track session import code.
StarBurn_CdvdBurnerGrabber_GetRPC | This function gets RPC (region play code) and some additional DVD region management information from "DVD part" of the CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetSpeeds | This function gets current read and write and top supported read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device. This speeds later will be used to set current speeds during all read and write operations.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx | This function returns DVD+R(W) burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx | This function returns DVD+R(W) burner device object extended extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetTOCInformation | This function gets TOC information of the currently inserted disc in the CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformation | This function gets track information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx | This function gets track extended information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabCD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format.
StarBurn_CdvdBurnerGrabber_GrabDVD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files.
StarBurn_CdvdBurnerGrabber_GrabDVDEx | This function grabs disc image (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. StarBurn_CdvdBurnerGrabber_GrabDVDEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabDVDFast | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. Works faster than StarBurn_CdvdBurnerGrabber_GrabDVD
StarBurn_CdvdBurnerGrabber_GrabRange | This function grabs range of logical blocks from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrack | This function grabs track from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrackEx | This function grabs track (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device. StarBurn_CdvdBurnerGrabber_GrabTrackEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode | This is function StarBurn_CdvdBurnerGrabber_GrabTrackUnicode.
StarBurn_CdvdBurnerGrabber_IsDiscBlank | This function detect blank state of currently inserted disc in CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_Load | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_LoadEx | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device. Unlike StarBurn_CdvdBurnerGrabber_Load(...) this API call allows to control should it return immediately or wait until the drive would become into ready state.
StarBurn_CdvdBurnerGrabber_Lock | This function locks the media inside the CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_MSFToLBA | This function converts MSF (minute:second:frame) address into the LBA (logical block address).
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadATIP | This function reads ATIP information from the media currently inserted into CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_ReadCooked | This function reads one or more logical block(s) from the currently inserted CD/DVD/Blu-Ray/HD-DVD in cooked format.
StarBurn_CdvdBurnerGrabber_ReadLB | This function reads one logical block from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadRaw | This function reads one or more logical block(s) from the currently inserted CD in RAW format.
StarBurn_CdvdBurnerGrabber_Release | This function releases the media inside the CD/DVD/Blu-Ray/HD-DVD device after the media was locked before.
StarBurn_CdvdBurnerGrabber_SendOPC | This function sends OPC (Optimum Power Calibration) for current write speed on CD/DVD/Blu-Ray/HD-DVD burner device and current CD/DVD/Blu-Ray/HD-DVD media. The set laser level will be used later during all write operations.
StarBurn_CdvdBurnerGrabber_SessionAtOnce | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create or ISO image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW | This function records raw image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in raw Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode.
StarBurn_CdvdBurnerGrabber_SetBUP | This function sets BUP (Buffer Underrun Protection) on CD/DVD/Blu-Ray/HD-DVD burner device that supports BUP. BUP must be enabled for successful completion of write operations.
StarBurn_CdvdBurnerGrabber_SetCDTextItem | Sets CD-Text item for the specified CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_SetReadSpeed | This function sets read speed for CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_SetSpeeds | This function sets current read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device This speeds later will be used during all read and write operations.
StarBurn_CdvdBurnerGrabber_StopPlayScan | This function resets media state inside CD/DVD/Blu-Ray/HD-DVD burner device object. This actions allow to update disc content w/o need to eject the disc. Could be used for multiple burnings w/o disc eject or manual disc data verification.
StarBurn_CdvdBurnerGrabber_SuperVideoCD | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode.
StarBurn_CdvdBurnerGrabber_TestUnitReady | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations.
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. The only difference between this and simple StarBurn_CdvdBurnerGrabber_TestUnitReady() is that this code passed parameter to wait for unit to become ready. And "simple" code uses default timeout of 20 seconds.
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. This "double extended" variant of the call also can wait for particular amount of seconds and do "fast exit" if there's no disc in drive.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode | This API call deals with audio tracks with Unicode names only.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx | This API call deals with audio tracks with Unicode names only. Also it allows to set track-to-track pause length.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode. If audio content is recorded this API call can change default Track-At-Once track-to-track pause length from 150 logical blocks (2 seconds) to any passed one.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe | This function records ISO9660 or Joliet file system image located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx | This function records ISO9660 or Joliet file system image or audio stream located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup | This function parses the UDF file system on disc and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx | This function parses the UDF file system on disc and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_VerifyFile | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileEx | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode.
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileUnicode.
StarBurn_CdvdBurnerGrabber_VerifyTree | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyTreeEx | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VideoCD | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_VideoCDEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDUnicode.
StarBurn_CorrectISO9660Name_Default | This function generates next ISO9660 file name to make it unique.
StarBurn_CorrectJolietName_Default | This function generates next Joliet file name to make it unique.
StarBurn_CreatePipe | This function creates pipe for all of the StarBurn pipe operations and returns both "read" and "write" handles for it.
StarBurn_Destroy | This function frees allocated memory in the way of destroying the object that toolkit created internally. This is universal call, it frees all the objects and does not care about object type.
StarBurn_DestroyPipe | This function closes both "read" and "write" pipe handles.
StarBurn_DownShut | This function uninitialize burning toolkit. It's expected to be called after very last function call before exiting from StarBurn client application. It's a good idea to gather the trash before exiting. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used.
StarBurn_DVDVideo_Create | This function creates DVD-Video file system object from passed pointer to VIDEO_TS directory with DVD corresponding files.
StarBurn_DVDVideo_CreateUnicode | This is function StarBurn_DVDVideo_CreateUnicode.
StarBurn_DVDVideo_Destroy | This function destroys DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetSizeInUCHARs | This function gets file system content size in UCHARs from DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetTreePointer | This function returns pointer to ISO9660 file tree object embedded to DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_PatchHeader | This function patches IFO/BUF file header RBA for BUP.
StarBurn_DVDVideo_PatchTable | This function patches IFO/BUF file table RBAs.
StarBurn_DVDVideo_Read | This function reads requested number of UCHARs from DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) from it's current read position.
StarBurn_DVDVideo_SeekToBegin | This function moves DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) current read position to the very beginning.
StarBurn_ElTorito_BootCatalogAddSection | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_BootCatalogAddSectionUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_ElTorito_CreateBootCatalog | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_CreateBootCatalogUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_FileClose | This fucntion closes file handle embedded to file object.
StarBurn_FileCreate | This function creates new file from the passed file path and name.
StarBurn_FileInitialize | This function initializes file handle embedded to file object with bad file handle value.
StarBurn_FileOpen | This function opens existing file from the passed file path and name.
StarBurn_FileOpenEx | This function opens existing file from the passed file path and name.
StarBurn_FileRead | This function reads asked amount of unsigned chars from file at current seek position.
StarBurn_FileReWind | This function rewinds file position in unsigned chars to the very beginning for the file.
StarBurn_FileSeek | This function sets file position in unsigned chars to required one.
StarBurn_FileSeekRead | This function sets file position in unsigned chars to required one and reads requested amounts unsigned chars.
StarBurn_FileSizeInUCHARsGet | This function gets file size in unsigned chars.
StarBurn_FileUnicodeCreate | This function creates new file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpen | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpenEx | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileWrite | This function writes asked amount of unsigned chars to file at current seek position
StarBurn_FindDevice | This function finds device of the specified device type.
StarBurn_GetAudioFileStreamSizeInUCHARs | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast | This is function StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast.
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode | This is function StarBurn_GetAudioFileStreamSizeInUCHARsUnicode.
StarBurn_GetBufferUnderrunTimeOutInMs | This function returns buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_GetDeviceLetter | This function returns device letter (device root path) for a device name, like the one used in StarBurn_CdvdBurnerGrabber_CreateEx(...) API call.
StarBurn_GetDeviceLetterUnicode | This is function StarBurn_GetDeviceLetterUnicode.
StarBurn_GetDeviceNameByDeviceAddress | This function gets device name by device address.
StarBurn_GetDeviceTimeOutByDeviceAddress | This function gets device timeout in seconds by device SCSI address.
StarBurn_GetDVDPadding | This function returns is DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) enabled (TRUE) or disabled (FALSE).
StarBurn_GetDVDPLUSRDLCompatibleMode | This function returns is DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) enabled (TRUE) or disabled (FALSE).
StarBurn_GetEjectAfterFail | This function returns is so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) enabled (TRUE) or disabled (FALSE).
StarBurn_GetFastReadTOC | This function returns is so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn trys to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode enabled (TRUE) or disabled (FALSE).
StarBurn_GetId | This function gets ASPI layer ID strings.
StarBurn_GetIs64KBIO | This function returns is so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) currently enabled (TRUE) or disabled (FALSE).
StarBurn_GetIsCollisionDetectionDisabled | This function returns is collision detection disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_GetIsSafeGrabbingEnabled | This function returns is so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) enabled (TRUE) or disabled (FALSE).
StarBurn_GetVersion | This function returns a 32-bit unsigned long value that contains packed numbers that represent the year, the month and the date of the toolkit build. So 10th of March, year of 1978 will look like 0x19780310.
StarBurn_GetVolumeIDs | This function gets volume ID from ISO9660/Joliet volume name.
StarBurn_ImageFile_UDFFileSystemLookup | This function parses the UDF file system inside image file and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_ImageFile_UDFFileSystemLookupEx | This function parses the UDF file system inside image file and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_IsAudioFileSupported | This function returns is currently passed file supported as source audio file.
StarBurn_IsAudioFileSupportedUnicode | This is function StarBurn_IsAudioFileSupportedUnicode.
StarBurn_IsLocalDateTimeUsed | This is function StarBurn_IsLocalDateTimeUsed.
StarBurn_ISO2_Check1999Name | This function checks if given string valid ISO9660:1999 file (or directory) name
StarBurn_ISO2_CheckJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name
StarBurn_ISO2_CheckLevel1Name | This function checks if given string valid ISO9660 Level 1 file (or directory) name
StarBurn_ISO2_CheckLevel2Name | This function checks if given string valid ISO9660 Level 2 file (or directory) name
StarBurn_ISO2_CheckRelaxedJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name with less restrictions: names may contain more than one dot.
StarBurn_ISO2_CreateNewName | This function creates new ANSI name by adding ~XX (where XX is a number (Seed)) at the end of file name.
StarBurn_ISO2_DirectoryBrowse | This function browses ISO9660 directory content.
StarBurn_ISO2_DirectoryCreate | This function creates ISO9660 directory.
StarBurn_ISO2_DirectoryDestroy | This function destroys created ISO9660 directory object.
StarBurn_ISO2_DirectoryProcess | This function processes single ISO9660 directory.
StarBurn_ISO2_DirectoryQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_DirectoryRootCreate | This function creates root ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeCreate | This function creates UNICODE ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeProcess | This function processes single UNICODE ISO9660 directory.
StarBurn_ISO2_FileCreate | This function creates ISO9660 file.
StarBurn_ISO2_FileDestroy | This function destroys created ISO9660 file object.
StarBurn_ISO2_FileDirectoryDateTimeGet | This function gets date and time from created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryDateTimeSet | This function sets date and time on created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryNameSet | This function set new name for ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for ISO9660 file or directory object.
StarBurn_ISO2_FileMemoryCreate | This function creates ISO9660 memory file.
StarBurn_ISO2_FileMemoryUnicodeCreate | This function creates Unicode ISO9660 memory file.
StarBurn_ISO2_FileQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_FileSetAttributes | This function sets attributes for ISO9660 file.
StarBurn_ISO2_FileUnicodeCreate | This function creates UNICODE ISO9660 file.
StarBurn_ISO2_ImpVolumeCreate | This function processes contents of single UNICODE ISO9660 directory. __stdcall StarBurn_ISO2_DirectoryContentsUnicodeProcess( const unsigned short *UnicodePathName, unsigned long *GUID, void *Root, PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Callback, const void *Context, STARBURN_ISO2_FILE_DATE_TIME *DateTime ); This function creates ISO9660 import volume.
StarBurn_ISO2_ImpVolumeDestroy | This function destroys created ISO9660 import volume object.
StarBurn_ISO2_ImpVolumeImport | This function imports ISO9660 import volume content.
StarBurn_ISO2_ISO9660FileTreeCreate | This function create ISO image from already created ISO9660 volume.
StarBurn_ISO2_VolumeCreate | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateBoot | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateBootElTorito | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateEx | This function creates ISO9660 volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateExBoot | This function creates ISO9660 bootable volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateUnicode | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateUnicodeBoot | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeDescriptorsBufferGet | This function get ISO9660 volume descriptors buffer.
StarBurn_ISO2_VolumeDestroy | This function destroys created ISO9660 volume object.
StarBurn_ISO2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_ISO2_VolumeSizeInUCHARsGet | This function get ISO9660 volume size in unsigned chars.
StarBurn_ISO9660JolietFileTree_Add | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddEx | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddMemory | This function adds the node created from the memory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddW | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations. Unlike other tree management calls this one deals with Unicode names (wide char variant of basic call).
StarBurn_ISO9660JolietFileTree_AddZeroFile | This function adds the new "filled with zeros" file to already created ISO9660 or Joliet file tree. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_BuildImage | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_BuildImageEx | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media. It's identical to StarBurn_ISO9660JolietFileTree_BuildImage except has some extra parameter to put into file system descriptor.
StarBurn_ISO9660JolietFileTree_Cancel | This function cancel ISO9660 or Joliet file tree creation process.
StarBurn_ISO9660JolietFileTree_Create | This function allocates in the memory and initializes ISO9660 or Joliet file tree. Later this file tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be recorder directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate buffering operations on the hard disk.
StarBurn_ISO9660JolietFileTree_GetAttributes | This function returns ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_GetAutoSorting | This function returns ISO9660 or Joliet file tree node sorting mode.
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs | This function returns ISO9660 or Joliet file tree file size in UCHARs.
StarBurn_ISO9660JolietFileTree_GetFirstKid | This function returns ISO9660 or Joliet file tree node first kid pointer.
StarBurn_ISO9660JolietFileTree_GetFullPath | This function returns full path to ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetKidType | This function returns type of ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetLevel | This function returns ISO9660 or Joliet file tree level. The number of levels in the created tree.
StarBurn_ISO9660JolietFileTree_GetNames | This function returns ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_ISO9660JolietFileTree_GetNamesEx | This function returns ISO9660 or Joliet file tree node names (long, short and absolute). Also it returns file system dependent names in ANSI and Unicode.
StarBurn_ISO9660JolietFileTree_GetNamesW | StarBurn_ISO9660JolietFileTree_GetNamesW function is not documented
StarBurn_ISO9660JolietFileTree_GetNextKid | This function returns ISO9660 or Joliet file tree root node next kid pointer.
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime | This function returns ISO9660 or Joliet file tree node ISO9660 time stamp (date and time).
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs | This function returns ISO9660 or Joliet file tree node power (file size) in UCHARs.
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA | This function returns ISO9660 or Joliet file tree node starting LBA after the image was built.
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime | This function returns ISO9660 or Joliet file tree node SYSTEMTIME.
StarBurn_ISO9660JolietFileTree_GetParent | This function returns ISO9660 or Joliet file tree node parent pointer.
StarBurn_ISO9660JolietFileTree_GetRoot | This function returns ISO9660 or Joliet file tree root node pointer.
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs | This function returns ISO9660 or Joliet built file system image size in UCHARs.
StarBurn_ISO9660JolietFileTree_ImportFile | This function imports file for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_ImportTrack | This function imports track for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_Read | This function reads ISO9660 or Joliet file system image from current offset into the user's data buffer. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized. The data that is read can be either stored in the file on the hard disk or directly written to CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_Remove | This function deletes ISO9660 or Joliet file tree node and all it's kids.
StarBurn_ISO9660JolietFileTree_SeekToBegin | This function seeks the ISO9660 or Joliet file system image from current offset to the very beginning so read operation will start from the 0 offset of the file system image. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized.
StarBurn_ISO9660JolietFileTree_SetAttributes | This function sets ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_SetAutoSorting | This function sets ISO9660 or Joliet file tree node auto sorting mode.
StarBurn_ISO9660JolietFileTree_SetBootImage | This function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetBootImageEx | This extended function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetNames | This function sets ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_SetBufferUnderrunTimeOutInMs | This function sets buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_SetDeviceTimeOutByDeviceAddress | This function sets device timeout in seconds by device SCSI address.
StarBurn_SetDVDPadding | This function sets DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetDVDPLUSRDLCompatibleMode | This function sets DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetEjectAfterFail | This function sets so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetFastReadTOC | This function sets so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn try to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode to enabled (TRUE) or disabled (FALSE).
StarBurn_SetIs64KBIO | This function sets current so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) to enabled (TRUE) or disabled (FALSE) state.
StarBurn_SetIsCollisionDetectionDisabled | This function sets collision detection to disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_SetIsSafeGrabbingEnabled | This function sets so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetUsingLocalDateTime | This is function StarBurn_SetUsingLocalDateTime.
StarBurn_SetUsingUTCDateTime | This is function StarBurn_SetUsingUTCDateTime.
StarBurn_sprintf_s | This function wrap runtime sprintf_s function. In Visual Studio 2003 function sprintf_s not present.
StarBurn_SPTD_GetVersion | This function checks if the SPTD (SCSI Pass Through Direct) driver is present and gets SPTD driver version.
StarBurn_StarPort_DeviceAddLocal | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceAddLocalEx | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be added persistent.
StarBurn_StarPort_DeviceAddRemote | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be mount persistent.
StarBurn_StarPort_DeviceAddRemoteEx | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceListQueryLocal | This function gets device list from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Unlike StarBurn_StarPort_DeviceListQueryRemote API call which retrieves information about REMOTE device list this call gets information about LOCAL device list.
StarBurn_StarPort_DeviceListQueryRemote | This function gets device list from remote StarWind iSCSI target. StarWind exports RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) targets. Unlike StarBurn_StarPort_DeviceListQueryLocal API call which retreives information about LOCAL device list this call gets information about REMOTE device list.
StarBurn_StarPort_DeviceRemove | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceRemoveEx | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_GetDeviceInformation | This function retrieves device type, vendor ID, product ID and revision for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceLetter | This function retrieves device letter (symbolic link) for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceSCSIAddress | This function retrieves device SCSI address for StarPort device by its target ID.
StarBurn_StarPort_GetVersion | This function checks if the StarPortLite driver is installed and that its API version is equal to the one StarBurn was built with.
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek | This function seeks all of the internal object pointers to the very beginning of it so following read operations would start from the very beginning instead of the currently set position.
StarBurn_StarWave_CompressedFileReaderObjectCreate | This function creates compressed file reader object from passed compressed audio file name.
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode.
StarBurn_StarWave_CompressedFileReaderObjectDestroy | This function destroys compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectRead | This function reads uncompressed payload data chunk from underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate | This is function StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate.
StarBurn_StarWave_CompressedFileRecompress | This function recompresse already compressed file to new one with another compression.
StarBurn_StarWave_CompressedFileRecompressUnicode | This is function StarBurn_StarWave_CompressedFileRecompressUnicode.
StarBurn_StarWave_CompressedFileSupportedIs | This function checks is file name actually points to supported compressed audio file.
StarBurn_StarWave_CompressedFileUncompress | This function uncompresses compressed file to either WAV or RAW PCM.
StarBurn_StarWave_CompressedFileUncompressUnicode | This is function StarBurn_StarWave_CompressedFileUncompressUnicode.
StarBurn_StarWave_CompressedFileWriterObjectCreate | This function creates compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode.
StarBurn_StarWave_CompressedFileWriterObjectDestroy | This function destroys compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectWrite | This function writes uncompressed data chunk to compressed file writer object.
StarBurn_StarWave_UncompressedFileCompress | This function compresses uncompressed file to new one with asked compression.
StarBurn_StarWave_UncompressedFileCompressUnicode | This is function StarBurn_StarWave_UncompressedFileCompressUnicode.
StarBurn_StarWave_UncompressedFileSupportedIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_VersionGet | This function returns StarWave library version.
StarBurn_StarWave2_Convert | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertEx | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertExUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_EncodeMP3OGGFromWAV | This function compress audio file from WAV (44100Hz, 16, stereo) format to MP3 and OGG format.
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode | This is function StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode.
StarBurn_StarWave2_IsFileSupported | This function determines audio file by StarWave2 library supported is.
StarBurn_StarWave2_IsFileSupportedUnicode | This function determines audio file by StarWave2 library supported is.
StarBurn_strcpy_s | This function wrap runtime strcpy_s function. In Visual Studio 2003 function strcpy_s not present.
StarBurn_swprintf_s | This function wrap runtime swprintf_s function. In Visual Studio 2003 oriinal swprintf_s not present.
StarBurn_UDF_Add | Creates the UDF Tree Node
StarBurn_UDF_AddUnicode | This is function StarBurn_UDF_AddUnicode.
StarBurn_UDF_CleanUp | This function removes created UDF tree from the pointed UDF tree node sequentially. Processes file formatted UDF nodes and either closes file handles or frees memory (non-cached vs. cached content).
StarBurn_UDF_Create | StarBurn_UDF_Create() function is obsolete. Use StarBurn_UDF_CreatEx() instead of it
StarBurn_UDF_CreateEx | This function creates UDF tree from the allocated data buffers.
StarBurn_UDF_CreateExUnicode | This is function StarBurn_UDF_CreateExUnicode.
StarBurn_UDF_CreateUnicode | This is function StarBurn_UDF_CreateUnicode.
StarBurn_UDF_Destroy | This function devastates created UDF tree from the pointed root recursively.
StarBurn_UDF_DestroyNodeAndKids | Destroys UDF Tree Node and all its kids
StarBurn_UDF_FormatTreeItemAsDirectory | This function formats UDF tree item as directory.
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode | This is function StarBurn_UDF_FormatTreeItemAsDirectoryUnicode.
StarBurn_UDF_FormatTreeItemAsFile | This function formats UDF tree item as file.
StarBurn_UDF_FormatTreeItemAsFileUnicode | This is function StarBurn_UDF_FormatTreeItemAsFileUnicode.
StarBurn_UDF_GetFirstChild | This function returns the pointer to first child node
StarBurn_UDF_GetNextSibling | This function returns the pointer to next sibling node
StarBurn_UDF_GetNodeObject | Returns the object to current Tree Node
StarBurn_UDF_GetParent | This function returns the pointer to next parent node
StarBurn_UDF_GetPreviousSibling | This function returns the pointer to previous sibling node
StarBurn_UDF2_DirectoryBrowse | This function browses UDF directory content.
StarBurn_UDF2_DirectoryContentsProcess | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsProcessEx | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcess | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryCreate | This function creates UDF directory.
StarBurn_UDF2_DirectoryDestroy | This function destroys created UDF directory object.
StarBurn_UDF2_DirectoryProcess | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessExEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryQuery | This function does query for UDF directory properties.
StarBurn_UDF2_DirectoryRootCreate | This function creates root UDF directory.
StarBurn_UDF2_DirectoryUnicodeCreate | This function creates UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcess | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessExEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_FileBootCreate | This function creates UDF boot file.
StarBurn_UDF2_FileBootUnicodeCreate | This function creates UNICODE UDF boot file.
StarBurn_UDF2_FileCreate | This function creates UDF file.
StarBurn_UDF2_FileDestroy | This function destroys created UDF file object.
StarBurn_UDF2_FileDirectoryDateTimeGet | This function gets date and time from created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeGetEx | This function gets date and time from created UDF file or directory object. It may get creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryDateTimeSet | This function sets date and time on created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeSetEx | This function sets date and time on created UDF file or directory object. It may set creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryNameSet | This function set new name for UDF file or directory object.
StarBurn_UDF2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for UDF file or directory object.
StarBurn_UDF2_FileMemoryCreate | This function creates UDF memory file.
StarBurn_UDF2_FileMemoryUnicodeCreate | This function creates UNICODE UDF memory file.
StarBurn_UDF2_FileQuery | This function do query for UDF file properties.
StarBurn_UDF2_FileSetAttributes | This function sets attributes for UDF file.
StarBurn_UDF2_FileSystemGetSizes | This function calculates UDF file system sizes in Bytes and LBS on the fly ( without build volume ).
StarBurn_UDF2_FileUnicodeCreate | This function creates UNICODE UDF file.
StarBurn_UDF2_ImpVolumeCreate | This function creates UDF import volume.
StarBurn_UDF2_ImpVolumeDestroy | This function destroys created UDF import volume object.
StarBurn_UDF2_ImpVolumeImport | This function imports UDF import volume content.
StarBurn_UDF2_ISO9660FileTreeCreate | This function create ISO image from already created UDF volume.
StarBurn_UDF2_ISO9660FileTreeCreateEx | This function create ISO image from already created UDF volume.
StarBurn_UDF2_VolumeAnchorGet | This function gets first anchor volume descriptor pointer we'll have to replace on rewritable media.
StarBurn_UDF2_VolumeCreate | This function creates UDF 1.02 volume.
StarBurn_UDF2_VolumeCreateBoot | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateEx | This function creates UDF volume.
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeDestroy | This function destroys created UDF volume object.
StarBurn_UDF2_VolumeInitialSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_UDF2_VolumeSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSizeInUCHARsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeStore | This function stores UDF volume to file.
StarBurn_UDF2_VolumeUnicodeCreate | This function creates UDF 1.02 UNICODE volume.
StarBurn_UDF2_VolumeUnicodeCreateBoot | This function creates UDF Unicode Bootable volume.
StarBurn_UDF2_VolumeUnicodeCreateEx | This function creates UDF UNICODE volume.
StarBurn_UDFBridge_CreateEx | This is function StarBurn_UDFBridge_CreateEx.
StarBurn_UDFBridge_CreateExUnicode | This is function StarBurn_UDFBridge_CreateExUnicode.
StarBurn_UpStart | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. License file StarBurn.key is assumed to be located near main application executable. Since StarBurn SDK V12 it's possible to use this call again. It will just enable using embedded evaluational StarBurn SDK key (file shipped with StarBurn SDK... more
StarBurn_UpStartEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. The difference between this call and call to StarBurn_UpStart(...) is that this particular call assumes StarBurn key is being embedded to the application binary and StarBurn_UpStart(...) always looks for StarBurn.key near application executable. Use this API... more
StarBurn_UpStartExEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Unlike StarBurn_UpStartEx(...) API call this one allows to use custom debug output control. See StarBurn_UpStartEx(...) API call for more information about this topic.


Functions

Legend
Legend
Method


Legend

Legend
Functions
Legend
Method


Macros

Macros
Macros
Macros
Name | Description
__STARBURN_H__ | Define StarBurn.h to avoid including it more then once
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS | ASPI safe buffer size in UCHARs. ASPI is assumed to support at least 64KB large transfer per time. 64KB - PAGE_SIZE_IN_UCHARS was old default value. Now we'll use DVD_ECC_BLOCK_SIZE_IN_UCHARS as it's smaller and produce better results when dealing with DVD media
AUDIO_LB_SIZE_IN_UCHARS | Audio LB (logical block) size in UCHARs
BLURAY_SPEED_IN_KBPS_1X | Actually 4495.5
BLURAY_SPEED_IN_KBPS_2X | 2X Blu-Ray speed constant (BD-R and BD-RE)
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS | Default buffer status report delay in seconds
CACHE_SIZE_IN_MBS | 64
CD_SPEED_IN_KBPS_10X | 10X CD speed constant
CD_SPEED_IN_KBPS_12X | 12X CD speed constant
CD_SPEED_IN_KBPS_16X | 16X CD speed constant
CD_SPEED_IN_KBPS_1X | 1X CD speed constant
CD_SPEED_IN_KBPS_20X | 20X CD speed constant
CD_SPEED_IN_KBPS_24X | 24X CD speed constant
CD_SPEED_IN_KBPS_2P2X | 2.2X CD speed constant
CD_SPEED_IN_KBPS_2X | 2X CD speed constant
CD_SPEED_IN_KBPS_32X | 32X CD speed constant
CD_SPEED_IN_KBPS_36X | 36X CD speed constant
CD_SPEED_IN_KBPS_3X | 3X CD speed constant
CD_SPEED_IN_KBPS_40X | 40X CD speed constant
CD_SPEED_IN_KBPS_44X | 44X CD speed constant
CD_SPEED_IN_KBPS_48X | 48X CD speed constant
CD_SPEED_IN_KBPS_4X | 4X CD speed constant
CD_SPEED_IN_KBPS_52X | 52X CD speed constant
CD_SPEED_IN_KBPS_56X | 56X CD speed
CD_SPEED_IN_KBPS_6X | 6X CD speed constant
CD_SPEED_IN_KBPS_72X | 72X CD speed
CD_SPEED_IN_KBPS_8X | 8X CD speed constant
CDVD_SPEED_IS_KBPS_MAXIMUM | Top supported CD/DVD/Blu-Ray/HD-DVD speed constant (wildcard)
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES | Default number of read retries during verification process
DEVICES_PER_BUS | Top number of SCSI devices per logical SCSI bus (was 15 originally)
DISC_STATUS_COMPLETE | Disc is complete
DISC_STATUS_EMPTY | Disc is empty
DISC_STATUS_INCOMPLETE | Disc is incomplete
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Doubled...
DVD_ECC_BLOCK_SIZE_IN_LBS | DVD ECC block size in logical blocks (2048 UCHARs each)
DVD_ECC_BLOCK_SIZE_IN_UCHARS | DVD ECC block size in UCHARs. This is true "hardware" logical block size on DVD. It's recommended to have transfers of this size and this size aligned
DVD_PROTECTION_CPRM | DVD with CPRM (Copy-Protected Removable Media) protection
DVD_PROTECTION_CSS | DVD with CSS (Content Scrambling System) protection
DVD_PROTECTION_NONE | DVD w/o any protection system
DVD_SPEED_IN_KBPS_10X | 10X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_12X | 12X DVD speed constant (DVD-R, DVD+R)
DVD_SPEED_IN_KBPS_16X | 16X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_18X | 18X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_1X | 1X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_20X | 20X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_22X | 22X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_24X | 24X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_2DOT4X | 2.4X DVD speed constant (DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_2X | 2X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_32X | 32X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_3X | 3X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_40X | 40X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_48X | 48X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_4X | 4X DVD speed constant (DVD-R, DVD-R DL, DVD-RW, DVD+R, DVD+R DL, DVD+RW and DVD-RAM)
DVD_SPEED_IN_KBPS_50X | 50X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_5X | 5X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_6X | 6X DVD speed constant (DVD-RW)
DVD_SPEED_IN_KBPS_8X | 8X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
ELTORITO_BOOTABLE | Bootable disc ID
ELTORITO_BOOTSYSTEM_ID | Bootable specification signature
ELTORITO_DEF_LOAD_SEGMENT | Real mode code load segment
ELTORITO_NON_BOOTABLE | Non-bootable disc ID
ERROR_FIELD_C2_AND_BLOCK_ERROR | C2 and block error information
ERROR_FIELD_C2_ERROR | C2 error information
ERROR_FIELD_NO_ERROR | No error information
ERROR_FIELD_RESERVED | Reserved
EXPECTED_LB_TYPE_ANY | Accept all LBs
EXPECTED_LB_TYPE_CDDA | Accept only CDDA (CD digital audio) LBs
EXPECTED_LB_TYPE_MODE1 | Accept only MODE1 LBs
EXPECTED_LB_TYPE_MODE2 | Accept only MODE2 LBs (both Form1 and Form2)
EXPECTED_LB_TYPE_MODE2_FORM1 | Accept only MODE2 Form1 LBs
EXPECTED_LB_TYPE_MODE2_FORM2 | Accept only MODE2 Form2 LBs
HARD_DISK_LB_SIZE_IN_UCHARS | Hard disk LB (logical block) size in UCHARs
HEADER_CODE_ALL_HEADERS | Both header and subheader
HEADER_CODE_HEADER_ONLY | 4-byte header
HEADER_CODE_NONE | No header
HEADER_CODE_SUBHEADER_ONLY | MODE2 Form1 or Form2 subheader
ISO9660_DATE_SIZE_IN_UCHARS | ISO9660 date size in UCHARs
ISO9660_FILE_SIZE_IN_UCHARS | ISO9660 file size in UCHARs
ISO9660_NAME_SIZE_IN_UCHARS | ISO9660 name size in UCHARs
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS | ISO9660 volume descriptor system and volume ID size in UCHARs
ISO9660_TREE_LEVEL | ISO9660 top supported file tree level
LAST_SESSION_COMPLETE | Last session is complete
LAST_SESSION_EMPTY | Last session is empty
LAST_SESSION_INCOMPLETE | Last session is incomplete
MODE1_LB_SIZE_IN_UCHARS | MODE1 LB (logical block) size in UCHARs
MODE2_FORM1_LB_SIZE_IN_UCHARS | MODE2 Form1 LB (logical block) size in UCHARs
MODE2_FORM2_LB_SIZE_IN_UCHARS | MODE2 Form2 LB (logical block) size in UCHARs
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS | MODE2 Form2 + 8 UCHARs of subheader LB (logical block) size in UCHARs
MODE2_FORMLESS_LB_SIZE_IN_UCHARS | MODE2 Formless LB (logical block) size in UCHARS
NUMBER_OF_RAW_TRACKS | Top number of raw tracks (including maintenance tracks) on CD/DVD/Blu-Ray/HD-DVD disc. This is calculated based on the worst CD case when all tracks will be in a separate sessions. We need this approximate value to avoid allocating TOC_INFORMATION structure dynamically.
NUMBER_OF_READ_RETRIES | Default number of retries on read operations (if bad block was possibly hit, was 2 originally)
NUMBER_OF_SUBCHANNELS | sub-channels from P to W
NUMBER_OF_TRACKS | Top number of tracks (or border-in/border-out zones) on CD/DVD/Blu-Ray/HD-DVD disc
PAGE_SIZE_IN_UCHARS | Small page size in UCHARs on x86 machines (default allocatable storage)
RAW_LB_PQ_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with PQ sub-channel size in UCHARs
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with RAW P-W sub-channel size in UCHARs
RAW_LB_SIZE_IN_UCHARS | RAW LB (logical block) size in UCHARs
READ_REPORT_DELAY_IN_SECONDS | Default read report delay in seconds
SCSI_DEVICE_DIRECT_ACCESS | SCSI disk device
SCSI_DEVICE_MAGNETO_OPTICAL | SCSI MO (Magneto-Optical) disk device
SCSI_DEVICE_MEDIUM_CHANGER | SCSI jukebox (disc changer) device
SCSI_DEVICE_NETWORK | SCSI network device
SCSI_DEVICE_PRINTER | SCSI printer device
SCSI_DEVICE_PROCESSOR | SCSI processor device
SCSI_DEVICE_RO_DIRECT_ACCESS | SCSI CD/DVD/Blu-Ray/HD-DVD device
SCSI_DEVICE_SCANNER | SCSI scanner device
SCSI_DEVICE_SEQUENTIAL_ACCESS | SCSI tape device
SCSI_DEVICE_UNPRESENT | SCSI device... Is gone!
SCSI_DEVICE_WILDCARD | SCSI device any (wildcard for StarBurn_FindDevice() function)
SCSI_DEVICE_WORM | SCSI WORM (Write-Once-Read-Multiple) device
SHORT_RAW_LB_SIZE_IN_UCHARS | Short (w/o sync and header) RAW LB (logical block) size in UCHARs
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Number of logical blocks on single layer DVD
SMALLEST_CACHE_SIZE_IN_MBS | Smallest cache size in MBs that toolkit will allow to use to buffer "write" operations
SMALLEST_CACHE_SIZE_IN_UCHARS | Smallest cache size in UCHARs that toolkit will allow to use to buffer "write" operations
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_FULL.
STARBURN_BDRE_FORMAT_CERTIFICATION_NO | BD-RE format certification types
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK.
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED.
STARBURN_BDRE_FORMAT_DEFAULT | BD-RE format types
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION | This is macro STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION.
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITH_SPARE_AREA.
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA.
STARBURN_CACHE_SIZE_READ_ONLY | Default cache size for I/O operations
STARBURN_CACHE_SIZE_READ_WRITE | This is macro STARBURN_CACHE_SIZE_READ_WRITE.
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED.
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY | File attributes ( flags for Attributes member of STARBURN_UDF2_FILE_INFO & STARBURN_ISO2_FILE_INFO )
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN.
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT | This is macro StarBurn_CdvdBurnerGrabber_GetDeviceInformationT.
StarBurn_CdvdBurnerGrabber_GrabTrackT | This is macro StarBurn_CdvdBurnerGrabber_GrabTrackT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDT.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT | This is macro StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT.
StarBurn_CdvdBurnerGrabber_VerifyFileExT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileExT.
StarBurn_CdvdBurnerGrabber_VerifyFileT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileT.
StarBurn_CdvdBurnerGrabber_VideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExExT.
StarBurn_CdvdBurnerGrabber_VideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExT.
StarBurn_CdvdBurnerGrabber_VideoCDT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDT.
STARBURN_DEBUG_FACILITY_ALLMESSAGES | Debug facility: Permit All Messages
STARBURN_DEBUG_FACILITY_ALLTARGETS | Debug facility: All targets
STARBURN_DEBUG_FACILITY_CUSTOM | Debug facility: Custom
STARBURN_DEBUG_FACILITY_DEBUG | Debug facility: Permit Debug Messages
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT | Debug facility: Debug output
STARBURN_DEBUG_FACILITY_ERROR | Debug facility: Permit Error Messages
STARBURN_DEBUG_FACILITY_LOG_FILE | Debug facility: Log file
STARBURN_DEBUG_FACILITY_NONE | Debug facility: None
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE | Debug facility: System console
STARBURN_DEBUG_FACILITY_TRACE | Debug facility: Permit Trace Messages
STARBURN_DEBUG_FACILITY_WARNING | Debug facility: Permit Warning Messages
STARBURN_DISC_TYPE_CDDA | Disc type is CDDA (CD-ROM or Digital Audio)
STARBURN_DISC_TYPE_CDI | Disc type is CDI
STARBURN_DISC_TYPE_UNDEFINED | Disc type is undefined
STARBURN_DISC_TYPE_XA | Disc type is CD-ROM XA
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES | DVD-Video maximum number of titles
StarBurn_DVDVideo_CreateT | This is macro StarBurn_DVDVideo_CreateT.
StarBurn_ElTorito_BootCatalogAddSectionT | This is macro StarBurn_ElTorito_BootCatalogAddSectionT.
StarBurn_ElTorito_CreateBootCatalogT | This is macro StarBurn_ElTorito_CreateBootCatalogT.
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARs_FastT.
StarBurn_GetAudioFileStreamSizeInUCHARsT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARsT.
StarBurn_GetDeviceLetterT | TCHAR functions
STARBURN_IMPEX_API | declspec( dllexport )
StarBurn_IsAudioFileSupportedT | This is macro StarBurn_IsAudioFileSupportedT.
StarBurn_ISO2_VolumeCreateBootElToritoT | This is macro StarBurn_ISO2_VolumeCreateBootElToritoT.
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE | This is macro STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE.
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY | This is macro STARBURN_ISO9660_FILE_FLAGS_DIRECTORY.
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE | This is macro STARBURN_ISO9660_FILE_FLAGS_EXISTENCE.
STARBURN_ISO9660_FILE_FLAGS_NONE | ISO9660 file attributes flags
STARBURN_ISO9660_FILE_FLAGS_RECORD | This is macro STARBURN_ISO9660_FILE_FLAGS_RECORD.
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS | ( 4GB - 1 )
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS | This is macro STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS.
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS |
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS | ISO9660 constants (begin)
STARBURN_ISO9660_TYPE_1999 | This is macro STARBURN_ISO9660_TYPE_1999.
STARBURN_ISO9660_TYPE_JOLIET | This is macro STARBURN_ISO9660_TYPE_JOLIET.
STARBURN_ISO9660_TYPE_JOLIET_RELAXED | This is macro STARBURN_ISO9660_TYPE_JOLIET_RELAXED.
STARBURN_ISO9660_TYPE_LEVEL1 | ISO9660 file system type
STARBURN_ISO9660_TYPE_LEVEL2 | This is macro STARBURN_ISO9660_TYPE_LEVEL2.
STARBURN_LOADING_MECHANISM_TYPE_CADDY | Loading mechanism type constants
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE | This is macro STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE.
STARBURN_LOADING_MECHANISM_TYPE_CHANGER | This is macro STARBURN_LOADING_MECHANISM_TYPE_CHANGER.
STARBURN_LOADING_MECHANISM_TYPE_POP_UP | This is macro STARBURN_LOADING_MECHANISM_TYPE_POP_UP.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED1.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED2.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED3.
STARBURN_LOADING_MECHANISM_TYPE_TRAY | This is macro STARBURN_LOADING_MECHANISM_TYPE_TRAY.
STARBURN_PIPE_SIZE_IN_UCHARS | 60, 64 or 32 KB I/O packets
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS | StarBurn smallest split file size in megabytes
StarBurn_StarWave_CompressedFileReaderObjectCreateT | This is macro StarBurn_StarWave_CompressedFileReaderObjectCreateT.
StarBurn_StarWave_CompressedFileRecompressT | This is macro StarBurn_StarWave_CompressedFileRecompressT.
StarBurn_StarWave_CompressedFileUncompressT | This is macro StarBurn_StarWave_CompressedFileUncompressT.
StarBurn_StarWave_CompressedFileWriterObjectCreateT | This is macro StarBurn_StarWave_CompressedFileWriterObjectCreateT.
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS | StarWave recommended I/O buffer size in UCHARs. It's *STRONGLY* recommended to use either it or multiplications of STARWAVE_IO_BUFFER_SIZE_IN_UCHARS as internal calculations and indexations are integer rather then float based
StarBurn_StarWave_UncompressedFileCompressT | This is macro StarBurn_StarWave_UncompressedFileCompressT.
StarBurn_StarWave_UncompressedFileSupportedIsT | This is macro StarBurn_StarWave_UncompressedFileSupportedIsT.
StarBurn_StarWave2_ConvertExT | This is macro StarBurn_StarWave2_ConvertExT.
StarBurn_StarWave2_EncodeMP3OGGFromWAVT | This is macro StarBurn_StarWave2_EncodeMP3OGGFromWAVT.
StarBurn_StarWave2_GetFileReaderAndFactoryT | This is macro StarBurn_StarWave2_GetFileReaderAndFactoryT.
StarBurn_UDF_AddT | This is macro StarBurn_UDF_AddT.
StarBurn_UDF_CreateExT | This is macro StarBurn_UDF_CreateExT.
StarBurn_UDF_CreateT | This is macro StarBurn_UDF_CreateT.
StarBurn_UDF_FormatTreeItemAsDirectoryT | This is macro StarBurn_UDF_FormatTreeItemAsDirectoryT.
StarBurn_UDF_FormatTreeItemAsFileT | This is macro StarBurn_UDF_FormatTreeItemAsFileT.
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS | Name constants
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS | This is macro STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS.
StarBurn_UDF2_VolumeCreateBootElToritoT | This is macro StarBurn_UDF2_VolumeCreateBootElToritoT.
StarBurn_UDFBridge_CreateExT | This is macro StarBurn_UDFBridge_CreateExT.
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS | StarPort device name size in UCHARs
STARWAVEFACTORY_ID_DSHOW | This is macro STARWAVEFACTORY_ID_DSHOW.
STARWAVEFACTORY_ID_MP3 | This is macro STARWAVEFACTORY_ID_MP3.
STARWAVEFACTORY_ID_OGG | This is macro STARWAVEFACTORY_ID_OGG.
STARWAVEFACTORY_ID_WAV | StarWave2 factory ids
STARWAVEFACTORY_ID_WMA | This is macro STARWAVEFACTORY_ID_WMA.
SUBCHANNEL_NO | No sub-channel
SUBCHANNEL_PQ | PQ sub-channel
SUBCHANNEL_PQ_SIZE_IN_UCHARS | PQ sub-channel size in UCHARs
SUBCHANNEL_RAW_PW | RAW P-W sub-channel
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS | Raw P-W sub-channel size in UCHARs
SUBCHANNEL_RESERVED | Reserved
SUBCHANNEL_RW | R-W sub-channel
SUBCHANNEL_SIZE_IN_UCHARS | Sub-channel size in UCHARs
TRACK_NUMBER_INVISIBLE | Special "invisible" track number
TYPE_CODE_LAST_CHANCE | Logical Unit region is set. Additional restrictions required to make a change
TYPE_CODE_NONE | No Logical Unit region setting
TYPE_CODE_PERM | Logical Unit region has been set permanently, but may be reset by vendor if necessery
TYPE_CODE_SET | Logical Unit region is set
UDF_FILE_SET_DESCRIPTOR_LBA | UDF file set descriptor logical block address
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA | UDF file set descriptor terminator logical block address
UDF_FIRST_ANCHOR_LBA | First anchor volume descriptor pointer LBA
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS | UDF head size in logical blocks
UDF_ISO9660_FILE_SYSTEM_LBA | UDF/ISO9660 bridge file system logical block address
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS | define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 6
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS | UDF logical block size in UCHARs
UDF_NAME_SIZE_IN_UCHARS | UDF longest name size in UCHARs
UDF_NAME_SIZE_IN_UCHARS_ACTUAL | This is macro UDF_NAME_SIZE_IN_UCHARS_ACTUAL.
UDF_NSR_DESCRIPTOR_LBA | UDF NSR descriptor pointer LBA
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS | UDF tail size in logical blocks
WAVE_FILE_ALIGNMENT | WAVE file data alignment (4 UCHARs, 1 ULONG)
WAVE_FILE_BITS_PER_SAMPLE | WAVE file bits per sample
WAVE_FILE_CHANNELS | WAVE file number of channels
WAVE_FILE_DATA_SIGNATURE | WAVE file DATA signature
WAVE_FILE_RIFF_SIGNATURE | WAVE file RIFF signature
WAVE_FILE_SAMPLES_PER_SECOND | WAVE file samples per second
WAVE_FILE_TAG_SIGNATURE | WAVE file TAG signature
WAVE_FILE_WAVE_FORMAT | WAVE file WAVE format
WAVE_FILE_WAVE_SIGNATURE | WAVE file WAVE signature
WRITE_REPORT_DELAY_IN_SECONDS | Default write report delay in seconds


Structs, Records, Enums Enumerations

Structs, Records, Enums Enumerations
Structs, Records, Enums | Legend
Enumerations
Name | Description
_CALLBACK_NUMBER | Enum that represents callback number
_DISC_TYPE | Enum that represents inserted disc type
_ERASE_TYPE | Enum that represents erase type
_EXCEPTION_NUMBER | Enum that represents exception number
_FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
_FILE_TREE | Enum that represents file tree
_ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
_NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
_READ_MODE | Enum that represents raw read modes
_STARBURN_CD_MODE | Enum that represents CD modes type
_STARBURN_ELTORITO_MEDIA | Media emulation types
_STARBURN_ELTORITO_PLATFORM | ElTorito platform types
_STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
_STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
_STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
_STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
_STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
_STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
_STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
_STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_UDF_OS_CLASS | UDF OS class
_UDF_VERSION | Enum that represents UDF version
_WRITE_MODE | Enum that represents write modes
CALLBACK_NUMBER | Enum that represents callback number
DISC_TYPE | Enum that represents inserted disc type
ERASE_TYPE | Enum that represents erase type
EXCEPTION_NUMBER | Enum that represents exception number
FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
FILE_TREE | Enum that represents file tree
ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PCALLBACK_NUMBER | Enum that represents callback number
PDISC_TYPE | Enum that represents inserted disc type
PERASE_TYPE | Enum that represents erase type
PEXCEPTION_NUMBER | Enum that represents exception number
PFILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
PFILE_TREE | Enum that represents file tree
PISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
PNAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PPSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PPSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PPSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PPSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PREAD_MODE | Enum that represents raw read modes
PSTARBURN_CD_MODE | Enum that represents CD modes type
PSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PSTARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
PSTARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
PSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PWRITE_MODE | Enum that represents write modes
READ_MODE | Enum that represents raw read modes
STARBURN_CD_MODE | Enum that represents CD modes type
STARBURN_ELTORITO_MEDIA | Media emulation types
STARBURN_ELTORITO_PLATFORM | ElTorito platform types
STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
UDF_OS_CLASS | UDF OS class
UDF_VERSION | Enum that represents UDF version
WRITE_MODE | Enum that represents write modes


Enumerations

Legend
Legend
Enumeration


Legend

Legend
Structs, Records, Enums
Legend
Enumeration
Structure


Structs, Records, Enums Structures

Structs, Records, Enums Structures
Structs, Records, Enums | Legend
Structures
Name | Description
_CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
_DAO_DISC_LAYOUT | Structure that represents DAO disc layout
_DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
_DISC_FILESYSTEM | Structure with disc file system flags
_DISC_LAYOUT | Structure that represents disc layout
_DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
_DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
_FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
_ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
_NAME_COLLISION_INFO | Structure that represents information about name collision
_PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
_SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
_STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
_STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
_STARBURN_DISC_INFORMATION | Structure that represents Disc information
_STARBURN_ISO9660_DIRECTORY_INFO | This is record _STARBURN_ISO9660_DIRECTORY_INFO.
_STARBURN_ISO9660_FILE_INFO | ISO9660 file information
_STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
_STARBURN_TRACK_INFORMATION | Structure that represents Track information
_STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
_STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
_STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
_STARBURN_UDF2_FILE_INFO | UDF file information
_STARPORT_DEVICE_LIST | Structure that represents StarPort device list
_STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
_STARWAVE2_COMPRESSION_PROFILE |
_TOC_ENTRY | Structure that represents TOC entry
_TOC_INFORMATION | Structure that represents TOC information
_UDF_CONTROL_BLOCK | Structure that represents UDF control block
_UDF_FILE_EXTENT | Structure that describes a single file extent
_UDF_FILE_HANDLE | Structure that represents UDF file handle
_UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
_UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_TREE_ITEM | Structure that represents UDF tree item
_WAVE_FILE_HEADER | Structure that represents WAVE file header
_WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
DAO_DISC_LAYOUT | Structure that represents DAO disc layout
DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
DISC_FILESYSTEM | Structure with disc file system flags
DISC_LAYOUT | Structure that represents disc layout
DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
NAME_COLLISION_INFO | Structure that represents information about name collision
PCDB_FAILURE_INFORMATION | Structure that represents CDB failure information
PDAO_DISC_LAYOUT | Structure that represents DAO disc layout
PDAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
PDISC_FILESYSTEM | Structure with disc file system flags
PDISC_LAYOUT | Structure that represents disc layout
PDISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
PDVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
PFULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
PISO9660_DATE_TIME | Structure that represents ISO9660 date and time
PNAME_COLLISION_INFO | Structure that represents information about name collision
PPQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PPSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PPSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PPSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PPSTARWAVE2_COMPRESSION_PROFILE |
PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PSCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
PSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PSTARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
PSTARBURN_DISC_INFORMATION | Structure that represents Disc information
PSTARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
PSTARBURN_TRACK_INFORMATION | Structure that represents Track information
PSTARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
PSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PSTARWAVE2_COMPRESSION_PROFILE |
PTOC_ENTRY | Structure that represents TOC entry
PTOC_INFORMATION | Structure that represents TOC information
PUDF_CONTROL_BLOCK | Structure that represents UDF control block
PUDF_FILE_EXTENT | Structure that describes a single file extent
PUDF_FILE_HANDLE | Structure that represents UDF file handle
PUDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
PUDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_TREE_ITEM | Structure that represents UDF tree item
PWAVE_FILE_HEADER | Structure that represents WAVE file header
PWAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
STARBURN_DISC_INFORMATION | Structure that represents Disc information
STARBURN_ISO9660_DIRECTORY_INFO | This is type STARBURN_ISO9660_DIRECTORY_INFO.
STARBURN_ISO9660_FILE_INFO | ISO9660 file information
STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
STARBURN_TRACK_INFORMATION | Structure that represents Track information
STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
STARBURN_UDF2_FILE_INFO | UDF file information
STARPORT_DEVICE_LIST | Structure that represents StarPort device list
STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
STARWAVE2_COMPRESSION_PROFILE |
TOC_ENTRY | Structure that represents TOC entry
TOC_INFORMATION | Structure that represents TOC information
UDF_CONTROL_BLOCK | Structure that represents UDF control block
UDF_FILE_EXTENT | Structure that describes a single file extent
UDF_FILE_HANDLE | Structure that represents UDF file handle
UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_TREE_ITEM | Structure that represents UDF tree item
WAVE_FILE_HEADER | Structure that represents WAVE file header
WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk


Structures

Legend
Legend
Structure


Types

Types
Types
Types
Name | Description
CFuncStarWaveConversionCallback | type of callback function
PCALLBACK | Callback type (function of this type must be passed as callback)
PSTARBURN_CLOSEHANDLE_CALLBACK | This is type PSTARBURN_CLOSEHANDLE_CALLBACK.
PSTARBURN_CREATEFILE_CALLBACK | This is type PSTARBURN_CREATEFILE_CALLBACK.
PSTARBURN_DELETEFILE_CALLBACK | This is type PSTARBURN_DELETEFILE_CALLBACK.
PSTARBURN_FILE_OBJECT | Structure that represents StarBurn file object used internally with file I/O
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | This is type PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK.
PSTARBURN_ISO2_COLLISION_CALLBACK | StarBurn ISO name collision handling callback
PSTARBURN_ISO2_PROGRESS_CALLBACK | StarBurn ISO progress callback
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK | StarBurn ISO Unicode name collision handling callback
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK | StarBurn ISO UNICODE progress callback
PSTARBURN_ISO9660_READ_CALLBACK | StarBurn ISO2 read callback (for import)
PSTARBURN_READFILE_CALLBACK | This is type PSTARBURN_READFILE_CALLBACK.
PSTARBURN_SET_FILE_POINTER_CALLBACK | This is type PSTARBURN_SET_FILE_POINTER_CALLBACK.
PSTARBURN_STARWAVE_CALLBACK | StarWave callback passed to I/O functions. Return anything except zero from it to cancel I/O operation
PSTARBURN_UDF2_COLLISION_CALLBACK_EX | StarBurn UDF ansi name collision handling callback
PSTARBURN_UDF2_IMPORT_CALLBACK | StarBurn UDF2 import callback
PSTARBURN_UDF2_PROGRESS_CALLBACK | StarBurn UDF2 progress callback
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX | StarBurn UDF Unicode name collision handling callback
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK | StarBurn UDF2 UNICODE progress callback
PSTARBURN_WRITEFILE_CALLBACK | This is type PSTARBURN_WRITEFILE_CALLBACK.


Topics

Topics
Introduction
Topics
Name | Description
Copyright | Copyright © Rocket Division Software 2001-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of Rocket Division Software. Copyright © StarBurn Software 2009-2016. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written consent of StarBurn Software.
Trademarks | "StarBurn Software", “Rocket Division Software”, “StarBurn”, “StarBurn SDK” and the StarBurn Software, Rocket Division Software, StarBurn, StarBurn SDK logos are trademarks of Rocket Division Software and StarBurn Software which may be registered in some jurisdictions. All other trademarks are owned by their respective owners.
Changes | The material in this document is for information only and is subject to change without notice. While reasonable efforts have been made in the preparation of this document to assure its accuracy, StarBurn Software assumes no liability resulting from errors or omissions in this document, or from the use of the information contained herein. StarBurn Software reserves the right to make changes in the product design without reservation and without notification to its users.
Technical support and service | If you have questions about installing or using this software, check this and other documents first - you will find answers to most of your questions here or there. If you need further assistance, please contact us.


Example

Example
StarBurn_CdvdBurnerGrabber_AuthorizeDVD Function

This example allocates CdvdBurnerGrabber object, gets protection system, authorizes DVD disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to authorize the DVD disc (it's expected that DVD disc has CSS protection)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_AuthorizeDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_AuthorizeDVD Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem


Example

Example
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx Function

This example allocates CdvdBurnerGrabber object, gets protection system, authorizes DVD disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;
UCHAR l__UCHAR__BusKeyForDiscKey[ 5 ] = { 0, 0, 0, 0, 0 };

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to authorize the DVD disc (it's expected that DVD disc has CSS protection) and keep bus key for disc key
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__BusKeyForDiscKey
    );

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem


Example

Example
StarBurn_CdvdBurnerGrabber_Blank Function

This example allocates CdvdBurnerGrabber object, erases the media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to erase the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Blank(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ERASE_TYPE_BLANK_DISC_FAST
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Blank Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, ERASE_TYPE


Example

Example
StarBurn_CdvdBurnerGrabber_BluRayFormat Function

This example allocates CdvdBurnerGrabber object, formats the BD-RE media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__FormatProfileNumber = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check for the BD-RE media inserted

// Get possible format profiles and pick up format profile number

// Try to format the Blu-Ray rewrittable media (BD-RE)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_BluRayFormat(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__ULONG__FormatProfileNumber
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_BluRayFormat Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_BluRayFormatQuery, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery Function

This example allocates CdvdBurnerGrabber object, queries available Blu-Ray formats and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__FormatProfileBuffer[ PAGE_SIZE_IN_UCHARS ];
ULONG l__ULONG__FormatProfileBufferSizeInUCHARs = sizeof( l__UCHAR__FormatProfileBuffer );

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check for the BD-RE media inserted

// Query available Blu-Ray formats
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__FormatProfileBuffer,
    &l__ULONG__FormatProfileBufferSizeInUCHARs
    );

// Try to format the Blu-Ray rewrittable media

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_BluRayFormat, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_Cancel Function

This example allocates CdvdBurnerGrabber object, cancels current I/O process and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Initiate some I/O process here

// Cancel initiated I/O process
StarBurn_CdvdBurnerGrabber_Cancel();

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Cancel Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_GrabTrack, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD


Example

Example
StarBurn_CdvdBurnerGrabber_CloseSession Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media, closes session and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\ISO9660.ISO",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to close session
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CloseSession(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_CloseSession Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_Create Function

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Create Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_CreateEx Function

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber using name "D:" with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CreateEx(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    "D:",
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_CreateEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateExEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_CreateExEx Function

This example allocates CdvdBurnerGrabber object and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber using name "CdRom0" with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_CreateExEx(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    L"CdRom0",
    TRUE,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_CreateExEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


See Also

See Also
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile


Example

Example
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare DAO disc layout
RtlZeroMemory(
    &l__DAO_DISC_LAYOUT,
    sizeof( l__DAO_DISC_LAYOUT )
    );

// Set file name
strcpy(
    l__DAO_DISC_LAYOUT.m__DAO_DISC_LAYOUT_ENTRY.m__CHAR__TrackName,
    "C:\ISO9660.ISO"
    );

// Set number of tracks
l__DAO_DISC_LAYOUT.m__LONG__NumberOfTracks = 1;

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once PQ mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    FALSE, // No sub-channel repair
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree Function

This example allocates CdvdBurnerGrabber object, creates ISO9660 or Joliet file system image located in a file tree object and burns it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and initialize ISO9660 or Joliet file tree object here pointed by l__PVOID__ISO9660JolietFileTree

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once PQ mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__ISO9660JolietFileTree,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile


See Also

See Also
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile


Example

Example
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare DAO disc layout
RtlZeroMemory(
    &l__DAO_DISC_LAYOUT,
    sizeof( l__DAO_DISC_LAYOUT )
    );

// Set file name
strcpy(
    l__DAO_DISC_LAYOUT.m__DAO_DISC_LAYOUT_ENTRY.m__CHAR__TrackName,
    "C:\ISO9660.ISO"
    );

// Set number of tracks
l__DAO_DISC_LAYOUT.m__LONG__NumberOfTracks = 1;

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    FALSE, // No sub-channel repair
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree Function

This example allocates CdvdBurnerGrabber object, creates ISO9660 or Joliet file system image located in a file tree object and burns it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and initialize ISO9660 or Joliet file tree object here pointed by l__PVOID__ISO9660JolietFileTree

// Try to record the ISO9660 or Joliet file system image in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__ISO9660JolietFileTree,
    FALSE, // No XA, just ordinary CDROM
    FALSE, // No test write, real burn
    FALSE, // No next session allowed
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile


Example

Example
StarBurn_CdvdBurnerGrabber_Eject Function

This example allocates CdvdBurnerGrabber object, ejects the media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Eject(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Eject Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_ExecuteGeneric Function

This example allocates CdvdBurnerGrabber object, sends custom command and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__CDB[ 12 ];
UCHAR l__UCHAR__Data[ 0x2000 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format CDB and data buffer here...

// Try to send custom CDB to CD/DVD/Blu-Ray/HD-DVD burner device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ExecuteGeneric(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__CDB,
    sizeof( l__UCHAR__CDB ),
    &l__UCHAR__Data,
    sizeof( l__UCHAR__Data ),
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_ExecuteGeneric Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_ImportTrack


Example

Example
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats Function

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Prepare advanced supported media formats
RtlZeroMemory(
    &l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS,
    sizeof( l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS )
    );

// Set structure size in UCHARs
l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS.m__ULONG__SizeInUCHARs = sizeof( l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS );

// Get CdvdBurnerGrabber device extended information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats(
    l__PVOID__CdvdBurnerGrabber,
    &l__STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx


Example

Example
StarBurn_CdvdBurnerGrabber_GetBUP Function

This example allocates CdvdBurnerGrabber object, gets BUP status and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsBUPEnabled;
BOOLEAN l__BOOLEAN__IsBUPSupported;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsBUPEnabled,
    &l__BOOLEAN__IsBUPSupported
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetBUP Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetDeviceInformation Function

This example allocates CdvdBurnerGrabber object, retrieves device information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
CHAR l__CHAR__VendorID[ 1024 ];
CHAR l__CHAR__ProductID[ 1024 ];
CHAR l__CHAR__ProductRevisionLevel[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare vendor ID and product ID and product revision level buffers

RtlZeroMemory(
    &l__CHAR__VendorID,
    sizeof( l__CHAR__VendorID )
    );

RtlZeroMemory(
    &l__CHAR__ProductID,
    sizeof( l__CHAR__ProductID )
    );

RtlZeroMemory(
    &l__CHAR__ProductRevisionLevel,
    sizeof( l__CHAR__ProductRevisionLevel )
    );

// Get CdvdBurnerGrabber device information
StarBurn_CdvdBurnerGrabber_GetDeviceInformation(
    l__PVOID__CdvdBurnerGrabber,
    ( PCHAR )( &l__CHAR__VendorID ),
    ( PCHAR )( &l__CHAR__ProductID ),
    ( PCHAR )( &l__CHAR__ProductRevisionLevel ),
    &l__ULONG__CacheBufferSizeInUCHARs
    );

// Do something with CdvdBurnerGrabber device object and it's information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDeviceInformation Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem Function

Please see GUI DataBurner sample as example how to use StarBurn_GetDiscFileSystem API call.


Example

Example
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace Function

This example allocates CdvdBurnerGrabber object, gets free disc space and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
CD_MODE l__CD_MODE(CD_MODE_DATA);
LONG l__LONG__FreeSpaceInLBs(0);
LARGE_INTEGER l__LARGE_INTEGER__FreeSpaceInUCHARs;

l__LARGE_INTEGER__FreeSpaceInUCHARs.QuadPart = 0;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current disc free space
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace(
l__PVOID__CdvdBurnerGrabber,
l__CD_MODE,
&l__LONG__FreeSpaceInLBs,
&l__LARGE_INTEGER__FreeSpaceInUCHARs
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetDiscInformation Function

This example allocates CdvdBurnerGrabber object, gets disc information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_DISC_INFORMATION l__STARBURN_DISC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare disc information buffer
RtlZeroMemory(
    &l__STARBURN_DISC_INFORMATION,
    sizeof( l__STARBURN_DISC_INFORMATION )
    );

// Try to get current disc information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PSTARBURN_DISC_INFORMATION )( &l__STARBURN_DISC_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDiscInformation Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetTrackInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace Function

This example allocates CdvdBurnerGrabber object, gets used disc space and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LARGE_INTEGER l__LARGE_INTEGER__UsedSpace;

l__LARGE_INTEGER__UsedSpace.QuadPart = 0;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current disc used space
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
&l__LARGE_INTEGER__UsedSpace
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem Function

This example allocates CdvdBurnerGrabber object, gets protection system and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDProtectionSystem = DVD_PROTECTION_NONE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get inserted disc type, supposed to be DVD...

// Try to get DVD protection system
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDProtectionSystem
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem


Example

Example
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask Function

This example allocates CdvdBurnerGrabber object, gets DVD region and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__DVDRegionMask;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get DVD region mask from DVD media inserted to device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__DVDRegionMask
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_GetRPC, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType Function

This example allocates CdvdBurnerGrabber object, retrieves inserted disc type and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DISC_TYPE l__DISC_TYPE = DISC_TYPE_UNKNOWN;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get inserted disc type
l__DISC_TYPE = StarBurn_CdvdBurnerGrabber_GetInsertedDiscType( l__PVOID__CdvdBurnerGrabber );

// Do something with CdvdBurnerGrabber device object and it's inserted disc type here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetLastAddress Function

This example allocates CdvdBurnerGrabber object, gets last recorded address and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__LastRecordedLBA = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get last recorded address
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetLastAddress(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__ULONG__LastRecordedLBA
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetLastAddress Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_GetLastTrack


Example

Example
StarBurn_CdvdBurnerGrabber_GetLastTrack Function

This example allocates CdvdBurnerGrabber object, gets last recorded track number and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__LastRecordedTrackNumber;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get last recorded track number
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetLastTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__LastRecordedTrackNumber
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetLastTrack Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_ImportTrack


Example

Example
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions Function

This example allocates CdvdBurnerGrabber object, gets mechanical options and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsLockUnLockSupported = FALSE;
BOOLEAN l__BOOLEAN__IsLocked = FALSE;
BOOLEAN l__BOOLEAN__IsLoadEjectSupported = FALSE;
UCHAR l__UCHAR__LoadingMechanismType = 0x00;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get media and tray statuses
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsLockUnLockSupported,
    &l__BOOLEAN__IsLocked,
    &l__BOOLEAN__IsLoadEjectSupported,
    &l__UCHAR__LoadingMechanismType
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx, StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus


Example

Example
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus Function

This example allocates CdvdBurnerGrabber object, gets media and tray statuses and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsMediaPresent;
BOOLEAN l__BOOLEAN__IsDoorOrTrayOpen;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get media and tray statuses
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsMediaPresent,
    &l__BOOLEAN__IsDoorOrTrayOpen
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx


Example

Example
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors Function

This example allocates CdvdBurnerGrabber object, gets number of system descriptors and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
LONG l__LONG__NumberOfSystemDescriptors = 0;
PUCHAR l__PUCHAR__SystemStructures = 0;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Allocate enough memory for system structures in l__PUCHAR__SystemStructures here...

// Read system structures from the optical disc to l__PUCHAR__SystemStructures buffer here...

// Try to get number of system descriptors
l__LONG__NumberOfSystemDescriptors =
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors(
    l__PVOID__CdvdBurnerGrabber,
    l__PUCHAR__SystemStructures,
    SYSTEM_STRUCTURES_SIZE_IN_LOGICAL_BLOCKS
    );

// Do something with l__LONG__NumberOfSystemDescriptors here...

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create


Example

Example
StarBurn_CdvdBurnerGrabber_GetRPC Function

This example allocates CdvdBurnerGrabber object, gets DVD region management information from CD/DVD/Blu-Ray/HD-DVD device object and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__TypeCode;
UCHAR l__UCHAR__NumberOfVendorResetsAvailable;
UCHAR l__UCHAR__NumberOfUserControlledChangesAvailable;
UCHAR l__UCHAR__RegionMask;
UCHAR l__UCHAR__RPCScheme;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get DVD region management information from DVD device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetRPC(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__TypeCode,
    &l__UCHAR__NumberOfVendorResetsAvailable,
    &l__UCHAR__NumberOfUserControlledChangesAvailable,
    &l__UCHAR__RegionMask,
    &l__UCHAR__RPCScheme
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetRPC Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetDVDRegionMask


Example

Example
StarBurn_CdvdBurnerGrabber_GetSpeeds Function

This example allocates CdvdBurnerGrabber object, gets all (current and top supported) read and write speeds and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__CurrentReadSpeed;
ULONG l__ULONG__MaximumReadSpeed;
ULONG l__ULONG__CurrentWriteSpeed;
ULONG l__ULONG__MaximumWriteSpeed;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get current and top supported CD/DVD/Blu-Ray/HD-DVD read/write speeds on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetSpeeds(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__ULONG__CurrentReadSpeed,
    &l__ULONG__MaximumReadSpeed,
    &l__ULONG__CurrentWriteSpeed,
    &l__ULONG__MaximumWriteSpeed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and it's speeds here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetSpeeds Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx


Example

Example
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats Function

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsCDRRead;
BOOLEAN l__BOOLEAN__IsCDERead;
BOOLEAN l__BOOLEAN__IsDVDROMRead;
BOOLEAN l__BOOLEAN__IsDVDRRead;
BOOLEAN l__BOOLEAN__IsDVDRAMRead;
BOOLEAN l__BOOLEAN__IsTestWrite;
BOOLEAN l__BOOLEAN__IsCDRWrite;
BOOLEAN l__BOOLEAN__IsCDEWrite;
BOOLEAN l__BOOLEAN__IsDVDRWrite;
BOOLEAN l__BOOLEAN__IsDVDRAMWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsCDRRead,
    &l__BOOLEAN__IsCDERead,
    &l__BOOLEAN__IsDVDROMRead,
    &l__BOOLEAN__IsDVDRRead,
    &l__BOOLEAN__IsDVDRAMRead,
    &l__BOOLEAN__IsTestWrite,
    &l__BOOLEAN__IsCDRWrite,
    &l__BOOLEAN__IsCDEWrite,
    &l__BOOLEAN__IsDVDRWrite,
    &l__BOOLEAN__IsDVDRAMWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx Function

This example allocates CdvdBurnerGrabber object, retrieves device extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsDVDPLUSRWRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsDVDPLUSRWRead,
    &l__BOOLEAN__IsDVDPLUSRRead,
    &l__BOOLEAN__IsDVDPLUSRWWrite,
    &l__BOOLEAN__IsDVDPLUSRWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats


Example

Example
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx Function

This example allocates CdvdBurnerGrabber object, retrieves device extended extended information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
ULONG l__ULONG__CacheBufferSizeInUCHARs;
CHAR l__CHAR__ExceptionText[ 1024 ];
BOOLEAN l__BOOLEAN__IsDVDPLUSRWRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRDLRead;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRWrite;
BOOLEAN l__BOOLEAN__IsDVDPLUSRDLWrite;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get CdvdBurnerGrabber device information here...

// Get CdvdBurnerGrabber device extended information
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx(
    l__PVOID__CdvdBurnerGrabber,
    &l__BOOLEAN__IsDVDPLUSRWRead,
    &l__BOOLEAN__IsDVDPLUSRRead,
    &l__BOOLEAN__IsDVDPLUSRDLRead,
    &l__BOOLEAN__IsDVDPLUSRWWrite,
    &l__BOOLEAN__IsDVDPLUSRWrite,
    &l__BOOLEAN__IsDVDPLUSRDLWrite
    );

// Do something with CdvdBurnerGrabber device object and it's extended information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDeviceInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats


Example

Example
StarBurn_CdvdBurnerGrabber_GetTOCInformation Function

This example allocates CdvdBurnerGrabber object, gets TOC information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Try to get current TOC information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTOCInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PTOC_INFORMATION )( &l__TOC_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetTOCInformation Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY


Example

Example
StarBurn_CdvdBurnerGrabber_GetTrackInformation Function

This example allocates CdvdBurnerGrabber object, gets "invisible" track information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_TRACK_INFORMATION l__STARBURN_TRACK_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare track information buffer
RtlZeroMemory(
    &l__STARBURN_TRACK_INFORMATION,
    sizeof( l__STARBURN_TRACK_INFORMATION )
    );

// Try to get "invisible" track information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTrackInformation(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRACK_NUMBER_INVISIBLE,
    ( PSTARBURN_TRACK_INFORMATION )( &l__STARBURN_TRACK_INFORMATION )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and track information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetTrackInformation Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_DISC_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx Function

This example allocates CdvdBurnerGrabber object, gets "invisible" track information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
STARBURN_TRACK_INFORMATION_EX l__STARBURN_TRACK_INFORMATION_EX;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare track information buffer
RtlZeroMemory(
&l__STARBURN_TRACK_INFORMATION_EX,
sizeof( l__STARBURN_TRACK_INFORMATION_EX )
);

// Try to get "invisible" track information
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
TRACK_NUMBER_INVISIBLE,
( PSTARBURN_TRACK_INFORMATION_EX )( &l__STARBURN_TRACK_INFORMATION_EX )
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and track information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_TRACK_INFORMATION_EX, STARBURN_TRACK_INFORMATION, STARBURN_DISC_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_GrabCD Function

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, also use fast software error correction
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    READ_MODE_RAW,
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS,
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabCD Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack


Example

Example
StarBurn_CdvdBurnerGrabber_GrabDVD Function

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    1024, // 1GB
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabDVD Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabDVDEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrackEx


Example

Example
StarBurn_CdvdBurnerGrabber_GrabDVDEx Function

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
&l__TOC_INFORMATION,
sizeof( l__TOC_INFORMATION )
);

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
(PSTARBURN_CREATEFILE_CALLBACK)CallbackCreateFile,
(PSTARBURN_SET_FILE_POINTER_CALLBACK)CallbackSetFilePointer,
(PSTARBURN_READFILE_CALLBACK)CallbackReadFile,
(PSTARBURN_WRITEFILE_CALLBACK)CallbackWriteFile,
(PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK )CallbackFlushFileBuffers,
(PSTARBURN_CLOSEHANDLE_CALLBACK)CallbackCloseHandle,
(PSTARBURN_DELETEFILE_CALLBACK)CallbackDeleteFile,
"disc01",
1024, // 1GB
NUMBER_OF_READ_RETRIES,
TRUE,
FALSE,
READ_REPORT_DELAY_IN_SECONDS
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabDVDFast Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabTrack


Example

Example
StarBurn_CdvdBurnerGrabber_GrabDVDFast Function

This example allocates CdvdBurnerGrabber object, grabs disc and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the disc with 2 retries on bad block hit and single read status report per every 1 second, store all the CD/DVD/Blu-Ray/HD-DVD
// image into series of files 1024MB (1GB) each
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabDVD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "disc01",
    1024, // 1GB
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_GrabRange Function

This example allocates CdvdBurnerGrabber object, grabs range of logical blocks track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the range of 1001 logical blocks (range is both sides inclusive) (from TOC we know that this range 0 = 1000 is
// valid) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabRange(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0,
    1000,
    "track01range",
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabRange Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD


Example

Example
StarBurn_CdvdBurnerGrabber_GrabTrack Function

This example allocates CdvdBurnerGrabber object, grabs first track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Try to grab the track (from TOC we know that this is audio track) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    1,
    "track01.mp3",
    NUMBER_OF_READ_RETRIES,
    TRUE,
    FALSE,
    READ_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabTrack Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD


See Also

See Also
StarBurn_CdvdBurnerGrabber_GrabTrackEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabDVDEx, StarBurn_CdvdBurnerGrabber_GrabDVDFast


Example

Example
StarBurn_CdvdBurnerGrabber_GrabTrackEx Function

This example allocates CdvdBurnerGrabber object, grabs first track and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
&l__TOC_INFORMATION,
sizeof( l__TOC_INFORMATION )
);

// Get TOC information here and analyze it...

// Try to grab the track (from TOC we know that this is audio track) with 2 retries and read report status every 1 second
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GrabTrackEx(
l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
(PSTARBURN_CREATEFILE_CALLBACK)CallbackCreateFile,
(PSTARBURN_WRITEFILE_CALLBACK)CallbackWriteFile,
(PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK )CallbackFlushFileBuffers,
(PSTARBURN_CLOSEHANDLE_CALLBACK)CallbackCloseHandle,
(PSTARBURN_DELETEFILE_CALLBACK)CallbackDeleteFile,
1,
"track01.mp3",
NUMBER_OF_READ_RETRIES,
TRUE,
FALSE,
READ_REPORT_DELAY_IN_SECONDS
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_IsDiscBlank Function

This example allocates CdvdBurnerGrabber object, detect is disc blank and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsDiscBlank(FALSE);

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to detect is disc blank
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_IsDiscBlank(
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
&l__BOOLEAN__IsDiscBlank
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_IsDiscBlank Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetDiscInformation, StarBurn_CdvdBurnerGrabber_GetTrackInformation, StarBurn_CdvdBurnerGrabber_GetTOCInformation, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, STARBURN_DISC_INFORMATION, STARBURN_TRACK_INFORMATION, STARBURN_TOC_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_Load Function

This example allocates CdvdBurnerGrabber object, ejects the media, loads it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media here...

// Try to load the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Load(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Load Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_LoadEx, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_LoadEx Function

This example allocates CdvdBurnerGrabber object, ejects the media, loads it (waiting for the drive to become into ready state) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to eject the media here...

// Try to load the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_LoadEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRUE // We want to return only after drive would become into ready state
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_LoadEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_Load, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_Lock Function

This example allocates CdvdBurnerGrabber object, locks it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to lock the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Lock(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Lock Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_Release


Example

Example
StarBurn_CdvdBurnerGrabber_MSFToLBA Function

Please see DiscAtOnceFromFile sample to see how to use StarBurn_MSFToLBA API call should be used.


See Also

See Also
StarBurn_CdvdBurnerGrabber_MSFToLBA Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx


See Also

See Also
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD


Example

Example
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes Function

This example allocates CdvdBurnerGrabber object, probes supported read modes and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsCooked = FALSE;
BOOLEAN l__BOOLEAN__IsRaw = FALSE;
BOOLEAN l__BOOLEAN__IsRawPQ = FALSE;
BOOLEAN l__BOOLEAN__IsRawRawPW = FALSE;
BOOLEAN l__BOOLEAN__IsPQ = FALSE;
BOOLEAN l__BOOLEAN__IsRawPW = FALSE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to probe supported read modes
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsCooked,
    &l__BOOLEAN__IsRaw,
    &l__BOOLEAN__IsRawPQ,
    &l__BOOLEAN__IsRawRawPW,
    &l__BOOLEAN__IsPQ,
    &l__BOOLEAN__IsRawPW
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and supported read modes information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes Function

This example allocates CdvdBurnerGrabber object, probes supported write modes and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsTrackAtOnce = FALSE;
BOOLEAN l__BOOLEAN__IsSessionAtOnce = FALSE;
BOOLEAN l__BOOLEAN__IsDiscAtOncePQ = FALSE;
BOOLEAN l__BOOLEAN__IsDiscAtOnceRawPW = FALSE;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to probe supported write modes
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsTrackAtOnce,
    &l__BOOLEAN__IsSessionAtOnce,
    &l__BOOLEAN__IsDiscAtOncePQ,
    &l__BOOLEAN__IsDiscAtOnceRawPW
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and supported write modes information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe


Example

Example
StarBurn_CdvdBurnerGrabber_ReadATIP Function

This example allocates CdvdBurnerGrabber object, reads ATIP information and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UCHAR l__UCHAR__ATIP[ 4096 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get ATIP information from device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadATIP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__UCHAR__ATIP,
    sizeof( l__UCHAR__ATIP )
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_ReadATIP Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_ReadCooked Function

This example allocates CdvdBurnerGrabber object, reads 2 (two) cooked logical blocks and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;
UCHAR l__UCHAR__Buffer[ 8192 ]; // We do allocate buffer on the stack but it's not correct. Page-aligned memory must be used.

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Prepare the buffer
RtlZeroMemory(
    &l__UCHAR__Buffer,
    sizeof( l__UCHAR__Buffer )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it

// Get currently inserted disc and analyze it

// Try to grab two cooked logical blocks starting from LBA 100 (from TOC we know that address 100 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadCooked(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PUCHAR )( &l__UCHAR__Buffer ),    // Pointer to data buffer to receive the payload
    sizeof( l__UCHAR__Buffer ),         // Data buffer size in unsigned char(s)
    100,                                // Start from logical block number 100
    2                                   // 2 logical blocks
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and read sectors here

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_ReadCooked Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange, StarBurn_CdvdBurnerGrabber_ReadLB, StarBurn_CdvdBurnerGrabber_ReadRaw


Example

Example
StarBurn_CdvdBurnerGrabber_ReadLB Function

This example allocates CdvdBurnerGrabber object, reads one logical block and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it...

// Allocate buffer
UCHAR l__UCHAR__Buffer[4096];

// Try to grab one logical block with address 1000 (from TOC we know that this address 1000 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadLB(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    1000,
    l__UCHAR__Buffer,
    4096
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and disc information here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_ReadLB Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange


See Also

See Also
StarBurn_CdvdBurnerGrabber_ReadRaw Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, TOC_INFORMATION, TOC_ENTRY, StarBurn_CdvdBurnerGrabber_GrabCD, StarBurn_CdvdBurnerGrabber_GrabDVD, StarBurn_CdvdBurnerGrabber_GrabRange, StarBurn_CdvdBurnerGrabber_ReadLB, StarBurn_CdvdBurnerGrabber_ReadCooked


Example

Example
StarBurn_CdvdBurnerGrabber_ReadRaw Function

This example allocates CdvdBurnerGrabber object, reads 2 (two) RAW logical blocks and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
TOC_INFORMATION l__TOC_INFORMATION;
UCHAR l__UCHAR__Buffer[ 8192 ]; // We do allocate buffer on the stack but it's not correct. Page-aligned memory must be used.

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Prepare the buffer
RtlZeroMemory(
    &l__UCHAR__Buffer,
    sizeof( l__UCHAR__Buffer )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare TOC information buffer
RtlZeroMemory(
    &l__TOC_INFORMATION,
    sizeof( l__TOC_INFORMATION )
    );

// Get TOC information here and analyze it

// Get currently inserted disc and analyze it. We can do RAW read from CD media only

// Probe supported read modes as we need to read in the ones drive really supports

// Try to grab two RAW logical blocks starting from LBA 100 (from TOC we know that address 100 is valid)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_ReadRaw(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    EXPECTED_LB_TYPE_ANY,               // Accept any logical blocks
    100,                                // Start from logical block number 100
    2,                                  // 2 logical blocks only
    ERROR_FIELD_NO_ERROR,               // No error data included
    TRUE,                               // YES, we need EDC/ECC data
    TRUE,                               // YES, we need user data
    HEADER_CODE_ALL_HEADERS,            // We need ALL of the headers
    TRUE,                               // YES, we need SYNC pattern
    SUBCHANNEL_RAW_PW,                  // Read RAW P-W sub-channel from the disc
    ( PUCHAR )( &l__UCHAR__Buffer ),    // Pointer to data buffer to receive the payload
    sizeof( l__UCHAR__Buffer )          // Data buffer size in unsigned char(s)
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object and read sectors here

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_Release Function

This example allocates CdvdBurnerGrabber object, locks it, releases (unlocks) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to lock media here...

// Try to release (unlock) the media
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Release(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_Release Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_Lock


Example

Example
StarBurn_CdvdBurnerGrabber_SendOPC Function

This example allocates CdvdBurnerGrabber object, sends optimum power calibration for current write speed and current CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to send optimum power calibration
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SendOPC(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SendOPC Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_SessionAtOnce Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image from file tree to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
DISC_LAYOUT l__DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to create ISO9660 or Joliet file system image with help of StarBurn_ISO9660JolietFileTree_Create and
// StarBurn_ISO9660JolietFileTree_BuildImage, l__PVOID__FileTree used as the pointer to the object...

// Fill DISC_LAYOUT structure here

RtlZeroMemory(
    &l__DISC_LAYOUT,
    sizeof( l__DISC_LAYOUT )
    );

l__DISC_LAYOUT.m__LONG__NumberOfEntries = 1;

l__DISC_LAYOUT.m__DISC_LAYOUT_ENTRY[ 0 ].m__PVOID__ISO9660JolietFileTree = l__PVOID__FileTree;

// Try to record the ISO9660 or Joliet file system image in Session-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SessionAtOnce(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__DISC_LAYOUT,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SessionAtOnce Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree


Example

Example
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW Function

This example allocates CdvdBurnerGrabber object, records raw image to the CD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the raw image in RAW SUB Session-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "Image.MDS",
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    TRUE,   // Write lead-in manually
    TRUE    // Amplify weak
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW


Example

Example
StarBurn_CdvdBurnerGrabber_SetBUP Function

This example allocates CdvdBurnerGrabber object, gets BUP status and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
BOOLEAN l__BOOLEAN__IsBUPEnabled;
BOOLEAN l__BOOLEAN__IsBUPSupported;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_GetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    &l__BOOLEAN__IsBUPEnabled,
    &l__BOOLEAN__IsBUPSupported
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Check is BUP supported, if yes - try to enable it
if ( l__BOOLEAN__IsBUPSupported == TRUE )
{

// Try to set BUP on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetBUP(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    TRUE
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SetBUP Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_GetBUP, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_SetCDTextItem Function

This example allocates CdvdBurnerGrabber object, specifies the CD-Text for a disc and for 3 track and burns the disc.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
DAO_DISC_LAYOUT l__DAO_DISC_LAYOUT;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add files to burn here by filling l__DAO_DISC_LAYOUT information

// Try to set CD-Text information for 3d track
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetCDTextItem(
    l__PVOID__CdvdBurnerGrabber,
    3,
    "My band",
    "My new song",
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status
    );

// Check for success
if (l__EXCEPTION_NUMBER != EN_SUCCESS)
{
// Handle error here...
}

// Try to set CD-Text information for the whole disc
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetCDTextItem(
    l__PVOID__CdvdBurnerGrabber,
    0,
    "My band",
    "My first album",
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status
    );

// Check for success
if (l__EXCEPTION_NUMBER != EN_SUCCESS)
{
// Handle error here...
}

// Try to burn ISO/sound/MDS image to the disc as CDROM XA (MODE2 Form1) or CDDA (CD digital audio) in Disc-At-Once raw P-W mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    &l__CDB_FAILURE_INFORMATION,
    &l__DAO_DISC_LAYOUT,
    FALSE,
    l__BOOLEAN__IsTestWrite,
    FALSE, // Next session allowed
    FALSE, // Do NOT repair broken sub-channel
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SetCDTextItem Function
See Also

StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile, StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_CreateEx


Example

Example
StarBurn_CdvdBurnerGrabber_SetReadSpeed Function

This example allocates CdvdBurnerGrabber object, sets maximum allowed read speed and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to set maximum allowed read speed
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetReadSpeed(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0xFFFF
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SetReadSpeed Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_GetSpeeds


Example

Example
StarBurn_CdvdBurnerGrabber_SetSpeeds Function

This example allocates CdvdBurnerGrabber object, sets top supported read and write speeds and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to set top supported CD/DVD/Blu-Ray/HD-DVD read/write speeds on the device
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SetSpeeds(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    0xFFFF,
    0xFFFF
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SetSpeeds Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_CreateEx, StarBurn_CdvdBurnerGrabber_SetReadSpeed, StarBurn_CdvdBurnerGrabber_GetSpeeds


Example

Example
StarBurn_CdvdBurnerGrabber_StopPlayScan Function

This example allocates CdvdBurnerGrabber object, burns something and does manual verification and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn image here...

// Try to update device state
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_StopPlayScan(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Manually verify recorded image here...

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_StopPlayScan Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile


Example

Example
StarBurn_CdvdBurnerGrabber_SuperVideoCD Function

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
ULONG l__ULONG__Status;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Track-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\MOVIE.MPEG2",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SuperVideoCD Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VideoCD


See Also

See Also
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_VideoCDEx


Example

Example
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx Function

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG2",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx Function

This example allocates CdvdBurnerGrabber object, records the SVCD/MPEG2 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more. Custom user file name is passed to have own data track on resulting SVCD.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the SVCD/MPEG2 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG2",  // Second MPEG2 track
    "C:\DATA.ISO",     // First DATA track
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_VideoCDExEx, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx


Example

Example
StarBurn_CdvdBurnerGrabber_TestUnitReady Function

This example allocates CdvdBurnerGrabber object, tests unit ready and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReady(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TestUnitReady Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx, StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx


Example

Example
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx Function

This example allocates CdvdBurnerGrabber object, tests unit ready for 10 seconds (instead of default 20) and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready for 10 seconds
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    10 // 10 seconds to test unit to become into ready state
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx


Example

Example
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx Function

This example allocates CdvdBurnerGrabber object, tests unit ready and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to test unit ready
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    5,      // 5 seconds to wait for device to become ready
    TRUE    // Fast exit if there's no disc in drive
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TestUnitReady, StarBurn_CdvdBurnerGrabber_TestUnitReadyEx


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\ISO9660.ISO",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx Function

This example allocates CdvdBurnerGrabber object, records sound track image to the CD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to sound track image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\TRACK.WAV",
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    0x0000, // Zero-sized pause between tracks
    TRUE    // Yes, apply pause change
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory Function

This example allocates CdvdBurnerGrabber object, reads ISO9660 or Joliet file system image to the memory, records it to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PUCHAR l__PUCHAR__MemoryRegion;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in memory. Pointer would be
// stored in l__UCHAR__MemoryRegion and memory region size would be stored in
// l__LARGE_INTEGER__SizeInUCHARs variable

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PVOID )( l__PUCHAR__MemoryRegion ),
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    FALSE // We burn data compilation
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx Function

This example allocates CdvdBurnerGrabber object, reads audio track content to the memory, records it to the CD recordable media and destroys the device object after it's not needed any more. Also it sets track-to-track pause to zero.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber = NULL;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PUCHAR l__PUCHAR__MemoryRegion = NULL;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare audio track and store it to the memory. Pointer would be
// stored in l__UCHAR__MemoryRegion and memory region size would be stored in
// l__LARGE_INTEGER__SizeInUCHARs variable

// Try to record the audio track in Track-At-Once mode and set zero-sized track-to-track pause
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PVOID )( l__PUCHAR__MemoryRegion ),
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    TRUE,   // We burn audio compilation
    0,      // Track-to-track pause length of ZERO
    TRUE    // Yes, please alter default pause length
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
HANDLE l__HANDLE__Pipe = INVALID_HANDLE_VALUE;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in pipe

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__HANDLE__Pipe,
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
HANDLE l__HANDLE__Pipe = INVALID_HANDLE_VALUE;
LARGE_INTEGER l__LARGE_INTEGER__SizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare file system image or file and keep in pipe

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__HANDLE__Pipe,
    l__LARGE_INTEGER__SizeInUCHARs,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS,
    FALSE // We burn data compilation
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree Function

This example allocates CdvdBurnerGrabber object, records the ISO9660 or Joliet file system image from file tree to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to create ISO9660 or Joliet file system image with help of StarBurn_ISO9660JolietFileTree_Create and
// StarBurn_ISO9660JolietFileTree_BuildImage, l__PVOID__FileTree used as the pointer to the object...

// Try to record the ISO9660 or Joliet file system image in Track-At-Once mode
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    FALSE,
    FALSE,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup Function

Please see UDFLookup sample as example how to use StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup API call.


Example

Example
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx Function

Please see UDFLookup sample as example how to use StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup API call.


Example

Example
StarBurn_CdvdBurnerGrabber_VerifyFile Function

This example allocates CdvdBurnerGrabber object, burns image "IMAGE.ISO", verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn prepared file system image "IMAGE.ISO" here

// Try to verify file image
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyFile(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "IMAGE.ISO",
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VerifyFile Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyTree


Example

Example
StarBurn_CdvdBurnerGrabber_VerifyFileEx Function

This example allocates CdvdBurnerGrabber object, burns image "IMAGE.ISO", verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Burn prepared file system image "IMAGE.ISO" here

// Try to verify file image
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyFileEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "IMAGE.ISO",
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000, // Call progress callback after every 1000 logical blocks processed
    10 // Allow up to 10 attempts to read failed logical block
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VerifyFileEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyTree, StarBurn_CdvdBurnerGrabber_VerifyFile


Example

Example
StarBurn_CdvdBurnerGrabber_VerifyTree Function

This example allocates CdvdBurnerGrabber object, burns file tree, verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and burn ISO9660 or Joliet file tree here

// Try to verify file tree
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyTree(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VerifyTree Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTreeEx, StarBurn_CdvdBurnerGrabber_VerifyFile


Example

Example
StarBurn_CdvdBurnerGrabber_VerifyTreeEx Function

This example allocates CdvdBurnerGrabber object, burns file tree, verifies it and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__FileTree;
LONG l__LONG__FailedLBA;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and burn ISO9660 or Joliet file tree here

// Try to verify file tree
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VerifyTreeEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    l__PVOID__FileTree,
    0, // Assume we've started to burn from LBA 0
    &l__LONG__FailedLBA,
    1000 // Call progress callback after every 1000 logical blocks processed,
    10 // Allow up to 10 attempts to read failed logical block
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VerifyTreeEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_VerifyTree, StarBurn_CdvdBurnerGrabber_VerifyFile


Example

Example
StarBurn_CdvdBurnerGrabber_VideoCD Function

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Track-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCD(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    "C:\MOVIE.MPEG1",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VideoCD Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD


Example

Example
StarBurn_CdvdBurnerGrabber_VideoCDEx Function

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCDEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG1",
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VideoCDEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx


Example

Example
StarBurn_CdvdBurnerGrabber_VideoCDExEx Function

This example allocates CdvdBurnerGrabber object, records the VCD/MPEG1 image to the CD/DVD/Blu-Ray/HD-DVD media and destroys the device object after it's not needed any more. Custom user file name is passed to have own data track on resulting VCD.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to record the VCD/MPEG1 image (in Session-At-Once mode)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_VideoCDExEx(
    l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    WRITE_MODE_SESSION_AT_ONCE,
    "C:\MOVIE.MPEG1",  // Second MPEG1 track
    "C:\DATA.ISO",     // First DATA track
    "Album",
    0x0001,
    0x0001,
    FALSE,
    WRITE_REPORT_DELAY_IN_SECONDS,
    BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_CdvdBurnerGrabber_VideoCDExEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, StarBurn_CdvdBurnerGrabber_SetSpeeds, StarBurn_CdvdBurnerGrabber_SendOPC, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_SuperVideoCD, StarBurn_CdvdBurnerGrabber_VideoCD, StarBurn_CdvdBurnerGrabber_SuperVideoCDEx, StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx, StarBurn_CdvdBurnerGrabber_VideoCDEx


Example

Example
StarBurn_CorrectISO9660Name_Default Function

N/A


See Also

See Also
StarBurn_CorrectISO9660Name_Default Function
See Also

StarBurn_CorrectJolietName_Default


Example

Example
StarBurn_CorrectJolietName_Default Function

N/A


See Also

See Also
StarBurn_CorrectJolietName_Default Function
See Also

StarBurn_CorrectISO9660Name_Default


Example

Example
StarBurn_CreatePipe Function

This example allocates both "read" and "write" handles for the same pipe, does some I/O and closes them both later.

// Somewhere in the data region
HANDLE l__HANDLE__ReadPipe = INVALID_HANDLE_VALUE;
HANDLE l__HANDLE__WritePipe = INVALID_HANDLE_VALUE;
ULONG l__ULONG__Status = ERROR_SUCCESS;

// Try to create pipe
l__ULONG__Status =
StarBurn_CreatePipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );

// Check for success
if ( l__ULONG__Status != ERROR_SUCCESS )
{
// Handle error here...
}

// Do something with the pipe handles here...

// Close both "read" and "write" pipe handles
StarBurn_DestroyPipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );


See Also

See Also
StarBurn_CreatePipe Function
See Also

StarBurn_DestroyPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx


Example

Example
StarBurn_Destroy Function

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    TRUE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_Destroy Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_CdvdBurnerGrabber_Create


Example

Example
StarBurn_DestroyPipe Function

This example allocates both "read" and "write" handles for the same pipe, does some I/O and closes them both later.

// Somewhere in the data region
HANDLE l__HANDLE__ReadPipe = INVALID_HANDLE_VALUE;
HANDLE l__HANDLE__WritePipe = INVALID_HANDLE_VALUE;
ULONG l__ULONG__Status = ERROR_SUCCESS;

// Try to create pipe
l__ULONG__Status =
StarBurn_CreatePipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );

// Check for success
if ( l__ULONG__Status != ERROR_SUCCESS )
{
// Handle error here...
}

// Do something with the pipe handles here...

// Close both "read" and "write" pipe handles
StarBurn_DestroyPipe(
    &l__HANDLE__ReadPipe,
    &l__HANDLE__WritePipe
    );


See Also

See Also
StarBurn_DestroyPipe Function
See Also

StarBurn_CreatePipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx


Example

Example
StarBurn_DownShut Function

This example just uninitialize toolkit.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;

// Try to uninitialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_DownShut();

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}


See Also

See Also
StarBurn_DownShut Function
See Also

See samples for details how and when call StarBurn_DownShut() function.


Example

Example
StarBurn_DVDVideo_Create Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Create API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_Create Function
See Also

StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer


Example

Example
StarBurn_DVDVideo_Destroy Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Destroy API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_Destroy Function
See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer


Example

Example
StarBurn_DVDVideo_GetSizeInUCHARs Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_GetSizeInUCHARs API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_GetSizeInUCHARs Function
See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetTreePointer


Example

Example
StarBurn_DVDVideo_GetTreePointer Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_GetTreePointer API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_GetTreePointer Function
See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs


Example

Example
StarBurn_DVDVideo_PatchHeader Function

See the DVDVideoBuildImage example.


Example

Example
StarBurn_DVDVideo_PatchTable Function

See the DVDVideoBuildImage example.


Example

Example
StarBurn_DVDVideo_Read Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_Read API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_Read Function
See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_SeekToBegin, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer


Example

Example
StarBurn_DVDVideo_SeekToBegin Function

See DVDVideoTrackAtOnceFromFileEx and DVDVideoBuildImageEx StarBurn sample applications as an example how to use StarBurn_DVDVideo_SeekToBegin API call and all of the companion DVD-Video sub-API calls.


See Also

See Also
StarBurn_DVDVideo_SeekToBegin Function
See Also

StarBurn_DVDVideo_Create, StarBurn_DVDVideo_Destroy, StarBurn_DVDVideo_Read, StarBurn_DVDVideo_GetSizeInUCHARs, StarBurn_DVDVideo_GetTreePointer


Example

Example
StarBurn_FindDevice Function

This example finds first first CD/DVD/Blu-Ray/HD-DVD device, allocates CdvdBurnerGrabber object, and destroys the device object after it's not needed any more.

VOID
__stdcall
Find_Callback(
    IN CALLBACK_NUMBER p__CALLBACK_NUMBER,
    IN PVOID p__PVOID__CallbackContext,
    IN PVOID p__PVOID__CallbackSpecial1,
    IN PVOID p__PVOID__CallbackSpecial2
    )
{

PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on passed address (bus ID is always 0 in case of ASPI and LUN cannot be probed so
// always 0 as well) with 32MB of cache)
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    ( UCHAR )( p__PVOID__CallbackSpecial1) ,
    0,
    ( UCHAR )( p__PVOID__CallbackSpecial2) ,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with CdvdBurnerGrabber device object here...

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}

}

// Somewhere in the code

// Try to find device
if (
StarBurn_FindDevice(
    SCSI_DEVICE_RO_DIRECT_ACCESS,
    TRUE,
    ( PCALLBACK )( Find_Callback ),
    NULL
    ) == 0
)
{
// Handle error here...
}
else
{
// All actions are in the callback function...
}


See Also

See Also
StarBurn_FindDevice Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION


Example

Example
StarBurn_GetAudioFileStreamSizeInUCHARs Function

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.


See Also

See Also
StarBurn_GetAudioFileStreamSizeInUCHARs Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_GetAudioFileStreamSizeInUCHARs_Fast


Example

Example
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast Function

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.


See Also

See Also
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_GetAudioFileStreamSizeInUCHARs


Example

Example
StarBurn_GetBufferUnderrunTimeOutInMs Function

There are no samples for StarBurn_GetBufferUnderrunTimeOutInMs(...) API call.


See Also

See Also
StarBurn_GetBufferUnderrunTimeOutInMs Function
See Also

StarBurn_SetBufferUnderrunTimeOutInMs


Example

Example
StarBurn_GetDeviceLetter Function

Please see GUI samples as example how to use StarBurn_GetDeviceLetter API call.


See Also

See Also
StarBurn_GetDeviceLetter Function
See Also

StarBurn_CdvdBurnerGrabber_CreateEx.


Example

Example
StarBurn_GetDeviceNameByDeviceAddress Function

This example gets device name by device address.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
CHAR l__CHAR__DeviceName[ MAX_PATH ];

// Prepare device name
RtlZeroMemory(
    &l__CHAR__DeviceName,
    sizeof( l__CHAR__DeviceName )
    );

// Try to get device name by device address 0:0:1:0
l__EXCEPTION_NUMBER =
StarBurn_GetDeviceNameByDeviceAddress(
    0,
    1,
    0,
    0,
    ( PCHAR )( &l__CHAR__DeviceName )
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with device name here...


See Also

See Also
StarBurn_GetDeviceNameByDeviceAddress Function
See Also

StarBurn_GetVersion, StarBurn_CdvdBurnerGrabber_Create


Example

Example
StarBurn_GetDeviceTimeOutByDeviceAddress Function

Please see FindDevice sample as example how to use StarBurn_GetDeviceTimeOutByDeviceAddress API call.


See Also

See Also
StarBurn_GetDeviceTimeOutByDeviceAddress Function
See Also

StarBurn_SetDeviceTimeOutByDeviceAddress


Example

Example
StarBurn_GetDVDPadding Function

There are no examples for StarBurn_GetDVDPadding(...) API call.


See Also

See Also
StarBurn_GetDVDPadding Function
See Also

StarBurn_SetDVDPadding


Example

Example
StarBurn_GetDVDPLUSRDLCompatibleMode Function

There are no examples for StarBurn_GetDVDPLUSRDLCompatibleMode(...) API call.


See Also

See Also
StarBurn_GetDVDPLUSRDLCompatibleMode Function
See Also

StarBurn_SetDVDPLUSRDLCompatibleMode


Example

Example
StarBurn_GetEjectAfterFail Function

There are no examples for StarBurn_GetEjectAfterFail(...) API call.


See Also

See Also
StarBurn_GetEjectAfterFail Function
See Also

StarBurn_SetEjectAfterFail


Example

Example
StarBurn_GetFastReadTOC Function

Please see GrabTrack sample no how to use StarBurn_GetFastReadTOC(...) API call.


See Also

See Also
StarBurn_GetFastReadTOC Function
See Also

StarBurn_SetFastReadTOC


Example

Example
StarBurn_GetId Function

Please see FindDevice sample as example how to use StarBurn_GetId API call.


See Also

See Also
StarBurn_GetId Function
See Also

There are no companion API calls for this one.


Example

Example
StarBurn_GetIs64KBIO Function

There are no examples for StarBurn_GetIs64KBIO(...) API call.


See Also

See Also
StarBurn_GetIs64KBIO Function
See Also

StarBurn_SetIs64KBIO


Example

Example
StarBurn_GetIsCollisionDetectionDisabled Function

Please see BuildImage sample to find out how collision detection could be disabled and enabled during file system image creation.


See Also

See Also
StarBurn_GetIsCollisionDetectionDisabled Function
See Also

StarBurn_SetIsCollisionDetectionDisabled


Example

Example
StarBurn_GetIsSafeGrabbingEnabled Function

There are no examples for StarBurn_GetIsSafeGrabbingEnabled(...) API call.


See Also

See Also
StarBurn_GetIsSafeGrabbingEnabled Function
See Also

StarBurn_SetIsSafeGrabbingEnabled


Example

Example
StarBurn_GetVersion Function

This example checks for the toolkit version.

// Somewhere in the data region
ULONG l__ULONG__Version;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}


See Also

See Also
StarBurn_GetVersion Function
See Also

Samples for more details about differences between newer and older toolkit versions.


Example

Example
StarBurn_GetVolumeIDs Function

Please see BuildImageWithImportFromFile sample as example how to use StarBurn_GetVolumeIDs API call.


See Also

See Also
StarBurn_GetVolumeIDs Function
See Also

There are no companion API calls for this one.


StarBurn.h Enumerations

StarBurn.h Enumerations
StarBurn.h | Legend
Enumerations
Name | Description
_CALLBACK_NUMBER | Enum that represents callback number
_DISC_TYPE | Enum that represents inserted disc type
_ERASE_TYPE | Enum that represents erase type
_EXCEPTION_NUMBER | Enum that represents exception number
_FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
_FILE_TREE | Enum that represents file tree
_ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
_NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
_READ_MODE | Enum that represents raw read modes
_STARBURN_CD_MODE | Enum that represents CD modes type
_STARBURN_ELTORITO_MEDIA | Media emulation types
_STARBURN_ELTORITO_PLATFORM | ElTorito platform types
_STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
_STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
_STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
_STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
_STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
_STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
_STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
_STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
_UDF_OS_CLASS | UDF OS class
_UDF_VERSION | Enum that represents UDF version
_WRITE_MODE | Enum that represents write modes
CALLBACK_NUMBER | Enum that represents callback number
DISC_TYPE | Enum that represents inserted disc type
ERASE_TYPE | Enum that represents erase type
EXCEPTION_NUMBER | Enum that represents exception number
FILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
FILE_TREE | Enum that represents file tree
ISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
NAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PCALLBACK_NUMBER | Enum that represents callback number
PDISC_TYPE | Enum that represents inserted disc type
PERASE_TYPE | Enum that represents erase type
PEXCEPTION_NUMBER | Enum that represents exception number
PFILE_TIME | Enum that represents file time that will be included in the ISO9660/Joliet image
PFILE_TREE | Enum that represents file tree
PISO9660_KIDTYPE | Enum that represent type of ISO9660 tree node
PNAME_COLLISION_SOLUTION | Enum that represents the solutions of name collisions
PPSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PPSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PPSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PPSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PREAD_MODE | Enum that represents raw read modes
PSTARBURN_CD_MODE | Enum that represents CD modes type
PSTARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
PSTARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PSTARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
PSTARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
PSTARPORT_DEVICE_TYPE | Enum that represents StarPort device type
PSTARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
PWRITE_MODE | Enum that represents write modes
READ_MODE | Enum that represents raw read modes
STARBURN_CD_MODE | Enum that represents CD modes type
STARBURN_ELTORITO_MEDIA | Media emulation types
STARBURN_ELTORITO_PLATFORM | ElTorito platform types
STARBURN_STARWAVE_CALLBACK_REASON | StarWave callback reasons we'll be using
STARBURN_STARWAVE_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates, all of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
STARBURN_STARWAVE2_COMPRESS_TYPE | Compress settings
STARBURN_STARWAVE2_CONVERSION_MODE | Structure that represents conversion mode
STARBURN_STARWAVE2_QUALITY_MODE | Enum that represents MP3 quality for conversion
STARBURN_UDF_BRIDGE_TYPE | Restore original structure packing
STARBURN_UDF2_FILE_DATE_TIME_TYPE | Enum that represents StarBurn date/time type for files in UDF
STARPORT_DEVICE_TYPE | Enum that represents StarPort device type
STARWAVE2_COMPRESSION | Compression templates we'll be using, pointer to compression templates and pointer to pointer to compression templates All of the compression templates are 44 kHz, stereo, 16-bit, CBR or VBR
UDF_OS_CLASS | UDF OS class
UDF_VERSION | Enum that represents UDF version
WRITE_MODE | Enum that represents write modes


StarBurn.h Functions

StarBurn.h Functions
StarBurn.h | Legend
Functions
Name | Description
StarBurn_CdvdBurnerGrabber_AuthorizeDVD | This function authorizes DVD that has CSS protection system.
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx | This function authorizes DVD that has CSS protection system and keeps bus key for disc key.
StarBurn_CdvdBurnerGrabber_Blank | This function erases the rewritable media inserted into CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormat | This function formats Blu-Ray rewritable media (BD-RE) inserted into the Blu-Ray burner device.
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery | This function queries available Blu-Ray formats for the currently inserted Blu-Ray rewritable media (BD-RE).
StarBurn_CdvdBurnerGrabber_Cancel | This function cancels current read or write process on the CD/DVD/Blu-Ray/HD-DVD burner.
StarBurn_CdvdBurnerGrabber_CloseSession | This function closes session on on CD/DVD/Blu-Ray/HD-DVD burner device after something was written using StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe or StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile.
StarBurn_CdvdBurnerGrabber_Create | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD releated actions.
StarBurn_CdvdBurnerGrabber_CreateEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTI (SCSI Pass Through Interface) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_CreateExEx | This function creates CD/DVD/Blu-Ray/HD-DVD burner device object using SPTD (SCSI Pass Through Direct) transport. This object will be used later to perform CD/DVD/Blu-Ray/HD-DVD related actions.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once PQ mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be one sound file or full set of sound files if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode | This API accepts track names in Unicode format and does AUDIO only DAO burn.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree | This function records ISO9660 or Joliet file system image located in file tree object with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Disc-At-Once raw P-W mode.
StarBurn_CdvdBurnerGrabber_Eject | This function ejects the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ExecuteGeneric | This function executes custom CDB (Command Descriptor Block) on CD/DVD/Blu-Ray/HD-DVD burner device object. This could be used to deal with the propriatry hardware or execute some special code StarBurn does not support out-of-box.
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetBUP | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device supports BUP (Buffer Underrun Protection) or not and what is BUP current status (if supported). This information can be used later to set BUP status before starting write operations.
StarBurn_CdvdBurnerGrabber_GetDeviceInformation | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode | This is function StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode.
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem | This function detects recorded optical disc file system.
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace | This function gets disc free space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscInformation | This function gets disc information of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace | This function gets disc used space of the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem | This function gets DVD protection system of inserted DVD media into DVD device.
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask | This function gets DVD region mask from DVD media inserted to CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType | This function returns inserted to CD/DVD/Blu-Ray/HD-DVD burner device disc type. This data can be used to report it to the user and to select the stream type to record.
StarBurn_CdvdBurnerGrabber_GetLastAddress | This function gets last recorded address from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such an address could be used for already recorded session import with the UDF mastering.
StarBurn_CdvdBurnerGrabber_GetLastTrack | This function gets last recorded track from CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object. Such a track number could be used for already recorded session import.
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions | This function gets mechanical options (is device capable of programmatically load/eject and lock/unlock etc) from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus | This function gets media (inserted or not) and tray (opened or closed) statuses from CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors | This function gets number of system descriptors in system structures stream. This value is used for updating head of the image when creating signle track session import code.
StarBurn_CdvdBurnerGrabber_GetRPC | This function gets RPC (region play code) and some additional DVD region management information from "DVD part" of the CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_GetSpeeds | This function gets current read and write and top supported read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device. This speeds later will be used to set current speeds during all read and write operations.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats | This function returns CD/DVD/Blu-Ray/HD-DVD burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx | This function returns DVD+R(W) burner device object extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx | This function returns DVD+R(W) burner device object extended extended information. This data can be used to report the capabilities of the device to the user.
StarBurn_CdvdBurnerGrabber_GetTOCInformation | This function gets TOC information of the currently inserted disc in the CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformation | This function gets track information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx | This function gets track extended information of the asked track number on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabCD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format.
StarBurn_CdvdBurnerGrabber_GrabDVD | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files.
StarBurn_CdvdBurnerGrabber_GrabDVDEx | This function grabs disc image (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. StarBurn_CdvdBurnerGrabber_GrabDVDEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabDVDFast | This function grabs disc image from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device and store it in MDS format, disc image will be stored into the series of files. Works faster than StarBurn_CdvdBurnerGrabber_GrabDVD
StarBurn_CdvdBurnerGrabber_GrabRange | This function grabs range of logical blocks from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrack | This function grabs track from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_GrabTrackEx | This function grabs track (extended) from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device. StarBurn_CdvdBurnerGrabber_GrabTrackEx function for all I/O files operations use user's callback functions.
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode | This is function StarBurn_CdvdBurnerGrabber_GrabTrackUnicode.
StarBurn_CdvdBurnerGrabber_IsDiscBlank | This function detect blank state of currently inserted disc in CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_Load | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_LoadEx | This function loads the media on CD/DVD/Blu-Ray/HD-DVD burner device. Unlike StarBurn_CdvdBurnerGrabber_Load(...) this API call allows to control should it return immediately or wait until the drive would become into ready state.
StarBurn_CdvdBurnerGrabber_Lock | This function locks the media inside the CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_MSFToLBA | This function converts MSF (minute:second:frame) address into the LBA (logical block address).
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes | This function probes supported read modes on the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadATIP | This function reads ATIP information from the media currently inserted into CD/DVD/Blu-Ray/HD-DVD burner device object created with the call to the one of the StarBurn_CdvdBurnerGrabber_Create or StarBurn_CdvdBurnerGrabber_CreateEx API calls.
StarBurn_CdvdBurnerGrabber_ReadCooked | This function reads one or more logical block(s) from the currently inserted CD/DVD/Blu-Ray/HD-DVD in cooked format.
StarBurn_CdvdBurnerGrabber_ReadLB | This function reads one logical block from the currently inserted disc on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_ReadRaw | This function reads one or more logical block(s) from the currently inserted CD in RAW format.
StarBurn_CdvdBurnerGrabber_Release | This function releases the media inside the CD/DVD/Blu-Ray/HD-DVD device after the media was locked before.
StarBurn_CdvdBurnerGrabber_SendOPC | This function sends OPC (Optimum Power Calibration) for current write speed on CD/DVD/Blu-Ray/HD-DVD burner device and current CD/DVD/Blu-Ray/HD-DVD media. The set laser level will be used later during all write operations.
StarBurn_CdvdBurnerGrabber_SessionAtOnce | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create or ISO image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW | This function records raw image with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in raw Session-At-Once mode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode.
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode | This is function StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode.
StarBurn_CdvdBurnerGrabber_SetBUP | This function sets BUP (Buffer Underrun Protection) on CD/DVD/Blu-Ray/HD-DVD burner device that supports BUP. BUP must be enabled for successful completion of write operations.
StarBurn_CdvdBurnerGrabber_SetCDTextItem | Sets CD-Text item for the specified CD/DVD/Blu-Ray/HD-DVD device.
StarBurn_CdvdBurnerGrabber_SetReadSpeed | This function sets read speed for CD/DVD/Blu-Ray/HD-DVD media currently inserted to CD/DVD/Blu-Ray/HD-DVD burner device object.
StarBurn_CdvdBurnerGrabber_SetSpeeds | This function sets current read and write speeds on CD/DVD/Blu-Ray/HD-DVD burner device This speeds later will be used during all read and write operations.
StarBurn_CdvdBurnerGrabber_StopPlayScan | This function resets media state inside CD/DVD/Blu-Ray/HD-DVD burner device object. This actions allow to update disc content w/o need to eject the disc. Could be used for multiple burnings w/o disc eject or manual disc data verification.
StarBurn_CdvdBurnerGrabber_SuperVideoCD | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device.
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx | This function records SVCD/MPEG2 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode.
StarBurn_CdvdBurnerGrabber_TestUnitReady | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations.
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. The only difference between this and simple StarBurn_CdvdBurnerGrabber_TestUnitReady() is that this code passed parameter to wait for unit to become ready. And "simple" code uses default timeout of 20 seconds.
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx | This function tests is CD/DVD/Blu-Ray/HD-DVD burner device object unit ready or not. This information can be used later to start I/O operations. This "double extended" variant of the call also can wait for particular amount of seconds and do "fast exit" if there's no disc in drive.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode | This API call deals with audio tracks with Unicode names only.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx | This API call deals with audio tracks with Unicode names only. Also it allows to set track-to-track pause length.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx | This function records ISO9660 or Joliet file system image located in a file on the hard disk (also it can be sound file if an audio CD is mastered) with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode | This is function StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx | This function records ISO9660 or Joliet file system image or audio stream located in a memory with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode. If audio content is recorded this API call can change default Track-At-Once track-to-track pause length from 150 logical blocks (2 seconds) to any passed one.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe | This function records ISO9660 or Joliet file system image located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx | This function records ISO9660 or Joliet file system image or audio stream located in a pipe with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx | This function records ISO9660 or Joliet file system image located in a virtual file tree created with StarBurn_ISO9660JolietFileTree_Create with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup | This function parses the UDF file system on disc and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx | This function parses the UDF file system on disc and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_CdvdBurnerGrabber_VerifyFile | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileEx | This function verifies recorded file system image on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular image recording (or maybe other image). This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode.
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode | This is function StarBurn_CdvdBurnerGrabber_VerifyFileUnicode.
StarBurn_CdvdBurnerGrabber_VerifyTree | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VerifyTreeEx | This function verifies recorded file system tree on CD/DVD/Blu-Ray/HD-DVD burner device object used for this particular tree recording. This information can be used to be sure recorded disc is readable and really contains recorded information.
StarBurn_CdvdBurnerGrabber_VideoCD | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in Track-At-Once mode.
StarBurn_CdvdBurnerGrabber_VideoCDEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExEx | This function records VCD/MPEG1 image located in a file on the hard disk with current write speed on CD/DVD/Blu-Ray/HD-DVD burner device in selected write mode.
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDExUnicode.
StarBurn_CdvdBurnerGrabber_VideoCDUnicode | This is function StarBurn_CdvdBurnerGrabber_VideoCDUnicode.
StarBurn_CorrectISO9660Name_Default | This function generates next ISO9660 file name to make it unique.
StarBurn_CorrectJolietName_Default | This function generates next Joliet file name to make it unique.
StarBurn_CreatePipe | This function creates pipe for all of the StarBurn pipe operations and returns both "read" and "write" handles for it.
StarBurn_Destroy | This function frees allocated memory in the way of destroying the object that toolkit created internally. This is universal call, it frees all the objects and does not care about object type.
StarBurn_DestroyPipe | This function closes both "read" and "write" pipe handles.
StarBurn_DownShut | This function uninitialize burning toolkit. It's expected to be called after very last function call before exiting from StarBurn client application. It's a good idea to gather the trash before exiting. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used.
StarBurn_DVDVideo_Create | This function creates DVD-Video file system object from passed pointer to VIDEO_TS directory with DVD corresponding files.
StarBurn_DVDVideo_CreateUnicode | This is function StarBurn_DVDVideo_CreateUnicode.
StarBurn_DVDVideo_Destroy | This function destroys DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetSizeInUCHARs | This function gets file system content size in UCHARs from DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_GetTreePointer | This function returns pointer to ISO9660 file tree object embedded to DVD-Video file system object created with StarBurn_DVDVideo_Create API call.
StarBurn_DVDVideo_PatchHeader | This function patches IFO/BUF file header RBA for BUP.
StarBurn_DVDVideo_PatchTable | This function patches IFO/BUF file table RBAs.
StarBurn_DVDVideo_Read | This function reads requested number of UCHARs from DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) from it's current read position.
StarBurn_DVDVideo_SeekToBegin | This function moves DVD-Video file system object (created with StarBurn_DVDVideo_Create API call) current read position to the very beginning.
StarBurn_ElTorito_BootCatalogAddSection | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_BootCatalogAddSectionUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_ElTorito_CreateBootCatalog | This function creates ElTorito boot catalog (ANSI names).
StarBurn_ElTorito_CreateBootCatalogUnicode | This function creates ElTorito boot catalog (UNICODE names).
StarBurn_FileClose | This fucntion closes file handle embedded to file object.
StarBurn_FileCreate | This function creates new file from the passed file path and name.
StarBurn_FileInitialize | This function initializes file handle embedded to file object with bad file handle value.
StarBurn_FileOpen | This function opens existing file from the passed file path and name.
StarBurn_FileOpenEx | This function opens existing file from the passed file path and name.
StarBurn_FileRead | This function reads asked amount of unsigned chars from file at current seek position.
StarBurn_FileReWind | This function rewinds file position in unsigned chars to the very beginning for the file.
StarBurn_FileSeek | This function sets file position in unsigned chars to required one.
StarBurn_FileSeekRead | This function sets file position in unsigned chars to required one and reads requested amounts unsigned chars.
StarBurn_FileSizeInUCHARsGet | This function gets file size in unsigned chars.
StarBurn_FileUnicodeCreate | This function creates new file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpen | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileUnicodeOpenEx | This function opens existing file from the passed UNICODE file path and name.
StarBurn_FileWrite | This function writes asked amount of unsigned chars to file at current seek position
StarBurn_FindDevice | This function finds device of the specified device type.
StarBurn_GetAudioFileStreamSizeInUCHARs | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast | This function returns audio stream size in UCHARs for passed supported as source audio file.
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast | This is function StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast.
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode | This is function StarBurn_GetAudioFileStreamSizeInUCHARsUnicode.
StarBurn_GetBufferUnderrunTimeOutInMs | This function returns buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_GetDeviceLetter | This function returns device letter (device root path) for a device name, like the one used in StarBurn_CdvdBurnerGrabber_CreateEx(...) API call.
StarBurn_GetDeviceLetterUnicode | This is function StarBurn_GetDeviceLetterUnicode.
StarBurn_GetDeviceNameByDeviceAddress | This function gets device name by device address.
StarBurn_GetDeviceTimeOutByDeviceAddress | This function gets device timeout in seconds by device SCSI address.
StarBurn_GetDVDPadding | This function returns is DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) enabled (TRUE) or disabled (FALSE).
StarBurn_GetDVDPLUSRDLCompatibleMode | This function returns is DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) enabled (TRUE) or disabled (FALSE).
StarBurn_GetEjectAfterFail | This function returns is so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) enabled (TRUE) or disabled (FALSE).
StarBurn_GetFastReadTOC | This function returns is so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn trys to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode enabled (TRUE) or disabled (FALSE).
StarBurn_GetId | This function gets ASPI layer ID strings.
StarBurn_GetIs64KBIO | This function returns is so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) currently enabled (TRUE) or disabled (FALSE).
StarBurn_GetIsCollisionDetectionDisabled | This function returns is collision detection disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_GetIsSafeGrabbingEnabled | This function returns is so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) enabled (TRUE) or disabled (FALSE).
StarBurn_GetVersion | This function returns a 32-bit unsigned long value that contains packed numbers that represent the year, the month and the date of the toolkit build. So 10th of March, year of 1978 will look like 0x19780310.
StarBurn_GetVolumeIDs | This function gets volume ID from ISO9660/Joliet volume name.
StarBurn_ImageFile_UDFFileSystemLookup | This function parses the UDF file system inside image file and calls a callback function for each found file. The information about LBAs that file resides on is passed to callback function.
StarBurn_ImageFile_UDFFileSystemLookupEx | This function parses the UDF file system inside image file and calls a callback function for each found file and directory. The information about LBAs that file resides on is passed to callback function.
StarBurn_IsAudioFileSupported | This function returns is currently passed file supported as source audio file.
StarBurn_IsAudioFileSupportedUnicode | This is function StarBurn_IsAudioFileSupportedUnicode.
StarBurn_IsLocalDateTimeUsed | This is function StarBurn_IsLocalDateTimeUsed.
StarBurn_ISO2_Check1999Name | This function checks if given string valid ISO9660:1999 file (or directory) name
StarBurn_ISO2_CheckJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name
StarBurn_ISO2_CheckLevel1Name | This function checks if given string valid ISO9660 Level 1 file (or directory) name
StarBurn_ISO2_CheckLevel2Name | This function checks if given string valid ISO9660 Level 2 file (or directory) name
StarBurn_ISO2_CheckRelaxedJolietName | This function checks if given string valid ISO9660 Joliet file (or directory) name with less restrictions: names may contain more than one dot.
StarBurn_ISO2_CreateNewName | This function creates new ANSI name by adding ~XX (where XX is a number (Seed)) at the end of file name.
StarBurn_ISO2_DirectoryBrowse | This function browses ISO9660 directory content.
StarBurn_ISO2_DirectoryCreate | This function creates ISO9660 directory.
StarBurn_ISO2_DirectoryDestroy | This function destroys created ISO9660 directory object.
StarBurn_ISO2_DirectoryProcess | This function processes single ISO9660 directory.
StarBurn_ISO2_DirectoryQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_DirectoryRootCreate | This function creates root ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeCreate | This function creates UNICODE ISO9660 directory.
StarBurn_ISO2_DirectoryUnicodeProcess | This function processes single UNICODE ISO9660 directory.
StarBurn_ISO2_FileCreate | This function creates ISO9660 file.
StarBurn_ISO2_FileDestroy | This function destroys created ISO9660 file object.
StarBurn_ISO2_FileDirectoryDateTimeGet | This function gets date and time from created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryDateTimeSet | This function sets date and time on created ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryNameSet | This function set new name for ISO9660 file or directory object.
StarBurn_ISO2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for ISO9660 file or directory object.
StarBurn_ISO2_FileMemoryCreate | This function creates ISO9660 memory file.
StarBurn_ISO2_FileMemoryUnicodeCreate | This function creates Unicode ISO9660 memory file.
StarBurn_ISO2_FileQuery | This function do query for ISO9660 file properties.
StarBurn_ISO2_FileSetAttributes | This function sets attributes for ISO9660 file.
StarBurn_ISO2_FileUnicodeCreate | This function creates UNICODE ISO9660 file.
StarBurn_ISO2_ImpVolumeCreate | This function processes contents of single UNICODE ISO9660 directory. __stdcall StarBurn_ISO2_DirectoryContentsUnicodeProcess( const unsigned short *UnicodePathName, unsigned long *GUID, void *Root, PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Callback, const void *Context, STARBURN_ISO2_FILE_DATE_TIME *DateTime ); This function creates ISO9660 import volume.
StarBurn_ISO2_ImpVolumeDestroy | This function destroys created ISO9660 import volume object.
StarBurn_ISO2_ImpVolumeImport | This function imports ISO9660 import volume content.
StarBurn_ISO2_ISO9660FileTreeCreate | This function create ISO image from already created ISO9660 volume.
StarBurn_ISO2_VolumeCreate | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateBoot | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateBootElTorito | This function creates ISO9660 bootable volume (ANSI names).
StarBurn_ISO2_VolumeCreateEx | This function creates ISO9660 volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateExBoot | This function creates ISO9660 bootable volume (with both Unicode and ANSI names).
StarBurn_ISO2_VolumeCreateUnicode | This function creates ISO9660 volume.
StarBurn_ISO2_VolumeCreateUnicodeBoot | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito | This function creates ISO9660 bootable volume (Unicode names).
StarBurn_ISO2_VolumeDescriptorsBufferGet | This function get ISO9660 volume descriptors buffer.
StarBurn_ISO2_VolumeDestroy | This function destroys created ISO9660 volume object.
StarBurn_ISO2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_ISO2_VolumeSizeInUCHARsGet | This function get ISO9660 volume size in unsigned chars.
StarBurn_ISO9660JolietFileTree_Add | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddEx | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddMemory | This function adds the node created from the memory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_AddW | This function adds the tree created from the directory to already created ISO9660 or Joliet file tree from passed directory. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations. Unlike other tree management calls this one deals with Unicode names (wide char variant of basic call).
StarBurn_ISO9660JolietFileTree_AddZeroFile | This function adds the new "filled with zeros" file to already created ISO9660 or Joliet file tree. Later this tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be burn directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate operations.
StarBurn_ISO9660JolietFileTree_BuildImage | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_BuildImageEx | This function builds ISO9660 or Joliet file system image from ISO9660 or Joliet file tree (assign all the logical block offsets and allocates and initializes all file system internal structures). Later this tree can be used to store the "virtual" ISO9660 or Joliet image to the file on the disk or to burn this ISO9660 or Joliet image directly to the CD/DVD/Blu-Ray/HD-DVD media. It's identical to StarBurn_ISO9660JolietFileTree_BuildImage except has some extra parameter to put into file system descriptor.
StarBurn_ISO9660JolietFileTree_Cancel | This function cancel ISO9660 or Joliet file tree creation process.
StarBurn_ISO9660JolietFileTree_Create | This function allocates in the memory and initializes ISO9660 or Joliet file tree. Later this file tree can be used to build "virtual" ISO96600 or Joliet file system image. Resulting "virtual" image can be either stored in the file on the disk or be recorder directly to the CD/DVD/Blu-Ray/HD-DVD media w/o any other intermediate buffering operations on the hard disk.
StarBurn_ISO9660JolietFileTree_GetAttributes | This function returns ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_GetAutoSorting | This function returns ISO9660 or Joliet file tree node sorting mode.
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs | This function returns ISO9660 or Joliet file tree file size in UCHARs.
StarBurn_ISO9660JolietFileTree_GetFirstKid | This function returns ISO9660 or Joliet file tree node first kid pointer.
StarBurn_ISO9660JolietFileTree_GetFullPath | This function returns full path to ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetKidType | This function returns type of ISO9660 or Joliet file tree node.
StarBurn_ISO9660JolietFileTree_GetLevel | This function returns ISO9660 or Joliet file tree level. The number of levels in the created tree.
StarBurn_ISO9660JolietFileTree_GetNames | This function returns ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_ISO9660JolietFileTree_GetNamesEx | This function returns ISO9660 or Joliet file tree node names (long, short and absolute). Also it returns file system dependent names in ANSI and Unicode.
StarBurn_ISO9660JolietFileTree_GetNamesW | StarBurn_ISO9660JolietFileTree_GetNamesW function is not documented
StarBurn_ISO9660JolietFileTree_GetNextKid | This function returns ISO9660 or Joliet file tree root node next kid pointer.
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime | This function returns ISO9660 or Joliet file tree node ISO9660 time stamp (date and time).
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs | This function returns ISO9660 or Joliet file tree node power (file size) in UCHARs.
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA | This function returns ISO9660 or Joliet file tree node starting LBA after the image was built.
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime | This function returns ISO9660 or Joliet file tree node SYSTEMTIME.
StarBurn_ISO9660JolietFileTree_GetParent | This function returns ISO9660 or Joliet file tree node parent pointer.
StarBurn_ISO9660JolietFileTree_GetRoot | This function returns ISO9660 or Joliet file tree root node pointer.
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs | This function returns ISO9660 or Joliet built file system image size in UCHARs.
StarBurn_ISO9660JolietFileTree_ImportFile | This function imports file for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_ImportTrack | This function imports track for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_Read | This function reads ISO9660 or Joliet file system image from current offset into the user's data buffer. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized. The data that is read can be either stored in the file on the hard disk or directly written to CD/DVD/Blu-Ray/HD-DVD media.
StarBurn_ISO9660JolietFileTree_Remove | This function deletes ISO9660 or Joliet file tree node and all it's kids.
StarBurn_ISO9660JolietFileTree_SeekToBegin | This function seeks the ISO9660 or Joliet file system image from current offset to the very beginning so read operation will start from the 0 offset of the file system image. ISO9660 or Joliet file tree must have assigned all the logical block offsets and all file system internal structures allocated and initialized.
StarBurn_ISO9660JolietFileTree_SetAttributes | This function sets ISO9660 or Joliet file tree node attributes.
StarBurn_ISO9660JolietFileTree_SetAutoSorting | This function sets ISO9660 or Joliet file tree node auto sorting mode.
StarBurn_ISO9660JolietFileTree_SetBootImage | This function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetBootImageEx | This extended function sets boot image for created ISO9660 or Joliet file tree.
StarBurn_ISO9660JolietFileTree_SetNames | This function sets ISO9660 or Joliet file tree node names (long, short and absolute).
StarBurn_SetBufferUnderrunTimeOutInMs | This function sets buffer underrun timeout in milliseconds. It's amount of time StarBurn core would wait before resubmitting each command to the drive if burning was faster then reading and StarBurn had exhausted software cache it uses for buffering. Modern hardware has BUP (Buffer Underrun Protection) and would perfectly survive in such a condition and keep burning disc still usable.
StarBurn_SetDeviceTimeOutByDeviceAddress | This function sets device timeout in seconds by device SCSI address.
StarBurn_SetDVDPadding | This function sets DVD padding mode (when at least 1GB of the data would be recorded to DVD media - required for DVD-Video compilations to work properly on standalone DVD players) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetDVDPLUSRDLCompatibleMode | This function sets DVD+R DL (Dual Layer) so-called "compatible mode" (when layer would be switched exactly at 1/2 of the data payload recorded on the disc - required for DVD-Video compilations to work properly) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetEjectAfterFail | This function sets so-called "eject after fail" (if during burning process error would happen - should StarBurn eject disc or not) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetFastReadTOC | This function sets so-called "fast read TOC" (TOC information is not 100% accurate - to get EXACT track length StarBurn try to read beginning and end of the track to find sub-channel index switch indicating EXACT track beginning or EXACT track end) mode to enabled (TRUE) or disabled (FALSE).
StarBurn_SetIs64KBIO | This function sets current so-called "64KB I/O" (when StarBurn issues 64KB I/O packets instead of the 32KB ones) to enabled (TRUE) or disabled (FALSE) state.
StarBurn_SetIsCollisionDetectionDisabled | This function sets collision detection to disabled (TRUE) or enabled (FALSE). If collision detection is enabled - every new file added to ISO9660 or Joliet file tree would be checked to have unique name. If such a file already exist - special callback (collision detection one) would be called so user would be able to either replace or rename new or old file. However if collision detection is disabled - no comparison and no actions would be performed. File would be just added to the destination file system image AS IS, having it's original name.
StarBurn_SetIsSafeGrabbingEnabled | This function sets so-called "safe grabbing" (when StarBurn would mix read commands with checking for device to become ready - required to workaround broken ATAPI-to-USB bridges) to enabled (TRUE) or disabled (FALSE).
StarBurn_SetUsingLocalDateTime | This is function StarBurn_SetUsingLocalDateTime.
StarBurn_SetUsingUTCDateTime | This is function StarBurn_SetUsingUTCDateTime.
StarBurn_sprintf_s | This function wrap runtime sprintf_s function. In Visual Studio 2003 function sprintf_s not present.
StarBurn_SPTD_GetVersion | This function checks if the SPTD (SCSI Pass Through Direct) driver is present and gets SPTD driver version.
StarBurn_StarPort_DeviceAddLocal | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceAddLocalEx | This function adds local device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be added persistent.
StarBurn_StarPort_DeviceAddRemote | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Device can be mount persistent.
StarBurn_StarPort_DeviceAddRemoteEx | This function adds remote device (RAM disk, hard disk or DVD-ROM emulation) to StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceListQueryLocal | This function gets device list from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver. Unlike StarBurn_StarPort_DeviceListQueryRemote API call which retrieves information about REMOTE device list this call gets information about LOCAL device list.
StarBurn_StarPort_DeviceListQueryRemote | This function gets device list from remote StarWind iSCSI target. StarWind exports RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) targets. Unlike StarBurn_StarPort_DeviceListQueryLocal API call which retreives information about LOCAL device list this call gets information about REMOTE device list.
StarBurn_StarPort_DeviceRemove | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_DeviceRemoveEx | This function removes device from StarPort virtual storage controller. StarPort acts like RAM disk, hard disk and DVD-ROM emulator, AoE (ATA-over-Ethernet) and iSCSI (SCSI-over-IP) initiator driver.
StarBurn_StarPort_GetDeviceInformation | This function retrieves device type, vendor ID, product ID and revision for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceLetter | This function retrieves device letter (symbolic link) for StarPort device by its target ID.
StarBurn_StarPort_GetDeviceSCSIAddress | This function retrieves device SCSI address for StarPort device by its target ID.
StarBurn_StarPort_GetVersion | This function checks if the StarPortLite driver is installed and that its API version is equal to the one StarBurn was built with.
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek | This function seeks all of the internal object pointers to the very beginning of it so following read operations would start from the very beginning instead of the currently set position.
StarBurn_StarWave_CompressedFileReaderObjectCreate | This function creates compressed file reader object from passed compressed audio file name.
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode.
StarBurn_StarWave_CompressedFileReaderObjectDestroy | This function destroys compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectRead | This function reads uncompressed payload data chunk from underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast | This function returns uncompressed payload size in UCHARs for underlying compressed file reader object.
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate | This is function StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate.
StarBurn_StarWave_CompressedFileRecompress | This function recompresse already compressed file to new one with another compression.
StarBurn_StarWave_CompressedFileRecompressUnicode | This is function StarBurn_StarWave_CompressedFileRecompressUnicode.
StarBurn_StarWave_CompressedFileSupportedIs | This function checks is file name actually points to supported compressed audio file.
StarBurn_StarWave_CompressedFileUncompress | This function uncompresses compressed file to either WAV or RAW PCM.
StarBurn_StarWave_CompressedFileUncompressUnicode | This is function StarBurn_StarWave_CompressedFileUncompressUnicode.
StarBurn_StarWave_CompressedFileWriterObjectCreate | This function creates compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode | This is function StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode.
StarBurn_StarWave_CompressedFileWriterObjectDestroy | This function destroys compressed file writer object.
StarBurn_StarWave_CompressedFileWriterObjectWrite | This function writes uncompressed data chunk to compressed file writer object.
StarBurn_StarWave_UncompressedFileCompress | This function compresses uncompressed file to new one with asked compression.
StarBurn_StarWave_UncompressedFileCompressUnicode | This is function StarBurn_StarWave_UncompressedFileCompressUnicode.
StarBurn_StarWave_UncompressedFileSupportedIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx | This function checks is file name actually points to supported uncompressed audio file.
StarBurn_StarWave_VersionGet | This function returns StarWave library version.
StarBurn_StarWave2_Convert | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertEx | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertExUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_ConvertUnicode | This function convert audio files from any supported format to any other. Supported formats are: WAV (44100Hz, 16, stereo), MP3, WMA, OGG, FLAC, Windows Media formats (ASF, WMV etc.) (for reading)
StarBurn_StarWave2_EncodeMP3OGGFromWAV | This function compress audio file from WAV (44100Hz, 16, stereo) format to MP3 and OGG format.
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode | This is function StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode.
StarBurn_StarWave2_IsFileSupported | This function determines audio file by StarWave2 library supported is.
StarBurn_StarWave2_IsFileSupportedUnicode | This function determines audio file by StarWave2 library supported is.
StarBurn_strcpy_s | This function wrap runtime strcpy_s function. In Visual Studio 2003 function strcpy_s not present.
StarBurn_swprintf_s | This function wrap runtime swprintf_s function. In Visual Studio 2003 oriinal swprintf_s not present.
StarBurn_UDF_Add | Creates the UDF Tree Node
StarBurn_UDF_AddUnicode | This is function StarBurn_UDF_AddUnicode.
StarBurn_UDF_CleanUp | This function removes created UDF tree from the pointed UDF tree node sequentially. Processes file formatted UDF nodes and either closes file handles or frees memory (non-cached vs. cached content).
StarBurn_UDF_Create | StarBurn_UDF_Create() function is obsolete. Use StarBurn_UDF_CreatEx() instead of it
StarBurn_UDF_CreateEx | This function creates UDF tree from the allocated data buffers.
StarBurn_UDF_CreateExUnicode | This is function StarBurn_UDF_CreateExUnicode.
StarBurn_UDF_CreateUnicode | This is function StarBurn_UDF_CreateUnicode.
StarBurn_UDF_Destroy | This function devastates created UDF tree from the pointed root recursively.
StarBurn_UDF_DestroyNodeAndKids | Destroys UDF Tree Node and all its kids
StarBurn_UDF_FormatTreeItemAsDirectory | This function formats UDF tree item as directory.
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode | This is function StarBurn_UDF_FormatTreeItemAsDirectoryUnicode.
StarBurn_UDF_FormatTreeItemAsFile | This function formats UDF tree item as file.
StarBurn_UDF_FormatTreeItemAsFileUnicode | This is function StarBurn_UDF_FormatTreeItemAsFileUnicode.
StarBurn_UDF_GetFirstChild | This function returns the pointer to first child node
StarBurn_UDF_GetNextSibling | This function returns the pointer to next sibling node
StarBurn_UDF_GetNodeObject | Returns the object to current Tree Node
StarBurn_UDF_GetParent | This function returns the pointer to next parent node
StarBurn_UDF_GetPreviousSibling | This function returns the pointer to previous sibling node
StarBurn_UDF2_DirectoryBrowse | This function browses UDF directory content.
StarBurn_UDF2_DirectoryContentsProcess | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsProcessEx | This function processes contents of single UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcess | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx | This function processes contents of single UNICODE UDF directory.
StarBurn_UDF2_DirectoryCreate | This function creates UDF directory.
StarBurn_UDF2_DirectoryDestroy | This function destroys created UDF directory object.
StarBurn_UDF2_DirectoryProcess | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryProcessExEx | This function processes single UDF directory.
StarBurn_UDF2_DirectoryQuery | This function does query for UDF directory properties.
StarBurn_UDF2_DirectoryRootCreate | This function creates root UDF directory.
StarBurn_UDF2_DirectoryUnicodeCreate | This function creates UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcess | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_DirectoryUnicodeProcessExEx | This function processes single UNICODE UDF directory.
StarBurn_UDF2_FileBootCreate | This function creates UDF boot file.
StarBurn_UDF2_FileBootUnicodeCreate | This function creates UNICODE UDF boot file.
StarBurn_UDF2_FileCreate | This function creates UDF file.
StarBurn_UDF2_FileDestroy | This function destroys created UDF file object.
StarBurn_UDF2_FileDirectoryDateTimeGet | This function gets date and time from created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeGetEx | This function gets date and time from created UDF file or directory object. It may get creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryDateTimeSet | This function sets date and time on created UDF file or directory object.
StarBurn_UDF2_FileDirectoryDateTimeSetEx | This function sets date and time on created UDF file or directory object. It may set creation, last access, or last write date and time.
StarBurn_UDF2_FileDirectoryNameSet | This function set new name for UDF file or directory object.
StarBurn_UDF2_FileDirectoryUnicodeNameSet | This function set new UNICODE name for UDF file or directory object.
StarBurn_UDF2_FileMemoryCreate | This function creates UDF memory file.
StarBurn_UDF2_FileMemoryUnicodeCreate | This function creates UNICODE UDF memory file.
StarBurn_UDF2_FileQuery | This function do query for UDF file properties.
StarBurn_UDF2_FileSetAttributes | This function sets attributes for UDF file.
StarBurn_UDF2_FileSystemGetSizes | This function calculates UDF file system sizes in Bytes and LBS on the fly ( without build volume ).
StarBurn_UDF2_FileUnicodeCreate | This function creates UNICODE UDF file.
StarBurn_UDF2_ImpVolumeCreate | This function creates UDF import volume.
StarBurn_UDF2_ImpVolumeDestroy | This function destroys created UDF import volume object.
StarBurn_UDF2_ImpVolumeImport | This function imports UDF import volume content.
StarBurn_UDF2_ISO9660FileTreeCreate | This function create ISO image from already created UDF volume.
StarBurn_UDF2_ISO9660FileTreeCreateEx | This function create ISO image from already created UDF volume.
StarBurn_UDF2_VolumeAnchorGet | This function gets first anchor volume descriptor pointer we'll have to replace on rewritable media.
StarBurn_UDF2_VolumeCreate | This function creates UDF 1.02 volume.
StarBurn_UDF2_VolumeCreateBoot | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeCreateEx | This function creates UDF volume.
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito | This function creates UDF Bootable volume.
StarBurn_UDF2_VolumeDestroy | This function destroys created UDF volume object.
StarBurn_UDF2_VolumeInitialSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSeekRead | This function seeks to passed offset and reads requested amount of data.
StarBurn_UDF2_VolumeSizeInLBsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeSizeInUCHARsGet | This function get UDF volume size in unsigned chars.
StarBurn_UDF2_VolumeStore | This function stores UDF volume to file.
StarBurn_UDF2_VolumeUnicodeCreate | This function creates UDF 1.02 UNICODE volume.
StarBurn_UDF2_VolumeUnicodeCreateBoot | This function creates UDF Unicode Bootable volume.
StarBurn_UDF2_VolumeUnicodeCreateEx | This function creates UDF UNICODE volume.
StarBurn_UDFBridge_CreateEx | This is function StarBurn_UDFBridge_CreateEx.
StarBurn_UDFBridge_CreateExUnicode | This is function StarBurn_UDFBridge_CreateExUnicode.
StarBurn_UpStart | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. License file StarBurn.key is assumed to be located near main application executable. Since StarBurn SDK V12 it's possible to use this call again. It will just enable using embedded evaluational StarBurn SDK key (file shipped with StarBurn SDK... more
StarBurn_UpStartEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Starting from build 4.2.6 it's *REQUIRED* to call this function, it does not matter what build (static Vs. dynamic) of StarBurn is used. The difference between this call and call to StarBurn_UpStart(...) is that this particular call assumes StarBurn key is being embedded to the application binary and StarBurn_UpStart(...) always looks for StarBurn.key near application executable. Use this API... more
StarBurn_UpStartExEx | This function initializes burning toolkit. It's expected to be called as the very first function call before calling any other StarBurn exported code. Some of StarBurn functions would work with not initialized core, some would fail with EN_REGISTRATION_FAILED error. Unlike StarBurn_UpStartEx(...) API call this one allows to use custom debug output control. See StarBurn_UpStartEx(...) API call for more information about this topic.


Legend

Legend
StarBurn.h
Legend
Enumeration
Structure
Method


StarBurn.h Macros

StarBurn.h Macros
StarBurn.h
Macros
Name | Description
__STARBURN_H__ | Define StarBurn.h to avoid including it more then once
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS | ASPI safe buffer size in UCHARs. ASPI is assumed to support at least 64KB large transfer per time. 64KB - PAGE_SIZE_IN_UCHARS was old default value. Now we'll use DVD_ECC_BLOCK_SIZE_IN_UCHARS as it's smaller and produce better results when dealing with DVD media
AUDIO_LB_SIZE_IN_UCHARS | Audio LB (logical block) size in UCHARs
BLURAY_SPEED_IN_KBPS_1X | Actually 4495.5
BLURAY_SPEED_IN_KBPS_2X | 2X Blu-Ray speed constant (BD-R and BD-RE)
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS | Default buffer status report delay in seconds
CACHE_SIZE_IN_MBS | 64
CD_SPEED_IN_KBPS_10X | 10X CD speed constant
CD_SPEED_IN_KBPS_12X | 12X CD speed constant
CD_SPEED_IN_KBPS_16X | 16X CD speed constant
CD_SPEED_IN_KBPS_1X | 1X CD speed constant
CD_SPEED_IN_KBPS_20X | 20X CD speed constant
CD_SPEED_IN_KBPS_24X | 24X CD speed constant
CD_SPEED_IN_KBPS_2P2X | 2.2X CD speed constant
CD_SPEED_IN_KBPS_2X | 2X CD speed constant
CD_SPEED_IN_KBPS_32X | 32X CD speed constant
CD_SPEED_IN_KBPS_36X | 36X CD speed constant
CD_SPEED_IN_KBPS_3X | 3X CD speed constant
CD_SPEED_IN_KBPS_40X | 40X CD speed constant
CD_SPEED_IN_KBPS_44X | 44X CD speed constant
CD_SPEED_IN_KBPS_48X | 48X CD speed constant
CD_SPEED_IN_KBPS_4X | 4X CD speed constant
CD_SPEED_IN_KBPS_52X | 52X CD speed constant
CD_SPEED_IN_KBPS_56X | 56X CD speed
CD_SPEED_IN_KBPS_6X | 6X CD speed constant
CD_SPEED_IN_KBPS_72X | 72X CD speed
CD_SPEED_IN_KBPS_8X | 8X CD speed constant
CDVD_SPEED_IS_KBPS_MAXIMUM | Top supported CD/DVD/Blu-Ray/HD-DVD speed constant (wildcard)
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES | Default number of read retries during verification process
DEVICES_PER_BUS | Top number of SCSI devices per logical SCSI bus (was 15 originally)
DISC_STATUS_COMPLETE | Disc is complete
DISC_STATUS_EMPTY | Disc is empty
DISC_STATUS_INCOMPLETE | Disc is incomplete
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Doubled...
DVD_ECC_BLOCK_SIZE_IN_LBS | DVD ECC block size in logical blocks (2048 UCHARs each)
DVD_ECC_BLOCK_SIZE_IN_UCHARS | DVD ECC block size in UCHARs. This is true "hardware" logical block size on DVD. It's recommended to have transfers of this size and this size aligned
DVD_PROTECTION_CPRM | DVD with CPRM (Copy-Protected Removable Media) protection
DVD_PROTECTION_CSS | DVD with CSS (Content Scrambling System) protection
DVD_PROTECTION_NONE | DVD w/o any protection system
DVD_SPEED_IN_KBPS_10X | 10X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_12X | 12X DVD speed constant (DVD-R, DVD+R)
DVD_SPEED_IN_KBPS_16X | 16X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_18X | 18X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_1X | 1X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_20X | 20X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_22X | 22X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_24X | 24X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_2DOT4X | 2.4X DVD speed constant (DVD+R, DVD+R DL and DVD+RW)
DVD_SPEED_IN_KBPS_2X | 2X DVD speed constant (DVD-R, DVD-RW and DVD-RAM)
DVD_SPEED_IN_KBPS_32X | 32X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_3X | 3X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_40X | 40X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_48X | 48X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_4X | 4X DVD speed constant (DVD-R, DVD-R DL, DVD-RW, DVD+R, DVD+R DL, DVD+RW and DVD-RAM)
DVD_SPEED_IN_KBPS_50X | 50X DVD speed constant (DVD+R and DVD-R)
DVD_SPEED_IN_KBPS_5X | 5X DVD speed constant (DVD-RAM)
DVD_SPEED_IN_KBPS_6X | 6X DVD speed constant (DVD-RW)
DVD_SPEED_IN_KBPS_8X | 8X DVD speed constant (DVD-R, DVD-R DL, DVD+R, DVD+R DL and DVD+RW)
ELTORITO_BOOTABLE | Bootable disc ID
ELTORITO_BOOTSYSTEM_ID | Bootable specification signature
ELTORITO_DEF_LOAD_SEGMENT | Real mode code load segment
ELTORITO_NON_BOOTABLE | Non-bootable disc ID
ERROR_FIELD_C2_AND_BLOCK_ERROR | C2 and block error information
ERROR_FIELD_C2_ERROR | C2 error information
ERROR_FIELD_NO_ERROR | No error information
ERROR_FIELD_RESERVED | Reserved
EXPECTED_LB_TYPE_ANY | Accept all LBs
EXPECTED_LB_TYPE_CDDA | Accept only CDDA (CD digital audio) LBs
EXPECTED_LB_TYPE_MODE1 | Accept only MODE1 LBs
EXPECTED_LB_TYPE_MODE2 | Accept only MODE2 LBs (both Form1 and Form2)
EXPECTED_LB_TYPE_MODE2_FORM1 | Accept only MODE2 Form1 LBs
EXPECTED_LB_TYPE_MODE2_FORM2 | Accept only MODE2 Form2 LBs
HARD_DISK_LB_SIZE_IN_UCHARS | Hard disk LB (logical block) size in UCHARs
HEADER_CODE_ALL_HEADERS | Both header and subheader
HEADER_CODE_HEADER_ONLY | 4-byte header
HEADER_CODE_NONE | No header
HEADER_CODE_SUBHEADER_ONLY | MODE2 Form1 or Form2 subheader
ISO9660_DATE_SIZE_IN_UCHARS | ISO9660 date size in UCHARs
ISO9660_FILE_SIZE_IN_UCHARS | ISO9660 file size in UCHARs
ISO9660_NAME_SIZE_IN_UCHARS | ISO9660 name size in UCHARs
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS | ISO9660 volume descriptor system and volume ID size in UCHARs
ISO9660_TREE_LEVEL | ISO9660 top supported file tree level
LAST_SESSION_COMPLETE | Last session is complete
LAST_SESSION_EMPTY | Last session is empty
LAST_SESSION_INCOMPLETE | Last session is incomplete
MODE1_LB_SIZE_IN_UCHARS | MODE1 LB (logical block) size in UCHARs
MODE2_FORM1_LB_SIZE_IN_UCHARS | MODE2 Form1 LB (logical block) size in UCHARs
MODE2_FORM2_LB_SIZE_IN_UCHARS | MODE2 Form2 LB (logical block) size in UCHARs
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS | MODE2 Form2 + 8 UCHARs of subheader LB (logical block) size in UCHARs
MODE2_FORMLESS_LB_SIZE_IN_UCHARS | MODE2 Formless LB (logical block) size in UCHARS
NUMBER_OF_RAW_TRACKS | Top number of raw tracks (including maintenance tracks) on CD/DVD/Blu-Ray/HD-DVD disc. This is calculated based on the worst CD case when all tracks will be in a separate sessions. We need this approximate value to avoid allocating TOC_INFORMATION structure dynamically.
NUMBER_OF_READ_RETRIES | Default number of retries on read operations (if bad block was possibly hit, was 2 originally)
NUMBER_OF_SUBCHANNELS | sub-channels from P to W
NUMBER_OF_TRACKS | Top number of tracks (or border-in/border-out zones) on CD/DVD/Blu-Ray/HD-DVD disc
PAGE_SIZE_IN_UCHARS | Small page size in UCHARs on x86 machines (default allocatable storage)
RAW_LB_PQ_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with PQ sub-channel size in UCHARs
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS | RAW LB (logical block) with RAW P-W sub-channel size in UCHARs
RAW_LB_SIZE_IN_UCHARS | RAW LB (logical block) size in UCHARs
READ_REPORT_DELAY_IN_SECONDS | Default read report delay in seconds
SCSI_DEVICE_DIRECT_ACCESS | SCSI disk device
SCSI_DEVICE_MAGNETO_OPTICAL | SCSI MO (Magneto-Optical) disk device
SCSI_DEVICE_MEDIUM_CHANGER | SCSI jukebox (disc changer) device
SCSI_DEVICE_NETWORK | SCSI network device
SCSI_DEVICE_PRINTER | SCSI printer device
SCSI_DEVICE_PROCESSOR | SCSI processor device
SCSI_DEVICE_RO_DIRECT_ACCESS | SCSI CD/DVD/Blu-Ray/HD-DVD device
SCSI_DEVICE_SCANNER | SCSI scanner device
SCSI_DEVICE_SEQUENTIAL_ACCESS | SCSI tape device
SCSI_DEVICE_UNPRESENT | SCSI device... Is gone!
SCSI_DEVICE_WILDCARD | SCSI device any (wildcard for StarBurn_FindDevice() function)
SCSI_DEVICE_WORM | SCSI WORM (Write-Once-Read-Multiple) device
SHORT_RAW_LB_SIZE_IN_UCHARS | Short (w/o sync and header) RAW LB (logical block) size in UCHARs
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS | Number of logical blocks on single layer DVD
SMALLEST_CACHE_SIZE_IN_MBS | Smallest cache size in MBs that toolkit will allow to use to buffer "write" operations
SMALLEST_CACHE_SIZE_IN_UCHARS | Smallest cache size in UCHARs that toolkit will allow to use to buffer "write" operations
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_FULL.
STARBURN_BDRE_FORMAT_CERTIFICATION_NO | BD-RE format certification types
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK.
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED | This is macro STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED.
STARBURN_BDRE_FORMAT_DEFAULT | BD-RE format types
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION | This is macro STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION.
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITH_SPARE_AREA.
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA | This is macro STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA.
STARBURN_CACHE_SIZE_READ_ONLY | Default cache size for I/O operations
STARBURN_CACHE_SIZE_READ_WRITE | This is macro STARBURN_CACHE_SIZE_READ_WRITE.
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED.
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY | File attributes ( flags for Attributes member of STARBURN_UDF2_FILE_INFO & STARBURN_ISO2_FILE_INFO )
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN.
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED | This is macro STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED.
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT.
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT | This is macro StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT.
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT | This is macro StarBurn_CdvdBurnerGrabber_GetDeviceInformationT.
StarBurn_CdvdBurnerGrabber_GrabTrackT | This is macro StarBurn_CdvdBurnerGrabber_GrabTrackT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT.
StarBurn_CdvdBurnerGrabber_SessionAtOnceT | This is macro StarBurn_CdvdBurnerGrabber_SessionAtOnceT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDExT.
StarBurn_CdvdBurnerGrabber_SuperVideoCDT | This is macro StarBurn_CdvdBurnerGrabber_SuperVideoCDT.
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT | This is macro StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT.
StarBurn_CdvdBurnerGrabber_VerifyFileExT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileExT.
StarBurn_CdvdBurnerGrabber_VerifyFileT | This is macro StarBurn_CdvdBurnerGrabber_VerifyFileT.
StarBurn_CdvdBurnerGrabber_VideoCDExExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExExT.
StarBurn_CdvdBurnerGrabber_VideoCDExT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDExT.
StarBurn_CdvdBurnerGrabber_VideoCDT | This is macro StarBurn_CdvdBurnerGrabber_VideoCDT.
STARBURN_DEBUG_FACILITY_ALLMESSAGES | Debug facility: Permit All Messages
STARBURN_DEBUG_FACILITY_ALLTARGETS | Debug facility: All targets
STARBURN_DEBUG_FACILITY_CUSTOM | Debug facility: Custom
STARBURN_DEBUG_FACILITY_DEBUG | Debug facility: Permit Debug Messages
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT | Debug facility: Debug output
STARBURN_DEBUG_FACILITY_ERROR | Debug facility: Permit Error Messages
STARBURN_DEBUG_FACILITY_LOG_FILE | Debug facility: Log file
STARBURN_DEBUG_FACILITY_NONE | Debug facility: None
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE | Debug facility: System console
STARBURN_DEBUG_FACILITY_TRACE | Debug facility: Permit Trace Messages
STARBURN_DEBUG_FACILITY_WARNING | Debug facility: Permit Warning Messages
STARBURN_DISC_TYPE_CDDA | Disc type is CDDA (CD-ROM or Digital Audio)
STARBURN_DISC_TYPE_CDI | Disc type is CDI
STARBURN_DISC_TYPE_UNDEFINED | Disc type is undefined
STARBURN_DISC_TYPE_XA | Disc type is CD-ROM XA
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES | DVD-Video maximum number of titles
StarBurn_DVDVideo_CreateT | This is macro StarBurn_DVDVideo_CreateT.
StarBurn_ElTorito_BootCatalogAddSectionT | This is macro StarBurn_ElTorito_BootCatalogAddSectionT.
StarBurn_ElTorito_CreateBootCatalogT | This is macro StarBurn_ElTorito_CreateBootCatalogT.
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARs_FastT.
StarBurn_GetAudioFileStreamSizeInUCHARsT | This is macro StarBurn_GetAudioFileStreamSizeInUCHARsT.
StarBurn_GetDeviceLetterT | TCHAR functions
STARBURN_IMPEX_API | declspec( dllexport )
StarBurn_IsAudioFileSupportedT | This is macro StarBurn_IsAudioFileSupportedT.
StarBurn_ISO2_VolumeCreateBootElToritoT | This is macro StarBurn_ISO2_VolumeCreateBootElToritoT.
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE | This is macro STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE.
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY | This is macro STARBURN_ISO9660_FILE_FLAGS_DIRECTORY.
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE | This is macro STARBURN_ISO9660_FILE_FLAGS_EXISTENCE.
STARBURN_ISO9660_FILE_FLAGS_NONE | ISO9660 file attributes flags
STARBURN_ISO9660_FILE_FLAGS_RECORD | This is macro STARBURN_ISO9660_FILE_FLAGS_RECORD.
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS | ( 4GB - 1 )
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS | This is macro STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS.
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS |
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS | ISO9660 constants (begin)
STARBURN_ISO9660_TYPE_1999 | This is macro STARBURN_ISO9660_TYPE_1999.
STARBURN_ISO9660_TYPE_JOLIET | This is macro STARBURN_ISO9660_TYPE_JOLIET.
STARBURN_ISO9660_TYPE_JOLIET_RELAXED | This is macro STARBURN_ISO9660_TYPE_JOLIET_RELAXED.
STARBURN_ISO9660_TYPE_LEVEL1 | ISO9660 file system type
STARBURN_ISO9660_TYPE_LEVEL2 | This is macro STARBURN_ISO9660_TYPE_LEVEL2.
STARBURN_LOADING_MECHANISM_TYPE_CADDY | Loading mechanism type constants
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE | This is macro STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE.
STARBURN_LOADING_MECHANISM_TYPE_CHANGER | This is macro STARBURN_LOADING_MECHANISM_TYPE_CHANGER.
STARBURN_LOADING_MECHANISM_TYPE_POP_UP | This is macro STARBURN_LOADING_MECHANISM_TYPE_POP_UP.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED1.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED2.
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 | This is macro STARBURN_LOADING_MECHANISM_TYPE_RESERVED3.
STARBURN_LOADING_MECHANISM_TYPE_TRAY | This is macro STARBURN_LOADING_MECHANISM_TYPE_TRAY.
STARBURN_PIPE_SIZE_IN_UCHARS | 60, 64 or 32 KB I/O packets
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS | StarBurn smallest split file size in megabytes
StarBurn_StarWave_CompressedFileReaderObjectCreateT | This is macro StarBurn_StarWave_CompressedFileReaderObjectCreateT.
StarBurn_StarWave_CompressedFileRecompressT | This is macro StarBurn_StarWave_CompressedFileRecompressT.
StarBurn_StarWave_CompressedFileUncompressT | This is macro StarBurn_StarWave_CompressedFileUncompressT.
StarBurn_StarWave_CompressedFileWriterObjectCreateT | This is macro StarBurn_StarWave_CompressedFileWriterObjectCreateT.
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS | StarWave recommended I/O buffer size in UCHARs. It's *STRONGLY* recommended to use either it or multiplications of STARWAVE_IO_BUFFER_SIZE_IN_UCHARS as internal calculations and indexations are integer rather then float based
StarBurn_StarWave_UncompressedFileCompressT | This is macro StarBurn_StarWave_UncompressedFileCompressT.
StarBurn_StarWave_UncompressedFileSupportedIsT | This is macro StarBurn_StarWave_UncompressedFileSupportedIsT.
StarBurn_StarWave2_ConvertExT | This is macro StarBurn_StarWave2_ConvertExT.
StarBurn_StarWave2_EncodeMP3OGGFromWAVT | This is macro StarBurn_StarWave2_EncodeMP3OGGFromWAVT.
StarBurn_StarWave2_GetFileReaderAndFactoryT | This is macro StarBurn_StarWave2_GetFileReaderAndFactoryT.
StarBurn_UDF_AddT | This is macro StarBurn_UDF_AddT.
StarBurn_UDF_CreateExT | This is macro StarBurn_UDF_CreateExT.
StarBurn_UDF_CreateT | This is macro StarBurn_UDF_CreateT.
StarBurn_UDF_FormatTreeItemAsDirectoryT | This is macro StarBurn_UDF_FormatTreeItemAsDirectoryT.
StarBurn_UDF_FormatTreeItemAsFileT | This is macro StarBurn_UDF_FormatTreeItemAsFileT.
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS | Name constants
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS | This is macro STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS.
StarBurn_UDF2_VolumeCreateBootElToritoT | This is macro StarBurn_UDF2_VolumeCreateBootElToritoT.
StarBurn_UDFBridge_CreateExT | This is macro StarBurn_UDFBridge_CreateExT.
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS | StarPort device name size in UCHARs
STARWAVEFACTORY_ID_DSHOW | This is macro STARWAVEFACTORY_ID_DSHOW.
STARWAVEFACTORY_ID_MP3 | This is macro STARWAVEFACTORY_ID_MP3.
STARWAVEFACTORY_ID_OGG | This is macro STARWAVEFACTORY_ID_OGG.
STARWAVEFACTORY_ID_WAV | StarWave2 factory ids
STARWAVEFACTORY_ID_WMA | This is macro STARWAVEFACTORY_ID_WMA.
SUBCHANNEL_NO | No sub-channel
SUBCHANNEL_PQ | PQ sub-channel
SUBCHANNEL_PQ_SIZE_IN_UCHARS | PQ sub-channel size in UCHARs
SUBCHANNEL_RAW_PW | RAW P-W sub-channel
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS | Raw P-W sub-channel size in UCHARs
SUBCHANNEL_RESERVED | Reserved
SUBCHANNEL_RW | R-W sub-channel
SUBCHANNEL_SIZE_IN_UCHARS | Sub-channel size in UCHARs
TRACK_NUMBER_INVISIBLE | Special "invisible" track number
TYPE_CODE_LAST_CHANCE | Logical Unit region is set. Additional restrictions required to make a change
TYPE_CODE_NONE | No Logical Unit region setting
TYPE_CODE_PERM | Logical Unit region has been set permanently, but may be reset by vendor if necessery
TYPE_CODE_SET | Logical Unit region is set
UDF_FILE_SET_DESCRIPTOR_LBA | UDF file set descriptor logical block address
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA | UDF file set descriptor terminator logical block address
UDF_FIRST_ANCHOR_LBA | First anchor volume descriptor pointer LBA
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS | UDF head size in logical blocks
UDF_ISO9660_FILE_SYSTEM_LBA | UDF/ISO9660 bridge file system logical block address
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS | define UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS 6
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS | UDF logical block size in UCHARs
UDF_NAME_SIZE_IN_UCHARS | UDF longest name size in UCHARs
UDF_NAME_SIZE_IN_UCHARS_ACTUAL | This is macro UDF_NAME_SIZE_IN_UCHARS_ACTUAL.
UDF_NSR_DESCRIPTOR_LBA | UDF NSR descriptor pointer LBA
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS | UDF tail size in logical blocks
WAVE_FILE_ALIGNMENT | WAVE file data alignment (4 UCHARs, 1 ULONG)
WAVE_FILE_BITS_PER_SAMPLE | WAVE file bits per sample
WAVE_FILE_CHANNELS | WAVE file number of channels
WAVE_FILE_DATA_SIGNATURE | WAVE file DATA signature
WAVE_FILE_RIFF_SIGNATURE | WAVE file RIFF signature
WAVE_FILE_SAMPLES_PER_SECOND | WAVE file samples per second
WAVE_FILE_TAG_SIGNATURE | WAVE file TAG signature
WAVE_FILE_WAVE_FORMAT | WAVE file WAVE format
WAVE_FILE_WAVE_SIGNATURE | WAVE file WAVE signature
WRITE_REPORT_DELAY_IN_SECONDS | Default write report delay in seconds


StarBurn.h Structures

StarBurn.h Structures
StarBurn.h | Legend
Structures
Name | Description
_CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
_DAO_DISC_LAYOUT | Structure that represents DAO disc layout
_DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
_DISC_FILESYSTEM | Structure with disc file system flags
_DISC_LAYOUT | Structure that represents disc layout
_DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
_DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
_FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
_ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
_NAME_COLLISION_INFO | Structure that represents information about name collision
_PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
_SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
_STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
_STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
_STARBURN_DISC_INFORMATION | Structure that represents Disc information
_STARBURN_ISO9660_DIRECTORY_INFO | This is record _STARBURN_ISO9660_DIRECTORY_INFO.
_STARBURN_ISO9660_FILE_INFO | ISO9660 file information
_STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
_STARBURN_TRACK_INFORMATION | Structure that represents Track information
_STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
_STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
_STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
_STARBURN_UDF2_FILE_INFO | UDF file information
_STARPORT_DEVICE_LIST | Structure that represents StarPort device list
_STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
_STARWAVE2_COMPRESSION_PROFILE |
_TOC_ENTRY | Structure that represents TOC entry
_TOC_INFORMATION | Structure that represents TOC information
_UDF_CONTROL_BLOCK | Structure that represents UDF control block
_UDF_FILE_EXTENT | Structure that describes a single file extent
_UDF_FILE_HANDLE | Structure that represents UDF file handle
_UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
_UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
_UDF_TREE_ITEM | Structure that represents UDF tree item
_WAVE_FILE_HEADER | Structure that represents WAVE file header
_WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
CDB_FAILURE_INFORMATION | Structure that represents CDB failure information
DAO_DISC_LAYOUT | Structure that represents DAO disc layout
DAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
DISC_FILESYSTEM | Structure with disc file system flags
DISC_LAYOUT | Structure that represents disc layout
DISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
DVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
FULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
ISO9660_DATE_TIME | Structure that represents ISO9660 date and time
NAME_COLLISION_INFO | Structure that represents information about name collision
PCDB_FAILURE_INFORMATION | Structure that represents CDB failure information
PDAO_DISC_LAYOUT | Structure that represents DAO disc layout
PDAO_DISC_LAYOUT_ENTRY | Structure that represents DAO disc layout entry (track)
PDISC_FILESYSTEM | Structure with disc file system flags
PDISC_LAYOUT | Structure that represents disc layout
PDISC_LAYOUT_ENTRY | Structure that represents disc layout entry (track)
PDVD_VIDEO_CONTROL_BLOCK | Structure that represents DVD-Video control block and pointer to DVD-Video control block
PFULL_TOC_ENTRY_RAW | Structure that represents full TOC entry
PISO9660_DATE_TIME | Structure that represents ISO9660 date and time
PNAME_COLLISION_INFO | Structure that represents information about name collision
PPQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PPSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PPSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PPSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PPSTARWAVE2_COMPRESSION_PROFILE |
PQ_SUBCHANNEL | Structure that represents formatted PQ sub-channel
PSCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
PSTARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
PSTARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
PSTARBURN_DISC_INFORMATION | Structure that represents Disc information
PSTARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
PSTARBURN_TRACK_INFORMATION | Structure that represents Track information
PSTARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
PSTARPORT_DEVICE_LIST | Structure that represents StarPort device list
PSTARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
PSTARWAVE2_COMPRESSION_PROFILE |
PTOC_ENTRY | Structure that represents TOC entry
PTOC_INFORMATION | Structure that represents TOC information
PUDF_CONTROL_BLOCK | Structure that represents UDF control block
PUDF_FILE_EXTENT | Structure that describes a single file extent
PUDF_FILE_HANDLE | Structure that represents UDF file handle
PUDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
PUDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
PUDF_TREE_ITEM | Structure that represents UDF tree item
PWAVE_FILE_HEADER | Structure that represents WAVE file header
PWAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk
SCSI_DEVICE_ADDRESS | Structure that represents SCSI device address
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS | Structure that represents advanced supported media formats
STARBURN_BDRE_FORMAT_PROFILE | Structure that represents format profile for BD-RE media
STARBURN_DISC_ATIP_INFORMATION | Structure that represents Disc ATIP information
STARBURN_DISC_INFORMATION | Structure that represents Disc information
STARBURN_ISO9660_DIRECTORY_INFO | This is type STARBURN_ISO9660_DIRECTORY_INFO.
STARBURN_ISO9660_FILE_INFO | ISO9660 file information
STARBURN_STARWAVE2_INIT_PARAMS | Structure that represents initialization parameters for audio conversion
STARBURN_TRACK_INFORMATION | Structure that represents Track information
STARBURN_TRACK_INFORMATION_EX | Structure that represents Track information extended
STARBURN_UDF2_DIRECTORY_INFO | UDF directory information
STARBURN_UDF2_FILE_DATE_TIME | Structure that represents UDF2 file date and time
STARBURN_UDF2_FILE_INFO | UDF file information
STARPORT_DEVICE_LIST | Structure that represents StarPort device list
STARPORT_DEVICE_LIST_ENTRY | Structure that represents StarPort device list entry
STARWAVE2_COMPRESSION_PROFILE |
TOC_ENTRY | Structure that represents TOC entry
TOC_INFORMATION | Structure that represents TOC information
UDF_CONTROL_BLOCK | Structure that represents UDF control block
UDF_FILE_EXTENT | Structure that describes a single file extent
UDF_FILE_HANDLE | Structure that represents UDF file handle
UDF_FILE_LOOKUP_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
UDF_LOOKUP_DIR_ENTRY | Structure with directory entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_LOOKUP_FILE_ENTRY | Structure with file entry in callback from StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
UDF_TREE_ITEM | Structure that represents UDF tree item
WAVE_FILE_HEADER | Structure that represents WAVE file header
WAVE_FORMAT_CHUNK | Structure that represents WAVE format chunk


StarBurn.h Types

StarBurn.h Types
StarBurn.h
Types
Name | Description
CFuncStarWaveConversionCallback | type of callback function
PCALLBACK | Callback type (function of this type must be passed as callback)
PSTARBURN_CLOSEHANDLE_CALLBACK | This is type PSTARBURN_CLOSEHANDLE_CALLBACK.
PSTARBURN_CREATEFILE_CALLBACK | This is type PSTARBURN_CREATEFILE_CALLBACK.
PSTARBURN_DELETEFILE_CALLBACK | This is type PSTARBURN_DELETEFILE_CALLBACK.
PSTARBURN_FILE_OBJECT | Structure that represents StarBurn file object used internally with file I/O
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK | This is type PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK.
PSTARBURN_ISO2_COLLISION_CALLBACK | StarBurn ISO name collision handling callback
PSTARBURN_ISO2_PROGRESS_CALLBACK | StarBurn ISO progress callback
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK | StarBurn ISO Unicode name collision handling callback
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK | StarBurn ISO UNICODE progress callback
PSTARBURN_ISO9660_READ_CALLBACK | StarBurn ISO2 read callback (for import)
PSTARBURN_READFILE_CALLBACK | This is type PSTARBURN_READFILE_CALLBACK.
PSTARBURN_SET_FILE_POINTER_CALLBACK | This is type PSTARBURN_SET_FILE_POINTER_CALLBACK.
PSTARBURN_STARWAVE_CALLBACK | StarWave callback passed to I/O functions. Return anything except zero from it to cancel I/O operation
PSTARBURN_UDF2_COLLISION_CALLBACK_EX | StarBurn UDF ansi name collision handling callback
PSTARBURN_UDF2_IMPORT_CALLBACK | StarBurn UDF2 import callback
PSTARBURN_UDF2_PROGRESS_CALLBACK | StarBurn UDF2 progress callback
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX | StarBurn UDF Unicode name collision handling callback
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK | StarBurn UDF2 UNICODE progress callback
PSTARBURN_WRITEFILE_CALLBACK | This is type PSTARBURN_WRITEFILE_CALLBACK.


Example

Example
StarBurn_ImageFile_UDFFileSystemLookup Function

Please see UDFLookupISO sample as example how to use StarBurn_ImageFile_UDFFileSystemLookup API call.


Example

Example
StarBurn_ImageFile_UDFFileSystemLookupEx Function

Please see UDFLookupISO sample as example how to use StarBurn_ImageFile_UDFFileSystemLookup API call.


Example

Example
StarBurn_IsAudioFileSupported Function

Please see TrackAtOnceFromFile and SessionAtOnceFromFile samples to see how to use StarBurn_IsAudioFileSupported API call and AudioCompressor sample to see how to use StarWave API calls.


See Also

See Also
StarBurn_IsAudioFileSupported Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs


Example

Example
StarBurn_ISO9660JolietFileTree_Add Function

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Add(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_Add Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx


Example

Example
StarBurn_ISO9660JolietFileTree_AddEx Function

This example allocates Joliet file tree with required time for root node and destroys the tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;
SYSTEMTIME l__SYSTEMTIME;
FILETIME l__FILETIME;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Format system time here

ZeroMemory(
    &l__SYSTEMTIME,
    sizeof( l__SYSTEMTIME )
    );

l__SYSTEMTIME.wYear = 1991;

l__SYSTEMTIME.wMonth = 3;

l__SYSTEMTIME.wDayOfWeek = 1;

l__SYSTEMTIME.wDay = 1;

l__SYSTEMTIME.wHour = 2;

l__SYSTEMTIME.wMinute = 30;

l__SYSTEMTIME.wSecond = 40;

l__SYSTEMTIME.wMilliseconds = 10;

// Covert system time to file time
SystemTimeToFileTime(
    &l__SYSTEMTIME,
    &l__FILETIME
    );

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddEx(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__FILETIME,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_AddEx Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_Add


Example

Example
StarBurn_ISO9660JolietFileTree_AddMemory Function

This example allocates Joliet file tree, adds memory node to it and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;
UCHAR l__UCHAR__MemoryNode[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__MemoryNodeSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Add(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Prepare memory node memory
RtlZeroMemory(
    &l__UCHAR__MemoryNode,
    sizeof( l__UCHAR__MemoryNode )
    );

// Format memory node here and store all required data into l__UCHAR__MemoryNode buffer

// Set size of memory node
l__LARGE_INTEGER__MemoryNodeSizeInUCHARs.QuadPart = sizeof( l__UCHAR__MemoryNode );

// Try to add memory node as "MemoryNodeName" to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddMemory(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PUCHAR )( &l__UCHAR__MemoryNode ),
    l__LARGE_INTEGER__MemoryNodeSizeInUCHARs,
    "MemoryNodeName",
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_AddMemory Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid


Example

Example
StarBurn_ISO9660JolietFileTree_AddW Function

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__Root;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to get root here
l__PVOID__Root =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct reply
if ( l__PVOID__Root == NULL )
{
// Handle error here, keep in mind that root CAN be NULL if nothing was added to tree before...
}

// Try to add all from the root directory of the drive D: to already created Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_AddW(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    L"D:\",
    NULL,
    FILE_TIME_LAST_WRITE,
    &l__PVOID__Root,
    &l__PVOID__NewNode
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_AddW Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx


See Also

See Also
StarBurn_ISO9660JolietFileTree_AddZeroFile Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_AddEx, StarBurn_ISO9660JolietFileTree_Add


Example

Example
StarBurn_ISO9660JolietFileTree_BuildImage Function

This example allocates Joliet file tree from the directory, builds the image and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_BuildImage Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, StarBurn_ISO9660JolietFileTree_BuildImageEx


See Also

See Also
StarBurn_ISO9660JolietFileTree_BuildImageEx Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, StarBurn_ISO9660JolietFileTree_BuildImage


Example

Example
StarBurn_ISO9660JolietFileTree_BuildImageEx Function

This example allocates Joliet file tree from the directory, builds the image and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImageEx(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application",
    "SystemID",
    "CopyFile",
    "BiblioFile",
    "CreateDate",
    "ModifyDate",
    "ExpireDate",
    "EffectDate"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_ISO9660JolietFileTree_Cancel Function

This example allocates Joliet file tree, initiates tree creation, cancels it and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Cancel tree creation process. Keep in mind that this code must be called from the different thread
StarBurn_ISO9660JolietFileTree_Cancel( l__PVOID__FileTree );

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_Cancel Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_Read, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_SeekToBegin


Example

Example
StarBurn_ISO9660JolietFileTree_Create Function

This example allocates Joliet file tree and destroys it after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    TRUE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_Create Function
See Also

StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER, FILE_TREE, FILE_TIME, StarBurn_ISO9660JolietFileTree_Add


Example

Example
StarBurn_ISO9660JolietFileTree_GetAttributes Function

This example allocates Joliet file tree, get root node, gets attributes and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
ULONG l__ULONG__Attributes;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get attributes node here
l__ULONG__Attributes =
StarBurn_ISO9660JolietFileTree_GetAttributes(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetAttributes Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetAutoSorting Function
See Also

StarBurn_ISO9660JolietFileTree_SetSorting, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy


Example

Example
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs Function

This example allocates Joliet file tree, get root node, gets file size in UCHARs and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
LARGE_INTEGER l__LARGE_INTEGER__FileSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get file size in UCHARs here
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    &l__LARGE_INTEGER__FileSizeInUCHARs
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetFirstKid Function

This example allocates Joliet file tree, get root node, gets first kid and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetFirstKid Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid


Example

Example
StarBurn_ISO9660JolietFileTree_GetFullPath Function

There are no examples for StarBurn_ISO9660JolietFileTree_GetFullPath(...) API call.


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetFullPath Function
See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetKidType Function
See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetLevel Function

This example allocates Joliet file tree, checks tree level and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
LONG l__LONG__TreeLevel;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get tree level here
l__LONG__TreeLevel =
StarBurn_ISO9660JolietFileTree_GetLevel( l__PVOID__FileTree );

// Check for tree level here
if ( l__LONG__TreeLevel > 8 )
{
// Handle error here...
}

// Do something with Joliet file tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetLevel Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_Destroy


Example

Example
StarBurn_ISO9660JolietFileTree_GetNames Function

This example allocates Joliet file tree, get root node, gets names and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNames Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_SetNames


Example

Example
StarBurn_ISO9660JolietFileTree_GetNamesEx Function

This example allocates Joliet file tree, get root node, gets names and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];
CHAR l__CHAR__FileSystemName[ MAX_PATH ];
WCHAR l__WCHAR__FileSystemName[ MAX_PATH ];

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNamesEx(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName ),
    ( PCHAR )( &l__CHAR__FileSystemName ),
    ( PUSHORT )( &l__WCHAR__FileSystemName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNamesEx Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_SetNames


Example

Example
StarBurn_ISO9660JolietFileTree_GetNextKid Function

This example allocates Joliet file tree, get root node, gets first kid and next kid and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;
PVOID l__PVOID__NextKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Get next kid node node here
l__PVOID__NextKidNode =
StarBurn_ISO9660JolietFileTree_GetNextKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    l__PVOID__FirstKidNode
    );

// Check for correct response
if ( l__PVOID__NextKidNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNextKid Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetFirstKid


Example

Example
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime Function

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime(...) API call.


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime Function
See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs Function

This example allocates Joliet file tree, get root node, gets node power in UCHARs and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
LARGE_INTEGER l__LARGE_INTEGER__NodePowerInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get node power in UCHARs here
l__LARGE_INTEGER__NodePowerInUCHARs.LowPart =
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PLONG )( &l__LARGE_INTEGER__NodePowerInUCHARs.HighPart )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA Function

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime(...) API call.


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA Function
See Also

StarBurn_ISO9660JolietFileTree_GetNodeSystemTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime Function

There are no examples for StarBurn_ISO9660JolietFileTree_GetNodeSystemTime(...) API call.


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime Function
See Also

StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs


Example

Example
StarBurn_ISO9660JolietFileTree_GetParent Function

This example allocates Joliet file tree, get root node, gets parent and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__ParentNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get parent node here
l__PVOID__ParentNode =
StarBurn_ISO9660JolietFileTree_GetParent(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response (MUST be NULL)
if ( l__PVOID__ParentNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetParent Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid


Example

Example
StarBurn_ISO9660JolietFileTree_GetRoot Function

This example allocates Joliet file tree, get root node and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetRoot Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_Destroy


Example

Example
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs Function

This example allocates Joliet file tree from the directory, builds file system image, gets file system image size in UCHARs, checks for compatibility and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
LARGE_INTEGER l__LARGE_INTEGER__FileSystemImageSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8,
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Get file system image size in UCHARs
l__LARGE_INTEGER__FileSystemImageSizeInUCHARs.LowPart =
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs(
    l__PVOID__FileTree,
    &l__LARGE_INTEGER__FileSystemImageSizeInUCHARs.HighPart
    );

// Check for enough space on the media here (either hard disk or CD/DVD/Blu-Ray/HD-DVD)
if ( l__LARGE_INTEGER__FileSystemImageSizeInUCHAR.QuadPart < ... )
{
// Handle error here...
}

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_BuildImage, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER


Example

Example
StarBurn_ISO9660JolietFileTree_ImportFile Function
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to import file system structures from the file
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_ImportFile(
    l__PVOID__CdvdBurnerGrabber,
    l__PVOID__ISO9660JolietFileTree,
    "Image.ISO", // Import FS structures from file called "Image.ISO"
    TRUE, // Try to proceed as Joliet
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_ImportFile Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_ImportTrack


Example

Example
StarBurn_ISO9660JolietFileTree_ImportTrack Function
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to import file system structures from the track
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_ImportTrack(
    l__PVOID__CdvdBurnerGrabber,
    l__PVOID__ISO9660JolietFileTree,
    0x01, // First track,
    TRUE, // Try to proceed as Joliet
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_ImportTrack Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce, StarBurn_CdvdBurnerGrabber_ImportFile


Example

Example
StarBurn_ISO9660JolietFileTree_Read Function

This example allocates Joliet file tree from the directory, builds file system image, reads some data from it and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
UCHAR l__UCHAR__DataBuffer[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__NumberOfUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Prepare data buffer
RtlZeroMemory(
    &l__UCHAR__DataBuffer,
    sizeof( l__UCHAR__DataBuffer )
    );

// Set transfer size
l__LARGE_INTEGER__NumberOfUCHARs.QuadPart = sizeof( l__UCHAR__DataBuffer );

// Try to read
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Read(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    l__LARGE_INTEGER__NumberOfUCHARs.LowPart,
    ( PUCHAR )( &l__UCHAR__DataBuffer )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with data buffer here...

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_Read Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_BuildImage, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER


Example

Example
StarBurn_ISO9660JolietFileTree_Remove Function

This example allocates Joliet file tree, get root node, gets first kid, deletes first node and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
PVOID l__PVOID__FirstKidNode;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get first kid node here
l__PVOID__FirstKidNode =
StarBurn_ISO9660JolietFileTree_GetFirstKid(
    l__PVOID__FileTree,
    l__PVOID__RootNode
    );

// Check for correct response
if ( l__PVOID__FirstKidNode == NULL )
{
// Handle error here...
}

// Try to delete first kid
if (
StarBurn_ISO9660JolietFileTree_Remove(
    l__PVOID__ISO9660JolietFileTree,
    &l__PVOID__FirstKidNode
    ) == FALSE
)
{
// Handle error here...
}

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_Remove Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_Add


Example

Example
StarBurn_ISO9660JolietFileTree_SeekToBegin Function

This example allocates Joliet file tree from the directory, builds file system image, reads some stuff from it and destroys the file tree after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
UCHAR l__UCHAR__DataBuffer[ 4096 ];
LARGE_INTEGER l__LARGE_INTEGER__NumberOfUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Try to build the image, start with LBA 0 and include up to 8 levels into the image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_BuildImage(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    0,
    8
    FALSE,
    "Volume",
    "Publisher",
    "Application"
    );

// Prepare data buffer
RtlZeroMemory(
    &l__UCHAR__DataBuffer,
    sizeof( l__UCHAR__DataBuffer )
    );

// Set transfer size
l__LARGE_INTEGER__NumberOfUCHARs.QuadPart = sizeof( l__UCHAR__DataBuffer );

// Try to read
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Read(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    l__LARGE_INTEGER__NumberOfUCHARs.LowPart,
    ( PUCHAR )( &l__UCHAR__DataBuffer )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with data buffer here...

// Try to seek to the very beging of the "virtual" file system image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SeekToBegin(
    l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with image once again...

// Perform actions with Joliet tree here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_SeekToBegin Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Read, StarBurn_Destroy, PCALLBACK, EXCEPTION_NUMBER,


Example

Example
StarBurn_ISO9660JolietFileTree_SetAttributes Function

This example allocates Joliet file tree, get root node, gets attributes and destroys it (tree) after it's not needed any more.


See Also

See Also
StarBurn_ISO9660JolietFileTree_SetAttributes Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid


See Also

See Also
StarBurn_ISO9660JolietFileTree_SetAutoSorting Function
See Also

StarBurn_ISO9660JolietFileTree_GetSorting, StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy


Example

Example
StarBurn_ISO9660JolietFileTree_SetBootImage Function
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to set boot image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SetBootImage(
    l__PVOID__ISO9660JolietFileTree,
    "C:\bootimage.bin", // Here is our boot image we gonna use
    6, // Just stick with 6 here...
    ELTORITO_MEDIA_FLOPPY144,
    1,// set only one sector to load
    FALSE, // don't hide the file
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_SetBootImage Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce


Example

Example
StarBurn_ISO9660JolietFileTree_SetBootImageEx Function
// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
PVOID l__PVOID__ISO9660JolietFileTree;

// Prepare exception text buffer
RtlZeroMemory(
&l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText )
);

// Prepare CDB failure information
RtlZeroMemory(
&l__CDB_FAILURE_INFORMATION,
sizeof( l__CDB_FAILURE_INFORMATION )
);

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
&l__PVOID__CdvdBurnerGrabber,
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError,
&l__CDB_FAILURE_INFORMATION,
( PCALLBACK )( StarBurn_Callback ),
0,
0,
4,
0,
32
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Create and add something to ISO9660 file tree here

// Try to set boot image
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_SetBootImageEx(
l__PVOID__ISO9660JolietFileTree,
"C:\bootimage.bin", // Here is our boot image we gonna use
"boot.img",
0, //Attributes
6, // Just stick with 6 here...
ELTORITO_MEDIA_CUSTOM, //No emulation
4,// set four sector to load
ELTORITO_DEF_LOAD_SEGMENT,
TRUE, // hide the file
FALSE, //No recalculation CRC
l__CHAR__ExceptionText,
sizeof( l__CHAR__ExceptionText ),
&l__ULONG__SystemError
);

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_SetBootImageEx Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_Create, PCALLBACK, EXCEPTION_NUMBER, CDB_FAILURE_INFORMATION, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree, StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile, StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree, StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree, StarBurn_CdvdBurnerGrabber_SessionAtOnce


Example

Example
StarBurn_ISO9660JolietFileTree_SetNames Function

This example allocates Joliet file tree, get root node, gets names, sets new ones and destroys it (tree) after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__FileTree;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__TreeNodes;
ULONG l__ULONG__SystemError;
CHAR l__CHAR__ExceptionText[ 1024 ];
PVOID l__PVOID__RootNode;
CHAR l__CHAR__AbsoluteName[ MAX_PATH ];
CHAR l__CHAR__LongName[ MAX_PATH ];
CHAR l__CHAR__ShortName[ MAX_PATH ];
INT l__INT__NameSizeInUCHARs;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Try to create Joliet file tree
l__EXCEPTION_NUMBER =
StarBurn_ISO9660JolietFileTree_Create(
    &l__PVOID__FileTree,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    ( PCALLBACK )( StarBurn_Callback ),
    ( PVOID )( &l__LONG__TreeNodes ),
    TRUE,
    FALSE,
    FILE_TREE_JOLIET
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add directories or files with the help of the StarBurn_ISO9660JolietFileTree_Add here...

// Get root node here
l__PVOID__RootNode =
StarBurn_ISO9660JolietFileTree_GetRoot( l__PVOID__FileTree );

// Check for correct response
if ( l__PVOID__RootNode == NULL )
{
// Handle error here...
}

// Get names here
StarBurn_ISO9660JolietFileTree_GetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Change long name

l__INT__NameSizeInUCHARs = strlen( l__CHAR__LongName );

RtlZeroMemory(
&l__CHAR__LongName,
sizeof( l__CHAR__LongName )
);

strncpy(
l__CHAR__LongName,
"New name",
l__INT__NameSizeInUCHARs
);

// Set names here
StarBurn_ISO9660JolietFileTree_SetNames(
    l__PVOID__FileTree,
    l__PVOID__RootNode,
    ( PCHAR )( &l__CHAR__AbsoluteName ),
    ( PCHAR )( &l__CHAR__LongName ),
    ( PCHAR )( &l__CHAR__ShortName )
    );

// Do something with Joliet file tree root node here...

// Destroy the Joliet file tree
StarBurn_Destroy( &l__PVOID__FileTree );

// Just check for pointer (paranoid?)
if ( l__PVOID__FileTree != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_ISO9660JolietFileTree_SetNames Function
See Also

StarBurn_ISO9660JolietFileTree_Create, StarBurn_ISO9660JolietFileTree_Add, StarBurn_ISO9660JolietFileTree_GetRoot, StarBurn_Destroy, StarBurn_ISO9660JolietFileTree_GetNextKid, StarBurn_ISO9660JolietFileTree_GetFirstKid, StarBurn_ISO9660JolietFileTree_GetAttributes, StarBurn_ISO9660JolietFileTree_GetNames


Example

Example
StarBurn_SetBufferUnderrunTimeOutInMs Function

There are no samples for StarBurn_SetBufferUnderrunTimeOutInMs(...) API call.


See Also

See Also
StarBurn_SetBufferUnderrunTimeOutInMs Function
See Also

StarBurn_GetBufferUnderrunTimeOutInMs


Example

Example
StarBurn_SetDeviceTimeOutByDeviceAddress Function

Please see FindDevice sample as example how to use StarBurn_SetDeviceTimeOutByDeviceAddress API call.


See Also

See Also
StarBurn_SetDeviceTimeOutByDeviceAddress Function
See Also

StarBurn_GetDeviceTimeOutByDeviceAddress


Example

Example
StarBurn_SetDVDPadding Function

There are no examples for StarBurn_SetDVDPadding(...) API call.


See Also

See Also
StarBurn_SetDVDPadding Function
See Also

StarBurn_GetDVDPadding


Example

Example
StarBurn_SetDVDPLUSRDLCompatibleMode Function

There are no examples for StarBurn_SetDVDPLUSRDLCompatibleMode(...) API call.


See Also

See Also
StarBurn_SetDVDPLUSRDLCompatibleMode Function
See Also

StarBurn_GetDVDPLUSRDLCompatibleMode


Example

Example
StarBurn_SetEjectAfterFail Function

There are no examples for StarBurn_SetEjectAfterFail(...) API call.


See Also

See Also
StarBurn_SetEjectAfterFail Function
See Also

StarBurn_GetEjectAfterFail


Example

Example
StarBurn_SetFastReadTOC Function

Please see GrabTrack sample no how to use StarBurn_SetFastReadTOC(...) API call.


See Also

See Also
StarBurn_SetFastReadTOC Function
See Also

StarBurn_GetFastReadTOC


Example

Example
StarBurn_SetIs64KBIO Function

There are no examples for StarBurn_SetIs64KBIO(...) API call.


See Also

See Also
StarBurn_SetIs64KBIO Function
See Also

StarBurn_GetIs64KBIO


Example

Example
StarBurn_SetIsCollisionDetectionDisabled Function

Please see BuildImage sample to find out how collision detection could be disabled and enabled during file system image creation.


See Also

See Also
StarBurn_SetIsCollisionDetectionDisabled Function
See Also

StarBurn_GetIsCollisionDetectionDisabled


Example

Example
StarBurn_SetIsSafeGrabbingEnabled Function

There are no examples for StarBurn_SetIsSafeGrabbingEnabled(...) API call.


See Also

See Also
StarBurn_SetIsSafeGrabbingEnabled Function
See Also

StarBurn_GetIsSafeGrabbingEnabled


Example

Example
StarBurn_SPTD_GetVersion Function

This example just checks for the SPTD presence and queries SPTD driver version.

// Somewhere in the data region
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
ULONG l__ULONG__SystemError = ERROR_SUCCESS;
UCHAR l__UCHAR__Major = 0;
UCHAR l__UCHAR__Minor = 0;

// Try to get SPTD driver version
l__EXCEPTION_NUMBER =
StarBurn_SPTD_GetVersion(
&l__UCHAR__Major,
&l__UCHAR__Minor,
&l__ULONG__SystemError
);

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the SPTD here...


See Also

See Also
StarBurn_SPTD_GetVersion Function
See Also

StarBurn_Destroy, StarBurn_CdvdBurnerGrabber_CreateExEx, EXCEPTION_NUMBER


Example

Example
StarBurn_StarPort_DeviceAddLocal Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddLocal API call.


See Also

See Also
StarBurn_StarPort_DeviceAddLocal Function
See Also

StarBurn_StarPort_DeviceAddLocalEx, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceAddRemoteEx


Example

Example
StarBurn_StarPort_DeviceAddLocalEx Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddLocal API call.


See Also

See Also
StarBurn_StarPort_DeviceAddLocalEx Function
See Also

StarBurn_StarPort_DeviceAddLocal,StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceAddRemoteEx


Example

Example
StarBurn_StarPort_DeviceAddRemote Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddRemote API call.


See Also

See Also
StarBurn_StarPort_DeviceAddRemote Function
See Also

StarBurn_StarPort_DeviceAddRemoteEx, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceAddLocalEx


Example

Example
StarBurn_StarPort_DeviceAddRemoteEx Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceAddRemote API call.


See Also

See Also
StarBurn_StarPort_DeviceAddRemoteEx Function
See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceAddLocalEx


Example

Example
StarBurn_StarPort_DeviceListQueryLocal Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceListQueryLocal API call.


See Also

See Also
StarBurn_StarPort_DeviceListQueryLocal Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddRemote


Example

Example
StarBurn_StarPort_DeviceListQueryRemote Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceListQueryRemote API call.


See Also

See Also
StarBurn_StarPort_DeviceListQueryRemote Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote


Example

Example
StarBurn_StarPort_DeviceRemove Function

Please see StarPort sample as example how to use StarBurn_StarPort_DeviceRemove API call.


See Also

See Also
StarBurn_StarPort_DeviceRemove Function
See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemoveEx


See Also

See Also
StarBurn_StarPort_DeviceRemoveEx Function
See Also

StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove


Example

Example
StarBurn_StarPort_GetDeviceInformation Function

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceInformation API call.


See Also

See Also
StarBurn_StarPort_GetDeviceInformation Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter, StarBurn_StarPort_GetVersion.


Example

Example
StarBurn_StarPort_GetDeviceLetter Function

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceLetter API call.


See Also

See Also
StarBurn_StarPort_GetDeviceLetter Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote


Example

Example
StarBurn_StarPort_GetDeviceSCSIAddress Function

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetDeviceSCSIAddress API call.


See Also

See Also
StarBurn_StarPort_GetDeviceSCSIAddress Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter, StarBurn_StarPort_GetVersion, StarBurn_StarPort_GetDeviceLetter


Example

Example
StarBurn_StarPort_GetVersion Function

Please see StarPort GUI sample as example how to use StarBurn_StarPort_GetVersion API call.


See Also

See Also
StarBurn_StarPort_GetVersion Function
See Also

StarBurn_StarPort_DeviceAddLocal, StarBurn_StarPort_DeviceRemove, StarBurn_StarPort_DeviceListQueryLocal, StarBurn_StarPort_DeviceAddRemote, StarBurn_StarPort_DeviceListQueryRemote, StarBurn_StarPort_GetDeviceLetter


Example

Example
StarBurn_StarWave2_Convert Function

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_Convert is similar with obvious changes.


Example

Example
StarBurn_StarWave2_ConvertEx Function

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_ConvertEx is similar with obvious changes.


Example

Example
StarBurn_StarWave2_ConvertExUnicode Function

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertEx. Use of StarBurn_StarWave2_ConvertExUnicode is similar with obvious changes.


Example

Example
StarBurn_StarWave2_ConvertUnicode Function

See AudioConverter StarBurn sample application as an example how to use StarBurn_StarWave2_ConvertExEx. Use of StarBurn_StarWave2_ConvertUnicode is similar with obvious changes.


Example

Example
StarBurn_StarWave2_EncodeMP3OGGFromWAV Function

See AudioCompressor StarBurn sample applications as an example how to use


Example

Example
StarBurn_StarWave2_IsFileSupported Function
ULONG res = StarBurn_StarWave2_IsFileSupported("track1.wav");

if(res == ERROR_SUCCESS)
{
    ... //doing smth with file
}


Example

Example
StarBurn_StarWave2_IsFileSupportedUnicode Function
ULONG res = StarBurn_StarWave2_IsFileSupportedUnicode(CA2W("track1.wav"));

if(res == ERROR_SUCCESS)
{
    ... //doing smth with file
}


Example

Example
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectBeginSeek API call.


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_CompressedFileReaderObjectCreate Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectCreate API call.


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectCreate Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_CompressedFileReaderObjectDestroy Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectDestroy API call.


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectDestroy Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress


Example

Example
StarBurn_StarWave_CompressedFileReaderObjectRead Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectRead API call.


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectRead Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet API call.


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast


See Also

See Also
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_CompressedFileRecompress Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileRecompress API call.


See Also

See Also
StarBurn_StarWave_CompressedFileRecompress Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileSupportedIs


Example

Example
StarBurn_StarWave_CompressedFileSupportedIs Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileSupportedIs API call.


See Also

See Also
StarBurn_StarWave_CompressedFileSupportedIs Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_CompressedFileUncompress Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileUncompress API call.


See Also

See Also
StarBurn_StarWave_CompressedFileUncompress Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs


Example

Example
StarBurn_StarWave_CompressedFileWriterObjectCreate Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectCreate API call.


See Also

See Also
StarBurn_StarWave_CompressedFileWriterObjectCreate Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress,


Example

Example
StarBurn_StarWave_CompressedFileWriterObjectDestroy Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectDestroy API call.


See Also

See Also
StarBurn_StarWave_CompressedFileWriterObjectDestroy Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileSupportedIs


Example

Example
StarBurn_StarWave_CompressedFileWriterObjectWrite Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_CompressedFileWriterObjectWrite API call.


See Also

See Also
StarBurn_StarWave_CompressedFileWriterObjectWrite Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_UncompressedFileCompress Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_UncompressedFileCompress API call.


See Also

See Also
StarBurn_StarWave_UncompressedFileCompress Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress


Example

Example
StarBurn_StarWave_UncompressedFileSupportedIs Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_UncompressedFileSupportedIs API call.


See Also

See Also
StarBurn_StarWave_UncompressedFileSupportedIs Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs


See Also

See Also
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx


See Also

See Also
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_VersionGet, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs, StarBurn_StarWave_UncompressedFileSupportedUnicodeIs


Example

Example
StarBurn_StarWave_VersionGet Function

See AudioCompressor StarBurn sample application as an example how to use StarBurn_StarWave_VersionGet API call.


See Also

See Also
StarBurn_StarWave_VersionGet Function
See Also

StarBurn_StarWave_CompressedFileReaderObjectCreate, StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet, StarBurn_StarWave_CompressedFileReaderObjectBeginSeek, StarBurn_StarWave_CompressedFileReaderObjectRead, StarBurn_StarWave_CompressedFileReaderObjectDestroy, StarBurn_StarWave_UncompressedFileSupportedIs, StarBurn_StarWave_CompressedFileWriterObjectCreate, StarBurn_StarWave_CompressedFileWriterObjectWrite, StarBurn_StarWave_CompressedFileWriterObjectDestroy, StarBurn_StarWave_UncompressedFileCompress, StarBurn_StarWave_CompressedFileUncompress, StarBurn_StarWave_CompressedFileRecompress, StarBurn_StarWave_CompressedFileSupportedIs


Example

Example
StarBurn_UDF_CleanUp Function

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_TREE_ITEM l__UDF_TREE_ITEM__File[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff
StarBurn_UDF_CleanUp(
    &l__UDF_TREE_ITEN__File[ 0 ],
    10
    );

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_UDF_CleanUp Function
See Also

StarBurn_UDF_CreateEx, StarBurn_UDF_Destroy, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile


See Also

See Also
StarBurn_UDF_CreateEx Function
See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile


Example

Example
StarBurn_UDF_CreateEx Function

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

unsigned char g__UCHAR__FileSystemHead[ ( UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemTail[ ( UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemStructures[ ( 1024 * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];

UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


Example

Example
StarBurn_UDF_Destroy Function

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Director[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Add nodes with StarBurn_UDF_FormatTreeItemAsXxx here

// Create UDF tree with StarBurn_UDF_CreateEx() here

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_UDF_Destroy Function
See Also

StarBurn_UDF_CreateEx, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory, StarBurn_UDF_FormatTreeItemAsFile


Example

Example
StarBurn_UDF_FormatTreeItemAsDirectory Function

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;

unsigned char g__UCHAR__FileSystemHead[ ( UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemTail[ ( UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];
unsigned char g__UCHAR__FileSystemStructures[ ( 1024 * UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS ) ];

UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format VIDEO_TS directory
StarBurn_UDF_FormatTreeItemAsDirectory(
    &l__UDF_TREE_ITEM__Directory[ 2 ],
    ( ++l__ULONG__GUID ),
    "VIDEO_TS",
    &l__UDF_TREE_ITEM__Directory[ 1 ]
    );

// Format file node 1 as file
l__ULONG__SystemError =
StarBurn_UDF_FormatTreeItemAsFile(
    &g__UDF_TREE_ITEM__File[ 1 ],
    ( ++l__ULONG__GUID ),
    "video_ts.ifo",
    "c:\VOB\video_ts.ifo",
    &l__UDF_TREE_ITEM__Directory[ 2 ]
    );

// Handle error case here if l__ULONG__SystemError is not NO_ERROR...

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    ( PUCHAR )( &g__UCHAR__FileSystemHead ),
    sizeof( g__UCHAR__FileSystemHead ),
    ( PUCHAR )( &g__UCHAR__FileSystemTail ),
    sizeof( g__UCHAR__FileSystemTail ),
    ( PUCHAR )( &g__UCHAR__FileSystemStructures ),
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_UDF_FormatTreeItemAsDirectory Function
See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsFile


Example

Example
StarBurn_UDF_FormatTreeItemAsFile Function

This example allocates CdvdBurnerGrabber object, creates and destroys UDF tree and destroys the device object after it's not needed any more.

// Somewhere in the data region
PVOID l__PVOID__CdvdBurnerGrabber;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER;
ULONG l__ULONG__SystemError;
CDB_FAILURE_INFORMATION l__CDB_FAILURE_INFORMATION;
UDF_TREE_ITEM l__UDF_TREE_ITEM__Directory[ 10 ];
UDF_CONTROL_BLOCK l__UDF_CONTROL_BLOCK;
UDF_TREE_ITEM g__UDF_TREE_ITEM__File[ 200 ]; // File[ 0 ] is not used

// Prepare exception text buffer
RtlZeroMemory(
    &l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText )
    );

// Prepare CDB failure information
RtlZeroMemory(
    &l__CDB_FAILURE_INFORMATION,
    sizeof( l__CDB_FAILURE_INFORMATION )
    );

// Try to create CdvdBurnerGrabber on 0:0:4:0 with 32MB of cache
l__EXCEPTION_NUMBER =
StarBurn_CdvdBurnerGrabber_Create(
    &l__PVOID__CdvdBurnerGrabber,
    l__CHAR__ExceptionText,
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__SystemError,
    &l__CDB_FAILURE_INFORMATION,
    ( PCALLBACK )( StarBurn_Callback ),
    0,
    0,
    4,
    0,
    32
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Format file node 1 as file
l__ULONG__SystemError =
StarBurn_UDF_FormatTreeItemAsFile(
    &g__UDF_TREE_ITEM__File[ 1 ],
    ( ++l__ULONG__GUID ),
    "video_ts.ifo",
    "c:\VOB\video_ts.ifo",
    &l__UDF_TREE_ITEM__Directory[ 2 ]
    );

// Handle error case here if l__ULONG__SystemError is not NO_ERROR...

// Create UDF tree with StarBurn_UDF_CreateEx() here
l__EXCEPTION_NUMBER =
StarBurn_UDF_CreateEx(
    &l__UDF_TREE_ITEM__Directory[ 1 ], // This is ROOT
    &l__UDF_TREE_ITEM__Directory[ 2 ], // This is VIDEO_TS and not ROOT, for VIDEO_TS listing
    &l__UDF_TREE_ITEM__Directory[ 3 ], // This is AUDIO_TS and not ROOT, for AUDIO_TS listing
    &l__UDF_CONTROL_BLOCK,
    ( CHAR * )( &l__CHAR__ExceptionText ),
    sizeof( l__CHAR__ExceptionText ),
    &l__ULONG__Status,
    "VolumeLabel",
    "PublisherName",
    "ApplicationName",
    2006,   // Year
    10,     // Month
    20,     // Day,
    12,     // Hour
    10,     // Minute
    0,      // Second
    50      // Millisecond
    );

// Check for correct reply
if (  l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}

// Do something with the UDF tree here (maybe burn to CdvdBurnerGrabber object)

// Clean up UDF stuff with StarBurn_UDF_CleanUp() here

// Destroy UDF tree from the root
StarBurn_UDF_Destroy(
    &l__UDF_TREE_ITEM__Directory[ 0 ],
    &l__UDF_CONTROL_BLOCK
    );

// Destroy the CdvdBurnerGrabber
StarBurn_Destroy( &l__PVOID__CdvdBurnerGrabber );

// Just check for pointer (paranoid?)
if ( l__PVOID__CdvdBurnerGrabber != NULL )
{
// Handle error here...
}


See Also

See Also
StarBurn_UDF_FormatTreeItemAsFile Function
See Also

StarBurn_UDF_Destroy, StarBurn_UDF_CleanUp, StarBurn_UDF_FormatTreeItemAsDirectory


Example

Example
StarBurn_UpStart Function

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStart();

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}


See Also

See Also
StarBurn_UpStart Function
See Also

See samples for details how and when call StarBurn_UpStart() function.


Example

Example
StarBurn_UpStartEx Function

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
UCHAR l__UCHAR__RegistrationKey[ ] = { ... }; // Registration key goes here

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStartEx(
    ( PVOID )( &l__UCHAR__RegistrationKey ),
    sizeof( l__UCHAR__RegistrationKey )
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}


See Also

See Also
StarBurn_UpStartEx Function
See Also

See samples for details how and when call StarBurn_UpStart() and StarBurn_UpStartEx() functions.


Example

Example
StarBurn_UpStartExEx Function

This example checks for the toolkit version and initializes it.

// Somewhere in the data region
ULONG l__ULONG__Version;
EXCEPTION_NUMBER l__EXCEPTION_NUMBER = EN_SUCCESS;
UCHAR l__UCHAR__RegistrationKey[ ] = { ... }; // Registration key goes here
HANDLE l__HANDLE__DebugLogFile = INVALID_HANDLE_VALUE;

// Get toolkit version
l__ULONG__Version =
StarBurn_GetVersion();

// Check for correct number
if ( l__ULONG__Version < SUPPORTED_VERSION_NUMBER )
{
// Handle error here...
}

// We assume l__HANDLE__DebugLogFile was initialized before

// Try to initialize toolkit
l__EXCEPTION_NUMBER =
StarBurn_UpStartExEx(
    ( PVOID )( &l__UCHAR__RegistrationKey ),
    sizeof( l__UCHAR__RegistrationKey ),
    STARBURN_DEBUG_FACILITY_CUSTOM,
    NULL,
    l__HANDLE__DebugLogFile
    );

// Check for success
if ( l__EXCEPTION_NUMBER != EN_SUCCESS )
{
// Handle error here...
}


See Also

See Also
StarBurn_UpStartExEx Function
See Also

See samples for details how and when call StarBurn_UpStart() and StarBurn_UpStartEx() functions.


Contents

Contents
Introduction
Copyright
Trademarks
Changes
Technical support and service
Symbol Reference
Functions
StarBurn_CdvdBurnerGrabber_AuthorizeDVD Function
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx Function
StarBurn_CdvdBurnerGrabber_Blank Function
StarBurn_CdvdBurnerGrabber_BluRayFormat Function
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery Function
StarBurn_CdvdBurnerGrabber_Cancel Function
StarBurn_CdvdBurnerGrabber_CloseSession Function
StarBurn_CdvdBurnerGrabber_Create Function
StarBurn_CdvdBurnerGrabber_CreateEx Function
StarBurn_CdvdBurnerGrabber_CreateExEx Function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile Function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode Function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree Function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile Function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode Function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode Function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree Function
StarBurn_CdvdBurnerGrabber_Eject Function
StarBurn_CdvdBurnerGrabber_ExecuteGeneric Function
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats Function
StarBurn_CdvdBurnerGrabber_GetBUP Function
StarBurn_CdvdBurnerGrabber_GetDeviceInformation Function
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode Function
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem Function
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace Function
StarBurn_CdvdBurnerGrabber_GetDiscInformation Function
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace Function
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem Function
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask Function
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType Function
StarBurn_CdvdBurnerGrabber_GetLastAddress Function
StarBurn_CdvdBurnerGrabber_GetLastTrack Function
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions Function
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus Function
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors Function
StarBurn_CdvdBurnerGrabber_GetRPC Function
StarBurn_CdvdBurnerGrabber_GetSpeeds Function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats Function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx Function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx Function
StarBurn_CdvdBurnerGrabber_GetTOCInformation Function
StarBurn_CdvdBurnerGrabber_GetTrackInformation Function
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx Function
StarBurn_CdvdBurnerGrabber_GrabCD Function
StarBurn_CdvdBurnerGrabber_GrabDVD Function
StarBurn_CdvdBurnerGrabber_GrabDVDEx Function
StarBurn_CdvdBurnerGrabber_GrabDVDFast Function
StarBurn_CdvdBurnerGrabber_GrabRange Function
StarBurn_CdvdBurnerGrabber_GrabTrack Function
StarBurn_CdvdBurnerGrabber_GrabTrackEx Function
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode Function
StarBurn_CdvdBurnerGrabber_IsDiscBlank Function
StarBurn_CdvdBurnerGrabber_Load Function
StarBurn_CdvdBurnerGrabber_LoadEx Function
StarBurn_CdvdBurnerGrabber_Lock Function
StarBurn_CdvdBurnerGrabber_MSFToLBA Function
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes Function
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes Function
StarBurn_CdvdBurnerGrabber_ReadATIP Function
StarBurn_CdvdBurnerGrabber_ReadCooked Function
StarBurn_CdvdBurnerGrabber_ReadLB Function
StarBurn_CdvdBurnerGrabber_ReadRaw Function
StarBurn_CdvdBurnerGrabber_Release Function
StarBurn_CdvdBurnerGrabber_SendOPC Function
StarBurn_CdvdBurnerGrabber_SessionAtOnce Function
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW Function
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode Function
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode Function
StarBurn_CdvdBurnerGrabber_SetBUP Function
StarBurn_CdvdBurnerGrabber_SetCDTextItem Function
StarBurn_CdvdBurnerGrabber_SetReadSpeed Function
StarBurn_CdvdBurnerGrabber_SetSpeeds Function
StarBurn_CdvdBurnerGrabber_StopPlayScan Function
StarBurn_CdvdBurnerGrabber_SuperVideoCD Function
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx Function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx Function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode Function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode Function
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode Function
StarBurn_CdvdBurnerGrabber_TestUnitReady Function
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx Function
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree Function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx Function
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup Function
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx Function
StarBurn_CdvdBurnerGrabber_VerifyFile Function
StarBurn_CdvdBurnerGrabber_VerifyFileEx Function
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode Function
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode Function
StarBurn_CdvdBurnerGrabber_VerifyTree Function
StarBurn_CdvdBurnerGrabber_VerifyTreeEx Function
StarBurn_CdvdBurnerGrabber_VideoCD Function
StarBurn_CdvdBurnerGrabber_VideoCDEx Function
StarBurn_CdvdBurnerGrabber_VideoCDExEx Function
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode Function
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode Function
StarBurn_CdvdBurnerGrabber_VideoCDUnicode Function
StarBurn_CorrectISO9660Name_Default Function
StarBurn_CorrectJolietName_Default Function
StarBurn_CreatePipe Function
StarBurn_Destroy Function
StarBurn_DestroyPipe Function
StarBurn_DownShut Function
StarBurn_DVDVideo_Create Function
StarBurn_DVDVideo_CreateUnicode Function
StarBurn_DVDVideo_Destroy Function
StarBurn_DVDVideo_GetSizeInUCHARs Function
StarBurn_DVDVideo_GetTreePointer Function
StarBurn_DVDVideo_PatchHeader Function
StarBurn_DVDVideo_PatchTable Function
StarBurn_DVDVideo_Read Function
StarBurn_DVDVideo_SeekToBegin Function
StarBurn_ElTorito_BootCatalogAddSection Function
StarBurn_ElTorito_BootCatalogAddSectionUnicode Function
StarBurn_ElTorito_CreateBootCatalog Function
StarBurn_ElTorito_CreateBootCatalogUnicode Function
StarBurn_FileClose Function
StarBurn_FileCreate Function
StarBurn_FileInitialize Function
StarBurn_FileOpen Function
StarBurn_FileOpenEx Function
StarBurn_FileRead Function
StarBurn_FileReWind Function
StarBurn_FileSeek Function
StarBurn_FileSeekRead Function
StarBurn_FileSizeInUCHARsGet Function
StarBurn_FileUnicodeCreate Function
StarBurn_FileUnicodeOpen Function
StarBurn_FileUnicodeOpenEx Function
StarBurn_FileWrite Function
StarBurn_FindDevice Function
StarBurn_GetAudioFileStreamSizeInUCHARs Function
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast Function
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast Function
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode Function
StarBurn_GetBufferUnderrunTimeOutInMs Function
StarBurn_GetDeviceLetter Function
StarBurn_GetDeviceLetterUnicode Function
StarBurn_GetDeviceNameByDeviceAddress Function
StarBurn_GetDeviceTimeOutByDeviceAddress Function
StarBurn_GetDVDPadding Function
StarBurn_GetDVDPLUSRDLCompatibleMode Function
StarBurn_GetEjectAfterFail Function
StarBurn_GetFastReadTOC Function
StarBurn_GetId Function
StarBurn_GetIs64KBIO Function
StarBurn_GetIsCollisionDetectionDisabled Function
StarBurn_GetIsSafeGrabbingEnabled Function
StarBurn_GetVersion Function
StarBurn_GetVolumeIDs Function
StarBurn_ImageFile_UDFFileSystemLookup Function
StarBurn_ImageFile_UDFFileSystemLookupEx Function
StarBurn_IsAudioFileSupported Function
StarBurn_IsAudioFileSupportedUnicode Function
StarBurn_IsLocalDateTimeUsed Function
StarBurn_ISO2_Check1999Name Function
StarBurn_ISO2_CheckJolietName Function
StarBurn_ISO2_CheckLevel1Name Function
StarBurn_ISO2_CheckLevel2Name Function
StarBurn_ISO2_CheckRelaxedJolietName Function
StarBurn_ISO2_CreateNewName Function
StarBurn_ISO2_DirectoryBrowse Function
StarBurn_ISO2_DirectoryCreate Function
StarBurn_ISO2_DirectoryDestroy Function
StarBurn_ISO2_DirectoryProcess Function
StarBurn_ISO2_DirectoryQuery Function
StarBurn_ISO2_DirectoryRootCreate Function
StarBurn_ISO2_DirectoryUnicodeCreate Function
StarBurn_ISO2_DirectoryUnicodeProcess Function
StarBurn_ISO2_FileCreate Function
StarBurn_ISO2_FileDestroy Function
StarBurn_ISO2_FileDirectoryDateTimeGet Function
StarBurn_ISO2_FileDirectoryDateTimeSet Function
StarBurn_ISO2_FileDirectoryNameSet Function
StarBurn_ISO2_FileDirectoryUnicodeNameSet Function
StarBurn_ISO2_FileMemoryCreate Function
StarBurn_ISO2_FileMemoryUnicodeCreate Function
StarBurn_ISO2_FileQuery Function
StarBurn_ISO2_FileSetAttributes Function
StarBurn_ISO2_FileUnicodeCreate Function
StarBurn_ISO2_ImpVolumeCreate Function
StarBurn_ISO2_ImpVolumeDestroy Function
StarBurn_ISO2_ImpVolumeImport Function
StarBurn_ISO2_ISO9660FileTreeCreate Function
StarBurn_ISO2_VolumeCreate Function
StarBurn_ISO2_VolumeCreateBoot Function
StarBurn_ISO2_VolumeCreateBootElTorito Function
StarBurn_ISO2_VolumeCreateEx Function
StarBurn_ISO2_VolumeCreateExBoot Function
StarBurn_ISO2_VolumeCreateUnicode Function
StarBurn_ISO2_VolumeCreateUnicodeBoot Function
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito Function
StarBurn_ISO2_VolumeDescriptorsBufferGet Function
StarBurn_ISO2_VolumeDestroy Function
StarBurn_ISO2_VolumeSeekRead Function
StarBurn_ISO2_VolumeSizeInUCHARsGet Function
StarBurn_ISO9660JolietFileTree_Add Function
StarBurn_ISO9660JolietFileTree_AddEx Function
StarBurn_ISO9660JolietFileTree_AddMemory Function
StarBurn_ISO9660JolietFileTree_AddW Function
StarBurn_ISO9660JolietFileTree_AddZeroFile Function
StarBurn_ISO9660JolietFileTree_BuildImage Function
StarBurn_ISO9660JolietFileTree_BuildImageEx Function
StarBurn_ISO9660JolietFileTree_Cancel Function
StarBurn_ISO9660JolietFileTree_Create Function
StarBurn_ISO9660JolietFileTree_GetAttributes Function
StarBurn_ISO9660JolietFileTree_GetAutoSorting Function
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs Function
StarBurn_ISO9660JolietFileTree_GetFirstKid Function
StarBurn_ISO9660JolietFileTree_GetFullPath Function
StarBurn_ISO9660JolietFileTree_GetKidType Function
StarBurn_ISO9660JolietFileTree_GetLevel Function
StarBurn_ISO9660JolietFileTree_GetNames Function
StarBurn_ISO9660JolietFileTree_GetNamesEx Function
StarBurn_ISO9660JolietFileTree_GetNamesW Function
StarBurn_ISO9660JolietFileTree_GetNextKid Function
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime Function
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs Function
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA Function
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime Function
StarBurn_ISO9660JolietFileTree_GetParent Function
StarBurn_ISO9660JolietFileTree_GetRoot Function
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs Function
StarBurn_ISO9660JolietFileTree_ImportFile Function
StarBurn_ISO9660JolietFileTree_ImportTrack Function
StarBurn_ISO9660JolietFileTree_Read Function
StarBurn_ISO9660JolietFileTree_Remove Function
StarBurn_ISO9660JolietFileTree_SeekToBegin Function
StarBurn_ISO9660JolietFileTree_SetAttributes Function
StarBurn_ISO9660JolietFileTree_SetAutoSorting Function
StarBurn_ISO9660JolietFileTree_SetBootImage Function
StarBurn_ISO9660JolietFileTree_SetBootImageEx Function
StarBurn_ISO9660JolietFileTree_SetNames Function
StarBurn_SetBufferUnderrunTimeOutInMs Function
StarBurn_SetDeviceTimeOutByDeviceAddress Function
StarBurn_SetDVDPadding Function
StarBurn_SetDVDPLUSRDLCompatibleMode Function
StarBurn_SetEjectAfterFail Function
StarBurn_SetFastReadTOC Function
StarBurn_SetIs64KBIO Function
StarBurn_SetIsCollisionDetectionDisabled Function
StarBurn_SetIsSafeGrabbingEnabled Function
StarBurn_SetUsingLocalDateTime Function
StarBurn_SetUsingUTCDateTime Function
StarBurn_sprintf_s Function
StarBurn_SPTD_GetVersion Function
StarBurn_StarPort_DeviceAddLocal Function
StarBurn_StarPort_DeviceAddLocalEx Function
StarBurn_StarPort_DeviceAddRemote Function
StarBurn_StarPort_DeviceAddRemoteEx Function
StarBurn_StarPort_DeviceListQueryLocal Function
StarBurn_StarPort_DeviceListQueryRemote Function
StarBurn_StarPort_DeviceRemove Function
StarBurn_StarPort_DeviceRemoveEx Function
StarBurn_StarPort_GetDeviceInformation Function
StarBurn_StarPort_GetDeviceLetter Function
StarBurn_StarPort_GetDeviceSCSIAddress Function
StarBurn_StarPort_GetVersion Function
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek Function
StarBurn_StarWave_CompressedFileReaderObjectCreate Function
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode Function
StarBurn_StarWave_CompressedFileReaderObjectDestroy Function
StarBurn_StarWave_CompressedFileReaderObjectRead Function
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet Function
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast Function
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate Function
StarBurn_StarWave_CompressedFileRecompress Function
StarBurn_StarWave_CompressedFileRecompressUnicode Function
StarBurn_StarWave_CompressedFileSupportedIs Function
StarBurn_StarWave_CompressedFileUncompress Function
StarBurn_StarWave_CompressedFileUncompressUnicode Function
StarBurn_StarWave_CompressedFileWriterObjectCreate Function
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode Function
StarBurn_StarWave_CompressedFileWriterObjectDestroy Function
StarBurn_StarWave_CompressedFileWriterObjectWrite Function
StarBurn_StarWave_UncompressedFileCompress Function
StarBurn_StarWave_UncompressedFileCompressUnicode Function
StarBurn_StarWave_UncompressedFileSupportedIs Function
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs Function
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx Function
StarBurn_StarWave_VersionGet Function
StarBurn_StarWave2_Convert Function
StarBurn_StarWave2_ConvertEx Function
StarBurn_StarWave2_ConvertExUnicode Function
StarBurn_StarWave2_ConvertUnicode Function
StarBurn_StarWave2_EncodeMP3OGGFromWAV Function
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode Function
StarBurn_StarWave2_IsFileSupported Function
StarBurn_StarWave2_IsFileSupportedUnicode Function
StarBurn_strcpy_s Function
StarBurn_swprintf_s Function
StarBurn_UDF_Add Function
StarBurn_UDF_AddUnicode Function
StarBurn_UDF_CleanUp Function
StarBurn_UDF_Create Function
StarBurn_UDF_CreateEx Function
StarBurn_UDF_CreateExUnicode Function
StarBurn_UDF_CreateUnicode Function
StarBurn_UDF_Destroy Function
StarBurn_UDF_DestroyNodeAndKids Function
StarBurn_UDF_FormatTreeItemAsDirectory Function
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode Function
StarBurn_UDF_FormatTreeItemAsFile Function
StarBurn_UDF_FormatTreeItemAsFileUnicode Function
StarBurn_UDF_GetFirstChild Function
StarBurn_UDF_GetNextSibling Function
StarBurn_UDF_GetNodeObject Function
StarBurn_UDF_GetParent Function
StarBurn_UDF_GetPreviousSibling Function
StarBurn_UDF2_DirectoryBrowse Function
StarBurn_UDF2_DirectoryContentsProcess Function
StarBurn_UDF2_DirectoryContentsProcessEx Function
StarBurn_UDF2_DirectoryContentsUnicodeProcess Function
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx Function
StarBurn_UDF2_DirectoryCreate Function
StarBurn_UDF2_DirectoryDestroy Function
StarBurn_UDF2_DirectoryProcess Function
StarBurn_UDF2_DirectoryProcessEx Function
StarBurn_UDF2_DirectoryProcessExEx Function
StarBurn_UDF2_DirectoryQuery Function
StarBurn_UDF2_DirectoryRootCreate Function
StarBurn_UDF2_DirectoryUnicodeCreate Function
StarBurn_UDF2_DirectoryUnicodeProcess Function
StarBurn_UDF2_DirectoryUnicodeProcessEx Function
StarBurn_UDF2_DirectoryUnicodeProcessExEx Function
StarBurn_UDF2_FileBootCreate Function
StarBurn_UDF2_FileBootUnicodeCreate Function
StarBurn_UDF2_FileCreate Function
StarBurn_UDF2_FileDestroy Function
StarBurn_UDF2_FileDirectoryDateTimeGet Function
StarBurn_UDF2_FileDirectoryDateTimeGetEx Function
StarBurn_UDF2_FileDirectoryDateTimeSet Function
StarBurn_UDF2_FileDirectoryDateTimeSetEx Function
StarBurn_UDF2_FileDirectoryNameSet Function
StarBurn_UDF2_FileDirectoryUnicodeNameSet Function
StarBurn_UDF2_FileMemoryCreate Function
StarBurn_UDF2_FileMemoryUnicodeCreate Function
StarBurn_UDF2_FileQuery Function
StarBurn_UDF2_FileSetAttributes Function
StarBurn_UDF2_FileSystemGetSizes Function
StarBurn_UDF2_FileUnicodeCreate Function
StarBurn_UDF2_ImpVolumeCreate Function
StarBurn_UDF2_ImpVolumeDestroy Function
StarBurn_UDF2_ImpVolumeImport Function
StarBurn_UDF2_ISO9660FileTreeCreate Function
StarBurn_UDF2_ISO9660FileTreeCreateEx Function
StarBurn_UDF2_VolumeAnchorGet Function
StarBurn_UDF2_VolumeCreate Function
StarBurn_UDF2_VolumeCreateBoot Function
StarBurn_UDF2_VolumeCreateBootElTorito Function
StarBurn_UDF2_VolumeCreateEx Function
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito Function
StarBurn_UDF2_VolumeDestroy Function
StarBurn_UDF2_VolumeInitialSizeInLBsGet Function
StarBurn_UDF2_VolumeSeekRead Function
StarBurn_UDF2_VolumeSizeInLBsGet Function
StarBurn_UDF2_VolumeSizeInUCHARsGet Function
StarBurn_UDF2_VolumeStore Function
StarBurn_UDF2_VolumeUnicodeCreate Function
StarBurn_UDF2_VolumeUnicodeCreateBoot Function
StarBurn_UDF2_VolumeUnicodeCreateEx Function
StarBurn_UDFBridge_CreateEx Function
StarBurn_UDFBridge_CreateExUnicode Function
StarBurn_UpStart Function
StarBurn_UpStartEx Function
StarBurn_UpStartExEx Function
Structs, Records, Enums
_CALLBACK_NUMBER Enumeration
_CDB_FAILURE_INFORMATION Structure
_DAO_DISC_LAYOUT Structure
_DAO_DISC_LAYOUT_ENTRY Structure
_DISC_FILESYSTEM Structure
_DISC_LAYOUT Structure
_DISC_LAYOUT_ENTRY Structure
_DISC_TYPE Enumeration
_DVD_VIDEO_CONTROL_BLOCK Structure
_ERASE_TYPE Enumeration
_EXCEPTION_NUMBER Enumeration
_FILE_TIME Enumeration
_FILE_TREE Enumeration
_FULL_TOC_ENTRY_RAW Structure
_ISO9660_DATE_TIME Structure
_ISO9660_KIDTYPE Enumeration
_NAME_COLLISION_INFO Structure
_NAME_COLLISION_SOLUTION Enumeration
_PQ_SUBCHANNEL Structure
_READ_MODE Enumeration
_SCSI_DEVICE_ADDRESS Structure
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
_STARBURN_BDRE_FORMAT_PROFILE Structure
_STARBURN_CD_MODE Enumeration
_STARBURN_DISC_ATIP_INFORMATION Structure
_STARBURN_DISC_INFORMATION Structure
_STARBURN_ELTORITO_MEDIA Enumeration
_STARBURN_ELTORITO_PLATFORM Enumeration
_STARBURN_ISO9660_DIRECTORY_INFO Structure
_STARBURN_ISO9660_FILE_INFO Structure
_STARBURN_STARWAVE_CALLBACK_REASON Enumeration
_STARBURN_STARWAVE_COMPRESSION Enumeration
_STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration
_STARBURN_STARWAVE2_CONVERSION_MODE Enumeration
_STARBURN_STARWAVE2_INIT_PARAMS Structure
_STARBURN_STARWAVE2_QUALITY_MODE Enumeration
_STARBURN_TRACK_INFORMATION Structure
_STARBURN_TRACK_INFORMATION_EX Structure
_STARBURN_UDF_BRIDGE_TYPE Enumeration
_STARBURN_UDF2_DIRECTORY_INFO Structure
_STARBURN_UDF2_FILE_DATE_TIME Structure
_STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration
_STARBURN_UDF2_FILE_INFO Structure
_STARPORT_DEVICE_LIST Structure
_STARPORT_DEVICE_LIST_ENTRY Structure
_STARPORT_DEVICE_TYPE Enumeration
_STARWAVE2_COMPRESSION Enumeration
_STARWAVE2_COMPRESSION_PROFILE Structure
_TOC_ENTRY Structure
_TOC_INFORMATION Structure
_UDF_CONTROL_BLOCK Structure
_UDF_FILE_EXTENT Structure
_UDF_FILE_HANDLE Structure
_UDF_FILE_LOOKUP_ENTRY Structure
_UDF_LOOKUP_DIR_ENTRY Structure
_UDF_LOOKUP_FILE_ENTRY Structure
_UDF_OS_CLASS Enumeration
_UDF_TREE_ITEM Structure
_UDF_VERSION Enumeration
_WAVE_FILE_HEADER Structure
_WAVE_FORMAT_CHUNK Structure
_WRITE_MODE Enumeration
CALLBACK_NUMBER Enumeration
CDB_FAILURE_INFORMATION Structure
DAO_DISC_LAYOUT Structure
DAO_DISC_LAYOUT_ENTRY Structure
DISC_FILESYSTEM Structure
DISC_LAYOUT Structure
DISC_LAYOUT_ENTRY Structure
DISC_TYPE Enumeration
DVD_VIDEO_CONTROL_BLOCK Structure
ERASE_TYPE Enumeration
EXCEPTION_NUMBER Enumeration
FILE_TIME Enumeration
FILE_TREE Enumeration
FULL_TOC_ENTRY_RAW Structure
ISO9660_DATE_TIME Structure
ISO9660_KIDTYPE Enumeration
NAME_COLLISION_INFO Structure
NAME_COLLISION_SOLUTION Enumeration
PCALLBACK_NUMBER Enumeration
PCDB_FAILURE_INFORMATION Structure
PDAO_DISC_LAYOUT Structure
PDAO_DISC_LAYOUT_ENTRY Structure
PDISC_FILESYSTEM Structure
PDISC_LAYOUT Structure
PDISC_LAYOUT_ENTRY Structure
PDISC_TYPE Enumeration
PDVD_VIDEO_CONTROL_BLOCK Structure
PERASE_TYPE Enumeration
PEXCEPTION_NUMBER Enumeration
PFILE_TIME Enumeration
PFILE_TREE Enumeration
PFULL_TOC_ENTRY_RAW Structure
PISO9660_DATE_TIME Structure
PISO9660_KIDTYPE Enumeration
PNAME_COLLISION_INFO Structure
PNAME_COLLISION_SOLUTION Enumeration
PPQ_SUBCHANNEL Structure
PPSTARBURN_BDRE_FORMAT_PROFILE Structure
PPSTARBURN_STARWAVE_CALLBACK_REASON Enumeration
PPSTARBURN_STARWAVE_COMPRESSION Enumeration
PPSTARPORT_DEVICE_LIST Structure
PPSTARPORT_DEVICE_LIST_ENTRY Structure
PPSTARPORT_DEVICE_TYPE Enumeration
PPSTARWAVE2_COMPRESSION Enumeration
PPSTARWAVE2_COMPRESSION_PROFILE Structure
PQ_SUBCHANNEL Structure
PREAD_MODE Enumeration
PSCSI_DEVICE_ADDRESS Structure
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
PSTARBURN_BDRE_FORMAT_PROFILE Structure
PSTARBURN_CD_MODE Enumeration
PSTARBURN_DISC_ATIP_INFORMATION Structure
PSTARBURN_DISC_INFORMATION Structure
PSTARBURN_STARWAVE_CALLBACK_REASON Enumeration
PSTARBURN_STARWAVE_COMPRESSION Enumeration
PSTARBURN_STARWAVE2_CONVERSION_MODE Enumeration
PSTARBURN_STARWAVE2_INIT_PARAMS Structure
PSTARBURN_STARWAVE2_QUALITY_MODE Enumeration
PSTARBURN_TRACK_INFORMATION Structure
PSTARBURN_TRACK_INFORMATION_EX Structure
PSTARPORT_DEVICE_LIST Structure
PSTARPORT_DEVICE_LIST_ENTRY Structure
PSTARPORT_DEVICE_TYPE Enumeration
PSTARWAVE2_COMPRESSION Enumeration
PSTARWAVE2_COMPRESSION_PROFILE Structure
PTOC_ENTRY Structure
PTOC_INFORMATION Structure
PUDF_CONTROL_BLOCK Structure
PUDF_FILE_EXTENT Structure
PUDF_FILE_HANDLE Structure
PUDF_FILE_LOOKUP_ENTRY Structure
PUDF_LOOKUP_DIR_ENTRY Structure
PUDF_LOOKUP_FILE_ENTRY Structure
PUDF_TREE_ITEM Structure
PWAVE_FILE_HEADER Structure
PWAVE_FORMAT_CHUNK Structure
PWRITE_MODE Enumeration
READ_MODE Enumeration
SCSI_DEVICE_ADDRESS Structure
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS Structure
STARBURN_BDRE_FORMAT_PROFILE Structure
STARBURN_CD_MODE Enumeration
STARBURN_DISC_ATIP_INFORMATION Structure
STARBURN_DISC_INFORMATION Structure
STARBURN_ELTORITO_MEDIA Enumeration
STARBURN_ELTORITO_PLATFORM Enumeration
STARBURN_ISO9660_DIRECTORY_INFO Structure
STARBURN_ISO9660_FILE_INFO Structure
STARBURN_STARWAVE_CALLBACK_REASON Enumeration
STARBURN_STARWAVE_COMPRESSION Enumeration
STARBURN_STARWAVE2_COMPRESS_TYPE Enumeration
STARBURN_STARWAVE2_CONVERSION_MODE Enumeration
STARBURN_STARWAVE2_INIT_PARAMS Structure
STARBURN_STARWAVE2_QUALITY_MODE Enumeration
STARBURN_TRACK_INFORMATION Structure
STARBURN_TRACK_INFORMATION_EX Structure
STARBURN_UDF_BRIDGE_TYPE Enumeration
STARBURN_UDF2_DIRECTORY_INFO Structure
STARBURN_UDF2_FILE_DATE_TIME Structure
STARBURN_UDF2_FILE_DATE_TIME_TYPE Enumeration
STARBURN_UDF2_FILE_INFO Structure
STARPORT_DEVICE_LIST Structure
STARPORT_DEVICE_LIST_ENTRY Structure
STARPORT_DEVICE_TYPE Enumeration
STARWAVE2_COMPRESSION Enumeration
STARWAVE2_COMPRESSION_PROFILE Structure
TOC_ENTRY Structure
TOC_INFORMATION Structure
UDF_CONTROL_BLOCK Structure
UDF_FILE_EXTENT Structure
UDF_FILE_HANDLE Structure
UDF_FILE_LOOKUP_ENTRY Structure
UDF_LOOKUP_DIR_ENTRY Structure
UDF_LOOKUP_FILE_ENTRY Structure
UDF_OS_CLASS Enumeration
UDF_TREE_ITEM Structure
UDF_VERSION Enumeration
WAVE_FILE_HEADER Structure
WAVE_FORMAT_CHUNK Structure
WRITE_MODE Enumeration
Types
CFuncStarWaveConversionCallback Type
PCALLBACK Type
PSTARBURN_CLOSEHANDLE_CALLBACK Type
PSTARBURN_CREATEFILE_CALLBACK Type
PSTARBURN_DELETEFILE_CALLBACK Type
PSTARBURN_FILE_OBJECT Type
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK Type
PSTARBURN_ISO2_COLLISION_CALLBACK Type
PSTARBURN_ISO2_PROGRESS_CALLBACK Type
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK Type
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK Type
PSTARBURN_ISO9660_READ_CALLBACK Type
PSTARBURN_READFILE_CALLBACK Type
PSTARBURN_SET_FILE_POINTER_CALLBACK Type
PSTARBURN_STARWAVE_CALLBACK Type
PSTARBURN_UDF2_COLLISION_CALLBACK_EX Type
PSTARBURN_UDF2_IMPORT_CALLBACK Type
PSTARBURN_UDF2_PROGRESS_CALLBACK Type
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX Type
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK Type
PSTARBURN_WRITEFILE_CALLBACK Type
Macros
__STARBURN_H__ Macro
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS Macro
AUDIO_LB_SIZE_IN_UCHARS Macro
BLURAY_SPEED_IN_KBPS_1X Macro
BLURAY_SPEED_IN_KBPS_2X Macro
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS Macro
CACHE_SIZE_IN_MBS Macro
CD_SPEED_IN_KBPS_10X Macro
CD_SPEED_IN_KBPS_12X Macro
CD_SPEED_IN_KBPS_16X Macro
CD_SPEED_IN_KBPS_1X Macro
CD_SPEED_IN_KBPS_20X Macro
CD_SPEED_IN_KBPS_24X Macro
CD_SPEED_IN_KBPS_2P2X Macro
CD_SPEED_IN_KBPS_2X Macro
CD_SPEED_IN_KBPS_32X Macro
CD_SPEED_IN_KBPS_36X Macro
CD_SPEED_IN_KBPS_3X Macro
CD_SPEED_IN_KBPS_40X Macro
CD_SPEED_IN_KBPS_44X Macro
CD_SPEED_IN_KBPS_48X Macro
CD_SPEED_IN_KBPS_4X Macro
CD_SPEED_IN_KBPS_52X Macro
CD_SPEED_IN_KBPS_56X Macro
CD_SPEED_IN_KBPS_6X Macro
CD_SPEED_IN_KBPS_72X Macro
CD_SPEED_IN_KBPS_8X Macro
CDVD_SPEED_IS_KBPS_MAXIMUM Macro
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES Macro
DEVICES_PER_BUS Macro
DISC_STATUS_COMPLETE Macro
DISC_STATUS_EMPTY Macro
DISC_STATUS_INCOMPLETE Macro
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro
DVD_ECC_BLOCK_SIZE_IN_LBS Macro
DVD_ECC_BLOCK_SIZE_IN_UCHARS Macro
DVD_PROTECTION_CPRM Macro
DVD_PROTECTION_CSS Macro
DVD_PROTECTION_NONE Macro
DVD_SPEED_IN_KBPS_10X Macro
DVD_SPEED_IN_KBPS_12X Macro
DVD_SPEED_IN_KBPS_16X Macro
DVD_SPEED_IN_KBPS_18X Macro
DVD_SPEED_IN_KBPS_1X Macro
DVD_SPEED_IN_KBPS_20X Macro
DVD_SPEED_IN_KBPS_22X Macro
DVD_SPEED_IN_KBPS_24X Macro
DVD_SPEED_IN_KBPS_2DOT4X Macro
DVD_SPEED_IN_KBPS_2X Macro
DVD_SPEED_IN_KBPS_32X Macro
DVD_SPEED_IN_KBPS_3X Macro
DVD_SPEED_IN_KBPS_40X Macro
DVD_SPEED_IN_KBPS_48X Macro
DVD_SPEED_IN_KBPS_4X Macro
DVD_SPEED_IN_KBPS_50X Macro
DVD_SPEED_IN_KBPS_5X Macro
DVD_SPEED_IN_KBPS_6X Macro
DVD_SPEED_IN_KBPS_8X Macro
ELTORITO_BOOTABLE Macro
ELTORITO_BOOTSYSTEM_ID Macro
ELTORITO_DEF_LOAD_SEGMENT Macro
ELTORITO_NON_BOOTABLE Macro
ERROR_FIELD_C2_AND_BLOCK_ERROR Macro
ERROR_FIELD_C2_ERROR Macro
ERROR_FIELD_NO_ERROR Macro
ERROR_FIELD_RESERVED Macro
EXPECTED_LB_TYPE_ANY Macro
EXPECTED_LB_TYPE_CDDA Macro
EXPECTED_LB_TYPE_MODE1 Macro
EXPECTED_LB_TYPE_MODE2 Macro
EXPECTED_LB_TYPE_MODE2_FORM1 Macro
EXPECTED_LB_TYPE_MODE2_FORM2 Macro
HARD_DISK_LB_SIZE_IN_UCHARS Macro
HEADER_CODE_ALL_HEADERS Macro
HEADER_CODE_HEADER_ONLY Macro
HEADER_CODE_NONE Macro
HEADER_CODE_SUBHEADER_ONLY Macro
ISO9660_DATE_SIZE_IN_UCHARS Macro
ISO9660_FILE_SIZE_IN_UCHARS Macro
ISO9660_NAME_SIZE_IN_UCHARS Macro
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS Macro
ISO9660_TREE_LEVEL Macro
LAST_SESSION_COMPLETE Macro
LAST_SESSION_EMPTY Macro
LAST_SESSION_INCOMPLETE Macro
MODE1_LB_SIZE_IN_UCHARS Macro
MODE2_FORM1_LB_SIZE_IN_UCHARS Macro
MODE2_FORM2_LB_SIZE_IN_UCHARS Macro
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS Macro
MODE2_FORMLESS_LB_SIZE_IN_UCHARS Macro
NUMBER_OF_RAW_TRACKS Macro
NUMBER_OF_READ_RETRIES Macro
NUMBER_OF_SUBCHANNELS Macro
NUMBER_OF_TRACKS Macro
PAGE_SIZE_IN_UCHARS Macro
RAW_LB_PQ_SUB_SIZE_IN_UCHARS Macro
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS Macro
RAW_LB_SIZE_IN_UCHARS Macro
READ_REPORT_DELAY_IN_SECONDS Macro
SCSI_DEVICE_DIRECT_ACCESS Macro
SCSI_DEVICE_MAGNETO_OPTICAL Macro
SCSI_DEVICE_MEDIUM_CHANGER Macro
SCSI_DEVICE_NETWORK Macro
SCSI_DEVICE_PRINTER Macro
SCSI_DEVICE_PROCESSOR Macro
SCSI_DEVICE_RO_DIRECT_ACCESS Macro
SCSI_DEVICE_SCANNER Macro
SCSI_DEVICE_SEQUENTIAL_ACCESS Macro
SCSI_DEVICE_UNPRESENT Macro
SCSI_DEVICE_WILDCARD Macro
SCSI_DEVICE_WORM Macro
SHORT_RAW_LB_SIZE_IN_UCHARS Macro
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS Macro
SMALLEST_CACHE_SIZE_IN_MBS Macro
SMALLEST_CACHE_SIZE_IN_UCHARS Macro
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL Macro
STARBURN_BDRE_FORMAT_CERTIFICATION_NO Macro
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK Macro
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED Macro
STARBURN_BDRE_FORMAT_DEFAULT Macro
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION Macro
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA Macro
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA Macro
STARBURN_CACHE_SIZE_READ_ONLY Macro
STARBURN_CACHE_SIZE_READ_WRITE Macro
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED Macro
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY Macro
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN Macro
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED Macro
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT Macro
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT Macro
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT Macro
StarBurn_CdvdBurnerGrabber_GrabTrackT Macro
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT Macro
StarBurn_CdvdBurnerGrabber_SessionAtOnceT Macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT Macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT Macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDT Macro
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT Macro
StarBurn_CdvdBurnerGrabber_VerifyFileExT Macro
StarBurn_CdvdBurnerGrabber_VerifyFileT Macro
StarBurn_CdvdBurnerGrabber_VideoCDExExT Macro
StarBurn_CdvdBurnerGrabber_VideoCDExT Macro
StarBurn_CdvdBurnerGrabber_VideoCDT Macro
STARBURN_DEBUG_FACILITY_ALLMESSAGES Macro
STARBURN_DEBUG_FACILITY_ALLTARGETS Macro
STARBURN_DEBUG_FACILITY_CUSTOM Macro
STARBURN_DEBUG_FACILITY_DEBUG Macro
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT Macro
STARBURN_DEBUG_FACILITY_ERROR Macro
STARBURN_DEBUG_FACILITY_LOG_FILE Macro
STARBURN_DEBUG_FACILITY_NONE Macro
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE Macro
STARBURN_DEBUG_FACILITY_TRACE Macro
STARBURN_DEBUG_FACILITY_WARNING Macro
STARBURN_DISC_TYPE_CDDA Macro
STARBURN_DISC_TYPE_CDI Macro
STARBURN_DISC_TYPE_UNDEFINED Macro
STARBURN_DISC_TYPE_XA Macro
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES Macro
StarBurn_DVDVideo_CreateT Macro
StarBurn_ElTorito_BootCatalogAddSectionT Macro
StarBurn_ElTorito_CreateBootCatalogT Macro
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT Macro
StarBurn_GetAudioFileStreamSizeInUCHARsT Macro
StarBurn_GetDeviceLetterT Macro
STARBURN_IMPEX_API Macro
StarBurn_IsAudioFileSupportedT Macro
StarBurn_ISO2_VolumeCreateBootElToritoT Macro
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE Macro
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY Macro
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE Macro
STARBURN_ISO9660_FILE_FLAGS_NONE Macro
STARBURN_ISO9660_FILE_FLAGS_RECORD Macro
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS Macro
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS Macro
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS Macro
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS Macro
STARBURN_ISO9660_TYPE_1999 Macro
STARBURN_ISO9660_TYPE_JOLIET Macro
STARBURN_ISO9660_TYPE_JOLIET_RELAXED Macro
STARBURN_ISO9660_TYPE_LEVEL1 Macro
STARBURN_ISO9660_TYPE_LEVEL2 Macro
STARBURN_LOADING_MECHANISM_TYPE_CADDY Macro
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE Macro
STARBURN_LOADING_MECHANISM_TYPE_CHANGER Macro
STARBURN_LOADING_MECHANISM_TYPE_POP_UP Macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 Macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 Macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 Macro
STARBURN_LOADING_MECHANISM_TYPE_TRAY Macro
STARBURN_PIPE_SIZE_IN_UCHARS Macro
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS Macro
StarBurn_StarWave_CompressedFileReaderObjectCreateT Macro
StarBurn_StarWave_CompressedFileRecompressT Macro
StarBurn_StarWave_CompressedFileUncompressT Macro
StarBurn_StarWave_CompressedFileWriterObjectCreateT Macro
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS Macro
StarBurn_StarWave_UncompressedFileCompressT Macro
StarBurn_StarWave_UncompressedFileSupportedIsT Macro
StarBurn_StarWave2_ConvertExT Macro
StarBurn_StarWave2_EncodeMP3OGGFromWAVT Macro
StarBurn_StarWave2_GetFileReaderAndFactoryT Macro
StarBurn_UDF_AddT Macro
StarBurn_UDF_CreateExT Macro
StarBurn_UDF_CreateT Macro
StarBurn_UDF_FormatTreeItemAsDirectoryT Macro
StarBurn_UDF_FormatTreeItemAsFileT Macro
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS Macro
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS Macro
StarBurn_UDF2_VolumeCreateBootElToritoT Macro
StarBurn_UDFBridge_CreateExT Macro
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS Macro
STARWAVEFACTORY_ID_DSHOW Macro
STARWAVEFACTORY_ID_MP3 Macro
STARWAVEFACTORY_ID_OGG Macro
STARWAVEFACTORY_ID_WAV Macro
STARWAVEFACTORY_ID_WMA Macro
SUBCHANNEL_NO Macro
SUBCHANNEL_PQ Macro
SUBCHANNEL_PQ_SIZE_IN_UCHARS Macro
SUBCHANNEL_RAW_PW Macro
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS Macro
SUBCHANNEL_RESERVED Macro
SUBCHANNEL_RW Macro
SUBCHANNEL_SIZE_IN_UCHARS Macro
TRACK_NUMBER_INVISIBLE Macro
TYPE_CODE_LAST_CHANCE Macro
TYPE_CODE_NONE Macro
TYPE_CODE_PERM Macro
TYPE_CODE_SET Macro
UDF_FILE_SET_DESCRIPTOR_LBA Macro
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA Macro
UDF_FIRST_ANCHOR_LBA Macro
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS Macro
UDF_ISO9660_FILE_SYSTEM_LBA Macro
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS Macro
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS Macro
UDF_NAME_SIZE_IN_UCHARS Macro
UDF_NAME_SIZE_IN_UCHARS_ACTUAL Macro
UDF_NSR_DESCRIPTOR_LBA Macro
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS Macro
WAVE_FILE_ALIGNMENT Macro
WAVE_FILE_BITS_PER_SAMPLE Macro
WAVE_FILE_CHANNELS Macro
WAVE_FILE_DATA_SIGNATURE Macro
WAVE_FILE_RIFF_SIGNATURE Macro
WAVE_FILE_SAMPLES_PER_SECOND Macro
WAVE_FILE_TAG_SIGNATURE Macro
WAVE_FILE_WAVE_FORMAT Macro
WAVE_FILE_WAVE_SIGNATURE Macro
WRITE_REPORT_DELAY_IN_SECONDS Macro
Files
StarBurn.h


Index

Index
_ | A | B | C | D | E | F | H | I | K | L | M | N | P | R | S | T | U | W
_
__STARBURN_H__
__STARBURN_H__ macro
_CALLBACK_NUMBER
_CALLBACK_NUMBER enumeration
_CDB_FAILURE_INFORMATION
_CDB_FAILURE_INFORMATION structure
_DAO_DISC_LAYOUT
_DAO_DISC_LAYOUT structure
_DAO_DISC_LAYOUT_ENTRY
_DAO_DISC_LAYOUT_ENTRY structure
_DISC_FILESYSTEM
_DISC_FILESYSTEM structure
_DISC_LAYOUT
_DISC_LAYOUT structure
_DISC_LAYOUT_ENTRY
_DISC_LAYOUT_ENTRY structure
_DISC_TYPE
_DISC_TYPE enumeration
_DVD_VIDEO_CONTROL_BLOCK
_DVD_VIDEO_CONTROL_BLOCK structure
_ERASE_TYPE
_ERASE_TYPE enumeration
_EXCEPTION_NUMBER
_EXCEPTION_NUMBER enumeration
_FILE_TIME
_FILE_TIME enumeration
_FILE_TREE
_FILE_TREE enumeration
_FULL_TOC_ENTRY_RAW
_FULL_TOC_ENTRY_RAW structure
_ISO9660_DATE_TIME
_ISO9660_DATE_TIME structure
_ISO9660_KIDTYPE
_ISO9660_KIDTYPE enumeration
_NAME_COLLISION_INFO
_NAME_COLLISION_INFO structure
_NAME_COLLISION_SOLUTION
_NAME_COLLISION_SOLUTION enumeration
_PQ_SUBCHANNEL
_PQ_SUBCHANNEL structure
_READ_MODE
_READ_MODE enumeration
_SCSI_DEVICE_ADDRESS
_SCSI_DEVICE_ADDRESS structure
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
_STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS structure
_STARBURN_BDRE_FORMAT_PROFILE
_STARBURN_BDRE_FORMAT_PROFILE structure
_STARBURN_CD_MODE
_STARBURN_CD_MODE enumeration
_STARBURN_DISC_ATIP_INFORMATION
_STARBURN_DISC_ATIP_INFORMATION structure
_STARBURN_DISC_INFORMATION
_STARBURN_DISC_INFORMATION structure
_STARBURN_ELTORITO_MEDIA
_STARBURN_ELTORITO_MEDIA enumeration
_STARBURN_ELTORITO_PLATFORM
_STARBURN_ELTORITO_PLATFORM enumeration
_STARBURN_ISO9660_DIRECTORY_INFO
_STARBURN_ISO9660_DIRECTORY_INFO structure
_STARBURN_ISO9660_FILE_INFO
_STARBURN_ISO9660_FILE_INFO structure
_STARBURN_STARWAVE_CALLBACK_REASON
_STARBURN_STARWAVE_CALLBACK_REASON enumeration
_STARBURN_STARWAVE_COMPRESSION
_STARBURN_STARWAVE_COMPRESSION enumeration
_STARBURN_STARWAVE2_COMPRESS_TYPE
_STARBURN_STARWAVE2_COMPRESS_TYPE enumeration
_STARBURN_STARWAVE2_CONVERSION_MODE
_STARBURN_STARWAVE2_CONVERSION_MODE enumeration
_STARBURN_STARWAVE2_INIT_PARAMS
_STARBURN_STARWAVE2_INIT_PARAMS structure
_STARBURN_STARWAVE2_QUALITY_MODE
_STARBURN_STARWAVE2_QUALITY_MODE enumeration
_STARBURN_TRACK_INFORMATION
_STARBURN_TRACK_INFORMATION structure
_STARBURN_TRACK_INFORMATION_EX
_STARBURN_TRACK_INFORMATION_EX structure
_STARBURN_UDF_BRIDGE_TYPE
_STARBURN_UDF_BRIDGE_TYPE enumeration
_STARBURN_UDF2_DIRECTORY_INFO
_STARBURN_UDF2_DIRECTORY_INFO structure
_STARBURN_UDF2_FILE_DATE_TIME
_STARBURN_UDF2_FILE_DATE_TIME structure
_STARBURN_UDF2_FILE_DATE_TIME_TYPE
_STARBURN_UDF2_FILE_DATE_TIME_TYPE enumeration
_STARBURN_UDF2_FILE_INFO
_STARBURN_UDF2_FILE_INFO structure
_STARPORT_DEVICE_LIST
_STARPORT_DEVICE_LIST structure
_STARPORT_DEVICE_LIST_ENTRY
_STARPORT_DEVICE_LIST_ENTRY structure
_STARPORT_DEVICE_TYPE
_STARPORT_DEVICE_TYPE enumeration
_STARWAVE2_COMPRESSION
_STARWAVE2_COMPRESSION enumeration
_STARWAVE2_COMPRESSION_PROFILE
_STARWAVE2_COMPRESSION_PROFILE structure
_TOC_ENTRY
_TOC_ENTRY structure
_TOC_INFORMATION
_TOC_INFORMATION structure
_UDF_CONTROL_BLOCK
_UDF_CONTROL_BLOCK structure
_UDF_FILE_EXTENT
_UDF_FILE_EXTENT structure
_UDF_FILE_HANDLE
_UDF_FILE_HANDLE structure
_UDF_FILE_LOOKUP_ENTRY
_UDF_FILE_LOOKUP_ENTRY structure
_UDF_LOOKUP_DIR_ENTRY
_UDF_LOOKUP_DIR_ENTRY structure
_UDF_LOOKUP_FILE_ENTRY
_UDF_LOOKUP_FILE_ENTRY structure
_UDF_OS_CLASS
_UDF_OS_CLASS enumeration
_UDF_TREE_ITEM
_UDF_TREE_ITEM structure
_UDF_VERSION
_UDF_VERSION enumeration
_WAVE_FILE_HEADER
_WAVE_FILE_HEADER structure
_WAVE_FORMAT_CHUNK
_WAVE_FORMAT_CHUNK structure
_WRITE_MODE
_WRITE_MODE enumeration
A
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS
ASPI_SAFE_BUFFER_SIZE_IN_UCHARS macro
AUDIO_LB_SIZE_IN_UCHARS
AUDIO_LB_SIZE_IN_UCHARS macro
B
BLURAY_SPEED_IN_KBPS_1X
BLURAY_SPEED_IN_KBPS_1X macro
BLURAY_SPEED_IN_KBPS_2X
BLURAY_SPEED_IN_KBPS_2X macro
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS
BUFFER_STATUS_REPORT_DELAY_IN_SECONDS macro
C
CACHE_SIZE_IN_MBS
CACHE_SIZE_IN_MBS macro
CALLBACK_NUMBER
CALLBACK_NUMBER enumeration
CD_MODE_AUDIO enumeration member
CD_MODE_DATA enumeration member
CD_MODE_RESERVED enumeration member
CD_MODE_UNKNOWN enumeration member
CD_MODE_VIDEO enumeration member
CD_SPEED_IN_KBPS_10X
CD_SPEED_IN_KBPS_10X macro
CD_SPEED_IN_KBPS_12X
CD_SPEED_IN_KBPS_12X macro
CD_SPEED_IN_KBPS_16X
CD_SPEED_IN_KBPS_16X macro
CD_SPEED_IN_KBPS_1X
CD_SPEED_IN_KBPS_1X macro
CD_SPEED_IN_KBPS_20X
CD_SPEED_IN_KBPS_20X macro
CD_SPEED_IN_KBPS_24X
CD_SPEED_IN_KBPS_24X macro
CD_SPEED_IN_KBPS_2P2X
CD_SPEED_IN_KBPS_2P2X macro
CD_SPEED_IN_KBPS_2X
CD_SPEED_IN_KBPS_2X macro
CD_SPEED_IN_KBPS_32X
CD_SPEED_IN_KBPS_32X macro
CD_SPEED_IN_KBPS_36X
CD_SPEED_IN_KBPS_36X macro
CD_SPEED_IN_KBPS_3X
CD_SPEED_IN_KBPS_3X macro
CD_SPEED_IN_KBPS_40X
CD_SPEED_IN_KBPS_40X macro
CD_SPEED_IN_KBPS_44X
CD_SPEED_IN_KBPS_44X macro
CD_SPEED_IN_KBPS_48X
CD_SPEED_IN_KBPS_48X macro
CD_SPEED_IN_KBPS_4X
CD_SPEED_IN_KBPS_4X macro
CD_SPEED_IN_KBPS_52X
CD_SPEED_IN_KBPS_52X macro
CD_SPEED_IN_KBPS_56X
CD_SPEED_IN_KBPS_56X macro
CD_SPEED_IN_KBPS_6X
CD_SPEED_IN_KBPS_6X macro
CD_SPEED_IN_KBPS_72X
CD_SPEED_IN_KBPS_72X macro
CD_SPEED_IN_KBPS_8X
CD_SPEED_IN_KBPS_8X macro
CDB_FAILURE_INFORMATION
CDB_FAILURE_INFORMATION structure
CDVD_SPEED_IS_KBPS_MAXIMUM
CDVD_SPEED_IS_KBPS_MAXIMUM macro
CFuncStarWaveConversionCallback
CFuncStarWaveConversionCallback type
Changes
CN_BDRE_FORMAT_BEGIN enumeration member
CN_BDRE_FORMAT_END enumeration member
CN_BUFFER_UNDERRUN enumeration member
CN_CDVD_BLANKAREA_PROGRESS enumeration member
CN_CDVD_BUFFER_STATUS enumeration member
CN_CDVD_DPM_BEGIN enumeration member
CN_CDVD_DPM_END enumeration member
CN_CDVD_DPM_PROGRESS enumeration member
CN_CDVD_READ_BAD_BLOCK_HIT enumeration member
CN_CDVD_READ_CANCEL_QUERY enumeration member
CN_CDVD_READ_ECCEDC_BAD_BLOCK_HIT enumeration member
CN_CDVD_READ_PROGRESS enumeration member
CN_CDVD_READ_RETRY enumeration member
CN_CDVD_SPLIT_BEGIN enumeration member
CN_CDVD_SPLIT_END enumeration member
CN_CDVD_TRACK_BEGIN enumeration member
CN_CDVD_TRACK_END enumeration member
CN_CDVD_VERIFY_BEGIN enumeration member
CN_CDVD_VERIFY_END enumeration member
CN_CDVD_VERIFY_PROGRESS enumeration member
CN_CDVD_WRITE_BEGIN enumeration member
CN_CDVD_WRITE_END enumeration member
CN_CDVD_WRITE_PROGRESS enumeration member
CN_DVD_MEDIA_PADDING_BEGIN enumeration member
CN_DVD_MEDIA_PADDING_END enumeration member
CN_DVD_MEDIA_PADDING_SIZE enumeration member
CN_DVD_MEDIA_PADDING_WRITE_PROGRESS enumeration member
CN_DVD_TEST_WRITE_DISABLED enumeration member
CN_DVDPLUSRW_FORMAT_BEGIN enumeration member
CN_DVDPLUSRW_FORMAT_END enumeration member
CN_DVDRAM_FORMAT_BEGIN enumeration member
CN_DVDRAM_FORMAT_END enumeration member
CN_DVDRW_QUICK_FORMAT_BEGIN enumeration member
CN_DVDRW_QUICK_FORMAT_END enumeration member
CN_FILE_TREE_PROGRESS_ADD enumeration member
CN_FILE_TREE_PROGRESS_IGNORE enumeration member
CN_FILE_TREE_PROGRESS_NAME_COLLISION enumeration member
CN_FILE_TREE_PROGRESS_REMOVE enumeration member
CN_FIND_DEVICE enumeration member
CN_SAO_TRACK_WRITE_BEGIN enumeration member
CN_SAO_TRACK_WRITE_END enumeration member
CN_SYNCHRONIZE_CACHE_BEGIN enumeration member
CN_SYNCHRONIZE_CACHE_END enumeration member
CN_TARGET_FILE_ANALYZE_BEGIN enumeration member
CN_TARGET_FILE_ANALYZE_END enumeration member
CN_UDF_FILE_LOOKUP enumeration member
CN_UDF_LOOKUP_DIR enumeration member
CN_UDF_LOOKUP_FILE enumeration member
CN_WAIT_CACHE_FULL_BEGIN enumeration member
CN_WAIT_CACHE_FULL_END enumeration member
COMPRESS_TYPE_CUSTOM enumeration member
COMPRESS_TYPE_FORCE_INT enumeration member
COMPRESS_TYPE_INVALID_VALUE enumeration member
COMPRESS_TYPE_MP3_ABR enumeration member
COMPRESS_TYPE_MP3_CBR enumeration member
COMPRESS_TYPE_MP3_VBR enumeration member
COMPRESS_TYPE_OGG_ABR enumeration member
COMPRESS_TYPE_OGG_APPROXIMATE enumeration member
COMPRESS_TYPE_OGG_CBR enumeration member
COMPRESS_TYPE_OGG_VBR enumeration member
COMPRESS_TYPE_UNCOMPRESSED_WAV_44100_STEREO enumeration member
COMPRESS_TYPE_WMA_CBR enumeration member
COMPRESS_TYPE_WMA_LOSSLESS_VBR enumeration member
COMPRESS_TYPE_WMA_VBR enumeration member
Copyright
D
DAO_DISC_LAYOUT
DAO_DISC_LAYOUT structure
DAO_DISC_LAYOUT_ENTRY
DAO_DISC_LAYOUT_ENTRY structure
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES
DEFAULT_NUMBER_OF_VERIFY_READ_RETRIES macro
DEVICES_PER_BUS
DEVICES_PER_BUS macro
DISC_FILESYSTEM
DISC_FILESYSTEM structure
DISC_LAYOUT
DISC_LAYOUT structure
DISC_LAYOUT_ENTRY
DISC_LAYOUT_ENTRY structure
DISC_STATUS_COMPLETE
DISC_STATUS_COMPLETE macro
DISC_STATUS_EMPTY
DISC_STATUS_EMPTY macro
DISC_STATUS_INCOMPLETE
DISC_STATUS_INCOMPLETE macro
DISC_TYPE
DISC_TYPE enumeration
DISC_TYPE_BDR enumeration member
DISC_TYPE_BDRE enumeration member
DISC_TYPE_BDROM enumeration member
DISC_TYPE_CDR enumeration member
DISC_TYPE_CDROM enumeration member
DISC_TYPE_CDRW enumeration member
DISC_TYPE_DDCDR enumeration member
DISC_TYPE_DDCDROM enumeration member
DISC_TYPE_DDCDRW enumeration member
DISC_TYPE_DVDPLUSR enumeration member
DISC_TYPE_DVDPLUSR_DL enumeration member
DISC_TYPE_DVDPLUSRW enumeration member
DISC_TYPE_DVDR enumeration member
DISC_TYPE_DVDR_DL enumeration member
DISC_TYPE_DVDRAM enumeration member
DISC_TYPE_DVDROM enumeration member
DISC_TYPE_DVDRWRO enumeration member
DISC_TYPE_DVDRWSR enumeration member
DISC_TYPE_HDDVDR enumeration member
DISC_TYPE_HDDVDROM enumeration member
DISC_TYPE_HDDVDRW enumeration member
DISC_TYPE_NO_MEDIA enumeration member
DISC_TYPE_UNKNOWN enumeration member
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS
DUAL_LAYER_DVD_CAPACITY_SIZE_IN_LBS macro
DVD_ECC_BLOCK_SIZE_IN_LBS
DVD_ECC_BLOCK_SIZE_IN_LBS macro
DVD_ECC_BLOCK_SIZE_IN_UCHARS
DVD_ECC_BLOCK_SIZE_IN_UCHARS macro
DVD_PROTECTION_CPRM
DVD_PROTECTION_CPRM macro
DVD_PROTECTION_CSS
DVD_PROTECTION_CSS macro
DVD_PROTECTION_NONE
DVD_PROTECTION_NONE macro
DVD_SPEED_IN_KBPS_10X
DVD_SPEED_IN_KBPS_10X macro
DVD_SPEED_IN_KBPS_12X
DVD_SPEED_IN_KBPS_12X macro
DVD_SPEED_IN_KBPS_16X
DVD_SPEED_IN_KBPS_16X macro
DVD_SPEED_IN_KBPS_18X
DVD_SPEED_IN_KBPS_18X macro
DVD_SPEED_IN_KBPS_1X
DVD_SPEED_IN_KBPS_1X macro
DVD_SPEED_IN_KBPS_20X
DVD_SPEED_IN_KBPS_20X macro
DVD_SPEED_IN_KBPS_22X
DVD_SPEED_IN_KBPS_22X macro
DVD_SPEED_IN_KBPS_24X
DVD_SPEED_IN_KBPS_24X macro
DVD_SPEED_IN_KBPS_2DOT4X
DVD_SPEED_IN_KBPS_2DOT4X macro
DVD_SPEED_IN_KBPS_2X
DVD_SPEED_IN_KBPS_2X macro
DVD_SPEED_IN_KBPS_32X
DVD_SPEED_IN_KBPS_32X macro
DVD_SPEED_IN_KBPS_3X
DVD_SPEED_IN_KBPS_3X macro
DVD_SPEED_IN_KBPS_40X
DVD_SPEED_IN_KBPS_40X macro
DVD_SPEED_IN_KBPS_48X
DVD_SPEED_IN_KBPS_48X macro
DVD_SPEED_IN_KBPS_4X
DVD_SPEED_IN_KBPS_4X macro
DVD_SPEED_IN_KBPS_50X
DVD_SPEED_IN_KBPS_50X macro
DVD_SPEED_IN_KBPS_5X
DVD_SPEED_IN_KBPS_5X macro
DVD_SPEED_IN_KBPS_6X
DVD_SPEED_IN_KBPS_6X macro
DVD_SPEED_IN_KBPS_8X
DVD_SPEED_IN_KBPS_8X macro
DVD_VIDEO_CONTROL_BLOCK
DVD_VIDEO_CONTROL_BLOCK structure
E
ELTORITO_BOOTABLE
ELTORITO_BOOTABLE macro
ELTORITO_BOOTSYSTEM_ID
ELTORITO_BOOTSYSTEM_ID macro
ELTORITO_DEF_LOAD_SEGMENT
ELTORITO_DEF_LOAD_SEGMENT macro
ELTORITO_MEDIA_CUSTOM enumeration member
ELTORITO_MEDIA_FLOPPY120 enumeration member
ELTORITO_MEDIA_FLOPPY144 enumeration member
ELTORITO_MEDIA_FLOPPY288 enumeration member
ELTORITO_MEDIA_HARDDISK enumeration member
ELTORITO_NON_BOOTABLE
ELTORITO_NON_BOOTABLE macro
ELTORITO_PLATFORM_80X86 enumeration member
ELTORITO_PLATFORM_EFI enumeration member
ELTORITO_PLATFORM_MAC enumeration member
ELTORITO_PLATFORM_POWERPC enumeration member
EN_ACCESS_TO_FEATURE_DENIED enumeration member
EN_BUFFER_TOO_SMALL enumeration member
EN_BUFFER_UNDERRUN enumeration member
EN_CACHE_IS_TOO_SMALL enumeration member
EN_CALL_IS_OBSOLETE enumeration member
EN_DEVICE_SHARING_VIOLATION enumeration member
EN_DPM_FAILED enumeration member
EN_ERROR_RECOVERY_FAILED enumeration member
EN_FAILURE enumeration member
EN_FILE_TOO_BIG enumeration member
EN_FULL_ERASE_REQUIRED enumeration member
EN_GENERAL_READ_ERROR enumeration member
EN_GENERAL_SEEK_ERROR enumeration member
EN_ILLEGAL_OPERATION_FOR_TRACK enumeration member
EN_INVALID_EXCEPTION enumeration member
EN_INVALID_FIELD_IN_CDB enumeration member
EN_INVALID_INPUT_PARAMETER enumeration member
EN_INVALID_RESPONSE enumeration member
EN_INVALID_STATE enumeration member
EN_MEMORY_ALLOCATION_FAILED enumeration member
EN_NOT_FOUND enumeration member
EN_NOT_IMPLEMENTED enumeration member
EN_PATH_TOO_LONG enumeration member
EN_RANGE enumeration member
EN_REGISTRATION_FAILED enumeration member
EN_REQUEST_TOO_LARGE enumeration member
EN_SCSI_CDB_FAILED enumeration member
EN_SCSI_DEVICE_BUSY enumeration member
EN_SCSI_DEVICE_INVALID_TYPE enumeration member
EN_SCSI_TRANSPORT_FAILED enumeration member
EN_SUCCESS enumeration member
EN_SYSTEM_CALL_FAILED enumeration member
EN_SYSTEM_CALL_FAILED_EX enumeration member
EN_UNDER_CONSTRUCTION enumeration member
EN_UNRECOGNIZED_MEDIA enumeration member
EN_UNSUPPORTED_AUDIO enumeration member
EN_UNSUPPORTED_READ_MODE enumeration member
EN_USER_EXCEPTION enumeration member
EN_VERIFY_FAILED enumeration member
EN_WRONG_OS_VERSION enumeration member
ERASE_TYPE
ERASE_TYPE enumeration
ERASE_TYPE_BLANK_DISC_FAST enumeration member
ERASE_TYPE_BLANK_DISC_FULL enumeration member
ERASE_TYPE_BLANK_SESSION enumeration member
ERASE_TYPE_BLANK_TRACK enumeration member
ERASE_TYPE_BLANK_TRACK_TAIL enumeration member
ERASE_TYPE_UNCLOSE_LAST_SESSION enumeration member
ERASE_TYPE_UNRESERVE_TRACK enumeration member
ERROR_FIELD_C2_AND_BLOCK_ERROR
ERROR_FIELD_C2_AND_BLOCK_ERROR macro
ERROR_FIELD_C2_ERROR
ERROR_FIELD_C2_ERROR macro
ERROR_FIELD_NO_ERROR
ERROR_FIELD_NO_ERROR macro
ERROR_FIELD_RESERVED
ERROR_FIELD_RESERVED macro
EXCEPTION_NUMBER
EXCEPTION_NUMBER enumeration
EXPECTED_LB_TYPE_ANY
EXPECTED_LB_TYPE_ANY macro
EXPECTED_LB_TYPE_CDDA
EXPECTED_LB_TYPE_CDDA macro
EXPECTED_LB_TYPE_MODE1
EXPECTED_LB_TYPE_MODE1 macro
EXPECTED_LB_TYPE_MODE2
EXPECTED_LB_TYPE_MODE2 macro
EXPECTED_LB_TYPE_MODE2_FORM1
EXPECTED_LB_TYPE_MODE2_FORM1 macro
EXPECTED_LB_TYPE_MODE2_FORM2
EXPECTED_LB_TYPE_MODE2_FORM2 macro
F
FILE_TIME
FILE_TIME enumeration
FILE_TIME_CREATION enumeration member
FILE_TIME_LAST_ACCESS enumeration member
FILE_TIME_LAST_WRITE enumeration member
FILE_TREE
FILE_TREE enumeration
FILE_TREE_ISO9660 enumeration member
FILE_TREE_JOLIET enumeration member
Files
FULL_TOC_ENTRY_RAW
FULL_TOC_ENTRY_RAW structure
Functions
H
HARD_DISK_LB_SIZE_IN_UCHARS
HARD_DISK_LB_SIZE_IN_UCHARS macro
HEADER_CODE_ALL_HEADERS
HEADER_CODE_ALL_HEADERS macro
HEADER_CODE_HEADER_ONLY
HEADER_CODE_HEADER_ONLY macro
HEADER_CODE_NONE
HEADER_CODE_NONE macro
HEADER_CODE_SUBHEADER_ONLY
HEADER_CODE_SUBHEADER_ONLY macro
I
Introduction
ISO9660_DATE_SIZE_IN_UCHARS
ISO9660_DATE_SIZE_IN_UCHARS macro
ISO9660_DATE_TIME
ISO9660_DATE_TIME structure
ISO9660_FILE_SIZE_IN_UCHARS
ISO9660_FILE_SIZE_IN_UCHARS macro
ISO9660_KIDTYPE
ISO9660_KIDTYPE enumeration
ISO9660_NAME_SIZE_IN_UCHARS
ISO9660_NAME_SIZE_IN_UCHARS macro
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS
ISO9660_SYSTEM_VOLUME_ID_SIZE_IN_UCHARS macro
ISO9660_TREE_LEVEL
ISO9660_TREE_LEVEL macro
K
KIDTYPE_FROMDISK enumeration member
KIDTYPE_IMPORTED enumeration member
KIDTYPE_UNKNOWN enumeration member
KIDTYPE_VIRTUAL enumeration member
L
LAST_SESSION_COMPLETE
LAST_SESSION_COMPLETE macro
LAST_SESSION_EMPTY
LAST_SESSION_EMPTY macro
LAST_SESSION_INCOMPLETE
LAST_SESSION_INCOMPLETE macro
M
Macros
MODE1_LB_SIZE_IN_UCHARS
MODE1_LB_SIZE_IN_UCHARS macro
MODE2_FORM1_LB_SIZE_IN_UCHARS
MODE2_FORM1_LB_SIZE_IN_UCHARS macro
MODE2_FORM2_LB_SIZE_IN_UCHARS
MODE2_FORM2_LB_SIZE_IN_UCHARS macro
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS
MODE2_FORM2_SUB_LB_SIZE_IN_UCHARS macro
MODE2_FORMLESS_LB_SIZE_IN_UCHARS
MODE2_FORMLESS_LB_SIZE_IN_UCHARS macro
N
NAME_COLLISION_FORCE_DWORD enumeration member
NAME_COLLISION_INFO
NAME_COLLISION_INFO structure
NAME_COLLISION_MERGE_FOLDERS enumeration member
NAME_COLLISION_RENAME_NEW enumeration member
NAME_COLLISION_REPLACE_OLD enumeration member
NAME_COLLISION_SKIP_NEW enumeration member
NAME_COLLISION_SOLUTION
NAME_COLLISION_SOLUTION enumeration
NUMBER_OF_RAW_TRACKS
NUMBER_OF_RAW_TRACKS macro
NUMBER_OF_READ_RETRIES
NUMBER_OF_READ_RETRIES macro
NUMBER_OF_SUBCHANNELS
NUMBER_OF_SUBCHANNELS macro
NUMBER_OF_TRACKS
NUMBER_OF_TRACKS macro
P
PAGE_SIZE_IN_UCHARS
PAGE_SIZE_IN_UCHARS macro
PCALLBACK
PCALLBACK type
PCALLBACK_NUMBER
PCALLBACK_NUMBER enumeration
PCDB_FAILURE_INFORMATION
PCDB_FAILURE_INFORMATION structure
PDAO_DISC_LAYOUT
PDAO_DISC_LAYOUT structure
PDAO_DISC_LAYOUT_ENTRY
PDAO_DISC_LAYOUT_ENTRY structure
PDISC_FILESYSTEM
PDISC_FILESYSTEM structure
PDISC_LAYOUT
PDISC_LAYOUT structure
PDISC_LAYOUT_ENTRY
PDISC_LAYOUT_ENTRY structure
PDISC_TYPE
PDISC_TYPE enumeration
PDVD_VIDEO_CONTROL_BLOCK
PDVD_VIDEO_CONTROL_BLOCK structure
PERASE_TYPE
PERASE_TYPE enumeration
PEXCEPTION_NUMBER
PEXCEPTION_NUMBER enumeration
PFILE_TIME
PFILE_TIME enumeration
PFILE_TREE
PFILE_TREE enumeration
PFULL_TOC_ENTRY_RAW
PFULL_TOC_ENTRY_RAW structure
PISO9660_DATE_TIME
PISO9660_DATE_TIME structure
PISO9660_KIDTYPE
PISO9660_KIDTYPE enumeration
PNAME_COLLISION_INFO
PNAME_COLLISION_INFO structure
PNAME_COLLISION_SOLUTION
PNAME_COLLISION_SOLUTION enumeration
PPQ_SUBCHANNEL
PPQ_SUBCHANNEL structure
PPSTARBURN_BDRE_FORMAT_PROFILE
PPSTARBURN_BDRE_FORMAT_PROFILE structure
PPSTARBURN_STARWAVE_CALLBACK_REASON
PPSTARBURN_STARWAVE_CALLBACK_REASON enumeration
PPSTARBURN_STARWAVE_COMPRESSION
PPSTARBURN_STARWAVE_COMPRESSION enumeration
PPSTARPORT_DEVICE_LIST
PPSTARPORT_DEVICE_LIST structure
PPSTARPORT_DEVICE_LIST_ENTRY
PPSTARPORT_DEVICE_LIST_ENTRY structure
PPSTARPORT_DEVICE_TYPE
PPSTARPORT_DEVICE_TYPE enumeration
PPSTARWAVE2_COMPRESSION
PPSTARWAVE2_COMPRESSION enumeration
PPSTARWAVE2_COMPRESSION_PROFILE
PPSTARWAVE2_COMPRESSION_PROFILE structure
PQ_SUBCHANNEL
PQ_SUBCHANNEL structure
PREAD_MODE
PREAD_MODE enumeration
PSCSI_DEVICE_ADDRESS
PSCSI_DEVICE_ADDRESS structure
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
PSTARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS structure
PSTARBURN_BDRE_FORMAT_PROFILE
PSTARBURN_BDRE_FORMAT_PROFILE structure
PSTARBURN_CD_MODE
PSTARBURN_CD_MODE enumeration
PSTARBURN_CLOSEHANDLE_CALLBACK
PSTARBURN_CLOSEHANDLE_CALLBACK type
PSTARBURN_CREATEFILE_CALLBACK
PSTARBURN_CREATEFILE_CALLBACK type
PSTARBURN_DELETEFILE_CALLBACK
PSTARBURN_DELETEFILE_CALLBACK type
PSTARBURN_DISC_ATIP_INFORMATION
PSTARBURN_DISC_ATIP_INFORMATION structure
PSTARBURN_DISC_INFORMATION
PSTARBURN_DISC_INFORMATION structure
PSTARBURN_FILE_OBJECT
PSTARBURN_FILE_OBJECT type
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK
PSTARBURN_FLUSH_FILE_BUFFERS_CALLBACK type
PSTARBURN_ISO2_COLLISION_CALLBACK
PSTARBURN_ISO2_COLLISION_CALLBACK type
PSTARBURN_ISO2_PROGRESS_CALLBACK
PSTARBURN_ISO2_PROGRESS_CALLBACK type
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK
PSTARBURN_ISO2_UNICODE_COLLISION_CALLBACK type
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK
PSTARBURN_ISO2_UNICODE_PROGRESS_CALLBACK type
PSTARBURN_ISO9660_READ_CALLBACK
PSTARBURN_ISO9660_READ_CALLBACK type
PSTARBURN_READFILE_CALLBACK
PSTARBURN_READFILE_CALLBACK type
PSTARBURN_SET_FILE_POINTER_CALLBACK
PSTARBURN_SET_FILE_POINTER_CALLBACK type
PSTARBURN_STARWAVE_CALLBACK
PSTARBURN_STARWAVE_CALLBACK type
PSTARBURN_STARWAVE_CALLBACK_REASON
PSTARBURN_STARWAVE_CALLBACK_REASON enumeration
PSTARBURN_STARWAVE_COMPRESSION
PSTARBURN_STARWAVE_COMPRESSION enumeration
PSTARBURN_STARWAVE2_CONVERSION_MODE
PSTARBURN_STARWAVE2_CONVERSION_MODE enumeration
PSTARBURN_STARWAVE2_INIT_PARAMS
PSTARBURN_STARWAVE2_INIT_PARAMS structure
PSTARBURN_STARWAVE2_QUALITY_MODE
PSTARBURN_STARWAVE2_QUALITY_MODE enumeration
PSTARBURN_TRACK_INFORMATION
PSTARBURN_TRACK_INFORMATION structure
PSTARBURN_TRACK_INFORMATION_EX
PSTARBURN_TRACK_INFORMATION_EX structure
PSTARBURN_UDF2_COLLISION_CALLBACK_EX
PSTARBURN_UDF2_COLLISION_CALLBACK_EX type
PSTARBURN_UDF2_IMPORT_CALLBACK
PSTARBURN_UDF2_IMPORT_CALLBACK type
PSTARBURN_UDF2_PROGRESS_CALLBACK
PSTARBURN_UDF2_PROGRESS_CALLBACK type
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX
PSTARBURN_UDF2_UNICODE_COLLISION_CALLBACK_EX type
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK
PSTARBURN_UDF2_UNICODE_PROGRESS_CALLBACK type
PSTARBURN_WRITEFILE_CALLBACK
PSTARBURN_WRITEFILE_CALLBACK type
PSTARPORT_DEVICE_LIST
PSTARPORT_DEVICE_LIST structure
PSTARPORT_DEVICE_LIST_ENTRY
PSTARPORT_DEVICE_LIST_ENTRY structure
PSTARPORT_DEVICE_TYPE
PSTARPORT_DEVICE_TYPE enumeration
PSTARWAVE2_COMPRESSION
PSTARWAVE2_COMPRESSION enumeration
PSTARWAVE2_COMPRESSION_PROFILE
PSTARWAVE2_COMPRESSION_PROFILE structure
PTOC_ENTRY
PTOC_ENTRY structure
PTOC_INFORMATION
PTOC_INFORMATION structure
PUDF_CONTROL_BLOCK
PUDF_CONTROL_BLOCK structure
PUDF_FILE_EXTENT
PUDF_FILE_EXTENT structure
PUDF_FILE_HANDLE
PUDF_FILE_HANDLE structure
PUDF_FILE_LOOKUP_ENTRY
PUDF_FILE_LOOKUP_ENTRY structure
PUDF_LOOKUP_DIR_ENTRY
PUDF_LOOKUP_DIR_ENTRY structure
PUDF_LOOKUP_FILE_ENTRY
PUDF_LOOKUP_FILE_ENTRY structure
PUDF_TREE_ITEM
PUDF_TREE_ITEM structure
PWAVE_FILE_HEADER
PWAVE_FILE_HEADER structure
PWAVE_FORMAT_CHUNK
PWAVE_FORMAT_CHUNK structure
PWRITE_MODE
PWRITE_MODE enumeration
R
RAW_LB_PQ_SUB_SIZE_IN_UCHARS
RAW_LB_PQ_SUB_SIZE_IN_UCHARS macro
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS
RAW_LB_RAW_PW_SUB_SIZE_IN_UCHARS macro
RAW_LB_SIZE_IN_UCHARS
RAW_LB_SIZE_IN_UCHARS macro
READ_MODE
READ_MODE enumeration
READ_MODE_COOKED enumeration member
READ_MODE_PQ enumeration member
READ_MODE_RAW enumeration member
READ_MODE_RAW_PQ enumeration member
READ_MODE_RAW_PW enumeration member
READ_MODE_RAW_RAW_PW enumeration member
READ_REPORT_DELAY_IN_SECONDS
READ_REPORT_DELAY_IN_SECONDS macro
S
SCSI_DEVICE_ADDRESS
SCSI_DEVICE_ADDRESS structure
SCSI_DEVICE_DIRECT_ACCESS
SCSI_DEVICE_DIRECT_ACCESS macro
SCSI_DEVICE_MAGNETO_OPTICAL
SCSI_DEVICE_MAGNETO_OPTICAL macro
SCSI_DEVICE_MEDIUM_CHANGER
SCSI_DEVICE_MEDIUM_CHANGER macro
SCSI_DEVICE_NETWORK
SCSI_DEVICE_NETWORK macro
SCSI_DEVICE_PRINTER
SCSI_DEVICE_PRINTER macro
SCSI_DEVICE_PROCESSOR
SCSI_DEVICE_PROCESSOR macro
SCSI_DEVICE_RO_DIRECT_ACCESS
SCSI_DEVICE_RO_DIRECT_ACCESS macro
SCSI_DEVICE_SCANNER
SCSI_DEVICE_SCANNER macro
SCSI_DEVICE_SEQUENTIAL_ACCESS
SCSI_DEVICE_SEQUENTIAL_ACCESS macro
SCSI_DEVICE_UNPRESENT
SCSI_DEVICE_UNPRESENT macro
SCSI_DEVICE_WILDCARD
SCSI_DEVICE_WILDCARD macro
SCSI_DEVICE_WORM
SCSI_DEVICE_WORM macro
SHORT_RAW_LB_SIZE_IN_UCHARS
SHORT_RAW_LB_SIZE_IN_UCHARS macro
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS
SINGLE_LAYER_DVD_CAPACITY_SIZE_IN_LBS macro
SMALLEST_CACHE_SIZE_IN_MBS
SMALLEST_CACHE_SIZE_IN_MBS macro
SMALLEST_CACHE_SIZE_IN_UCHARS
SMALLEST_CACHE_SIZE_IN_UCHARS macro
StarBurn.h
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS
STARBURN_ADVANCED_SUPPORTED_MEDIA_FORMATS structure
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL
STARBURN_BDRE_FORMAT_CERTIFICATION_FULL macro
STARBURN_BDRE_FORMAT_CERTIFICATION_NO
STARBURN_BDRE_FORMAT_CERTIFICATION_NO macro
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK
STARBURN_BDRE_FORMAT_CERTIFICATION_QUICK macro
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED
STARBURN_BDRE_FORMAT_CERTIFICATION_RESERVED macro
STARBURN_BDRE_FORMAT_DEFAULT
STARBURN_BDRE_FORMAT_DEFAULT macro
STARBURN_BDRE_FORMAT_PROFILE
STARBURN_BDRE_FORMAT_PROFILE structure
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION
STARBURN_BDRE_FORMAT_SPARE_AREA_EXPANSION macro
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA
STARBURN_BDRE_FORMAT_WITH_SPARE_AREA macro
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA
STARBURN_BDRE_FORMAT_WITHOUT_SPARE_AREA macro
STARBURN_CACHE_SIZE_READ_ONLY
STARBURN_CACHE_SIZE_READ_ONLY macro
STARBURN_CACHE_SIZE_READ_WRITE
STARBURN_CACHE_SIZE_READ_WRITE macro
STARBURN_CD_MODE
STARBURN_CD_MODE enumeration
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED
STARBURN_CDFS2_FILE_ATTRIBUTE_DELETED macro
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY
STARBURN_CDFS2_FILE_ATTRIBUTE_DIRECTORY macro
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN
STARBURN_CDFS2_FILE_ATTRIBUTE_HIDDEN macro
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED
STARBURN_CDFS2_FILE_ATTRIBUTE_IMPORTED macro
StarBurn_CdvdBurnerGrabber_AuthorizeDVD
StarBurn_CdvdBurnerGrabber_AuthorizeDVD function
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx
StarBurn_CdvdBurnerGrabber_AuthorizeDVDEx function
StarBurn_CdvdBurnerGrabber_Blank
StarBurn_CdvdBurnerGrabber_Blank function
StarBurn_CdvdBurnerGrabber_BluRayFormat
StarBurn_CdvdBurnerGrabber_BluRayFormat function
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery
StarBurn_CdvdBurnerGrabber_BluRayFormatQuery function
StarBurn_CdvdBurnerGrabber_Cancel
StarBurn_CdvdBurnerGrabber_Cancel function
StarBurn_CdvdBurnerGrabber_CloseSession
StarBurn_CdvdBurnerGrabber_CloseSession function
StarBurn_CdvdBurnerGrabber_Create
StarBurn_CdvdBurnerGrabber_Create function
StarBurn_CdvdBurnerGrabber_CreateEx
StarBurn_CdvdBurnerGrabber_CreateEx function
StarBurn_CdvdBurnerGrabber_CreateExEx
StarBurn_CdvdBurnerGrabber_CreateExEx function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFile function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileT macro
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromFileUnicode function
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree
StarBurn_CdvdBurnerGrabber_DiscAtOncePQFromTree function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFile function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileAudioUnicode function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileT macro
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromFileUnicode function
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree
StarBurn_CdvdBurnerGrabber_DiscAtOnceRawPWFromTree function
StarBurn_CdvdBurnerGrabber_Eject
StarBurn_CdvdBurnerGrabber_Eject function
StarBurn_CdvdBurnerGrabber_ExecuteGeneric
StarBurn_CdvdBurnerGrabber_ExecuteGeneric function
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats
StarBurn_CdvdBurnerGrabber_GetAdvancedSupportedMediaFormats function
StarBurn_CdvdBurnerGrabber_GetBUP
StarBurn_CdvdBurnerGrabber_GetBUP function
StarBurn_CdvdBurnerGrabber_GetDeviceInformation
StarBurn_CdvdBurnerGrabber_GetDeviceInformation function
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT
StarBurn_CdvdBurnerGrabber_GetDeviceInformationT macro
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode
StarBurn_CdvdBurnerGrabber_GetDeviceInformationUnicode function
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem
StarBurn_CdvdBurnerGrabber_GetDiscFileSystem function
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace
StarBurn_CdvdBurnerGrabber_GetDiscFreeSpace function
StarBurn_CdvdBurnerGrabber_GetDiscInformation
StarBurn_CdvdBurnerGrabber_GetDiscInformation function
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace
StarBurn_CdvdBurnerGrabber_GetDiscUsedSpace function
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem
StarBurn_CdvdBurnerGrabber_GetDVDProtectionSystem function
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask
StarBurn_CdvdBurnerGrabber_GetDVDRegionMask function
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType
StarBurn_CdvdBurnerGrabber_GetInsertedDiscType function
StarBurn_CdvdBurnerGrabber_GetLastAddress
StarBurn_CdvdBurnerGrabber_GetLastAddress function
StarBurn_CdvdBurnerGrabber_GetLastTrack
StarBurn_CdvdBurnerGrabber_GetLastTrack function
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions
StarBurn_CdvdBurnerGrabber_GetMechanicalOptions function
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus
StarBurn_CdvdBurnerGrabber_GetMediaTrayStatus function
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors
StarBurn_CdvdBurnerGrabber_GetNumberOfSystemDescriptors function
StarBurn_CdvdBurnerGrabber_GetRPC
StarBurn_CdvdBurnerGrabber_GetRPC function
StarBurn_CdvdBurnerGrabber_GetSpeeds
StarBurn_CdvdBurnerGrabber_GetSpeeds function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormats function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsEx function
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx
StarBurn_CdvdBurnerGrabber_GetSupportedMediaFormatsExEx function
StarBurn_CdvdBurnerGrabber_GetTOCInformation
StarBurn_CdvdBurnerGrabber_GetTOCInformation function
StarBurn_CdvdBurnerGrabber_GetTrackInformation
StarBurn_CdvdBurnerGrabber_GetTrackInformation function
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx
StarBurn_CdvdBurnerGrabber_GetTrackInformationEx function
StarBurn_CdvdBurnerGrabber_GrabCD
StarBurn_CdvdBurnerGrabber_GrabCD function
StarBurn_CdvdBurnerGrabber_GrabDVD
StarBurn_CdvdBurnerGrabber_GrabDVD function
StarBurn_CdvdBurnerGrabber_GrabDVDEx
StarBurn_CdvdBurnerGrabber_GrabDVDEx function
StarBurn_CdvdBurnerGrabber_GrabDVDFast
StarBurn_CdvdBurnerGrabber_GrabDVDFast function
StarBurn_CdvdBurnerGrabber_GrabRange
StarBurn_CdvdBurnerGrabber_GrabRange function
StarBurn_CdvdBurnerGrabber_GrabTrack
StarBurn_CdvdBurnerGrabber_GrabTrack function
StarBurn_CdvdBurnerGrabber_GrabTrackEx
StarBurn_CdvdBurnerGrabber_GrabTrackEx function
StarBurn_CdvdBurnerGrabber_GrabTrackT
StarBurn_CdvdBurnerGrabber_GrabTrackT macro
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode
StarBurn_CdvdBurnerGrabber_GrabTrackUnicode function
StarBurn_CdvdBurnerGrabber_IsDiscBlank
StarBurn_CdvdBurnerGrabber_IsDiscBlank function
StarBurn_CdvdBurnerGrabber_Load
StarBurn_CdvdBurnerGrabber_Load function
StarBurn_CdvdBurnerGrabber_LoadEx
StarBurn_CdvdBurnerGrabber_LoadEx function
StarBurn_CdvdBurnerGrabber_Lock
StarBurn_CdvdBurnerGrabber_Lock function
StarBurn_CdvdBurnerGrabber_MSFToLBA
StarBurn_CdvdBurnerGrabber_MSFToLBA function
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes
StarBurn_CdvdBurnerGrabber_ProbeSupportedReadModes function
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes
StarBurn_CdvdBurnerGrabber_ProbeSupportedWriteModes function
StarBurn_CdvdBurnerGrabber_ReadATIP
StarBurn_CdvdBurnerGrabber_ReadATIP function
StarBurn_CdvdBurnerGrabber_ReadCooked
StarBurn_CdvdBurnerGrabber_ReadCooked function
StarBurn_CdvdBurnerGrabber_ReadLB
StarBurn_CdvdBurnerGrabber_ReadLB function
StarBurn_CdvdBurnerGrabber_ReadRaw
StarBurn_CdvdBurnerGrabber_ReadRaw function
StarBurn_CdvdBurnerGrabber_Release
StarBurn_CdvdBurnerGrabber_Release function
StarBurn_CdvdBurnerGrabber_SendOPC
StarBurn_CdvdBurnerGrabber_SendOPC function
StarBurn_CdvdBurnerGrabber_SessionAtOnce
StarBurn_CdvdBurnerGrabber_SessionAtOnce function
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPW function
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWT macro
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode
StarBurn_CdvdBurnerGrabber_SessionAtOnceRawRawPWUnicode function
StarBurn_CdvdBurnerGrabber_SessionAtOnceT
StarBurn_CdvdBurnerGrabber_SessionAtOnceT macro
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode
StarBurn_CdvdBurnerGrabber_SessionAtOnceUnicode function
StarBurn_CdvdBurnerGrabber_SetBUP
StarBurn_CdvdBurnerGrabber_SetBUP function
StarBurn_CdvdBurnerGrabber_SetCDTextItem
StarBurn_CdvdBurnerGrabber_SetCDTextItem function
StarBurn_CdvdBurnerGrabber_SetReadSpeed
StarBurn_CdvdBurnerGrabber_SetReadSpeed function
StarBurn_CdvdBurnerGrabber_SetSpeeds
StarBurn_CdvdBurnerGrabber_SetSpeeds function
StarBurn_CdvdBurnerGrabber_StopPlayScan
StarBurn_CdvdBurnerGrabber_StopPlayScan function
StarBurn_CdvdBurnerGrabber_SuperVideoCD
StarBurn_CdvdBurnerGrabber_SuperVideoCD function
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx
StarBurn_CdvdBurnerGrabber_SuperVideoCDEx function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx
StarBurn_CdvdBurnerGrabber_SuperVideoCDExEx function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExT macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode
StarBurn_CdvdBurnerGrabber_SuperVideoCDExExUnicode function
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT
StarBurn_CdvdBurnerGrabber_SuperVideoCDExT macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode
StarBurn_CdvdBurnerGrabber_SuperVideoCDExUnicode function
StarBurn_CdvdBurnerGrabber_SuperVideoCDT
StarBurn_CdvdBurnerGrabber_SuperVideoCDT macro
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode
StarBurn_CdvdBurnerGrabber_SuperVideoCDUnicode function
StarBurn_CdvdBurnerGrabber_TestUnitReady
StarBurn_CdvdBurnerGrabber_TestUnitReady function
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx
StarBurn_CdvdBurnerGrabber_TestUnitReadyEx function
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx
StarBurn_CdvdBurnerGrabber_TestUnitReadyExEx function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFile function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicode function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileAudioUnicodeEx function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileEx function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileT macro
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromFileUnicode function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemory function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromMemoryEx function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipe function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromPipeEx function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTree function
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx
StarBurn_CdvdBurnerGrabber_TrackAtOnceFromTreeEx function
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookup function
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx
StarBurn_CdvdBurnerGrabber_UDFFileSystemLookupEx function
StarBurn_CdvdBurnerGrabber_VerifyFile
StarBurn_CdvdBurnerGrabber_VerifyFile function
StarBurn_CdvdBurnerGrabber_VerifyFileEx
StarBurn_CdvdBurnerGrabber_VerifyFileEx function
StarBurn_CdvdBurnerGrabber_VerifyFileExT
StarBurn_CdvdBurnerGrabber_VerifyFileExT macro
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode
StarBurn_CdvdBurnerGrabber_VerifyFileExUnicode function
StarBurn_CdvdBurnerGrabber_VerifyFileT
StarBurn_CdvdBurnerGrabber_VerifyFileT macro
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode
StarBurn_CdvdBurnerGrabber_VerifyFileUnicode function
StarBurn_CdvdBurnerGrabber_VerifyTree
StarBurn_CdvdBurnerGrabber_VerifyTree function
StarBurn_CdvdBurnerGrabber_VerifyTreeEx
StarBurn_CdvdBurnerGrabber_VerifyTreeEx function
StarBurn_CdvdBurnerGrabber_VideoCD
StarBurn_CdvdBurnerGrabber_VideoCD function
StarBurn_CdvdBurnerGrabber_VideoCDEx
StarBurn_CdvdBurnerGrabber_VideoCDEx function
StarBurn_CdvdBurnerGrabber_VideoCDExEx
StarBurn_CdvdBurnerGrabber_VideoCDExEx function
StarBurn_CdvdBurnerGrabber_VideoCDExExT
StarBurn_CdvdBurnerGrabber_VideoCDExExT macro
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode
StarBurn_CdvdBurnerGrabber_VideoCDExExUnicode function
StarBurn_CdvdBurnerGrabber_VideoCDExT
StarBurn_CdvdBurnerGrabber_VideoCDExT macro
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode
StarBurn_CdvdBurnerGrabber_VideoCDExUnicode function
StarBurn_CdvdBurnerGrabber_VideoCDT
StarBurn_CdvdBurnerGrabber_VideoCDT macro
StarBurn_CdvdBurnerGrabber_VideoCDUnicode
StarBurn_CdvdBurnerGrabber_VideoCDUnicode function
StarBurn_CorrectISO9660Name_Default
StarBurn_CorrectISO9660Name_Default function
StarBurn_CorrectJolietName_Default
StarBurn_CorrectJolietName_Default function
StarBurn_CreatePipe
StarBurn_CreatePipe function
STARBURN_DEBUG_FACILITY_ALLMESSAGES
STARBURN_DEBUG_FACILITY_ALLMESSAGES macro
STARBURN_DEBUG_FACILITY_ALLTARGETS
STARBURN_DEBUG_FACILITY_ALLTARGETS macro
STARBURN_DEBUG_FACILITY_CUSTOM
STARBURN_DEBUG_FACILITY_CUSTOM macro
STARBURN_DEBUG_FACILITY_DEBUG
STARBURN_DEBUG_FACILITY_DEBUG macro
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT
STARBURN_DEBUG_FACILITY_DEBUG_OUTPUT macro
STARBURN_DEBUG_FACILITY_ERROR
STARBURN_DEBUG_FACILITY_ERROR macro
STARBURN_DEBUG_FACILITY_LOG_FILE
STARBURN_DEBUG_FACILITY_LOG_FILE macro
STARBURN_DEBUG_FACILITY_NONE
STARBURN_DEBUG_FACILITY_NONE macro
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE
STARBURN_DEBUG_FACILITY_SYSTEM_CONSOLE macro
STARBURN_DEBUG_FACILITY_TRACE
STARBURN_DEBUG_FACILITY_TRACE macro
STARBURN_DEBUG_FACILITY_WARNING
STARBURN_DEBUG_FACILITY_WARNING macro
StarBurn_Destroy
StarBurn_Destroy function
StarBurn_DestroyPipe
StarBurn_DestroyPipe function
STARBURN_DISC_ATIP_INFORMATION
STARBURN_DISC_ATIP_INFORMATION structure
STARBURN_DISC_INFORMATION
STARBURN_DISC_INFORMATION structure
STARBURN_DISC_TYPE_CDDA
STARBURN_DISC_TYPE_CDDA macro
STARBURN_DISC_TYPE_CDI
STARBURN_DISC_TYPE_CDI macro
STARBURN_DISC_TYPE_UNDEFINED
STARBURN_DISC_TYPE_UNDEFINED macro
STARBURN_DISC_TYPE_XA
STARBURN_DISC_TYPE_XA macro
StarBurn_DownShut
StarBurn_DownShut function
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES
STARBURN_DVD_VIDEO_MAX_NUMBER_OF_TITLES macro
StarBurn_DVDVideo_Create
StarBurn_DVDVideo_Create function
StarBurn_DVDVideo_CreateT
StarBurn_DVDVideo_CreateT macro
StarBurn_DVDVideo_CreateUnicode
StarBurn_DVDVideo_CreateUnicode function
StarBurn_DVDVideo_Destroy
StarBurn_DVDVideo_Destroy function
StarBurn_DVDVideo_GetSizeInUCHARs
StarBurn_DVDVideo_GetSizeInUCHARs function
StarBurn_DVDVideo_GetTreePointer
StarBurn_DVDVideo_GetTreePointer function
StarBurn_DVDVideo_PatchHeader
StarBurn_DVDVideo_PatchHeader function
StarBurn_DVDVideo_PatchTable
StarBurn_DVDVideo_PatchTable function
StarBurn_DVDVideo_Read
StarBurn_DVDVideo_Read function
StarBurn_DVDVideo_SeekToBegin
StarBurn_DVDVideo_SeekToBegin function
StarBurn_ElTorito_BootCatalogAddSection
StarBurn_ElTorito_BootCatalogAddSection function
StarBurn_ElTorito_BootCatalogAddSectionT
StarBurn_ElTorito_BootCatalogAddSectionT macro
StarBurn_ElTorito_BootCatalogAddSectionUnicode
StarBurn_ElTorito_BootCatalogAddSectionUnicode function
StarBurn_ElTorito_CreateBootCatalog
StarBurn_ElTorito_CreateBootCatalog function
StarBurn_ElTorito_CreateBootCatalogT
StarBurn_ElTorito_CreateBootCatalogT macro
StarBurn_ElTorito_CreateBootCatalogUnicode
StarBurn_ElTorito_CreateBootCatalogUnicode function
STARBURN_ELTORITO_MEDIA
STARBURN_ELTORITO_MEDIA enumeration
STARBURN_ELTORITO_PLATFORM
STARBURN_ELTORITO_PLATFORM enumeration
StarBurn_FileClose
StarBurn_FileClose function
StarBurn_FileCreate
StarBurn_FileCreate function
StarBurn_FileInitialize
StarBurn_FileInitialize function
StarBurn_FileOpen
StarBurn_FileOpen function
StarBurn_FileOpenEx
StarBurn_FileOpenEx function
StarBurn_FileRead
StarBurn_FileRead function
StarBurn_FileReWind
StarBurn_FileReWind function
StarBurn_FileSeek
StarBurn_FileSeek function
StarBurn_FileSeekRead
StarBurn_FileSeekRead function
StarBurn_FileSizeInUCHARsGet
StarBurn_FileSizeInUCHARsGet function
StarBurn_FileUnicodeCreate
StarBurn_FileUnicodeCreate function
StarBurn_FileUnicodeOpen
StarBurn_FileUnicodeOpen function
StarBurn_FileUnicodeOpenEx
StarBurn_FileUnicodeOpenEx function
StarBurn_FileWrite
StarBurn_FileWrite function
StarBurn_FindDevice
StarBurn_FindDevice function
StarBurn_GetAudioFileStreamSizeInUCHARs
StarBurn_GetAudioFileStreamSizeInUCHARs function
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast
StarBurn_GetAudioFileStreamSizeInUCHARs_Fast function
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT
StarBurn_GetAudioFileStreamSizeInUCHARs_FastT macro
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast
StarBurn_GetAudioFileStreamSizeInUCHARs_UnicodeFast function
StarBurn_GetAudioFileStreamSizeInUCHARsT
StarBurn_GetAudioFileStreamSizeInUCHARsT macro
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode
StarBurn_GetAudioFileStreamSizeInUCHARsUnicode function
StarBurn_GetBufferUnderrunTimeOutInMs
StarBurn_GetBufferUnderrunTimeOutInMs function
StarBurn_GetDeviceLetter
StarBurn_GetDeviceLetter function
StarBurn_GetDeviceLetterT
StarBurn_GetDeviceLetterT macro
StarBurn_GetDeviceLetterUnicode
StarBurn_GetDeviceLetterUnicode function
StarBurn_GetDeviceNameByDeviceAddress
StarBurn_GetDeviceNameByDeviceAddress function
StarBurn_GetDeviceTimeOutByDeviceAddress
StarBurn_GetDeviceTimeOutByDeviceAddress function
StarBurn_GetDVDPadding
StarBurn_GetDVDPadding function
StarBurn_GetDVDPLUSRDLCompatibleMode
StarBurn_GetDVDPLUSRDLCompatibleMode function
StarBurn_GetEjectAfterFail
StarBurn_GetEjectAfterFail function
StarBurn_GetFastReadTOC
StarBurn_GetFastReadTOC function
StarBurn_GetId
StarBurn_GetId function
StarBurn_GetIs64KBIO
StarBurn_GetIs64KBIO function
StarBurn_GetIsCollisionDetectionDisabled
StarBurn_GetIsCollisionDetectionDisabled function
StarBurn_GetIsSafeGrabbingEnabled
StarBurn_GetIsSafeGrabbingEnabled function
StarBurn_GetVersion
StarBurn_GetVersion function
StarBurn_GetVolumeIDs
StarBurn_GetVolumeIDs function
StarBurn_ImageFile_UDFFileSystemLookup
StarBurn_ImageFile_UDFFileSystemLookup function
StarBurn_ImageFile_UDFFileSystemLookupEx
StarBurn_ImageFile_UDFFileSystemLookupEx function
STARBURN_IMPEX_API
STARBURN_IMPEX_API macro
StarBurn_IsAudioFileSupported
StarBurn_IsAudioFileSupported function
StarBurn_IsAudioFileSupportedT
StarBurn_IsAudioFileSupportedT macro
StarBurn_IsAudioFileSupportedUnicode
StarBurn_IsAudioFileSupportedUnicode function
StarBurn_IsLocalDateTimeUsed
StarBurn_IsLocalDateTimeUsed function
StarBurn_ISO2_Check1999Name
StarBurn_ISO2_Check1999Name function
StarBurn_ISO2_CheckJolietName
StarBurn_ISO2_CheckJolietName function
StarBurn_ISO2_CheckLevel1Name
StarBurn_ISO2_CheckLevel1Name function
StarBurn_ISO2_CheckLevel2Name
StarBurn_ISO2_CheckLevel2Name function
StarBurn_ISO2_CheckRelaxedJolietName
StarBurn_ISO2_CheckRelaxedJolietName function
StarBurn_ISO2_CreateNewName
StarBurn_ISO2_CreateNewName function
StarBurn_ISO2_DirectoryBrowse
StarBurn_ISO2_DirectoryBrowse function
StarBurn_ISO2_DirectoryCreate
StarBurn_ISO2_DirectoryCreate function
StarBurn_ISO2_DirectoryDestroy
StarBurn_ISO2_DirectoryDestroy function
StarBurn_ISO2_DirectoryProcess
StarBurn_ISO2_DirectoryProcess function
StarBurn_ISO2_DirectoryQuery
StarBurn_ISO2_DirectoryQuery function
StarBurn_ISO2_DirectoryRootCreate
StarBurn_ISO2_DirectoryRootCreate function
StarBurn_ISO2_DirectoryUnicodeCreate
StarBurn_ISO2_DirectoryUnicodeCreate function
StarBurn_ISO2_DirectoryUnicodeProcess
StarBurn_ISO2_DirectoryUnicodeProcess function
StarBurn_ISO2_FileCreate
StarBurn_ISO2_FileCreate function
StarBurn_ISO2_FileDestroy
StarBurn_ISO2_FileDestroy function
StarBurn_ISO2_FileDirectoryDateTimeGet
StarBurn_ISO2_FileDirectoryDateTimeGet function
StarBurn_ISO2_FileDirectoryDateTimeSet
StarBurn_ISO2_FileDirectoryDateTimeSet function
StarBurn_ISO2_FileDirectoryNameSet
StarBurn_ISO2_FileDirectoryNameSet function
StarBurn_ISO2_FileDirectoryUnicodeNameSet
StarBurn_ISO2_FileDirectoryUnicodeNameSet function
StarBurn_ISO2_FileMemoryCreate
StarBurn_ISO2_FileMemoryCreate function
StarBurn_ISO2_FileMemoryUnicodeCreate
StarBurn_ISO2_FileMemoryUnicodeCreate function
StarBurn_ISO2_FileQuery
StarBurn_ISO2_FileQuery function
StarBurn_ISO2_FileSetAttributes
StarBurn_ISO2_FileSetAttributes function
StarBurn_ISO2_FileUnicodeCreate
StarBurn_ISO2_FileUnicodeCreate function
StarBurn_ISO2_ImpVolumeCreate
StarBurn_ISO2_ImpVolumeCreate function
StarBurn_ISO2_ImpVolumeDestroy
StarBurn_ISO2_ImpVolumeDestroy function
StarBurn_ISO2_ImpVolumeImport
StarBurn_ISO2_ImpVolumeImport function
StarBurn_ISO2_ISO9660FileTreeCreate
StarBurn_ISO2_ISO9660FileTreeCreate function
StarBurn_ISO2_VolumeCreate
StarBurn_ISO2_VolumeCreate function
StarBurn_ISO2_VolumeCreateBoot
StarBurn_ISO2_VolumeCreateBoot function
StarBurn_ISO2_VolumeCreateBootElTorito
StarBurn_ISO2_VolumeCreateBootElTorito function
StarBurn_ISO2_VolumeCreateBootElToritoT
StarBurn_ISO2_VolumeCreateBootElToritoT macro
StarBurn_ISO2_VolumeCreateEx
StarBurn_ISO2_VolumeCreateEx function
StarBurn_ISO2_VolumeCreateExBoot
StarBurn_ISO2_VolumeCreateExBoot function
StarBurn_ISO2_VolumeCreateUnicode
StarBurn_ISO2_VolumeCreateUnicode function
StarBurn_ISO2_VolumeCreateUnicodeBoot
StarBurn_ISO2_VolumeCreateUnicodeBoot function
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito
StarBurn_ISO2_VolumeCreateUnicodeBootElTorito function
StarBurn_ISO2_VolumeDescriptorsBufferGet
StarBurn_ISO2_VolumeDescriptorsBufferGet function
StarBurn_ISO2_VolumeDestroy
StarBurn_ISO2_VolumeDestroy function
StarBurn_ISO2_VolumeSeekRead
StarBurn_ISO2_VolumeSeekRead function
StarBurn_ISO2_VolumeSizeInUCHARsGet
StarBurn_ISO2_VolumeSizeInUCHARsGet function
STARBURN_ISO9660_DIRECTORY_INFO
STARBURN_ISO9660_DIRECTORY_INFO structure
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE
STARBURN_ISO9660_FILE_FLAGS_ASSOCIATED_FILE macro
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY
STARBURN_ISO9660_FILE_FLAGS_DIRECTORY macro
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE
STARBURN_ISO9660_FILE_FLAGS_EXISTENCE macro
STARBURN_ISO9660_FILE_FLAGS_NONE
STARBURN_ISO9660_FILE_FLAGS_NONE macro
STARBURN_ISO9660_FILE_FLAGS_RECORD
STARBURN_ISO9660_FILE_FLAGS_RECORD macro
STARBURN_ISO9660_FILE_INFO
STARBURN_ISO9660_FILE_INFO structure
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS
STARBURN_ISO9660_FILE_MAX_SIZE_IN_UCHARS macro
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS
STARBURN_ISO9660_JOLIET_NAME_SIZE_IN_WCHARS macro
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS
STARBURN_ISO9660_JOLIET_RELAXED_NAME_SIZE_IN_WCHARS macro
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS
STARBURN_ISO9660_NAME_SIZE_IN_SYMBOLS macro
STARBURN_ISO9660_TYPE_1999
STARBURN_ISO9660_TYPE_1999 macro
STARBURN_ISO9660_TYPE_JOLIET
STARBURN_ISO9660_TYPE_JOLIET macro
STARBURN_ISO9660_TYPE_JOLIET_RELAXED
STARBURN_ISO9660_TYPE_JOLIET_RELAXED macro
STARBURN_ISO9660_TYPE_LEVEL1
STARBURN_ISO9660_TYPE_LEVEL1 macro
STARBURN_ISO9660_TYPE_LEVEL2
STARBURN_ISO9660_TYPE_LEVEL2 macro
StarBurn_ISO9660JolietFileTree_Add
StarBurn_ISO9660JolietFileTree_Add function
StarBurn_ISO9660JolietFileTree_AddEx
StarBurn_ISO9660JolietFileTree_AddEx function
StarBurn_ISO9660JolietFileTree_AddMemory
StarBurn_ISO9660JolietFileTree_AddMemory function
StarBurn_ISO9660JolietFileTree_AddW
StarBurn_ISO9660JolietFileTree_AddW function
StarBurn_ISO9660JolietFileTree_AddZeroFile
StarBurn_ISO9660JolietFileTree_AddZeroFile function
StarBurn_ISO9660JolietFileTree_BuildImage
StarBurn_ISO9660JolietFileTree_BuildImage function
StarBurn_ISO9660JolietFileTree_BuildImageEx
StarBurn_ISO9660JolietFileTree_BuildImageEx function
StarBurn_ISO9660JolietFileTree_Cancel
StarBurn_ISO9660JolietFileTree_Cancel function
StarBurn_ISO9660JolietFileTree_Create
StarBurn_ISO9660JolietFileTree_Create function
StarBurn_ISO9660JolietFileTree_GetAttributes
StarBurn_ISO9660JolietFileTree_GetAttributes function
StarBurn_ISO9660JolietFileTree_GetAutoSorting
StarBurn_ISO9660JolietFileTree_GetAutoSorting function
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs
StarBurn_ISO9660JolietFileTree_GetFileSizeInUCHARs function
StarBurn_ISO9660JolietFileTree_GetFirstKid
StarBurn_ISO9660JolietFileTree_GetFirstKid function
StarBurn_ISO9660JolietFileTree_GetFullPath
StarBurn_ISO9660JolietFileTree_GetFullPath function
StarBurn_ISO9660JolietFileTree_GetKidType
StarBurn_ISO9660JolietFileTree_GetKidType function
StarBurn_ISO9660JolietFileTree_GetLevel
StarBurn_ISO9660JolietFileTree_GetLevel function
StarBurn_ISO9660JolietFileTree_GetNames
StarBurn_ISO9660JolietFileTree_GetNames function
StarBurn_ISO9660JolietFileTree_GetNamesEx
StarBurn_ISO9660JolietFileTree_GetNamesEx function
StarBurn_ISO9660JolietFileTree_GetNamesW
StarBurn_ISO9660JolietFileTree_GetNamesW function
StarBurn_ISO9660JolietFileTree_GetNextKid
StarBurn_ISO9660JolietFileTree_GetNextKid function
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime
StarBurn_ISO9660JolietFileTree_GetNodeISO9660DateTime function
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs
StarBurn_ISO9660JolietFileTree_GetNodePowerInUCHARs function
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA
StarBurn_ISO9660JolietFileTree_GetNodeStartingLBA function
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime
StarBurn_ISO9660JolietFileTree_GetNodeSystemTime function
StarBurn_ISO9660JolietFileTree_GetParent
StarBurn_ISO9660JolietFileTree_GetParent function
StarBurn_ISO9660JolietFileTree_GetRoot
StarBurn_ISO9660JolietFileTree_GetRoot function
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs
StarBurn_ISO9660JolietFileTree_GetSizeInUCHARs function
StarBurn_ISO9660JolietFileTree_ImportFile
StarBurn_ISO9660JolietFileTree_ImportFile function
StarBurn_ISO9660JolietFileTree_ImportTrack
StarBurn_ISO9660JolietFileTree_ImportTrack function
StarBurn_ISO9660JolietFileTree_Read
StarBurn_ISO9660JolietFileTree_Read function
StarBurn_ISO9660JolietFileTree_Remove
StarBurn_ISO9660JolietFileTree_Remove function
StarBurn_ISO9660JolietFileTree_SeekToBegin
StarBurn_ISO9660JolietFileTree_SeekToBegin function
StarBurn_ISO9660JolietFileTree_SetAttributes
StarBurn_ISO9660JolietFileTree_SetAttributes function
StarBurn_ISO9660JolietFileTree_SetAutoSorting
StarBurn_ISO9660JolietFileTree_SetAutoSorting function
StarBurn_ISO9660JolietFileTree_SetBootImage
StarBurn_ISO9660JolietFileTree_SetBootImage function
StarBurn_ISO9660JolietFileTree_SetBootImageEx
StarBurn_ISO9660JolietFileTree_SetBootImageEx function
StarBurn_ISO9660JolietFileTree_SetNames
StarBurn_ISO9660JolietFileTree_SetNames function
STARBURN_LOADING_MECHANISM_TYPE_CADDY
STARBURN_LOADING_MECHANISM_TYPE_CADDY macro
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE
STARBURN_LOADING_MECHANISM_TYPE_CARTRIDGE macro
STARBURN_LOADING_MECHANISM_TYPE_CHANGER
STARBURN_LOADING_MECHANISM_TYPE_CHANGER macro
STARBURN_LOADING_MECHANISM_TYPE_POP_UP
STARBURN_LOADING_MECHANISM_TYPE_POP_UP macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1
STARBURN_LOADING_MECHANISM_TYPE_RESERVED1 macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2
STARBURN_LOADING_MECHANISM_TYPE_RESERVED2 macro
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3
STARBURN_LOADING_MECHANISM_TYPE_RESERVED3 macro
STARBURN_LOADING_MECHANISM_TYPE_TRAY
STARBURN_LOADING_MECHANISM_TYPE_TRAY macro
STARBURN_PIPE_SIZE_IN_UCHARS
STARBURN_PIPE_SIZE_IN_UCHARS macro
StarBurn_SetBufferUnderrunTimeOutInMs
StarBurn_SetBufferUnderrunTimeOutInMs function
StarBurn_SetDeviceTimeOutByDeviceAddress
StarBurn_SetDeviceTimeOutByDeviceAddress function
StarBurn_SetDVDPadding
StarBurn_SetDVDPadding function
StarBurn_SetDVDPLUSRDLCompatibleMode
StarBurn_SetDVDPLUSRDLCompatibleMode function
StarBurn_SetEjectAfterFail
StarBurn_SetEjectAfterFail function
StarBurn_SetFastReadTOC
StarBurn_SetFastReadTOC function
StarBurn_SetIs64KBIO
StarBurn_SetIs64KBIO function
StarBurn_SetIsCollisionDetectionDisabled
StarBurn_SetIsCollisionDetectionDisabled function
StarBurn_SetIsSafeGrabbingEnabled
StarBurn_SetIsSafeGrabbingEnabled function
StarBurn_SetUsingLocalDateTime
StarBurn_SetUsingLocalDateTime function
StarBurn_SetUsingUTCDateTime
StarBurn_SetUsingUTCDateTime function
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS
STARBURN_SMALLEST_SPLIT_FILE_SIZE_IN_MBS macro
StarBurn_sprintf_s
StarBurn_sprintf_s function
StarBurn_SPTD_GetVersion
StarBurn_SPTD_GetVersion function
StarBurn_StarPort_DeviceAddLocal
StarBurn_StarPort_DeviceAddLocal function
StarBurn_StarPort_DeviceAddLocalEx
StarBurn_StarPort_DeviceAddLocalEx function
StarBurn_StarPort_DeviceAddRemote
StarBurn_StarPort_DeviceAddRemote function
StarBurn_StarPort_DeviceAddRemoteEx
StarBurn_StarPort_DeviceAddRemoteEx function
StarBurn_StarPort_DeviceListQueryLocal
StarBurn_StarPort_DeviceListQueryLocal function
StarBurn_StarPort_DeviceListQueryRemote
StarBurn_StarPort_DeviceListQueryRemote function
StarBurn_StarPort_DeviceRemove
StarBurn_StarPort_DeviceRemove function
StarBurn_StarPort_DeviceRemoveEx
StarBurn_StarPort_DeviceRemoveEx function
StarBurn_StarPort_GetDeviceInformation
StarBurn_StarPort_GetDeviceInformation function
StarBurn_StarPort_GetDeviceLetter
StarBurn_StarPort_GetDeviceLetter function
StarBurn_StarPort_GetDeviceSCSIAddress
StarBurn_StarPort_GetDeviceSCSIAddress function
StarBurn_StarPort_GetVersion
StarBurn_StarPort_GetVersion function
STARBURN_STARWAVE_CALLBACK_REASON
STARBURN_STARWAVE_CALLBACK_REASON enumeration
STARBURN_STARWAVE_CALLBACK_REASON_PROGRESS enumeration member
STARBURN_STARWAVE_CALLBACK_REASON_UNKNOWN enumeration member
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek
StarBurn_StarWave_CompressedFileReaderObjectBeginSeek function
StarBurn_StarWave_CompressedFileReaderObjectCreate
StarBurn_StarWave_CompressedFileReaderObjectCreate function
StarBurn_StarWave_CompressedFileReaderObjectCreateT
StarBurn_StarWave_CompressedFileReaderObjectCreateT macro
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode
StarBurn_StarWave_CompressedFileReaderObjectCreateUnicode function
StarBurn_StarWave_CompressedFileReaderObjectDestroy
StarBurn_StarWave_CompressedFileReaderObjectDestroy function
StarBurn_StarWave_CompressedFileReaderObjectRead
StarBurn_StarWave_CompressedFileReaderObjectRead function
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet function
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast
StarBurn_StarWave_CompressedFileReaderObjectUncompressedSizeGet_Fast function
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate
StarBurn_StarWave_CompressedFileReaderObjectUnicodeCreate function
StarBurn_StarWave_CompressedFileRecompress
StarBurn_StarWave_CompressedFileRecompress function
StarBurn_StarWave_CompressedFileRecompressT
StarBurn_StarWave_CompressedFileRecompressT macro
StarBurn_StarWave_CompressedFileRecompressUnicode
StarBurn_StarWave_CompressedFileRecompressUnicode function
StarBurn_StarWave_CompressedFileSupportedIs
StarBurn_StarWave_CompressedFileSupportedIs function
StarBurn_StarWave_CompressedFileUncompress
StarBurn_StarWave_CompressedFileUncompress function
StarBurn_StarWave_CompressedFileUncompressT
StarBurn_StarWave_CompressedFileUncompressT macro
StarBurn_StarWave_CompressedFileUncompressUnicode
StarBurn_StarWave_CompressedFileUncompressUnicode function
StarBurn_StarWave_CompressedFileWriterObjectCreate
StarBurn_StarWave_CompressedFileWriterObjectCreate function
StarBurn_StarWave_CompressedFileWriterObjectCreateT
StarBurn_StarWave_CompressedFileWriterObjectCreateT macro
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode
StarBurn_StarWave_CompressedFileWriterObjectCreateUnicode function
StarBurn_StarWave_CompressedFileWriterObjectDestroy
StarBurn_StarWave_CompressedFileWriterObjectDestroy function
StarBurn_StarWave_CompressedFileWriterObjectWrite
StarBurn_StarWave_CompressedFileWriterObjectWrite function
STARBURN_STARWAVE_COMPRESSION
STARBURN_STARWAVE_COMPRESSION enumeration
STARBURN_STARWAVE_COMPRESSION_NONE enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_128K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_160K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_192K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_256K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_320K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_32K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_48K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_64K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_80K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_CBR_96K enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_LOSSLESS_VBR_Q100 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q10 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q25 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q50 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q75 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q90 enumeration member
STARBURN_STARWAVE_COMPRESSION_WMA_VBR_Q98 enumeration member
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS
STARBURN_STARWAVE_IO_BUFFER_SIZE_IN_UCHARS macro
StarBurn_StarWave_UncompressedFileCompress
StarBurn_StarWave_UncompressedFileCompress function
StarBurn_StarWave_UncompressedFileCompressT
StarBurn_StarWave_UncompressedFileCompressT macro
StarBurn_StarWave_UncompressedFileCompressUnicode
StarBurn_StarWave_UncompressedFileCompressUnicode function
StarBurn_StarWave_UncompressedFileSupportedIs
StarBurn_StarWave_UncompressedFileSupportedIs function
StarBurn_StarWave_UncompressedFileSupportedIsT
StarBurn_StarWave_UncompressedFileSupportedIsT macro
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs
StarBurn_StarWave_UncompressedFileSupportedUnicodeIs function
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx
StarBurn_StarWave_UncompressedFileSupportedUnicodeIsEx function
StarBurn_StarWave_VersionGet
StarBurn_StarWave_VersionGet function
STARBURN_STARWAVE2_COMPRESS_TYPE
STARBURN_STARWAVE2_COMPRESS_TYPE enumeration
STARBURN_STARWAVE2_CONVERSION_MODE
STARBURN_STARWAVE2_CONVERSION_MODE enumeration
StarBurn_StarWave2_Convert
StarBurn_StarWave2_Convert function
StarBurn_StarWave2_ConvertEx
StarBurn_StarWave2_ConvertEx function
StarBurn_StarWave2_ConvertExT
StarBurn_StarWave2_ConvertExT macro
StarBurn_StarWave2_ConvertExUnicode
StarBurn_StarWave2_ConvertExUnicode function
StarBurn_StarWave2_ConvertUnicode
StarBurn_StarWave2_ConvertUnicode function
StarBurn_StarWave2_EncodeMP3OGGFromWAV
StarBurn_StarWave2_EncodeMP3OGGFromWAV function
StarBurn_StarWave2_EncodeMP3OGGFromWAVT
StarBurn_StarWave2_EncodeMP3OGGFromWAVT macro
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode
StarBurn_StarWave2_EncodeMP3OGGFromWAVUnicode function
StarBurn_StarWave2_GetFileReaderAndFactoryT
StarBurn_StarWave2_GetFileReaderAndFactoryT macro
STARBURN_STARWAVE2_INIT_PARAMS
STARBURN_STARWAVE2_INIT_PARAMS structure
StarBurn_StarWave2_IsFileSupported
StarBurn_StarWave2_IsFileSupported function
StarBurn_StarWave2_IsFileSupportedUnicode
StarBurn_StarWave2_IsFileSupportedUnicode function
STARBURN_STARWAVE2_MP3_MODE_MAX enumeration member
STARBURN_STARWAVE2_MP3_MODE0 enumeration member
STARBURN_STARWAVE2_MP3_MODE1 enumeration member
STARBURN_STARWAVE2_MP3_MODE2 enumeration member
STARBURN_STARWAVE2_OGG_MODE_MAX enumeration member
STARBURN_STARWAVE2_OGG_MODE0 enumeration member
STARBURN_STARWAVE2_OGG_MODE1 enumeration member
STARBURN_STARWAVE2_OGG_MODE2 enumeration member
STARBURN_STARWAVE2_QM_FAST enumeration member
STARBURN_STARWAVE2_QM_HIGH enumeration member
STARBURN_STARWAVE2_QM_STANDARD enumeration member
STARBURN_STARWAVE2_QUALITY_MODE
STARBURN_STARWAVE2_QUALITY_MODE enumeration
StarBurn_strcpy_s
StarBurn_strcpy_s function
StarBurn_swprintf_s
StarBurn_swprintf_s function
STARBURN_TRACK_INFORMATION
STARBURN_TRACK_INFORMATION structure
STARBURN_TRACK_INFORMATION_EX
STARBURN_TRACK_INFORMATION_EX structure
StarBurn_UDF_Add
StarBurn_UDF_Add function
StarBurn_UDF_AddT
StarBurn_UDF_AddT macro
StarBurn_UDF_AddUnicode
StarBurn_UDF_AddUnicode function
STARBURN_UDF_BRIDGE_TYPE
STARBURN_UDF_BRIDGE_TYPE enumeration
StarBurn_UDF_CleanUp
StarBurn_UDF_CleanUp function
StarBurn_UDF_Create
StarBurn_UDF_Create function
StarBurn_UDF_CreateEx
StarBurn_UDF_CreateEx function
StarBurn_UDF_CreateExT
StarBurn_UDF_CreateExT macro
StarBurn_UDF_CreateExUnicode
StarBurn_UDF_CreateExUnicode function
StarBurn_UDF_CreateT
StarBurn_UDF_CreateT macro
StarBurn_UDF_CreateUnicode
StarBurn_UDF_CreateUnicode function
StarBurn_UDF_Destroy
StarBurn_UDF_Destroy function
StarBurn_UDF_DestroyNodeAndKids
StarBurn_UDF_DestroyNodeAndKids function
StarBurn_UDF_FormatTreeItemAsDirectory
StarBurn_UDF_FormatTreeItemAsDirectory function
StarBurn_UDF_FormatTreeItemAsDirectoryT
StarBurn_UDF_FormatTreeItemAsDirectoryT macro
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode
StarBurn_UDF_FormatTreeItemAsDirectoryUnicode function
StarBurn_UDF_FormatTreeItemAsFile
StarBurn_UDF_FormatTreeItemAsFile function
StarBurn_UDF_FormatTreeItemAsFileT
StarBurn_UDF_FormatTreeItemAsFileT macro
StarBurn_UDF_FormatTreeItemAsFileUnicode
StarBurn_UDF_FormatTreeItemAsFileUnicode function
StarBurn_UDF_GetFirstChild
StarBurn_UDF_GetFirstChild function
StarBurn_UDF_GetNextSibling
StarBurn_UDF_GetNextSibling function
StarBurn_UDF_GetNodeObject
StarBurn_UDF_GetNodeObject function
StarBurn_UDF_GetParent
StarBurn_UDF_GetParent function
StarBurn_UDF_GetPreviousSibling
StarBurn_UDF_GetPreviousSibling function
STARBURN_UDF2_DIRECTORY_INFO
STARBURN_UDF2_DIRECTORY_INFO structure
StarBurn_UDF2_DirectoryBrowse
StarBurn_UDF2_DirectoryBrowse function
StarBurn_UDF2_DirectoryContentsProcess
StarBurn_UDF2_DirectoryContentsProcess function
StarBurn_UDF2_DirectoryContentsProcessEx
StarBurn_UDF2_DirectoryContentsProcessEx function
StarBurn_UDF2_DirectoryContentsUnicodeProcess
StarBurn_UDF2_DirectoryContentsUnicodeProcess function
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx
StarBurn_UDF2_DirectoryContentsUnicodeProcessEx function
StarBurn_UDF2_DirectoryCreate
StarBurn_UDF2_DirectoryCreate function
StarBurn_UDF2_DirectoryDestroy
StarBurn_UDF2_DirectoryDestroy function
StarBurn_UDF2_DirectoryProcess
StarBurn_UDF2_DirectoryProcess function
StarBurn_UDF2_DirectoryProcessEx
StarBurn_UDF2_DirectoryProcessEx function
StarBurn_UDF2_DirectoryProcessExEx
StarBurn_UDF2_DirectoryProcessExEx function
StarBurn_UDF2_DirectoryQuery
StarBurn_UDF2_DirectoryQuery function
StarBurn_UDF2_DirectoryRootCreate
StarBurn_UDF2_DirectoryRootCreate function
StarBurn_UDF2_DirectoryUnicodeCreate
StarBurn_UDF2_DirectoryUnicodeCreate function
StarBurn_UDF2_DirectoryUnicodeProcess
StarBurn_UDF2_DirectoryUnicodeProcess function
StarBurn_UDF2_DirectoryUnicodeProcessEx
StarBurn_UDF2_DirectoryUnicodeProcessEx function
StarBurn_UDF2_DirectoryUnicodeProcessExEx
StarBurn_UDF2_DirectoryUnicodeProcessExEx function
STARBURN_UDF2_FILE_DATE_TIME
STARBURN_UDF2_FILE_DATE_TIME structure
STARBURN_UDF2_FILE_DATE_TIME_TYPE
STARBURN_UDF2_FILE_DATE_TIME_TYPE enumeration
STARBURN_UDF2_FILE_INFO
STARBURN_UDF2_FILE_INFO structure
StarBurn_UDF2_FileBootCreate
StarBurn_UDF2_FileBootCreate function
StarBurn_UDF2_FileBootUnicodeCreate
StarBurn_UDF2_FileBootUnicodeCreate function
StarBurn_UDF2_FileCreate
StarBurn_UDF2_FileCreate function
StarBurn_UDF2_FileDestroy
StarBurn_UDF2_FileDestroy function
StarBurn_UDF2_FileDirectoryDateTimeGet
StarBurn_UDF2_FileDirectoryDateTimeGet function
StarBurn_UDF2_FileDirectoryDateTimeGetEx
StarBurn_UDF2_FileDirectoryDateTimeGetEx function
StarBurn_UDF2_FileDirectoryDateTimeSet
StarBurn_UDF2_FileDirectoryDateTimeSet function
StarBurn_UDF2_FileDirectoryDateTimeSetEx
StarBurn_UDF2_FileDirectoryDateTimeSetEx function
StarBurn_UDF2_FileDirectoryNameSet
StarBurn_UDF2_FileDirectoryNameSet function
StarBurn_UDF2_FileDirectoryUnicodeNameSet
StarBurn_UDF2_FileDirectoryUnicodeNameSet function
StarBurn_UDF2_FileMemoryCreate
StarBurn_UDF2_FileMemoryCreate function
StarBurn_UDF2_FileMemoryUnicodeCreate
StarBurn_UDF2_FileMemoryUnicodeCreate function
StarBurn_UDF2_FileQuery
StarBurn_UDF2_FileQuery function
StarBurn_UDF2_FileSetAttributes
StarBurn_UDF2_FileSetAttributes function
StarBurn_UDF2_FileSystemGetSizes
StarBurn_UDF2_FileSystemGetSizes function
StarBurn_UDF2_FileUnicodeCreate
StarBurn_UDF2_FileUnicodeCreate function
StarBurn_UDF2_ImpVolumeCreate
StarBurn_UDF2_ImpVolumeCreate function
StarBurn_UDF2_ImpVolumeDestroy
StarBurn_UDF2_ImpVolumeDestroy function
StarBurn_UDF2_ImpVolumeImport
StarBurn_UDF2_ImpVolumeImport function
StarBurn_UDF2_ISO9660FileTreeCreate
StarBurn_UDF2_ISO9660FileTreeCreate function
StarBurn_UDF2_ISO9660FileTreeCreateEx
StarBurn_UDF2_ISO9660FileTreeCreateEx function
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS
STARBURN_UDF2_NAME_SIZE_IN_SYMBOLS macro
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS
STARBURN_UDF2_PATH_SIZE_IN_SYMBOLS macro
StarBurn_UDF2_VolumeAnchorGet
StarBurn_UDF2_VolumeAnchorGet function
StarBurn_UDF2_VolumeCreate
StarBurn_UDF2_VolumeCreate function
StarBurn_UDF2_VolumeCreateBoot
StarBurn_UDF2_VolumeCreateBoot function
StarBurn_UDF2_VolumeCreateBootElTorito
StarBurn_UDF2_VolumeCreateBootElTorito function
StarBurn_UDF2_VolumeCreateBootElToritoT
StarBurn_UDF2_VolumeCreateBootElToritoT macro
StarBurn_UDF2_VolumeCreateEx
StarBurn_UDF2_VolumeCreateEx function
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito
StarBurn_UDF2_VolumeCreateUnicodeBootElTorito function
StarBurn_UDF2_VolumeDestroy
StarBurn_UDF2_VolumeDestroy function
StarBurn_UDF2_VolumeInitialSizeInLBsGet
StarBurn_UDF2_VolumeInitialSizeInLBsGet function
StarBurn_UDF2_VolumeSeekRead
StarBurn_UDF2_VolumeSeekRead function
StarBurn_UDF2_VolumeSizeInLBsGet
StarBurn_UDF2_VolumeSizeInLBsGet function
StarBurn_UDF2_VolumeSizeInUCHARsGet
StarBurn_UDF2_VolumeSizeInUCHARsGet function
StarBurn_UDF2_VolumeStore
StarBurn_UDF2_VolumeStore function
StarBurn_UDF2_VolumeUnicodeCreate
StarBurn_UDF2_VolumeUnicodeCreate function
StarBurn_UDF2_VolumeUnicodeCreateBoot
StarBurn_UDF2_VolumeUnicodeCreateBoot function
StarBurn_UDF2_VolumeUnicodeCreateEx
StarBurn_UDF2_VolumeUnicodeCreateEx function
StarBurn_UDFBridge_CreateEx
StarBurn_UDFBridge_CreateEx function
StarBurn_UDFBridge_CreateExT
StarBurn_UDFBridge_CreateExT macro
StarBurn_UDFBridge_CreateExUnicode
StarBurn_UDFBridge_CreateExUnicode function
StarBurn_UpStart
StarBurn_UpStart function
StarBurn_UpStartEx
StarBurn_UpStartEx function
StarBurn_UpStartExEx
StarBurn_UpStartExEx function
STARPORT_DEVICE_LIST
STARPORT_DEVICE_LIST structure
STARPORT_DEVICE_LIST_ENTRY
STARPORT_DEVICE_LIST_ENTRY structure
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS
STARPORT_DEVICE_NAME_SIZE_IN_UCHARS macro
STARPORT_DEVICE_TYPE
STARPORT_DEVICE_TYPE enumeration
STARPORT_DEVICE_TYPE_AOE enumeration member
STARPORT_DEVICE_TYPE_DVD enumeration member
STARPORT_DEVICE_TYPE_HDD enumeration member
STARPORT_DEVICE_TYPE_ISCSI enumeration member
STARPORT_DEVICE_TYPE_RAM enumeration member
STARPORT_DEVICE_TYPE_UNKNOWN enumeration member
STARWAVE2_COMPRESSION
STARWAVE2_COMPRESSION enumeration
STARWAVE2_COMPRESSION_NONE enumeration member
STARWAVE2_COMPRESSION_PROFILE
STARWAVE2_COMPRESSION_PROFILE structure
STARWAVE2_COMPRESSION_WMA_CBR_128K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_160K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_192K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_256K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_320K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_32K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_48K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_64K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_80K enumeration member
STARWAVE2_COMPRESSION_WMA_CBR_96K enumeration member
STARWAVE2_COMPRESSION_WMA_LOSSLESS_VBR_Q100 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q10 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q25 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q50 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q75 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q90 enumeration member
STARWAVE2_COMPRESSION_WMA_VBR_Q98 enumeration member
STARWAVEFACTORY_ID_DSHOW
STARWAVEFACTORY_ID_DSHOW macro
STARWAVEFACTORY_ID_MP3
STARWAVEFACTORY_ID_MP3 macro
STARWAVEFACTORY_ID_OGG
STARWAVEFACTORY_ID_OGG macro
STARWAVEFACTORY_ID_WAV
STARWAVEFACTORY_ID_WAV macro
STARWAVEFACTORY_ID_WMA
STARWAVEFACTORY_ID_WMA macro
Structs, Records, Enums
SUBCHANNEL_NO
SUBCHANNEL_NO macro
SUBCHANNEL_PQ
SUBCHANNEL_PQ macro
SUBCHANNEL_PQ_SIZE_IN_UCHARS
SUBCHANNEL_PQ_SIZE_IN_UCHARS macro
SUBCHANNEL_RAW_PW
SUBCHANNEL_RAW_PW macro
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS
SUBCHANNEL_RAW_PW_SIZE_IN_UCHARS macro
SUBCHANNEL_RESERVED
SUBCHANNEL_RESERVED macro
SUBCHANNEL_RW
SUBCHANNEL_RW macro
SUBCHANNEL_SIZE_IN_UCHARS
SUBCHANNEL_SIZE_IN_UCHARS macro
T
Technical support and service
TOC_ENTRY
TOC_ENTRY structure
TOC_INFORMATION
TOC_INFORMATION structure
TRACK_NUMBER_INVISIBLE
TRACK_NUMBER_INVISIBLE macro
Trademarks
TYPE_CODE_LAST_CHANCE
TYPE_CODE_LAST_CHANCE macro
TYPE_CODE_NONE
TYPE_CODE_NONE macro
TYPE_CODE_PERM
TYPE_CODE_PERM macro
TYPE_CODE_SET
TYPE_CODE_SET macro
Types
U
UDF_BRIDGE_TYPE_DVDVIDEO enumeration member
UDF_BRIDGE_TYPE_FORCE_DWORD enumeration member
UDF_BRIDGE_TYPE_ISO9660 enumeration member
UDF_BRIDGE_TYPE_ISO9660_JOLIET enumeration member
UDF_BRIDGE_TYPE_NONE enumeration member
UDF_CONTROL_BLOCK
UDF_CONTROL_BLOCK structure
UDF_FILE_DATE_TIME_TYPE_CREATION enumeration member
UDF_FILE_DATE_TIME_TYPE_LAST_ACCESS enumeration member
UDF_FILE_DATE_TIME_TYPE_LAST_WRITE enumeration member
UDF_FILE_EXTENT
UDF_FILE_EXTENT structure
UDF_FILE_HANDLE
UDF_FILE_HANDLE structure
UDF_FILE_LOOKUP_ENTRY
UDF_FILE_LOOKUP_ENTRY structure
UDF_FILE_SET_DESCRIPTOR_LBA
UDF_FILE_SET_DESCRIPTOR_LBA macro
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA
UDF_FILE_SET_DESCRIPTOR_TERMINATOR_LBA macro
UDF_FIRST_ANCHOR_LBA
UDF_FIRST_ANCHOR_LBA macro
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS
UDF_HEAD_SIZE_IN_LOGICAL_BLOCKS macro
UDF_ISO9660_FILE_SYSTEM_LBA
UDF_ISO9660_FILE_SYSTEM_LBA macro
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS
UDF_ISO9660_FILE_SYSTEM_SIZE_IN_LBS macro
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS
UDF_LOGICAL_BLOCK_SIZE_IN_UCHARS macro
UDF_LOOKUP_DIR_ENTRY
UDF_LOOKUP_DIR_ENTRY structure
UDF_LOOKUP_FILE_ENTRY
UDF_LOOKUP_FILE_ENTRY structure
UDF_NAME_SIZE_IN_UCHARS
UDF_NAME_SIZE_IN_UCHARS macro
UDF_NAME_SIZE_IN_UCHARS_ACTUAL
UDF_NAME_SIZE_IN_UCHARS_ACTUAL macro
UDF_NSR_DESCRIPTOR_LBA
UDF_NSR_DESCRIPTOR_LBA macro
UDF_OS_CLASS
UDF_OS_CLASS enumeration
UDF_OS_CLASS_BE_OS enumeration member
UDF_OS_CLASS_DOS enumeration member
UDF_OS_CLASS_MACINTOSH_OS enumeration member
UDF_OS_CLASS_OS_2 enumeration member
UDF_OS_CLASS_OS_400 enumeration member
UDF_OS_CLASS_UNDEFINED enumeration member
UDF_OS_CLASS_UNIX enumeration member
UDF_OS_CLASS_WINDOWS_9X enumeration member
UDF_OS_CLASS_WINDOWS_CE enumeration member
UDF_OS_CLASS_WINDOWS_NT enumeration member
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS
UDF_TAIL_SIZE_IN_LOGICAL_BLOCKS macro
UDF_TREE_ITEM
UDF_TREE_ITEM structure
UDF_VERSION
UDF_VERSION enumeration
UDF_VERSION_1_02 enumeration member
UDF_VERSION_1_50 enumeration member
UDF_VERSION_2_00 enumeration member
UDF_VERSION_2_01 enumeration member
UDF_VERSION_2_50 enumeration member
UDF_VERSION_2_60 enumeration member
W
WAVE_FILE_ALIGNMENT
WAVE_FILE_ALIGNMENT macro
WAVE_FILE_BITS_PER_SAMPLE
WAVE_FILE_BITS_PER_SAMPLE macro
WAVE_FILE_CHANNELS
WAVE_FILE_CHANNELS macro
WAVE_FILE_DATA_SIGNATURE
WAVE_FILE_DATA_SIGNATURE macro
WAVE_FILE_HEADER
WAVE_FILE_HEADER structure
WAVE_FILE_RIFF_SIGNATURE
WAVE_FILE_RIFF_SIGNATURE macro
WAVE_FILE_SAMPLES_PER_SECOND
WAVE_FILE_SAMPLES_PER_SECOND macro
WAVE_FILE_TAG_SIGNATURE
WAVE_FILE_TAG_SIGNATURE macro
WAVE_FILE_WAVE_FORMAT
WAVE_FILE_WAVE_FORMAT macro
WAVE_FILE_WAVE_SIGNATURE
WAVE_FILE_WAVE_SIGNATURE macro
WAVE_FORMAT_CHUNK
WAVE_FORMAT_CHUNK structure
WRITE_MODE
WRITE_MODE enumeration
WRITE_MODE_DISC_AT_ONCE_PQ enumeration member
WRITE_MODE_DISC_AT_ONCE_RAW_PW enumeration member
WRITE_MODE_SESSION_AT_ONCE enumeration member
WRITE_MODE_TRACK_AT_ONCE enumeration member
WRITE_REPORT_DELAY_IN_SECONDS
WRITE_REPORT_DELAY_IN_SECONDS macro


Welcome

StarBurn SDK

CD/DVD/Blu-Ray/HD-DVD Burning, Grabbing and Mastering Toolkit

Version 15.6 'Patriot' ( Build 2016-04-01 )

Copyright (c) 2001-2016 Rocket Division Software. All rights reserved.

Copyright (c) 2009-2016 StarBurn Software. All rights reserved.